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Document Conventions

There are several conventions that are used throughout this document to indicate actions to be taken or to 
highlight important information.  The conventions are as follows:

Item
 

Meaning

View Perimeter a command name or a file that you are to select

Tools > Options a command path that you are to select – usually from the pull-down 
menus

Document Name the name of a document that is not hyperlinked

Emphasis style used when referring to important word or phrases

Hyperlink style used when you have a direct link to another document on the web

Key in entering data with the keyboard

Quote style used to indicate an external source quotation

Note: text information about a command or process that you should pay 
particular attention to

1. Numbered Steps actions that you are to perform as part of the lab activities

<D> or Data press the data button on the mouse

<R> or Reset press the reset button on the mouse

<T> or Tentative press the tentative button on the mouse
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LAB 1 - Getting Started in ROW Geometry and 
Plans

This lab demonstrates starting InRoads and InRoads Survey.  If you are new user to InRoads it is recommended 
to check the setup to verify the correct standard resources are being used. 

Chapter Objectives:

 To launch the applications InRoads and InRoads Survey

 To be able to set Project Defaults for working with the ROW Survey group

Lab 1.1 - Opening InRoads and Launching InRoads Survey

1. There are three main methods to Start InRoads: choose one of the followoing methods

♦ Choose Start > All Programs > Bentley > InRoads Group V89 (SELECTseries 
2) > InRoads. MicroStation will open allowing you to choose the design file; once the 
design file opens InRoads will start

♦ Choose the Desktop icon for InRoads if one is available on your machine. 
MicroStation will open allowing you to choose the design file; once the design file 
opens InRoads will start

♦ If you already have MicroStation open, you can choose the InRoads icon from the 
MicroStation main toolbar

2. In the MicroStation Manager dialog box, go to the Workspace group section and change the 
User field to CDOT USER, the Project field to 12345 and the Interface field to CDOT. 

This workspace setup should load the correct MicroStation environment (including toolbars) 
when the selected MicroStation file is opened.

3. Navigate to the ROW_Survey\Drawings\Reference_Files directory and <D> the filename 
12345ROW_Model.dgn
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4. <D> Open to open the file.

Note: InRoads was used to enter the CAD file.  Using InRoads vs. InRoads Survey 
allows access to the full range of geometry commands available. By itself, InRoads 
Survey does provide somewhat limited geometry functions. By enabling InRoads 
initially, the full range of geometry functions is available to the user.  Additionally, 
the functions of InRoads Survey are also required because a fieldbook will be used 
to export survey data to a geometry project. This data will serve as a foundation for 
establishing existing property and land lines.  Once the electronic fieldbook has 
been exported, InRoads Survey will no longer be necessary.

5. Verify InRoads and InRoads Survey are both operating.

Note: The title bar for the InRoads interface is labeled: Bentley InRoads V8i (SELECTseries 
2) denoting that InRoads is running. Additionally, if enabled, the functions of InRoads 
Survey are apparent in the menu and workspace bars.
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6. If Either InRoads or InRoads Survey needs to be enabled select 
Tools > Product Add-Ins, and enable the appropriate application by selecting the 
application and <D> OK.

Note: From this point forward, unless specifically instructed to use MicroStation commands, 
all references to the selection of icons, tools, or menu pull-downs, refer to the InRoads 
interface.

Lab 1.2 - Project Defaults

Introduction

Defined default locations for both general InRoads resource files and project specific data files 
make it easier to conform to graphics standards and assist in navigating to the correct project 
directories when loading or saving data files.

Setting project defaults

1. From the pull down menu select File > Project Defaults.

The CDOT environment is configured to read MicroStation variables defined when the project 
creation utility is run.  These variables are automatically read when MicroStation is launched.  
Selecting the appropriate 'Project' in the MicroStation Manager dialog identifies the specific 
project folder referred to by the variable $(MS_DEF).

2. Select CDOT ROW_Survey Discipline from the drop-down Configuration Name: list.
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3. <D> Apply and then <D> Close.

Note: Choosing the appropriate discipline from the Configuration Name selection list will 
modify directory paths as configured by CDOT.  If necessary, <D> the Import button 
and select the file: C:\Projects\12345\Project_Configuration\CDOT_Disciplines.reg to 
populate the Configuration Name drop-down list.
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LAB 2 - Working with Survey Data

This lab demonstrates working with survey data as a foundation for our initial geometry. Exporting the survey 
field book to an InRoads geometry project will generate alignments along linear items and Cogo points at all 
survey shot locations.

Chapter Objectives: 

 Load existing completed survey data

 Filter survey data to select only points and alignments that will be needed

 Exporting filtered survey data to a Geometry Project as cogo points and horizontal and 
vertical alignments

Lab 2.1 - Load Project Data

The goal of this exercise is to export observations from an InRoads Survey fieldbook to a Geometry Project 
creating Cogo points and alignments.

The fieldbook for this project, 12345SURV_Fieldbook.fwd contains control monuments, found monuments, 
and general topography observations. While this is all valid information, it is desirable to work with a subset of 
the survey information such as pavement centerlines, control lines, or other specific entities by excluding 
terrain strings and other topographic information that does not relate to the development of ROW geometry. 
Working with a subset of the information increases efficiency by working with a smaller data set and freeing-
up additional resources for other operations. Exporting a portion of a survey fieldbook can be accomplished by 
using Survey Feature Filters when creating the InRoads geometry project.

1. From the pull down menu select File > Open the Open dialog appears.

2. Select the fieldbook file 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\12345SURV_Fieldbook.fwd.

3. <D> Open button then <D> the Cancel button the file will be opened in InRoads 
Survey and the Open dialog will close.

Once the fieldbook has loaded, InRoads will automatically fit the extents of the fieldbook to the 
MicroStation screen.
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4. From the pull down menu or View Survey Data toolbar toggle on Survey > View Survey 
Data > Planametrics | Point Names | Symbols |Codes | Notes.

5. Use the MicroStation Fit View command to get an indication of the survey information 
contained in the fieldbook.

6. Take a few minutes to zoom in and navigate around the MicroStation screen to investigate 
the survey data displayed as it relates to the project layout.

Note: Fieldbook information is displayed dynamically in the MicroStation file. To adjust 
the size of the information displayed Tools > Survey Options [Symbology]. 
Select a category under Symbology and <D> Edit View to adjust text or symbol 
size.

Note: Take notice of the various survey control, ROW and property monuments.  
Pavement shots, and general topography shots are seen representing terrain breaks, 
signs, culvert ends, and other features.  It is desirable to filter unrelated topography 
information from our electronic fieldbook prior to exporting it to the right of way 
geometry project.
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Lab 2.2 - Filtering the Survey Data

The goal is to write only the information important to establishing ownership and right of way parcels to a 
geometry project.  The use of Survey feature filters will assist in sorting the data. When a Survey feature filter 
is activated, the displayed contents of the electronic fieldbook will update along with the associated graphics 
display. The dynamic graphics display can be used as a preview of the data being written to graphics, a DTM, 
or to the geometry project.

A survey feature filter affects commands for:

 Electronic fieldbook data

 Survey data to surface

 Survey data to geometry

 Survey data to graphics

 Viewing of dynamic survey data

1. Use MicroStation view commands to display any portion of the project area. This display 
can be used as a preview of our Fieldbook filter.

2. From the pull down menu select Survey > Fieldbook Data the Fieldbook Data dialog 
will appear.
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3. From the Fieldbook Data dialog <D> on the Survey Style Filter icon the Survey Style 
Filter dialog will appear.

Create the Roadway Centerlines survey feature filter

1. In the Survey Style Filter dialog, <D> Save As

2. In the Save Filter As dialog, enter Roadway Centerlines

3. <D> OK button the Save Filter As dialog will close.
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4. Toggle None for the Start With option.

5. From the Properties drop down menu select Numeric Code.

6. In the Value field enter a value of 1313.

7. Toggle Include for the Mode option.

8. <D> the Add Rule button the rule will be added to the list.

9. Back in the Value field enter a value of 1316. Keep the rest of the settings the same.

10. <D> the Add Rule button the rule will be added to the list.

11. Continue this process to add the following Rules:
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♦ 1317-1326, 1332, and 1335

12. From the Survey Style Filter dialog <D> Save then <D> the OK button the dialog will 
close and the new filter will be saved.

13. From the InRoads Locks toolbar, Toggle ON the Feature Filter Lock
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14. Open the Fieldbook Data dialog if it is not already opened.  The Fieldbook Data will 
update to display only the data that passes the survey style filter.

15. View the MicroStation graphics displayed.  The display graphics reflect the current 
contents of the fieldbook.

Note: The graphics automatically refresh by default, Automatic Refresh is toggled on under 
Tools > Survey Options.  If it is not toggled on the graphics can be regenerated 
manually from the InRoads pull down menu Survey > Regenerate Graphics.

Create the Right of Way survey feature filter.

When a fieldbook is exported to graphics, geometry, or a DTM, only the survey shots that pass 
the filter will be exported. In this case, additional information is desired for the development of 
right-of-way.
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1. Reopen the Survey Style Filter dialog from the pull down menu select 
Survey > Survey Style Filter.

2. From the Survey Style Filter dialog make sure the Roadway Centerlines filter is selected.

3. In the Survey Style Filter dialog, <D> the Save As button the Save Filter As dialog will 
appear.

4. In the Save Filter As dialog, enter Right of Way.

5. <D> the OK button the dialog will close and Right of Way will be the active Survey Style 
Filter.

6. Toggle None for the Start With option.

7. From the Properties drop down menu select Alpha Code.

8. In the Value field enter a value of 5??.

Note: The "??" in the key-in value is used as a wild card value when searching for data.  The 
value of "5??" will return the range of codes 500-599.

9. Toggle Include for the Mode option.
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10. <D> the Add Rule button the rule will be added to the list.

11. Back in the Value field enter a value of 10?? Keep the rest of the settings the same.

12. <D> the Add Rule button the rule will be added to the list.
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13. From the Survey Style Filter dialog <D> Save then <D> the OK button the dialog will 
close and the new filter will be saved. 

14. The Feature Filter Lock should still be toggled ON.  The MicroStation display updates to 
display only the survey codes that pass the active filter.

Note: The filter Right of Way includes codes for both property information and roadway 
centerline information.  Now that a Survey Style Filter is active, it will be applied when 
exporting survey data to geometry.
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Lab 2.3 - Exporting a Filtered InRoads Survey Fieldbook to 
Geometry

When exporting a Fieldbook to graphics, a DTM, or to a geometry project, only the items active in the 
Fieldbook are exported. Using a Survey Feature filter allows control of which survey data gets exported.

1. From the pull down menu select Survey > Fieldbook Data the Fieldbook Data dialog 
will appear.

2. From the Fieldbook Data dialog select the Survey Style Filter icon. 

3. From the Survey Style Filter dialog select the filter name Right of Way

4. <D> the OK button.  The Right of Way filter will be active and the Survey Style Filter 
dialog will close.  

5. From the Locks toolbar toggle ON the InRoads Feature Filter lock.
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6. From the pull down menu select Survey > Survey Data to Geometry.  The Survey 
Data to Geometry dialog will appear.

7. In the Project Name field key-in the Geometry Project Name 12345_ROW.  A new 
Geometry Project will be created by that name.

8. From the Description drop down menu select Use Style Description.

9. From the Curve Stroking drop down menu select Horizontal and Vertical.

10. From the Duplicate Names section select the radio button Rename.

11. <D> the Filter button the Survey Style Filter dialog will appear.  Review the filters rules 
prior to exporting.

12. <D> OK to close the Survey Style Filter dialog as it was used for review and is not 
required to be open.

13. <D> Apply on the Survey Data to Geometry dialog.  The geometry project is created, the 
Cogo points are created, and horizontal and vertical alignments are generated.
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14. Examine InRoads Explorer to verify geometry data was created.

15. The survey fieldbook is no longer needed, go to the Survey Workspace tab and <R> 
12345SURV_Fieldbook and choose Close from the fly-out list.  This will remove it from 
memory, saving the file should not be necessary.

16. From the InRoads Locks toolbar toggle OFF the InRoads Feature Filter lock.

Lab 2.4 - Saving a Geometry Project

InRoads is Memory based, not Disk based. The file(s) seen in the InRoads Workspace pane are 
copies from the disk drive and reside in the computer's memory. Any changes to these files (or 
creation of new data files) require saving back to the disk drive.

1. From the Geometry Workspace Pane <R> on the Geometry Project 12345_ROW and select 
Save As from the fly-out menu the Save As dialog will appear.

2. Select the drop-down list for the Active: field and select 12345_ROW from the list.
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3. Verify the same name is populating the File Name: 12345_ROW.

Note: By default it should be saved to the folder: 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\ as this was the path for 
geometry files defined in the Project Defaults configuration file.

4. <D> on the Save in: Geometry to verify the folder location.

5. After the correct folder location is identified, <D> Save then <D> the Cancel buttons.

♦ When the Geometry Project is saved to the hard drive it takes on an extension of .alg

♦ The directory folder for geometry already contains four geometry projects.  
12345_DESIGN.alg contains design centerline information and will be used to 
facilitate development of the right of way plans.
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♦ The Geometry Styles associated with the exported fieldbook are derived from the 
Survey Feature Style definition at the time geometry is exported from InRoads Survey.

♦ Geometry styles can be assigned (or reassigned) to alignments in the Geometry > Copy 
Geometry dialog.  No equivalent command exists for Cogo Points.  However, a 
Geometry Style can be assigned to alignments or Cogo points when using the 
horizontal annotation command to view geometry information.



Page 26 Colorado Department of Transportation

LAB 2 - Working with Survey Data Labs for ROW Geometry



Colorado Department of Transportation   Page 27

LAB 3 - Geometry Projects

This lab demonstrates opening and viewing Geometry Projects in MicroStation. Geometry data such as a 
horizontal alignment will be copied from one Geometry Project to another.

Chapter Objectives:

 Open an existing Geometry Project

 View the data stored in the Geometry Project such as the horizontal alignments and Cogo 
points

 Managing and copying Geometry Project data between files

Lab 3.1 - Opening and Viewing Geometry Projects

1. Open the MicroStation design file 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\12345ROW_Model.dgn

2. Open the Geometry Project 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\12345_ROW.alg that was created in 
the earlier lab.

3. From the MicroStation pull down menu select Utilities > Saved Views the Saved Views 
dialog will appear.

4. From the Saved Views dialog select the saved view name Geometry Verify then <D> in 
MicroStation view 1. This will make it easier to verify the geometry project information by 
turning off all the ROW_* levels.

5. Dismiss the Saved View dialog box.

Note: When we need to see the ROW information in later steps, we will recall it using a 
different Saved View named ROW Reference.
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6. From the InRoads pull down menu select Geometry > View Geometry > Horizontal 
Annotation the View Horizontal Annotation dialog will appear.

7. Select the Main tab in the View Horizontal Annotation dialog.
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8. In the Include field for Horizontal Alignments key-in an asterisk * (wild-card) then Tab 
key to identify all horizontal alignments.
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9. <D> the Preferences button at the bottom of the dialog the Preferences dialog will 
appear.

10. Select the preference name CDOT.

11. <D> the Load then <D> the Close buttons. The Preferences dialog will close and the 
default CDOT preference will be loaded.

12. In the Apply Style section of the Main tab select the Active radio button.

13. From the Horizontal Alignment drop down list select ALG_Existing.

14. In the Annotate section of the Main tab uncheck Elements.

15. <D> the Apply button the selected horizontal alignments and alignment points will be 
displayed in the MicroStation view.

16. In the Include field for Cogo Points key-in an asterisk * (wild-card) then Tab key to 
identify all horizontal alignments.
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17. <D> the Apply button the selected horizontal alignments, alignment points and Cogo 
points will be displayed in the MicroStation view.

18. Use MicroStation view commands to zoom into the graphics to review the display of 
alignments and Cogo points.

Lab 3.2 - Copying Geometry data

The current geometry project contains only information exported from the fieldbook. Another geometry 
project, 12345_DESIGN contains the design centerline alignment and is needed for development of right of 
way for this project. 
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The design section has developed a horizontal alignment representing the construction reference line for this 
project. Multiple geometry projects can be loaded into memory simultaneously and be accessed as needed. 
However, it is much easier (and sometimes necessary) to have the appropriate geometry information contained 
in a single geometry project. To that end, copy the design reference line from the geometry project 
12345_DESIGN to the geometry project 12345_ROW. In order to copy geometry from one project to another, 
they must both be loaded into memory.

1. From the menu pull down select File > Open the Open dialog will appear.

2. Path to the file and folder 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\12345_DESIGN.alg

3. <D> the Open the <D> the Cancel buttons. The file will be loaded into memory and the 
dialog will be dismissed.

There is a single horizontal alignment needed from the 12345_DESIGN geometry project. It is 
named C_Centerline
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4. From the pull down menu select Geometry > Copy Geometry the Copy Geometry 
dialog will appear.

5. In the Copy Geometry dialog select the Horizontals tab.

6. In the From section select the Geometry Project: 12345_DESIGN.

7. In the list of horizontals select the name C_Centerline.

8. In the To section, set the Geometry Project: 12345_ROW.
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9. <D> the Apply then <D> the Close buttons. The horizontal alignment will be copied and 
the dialog will be dismissed.

Note: The dialog is divided into 2 sections. The top half of the dialog being the geometry 
project being copied from, with the lower half being the geometry project being 
copied to. Alignments being copied can be assigned a new name, description, or 
style during the copy process.

10. From the Geometry Workspace pane <R> the Geometry Project 12345_DESIGN and 
select Close from the fly out list. InRoads may ask to save the file select no.

Note: The geometry project 12345_ROW should be the active geometry project. By 
default any geometry viewing or creation commands operate on the active 
geometry project. The active geometry project is indicated by a red box next to the 
name. Deleting the active project leaves InRoads in the state of no active project 
being defined. 

11. From the Geometry Workspace pane <R> on the Geometry Project name 12345_ROW and 
select Set Active from the fly-out menu.

12. Expand the display tree of active Geometry Project by selecting the plus sign.

13. <R> the Horizontal Alignment C_Centerline and select Set Active from the fly out list.

For orientation purposes, display the graphics and stationing for alignment C_Centerline

14. From the pull down menu select Geometry > View Geometry > Active Horizontal

15. From the pull down menu select Geometry > View Geometry > Stationing

Note: The global scale factor and selected preference influence the display of geometry 
and stationing.
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16. In the InRoads Explorer pane, <R> on the Geometry Project 13245_ROW and select Save 
from the fly-out menu.
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LAB 4 - Creating Cogo Points

This lab demonstrates creating cogo points a number of different ways.  The Cogo points will then be displayed 
in the MicroStation view.

Chapter Objectives: 

 Enabling the Cogo audit trail

 Creating Cogo points graphically

 Creating Cogo points by coordinate input

 Writing geometry vertices to the Cogo buffer

 Geometry Snaps - review only

 Cogo point intersection commands

 Create alignments with Cogo Points

 Create parallel and offset alignments

 Create parcels

Lab 4.1 - Recording coordinate geometry results

Enabling the Cogo audit trail allows the InRoads user to record edits made to the geometry project. The edits 
are written to a text file sharing the location and name of the geometry project with the exception of the 
filename extension is defined as *. atf. 

1. Open the MicroStation design file 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\12345ROW_Model.dgn

2. Open the Geometry Project 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\12345_ROW.alg that was created in 
the earlier lab.

3. From the InRoads Locks toolbar, enable the Cogo audit trail.

Note: Activate the Cogo audit trail only after a geometry project has been written to disk. 
Doing so allows the *.atf to track filename and directory location. The audit trail 
file can not be executed to reconstruct geometry but tracks geometry results similar 
to results shown if the report lock is enabled.

4. The Cogo audit trail file, *.atf file, can be opened at anytime with a text editor such as 
notepad.

Lab 4.2 - Cogo point creation by graphic input

Prior to generating the proposed right-of-way geometry, the public land survey lines (section lines), existing 
right-of way, and existing parcels will be developed. Additionally the reference line alignment vertices will be 
sent to the Cogo buffer.

5. Use the MicroStation Fit View command to view the extents of the project.



Page 38 Colorado Department of Transportation

LAB 4 - Creating Cogo Points Labs for ROW Geometry

6. From the pull down menu select Utilities > Saved Views the Saved Views dialog will 
appear.

7. On the view named ROW Reference  <D><D> and then <D> in the MicroStation view 1.  
This exercise will be working in the Summit Business Park area outlined below. 

8. Use the MicroStation Window command to zoom into this area.

Note: Cogo point 105 was created by the fieldbook export. The locations marked as 117 
& 120 are required to establish section lines that are necessary for the development 
of right of way. These 2 Cogo points will be created in the following exercises.
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9. Use MicroStation to Window into the location for point 117.

10. From the pull down menu select Geometry > Cogo Points > New the New Cogo Point 
dialog will appear.

11. In the Name field key-in 117.
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12. <D> the Northing Easting Elevation Target button to interactively define the coordinates.  
The New Cogo Point dialog will temporarily minimize to allow for more of the 
MicroStation view to be available.

13. <T> then <D> to the CAD graphics at the section corner. The New Cogo Point dialog will 
reappear with the coordinates applied.

14. In the Description field key-in N 1/4 Cor Section 14.



Colorado Department of Transportation   Page 41

Labs for ROW Geometry LAB 4 - Creating Cogo Points

15. From the Style drop down list select the RW_Working-exist.

16. <D> Apply then <D> the Close buttons.  The Cogo point is created and displayed to the 
MicroStation screen.

If Report lock is ON, a Results dialog opens.

17. <D> the Close button in the Results dialog.
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Lab 4.3 - Cogo point creation by coordinate input

In the New Cogo Point dialog, define Cogo point 120 which is located south of Summit Business Park

1. In the Name field key-in 120.

Note: When entering subsequent Cogo points the Name field automatically increments to 
the next unused point identifier. Also when entering coordinates do not input 
commas, they are shown here for readability purposes.

2. From another source, the SE Corner of Section 14 (future point 120) has been determined 
as having the coordinate values of:

♦ North =1,553,239.97
♦ East = 3,279,699.86

3. In the Description field key-in SE Cor Section 14

4. From the Style drop down list select RW_Working-exist

5. <D> Apply then <D> the Close buttons.  The Cogo point is created and displayed to the 
MicroStation screen.
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Lab 4.4 - Centering a MicroStation View on a Cogo Point

1. From the pull down menu select Geometry > Cogo Points > Center Point the Micro-
Station status bar prompts you to Identify point/Key in point name.

2. In the MicroStation Key-in window, key-in 120  <Enter>

3. If more then one view is opened you are prompted to Select a View.

4. <D> in any MicroStation View the MicroStation view is repositioned to center the 
specified Cogo point.

Note: The above command will not change the display volume of the MicroStation 
screen.   You may be required to zoom in or out to achieve desirable results.

5. Continue to Center other cogo points 105 and 117.

6. Open the Cogo Audit trail file to view results.
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LAB 5 - Alignment to Cogo Buffer

This lab demonstrates that alignment cogo point naming can be defined by the user or assigned by InRoads 
using a user specified seed name. While the overall alignment must be assigned a unique name, the vertices 
(PI's, PC's, PT's, etc) of said alignments can exist in three states, as: cogo points, named points, or unnamed 
points.

Chapter Objectives:

 Create cogo points from a horizontal alignment

 Review cogo points stored in the Cogo Buffer

1. Open the MicroStation design file 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\12345ROW_Model.dgn

2. Open the Geometry Project 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\12345ROW.alg that was created in 
the earlier lab.

3. From the Geometry Workspace pane <R> on the Geometry Project name 12345_ROW and 
select Set Active from the fly-out menu.

4. Expand the display tree of active Geometry Project by selecting the plus sign.

5. <R> the Horizontal Alignment C_Centerline and select Set Active from the fly out list.

6. From the pull down menu select Geometry > Review Horizontal the Review 
Horizontal Alignment dialog will appear with C_Centerline as the active alignment.

As they relate to the Cogo buffer, InRoads reserves geometry point names. These are reserved 
as Cogo point ID's in the event the named geometry points are written to the Cogo buffer. If the 
alignment containing the named geometry points is written to the Cogo buffer, the naming 
between geometry points and cogo points is synchronized.

Note: The information in parenthesis shows the identifier of the vertices either as Cogo 
points or as named or unnamed geometry points. In this case, the alignment 
C_Centerline was created as unnamed geometry points.
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The assignment of geometry names at time of creation (or editing) is controlled by: 
File > Project Options [Geometry] tab.

Write the vertices for alignment C_Centerline to the Cogo buffer. Doing so will facilitate the 
generation of additional geometry for the development of the project.
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7. Select Geometry > Horizontal Curve Set > Events the Horizontal Events dialog 
opens.

8. <D> the radio button for Alignment Point to Cogo

Note: The seed name field only applies to unnamed geometry points. If names are 
already assigned to the alignment, the assigned names will be used regardless of 
input into the Seed Name field. The active alignment C_Centerline does not have 
geometry point names assigned so input here is desired. If no seed name is defined 
here, the next available Cogo point number would be used and incrementally 
increased.

Reviewing the Cogo buffer indicates that the range of number from 121-1007 are unused. For 
simplicity, set point number 200 as the initial Cogo point ID to assign to the alignment vertices 
(more on reviewing the Cogo buffer in the following lab).

9. Key-in 200 as the Seed Name

10. Key-in Design Ref line in the Description field
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11. Select ALG_PRO as the geometry style to assign to the new Cogo points

12. <D> Apply then <D> the Close buttons the points will be added to the cogo buffer and 
the dialog will be dismissed.

13. In the Geometry Workspace pane review the Cogo Buffer to verify the results by <D> on 
the Cogo Buffer then reviewing the Feedback pane.

14. <R> on the Geometry Project name 12345_ROW from the pop up menu <D> Save
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LAB 6 - Reviewing Cogo Points

This lab demonstrates that Cogo points can be reviewed in the InRoads feedback pane and then exported to a 
text file.

Chapter Objectives: 

 Review Cogo points in the feedback pane of the InRoads interface

 Save Cogo points stored in the Geometry Project to a simple text file

1. Open the MicroStation design file 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\12345ROW_Model.dgn

2. Open the Geometry Project 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\12345_ROW.alg that was created in 
the earlier lab.

3. From the Geometry Workspace pane <R> on the Geometry Project name 12345_ROW and 
select Set Active from the fly-out menu.

4. In the Geometry Workspace pane review the Cogo Buffer to verify the results by <D> on 
the Cogo Buffer then reviewing the Feedback pane.

Note: Cogo points can be assigned either numbers or names. When alpha characters are 
used, names are case sensitive; RL_10 is not the same point as rl_10.

5. <D> on the column headers Name | Northing to sort the cogo points in ascending and 
descending order.

6. <D> hold and drag a column header to reorder the columns.
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7. From the pull down menu select Geometry > Review Geometry Points the Review 
Geometry Points dialog will appear.

8. In the Name field key-in 200 then the Tab key the dialog will display the cogo point 
information.

Note: This dialog can be used to evaluate individual Cogo points (or named geometry 
points) by navigating with the provided buttons. Also if Center in View is enabled, 
the MicroStation view will center on the point selected.

9. <D> the Next | Previous | First | Last buttons to navigate the cogo points stored in the 
cogo buffer.
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10. <D> the Report button the Results dialog will appear with all the cogo points listed.

Note: This Results dialog will list both Cogo points and named geometry points (named 
alignment vertices not stored as Cogo points). This is signified by the name of the 
command used to generate this report Review Geometry Points, not Cogo points. 
Named geometry points are not written to the Cogo buffer automatically. However 
they are reserved.

11. <D> the Save As button the Save As dialog will appear.

12. Path to the folder InRoads\Geometry

13. Key-in the file name GeoPoints.txt 

14. <D> the Save button the file will be stored and the dialog will be dismissed.

15. <R> on the Geometry Project name 12345_ROW from the pop up menu <D> Save
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LAB 7 - Geometry Snaps

This lab demonstrates InRoads geometry snaps which allow the user added functions to ensure geometry point 
locations and direction criteria are selected at defined geometry locations. In this lab the geometry inverse 
command is used for illustration. Geometry snaps can be applied when creating alignments, using traverse 
commands or almost any geometry related command. Using geometry snaps will ensure specific locations are 
selected.

InRoads geometry snaps are analogous to MicroStation snaps such as the keypoint snap. When enabled, the 
software only allows selection at specific locations.

Chapter Objectives:

 Use both No Snap and Point Snap from the Locks toolbar

 Use the Inverse Direction tool on Cogo points

1. Open the MicroStation design file 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\12345ROW_Model.dgn

2. Open the Geometry Project 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\12345_ROW.alg that was created in 
the earlier lab.

3. From the Geometry Workspace pane <R> on the Geometry Project name 12345_ROW and 
select Set Active from the fly-out menu.

4. Make sure the locks toolbar is open from the pull down menu select 
Tools > Locks > Toolbar dock the toolbar into the InRoads interface.

5. <D> on the Element Snap Lock icon in the InRoads Locks toolbar.

6. <D> on the Element Snap Lock icon a second time to cycle through the three geometry 
snap modes:

♦ No Snap - Element snap off 

♦ Point snap - locks to Cogo points or alignment vertices 

♦ Element snap - select tangents for direction definition 
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7. Window the MicroStation view as shown below.

Note: To explore the Element Point snap use the inverse command to report distance and 
direction between cursor locations.

8. Set the Element Snap Lock OFF    

9. From the pull down menu select Geometry > Utilities > Inverse Direction the Inverse 
Direction dialog will appear.

10. <D> the Inverse tab the <D> the Interactive button. After selecting the Interactive 
button you are prompted in the MicroStation status bar to Identify Initial Point/Key in 
Initial Point.
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11. <D> near Cogo point 117 and then <D> near Cogo point 105.

Dynamic graphics will appear and both the MicroStation and InRoads command fields will 
report the results. A question mark indicates that a specific Cogo point has not been 
selected. In this case, the bearing and distance readout reflects the values between the data 
<D> points given. Not between defined geometry points.

12. Toggle ON the Geometry Point Snap Lock to select defined geometry.

13. From the pull down menu select Geometry > Utilities > Inverse Direction the Inverse 
Direction dialog will appear.

14. <D> the Inverse tab the <D> the Interactive button. After selecting the Interactive 
button you are prompted to Identify Initial Point/Key in Initial Point.

15. <D> near Cogo Point 117 and then <D> near Cogo point 105. InRoads reports the bearing 
and distance between points 117 and 105.

16. Move the cursor around the MicroStation view. Note how the cursor 'snaps' between 
specific geometry vertices. 

17. Toggle Geometry Snap Lock OFF.



Page 56 Colorado Department of Transportation

LAB 7 - Geometry Snaps Labs for ROW Geometry

Note: Geometry snaps, if enabled, operate whether the related graphics are visible or not.

After initializing the Inverse Direction command, point numbers can also be keyed into the 
Inverse Direction tab Point key-in field.

18. From the pull down menu select Geometry > Utilities > Inverse Direction the Inverse 
Direction dialog will appear.

19. <D> the Inverse tab.

20. In the Point field key-in 117 then Tab key.

21. In the Point field key-in 120 then Tab key the results dialog will appear with the distance 
and direction displayed.

Note: The geometry snap element will be covered in following exercises. 

22. <R> on the Geometry Project name 12345_ROW from the pop up menu <D> Save
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LAB 8 - Cogo Point by Traverse

This lab demonstrates the use of the Traverse command to establish the West ¼ corner from Cogo point 105. 
Development of the right of way for the project requires the establishment of the West ¼ corner for Section 13 
which lies South of the project reference line near the Northeast corner of the Summit Business Park 
development.

Chapter Objectives:

 Create Cogo points using direction and bearings key-ins

1. Open the MicroStation design file 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\12345ROW_Model.dgn

2. Open the Geometry Project 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\12345_ROW.alg that was created in 
the earlier lab.

3. From the Geometry Workspace pane <R> on the Geometry Project name 12345_ROW and 
select Set Active from the fly-out menu.

The West ¼ corner has been determined to lie south of the NW corner of section 13 (Cogo 
point 105) at:

♦ S 00-37-05 E 

♦ 2,643.99 feet
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4.  From the pull down menu select Geometry > Traverse the Traverse dialog will appear.

5. From the Method radio button select Direction.

6. From the Insert Point Mode radio button select To Cogo Buffer

7. In the Occupied Point section of the dialog key-in the Name: 105 then Tab key. The 
coordinates for point 105 will display.

8. In the Course section of the dialog key-in the Direction: S 0 37 05 E

9. In the Course section of the dialog key-in the Horizontal Distance: 2643.99

10. In the Foresight Point section of the dialog key-in the Name: 119

11. In the Foresight Point section of the dialog key-in the Description: W 1/4 Cor Sec 13

12. In the Foresight Point section of the dialog select the Style RW_Working-exist from the 
drop down list.
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13. <D> the Apply button the point 119 will be created and become the occupied point. The 
foresight point will automatically increment to the next available number.

Note: If point 119 would have already existed, the next available point number would be 
used and 119 would not have been overwritten.

From the newly created point 119, traverse to the east establishing point 121 on the South 
right-of-way line of S.H. No. 86. Said point lying at N 89^12'18" E, a distance of 30' (RW 
width) + 660.53' (ROW length).

14. From the Method radio button select Direction.

15. From the Insert Point Mode radio button select To Cogo Buffer

16. Verify the Occupied Point is the Name: 119.

17. In the Course section of the dialog key-in the Direction: N 89 12 18 E

18. In the Course section of the dialog key-in the Horizontal Distance: 30+660.53 <Tab>

19. Verify the Foresight Point is the Name: 121

20. In the Foresight Point section of the dialog key-in the Description: South ROW point

21. In the Foresight Point section of the dialog select the Style RW_Working-exist from the 
drop down list.

22. <D> the Apply button the point 121 will be created and become the occupied point.

Note: Notice the previous foresight point has become the occupied point. Also note math 
operations can be used in the input fields. Once you [tab] from the field, the math 
operation computes. Experiment using +, -, *, /

23. Close traverse dialog box.

24. <R> on the Geometry Project name 12345_ROW from the pop up menu <D> Save.
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LAB 9 - Horizontal Alignments from Cogo 
Points

This lab will expand on previous training to create alignments by chaining Cogo points together. This 
methodology, commonly referred to as the “PI Method” and will utilize the Geometry > Horizontal Curve Set 
tools. 

Chapter Objectives:

 Become more familiar with the Geometry Point Snap Lock

 Create an alignment using Cogo points

Lab 9.1 - Generate Alignment using Cogo points

1. Open the MicroStation design file 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\12345ROW_Model.dgn

2. Open the Geometry Project 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\12345_ROW.alg that was created in 
the earlier lab.

3. From the Geometry Workspace pane <R> on the Geometry Project name 12345_ROW and 
select Set Active from the fly-out menu.

Connect the 3 Cogo points 120, 119, and 105 established along the west line of Section 13 
to form an alignment that represents the center line of County Road 303. Once established, 
this alignment can be used for establishing the right of way limits for said road.

4. Set the MicroStation View to show the subject area.

5. <D> Geometry Point Snap Lock ON.
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6. From the pull down menu select 
Geometry > Utilities > Create/Edit Alignment by Cogo Points. A warning 
message may appear which indicates that the active alignment may have illegal 
(unassigned) point names. 

Recall that the alignment C_Centerline was created with unnamed geometry points (you 
can verify this with Geometry > Review Horizontal). In a previous exercise the alignment 
points were written to the Cogo buffer. Doing so created Cogo points for the alignment 
vertices but did not associate the created Cogo points back to the alignment. You are 
presented with two options:

♦ Selecting No: The identified alignment continues to exist using unnamed geometry 
points, which is OK and the Create/Edit Alignment by Cogo Points dialog will open.

♦ Selecting Yes: InRoads will associate the Cogo points created back to the alignment 
vertices. Either solution is OK, ultimately it is at your discretion which to choose.

7. <D> the Yes button. The Create/Edit Alignment by Cogo Points dialog will open.

Note: The alignment C_Centerline is defined as having Cogo point numbers assigned at 
its vertices. The letter C indicates the Cogo point identified is the Center of a curve. 
The letters R or L indicate the curve direction (Right or Left).
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8. In the Name field key-in West Line of Sec 13 and then the <Tab> key. The dialog will 
clear and allow the creation of a new alignment

9. In the Description field key-in CL CR 303and then the Tab key.

10. From the Style drop down list select RW_Sec-Line_ex

Note: In this instance CL CR stands for Center Line of County Road 303. Do not confuse 
the L and R used in the description with the L and R used to indicate the curve 
direction, as described on the previous page.
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11. <D> the Start button the dialog will collapse and you are prompted to Identify Point.

12. <D> near the points on the screen starting on the south end.   Continue to graphically select 
points to define the alignment. Graphics will display showing the alignment location. By 
default, the alignment will pass through the existing geometry points nearest the data point 
because the geometry point snap is enabled.

13. <R> when finished selecting points graphically, the Create/Edit Alignment by Cogo Points 
dialog will redisplay.
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14. <D> Stop button the Create/Edit Alignment by Cogo Points dialog will show the selected 
points in the Alignment Definition.

Note:Cogo points can be deleted, inserted, cleared, 
or edited directly in the Alignment definition 
section of the Create/Edit Alignment by Cogo 
Points dialog. If desired, the entire definition can be 
input through the use of the keyboard.If any points 
were selected by mistake, they can be edited. Using 
the cursor and keyboard, simply replace the 
accidental input(s).

15. In the Alignment Definition area key-in 119 for the second point.

16. <D> Apply the horizontal alignment is created and displayed.
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Note:

♦ Alignments are direction based. If the above workflow was followed, the created 
alignment runs South to North. This becomes important when offsetting the alignment 
to either the left or right (left is input as a negative number)

♦ Alignment direction can be ascertained by: reviewing the alignment, by tracking, or by 
displaying stationing

♦ Alignment direction can be 'reversed' by using the Geometry > Transpose command

♦ Alignments created by chaining Cogo points can be edited using the Geometry > 
Horizontal Curve Set tools

17. In the InRoads explorer pane, verify the alignment was created

18. <R> the alignment name West Line of Sec 13 from the pop up menu <D> Review

19. <R> the Geometry Project name 12345_ROW from the pop up menu <D> Save
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Development of right of way information can be facilitated using Cogo intersection commands.  These Cogo 
points can then in-turn be used to define alignments (parcels).  While this is a potential workflow, it is not 
necessary to first create Cogo points.  It is simply one solution to establish required geometry information.

Chapter Objectives:

 Create Cogo points through various Intersection Commands 

 Generate Alignments from Cogo Points

In order, create Cogo points for:

♦ A) The intersection of the design reference line and the west line of section 13, “Lab 
10.1 - Alignment-Alignment Intersection”

♦ B) The NE corner of Summit Business Park, “Lab 10.2 - Alignment - Alignment 
Intersection using Offsets”

♦ C) A right of way point on the east side of County Road 303, “Lab 10.3 - Direction - 
Alignment Intersection”

♦ D) The NW corner of Summit Business Park, “Lab 10.4 - Station & Offset”

♦ E) The SW corner of Summit business Park, “Lab 10.5 - Traversing”

♦ F) The SE corner of Summit business Park, “Lab 10.6 - Direction - Direction 
Intersection”
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Lab 10.1 - Alignment-Alignment  Intersection

Grouping Cogo point numbers together is desired. All Cogo points for these exercises are to start with point 
number 300 and automatically increment.  Establish a Cogo point at the intersection of the project reference 
line with the west line of section 13. Two alignments exist representing these features: C_Centerline & West 
Line Sec 13

1. Select File > Project Options > [Geometry]

♦ Input a Seed Point Name of 300

2. <D> Apply

3. <D> Close

4. Select Geometry > Locate > Intersection

The Intersection dialog opens.  The Type selection list defines typical Cogo intersection 
commands. 
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5. Select Type: Alignment/Alignment

6. Complete the dialog as shown below.

Note: In addition to selecting the alignments to intersect, offsets can be defined. A 
negative sign (-) indicates an offset to the left.

7. <D> Apply, a results dialog opens if report lock is enabled. Also if Cogo Audit Trail is 
still enabled from a previous lab, the results are written to the *.atf
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8. Key-in a Description, and choose a Style as shown.

Note: If it is possible for the intersection command to provide another solution, selecting 
the Reject button will display the alternative results.  Results are shown 
numerically in the dialog and dynamically on in the MicroStation screen.

9. <D> Accept -  the new Cogo point is created at the intersection.
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Lab 10.2 - Alignment - Alignment Intersection using Offsets

Use the intersection command to establish point 301 at the intersection of the south right of way of S.H. 86 and 
the west right of way of CR 303.

1. Select Geometry > Locate > Intersection

2. Complete the dialog as shown.



Page 72 Colorado Department of Transportation

LAB 10 - Cogo Intersection Commands Labs for ROW Geometry

Note: Notice the negative offset defined for Alignment 2. The alignment representing the 
west line of section 13 runs south to north. A negative offset indicates a distance to 
the left.

3. <D> Apply

4. In the Location Results dialog, Key-in:

♦ Seed Name: 301
♦ Description: Existing RW @ CR 303
♦ Style: RW_ROW-Line_Exist

5. <D> Accept - to create point 301.
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Lab 10.3 - Direction - Alignment Intersection

Use the intersection command to establish point 302 on the east right of way of county road 303.

1. Geometry > Locate > Intersection

2. Complete the dialog as shown below:

♦ Type: Direction/Alignment
♦ Name: 119 (origin point)

♦ Direction: a 119 121  <tab> (computes the bearing from point 119 to 121)

♦ Alignment: West Line of Section 13
♦ Offset: 30.00 (to the right - positive)

3. <D> Apply
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The Locate Results dialog appears.

4. Seed name should reflect 302, if not, key it and a description in, and select a style.

 

5. <D> Accept - to create cogo point 302.

The limits of the adjacent subdivision, Summit Business Park, will be established.  We had 
previously defined the NE corner of the plat at Cogo point 301. 

♦ Establishing the plat boundaries will be done in the following order:

♦ Establish the NW corner by Station and offset

♦ Establish the SW corner by bearing & distance

♦ Establish the SE corner by intersection

♦ Create an alignment representing the subdivision boundary
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Lab 10.4 - Station & Offset

Use MicroStation to view the NW corner of the subdivision


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Establish a Cogo point at the NW corner of the subdivision.

 

A Cogo point is necessary at station A 414+48.30, 100.09’ RT

The stationing for establishing point 303 is relative to the reference line C_Centerline. The letter ‘A’ indicates 
this location falls within a station equation range.

1. Set C_Centerline as the active horizontal alignment. 

2. Select Geometry > Horizontal Curve Set > Events

The Horizontal Events dialog is multi-functional; it provides the ability to enter:

♦ Event points relative to a horizontal alignment 

♦ Generates points in the Cogo buffer

♦ Generates Cogo Points based on alignment vertices



Colorado Department of Transportation   Page 77

Labs for ROW Geometry LAB 10 - Cogo Intersection Commands

3. In the Add As section: radio button on Cogo Point

4. Set Define By to: Single Station              

♦ Single Station - defines a location by station, offset definition

♦ Single Point - defines locations by coordinate values

♦ Multiple Stations -  defines locations at a specified intervals and offsets

5. Key-in a Seed Name: 303

6. Enter a Description and select a Style as shown.

7. Key-in Station: A 414+48.30

8. Key-in Offset 100.09

9. <D> Apply - to create the Cogo point.

 

10. <D> Close to close the Horizontal Events dialog.

The cogo point is created.
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Alternative Solution

1. Select Geometry > Cogo Points > New

The Define By field can be toggled between Northing/Easting and Station/Offset.

Lab 10.5 - Traversing

Create a Cogo point to establish the SW corner of Summit Business Park by bearing and distance.  The corner 
lies S 0° 34' 04.55" E, 1822.75 feet south of the NW corner of the plat.

1. Select Geometry > Traverse
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2. Input the data values as shown below. 

3. <D> Apply - to create a Cogo point at the Southwest corner of the plat.
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Lab 10.6 - Direction - Direction Intersection

Three of the four corners for the plat Summit Business Park are created.  Only the SE corner remains.  
Establish the SE corner by intersection.

Criteria for establishing the SE corner:

 The south line of the plat bears N 89 55 40.5 E

 The east line of the plat is parallel to the west line of Section 13

1. Select Geometry > Locate > Intersection

2. Set Type: Direction/Direction

Direction 1 

 Name: 304
 Direction: Key-in N 89 55 40.5 E
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Note: The selection button on the dialog can be used to populate the Name (coordinate) 

fields.  To select Cogo points the point snap must be toggled on.  . Turn this lock off 
after use.

Direction 2

 Name: 301
 Direction: Key-in  S 0 36 36.66 E (SE or NW will both work)

Note: The Angular Precision set by Tools > Options > [Precision] affects the display of 
Direction input fields throughout InRoads.  CDOT Preferences set the Angular 
Precision to 0, therefore an input of N 0 36 36.66 W will be reformatted by InRoads as 
N 0 36 37 W.  The actual input will be used in the calculation.

Note: The selection button on the dialog can be used to populate the Direction field. 

The required direction is parallel to the west line of section 13
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To use the selection button for direction definition:

 Toggle on the Element lock  

 <D> on the selection button 

 <D> on the west line of the SW ¼ of Section 13

The direction of the identified geometry line populates the dialog.
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1. Make sure both offsets are set to zero

2. <D> Apply 

The Locate Results dialog appears.

Enter:

 Seed Name: 305
 Description: SE Cor SBP @ CR 303
 Style: RW_ROW-Line_ex

1. <D> Accept - to create the final Cogo point at the Southeast corner of the plat.

2.  Toggle the geometry snap  Off       

Note: It is good practice to leave geometry snaps off except when explicitly required.
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Chapter Objectives:

 Create Cogo points through various Intersection Commands 

 Generate Alignments from Cogo Points

The plat of Summit Business Park has the 4 corners defined by Cogo points.  Creating a closed alignment using 
the PI Method to represent the boundary of the plat will facilitate right of way creation.

Create a new horizontal alignment named Summit Business Park.

1. Select File > New > [Geometry]

2. Type: Horizontal Alignment

3. Name: Summit Business Park

4. Description: SW of int. of RL & CR 303

5. Style: RW_Property-Bndry-Line_ex

6. Curve Definition: Arc

7. <D> Apply
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8. Set the active horizontal alignment: Summit Business Park 

9. Select Geometry > Horizontal Curve Set > Add PI

10. You are Prompted to: Identify Alignment End
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11. Toggle On the geometry Point snap  

12. Select the plat corners in a counter-clockwise direction

13. <D> near the SW corner of the plat (defines the POB)

14. <D> near the SE corner of the plat

15. <D> near the NE corner of the plat

16. <D> near the NW corner of the Plat

17. <D> near the SW corner of the plat (defines the POE)

18. <R> to cancel point selection, <R> to terminate the command

19. Toggle Off the geometry point snap 

20. Select Geometry > Review Horizontal to verify the contents of the alignment.

Note: Notice the lack of point names (or Cogo numbers) in the parentheses.  Also note 
the parcel area information is displayed and the alignment is dynamically 
highlighted on the screen.

21. Close the Review Horizontal Alignment dialog
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The population of the name/number field is contingent on the settings under File > 
Project Options  [Geometry] at time of geometry creation.

Geometry Verification

As seen above, the Cogo points selected to define the alignment are not necessarily a part of the 
definition of the alignment.  To rectify this, 2 possible solutions exist.  Firstly, the Create/Edit 
Alignment by Cogo Points command could have been used to generate the alignment initially.  
Secondly, this same command can be used to assign and verify the alignment.

1. Select Geometry > Utilities > Create/Edit Alignment by Cogo Points
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2. <D> Yes

The alignment is associated with the selected Cogo Points.

3. Edit points as necessary.

4. <D> Apply – verify results by reviewing the alignment.
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Lot number 1 lies at the Northeast corner of the Summit Business Park plat. Right of way acquisition will 
occur along the northerly limits of the plat. A parcel needs to be created from the deed information for lot 1.

Chapter Objectives:

 Create a closed parcel

 Use Traverse Edit Add-In application

To create the parcel (closed alignment) for lot 1, the InRoads command Geometry > 
Traverse could be used.  Another solution is to use the Traverse Edit command.  Traverse Edit 
is an Application ADD-In command and must be enabled.  In addition to allowing traversing, 
the traverse edit command reports on parcel closure and provides adjustment commands. 
Additionally a Mets and Bounds command could be used.  

1. Using InRoads, select: Tools > Application ADD-Ins…

2. Toggle On the Traverse Edit Add-in
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3. <D> OK

Note: When enabling the Traverse Edit Add-In, the Metes & Bounds and Traverse 
Adjustments command are also enabled.

These commands provide similar functions. The Metes & Bounds dialog is presented in a table 
format and edits can be accomplished directly in the dialog. Traverse adjustment can be 
accomplished by selecting Geometry > Utilities > Traverse adjustment. The Traverse edit 
dialog provides input, edits, and adjustment in a single dialog.

Note: The Traverse edit command will be used in this lab and requires an alignment 
to exist prior to populating the alignment. The Metes & Bounds dialog allows 
creation of an alignment in the dialog. 

Create an alignment to store Lot number 1.

4. File > New > [Geometry], Select the Geometry tab and input:

5. Type: Horizontal Alignment
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6. Name: Summit BP Lot 1

7. Description: Lot 1 of Summit Business Park

8. Style: RW_Property-Bndry-Line_ex

9. <D> Apply

10. Select Geometry > Utilities > Traverse Edit to open the Traverse Edit dialog box.

11. Set the fields for the Geometry Project and Horizontal Alignment.

12. Key-in: 301 for the Starting Point (Cogo point 301 is located at the NE corner of lot 1).
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13. Lot 1 is described as:

Commencing at the West ¼ corner of Section 13, Township 8 South., Range 64 West.  
Thence along said section line N 0-37-05 W, 154.14 feet. Thence departing from said 
section line S 89-22-55 W, 30.00 feet to the westerly right-of-way line of County Road 
33 and the Point of Beginning.

1. Thence S 0-36-32 E, to the northerly right of way line of Summit Business Park Road, 
384.92 feet.

2. Thence along said right of way line, S 89-23-57 W, 98.15 to a point of curvature. 

3. Thence N 81-49-50 W, 64.65 feet along the chord of said curve, having a 200.00’ 
radius to the right.

4. Thence N 73-03-36”W, 129.63 feet. Thence departing from Summit Business Park 
Road, N 0-34-22 W to the southerly right of way line of S.H. 86, 416.94 feet.

5. Thence along said right of way line, S 74-45-58 E, 296.65 to the point of beginning.

14. <D> the Add After button on the Traverse Edit dialog.

15. Set Type: Linear
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16. Input the Direction and Distance for the first course as shown.

17. <D> Apply - the course is added to the alignment.

18. Input the second Course.



Page 96 Colorado Department of Transportation

LAB 12 - Parcel Creation by Deed Labs for ROW Geometry

19. <D> Apply - the second course is added to the alignment.

20. Input the third course – change Type: Circular
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21. <D> Apply - the third course is added to the alignment.

Note: As courses are entered, the parent dialog displays closure results.

22. Input the fourth course and <D> Apply
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23. Input the fifth course and <D> Apply

24. Input the sixth and final course and <D> Apply
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25. Review Closure Results in the parent dialog.

26. <D> Apply to create the alignment.

Note: The Report button on the dialog can be used to summarize the alignment. The 
report can be written to a text file.

The Adjustments button on the Traverse Edit dialog is dithered.  If the alignment 
contains circular elements, adjustments are not enabled.

Challenge Lab:

♦ Edit the record containing the curve by <D> on it and selecting Edit
♦ Change the record type to Linear
♦ Input the chord Direction and an the chord distance (which is incorrect) <D> Apply
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♦ Close the Edit Element dialog

♦ <D> on the Adjustments button

Select the appropriate Method

<D> OK to apply the selected adjustment

Note: The columns for Unadjusted and Adjusted values.  As the various radio 
buttons for method are selected, the adjusted values update providing a 
preview of potential solutions.
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InRoads has a utility to create additional parcels (closed alignments) from existing parcels and crossing 
alignments.  As illustrated below, lots 1-4 have been created and the proposed right of way indicates required 
right of way acquisition along the northerly limits of the lots.

Chapter Objectives:

 Create a closed alignment from existing alignments

The command used for this exercise is another application ADD-In and is added to the 
Geometry > Utilities menu.  The Create Right-of-Way menu item is a subset of the Lot 
Creation application.
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If you do not see the Create Right-of-Way option, go to Tools > Applications Add-Ins 
and activate Lot Layout Add-In. 

Parcels have been created for Lots 1-4 and stored in the Geometry Project 12345_SummitBP.  
Load this geometry project from the folder:
C:\Projects\12345\ROW Survey\InRoads\Geometry

1. File > Open – Open the Geometry folder noted above.
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2. Load the 12345_SummitBP.alg file.

 

3. Select Geometry > Utilities > Create Right-of-Way

Dialog Settings:
♦ Alignment (selected) - Original parcels impacted by ROW acquisition

♦ Cogo Points - If enabled, will create Cogo points at the intersection of the proposed 
right of way and existing lot lines

♦ Right of Way - If enabled, creates parcels representing the acquisition area

♦ Remainder - If enabled, creates parcels representing the remainder of the selected lots
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4. Complete the Cogo Points section as shown.

5. Complete the Right-of-Way section as shown.
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6. Complete the Remainder section as shown.

7. <D> in the Alignment field and then <D> on the Filter button.

8. Under the Available column, select Summit BP Lots 1-4.

9. <D> the Add button.
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10. <D> OK

11. The parcels are added to the list.

12. <D> Apply - you are prompted to identify the Right of Way Alignment.
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13. <D> on the alignment S.H. 86 South ROW - parcel previews will highlight

 

14. <D> inside any acquisition parcel to define which side of the identified alignment the 
acquisition parcels lay - the parcels and Cogo points are then created.
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Parcel information can be annotated in the MicroStation drawing using InRoads geometry commands.

Chapter Objectives:

 Annotate traverse information

The InRoads command used for this exercise is located on the Geometry > View Geometry 
menu.  

1. Select Geometry > View Geometry > Closed Areas

2. <D> the Preferences button.

3. Load the settings for proposed parcels.

4. Define the acquisition parcels for annotation. Use the filter the select the alignments. Enter 
a data point in the alignment field and the filter button activates.

5.
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6. Toggle On the desired information in the Annotate section, <D> Apply

 

7. Repeat steps 2-5 for the Remainder parcels using the Property-Existing Preference.

8. Toggle on all the Annotate radio buttons, <D> Apply - the graphics refresh.

Note:

♦ There are saved preferences in the View Closed Area dialog for existing vs. 
proposed annotation

♦ The number of decimal places, prefix, and Suffix annotation can be input by the user.
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Challenge Exercise – Transforming a parcel

Use the TravEdit command to generate a parcel (alignment) for lot 5 of Summit Business Park.  
The graphic below shows the required courses to create said parcel.  Once created, use the 
Transform command to move and rotate the parcel so that the NE line of Lot 5 coincides with 
the SW line of Lot 4.

Create a Horizontal Alignment to store Lot 5.

1. Select File > New > [Geometry] – Horizontal Alignment

2. Select Geometry > Utilities > Traverse Edit

Assume a starting location (this may be based on a call-out, existing geometry point, or an 
assumed location).
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Key-in a Starting Point of: - DO NOT INPUT COMMAS
N = 1,556,000.00
E = 3,277,600.00

Enter clockwise courses beginning with the NW corner of Lot 5.

3. Select Add After and input:
S 62-33-49 E, 638.13
S 41-40-12 W, 92.80
S 88-10-38 W, 492.83
N 01-49-28 W, 379.21
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4. <D> Apply to create the parcel once all courses have been entered and verified by 
reviewing the closure results.

 

The parcel is created to the west of the true location.  It also has a slight rotation. 

Use the Transform command to relocate and rotate the parcel.  Do so in 2 steps. First move the 
parcel, and then rotate it to align with Lot 4.

5. Select Geometry > Utilities > Transform

6. Identify the Alignment to transform

7. Identify the coordinate values for both the Original & Destination Points
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8. <D> Apply

 

The parcel is relocated but a rotation is evident.

Continuing to use the transform dialog.

9. Set the Original Point and Destination Point to the same value (the point to rotate about)

10. Identify the value of rotation required by key-in or by using the selection icon to 
graphically pick points A, B, & C shown above to define the rotation angle. 

11. <D> Apply
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The parcel (alignment) is transformed.

Important! Verify the results with reports, display, annotation, or other means.

Note: Relocating and rotating the parcel could have been accomplished in a single 
operation if so desired
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LAB 15 - Parcel Descriptions

The InRoads Report Browser allows the user to view reports using a reporting utility based on the eXtensible 
Markup Language or more commonly referred to as XML. Like the HTML language used for web 
development, XML reporting is based on tags and attributes which delineate elements of data. Formatting of 
XML data is accomplished through the use of XSL, or style sheets and displays in a web browser page.

Chapter Objectives:

 Create a parcel legal description

1. Select the Tools > XML Reports menu item to check the available menu items.

2. Select Legal Description

3. <D> the Filter button and add Summit BP Lot 1Acquire as a selected alignment.

4. <D> OK

5. <D> Apply

6.
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An XML file and a report is created with format and display from an InRoads default style 
sheet.

7. <D> on the various report styles (*.xsl) displayed in the left panel and notice the change to 
the format and contents of the displayed report.

8. In the Report display, select Tools > Format Options

9. <D> Acres/Hectares: Set to 5 decimal places - the report updates.
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10. Change any of the fields in the Format Options dialog and notice the report interactively 
updates.

11. <D> on the CDOT folder and select the various formats.

12. In the Report display, select File > Save As…

Save As: 

Path: C:\Projects\12345\ROW_Survey\InRoads\Reports
File Name: SBP Lot 1Acquistion.xml

13. <D> Save
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Reports can also be recalled for reformatting, etc.

14. Select Tools > View XML Reports

15. From the report browser  File > Open 

16. Open the SBP Lots 1-4.xml file from the folder: 
C:\Projects\12345\ROW_Survey\InRoads\Reports\

17. Select the folder and style sheet to apply to the XML data.

18. <D> on the category Geometry and style sheet Area.xsl

Note: Lot areas and perimeter distances are reported.



Colorado Department of Transportation   Page 121

Labs for ROW Geometry LAB 15 - Parcel Descriptions

19. In the category CDOT, access style sheet List Coordinates

The report is redisplayed to display alignment coordinates.

20. While viewing the xml report, <R> in the area of the screen listing the coordinates. A fly-
out menu appears.
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21. <D> on Export to Microsoft Excel

Excel will launch Excel.
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To view the source information the xml report was generated from:

22. In the Report browser, select Raw-xml.xsl in the left panel

What you see are the xml tags and attributes which define the report contents. Formatting 
of this data for display is accomplished through the use of xsl, or style sheets.  Style sheets 
can be developed by the user for customized reports or formats.

Other formats:

In the category DataCollection access style sheet 
ListCoordinatesSDR32InternationalFoot

Experiment with other style sheets such as HorizontalElementsSDR33 as well as other style 
sheets in the Geometry category.
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Chapter Objectives:

 Import Cogo Points from graphics

 Import Cogo Points from ICS

Lab 16.1 - Importing Cogo Points from Graphics

Graphic elements can be imported to generate geometry. Some of the valid element types are: 
lines, linestrings, cells, text, shapes, etc. Refer to the InRoads help topic Import Geometry

To import Cogo points from a graphics file;

1. Identify graphics using a selection set or a MicroStation fence
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2. Select File > Import > Geometry > [From Graphics] Type – Cogo Points

3. <D> Apply

4. Verify the results
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Lab 16.2 - Importing Cogo Point from ICS

From the CDOT manual: Roadway Design Using InRoads – Importing Geometry from text 
files

Text files may be imported from several formats, the easiest of which to create is an .ics file. 
(Interactive Coordinate geometry Subsystem) This file type was first used with a product of the 
same name many years ago, but is still in use with InRoads today. It is basically a list of cogo 
commands along with the input for those commands.

If you have a text file of coordinates, you can create an .ics file by adding a Store command at 
the top and formatting the file similar to the one shown below.

1. Choose File > Import > Geometry > [ICS]
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2. Browse to find the file then choose Apply. 

The cogo points will be added to the active geometry project. You may then use Geometry > 
Utilities > Create/Edit Alignment to join the points, forming an Alignment and 
Geometry > Horizontal Curve Sets > Define Curves to add curves to the alignment.  
You can also accomplish these same tasks within the .ics file.  See the Bentley Help topic 
Alpha Cogo
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Chapter Objectives:

 Setup project parameters

Project geometry parameters are defined by the user.

1. Select File > Project Options > [Geometry] 

Geometry Defaults
○ Plotting Height - default elevation assigned to geometry points. Defines the 

elevation at which annotation will be placed in a 3D file.

○ Seed Alignment Name - initial name assigned to alignments

○ Seed Point Name - initial Cogo point name or alignment vertices name

○ Curve Definition - arc, chord, length of curve definitions

○ Angular Mode - Bearings or Azimuth settings

○ Point Names During Edits - horizontal alignment vertices

○ Do not assign - creates unnamed points
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○ Assign - creates sequential alignment vertices names based on the seed point 
name

Note: Alignment vertices defined with alphanumeric characters are not entered into 
the Cogo buffer by default.  The Horizontal Event Point command can be used 
to send alignment key points to the Cogo buffer.

2. <D> Units and Format

InRoads does not recognize or use the unit definition associated with the host MicroStation 
file. The units defined under the units and format tab define the units of measure for 
InRoads data. For commands that utilize distance or area parameters, InRoads looks to the 
settings in this dialog to determine if the distance or area defined is imperial or metric units.

○ Units Linear - Imperial or Metric

○ Units Angular - Degrees, Grads, or Radians

○ Format Angular - Degrees, Minutes, Seconds or Decimal Degrees
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3. <D> Precision

The precision tab defines the number of decimal places displayed in dialogs. It also defines 
the number of decimal places displayed when posting information to the MicroStation 
screen or when writing data to an ASCII file.

Note: The settings in the precision tab only effect display settings. It does not define 
computational parameters.
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LAB 18 - Horizontal Regression Analysis

Regression analysis can be used to facilitate the development of horizontal alignments by creating a ‘best-fit’ 
alignment through defined points.

Chapter Objectives:

 Setup horizontal regression analysis project parameters

Regression analysis setup.

1. Create a horizontal alignment to store the results in.

2. Select Tools > Application Add-ins to enable the command.

3. Select Geometry > Horizontal Regression > Add Regression Point  The Add 
Horizontal Regression Points dialog will appear.
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4. <D> in the Include field so the Filter button becomes activated.

5. <D> the Filter button.  The Geometry Selection Filter dialog will appear.

6. Create a selection of centerline points to be used for analysis.
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7. <D> the OK button in the Geometry Selection Filter dialog.

8. <D> the selection button.  Use the combination box or graphically define the first and 
second points to define initial point and direction for evaluation.

9. <D> the first point in the MicroStation view and <D> second point in the view to define 
the direction of the analysis.

10. <D> the Apply & Close buttons.
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11. Select Geometry > Horizontal Regression > Edit/Review Regression Points.  
The Edit / Review Horizontal Regression Points dialog will appear.

12. Refine the selection of points to be used for analysis by using the Ctrl and Shift keys or 
using the Select button to define a selection area. Alternatively a fence can be placed 
around the points to be included in the regression. If a fence is used, a <Shift> <D> on the 
Select Only button will include fenced points in the regression analysis.

Note: Additional information can be access by selecting the Help button found in all 
dialogs.

13. <R> on points and select Edit from the fly-out menu to edit.  The Edit Horizontal 
Regression Point dialog will appear.

14. <D> the radio button Yes to Include in Analysis.

15. <D> Apply to effect any changes then Close. 

Note: The Offset value show above regresses through a point at the defined offset from 
the selected point. To define a regression bandwidth, select the Quick button on the 
Edit/Review dialog. Tolerance defines only points that are offset less than or equal 
to the tolerance defined.
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16. Select Geometry > Horizontal Regression > Single Element Regression 
Analysis  The Single Horizontal Element dialog will appear.

17. Select Geometry > Horizontal Regression > View Regression Point to display 
symbology for the selected points.

18. Select Element Type: Linear or Circle

19. <D> Compute to view the results in the MicroStation view.
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20. <D> Save to create the alignment element.

21. <D> the Report button to view a summary.

22. Review the results.

Note: Additional curves and tangents would have to be regressed to complete the 
alignment. Once created, regressed elements could be managed using the advanced 
geometry Horizontal Element commands.
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LAB 19 - Placing cells

Standard sheets have been provided to facilitate plan development. These sheet require customization for 
specific projects

Chapter Objectives:

 Open MicroStation Title Sheet using CDOT User workspace

 Place RLS Stamp at correct scale for Title Sheet

1. In the MicroStation Manager dialog box, go to the Workspace group section and 
change the User field to CDOT USER, the Project field to 12345 and the Interface 
field to CDOT. 

This workspace setup should load the correct MicroStation environment (including toolbars) 
when the selected MicroStation file is opened.

2. Navigate to the folder ROW_Survey\Drawings 

3. <D> on file 12345ROW_TitleSht.dgn
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4. <D> Open in the MicroStation Manager dialog box to open the file.

Your graphics window should appear as shown.
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Note: The file names and directory structure used in this course are based on current 
information.  As the CDOT configuration develops and directory structure and file 
naming conventions are standardized, these may change.

The default Model scale for CDOT plan sheets is 1:100.  For sheets that are text 
based such as title sheets, and tabulation sheets, the Model scale is set to 1:1. Using 
the annotation scale lock synchronizes both graphics and text placed in the 
drawing.  For drawings at other scales, the model properties will require 
modification.  See the instructor if additional information is required.

Insert the Region, Designer information in the upper-left corner of the sheet.

5.  The CDOT Menu should open by default when MicroStation is launched.  If for any 
reason the CDOT Menu is not open, you can open it from the Main Task menu.

6. From the CDOT Menu <D> on Group Display>Select All.

7. Select  ROW Survey in Group Display

8. Set the Status to Proposed

9. Select Borders PLS
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10. Select the Survey Supervisor Kevin Williams

 

11. In the Active Settings dialog box  set Active Scale to 1.00 and Active Angle to 
0.00

   

12. <D> Apply

13. <D> Close

14. Place the cell at the upper-left corner of the sheet as shown


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Challenge Exercises

 Verify the coordinates at the lower left corner of the sheet (tentative snap).  Should be at 
0,0,0

 Determine the length and height of sheet (measure tools or AccuDraw).  Should be 11 x 17

 Investigate the levels the graphics are on (level display, element information, or pop-up 
information)
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LAB 20 - Editing Text

Chapter Objectives:

 Edit existing text

 Add additional text

Formatting has been defined for standard sheets.  Text fields indicated with an ‘X’ indicates the 
user needs to input project or sheet specific information.

1. Navigate to the ROW_Survey\Drawings\ directory and open the filename 
12345ROW_TitleSht.dgn

2. Window into the top center of the title sheet.

3. Select the Edit Text command.

4. <D> on the FEDERAL AID PROJECT NO. XXXXXXXXX text string.

5. In the Text Editor dialog box, correct the project identifier text and change to STA 086A 
– 039 as shown.
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6. <D> on the MicroStation screen to execute the edit.

7. Optional – complete edits to the other project identification text.

Challenge Exercises

 Add another line of text that matches both the text and symbology of the existing text

 Complete the upper right-hand corner of the sheet as shown

 Use the Edit Text command to complete the scale bar
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Vicinity maps can be referenced to the title sheet. These maps can be in the form of vector files (CADD 
elements) or raster files (images).

The CDOT standard procedure is to use county maps that have been translated from GIS information, these 
maps can be found on the shared drive at: \\public\CADD County Maps\. The county of interest should be 
copied to your project location drawings folder and can be attached as a reference file to the Title Map. The 
local map can be edited as desired without affecting the original.

Chapter Objectives:

 Reference CADD County Map into Title Sheet

 Trim Vicinity Map reference file

For training purposes, a vicinity map has been stored in the References folder.

Review the vicinity map.

1. Open the MicroStation file Elbert.dgn
this file is located in: C:\Projects\12345\Design\Drawings\Reference_Files

This file contains a Saved View to assist in attaching it as a reference file.

2. Select Utilities > Saved Views from the MicroStation pull-down menu.

3. <D> on the saved view by the name of plan
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4. <D> in the MicroStation view

The MicroStation view updates to the limits of the saved view.

5. Use other MicroStation view commands to investigate the contents of the drawing.

Open the MicroStation Level Display dialog to investigate level stratification by choosing, 
Settings > Level > Display.  Note all information resides on GIS_* levels.
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6. Turn level displays on and off to verify data stratification, then Close the Level Display 
dialog.

Attaching a vicinity map as a reference file

Attach the vicinity file as a reference file to the title sheet. Once attached, move, scale, and 
constrain the display limits.

Reopen the title sheet: 12345ROW_TitleSht.dgn. Once open:

1. Select File > References from the MicroStation menu bar.

2. In the References dialog box, select Tools > Attach

3. <D> the file Elbert.dgn from the ….Design\Drawings\Reference_Files directory.

4. <D> Open
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5. Key-in the Logical Name: Vicinity 

6. Key-in the Description: GIS locator map for title sheet

7. Select the Saved View > plan option in the Orientation section of the dialog box.

8. GIS maps have been designed to be inserted at a scale factor of 1:5280 (Master : 
Reference).  Enter that value for the Scale option.
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9. <D> OK

 

In the MicroStation view window, the limits of the saved view dynamically display relative to 
the location of the cursor.



Page 152 Colorado Department of Transportation

LAB 21 - Vicinity Map - Vector Labs for ROW Geometry

10. <D> in the MicroStation view window area to attach and display the contents of the 
reference file.

11. Select the MicroStation Fit command.

Move the reference file to align with the title sheet.

12. Select Tools > Move in the References dialog.
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13. <D> at point A and then <D> at point B to move the attached reference file.

Execute additional move commands to reposition the reference file as necessary.

14. <R> to exit the Move References command.

15. Zoom into the Project Location Map area of the Title Sheet.
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Constrain the display limits of the reference file (clip boundary)

16. Select Tools > Clip Boundary from the Reference File dialog. 
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17. In the Tool Settings dialog. Set method to Element

18. <D> on the shape representing the limits of the location map display.

19. <D> a second time (anywhere on the screen) to accept the displayed solution.
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20. Use the MicroStation command Modify Element command to resize the shape identified to 
define the clip boundary.

The reference file clip boundary will reconfigure with the shape modifications.

Note: The exercise just completed used an existing MicroStation shape to define 
reference file clipping boundaries.  The same process can be followed by using a 
MicroStation Fence to define (and redefine) the reference file clip boundary.

Challenge Exercises:

 Move the shape used to define the reference file limits.  What happens to the graphics 
limits displayed?

 Use the References dialog to move the vicinity map after it has been clipped.

 Delete the shape used to define the reference file limits. What happens?  (select undo, to 
restore the shape)

 Turn levels on and off for the reference file attachment

 Constrain the reference file display using a fence block

 Try using a circular fence to define the clipping limits

 Define a clip mask within the reference file limits
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 Modify elements in the file Elbert.dgn, what happens to the graphics displayed in the 
vicinity map?
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LAB 22 - Locator Map – Raster Reference File

Chapter Objectives:

 Reference locator map into Title Sheet

 Trim locator map reference file

Attach a raster reference file for the locator map. Once attached, move, scale, and constrain the 
display limits.

In the CADD file for the title sheet:

1. Remove the reference file (Elbert.dgn) from the previous exercise by selecting Tools > 
Detach from the References dialog box.  

2. Select File > Raster Manager from the MicroStation menu bar.

3. Select File > Attach > Raster in the Raster Manager dialog.

4. Browse to the …\ROW_Survey\Drawings\Reference_File folder and select the file
Raster locator map.jpg

5. Key-in the Logical Name Locator
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6. Key-in the Description Raster location map

7. <D> OK

8. As in the previous lab, <D> to define the lower left and upper right corners that define the 
desired limits for the reference file.

The raster reference file is attached to the title sheet
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9. In the Raster Manager dialog, select Edit > Clip

10. Follow the MicroStation prompts to define the clip of the raster so it appears approximately 
as shown.
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LAB 23 - Annotation

Chapter Objectives:

 Annotate using the Place Note command

Annotate the locator map using the MicroStation place note command.  First select the correct 
symbology using the CDOT Menu.

1. Activate the Drafting Group Display.

2. <D> Text button in Drafting area.

3. Set the Title Text Type (button labeled T in Drafting area).

4. Set the Justification to Left Top 

5. Select .14” 100% Place Note as shown.

The correct settings and symbology are now set and the MicroStation Place Note command 
should automatically execute with the correct Text Style specified in the Place Note dialog.
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6. Select the Dimension Style CDOT 1

7. Expand the Place Note dialog and note the available options.  Make sure the options 
selected match those shown below.
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8.  Key-in the required text as shown.

9. Follow the MicroStation prompts to place the leader line and text (the first <D> will 
define the location of the arrow).

Repeat for the end of project information.

10. Key-in the required text as shown.
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Follow the MicroStation prompts to place the leader line and text

11. Select File > Save Settings

Challenge Exercises:

 Insert a scale bar cell and/or north arrow (General.cel)

 Input a basis of bearing note

 Replace the information in the top-left corner of the sheet (ROW.cel)
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LAB 24 - Land Survey Control Diagram Plan 
Sheet

Chapter Objectives:

 Import XML data into a MicroStation file

In this sheet, coordinate information will be input in a tabular format.

1. Select File > Open (if MicroStation is currently open).

 

2. <D> the filename 12345SURV_PlanLSCD##.dgn

3.  Select File > Save As from the MicroStation Manger dialog.

4. Key-in 12345SURV_PlanLSCD3B.dgn
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5. <D> Save

 

6. Zoom/Window into the upper-right corner of the sheet.

7. Edit the text as shown using Edit Text command.

8. Use the MicroStation Fit command to view the entire sheet.

In this sheet, place coordinate information representing a Project Coordinate Summary Table. 
This coordinate information will be extracted from InRoads using the reporting utility XML.
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Using XML to report on Coordinates

Use InRoads and XML reporting to insert a Project Coordinate Summary Table. Report on 
points 100-120.

9. If not already running and loaded:

○ Launch InRoads & Load the Geometry Project 12345_ROW.alg from 
C:\Projects\12345\ROW_Survey\InRoads\Geometry

10. Select Tools > XML Reports > Geometry from the InRoads interface.

11. In the XML Reports dialog, <D> the Geometry folder and identify Cogo points 100-120

12. <D> Apply. The report browser will open to a default report style.

13. <D> the CDOT Folder.
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14. <D> the CDOT_ListCoordinates.xsl style sheet.

15. Select File > Save As

16. Navigate to the 12345\ROW_Survey\InRoads\Reports folder and input the file 
name 12345_PCST01.xml

17. <D> Save to save the file.

Excel in MicroStation

Tables can be created in MicroStation by linking information that is contained in an Excel 
spreadsheet.  There are several advantages to using the linked spreadsheet method.  Some of 
these are:

♦ Text formatting in the spreadsheet is retained by MicroStation

♦ Graphics (borders, girds, etc) are retained from the Excel file
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♦ Updates to the Excel file are reflected in the MicroStation file

In the Bentley InRoads Report Browser:

18. <R> on the report in the coordinate list area as shown.  A fly out menu will appear.



19. Place the cursor over the coordinates (the bottom half of report) and select Export to 
Microsoft Excel from the fly-out menu.

Excel should automatically launch if it is installed on the PC being used.
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20. Make changes to the data or add formatting.

21. and save the spreadsheet to the …\ROW_Survey\InRoads\Reports\ directory.
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22. Select the range of information to be displayed in the MicroStation file.

23. <R> on the spreadsheet data and select Copy from the fly-out menu.

RETURN TO MICROSTATION

24. Select Edit > Paste Special from the MicroStation menu bar.

25. <D> the Linked Microsoft Office Excel 2003 Worksheet option.

26. <D> Paste

Note: By choosing linked, updates made to the Excel file can be passed back to the 
MicroStation file through updating.  Selecting embedded does not provide this 
dynamic ability.  
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27. In the Paste OLE dialog box, set Paste as to Link, Method to By Size, and input a 
Scale of 10

 

Note: At this time, we do not fully understand the correlation between the scale and 
resulting text size. For this example, 10 seemed to produce reasonable results.  
Once placed, the text height can be measured and the bounding shape of the linked 
Excel table can be scaled up or down accordingly to achieve required text size.

Note: Hatching on the MicroStation representation of the linked Excel data indicates the 
spreadsheet is currently open for editing.

28. Close Excel and note the hatching is eliminated  from the display.

Activating the Element Selection tool and entering a <D><D> on the border of the linked 
table in MicroStation will launch the Excel application.  If the Excel file is initialized from 
MicroStation the linked data will automatically update when the Excel file is saved and 
closed.

29. Use the MicroStation Element Selection Tool and <D><D> on the border of the linked 
data.

30. Make an edit to the spreadsheet data or formatting.
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31. Save and Close the Excel file. Note the linked data in the MicroStation file updates.

If the linked data is edited by launching the application outside of MicroStation, a manual 
update command must be executed. Select Edit > Update Links from the MicroStation 
menu bar to refresh the linked MicroStation graphics.

The linked data can be moved, scaled, or otherwise manipulated with MicroStation 
commands by selecting the border of the linked object.
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LAB 25 - Tabulation Properties Sheet

Chapter Objectives:

 Edit Microsoft Excel information from within MicroStation

In this sheet, information will be updated using Microsoft Excel.

Return to the MicroStation manager dialog.

1. Select File > Open

2. <D> the filename 12345ROW_TabProp01.dgn

3. <D> Open




4. <D> <D> on the outline of  linked data to open up XLS link in Excel.
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Note: When a linked excel file is opened for editing in Excel a hatched pattern displays in 
your MicroStation view.  This is to indicate that the file is being accessed from an 
external program.

    

5. Insert data into Excel.  (sample data is provided below)



 

Parcel No: 1 
Owner: Dianne M. McNamara & Ronald Eggleston
Address: 5937 Highway 86
               Elizabeth, CO  80107
Location: SE 1/ 4 Sec 9
Area of Parcel: 20,995 s.f.
                         (0.51 acre)
Net Area: 20,995 s.f.
                         (0.51 acre)
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6. Save and Exit in Excel; the MicroStation file will update.

  

7. To update MicroStation without exiting Excel: Save edited  Excel data. Then select 
Edit>Update Links from the MicroStation pull-down.


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LAB 26 - Reference Files for Plan Sheets

Chapter Objectives:

 Create plan sheets referencing in files

 Clipping reference files

 Rotate reference files

Two approaches can be used to assemble plan sheets.  In the first part of this chapter the 
‘manual’ method of attaching reference files will be used.  This is followed by using the 
InRoads sheet generation command known as the Plan and Profile Generator.

The contents of the reference files are not important to this process and may not accurately 
reflect the contents and layout of a final plan sheet.

This lab will relocate the border sheet to align with the design graphics.

Moving border sheets to align with design information

In a previous exercise graphics (locator map) were moved to align with the title sheet. This may 
suffice for information that is not coordinate dependent but is not an acceptable practice in the 
generation of engineering drawings.  The following workflow will result in a product that 
conforms to CDOT standards.  
This first lab uses the ‘manual’ method for designing a plan set layout and assembling the plan 
sheets.  A following lab will use the InRoads Plan and Profile generator command to 
‘automate’ the process.

The process for this lab is:

 Define the plan sheet limits, rotation, and size(s)

 Create a sheet file containing a border for each plan sheet

 Attach the appropriate reference files

 Rotate sheets normal to the MicroStation view for ease of use

 Define reference file clip boundaries
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1. Open the MicroStation file 12345ROW_Model.dgn

 

2. Select the MicroStation Fit command to expand the view to show all graphics.

3. Select Element > Cells to verify the ROW cell library is attached.
If not, select File > Attach from the Cell Library dialog and attach ROW.cel from the 
cell library list.
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4. <D><D> rapidly on the cell name RWPL Cuts to identify this as the ‘Placement’ cell and 
activate the place cell command.

5. In the Place Active Cell dialog, set the X and Y scale to 300, and Active Angle to 0.  
A Z scale of 1.0 should be used.  An X and Y scale of 300 is used because this reflects the 
scale the survey control diagram sheets will be developed at.
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About this cell:
This cell was created to facilitate the planning of eventual sheets.  It contains text characters 
that can be edited to indicate sheet name, rotation, & scale.  The outer line-work depicts the 
maximum display limits for graphics as it relates to the border sheet. The inside shape reflects 
½ inch inside this maximum limit. It also reflects the maximum limits that would be displayed 
if the sheet was created with the Plan and Profile generator command within InRoads.  The 
‘dots’ in the vertical lines represent ½ of the sheet height and assist in centering planimetrics 
information on the sheet.  All information is written to the MicroStation level 
DRAFT_INFO_No-Plot.

6. <D> to place the cell in the MicroStation file, move as necessary.  These graphics will 
define the limits for the plan sheet when referenced back to the border.

The above graphics approximately represent the required limits for the first sheet.  Position the 
sheet limit cell as you see fit.

7. Use the Edit Text command to complete the text at the bottom of the sheet.  This will assist 
in managing the sheets as reference files.
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8. <D> on the text at the bottom of the layout sheet.

9. Replace the appropriate sheet information in the Text Editor as follows:
LSCD03C
00-00-00
1”=300’

10. <D> anywhere to accept the change.

11. Use the MicroStation Copy command to duplicate the graphics for the second sheet.
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12. Use the MicroStation Rotate command to align the graphics for the second sheet (345 
degrees, -15 also works).

Replace the appropriate sheet information at the bottom of the copied sheet.  

13. In the Text Editor enter:
345-00-00

14. Continue planning the sheet layout for the remainder of the project.

Complete a few sheets to understand the concept. It is not the intention of this lab to complete 
the layout for the entire project.
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Note: Sheets at other scales could also be laid-out at this time.  For instance, 
monumentation or right of way plan sheets at a scale of 1”=100’

A major benefit of this workflow is that the eventual limits and orientation of sheets are 
determined early in the process. These sheet limits can be used to identify proper positioning, 
size, and rotation of text and tables. This is in addition to acting as a guide for attaching the 
planimetrics to the border sheets.

Assembling the plan sheets

15. Open the MicroStation file ….ROW_Survey\Drawings\ 
12345SURV_PlanLSCD##.dgn

 

16. File > Save the MicroStation file as ….ROW_Survey\Drawings\ 
12345SURV_PlanLSCD3B.dgn the new file is written to disk and opened.
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This file will be used to assemble drawing 4 of the plan subset.  This will be accomplished by 
aligning a cell representing the border with the planimetrics. The current graphics will not be 
used.

17. Delete the border sheet graphics contained in the MicroStation file.

This sheet will be developed at a scale of 1:300. The MicroStation model properties require 
modification so that the annotation scale matches the plot scale.

18. Open the Models dialog.

19. <D> the Edit Model Properties icon.

  

20. <D> the drop-down list and select CUSTOM, then input 300:1
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21. Set the Line Style Scale to Annotation Scale.

  

22. <D> OK

23. Attach the file used in the geometry training portion of this course from the 
…\ROW_Survey\Drawings\Reference_Files folder;

♦ 12345ROW_Model.dgn

24. Select File > References
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25. From the References menu select Tools > Attach

26. Highlight the file 12345ROW_Model.dgn and <D> Open.

The Reference Attachment Settings dialog appears for the 12345ROW_Model.dgn 
file.
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27. Enter a Logical Name and Description as shown.

28. <D> OK 

The file is now attached.

29. Close the References dialog.

30. Select the MicroStation Fit command.
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31. Window or Zoom into the beginning of the project.

 

Note the graphics placed previously to indicate sheet limits.

32. Place the cell called ROW Plan border sheet from the CDOT Menu.  



33. <D> Settings to and change the Active Scale to 300 and <D> Apply

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34. Place the sheet border cell so the lower-left corner coincides with the corner indicated on 
the sheet limits cell placed previously.

35. In the Reference dialog, identify the reference file and select 
Tools > Clip Boundary 

 

36. In the Set Reference Clip Boundary dialog, select the Element Method.
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37. <D> on the shape inset ½ inch from the border.

 

38. <D> anywhere to accept the clip.

The plan sheet display limits are now constrained to a desirable limit.

39. Turn off level DRAFT_INFO_No-Plot  in the reference file 12345ROW_Model.dgn to 
turn off the sheet lay-outs (Select Settings > Level Display).



Colorado Department of Transportation   Page 195

Labs for ROW Geometry LAB 26 - Reference Files for Plan Sheets

Make appropriate edits to the title block and add any sheet specific information necessary.

 

Using the tentative (snap) button <T> to query coordinate values that correctly reflect project 
coordinates.  Additionally an InRoads command, such as tracking, will verify the graphics are 
coordinately correct.

Once the first sheet is complete subsequent sheets are much easier.  The reason being is the 
sheet file can be duplicated with the reference files already attached. Moving the border sheet 
and redefining the clipping boundaries will define subsequent sheets.
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40. Select File > Save as, input name 12345ROWSURVPLlanSheetLSCD3D.dgn

41. <D> Save.

Note: The Save As command will automatically save the current drawing to the hard 
drive, then copy and rename to the specified file name and open the new drawing.

42. Place a MicroStation fence over an area that would encompass the next sheet in the set.
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43. In the References dialog, identify the 12345ROW_Model.dgn file and Select Tools > 
Clip Boundary 

44. In the Set Reference Clip Boundary dialog, select the Fence Method.

45. <D> on the MicroStation screen to accept the new clip boundary.

46. Turn On the level DRAFT_INFO_No-Plot in the reference file 12345ROW_Model.dgn to 
turn the sheet lay-outs back on.
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47. Use the MicroStation Move command to relocate the border sheet. Also Rotate the 
border sheet to align with the predefined sheet limits.

Rotate the MicroStation view so that the sheet is normal to the view.

48. Key-in rv=0,0,15  (rotate view = X,Y, Z) for this 3D file
rv=15  if in a 2D file.

49. <D> on the MicroStation screen to initialize the rotation.
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Note: The above key-ins vary based on the dimension of the MicroStation file, 2D or 3D. 
When working in a 3D file, the key-in is: rv=0,0,15 (rotate view=x-value, y-value, 
z-value).  Rotation is specified in relative to the Z axis as that is the axis 
perpendicular to the view.  Also, rotating a MicroStation view simply rotates the 
viewing of the graphics. The coordinate system is still relative to the graphics and 
any coordinate or alignment information extracted will be correct.

 

Define a reference clip boundary, as you did earlier.

50. In the Reference dialog, identify the reference file and select 
Tools > Clip Boundary 
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51. In the Set Reference Clip Boundary dialog, select the Element Method.

 

52. <D> on the shape inset ½ inch from the border.

53. <D> anywhere to accept the clip.

54. Update information in the title block of the sheet as necessary.

55. Select File > Save Settings

This same procedure can be repeated to complete the remainder of the sheets.
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The following exercise will step through creating a full plan view depicting right of way plan 
sheets (sheet subset 5) at a scale of 1”100’. The plan sheets will be centered along the design 
alignment for the project S.H. 86.

Chapter Objectives:

 Create plan sheets using InRoads Plan and Proflile Generator

 Edit reference clip boundary

1. Open the MicroStation file 12345ROW_Model.dgn
from the …\Survey_ROW\Drawings\Reference_Files folder.

Note: The MicroStation file opened is immaterial and only acts as an interface to 
InRoads. New plan sheets will be created and the open drawing will not be 
impacted.

2. Load the geometry project 12345_ROW if not already in memory

3. Select Tools > Options [Factors] and set the global scale factors to 100 then <D> Close 
to dismiss the Options dialog box.

4. <R> on the alignment C_Centerline and select Set Active from the fly-out list.

5. Select Drafting > Plan and Profile Generator…
from the InRoads interface.

By default, the dialog will populate with the CDOT preferences (100 horiontal scale by 1x 
vertical exageration Plan & Profile sheet).

Note: Drafting notes is an InRoads Application Add-In. If the Drafting category is 
not shown in the InRoads menu bar, select Tools > Application Add-Ins and 
enable Drafting Production Add-In.

6. Select the Preferences button (at the bottom of the Plan and Profile Generator 
dialog).

7. Select the preference named - 100 Scale ROW Plan Sheet

8. <D> Load 
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9. <D> Close

Preferences developed for ROW are:

♦ 100, 200, and  300 scale full plan view ROW Sheets

Main Tab
By default, the active horizontal alignment and the begin/end station limts for said alignment 
will populate the dialog.

10. Load the appropriate Preference (if not done in step 6)

11. Select the appropriate Horizontal Alignment 
(the sheet will be centered on the defined alignment).

12. Redefine start and stop station limits to:
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 Start: 314+56.59

 Stop: B 450+00.00

Note: The ‘B’ in the ‘stop’ station defined above is required as it indicates the stop 
station falls within a station-equation range.

Length defines the length along the alignment that will fit in a plan view.  1450 feet is the 
default for a 100 scale 11” x 17” plotted sheet. 

Changing Scale:
A 200 scale plot will display 2,900 feet along the alignment in plan view, a 300 scale plot will 
display 4,350 feet.  

If something other than 100 scale is desired, the user must proportionally change:

♦ Main tab – modify Length

♦ Plan Controls tab – modify Width Left, & Width Right

♦ View Layout tab – modify Scale

♦ Symbols and Details – modify Scale

Plan Controls tab

13. Select the Model Files button to pick the Drawing files (references) for display in plan 
view. 

14. Select the file 12345ROWModel01.dgn in the Open Model File dialog.



Page 204 Colorado Department of Transportation

LAB 27 - Project Specific Plan Sheets Labs for ROW Geometry

15. <D> Open
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Width Left and Width Right define plan view limits perpendicular from the reference line 
(left is negative).

The Boundary Chords setting will create a clipping limit that will fit the extents of the plan 
window area. This reference file clipping edge should be considered a “first pass limit” and 
may have to be edited on curved portions of the corridor path in locations where the desired 
limits extend beyond this “calculated” clipping limit. This plan limit editing, along with any 
shifting of the plan window position, is accomplished on the Sheet Index tab after the sheets 
have been created or through the use of the MicroStation references dialog.

Model Files & Levels
The Model files selected will be attached as reference files. The attached files will have all 
levels turned on that contain data. If additional data (levels) are added to the referenced files 
after the sheets are created, the user is required to turn on the appropriate levels through the use 
of the references dialog box.

Additionally, the files referenced will have the design file ‘Default’ model attached. The user 
should not use any model space other than ‘Default’.

Profile Controls tab
No action required
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Sheet Layout tab

 

16. <D> the … button next to Host File to identify the path and initial sheet name for the new 
drawing set. The Host File refers to the new MicroStation plan drawings that will be 
created by this tool. The last number, “1”, will be automatically incremented as each new 
sheet is created.  Set to the project directory, i.e.
…..ROW_Survey\Drawings\ 12345ROW_Plan01.dgn

17. <D> Save in the Save As dialog.
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18. The Seed Host File is the ‘prototype’ file used to create the Host files and should be set 
to:
C:\Program Files\Workspace-CDOT\Standards-Global\MicroStation\Seed\3D-
Seed_CDOT.dgn

19. Make sure the Level and Symbology options in the Clipping Boundary section display 
SHEET_Clip-Boundary.

View Layout tab
This tab sets location (origin) for the plan views relative to the border sheet.  No user input is 
required in this dialog.

Note: The Location of the Plan position is computed from the outside edge of the border 
sheet in paper (plotted) units.

Border and Title tab
The only user input on this tab is to ensure the correct cell is specified for the border sheet. No 
other user input is required in this dialog unless creating sheets at a scale other than 1”=100’. 

Source cell library: C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\cells\General.cel 
Cell Placed:
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20. Verify Cell Name: SHEET_ROW-Plan-Sheet
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Symbols and Details tab
No user input is required in this dialog unless modifications to the stored preference are 
required.

 

The North Arrow position set by the Location in Paper Units and is set to the upper right 
corner of the sheet. This is a rough placement and will likely have to be moved for clarity and 
conflicts on many sheets. Once the sheets are constructed each sheet should be checked for 
optimum cell position.
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Match Lines tab
No user input is required in this dialog. Match lines are not being used for ROW sheets.

 

Executing the Plan & Profile Command
Once the Apply command is executed, the workflow process for this command follows the 
following sequence:

 Plan view reference limits are established.

 New drawing files are created based on the host file name.

 Each new drawing file has 3 items generated.

♦ Plan views

♦ Border sheet placed as a cell in each generated drawing

♦ North arrow placed on each sheet

 The Plan and Profile dialog (sheet index tab) will populate with sheets created and sheet 
limits.

Sheet Index tab
Nothing is required by the user on this tab prior to executing the PnP command. A summary of 
sheets created is displayed after successful execution of the command.

21. <D> Apply, the routine will run and MicroStation will cycle through the sheets as they are 
created – be patient and wait for the command to complete.
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The Sheet Index tab will display a list of sheets created and MicroStation will display the last 
sheet created.

22. Select Save As from the Sheet Index tab to store a project specific View Definition File 
(VDF). A VDF file allows sheet definitions to be recalled and modified in subsequent 
MicroStation/InRoads sessions if necessary.

23. Name the file 100 scale ROW plan sheets.vdf

24. <D> Save



Page 212 Colorado Department of Transportation

LAB 27 - Project Specific Plan Sheets Labs for ROW Geometry

Displaying sheets
By highlighting a specific sheet in the Sheet Index tab and selecting Show Sheet, MicroStation 
will open the selected drawing.

25. Identify Sheet 1 and <D> Show Sheet

MicroStation opens the identified sheet
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26. Identify Sheet 2 and <D> Show Sheet

27. Use the MicroStation Modify command to adjust the clipping shape to any new location.

28. <D> Show Sheet to redefine the clipping limits after modifying the clipping shape.

Note: Other modification tools such as insert vertex and delete vertex can be used also.

Standard MicroStation References commands can also be applied.

29. Use the MicroStation Modify command to adjust the clipping shape to any new location.

30. Select File > References from the MicroStation menu bar.

31. Highlight the 12345ROW_Model.dgn file.
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32. Select Tools > Clip Boundary from the References dialog.

33. Set the Method to Element

34. <D> on the modified clipping shape in the MicroStation view.

35. <D> to accept the command.

Notes:   
♦ The clipping boundary is now defined by the identified shape. Using any MicroStation 

command to modify this shape will automatically update the reference file clipping 
boundary.  This shape is on the level GEN_SHEET_Clip-Boundary.  This level is 
configured as a non-plotting level. 

♦ Deleting the clipping boundary shape will result in the reference file display limits 
reverting to the initial limits defined by the PnP command.

♦ Regenerating a sheet from the PnP Sheet Index tab will also cause the sheet to revert to 
the reference file display limits initially defined by the PnP command.

After the Plan and Profile Generator has been run, each sheet should be reviewed for:

 North Arrow position (move the cell using MicroStation move command)

 Plan view Clipping limits 

 Title block information
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Main tab – After running the P&P command
Once the command has been run, the Geometry Project field will populate and the Plan and 
Profile view limits display.

Double clicking on a specific Plan View sheet opens an Edit Plan View dialog. Sheet limits can 
be modified numerically and reference files can be added or removed.

Challenge Exercises:
♦ Modify the last sheet to add 500’ to the stop station

♦ Modify any sheet to change the left and/or right offsets

♦ Add or subtract from the model file list

♦ Modify the station limits on the first sheets and ‘adjust’ adjacent sheet
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