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LAB 4 - Creating the Project and Design Model

In this lab, you’ll create a new 12345 project using the Create Project Directory Structure program. 
Then, you’ll create a new Roadway Design model from an auto-populated file (generated by the Create Project 
Directory Structure program) and by creating one from a CDOT 3D seed file. Once created, you’ll reference 
other discipline’s work in order to start the design. 

In subsequent labs, you’ll use a similar process to create other discipline model files (Bridge, Landscape & 
Environmental, Traffic, etc.).

Chapter Objectives:

After completing this exercise you will know how to:

 Create a new project and project configuration file (PCF) using the Create Project 
Directory Structure program.

 Re-assign a project number via the PCF.

 Create a new design model using a CDOT seed file.

 Create a new design model using an auto-populated model file.

 Attach a reference.

 Turn reference displays on/off.

 Turn reference levels on/off.

Lab 4.1 - Create a Sample 99999 Project

In this example, you are starting your project before a project number has been assigned. You 
will temporarily assign the project number 99999. Later in this lab, you will learn how to 
change this project number by updating MicroStation’s project configuration file.

1. From the Windows Start Menu, select Start > All Programs > 
_CDOT_CADD_Information > V08.11.xx-V8i > Create V8i Project Directory 
Structure.

2. Verify that the Project Template location is set to C:\Workspace\Workspace-
CDOT_V8i\Project Template.

3. Set Destination to C:\Projects.

4. Key in 99999 for the Project Code.

The project number must be a 5-digit numeric code.

5. Toggle on Create Project Configuration File.

6. Select Apply.
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The project directory structure is created in the C:\Projects folder and the Project 
Configuration File (PCF) file is created.

7. Close the CDOT Project Creation Utility.

8. Use My Computer or Windows Explorer to navigate to the C:\Projects\99999 folder to 
review your project directory structure. Note that several generic CDOT files (e.g. 
99999Des_Model.dgn) have automatically been created.

9. Use My Computer or Windows Explorer to navigate to C:\Workspace > Workspace-
CDOT_V8i> Standards-Local > Projects.



Colorado Department of Transportation   Page 107

Labs for MicroStation V8i SS2 LAB 4 - Creating the Project and Design Model

10. Double-click on the 99999.pcf file to open it in Notepad.

The PCF defines a specific directory that MicroStation defaults to when opening up a DGN 
file or referencing model files. It makes setting paths much easier in MicroStation. 

If your project was installed on a project manager’s machine, you could edit this file to 
specify the location. See the CDOT PCF Management workflow for more information.

11. Close the Notepad file. If prompted to save changes, select No.

12. Close My Computer or Windows Explorer.

You will later edit the 99999 project and update it with an actual project number. For now, 
you will continue working in the example 12345 project.

Lab 4.2 - Select Group Environment

Run the Select Group Environment Utility to determine which CDOT level libraries will 
be attached and available for use.

1. From your desktop’s Start Menu, choose Start > All Programs > 
_CDOT_CADD_Information > 08.11.xx-V8i > Select Group Environment. In the 
Select Group Environment box, select xxMulti-Discipline, and then select OK.

Any MicroStation design file that is now opened will have all level libraries (general and 
all disciplines) automatically attached.

Note: You only have to run this program once. The only time you have to re-run it is if 
you wish to switch groups on the same machine.
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Lab 4.3 - Starting MicroStation

1. Start MicroStation by double-clicking the desktop shortcut or by selecting Start > All Pro-
grams > Bentley > MicroStation V8i (SELECTseries 2).

2. Set the MicorStation Workspace in the lower portion on the dialog box, set:

♦ User:  CDOT User
This sets user preferences and users customized options like custom toolbars.

♦ Project: 12345

Note: Be sure to re-set this option because it will default to you upper level project 
directory.

This Project component of the workspace should already be set by the PCF file created by 
running the CDOT Project Creation Utility. It sets the proper path for opening, saving and 
attaching files.

♦ Interface: CDOT
This loads custom menus and tools at the organizational level. The CDOT interface will 
load, among other things, the CDOT Groups Menu.

Lab 4.4 - Create a New Design Model File

There are two ways you can create a new file: Using a seed file or from a CDOT auto-
populated model file. You’ll practice both in this session.
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Creating a new design file using a CDOT seed file

1. From the MicroStation Manager dialog box, select the New File icon.

2. In the Seed File section, choose the Browse button.
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3. Highlight the seed file 3D-Seed_CDOT.dgn and choose Open.

Note: The seed file will copy over all of CDOT’s default MicroStation settings when 
creating the new file.

4. Set the Directory to \Design\Working. 

5. Set Save as Type: to MicroStation DGN Files (*.dgn).

6. Key in the name CU12345DES_Model02.dgn.

7. Select Save to create the file.

The file is created from the seed file and placed in the Working folder. When creating a 
new working model file, you’ll prefix it with your initials (you’ll use CU for CDOT USER 
for this class).



Colorado Department of Transportation   Page 111

Labs for MicroStation V8i SS2 LAB 4 - Creating the Project and Design Model

The working folder is for files that you are using for your design process prior to the design 
being finished. Once complete, you will move the files to the Reference_Files folder and 
take the CU off of the file name.

8. In the MicroStation Manager box, choose Open.

9. The blank file opens with all of the standard settings from the CDOT seed file.
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Check settings

1. Select Settings > Design File > Working Units. These are the CDOT standard units 
copied from the seed file.

2. <D> Angle Readout from the Category list. These are the CDOT standard units copied 
from the seed file.

3. Cancel the dialog box.

4. Choose File > Close to return to the MicroStation Manager. 
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5. From the MicroStation Manager select the file and press the Delete key on your 
keyboard and choose Yes from the Delete File box to delete the file you just created.

Lab 4.5 - Create a New File by Copying an Auto-populated Model 
File

1. In the MicroStation Manager, navigate to the \Design\Draw-
ings\Reference_Files folder.

2. Select 12345DES_Model##.dgn and choose Open.
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3. After opening the file, select File > Save As, navigate to the \Design\Working folder 
key in the name CU12345DES_Model02.dgn and select Save.

The file is copied to the new name into the working folder. 

Check settings

1. Select Settings > Design File > Working Units. These are the CDOT standard units, 
which are the same as the seed file units.



Colorado Department of Transportation   Page 115

Labs for MicroStation V8i SS2 LAB 4 - Creating the Project and Design Model

2. <D> Angle Readout from the Category list. These are the CDOT standard units, which 
are the same as the seed file units.

3. Cancel the dialog box.

Note: The auto-populated file provides the same settings as a seed file. You can create a 
new file either way with the same results. However, by copying a CDOT auto-
populated file, the name is automatically set to the CDOT standard, you only have 
to change the counter.

Lab 4.6 - Attach the Survey/Topo Reference

After creating your initial design model, you can attach other groups’ work that you’ll need to 
start your design. In this case, attach the existing survey and topographic information.

1. Select File > Reference.

Note: You can also choose References from the Primary toolbar.

2. On the References dialog, select Tools > Attach.

3. Your current Directory should be C:\Projects\12345 (obtained from your PCF file).

4. Navigate to \ROW_Survey\Drawings\Reference_Files.
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5. Select 12345SURV_Topo100.dgn from the list of files.

6. Set Attachment Method to Interactive and select Open.

The Interactive method allows you to supply additional reference settings in the next dialog 
box. 

7. In the Reference Attachment settings box, key in a Logical Name of Survey/
Topo and set:

♦ Orientation to Coincident World (to align Master file and Reference file global 
origins)

♦ Scale to 1:1 (to bring in graphics full scale)

♦ Nested Attachments to No Nesting
♦ Display Raster Reference on

♦ Global Linestyle Scale None
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8. Select OK.

9. Fit the view.
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The Survey/Topo reference is attached to the design model master file. The graphics come 
in at their true coordinates (Coincident-World) and the actual size (1:1 scale).

10. Window in on the Survey graphics at the beginning of the project.

11. In the Reference dialog, make sure Show Hierarchy is turned on and highlight the 
Survey/Topo reference on the right-side.

12. Toggle the Display option off.

13. Fit the view.
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With the reference display turned off, there are no graphics to display, since the design 
model is currently empty.

14. Toggle the Display option back on.

15. Fit the view.

The design file is now ready to placed proposed graphics with survey and topo graphics 
referenced for information purposes.

Turn survey levels on/off

1. Window around the intersection near the center of the project.
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2. Zoom in as shown.

3. Hover over one of the barbed wire fence lines.

Basic element information “pops up” at your cursor location. MicroStation tells you that 
the element is on level TOPO_FENCE_Barbed-Wire and located in the Survey/Topo 
reference. 

4. Open Level Display from the Primary toolbar.

5. Highlight the master file CU12345Design_Model02.dgn.
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6. Sort on Used levels.

Note: That there are no used levels in the master file since there are no graphics in the 
design model file.

7. Highlight the Survey/Topo reference underneath the master file

8. Sort on Name, then sort on Used.

Note: That the reference has several used levels.
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9. Turn off the level TOPO_FENCE_Barbed-Wire.

10. Right click in the list of levels and select Off By Element.
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11. <D> on one of the green breaklines to turn off the level TOPO_TERRAIN_Break-Lines.

12. Update the view.
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13. Turn other Survey levels on/off as desired.

Note: You have control over all reference levels just like levels in the master file.

14. Turn all Survey levels back on.

15. From the MicroStation Main taskbar, select Delete Element.

16. <D> on the barbed wire fence.

The command is now not available because the barbed wire fence is in the reference file, 
not the active file. You can not delete or modify reference graphics.

17. In the Reference dialog, turn off Snap for the Survey/Topo reference.

18. Try to tentative snap on some of the Survey graphics.

With Snap turned off, you can’t tentative to the graphics in the reference file.

19. In the Reference dialog, and turn off Locate for the SurveyTopo reference.
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20. On the Main taskbar, choose the Element Selection tool and hold your cursor over some 
of the survey graphics.

 

With Locate off, you can’t located reference elements for information, measuring, 
copying, etc.

21. In the References dialog, turn Snap and Locate back on for the Survey/Topo 
reference.

22. Hold your cursor over some of the reference graphics.

You can now locate the graphics.
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23. <T> on some reference graphics.

You can now snap to the reference graphics for coordinate information.

Note: It’s often helpful to turn Snap off in a reference in dense areas where you don’t 
want to snap to reference graphics. It’s useful to turn Locate off for a reference if 
you’re copying master file graphics and you don’t want to accidentally copy the 
reference graphics.

Live Nesting

1. Window around the intersection as shown.
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2. In the Reference dialog, change No Nesting to Live Nesting and set the Depth to 1. 
Expand the Hierarchy list to show all nested references.

The Survey fieldbook data files, which are referenced to the Survey/Topo model, are now 
displayed in the file.

3. Review the graphics.

The Nested graphics, including the existing contours are now shown in the file.
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4. On the left side of the Reference dialog, highlight the Survey/Topo reference. On the 
right-hand side of the References box, highlight the Contour (Surface data) nested 
reference and toggle off the Display.

 

The display of just the nested contour graphics is turned off.

5. Turn the Contour reference Display back on.
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6. On the left side of the Reference dialog, highlight the Design Model master file. On 
the right-hand side of the References box, highlight the Survey/Topo reference and 
toggle off the Display.

All graphics in the file are turned off. 

Note: With a nested reference, when you turn off the display of the upper level reference, 
all nested references are turned off too.

7. Turn the Survey/Topo reference display back on.

8. Open the Level Display box and expand the Target Tree list.
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9. Select the Contour nested reference and toggle off the minor contour level.

You have control over all nested reference levels via Level Display.

10. Turn the minor contours back on and Close the Level Display box.

You will work more with nested references and the Copy Attachment options in later labs.
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11. Choose File > Close to return to the MicroStation Manager.

12. From the MicroStation Manager select the file CU12345DES_Model02.dgn and 
press the Delete key on your keyboard and choose Yes from the Delete File box to delete 
the file.

Note: In this class, you’ll work with the previously created Design Model file 
12345DES_Model.dgn in the Reference_Files folder.

13. Cancel the MicroStation Manager box.

Lab 4.7 - Update Project 99999

You have now been assigned a project code of 54321 for the previously created 99999 
project. Update the PCF to reflect this change.

1. Using My Computer or Windows Explorer, navigate to the CDOT workspace (C:\Work-
space\Workspace-CDOT_V8i\Standards-Local\Projects).



Page 132 Colorado Department of Transportation

LAB 4 - Creating the Project and Design Model Labs for MicroStation V8i SS2

2. Double-click on 99999.pcf to open it with Notepad.

3. On the second line under Project Directory, edit it as follows:

MS_DEF=C:/Projects/54321/

 

4. Select File > Save As, name the file 54321.pcf. and select Save.

Note: By updating the MS_DEF path, all reference paths are updated as well.

5. Close the 54321.pcf file in Notepad.
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6. Delete the 99999.pcf file from the C:\Workspace\Workspace-
CDOT_V8i\Standards-Local\Projects folder.

7. Using My Computer or Explorer, navigate to the C:\Projects\99999 folder.
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8. Rename the folder C:\Projects\54321.

9. Start MicroStation and select the Project drop-down

Note that 99999 is no longer available and has been replaced by 54321.
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10. Set Project to 54321.

The project directory structure is selected.

Note: All files prefixed with 99999, would need to be renamed with the prefix 54321 on 
the hard drive.

11. Cancel the MicroStation Manager.
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