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LAB 7 - Building Components

This lab demonstrates the various methods of creating components, setting component and point properties, 
and illustrating how point constraints work.  There are three basic options used to create components; simple, 
constrained/unconstrained, and end condition.

Chapter Objectives:

 Build a simple component

 Build a constrained component

 Build an end condition component

 Demonstrate the commonly used constraints; horizontal, vertical, slope, and vector/offset

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.ird

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 7.1 - Build A Simple Component

Use the simple option to build a regular closed shape component with horizontal and slope constraints such as 
those used for building pavement components. 

1. Open MicroStation and InRoads using the 12345DES_Model.dgn file found in the direc-
tory C:\Projects\12345\Design\Drawings\Reference_Files.

2. Select File > Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\DES12345_Templates.itl from the 
available files.

4. <D> Open then <D> Cancel the Open dialog box.

5. Select Modeler > Create Template from the InRoads menu bar.

Setting up Template Options makes point placement easier.  For this lab, affixes will be turned 
off  so that the component can be used on either side of the template.  The step value will be set 
so to a small value so that when creating a template, components will snap to the correct points.  
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6. Select Tools > Options from the Create Template menu bar.

7. Toggle off Apply Affixes.

8. Set the X and Y Step Options to 0.10. 

9. <D> OK.

The next series of steps creates a new project specific folder to store the components that will 
be created in the lab.  Creating project specific folders in the template library makes easier to 
find project specific components.

10. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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11. <D> <D> on the 4 ‐ Components folder to expand the folder.

12. <R> on the 4 – Components and select New > Folder from the right click menu.

13. Key in 12345 Components for the folder name.

Components are the building blocks of templates.  Create a pavement component using the 
Simple option.  This option is used because it automatically sets up the constraints of the 
component.

14. <R> on the 12345 Components folder and select New  > Template from the right 
click menu.

15. Key in CONC_Lane_12”x12’ for the component name.
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16. <D> on the Dynamic Settings button to display the Dynamic Settings tool settings box.

17. <R> In the Template View window and Select Add New Component > Simple from 
the right click menu.

The next steps define the style that the component will use, the point names, and the origin of 
the component.

18. In the Current Component area, key in CONC_Lane_12”x12’ into the Name field.

19. Set the Style to D_CONC_Pvmt_12in using the drop down menu.

20. Key in 1 for the Thickness.
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Note: This is where the values of all the constraints are set.  If needed, these values can 
be modified later.

21. Move the pointer into the magenta square (this is the template origin and is usually at the 
coordinate 0,0).  Adjust the pointer location until the Dynamic Settings readout is 0.00 for 
both X and Y.

22. <D> to place the element.

C

23. <D> <D> on the origin.  

24. Select Conc_Centerline‐Top from the Name drop down menu.
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25. <D> Apply.

26. <D> Next and rename the remaining points as shown below using the Name pull-down 
menu.

This completes the creation of a simple, closed shaped component with horizontal and slope 
constraints.

Lab 7.2 - Build a Constrained Component

In addition to building regular closed shape components, irregular and/or open shaped components can be 
created using the contrained or unconstrained options for adding components.  They can also be used to build 
linear, non-end condition components.  Use the constrained option to define horizontal and/or vertical 
constraints (such as a horizontal or vertical offset from another point).  Use the unconstrained method to define 
points that don’t depend on other points for their placement.
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1. <R> on the 12345 Components folder and select New  > Template from the right 
click menu.

2. Key in CONC_Shoulder_12”x8’ for the component name.

3. <R> In the Template View window and Select Add New Component > Constrained 
from the right click menu.

4. In the Current Component area, key in CONC_Shoulder_12”x8’ into the Name field.

5. Set the Style to D_CONC_Pvmt_12in using the drop down menu.

When placing constrained or unconstrained components, each point of the component must be 
placed individually.   Use the Dynamic  Settings dialog box is to enter point names, styles, and 
locations.

6. Select Conc_Laneline‐Top from the Point Name drop down menu on the Dynamic Settings 
dialog box.

7. Move the pointer on to the template origin and <D>.  

8. Dynamic Settings dialog box, Select Conc_EOP‐Top from the Point Name drop down 
menu.

9. Change the key in mode to hs= (horizontal distance and slope).
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10. Key in 8,-.02 in the key in field.  This is the horizontal distance and slope from the 
previously placed point.

11. Press the Enter key to place the point.

12. Select ABC_EOP‐Top from the Point Name drop down menu.

13. Change the key in mode to dl= (horizontal and vertical distance from the last entered 
point).

14. Key in 0,-1 in the key in field.  This is the horizontal distance and vertical distance from 
the previously placed point.

15. Press the Enter key to place the point.

16. Select ABC_Laneline‐Top from the Point Name drop down menu.

17. Change the key in mode back to hs= (horizontal distance and slope).
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18. Key in -8,-.02 in the key in field.  

19. Press the Enter key to place the point.

20. <R> anywhere. This dialog box is where you define if the shape is closed or not. 

21. Verify that Closed Shape is toggled On.

22. Select Finish from the right click menu to complete the component.

You should now understand how to create a constrained, closed shaped component.  By 
reviewing the steps above, now you should also be able to also create unconstrained and open 
shaped components simply by choosing different options from the dialog boxes that were 
introduced.

Lab 7.3 - Build an End Condition Component

In theses next steps you will use the end condition option to create a linear component that can seek a target.   
This lab will focus on the point property called End Condition is Infinite. Once you understand the steps to 
evaluate the effects of this property on and end condition, use the same steps to test the effects of other end 
condition point properties.  Many of these properties determine how the component will behave when a target 
is found.

1. Create a new template as described in the previous lab and name it 6to1_Fill.
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2. <R> In the Template View window and Select Add New Component > End 
Condition from the right click menu.

3. Key in 6 to 1 Fill for the Name.

4. Select D_Toe‐of‐Fill for the Style.

Additional component properties are required for end conditions.  These determine what the 
end condition attempts to tie to (the Target) and the order in which it is processed (the Priority).

5. <D> on the Target Type drop down menu.  Examine the options available.

6. Select Surface from the Target Type drop down menu.  

7. <D> on the Surface drop down menu.  Notice that either Active or a particular surface can 
be selected.

8. Select Active from the drop down menu.  This will allow the end condition to solve 
regardless of the surface specified in Roadway Designer.

9. Key in 1 for the Priority.
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Note: This example illustrates an end section with one component.  When there are 
several components defined in an end condition, they are evaluated in order of 
their assigned priority.  A component with a priority of 1 will be evaluated before a 
component with a priority of 2. 

Next, additional point properties, such as point names, will be defined for the end condition.  
Use the Dynamic Settings dialog box to finish defining these properties.

10. In the Dynamic Settings dialog box, select POSS for the Point Name.

11. Move the pointer on to the template origin and <D>.  

12. In the Dynamic Settings dialog box, toggle on End Condition is Infinite.  This option 
allows a component to “stretch” until a target is found.

13. Select Toe‐of‐Fill for the Point Name.

14. Change the key in mode to hs=.

15. Key in 12,-.1667. and press Enter. (This value could also be typed in as 12,-1:6).  

16. <R> and select Finish from the right click menu.

The steps above created a component that will seek a target at a -1:6 slope for a horizontal 
distance up to 12 feet.  However, because the option End Condition is Infinite was toggled On, 
the component ignores the horizontal distance criteria and will seek a target beyond the 12 foot 
limitation.
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17. In the Create Template dialog box, <D> the Test button located to the bottom right of the 
Template View window as shown below.

18. In the Test End Conditions dialog box, <D> the Draw button.

19. Move the pointer up and down in the view area to see how the end condition performs.

Note: The dotted line in the Test End Condition view window shows the component at 
the defined slope and length.  As the proposed surface moves beyond the limits of 
the defined component, the result of the End Condition is Infinite toggled On is 
that the end condition solution expands beyond the original limits of the 
component.  <D> Close.
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20. <D> <D> on the Toe‐of‐Fill point.

21. Toggle off End Condition is Infinite.

22. <D> Apply and <D> Close.

23. <D> Test.

24. In the Test End Conditions dialog box, <D> Draw and notice how the end condition 
behaves.

25. <D> Close.

Note: When the End Condition is Infinite option is Off, the end condition solution is 
limited to the limits of the originally defined component.

26. Select File > Save the Create Template dialog box.

Lab 7.4 - How Point Constraints Work

Point constraints are used to form a relationship between points.  This relationship is used to change the shape 
of the components based on events that occur within the corridor. The following steps will demonstrate how to 
assign and modify point controls, and how to evaluate a component by making changes to point controls.  
change, create the impact of 

1. Verify the Create Template dialog box is open. 

2. Open the folder 4 – Components > Aggregate Bases > Shoulders.

3. <D> <D>  on the ABC_Outside_Shoulder component.

4. <D> <D> on the ABC_Hinge-Top point.

5. In the Point Properties dialog box, notice that this point has both a Horizontal and Slope 
constraint.
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6. Change the Slope constraint to None and <D> Apply. This will allow the point to move 
up and down independent of any other point.

7. <D> Close.

8. Notice in the Create Template view window how the point symbol (+) changes from red to 
yellow.  This color change means the point has changed from fully constrained to partially 
constrained.

                   

9. <R> on the ABC_Hinge-Top point and select Move Point from the menu.

Note: The Move Point command will not appear in the menu if the point is fully 
constrained.

10. Because the point still has a Horizontal constraint, it will only move up and down while 
maintaining the 12 foot offset from the constraint point, ABC_Shoulder-Top.

11. <R> to exit the Move command.
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12. <D> <D> on the Subbase_Hinge-Top point.

13. Notice that Subbase_Hinge-Top is constrained both horizontally and vertically to  
ABC_Hinge-Top. Therfore, if ABC_Hinge-Top moves, Subbase_Hinge-Top will follow 
according to what is entered in the constraint Value: field. The next few step will 
demonstrate how this works.

14. <D> Close.

15. <R> on the ABC_Hinge-Top point and select Move Point from the menu.

16. Notice how the point Subbase_Hinge‐Top stays 0.5 feet directly below point ABC_Hinge‐
Top. This is because the point has a Horizontal constraint of 0 and a Vertical constraint of -
0.5. from ABC_Hinge-Top.

17. <R> to exit the Move command.

The point ABC_EOP-Top is also fully constrained by ABC_Hinge‐Top. The difference with 
this point it that it that the second constraint is by Vector-Offset instead of Vertical.

18. <D> <D> on the ABC_EOP-Top to look at the Vector/Offset constraint.

19. Notice that this type of constraint uses two parent points instead of one. The slope between 
the two parent points determines the “vector” at which the point will be placed.

20. <D> Close.

21. Move the point ABC_Hinge‐Top again and notice how the point ABC_EOP-Top moves 
with it.  The Vector/Offset constraint forces the point ABC_EOP‐Top to maintain the same 
slope defined by ABC_Shoulder‐Top and ABC_Hinge‐Top.  

22. <R> to exit the Move command.

The next few steps demonstrate how ABC_Hinge-Top behave with a vertical constraint and 
without a horizontal constraint.

23. <D> <D> on the ABC_Hinge-Top point.

24. Change the None constraint back to Slope.
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25. Set the Parent 1 to ABC_Shoulder‐Top and change the Horizontal constraint to None.

26. <D> Apply.

Note: When you click Apply, the two constraints will switch places.  This is because the 
None constraint will always end up as Constraint 2.

27. <D> Close.

28. Move the point ABC_Hinge-Top again an notice that now the point only moves to teh 
left and right.  The Slope constraint forces it to maintain a -2.0% slope from the point 
ABC_Shoulder-Top.

29. <R> to exit the Move command.

30. Reset the point ABC_Hinge-Top back to its original setup. <D> <D> on the  point, change 
the None constraint back to Horizontal, and set Parent 1: to ABC_Shoulder‐Top.

31. <D> Apply.

32. <D> Close.

Chapter Summary:

 Use a simple component to quickly generate an unconstrained closed shape.  Lab 7.1 -Build 
A Simple Component showed how to modify point names in using the Point Properties 
dialog. 

 The next lab, Lab 7.2 -Build a Constrained Component, demonstrated how to create a 
constrained component from scratch using the Dynamic Settings dialog box and various 
methods for the key-in. 
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 Lab 7.3 -Build an End Condition Component explored the special features of an end 
condition component.  For end condition components there are additional options in the 
Dynamic Settings dialog box which determine how end condition points in relation to a 
target.  

 In Lab 7.4 -How Point Constraints Work several constraint options were explored 
including Horizontal, Vertical and Vector-Offset.  This lab demonstrated how changing the 
constraint method affects the points position and how points react to the Parent it is 
constrained to.
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