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LAB 27 - Create Raised Median

This lab demonstrates a procedure for modeling a roadway which includes a raised median and a median 
opening.  The exercise below uses a single template which utilizes point controls and display rules to achieve 
the two different roadway sections. Additionally a second template is used to model the median openings.

Chapter Objectives:

 Use a single template to model the mainline with and without a median

 Create display rules which determine when the raised median excluded

 Use point controls to define the location of the median nose

 Model multiple corridors

 Combine corridors in a single final surface

Lab 27.1 - Open Lab Files

An initial model of the roadway is crated using the roadway typical section without the median. 
This is done for the purposed of extracting the profile gradeline for the median noses.

1. Open MicroStation and InRoads using the 12345DES_Model-Create Raised Median.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the file C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\
Preferences\CDOT_Civil.xin

4. Continue to select the following files from C:\Projects\12345\Design\InRoads\ and the 
<D> Open button.

♦ 12345DES_Existing-Create Raised Median.dtm

♦ 12345DES_Geometry-Create Raised Median.alg

♦ 12345DES_Templates-Create Raised Median.itl

♦ 12345DES_Roadweay-Create Raised Median.ird

5. <D> Cancel the Open dialog box to close.

Lab 27.2 - Workflow

A summary of the overall process

1. In addition to the mainline horizontal and vertical alignments, create horizontal align-
ment(s) for the median nose.

2. Create a template for the crowned roadway - without the raised median.

3. Model the mainline using the crowned template.

4. Create the vertical alignments for the median noses by extracting their elevations from the 
surface created in the previous step.

5. Create a template for the median noses
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6. Model the median noses

7. Create a template for the raised median

8. Add Display Rules to the components of the raised median.

9. Create a corridor definition for the raised median

10. Add point controls to constrain the raised median template to run as defined, constrained to 
the medians or to the mainline alignment.

11. Define key stations for template drops.

12. Create the final design surface by modeling the mainline and median openings 
simultaneously.

Modeling Schematic
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Lab 27.3 -  Review The Alignments

In this exercise three alignments are used. Federal CL for the main corridor and Median Nose 
& Median Nose_North which define the median opening and termination.

1. Select the Geometry tab in the InRoads Explorer

2. View the horizontal alignments Federal CL, Median Nose & Median Nose_North 

3. View stationing for horizontal alignment Federal CL
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Lab 27.4 -  Review Data

An initial model of the roadway was created using a crowned roadway section (without the 
raised median). This is done for the purpose of extracting the vertical profile of the median 
noses which is accomplished by using the command File > Import > Geometry [Vertical 
From Surface]. This step has already been completed.

1. Select Modeler > Create Template from the InRoads menu bar.

2. In the Create Template dialog review the template for Median Nose in the 1-Templates 
folder.
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3. Also in the Create Template dialog review the template for Federal Blvd in the 
1-Templates folder. This template was use to create a preliminary model.  This model was 
used to extract vertical alignments for the median alignments.  

4. The template Federal Blvd with Raised Median. Display rules control if the median is 
modeled.

5. An expanded view of the median. The ‘Laneline’ points will be controlled by both the 
Federal Blvd. and median alignments. Additionally the median components will be 
assigned display rules which will test the distance between the lanelines and the PGL.

Lab 27.5 - Add Display Rules

Display rules can be associated with components to test if the component should be displayed 
or not.

1. Copy the template  Federal Blvd with Raised Median to 
Federal Blvd with Raised Median_DR

2. Open Federal Blvd with Raised Median_DR for editing

3. The goal is to eliminate the construction of the median components if the distance between 
either lanelines and the PGL is less than 5.50’.

Note: 5.50 feet represents the distance from the mainline alignment to the PC or PT of 
the alignments for the median noses.
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4. Select the median curb and gutter component named LT_C/G_Type2-1B for editing.

5. Select Edit

6. Select Add

7. Create a Display Rule that tests the distance between the Left Laneline and the PGL.

♦ Name: LeftC/G

♦ Description: test distance between LT laneline and PGL

♦ Type: Absolute Horizontal

♦ Between: LT_Conc_Laneline-Top1 and PGL

♦ Test: >=

♦ Value: 5.50
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8. Select Rule for the LT Laneline, OK & Apply

9. Select the component RT_C/G_Type2-1B for editing.

10. Build and apply a similar rule for the RT Laneline.

♦ Name: RightC/G

♦ Test between RT_Conc_Laneline-Top1 and PGL

♦ All other fields are the same

11. Edit the component CONC_Sidewalk-4”

12. Build and Apply a Display Rule to test for a minimum distance of 11.00 feet between the 
RT and LT Lanelines for the Median Cover (Conc_Sidewalk-4”)

♦ Name: MedianPavt

♦ Description: Test width between lanelines

♦ Type: Absolute Horizontal

♦ Between: LT_Conc_Laneline-Top1 and RT_Conc_Laneline-Top1

♦ Test: >=

♦ Value: 11.00

13. Save and Close the Create Template dialog.
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Lab 27.6 - Create Corridors

Corridors contain definitions for which alignments, templates, point controls, etc. to 
incorporate when modeling the roadway.   In this exercise, three corridors are defined, one for 
each median nose and one for the mainline. 

1. Select Modeler > Roadway Designer

2. Select Corridor > Corridor Management from the Roadway Designer menu bar or 

<D> the Manage Corridors button .

3. Add corridors for both median openings.

♦ Name: Median Nose

♦ Type: Alignment

♦ Horizontal Alignment: Median Nose

♦ Vertical Alignment: Median NoseV

4. Add corridor definition for corridor Median Nose_North

♦ Name: Median Nose_North

♦ Type: Alignment

♦ Horizontal Alignment: Median Nose_North

♦ Vertical Alignment: Median Nose_NorthV

5. Add and Close
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Lab 27.7 -  Add Template Assignments

Templates define the cross section of the design model.  They are assigned to the corridor 
through the Template Drops dialog box.  The starting station defaults to the beginning of the 
alignment so setting the interval and selecting the desired template is all of the input that is 
required.

1. Select Corridor > Template Drops from the Roadway Designer menu bar or <D> the 

template drops button .

2. Add template assignment to Median Nose 

♦ Template: Median Nose

♦ Interval of 1’

3. <D> Add then Close.
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4. Add template assignment to Median Nose_North

♦ Template: Median Nose_North

♦ Interval of 1’

5. <D> Add then Close.

6. Roadway Designer can be used to evaluate the two median corridors.



Colorado Department of Transportation   Page 583

Labs for InRoads XM LAB 27 - Create Raised Median

Note: The template data is displayed in the template view.  There are two options for 
scrolling through the design, using the station arrows below the template view and 
using the station line in the plan view.

7. <D> on the station arrows to scroll through the design.

8. <D> and Hold on the yellow station line.  Move the pointer back and forth to scroll 
through the design.

The median models are now ready to be evaluated.

9. From the pull down menu in the Roadway Designer dialog 
Corridor > Corridor Management.

10. Create a corridor for the Mainline.

♦ Name: Federal_Display_Rule

♦ Type: Alignment

♦ Horizontal Alignment: Federal CL

♦ Vertical Alignment: Federal CL_V

♦ Start Station: 8+00

♦ Stop Station: 19+00

11. <D> Add

12. <D> Close

13. From the Roadway Designer dialog Corridor > Template Drops

14. Add template assignments to the corridor Federal_Display_Rule.

♦ Station: 8+00
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♦ Interval of 10’

♦ Template:Federal Blvd with Raised Median_DR

15. <D> Add

16. <D> Close

17. Evaluate the Federal_Display_Rule corridor.

Lab 27.8 - Change Roadway Designer Settings

The Roadway Designer settings determine if additional stations are processed, what information is displayed in 
the views, and what information is included in the processing report.  In this exercise, horizontal cardinal and 
event points are processed, cut and fill information is added to the template view, and component and point 
information is added to the processing report.

The first series of steps tell the Roadway Designer to process the  horizontal cardinal and event points. 

1. From the Roadway Designer menu bar, select Tools > Options.
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2. In the Roadway Designer Options dialog box, toggle on Horizontal Cardinal Points, 
Vertical Cardinal Points, External Control Points, Reference Graphics, and 
Transition Graphics.

3. <D> OK.

4. Scroll through the stations and notice that some stations do not fall on even intervals.  
These are the cardinal and event points.
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Lab 27.9 - Point Controls

This series of steps adds Point Controls (overrides) to the corridor definition previously defined 
in Roadway Designer.

1. Select Corridor > Point Controls from the Roadway Designer menu bar or <D> the 

Point Control button .

2. The roadway will model as defined until it encounters a point control. For this design, three 
point controls are required for each side of the roadway (Left laneline and Right laneline). 
The first control instructs the laneline to follow a feature created by the Median Nose 
corridor. The second control instructs the laneline to follow the mainline alignment. The 
third control instructs the laneline to follow a feature created by the Median Nose_North 
corridor.

3. Verify the corridor Federal_Display_Rule is the active corridor.

4. Create the following Point Control entries to instruct the template point  
RT_Conc_Laneline-Top1 to follow a feature (by the same name) created by the Median 
Nose corridor.

5. First Point Control

♦ Point: RT_Conc_Laneline-Top1

♦ Mode: Both 

♦ Control Type: Corridor Point

♦ Corridor: Median Nose

♦ Reference Point: Conc_Laneline-Top 1

♦ Station Start: 10+00.00 (begin of median radius)

♦ Station Stop: 10+05.50 (end of median radius/nose)

6. <D> ADD

7. Second Point Control

♦ Point: RT_Conc_Laneline-Top1

♦ Mode: Both 

♦ Control Type: Alignment
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♦ Horizontal Alignment: Federal CL

♦ Vertical Alignment: Federal CL_V

♦ Station Start: 10+05.51 (end of median radius/nose - beginning of median opening)

♦ Station Stop: 12+00.00 (beginning of north median/radius nose)

8. <D> ADD

9. Third Point Control

♦ Point: RT_Conc_Laneline-Top1

♦ Mode: Both 

♦ Control Type: Corridor Point

♦ Corridor: Median Nose_North

♦ Reference Point: Conc_Laneline-Top 1

♦ Station Start: 12+00.00 (begin of median radius/nose)

♦ Station Stop: 12+05.00 (end of median radius)

10. <D> ADD

11. Add the fourth, fith, and sixth entry for the LT_Conc_Laneline-Top1 point. The definitions 
mimic the definitions use for the RT_Conc_Laneline-Top1 point.

12. <D> ADD

13. <D> Close
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14. Review the results graphically in Roadway Designer. You should see the raised median 
disappear between stations 10+00.00 and 10+05.00 and again between 12+00.00 and 
12+05.00. Between these station limits, the corridors for the medians will complete the 
model.

15. You should also see the left and right pavement edges running together between stations 
10+05.51 and 12+00.00.  This represents the median opening.

Lab 27.10 - Adding Key Stations

Key Stations are specific locations you define relative to your design.  At these locations an 
additional template is processed.  You can also elect to create a cross section a locations defined 
by key stations.  Examples of Key Stations may be at driveways, side roads, drainage or in the 
case of this exercise, just prior to and after the application of point controls. This ensures the 
roadway models as designed and eliminates transitions between point controls and the next 
corridor defined interval.

1. Select Corridor > Key Stations  from the Roadway Designer menu bar or <D> the Point 

Control button .

2. Key-in the station values immediately before and after the point controls.  Select Add 
after each entry.

♦ 9+99.99

♦ 10+05.51

♦ 11+99.99
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♦ 12+05.51

3. D > Close

4. Select File > Save from the Roadway Designer menu.

Lab 27.11 - Creating the Model

With all the corridors, template applications, point controls and key stations defined, the model 
is ready to be created.

1. Select Corridor > Create Surface from the Roadway Designer menu bar or <D> the 

Point Control button 

2. Select the following corridors for modeling:

♦ Federal_Display_Rule

♦ Median Nose

♦ Median Nose_North

3. <D> on Clipping Options

4. Under the Clipping Option column, <D> to cycle through the options and set both the 
Median Nose and Median Nose_North corridors to Clip None.
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Also set:

♦ Name: Design Model

♦ Default Preference: Proposed

And toggle on:

♦ Densify Horizontal Curves using Chord Height Tolerance

♦ Densify Vertical Curves using Chord Height Tolerance

♦ Triangulate

♦ Remove Loops

♦ Display Features in Plan View

And toggle off:

♦ Add Exterior Boundary - Style:

Lab 27.12 - Review the Design

Use you knowledge of InRoads to review your model. 

Some methods may include:
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 A 3D isometric view of DTM features

 DTM triangles

Contours, profiles and cross sections are additional options.

Chapter Summary:

 In Lab 27.5 -Add Display Rules were created and associated with template components.

 In Lab 27.9 -Point Controls were defined to modify the application of the defined template

 In Lab 27.10 -Adding Key Stations are used to define supplemental template application 
stations.

 In Lab 27.11 -Creating the Model multiple corridors are modeled simultaneously and 
corridor clipping option are defined.
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