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LAB 21 - Creating an Island

In this lab, and island with pedestrian ramps is constructed on the southeast corner of the intersection.  Surface 
features of the island are built using various MicroStation commands and InRoads surface design and editing 
tools.  The island model is added to the proposed intersection model to create a triangulated model of the 
finished grade surface.  Because the island is constructed by feature modeling techniques, there are no 
components included in the model.

Chapter Objectives:

 Lay out the horizontal geometry of the island.

 Identify ramp locations.

 Add elevations to the island shape.

 Create curb and ramp features.

The following files are used with this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Intersec100SH86.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Islands.alg

 C:\Projects\12345\Design\InRoads\Intersection.dtm

The two roads of the intersection are 4 lane curb and gutter.  Each has an additional lane through the 
intersection for a turn bay and acceleration lane.  The island protects the right turn lane from through traffic on 
SH 86.

The SE Curb Return alignment (in the quadrant of the island) represents the edge of pavement for the right turn 
lane.  The features constructed for the island represent the gutter flowline around the island and the pedestrian 
ramps leading on to the island.

Lab 21.1 - Layout the Island Geometry

Section Objectives:

 Use horizontal alignment graphics to create the basic outline of the island.

 Define the radii for the island corners.

 Layout the initial geometry for the pedestrian ramps.

The basic outline of the island is created by offseting the alignment graphics.  This is done by 
displaying the alignments from InRoads then using the MicroStation Move Parallel command 
to copy the graphics to the desired locations.  Construct Circular Fillet is used to create the 
rounded corners for the island.  The pedestrian ramps are laidout with a variety of  
MicroStation tools like, Place Smartline, Construct Line at Active Angle, Extend Element to 
Intersect, etc.

1. Open MicroStation and InRoads with the 
C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Intersec100SH86.dgn 
file.

2. Verify that the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ 
InRoads\Preferences\CDOT_Civil.xin is loaded.
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3. Open the following InRoads files (they are all in the C:\Projects\12345\Design\InRoads\ 
folder):

♦ 12345DES_Geometry-Islands.alg

♦ Intersection.dtm

4. From the InRoads menu bar, select File > New.

5. Select the Surface tab in the New dialog box.

6. Set the Type to Design.

7. Key in SE Island for the Name.

8. Key in Island for SE quad SH 86 and Side Road for the Description.

9. Set the Preferance to Proposed.

10. <D> Apply then <D> Close.

This surface is used to store the island surface data as its being created.  It also protects the data 
in the Intersection.dtm from being accidently modified while editing the island surface 
features.

11. In the InRoads Explorer, expand the 12345DES_Geometry geometry project.

12. <R> on the SH 86 horizontal alignment and select View from the menu.

13. Repeat the process for the SideRoad and SE Curb Return  horizontal alignment

The MicroStation Move Parallel command is used to offset these lines.  The SE Curb Return 
line is offset 14’ (12’ for the driving lane and 2’ for the gutter) to the left to form one side of the 
island.  The SH 86 and SideRoad lines are offset 26’ (24’ for the driving lane and 2’ for the 
gutter) to the right to form the other two sides.
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14. From the MicroStation Main toolbar, select Move Parallel.

15. In the Move/Copy Parallel tool settings box, toggle on Distance.

16. Key in 14 for the value.

17. Toggle on Make Copy.  

18. <D> on the SE Curb Return line.

19. Move the cursor to the left of the line and <D> to make the copy. <R> to exit the command.

20. In the Move/Copy Parallel tool settings box, key in 26 for the value.

21. <D> on the SH 86 line the <D> to the right of the line.  <R> to exit the command.
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22. <D> on the SideRoad line the <D> to the right of the line.  <R> to exit the command.  
The illustration below shows the results.

Next the radii for the island corners are added.  The corner facing into the intersection has a 15’ 
radius.  The other two have a radius of 5’.  These are placed using the Construct Circular Fillet 
command.

23. Select the Construct Circular Fillet command from the MicroStation Main toolbar.

24. In the tool settings box, key in 15 for the Radius.

25. Set Truncate to Both.
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26. <D> on the lines as shown in the illustration below.

27. In the tool settings box, key in 5 for the Radius.

28. Place the other two fillets as done in step 25.  The illustration shows the results.

With the outline of the island in place, the pedestrain ramps can be located.  These are placed in 
the center of each side of the island.  The MicroStation Construct Line At Active Angle 
command is used to place the ramp centerline perpendicular to the island side.  

Note: The dimensions for the pedestrain ramp are taken from the M-608-1 Curb Ramps 
standard, page 104 of the M & S Standards July 2006 edition.

29. Select the Construct Line At Active Angle command from the MicroStation Main 
toolbar.
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30. In the tool settings dialog box, set the Method to From Point.

31. Set the Active Angle to 90^00’00”.

32. Toggle on Length and key in 3 for the value.  This is the length of the 20:1 slope at the 
mouth of the ramp.

33. <T> to the center of a side of the island, move the cursor inside the island and <D>.

34. Repeat step 32 for the other two sides.  The illustration shows the results.

35. From the MicroStation Main toolbar, select Move Parallel.

36. In the Move/Copy Parallel tool settings box, toggle on Distance.

37. Key in 2 for the value.

38. Copy each of the ramp centerlines to either side of itself.  These will make up the edges of 
the ramp tread.  The illustration shows the results.

39. Delete the ramp centerline elements, they will not be used again.

40. From the MicroStation Main toolbar, select Move Parallel.

41. In the Move/Copy Parallel tool settings box, toggle on Distance.

42. Key in 6 for the value.
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43. Copy each of the ramp edge lines to the outside of itself.  These lines are used to create the 
ramps “wings”.   The illustration shows the results.

Section Summary:

InRoads was used to display the alignments that are the basis of the island.  These were copied 
to their exact XY location using the MicroStation Move Parallel command.  Rounded corners 
were added to the island using the Construct Circular Fillet command.  The initial parts of the 
pedestrain ramps were added using the Construct Line At Active Angle command.

Lab 21.2 - Create Ramp and Curb Graphic Elements

The outline of the island is complete.  Now this outline needs to match the elevations in the design surface.  
The Drape Surface and Import Surface From Graphics commands are used to create dtm features of the island 
at the desired elevations.  The ramp elements are draped to set the initial elevation, then Generate Longitudinal 
Feature is used to apply the proper slope to the element.

Section Objectives:

 Create graphic elements of the island at the design surface elevation.

 Modify slope on ramp landing elements.

 Create curb elements.

 Modify the curb elements for the ramp wings.

 Add the ramp wing elements.

All of the graphic elements that make up the island and curb ramps are draped to the 
intersection surface.  This sets the graphic elements of the island outline to the proper elevation.  
It also sets the initial elevations for the curb ramp features.

1. Highlight all of the elements that make up the island and ramp.
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2. Select Surface > Design Surface > Drape Surface from the InRoads main menu.  
This displays the Drape Surface dialog box.

3. In the Drape Surface dialog box, set the Destination Surface to Intersection (this is the 
surface whose elevations are going to be matched).

4. Set the Input Mode to Single.

5. Toggle on Destination Level and select DES_ROADWAY_Curb-Flowline from the 
drop down menu.

6. Toggle on Delete Original Graphics.
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7. <D> Apply.   This displays a message window asking, “Use elements contained in 
selection set?”.  <D> OK to complete the processing.

8. <D> Close to dismiss the Drape Surface dialog box.

The result of the command is that the graphic elements selected are redrawn at the elevation of 
the  intersection surface.  Next, the lines representing the pedestrian ramps are given the proper 
slope.  These elements represent the landing pad of the pedestrian ramp and have a 20:1 slope.

9. Zoom In around the ramp lines on the long arc of the island.

10. Select Extend Element to Intersection from the MicroStation main menu.

11. Extend the outside ramp line to meet the Island line.

Next, check the direction of the lines.  This will affect how the Generate Longitudinal Feature 
command operates.

12. <D> the Change Element Direction tool from the Misc. Tools bar.  The toolbar is 
usually docked at the top of the MicroStation window.  If it is not docked, select CDOT 
Tools > Misc. Tools from the CDOT Menu menu bar.
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13. <D> on one of the ramp landing edge lines.  An arrow appears on the line.

14. Repeat step 13 for each of the ramp lines

15. Select Surface > Design Surface > Generate Longitudinal Feature from the 
InRoads main menu.  This displays the Generate Longitudinal Feature dialog box.

16. On the Generate Longitudinal Feature dialog box Main tab, Toggle on Interval and set 
the value to 1.00.

17. Toggle on Stroke Tolerance and set the value to 0.01.

18. Use the Feature Style drop down menu and select D_CONC_Sw.
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19. Toggle on Generate Graphics Only.

20. <D> the Controls tab.

21. Set the Horizontal Method to Offset From Primary Feature.  Leave the Start and Stop 
values at 0.00.

22. Set the Vertical Method to Elevation/Longitudinal Slope.

23. <D> the ‘target” button for Start Elevation, then <T> to the ramp landing line where it 
intersects the island outline and <D> to accept.

24. Key in 5.00% (1:20) for the Longitudinal Slope.
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25. <D> Apply.  Follow the prompts located in the lower left corner of the MicroStation 
window.  Use the same line for the Primary and Secondary element.  The illustration below 
lists the prompts and the action taken.

The illustration below shows the results of the Generate Longitudinal Feature command in a 
rotated view.

26. Repeat steps 23 through 25 for the remaining ramp landing lines (there are 5 more).

27. Rotate the view so the the originl ramp tread lines can be seen under the new lines.
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28. Delete the original ramp tread lines from each ramp.

29. Rotate the view back to a Top view.

30. Select the MicroStation Place Smartline command.

31. Place a line connecting the back of each ramp tread line.  Be sure to <T> to the end of of 
each line so that the elevation of the new line will be correct.

Next, the generate longitudinal feature command is used to create the back of the pedestrian 
ramps.
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32. From the InRoads main menu, select Surface > Design Surface > Generate 
Longitudinal Feature.  The settings on the Main tab are the same as those set earlier.

33. <D> the Controls tab.

34. In the Horizontal area, set the Method to Offset from Primary Feature.

35. Key in 4.50 for the Start Offset and Stop Offset.  This is the minimum length for this 
section of the ramp according to the M & S Standard.

36. In the Vertical area, set the Method to Offset/Offset.
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37. Key in 0.32 for the Start Offset and Stop Offset.  This is the difference in height from the 
end of the 20 to 1 tread slope to the top of the curb.

38. <D> Apply.  Then follow the prompts.  Use the ramp tread end line as the primary and 
reference element.  <R> to use the entire line.  <D> in the middle of the Island for the 
location.
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39. Repeat step 38 for each ramp.  The illustration below shows the results.  Dismiss the 
Generate Longitudinal Feature dialog box when finished.

40. Select the MicroStation Place Smartline command.

41. Place a lines to complete the sides of each ramp tread.  Be sure to <T> to the end of of each 
line so that the elevation of the new line will be correct.  The illustration below shows the 
results.

Next, elements defining the curb are added.  The Generate Longitudinal Feature command is 
used for this.

42. From the InRoads main menu, select Surface > Design Surface > Generate 
Longitudinal Feature.

43. On the Main tab, key in 1.00 for the Interval.
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44. Set the Feature Style to D_C/G_Ty2_Sect II-B.  The other settings remain as set.

45. <D> the Controls tab.

46. Verify that the Horizontal Method is set to Offset from Primary Feature.

47. Key in 0.125 for the Start Offset and Stop Offset.  This is the horizontal distance from the 
gutter flowline to the top front of the curb according to the M & S Standard.  Note: the 
entry will be rounded to 0.13 in the dialog box.

48. Verify that the Vertical Method is set to Offset/Offset.
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49. Key in 0.50 for the Start Offset and Stop Offset.  This is the height of the curb.

50. <D> Apply.  Then follow the prompts.  <D> an island outline element for the primary 
feature and use the same one for the reference feature.  <D> in the middle of the Island for 
the location.  The illustration shows an example of the results.

51. Repeat step 49 for each element in the island outline.
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52. On the Generate Longitudinal Feature’s Controls tab, key in 0.375 for the Horizontal 
Start Offset and Stop Offset.  This is the width of the curb top. Note: the entry will be 
rounded to 0.38 in the dialog box.

53. In the Vertical area, key in 0.00 for the Start Offset and Stop Offset.

54. <D> Apply.  Then follow the prompts.  <D> a top of curb element for the primary feature 
and use the same one for the reference feature.  <D> in the middle of the Island for the 
location.  The illustration shows an example of the results.
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55. <D> Close to dismiss the Generate Longitudinal Feature dialog box.

The final step, before importing the graphics into the surface is to modify the curbs and add the 
ramp wings.  This includes partial deleting the top of curb lines in the area of the ramps and 
drawing lines for the wings.

56. Zoom in around one of the ramps so that the wing lines and each of the curb lines are 
visible.

57. From the MicroStation main toolbar, select the IntelliTrim command.

58. In the tool settings dialog box, set the Mode to Quick.

59. Set the Operation to Cut.

60. <T> the <D> on the ends of each of the wing lines.  This cuts the curb top lines in these 
locations.

61. <D> and drag through the curb top lines inside the ramp tread as shown in the illustration 
below.

This has broken each of the curb top lines into four sections.  The sections inside the ramp area 
will be modified after they are imported into the surface.  Those outside will be left as is.

Next the lines representing the ramp wings are drawn.

62. From the MicroStation main toolbar, select the Place SmartLine command.
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63. <T> then <D> to the points indicated in the illustration below.

Important! Be sure to snap to the curb top lines.  Snapping to any othe line in this area 
will result in the wing being placed at the wrong elevation.

64. Select the MicroStation Delete command.

65. Delete the wing position lines.
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66. Repeat steps 56 through 65 for the other two ramps.  The illustration below shows the 
island and ramps completed to this point.

Section Summary:
♦ The InRoads Generate Longitudinal Feature command is used to provide elevation to 

graphic elements.

♦ When creating additional elements to be imported into a surface, snapping to elements 
at the proper elevation creates additional elements at the proper elevation.

Lab 21.3 -  Importing Graphics to Surface and Modifying Features

With the exception of the curb top lines inside the ramp areas, the graphic elements for creating the island 
surface are in place.  In this section, the graphic elements are imported into a surface and InRoads tools are 
used to modify the curb features inside the ramp areas.

Section Objectives:

♦ Import Graphics to create a surface.

♦ Use Trim Feature to modify curb top features in the ramp areas.

♦ Use Edit Feature Point for the final cleanup of the curb top features.



Colorado Department of Transportation   Page 431

Labs for InRoads XM LAB 21 - Creating an Island

1. Zoom out in the MicroStation view so that the entire Island can be seen.

2. On the MicroStation menu bar, select Edit > Select All.  This highlights all of the 
elements in the drawing.

3. From the InRoads menu bar, select File > Import > Surface.

4. In the Import Surface dialog box, verify that the From Graphics tab is selected.

5. Select SE Island for the Surface.

6. Verify that Load From is set to Single Element.

7. Verify that Elevations is set to Use Element Elevations.

8. In the Seed Name field, key in SE_Island.

9. Set the Feature Style to D_Curb.
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10. Verify that the Point Type is set to Breakline.

11. <D> Apply.

12. <D> OK on the “Use elements contained in selection set?” message window.

13. <D> Close to dismiss the Import Surface dialog box.

All of the graphic elements have been save into the dtm (surface).  The elements used to create 
the surface are deleted because they will be in the way when performing the next steps.  The 
feature editing commands will automatically update displayed feature graphics but not the 
MicroStation elements originally used to create those features.

14. Select the MicroStation Delete command or press the Delete key to delete the graphic 
elements.



Colorado Department of Transportation   Page 433

Labs for InRoads XM LAB 21 - Creating an Island

15. Select Surface > View Surface > Features from the InRoads menu bar.

16. In the View Features dialog box, verify that the Surface is set to SE Island.

17. Verify that all of the  features are highlighted.

18. <D> Apply then <D> Close to dismiss the View Features dialog box.

19. In the MicroStation view, zoom in on one of the ramps.

20. From the InRoads menu bar select Surface > Edit Surface > Trim Features.
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21. In the Trim Features dialog box, in the Elevation area, toggle on Match at 
Intersection.

22. <D> the target button  Then <D>  the curb back line.  This highlights that feature in the 
list.

23. <D> Apply then <D> to Accept.

24. <D> the ramp tread line then <D> again to accept it.

25. <D> inside the tread area to accept the command and trim the curb feature.
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26. Repeat steps 22 through 25 for the other curb top features in the ramp area.  The illustration 
shows the results.

In a rotated view, notice that the curb top lines do not slope consistantly from the wing to the 
tread.  This is because the Trim Feature command matches the elevation from the intersection 
of the features to the next vertex in the trimmed feature.

To correct this, the feature points between the beginning and end point are deleted.

27. From the InRoads menu bar, select Surface > Edit Surface > Edit Feature Point.

28. Verify that the Surface is set to SE Island.
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29. <D> the target button for Feature, then <D> on the curb back line.

30. <D> the advance point button  to select point 2 on the feature.

31. <D> the Delete button then <D> Apply.

32. Repeat step 31 until only two points are left in the feature.

33. Repeat steps 29 through 32 to the remaining curb top features within the ramp area.  The 
illustration below shows a completed ramp.
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34. Repeat steps 19 through 33 for the other two ramps.  

Important! Be sure to rotate to a Top view when performing the Trim Feature 
command.  This will make it easier to identify the trim location.

35. In the InRoads Explorer, <R> on SE Surface and select Triangulate from the right click 
menu.

36. <R> on SE Surface and select Save.

37. Exit InRoads and MicroStation.

The illustration below shows the contours for the island.



Page 438 Colorado Department of Transportation

LAB 21 - Creating an Island Labs for InRoads XM

Below is a rendering of the Island surface on the Intersection surface.

Section Summary:
♦ When importing graphic elements into a surface, if the elements are not selected ahead 

of time, each element can be given a unique name.

♦ Use the Trim Feature command in a top view.  This helps when indicating which part 
of the feature to trim.

♦ Use the Edit Feature Point command to remove points from a feature.  Delete Feature 
Point only works with Random points.

Chapter Summary:

 The island was created using MicroStation commands and InRoads surface editing 
commands.

 Because it was created as surface features only, there are no components in the island 
surface.

 The Drape Surface and Generate Longitudinal Feature commands were used to create 
graphic elements that were edited before they were imported into the surface.
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