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LAB 1 - Getting Started in MicroStation

Chapter Objectives:

After completing this exercise you will know how to:

 Start MicroStation

 Open a MicroStation design file

 Use the MicroStation mouse buttons

 Navigate the MicroStation interface

 Use the View Control commands

 Assign view controls to the mouse wheel

 Float and dock toolbars

 Show and hide tools on toolbars

 Access the MicroStation Key-in box

Lab 1.1 - Starting MicroStation

To start MicroStation:

1. Select Start >All Programs > Bentley > MicroStation V8 XM > MicroStation V8 XM Edi-
tion

or

Double-click on the MicroStation V8 XM Edition icon located on your desktop.

MicroStation will start and the MicroStation Manager dialog box will appear on your 
screen.
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Lab 1.2 - The MicroStation Manager Dialog Box

The MicroStation Manager is your file management interface in MicroStation. It allows you to create, 
rename, delete, and open files as well as set workspace parameters. Within MicroStation Manager the user will 
set three important components: User, Project, and Interface. Setting these components allow you to more 
easily access the project directory structure and customize the MicroStation interface.

Note: Do not press <Enter> after you key data in a dialog box unless you are ready to apply 
the settings.  Use the <Tab> key or your mouse cursor to move from one field to the 
next to choose or enter your setup options before you Apply or OK the command.

Opening files

1. In the lower right-hand portion on the dialog box set the three components as shown below

♦ User: CDOT User
♦ Project: 12345
♦ Interface: CDOT

Note: The Project option automatically sets the directory to C:\Projects\12345. You’ll 
lean more about the project configuration file (PCF) in chapter 4.

2. In the MicroStation Manager, navigate to \Design\Drawings\Reference_Files folder.

3. Highlight 12345DES_Model.dgn as the design file to open.

4. A thumbnail preview of the file is shown.

5. Select OK to open the design file.
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6. This is a design model file of CDOT project SH 86, which will serve as the example project 
for this class as well as other CDOT training classes.

Note: The CDOT Menu opens automatically. You’ll use this menu later. For now, 
minimize or close the CDOT menu.

Lab 1.3 - Working with the Mouse

While in MicroStation, your mouse operations include:

<D> Data (usually the left button) for selecting tools, highlighting fields, moving dialog boxes, 
confirming actions, etc.

<R> Reset (usually the right button) for terminating commands, rejecting actions, etc.

<T> Tentative (usually the middle button or scroll wheel) for snapping to existing elements at 
exact locations.

Lab 1.4 - Access Pull-Down Menus

Use pull-down menus to select settings and non-drawing commands from the application window.  You can 
either post a menu (display it until you select a function from the menu) or open the menu and select a 
command all in one step.

Post a pull-down menu from the command window

1. Point your cursor to File in the application window and select it by clicking the data point 
once <D>.
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♦ The pull-down menu appears.

♦ Menu names followed by ... indicate a dialog box will open when you select the item.

♦ Names with an arrow to the right indicate there is a sub-menu associated with the item.

♦ You can also use the keyboard to select a command from a menu.

♦ The bottom portion of the file menu will display a file history allowing the user to open 
previously opened files more easily.

2. Use the up and down arrow keys on your keyboard to move up and down an item list or 
move your cursor.

♦ Text to the right of an item indicates the hot key or shortcut to use to activate the 
command (e.g., Ctrl+N means to hold down the Ctrl key and type N).

♦ Underlined letters indicate a shortcut key to choose an item from a menu.
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3. Move your cursor to Element to show the element pull-down menu. 

Lab 1.5 - Open a Settings Box

1. Select Settings > Locks  > Toggles to open the Locks settings box.

Note: A settings box, like the Locks box, does not have any command buttons (OK, 
Close, etc.).  Settings boxes can be left open while working in MicroStation.
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2. Close the Locks settings box by selecting the X in the upper right hand corner.

Lab 1.6 - Control Views

Turn on additional views

1. From the View Toggles box (lower left of the screen), toggle on
views 2, 3 and 4.  <D>.

Note: By default, views 1-4 open in screen 1, views 5-8 open in screen 2. To move a view 
to a different screen, select the “M” control menu and choose Change Screen.
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2. Select Window > Tile to arrange the views.
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Fit View 1

1. From the View Control toolbar in View 1, select Fit View.

All of the plan view graphics appear in the view.
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Rotate all views to top

1. From the View Control toolbar in View 2 select Rotate View.

2. In the Rotate View tool settings box, set Method to Top. 

3. <D> in View 2 to change it to a top view (verify the view name is Top).

4. Fit view 2.
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5. Repeat the above steps to rotate views 3 and 4 to a Top view and Fit the views.

Zoom In within a view

1. From the View Control toolbar in View 2, select Zoom In.



Colorado Department of Transportation   Page 21

Labs for MicroStation XM LAB 1 - Getting Started in MicroStation

2. Place your cursor (the X cross-hair) in the center of the intersection and place a data point 
<D>.

The view is updated to Zoom In twice as close.  The center of the view is the data point you 
identified.
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3. Continue placing data points until you’ve zoomed in to the intersection as shown.

4. Reset <R> to end the Zoom In command.

Turn off the raster files

The model file has aerial photos attached. These raster images can be turned off while working 
in the file.

1. Select File > Raster Manager.

2. Select both .TIF files using the shift or ctrl key.
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3. From the View toggles, bottom left of the dialog bog, toggle off all Views (1-8).

4. Close the Raster Manager box.

Zoom out in a view

1. From the View Control toolbar in View 2, select Zoom Out.

The view is updated to zoom out twice as far.

2. Again in View 2, <D> in the center of the intersection to zoom out again until you can see 
the entire intersection cross road.

Use the Window Area command

1. From the View Control toolbar in View 3, select Window Area.   

2. <D> above and to the left of the beginning of the project.
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3. <D> again below and to the right of the first point as shown (this will draw a box around 
what you want to show close-up).

The view is updated to show the alignment at the beginning of the project.
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4. While still in the Window Area command, move your cursor over to View 4 and <D> 
above and to the left of the alignment end as shown.

5. <D> again below and to the right of the alignment end.

The view is updated to show the end of the project.
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Your views should look similar to the illustration below.

Fit views

1. From View 2, select Fit View.

All of the graphics in View 2 are displayed in the view. The Fit View command is a handy 
way to see all graphics on levels that are on.
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2. With the Fit command active, <D> in views 3 and 4 to select these views to fit.

Close some views

1. Toggle off views 2, 3 and 4 on the View Toggles box.
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Note: You can also click the X icon in the view’s upper right corner to close it or you can 
double-click on the M icon, the control menu icon, in the upper left corner of a 
view.

Make view one fill the screen

1. Select the Maximize button in the upper right corner of View 1.
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2. Fit View 1.

Lab 1.7 - Mouse Wheel Settings

Note: If you do not have a mouse with a wheel, go to the next section titled Try Out Tool 
Boxes.

Use the wheel on the mouse to Zoom In/Out

1. Position your cursor over the center of the intersection.

2. Roll the wheel up; this zooms in on your graphics.

3. Roll the wheel back; this zooms out.

Note: If you <T> on a location before rolling the wheel MicroStation will zoom in/out 
around that point.

Change the wheel settings

1. Select Workspace > Preferences > Mouse Wheel.
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2. Set the Wheel to Pan Left/Right.

3. Select OK to accept the changes and close the dialog box.

4. Move your mouse wheel back and forth to pan in the view.

Note: You can also Pan by selecting the pan command on the View Control toolbar.  
Specify a “from” and “to” point to move in the view. 

    

You can also Pan by pressing <Shift> on the keyboard and click <D> in the view. Then, 
drag your cursor in the direction you wish to move.

a. Practice panning with the Pan tool.

b. Practice panning using <Shift>+<D>.

Note: After you start panning, you can release the both the <Shift> and the <D> keys. 
<D> again to end the command.
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5. Set your wheel for the view control option you prefer (Workspace > Preferences > 
Mouse Wheel).
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Pan the project site

1. Window in to the beginning of the project as shown.

2. Use panning to review the SH 86 project site. 

♦ Start at the POB (STA 100+00) and pan to the right along SH 86.
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♦ Pan across the intersection (between STA 220+00 and 230+00).
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♦ Continuing panning to the right through the transition from rural 2-lane to urban 2-lane 
with curb and sidewalk (around STA 353+00).
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♦ Stop at the POE.

Lab 1.8 - Try Out Tool Boxes

Pull a tool bar from the main palette

1. Select and hold down the Place SmartLine icon from the CDOT Main tool palette to dis-
play the Linear Elements tool bar.

2. Hold down the data button <D> and drag your cursor to the bottom to the Open as ToolBox.
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3. Select the Place SmartLine command.

The Tool Settings box shows this command’s settings options.

4. Select the Place Line command from the Linear Elements toolbar and notice the changes 
in the Tool Settings box.

The Tool Settings box updates for each tool selected.

5. Close the Linear Elements toolbar by clicking the x in the upper right corner.

Float and Dock Toolbars

 Float the Primary Toolbar

1. Position your cursor over the edge of the Primary Tools toolbar at the top of the application 
window.

2. Hold down the data button and drag the toolbar until it “floats” in the view.
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3. Repeat for the Standard toolbar.

Toggle the Primary Tools toolbox off/on

1. Select Tools > Primary.

The Primary Tools toolbox is turned off.

2. Select Tools > Primary again to toggle it back on.

3. Dock the Primary Tools and Standard toolbars back to the upper right corner of the 
application window by dragging the title bar with the data button.

Note: Any toolbar can be docked on the perimeter (top, bottom, left, or right sides) of 
MicroStation’s application window. 

Show/Hide Tools

1. Open the Linear Elements toolbar as shown above. 
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2. Right-click anywhere on the Linear Elements toolbar.  In the list of tools, toggle off Place 
SmartLine.

The SmartLine tool is removed from the toolbar.

3. Right-click <R> again and turn Place SmartLine back on.

4. Right-click <R> and choose List.

5. Toggle off the last four tools.

6. Choose OK.

The toolbar is updated to show these tools hidden.
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7. Right-click <R> and select Show All.

All tools are now shown on the toolbar.

8. Close the Linear Elements toolbar (click the X in the upper right corner)

Note: Use this procedure to customize any toolbar to show just the tools you want.
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Lab 1.9 - Using the Key-In Box

Open and dock the key-in box

1. Verify the Key-in box is opened and docked.

Note: If the Key-In box is not open, select Utilities > Key-in to open it. 

2. Float the Key-in box from its docked position.
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3. Expand it by grabbing the bottom of the box and dragging down.

Key-ins can be selected from the list but are typically typed directly into the box.

4. Grab the title bar of the key-in box and drag it to the blank space at the top of the 
application window.

The Key-in box docks beside the other tool bars in the application window.

Note: You can also dock the Key-in box at the bottom of the screen if you prefer.

Lab 1.10 - Save settings 

Save settings in the file so the views will look the same when you next open the design file.

1. Fit View 1.

2. In the Key-in box you just docked, place a data point to set the focus in this box (you will 
get a blinking cursor).

3. Key in File (short for File design), then press <Enter> on the keyboard.

Note: You always press <Enter> or <Tab> after key-ins in the Key-in box.

Keep the Key-in box docked.  It is where you will key in all MicroStation commands.
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Note: To Save Settings, you could also select File > Save Settings or use the short cut 
CTRL-F. Most commands can be accomplished with either key-ins or by selecting 
from the menu or toolbars.

By saving settings, the next time you enter this design file, it will be exactly as you left it.

4. Choose File > Exit to exit MicroStation and your design file.

Note: You can change your MicroStation user preferences to always save setting upon 
exiting the file. Select Workspace > Preferences > Operation and toggle on 
Save Settings on Exit. Just remember that if you’re working in another user’s file, 
you’ll change their setting.
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