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Lab 5.1 - Managing Survey Files

In Section 1 of the training a fieldbook, design file, surface model, and geometry project were 
created.  Consider that work to be out of date and those files will need to be managed in the 
Working directory.

1. Open Windows Explorer and path to the directory 
C:\Projects\12345\ROW_Survey\Working

2. Rename the working file with your initials and date YYYY-MM-DD for example 
RBM12345SurveyTopo100Scale01_2009-11-04.dgn

Note: When the design file has been finalized it will be moved to the 
ROW_Survey\Drawings\Reference_Files\ directory for use by the rest of the 
project team.
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Lab 5.2 - Importing Control Files

Section Objectives:

♦ Import a CDOT survey control file that has the points as fixed positions.

♦ View the control file points in the fieldbook dialog and in the MicroStation view.

1. Double-click on the InRoads Survey desktop button    or select 
Start > All Programs > Bentley > InRoads Group V8i > InRoads Survey.

2. In the MicroStation Manager dialog go to the Workspace group section and change
User: CDOT User
Project: 12345
Interface: CDOT
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3. In the MicroStation Manager dialog path to the directory: 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\

4. Select the file 12345SURV_Topo##Scale##.dgn from the MicroStation Manager 
dialog.

Note: The purpose of the files with “##” symbols are for creating new files with the 
correct naming convention.

5. <D> Open the MicroStation Manager dialog will close and open the drawing file.

6. From the MicroStation pull-down menu File > Save As the Save As dialog will appear.

7. Path to the folder C:\Projects\12345\ROW_Survey\Working

8. Replace the ## symbols with 100 scale and 01 model. 
Type in Files: 12345SURV_Topo100Scale01.dgn
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9. <D> the Save button the Save As dialog will close and MicroStation reflect that you are 
working in the file 12345SURV_Topo100Scale01.dgn.

10. Launch InRoads Survey from the Colorado DOT toolbar. Alternatively it can be launced 
from the main MicroStation pull-down menu by selecting Applications>InRoads 
Group>Activate Survey

11. Once InRoads opens, from the InRoads pull down menu, select 
File > New.  The New dialog will appear.
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12. Select the Survey Data tab.

13. Key in the Name: 12345SURVFieldbook01

14. <D> the Apply button. The new survey fieldbook will appear below.

15. <D> the Close button. The New dialog will close.

16. From the Workspace bar the 12345SURVFieldbook01 will be active.
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17. From the pull-down menu, select File > Import > Survey Data. The Import dialog will 
open.

18. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

19. Verify the Files of type: CDOTCTL (*.CTL)

♦ Importing the CTL file first is only needed if the field books being imported are 
conventional files.  GPS (positional) files do not require the CTL file.

Note: The Files of type: drop-down box works as a filter.  Allowing to the files that 
have the particular file extensions to be viewed.  This allows InRoads Survey to 
utilize a specific import wizard for each file type.
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20. <D> the Options button.

Note: This is the same dialog that can be opened from Tools > Survey Options
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21. Verify the Cell, Text, and Line Scales are all set to 100, 20 ,100

22. Verify Fieldbook Audit Trail File Name is still set from Section 1.
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\
”UserInitials”_FieldBookEdits.log

23. <D> the OK button.  The Survey Options dialog will close.
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24. <D> the Import button.  The Import dialog will remain open allowing  additional files to 
be imported.

25. <D> the Close button.

Note: Upon closing, InRoads Survey executes the import routine.

26. From the pull-down menu, select Survey > Fieldbook Data….  Take a minute to review 
the imported Survey control data that is now contained in the electronic Fieldbook.
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27. While the Fieldbook Data dialog is open, also look at the MicroStation view and 
displayed graphics.

28. Practice changing the display graphics using the View Survey Data toolbar.

29. Continue to practice zooming and panning using the MicroStation view border buttons.

30. Close the Fieldbook Data dialog.

31. Fit View from the View Survey Data toolbar.

It is up to the user to determine when to save the data in InRoads Survey.  Until now the 
fieldbook is being stored in memory. If something was to cause InRoads to close, your data 
would be lost.
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32. File > Save > Survey Data the Save As dialog will open.

33. Verify the directory location:
C:\Projects\12345\ROW_Survey\InRoads\Field_Books

34. Choose the Active: 12345SURVFieldbook01 at the bottom of the dialog.

35. Verify the File Name: 12345SURVFieldbook01.fwd
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36. <D> the Save button.  The file will be saved to disk and will show in the dialog.

37. <D> the Cancel button.  The Save As dialog will close.



Colorado Department of Transportation   Page 71

Labs for Using InRoads Survey for Data Reduction LAB 5 - Importing Data

Lab 5.3 - Importing Data collector files

Section Objectives:

♦ Import multiple raw Sokkia SDR topo files into the InRoads Survey fieldbook file.

♦ Import a raw Trimble DC topo file into the InRoads Survey fieldbook file.

♦ Create an error log file for keeping track of code errors in the fieldbook file.

♦ Correct code error problems using the Resolve Code Error dialog.

♦ Review topo points in the Fieldbook dialog and MicroStation view.

Importing SDR files

1. From the Workspace bar select and highlight 12345SURVFieldbook01 and <R> to view 
the shortcut menu.

2. <D> Import… The Import dialog will appear.

♦ This is a same as using the pull-down menu File > Import > Survey Data.
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3. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

4. Change the drop-down arrow Files of type: Sokkia SDR (*.sdr)

5. Select the file 12345AAAIR.sdr from the filtered list of files.

6. <D> the Import button.  The Import dialog will remain open allowing additional files to 
be imported.

7. <D> the Close button.
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8. Select the Fieldbook    button from the Survey toolbar.  The Survey Fieldbook will 
appear.

9. Take a minute to review the observations from Station Name 2000 that was imported into 
the electronic Fieldbook.

10. Close the Fieldbook dialog <D> the X in the upper right hand corner of the dialog.

Resolving Code errors

From the Tools > Survey Options dialog the choice was made to resolve any code errors 
when the data is imported. There are a couple of ways to handle code errors.

1. Re-open the Import dialog.

2. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

3. Verify the drop-down arrow Files of type: Sokkia SDR (*.sdr)

4. Select the file 12345BBBIR.sdr from the filtered list of files.

5. <D> the Import button.  Only one file can be selected at a time.  The Import dialog will 
remain open allowing for additional files to be imported.

6. <D> the OK button in the SDR Tolerance dialog box.



Page 74 Colorado Department of Transportation

LAB 5 - Importing Data Labs for Using InRoads Survey for Data Reduction

7. <D> the Close button.  The imported SDR files will be processed.

Note: There are code errors with these files; the Resolve Code Errors dialog will appear.

8. Key-in Change To: 1699

9. <D> the Retry button.  The code will be processed and the next error will appear.  

Continue this process for the next three code errors.

10. Key-in Change To: 5182 <D> the Retry button.
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11. Key-in Change To: 4210.08 ST <D> the Retry button.

12. Key-in Change To: 4274 <D> the Retry button.  The Resolve Code Error dialog will 
close and Survey will process the data.

13. From the pull-down menu, select File > Import > Survey Data.  The Import dialog will 
open.

14. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

15. Verify the drop-down arrow Files of type: Sokkia SDR (*.sdr)
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16. Select the file 1234500CCCIR.sdr from the filtered list of files.

17. <D> the Import button.  The Import dialog will remain open allowing for additional files 
to be imported.

18. Continue to import the remaining SDR files 1234500DDDIR- 123450EEEIR

♦ If a previously imported SDR file was selected the following dialog will appear.

19. <D> the No button and go back and select a different file.
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Importing Trimble DC file

20. Change the drop-down arrow Files of type: Trimble DC (*.dc)

21. Select the file 12345FFFIR.dc from the filtered list of files.

22. <D> the Import button.  The Import dialog will remain open allowing for additional files 
to be imported.

23. <D> the Close button.  If errors are present in the input files, the Resolve Code Errors 
dialog will appear.

24. <D> the Log File Name key in field. The Browse button will become activated.
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25. <D> the Browse button in the Resolve Code Error dialog.  The Browse dialog will appear.

26. Path to the Save in folder C:\Projects\12345\ROW_Survey\InRoads\Field_Books.

27. Key in the file name ResolveCodeErrors_All.log

28. <D> the Save button the Browse dialog will close and the file name and path will appear 
in the Log File Name field.
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29. <D> the Ignore All button.  The Results dialog will appear showing the errors and the log 
file will be saved.

30. <D> the Close button in the Results dialog.  Those errors will be addressed later in this 
lab.

31. Select the Fieldbook    button from the Survey toolbar.  The Survey Fieldbook will 
appear.

32. Take a minute to review the observations from Station Name 12345FFFIR that was 
imported into the electronic Fieldbook.
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33. Locate Station Name: 12345CCCIR Point Name: 13619.  Notice the code is red, 
representing an error.

Note: While the Fieldbook Data dialog is open, look at the MicroStation view and 
displayed graphics.

34. Locate the same point in View 1 using one of the following methods.

♦ <R> Point Name to view the Fieldbook shortcut list and select Center
or
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♦ From the pull-down menu, select Survey > Find Point in View

Note: The code errors will be corrected in the fieldbook later in the lab.

35. Close the Fieldbook dialog and any other dialogs.
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Lab 5.4 - Importing ASCII files

In the following steps an ASCII file will be imported.  To import ASCII files the Text Import 
Wizard (TIW) will be used.  This format created for importing text can be saved and recalled 
for future use.

Section Objectives:

♦ Import a custom ASCII report with the Text Import Wizard.

♦ Create a new standard import selection for future use.

♦ Review the points in the Fieldbook file and MicroStation view.

1. From the pull-down menu, select File > Import > Survey Data.  The Import dialog will 
open.

2. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

3. Change the drop-down arrow Files of type: Text File (*.*)  All the files in the directory 
will be shown.
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4. Select the file 12345TestHoles.xyz

5. <D> the Import button.  The Text Import Wizard dialog will appear.

6. Change the entry field Start Import at Row: 7 and Tab out of the field. This will ignore 
the header information in the file.

7. Verify the Record Format radio button is set to Uniform.
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8. Verify the Original Data Type radio button is set to Delimited.

9. <D> the Next > button.  The Step 2 of 3 dialog will appear.

10. In the Delimiters section of the dialog check on the Comma delimiter field as this 
defines what separates our columns of data.  Verify the rest of the dialog is set as shown 
below.
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11. <D> the Next > button.  The final Step 3 of 3 dialog will appear.
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12. Select the header of the first column labeled Skip.  The column will highlight as shown 
below.

13. From the Column Data Format drop-down box select Point Name

14. Select the second Skip column header then select Easting from the Column Data Format 
drop-down box.

15. Select the third Skip column header then select Northing from the Column Data Format 
drop-down box.

16. Select the fourth Skip column header then select Elevation from the Column Data 
Format drop-down box.

17. Select the fifth Skip column header then select Code from the Column Data Format 
drop-down box.
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18. <D> the Save As button.  The Save As dialog will appear.

19. Key in File name: ASCII Import ENEc

20. <D> the Save button.  The Save As dialog will close and and error dialog will appear.

Note: Because files can not be saved to the Program Files directory on the computer the file 
will default to the users login C:\Users\cdot\Documents folder structure.

21. <D> the Yes button. The Save in the CDOT User folder will appear.
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22. <D> the Save button and the dialog will close.

23. The Save Format to File Types dialog will appear.  Verify Format Name: ASCII 
Import ENEc

24. <D> the Yes button.  The Save Format to File Types dialog will close and the Step 3 of 3 
dialog will reappear.

Note: The Text Import Wizard has been created for future use.

25. In the Step 3 of 3 dialog <D> the Cancel button.  The Step 3 of 3 dialog will close and the 
Import dialog will reappear.

26. In the Import dialog change the Files of type: ASCII Import ENEc (*.xyz)

Note: The extension for the filter (*.xyz) came from the original file extensions that was 
imported.
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27. Select the file 12345TestHoles.xyz

28. <D> the Import then Close buttons.

29. <D> Ignore All in the Resolve Code Error dialog and then close the dialog.  

Note: The Resolve Code Error dialog continues to open because the entire file is 
processed each time a file is imported.

30. <D> the Close button in the Results dialog.

31. Review the data that was imported Survey > Fieldbook Data…
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32. Locate the file that was imported into the Fieldbook Data dialog.  As files are imported 
to the fieldbook they will always append to the active fieldbook.

33. Select Point Name 20006 in the fieldbook.

34. <R> Center Point Name 20006 to the MicroStation view.

Note: The center command from the shortcut menu works with the current zoom ratio 
and will not zoom into the point.
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35. Save the Survey fieldbook.  From the Workspace Bar <R> on 12345SURVFieldbook01 
select Save from the shortcut menu.

36. The Status Bar will show that it was saved.
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Section Summary:
♦ In Lab 5.1 -Managing Survey Files the working directory was cleaned up to avoid any 

name conflicts.

♦ In Lab 5.2 -Importing Control Files the CDOT survey control file was added first to 
the InRoads Survey fieldbook file.

♦ Lab 5.3 -Importing Data collector files additional raw survey topo files from a Sokkia 
and Trimble data collectors were added to the InRoads Survey fieldbook file.

♦ In Lab 5.4 -Importing ASCII files a custom ASCII file was imported into the InRoads 
Survey fieldbook file and the settings were stored in the product for future use.
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