
Colorado Department of Transportation   Page 155

LAB 8 - Exporting the Fieldbook

Lab 8.1 - Exporting Survey Data to Graphics

Managing Drawings in the Reference Files folder

The files in the Reference Files folder are for other disciplines to reference.  Other disciplines 
are to reference in the 01 model file.  There are already 01 files in the Reference Files folder 
that are out of date.  The new Survey Fieldbook that is exported will become the new 01 file.

Section Objectives:

♦ Create a new design file to write survey data to graphics.

♦ Run the CDOT Stratify Survey tool from the CDOT Menu.

1. Open Windows Explorer.

2. Navigate to the folder C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\

3. Rename each file 12345SURV_Topo* with a 01 counter and rename it to 02.

Note: The next steps will create these model files with an updated InRoads Survey fieldbook.
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Creating new 01 design files.

4. From the MicroStation pull down menu select File > Open the Open dialog will appear.

5. In the MicroStation Manager dialog path to the directory: 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\

6. Select the file 12345SURV_Topo##Scale##.dgn from the Open dialog.

Note: The purpose of the files with “##” symbols are for creating new files with the correct 
naming convention.

7. <D> the Open button MicroStation Manager dialog will close and open the file.

8. From the MicroStation pull down menu select File > Save As the Save As dialog will 
appear.
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9. Replace the ## symbols with 100 scale and 01 model. 
Type in File name: 12345SURV_Topo100Scale01.dgn

10. <D> the Save button the Save As dialog will close and MicroStation will open the file 
12345SURV_Topo100Scale01.dgn

11. Verify the 12345SURVFieldbook01 survey fieldbook is active.  You can tell which 
fieldbook is active by the red box around the fieldbook button.
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12. To modify the scale as it relates to cells, text, and linestyles go to 
Tools > Survey Options > [General]. The Survey Options dialog will appear.

13. Set the Scales for Cell, Text, and Line as shown below.

♦ Cell Scale:100
♦ Text Scale:20
♦ Line Scale:100

Note: Segregate Text by Feature Level, should be checked on, this will save the symbols, 
point names, codes, notes, errors, and elevations to the same level as the survey feature.

14. <D> the OK button the Survey Options dialog will close.
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15. From the InRoads pull down menu select, Survey > View Survey Data > Write 
Survey Data to Graphics… the Write Survey Data to Graphics dialog will open.

Note: By default if you had dynamic graphics still toggled on, those same components would 
be toggled on in the Write Survey Data to Graphics dialog.

16. Check ON the Select All box.

17. From the drop down list for Curve Stroking: Horizontal Only

18. <D> the Apply then Close button. The Survey fieldbook planimetrics has been written to 
graphics.

19. Verify all View Survey Data buttons are toggled display off.
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20. From the MicroStation view border Fit the design file.

21. Review your results.

22. From the CDOT Menu pull-down select CDOT Tools > Stratify Survey.  The 
Stratify Survey dialog will appear.

23. Type in the Scale: 20

Note:

♦ Under Existing Files, the Append option will add or merge the new data into an 
existing file. A new file will be created if the file does not already exist.

♦ Under Existing Files, the Overwrite All option will create a new file, deleting any 
previously existing file.

♦ Under Existing Files, the Overwrite None option will disable the processing option for 
a file if the file already exists.

♦ The Process option Adjust Planimetrics will resize the planimetrics text (if necessary) 
and convert the grouped text strings to view independent cells in order to allow for 
viewing this text in any 3D view.

24. Verify the JPC, Scale, and Sheet Number entries are correct.  Altering any of those values 
will automatically alter the output file names.  If the Attach check box in the Contours 
section is grayed out, the contour file does not exist.  You may edit the name specified in 
the File Name field to enter the name of an existing contour file.

25. <D> OK button to start the process.
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26. As the data is being moved to the appropriate reference file a Processing Status dialog 
provides an update on the progress.  You may Cancel at any time to stop the processing, if 
necessary.

27. When completed, a Processing Completed message is displayed.  <D> OK to exit the 
program.

28. The fieldbook data has now been stratified into separate reference files. The planimetrics 
will be in the master design file with all of the symbols, names, codes, etc., attached as 
reference files. To view these attachments select File > Reference from the MicroStation 
pull down menu.
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Lab 8.2 - Exporting Survey Data to Surface

Managing Drawings in the Reference Files folder

The files in the Reference Files folder are for other disciplines to reference.  Other disciplines 
are to reference in the contour model file.  There is already a contour file in the Reference Files 
folder that is out of date.  The new Survey Fieldbook that is exported will become the new 
contour file.

Section Objectives:

♦ Create a new design file to create the surface display graphics.

♦ Export the survey data to a surface file for a final deliverable.

♦ Use the delete triangle command to constrain the triangles to the survey points 
collected in the field.

♦ View the new surface perimeter.

♦ Import new perimeter into the surface as an exterior boundary.

1. From the MicroStation pull down menu select File > New.  The New dialog will appear.

2. Navigate to the file folder Reference_Files by double clicking the directory folders.

3. At the bottom of the dialog box verify that the seed file is set to Roadway_Design_3D.dgn.

4. Key in the file to be created 12345SURVContour100Scale2_10.dgn

5. <D> the OK button in the New dialog.  The New dialog will close and the file 
12345SURVContour100Scale2_10.dgn  will open.

6.  From the MicroStation menu pull down select Settings > Drawing Scale the Drawing 
Scale dialog will appear.
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7. In the Annotation drop down list select 1” = 1’

8. From the MicroStation pull down menu select File > Save Settings.

Note: The reason annotation scale needs to be set to 1”=1’ is so that the linestyles will be 
displayed correctly from InRoads Survey.

9. Verify the 12345SURVFieldbook01 fieldbook is active.  You can tell which fieldbook is 
active by the red box around the fieldbook button.

Survey Data to Surface

10. From the InRoads pull down menu, select File > New.  The New dialog will appear.

11. <D> the Surface tab.

12. From the drop down list select Type: Existing

13. Key in the surface Name: 12345SURVSurface01

14. Key in the Description: CDOT Surface Final

Note: Key in any additional file information in the Description field of the dialog, such as 
Date, User, and Design file name. You have up to 34 characters even though you may 
not see all the characters in the Description field.

15. Keep the Maximum Length set to 0

16. From the drop down list Preference: Existing 10’ Mjr – 2’ Minor

17. <D> the Apply then Close buttons.
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18. From the pull down menu Survey > Survey Data to Surface.  The 
Survey Data to Surface dialog will appear.

19. From the drop down list Surface Name: 12345SURVSurface01 

20. Type in the Parent Name: Survey Fieldbook Export

21. From the drop down list Description: Use Style Description

22. Keep the Tolerance and Maximum Segment Length set to 0.00

23. From the drop down list Curve Stroking Mode: Horizontal Only

24. Check ON Always Use: Style

25. Check ON Triangulate Surface

26. <D> the OK button the Triangulate Surface dialog will appear.
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27. Leave all settings unchecked. Maximum Length should be set to 0.00.

28. <D> the Apply button.  The Results section of the dialog should look similar to the image 
below.

29. <D> the More button. The Surface Properties dialog will appear.

30. Verify you are working with the correct surface 12345SURVSurface01.

31. Review the section for Data Range. The Northing, Easting, and Elevation values should 
fall within the project limits.
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32. On the Advanced tab choose 
Cross Sections - Symbology: T_Existing_Ground

33. On the Advanced tab choose 
Profiles - Symbology: T_Existing_Ground

34. <D> Apply then Close in the Surface Properties dialog.

35. <D> the Close button in the Triangulate Surface dialog.

36. Use the Workspace bar scroll arrows to view the Surfaces tab.

37. Verify 12345SURVSurface01 is the active surface.

Note: You can change the active surface from the pull-down menu Surface > Active Surface; 
highlight the surface name and <D> the Apply button.
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38. From the InRoads pull down File > Save > Surface.  The Save As dialog will appear 
with the Save as type: Surfaces (*.dtm).

39. Verify you are in the correct project directory.
C:\Projects\12345\ROW_Survey\InRoads\DTM

40. The file name should match the Active name at the bottom of the Save As dialog.  If 
necessary, use the drop down arrow in the Active field and reselect the desired name to 
ensure the saved file name will match the surface name.

Note: Ensuring that the saved Surface name in the project folder matches the Surface name 
displayed in InRoads explorer will minimize any confusion.

41. <D> the Save then Cancel button.  The file will be saved to disk and the Save As dialog 
will close. 
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Lab 8.3 - Exterior Boundary

Errant triangles can be eliminated by controlling the maximum triangle length. However this 
can cause problems in areas of the DTM where data density varies. A more refined method is to 
add an exterior boundary that constrains the triangles to fall within the limit of the exterior 
boundary.

Section Objectives:

♦ Delete unwanted triangles from the design file.

♦ Display the perimeter of the model (active triangle limits).

♦ Import the displayed perimeter into the DTM as an exterior feature.

♦ Verify the results.

1. Open the MicroStation file - 12345SURVContour100Scale2_10.dgn

2. Open the InRoads Survey Fieldbook file - 12345SURVFieldbook01.fwd

3. Open the InRoads Survey Surface file - 12345SURVSurface01.dtm

4. Using MicroStation Delete.  Delete all graphics from the design file.

5. Using MicroStation Window Area button center the survey fieldbook dynamic display 
planimetric graphics to View 1 Top rotation.

6. From the pull down menu select, Surface > View Surface > Perimeter.  The 
View Perimeter dialog will appear.

7. <D> the Preferences… button.  The Preferences dialog will appear.

8. Select CDOT from the Preferences dialog

9. <D> the Load then Close buttons in the Preferences dialog.

10. <D> the Apply button in the View Perimeter dialog.
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11. Review your results.

12. Close the View Perimeter dialog.

Note: The perimeter will be used as a reference line as triangles are deleted.

13. Redisplay the triangles Surface > View Surface > Triangles.  The View Triangles 
dialog will appear.

14. Load the Existing Preferece for View Triangles.

15. <D> the Apply button in the View Triangles dialog.

16. From the InRoads pull down menu select, Surface > Edit Surface > Delete Triangle.  
The Delete Triangle dialog will appear.

17. <D> the Apply button.  The Delete Triangle dialog will minimize allowing you to select a 
point in the view.
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18. <D> a point in the MicroStation view off to the side of the surface limits.

♦ There is no need to hold down on the Left mouse button.

19. Move the cursor, a line will be displayed

20. Sweep the cursor over the surface model to dynamically highlight surface triangles

Note: The line highlights triangles as they are crossed. Highlighted triangles will be removed 
from the surface model once a data point <D> is given to establish the endpoint of the 
line (selection). 

21. <D> a second point to define the line at the point shown above.

22. <D> a point in the view to accept and delete the triangles.

23. Continue drawing lines to remove undesirable triangles from other areas of the surface.

24. <R> when you have completed deleting triangles from this zoom ratio.  The Delete 
Triangle dialog will reappear.

Note: You can write triangles to the display as MicroStation graphics at any time. Do not re-
triangulate the surface before defining an exterior boundary as deleted triangles will be 
re-established. 

Note: If the triangles are redisplayed, keep in mind, displayed triangles are a reflection of 
what InRoads has in memory at a specific point in time. If triangles are deleted (from 
memory) the MicroStation graphics displayed will not reflect this change until the 
triangles written to graphics are redisplayed (refreshed).
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25. Use MicroStation to view Window into an area of the survey.

26. From the View Survey toolbar toggle display ON for Symbols 

♦ If your symbols are not displaying make sure the level is turned on.

Note: Triangles should only span between known (collected) points. The above graphic 
shows a group of triangles that should be eliminated.

27. Continue to Pan along the file and deleting triangles.  Don’t be concerned that the model 
may not be perfect for this training.

When you have finished:

28. <D> the Close button in the Delete Triangle dialog.

29. From the View Survey toolbar toggle display OFF for Symbols 
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30. Redisplay the perimeter Surface > View Surface > Perimeter.  The View Perimeter 
dialog will appear.

31. <D> the Apply button in the View Perimeter dialog.

32. Review your results.

Note: This closed shape represents the edge of the surface (triangles) spatially correct 
(location and elevation). Importing this shape into the DTM will act as an exterior 
boundary to constrain the triangulation process.

33. From the InRoads pull down menu select, File > Import > Surface.  The Import Surface 
dialog will appear.
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34. Set the following dialog items:

♦ Surface: 12345SURVSurface01

♦ Load From: Single Element
♦ Elevations: Use Element Elevations
♦ Key-in Seed Name: Exterior1
♦ Feature Style: T_Exterior Boundary
♦ Point Type: Exterior

35. <D> the Apply button.  The Import Surface dialog will minimize allowing you to select 
the perimeter element.

36. <D> on the surface Perimeter graphics displayed in MicroStation View 1.

37. <D> again to accept this element.  The Import Surface dialog will reappear.

38. <D> the Close button in the Import Surface dialog.
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39. From the pull down menu select, Surface > Triangulate Surface. The 
Triangulate Surface dialog will appear.

40. <D> the Apply button in the Triangulate Surface dialog.
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41. <D> the More button on the Triangulate Surface dialog.  The Surface Properties dialog 
will appear.

42. Review your results.

Note: The surface now has Exterior point data, your numbers will not match exactly.

43. <D> the Close button in the Surface Properties dialog.

44. <D> the Close button in the Triangulate Surface dialog.
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45. Redisplay the triangles Surface > View Surface > Triangles.  The View Triangles 
dialog will appear.

46. <D> the Apply button in the View Triangles dialog.

47. Review your results.

48. In the Workspace bar Surface tab <R> on 12345SURVSurface01 select Save from the 
shortcut menu.
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Contour Files

Contour information will be saved to separate files for ease of referencing and level control.  
Each scale and contour interval will have a unique name.

49. From the pull-down menu select, File> Project Options.  The InRoads Options dialog 
will appear.

50. <D> the Factors tab.

Note: The values shown here will be applied to all commands that display text, cells, or 
linestyles.

51. Verify the Scale Factors 

♦ Text: 20
♦ Cell: 100
♦ Linestyle:  100

52. <D> the Apply then Close buttons.
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53. From the pull-down menu select, Surface > View Surface > Contours.  The 
View Contours dialog will appear.

54. Verify the active Surface: 12345SURVSurface01

55. <D> the Preferences button.

56. Select the preference Existing 10’ Mjr – 2’ Minor

57. <D> the Load then Close buttons.
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58.   <D> the Apply button.  The View Contours dialog will temporarily minimize as the 
surface is processed and the contours are generated the dialog will reappear when the 
contours have been generated.

59.   Review your results.
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Lab 8.4 - Exporting Survey Data to Geometry - FINAL

Section Objectives:

♦ Export survey data to a Geometry Project for a final deliverable.

1. Verify the 12345SURVFieldbook01 fieldbook you want to export is active.  You can tell 
which fieldbook is active by the red box around the fieldbook button.

2. From the InRoads pull down menu, select File > New.  The New dialog will appear.

3. Select the Geometry tab.

4. From the type pick list verify the Type: Geometry Project

5. Key in the geometry Name: 12345SURVGeometry01

6. Key in the Description: CDOT Geometry Final

Note: Key in any additional file information in the Description field of the dialog, such as 
Date, User, and Design file name. You have up to 34 characters even though you may 
not see all the characters in the Description field.
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7. <D> the Apply and Close buttons.

8. From the InRoads pull down menu, select Survey > Survey Data to Geometry.  The 
Survey Data to Geometry dialog will appear.

9. From the drop down list select Project Name: 12345SURVGeometry01

10. Set the Description: Use Style Description

11. Set the Curve Stroking: Horizontal Only

12. <D> the Apply then Close button.
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13. Use the Workspace pane scroll arrows to view the Geometry tab.

14. Verify 12345SURVGeometry01 is the active Geometry Project.

15. From the InRoads pull down select File > Save > Geometry Project.  The Save As 
dialog will appear with the Save as type: Geometry (*.alg).

16. Verify you are in the correct project directory. 
C:\Projects\12345\ROW_Survey\InRoads\Geometry

17. The file name should match the Active name at the bottom of the Save As dialog.  If 
necessary, use the drop-down arrow in the Active field and reselect the desired name to 
ensure the saved file name will match the surface name.

Note: Ensuring that the saved Geometry name in the project folder matches the Geometry 
name displayed in InRoads explorer will minimize any confusion.

18. <D> the Save and then the Cancel button.  The file will be saved to disk and the Save As 
dialog will close.
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Lab 8.5 - Saving an InRoads Project file RWK

Project file stores the location of multiple InRoads files.  RWK files allow the user to open just 
one RWK which could load a survey, surface, and geometry project.  The RWK can be opened 
and edited in Notepad incase there are changes in the directory structure.

Section Objectives:

♦ Create a new Project file that will autoload the survey fieldbook file and final 
deliverable.

1.  From the pull down menu, select File > Save > Project.  The Save As dialog will appear.

2. Key-in the File name: 12345Project.rwk

3. <D> the Options… button.  The Project Options dialog will appear.
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4. From the Surfaces tab check the Add and Update boxes for Surface Name 
12345SURVSurface01.

5. From the Geometry Project tab check the Add and Update boxes for Geometry Name 
12345SURVGeometry01.

6. From the Survey tab check only the Add box for Survey Name 12345SURVFieldbook01.
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Note: By only selecting the Add check box for the Survey tab the file will act as read only 
when opened and saved with the RWK file in the future.

7. <D> the OK button.  The Project Options dialog will close.

8. <D> the Save then Cancel buttons.  The Save As dialog will close.
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Lab 8.6 - Directory Clean up

1. Open Windows Explorer Windows + E

2. Navigate to the folder C:\Projects\12345\ROW_Survey\Working

3. Delete any old or duplicated files for the Working directory.

Section Summary:
♦ In Lab 8.1 -Exporting Survey Data to Graphics the survey fieldbook was exported to 

graphics including the point names, codes, etc.  The file was then stratified using the 
custom application CDOT Stratify Survey to create multiple survey files and reference 
the files appropriately.

♦ In Lab 8.2 -Exporting Survey Data to Surface the survey fieldbook was exported to the 
final surface file.  

♦ In Lab 8.3 -Exterior Boundary the surface was then cleaned up by deleting errant 
triangles and a new exterior boundary was created.

♦ In Lab 8.4 -Exporting Survey Data to Geometry - FINAL the survey fieldbook file was 
exported as a final geometry project.

♦ In Lab 8.5 -Saving an InRoads Project file RWK the final deliverable survey files were 
used to create a Project file to help the user load multiple files.

♦ In Lab 8.6 -Directory Clean up the working directory was cleaned up to make sure all 
files that were no longer needed were removed from the folder.
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