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Lab 9.1 - Locks

Section Objectives:

♦ View surface triangles using Pencil lock with different Preferences.

Locks Toolbar

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. Verify both the Feature Filter Lock    and Style Lock    are toggled OFF.  The Locks 
are toggled OFF when the button appears darker.

4. From the InRoads pull down menu select, 
Surface > View Surface > Triangles.  The View Triangles dialog will appear.

5. <D> the Apply button.  The View Triangles dialog will minimize as the triangles are 
generated.  The dialog will reappear when it is finished.

Note: The triangles displayed are not using the correct element attributes for color and 
level.  Using the Pencil mode will erase the current displayed triangles and 
redisplay the correct element attributes for existing triangles.

6. <D> the Preferences… button.  The Preferences dialog will appear.
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7. Select the Existing preference.

8. <D> the Load then Close buttons.

9. <D> the Apply button.

Note: Notice how the old triangles are “erased” and the new triangles are redrawn using 
the loaded existing preference.

Section Summary:
♦ In this lab we viewed surface triangles using Pencil lock with different Preferences.

Lab 9.2 - Advanced Locks

Section Objectives:

♦ In this lab the difference between Pencil and Pen lock will be shown.

These are only generalized steps to guide you.  Ask your instructor if you have any questions.

1. Using MicroStation Delete.  Delete all triangles from the DGN file.

2. Toggle the Write lock from Pencil    mode to Pen    mode.

3. Display the triangles using Preference Existing.
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4. Redisplay the triangles using Preference Proposed.

Note: You should end up with two sets of triangles.  Pen mode can be used for other 
display operations such as perimeter and contours.
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When you have finished:

5. Using MicroStation Delete button.  Delete all triangles from the DGN file.

6. From the MicroStation pull down menu select, 
File > Compress > Design

7. Verify your Locks toolbar is set back to Pencil    mode.

Section Summary:
♦ In this lab Pen lock was demonstrated using View Triangles command.



Colorado Department of Transportation   Page 191

Labs for Using InRoads Survey for Data Reduction LAB 9 - Additional Exercises

Lab 9.3 - Global Scale Factor

InRoads annotation (text, cells, and linestyles) is controlled with configurable scale settings. In 
the case of contour labeling, text size is driven by 2 factors.  The text size specified in the 
View Contours dialog box and the active settings (multiplier) defined through the use of a 
Global Scale Factor.

Section Objectives:

♦ In this lab the text scale factor will be changed to show how to modify text sizes when 
displaying contour labels.

♦ In this lab the Global Scale factor Add-in will be added to the Tools pull down menu 
for easier access to the scales.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. From the pull-down menu select, File > Project Options.  The InRoads Options dialog 
will appear.
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4. <D> the Factors tab.

Note: The values shown here will be applied to all commands that display text, cells, or 
line styles.
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5. Set the Text, Cell and Line Style Scale Factors to 100

6. <D> the Apply then Close buttons.

7. From the pull-down menu select, 
Surface > View Surface > Contours.  The View Contours dialog will appear.

8. Verify the active Surface: 12345SURVSurface01

9. Load the CDOT Preference
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10. <D> the Apply button.  The View Contours dialog will temporarily minimize as the 
surface is processed and the contours are generated the dialog will reappear when the 
contours have been generated.

11. Review your results.
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12. From the pull-down menu select, File > Project Options.  The InRoads Options dialog 
will appear.

13. <D> the Factors tab.

14. Set the Text, Cell and Line Style Scale Factors to 50

15. <D> the Apply then Close buttons.
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16. <D> the Apply button in the View Contours dialog.  Notice the change in the annotation 
size.

The Global Scale Factor dialog is frequently used. It can be added to the interface for easy 
access.

17. From the pull down menu select, Tools > Application Add-Ins, the 
Applications Add-ins dialog will appear.

18. Check ON Global Scale Factor Add-In.

Note: The Description section of the dialog will give details where to find the added 
command in the pull down menus.
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19. <D> the OK button.  The Application Add-ins dialog will close.

20. From the pull down menu select, Tools > Global Scale Factors...  The Global Scale 
Factors dialog will appear.

Note: The Scale Factors dialog can remain open saving space and time.

21. Key-in the Text, Cell, and Line Style Scale Factors dialog to 100

22. <D> the Apply button.

Section Summary:
♦ In this lab the text scale factor was changed to show how to modify text sizes when 

displaying contour labels.

♦ In this lab the Global Scale factor Add-in was added to the Tools pull down menu for 
easier access to the scales.
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Lab 9.4 - View Surface Display Constrained

Most surface display commands have the option to display within the limits of a fence place in 
a MicroStation model.

Section Objectives:

♦ In this lab a MicroStation fence will be placed in the file to constrain the triangles 
inside the fence.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. From the InRoads pull down menu select, Surface > Update 3-D/Plan Surface 
Display.  The Update 3-D/Plan Surface Display dialog will appear.

4. Verify 12345SURVSurface01 is the active surface.

5. Check ON Perimeter box.

6. Check ON Contours box.

7. <D> the Apply buttons.  The Contours and Perimeter graphics will be displayed to the 
design file.
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8. Using MicroStation view commands window into a portion of the surface.

9. From the MicroStation Main toolbar <D> the Place Fence button.

10. From the Tool Settings dialog select Fence Type: From View

11. <D> a point in View 1.  The Fence will appear around the edge of the view border.
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12. From the InRoads pull down menu select, Surface > Update 3-D/Plan Surface 
Display.  The Update 3-D/Plan Surface Display dialog will appear.

Note: Notice this time Fence Mode became active and the mode is set to Inside.

13. The triangles will display inside the fence.

14. Using MicroStation view commands zoom out from the triangles and review your result

15. <D> the Close button in the Update 3-D/Plan Surface Display dialog.

Section Summary:
♦ In this lab a MicroStation fence was be placed in the file to constrain the triangles 

inside the fence.
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Lab 9.5 - View Contour Settings

Section Objectives:

♦ Use different Preferences will be used to display contours.

♦ Change settings in the Advanced tab of the View Contours dialog to view contours 
smooth or between an elevation range.

♦ Change settings in the Labels tab of the View Contours dialog to view contour labels at 
different intervals and display options.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. Using MicroStation Delete button.  Delete all Contours in the drawing.

4. From the pull-down Surface > View Surface > Contours.  The View Contours dialog 
will appear.

5. Verify the active Surface: 12345SURV_Surface_Existing
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6. <D> the Preferences… button.  The Preferences dialog will appear.

7. Select the preference Existing 10’Mjr – 2’ Minor.

8. <D> the Load then Close buttons.

Note: Notice the change in the Interval and Minors per Major settings.

9. <D> the Apply button.
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10. Review your results.

11. <D> the Advanced tab in the View Contours dialog.

12. Check OFF Smooth in the View Contours dialog.

13. <D> the Apply button and review your results.

14. Check ON Elevation in the View Contours dialog.

15. Set the Elevation High and Low values that will work with the loaded surface.

16. <D> the Apply button and review your results.
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17. <D> the Labels tab in the View Contours dialog.

18. Continue to display contours using different settings in the 
Major Labels and Minor Labels sections.

♦ Precision

♦ Orientation

♦ Spacing

♦ Prefix

♦ Suffix

Note: Ask your instructor if you have a question on any of these settings.

When you have finished:

19. Reload the Preference Existing 10’Mjr – 2’ Minor.

20. Redisplay the contours.

Section Summary:
♦ In this lab different Preferences were used to display contours.

♦ In this lab changes in the Advanced tab were made to view contours smooth or 
displayed between an elevation range defined by the user.

♦ In this lab change settings in the Labels tab were made to view contour labels at 
different intervals and display options.
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Lab 9.6 -  Profiles from existing alignments

Section Objectives:

♦ Create a Profile from an existing horizontal alignment to create a profile to help 
evaluate the existing surface.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. Open an InRoads Geometry Project.

InRoads Survey only allows for multipoint profiles.  To create profiles from an existing 
alignment InRoads needs to be activated.

4. From the InRoads pull down menu select Tools > Product Add-ins.  The 
Product Add-ins dialog will appear.

5. Select the Bentley InRoads V8i application and select the OK button.  InRoads 
application will be added to the InRoads Survey interface.

6. From the InRoads pull down menu select 
Geometry > Active Geometry.  The Active Geometry dialog will appear.

7. Select the Type: Horizontal Alignment
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8. <D> the Target    button.  The Active Geometry dialog will minimize allowing you to 
select the centerline in the MicroStation view.

9. <D> the centerline of the road.  The centerline of road will highlight and the Active 
Geometry dialog will reappear.

10. <D> the Apply then Close buttons.  The Horizontal Alignment name will be active.

11. From the InRoads pull down menu select, Geometry > Fit Alignment.

12. <R> for the active alignment in the MicroStation View.

13. From the pull down menu select, Geometry > View Geometry > Active Horizontal

Note: The above graphic is where the profile will be extracted.

14. From the pull down menu select, Tools > Global Scale Factors…  The Scale Factors 
dialog will appear.
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15. Key-in the scale factor 100

16. <D> the Apply then Close buttons.

17. From the InRoads pull down menu select Evaluation > Profile > Create Profile.  The 
Create Profile dialog will appear.

18. <D> the Preferences… button.  The Preferences dialog will appear.

19. Select the preference name 5x Vertical.

20. <D> the Load then Close buttons.
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21. On the Create Profile dialog Create Profile > General leaf 
Set Name: DTM Chk Alignment

22. Verify 12345SURV_Surface_Existing is checked in the Surfaces section.

23. On the Create Profile dialog Create Profile > Source leaf.

24. Set the Radio button to Alignment

25. <D> the Apply button.  The dialog will minimize allowing you to select the location of the 
profile in the MicroStation view.

26. <D> a location in the MicroStation view to draw the profile.  The Create Profile dialog 
will reappear and the Profile is generated.
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27. Review your results.

28. Continue to generate profiles along the remainder of the centerline.

When finished:

29. Using MicroStation Delete button.  Delete all DTM Check profiles.

Section Summary:
♦ In this lab a profile was created from an existing horizontal alignment to help evaluate 

the existing surface.
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Lab 9.7 - Cross Sections

Section Objectives:

♦ Create a Cross Section set from an existing horizontal alignment to help evaluate the 
existing surface.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. Open an InRoads Geometry Project.

InRoads Survey only allows for multipoint profiles.  To create profiles from an existing 
alignment InRoads needs to be added. Skip to steps 4 and 5 if InRoads is already activated. 

4. From the InRoads pull down menu select Tools > Product Add-ins.  The 
Product Add-ins dialog will appear.

5. Select the Bentley InRoads V8i application and select the OK button.  InRoads 
application will be added to the InRoads Survey interface.

6. From the InRoads pull down menu select 
Geometry > Active Geometry.  The Active Geometry dialog will appear.

7. Select the Type: Horizontal Alignment
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8. <D> the Target    button.  The Active Geometry dialog will minimize allowing you to 
select the centerline in the MicroStation view.

9. <D> the centerline of the road.  The centerline of road will highlight and the Active 
Geometry dialog will reappear.

10. <D> the Apply then Close buttons.  The Horizontal Alignment name will be active.

11. From the InRoads pull down menu select, Geometry > Fit Alignment.

12. <R> for the active alignment in the MicroStation View.

13. From the pull down menu select, Geometry > View Geometry > Active Horizontal

Note: The above graphic is where the profile will be extracted.

14. From the pull down menu select, Tools > Global Scale Factors…  The Scale Factors 
dialog will appear.
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15. Key-in the scale factor 50

16. <D> the Apply then Close buttons.

17. On the Create Cross Section dialog Create Cross Section > General leaf 
Set Name: DTM Chk Alignment

18. Verify 12345SURV_Surface_Existing is checked in the Surfaces section.

19. On the Create Cross Section dialog Create Cross Section > Source leaf.
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20. Set the Radio button to Alignment.

21. <D> the Apply button.  The dialog will minimize allowing you to select the location of the 
profile in the MicroStation view.

22. <D> a location in the MicroStation view to draw the profile.  The Create Cross Section 
dialog will reappear and the cross sections will be generated.

23. Review your results.

Section Summary:
♦ In this lab a cross section set was created from an existing horizontal alignment to help 

evaluate the existing surface.
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Lab 9.8 - Survey

Survey Feature Filters

The geometry project 12345SURVGeometry01 contains horizontal and vertical alignments for 
every linear item that was surveyed. Additionally the Cogo buffer contains points for every 
survey shot collected.  While this may be desirable information, often it is desirable to work 
with a subset of the survey information such as pavement center lines, control lines, or other 
specific entities. Working with a subset of the information increases efficiency by working with 
a smaller data set and freeing-up additional computer memory for other operations. This can be 
accomplished by using Survey Feature Filters when exporting survey data (Fieldbook) to a 
geometry project.

Section Objectives:

♦ The goal is to have a geometry project that contains only the information important to 
establishing the centerline of the existing road.

♦ The use of survey style filters will assist in sorting the data.

1. Open a new working MicroStation design file.

2. Open an InRoads Survey Fieldbook.

3. From the pull down menu select Survey > Survey Style Filter.  The 
Survey Style Filter dialog will appear.
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4. Toggle the radio button Start With: None

5. Select Properties: Numeric Code

6. Key-in the Value: 1316

7. Toggle the radio button Mode: Include

8. <D> the Add Rule button.  The rule will be added to the Rules List.

9. Add additional numeric rules for:

♦ 1318
♦ 1319
♦ 1320
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10. Select Properties: Alpha Code

11. Key-in the Value: 10*

12. Toggle the radio button Mode: Include

13. <D> the Add Rule button.  The rule will be added to the Rules List.

14. <D> the Save As button.  The Save Filter As dialog will appear.

15. Key-in the Name: Survey Keypoints

16. <D> the OK button in the Save Filter As dialog.



Colorado Department of Transportation   Page 217

Labs for Using InRoads Survey for Data Reduction LAB 9 - Additional Exercises

17. <D> the OK button.  The Survey Feature Filter dialog will close.

Note: The Survey Feature Filter just built is for filtering information contained in a 
Survey Fieldbook and gets saved in the Survey Feature Table (fwf) file vs. in the 
InRoads Civil.ini file as Feature Filters do. Therefore, it gets applied within the 
Fieldbook and not in the InRoads Feature Filter interface. However the Filter Lock 
needs to be turned on in the InRoads Locks toolbar for it to be active.

18. On the Locks toolbar, toggle ON the Feature Filter Lock
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Note: Notice that 2 things happen, the Fieldbook Data dialog will update to display only 
the data that passes the filter. Also the MicroStation display will only display 
survey data that passes the filter.

Section Summary:
♦ In this lab a survey style filter was created to only export data from the fieldbook to a 

Geometry Project that pertained to reestablishing the mainline.



Colorado Department of Transportation   Page 219

Labs for Using InRoads Survey for Data Reduction LAB 9 - Additional Exercises

Lab 9.9 - Importing multiple files

To speed up the process of importing multiple files you can create a Group file. This.is a simple 
text file that points to the file location and import wizard to use.    When it is available these are 
the steps for using Group Files on import.

Section Objectives:

♦ Import multiple Sokkia SDR files as one into InRoads Survey using a Group of files 
ASCII file.

1. From the pull-down menu, select File > Import > Survey Data.  The Import dialog will 
open.

2. Change the drop-down arrow Files of type: Group of Files (*.*)

3. Path to the folder C:\Projects\12345\ROW_Survey\Survey\Raw_Data

4. Select the file LoadSDR_files.txt from the unfiltered list of files.

♦ The Group of files option is a handy way to load multiple files at one time.  The file is 
a simple ASCII text file that shows the file location and import type.  Below is a screen 
shot of the file opened in Notepad.  This file would need to be created prior to using it 
on a different project.

5. In the Import dialog <D> the Import button.

6. <D> the Close button.  All the files listed in the text file will be imported.

Section Summary:
♦ In this lab a Group of SDR files were imported at one time using an existing ASCII.
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Lab 9.10 - Metric Survey Data to Imperial Survey Data

Section Objectives:

♦ To convert an existing InRoads Survey fieldbook file units from Metric to US Feet.

1. Open a new working MicroStation model file.

2. Once MicroStation and InRoads Survey opens. From the InRoads pull-down menu, select 
File > New.  The New dialog will appear.

3. Select the Survey Data tab.

4. Key in the Name: 12345SURVFieldbook01

5. Select the Apply button. The new fieldbook will appear below.

6. <D> the Close button.

7. From the Workspace bar the 12345SURVFieldbook01 should be active.

8. From the pull-down menu, select File > Import > Survey Data. The Import dialog will 
open.

9. Path to the Look in: C:\Projects\12345\ROW_Survey\Survey\Raw_Data
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10. Verify the Files of type: Sokkia SDR (*.sdr)

11. <D> the Options button.
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12. Select the Units tab.

13. Change the Linear Format Units: Meters

14. <D> the OK button.  The Survey Options dialog will close.

15. In the Import dialog select the data collector file you will be importing.

16. <D> the Import then Close buttons.

17. From the pull-down menu, select Survey > Fieldbook Data.  Take a minute to review 
the imported Survey control data that is now contained in the electronic Fieldbook.
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18. From the pull-down menu, select Tools > Survey Options the Survey Options dialog 
will appear.

19. Select the Units tab.

20. Change the Linear Format Units: US Feet

21. <D> the OK button.  The Survey Options dialog will close.

22. From the pull-down menu, select Survey > Fieldbook Data.  Take a minute to review 
the transformed Survey data that is now contained in the electronic Fieldbook.

Note: The file has now been converted to US Feet Units.

23. From the pull-down menu, select File > Save > Survey Data the Save As dialog will 
appear.

24. <D> the Save and Cancel buttons.  The Save As dialog will close.

Section Summary:
♦ In this lab an existing Metric fieldbook file was converted to US Feet units.
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Lab 9.11 - Exporting Survey Data to Sokkia SDR file

Exporting the fieldbook out to a SDR format would be required if you wanted to use the points 
and stake them out in the field.

Section Objectives:

♦ Create a Sokkia SDR file format file from the InRoads Survey fieldbook.

1. Verify the 12345SURV_Fieldbook fieldbook you want to export is active.  You can tell 
which fieldbook is active by the red box around the fieldbook button.

2. From the pull-down menu, select File > Export > Survey Data.  The Export dialog will 
appear.

3. Change the directory to: 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books

4. Select the down arrow for Export as type: review the available file formats available.

5. Select from the list Export as type: Sokkia SDR33 (*.sdr)

6. Key-in the new file name 12345SURV_Fieldbook.sdr

7. <D> the Export button.  The Export dialog will close.

8. Open Windows Explorer Windows + E

9. Open and review the file in Notepad.
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\ 12345SURV_Fieldbook.sdr

Note: This file is ready to be uploaded into the data collector.  If you need to import this file 
back into InRoads Survey for any reason you will need to add survey header 
information into file.



Colorado Department of Transportation   Page 225

Labs for Using InRoads Survey for Data Reduction LAB 9 - Additional Exercises

Section Summary:
♦ In this lab a Sokkia SDR file was created using the Export as type tool.
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Lab 9.12 - Exporting Survey Data using Text Export Wizard

Exporting the fieldbook out to another format would be required if you wanted to use the points 
and stake them out in the field.

Section Objectives:

♦ Create a customized exported ASCII file from the InRoads Survey Fieldbook using 
Text Export Wizard.

1. Verify the 12345SURV_Fieldbook fieldbook you want to export is active.  You can tell 
which fieldbook is active by the red box around the fieldbook button.

2. From the pull-down menu, select File > Export > Survey Data.  The Export dialog will 
appear.

3. Change the directory to: 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books

4. Select the down arrow for Export as type: review the available file formats available.

5. Select from the list Export as type: Text File (*.*)

6. Key-in the new file name 12345SURV_Fieldbook.txt
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7. <D> the Export button.  The Export dialog will close and the 
Text Export Wizard dialog will appear.

8. <D> the radio button Comma

9. Key-in Number of Columns: 7

10. Key-in File Header: CDOT Survey Training “Initials” “Date”

11. Key-in File Tail: Exported Fieldbook 12345SURV_Fieldbook.fwd



Page 228 Colorado Department of Transportation

LAB 9 - Additional Exercises Labs for Using InRoads Survey for Data Reduction

12. <D> the Next > button.  The final Step 2 of 2 dialog will appear.

13. <D> the header of the first column.  The column will highlight as shown below.

14. From the Data Type radio button select String: Export

15. In the Justification section of the dialog set the radio button to Left

16. <D> the second column header then select Point Name from the Data Type radio 
button.

♦ Justification: Left

17. Select the third column header then select Northing from the Data Type radio button.

♦ Justification: Left
♦ Precision: 2
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18. Select the fourth column header then select Easting from the 
Data Type radio button.

♦ Justification: Left
♦ Precision: 2

19. Select the fifth column header then select Elevation from the 
Data Type radio button.

♦ Justification: Left
♦ Precision: 4

20. Select the sixth column header then select Code from the 
Data Type radio button.

♦ Justification: Left

21. Select the seventh column header then select Description from the
 Data Type radio button.

♦ Justification: Left
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22. <D> the Save As button.  The Save As dialog will appear.

23. Key in File name: ASCII Export.tew

24. <D> the Save button.  The Save As dialog will close.

25. The Save Format to File Types dialog will appear.  Verify Format Name: ASCII Export

26. <D> the Yes button.  The Save Format to File Types dialog will close and the Step 2 of 2 
dialog will reappear.

27. In the Step 2 of 2 dialog <D> the Cancel button.  The Step 2 of 2 dialog will close.
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28. From the pull down menu select, File > Export > Survey Data

29. In the Export dialog change the Export as type: ASCII Export (*.txt)

30. Path to the directory: C:\Projects\12345\ROW_Survey\InRoads\Field_Books

31. File name 12345SURV_Fieldbook.txt

32. <D> the Export button.  The Export dialog will close.

33. Open Windows Explorer Windows + E

34.  Open and review the file created in Notepad.
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\12345SURV_Fieldbook.txt
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Section Summary:
♦ In this lab the Text Export Wizard was used to create a customized ASCII file from an 

open InRoads Survey Fieldbook.

Lab 9.13 - Exporting DC File from TGO

The workflows for exporting a DC file that will include the notes and attributes can be found on 
the CDOT CADD Library web page.
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Lab 9.14 - Merging InRoads Survey Fieldbook files

When a project is using more then one fieldbook for a particular job it is possible to merge 
those fieldbook files together.

Items to address prior to merging fieldbooks:

♦ There can not be duplicate point names between the fieldbooks.

♦ If you are using figure strings make sure they are not going to conflict with the figure 
strings in the other fieldbook.

Section Objectives:

♦ Merge two existing InRoads Survey Fieldbook files into one InRoads Survey 
Fieldbook file using the Import FWD tool.

1. Open a new working MicroStation model file.

2. Open an InRoads Survey Fieldbook.

3. From the InRoads pull down menu select File > Import > Survey Data The Import 
dialog will appear.

4. Select the Files of type: Field book (*.fwd)
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5. Select the fieldbook name you want to import.

6. <D> the Import then Close buttons.  The fieldbook files are now merged.

Section Summary:
♦ In this lab we merged two InRoad Survey Fieldbook files into one fieldbook file.
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