Labs for ROW Geometry

LAB 15 - Parcel Descriptions

LAB 15 - Parcel Descriptions

The InRoads Report Browser allows the user to view reports using a reporting utility based on the eXtensible
Markup Language or more commonly referred to as XML. Like the HTML language used for web
development, XML reporting is based on tags and attributes which delineate elements of data. Formatting of
XML data is accomplished through the use of XSL, or style sheets and displays in a web browser page.

Chapter Objectives:

e Create a parcel legal description

1. Select the Tools > XML Reports menu item to check the available menu items.
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Er)
377 MNamed Symbology Manager.
EYr Preference Manager
377 Style Manager...
337 Copy Preferences..

3¢ Highlight All Pencil

Opens XML Reports in your browser

£ Highlight All Ik
i+l Convert Penci to Ink

2. Select Legal Description

L3 La Geometry...

Q Station Base...

i) Station Offset

) Clearance. .

@ Stakeout...

Eﬁ Legal Description...

ﬁ Map Check

Iia Intersecting Alignment Stations...
& Poirt Validation. ..

Q Surfaces...

g Surface Check..

3. <D> the Filter button and add Summit BP Lot 1Acquire as a selected alignment.

E Geometry Selection Filter

4 UL

Name: Included -
Description: Included - -
Style: Included - -
Awailable:

Mame Description 5=
Summit BP Lot 4 Lot 4 of Summit Bu.. Ry
Summit BP Lot 1Rem Parcel Remainder RV
Summit BP Lot 2Acquire  Parcel Acquistion RV
Summit BP Lot 2Rem Parcel Remainder RV
Summit BP Lot 3Acquire  Parcel Acquistion Rl =
Summit BP Lot 3Rem Parcel Remainder RV
Summit BP Lot 4Acquire  Parcel Acquistion RV
Summit BP Lot 4Rem Parcel Remainder RV ™

i

Cancel
Preferences..
Help
Selected:
Name Description Sty
Summit BP Lot 1Acquire Parcel Acquistion RV

4. <D> OK
5. <D> Apply
6.
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An XML file and a report is created with format and display from an InRoads default style

sheet.

File Tools Help

2] Bentley Civil Report Browser - C:\Users\brysr\AppData\Local\Temp\RPTB514 xml

|C:\Work5pac:e\Workspace-C DOT_Vaih\Standards

Bridge -

Cant

CDOT

Clearance

Cross Slope Optimization

Custom

DataCollection

Evaluation

Geometry

ICs

Images

Intersecting Alignment Stations
LegalDescription

: @ Horizontal Alignment Legal Description x|

:] Horizontal Alignment Legal DescriptionRe

m

Property Description

Report Created: 3/29/2011
Time: 1:49pm

Project: 12345_SummitBP

Description: Lab 18
File Name: C:\Projects\12345
© \ROW_Survey\InRoads\Geometry\12345ROW_SummitBP _alg
Last
129/ -06-.
Revised: brysr 3/29/2011 1:06:47 PM
Input Grid 1.00000000 Note: Allunits in this report are in feet unless speciﬁed 2
Factor: otherwise.

Horizontal Alignment Legal Description Re
ParcelLayout From Reference xsl

;
PropertyDescription Extended xs|
Property Description Extended2 xsl
PropertyDescriptionLongMNames xsl
@ Right OfWay Takes xsl

Light Rail Manufacturing

MapCheck

Milling

Obsolete

Roadwavesion
I 2

Alignment Name: Summit BP Lot 1Acquire
Alignment Description: Parcel Acquisition

Beginning at a point thence M 0°34'22.3" W a distance of 20.04 feet thence S
74°45'58 4" E a distance of 296.65 feet thence S 0°3631.8" E a distance of
99.99 feet thence M 37°3526.5" W a distance of 127.29 feet thence N 74°
46°06.7" W a distance of 217.06 feet and the POINT OF BEGINNING.

The above described parcel contains + 0.20 acres (8779.96 sq. ft.)

7. <D> on the various report styles (*.xsl) displayed in the left panel and notice the change to
the format and contents of the displayed report.
8. Inthe Report display, select Tools > Format Options
Format Options (5]
Mode Precision Format
Northing/Essting: iz =] C';m]
e —IHeb
Elevation: Iﬂ
Angular: Degrees ~| [o =| [ddd"mmsss" | [ Include Angular Suffc
Slope: o123 ~| [s0% |
Use Altemate Slope if Slope Exceeds: 0.000%
Attemate Slope: [o =] J201 -
Linear: m
Station: jo12 | fssessss |
Acres/Hectares: 012~
Area Units: 0.1 ]
Cubic Units: 0.1 ~| ™ Convertto Cubic Yards
Direction: [Bearings L] |D j [ddd"mm’ss.s"lj
Face: Right Face b
Vertical Observation: |7angh -

9. <D> Acres/Hectares: Set to 5 decimal places - the report updates.

The above described parcel contains 4 2.69878 acres|(117559.0 sq. ft.)
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10. Change any of the fields in the Format Options dialog and notice the report interactively
updates.

11. <D> on the CDOT folder and select the various formats.

2] Bentley Civil Report Browser - C:\Users\brysr\AppData\Local\Temp\RPT22E5 xml [=][=][==]
File Tools Help
|C:\Workspac:e\Workspace-CDOT_\u’Ei\Standards -

™ EXHIBIT "A"

ridge -

Cart

C?)OT PROJECT NUMBER: 12345_SummitBP

&}] CDOT Adine Description xs| PARCEL NUMBER: Summit BP Lot 1Acquire

-&]] CDOT Air Rights Easement Descriptior PROJECT CODE: Lab 18

i) CDOT Fee Parcel Description xs! DATE: March 29 2011

g CDOT Pemmanent Easement Descriptic DESCR|PT|C,)N

m

Aj CDOT Slope Easement Description xs| =
Aj CDOT Temporary Easement Descriptio
A CDOT Utility Easement Description xs|
Aj CDOT_ListCoordinates xs|

A CDOT_Monumentation_Clearance xs|
E CDOT_Monumentation_ListCoordinate
Clearance

Cross Slope Optimization

Custom

DataCollection

Evaluation

Geometry

ICs

Images 1. Thence M. 00°34°22 3" W _, a distance of 20.04 feet;
Intersecting Alignment Stations
LegalDescription

Light RailManufacturing 2. Thence S. 74°45'68 4" E_, a distance of 296.65 feet;
MapCheck -
" [T G -

A tract or parcel of land No. Summit BP Lot 1Acquire of the
Department of Transportation, State of Colorado Project No.
12345_SummitBP containing 8,780 sq. ft. (0.202 acres), more or
less. in Section XX, Township X X, Range X X, of the X Principal
Meridian, in X County, Colorado, said tract or parcel being more
particularly described as follows:

Commencing at a point, whence JXXXX, said point also being the
TRUE POINT OF BEGINNING;

12. In the Report display, select File > Save As...

Save As:
Path: C:\Projects\12345\ROW_Survey\InRoads\Reports
File Name: SBP Lot 1Acquistion.xml

13. <D> Save

9| Save As [z |
Savein: | . Reports j EF '
= Name Date modif.. Type Size
e
ey = SBP Lot 1Acquistion.xml
Recent Places =
=] SBP Lots 1-4.xml
Desktop
i
I i
Ron Brys
A
Computer
[ ™8
)
Network
File name: |SBP Lot 1Acquistion xaml j Save
Save as type: |XML File: (i) j Cancel
Help
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Reports can also be recalled for reformatting, etc.

14.
15.
16.

17.
18.

Select Tools > View XML Reports

From the report browser File > Open

Open the SBP Lots 1-4.xml file from the folder:
C:\Projects\12345\ROW_Survey\InRoads\Reports\

Select the folder and style sheet to apply to the XML data.

<D> on the category Geometry and style sheet Area.xsl

0 Bentley InRoads Report Browser - C:\Projects\12345\ROW_Survey\InRoads\Reports\SBP Lots 14 xm! =1 cn === |

File Tools Help
[\ Workspace\Wodspace COOT_XM\Standards Global\InRaads \XM| 7
2 Geomety z Area Report

Aj] Aol

Af) CortroiLine Data xsl Report Created: 9/14/2009

Ai] HorizortalAlgrmentAndEvents xsl Time: 4:17pm

A]) HorzortalAlgrmentCurve SetReview xsl

Aj] HonzortalAlgrment Data xsl Project: 12345_SummitBP.alg

::g st bty i Description: Lab 18

Aj] HorizortalAlkgnment ReviewASCll xsl File Name: C:\Projects\12345

A} AignmentS. R ol * \ROW_SurveynRoads\G 12345 S BP 2lg

o e 2o £ Last o v 51772007 5:48:24 PM

:ﬂ xm:&mﬂm’:s Revised: ™

zortalBlementsXYZ.
Input Grid Mote: Allunis in this report are in feet unless

Aj) HorizontalEvents xd 1.000000

&.n Hor t od - Factor: specified otherwise. g

Aj) LstCoordinates xsl

Al] LsCoordnates Staton sl Area  Perimeter

) PrfeSatonBevaton b e M NN

:__g Prufieamnﬂe:‘lmllu Summit

Pucocthl P Lot 1624 4 4

&ﬂl m“’”“"umwds“ Ei Lo 2162425 9642: 2028.98

Aj) SetingOutTable xsl

Aj] SewDagram xsl Summit

A} SewDiagramLegacyFomat xal BP Lot 1176327 270047  1391.22

.&1] Traverse xs! 1

A]] TraverseCurveASCI xs! Summit

Af) TraverseCurve ASCI2 sl BP Lot 103354.3 237269 1349.76

Aj) TraverseCurve ASCII3xsl 2

! P

gj :w»’mmmlﬂ Eecenonoryl BPlot 106135 24438 160396

Aj] Vertical SigrmentAndEverts xsl 5 - .

Af] Vertical Abgrment Review xsl - bl

Note: Lot areas and perimeter distances are reported.

Page 120

Colorado Department of Transportation



Labs for ROW Geometry

LAB 15 - Parcel Descriptions

19. In the category CDOT, access style sheet List Coordinates

File Tools Help

2] Bentley Civil Report Browser - C:\Projects\12345\ROW_Survey\InRoads'\Reports\SBP Lots 1-4.xml

|C:\Wod{space\WoHﬂspaeeCDOT?VEi\StandardsGlcbal\

Bridge ~
Canit
CDoT
-] CDOT Adine Description xs!
@ CDOT Air Rights Easement Description xs!
--Aj] CDOT Fee Parcel Description xs|
@ CDOT Pemanent Easement Description xsl
@ CDOT Slope Easement Description xs|
.g CDOT Temporary Easement Description xsl
DOT Lty Essement Description s =

&3 Cl
-] CDOT_ListCoordinates xs|
™

@ CDOT_Monumentation_ListCoordinates xs
Clearance

Cross Slope Optimization
Custom

DataCallection

Evaluation

Geometry

ICs

Images

Intersecting Alignment Stations
LegalDescription

Light Rail Manufacturing
MapCheclk

Milling

Obsolete

RoadwayDesign
Crhamae

)
LA
—

m

List Coordinates Report

Report Created: 3/29/2011
Time: 2:02pm

Project: 12345_SummitBP.alg
Description: Lab 18
C:\Projects\12345

File Name: o5y 5 uveyiinRoads\Geometry\12345_SummitBF alg
Revi;ff‘ jerry 5/17/2007 5:48:24 PM

Alignment Name: Summit BP Lot 4

ﬁim’g NORTH (ft) EAST {f) ELEV ()  DESCRIPTION
1666287 884 3278721916 0.000
1555768.378 3278999 069 0.000
1866765210 3278950294 0.000

The report is redisplayed to display alignment coordinates.

20. While viewing the xml report, <R> in the area of the screen listing the coordinates. A fly-

out menu appears.
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21. <D> on Export to Microsoft Excel

@] Bentley InRoads Report Browser - C:\Users\PCALLA~1\AppData\Local\Temp\RPTEEDA.xml =R o>
File Tools Help
|'C."“ kspace \Workspace CDOT_XM\ jards-Global\inRoads \XMI -
= Gooty z dack lates Report
—Aj] Areaxsl Forward
Aj] ControlLineData xsl d: 9/14/2009
A7 Hodzortalh AndEvents xel Save Background As... -06pm
\~AJ] Horizontal MignmentCurve Set Review xsl Set as Background
g :wzm::w'“f::fﬁ Copy Background
7] Horizontal Aignment 5
(4] Horzontal AignmentReview xsl Select All
\~Ad] Horzortal MignmentFeviewASCl|xsl T Naterial\Part2\12345
4] HorizontalAlignment SuperelevationReview sl e ads\Geometry\12345ROW_SummitBP al
—Aj] Horizontal AndVertical Aignment Review xs! =
&Y HorzortalBements Table xs E Creste Shortcut 8:05:16 PM
A HorizontalBementsXYZxsl Add to Favorites... e s N VAR
&) HorzortalEvents xsl View Source v *m"‘;p:cr;e': :m'r'&;
+—~Aj] Horizontalinterpolated Slews xsl
E ListCoordinates xs! 7 Encoding »
i ListCoordinates Station xs!
A ProfileStationElevation xsl Print..
\~AJ] ProfileStation ElevationASCI|xsl = Print Preview... i Elevati Styl
5] ProjectAignmentListing s o ling evation tyle
K] Project AignmentListing Detais ! — RW_Property-
% z:";’gﬁmﬂ;“’ Append to Existing PDF o-04 000 Bngry-Line_ex
—AJ SlewDiagramLegacyFomat xs| Convert to Adobe PDF 4413 0.00 RW_Property-
%‘j :mvelsexsl o Customize Menu ' " Bndry-Line_ex
é‘] T: CurveASCIIZ xsl Export to Microsoft Excel 598 0.00 RW_Property-
| : O Brdry-Li
] TraverseCurveASCII3xsl Fill Forms nary-Line_ex
Vet oot sk
A ical Align
4] Vetical Aignment AndEvents xo Sl 42.03 0.00 RW_Property- hs
[ Ad] Vertical Alignment Review xsl — “ ) »
= | Properties
v
Excel will launch Excel.
‘ (o Hw9-em- s Bookl - Microsoft Excel = = X ‘
= |Home|| Insert | PageLi Furmu| Data | Rev'[evl\fi'ew | Add-]’.rj Prujecl| Acruhi|@ - 2 X
[ '-“3 % Calibri -1 - o, A Ej X - A7~ |
— @B L O-A N E % §l- 8-
—L L | ”5?-—'—' Number|| Styles | Cells 2
= Alignment | Editing |
| T4 - £ |
L a | B | e | b | E _ G g
1 \POINT NORTH (ft) EAST(ft)  ELEV (ft) DESCRIPTION
2 |NAME
3 1556287.884 3278721.916 o
4| 1555768.378 3278999.069 o
3 | 1555755.21 3278950.294 o
6 1555527.02 3279064.231 o
7 1555724.135  3278910.46 o
8 1556017.237 3278374.795 o
9 | 1556383.434 3278371.051 o
10| 1556287.884 3278721.916 o
i 4 » ¥| Sheetl Sheet? ~Sheet3 . vJ A I m 1]

Ready |

L
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To view the source information the xml report was generated from:

22. In the Report browser, select Raw-xml.xsl in the left panel

File Tools Help

2] Bentley Civil Report Browser - C:\Projects\12345\ROW_Survey\InRoads\Reports\SBP Lots 1-4.xml

|C:"-.‘.‘Vorkspace".‘Noﬁﬂ:space-CDOT)"Ei"-Standards-GIobaI'-.

MapCheclk ~
Miling
Obsolete
RoadwayDesign
Schemas
Stakeout
StationCifset
Superelevation
Surfaces
Survey

Tabling
TemplateLibrany
Tumouts

XIN

_Themes

i] cdotformat xsl

;] format xs|

z] raw-xml sl

Z] ShowAl xsl -

m

m s

<?xml version="1.0" encoding="iso-8859-1" ?>
- <InRoads cutputGridScaleFactor="1.000000" inputGridScaleFactor="1.000000"
linearUnits="Imperial" angularUnits="Degrees" gauge="4.708333"
equilibriumConstant="4.650000">
- <GeometryProject name="12345_SummitBP.alg" description="Lab 18"
file="C:\Projects\12345
\ROW_Survey\InRoads\Geometry\12345 SummitBP.alg"
lastRevisedDate="5/17/2007 5:48:24 PM' |astRevisedBy="jerry" >
- «Horizontalalignment name="Summit BP Lot 4"
style="RW_OWN_Prop-Line_exist" description="Lot 4 of Summit
Business Park" curvatureDefinition="arc"
lastRevisedDate="3/5/2006 9:46:45 PM" |astRevisedBy="Brys"
arez="216242.452854" perimeter="2028.981803"
fromFeature="false">
- <HorizontalElements >
- «HorizontalLine style="RW_OWN_Prop-Line_exist"
length="588.812589" direction="2.651510103">
- «Start style="RW_OWN_Prop-Line_exist"
northing="1556287.883900" <

What you see are the xml tags and attributes which define the report contents. Formatting
of this data for display is accomplished through the use of xsl, or style sheets. Style sheets
can be developed by the user for customized reports or formats.

Other formats:

In the category DataCollection access style sheet
ListCoordinatesSDR32InternationalFoot

2] Bentley InRoads Report Browser - C\Users\PCALLA~1\AppData'\Local\Temp\RPT2266.xml = | 5]
File Tools Help
|C:"-.Workspac:e"-.‘.‘\i'orkspace-cDOT_XM"-.Standar\:ls-GIobaI"- -
OONMSDR33 V04-04.xx 122211
----- E HorizontalElements SDR33Metric xs| - OENM1.00000000000000
""" 4] HorizontalElementsSDR33USSurveyFoot s 13NM3/14/2009 Point Listing for SDR33
""" 4] HorizontalOff Aligrment Points sl 13NMProject Name: 12345 SummitSP
----- E HorizontalOnAlignment Points xs| 13T514-SEP-2009 -
""" Al ListCoordinatesGeodimeterFomat s 08KI 1556037.855344003279640. 03934400
""" Al ListCoordinatesLeical6xsl = 08KI 1555652.959017003279644.12952200
""" 4] ListCoordinatesLeica s 08KI 1555651.929544003279545. 98172800
""" Al ListCoordinatesSDR33IntemationaiFoot xS 08KI 1555851.890535003279542, 03178200
""" 4] ListCoordinatesSDR33Metric s 08KI 1555661.116530003279481, 98780800
""" Al ListCoordinatesSDR33USSurveyFoot s 08KI 1555698.887083003279357.98247600
""" Al) SDMSFomat xsl 08KI 1556115.806242003279353. 81380500
""" Af) SmpleListCoordinates xsl 08KI 1556037.860302003279640. 03563800
----- E StakeoutSDR20xsl
----- E StakeoutSDR33xsl
----- E StakeoutSMI sl
----- E StationEquationsLeica 16 xsl
----- E StationEquationsLeicad xs|
----- Aj| TDSCR5Fomat xs| 2 e
] Tl 3 4 Tl b

Experiment with other style sheets such as HorizontalElementsSDR33 as well as other style

sheets in the Geometry category.
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