LAB 24 - Land Survey Control Diagram Plan

Sheet

Chapter Objectives:

e Import XML data into a MicroStation file

In this sheet, coordinate information will be input in a tabular format.

1. Select File > Open (if MicroStation is currently open).

Look in:

<

Recent Places

Desktop
:!-—.
]
CDOT_User
Computer
| WY
-
Network

Drawings

Mame
F412345ROW_Cty-24x18_22.dgn
P4 12345ROW_Cty-24:36_2%.dgn
F212345ROW_Mon##.dgn
F5412345ROW_Ownership=2.dgn
F512345ROW_Plan#£.dgn
F412345ROW_TabProp0l.dgn
F412345ROW_TabProp02.dgn
_P_']:JESROW_TahPmpGB.:Ign
F412345ROW_TabProp04.dgn
F212345R0W_TabPrope=.dgn
F2312345ROW._TitleSht.dgn
F4123455URV_MonRerd==.dgn

ML MicroStation Manager - C:\Projects\12345\ROW_Survey\Drawings\
- @7

Date modified

1/18/2008 815 ...
1/18/2008 815 ...
1/18/2008 815 ...
1/18/2008 815 ...
1/18/2008 8:15 ...
1/18/2008 815 ...
1/18/2008 815 ...
1/18/2008 815 ...
1/18/2008 815 ...
1/18/2008 8:15 ...
9/25/2009 817 ...
1/18/2008 8:15 ...

esv

Type

MicroStation D...
MicroStation D...
MicroStation D...
MicroStation D...
MicroStation D...
MicroStation D..,
MicroStation D...
MicroStation D...
MicroStation D...
MicroStation D..
MicroStation D...
MicroStation D...

NE® 3D-VBDGN

Size  *

ﬁ_
f

{F3123455URV PlanLSCD#=.dgn

1/18/.

MicroStation D..,

MicroStation D...
Micro5Station D...
Micro5Station D...

o —

[ Cancel | Project: (12345 -

F2123455URV_PlanPCD##.dgn 1/18/2008 845 .
E,’]‘lﬂ‘iSSUR‘-’_Ti{IElSCDﬂ.:Ign 1/18/2008 8:15 ...
E:’]IIHJESURV_Titl!PCDﬁ,dgn 1/18/2008 8:15 ...
‘ .
Fie name: 123455URV_PlanLSCO##E dgn
Fies of type: |41 Files )
|| Open as read-only

Interface: |CDOT -

2. <D> the filename 12345SURV_PlanLSCD##.dgn

3. Select File > Save As from the MicroStation Manger dialog.

4. Key-in 12345S5URV_PlanLSCD3B.dgn
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5. <D> Save

M Save As - C:\Projects\12345\ROW_Survey\Drawings\
Savein: |, Drawings - O ? ® [ [#]
B MName : Date modified Type »
e I Reference.Files F5{12345SURV_PlanLSCD## dgn
Recent Places || Tabs F234123455URV_PIanPCD#%.dgn
F12345ROW_Cnty-24x18_#=.dgn T24123455URV_TitleLSCD2#.dgn
- 312345ROW_Cnty-24:36_#2.dgn 412345SURV_TitlePCD#2.dgn

Desktop __-1‘12345ROW_M0n==.d.gr.|
F2412345ROW_Ownership##.dgn

;‘* F212345ROW_Plan=%.dgn
I £23412345ROW_TabProp01.dgn
CDOT_User  FEH12345ROW _TabProp02.dgn
. F2412345ROW_TabProp03.dgn
Ay F23412345ROW_TabProp04.dgn
F112345ROW_TabProp##.dgn

Computer B 1 9345ROW_TitleSht dgn
i FZ3123455URV_MonRerd#2.dgn
e

MNetwork

File name: I 123455URV_PlanLSCD3B dgn - I

Save
Save astype: IMuDStation VE DGN Files (".dgn) v] Cancel

6. Zoom/Window into the upper-right corner of the sheet.

7. Edit the text as shown using Edit Text command.

Land Survey ControlDiagram
Plan Sheet
Project Number: STA 086A-039
Project Location: SH 86 CORRIDOR PE
Project Location: COUNTY RD. 25 & 27 & 33

Project Code:{Last Mod. Date Subset Sheets Sheet No.
12345 -09 3 of XXX 3B

8. Use the MicroStation Fit command to view the entire sheet.

B Viewl, COOT Default

Z-aw- s rEe o

In this sheet, place coordinate information representing a Project Coordinate Summary Table.
This coordinate information will be extracted from InRoads using the reporting utility XML.

B %G
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Using XML to report on Coordinates

Use InRoads and XML reporting to insert a Project Coordinate Summary Table. Report on
points 100-120.

M Bentley InRoads XM Edition |=5ECE|
<Unnamed> rEsE 8Ny EX %A
Fle Suface Geometry Drainage Survey Evaluation Modeler Drgfting Tools Help
BE&EE <Unamed K IRER A B O S S
Name Description Style Ne =
=& Geometry Projects A1 00 Section Comner T_Section Cor... 1558 —
= Default w102 Quarter Section Corner T_Quarter Sect... 1558
e 12345_ROW 103 Quarter Section Corner T_Quarter Sect... 1555
‘x: 104 Quarter Section Corner T_Quarter Sect... 1555
f&:’. 105 Section Comer T_Section Cor... 1558
,. 3878 1 106 Quarter Section Corner T_Quarter Sect... 1558
'..’.: 1095_2 ‘.?:10? Quarter Section Corner T_Quarter Sect... 1555
— = = w108 Quarter Section Corner T_Quarter Sect... 1555 ~
E ] Surfaces | 2 Geometry || 4 | » ‘ T L
Extracts cross sections along an alignment or a linear graphics entity

9. If not already running and loaded:

o Launch InRoads & Load the Geometry Project 12345 _ROW.alg from
C:\Projects\12345\ROW_Survey\InRoads\Geometry

10. Select Tools > XML Reports > Geometry from the InRoads interface.

11. In the XML Reports dialog, <D> the Geometry folder and identify Cogo points Z00-120

Bt Geometry Report = | B |
Horizontal Alignments Cogo Paints
Include: ﬂ Include: I1Dc|_-|2;] Iﬂ
Selected: Selected:

Name Description  Style Name Style - Filter

100 T_Section Comer
102 T_Quarter Section Co... |_
103 T_Quarter Section Co... |
104 T_Quarter Section Co...
105 T_Section Comer
106 T_Quarter Section Co..
107 T_Quarter Section Co... ~

[ Include Vertical Alignments [ Interval: [50.00 J

@ Al Active Limits
[Include Cant Alignments [] Station
[ Include Horizontal Event Points J

12. <D> Apply. The report browser will open to a default report style.

13. <D> the CDOT Folder.
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14. <D> the CDOT_ListCoordinates.xsl style sheet.

Af) CDOT_ListCoordnates xsl

0] Bentley InRoads Report Browses - C:\Users\PCALLA-1\Apg ocal\Temp\RPTRICZxml (E=% ol
File Tocls Help
& rspace COOT M Sandards Gicbal
‘ .
] Bidge = '!:!il
23 Cart v,
- CL " — — —
A]) COOT Adne Description xs! = _—
Aj] CDOT Air Rights Easemant Description xsl = -
A]) COOT Fes Parcel Descrintion x5l List Coordinates Report
&3 CDOT Pemanant Easament Descriptson xsl
Aj) CDOT Siope Easement Description xsl Report Created: %/25/2009
&ECDOYTWEMMDMR‘H\BI s Time: 12:32pm
Aj) COOT Utity Easement Description xsl - =

A]] CDOT_Marumentation_Clesrsnce xsl Project: 12345 ROW
Aj] CDOT_Morumentation_ListCoordnates xsi Description:
21 Cearance C\Projects\12345
I3 Custom File Name: "% : .
=) DeeaColection : \ROW_Suney\inRoads\Geometry'12345_ROW alg
I=3 Evaluation ast -
B i Revisad: pcallahan 9/25/2009 12:00:21 PM
=3 Ics
[0 Images ;
= - s Cogo Points
2] LegalDescrption
21 LightRaiManufacturing ’:ﬁ',::g NORTH (f)  EAST(f)  ELEV () DESCRIPTION
|21 MapCheck
[T Obaalete 100 1658457 41 326929523 665437 Section Comer
L] RoadwayDesign
=] i £ 102 1?53430.5_3(_} ?2?5?9 98 ?654_1 3 ?uaner ?eclion (_:umel 4

15. Select File > Save As

16. Navigate to the 12345\ROW_Survey\InRoads\Reports folder and input the file

name 12345 PCSTO1.xml

& SaveAs
Savein: Reports L] = EfL B~
= Name’\ Date modif... Type Size Tags
s
2 SBP Lot 1.xml
Recent Places p— e
|| SBP Lots 1-4.xml
Desktop
i
B )il
CDOT_User
A
Computer
A
S
Network
File name: |1 2345_PCSTO1 2l j Save |
Save as type: | XL File (*xmi) | Cancel
Help

17. <D> Save to save the file.

Excel in MicroStation

Tables can be created in MicroStation by linking information that is contained in an Excel
spreadsheet. There are several advantages to using the linked spreadsheet method. Some of

these are:

¢ Text formatting in the spreadsheet is retained by MicroStation

¢ Graphics (borders, girds, etc) are retained from the Excel file
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¢ Updates to the Excel file are reflected in the MicroStation file
In the Bentley InRoads Report Browser:

18. <R> on the report in the coordinate list area as shown. A fly out menu will appear.

(e —
& Bentley InRioads Report Browser - C- APCALLA~1\App I\ Ternp RPTI904 xmi =3 Fof| = |
File Teols Help

C\Workspace Workspace-COOT_XM\Standards-Global inRoads JMI 7
[ cooT 7 Back
A&j) CDOT Adne Description xsl arwar
4] CDOT Ar Rights Essement Descrition sl
Aj] COOT Fee Parcel Description xsl b As...
CDOT Pemmanent Eassment Description xs!
&) CDOT Siope Easement Descrption st ates Report
Af] CDOT Temporary Easement Descrption xsl
CDOT Lkiey Easement Description xed d: 9/25/2009
Aj] COOT_LisCoorinates.xsl 2-39pm
CDOT_Monumentation_Clearance xsl E
.e_\"] COOT_Menumentation_ListCoordnates xsl =
|5 Cearance Create Shortcut
=] Custom D addto Favorites...
{21 DataCobection View So
= 1ew Jource
| Evaluation { jeometry\12345_ROW alg
2] Geometry Encoding 5 N
] Ks 021 PM
(] tmages Print...
E1 ntersecting Algrment Stations A
=1 LegalDescrption Cogo Print Preview...
|=) LightRaiMamfactuing Refresh
21 MapCheck P
|22 Obsolete N Append to Bxsting POF ELEV {ft) DESCRIPTION
] RoadwayDesign =
21 Schemas E""vmw“d"b“ FLE 6654.37 Section Comer
| Skt sl 665437 Quarter Section Comer
;l&wﬂﬁal - Export to Microsoft Excel T N x
ill Forms
RoboForm Toolbar
Save Forms
Properties

19. Place the cursor over the coordinates (the bottom half of report) and select Export to
Microsoft Excel from the fly-out menu.

Excel should automatically launch if it is installed on the PC being used.

;',"6:1 = ..:1 (Y @ s Bookl [Compatibility Mode] - Microsoft Ex... i ™
- Home.i Insert | Page I.zl Formul | Data | Rwiewl View | De\relo|| Project'| Acroha_l 'QJ - o X
‘-3 %  Calibri -S| G % Alllwl == 47~
F:aste - |B i T”-g il -_ j 'ﬂv Mumber | Styles | Cells @r da-
| - I ||[Ee] O A =2 - . ||k
| Clipboard = 7] Alignment ] Editing
| AL ~Q fo| _ 1l
| A B | (5 | D E F (<l
L POINT!NORTH (ft}) EAST (ft) ELEV (ft) DESCRIPTION
2 [NAME

3 | 100 1558457.41 3269295.23 06654.37 Section Corner

4 102 1558430.9 3266629.98 6654.37 Quarter Section Corner
35 103 1555770.83 3266639.57 6615.17 Quarter Section Corner
6 104 1555781.53 3269304.03 6627.27 Quarter Section Corner
7 105 1558527.87 3279643.18 6585.79 Section Corner

8 106 1558562.81 3282329.69 6505.88 Quarter Section Corner
9 | 107 1555920.99 3282335.45 6545.91 Quarter Section Corner
10| 108 1555884.03 3279671.7 6623.76 Quarter Section Corner

M 4 » ¥| Sheetl Sheet? ~Sheet3 .~ ¥J .
Ready | 7
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20. Make changes to the data or add formatting.

A B (& D E

1 | PROJECT COORDINATE SUMMARY TABLE

2 POINT NAME PROJECT COORDINATES

3 NORTH (ft)  EAST (ft) ELEV (ft) DESCRIPTION

4 100 1558457.41 326592595.23 6654.37 Section Corner

5 102 1558430.9 3266629.98 6654.37 Quarter Section Corner

6 (103 1555770.83 3266639.57 6615.17 Quarter Section Corner

7 104 1555781.53  3269304.03 6627.27 Quarter Section Corner

8 105 1558527.87 3279643.18 6585.79 Section Corner

9 106 1558562.81 3282329.69 6505.88 Quarter Section Corner

10 |107 1555920.99 3282335.45 6545.91 Quarter Section Corner

11 (108 1555884.03 3279671.7 6623.76 Quarter Section Corner
12

21. and save the spreadsheet to the ...\ROW_Survey\InRoads\Reports\ directory.

(%) Save As (=5

p—
L)v[;. <« 12385 » ROW Survey » InRoads » Reports ~ [ 42 ][ search

‘ Organize ~ f28 Views ~ B New Folder

Folders v  Name Date modified Type Size
. ROW_Survey - No items match your search,
| Correspondence
I Drawings
\. InRoads
\. DTM
|| Field_Books B
i Geometry
Ji Legals
.. Reports
. Research
I Survey —

File name:  Project Coordinate Summary

Save as type: [Exl:el 97-2003 Workbook (*.xls)

Authors: CDOT User Tags: Add atag

[] Save Thumbnail

“ Hide Folders Tools ~+ [ Save ] ’ Cancel
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22. Select the range of information to be displayed in the MicroStation file.

23.

’__‘\ W9~ @ 5 Project Coordinate Summaryxls [Compatibil.M - = X
—Ly Home|| Insert | Page La| Formul | Data | Review | View | Develol| Project!| Acroba | @ - = x
2 X ||| calibri 11 v (B = S o, e M = O
Paste o qg s l_E _E = ’ﬂ_"l Number Styles | Cells E' i3
- F B[O A |iE & (2| % 7 sl
Clipboard ™ Font P Alignment M Editina
| Al - ( ] PROJECTCO[ P ~[1 ~JAT A" S ~ % o
' 5 = = ®]z[Es=- - A 86
1 PROJECT COORDINATE SUMNM ARV TADLE | !
2 [POINTNAME PROJECT COORDINATES | & | cut
3 NORTH (ft)  EAST (ft) ELE 12 Copy
4 |00 1558457.41 326929523 6 L Paste
5 |102 1558430.9 3266629.98 6 Paste Special...
6 |103 1555770.83  3266639.57 6 Insert..,
7 |104 155578153 3269304.03 6 | peiete..
8 105 1558527.87 327964318 6 Clear Contents
9 |106 1558562.81 3282329.69 6 Filter ]
10 |107 1555920.99 3282335.45 B Sor: :
11 |108 1555884.03 3279671.7 6 =
12 od Insert Comment
4 4 » M| Sheetl Sheet2 ~Sheet3 70 AN . Format Cells..

=
Average: 1209588.525 Count: 47 Sum: 38706832.72 |_|E

N

Pick From Drop-down List...

Mame a Range...

@, Hyperlink...

<R> on the spreadsheet data and select Copy from the fly-out menu.

RETURN TO MICROSTATION

24.

25. <D> the Linked Microsoft Office Excel 2003 Worksheet option.
26.

Select Edit > Paste Special from the MicroStation menu bar.

M1 Paste Special 22

Picture of Microsoft Office Excel 2003 W
Embedded Microsoft Office Excel 2003 W
Linked Microsoft Office Excel 2003 Work:|=
Text To Design File
Rich Text to Design Fle
Linked Text To Design File ¥

[ Paste I [ Cancel l

<D> Paste

Note: By choosing linked, updates made to the Excel file can be passed back to the
MicroStation file through updating. Selecting embedded does not provide this

dynamic ability.
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27. In the Paste OLE dialog box, set Paste as to L/nk, Method to By Size, and input a
Scale of 10

| M4 Paste OLE Object =Rl
j

Object: Microsoft Office Excel 2003 Work
Pasteasi Lk  ~]

Method: |By Size -/

7] Display as icon
| Transparent Background
Rotate With View
Scale: | 10.0000
Size: (42.917x 20.937) "

Note: At this time, we do not fully understand the correlation between the scale and
resulting text size. For this example, 10 seemed to produce reasonable results.
Once placed, the text height can be measured and the bounding shape of the linked
Excel table can be scaled up or down accordingly to achieve required text size.

PO INORT R // ////////////// ELEV Bt ////

Jﬂ / / ‘ "r % , . 37 /., ,? oment-eroery
/5 / / v o

7 At/. A
/”/ v

108 1,
Ere
//// %f

,,,g///% / ”// Z///////////////ZZ//,Q,,,,,,, /5/5/////////////////

Note: Hatching on the MicroStation representation of the linked Excel data indicates the
spreadsheet is currently open for editing.

28. Close Excel and note the hatching is eliminated from the display.

Activating the Element Selection tool and entering a <D><D> on the border of the linked
table in MicroStation will launch the Excel application. If the Excel file is initialized from
MicroStation the linked data will automatically update when the Excel file is saved and
closed.

29. Use the MicroStation Element Selection Tool and <D><D> on the border of the linked
data.

X

30. Make an edit to the spreadsheet data or formatting.
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31. Save and Close the Excel file. Note the linked data in the MicroStation file updates.

POINT [NORTH EAST ELEV DESCRIPTION

102| 1,558,430.90 | 3,266,629.98 6,654.37 |Control Monument-Project
103| 1,555,770.83 | 3,266,639.57 6,615.17 |Control Monument-Project
]04| 1,555,781.53 | 3,265,304.03 6,627.27 |Control Monument-Project
]05| 1,558,527.87 | 3,279,643.18 6,585.79 |Control Monument-Project
]05| 1,558,562.81 | 3,282,329.69 6,505.88 |Control Monument-Project
]ﬂ?| 1,555,920.99 | 3,282,335.45 6,545.91 |Control Monument-Project
108| 1,555,884.03 | 3,279,671.70 6,623.76 |Control Monument-Project
]13| 1,556,247.10 | 3,279,252.22 6,624.10 |Traffic Control Double Yellow
]_1.?| 1,558,514.31 | 3,277,056.40 N/A North 1/4 Cor Section 14

If the linked data is edited by launching the application outside of MicroStation, a manual
update command must be executed. Select Edit > Update Links from the MicroStation

menu bar to refresh the linked MicroStation graphics.

The linked data can be moved, scaled, or otherwise manipulated with MicroStation

commands by selecting the border of the linked object.
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