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LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.



Page 650 Colorado Department of Transportation

LAB 30 - End Conditions that Require Multiple Solutions Labs for InRoads XM



Colorado Department of Transportation   Page 645

LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method
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12345DES_Template-End Cond Mult Sol.itl from the available files.
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5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.
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9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
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4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.



Page 650 Colorado Department of Transportation

LAB 30 - End Conditions that Require Multiple Solutions Labs for InRoads XM



Colorado Department of Transportation   Page 645

LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.



Page 648 Colorado Department of Transportation

LAB 30 - End Conditions that Require Multiple Solutions Labs for InRoads XM

23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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LAB 30 - End Conditions that Require Multiple 
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This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.



Page 648 Colorado Department of Transportation

LAB 30 - End Conditions that Require Multiple Solutions Labs for InRoads XM

23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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Solutions
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slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions. The section will place 
a minimum 2-foot deep ditch, with a berm if necessary, when in cut. The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height. This 
section is constructed using the drag and drop method. Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads using the 12345DES_Model-End Cond Mult Sol.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel to dismiss the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder. Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component. The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.
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18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop. The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2 in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D> the Close button in the Component Properties dialog box.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.

Chapter Summary:

 When multiple end conditions are chained together, if one part of the chain fails then the 
whole chain fails.

 End condition components that share a common starting point are considered a single end 
condition.
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