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LAB 31 - Create End Conditions to Search a 
Surface

This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.



Page 656 Colorado Department of Transportation

LAB 31 - Create End Conditions to Search a Surface Labs for InRoads V8i SS2

1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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LAB 31 - Create End Conditions to Search a 
Surface

This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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LAB 31 - Create End Conditions to Search a 
Surface

This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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LAB 31 - Create End Conditions to Search a 
Surface

This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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LAB 31 - Create End Conditions to Search a 
Surface

This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.



Page 654 Colorado Department of Transportation

LAB 31 - Create End Conditions to Search a Surface Labs for InRoads V8i SS2

1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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LAB 31 - Create End Conditions to Search a 
Surface

This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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LAB 31 - Create End Conditions to Search a 
Surface

This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.



Colorado Department of Transportation   Page 655

Labs for InRoads V8i SS2 LAB 31 - Create End Conditions to Search a Surface

10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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LAB 31 - Create End Conditions to Search a 
Surface

This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

The following files are used in this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create End Condit Search 
Surf.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create End Condit Search 
Surf.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create End Condit Search 
Surf.ird

 C:\Projects\12345\Design\InRoads\Exist_Ground_1-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Exist_Ground_3-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_2-Create End Condit Search Surf.dtm

 C:\Projects\12345\Design\InRoads\Rock_Layer_3-Create End Condit Search Surf.dtm

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Open the following files from C:\Projects\12345\Design\InRoads\ directory.

♦ CDOT_Civil.xin
♦ 12345DES_Geometry-Create End Condit Search Surf.alg
♦ 12345DES_Template-Create End Condit Search Surf.itl
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♦ 12345DES_Roadway-Create End Condit Search Surf.ird
♦ Exist_Ground_1-Create End Condit Search Surf.dtm
♦ Exist_Ground_2-Create End Condit Search Surf.dtm
♦ Exist_Ground_3-Create End Condit Search Surf.dtm
♦ Rock_Layer_2-Create End Condit Search Surf.dtm
♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the to dismiss the Open dialog box.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template to open it for editing.

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box
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8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.

Lab 31.3 - Create a Corridor and Template Drop

Build a corridor that follows the centerline alignment and extends along all three segments of 
the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar.

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline for the Horizontal Alignment.

♦ Select Centerline V for the Vertical Alignment.

13. <D> Add then <D> Close.
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1. Select Corridor> Template Drops from the Roadway Designer menu bar.

2. In the Template Drops dialog box, select Centerline for the Corridor name.

3. Key in 50 for the Interval.

4. Expand 1 - Templates folder in Library Templates area.

5. <D> on the 12345_HMA_2Lane_Rock template.

6. <D> Add then Close.

Lab 31.4 - Define target aliasing

Target aliasing allows multiple targets to be specified for a single end condition. In this 
example, the existing ground for the project was contained in three separate dtms.

7. Select Tools> Target Aliasing from the Roadway Designer menu bar.

8. In the Target Aliasing dialog box, select <Active Surface> for the Target.

9. Highlight Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.
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10. <D> Add.

11. Select Rock_Layer_2 for the Target.

12. Highlight Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.

13. <D> Add.

14. <D> OK.

Lab 31.5 - Review Design Model

View the corridor to examine the end condition’s behavior and determine if templates and target aliasing are 
working properly.
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1. In the Roadway Designer dialog box, key in 373+00 for the Station. Notice the end con-
ditions target the existing ground and rock layer surfaces in Roadway Designer dialog’s 
cross- section viewer.
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2. Key in 600+00 for the Station. Notice in the illustration below, that even though the 
surfaces are different, the end condition still solves. THis is because the Target Aliasing 
allows multiple surfaces to be specified for the end condition.

Chapter Summary:

 When end conditions are chained together (like the rock layer components used above), all 
parts of the chain must solve or the whole end condition fails.

 Use target aliasing to target multiple existing ground and rock layer surfaces.
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