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LAB 6 - Profiles and Vertical Alignments

Once the horizontal alignment is defined, then the profile and vertical alignment can be created. Profiles are a 
graphic representation of a surface along a specified path (alignment, graphic element, etc.). Profiles are also 
used to create and display vertical alignments.

Chapter Objectives:

 Review an existing vertical alignment.

 Create a profile.

 Update the profile with a variety of features.

 Display profile annotation data.

 Use vertical alignment tracking.

 Create a new vertical alignment.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Design.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

Lab 6.1 - Reviewing Vertical Alignments

Section Objectives:

♦ Examine the Review Vertical Geometry window and explore the functionality of the 
dialog box.

Reviewing vertical alignments is similar to reviewing horizontal alignments. The Review 
Vertical Alignment dialog box allows you to easily change between multiple Geometry 
Projects, Horizontal, and Vertical alignments.
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1. Select Geometry > Review Vertical from the InRoads main menu.

The review dialog box can also be opened with the right-click menu.

Section Summary:
♦ Reviewing vertical alignments works the same as reviewing horizontal alignments.

Lab 6.2 - Creating Profiles

Before a vertical alignment can be displayed graphically, a profile must be created. These are 
referred to as profile sets in InRoads. A profile set can be created from a horizontal alignment, 
a MicroStation element, or a series of data points. A profile can contain DTM surfaces, vertical 
alignments and DTM features. Once a profile set has been created, items displayed can be 
turned on or off and elements can be updated based on current data.
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Section Objectives:

♦ Examine the profile dialog box.

♦ Select profile Preferences.

♦ Display vertical alignment annotation.

The DTM 12345Surv_Surface_Existing surface will be used to display an existing ground-
line

1. In the InRoads explorer, select the Geometry tab, verify that 12345_Design is the 
active geometry project and that the horizontal alignment SH86 is the active alignment.

2. Select Evaluation > Profile > Create Profile from the InRoads main menu. The Create 
Profile dialog will appear.

3. <D> the Preferences button. The Preferences dialog box is displayed.

4. Highlight the 2x vertical preference.

   

5. <D> the Load then Close buttons. Notice that the Exaggeration has changed to 2.00.

Note: Load preferences before making any other menu settings. Loading Preferences 
resets all menu settings to those predefined in the preference.
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6. In the Surfaces area of the dialog box, Verify that the 12345SURV_Surface_Existing 
surface is toggled on.

7. <D> the Source leaf. Verify that the SH 86 alignment is selected.

8. <D> the Apply button. The Create Profile dialog box is temporarily minimized.
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9. You are prompted by MicroStation to ‘Identify location’. <D> in the MicroStation view. 
The Profile window is placed and the Create Profiles dialog box is restored.

Note: For convenience, we are displaying the profile in the current drawing. Normally, 
Profiles and cross sections are created in their own dgn files. Consult the directory 
structure and file naming convention for your specific discipline to determine 
standards relating to profile display.

Lab 6.3 - Viewing Vertical Alignments and Annotation

Once a profile is created from a horizontal alignment, vertical alignments associated with that 
horizontal alignment can be displayed.

Section Objectives:

 Display the vertical alignment line i a profile

 Display vertical alignment annotation

1. Select Geometry > View Geometry > Active Vertical to display a graphic of the 
active vertical alignment.
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♦ Alternately in the Workspace Bar under the Geometry tab you can <R> on the Vertical 
Alignment and select View just as you did with Horizontal Alignments.

 

Note: Annotation size for the index elevations and stationing calculated using the global 
scale factor. The profile text size can not be changes once the profile is displayed. 
To change the text size, the original profile is deleted and a new one is created 
using the desired global scale factor.

Vertical alignment annotation is used to display the vertical alignment line and other data in a 
profile set.

2. Select Geometry > View Geometry > Vertical Annotation from the InRoads main 
menu. This displays the View Vertical Annotation dialog box.
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3. Verify the appropriate Horizontal, Vertical Alignments, and Profile Set are correctly 
identified.

4. <D> the Apply button.

Take some time and investigate the remaining tabs along the top of the View Vertical 
Annotation dialog box and the individual settings for each.



Page 134 Colorado Department of Transportation

LAB 6 - Profiles and Vertical Alignments Labs for InRoads V8i SS2

5. <D> the Points tab. Note the settings in the Symbology portion of the dialog box. By 
default, the Proposed preferences are used.

6. <D> the Preferences button.

7. <D> the Existing preference.

8. <D> the Load then Close buttons.
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9. Note the change in the defined Symbology.

10. <D> the Apply button. Review the results in the MicroStation drawing. Notice that the 
data remains the same, however the symbology (level, color, etc.) is changed.

11. For practice, continue to Load and Display additional preferences. Investigate what levels 
the elements are being placed on. The various preferences determine the location of 
graphics.

Section Summary:
♦ Use the Preferences to make the major settings in the Create Profile and Vertical 

Alignment Annotation dialog boxes.

♦ View Active Vertical only displays the geometry elements that make up the vertical 
alignment.

♦ Vertical Alignment Annotation displays the geometry elements and text data that 
describe the alignment.

Lab 6.4 - Updating Profiles

When a profile is created the user has the option to display items such as: multiple surfaces, profile lines offset 
from the horizontal alignment, and features such as underground utilities and pipes. However, the Create 
Profile command does not allow the user to specify which features are displayed.

The Update Profile command should be used to add, remove, or update data within an existing profile set. This 
command allows the user to specify which features will be affected by the command and can also be used to 
update and surface data that has changed since the profile was created.
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Section Objectives:

♦ Use the Update Profile command to add features to the display.

♦ Illustrate how Global Scale Factors affect cell size.

♦ Examine how Feature Filters affect dialog box lists.

1. From the InRoads main menu, select Evaluation > Profile > Update Profile. The 
Update Profile dialog box is displayed.

2. Verify SH 86 is the active Profile Set.

3. In the Mode section toggle on Display On.

4. <D> the Crossing Features leaf.

5. In the Surfaces section highlight 12345SUR_Surface.
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6. <R> in the Crossing Features list and <D> Select All from the right click menu.

7. <D> the Apply button. Using MicroStation viewing tools locate a crossing culvert.

Profile and cross section displays are drawn at true horizontal scale. A vertical exaggeration is 
applied to cells displayed in profiles or cross sections based on the vertical scale applied to the 
grid. 

Note: Two classes of elements can be displayed on profiles; 1) True scale items such as 
culverts and 2) items represented by text such as utility crossings, flow-lines, 
ROW, etc.

For True Scale items:

The global scale factor for cells should be set to 1.
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For Informational items:

The global scale factor should be set equal to the plot scale.

Lab 6.5 - Refreshing a Profile Display

First, true-scale items such as the culverts.

1. Select Tools > Global Scale Factors.

2. <D> on the Scale Factor Lock icon so that it is in the open position. This allows 
modification to the cell scale only. This allows annotation and other commands to remain 
unaffected by the scale factor that is used specific for cells.

3. In the Cell field, key in 1.

4. <D> the Apply then Close buttons in the Global Scale Factor dialog box.

5. From the Locks toolbar, select CELL_True-Scale from the Feature Filter list. 

6. Toggle on the Feature Filter lock.

7. Close and reopen the Update Profile dialog box.

8. Verify SH 86 is still the active Profile Set. 

9. In the Mode section toggle on Refresh.

10. <D> the Crossing Features leaf.

11. Highlight the 12345SURV_Surface in the Surfaces area.



Colorado Department of Transportation   Page 139

Labs for InRoads V8i SS2 LAB 6 - Profiles and Vertical Alignments

12. Select all of the Crossing Features listed.

13. <D> the Apply button.

14. Use MicroStation viewing tools to locate a crossing culvert and review the results.

15. Use MicroStation Measuring tools to verify pipe size(s).

16. From the Locks toolbar select CELL_Plot-Scale from the Feature Filter list.



Page 140 Colorado Department of Transportation

LAB 6 - Profiles and Vertical Alignments Labs for InRoads V8i SS2

Note: Verify that the feature filter is toggled on.

17. Change the InRoads Scale Factor to 100 for cells.

Note: This is the desired plot scale change accordingly.

18. Close and reopen the Update Profile dialog box.

19. Verify SH 86 is still the active Profile Set. Use the target button next to the Profile Set to 
graphically change the active profile set.

20. In the Mode section toggle the radio Refresh button.

21. <D> the Crossing Features leaf.

22. <D> the surface name 12345SURV_Surface.

23. Select all of the Crossing Features listed.

24. <D> the Apply button.

25. Turn Off the Feature Filter lock.
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Section Summary:
♦ Update Profile is the better tool to use when adding features to a profile. With Update 

Profile the user can choose which features to display. With Create Profile, all features 
that can be displayed (based on feature style settings) are displayed.

♦ There are two types of feature cells used in profiles; true scale cells that use a global 
scale factor of 1 and plot scale cell that use a global scale factor the same as the plot 
scale.

Lab 6.6 - Annotating a Feature in a Profile

Features that have been displayed in profiles (or cross sections) can be annotated with 
information extracted from the surface model.

Section Objectives:

♦ Annotate the true scale features in the profile.

1. Using MicroStation commands, window into any culvert displayed in the profile created in 
the previous lab.

2. From the Locks toolbar select CELL_PLOT-Scale filter and verify the feature filter is 
toggled On.

3. Select Evaluation > Profile > Annotate Feature from the InRoads main menu. The 
Annotate Feature In Profile dialog box is displayed.
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4. Select the Annotate leaf. Notice that the features are already highlighted. Also, there is a 
drop down menu that is used for selecting the surface that contains the features to be 
annotated.

5. <D> the Apply button and review the results.

6. <D> the Points branch.

7. Toggle on the Feature Description.
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8. <D> the Apply button and review the results in your profile.

9. Experiment with enabling other options in the Point branch and redisplaying the 
annotation.

Challenge Exercise:

Update your profile to show projected features. Annotate the projected features.

Section Summary:
♦ Only features displayed in the profile can be annotated.

♦ Set the global scale factor for text to the plot scale before executing the command.

Lab 6.7 - Annotating a Profile

In addition to annotating vertical alignments, profiles can be annotated with both existing and 
design information.

Section Objectives:

♦ Add Existing and proposed elevation information to the profile.
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♦ Add Cut Depth and fill height information to the profile.

1. Select Evaluation > Profile > Annotate Profile from the InRoads main menu.

2. <D> Apply. The existing and proposed grades annotate the profile.

3. Take some time and review the leaves of the Annotate Profile dialog box. Investigate the 
individual settings for each.
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4. Now go back and <D> the Selection leaf.

Note: The dialog box shows two categories; Available and Selected. Available lists the 
items that can be annotated in a profile, Selected identifies the items chosen for 
annotation.

5. <D> the item Cut Depth from the Available list.

6. <D> the Add button. Cut Depth will be added to the Selected list.

7. <D> the item Fill Height from the Available list.

8. <D> the Add button. Fill Height will be added to the Selected list.

Note: Make sure that Existing and Proposed remain in the 1 and 2 slots. To move a 
selected item, highlight the item and <D> the Move Up or Move Down buttons

9. <D> the Apply button and review the profile display.
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Note: You may have to zoom out to view the additional annotation.

Section Summary:
♦ Annotate Profile is used to place existing surface elevations and vertical alignment 

elevations on the profile set.

♦ Other data related to profiles can also be displayed.

♦ When displaying additional data, make sure Existing and Proposed stay at the top of 
the list.

♦ Change the settings on the Frame leaf to move additional data closer to the profile 
window.

Lab 6.8 - Vertical Alignment Tracking

Vertical alignments can be interactively queried similar to horizontal alignments.

Section Objectives:

♦ Examine Vertical Alignment tracking in the profile.

♦ Examine the vertical alignment data in Horizontal Alignment tracking.

The next series of steps illustrates Vertical Alignment tracking.

1. Select Tools > Tracking > Vertical Alignments from the InRoads main menu.
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2. Move the cursor inside the Profile Set window and review the output in the InRoads Status 
bar.

Note: As you move your cursor in the profile set window InRoads displays vertical 
alignment information in the status field. There is not an option to write this 
information to the MicroStation file.
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This series of steps illustrates tracking vertical data in the plan view

3. Select Tools > Tracking > Horizontal Alignment.

4. Move the cursor along the active horizontal alignment and review the readout in the 
InRoads Status bar.

Results displayed are the station and offset relative to the active horizontal alignment. The 
elevation is relative to the active vertical alignment.

Section Summary:
♦ Tracking is used to gain information that is related to the horizontal and vertical 

alignments.

Lab 6.9 - Create a Vertical Alignment

Vertical alignments define an elevation path for the proposed design to follow. It is stored under the parent 
horizontal alignment.

Section Summary:
♦ Create a new vertical alignment slot.

♦ Add PIs to the vertical alignment.

♦ Define the vertical curves.

Create a slot in the active geometry project for your vertical alignment.

1. Select File > New.

2. <D> the Geometry tab.

3. Set the Type to Vertical Alignment.

4. Key in SH 86 V Alt1 for the Name.
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5. Key in Alternate vertical alignment for the Description.

6. Set the Style to ALG_PRO_Vert.

7. Verify that the Curve Definition is set to Parabolic.

8. Select Apply then Close

9. Set up your MicroStation windows so the entire profile is visible in one window, then open 
another MicroStation window and Zoom in to the beginning of the profile as shown.

        

Next, add PVIs to the Vertical Alignment.

10. Verify that the Write Mode is set Pencil.
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11. Select Geometry > Vertical Curve Set > Add PI from the InRoads main menu.

12. Select Apply.

13. For the first PVI, snap to the beginning of the ground line in the window where you are 
zoomed in.

14. In the MicroStation key in field, enter the following commands: (Be certain to use the % 
sign in the key-in.)

♦ dg=900,-3.76%

♦ dg=400,1.03% 

♦ dg=425,-4.29%
♦ se=11725,6574.78 
                               

The dg= key-ins place a PI at the specified distance and grade from the previous point. 
The se= key-in places a PI at the specified station and elevation.

15. <R> twice to exit, then Close the Add Vertical PI dialog box.

16. Update the view.
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The vertical alignment is displayed permanently in the design file. Because Pencil mode is 
active, the tangents will automatically update when the curves are added. 

17. Select Geometry > Vertical Curve Set > Define Curve from the InRoads main 
menu.

The Define Vertical Curve dialog box is automatically displayed ready to accept input for 
the first curve on the vertical alignment. To step to other curve sets, you can use Previous 
and Next, or First and Last.

18. Under the Vertical Curve area,  set Calculate By to Length of Curve.

19. Key in 300 for the Length.

20. Select Design Calc.
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21. Click in the Table Name field and Browse to the C:\Workspace\Workspace-
CDOT_V8i\ Standards-Global \ InRoads\Design Checks folder and select the 
file Vertical Design Checks.txt. 

22. Verify that the length of curve meets your design criteria.

23. <D> Cancel when done. Do not accept the minimum curve, just verify that yours meets 
the criteria.



Colorado Department of Transportation   Page 153

Labs for InRoads V8i SS2 LAB 6 - Profiles and Vertical Alignments

24. Select Apply

25. Select Next to move to the second intersection of tangents.

26. Verify that Calculate By: is set to Length of Curve.

27. Key in 250 for the Length.

28. Select Design Calc.

29. Verify that the length of curve meets your design criteria.

30. Select Apply.

31. Close the Define Vertical Curve Set dialog box.

32. Save the geometry project.

33. Close InRoads and MicroStation.Labs for InRoads V8i SS2

Section Summary:
♦ Vertical alignments are defined in the profile window.

♦ Vertical PIs can be added by data point or key in.

♦ The Define Curve dialog box can also be used to adjust PI stations and elevations.
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Chapter Summary:

 Use the review vertical alignment command to examine vertical alignment data when a 
profile is not required.

 Profiles are required to view vertical alignments graphically.

 Use Update Profile to add, remove, or revise data in a profile set.

 Annotate Feature in Profile only affects features displayed in the profile.

 Annotate Profile is used to display existing surface and vertical alignment elevations in the 
profile.

 Vertical Alignment Tracking displays Station, Offset, Elevation, and Grade information in 
the InRoads main dialog box.

 Typically, vertical alignments are defined by locating all of the VPIs then placing the 
curves.


