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This document has been prepared for the Colorado Department of Transportation by:   

And the following Sub-consultants:

Copyright

Copyright © 2011 Colorado Department of Transportation. All Rights Reserved

Many of the designations used by manufacturers and sellers to distinguish their products are claimed as 
trademarks. MicroStation and InRoads are trademarks of Bentley Systems Incorporated. Where other 
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Disclaimer
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for any consequential, incidental, special or exemplary damages even if appraised of the likelihood of such 
damages occurring.  CDOT does not warrant the documents against deficiencies of any kind.  The use of any of 
these documents for work which is under contract with CDOT, does not relieve the contractor from any 
obligation assumed by the contract, or from complete and proper fulfillment of the terms of the contract, nor 
does it entitle the contractor to compensation for damages or loss which could be attributed to such use.

Notice

This manual may be freely copied or distributed for the purpose of providing the Colorado Department of 
Transportation and Colorado customers a consistent guide to using the Bentley suite of products to meet 
CDOT's design and drafting standards.

Software Versions
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Document Conventions

There are several conventions that are used throughout this document to indicate actions to be taken or to 
highlight important information.  The conventions are as follows:

Item
 

Meaning

View Perimeter a command name or a file that you are to select

Tools > Options a command path that you are to select – usually from the pull-down 
menus

Document Name the name of a document that is not hyperlinked

Emphasis style used when referring to important word or phrases

Hyperlink style used when you have a direct link to another document on the web

Key in entering data with the keyboard

Quote style used to indicate an external source quotation

Note: text information about a command or process that you should pay 
particular attention to

1. Numbered Steps actions that you are to perform as part of the lab activities

<D> or Data press the data button on the mouse

<R> or Reset press the reset button on the mouse

<T> or Tentative press the tentative button on the mouse
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Preface (Under Development)

 How to contact CDOT CADD Manager

 Message from CADD Manager

♦ real success of manual is through participation by the users for updates

♦ Living document

♦ this is the opportunity to influence the development of the document

 How to use this manual
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InRoads V8i Resource Locations

This Section identifies the standard location of the InRoads V8i resources in the CDOT V8i configuration.  In 
addition, the location of InRoads resources CDOT users create through the design process will be identified.

Section Objectives:

♦ Identify the location of InRoads V8i resources delivered in the CDOT Workspace

♦ Indentify the location of the user generated InRoads V8i resources

Delivered InRoads V8i Resources

There are four InRoads V8i resources that are delivered in the CDOT Workspace.

♦ CDOT_Civil.xin - The CDOT_Civil.xin is a XML based preference file that replaces 
several files used by InRoads 2004.  This file is in the following location:

 \Workspace\Workspace-CDOT_V8i\Standards-Global\InRoads\Preferences

The new CDOT_Civil.xin preference file replaces the CDOT-Preferences.ini, CDOT-
Styles.ini, CDOT-Survey_Features.fwf, CDOT-Survey_Preferences.fxp, Impexp.ini, 
and CDOTCTL.tiw.  Existing Ini’s, fwf’s, fxp’s and tiw’s cannot open in InRoads V8i.

♦ CDOT_V8i Disciplines.reg - The CDOT_V8i Disciplines.reg file is only used once to 
setup the InRoads Project Defaults with variables that are defined in the Project 
Configuration File ( pcf).  This file is in the following location:

 \Workspace\Workspace-CDOT_V8i\Standards-Global\InRoads\Preferences

The registry file supplied for V8i does not replace the 2004 registry file.  The project 
defaults for the two versions of InRoads are stored in two different locations.  If the 
2004 version of the registry file was used, it is required to run the V8i version to update 
the variables in the project defaults to V8i.

♦ CDOT_Template-Library.itl - The CDOT_Template.itl file contains the CDOT 
standard InRoads templates and components. This file is in the following location:

 \Workspace\Workspace-CDOT_V8i\Standards-Global\InRoads\Templates

When building project templates and components, it is imperative the user copies the 
ITL file from the configuration into the project folder.  The location of this project 
specific file is \JPC# \[Discipline]\InRoads.  All modifications to the ITL file located in 
the configuration will be erased on log in.

The new V8i ITL file replaced the CDOT-Typical Sections.tml file.  Existing tml’s 
cannot open in InRoads V8i.

♦ Superelevations Tables - The superelevation tables for the AASHTO 2001 and 2004 
are found in the following location:

 \Workspace\Workspace-CDOT_V8i\Standards-Global\InRoads\Superelevation 
Tables
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V8i User Created InRoads Files

Throughout the design process several InRoads files will be created by the user.   These files 
are named with the Job Project Code (JPC) number and are stored in the \JPC# 
\[Discipline]\InRoads folder.

♦ JPC#.rwk - The rwk file is the InRoads Project file.  It contains the location of the files 
used for the project.  InRoads uses this file to load and save data to multiple files at one 
time.   The location varies by the discipline that creates the file.  This location is \JPC# 
\[Discipline]\InRoads.

The rwk file in V8i is the same file extension and serves the same purpose as the rwk 
file in InRoads 2004.  Existing rwk’s must be edited to reflect the new files used in 
InRoads V8i.

♦ JPC#.dtm - The dtm file is the InRoads Digital Terrain Model file and is stored in the 
project.  The existing dtm is located in \JPC# \ROW_Survey\InRoads\DTM\.  The 
location of the proposed dtm’s will vary by the discipline that creates the file.  This 
location is \JPC# \[Discipline]\InRoads.

InRoads 2004 generated design dtm’s will open in V8i but will not have the same 
functionality as InRoads V8i dtm’s.  This process doesn’t require a translation.  
Existing dtm’s generated by the survey division work properly with either version of 
the software.

♦ JPC#.alg - The alg file is the InRoads Geometry file and is stored in the project.  The 
location will vary by the discipline that creates the file.  This location is \JPC# 
\[Discipline]\InRoads.

InRoads 2004 generated alg’s will open in V8i with no translation.  The horizontal and 
vertical alignments are fully functional.  Superelevations defined in the 2004 alg  are 
not used by InRoads V8i.  They can be imported in the new Roadway Designer, ird file 
or recreated using the Superelevation Wizard.  Importing the superelevation will 
require editing in the new interactive superelevation diagrams.

♦ JPC#.ird - The ird file is the InRoads Roadway Definition file and is stored in the 
project.  The location will vary by the discipline that creates the file.  This location is 
\JPC# \[Discipline]\InRoads.

The new InRoads V8i ird file replaced the rwl file in InRoads 2004.  It contains the 
corridor definition, template drops, point controls, and superelevation data.  Existing 
rwl files cannot be opened in InRoads V8i.

Section Summary:

 Identify the location of InRoads V8i resources delivered in the CDOT Workspace

 Indentify which InRoads V8i resource files need to be copied to the project file and why

 Indentify the location of the user generated InRoads V8i resources
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Project Requirements for InRoads V8i

Several changes have been made to the InRoads environment that impacts the current CDOT workspace.  A 
new workspace has been developed for the V8i environment located at C:\Workspace\Workspace‐CDOT_V8i 
as opposed to the 2004 environment located at C:\Program Files\Workspace‐CDOT\.  This section explores 
these changes and how a project setup should be completed.

Proper project setup will greatly increase productivity and reduce errors. 

Section Objectives:

♦ Create a project folder using the Project Creation Utility

♦ Store project specific files in correct folders

Creating the Project Directory

The project directory structure is created using the CDOT Project Creation Utility to performs 
two functions; first it creates a project specific folder and file structure based on CDOT 
standards, and second, it creates a Project Configuration File (PCF) which stores variables to 
simplify file management for the user. The PCF file is utilized by both MicroStation and 
InRoads environments.

1. The project directory is created by running the Project Creation Utility program. To access 
this program go to Start > All Programs >_CDOT_CADD_Information > 8.11.xx – 
V8i > Create V8i Project Directory Structure.
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2. After selecting the Create Project Directory Structure program, the following dialog box 
will appear.

3. Enter the 5 digit Job Project Code (JPC) specific to your project. Verify the Create Project 
Configuration File box is checked ON. This should be on by default. This will create a 
customized PCF file for the project identified in the JPC field.

4. Select Apply. After the program has executed, select Close.

5. Open up Windows Explorer and browse to C:\Projects\ and verify the project folder and 
corresponding folder structure was created.

Project File Setup

Project files are stored in a project specific directory. Base project files must be copied into the 
correct folder locations, either by you or the discipline that is suppling the data.

1. Project survey data and existing topographical features are stored in the project DTM file. 
This DTM file will be the base for design. Copy the existing project surface DTM file into 
the C:\Project\#####\ROW_Survey\InRoads\DTM\ folder.

2. Project survey models contain the graphic output of the projects existing DTM. This DGNs 
will be the reference base for design.  Copy the existing project DGN files into the 
C:\Project\#####\ROW_Survey\Drawings\Reference_Files\ folder.

3. The project template file will contain the project typical sections used to create model 
DTM’s. Refer to Chapter 10 -Typical Sections “Creating a Project Template Library” on 
page 180

Converting to V8i

 Refer to Migrating CDOT Projects and MicroStation V8i Update Guide.pdf document for 
existing project conversions.

http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/MicroStaion XM/Migrating CDOT Projects and MicroStation XM Update Guide.pdf
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Section Summary:
♦ Roadway design and modeling are significantly different in InRoads V8i. Template 

and roadway libraries will need to be redone.

InRoads Project Setup

Several changes have been made to the InRoads environment that impact the current CDOT workspace.  Prior 
to opening or creating InRoads data, proper setup of the InRoads environment will streamline loading and 
saving project files created in InRoads.

Section Objectives:

♦ Identify how to setup a new Project Default

♦ Identify how to edit an existing Project Default

♦ Identify how to load a DTM

♦ Identity how to load an ALG

Project Defaults

InRoads project defaults perform two functions; first they load the appropriate CDOT standard 
resource files such as the standard XIN file, annotation resources, XML style sheets, etc.  
Additionally, they define default paths to project specific directory folders that contain project 
data such as DTM’s, alignments, survey data, etc.

Creating a New Project Default

To create a project specific Project Default Configuration:

1. Open the Project Defaults by Selecting, File > Project Defaults…
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2. <D> on the New button.

3. Enter in the Name of the New Configuration, 12345 and <D> on OK.

4. Fill in Preferences by <D> in the data entry field and <D> the Browse… button.

Note: The Default Preferences section specifies files.  These files will load into InRoads 
directly.  The Default Directory Paths section specifies a folder, not files.  Any files 
within the folder will not load, but when opening the file the browse dialog box 
will open to that folder.

5. Browse to the C:\Workspace\Workspace-CDOT_V8i\Standards-
Global\InRoads\Preferences folder.
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6. Select CDOT_Civil.xin and <D> on the Open button.

7. When finished identifying files and folders <D> on Apply and <D> on Close.

Editing an Existing Project Default

To edit a project specific Project Default Configuration:

1. Open the Project Defaults by selecting, File > Project Defaults…
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2. Select the project to modify by <D> on the Configuration Name pull down.

3. Edit the Files and Folder paths that are required.

4. <D> on Apply when finished.

Discipline Project Defaults

The workflow, CDOT InRoads V8i Project Defaults Management.pdf, utilizes a Project 
Configuration File (PCF) which is created at the start of a project. This PCF file is created by 
running the Project Creation Utility. The resulting PCF stores system variables to simplify file 
management for the user. This PCF file is utilized by both the MicroStation and InRoads 
environments.

InRoads Resources

Prior to designing in InRoads V8i, load the base InRoads project resource files.

Loading a DTM

To open a DTM file:

1. Open an existing DTM file by selecting, File > Open.

http://www.dot.state.co.us/DesignSupport/CADD%20and%20Engineering%20Innovation/Workflows/V8%20XM/CDOT%20InRoads%20XM%20Project%20Defaults%20Management.pdf
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2. Change the file type to Surfaces (*dtm) by <D> on Files of Types:

Note: Once the file type is selected, the path will change if identified in the Project 
Defaults.
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3. <D> on file 12345_existingground.dtm and <D> on Open.

4. <D> on Cancel to close the dialog box.

5. <D>  on the Surfaces tab to view the loaded DTM.
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Loading an ALG

To open an ALG file:

1. Open an existing ALG file by selecting, File > Open.

2. Change the file type to Geometry Projects (*.alg) by <D> on Files of Types:
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Note: When the file type is selected, the Look in folder location will change to the path 
defined in the Project Defaults.

3. <D> on file 12345DES_Geometry.alg and <D> on Open.

4. <D> on Cancel to close the dialog box.

5. <D>  on the Geometry tab to view the loaded ALG.

Section Summary:
♦ Understand the process to create a new Project Default in InRoads

♦ Understand the process to edit an existing Project Default in InRoads

♦ Understand Projects Defaults when using the CDOT_V8i Disciplines.reg file with a 
PCF

♦ Understand the process to load a DTM

♦ Understand the process to load an ALG



Colorado Department of Transportation   Page 29

Chapter 2 - InRoads Options

InRoads has a number of options and global settings that affect the availability of commands and operation of 
the program.  This chapter discusses the locks and options settings for InRoads V8i.

Chapter Objectives:

 Discuss the function of each of the InRoads Locks.

 Discuss the Options dialog box and identify the tabs that users can modify.

InRoads Locks

The locks in InRoads determine what can be displayed, how displayed items are updated, and how items are 
selected for use by the program.

Section Objectives:

♦ Describe the Feature Filter Lock

♦ Describe the Feature Highlight Lock

♦ Describe the Style Lock

♦ Describe Write  modes.

♦ Describe the Locate Lock

♦ Describe the Snap Lock

♦ Describe the Station Lock

♦ Describe the Report Lock

♦ Describe adding toolbars.

Feature Filter Lock

The Feature Filter lock is used to limit the number of features displayed in menu pick lists, 
based on used defined criteria.  This lock has two parts, the Filter Name drop down menu and 
the Feature Filter Lock (on/off switch).

 Filter Name – Lists the name of the Feature Filter that is currently active. It has no affect if 
the Feature Filter lock is off. If the Feature Filter lock is o n, it will limit dialog boxes to 
showing only the features that pass the filter. Feature Filters are stored in the CDOT-
Civil.xin file and are accessed by using the drop-down arrow next to the name.

 Feature Filter lock – If on, activates the current filter. If off, has no affect and all surface 
features are shown in boxes that list features.

Feature Highlight Lock
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This lock highlights features in the MicroStation view window that are selected in an InRoads 
dialog box. This lock should be left off until needed because many of the InRoads dialog boxes 
open with all of the features selected and it can take a long time to highlight all the features.

Style Lock

The Style lock, if on, forces many of the Surface View commands to display the 
requested data (triangles, contours, etc.) without bringing up the dialog box. The 
preference used is the one associated with the surface under Surface > Surface 
Properties. Style lock also forces the Cross Section Annotation command to use the 
named symbology associated with the feature for annotation properties. If off, the Style 
lock has no affect.

Write Modes

The Write Mode determines how InRoads graphic elements will behave when the data 
that generated the graphics changes.  There are two modes; Pencil and Pen.

 Pencil mode - The graphics are updated whenever the same display command is 
selected again. For example, if contours are displayed, then a different preference is 
selected and they are displayed again, the old contours are deleted and new contours are 
displayed.

 Pen mode - The graphics are not updated when the same display command is selected 
again. Instead, another copy is placed in the design file. 

 Delete Ink

Delete Ink overrides the Pen mode so that the graphics are treated like Pencil mode and the old 
ones are removed before new ones are placed.

Note: The Write mode of an element is saved with that element.  For example, contours that 
are displayed in pencil mode will still be deleted if the command is reused, even if the 
Write mode has been switched to Pen mode.

Locate Lock
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There are several commands in InRoads that will work on either DTM Features or on 
MicroStation graphical elements (Drape Surface, for example). These commands will “look” 

for features if toggled to Locate Features   and for MicroStation elements if it is set to 

Locate Graphics. It is shown here in Locate Graphics   mode.

Point Snap

Point Snap is used primarily when creating geometry and for some surface editing 
commands.  It can lock on to COGO points or feature vertices, or it can import a 
geometry element’s length and bearing into a dialog box input field.  Point Snap has 
three modes: No Snap, Point Snap and Element Snap

 No Snap  – No affect.  This is the mode used most often.

 Point Snap  – Some geometry commands (especially cogo commands) will lock onto 
the nearest geometry point’s coordinates when you select something graphically. This is 
useful when you need to identify a PC or PT, for example.  Also, some DTM editing 
commands, such as Partial Delete Feature, will lock onto the vertices or points that make 
up the feature.

 Element Snap – In Geometry when commands require a distance or a bearing, the 
Element Snap can be used. An existing geometry element needs to be identified (such as 
part of an existing alignment) and it will read the elements length or bearing (whichever is 
required).

Station Lock

Station lock locks onto even stations in the event that the alignment does not start on an 
even station. The station will be determined by the interval that is specified. For 
example, if an alignment is stationed at 100 ft. intervals, the displays will show even 
100 ft. stations. This affects not only station displays but virtually everything that uses 
a stationing interval, such as cross sections, profiles and modeling.



Page 32 Colorado Department of Transportation

Chapter 2 - InRoads Options A Practical Guide for Using InRoads V8i SS2

Report Lock

Some commands will return information if this lock is on.  For example, if a cogo point 
is stored and the Report lock is on, a Results box will pop open showing the coordinate 
and point number of the new point. If the Results box is left open, it will keep a running 
list of messages, which can be saved to a text file if desired.

COGO Audit Trail Lock

This lock is used to create a text file of the results of all COGO commands that were 
executed.  The data stored here is the same that is displayed in the Results window, if 
the Report Lock is on.

Section Summary:
♦ The Feature Filter lock is used to limit the number of choices in surface related dialog 

boxes.

♦ The Feature Highlight Lock Shows features selected in an InRoads dialog box in the 
MicroStation view window also.  It should only be used when needed as it can be slow 
to update.

♦ The Style Lock tells InRoads to use predefined settings when displaying data.  It also 
takes away the users ability to make settings changes.

♦ The Write modes determine if InRoads graphics are updated when the command is 
rerun or not.

♦ The Locate Lock is used “snap” to either surface features or MicroStation graphics.

♦ The Snap Lock is used to “snap” to COGO points or feature vertices, or to place 
geometry element data into dialog box input fields.

♦ Station Lock forces processing to occur at even  (*+00.00) stations, even when the  
alignment starts at an odd station.

♦ The Report Lock allows InRoads to supply the user with feedback.

♦ The COGO Audit Trail lock does the same thing as the report lock, but just for COGO 
commands.

The Options dialog box

The Options dialog box contains global settings that affect the overall function of the InRoads software.  Most 
of the settings are predefined for CDOT work and do not have to be modified.  However, some settings affect 
element display and must be changed by the user to fit their needs.
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Section Objectives:

♦ Describe the Options Precision tab.

♦ Describe the Options Factors tab.

The Precision tab

The settings on this tab determine the number of decimal places InRoads displays in the dialog 
boxes.  To change the precision:

1. Select File > Project Options from the InRoads menu bar.

2. <D> the Precision tab.

3. Use the drop down menus to set the desired precision.
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4. <D> Apply to accept the change.

5. <D> Close to dismiss the dialog box.

The Factors tab

The settings on the Factors tab controls scale factors for MicroStation elements displayed by 
InRoads.  InRoads displays three element types; Lines, Cells, and Text.  Each element type has 
a Factors setting.

To access the Factors settings:

1.  Select FIle > Project Options from the InRoads menu bar.

2. <D> the Factors tab.

The Text Scale Factor and the Cell Scale Factor should both be set to the same value, equal to 
the plot scale for the drawing.  The Line Style Scale Factor should be set to 1, this is modified 
by the Annotation Scale set in MicroStation.
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To change the Factors settings:

3. Toggle the “Lock” icon open.

4. Key in the desired value for the Text Scale Factor.

5. Key in the desired value for the Cell Scale Factor.

Note: The Text Scale Factor and the Cell Scale Factor should match.

6. Key in 1 for the Line Style Scale Factor.

7. <D> Apply to accept the change then <D> Close to dismiss the Options dialog box.

Section Summary:
♦ The options dialog box contains settings used throughout the InRoads program.

♦ Users should only have to access the Precision and Factors tabs.

♦ Precision settings change the readout in InRoads dialog boxes.

♦ Factors affect the display of MicroStation elements created from InRoads.

♦ The Line Stle Scale Factor is affected by the MicroStation Annotation Scale but the 
Text Scale Factor and the Cell Scale Factor are not.

InRoads Toolbars

Section Objectives:

 Demonstrate how to access InRoads toolbars.
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Most of the InRoads commands are located on toolbars as well as on the pulldown  menus.  
These toolbars as accessed through the Tools > Customize dialog.  Toolbars can be turned on 
and off at will.  You can also create your own toolbars using the customize dialog.

Initially, toolbars are docked on the InRoads menu, but may be pulled off of it and will 
remember their last location when they are closed and reopened.

Section Summary:

 Use InRoads toolbars for easy access to commands that are used often

Chapter Summary:The InRoads locks can be used to limit items in pick lists, force the program to used 
predefined display settings, automatically update graphics when data is changed, locate 
particular data types, and adjust processing locations.

Options are used to set the precision displayed in dialog boxes and set the scale factor for 
MicroStation elements created from InRoads.
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In the CDOT process, existing ground surfaces are created by Survey and any proposed models by Design. 
When presented with either of these for the first time, it is good practice to review the surface information and 
familiarize yourself with the data contained in the surface. It is also good to double-check the surface for any 
errors or omissions before they become larger issues after the surface has been used for modeling or volume 
calculations.

Using the techniques outlined here, you can review the data in the surface and view the data graphically, both 
of which allow you to check for problems and familiarize yourself with the data.

Chapter Objectives:

 To become familiar with the process used to analyze the data in an unknown surface.

 To be able to view DTM data graphically for a visual analysis of a surface.

Reviewing Surface Data

InRoads provides useful tools for reviewing surface data, including surface point data as well 
as the properties of features and components that are contained in the surface. 

Section Objectives:

 To learn the techniques available to review surface information before viewing the data.

 To be able to spot potential issues in a surface prior to it causing major problems.

Surface Properties

The Surface Properties dialog allows you to change the name, description or preference 
associated with the surface. By accessing the Advanced tab, you can also set the named 
symbology to be used when displaying the surface ground line in profiles and cross sections. 
The Advanced tab also allows the establishment of Offsets that can later be displayed when 
creating or updating a profile.

The Surface Properties dialog is accessed from several locations including the More option on 
the Triangulate Surface dialog. It may also be accessed directly from the pull-down menu or 
from the right-click menu in the workspace bar of the InRoads menu.
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1. Select Surface > Surface Properties

On the Main tab, you can: 

2. Select a Surface from the drop-down - this is set to the active surface by default.

3. Change the Name of the DTM as it is shown in dialog boxes. This does not change the 
name of the DTM file on the hard drive. 

4. Change the Description of the surface.

5. Set the Maximum Length - see the explanation on Maximum Length in the Triangulation 
section.

6. Set a Preference. The available preferences are surface display preferences. Selecting one 
here and toggling on the Style lock forces the view commands to use this preference and 
does not allow the dialog box to display for View Contours, Triangles, etc.

7. Set the Type of the surface. The type is critical to how the surface reacts in End Area 
Volumes. Options include Existing, Design, Substratum and Ignore. For details on these 
options, see the InRoads Online Help.

8. Extended Data Checks - toggle on to check DTM integrity (during triangulation) for 
crossing breaklines and miss-matched elevations.

9. Lock Triangulation - sets the triangulation so InRoads’ commands will not automatically 
retriangulate the surface. For example, if this is a surface from survey that you do not want 
to alter, toggle this option on.

Note: Compressing the surface retriangulates it even if this option is on.
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10. The Data Range category allows you to select a type of features and review the coordinate 
range it includes.

11. The Data Totals allow you to review the numbers of points and features for each type of 
feature.

12. The Report button generates a separate window summarizing surface properties. The 
generated report can be printed, written to the CAD file, or stored as an ASCII file.
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On the Advanced tab: 

 

13. Cross Section Symbology sets the named symbology used for the display of ground lines 
on cross sections. In the CDOT XIN file, there are symbologies created for use here. 
T_Existing_Ground for the existing topo and D_SURFACE_* for design surfaces.

14. Use Features Only prevents the surface line on the cross section from following the 
triangles. Instead, it is drawn by connecting the dots between the features in the surface. 
This should typically be off for existing surfaces and on for design surfaces.

15. Profile Symbology sets the named symbology used for the display of ground lines on 
profiles. In the CDOT XIN file, there are symbologies created for use here. 
T_Existing_Ground for the existing topo and D_SURFACE_* for design surfaces.

16. Lock Symbologies will force each of the offsets to use the same symbology specified 
above.

17. The Offset category is for establishing surface offsets for display on profiles. Up to 16 
offsets may be specified by defining the offset distance - positive values for offsets to the 
right and negative values for offsets to the left of the centerline. Each offset may have its 
own symbology.

18. Choose Apply if you make any changes.

19. Choose Close.
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Feature Properties

The Feature Properties dialog allows you to review a DTM by analyzing the individual 
features, and make changes to names, descriptions, etc. 

1. Select Surface > Feature > Feature Properties.

2. Select the Surface from the drop-down.

3. The Feature list shows all the features in the selected surface along with their styles and 
descriptions.

Note: The dialog honors the active feature filter if the Feature Filter lock is on.

Important! Features that appear red indicate their Style cannot be found in the currently 
loaded XIN file. Check to see if the correct Style is associated with the feature. 
If so, check to see that the correct XIN is loaded.

4. The Name and Description of the highlighted feature may be edited.

Note: Options other than Name can be edited for multiple features at one time. Select the 
features from the list using <Ctrl> or <Shift> keys or by using the Right-click menu to 
Select All.

5. If features are edited, before choosing Apply, the Refresh/Display in Plan View option can 
be toggled on to update the graphics with the new attributes.
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6. For a listing of the coordinates for each vertex in a feature, highlight the feature and select 
List Points. This is a good way to evaluate the elevations of the feature.

See the InRoads Online Help for additional information on other options.

7. If changes are made to a feature, be certain to choose Apply.

8. Close the dialog when done reviewing the features.

Feature Selection Filters

Feature Selection Filters provide a method of segregating features for use in other commands. 
For example, if you are working with the breaklines that form a ditch, you can use a selection 
filter containing just those breaklines, then turn on the Feature Filter Lock. Future commands 
that use features will show only those specified by the filter as being available.
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Feature Filters are stored in CDOT-Preferences.ini. The CDOT configuration contains 
predefined filters.

Locks affecting Features

Filter Name – Lists the name of the Feature Filter that is currently active. It has no affect if the 
Feature Filter lock is off. If the Feature Filter lock is on, it will limit dialog boxes to showing 
only the features that are within the filter. Feature Filters are stored in the XIN file and are 
accessed by using the drop-down arrow next to the name.

Feature Filter lock – If on, activates the current filter. If off, has no affect and all surface 
features are shown in boxes that list features. Shown here in the off position.

Feature Highlight lock – If on, when you choose a feature from a dialog box, the feature will 
graphically highlight whether it is displayed in the design file or not. Shown here in the off 
position. This lock should typically be kept off; if on, the opening of dialogs that list features is 
much slower as all the features will highlight initially.
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Component Properties

The Component Properties dialog allows you to review each of the components contained in 
the selected surface. You can also make changes to the Name, Description and Style as 
necessary.

Important! The Style associated with a component determines how the component’s 
volume is categorized in End Area Volumes. Components with like Styles are 
automatically totaled in the reports.

1. Select Surface > Feature > Component Properties.

2. Select the Surface from the drop-down.

3. The Component list shows all the components in the selected surface along with their 
styles and descriptions.

Important! Components that appear red indicate their Style cannot be found in the 
currently loaded XIN file. Check to see if the correct Style is associated with 
the component. If so, check to see that the correct XIN is loaded.

4. The Name and Description of the highlighted feature may be edited and a new Style 
assigned.

Note: Options other than Name can be edited for multiple features at one time. Select the 
features from the list using <Ctrl> or <Shift> keys or by using the Right-click menu to 
Select All.

5. Select List to generate a report of the Start and Stop stations of the highlighted component 
along with a list of the features making up the component.

6. Choose Apply if there are changes made to a component.

7. Choose Close
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Interrogate Surface

Interrogate Surface is used to report information about surface components at a given 
coordinate. The command generates a report listing each component encountered at the specific 
location, including the elevation. If the component is encountered twice (for example the top 
and bottom of a lift), it is listed twice in the report, with an elevation for each occurrence. This 
command is only valid for design surfaces containing components.

1. Select Surface > Utilities > Interrogate Surface.

2. Select the Surface you want to inquire on from the drop-down list.

3. Choose Apply.

4. <D> at the location (or key in a coordinate) where you want to inquire.

5. The information on each component encountered at the location is listed in the dialog.

6. Continue Data Pointing and the report information will update with the new location 
information.

7. Choose Close.

Note: The horizontal alignment used in creating the surface must be loaded as well as the 
surface.
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Tracking

The Tools > Tracking > Tracking command allows you to move your cursor and get a 
readout of the coordinate location and the interpolated elevation, as long as you are in a 
triangulated area. By toggling on the information you want, then choosing Activate, you can 
also Data point at any location and have the information written into the design file.

 

Note that the station and offset are also available for tracking when a geometry project is 
loaded and has an active alignment.
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Section Summary:

 The Surface Properties dialog gives an overall picture of the surface in question including 
data coordinate ranges. Here, you can often spot elevations that are out of the ordinary 
range.

 Feature Properties allows the analysis of surface data on an individual feature level, 
including elevations of the vertices of features.

 Feature Selection Filters allow you to create a subset or group of features to view or 
review.

 Component Properties show the individual components that make up a surface.

 DTM issues, such as bad elevations can often be spotted using Review commands.

 If you want surface coordinate or slope information, use the Tracking tool. You can also 
write this information into the DGN file. If you have a geometry project loaded, this 
command will also provide station / offset data.



Page 48 Colorado Department of Transportation

Chapter 3 - Initial Surface Procedures A Practical Guide for Using InRoads V8i SS2

Viewing a Surface

After reviewing surface data, you may also want to visually inspect the surface data. InRoads offers several 
surface view commands that can be used to spot surface problems and to become familiar with the surface.

Section Objectives:

 To learn how the View Surface commands work in InRoads.

 To learn how to use the Locks that affect DTM displays.

 To be able to apply the appropriate preference to meet CDOT standards.

Locks affecting Surface Displays

Two locks affect surface displays.

Style lock – If Style lock is on, the dialog box for the view command is not displayed. Instead, 
the display will be executed using the active surface and the preference assigned to the surface 
in the Surface > Surface Properties dialog.

Important! If you choose one of the View Surface commands and the dialog box does not 
appear, most likely the Style lock is on.

Pen / Pencil and Delete Ink – If the Pencil mode  is selected (as shown here), the graphics 
are updated whenever the same display command is selected again. For example, if you display 
the contours, then change to a different preference and display again, the old contours are 
deleted and the new contours are displayed.

If Pen mode  is selected there are two options. If Delete Ink  is off, the graphics are not 
updated when the same display command is selected again. Instead, another copy is placed in 
the design file. If Delete Ink is on, the graphics are treated like Pencil mode and the old one 
removed before the new ones are placed.
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Viewing the DTM Perimeter

The perimeter of a DTM is an outline of the current triangles, and therefore can only be 
displayed after a surface is triangulated. It should not be confused with an exterior boundary, 
which actually limits the triangulation. However, if there is an exterior boundary on the surface, 
the perimeter will be in the same location.

1. Choose Surface > View Surface > Perimeter.

 

2. Select Preferences and choose the appropriate CDOT preference.

3. Choose Load, then Close the Preference dialog.

4. Select the Surface from the drop-down list.

5. Select Apply and the perimeter is drawn in the MicroStation file.

6. Select Close.
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Viewing Triangles

It is sometimes useful to display triangles when evaluating a surface. You can check to see if a 
feature is triangulating, if the triangles are being formed correctly or if there are erroneous or 
extraneous triangles in your model.

1. Choose Surface > View Surface > Triangles.

2. Select Preferences and choose the appropriate CDOT preference.

3. Choose Load, then Close the Preference dialog.

Note: If you are just displaying triangles for review, you may skip the preference step and use 
the default CDOT preference.

4. Select the Surface from the drop-down list.

5. The Colored Model toggle will display the triangles, and if two adjacent features share the 
same Style, the triangles formed in between the features are ‘color-coded’ according to the 
plan symbology of the Style.
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6. Select Apply and the triangles are drawn in the MicroStation file.

7. Select Close.

Note: The triangle display is a MicroStation graphic group. If you need to delete the 
triangles, they will delete as one if the Graphic Group lock is on.

Viewing Contours

The contours for a model may be displayed using the Surface > View Surface > Contours 
command. There are several preferences available in this command, depending upon the type 
of surface and contours you want to display. 

1. Choose Surface > View Surface > Triangles.
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2. Select Preferences and choose the appropriate CDOT preference. The preferences are 
named according to proposed or existing and the interval. All display major and minor 
contours and the elevation labels. In addition, the Proposed preference displays major and 
minor depression contours. The preferences also set the level for displaying the contours, 
which in turn sets the ByLevel symbology.

3. Choose Load, then Close the Preference dialog.

4. If you do not want labels, you may toggle them off.

5. Select the Surface from the drop-down list.

6. Select Apply and the contours are drawn in the MicroStation file.

7. Select Close.

For information on additional options, see the InRoads Online Help.

Note: The contour display is a MicroStation graphic group. If you need to delete the 
contours, they will delete as one if the Graphic Group lock is on.
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Viewing Features

The features for a model may be displayed using the Surface > View Surface > Features 
command. There are several preferences available in this command, depending upon the type 
of surface and contours you want to display. 

1. Choose Surface > View Surface > Features.

2. Select the Surface from the drop-down.

3. The Feature list shows all the features in the selected surface along with their styles and 
descriptions.

Note: The dialog honors the active feature filter if the Feature Filter lock is on.

Important! Features that appear red indicate their Style cannot be found in the currently 
loaded XIN file. Check to see if the correct Style is associated with the feature. 
If so, check to see that the correct XIN is loaded.

4. Highlight the feature or features you want to display. You can right-click and choose Select 
All, None or Invert the selection.
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5. Select Apply and the features are drawn in the MicroStation file, using the associated 
Style to determine the Named Symbology to use.

6. Select Close.

Note: The feature display is not a MicroStation graphic group. If you need to delete the 
features, they must be deleted individually, as a selection set, with a fence or using 
Update 3D/Plan Surface Display as described below.

Viewing Components

Components are 3D shapes created by Roadway Designer as defined in Templates. They 
typically only reside in proposed models. Since they are critical to accurate volume calculations 
when shown on cross sections, it is often necessary to view them in the design file for 
evaluation purposes.

1. Choose Surface > View Surface > Components.

2. Select the Surface from the drop-down.
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3. The Component list shows all the features in the selected surface along with their styles 
and descriptions.

Important! Components that appear red indicate their Style cannot be found in the 
currently loaded XIN file. Check to see if the correct Style is associated with 
the component. If so, check to see that the correct XIN is loaded. If not, you 
can change the Style associated with a component using Surface > Feature 
> Component Properties. 

4. Highlight the component or components you want to display. You can right-click and 
choose Select All, None or Invert the selection.

5. Select Apply and the components are drawn in the MicroStation file, using the associated 
Style to determine the Named Symbology to use.

6. Select Close.
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Update 3-D/Plan Surface Displays

The Update 3D/Plan Surface Display command is very useful for displaying surface 
information in the MicroStation file. Rather than choosing individual surface display 
commands, you can use this one command to display the perimeter, triangles, contours, 
features, etc. What makes it even more useful is the option to turn these same displays off.

The one down-side to using this command is the inability to choose a preference to control the 
display. If Style lock is off, the displays requiring a preference automatically use the Preferred 
Preference as defined by the XIN file - in this case, the preference named CDOT. If Style lock 
is on, they use the preference assigned to the surface in Surface Properties.

1. Choose Surface > Update 3D/Plan Surface Display.

2. If using a fence, select the appropriate Fence Mode.

3. Select the Surface from the drop down menu.

4. Toggle the Item or Items to turn on or off in the design file.

5. Highlighting features from the Features list displays those features in the design file.

Note: The dialog honors the active feature filter if the Feature Filter lock is on.

Important! Features that appear red indicate their Style cannot be found in the currently 
loaded XIN file. Check to see if the correct Style is associated with the feature. 
If so, check to see that the correct XIN is loaded.

6. Select Close.

Note: The feature display is not a MicroStation graphic group. If you need to delete the 
features, this is a very handy method, since you do not have to create a selection set or 
make certain they are inside a fence to delete the entire set of features at once.

Section Summary:

 The view surface commands provide a visual look at the DTM.

 Several preferences are available to ensure the displays meet CDOT standards.
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 The Update 3D/Plan Surface Display dialog is a quick interface to most of the surface 
display commands.

Chapter Summary:

 DTMs should be reviewed and checked for accuracy when presented for the first time, or 
when created.

 Existing ground DTMs are created by Survey and can be reviewed and/or viewed as a 
check and familiarization process.

 Review commands provide a means of checking elevations, features, styles, etc. without 
displaying the DTM in the MicroStation file.

 View commands display the DTM for a visual check.
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Chapter 4 - Surface Fundamentals 

A digital terrain model (DTM) is a mathematical representation of topography that includes points and 
triangles and is often referred to as a surface. The triangles allow the DTM to provide elevation information at 
any location by interpolating the elevations of the three points making up the triangle in question.

Using Delauney’s criteria, InRoads calculates the smallest triangles possible for a given set of point data. 
Delauney’s criteria states that any triangle formed may be circumscribed and no other point will fall within the 
circle. Linear features must sometimes violate Delauney’s criteria in order to hold a constant slope between 
points. In other words, linear features will not allow triangles to cross them.

You may load as many DTMs as you need into memory when using InRoads. It is typical to have several 
DTMs loaded, since you will have an original and several design surfaces (such as multiple finished grades or 
alternative surfaces). At any given time, only one surface is active, meaning it will be the default when using 
any command requiring a surface.

When a digital terrain model is saved to the hard drive, it takes on an extension of DTM.

Chapter Objectives:

 To learn what a DTM is and how it is used in the CDOT design process.

 To learn the capabilities of an intelligent DTM and what it means for a DTM’s use in 
design.

 To learn how to manipulate DTMs after they have been created.

Introduction to DTMs

Before working with either existing or design surfaces, a basic understanding is needed of what is contained in 
a surface. This section introduces you to the different DTM point types and the purpose of these points. It also 
explains the concept of intelligent features in a surface and the proper use of features styles and named 
symbologies associated with these features.

Section Objectives:

 To become familiar with the point types used in a DTM and how they affect triangulation.

 To learn the make-up of an intelligent DTM including how Features, Styles and Named 
Symbologies work together.

 To learn the basics of how a DTM is created.

DTM Point Types

Everything that is used in a DTM is a feature, and each feature is assigned a point type. The 
point type determines how the feature reacts during triangulation. Random points triangulate to 
the closest point around them, while the other, linear, features will not allow triangles to cross 
meaning they hold a constant slope between their points.

The following point types can be used in an InRoads’ DTM.

Random

 Normal topo shots
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 Often used for spot shots, local highs and lows

Breakline

 Used to represent linear features such as ditches, ridges, and edges of pavement, and named 
accordingly

 No triangles cross breaklines — they take precedence over random points

 Must have at least two points to form a breakline (lines, linestrings, curvestrings and 
complex chains are acceptable for import)

 Can be densified or thinned

Contour Points

 Use when data comes from contours, e.g., digitized from aerial maps

 Work much like breaklines with a constant elevation

 Converts lines, linestrings, curvestrings and complex chains into DTM points

 Can be densified or thinned

 Inferred breaklines

 Only used with contour points

 Generated by the software

 Eliminate flat spots by forcing a slope on every triangle

 Add overhead to your surface

Interior

 Used to model holes in your surface where there is unknown survey data or areas you do 
not want considered in the DTM

 Requires at least three points to model a closed shape

 No triangles are formed inside an interior boundary

 You can have more than one interior boundary per surface, but they can not overlap

Exterior 

 Define limits of triangulation

 Requires at least three points to model a closed shape

 There is only one exterior boundary per surface
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Surface Triangulation

In order for a surface to be used for contouring, modeling, etc., it must be triangulated. The 
original ground surface received from Survey will already be triangulated, however, if any 
changes or edits are made to a surface it will have to be triangulated again before the changes 
show up in displays of the surface either in Plan, Profile or Cross Section.

To triangulate a surface:

1. Select Surface > Triangulate Surface

Note: A surface may also be triangulated by right-clicking it in the InRoads Explorer menu 
and selecting Triangulate from the list of available commands.

2. Choose the Surface from the drop-down list

The Maximum Length prevents the formation of any triangles with a leg longer than what is 
specified. This is useful for eliminating long, slender extraneous triangles that often appear 
around the edges of a surface, but care must be taken that the value entered is not small enough 
to prevent the formation of ‘good’ triangles in the middle of the surface. If the value is set to 
0.00, it is ignored and all triangles are formed.

Extended Data Checks evaluate the surface for crossing or overlapping features. Leave this 
toggle off for faster processing unless you receive an error when triangulating.

3. Apply and the surface is triangulated. 

4. Results show you the numbers of points and triangles formed, as well as the elapsed time. 
For more information, <D> the More button to access the Surface Properties dialog box.
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Intelligent DTMs

InRoads’ digital terrain models are intelligent models. By using Feature Names, Feature 
Styles and Named Symbologies as described below, the models will know what types of 
features can be displayed in which views as well as the symbology to use for displays.

Feature Names

Everything in a DTM is a feature and every feature must have a unique name. Often, when 
creating new features, you will be asked to supply a Seed Name. This seed name is used as the 
base for a unique feature name. For example, if you use creek as the Seed Name, and you load 
more than one (with a level or selection set, for example) the second will be named creek1, 
third creek2, etc.
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A feature can be either triangulating, such as breaklines representing ditches, centerlines, etc. 
or it can be non-triangulating, such as utilities that are below or above the ground surface. 
These types of non-triangulating features can be shown on cross section, profiles and in plan 
view without affecting the triangulated network.

Feature names are stored within the DTM.

Feature Styles

Feature Styles are assigned to features in the DTM. They control where and what the features 
is “allowed” to display, as well as assigning a named symbology. For example, when you 
assign a feature style to a feature, you are determining if it can be displayed in plan using lines, 
points and/or annotation; if it can be displayed in sections using points and/or annotation, etc.

Feature Styles are stored in CDOT-Preferences.ini.

Named Symbology

Named Symbologies are just what they sound like — setups, such as color, weight, line style, 
font that can be saved by name. They even go one step farther allowing these setups to share a 
name while establishing different symbologies for plan, cross sections and profiles. This way, 
one entity that uses a named symbology can still display using different setups in plan vs. cross 
section vs. profile. Just about anywhere you assign symbology, you can use a named 
symbology instead. CDOT named symbologies are setup to use ByLevel symbology.

Named Symbologies are stored in CDOT-Preferences.ini.

Creating a DTM

In the CDOT Process, the existing ground DTM is provided by Survey and proposed DTMs are 
created by InRoads tools such as Roadway Designer. However, there may be times when you 
may have to create or supplement one of these DTMs. If so, the data used to create the DTM 
may be in one of several formats. The most common formats are described below.

ASCII (text) Files

ASCII data can be loaded from several different formats. Using File > Text Import Wizard, 
you can specify the format for your data. This wizard takes you through the import process step 
by step. Some commonly used formats include:

 x,y,z

 northing, easting, elevation

 station, offset, elevation (baseline alignment required)

Note: These formats can have additional columns for ‘pen-up, pen-down’ to define separate 
linear elements in one file, for feature names, features styles, etc.

See the InRoads Online Help for additional information.
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Surface from graphics

Graphical data is sometimes used to generate existing or proposed surfaces using 
File > Import > Surface > From Graphics. When using graphics, some key points are 
listed below.

 Elevations may be taken from the element or from surface (if the surface has been 
triangulated already).

 Elevations may be taken from text if you’re loading random points that are graphically 
displayed in the correct location, with text listing the elevations.

 Linear features that contain curves can be densified using the chord height tolerance (set 
under Tools > Options > Tolerances).

 Linear elements can be densified by setting a maximum segment length or a point density 
interval.

 Points on linear elements can be thinned upon input using the Thin (and Tolerance) option.

See the InRoads Online Help for additional information.

In the Surface Editing Tools chapter of this document, you will find additional information on 
creating features using a variety of tools.
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Section Summary:

 Random points are for local high/low topo shots.

 Linear features in a DTM ensure a constant slope between the feature points.

 Exterior and Interior features limit the location of triangles (an exterior forms a boundary 
and an interior forms a hole).

 Each feature in a DTM has a unique name.

 Features are named to make them intelligent.

 Styles control where a feature can display and assign it a named symbology for it’s 
graphical attributes.

 Feature Styles and Named Symbologies are stored in CDOT-Preferences.ini.

 You can supplement a DTM with data from text files (ASCII) or from MicroStation 
graphics.
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DTM Utilities

There are several DTM utilities that allow you to manipulate the DTM after it has been created, both internally 
in InRoads memory and externally on the hard drive.

Section Objectives:

 To learn how to manipulate a DTM as a whole.

Active Surface

When you access commands in InRoads that require a surface, they always default to the Active 
surface. In most cases, you can simply use a drop-down in the command's dialog box to change 
to a different surface. However, in some circumstances you are not given that opportunity. Two 
examples include: 

 when Style lock is on and you use a View Surface command, and 

 when you use Apply Template with a template whose end condition seeks the Active 
Surface.

In these cases, you must first set the Active surface.

1. Select Surface > Active Surface.

2. From the list of loaded surfaces, highlight the one you want.

3. Choose Apply.

4. Choose Close.

An alternate method is to right-click on the surface in the workspace or explorer portion of the 
menu and select Set Active.

Note: The active surface is shown in the menu with a red box around the surface icon.
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Copy Surface

InRoads’ surfaces have a name that is used in all the dialog boxes (the internal name) and a 
name that is used on the hard drive (the external name). Although it is recommended, these two 
names are not required to match. However, you cannot have two surfaces loaded that are seen 
as being the same. Therefore, if you copy a surface on the hard drive, InRoads does not realize 
that it is a separate surface. If you load the original and the copy, it will assume you’re loading 
the same surface twice and will ask if you want to overwrite the first one loaded. Instead of 
making the copy in this manner, use the Copy Surface command inside InRoads.

1. Select Surface > Copy Surface.

2. Select the Surface you want to copy with the drop-down list in the From category.

3. In the To category, specify a Name, Description and Preference for the copy. (This is the 
internal name.)

4. Choose Apply.

5. Choose Close.

The new surface should now be saved to the hard drive. See the section on Saving Surfaces for 
additional details.
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Delete Surface

The Delete Surface command removes a surface from memory, but does not affect the surface 
on the hard drive. If you are using the Create Surface option within Roadway Designer, you do 
not have to delete the surface. Instead toggle on Empty Surface and it will remove the data 
from the surface before creating the new model. The Delete Surface command should be used 
when you are through with a surface but are not ready to exit InRoads, or if you want to re-use 
the name of a surface, but do not need its current contents.

1. Select Surface > Delete Surface.

2. Select the Surface you want to remove from memory from the list of loaded surfaces.

3. Toggle on Delete Surface Contents Only if you want to keep the name and other surface 
attributes but not the features.

4. Choose Apply.

5. Choose Close.

An alternate method is to right-click on the surface in the workspace or explorer portion of the 
menu and select Close to completely remove the surface from memory, or Empty to remove 
only the contents.
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Rename Surface

The Rename Surface command is used to change the internal name of a surface. It also allows 
you to change the Description and Preference associated with a surface.

1. Select Surface > Rename Surface.

2. Select the Surface you want to rename from the drop-down list in the From category.

3. Key in the new name in the To category.

4. Change the Description and/or Preference as desired.

5. Choose Apply.

6. Choose Close.

The surface should be saved to the hard drive after making the change.

Important! Do not use the rename command to make a copy of a surface. For example, do 
not rename a surface and then try to load the original surface again. InRoads 
still sees the surfaces as the same and will not allow both to be loaded. Instead, 
use Surface > Copy Surface.
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Save Surface

Surfaces can be saved using several methods including:

 Choose File > Save > Surface
The active surface is saved.

 Right-click on the Surface in the Explorer menu and chose Save 

The surface you highlighted is saved.

If the surface has never been saved, either of the above methods will bring up the Save > As 
box as shown below.

1. Choose File > Save As

2. Set the Files of Type to *.dtm

3. Choose the Active surface you want to save

4. The File name field should populate with the active surface name. If you want the hard 
drive name to be different, key in the File name

5. <D> Apply.
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Note: Surfaces have both an internal name that appears in the dialog boxes in InRoads and a 
name on the hard drive that has a .dtm extension. It is recommended that these names 
be the same, and care should be taken to make certain you have chosen the correct 
surface name to match the file name you specify. Otherwise, you could accidentally 
save over a file on the hard drive with the wrong surface.

The surface may also be saved as part of the project or RWK file.

Section Summary:

 The active surface is the default one used in many commands, but can typically be changed 
with a Surface drop-down option in the command.

 If Style lock is on, the active surface is more critical for View commands, since the 
command only works on the active surface.

 Surfaces can be renamed, but InRoads still sees the surface as the same one.

 Surfaces can be copied, in which case InRoads sees them as different surfaces.



Page 72 Colorado Department of Transportation

Chapter 4 - Surface Fundamentals A Practical Guide for Using InRoads V8i SS2

Chapter Summary:

 Intelligent DTMs are critical to the CDOT design process.

 Existing DTMs are created by survey and provide the basis for modeling proposed 
surfaces.

 Existing and proposed DTMs are used to compute volumes.
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Geometry describes the path that the proposed roadway will follow over the existing ground. This chapter 
covers the geometry file structure for various specialty groups, geometry management concepts, and some of 
the tools to view, review, and  edit geometry.

Chapter Objectives:

 Review various geometry file structures.

 Examine the Style Manager.

 Discuss geometry file management.

 Describe how to set geometry active.

 Review the Copy, Rename, and Delete geometry commands.

 Describe how to display a variety of horizontal geometry items into the MicroStation file.

 Describe how to use Tracking.

Geometry Data Review

Section Objectives:

 Describe the types of data available from survey geometry.

 Describe the  hierarchy within a geometry project.

 Describe the layout of typical geometry project for various specialty groups.

Geometry Data from Survey

Survey data will be used as a foundation for our initial geometry work. The survey staff exports 
linear elements from the survey fieldbook as alignments and Cogo points at all survey shot 
locations. This data may be used for:

 Establishing the centerline of existing roadways

 Flow-lines of existing stream or other drainage

 Locations of existing retaining walls or bridge geometry

 Locations of existing signs or utilities

 Existing pavement limits or curb and/or gutter locations

The goal is to review some of the geometry data the survey staff produces.

The Geometry Project

The geometry project, commonly referred to as the ‘ALG’ file, is the data file that stores 
horizontal and vertical alignments, and cogo points (called the cogo buffer). An older geometry 
file may also contain superelevation data.

The hierarchical relationship between the data stored in a geometry project is illustrated below.
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Generic Geometry Project

Multiple geometry projects can be loaded into memory. However, only one geometry project 
can be active at a given time. Within the active geometry project, a single horizontal and a 
single vertical alignment can be active at any given time.

Sample Roadway Design Geometry Project

A typical design geometry project may contain horizontal alignments for the mainline, side 
roads, ditches, or alternative designs. Each horizontal alignment may have associated vertical 
alignments and superelevation solutions.
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Sample Survey Geometry Project

(Exported from a Fieldbook)

Sample Cogo Buffer Contents

A typical geometry project generated from a survey fieldbook will contain Cogo points for 
each point surveyed. These Cogo points are indexed with the shot number recorded in the field 
during collection. In addition to the Cogo points, horizontal and associated vertical alignments 
are created for each linear feature surveyed in the field such as; edge of oil, ditch or stream 
shots, or centerline shots. These alignments inherit their name from a combination of the 
survey collection code and an incremental index number.
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Sample Right of Way Geometry Project

A typical Right of Way geometry project may contain only Cogo points and horizontal 
alignments. The horizontal alignments may represent existing or proposed ROW limits, 
easement limits, section lines, and parcels. A parcel is defined as an alignment that closes on 
itself.

Section Summary:

 The Survey groups collects and stores a variety of terrain information as geometry. This 
data can be useful when developing a design project.

 The hierarchy within an alg file is, from top down: Geometry Project, Horizontal 
Alignment, Vertical Alignment

 The Cogo Buffer is on the same level as horizontal alignments in the hierarchy, but has no 
children. However, cogo points contained in th ebuffer can be used to define a horizontal 
alignment.

 The data created and stored in a geometry project may be different or have different uses 
for each specialty group, but the hierarchy  will remain the same.
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Geometry Terminology and Attributes

Section Objectives:

 Describe the various type of geometry data.

Terminology of Geometry Data Types

 Geometry Project - All geometry, whether it’s horizontal, vertical, or cogo points is stored 
in a single digital container called a Geometry Project. To put it another way, individual 
horizontal, vertical, or cogo points cannot be written to disk by themselves, only within a 
geometry project. The same is true for loading data; only geometry projects can be loaded, 
not individual alignments.

 Cogo Point - Store the x, y, and z coordinate for a specific point. The information is in the 
following format: name, x, y, and z

 Horizontal Alignment - describes a horizontal path through the project

 Vertical Alignment  - describes a vertical path through the project

 Geometry Styles - Geometry Styles are saved settings that can be assigned to a geometry 
alignment or cogo point. The Geometry Style definition stores how the alignment or cogo 
point will be displayed in the CAD file. Geometry Styles can be assigned to Points, Lines, 
Arcs, and Spirals; each style will have settings for planimetrics and annotation display. The 
Geometry Styles are defined in the Style Manager dialog box.

Style Manager – Overview

The Style Manager is used to create, edit, and delete the Geometry Styles for Points, Lines, 
Arcs, and Spirals. The symbology is edited through the Named Symbology Manager which can 
be accessed from the Style Manager. Because the styles for surface features, survey features, 
and geometry are all stored in the xin file, the Style Manager Has filters to segregate the 
different types of styles.
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 Select Tools > Style Manager

Geometry Point Symbology

Geometry Point Symbology is a saved setting for horizontal and vertical alignment keypoints 
(vertices). Each vertex will be defined in the alignment as 1of 33 possible alignment keypoints 
such as: POB, PC, PI, PT, TS, PVT, PVT, etc. Each Geometry Point can be saved as a point 
Symbol Font or Cell definition depending on the annotation settings.  geometry point 
symbology is stored in the xin file and is accessed through the Named Symbology Manager.

Section Summary:

 There are three types of geometry data in InRoads V8i: Cogo Points, Horizontal 
Alignments, and Vertical Alignments. InRoads 2004 also has Seperelevation in the 
geometry project.

 Geometry, surface feature, and survey styles are all stored in the xin file.  Filters can be 
used to isolate the geometry styles.

 Editing the xin file (through Style Manager or Named Symdology Manager) is only 
temporary. The edited attributes will be changed back the next time you log into your 
computer.

Geometry Management

Section Objectives:

 Discuss when it is appropriate to create unit specific geometry projects.

When the Survey/ROW group exports geometry from an InRoads Survey Fieldbook, the Geometry Style 
assigned to the geometry element is based on the InRoads Feature Style assigned to the surveyed element. If 
the associated Geometry Style is not found, the Style Default is used. After exporting, the user can change the 
geometry style associated with existing geometry and apply appropriate symbology. This is true if working 
with geometry generated from field survey information or from geometry created in the design process.

As standard procedure, CDOT may wish to direct each discipline to maintain independent geometry projects 
for specific projects. By doing so, the various disciplines would be responsible for maintaining their data and 
also be responsible for coordinating with other workgroups to ensure everyone is working with the correct 
foundation geometry.

Possible scenarios:

 When Survey exports the fieldbook to a geometry project it is stored in: 
Drive:\JPC#\ROW\InRoads\Geometry\ as JPC#FB2006_02_06_A.alg (FieldBook A dated 
February 06, 2006 or otherwise named)

 Design may have use for selective items such as the centerline of road, fences, utilities, etc. 
as alignments and/or Cogo points, but not need or want alignments and Cogo points for 
every single observation taken in the field. For efficiency, not to mention segregation of 
data, the roadway design discipline may wish to store the alignments they develop in: 
Drive:\JPC#\DESIGN\InRoads\ as JPC#Design.alg (or otherwise named)

 Hydraulics or Traffic may desire alignments for drainage structures, waterways, or 
pavement design or marking. There may be no need for Design or Survey to access this 
data and vice versa.
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Segregating geometry by discipline specific geometry projects lessen the possibility of loss of data through the 
regeneration of data. If the survey staff collects additional data or otherwise makes edits to the electronic 
fieldbook, they will have to re-export (regenerate) the Geometry Project to provide current information. In 
doing so, the possibility exists to over-write geometry created by other means.

Additionally, allowing individual disciplines the ability to create geometry as needed eliminates the task of 
managing who has read/write access to a single ‘master’ geometry project and when access would be available. 
However, it does raise the issue of communication. If the disciplines are dependent on geometry information 
developed by others, it is imperative that down-stream users of that information are consulted and notified of 
relevant changes.

Section Summary:

 Each specialty group should maintain there own geometry file for a specific project.  This 
reduces the possibility of data being changed or lost due to the actions of someone else.

 Maintaining seperate geometry projects requires good communication between all groups 
involved with the project so that no one is using inaccurate data.

Geometry Management Tools

Section Objectives:

 Describe how to set geometry active.

 Discuss the Copy, Delete, and Rename Geometry commands.

 Describe how to save geometry.

Setting Active Geometry

In order to use an alignment for commands like Tracking or placing MicroStation elements 
with station/offset key ins, the desired alignment must be set active. The active geometry is 
identified in the InRoads Explorer by a red box around the geometry’s icon.

A geometry project or alignment can be set active by:
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1. Select Geometry > Active Geometry from the InRoads menu bar. This displays the 
Active Geometry dialog box.

2. In the Active Geometry dialog box, set the geometry Type using drop down menu.

3. Highlight the desired geometry from the list at the bottom of the dialog box.

4. <D> Apply to make the geometry active. 

5. Reset the Type as needed to select different levels of geometry to set as active. <D> Close 
to dismiss the the Active Geometry dialog box when finished.

Geometry can also be set active by accessing the right click menu from the InRoads Explorer.

1. <D> the Geometry tab at the bottom of the InRoads Explorer.

2. <R> on the desired geometry.
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3. Select Set Active from the right click menu.

Copy Geometry

Copy Geometry can be used to copy geometry from within the same geometry project, or 
from project to project.



Page 82 Colorado Department of Transportation

Chapter 5 - Inital Geometry Procedures A Practical Guide for Using InRoads V8i SS2

Delete Geometry

Delete Geometry removes the selected geometry from the internal memory.  If the 
geometry project is then saved, the deleted data will be removed from the hard drive as well. 
The Delete Contents Only toggle deletes the data but retains the placeholder within the 
geometry project.

Rename Geometry

Rename Geometry is used to change the name of a geometry project or individual 
alignment. It is also used to add/modify a description and change the style attached to the 
selected geometry.
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Saving an Alignment

Alignments are not saved individually. Instead, they are saved when the geometry project is 
saved.  Since you are working on a copy of the geometry project that is loaded in memory, 
saving is a good idea whenever you make changes to your alignment, and mandatory before 
exiting – assuming you want to save your changes.

Geometry projects can be saved using several methods including:

Choose File > Save > Geometry Project

The active geometry project is saved.

Right-click on the Geometry Project in the Explorer menu and chose Save 

The geometry project you highlighted is saved.

If the geometry project has never been saved, either of the previous methods will bring up the 
Save > As box shown below.
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Choose File>Save As

Set the Files of Type to (*.alg)

Choose the geometry project you want to save (in the Active category)

Key in the file name (or use the default)

Choose Save and the file is saved.

Note: Geometry projects have both an internal name that appears in the dialog boxes in 
InRoads and a name on the hard drive that has an .alg extension. Care should be taken to make 
certain you have chosen the correct geometry project name to match the file name you specify. 
Otherwise, you could accidentally save over a file on the hard drive with the wrong geometry 
project.

The geometry project may also be saved as part of the project file or .rwk, which you will be 
using in your lab activity.

Section Summary:

 When InRoads commands, other than Roadway Designer, reference geometry, they will 
look at the active geometry only, unless the dialog box being used has an option to specify 
other geometry.

 The Copy, Delete, and Rename Geometry commands wonk on whole geometry items only 
(Geometry projects, horizontal anilgments, or vertical alignments).  The tools to edit 
alignment components are discusse din th enext chapter.

 Be careful when saving a geometry project, the name seen in InRoads does not have to be 
the same as the one on the hard drive.

Viewing Horizontal Geometry

Section Objectives:

 Describe the methods to individual view horizontal alignments.
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 Describe how to view all of the horizontal alignments in a geometry project at once.

 Describe the View Stationing command.

 Describe the Veiw Horizontal Annotation and Curve Set Annotation commands.

Horizontal geometry is used as a reference line for determining stations and offset distances in a set of design 
plans. In InRoads, viewing a horizontal alignment places graphic elements representing that alignment into the 
MicroStation dgn file. The various methods od displaying horizontal geometry information are described 
below.

Viewing the Active Horizontal Alignment

To display the active horizontal alignment into the MicroStation dgn file:

1. Select Geometry > View Geometry > Active Horizontal from the InRoads menu 
bar.

An alignment can also be viewed (displayed) from the right click menu.

1. <D> the Geometry tab at the bottom of the InRoads Explorer.

2. <R> on the desired geometry.
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3. Select View from the right click menu.

Note: Using the right click menu to view an alignment also sets that alignment active.

Viewing All Of The Alignments In A Geometry Project

All of the alignment within a single geometry project can be displayed at one time.  To view all 
of the horizontal alignments in the active geometry project:

1. Select Geometry > View Geometry > All Horizontals trom the InRoads menu bar.

All of the alignments within a geometry project can also be viewed (displayed) from the right 
click menu.

1. <D> the Geometry tab at the bottom of the InRoads Explorer.

2. <R> on the desired geometry project.
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Select View All Horizontals from the right click menu.

Note: Using the right click menu to view all horizontal alignment sets the selected 
geometry project active.

Displaying Stationing

To display the stationing of an alignment in the design file, select Geometry > View 
Geometry > Stationing.  There are several standard CDOT preferences to choose from, 
depending upon the type of alignment you’re stationing as well as the station interval. Choose 
the appropriate preference, then Apply to see the stationing. The Station lock, if on, will force 
the display to even stations.

View Horizontal Annotation

Depending on the options selected, the user can define which alignments or Cogo points are 
annotated. This dialog is accessed by selecting:

Geometry > View Geometry > Horizontal Annotation
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Main Tab

Apply Style Section Section - This section is used to determine the style used for the 
annotation.

Assigned - This option uses the geometry style assigned to the alignment or cogo point.

Active - This option uses the styles selected in the drop down menus in this section.

Override - If the Active option is selected, selecting Override will use styles selected in the 
drop down menus in this section. In addition, the style assigned to the geometry element is 
changed to the active style.

Horizontal Alignments Section - This area is used to select the alignment(s) to be annotated.

The Include field is used to specify the desired alignmnet(s). Wildcards can be used to select 

multiple alignments. An alignment can be selected graphically using the target  button.

Cogo Points Section - This area is used to select the cogo points to be annotated.

The Include field is used to specify the desired cogo points. Wildcards and point ranges can be 

used to select multiple points. A cogo point can be selected graphically using the target   

button.

Selected Section ‐ These areas show the items that will be annotated.  Alignments and cogo 

points can be annotated at the same time
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Display as Complex Linestring - When on, the alignment is displayed as a complex linestring 
(a single graphic element).  When off, each element of the alignment is a seperate graphic 
element, though they are part of the same graphic group.

Display Section - This area is used to specify the types of points  and alignment elements to be 
displayed.

 Points -  When toggled on, the points symbols for the indicated point types are displayed.

♦ On-Alignment - POB, POE, PC, and PT are examples of on-alignment points.

♦ Off-Alignment - PI, and CC are examples of off-alignment points.

♦ Event Points - These are “stations of interest”  that the user adds to the alignment.

♦ Station Equations - These alter the normal stationing of the alignment, usually to 
match that of another alignment.

 Elements - When toggled on, the indicated alignment elements are displayed.

♦ Radials - Lines from the center of curve (CC) to the PC and PT.

♦ Chords - A line from the PC to the PT.

♦ Tangents - This is the line from the PC or PT to the PI.  For a compound or spiral curve 
it is from the PC or PT on the end curve to the PI on the main curve.

♦ Subtangents - This is the line from the PC or PT to the PI.  IT is displayed for each 
curve element in a compound curve.

Annotate Section - This section is used to identify what geometry element types will be 
annotated and how it will look.

Points - Text on/off for alignment keypoints or Cogo points

Elements - Text on/off for Bearing & Distance annotation

Dual Dimension - Imperial and Metric annotation

Try Alternate Styles - On/off for using alternate geometry styles

Extend Beyond Element - The annotation is placed even if it does not fit within the 
extents of the element. This applies only to lines and circular arcs and to annotation 
placed along the element.
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Tabling Tab

The CDOT configuration is not set up to use tabling, so this tab is not described.
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Styles Tab

The Styles tab is used to specify the display properties of geometry points and elements.  The 
styles specified here are used to display all point symbols, and if specified, for element and 
annotation styles as well. 

Point Section - This area is used to specify the style used for the following geometry points:

PC - point of curvature SPI - spiral point of intersection

PI - point of intersection PCC - point of compound curvature

CC - center of curvature PRC - point of reverse curvature

PT - point of tangency SS - spiral spiral

TS - tangent to spiral POB - point of beginning

SC - spiral to curve POE - point of ending

CS - curve to spiral ST - spiral to tangent

Event Points Station Equations

Override Point Stype with Alignment Style - When selected, the annotation text of points is 
displayed using the alignments style.  The point symbol uses the style specified above.  When 
toggled off, the style specified above is used for both the point symbol and the annotation.

Display Alignment Points Similar to Cogo Points - When selected, alignment points are 
displayed using the Cogo point style.
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Element Section - This area is used to specify the style used for the following geometry 
element types:

Radials Cords

Tangents            Subtangents

Override Element Style with Alignment Style - when selected, geometry elements are 
displayed with the alignment's style. When toggled off, they are displayed with the 
style specified above.

Curve Set Annotation

Annotating horizontal alignments to the CDOT standard is a two step process covered in the 
CDOT Annotating Horizontal and Vertical Alignments workflow. The process uses the 
Horizontal Annotation command described above to annotate the linear geometry segments.  
Curve Set Annotation is used to annotate circular and spiral curves.

To annotate the curves on an alignment, select Geometry > View Geometry > Curve Set 
Annotation from the InRoads menu bar.

General Leaf

Settings on the General leaf are used to specify what part of the alignment is annotated.

 Station Limits - Determines where along the alignment that annotation will occur.  When 
toggled off, the whole alignment is annotated.  When on, only curves within the station 
extents are annotated.

 Annotate Each Element of Curve Set - When on, each part of a compound curve is 
annotated as a seperate entity.  When off a compound curve is annotated with one set of 
curve data for the whole curve set.
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 Drop Station Equation Name -  Station equations have an alph(letter) component to the 
station.   When this toggle is on, the alph component of the station is dropped from the 
annotation display.

Annotation Leaf

The Annotation leaf is used to specify what information is included in the annotation. The 
toggle headings describe what will be annotated.  The columns prrform the following 
functions:

 Column - This determines the postition of the annotation.  1 is the leftmost column moving 
to the right as the numbers increase.  These are not absolute column numbers, however.  
They indicate the order in which the data is placed when two or more items occupy the 
same row.
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 Row - With the Column entry, this determines the postition of the annotation.  1 is the 
topmost row moving to the down as the numbers increase.  These are not absolute row 
numbers, however.  They indicate the order in which the data is placed when two or more 
items occupy the same column.

 Prefix - this is text added to the front of the data.

 Suffix - this is data added to the end of the data.

 Precision - This determines the number of decimal places displayed for the data.

 Format - Specifies the style that station and slope data is doisplayed.

Note: columns are seperated by a single space.  Therefore, additional editing may be 
required to make the annotation more readable if multiple columns are used.

Section Summary:

 Annotating an alignment to the CDOT standard is a two step process.  Refer to the, “CDOT 
Annotating Horizontal and Vertical Alignments” workflow for details on this process.

 Point Symbology for horizontal annotation is taken from the Styles tab and not the 
alignment.

Reviewing Geometry

The data within a geometry project can be accessed in ways other than by displaying it to MicroStation. The 
most common is Review Geometry.

Activating the Review Geometry Command

To review a horizontal alignment select Geometry > Review Horizontal from the InRoads 
menu bar.
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The Review Horizontal Alignment dialog box can also be displayed by right clicking on the 
alignment in the InRoads explorer or information panels and selecting Review from the menu.

Once the Review Horizontal Alignment dialog box is displayed, different alignments can be 
slelcted for review. Use the Geometry Project and Horizontal Alignment drop down menus to 
select the desired alignments.

Alignments can be viewed in one of three different Modes. The most commonly used mode is 
Alignment, which displays all of the data in one window.  The other two modes  are Curve Sets 
and Element. Examples of each mode are shown below:
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Alignment Mode:

Curve Sets Mode:
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Element Mode:

Note: The Element Mode activates the navagation buttons on the right side of the dialog box. 
These are used to select different alignment elements for viewing.

Section Summary:

 Use Review Geometry to become familiar with the different alignments in the project.

 When using the Element Mode,  the alignment element represented by the data in the 
dialog box is also highlighted in the MicroStation view window.

Tracking

Tracking is used to obtain location information about MicroStation elements in relation to the active horizontal 
alignment.

Section Objectives:

 Describe general Tracking.

 Describe Horizontal Alignment Tracking.

There are two methods of tracking a horizontal alignment.
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Tools > Tracking > Tracking – Tracks both the active horizontal alignment and the active 
surface.  After applying the command, data point a location in the design file and the requested 
information is displayed graphically.  The listed elevation is read from the surface at the cursor 
location, not at the alignment.

Settings

The Settings button is used to display the Tracking Symbology dialog box.  It is used to turn on 
or off the data types displayed in the Tracking dialog box. It is also used to define the 
symbology for tracking data displayed in the MicroStation dgn file.

Displaying Tracking Data

To display the data in the Tracking dialog box to the MicroStation dgn file, <D> on the desired 
location. To select an exact point on a grapic element, <T> to the desired point then <D>.
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Tools > Tracking > Horizontal Alignment – Tracks the horizontal alignment with a 
perpendicular line to your cursor. Gives a Station, Offset, Elevation readout in the message 
field, where the elevation is read from the active vertical alignment at the given station, not 
from the DTM.

If a second horizontal alignment is selected, the offset will be between the two alignments, 
perpendicular to the first.

Section Summary:

 Both tracking options report stations relative to the active alignment.

 General Tracking gives elevation data based on the active surface, Horizontal Alignment 
Tracking gives elevation data based on the active Vertical Alignment.

 General Tracking data can be displayed into the MicroStation dgn file.

Chapter Summary:

 The Geometry Project contains Horizontal Alignments, Vertical Alignments, and Cogo 
Points.

 Multiple geometry projects can be loaded at one time, but only the active project will be 
accessed by the program when executing a command.

 Geometry Styles are stored in the CDOT_Civil.xin file along with Survey and Surface 
styles.  Changes to the styles should be requested through the CADD Manager’s office.

 The Copy, Rename, and Delete Geometry commands work on geometry projects and 
horizontal and vertical alignments as a whole.  To learn about modifying alignment 
elements, see Defining Horizontal Alignments. 

 Viewing geometry writes the data graphically into the MicroStation dgn file.

 Viewing annotation writes text data about the alignment into the MicroStation dgn file.

 The review geometry command displays alignment data in a dialog box.  The data in the 
dialog box can be written to a text file.

 Tracking is used to identify station locations of items displayed in the MicroStation dgn 
file. With general Tracking, the data can be written into the dgn file.
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Chapter 6 - Defining Horizontal Alignments 

InRoads provides a number of options to create new alignments and modify existing ones. This chapter 
examines the most common methods for defining horizontal geometry.

Chapter Objectives:

 Outline the typical work flow for creating horizontal geometry.

 Explain how to create new geometry placeholders.

 Discuss the Horizontal Curve Set commands.

 Describe the Horizontal Element tools.

 Explain how to import an alignment from a graphic element.

 Give an overview of Cogo commands.

 Discuss some of the useful tools in the Geometry Utilities menu.

Creating Geometry

There are multiple methods for creating horizontal geometry in InRoads. These methods include: Horizontal 
Curve set commands, Horizontal Element commands, Importing various text files, Importing from graphics, 
various Cogo commands, and Creating parallel/offset alignments.

Section Objectives:

 Discuss InRoads Options that affect geometry.

 Describe how to add data to the Cogo Buffer.

 Describe the Horizontal Curve Set PI commands.

 Describe the Horizontal Curve Set Define Curve command.

 Describe the Horizontal Curve Set stationing commands.

 Give an overview of the Horizontal Element commands.

 Describe Importing an alignment from graphics.

 Give an overview of the Cogo commands.
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Options

A review of the geometry options from InRoads Options relative to geometry are found from 
the menu bar under File > Project Options [Geometry] tab.

Dialog Items

 Plotting Height: - The elevation for drawing horizontal geometry

 Seed Alignment Name: - Initial name assigned to newly created geometry unless specified 
otherwise.

 Seed Point Name: - Initial name assigned to new cogo points.

 Curve Definition:  -

♦ Horizontal: - Arc or Chord definitions

♦ Vertical: - Parabolic or Circular

♦ Measure:  -Along arc or along chord for curve definition

♦ Degree of Curve Length: - Specifies central angle that subtends this distance

♦ Unit Station Length: - Distance between major station intervals

 Define Transitions: - Defines spiral transitions by Length or Spiral constant

 Spiral Definition: - Defines default method for defining spiral transitions

 ICS Coordinate Sequence: - Defines input order of Northing/Easting’s for ICS batch input 
files.

 Vertical Angle Reference: - Defines vertical angle measurement in ICS files.
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 Angular Mode: - Specifies orientation for angles

 Point Name During Edits: - Defines whether names are assigned to geometry points 
during creation or editing.

 Default Access Modes- Specifies if the access to the geometry data is read only or read/
write.

♦ Horizontal Alignments -  Used to specify if the horizontal alignments are read only or 
read/write.

♦ Cogo Buffer -  Used to specify if theCogo Buffer is read only or read/write.

About geometry point names

Alignment key-points (PC, PI, PT, CC, etc) exist in one of three states:

 Unnamed

 Named

 Cogo Points

Reviewing an alignment displays the geometry point name. The above screenshot shows both 
named and unnamed points.

If Point Name During Edits is set to Named on the Options > Geometry menu; alignment key-
points are generated with a name based on the next available ID as specified in the Seed Point 
Name field. The specified seed point name can be alpha, numeric, or alphanumeric characters. 
The assigned name is also reserved in the Cogo buffer. However the point is not written to the 
Cogo Buffer automatically.
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Writing the active alignment keypoints to the Cogo 
Buffer

Select Geometry > Horizontal Curve Set > Events

In the above example, all alignment key-points that were not previously assigned a name are 
written to the Cogo buffer beginning with the ID number of 200.

Note: The command Geometry > Utilities > Assign Names can be used to add, delete, 
or rename geometry points. 

Typical Workflow

A predefined workflow for creating geometry is not dictated by InRoads. However, a common 
workflow might be:

1. Create or open an existing geometry project

2. Create horizontal alignments (or Cogo points)

3. Assign stationing for alignments
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4. Define alignment station equations, if any

5. Define alignment key-points (unique points of interest)

6. Review alignments

7. View created alignments

8. Display stationing for alignments

9. Annotate created alignments

10. Graphics clean-up

Creating New Geometry

In order to create a new alignment, you must first have a geometry project loaded. If you need 
to create a new one, choose File > New > Geometry set the Type to Geometry Project 
and enter a Name and Description.

Once the geometry project is loaded (and active), you may create a new alignment name. Select 
File > New > Geometry (if you have closed the dialog) and set the Type to Horizontal 
Alignment. Enter the Name, Description and select a Style.

Apply after filling in the appropriate information, then you may proceed with either the 
Horizontal Curve Set or Horizontal Element tools to enter the alignment data.
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Horizontal Curve Set commands

The Horizontal Curve Set commands make up an easy way to create alignments. They consist 
of five primary commands described below, and may be access from a toolbar (shown) or from 
the pulldown under Geometry > Horizontal Curve Set.

Add PI – Add PI is used to create a PI that begins a new alignment, or to add a PI onto either 
end of an existing alignment.

Insert PI – Insert PI is used to add a PI to an existing alignment between two existing PIs.

Move PI – Move PI is used to change the location of an existing PI.

Delete PI – Delete PI is used to remove a PI from an existing alignment. For removing more 
than one PI, you must choose and Accept each one individually. To remove all PIs associated 
with an alignment, but leave the alignment name, right-click on the alignment name in the 
Explorer menu and choose Empty.
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Defining Horizontal Curves

Define Horizontal Curve Set – is used to create a curve between alignment tangents or to 
revise an existing curve definition. The Previous and Next buttons can used to step sequentially 
through the alignment. The Select button can be used to graphically identify an alignment 
location for editing. As alignment components are selected, they highlight in the MicroStation 
view.

The Radius 1: field is for input of the radius of a single circular curve. Leading and Trailing 
Transition fields are for the input of spiral curve radii.
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The Curve Calculator is used to compute curve data for circular or spiral curves. In addition to 
deflection angle, one other curve criteria must be defined and locked prior to selecting the 
Compute button. The curve solutions can be passed to the parent dialog by selecting OK.

The Design Calculator is used to compute or look up curve data to meet design criteria.
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Setting the Beginning Station

The default station at the beginning of a newly created alignment is 0+00. To change it, select 
Geometry > Horizontal Curve Sets > Stationing.  Set the beginning station of the active 
alignment by keying in the desired new station and choosing Apply.  The options for Vertical 
Alignments should be considered carefully.  Do Not Update will leave there stationing as is, 
Synchronize Starting Stations will update their stationing to match that of the horizontal and 
Maintain Station Difference will keep any difference in the current starting stations, such as 
when the vertical alignment does not start at the beginning of the horizontal.

Note: InRoads does not require you to key in the ‘+’ when entering a station.  It will add the 
plus sign for you based on your preferences.
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Equations

If there are inequalities in your alignment, you may assign station equations. These equations 
can be either gap or overlap equations. To assign an equation, select Geometry > Horizontal 
Curve Sets > Stationing.  At the bottom of the dialog, choose New.  In the resulting box, 
enter the Back Station and the Ahead Station, with the ahead station prefixed with an equation 
name.  When choosing a name for the equation, remember that from this point in the alignment 
forward, stationing will be referred to by this name preceding the station so the shorter the 
name, the easier it will be for key-ins, etc.

You can have multiple equations in one alignment if necessary.

Horizontal Event Points

Horizontal Event points are points associated with an alignment that are not actually a part of 
the geometry of the alignment the way a PC, PT, or PI are. They are used for points that need to 
be annotated with stations and offsets, for points where you need special sections cut or for 
points where you want to be certain Roadway Designer drops a template.
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Select Geometry > Horizontal Curve Sets > Events.

Horizontal Event Points may be added as either Station and Offset (they move with the 
alignment if it is relocated or re-stationed) or as Northing and Easting (they remain fixed by 
coordinate values. The station and offset values relate back to the alignment and update as the 
alignment shifts). This dialog can also be used to create Cogo points or to assign Cogo points at 
alignment vertices.

Horizontal Elements 

The Horizontal Element tools allow you to create alignments without knowing the PI 
information.  They may be accessed from the toolbar shown above, or from the pulldown under 
Geometry > Horizontal Elements.

There are several advantages to this method.  One of the greatest advantages of the horizontal 
element alignments is that they do not have to be continuous.  For example, you can create 
elements that have the most constraints, leaving gaps between them, and then join them 
together with unconstrained tangents and curves.

Another advantage is the ease with which reverse and compound curves can be created, as well 
as curves greater than 180 degrees.
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When creating elements, you have three basic placement options for linear elements and the 
same three options for circular elements. These options are just for placement; once an element 
is placed and accepted, it is treated the same as any other element no matter the placement 
method.

 Fixed placement is used when you know exactly where the element is going to be located 
and you, in effect, lock it in place using a combination of coordinates, pass-through points, 
bearings or radii. When using the fixed placement options, the resulting elements are not 
tangent or coincident with any existing elements. This placement option is used to place 
standalone elements.

 Floating placement is used to establish elements coincident and tangent to an existing 
element with a pass-through point and a radius (for curves) and with a pass-through point 
or a bearing for lines. They force the alignment to be coincident and tangent at the end 
where they join and will lengthen or shorten the element they are being attached to as 
necessary to meet the criteria specified. They will only ensure tangency and coincidence at 
the end where they are attached to an existing element. The floating placement options will 
not connect two existing elements.

 Free placement is used to connect two existing elements. It ensures coincidence and 
tangency at both ends where it connects to the existing elements. The existing elements 
may lengthen or shorten as necessary, but will not change locations.

To create a horizontal element alignment, first give the alignment a name description and style, 
then use a combination of the fourteen commands to define the alignment. (The fifteenth 
command is for checking and correcting problems with the integrity of the alignment, 
described below.)

Check Integrity

The Check Integrity command on the Horizontal Element toolbar allows you to check the 
coincidence and tangency of horizontal alignments.  The Element tools allow you to place the 
different components of the alignment in whatever order you wish, therefore it is not 
uncommon for the elements to be “out of order”.  This is one of the situations where Check 
Integrity can help, since you cannot only check the integrity, but make changes to the elements 
to correct integrity problems.
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Importing alignments From graphics

If alignments are already defined graphically or in an electronic text file, they may be imported 
into InRoads without having to re-enter the data.

Alignments that has already been drawn graphically may be imported using 
File > Import > Geometry > From Graphics.

You can import Horizontal Alignments, Horizontal and Vertical Alignments, Cogo Points or 
Event Points. If the alignment has curves, it is typically best to toggle on Resolve Gaps and 
Nontangencies. If the alignment was drawn as a series of lines and/or arcs that have not 
been complexed, toggle on All Selected Elements Added to Single Alignment (you 
must first define a Fence or Selection Set of the elements, and the elements will import in the 
order of creation, even though they’re added to the same alignment).

After specifying the Name (which defaults if you don’t supply one), the Description and the 
Style, choose Apply. If you have first created a Selection Set or defined a fence, you will be 
asked to Accept the contents. If you have not, you’ll be asked to identify the element. In either 
case, after accepting, an alignment or alignments will be added to the geometry project listed in 
the Target section.
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Cogo Commands - Overview

Coordinate geometry commands are delivered with InRoads. There is no need to exit, start, or 
launch another product to access them. These commands provide an alternative method for 
creating horizontal alignments. One of the main differences in creating the Cogo alignments 
(sometimes referred to as figures) and other alignments is that Cogo alignments require that the 
points be established first, then joined together to form the alignments.

Once created, Cogo points and alignments are, in most cases, interchangeable with other 
horizontal points and alignments. There are a few key differences, however:

 Cogo points are always numbered as you go (beginning with the seed number established 
in Tools > Options > Geometry or with the next available number.

 Cogo points can stand alone, such as when locating a fire hydrant or signs.

There are several toolbars devoted to coordinate geometry described here. These same 
commands may be found under the Geometry heading on the pull-down menu.

Cogo Point commands

Use the Cogo Points commands to create, edit, copy, delete, or navigate to Cogo points. These 
commands can be accessed through tool bars or by selecting Geometry pull-down menu.

Cogo Traverse commands
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The Traverse commands can be used to generate Cogo points from known locations by 
inputting distance and bearing to the point being constructed (Direction Traverse). It may also 
be used for locating points by Angle or Deflection. Additionally, alignments and radial points 
can be created based on the statues of the Insert Point.

Cogo Intersection Commands

The Intersection commands can be used to generate point locations based on known points, 
alignments, stationing, and/or offsets.
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Create/Edit Alignment by Cogo Points

Alignments are created by chaining existing Cogo points together using the Create/Edit 
Alignment command. It is not necessary to create the alignment name prior to using this 
command; it may be entered here, along with a Description and Style. The points defining the 
alignment are listed in the Alignment Definition. The alignment can be defined graphically by 
selecting the Start button or the definition (or edits) can be keyed into the Alignment Definition 
field.

See the Bentley Help or InRoads Reference Guide for additional information on InRoads Cogo.

Section Summary:

 The data on the Options > Geometry tab is preset to CDOT standards. With the possible 
exception of Plotting Height and Seed names, this data should be left as is.

 Most of the commands that are used to create alignments do not add the geometry point 
generated to the Cogo buffer automatically. However, they can be added afterwards.

 New geometry is not written to the hard drive until the geometry project is saved.

 There are no dialog boxes associated with the Horizontal Curve Set PI commands. Prompts 
for these commands are displayed in the lower left corner of the MicroStation window.

 Use the Curve Calculator and the Design Calculator to compute the radius for curves.

 The beginning station and station equations for an alignment are defined using the 
Horizontal Curve Set > Stationing command.

 The Horizontal Curve Set > Events command is used to add stations “of importance” to the 
alignment and alignment points to the Cogo Buffer.

 Event points can also be used by other commands like Roadway Designer and Create Cross 
Sections to calculate data at those stations.
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 Horizontal Element tools can be used to create unconnected alignment elements within a 
single alignment.

 The Horizontal Element Check Integrity tool can be used on alignments created by any 
method. It is especially useful for trouble shooting alignments imported from graphics.

 Cogo commands are primarily used by the ROW/Survey specialty group.

Geometry Utilities

Geometry utilities act upon existing geometry to modify that geometry or create new geometry.

Section Objectives:

 Discuss the Transpose Alignment command.

 Discuss the Inverse command.

 Discuss the Transform Geometry command.

 Discuss the 

Transposing Alignments

Transposing an alignment reverses the direction of that alignment. Tangent sections are 
reversed and left-hand curves become right-hand curves. The beginning stationing value is 
retained; however, any station equations previously defined are deleted. Associated vertical 
alignments are also reversed. You may find the need to transpose an alignment if it was 
surveyed in a direction opposite from the direction you wish to design (up-stream vs. down 
stream). Other instances may be if you create an alignment by importing from graphics. 
InRoads will generate the alignment in the direction the MicroStation graphic was drawn which 
is not necessarily in the direction of ‘up-station’. Or you may simply create an alignment in the 
wrong direction using any of the InRoads geometry commands.

The transpose alignment command is found under the pull-down menu:

 Geometry > Utilities > Transpose 
The command executes once the alignment (s) for transform are chosen and Apply is selected. 
The user will have to redisplay any associated stationing or annotation of the transformed 
alignment(s).

Transposing an alignment

1. Use the review tools to evaluate the horizontal alignmentsand determine the direction they 
are running. 

Note: Alignments created by exporting an electronic fieldbook assume the direction of 
the data collection.

2. Select Geometry > Utilities > Transpose.
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3. Select the desired alignment and <D> Apply.

4. Review the alignment to verify the transposition.

5. Save the geometry project.

Inversing Between Alignments - Overview
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Another useful geometry utility is Geometry > Utilities > Inverse Direction. This 
command can be used to interactively inverse between data points identified graphically.

Enabling the geometry point snap will lock data points to defined alignment or Cogo keypoints. 
Executing a second graphic data point will post the inversed data to the MicroStation file.

Transforming Geometry - Overview

Entire geometry projects, individual alignments, or Cogo points can be transformed by moving, 
scaling, or rotating selected items. The transform command is found under the pull-down menu 

Geometry > Utilities > Transform
Shown above is the transformation of alignment Alternate B. The alignment has been moved 
100 feet east and 100 feet north as indicated in the delta coordinate values defined in Original 
Point & Destination Point fields. Additionally the alignment has been rotated 22 degrees 
clockwise. The point of rotation is about the coordinates defined in the Original Point fields.

Note: This command does not create a copy of the specified alignment. It will transform the 
original alignment specified. Use the Geometry > Copy Geometry command 
prior to use if a copy is desired.
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Offset Alignments - overview

Choose Geometry > Utilities > Parallel Horizontal Alignment

Items to examine are:

Mode - There are three modes; Specify, Interactive By Station, and Interactive By Element.

 Specify - This option uses the data in the From area of the dialog box to determine the 
length and location of the new alignment.

 Interactive By Station - This option identifies the length and location of the new alignment 
based on data clicks made in the MicroStation View window.  This option can use partial 
elements at the beginning and end of the new alignment.

  Interactive By Element - This option also identifies the length and location of the new 
alignment based on data clicks made in the MicroStation View window. However, this 
option uses the full length of all elements identified.

From - This area is used to identify the source, length, and offset of the new alignment within 
the dialog box.

 Horizontal Alignment - This drop down menu is used to specify the source of the offset 
alignment.

 Station Limits - This option is used to specify the length of the new alignment in relation to 
the source alignment. When toggled off the full length of the source alignment is used.

 Offset - This option determines the location to the left or right for the new alignment. 
Positive offsets are to the right, negative offsets are to the left of the source alignment.

To - This area is used  to specify the attributes of the new alignment.

 Name - The name for the new alignment is entered here. If left blank, the Seed Name from 
the Options dialog box is used.

 Description - The description for the new alignment is entered here. If left blank, no 
description is attached to the alignment.
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 Style - This drop down menu specifies the style for the new alignment.

 Copy Event Points - When on, event points from the source that are within the extents of 
the new alignment are added to the new alignment.

Note: The new alignmnet’s stationing is equated to the source alignment.

Section Summary:

 The Transpose command is used to change the direction of the alignment. The elements 
remain in their original locations, but the end of the element is now the beginning.

 The Inverse command computes the distance and bearing between two alignment points.

 The Transform command is used to chane an alignment from one measurement system to 
another.

 The Parallel Horizontal Alignment is used to copy all or part of an alignment a specified 
distance from its source.

Chapter Summary:

 New geometry is created in the heirarchial order as it is defined in the geometry project.

 The Horizontal Curve Set commands are the most common method used for creating new 
horizontal alignments

 Import from Graphics is used to make geometry from MicroStation elements.

 Horizontal Element and Cogo commands can be used to create solutions where 
inconsistancies occur using other methods.

 Use the Parallel horizontal Alignment command to create the basis fo offset control lines.
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Appendix A - ICS Geometry Input

Text files may be imported in several formats, one of the easiest is to create an .ics file 
(Interactive Coordinate geometry Subsystem). This file type was first used with a product of 
the same name many years ago, but is still in use with InRoads today. It takes the format of 
commands along with the input for those commands.

For example a text file of coordinates can be formatted in an .ics file by adding a Store 
command at the top and formatting the file similar to the one shown below.

Choose File > Import > Geometry > ICS. Browse to find the file, and then choose Apply.
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The cogo points will be added to the active geometry project. You may then use Geometry > 
Utilities > Create/Edit Alignment to join the points, forming an Alignment and 
Geometry > Horizontal Curve Sets > Define Curves to add curves to the alignment. 
You can also accomplish these same tasks within the .ics file. See the Bentley Help topic Alpha 
Cogo.

InRoads contains an alphanumeric interface for running Interactive Coordinate Geometry 
Subsystem (ICS) commands. This interface is also referred to as Cogo Classic and can be used 
to run batch runs of geometry commands.

ICS can be accessed through the Windows start menu by selecting:

Start > All Programs > Bentley > InRoads Group XM > Cogo Classic
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ICS Command Summary

Control Commands

CREATE PROJECT name description

LOAD PROJECT name

SAVE PROJECT fname

AUDIT FILE mode file.ext

mode: 0 - opens an existing file of the specified name so that data can be added to the end of
the file

1 - opens a new file of the name specified

-1 - closes the existing file

OUTPUT FILE mode file.ext

mode: 0 - records all input and output records in the output file

1 - suppresses recording of input and only records output

-1 - closes the existing file
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AUTO PLOT preference /z /!fnam

This command turns on the graphic auto plot lock and sets the active preference for 
automatically plotting points and figures in the design file. Issuing the command again with 
fnum equal to 0 will turn the auto plot lock off in the graphic environment.

Example: AUTO PLOT 0 !ALIGN1 # turns auto plot lock on and # sets the active preference to 
ALIGN1

AUTO PLOT 0 # turns off auto plot lock

Parameter Commands

SET HEIGHT HtFS1 hi1 htBS1 /htFS2 /hi2 /htBS2

SET PARAMETER dir

0 = north azimuth 1 = bearing

SET PROTECTION set prot

0 = Point Protection ON 1 = Point Protection OFF

SET REFERENCE

Sets the vertical angle reference: v = horizon z = zenith

SET SEQUENCE seq

Sets the coordinate sequence: x = x,y,z n = n,e,e

SET TOLERANCE dtol /atol

Sets a distance tolerance dtol and angle tolerance atol for the

following conditions:

- Colinearity of points on tangents

- Curve and spiral symmetry

- Curve and spiral tangency with subtangents

- Figure continuity at tangent points

Report Commands

ANGLES pBS pOC desFS

Computes and reports angles from pBS at pOC to points in desFS.

AREA DIRECTION des

Computes and reports the area and boundary courses of the closed figure defined by 
des.

DESCRIBE ALIGNMENT Hfg /x /sBEG /sEND

Lists the following alignment data for Hfg at interval x:

- coordinates and station of PC, PI, PT, CC

- distances and directions of tangents

- PI deflection angles
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- curve data

DESCRIBE VERT ALIGN sBEG /sEND

Describes the active vertical alignment, including points of vertical inflection, 
curvature, tangency, high and low points, and grades.

DISTANCE des

Computes and reports distances between points in des.

INVERSE DIRECTION des

Computes and reports distances and directions between points in des.

LIST COORDINATES des /mode

Lists the coordinates of each point in des.

LIST FIGURES des

Lists the figures and figure descriptions in des.

TRAVERSE ANGLES des

Computes and reports the lengths and the interior angles of lines in the traverse defined 
in des.

STATIONS AND OFFSETS desAL2 /x /sBEG /sEND

Computes and lists the stations and offsets of points in desAL2 from the active 
horizontal alignment.

Point Commands

STORE n c1 c2 /z /p /!fnam -OR- p c1 c2 /z /-cno /!fnam

Stores point n with coordinates c1, c2, and z. If optional p is specified, n takes its value. 
If optional -cno is specified as -1, -2, or -3 the coordinate c1, c2, or z is modified, 
respectively.

DELETE COORDINATES des

Deletes points in des from the .tdp project file.

DEFINE Z p z

Defines the elevation of point p.

POINT DESCRIPTION des *description

Defines the alpha description for the known point(s) in des.

Figure Commands

STORE FIGURE nfg des /pAL sAL

Defines the figure nfg in the .tdp file as the list of points in des.

DELETE FIGURE fg

Deletes the figure descriptions (but not points) from the .tdp project file.

FIGURE DESCRIPTION des *description

Defines the alpha description for the known figure(s) in des.
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Locate Commands

ANGLE RESECTION p1 p2 p3 ang1 ang2 /n

EXTEND ARC pPC pCC nPT [arc]

LEVEL RUN pBS rBS

LOCATE ANGLE pBS pOC nFS ang [dis] /vaFS /[off] /vaBS pVB

LOCATE DEFLECTION pBS pOC nFS defl [dis] /vaFS /[off] /vaBS /pVB

LOCATE DIRECTION p n dir [dis] /va /[off]

LOCATE FROM ALIGNMENT n sn /[off] /rod

Locates a point n along the active alignment at station sn at an optional offset off and 
rod reading rod.

rod = rod reading if Level Run is active

rod = elevation if Level Run is non-active

LOCATE LINE p1 p2 n [dis] /va /[off] /Mdis

TANGENT n1 pCC1 [r1] n2 pCC2 [r2] /dir /ext

TANGENT OFFSET n pOF p1 p2

Transformation Commands

COMPUTE TRANSFORM desFROM desTO

This command is initially used to set the rotation/translation values to be used in the 
transformation process. The "desFROM" values are two points that are located in the 
relative coordinate system. The "desTO" values are two points in the rotated/translated 
coordinate system that directly correspond with the two points in the relative 
coordinate system. The relationship between these two sets of points is that the 
measured distance must be exactly the same between each set of points (no scaling 
allowed).

TRANSFORM COORDINATES des

This command can be executed at any time, on any set of points/figures, AFTER the 
Compute Transform command has been processed. This command works with points 
or figures.

Divide Commands

DIVIDE ARC pPC pPT pCC div /n

Divides a clockwise arc with center pCC into div equal segments between pPC and 
pPT. Stores the resultant coordinates as n, n+1, etc.

DIVIDE FIGURE des div /n

Divides the figure des into div equal parts. Stores the resultant coordinates as n, n+1, 
etc.

DIVIDE LINE p1 p2 div /n

Divides line p1 p2 into div equal parts. Stores the resultant coordinates as points n, 
n+1, etc.
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Intersect Commands

ARC ARC INTERSECT n pCC1 [r1] pCC2 [r2] pID

ARC LINE DIRECTION n pCC [r] p dir pID /[off]

ARC LINE POINTS n pCC [r] p1 p2 pID /[off]

CURVE SPIRAL n [r] pCC pID pTS dirBT [ls] [dc]

CURVE SPIRAL POINTS n [r] pCC pID pTS pSIT pSC

DIRECTION INTERSECT n p1 dir1 p2 dir2 /[off1] /[off2] /va1 /va2

FIGURE ARC INTERSECT n fg pCC r pID /[offg]

FIGURE FIGURE INTERS n fg1 fg2 pID /[off1] /[off2]

FIGURE LINE INTERSECT n fg p dir pID /[offg] /[off]

LINE SPIRAL n p1 p2 pID pTS dirBT [ls] [dc]

LINE SPIRAL POINTS n p1 p2 pID pTS pSIT pSC

POINTS DIRECTION INTER n p1 p2 p3 dir /[off1] /[off2] /va

POINTS INTERSECT n p1 p2 p3 p4 /[off1] /[off2]

SPIRAL SPIRAL n pTS1 dirBT1 [ls1] [dc1] pTS2 dirBT2 [ls2] [dc2] /pID

SPIRAL SPIRAL POINTS n pTS1 dirBT1 [ls1] [dc1] pTS2 pSIT pSC2 /pID

Curve Commands

FIT CURVE pBT pPI pAT nPC nCC nPT /[r] -OR- pPC pOC pPT

Alignment Commands

SET ALIGNMENT Hfg /pAL /sAL /Vfg

Activates a horizontal alignment and optionally defines the stationing.

CLEAR ALIGNMENT

Clears the active alignment, and makes the active alignment Cogo.

POINTS ON ALIGNMENT x /n /[off] /sBEG /sEND /odd

Locates and lists coordinates of points n, n+1, etc. at each interval x along the active 
alignment at an optional offset off between sBEG and sEND with odd defining station 
lock on or off.

odd = 1 - Station Lock on

odd = 0 - Station Lock off

FIT ALIGNMENT nTS pBT pPI [dc] [ls1] [ls2] defl sign

Parallel Commands

PARALLEL LINE p1 p2 [off] /n1 n2

Locates points parallel with the line p1 p2 at an offset distance off, and stores them as 
n1 and n2.

PARALLEL FIGURE des /[off] /n /nfg /dz
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Locates a new parallel figure to des at an offset distance off, and stores points of the 
new figure as n, n+1, etc. and the new figure as nfg with an elevation difference of dz.

For an open figure: For a closed figure:

+off = to the right +off = external

-off = to the left -off = internal
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COGO Parameter Abbreviations

[ ] - parameters shown in the square
brackets utilize the Input Combined
Grid Factor 

Parameter Description Parameter Description
ang angle p known point
atol angle tolerance pAL point on the alignment
arc arc distance pAT point of the ahead tangent
-AL alignment pBS point of the backsight
c1,c2 coordinates 1 and 2 pBT point of the back tangent
cid spiral curve identification; 

thisparameter is not used by 
Simple Spiral, key in any 
number from 0 to 999.

pID known point that indicates 
which intersection is to be
chosen; positive is near, 
negative is far from the pID

Cno the field number of a coord 
to change in an existing 
point

pOC occupied point OR point on 
the curve

CC center of curve pOF point that perpendicularly 
offsets the pt. to be 
calculated

Dc degree of curve pVB point of the vertical 
backsight

defl deflection angles PC point of curvature
delta delta angle PI point of intersection
des point or figure description PT point of tangency
desc alpha description r# curve radius
dir direction rBS rod reading of the backsight
dirBT direction to the back tangent rod rod reading or elevation
dis distance s station
div number of divisions sAL station on the alignment
dtol distance tolerance sBEG beginning station
dz elevation difference sEND ending station
ext externality seq coordinate sequence (x or n)
fg figure sign sign of angle
fnam feature name sn station
fname file name SC spiral to curve point
fnum feature number SIT point of spiral intersection
-FS foresight TS tangent to spiral point
Gdis geodetic distance va vertical angle
Hfg horizontal figure vaBS vertical angle to backsight
hi# height of instrument vaFS vertical angle to foresight
ht# height of target Vfg vertical figure
ls# spiral arc length x station distance
Mdis measured distance z elevation
mode input/output mode n unknown point
name name of file nfg unknown figure
odd station lock on/off off offset
offg offset from figure
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Abbreviations for the ICS input commands

Abbreviation Command Comment
an r angle resection
an angles
a a i arc arc intersect
a d area directions
a f audit file
a l d arc line direction
a l p arc line points
a p auto plot assigns feature name/number to all of 

the following commands, i.e.: 
a p house
store 1 100 200 300
2 101 202 303
loc ang 1 2 30. 100.

c a clear alignment
c g f combined grid factor
c pr create project
c s p curve spiral points
c s curve spiral
c t compute transform
def z define z
del c delete coordinate
del f delete figure
des a describe alignment
des v describe vertical
di a divide arc
di f divide figure
di i direction intersect
di l divide line
dis distances
exi exit
ext a extent arc
f ar i figure arc intersect
f al fit alignment
f c fit curve
f d figure description
f f i figure figure intersect
f l i figure line intersect
i d inverse direction
i f input file
l a locate angle
l c list coordinate
l de locate deflection
l di locate direction
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l fi list figure "list figure (point des, i.e. 1-4) -1" 
lists all figures that points in the 
parentheses are located in.

l fr a locate from alignment
l l locate line
l pa load parameters
l pr load project
l r level run
l s p line spiral points
l s line spiral
o f output file
pa f parallel figure
pa l parallel line
pl c plot curve
pl l plot line
pl p plot point
pl s plot shape
po de point description
po di i point direction intersect
po i points intersect
po o a points on alignment
sa pa save parameters
sa pr save project
se a set alignment
se d set display "set display 0" turns scrolling off and 

"set display 1" turns scrolling
On

se h set height
se pa set parameters
se r set reference
se s set sequence
se t set tolerance
sp s spiral spiral
sp s p spiral spiral points
s a o station and offset
s f store figure
s store
t a traverse angle
t c transform coordinates
t o tangent offset
t tangent
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A profile represents the ground surface along a specified path. A profile of the horizontal alignment showing 
the existing surface ground line is required before creating the vertical alignment, also known as the design 
profile. Typically, at least to profile sets will be generated. One set is created for the plan sheets by Plan and 
Profile Generator and is covered in a later chapter. The other is a “working” profile that is used to create the 
vertical alignment and other design elements.

Chapter Objectives:

 Describe the Create Profile dialog box.

 Discuss the Update Profile dialog box.Examine the Annotate Profile dialog box.

 Describe Projecting a vertical alignment to a profile.

Creating Profiles

Section Objectives:

 Explain what preferences do.

 Discuss the settings on the Source, Include, and Offsets leaves of the Create Profile branch.

 Discuss the settings on the Limits leaf of the Controls branch.

Select Evaluation > Profile > Create Profile.
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There are several CDOT preferences for the different vertical exaggerations. Choose the 
appropriate one under Preferences and Load it to establish the settings in the dialog.

Because preferences reset the menu with predefined settings, the preference should be selected 
prior to making any changes to the dialog box.

Settings for the Create Profile Dialog Box

The settings for Axes, Grid, and Details are controlled by the Preferences and are not described 
here. Items under the Create Profile and Controls branches are set by the user and are discussed 
below.

Create Profile - General Leaf

The General leaf is where the user makes the initial choices about the profile display. Items to 
examine on this leaf are:

 Set Name - By default this is set to the active horizontal alignment’s name. InRoads uses 
the set name to determining which profile will be used when updating or annotating a 
profile if more than one exists in the drawing (dgn) file.

 Direction - Left to Right is the default value. This matches the typical alignment directions 
of west to east and south to north. If the horizontal alignment runs east to west or north to 
south, the Right to Left option can be selected.

 Exaggeration - These values are controlled by the Preference selected. If different values 
are required use the key in fields provided to enter the desired values.
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 Surfaces - Toggle on the check box for each surface to be included in the profile display. 
By default, the first surface loaded with the Existing type is toggled on.

Create Profile - Source Leaf

The Source leaf is used to specify the path along which surface data is collected for the ground 
line. Items to examine on this leaf are:

 Create - This option is used to specify if a profile window (grid) and surface data or just a 
profile window is displayed. If Window Only is selected, the profile grid will be created 
based on the Elevation Limits set on the Controls > Limits leaf (described below), even if 
they are toggled off.

 Alignment - This option is used to select the horizontal alignment along which surface data 
is collected. Use the drop down menu to select the desired alignment.

 Graphics - A MicroStation graphic element can be used to define the path for a profile. The 
graphic element can be a line, linestring, complex chain or closed shape. The element must 
be within the perimeter of one of the selected surfaces in order for the command to work.

♦ Alignment - Typically, a profile created along a graphic element can not be annotated 
or updated because there is no data for the graphic in the geometry project for the 
program to consult. Entering a name in the Alignment field causes the program to 
create a horizontal alignment from the graphic element which is stored in the active 
geometry project.

 Multipoint - This is option works similar the Graphics option except instead of selecting a 
graphic element data points are used to locate the path for the profile.

♦ Alignment - Typically, a profile created along from data points can not be annotated or 
updated because there is no data for the graphic in the geometry project for the 
program to consult. Entering a name in the Alignment field causes the program to 
create a horizontal alignment from the data points which is stored in the active 
geometry project.

 ASCII - This option uses a text file to create the profile. This text file contains two 
columns, one with the station and the other with the ground elevation. The filename is 
specified on the ASCII leaf.
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Create Profile - Include Leaf

The Include leaf is used to specify additional information to be displayed in the profile window.

 Items to examine on this leaf are:

 Crossing Features - This option displays surface features that run perpendicular to the 
alignment or defined path.

 Projected Features - This option displays surface features that run parallel to the alignment 
or defined path.

♦ Bandwidth - This is the distance to the left and right of the profile path that data is 
collected for the display of projected features.

○ Include Features - This is used to specify whether feature data is collected inside 
or outside the bandwidth.

○ Clip Features - When on features are clipped when they pass outside of the display 
area (inside or outside bandwidth specified above). When off, features partially 
inside the display area are displayed in their entirety.

 Display Planimetrics - This displays a graphic element that follows the path of the profile. 
This can be handy for Multipoint profiles.

 Show Data Outside Elevation - When on, any data inside the bandwidth will be displayed 
whether it is inside the profile window or not. When off, Only data that falls inside the 
profile’s elevation range will be displayed.

Note: This option displays all crossing features and all projected features within the 
bandwidth. If specific features are desired, they should be displayed using the 
Update Profile command. 
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Create Profile - Offsets Leaf

Offsets collect surface data at a specified distance from the profile path. The offset information 
is stored in the Surface Properties (See Initial Surface Procedures for more information). 
Toggle on the desired offsets to have that data displayed in the profile.

Controls - Limits leaf

The Limits leaf is used to set a specified size to the profile window.Items to examine on this 
leaf are:

 Elevation - This is used to set the high and low elevations that will be displayed for the 
profile grid.

♦ From Cogo Points -When selected, the high and low elevation fields are filled in with 
data collected from the active geometry project’s cogo buffer. The fields can be edited 
after the program populates the field.
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♦ From Regression Points - When selected, the high and low elevation fields are filled 
in with data collected from the active geometry project’s horizontal regression buffer. 
The fields can be edited after the program populates the field.

 Station - This sets the start and stop stations for the profile window.

 Window Clearance - This sets a minimum number of grids that will appear above and/or 
below the data line. Grids will be rounded up to the nearest interval specified in the Axes 
branch.

Displaying the Profile

Once the desired settings are made <D> the Apply button then <D> in the MicroStation view 
window. The <D> in the view locates the lower left corner of the profile grid when the 
direction is set to Left to Right. It is the lower right corner when the direction is set to Right to 
Left.

Section Summary:

 Preferences are predefined settings that can affect every leaf in the dialog box.

 Select the desired Preference before making other changes to the dialog box.

 With the exception o of the Create Profile branch and the Controls branch, all other settings 
are handled by the preference.

 Profiles generated from Graphics or Multipoint can not be updated because InRoads does 
not normally save the path by which they were created.

 Using the Alignment filed for profiles generated from Graphics or Multipoint saves the 
path of these as horizontal alignments in the active geometry project.

Updating Profiles

If there are changes that need to be made to the profile after it is cut, such as turning on or off a 
surface or features, or updating surfaces or features that have been modified, you can update 
the profile.

Section Objectives:

 Describe how each update Mode works.

  Discuss the settings on the various leaves.
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 Discuss the Style and Filter buttons.

Select Evaluation > Profile > Update Profile.

There are four leaves used to update the profile, Surface, Offsets, Crossing Features, and 
Projected Features. These are explained below.

Profile Set and Mode

The Profile Set drop down menu is used to select the profile to be updated when more than one 
profile set exists within the dgn file. The Mode is common to all leaves. It is used to specify 
how data is modified. There are three options; Refresh, Display On, and Display Off.

 Refresh - This option is used to update existing data in the profile.

 Display On - This option displays items not currently shown in the profile.

 Display Off - This option deletes items currently displayed in the profile.
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Surface Leaf

The Surface leaf is used to identify which surfaces) is to be modified.

Offsets Leaf

The Offsets leaf is used to update surface offsets. There are two areas in this leaf, Surfaces and 
Offsets.

 Surfaces - This area is used to identify the surface(s) that contain the offsets to be 
modified.

 Offsets - This area is used to select the offset to be modified.
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Note: Changes to the offset data are made in the Surface Properties dialog box (See 
Initial Surface Procedures for more information).

Crossing Features Leaf

The Crossing Features leaf is used to identify features that are perpendicular to the profile path 
for updating. There are two areas on this leaf; Surfaces and Crossing Features.

 Surfaces - This area is used to identify the surface(s) that contain the features to be 
updated.

 Crossing Features - This area is used to select the specific features to be modified. 
Features in the list are shown in one of three colors; black, grey, and red.

♦ Black - This color indicates that the Feature Style allows this feature to be displayed in 
the profile

♦ Grey - This color indicates that the Feature Style does not allow the feature to be 
displayed in the profile.

♦ Red - This color indicates that the Feature Style does not exist in the xin file and is, 
therefore, not a valid CDOT style.
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Projected Features Leaf

The Projected Features leaf is used to identify features that are parallel to the profile path for 
updating. There are three areas on this leaf; Surfaces, Projected Features, and Bandwidth.

 Surfaces - This area is used to identify the surface(s) that contain the features to be 
updated.

 Projected Features - This area is used to select the specific features to be modified. 
Features in the list are shown in one of three colors; black, grey, and red.

♦ Black - This color indicates that the Feature Style allows this feature to be displayed in 
the profile

♦ Grey - This color indicates that the Feature Style does not allow the feature to be 
displayed in the profile.

♦ Red - This color indicates that the Feature Style does not exist in the xin file and is, 
therefore, not a valid CDOT style.

♦ Bandwidth - This is the distance to the left and right of the profile path that data is 
collected for the display of projected features.

○ Include Features - This is used to specify whether feature data is collected inside 
or outside the bandwidth.

○ Clip Features - When on features are clipped when they pass outside of the display 
area (inside or outside bandwidth specified above). When off, features partially 
inside the display area are displayed in their entirety.
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Styles and Filter Buttons

The Style and Filter buttons are used to access the Style Manager and Feature Select Filter 
respectively. The Style Manager is used to change feature style properties and the Feature 
Select Filter is used to limit the number of features displayed in the dialog box.

 Styles - This button displays the Edit Style dialog box for the feature highlighted in the list 
box. The Edit Styles dialog box is used to temporarily modify a style to allow a feature to 
be displayed in the profile. The toggles to do this are shown in the illustration below.
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Note: Modifying a style changes data in the CDOT_Civil.xin file. This file is managed 
by ServerCop and will be overwritten at the next log in, wiping out any changes 
made to the styles. To request a permanent change to a style, contact the CADD 
Managers office.

 Filter - This button activates the Feature Selection Filter dialog box. The use of feature 
selection filters is explained in InRoads Options and Initial Surface Procedures.

Once the desired settings have been made, <D> the Apply button to update the profile. <D> 
Close to dismiss the dialog box.

Section Summary:

 The Mode is used to specify whether data is added, removed, or updated.

 Features should be added to the profile from this dialog box because it allows control over 
what features are displayed and the Create Profile command does not.

 Projected features run roughly parallel to the profile’s path. Crossing features run roughly 
perpendicular to it.

 Feature styles should only be changed to allow an item to be displayed in the profile. 
Changes to styles will be overwritten at log in.

 Use feature selection filters to reduce the items listed in a list box when searching for 
specific features.

Profile Annotation

Section Objectives:

 Discuss the profile annotation preferences.

 Describe items on the General leaf.
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Annotation is used to put text data in the profile. Typically, this is in the form of existing 
ground and proposed ground elevations. There are two Preferences set up for CDOT 
annotation. The CDOT preference displays existing and proposed ground elevations. CDOT 
Superelevation Diagram adds the superelevation diagram to the surface data. The desired 
preference should be selected prior to making changes in the dialog box. The preference sets 
the information in the other leaves of the dialog box, so the user only needs to look at the 
General leaf.

General Leaf

The General leaf is used to specify where data is taken from for the annotation. The items to 
examine are:

 Profile Set - This is used to specify which profile to annotate when more than one exists in 
the dgn file.

 Vertical Alignment - Proposed elevations are taken from the vertical alignment selected 
with this drop down menu.

 Surface - Existing elevations are taken from the surface selected with this drop down 
menu.

 Cant Alignment - This is used in rail applications and will not affect roadway design data.

 Corridor - This drop down menu is used to specify the corridor that contains the 
superelevation data to be annotated.

 Superelevation Control Lines - This area is used to select which superelevation control 
lines are used to create the superelevation diagram.
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After the desired settings are made, <D> the Apply button to display the annotation. The 
illustration below is an example of annotation using the CDOT Superelevation Diagram 
preference.

The green text (to the left of the grid line) represents the existing ground elevations. The red 
text (to the right of the grid line) is the proposed elevations. The superelevation diagram is 
placed below the profile grid.

Section Summary:

 There are two preferences that manage profile annotation; CDOT for most uses and CDOT 
Superelevation Diagram when the superelevation diagram is required.

 There is a separate command for annotating vertical geometry. The Annotate Profile 
command is mainly concerned with adding surface data annotation.

Projecting A Vertical Alignment From Another 
Horizontal Alignment On To A Profile

The ability to display the vertical alignment from one horizontal alignment into the profile of 
another will come in handy when designing merging roadways.

Section Objectives:

 Discuss the Alignments to Profile command
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To display a projected vertical alignment select Evaluation > Profile > Alignments to 
Profile from the InRoads menu bar.

The following items should be examined:

 Profile Set - This is used to select the profile that will be updated when more than one 
profile exists in the dgn file.

 Limits - Station Limits are used to define a specific area where the projected alignment will 
be displayed. To use Station Limits, toggle on Station and key in the Start and Stop 
stations.

 Interval - The projected alignment is not a display of the geometry elements of the selected 
vertical alignment. Instead, elevations of the projected alignment are plotted in the profile 
at corresponding stations and connected by a linestring. The interval determines the 
stations where data is collected.

 Alignments to Project - this field is used to specify the alignment(s) that will be displayed 
in the profile. Key in the alignment name to specify the desired alignment. a wildcard, the 
“*”, can be used to specify multiple verticals. The alignment can also be identified by using 
the “target” button and selecting a graphic of the horizontal alignment that contains the 
desired vertical alignment.

After the desired settings are made, <D> Apply to display the projected alignment into the 
profile. <D> Close to dismiss the dialog box.

Section Summary:

 Use this command to aid in merging one vertical alignment into another.

 Projected alignments can not be annotated.

Chapter Summary:

 Profiles are used when designing vertical alignments.

 A profile consists of a path (horizontal alignment, graphic element, or series of data points) 
and the elevations of a surface under that path.

 Use Update Profile to add additional details like crossing and projected features.

 Annotate the working profile with the existing ground elevations. It will make it easier to 
determine elevations at particular stations.

  Use projected alignments when designing a merging roadway.
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In InRoads, your project’s vertical alignment is created after establishing the centerline “path” 
or horizontal alignment. This vertical geometry is stored in the InRoads geometry project (the 
ALG file).

In the geometry project hierarchy, the vertical alignment is a “child” to the horizontal 
alignment. Therefore, you must first create the project’s horizontal alignment before creating a 
vertical alignment “child” underneath the horizontal “parent”. 

InRoads provides tools to help you design the vertical geometry within AAHSTO or CDOT 
project guidelines. You can also create multiple vertical alignments for each horizontal 
alignment if you wish to analyze different alternative alignments for cut/fill balancing or other 
design criteria (vertical curve designs, vertical grades, stopping sight distances, etc.) 

This chapter explains how and when to use the Vertical Curve Set tools to create your vertical 
geometry, as well as other tools that you can use to display, modify and annotate this geometry.

Chapter Objectives:

 Explain how vertical alignments are created and their relationship to other project data in 
the CDOT process.

 Investigate different options for reporting on vertical alignment geometry data and learn 
when to use each option.

 Explain how to effectively maintain and manage vertical alignments with InRoads.

Creating Vertical Alignments

The process of creating a vertical alignment requires that you first create a horizontal centerline 
alignment. You can then create a profile of the existing ground conditions along this horizontal 
alignment. It is directly on this existing ground profile grid where you “lay out” or create your 
vertical alignment.

You can use the Vertical Curve Set tools to place vertical PIs and then define your vertical 
curves on the profile. You can then move/edit VPIs and curve data as necessary to meet your 
project’s design criteria.
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Once you’ve established your vertical geometry using the best InRoads tools for your design 
situation, you can:

 Display your vertical alignment on the profile grid

 Annotate critical geometry data and other information directly on the alignment. 

 Produce geometry reports noting information like entrance and exit grades and lengths, 
PVC and PVT locations, high and low point locations, vertical curve lengths, k and r 
values, etc. 

This information is not only critical for interim design checks, but also for final project 
documentation.

Section Objectives:<

 Demonstrate how vertical alignment slots are created in the geometry project.

 Explain how the Vertical Curve Set tools are used to create a vertical alignment.

 Explain how precision keyins are used for placing vertical alignment VPIs.

 Explain how to edit alignment points (adding, inserting, moving or deleting VPIs).

 Explain how to edit vertical curve data.

 Demonstrate how to add vertical events to the alignment.

Creating Profiles

A profile of the horizontal alignment showing the existing surface ground line is required 
before creating a vertical alignment. The vertical geometry is then created directly on this 
profile grid.

Select Evaluation > Profile > Create Profile and then select the appropriate profile preference.

Make sure the correct horizontal alignment is active for profiling on the Source leaf. Multiple 
surfaces may be shown on one profile by selecting them in the Surfaces window on the 
General leaf. You may also show features that cross the alignment and projected features on 
the profile. These may be toggled on from the Include leaf before creating the profile.
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Note: There is no option to select specific features from the Create Profile dialog box. 
Therefore, it may be better to display features from the Update Profile command.

See the Profiles chapter for more information on creating profiles.

Creating a new Vertical Alignment Slot

In order to create a new vertical alignment, you must first have a geometry project loaded, with 
a parent horizontal alignment active. 
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Once the geometry project is loaded (and correct horizontal is active), you may create a new 
alignment name using the File > New > Geometry command.

For additional information on creating new geometry, see the chapter Initial Geometry 
Procedures.

Using the Vertical Curve Set Commands

Use the Vertical Curve Set tools to create the initial vertical alignment. These tools consist of 
five primary commands described below.

 

 Add Vertical PI – used to create a VPI that begins a new alignment, or to add a VPI onto 
either end of an existing alignment.

 Insert Vertical PI – used to add a VPI to an alignment between two existing VPIs.

 Move Vertical PI – used to change the location of an existing vertical VPI.

 Delete Vertical PI – used to remove a VPI from an existing alignment. For removing more 
than one VPI, you must choose and accept each one individually. To remove all VPIs 
associated with an alignment, but leave the alignment name, right-click on the alignment 
name in the InRoads Explorer window and choose Empty.
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 Define Vertical Curve – used to create a curve at a VPI on an alignment, or to revise an 
existing curve on an alignment. The Previous and Next buttons are used to step through the 
alignment. The tangents forming the VPI where the curve is to be defined will be 
highlighted graphically.

The Vertical PI section of this dialog box allows you to edit the edit the location of a 
vertical PI. For more information see the section Editing Vertical Alignments.

The Vertical Curve section of the dialog box is where you enter your vertical curve 
information. Options for defining vertical curves include:

♦ Length of Curve – specify the length of the vertical curve.

♦ r=(g2-g1)/L– specify the rate of change.

♦ Middle Ordinate – specify the middle ordinate or external distance.

♦ Pass-through – specify the pass-through point by station and elevation.

♦ K=L/(g2-g1) – specify the vertical curve K value.

♦ Unsymmetrical Length – specify the length from the PVC to the PVI and the distance 
from the PVI to the PVC.

Note: You must Apply after defining each VPI or curve. If you make a mistake and place 
a VPI in the wrong location or define a vertical curve incorrectly, you can select 
Undo to return the alignment to its previous values. Only one Undo action is 
available. 

Dynamics

The Dynamics dialog allows you to set intervals for placement of the vertical PIs. It locks your 
cursor into the desired station, elevation and/or grade intervals. This is also useful when editing 
a VPI because you can lock on a station interval, for example, when moving a VPI.
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The Vertical Design Calculator 

The Vertical Design Calculator is used to compute or look up curve data to ensure your design 
criteria are met. This tool uses the AASHTO green book design guidelines to compute your 
curve data based on values you input for:

 Design speed

 Headlight sight distance or

 Curve length.

When using the Vertical Design Calculator, ensure that you’re using the correct Vertical 
Design Checks.txt table, which contains data from the 2001 AAHSTO manual. The table file is 
located in the C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Design 
Checks folder in the CDOT workspace. 
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Keyins 

There are additional keyins that can be useful when creating a vertical alignment and using the 
Add, Insert or Move PI commands. These include:

 SE=station,elevation 

Example: SE=34500,8421

Use this keyin to place a VPI at a specific station and elevation. 

 DG=distance,grade 

Example: DG=1500,-2.5%  or  DG=1500,-.025

Use this keyin to place a VPI at a specific horizontal distance and grade from the 
previous VPI. Specify the grade as either a decimal or use the percent sign as shown in 
the example. 

To create a vertical alignment

1. Select File > Open to load the geometry project into InRoads memory.

2. In the InRoads Explorer, select the Geometry tab, right click on the correct horizontal 
alignment and Set Active.

3. Select File > Open to load the existing surface into InRoads memory.

4. Create a profile of the existing ground along the horizontal alignment. Select 
Evaluation>Profile>Create Profile.
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5. On the Create Profile dialog box, select Preferences and Load the desired preference for 
the profile display.

6. On the Create Profile dialog box General leaf, make sure the existing ground surface is 
toggled on.
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7. <D> Apply and then <D> to identify the location of the profile’s lower left corner.

8. You’re now ready to create a new vertical alignment. Select File > New > Geometry 
and select the Vertical Alignment tab.

9. Key-in a Name and Description for the alignment and then select the Style.

10. <D> Apply, then <D> Close to dismiss the dialog box.

11. Now input the alignment data. Select Geometry > Vertical Curve Set >Add PI.
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12. Enable Dynamics locks for Station, Elevation or Grade (if desired).

13. <D> Apply.

Note: As you drag the cursor in profile window, Station, Elevation and Grade 
dynamically displays in InRoads status window

14. Enter a data point <D> or snap to a location to define the first VPI, or use the SE= keyin to 
place it at a specific Station, Elevation location.

15. Place additional VPIs with data points <D> or by using either SE= or DG= (Distance, 
Grade) keyins.

16. <R> when finished placing VPIs.

17. <R> again out of the Add PI command.



A Practical Guide for Using Inroads V8i SS2   Page 159

Chapter 8 - Defining Vertical Geometry

18. You’re now ready to add Vertical Curves data. Select Geometry > Vertical Curve Set 
> Define Curve.

Note: The first two vertical tangents are highlighted.

19. Set Calculate By to the desired method (Length of Curve, Unsymmetrical Length, etc.) 
and enter the vertical curve value. 

Note: Select Design Calc to use AAHSTO design guidelines to look up or compute 
curve data.

20. <D> Apply to define the curve. 

21. Use the Next button to move to the next set of vertical tangents to define the next vertical 
curve.

22. Close the Define Vertical Curve dialog box when done.
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Editing Vertical Alignments

There are several options for editing or modifying a vertical PI or curve after it has been placed. 

Editing a VPI using the Define Vertical Curve Set command

While the primary purpose of the Define Vertical Curve Set command is to define a curve 
between two vertical tangents, you can also use this command to edit the VPI between these 
two tangents. By default, the fields in the Vertical PI section of the dialog box are populated 
with values that describe the position of the current VPI relative to the previous and next VPIs. 
However, you can change these values and then Apply to redefine the location of the VPI.

Set the Define PVI By option to the method you want to use to determine the PVI location. The 
four options are:

 Station and Elevation

 Station and Entrance Grade

 Station and Exit Grade

 Entrance and Exit Grades

You can move the PVI location using any of these methods. 

To edit a VPI using the Define Vertical Curve Set command

1. Select Geometry > Vertical Curve Set > Define Curve.

2. Identify the curve set containing the VPI you want to move.

Note: You can use the First/Last or Previous/Next buttons to highlight the curve or 
use the Target button to graphically select the curve on the profile.

Note: You do not have to have a curve defined to edit the VPI. InRoads treats a VPI 
as a zero length curve. If no curve is defined, the entrance and exit tangents at 
the VPI are highlighted.
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3. Set the Define PVI By to the desired option for specifying the move.

4. Key in the new values for either Station, Elevation, Entrance Grade or Exit Grade 
(depending on the method selected).

5. <D> Apply.

The VPI is moved to the new location. For example, if the Define PVI By option is set to 
Entrance and Exit Grades you can key in new Entrance Grade and Exit Grade values. the 
VPI is repositioned based on the intersection of those grades projected from the previous 
and next VPIs.

Editing a VPI using the Move Vertical PI command

This command repositions PVIs on the active vertical alignment. Any curves at the moved 
vertical PI are recomputed and updated.

To edit a VPI using the Move Vertical PI command

1. Select Geometry > Vertical Curve Set > Move PI or the Move PI command 
from the Vertical Curve Set toolbar. 

Note: The dialog box appears, and you are prompted to identify the element.
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2. Using the Station, Elevation, Grade, Distance, and Constraint options on the dialog 
box, you can you can set an interval to control the position of the VPI being placed 
while using this command. The cursor position is constrained or locked into the inter-
val specified by the values you provide. If no options are selected, the VPI may be 
moved to any location between it's neighboring VPIs. 

3. <D> Apply.

4. <D> near the VPI you want to move.

Note: The VPI is attached to your cursor. The command only looks for vertical points 
(VPIs), therefore you do not have to snap to the VPI. Just place a data point 
and you will pick up the closest VPI.

5. Specify the new location, either graphically or by precision key-in. 

Note: You are prompted to Accept or Reject the overall solution. Depending on the 
specifications, the warning message Solution Overlaps may be displayed.

6. <D> to accept the new location.

Updating curves

Use the Constraint parameter when you make an edit that affects the adjacent curves.

For example, changing the elevation of the current PVI would cause the following to be 
recomputed: exit grade of the previous curve, entrance and exit grade of the current curve, 
and entrance grade of the next curve. The previous curve would be recomputed by holding 
the original PVI station and elevation as well as the entrance grade. The exit grade would 
be recomputed by holding the length of curve. The next curve would be recomputed by 
holding the original PVI station and elevation as well as the exit grade. The entrance grade 
would be recomputed by holding the length of curve.
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In adjacent curves, the length of curve is either preserved or recomputed, based on the 
setting of the Constraint parameter.

Adding a Vertical PI

If you need to add a vertical PI onto the end of the alignment, use the Add Vertical PI 
command. Do not use this command to add a VPI between two existing VPIs. If you need to do 
this, use the Insert Vertical PI command.

To add a VPI on to the end of a vertical alignment

1. Select Geometry > Vertical Curve Set > Add PI.

Note: You can also select Add PI from the Vertical Curve Set toolbar.

2. Using the Station, Elevation, Grade, Distance, and Constraint options on the dialog 
box, you can you can set an interval to control the position of the VPI being placed 
while using this command. The cursor position is constrained or locked into the inter-
val specified by the values you provide. If no options are selected, the VPI may be 
moved to any location between it's neighboring VPIs.

3. <D> Apply.

Note: You are prompted to Identify Alignment End.

4. <D> beyond the end of the alignment where you want to add a VPI (either at the begin-
ning or end of the alignment).

Note: The VPI is attached to your cursor. The command only looks for vertical points 
(VPIs), therefore you do not have to snap to the VPI. Just place a data point 
and you will pick up the closest VPI.

5. You are prompted to Specify Point/Reject. Specify a location for the new VPI, either 
graphically with a <D> or by precision keyin. 

6. <D> to accept the new location.

7. <R> when done.

8. <R> again out of the Add Vertical PI command.

9. Close the Add Vertical PI box.

Inserting a Vertical PI

If you need add a VPI between two existing VPIs, you can insert the VPI on an existing vertical 
tangent using the Insert Vertical PI command.
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To insert a vertical PI

1. Select Geometry > Vertical Curve Set > Insert PI.

Note: You can also select Insert Vertical PI from the Vertical Curve Set toolbar.

2. Using the Station, Elevation, Grade, Distance, and Constraint options on the dialog 
box, you can you can set an interval to control the position of the VPI being placed 
while using this command. The cursor position is constrained or locked into the inter-
val specified by the values you provide. If no options are selected, the VPI may be 
moved to any location between it's neighboring VPIs.

3. <D> Apply.

4. You are prompted to Identify Element.

5. <D> on the vertical tangent where you want to insert the new VPI.

Note: As you move your cursor, it will “rubber-band” along the tangent.

6. You are prompted to Specify Point/Reject. Specify a location for the new VPI, 
either graphically with a <D> or by precision keyin.

Note: Your are prompted to Accept overall solution/Reject.

7. <D> to accept the new location.

8. <R> again out of the Add Vertical PI command.

Adding Vertical Event Points

Vertical Events are any special location on the vertical alignment that you may want to display 
and annotate on the alignment, or where you may want to later cut a cross section. (for 
example, at a bridge approach or culvert). Later, when you create a corridor along this 
alignment, you have the option to drop templates at event points and cut a cross section at the 
events.

To add vertical events points to your alignment

1. Select Geometry > Vertical Curve Set > Events.

2. Set the Define By option to either Single Station or Multiple Stations.

Note: Single Station is used to define one event point. Multiple Stations define mul-
tiple events over a station range.
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3. Key-in the Station for the event or use the target button to graphically select it on the 
profile grid.

4. If creating multiple events, set Locate By to either Segment Distance (if event points 
fall at even increments along the alignment) or Number of Segments (for event points 
spaced equidistantly along the station range). Then, key-in the appropriate values.

5. Toggle on Add Horizontal Event Points if you wish to add an event point on the hori-
zontal alignment (to show with horizontal stationing).

6. <D> Apply.
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Note: This adds the event point(s) to the alignment. The vertical events can be dis-
played and annotated with the Vertical Annotation command. See the section 
Annotating Vertical Alignments for more information.

Section Summary:

 A profile must be created and displayed before you can create a vertical alignment.

 The Vertical Curve Set tools are used to lay out the initial VPI locations on the vertical 
alignment.

 The SE= and DG= precision keyins are used to define specific VPI locations.

 The Define Vertical Curve command is used to create a curve at a VPI location. 

 There are several methods for creating vertical curves (length of curve, unsymmetrical 
length, r value, k value, etc.)

 The Vertical Design Calculator is used to look up or compute vertical curve data based on 
AAHSTO design guidelines.

 VPI locations can be edited using several different methods including the Move Vertical PI 
command and the Define Vertical Curve command. 

 VPIs can be added or inserted on a vertical alignment after it has been created.

 Vertical Event points are special locations on the vertical alignment that can be displayed 
or annotated on the alignment. Cross sections can also be cut at these locations.

Exploring Vertical Alignments

After creating the vertical alignment, you can obtain all of the alignment’s geometry data in 
report format. This information can be graphically annotated directly on the alignment graphics 
on the profile. You can also interactively track the alignment to obtain alignment information at 
a specific point location (station, offset, elevation, grade, etc.)

Section Objectives:

 Explain how to generate a vertical alignment geometry report.

 Demonstrate how to display the vertical alignment on the profile grid.

 Demonstrate how to annotate the vertical alignment point, tangent and curve data.

 Explain how to interactively obtain vertical alignment data at specific points.

Reviewing Vertical Alignments

Reviewing vertical alignments is similar to reviewing horizontal alignments. The Review 
Vertical Alignment dialog allows you to easily change between multiple Geometry Projects, 
Horizontal, and Vertical alignments.
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To review a vertical alignment

1. Select Geometry > Review Vertical.
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Note: The review dialog can also be opened by right-clicking on the alignment in the 
InRoads Explorer window.

Displaying Vertical Alignments

There are several methods for displaying vertical alignments in InRoads. The method you 
choose is based on the desired display.

If you choose one of the methods other than Vertical Annotation, a geometry style controls the 
level and therefore the symbology of the display. Geometry styles are associated with 
individual alignments when they are created. The CDOT standard styles have been pre-defined 
and are stored in the CDOT-Civil.xin file, accessed through the Tools > Style Manager dialog. 

To display the active alignment, choose Geometry > View Geometry > Active Vertical and the 
active alignment will display on every profile (created from the vertical’s parent horizontal) in 
the design file showing points and line work (no annotation).



A Practical Guide for Using Inroads V8i SS2   Page 169

Chapter 8 - Defining Vertical Geometry

To display any alignment, right-click on the alignment name in the Explorer window and 
choose View. The chosen alignment will display on every profile (created from the vertical’s 
parent horizontal) in the design file showing points and line work (no annotation).
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To display the alignment and annotate it at the same time, choose Geometry > View Geometry 
> Vertical Annotation. This command uses a preference to define the symbology of the vertical 
alignment and to define what and how the alignment is annotated. There are several CDOT 
preferences available for different types of vertical alignments.

    

To Display a Vertical Alignment

1. Select Geometry > View Geometry > Active Vertical to display a graphic of the 
active vertical alignment.

Note: Alternately in the you can right-click on the vertical alignment in the InRoads 
Explorer window and select View.
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Annotating Vertical Alignments

If you wish to display and annotate the vertical alignment, you can use the Vertical Annotation 
command. This command does not use a geometry style to display the alignment. Instead, you 
select a preference to not only display the alignments points, tangent lines and vertical curves, 
but to annotate this geometry as well. The preference determines:

 Which points will be displayed (VPIs, VPCs, low points, high points, vertical event points, 
etc.) and what will be annotated (Station, Elevation, etc.). 

 The display of the vertical tangents and what will be annotated (grade, slope length, etc.)

 The display of the vertical curves and what will be annotated (length, entrance grade, exit 
grade, sight distance, etc.)

 The location of the annotation along leader or witness lines.

To Annotate a Vertical Alignments

1. Select Geometry > View Geometry > Vertical Annotation to view vertical align-
ment annotation.

2. Verify the appropriate Horizontal, and Vertical Alignments are identified in addition to the 
Profile Set.
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3. Select Preferences, Load the desired preference then Close the Preferences box.

4. Take some time and along the top of the Vertical Annotation dialog investigate the remain-
ing tabs and the individual settings loaded by the preference for each tab. Note that vertical 
event points can be displayed and annotated on the Points tab.
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5. <D> Apply

 

Note: Edit the MDS text on the vertical curve annotation to show the actual design speed.

6. Close the Vertical Annotation dialog box when done.

Tracking

Vertical alignments can be interactively queried similar to horizontal alignments using the 
Tracking commands. There are two tracking options:
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 Tools > Tracking > Horizontal Alignment – tracks the horizontal alignment with a 
perpendicular line to your cursor. It gives a Station, Offset, Elevation readout in the 
message field, where the elevation shown is that of the active vertical alignment at the 
given station.

 Tools > Tracking > Vertical Alignment – tracks the vertical alignment on the profile grid 
with a vertical line to your cursor. It gives a Station, vertical Offset, Elevation and vertical 
alignment Grade readout at the location of your cursor.

Section Summary:<

 Use the Review Vertical Alignment report to generate standard point, tangent and curve 
data on the vertical alignment.

 Use Geometry > View Geometry > Active Vertical to display the vertical alignment on the 
profile grid using the assigned geometry style (line work only).
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 Use Geometry > View Geometry> Vertical Annotation to display and annotate the vertical 
alignment using a CDOT preference.

 Use Tools > Tracking > Horizontal Alignment to obtain vertical alignment elevation at 
any point on the alignment.

 Use Tools > Tracking > Vertical Alignment to obtain offset and grade information between 
your cursor and point on the profile.

Vertical Geometry Management Tools

While working with vertical alignment, there are several tools that can help you manage your data. Also, after 
you have created your alignment, it is important to save the geometry project with the new vertical alignment 
data.

Section Objectives:<

 Explain how to manage your vertical alignment data.

 Demonstrate how to save your vertical geometry.

Managing Vertical Alignment

There are several utilities that can help manage your vertical geometry. 

These options, which are accessed from the right-click shortcut menu in the InRoads Explorer, 
include:

 New – to create alignment slot information (name, description, style, etc.)

 Set Active – to select the vertical alignment for creating and editing.
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 Copy – to copy a vertical alignment from the same or different geometry project (e.g. when 
creating alternative vertical alignments, you can copy a previously created alignment and 
edit the copy to create the alternate alignment).

 Delete – to delete a vertical alignment from the geometry project. 

Note: This command works in memory. Be sure to save the geometry project if you no 
longer want the alignment in the geometry project.

 Empty – to empty the data out of a vertical alignment but keep the alignment slot 
information (name, description, style, etc.)

In addition, use the Geometry pull-down menu to access the following:

 Rename Geometry – to rename a vertical alignment. For example, when you are using an 
existing geometry project with alignments from Survey, you can use the Rename 
Geometry command to give the alignments project specific names.

Saving a Vertical Alignment

Alignments are not saved individually. Instead, they are saved when the geometry project is 
saved. Since you are working on a copy of the geometry project that is loaded in memory, 
saving is a good idea whenever you make changes to your alignment, and mandatory before 
exiting – assuming you want to save your changes.

Geometry projects can be saved using two options.

To save a geometry project (option 1)

1. Make sure the geometry project you want to save is active. If not, right-click on the geom-
etry project from the InRoads Explorer window and choose Set Active.

2. Choose File > Save > Geometry Project.

Note: The active geometry project is saved.
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To save a geometry project (option 2)

1. Right-click on the Geometry Project in the InRoads Explorer window and chose Save 

Note: The geometry project you highlighted is saved.

2. If the geometry project has never been saved, either of the previous methods will bring up 
the Save > As box shown below.

3. Set the Files of Type to (*.alg)

4. Choose the geometry project you want to save (from the Active list)

Note: After choosing the name from the Active list, the File name field is populated with 
the internal name of the geometry project. The File name is the hard drive name. 

5. If you want to change the name, key in a new file name or keep the default (the default is 
recommended).
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Note: Geometry projects have both an internal name that appears in the dialog boxes in 
InRoads and a name on the hard drive that has an.alg extension. Care should be 
taken to make certain you have chosen the correct geometry project name to match 
the file name you specify. Otherwise, you could accidentally save over a file on the 
hard drive with the wrong geometry project. It is recommended that your hard 
drive name match your internal (active) name.

6. <D> Apply and the file is saved.

Section Summary: 

 Use the InRoads Explorer right-click short cut menu to manage your vertical alignment 
data.

 The Delete Geometry command deletes vertical alignment (and other geometry data) from 
InRoads memory. Be sure to save the geometry project on the hard disk if you no longer 
want the alignment in the project.

 The Empty command will empty all alignment data, but keep the slot information.

 Alignments cannot be saved individually. You must save the entire geometry project with 
the new alignment data.

 It is recommended that your geometry project’s hard drive name match your internal 
(active) name to avoid confusion and the possibility of overwriting data.

Chapter Summary:<

 A general understanding of how to create an InRoads profile is required before creating and 
working with vertical alignments.

 Vertical alignments are part of the InRoads geometry project and stored in the *.alg file.

 Vertical alignments are “children” to the “parent” horizontal alignment. Therefore, you 
must have created a horizontal alignment before creating a vertical “child” underneath it. 

 You can create multiple vertical alignments underneath one horizontal for different design 
scenarios.

 A vertical alignment can be used along with a horizontal to define a corridor in Roadway 
Designer.

 After creating the vertical alignment, you can obtain geometry data from the alignment 
from several different sources including reports, interactive tracking, and graphical 
annotations.
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Whether you work on roadways or retaining walls, typical sections (known as templates in InRoads V8i) 
provide the tools necessary for creating 3D models for your proposed designs. Anything that can be defined by 
a typical cross section and horizontal and vertical alignments (not just roadways) can be modeled with 
templates. For example: channels, walls, ditches and dams can all be modeled using this approach.

The way a template and its points are defined is critical to how it will behave during the modeling process. The 
resulting model created from the templates is used to provide critical information to Construction. This 
information is generated from various reports like the Cross Section staking report (see the Roadway Modeling 
and Reports chapters for more information). 

Typical sections are stored in a template library (ITL) which is saved on the hard drive with an extension of 
*.itl. A standard template library file is based on the CDOT Roadway Design Guide 2005 and the CDOT M&S 
Standard Plans 2006 Edition. 

Chapter Objectives:

 To become familiar with how typical sections fit into CDOT’s design process.

 To learn how to match the CDOT standard templates to your design criteria.

 To gain an understanding of when to use the completed templates included in the default 
template library on your projects.

 To learn how to prepare typical sections that match your design criteria if the standard ones 
do not.

Template Library

Section Objectives:

 To create a project-specific template library using the CDOT standard template library.

 To copy templates from other jobs for use in a project-specific template library.

 To become familiar with the Create Template interface for creating and editing templates.

Templates are stored in a template library (.itl). CDOT has created a standard template library 
that contains several CDOT-specific templates. These CDOT standard templates are based on:

 Typical sections shown in the CDOT 2005 Roadway Design Guide manual

 Roadway components or features shown in the CDOT M&S Standard Plans 2006 Edition

 Clear Zone criteria

 CDOT’s Cut and Fill slope requirements

Standard Template Library

The CDOT standard templates are developed and maintained to facilitate the design process for 
CDOT projects. The path for CDOT’s standard template library is C:\Workspace\Workspace‐
CDOT_V8i\Standards‐Global\InRoads\Templates\ CDOT_Template‐Library.itl. The library 
consists of models of typical sections as defined in the CDOT 2005 Roadway Design Guide 
and other typical sections commonly encountered by CDOT designers. 
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Project Template Library

The CDOT library should be copied to the project folder and modified as needed for a 
particular project or design situation. This is accomplished by copying the CDOT_Template‐
Library.itl to the C:\Projects\JPC#\ Discipline\InRoads\ folder before editing. 

Important! Changes made to the standard CDOT_Template‐Library.itl in the \Standards‐
Global folder will be overwritten by CDOT’s file management software 
ServerCop during log in. 

Creating a Project Template Library

To create a project specific template library:

1. From the InRoads main menu, select the Templates bottom tab.

2. <R> on Template Library in the InRoads Explorer and select Open from the menu.

3. Navigate to C:\Workspace\Workspace-CDOT_V8i\Standards-
Global\InRoads\Templates.

4. Highlight the CDOT_Template‐Library.itl file and <D> Open.

5. <R> on the CDOT_Template_Library.itl file in the information pane and select Save As.
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6. Navigate to the project’s InRoads folder (C:\Projects\12345\Design\InRoads\ in this 
example).

7. In the Save As dialog box, key in the desired Name such as 12345_Template‐Library.itl.

8. <D> Save.

Note: The file may also be copied using Windows commands.

Update the *.rwk file to load the new template library. This ensures the new template library 
will open with the other InRoads data for the project.

9. From the InRoads main menu choose File > Save As.

10. In the Project Save As dialog box, navigate to the design folder 
(C:\Projects\12345\Design\InRoads\ in this example).

11. Choose Projects (*.rwk) from the Save as type: field 

12. Choose an existing project file from the Save As dialog box by highlighting it or key in the 
name of a new project file. (For this example 12345.rwk is used.)

13. Click on the Options button.



Page 182 Colorado Department of Transportation

Chapter 9 - Typical Sections A Practical Guide for Using InRoads V8i SS2

14. From the Template Library tab of the Project Options dialog box, verify the filename of the 
template library is correct and toggle on Update. (The Add automatically toggles on as 
well.)

15. Click OK to accept the changes in the Project Options dialog box.

16. Click Save to save the InRoads Project file.

17. Click Cancel to dismiss the Save As dialog box.

18. To load the project template library from this point on, open the Project file (12345.rwk).

Copying existing Templates to a Project Template Library

Templates created for previous projects can be used in the current project. These templates 
should be copied from their original libraries into the current project’s library. This avoids 
confusion and the possibility of altering the wrong template.

To copy a template into the project template library from another library:

1. Select Modeler > Create Template from the InRoads menu bar.

2. From the Create Template menu bar, select Tools > Template Library Organizer.

3. In the Template Library Organizer dialog box, <D> the  button.
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4. In the Open Template Library dialog box, navigate to the folder of the source template 
library (C:\Projects\55555\Design\InRoads\ in this example).

5. Highlight the source template library and <D> Open. The selected library is displayed in 
the right Available In area of the Template Library Organizer dialog box.

6. Expand the right template library to show the template you want to copy.

7. Expand the left template library to show where you want the template to reside.

8. Drag the desired template from the right library and drop it in the left (55555_HMA_4Lane 
in this example).

Note: Be certain to drop the template in the correct location. If it is dropped ‘in space’ 
and not in a folder, the template is not copied.

9. Repeat for any other templates you need to copy.
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10. <D> OK when finished.

Note: The left Available In pane is the library currently loaded in InRoads. Templates can 
be copied from the left library to the right as well.

Note: Templates are copied into the IRD file when setting up Template Drops (see the 
Roadway Modeling chapter for details). If a template you need resides in the IRD, 
you can open the IRD file here and copy template(s) from the IRD into your ITL.
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Create Template

The Create Template dialog (accessed from Modeler > Create Template) is used to create 
or edit templates within the loaded template library. It is a visual interface that allows you to see 
the template as it’s being created and to test the end conditions prior to using the template in 
Roadway Designer.

The Create Template dialog contains several areas as shown and described below.

Menu Bar

      

The Menu Bar consists of four pull-down menus.
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File Menu

The File menu is used to create, load and save the template library (ITL).

Important! While working in Create Template, you are working in your computer’s 
memory and you should periodically save your ITL file, such as after any 
major template edits. If you do not save changes to your ITL file, you will 
be asked to save upon exiting from the dialog. Once you have closed the 
dialog, unsaved changes are lost.

To translate a previous InRoads version TML file (InRoads V8.5 and earlier) to the new 
ITL format, select File > Import TML and specify the TML file.

Important! Be careful! Templates are drastically different in this version of InRoads 
than in 8.5 and prior versions. If you convert a template you must carefully 
check every aspect of the components and points to ensure they converted 
properly. In most instances, you are better off creating the template in the 
current version rather than converting.

To import a template from graphics, you can use File > Import Template. You must first 
draw the template with MicroStation, then make a selection set from the graphics before 
selecting this option. 

Edit

♦ The Edit menu contains standard edit functions that apply to the highlighted template 
or folder. See the Edit Commands section in the InRoads Online Help for more 
information.

Add

♦ Add > Simple, Constrained, Unconstrained, Null Point, End Condition and 
Overlay/Stripping: Used to create new components in the active template. 

Note: Each of the above Add options is described in greater detail in the Components 
section of this chapter.

Tools

♦ Tools > Template Library Organizer: Allows templates, point names and folders 
to be copied between two libraries. See the previous section on Copying existing 
Templates to a Project Template Library for additional details.
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♦ Tools > Apply Feature Name Override: Allows multiple point names in a 
template to create one feature in the resulting surface. Highlight the point names in the 
dialog and key in the name you want the combined feature to have, then <D> Apply. 
For example, use this when multiple Cut or Fill slopes would normally result in 
multiple features, but the desired result is one continuous feature instead. The feature 
names turn red in the template display to note the override is used. This can also be 
accomplished in the Point Properties for each of the points in question.

    

This option may also be useful when transitioning between two templates using 
different named points that you want to result in one continuous feature. For example, 
if the two templates use CL and Centerline, respectively, you may toggle on Apply 
Feature Name Override for both and use the same name for the resulting feature.

♦ Tools > Options: Allows the setting of default naming options for components and 
points. It also controls whether Affixes are used and if so, what they are. Steps can be 
set here for the placement of points and components on a grid, similar to 
MicroStation’s Grid lock.

♦ Tools > Dynamic Settings: Toggles on or off the Dynamic Settings box. See the 
Dynamic Settings section of this chapter for additional information.
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Library Tree

The Library tree is shown on the left pane of the Create Template dialog. Folders may be 
expanded or collapsed as necessary to see the template(s) available for copying or editing. The 
active template has a red box around its icon and is shown in the large template view at right. 
The highlighted template is shown in the Preview below the tree.

 Right-click on a folder to create a new folder or template, or access several of the Edit 
functions. See the Edit Commands section in the InRoads Online Help for more 
information.

 Right-click on a template to access several of the Edit functions. In addition, you can use:

♦ Set Active: Makes the template active (available for editing and shown in the large 
template view at right).

♦ Template Documentation Link...: Assigns a link to the template. This is very 
useful for documenting the template, section or individual component in the template. 
You can link a template to almost any type of file, including a word processor 
document, spreadsheet, text files or web page that explains or defines the template. The 
file is for reference only and does not affect the processing of the template.
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♦ Display: Brings up the template display dialog, allowing the display of the template 
on a grid in the MicroStation file. This can be used as the basis for your typical section 
drawing as an alternative to the CDOT Typical Section Program.

Active Template Tree

The pane on the left of Create Template can also be used to access the Active Template tree. At 
the bottom of the pane, select Active Template. Then, expand the portion of the template you 
want to access: either Points, Components or Display Rules. For each option, you can right-
click and Edit or Delete the individual items.

Note: This is the only place where you can change the name of a Display Rule.

At the bottom of the pane, there is an box displaying information about the highlighted item. It 
is informational only.

Preview

The pane at the left bottom of Create Template displays a preview of the highlighted template. 
From this pane, you can drag the template into the Active Template view to make a copy. You 
can drag it by the default drag-point (shown as a cyan box) or by any other point in the 
template. Dragging a template into itself is allowed.

http://www.google.com
http://www.google.com
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Current Template Information

The Current Template information is listed for the active template. In this area, you can add or 
change the template description but not the name. To change the name, right click the template 
in the library tree and choose Rename.

Display Options

The active template may be shown as Components (typical) or as Constraints (usually used 
when analyzing the constraints assigned). Point Names may be toggled on or off as desired. 
Display All Components will show any components in the template that are currently not 
displayed because of Display Rules. These components appear as dashed lines.

Important! When reviewing an unfamiliar template, it is always good to toggle on Display 
All Components so you can see any hidden components. 

Active Template Display

This view shows the active template. You may delete or rename templates in the list at left, but 
in order to make changes to a template it must be shown in this view. A template can be 
activated by double-clicking it in the library tree or by right-clicking on the template and 
choosing Set Active.

 At the bottom left of the view are the active template View Controls

These MicroStation-like controls allow you to Zoom In, Zoom Out, change the 
exaggeration in X or Y, Window Area and Fit the template in the window. Also on this set 
of commands are short-cuts to Undo and Redo as well as the toggle for Dynamic Settings. 
The Undo and Redo buffers are cleared when another template is activated or you close the 
dialog. 
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 Mouse Controls

The mouse wheel may be used to zoom in and out in this view. Clicking the wheel and 
holding it down while moving the mouse pans.

 Hover Options

♦ Over a Point

Hovering over a point brings up a pop-up of point information.

♦ Over a Line (component)

Hovering over a line of a component brings up a pop-up of component and segment 
information.

 Right-click menus

Right-clicking in the Active Template Display area brings up a menu. There are different 
menus available, depending upon where and when you click: in a clear area, on a point, on 
a line (component), while creating a component or while dragging component. Some of the 
commands are also found on the pull-down menus. When a right-click menu is active, the 
commands may be selected using either the left <D> or right <R> mouse button.
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♦ Right-click in a clear area.

○ Add New Component > Simple, Constrained, Unconstrained, Null, 
End Condition and Overlay/Stripping: Used to create a new component in 
the active template. See the Component section for details.

○ Template Documentation Link...: Assigns a link to the template. See the 
description in the previous section.

○ Check Point Connectivity...: Checks the template to see if any two points are 
closer together than the specified Tolerance. If there are, a box appears that lists the 
points for a specific location and allows you to choose which is to be deleted. If 
you want to keep both, choose <Esc>. Then, the next set of points are brought up. 
This is the same as Merging Points, but it seeks out the points for merging rather 
than having to select them individually.

○ Delete Components: Notice this is plural, which means you can <D> and drag 
your cursor across any number of components and they are deleted when you ‘let 
go’.

○ Change Template Origin: While this command is on all three right-click 
menus, it functions differently depending upon whether it is selected while right-
clicking on a point or not. On a point, it moves the template so that the point 
selected is at the 0,0 coordinate. If not on a point, it prompts you to identify the 
point you want to move to the 0,0 coordinate. 

Note: Remember, the 0,0 coordinate is where the template is applied to the 
horizontal and vertical alignment.

○ Delete Constraints from All Points: Removes all constraints from all points 
regardless of how they are set.

○ Set Dynamic Origin: This allows the Dynamic Origin (magenta box) to be 
moved to a different location. See the Dynamic Settings section later in this 
chapter for more details.

Important! The Dynamic Origin (magenta box) is not where the template is 
applied to the horizontal and vertical alignment.
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♦ Right-click on a point.

All of the clear area right-click options, plus:

○ Move Point: Allows the point to be moved graphically, or if Dynamic Settings is 
active the key-ins can be used. This command is only available for points that have 
no constraints (appear green and can be moved anywhere) or one constraint 
(appear yellow and must hold the value of the one constraint, e.g. if it has a slope 
constraint, it must be moved along that slope). 

Note: Red points cannot be moved unless at least one constraint is released. You 
can, however, Edit the constrained point and move it by changing the 
constraint value(s).

○ Edit Point: Brings up the Point Properties dialog and allows the editing of 
Names, Styles, Constraints, etc. See the section on Points for details.

○ Add Constraint: Allows the addition of a constraint to the point and prompts for 
the identification of the parent for the constraint, along with the value for the 
constraint. Add Full Constraint adds Horizontal and Vertical constraints at the 
same time. See the section on Point Constraints for additional details on available 
constraints and when to use each.

○ Delete Constraints: Menu options change depending upon the constraints 
currently assigned to the point. Allows the deletion of both or of individual 
constraints.

○ Delete Point: Removes the point from the template. If the point is between two 
points in a component, the remaining points are connected.

○ Delete From Components (Make Null): Removes the association of the 
point from the its component(s), but leaves the point along with its constraints 
intact.

○ Test Point Controls: Allows testing of constraint behavior as if external controls 
are applied to the point.
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♦ Right-click on a line.

All of the clear area right-click options, plus:

○ Edit Component: Brings up the Component Properties dialog and allows the 
editing of Name, Description, Styles, etc. See the section on Components for 
details.

○ Insert Point: Allows the placement of a new point in between two existing points. 
The point may be placed graphically or with key-ins using the Dynamic Settings 
box.

○ Add Point: Only available when right-clicking on a segment of an open 
component. Allows the placement of a new point at the end of the component 
closest to where you click.

○ Unmerge Component Points: Any common points between the component 
selected and other components are copied so that each component has only unique 
points. The copied points are named Copy of [original name]. Has no effect if the 
component does not share points with other components.

○ Set Component Display Rules: Brings up the Component Display 
Conditional Expressions dialog, which allows the creation or editing of Display 
Rules, and/or the assigning of Rules to the component selected. See the section on 
Display Rules for additional details.

○ Delete Component: Notice this is singular, which means it will delete only the 
component selected. If the line selected is common to multiple components, you 
are prompted for which you want to delete.
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♦ Right-click while using Add > Simple: 

○ Change Placement Point: By default, the Add > Simple command places 
the component by the upper left point of the parallelogram. Choosing this 
command moves the placement point to each of the other points successively 
around the component.

○ Mirror: Creates a second identical component (except for naming) mirrored about 
a vertical line at the 0 horizontal coordinate.

○ Reflect: Creates the component in the opposite direction.

○ Cancel: Stops the command without creating a component.

○ Set Dynamic Origin: See the Dynamic Settings section later in this chapter for 
more details.

♦ Right-click while using Add > Constrained, Unconstrained: 

○ Finish: Stops the placement of the component. Use this after the last point is 
entered.

○ Closed Shape: Makes the component being placed a closed shape. 

Important! Leaving Closed Shape toggled off and drawing the component closed 
is NOT the same as having Closed Shape toggled on. This is a 
component property and may be changed later, however. Components 
must be listed as Closed in order for them to be used in end-area 
volume calculations.

○ Mirror: Creates a second identical component (except for naming) mirrored about 
a vertical line at the 0 horizontal coordinate.

○ Undo Last: Removes only the last point created. This is very useful when you 
enter a wrong point, but don’t want to start over or wait until finished to correct the 
error in point properties.

○ Cancel: Stops the command and does not keep any entered points.

○ Set Dynamic Origin: See Dynamic Settings below.

♦ Right-click while dragging a template into the Active Template View. All of these 
commands are the same as described in the Right‐click while using Add > Simple 
section above.
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Dynamic Settings

The Dynamic Settings dialog can be very helpful when creating and editing templates. You can 
toggle on the dialog by selecting Tools > Dynamic Settings or by choosing the Dynamic 
Settings icon on the view controls toolbar in the Active Template view. The dialog changes 
depending upon if you are dealing with general components (as shown on the left) or end 
conditions (as shown on the right).

   

There are several options within the Dynamic Settings:

♦ The read-out can be shown as either X: and Y: or <D> on the label and it converts to X: 
and Slope:. This readout is from the Dynamic Origin which is shown as the small 
magenta box.

♦ Steps: Lists the steps or intervals as defined in Tools > Options and may also be 
entered here, either in X and Y master units or in X and Slope, depending upon the 
readout selected.

♦ Point Name: When creating a new point, the name listed is used. It may be chosen 
from the drop-down (which comes from the Point Name List) or keyed in. If a 
component is created, this name is used as the seed name for all the points.

♦ Point Style: If the Name is chosen from the drop-down, the Style is populated 
automatically from the Point Name List. If the name is keyed in, the Style may be 
chosen from the drop-down (which comes from the Styles in the current XIN). This 
style is assigned to the corresponding feature when the design surface is created by 
Roadway Designer.

♦ Apply Affixes: Toggles on or off the Affixes, which are set in Tools > Options.

♦ Key-ins: The drop-down menu lists the different key-ins that can be used when 
locating a point or component:

○ xy= x-value,y-value – based on the template grid

○ dl= delta x-value,delta y-value – from the previous point

○ hs= delta x-value,slope – from the previous point

○ vs= delta y-value,slope – from the previous point

○ ol= delta x-value,delta y-value – from the Dynamic Origin (magenta box)

○ os= delta x-value,slope – from the Dynamic Origin (magenta box)
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♦ Set Dynamic Origin: This allows the Dynamic Origin (magenta box) to be moved to 
a different location. Use this when the point being placed is offset a known x and y or x 
and slope from a point that is not the previous one located. Set the Dynamic Origin on 
the reference point, then use the ol or os key-ins listed above to locate the new point.

Important! The Dynamic Origin is not where the template is applied to the horizontal 
and vertical alignment. The template is applied at the 0,0 coordinate in the 
template grid. For clarity, you can keep the Dynamic Origin at the 0,0 
coordinate when not using it as noted above.

Additional options for End Condition Points are described in the CDOT End Conditions area of 
this chapter.

Test Mode

This command activates the Test End Conditions dialog as shown. 

To test the end conditions:

1. Choose the command while the template in question is active. If there are priority conflicts 
you will first be asked to choose the order of processing for the end conditions.

2. Select a target from the list of Available Targets (generated from the active template’s end 
conditions). 

3. Choose Draw and place the target in the desired position. If more than one target is listed, 
you may need to place all the targets before seeing a result.

4. After drawing the targets, you may select Failure Report for a list of end conditions that 
did not meet their targets.

5. Check Priorities allows the order of end conditions to be changed.

6. Check Duplicates checks the solution to see if there are multiple occurrences of the 
same feature name.
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7. In the Display Rules area, there is a list of the Display Rules found in the template. To 
force a temporary True or False results to see the outcome, select the rule and <D> on the 
True/False toggle.

8. Reset removes the targets and starts the process of testing over again.

Section Summary:

 The CDOT standard template library can be copied to start your project-specific library.

 Templates can be copied from previous projects.

 The Create Template dialog is used to create and edit templates.

 Right-click menus are available in the Create Template dialog. The commands they 
contain are context sensitive and depend upon where you are and what you are doing when 
you right click, for example: in a clear area, on a point or on a line of a component.

 The Dynamic Settings box allows you to use key-ins for precision placement of points and 
components.

 The Dynamic Origin (magenta box) is not where the template is applied. The 0,0 coordinate 
of the template is applied to the horizontal and vertical alignments.
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Organization of the Template Library

Section Objectives:

 To learn how the CDOT standard template library is structured and where to look for the 
necessary templates for your project.

 To learn how to modify the standard templates if necessary to meet your design criteria.

 To become familiar with the standard templates, sections and components available by 
reviewing how the standard templates are put together.

 To learn how the templates will work based on their component and point properties.

The CDOT_Template‐Library is structured with complete templates at the top of the folder 
structure and individual template pieces (called components) at the bottom. The purpose of this 
folder structure is to: 

1) Make completed templates more accessible in Roadway Designer and 

2) To emphasize that when building a new template, the first step is to create an empty 
template.

Note: In InRoads terminology, a template refers to everything in the template library that is 
not a folder or the point name list. To help with communication and training, CDOT 
has further categorized the contents of the template library into templates, sections, and 
components based on the completeness of the data they contain.

Each folder level in the template library (Templates, Sections, and Components) refers to the 
completeness of the template as follows:

 1 – Templates folder contains complete templates with the basic components of roadway 
cross sections.

 2 – Sections – Pavement folder contains portions of a roadway cross section including 
pavement and sub base for lanes, shoulders, curb and gutter, and medians.

 3 – Sections ‐ End Conditions folder contains Z-slope components, cut and fill slopes, and 
curb and gutter templates. 

  4 – Components contain individual building blocks for defining sections or templates. 

 The illustration below shows the standard template library’s top level folder structure as it 
appears in the Create Template dialog box.
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Templates

This folder contains standard templates based on the CDOT 2005 Roadway Design Guide. 
Modify these templates as needed. Save new or copied complete templates to this folder. 
InRoads V8i allows great flexibility in designing templates. With the advent of components, 
the design models used for CDOT’s V04.00.00 configurations adhere as much as possible to 
the CDOT 2005 Roadway Design Guide and the CDOT Standard Plans- M&S Standard 2006 
Edition.

The illustrations on the next several pages show the six templates included in the Templates 
folder as they appear in the Create Template dialog box.

 HMA_Divided_TypeA_4Lane – This is the typical design for a four lane divided highway 
based on Figure 4‐1 of the 2005 Roadway Design Guide. Each Pavement Section contains:

♦ 12 ft lanes (two lanes)

♦ 4 ft inside shoulders

♦ 12 ft outside shoulders

♦ Normal Crown Cross slope

Figure 1: HMA_Divided_TypeA_4Lane
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♦  The Hot Mix Asphalt pavement is 15” thick, made up of five lifts: 

○ 2 in top lift

○ 3 in middle lifts (three lifts) 

○ 4 in bottom lift

○ 6 in layer of Aggregate Base Course Class 6

The end conditions show the clear zone treatment and possible cut and fill slopes 
based on 6:1, 4:1 and 3:1 slopes. Please refer to the End Conditions section of this 
manual for a detailed discussion on the subject.

Figure 2: Pavement Section Detail from “Figure 
1:HMA_Divided_TypeA_4Lane” on page 200

Figure 3: End Conditions Detail
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“Figure 3:End Conditions Detail” on page 201 defines possible cut and fill solutions 
that tie the pavement section to the existing ground and are based on Table 4‐2 Fill 
Slopes of the 2005 Roadway Design Guide. This end condition includes:

♦ Z-Slope with a horizontal measurement of 12’ from the edge of pavement and a slope 
of 6 to 1

♦ (3) fill slopes; 6 to 1, 4 to 1, and 3 to 1

♦ (3) cut slopes; 6 to 1, 4 to 1, and 3 to 1

 CONC_Divided_TypeA_4Lane – This is the typical design for a four lane concrete highway 
based on Figure 4‐2 of the 2005 Roadway Design Guide. Each pavement section contains:

♦ 12 ft lanes (two lanes)

♦ 4 ft inside shoulders

♦ 12 ft outside shoulders

♦ The concrete thickness is 9 in

♦ 12 in ABC Class 6 base extends 2 ft past the edge of concrete and tapers down to the 
POSS as shown in the detail below

♦ End condition treatments are as shown from HMA_Divided_TypeA_4Lane

Figure 4: CONC_Divided_TypeA_4Lane
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 CONC_Ramp – The ramp template based on Figure 4‐3 of the 2005 Roadway Design 
Guide. The typical standard pavement section for single lane ramp for CDOT has a 15 ft 
lane, 4 ft and 6 ft shoulders. The pavement section contains:

♦ 15 ft lane

♦ 12 ft inside shoulder

♦ 6 ft outside shoulder

♦ The concrete pavement is 11 in thick

♦ 3 ft wide Hot Mix Asphalt pavement for guardrail type 3, 2 in thick, is placed along the 
shoulder edge. Refer to CDOT M&S Standards M-606-1.

♦ End condition treatments are as shown for HMA_Divided_TypeA_4Lane

Figure 5: CONC_Ramp
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 HMA_Urban_4Lane – This urban highway template is based on Figure 4‐4 of the 2005 
Roadway Design Guide. It contains:

♦ 12 ft lanes in each direction in a normal crown (two lanes)

♦ The asphalt pavement is 8 in thick, made up of:

○ 2 in top lift

○ 3 in middle lift

○ 3 in bottom lift

♦ 6 in layer of ABC Class 6 base runs under the asphalt to 12 in past the curb and gutter

♦ Type2-IIB curb section is used at the edge of pavement. This type of curb and gutter 
section allows the slope of the gutter pan to match the pavement cross slope for cross 
slopes greater than +4% or less than -4%

Note: To see the all the attached sections toggle on Display All Components in the 
Display section of the Create Template dialog box. The template is developed 
this way so that the end conditions connect properly to the top back of curb. 
Refer to Curb and Gutter discussions under the Pavement Sections of this 
manual for additional discussion on Curb and Gutter.

Figure 6: HMA_Urban_4Lane

Figure 7: Type2-IIB Curb Section
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 HMA_Crowned_B10 – This is a typical two lane normal crown template based on Figure 4‐
5 of the 2005 Roadway Design Guide. It contains:

♦ (1) 12 ft lane in each direction

♦ 12 ft Shoulders

♦ The asphalt pavement is 8 in thick, made up of:

○  2 in top lift

○ 3 in middle lift

○ 3 in bottom lift

♦ A 6 in layer of ABC extends 2 ft past the bottom lift on each side

♦ End condition treatments are as shown for HMA_Divided_TypeA_4Lane

Figure 8: HMA_Crowned_B10
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 HMA_Full_Depth_Widening_2Lane – This template is for use on widening and resurfacing 
projects based on the Edge of Pavement Detail in Figure 4‐5 of the 2005 Roadway Design 
Guide. It contains:

♦ 12 ft lane overlay to each side of the centerline

♦ 12 ft shoulders built to a full depth of 8 in of asphalt

♦ HMA is a 2 in thick overlay pavement and 8 in thick at the shoulders. It is made up of:

○ 2 in top lift that extends 24 ft to each side of the centerline

○ 4 in leveling layer under the 2 inch top lift 12 ft to each side of centerline

○ A stripping component that can be adjusted to define milling depth.

○ 3 in middle lift under the new 12 ft shoulders

○ 3 in bottom lift under the new 12 ft shoulders

○ A 6 in layer of ABC Class 6 under the shoulders extends 2 ft past the bottom lift on 
each side 

♦ End condition treatments are as shown for HMA_Divided_TypeA_4Lane

Figure 9: HMA_Full_Depth_Widening_2Lane
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Pavement Sections 

The 2 ‐ Sections ‐ Pavement folders contain full depth segments of the roadway pavement 
cross section of a template. Pavement sections are partial templates. They represent one 
segment of the total pavement. For example, sections from the Driving Lane Sections folder 
represent a single pavement section from the finished grade to the subgrade. The reader is 
encouraged to explore the contents of the Pavement Sections sub-directories since only some 
of the sections are displayed or discussed below. The folder structure for pavement sections is 
shown in the illustration below.

Curb and Gutter

The Curb and Gutter Sections folder shown above contains Curb and Gutters as defined in the 
CDOT Standard Plans-M&S Standards M-609-01.

In the folder;

♦ C/G_Type2‐IB is curb and Gutter Type 2 (Section IB)

♦ C/G_Type2‐IIB, is curb and Gutter Type 2 (Section IIB)

♦ C/G_Type2‐IM is curb and Gutter Type 2 (Section IM) and

♦ C/G_Type2‐IIM is curb and Gutter Type 2 (Section IIM)

The Curb and Gutters are modeled such that:

1. When the curb and gutter is attached to pavement with cross slope of less than 4% 
while more than -4%, the gutter cross slope will be as defined in CDOT M&S 
Standards M-609-1.

2. When the curb and gutter is attached to pavement with cross slope greater than 4% or 
less than -4%, the gutter cross slope will match the cross slope of the pavement.

Important! The desire to have the gutter match the cross slope of the pavement is not a 
given. This is a design decision left up to the CDOT designer or engineer in 
charge of the project. While the curb and gutter sections in the CDOT standard 
template library reflect this decision, they can be modified for other design 
situations. See the section Display Rules and Parent Components on how to 
use different design criteria with these sections.
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Gutter Pan Cross Slope example

The CDOT M&S Standard M-609-1 was used to model the Type2‐IIB curb and gutter 
section.   The Type2‐IIB curb and gutter section shown here is a good example of how the 
new software is used to accommodate CDOT design decisions.

♦ Figure 10:C/G_Type2-IIB Pavement Less Than 4% - 10 shows C/G_Type2‐IIB in a 
normal cross slope condition and

♦ Figure 11:C/G_Type2-IIB Pavement Greater Than 4% - C/G_Type2‐IIB Pavement 
Greater Than 4% shows C/G_Type2‐IIB in a superelevated cross slope condition. 

Figure 10: C/G_Type2-IIB Pavement Less Than 4%

Figure 11: C/G_Type2-IIB Pavement Greater Than 4%
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Shoulder Sections

Shoulders

The figure below shows standard shoulder sections and how they are applied to a template 
design.

 HMA_Inside_Shoulder_5Lifts‐12z and HMA_Outside_Shoulder_5Lifts‐12z – The “stair-
step” design of the pavement edge is based on the Edge of Pavement Detail in Figure 4‐5 
of the CDOT 2005 Roadway Design Guide. Both sections contain:

♦ 12 ft wide outside shoulder

♦ The Hot Mix Asphalt pavement is 15 in thick, made up of five lifts: 

○ 2 in top lift 

○ 3 in middle lifts (three lifts)

○ 4 in bottom lift

♦ 6 in layer of ABC, Class 6 base

Both inside and outside shoulders are created for the right side of the pavement section. 
The Mirror or Reflect command is used to place the left side version for this shoulder 
section. 
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End Conditions Sections 

The 3 ‐ Sections – End Conditions folder contains predefined sections for end conditions 
complete with multiple cut and fill solutions. This folder is divided into groups for Curb and 
Gutter side slopes and Z slopes.

End conditions refer to roadside designs associated with the unpaved clear zone area or 
roadside safety items like Guardrail type 7, Guardrail type 3 and cut and fill slopes.

End Conditions treatment or the selection of roadside safety items is influenced by several 
factors. These factors will vary even within the project.

Below are some of the factors that will influence End conditions or component selection:

1. Clear Zone requirements

2. Design Speed and traffic volumes

3. Roadway Category or designation

4. Local terrain

5. Structures and obstructions

6. Right of Way limitations

7. Drainage requirements

8. Project budget

9. Local preferences

For CDOT, the primary reference material for the determination of End Conditions 
requirements based on Clear Zone, design speed and traffic volume is the Roadside Design 
Guide, 2006 Edition, published by American Association of State Highway and Transportation 
Officials (AASHTO). Other references include:

 CDOT 2005 Roadway Design Guide

 CDOT Standard Plans - M&S Standards

The designer needs to be familiar with the project, factors influencing design decisions and the 
above references.
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Z-Slope End Conditions

Z‐Slope End Condition sections describe the horizontal width and slope of the Z-Slope 
component. For Example,  Z12_6_to_1 defines a Z-Slope component that measures 12’ 
horizontally and has a slope of 6 to 1. The dimensions for the Z-Slope components come from 
Figures 4‐1 and 4‐5 of the CDOT 2005 Roadway Design Guide. Cut and fill slopes are based 
on Table 4‐2 Fill Slopes of the CDOT 2005 Roadway Design Guide.

Component and Point Properties

Component and Point Properties are major factors in determining how components are 
modeled. These properties are covered in more detail in later sections of this document but for 
now it is necessary to mention a few details regarding some of these properties.

In the Component Properties dialog, all of the cut and fill components have their Target set to 
the active surface. This allows the same end condition to be used on multiple projects without 
having to edit each component that lists the target.

When multiple end condition components begin at the same location in the template, the 
Priority determines the order of processing. The lowest numbered Priority is used first. If the 
slope does not intercept the existing ground (or other listed target), the next lowest priority is 
tried, and so on. Once a solution is found, processing stops for that location and no other slopes 
are tried. If no solution is found, the end condition fails and no sideslope is formed for that 
location. Processing occurs at each station where a template is ‘dropped’. See the Roadway 
Modeling chapter for more details on Template Drops.
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One differentiating factor for end condition sections is whether or not the checkbox for End 
Condition Is Infinite point property is toggled on. 

♦ When toggled off, the maximum length of the end condition is determined by its 
constraint. 

♦ When on, the end condition can extend past the distance defined in the constraint.

Standard fill height maximums for each slope were used to determine the default horizontal 
measurement (the horizontal constraint value in the Point Properties dialog box) for each slope. 
The horizontal measurement is not important for slopes that are allowed to be infinite, although 
it cannot be 0.00.
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Following is an example end condition section.

 Z12_6_to_1 – This section contains:

♦ (1) Fixed Z-Slope component measuring 12’ horizontally and a slope of 6 to 1.

♦ (1) 6 to 1 fill slope measuring 12’ horizontally.  Priority is set to 1.

♦ (1) 4 to 1 fill slope measuring 58’ horizontally.  Priority is set to 2.

♦ (1) 3 to 1 fill slope measuring 60’ horizontally.  End Condition is Infinite is toggled on. 
Priority is set to 3.

♦ (1) 6 to 1 cut slope measuring 12’ horizontally.  Priority is set to 4.

♦ (1) 4 to 1 cut slope measuring 58’ horizontally.  Priority is set to 5.

♦ (1) 3 to 1 cut slope measuring 60’ horizontally.  End Condition is Infinite is toggled on. 
Priority is set to 6.

Figure 12: Z12_6_to_1 End Condition Detail
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Components

This folder contains the components used to build sections and complete templates. They are 
sorted into subfolders based on their use. The illustration below shows the subfolder structure 
of the 4 – Components folder of the standard template library as it appears in the Create 
Template dialog box.

The standard components can be grouped into three functional categories: 

 linear elements

 fixed shape elements

 variable shape elements

The examples below represent typical component designs from each of these categories and the 
unique elements of the different component types.

Linear Elements

Components in the End Conditions folder fall into the linear elements category. These 
components are simple linear elements generally used to define options for side slopes. 
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A typical end condition component, like the one illustrated below, is a single line segment. The 
right point is constrained to the origin (the left point) with a horizontal and a slope constraint. 
The information for defining end condition components comes from Chapter 4 of the 2005 
Roadway Design Guide.

♦ Fill_6_to_1 – The typical end condition component, like the one illustrated above, is a 
single line segment. Its properties are:

○ Check for Interception

○ Place Point at Interception

○ Horizontal constraint with a Value of 12

○ Slope constraint with a Value of -16.67%

○ Both constraints have the point POSS as the Parent

Figure 13: Fill_6_to_1
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Fixed Shape Elements

The majority of the remaining components are classified as fixed shape elements. Fixed shape 
elements typically remain constant throughout a model unless design criteria dictates 
otherwise, in which case they are modified by Superelevation Controls, Points Controls or 
Parametric Constraints. See the Roadway Modeling chapter for additional details. The shape 
may be a polygon or it may be more complex like curb and gutter.

Important! These components have the component property Close Shape toggled on in 
order to be used in End-Area Volume calculations.

 ABC_Lane – This component is typical of most surfacing and subbase components. It 
contains:

♦ 4 points

♦ The top right point is constrained to the origin with horizontal and slope constraints. 
The value of the horizontal constraint is 12. The value of the Slope constraint 
is -2.00%. 

♦ The two bottom points are constrained to the points above by horizontal and vertical 
constraints. The value of the horizontal constraint is 0. The value of the vertical 
constraint is -0.50. These values are the same on both points.

Figure 14: Typical Fixed Shape Element
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Variable Shape Elements

There are few exceptions to the previous example. Currently those exceptions are limited to the 
Guardrail Type 7‐CE component in the \Barriers & Misc Components\Guardrail Type 7 folder 
and both Wing Wall_Cast‐in‐Place components in the \Barriers & Misc Components\Walls 
folder. 

Shapes of variable components are not fixed but depend on other design criteria and are used in 
areas of the project where a variety of field conditions require on-demand changes to the 
component design. The two component types previously mentioned are illustrated below.

Median Barrier Example

Guardrail_Type 7‐CE – This illustration shows how the shape of the barrier varies with the 
elevation changes of the travelways on either side of the median in a divided highway. This 
barrier has base width of 23” at a height of 34”or less. When the height is 34” or more, the 
base varies in width from 23” to a maximum of 26.75”. The design is based on the CDOT 
M‐606‐13 Guardrail Type 7 F‐Shape Barrier standard. 

Details of this component include:

♦ Two points on the bottom of the barrier are tied to the elevation on their respective side 
of the median. 

♦ The barrier height and width vary with the elevation difference between the two sides.

♦ To learn how to apply this median barrier, see Lab 3.4 in the Labs for InRoads V8i 
guide.

Figure 15: Guardrail Type 7-CE
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Wing Wall Example

WingWall_Cast‐in‐Place‐Fixed‐Base - This component is set up to adjust the wall height 
from pavement surface to the top of the wall based on maximum fill heights. It is used 
when the wall rises above the level of the roadway surface. Its sister component, 
WingWall_Cast‐in‐Place‐Fixed‐Top is used when the wall drops below the level of the 
roadway surface.

♦ The design of this component is based on the CDOT M‐601‐20 Wingwalls for Pipe or 
Box Culverts standard. As the maximum fill height for a wall height is reached, the wall 
height rises and the base of the wall expands to set base widths. 

○ Is made up of 10 wall components with different base widths.

○ Display Rules are used that only allow the display of the proper wall component 
based on the height of the wall.

Section Summary:

 The CDOT standard template library is organized into Templates, Pavement Sections, End 
Condition Sections and Components.

 There are several example templates in the completed template folders that you can use ‘as-
is’ or modify to fit your design criteria.

 Pavement Sections contain multiple components and can be used to build completed 
templates if one of the standard templates does not fit your design criteria.

 End Condition Sections match CDOT’s the standard sideslope design criteria.

 Components are the basic building blocks that can be used to build sections and templates. 

Figure 16: WingWall Cast-in-Place Fixed Base
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Template Development

Section Objectives:

 To become familiar with the different areas of the standard template library and how the 
sections and components can be used to create templates.

 To develop a background knowledge of how Points and Point Constraints work so the 
CDOT standard templates can be used more effectively.

 To learn the differences between Component types and how each is used in the CDOT 
template library.

 To learn how to apply basic Component Properties to control their display in the plan and 
cross sections.

 To learn how to create more complex components using the Parent and Display Rule 
component properties.

When constructing a template in InRoads, it is best to use the largest assembly that meets the 
design criteria. For example, if a 2 lane road with paved shoulders is required, the 
HMA_Crowned_B10 template may be used and lane, shoulder widths and lift thicknesses 
adjusted as required. If a standard template is used, it should be copied and renamed prior to 
editing. This will identify the template as being used for the project. 

It should be noted, however, that because the surfacing components are merged most templates 
are not suitable for a major overhaul. It would be tedious to add an additional lane to the 
HMA_Crowned_B10 template, for example. Therefore, the sample templates should only be 
used if they are very close to the desired design.

If there is not a template that will work, the sections should be used to create the desired 
template. There are sections available that cover most design situations with minor 
modifications. Modifications to the sections should be done prior to placing the section in the 
template. Editing the section before placing it in the template will reduce the amount of editing 
required if the section is used more than once.

It should be noted that most sections are set up to be placed on the right side of the origin. To 
place a section to the left of the origin, Reflect the section during placement. If the template 
design is symmetrical, the section can be placed on both sides using the Mirror option.

Certain specialty components may be required for a project (Type 7 Guardrail and Walls, for 
example). The component folders also contain these special components as well as all of the 
parts used to create the sections and templates. Components can be used in the template or used 
to build a new section, if required.

Finally, if there is not a component that can be used, a new component can be built. If the new 
component is a single unique part, it can be built directly in the template. If the new component 
is used multiple times, it should be created by itself in the proper component folder. This makes 
it easier to place the component in a template multiple times, or to place the component in 
multiple templates.

The information presented below is in reverse order to the sequence presented above. This was 
done so that the templates can be explained from the smallest building block to the complete 
template.
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Components

This section describes how template components are made and how they are edited. Examples 
from the template library are used to highlight key points.

Template Points

All components are made up of points. The points used to define a template become breakline 
features in the resulting design model. A template point is assigned a name and a style (which, 
in turn has a named symbology assigned) that determine the name and the style of the feature 
when the design surface is created with Roadway Designer. The features are then saved as part 
of the surface. Each point on the template must have a unique name. If the same name is used 
twice, it is appended with a numeric counter.

Point Constraints

Each point in a template can have constraints to determine how the points are allowed to move 
and their connectivity within a template. Many of the constraints have values such as distances 
or slopes from reference points. These reference points are called Parents. When a point 
moves, any point that lists it as a Parent is affected. Since the affected point may also be a 
parent for other points, there is a domino-type effect. Depending upon the constraint, 0, 1 or 2 
parent(s) may be required. Parent points do not have to reside in the same component as the 
affected point.

Important! Point Controls and Parametric Constraints override Point Constraints. For 
more information, see Point Controls and Parametric Constraints in the 
Roadway Modeling chapter.

Points may be:

 Fully constrained (two constraints). Fully constrained points appear as RED plus signs on 
the template. Most points on a standard template should be fully constrained. 

    

An example of a fully constrained point is shown here. The SubBase_Laneline‐Top point is 
constrained Horizontally and Vertically to the Conc_Laneline‐Top point. When the 
Conc_Laneline‐Top moves, the SubBase_Laneline‐Top point moves with it, maintaining 
horizontal and vertical distances as defined by the constraint values.
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 Partially constrained (one constraint). Partially constrained points appear as YELLOW plus 
signs on the template. It is sometimes beneficial to remove one constraint from a fully 
constrained point just for testing. 

For example, you may remove the slope constraint, then move a point to ensure the points 
below follow (as during superelevation), or that a Display Rule works correctly.

 Unconstrained (no constraints). Unconstrained points appear as GREEN plus signs on the 
template. 

Typically unconstrained points are points that will be assigned to follow a certain path, 
such as the Centerline of the template which follows the horizontal and vertical alignments. 
Other points that you know are to be controlled with point controls, such as the centerline 
of another set of lanes (as in a divided highway) following different horizontal and vertical 
alignments may also be unconstrained.

In general, points other than the centerline should be fully constrained unless there are special 
circumstances dictating otherwise. For an example, see the Point Controls section of the 
Roadway Modeling chapter.
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There are several different types of constraints you can place on points:

 Horizontal: Requires 1 Parent. The point is locked by a horizontal distance from the parent, 
as specified by the Value entered. 

  

An example can be found in most of the CDOT templates including the Section 
HMA_DrivingLane‐2Lifts. Here, the HMA_Lift2_Laneline‐Top point is horizontally 
constrained to the HMA_Lift1_Laneline‐Top parent point by a value of 0.00, meaning it will 
always have the same width from centerline as its Parent.

 Vertical: Requires 1 Parent. The point is locked by a vertical distance from the parent, as 
specified by the Value entered. 

   

An example can be found in most of the CDOT templates including the Section 
HMA_DrivingLane‐2Lifts. Here, the HMA_Lift2_Laneline‐Top point is vertically 
constrained to the HMA_Lift1_Laneline‐Top parent point by a value of -0.167, meaning it 
always maintains this depth from the top.

 Slope: Requires 1 Parent. The point is locked by a slope from the parent, as specified by the 
Value entered. 
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An example can be found in most of the CDOT templates including the Section 
HMA_DrivingLane‐2Lifts. Here the HMA_Lift1_Laneline‐Top point is slope constrained to 
the HMA_Lift1_Centerline‐Top parent point by a value of -2.0%.

 Vector Offset: Requires 2 Parents. The point is locked onto a vector as defined by the 2 
parents. The point may be offset perpendicular from the vector by entering a Value. 
Positive values are offsets to the right of the vector, Negative values to the left. 

   

An example can be found in many of the CDOT templates including HMA_Crowned_B10. 
Here the RT_HMA_Lift1_Laneline‐Top point is locked onto the vector defined by 
HMA_Lift1_Centerline‐Top to RT_HMA_Lift1_EOP‐Top, with a 0.00 Offset.

Note: The Parent points defining the vector do not have to be on either side of the 
constrained point, nor do they have to be in the same component. They are simply 
used to define a vector and can be anywhere in the template. This is most often 
used when the Parents form a vector that is variable during modeling, such as in 
superelevation, and you want the constrained point to follow the variable vector.

 Project to Surface: No Parent point is required, but a parent direction and a surface value 
must be specified. The point projects in the direction selected until it intercepts the surface 
listed. 

   

An example can be found in several of the CDOT templates.

Important! If two adjacent points in the same component project to the same surface, 
the component will ‘trace’ the surface in between the points. 
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 Project to Design: No Parent is required. The point is projected at the slope or vector 
defined by the second constraint and stops when it encounters the design model. This is 
most often used when a subgrade must tie to a variable sideslope. The Value listed 
determines the maximum distance the projection can go and a positive value forces the 
projection to the right, negative to the left. A zero Value allows an unlimited distance to 
either the right or left, whichever interception is closer.

 Horizontal Maximum: Requires 2 Parents. The point is locked to a horizontal distance 
from whichever parent is further to the right, with the distance specified by the Value. 

 Horizontal Minimum: Requires 2 Parents. The point is locked to a horizontal distance from 
whichever parent is further to the left, with the distance specified by the Value. 

 Vertical Maximum: Requires 2 Parents. The point is locked to a vertical distance from 
whichever parent is higher, with the distance specified by the Value. 

   

An example can be found in the CDOT template Guardrail_Type 7‐CE. This barrier is 
designed to be used as a median barrier in a divided highway. The barrier changes height 
based on the elevations of the different connect points, but must maintain a certain height 
above whichever connect point is higher. The constraints for the Barrier Top are shown. 
When this barrier is used between sets of lanes that follow different verticals, the top of the 
barrier will always remain a set height above the higher of the vertical alignments.

 Vertical Minimum: Requires 2 Parents. The point is locked to a vertical distance from 
whichever parent is lower, the distance specified by the Value. 

   

An example can be found in the CDOT template Guardrail_Type 7‐CE. This barrier is 
designed to be used as a median barrier in a divided highway. The barrier changes height 
based on the elevations of the different connect points, but the base must be below 
whichever connect point is lower. The constraints for the Barrier Toe are shown. (The 
parents are the Barrier Toe points which are derived from the Connect points.)
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 Angle Distance: Requires 2 Parents. The point is locked to an angle from the line defined 
by the two parents and a distance along the defined angle from Parent 1. This is used when 
you want to maintain a rigid shape, even when the base rotates. An example would be a 
rigid barrier sitting on pavement that rotates in superelevation.

 Style: No Parent is required. The Style constraint overrides the other constraints as needed. 
When toggled on, a Style is specified. When the template is used in Roadway Designer, the 
active surface and geometry project are searched for an alignment or feature with the 
specified style. If found, the template point follows the feature or alignment. If the 
Horizontal toggle is on, this overrides the constraint controlling the horizontal placement of 
the point. If the Vertical toggle is on, this overrides the constraint controlling the vertical 
placement of the point. If the Both toggle is on, this overrides both of the listed point 
constraints and a variable slope and width is used to connect with the feature or alignment. 
A negative range value sets a horizontal limit and forces a search to the left, positive to the 
right. If the range is set to 0, the closest instance of the Style is found. 

Labels

All of the constraints with the exception of Style and Project to Design can have a Label. A 
Label is a variable that can be assigned start and stop values (by station range) in Roadway 
Designer using Parametric Constraints. If a Parametric Constraint is assigned for the label, 
the value in the template is ignored. If no Parametric Constraint is assigned for the label, the 
value listed for the constraint in the template is used.

For example, you can assign the same label to each of the lower points in a lift, then with one 
entry in the Parametric Constraints dialog, you can change the lift depth for the entire 
alignment or any station range, even across multiple templates as long as the same labels are 
used in the different templates.

Labels must be keyed in for the first use in a template, then are available in the drop-down in 
for future use in that template.

See the Parametric Constraints section of the Roadway Modeling chapter for details.

Creating Components

A component is a series of points that forms either an open or closed shape used in defining a 
typical section or template. Components typically represent different types of roadbed 
materials or sideslopes (asphalt lifts, aggregate base, subgrade, cut, fill, etc.). Components are 
named and assigned styles (materials). 

The Style assigned to the component controls its display in Create Template, Roadway 
Designer and Cross Sections. In addition, the Style associated with the component assigns the 
category of the volume if the component is used in end-area volumes.

There are six different methods of adding new components: Simple, Constrained, 
Unconstrained, Null Point, End Condition and Overlay/Stripping.
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The first three of these methods create standard components. With each, the first point placed is 
unconstrained unless it is snapped onto an existing point that already has constraints. The 
method used to create a general component does not stay with the component once it is created. 
The points created with either of these methods can be edited or deleted and new points can be 
inserted.

 A component created with the Simple command initially consists of four points that form a 
parallelogram. The shape is defined by slope, width and thickness (default values: 2%, 12 
ft and 0.4 ft, respectively). The Simple method can be used to create a pavement lift, for 
example. The upper-right point is constrained to the placement point by slope and 
horizontal constraints, while the two lower points are constrained to the points above them 
by horizontal and vertical constraints.

With the following options, you can either sketch in the points that you want, then edit or add 
constraints to determine the precise locations of each point, or you can use the key-ins available 
through the Dynamic Settings. See the previous section on Dynamic Settings for key in details.

 A component created with the Constrained command is initially made up of points where 
each is constrained to the previous one with horizontal and vertical constraints, so that if 
the initial point is moved, all of the other points move as well.

 A component created with the Unconstrained command consists of points with no 
constraints (the points can move independent of each other).
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There are three specialized components:

 A Null Point is a component made up of one point that is initially unconstrained. Null 
Points can be Parents for points in other components, in effect being used for reference. For 
example, a Null Point can be assigned to follow a right-of-way limit (alignment or feature) 
using Point Controls in Roadway Designer, then used as the horizontal constraint for a 
sideslope preventing it from exceeding the limit. 

Another example is when the control point on a divided highway is the imaginary point 
where the two pavement sections would intercept in the middle, such as the Control point 
in the HMA_Divided_TypeA_4Lane CDOT template. In this case, the template is based off 
the Control point, but the point is not part of any of the components.

Note: Null Points, by definition, are not triangulated. They may, however, be added to the 
design surface as non-triangulated features when using the Create Surface 
command. See the Roadway Modeling Chapter for additional details.

 End conditions are components that can seek targets like surfaces, alignments or features, 
and typically form the sideslopes of the design. 

Multiple end conditions may be used together to form a complete sideslope and multiple 
sideslopes or alternates may begin at the same location on the template. When this occurs, 
the end conditions are assigned a priority determining the order in which they are processed 
with the first one able to form a complete sideslope being the one that is used at that 
location while any other sideslopes are discarded. CDOT End Conditions are discussed in 
the following section.
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 Overlay/Stripping components can be built to either add leveling courses below pavement 
overlays or as stripping components to mill existing pavement. 
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Typical CDOT Surfacing Component

The average surfacing component is a closed shape of four points. It defines a single layer of a 
specific material (in this example it’s hot mix asphalt). Both the points and the shape itself have 
a list of attributes called properties.

Component Properties

The following steps illustrate how to change component attributes. To edit the component 
properties:

1. <R> on a line of the shape and choose Edit Component from the menu (you can also 
<D><D> on the line to display the Component Properties dialog).

2. Key in the desired Name.

3. Key in the desired Description.

4. Select the desired Style from the drop down menu.

5. <D> Apply to accept the changes.

Note: Components use generic styles for the material they represent. Access styles 
for specific grades of material (based on the Pay Item Code Book) through the 
Component Properties dialog.
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Point Properties

The following steps illustrate how to change point attributes. 

1. <R> on the point and choose Edit Point from the menu to access the Point Properties. 
(You can also <D><D> on the Point to display the Point Properties dialog.)

2. Key in the desired Name. The name can also be selected from the drop down menu. 
Selecting a name from the menu also changes the Surface Feature Style. Names 
selected from the menu can then be edited if necessary.

3. Select the desired Surface Feature Style.

4. Select a Type for Constraint 1. See the previous section on constraints for additional 
information on the options available.

5. Select a Parent 1 using the drop down menu or the target button. Select the Parent 2 if 
required by the constraint type.

6. Key in a Value.

7. Key in a Label if desired. See the previous section on Labels for more information.

8. <D> Apply to accept the change.

9. <D> Close to dismiss the Point Properties dialog.
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Point properties for the example surfacing component:

♦ The point HMA_Lift1_Laneline‐Top has two constraints (which makes it fully 
constrained).

○ Constraint 1 is a Horizontal constraint measured from the point 
HMA_Lift1_Centerline‐Top with a Value 0f 12. This sets the width of the 
component.

○ Constraint 2 is also measured from HMA_Lift1_Centerline‐Top. It is a Slope 
constraint that defines the cross-slope of the component, which is set to a Value of        
‐2.00%. Horizontal and slope constraints are typically used when defining the top 
point of a component.

♦ The point HMA_Lift2_Centerline‐Top also has two constraints.

○ Constraint 1 is a Horizontal constraint with a Value of 0, which places the point 
directly under its Parent 1 (HMA_Lift1_Centerline‐Top).
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○ Constraint 2 has a Value of 0.17 (2”) that defines the thickness of the component 
(measured from its Parent 1 point, HMA_Lift1_Centerline‐Top). The point 
HMA_Lift2_Laneline‐Top has the same constraints as HMA_Lift2_Centerline‐Top, 
except the Parent 1 is HMA_Lift1_Laneline‐Top for both constraints.

♦ This configuration of point constraints is the most efficient set-up for pavement 
components. It allows the user to change the width of the component by controlling a 
single point (HMA_Lift1_Laneline‐Top) while maintaining a constant pavement 
thickness.

Complex Surfacing Component

On resurfacing projects its common that a leveling course is required below the pavement 
overlay lift. Additionally pavement stripping (milling) is also a common requirement.
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A leveling course or courses can be added to define the depth and composition (component 
style) of material to be placed. 

The above illustration contains a single leveling course designed to a maximum depth of 4 
inches.  Based on project needs this component can be configured to achieve either a maximum 
depth or achieve variable depths. Through various top/bottom options it allows the flexability 
to provide a multitude of solutions. The intent of the shown component is to have the top 
constrained to a overlay component allowing the leveling course to follow superelevation or 
other controls applied to the overlay course. The bottom option can specifiy  a defined depth or 
be configured with a zero depth causing the bottom of the leveling course to follow existing 
conditions at any depth.  As defined, the bottom of the  leveling course will tie into the higher 
of existing conditions, or 4 inches below the bottom of the overlay.
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A stripping component is unique that it is defined by it’s bottom, constructs vertically and 
overlays other components in the template.  This component also contains options for 
contraining it’s vertical limit to meet project needs. The critical part of building a stripping 
component is to activeate the toggle that defines it as a stripping component (vs. a leveling 
component).
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A variation of a typical surfacing component is HMA_Outside_Shldr‐Lift2. This component has 
two additional points that define the stair-step found at the edge of asphalt.

The three bottom points are defined in the same manner as a typical surfacing component for 
the point HMA_Lift2_Laneline‐Top. Also, HMA_Lift2_Hinge‐Top is defined like 
HMA_Lift1_Laneline‐Top above. However, the constraints on point HMA_Lift2_EOP‐Top are 
different. Constraint 2 uses Vector‐Offset. This type of constraint projects a line through the 
two parent points (HMA_Lift2_Shoulder‐Top and HMA_Lift2_Hinge‐Top). The Value defines a 
perpendicular offset to that projected line (a positive value is to the right and a negative value is 
to the left). Because the value in this example is ‘0’, the child point is placed on the projected 
line. 

This constraint forces the segment between points HMA_Lift2_Hinge‐Top and 
HMA_Lift2_EOP‐Top to match the cross-slope of the segment to its left and maintain the 
continuity of the cross-slope, even through transitions for super elevation.
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Subbase component

Subbase components have many of the same features used in surfacing components. The 
SubBase_Outside_Shoulder component has five points that define the subbase under the 
shoulder. They are set up like the corresponding points in Surfacing Example 2. However, the 
POSS uses a Horizontal and a Slope constraint. This is done in order to maintain the slope from 
the Subbase_EOP‐Top to the POSS.
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End Condition components

End condition components are used to form the sideslopes of the design. For example, they 
project from the design pavement to the existing ground. Therefore, they have some unique 
component and point properties.

Component Properties

The component properties for End Conditions have an additional area for End Condition 
Properties. These properties list the Target Type and Priority for processing end condition 
components.
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Target Type 

This property determines what the end condition will try to intercept. The Target Type  
affects the way the side slope is constructed. Feature XYZ, Alignment XYZ, and Style XYZ 
will override the slope constraint and use whatever slope is necessary to tie to the target 
location. All other Target Types observe the slope constraint to locate the point.

Additional drop down menus are displayed below the Target Type. These are used to list 
the target of the type specified in the Target Type. 

The information required for each Target Type is:

♦ Surface – Set to Active (which will tie to whatever surface is active) or to a specific 
surface. Surface is the most common Target Type and used by most CDOT standard 
sideslopes.

♦ Elevation – Enter the target elevation in the Vertical Offset field. This can be useful for 
setting elevations of benches, for example.

♦ Feature XY, Feature Elevation, and Feature XYZ – Identify a surface (Active can be 
used) and the Feature Name that you want to seek. For example, you may need to tie 
into an existing curb or an existing ditch feature.

♦ Alignment XY, Alignment Elevation, and Alignment XYZ – All must have a horizontal 
alignment specified. Alignment Elevation and Alignment XYZ also need the Vertical 
Alignment identified. For example, Alignment Elevation can be used to tie a special 
ditch into the elevation of a vertical alignment.

♦ Style XY, Style Elevation, and Style XYZ – Specify a Style. These targets work just like 
the previous Feature and Alignment targets, except the sideslope looks for a Style used 
in the active surface or geometry project instead of a specific feature or alignment 
listed by name. For example, if you are wanting to tie into an existing curb, but the 
curb is made up of multiple features, you can tie into the style for the curb and the 
sideslope finds the first occurrence at each template drop.

Note: The most often used Target Type is Surface.
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Priority 

♦ This property determines the order in which end condition components are processed. 
The processing order is from the lowest numbered priority to the highest. The flattest 
slopes are set to the lowest numbered priority so that they are processed first. If you do 
not set the priorities ahead of time, they can be set when the end conditions are tested.

Point Properties

For points that are part of an end condition, four additional check boxes for End Condition 
Properties are added to the Point Properties.

♦ Check for Interception -   If on, the point checks for an interception of the target 
between the previous point and this one. In general, turn this option on for the last point 
in a cut or fill definition. An example of where it would be turned off is for the 
foreslope of a ditch that has a flat bottom. 

♦ Place Point at Interception - When on, the point will be constructed where it contacts 
the target. When off, the point is constructed as defined by its constraints. Turn on this 
option in most cases when Check for Interception is on.

♦ End Condition is Infinite – When on, the point will extend past its defined width in 
order to contact its target. When off the point must reach its target within its defined 
width in order to be constructed. This option is used for the steepest cut and fill slope 
defined in the template. Since it is off for shallower sideslopes, they will not extend 
beyond their constrained horizontal distance.

♦ Do Not Construct – When on, the point will be solved for as normal, but will not be 
used when creating the component.
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Display Rules and Parent Components

Display Rules and Parent Components are component properties that determine when a 
component is displayed. They are often useful for turning off and on different components 
based on what is happening in other areas of the template and therefore can be used to assist in 
changing the template based on certain CDOT design decisions.

Display Rules are conditional expressions defined by horizontal or vertical offsets between 
specified points, the slope between two points, or the display of another component. For 
example, when the distance between two inside edges in a divided template is > X, a median 
ditch component can be ‘turned on’; when it is < X, a barrier can be ‘turned on’ and the median 
ditch ‘turned off’.

 A Parent Component controls the display of associated components. For example, a specific 
component is displayed only when its Parent component is displayed.

 Use Display Rules to change the basic shape or type of a component used under certain 
conditions, as in the Curb & Gutter through superelevation example below. 

 Use Display Rules to have InRoads decide between a series of components, such as testing 
the height of wall needed and using different, but standard width bases based on that 
height, as in the Wing Wall example below.

 Use Parent components for a group of components that operate as a unit and are turned on 
or off together, as illustrated in the Benching example. 

Curb & Gutter through superelevation

An example of a design decision being built into a template can be found in the CDOT 
typical section library in the curb and gutter sections. The Curb and Gutters are modeled 
with unique elements.  The elements unique to the Curb and Gutter section are the two curb 
components attached; one component is modeled with a standard cross slope for the gutter 
pan and the other is modeled to match the cross slope of the pavement. If this is not desired, 
see the note at the end of the section on changing or eliminating this decision.

The assumed design decision is:

○ When the cross slope is between +4% and - 4%, a -1” per foot slope is used for the 
gutter.

○ When the cross slope is greater than +4% or less than - 4%, the slope of the gutter 
pan matches the cross slope of the driving lanes.

Conforming to the design standard or design decision in this case is accomplished using 
Display Rules. Display Rules are a list of criteria that determine when a particular 
component is displayed. The Parent Component property is also used. Components that 
are associated with a Parent component are only displayed when the Parent Component is 
displayed. In this example the curb components are parents to the ABC components. This 
insures that the proper ABC components are displayed together with their respective curb 
components. This is necessary due to the different slope constraints of the two components 
described in the previous section.

In this example, using the component C/G_Type2‐IIB, the slope of the gutter pan changes 
based on the cross slope of the driving lanes (typically needed through superelevated 
areas). This would be extremely difficult to modify the component using point controls. 
However this can be accomplished easily using Display Rules. 
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To create a Display Rule:

1. <R> on the component and select Edit Component.

Note: Display Rules can be created while editing any component in the template, 
then assigned to other components as necessary.

2. <D> the Edit button next to the Display Rules field. This displays the Component 
Display Conditional Expression dialog box.

3. To create a new rule, <D> Add. This will bring up the Display Rule dialog box.

Note: The Template Display Rules at the bottom of this dialog list all the rules 
available in the active template. The area at the top of the dialog show the rules 
assigned to the particular component being edited.
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4. Key in a Name for the rule (spaces are removed from the name automatically). 

Note: The Display Rule name cannot be changed in this dialog once it has been 
created. To change the name, go to the active template tree, right-click on the 
Display Rule and choose Edit.

5. Key in a Description.

6. Select the Type from the drop down menu. Select the component or point names as 
required. For the Component Is Displayed type, a component name is selected. For all 
other types, first and second points are selected.

Note: For a list of the different Types available and how they are used, see the 
Display Rule section of the InRoads Online Help.

7. Select the mathematical expression to be used.

8. Key in the Value that the expression is tested against.

9. <D> OK. This dismisses the Display Rule dialog box.

In the rule displayed above, if the slope between point Laneline‐Top and point Curb‐
Gutter‐top is less than or equal to +4.00% or -4.00% (because Absolute Slope is used) 
then the component will be displayed. This is determined at every template drop during 
processing.

10. Back on the Component Display Conditional Expression dialog box, highlight the 
desired rule from the Template Display Rules list.

11. <D> the Selected Rule button. This adds the rule to the Conditional Expression.
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12. <D> OK.

13. In the Component Properties dialog box, <D> Apply.

14. <D> Close to complete the process.

This component will now be displayed while the pavement component has a cross 
slope between +4% and -4%.

Important! If the decision is made that the gutter must match the pavement cross slope at a 
different slope, edit each of these rules and change the value to a different 
slope. If you do not want the match the pavement slope in super, edit the 
section, toggle on Display All Components and delete the two dashed-line 
components. Then, Delete the two Display Rules or remove them from the two 
components.
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Wing walls

Multiple Display Rules can be used to further define when a component is to be displayed. 
In the component WingWall_Cast‐in‐Place‐Fixed‐Base, a number of separate components 
have been used to define the base of the wall. The particular component used is determined 
by the height of the wall. As in the previous example, this involves an assumed design 
decision and can be changed as needed.

 The component WingWall‐h3 uses two Display Rules.

○ Greater_2.5ft, displays the component if the vertical difference between points 
Wall_Top‐Front and Swale Toe is greater than 2.5 feet.

○ Less_3.5ft, displays the component if the difference between the points Wall_Top‐
Front and Swale Toe is less than or equal to 3.5 feet.

The And between the rules means that both rules must be true before the component can be 
displayed.

To add multiple display rules to a component:

1. <R> on the component and select Edit Component.

2. <D> the WingWall‐h3 component.

3. <D> the Edit button next to the Display Rules field. This displays the Component 
Display Conditional Expression dialog box.

4. Highlight the desired rule from the Template Display Rules (Greater_2.5ft in the 
example).

5. <D> the Selected Rule button.
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6. <D> the desired Boolean Operator button (AND in the example).

7. Highlight the next display rule to be used (Less_3.5ft in the example).

8. <D> the Selected Rule button.

9. Repeat steps 5, 6, and 7 until all the desired rules are added.

10. <D> OK.

11. <D> Apply on the Component Properties to save the display rule.

Note: Rules can also be grouped using the parentheses.
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Benching

The display of one component can be tied to the display of another by setting a Parent 
Component. Using the HMA_Urban_4Lane template as an example, the Benching 
components are children of the C/G_Type2‐IIB components (and the cut and fill 
components are children of the benching components). This displays the sideslopes 
attached to the curb with the 1” per foot gutter slope only when that curb is displayed. The 
parent component must exist within the template. 

To select a parent component:

1. <R> on the ‘child’ component and select Edit Component.

2. Select the Parent Component using the drop down menu or the target button.

3. <D> Apply on the Component Properties dialog box to save the change.

4. <D> Close to dismiss the Component Properties dialog box.
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Sections

Components are used to build larger assemblies in the CDOT standard ITL called Sections 
(which are used in turn to build templates). A section is a combination of components that are 
copied from within the template library and pasted into the new section. Any time a group of 
components will be used more than once (in the same template or in other templates) it should 
be built as a section. Building sections makes it easier to assemble templates because multiple 
components are placed at one time. 

Using Components to Build a Section

This example illustrates the steps used to create an 11’ driving lane section with three lifts of 
asphalt and an aggregate base.

1. Expand the template library folder structure to show 2 – Sections –Pavement > 
Driving Lane Sections > Hot Mix Asphalt.

2. <R> on the Hot Mix Asphalt folder and select New > Template from the menu.

3. Key in the name for the new section (HMA_11ft_DrivingLane-3Lifts in this 
example).
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4. Expand the template library folder structure to show 4 – Components > Aggregate 
Bases > Driving Lanes.

5. <R> on ABC_Lane and select Rename.

6. Key in the new name (ABC_11ft-Lane for this example).

7. <D> <D> on the ABC_11ft-Lane component in the template library to make the 
ABC_11ft-Lane active.

8. <D> <D> on the ABC_Laneline-Top point to edit the Point Properties.

9. Change the Value of Constraint 1 (the Horizontal constraint) to 11.

10. <D> Apply, then <D> Close.

Note: To change the thickness of the component, edit the Vertical constraint on the two 
bottom points of the component.

Figure 17: Set Horizontal Constraint
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The aggregate base component is ready for use. Next, modify the asphalt lane components.

11. Expand the template library folder structure to show 4 – Components > Pavements > 
Hot Mix Asphalt > Lanes.

12. Repeat steps 5 through 10 above for HMA_Lane-Lift1, HMA_Lane-Lift2, and 
HMA_Lane-Lift3. Rename the lanes and change the value of Constraint 1 to 11.

13. Select Tools > Options from the Create Template menu bar.

14. Turn off the Apply Affixes check box.

15. Set the Step Options to 0.1 for both X and Y.
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16. <D> OK.

17. Select Tools > Dynamic Settings.

Steps 13 through 17 make it easier to place data into a new section. Turning off the affixes 
prevents getting LT_LT_ and RT_LT_, etc. appended to point names. The Step options 
create an invisible grid that helps when placing components. The Dynamic Settings is a 
dialog box where the step interval can be changed and precision key-ins can be used to 
place components.

The next steps place the components into the new section.

18. <D> <D> on the new section (HMA_11ft_DrivingLane‐3Lifts).
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19. <D> on the HMA_11ft- Lane-Lift1. This will display the component in the Preview 
window.

20. <D> and hold on the green”+” in the Preview window.

Figure 18: HMA_11ft-Lane-Lift1 Component
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21. Move the pointer into the magenta square in the Template View Window. The Dynamic 
Settings dialog box will show “0.00” for X and Y when the pointer is on the template 
origin.

Important! This assumes the magenta square is located at the 0,0 coordinate in the 
template view. If it is not, you can use Set Dynamic Origin to move it 
there, or make certain you drop the template on the 0,0 coordinate. You 
can also right-click on the insertion point after it’s dropped and choose Set 
Template Origin to move it to 0,0.

22. Release the left mouse button to place the component.

23.  <D> on the HMA_11ft- Lane-Lift2. This will display the component in the Preview 
window

24. <D> and hold on the green”+” in the Preview window.

Figure 19: Place First Component
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25. Move the pointer onto the HMA_Lift2_Centerline‐Top point. The “+” turns white to 
indicate that the points are in the same location.

26. Release the left mouse button to place the component.

27. Repeat steps 23 through 26 for HMA_11ft‐ Lane‐Lift3 and ABC_11ft‐Lane.

28. All of the components that make up the section are now placed. However, the point names 
used between lift 3 and the ABC need to be changed. When components are connected, 
shared points take the point name of the component placed first.

29. <D> <D> on the point HMA_Lift4_Centerline-Top to display the Point Properties 
dialog box.

30. Use the Name drop down menu to select ABC_Centerline-Top.

31. <D> Apply.

32. <D> Close to dismiss the Point Properties dialog box.

Figure 20: Place Second Component
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33. <D> <D> on HMA_Lift4_Laneline-Top to display the Point Properties dialog box.

34. Use the Name drop down menu to select ABC_Laneline-Top.

The section is now ready for use in a template.

Figure 21: Change Point Properties

Figure 22: Final HMA_11ft_DrivingLane-3Lifts
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Templates

Building a symmetrical template

This example uses the lane section created above along with modified shoulder sections and 
end conditions to create a complete two lane template.

Select Tools > Options from the Create Template menu bar.

1. Turn on the Apply Affixes check box.

2. <D> OK.

When Sections and Components are placed, the point names are appended with LT_ and RT_. 
This will replace the default 1, 2, etc. that is affixed to duplicate point names.

3. Expand the template library folder structure to show 1 – Templates.
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4. <R> on the 1- Templates and select New > Template.

5. Key in a Name for the template (HMA_2Lane-11ft_Shldr-4ft).

6. <D> <D> on HMA_2Lane-11ft_Shldr-4ft. This makes the new template active.

7. Expand the template library folder structure to show 2 – Sections - Pavements > 
Driving Lane Sections > Hot Mix Asphalt.

8. <D> on the HMA_11ft_DrivingLane-3Lifts section so that it is displayed in the Preview 
window.
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9. In the Preview window, <D> and hold the green “+”.

10. Move the pointer into the Template View window and <R> while still holding the left 
mouse button. This displays a right click menu. When the right click menu is displayed, the 
left mouse button can be released.

11. Select Mirror (using either the left or right mouse button).

12. Move the pointer to the template origin (magenta square). The Dynamic Settings dialog 
box will show “0.00” for X and Y when the pointer is on the template origin.
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Important! This assumes the magenta square is located at the 0,0 coordinate in the 
template view. If it is not, you can use Set Dynamic Origin to move it there, 
or make certain you drop the template on the 0,0 coordinate. You can also 
right-click on the insertion point after it’s dropped and choose Set 
Template Origin to move it to 0,0.

13. <D> to place the sections.

By selecting Mirror from the right click menu, both the left and right driving lanes were 
placed at the same time. Turning on the Affixes labeled the left side points with the LT_ 
prefix and the right side points with the RT_ prefix.

14. Expand the template library folder structure to show 2 – Sections - Pavements > 
Shoulder Sections > Hot Mix Asphalt.

15. <D> <D> on the HMA_Outside_Shoulder_3Lifts-12z. The section is displayed in the 
window.

This section models a shoulder to match the pavement section as well as the proper edge of 
pavement configuration. However, the 12 foot width must be reduced to 4 feet.

16. <D> <D> on the point HMA_Lift1_EOP-Top to display the Point Properties dialog box.

17. Change the Value of Constraint 1 (the Horizontal constraint) to 4.00.

18. <D> Apply.
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19. <D> Close.

Notice that by changing a single point (HMA_Lift1_EOP‐Top), all of the lifts in the section 
were modified.

The width of the ABC lift must be modified, otherwise, it will protrude above the finished 
grade of the side slope.

20. <D> <D> on the point ABC_EOP-Top to display the Point Properties dialog box.

21. Change the Value of Constraint 1 (the Horizontal constraint) to 1.50.

22. <D> Apply.



Page 260 Colorado Department of Transportation

Chapter 9 - Typical Sections A Practical Guide for Using InRoads V8i SS2

23. <D> Close.

Next, add the shoulders to the driving lanes.

24. <D> <D> HMA_2Lane-11ft_Shldr-4ft. 

25. <D> on the HMA_Outside_Shoulder_3Lifts-12z. 

26. In the Preview window, <D> and hold on the green “+”.

27. Move the pointer onto the point RT_HMA_Lift1_Laneline-Top so that the “+” turns white 
then release the left mouse button.

Note: Mirror is still on, so both shoulders are placed.

All of the components that make up the driving surface have been placed. Next, the vertical 
lines inside the template are removed. This will make each lift a single component.
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28. Place the pointer on one of the vertical lines and <R> to display the right click menu.

29. Select Merge Components. This removes the vertical line from the template.

30. Repeat steps 25 and 26 for all of the vertical lines inside the template. The final result is 
illustrated below:

Finally, the end conditions are added to the template.

31. Expand the template library folder structure to show 3 – Sections – End Conditions > 
Z-Slope End Conditions > Low Speed End Conditions.

32. <D> on the Z12_4_to_1 section.

33. In the Preview window, <D> and hold on the green “+”.
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34. Move the pointer onto the point RT_HMA_Lift1_EOP-Top so that the “+” turns white then 
release the left mouse button.

Both end conditions are placed and the template is complete.

Note: The vertical lines that appear inside the template in the illustration above are 
actually the point symbols. The points themselves are not connected vertically 
since the components were merged.
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Building an Asymmetrical Template

This example builds one half of a divided highway. It has two 12’ driving lanes, a 4’ shoulder 
on the right and a 10’ shoulder on the left. The pavement is 12” concrete. 

Start by creating an empty template.

1. Expand the template library folder structure to show 1 – Templates.

2. <R> on the 1- Templates folder and select New > Template.

3. Key in a name for the template (CONC_Divided_4Lane_Left-Side).

Make a copy of a concrete pavement section and edit the copy to match the pavement design.

4. Expand the template library folder structure to show 2 – Sections - Pavements > 
Driving Lane Sections > Concrete.

5. <R> on the CONC_Pvmt_12ftx13in section and select Copy from the right click menu.



Page 264 Colorado Department of Transportation

Chapter 9 - Typical Sections A Practical Guide for Using InRoads V8i SS2

6. <R> on the Concrete folder and select Paste from the right click menu.

7. <R> on the CONC_Pvmt_12ftx13in1section (this is the copy created in steps 5 and 6) 
and select Rename from the right click menu.

8. Key in a new name (CONC_Pvmt_12ftx12in).

9. <D> <D> on the CONC_Pvmt_12ftx12in section.

10. <D> <D> on the SubBase_Centerline-Top point.

11. Change the Value for Constraint 2 (the Vertical constraint) to -1.00.

12. <D> Apply.

13. <D> Close.
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14. Repeat steps 10 through 13 for the point SubBase_Laneline-Top, 
SubGrade_Centerline-Top, and SubGrade_Laneline-Top.

Edit existing concrete shoulder sections to match the pavement design.

15. Expand the template library folder structure to show 2 – Sections - Pavements > 
Shoulder Sections > Concrete.

16. <D> <D> the CONC_Inside_Shoulder-4ft-12z Section.

17. <D> <D> on the SubBase_Shoulder-Top point.

18. Change the Value for Constraint 2 (the Vertical constraint) to -1.00.

19. <D> Apply.
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20. <D> Close.

21. Repeat steps 10 through 13 for the point SubBase_Hinge-Top.

22. <D> <D> on the CONC_Outside_Shoulder-10ft-12z section.

23. Repeat steps 17 through 21 for the same points in this section.

Assemble the template from the modified sections and add the appropriate end conditions.

24. Expand the template library folder structure to show 1 – Templates.

25. <D> <D> on the CONC_Divided_4Lane_Left-Side template.

26. <D> on the CONC_Pvmt_12ftx12in section.

27. In the Preview window, <D> and hold on the green “+”.

28. Move the pointer into the Template View window and <R> while still holding the left 
mouse button. This displays a right click menu. When the right click menu is displayed, the 
left mouse button can be released.
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29. Select Reflect (using either the left or right mouse button).

30. If Mirror is on, <R> on Mirror to turn it off.

31. Move the pointer to the template origin and <D> to place the section.

32. In the Preview window, <D> and hold on the green “+”. Note: the same section is used 
to place the second driving lane.

33. Move the pointer onto the LT_Conc_Laneline-Top point and release the left mouse 
button to place the section.

34. <D> on the CONC_Outside_Shoulder-10ft-12z section.

35. In the Preview window, <D> and hold on the green “+”.

36. Move the pointer onto the LT_Conc_Laneline-Top1 point and release the left mouse 
button to place the section.

37. <D> the CONC_Inside_Shoulder-4ft-12z section.

38. In the Preview window, <D> and hold on the green “+”.

39. Move the pointer into the Template View window and <R>. Select Reflect. This turns the 
reflect option off.
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40. Move the pointer onto the Conc_Centerline-Top point. <D> to place the section. All of 
the components for the driving surface have been placed. The template looks like the   
illustration below. 

Remove the vertical lines from inside the template. 

41. Place the pointer on one of the vertical lines and <R> to display the right click menu.

42. Select Merge Components. This removes the vertical line from the template.

43. Repeat steps 41 and 42 for all of the vertical line inside the template. 

44. Rename points (indicated in the illustration below) to reflect their location.

45. <D> <D> on the Conc_Centerline-Top point.

46. Select Conc_Shoulder-Top from the Name drop down menu.

47. Change the name to Conc_ Inside_Shoulder-Top.
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48. <D> Apply.

49. Repeat steps 44 through 47 for the other five points. Select the appropriate material name 
for each point. Substitute Outside_ for the three left-most points and Inside_ for the 
three right-most points. The template should look like the illustration below.

50. <D> Close to close the Point Properties dialog.

Finish the template by attaching the end conditions.

51. Expand the template library folder structure to show 3 – Sections – End Conditions > 
Z-Slope End Conditions > High Speed End Conditions.
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52. <D> on the Z12_6_to_1 section.

53. In the Preview window, <D> and hold on the green “+”.

54. Move the pointer onto the RT_Conc_EOP-Top point. Release the left mouse button to 
place the end condition. 

55. Using the same end condition section in the Preview window, <D> and hold on the green 
“+”.

56. Move the pointer into the Template View window and <R>. Select Reflect. This turns the 
Reflect option on.

57. Move the pointer onto the LT_Conc_EOP-Top point. <D> to place the section. This 
completes the template.
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Modifying Templates to Fit a Project

In some instances, the sample templates can be used for a project with only minor 
modifications. The first example uses the HMA_Urban_4Lane template and modifies it by 
adding a sidewalk component behind the curb. The second example starts with the 
HMA_Crowned_B10 template and adds a new component for Lime Treated Subgrade.

Adding Sidewalk to a Curb & Gutter Template

This example builds a new section containing the 4"_CONC_Sidewalk component with the 
Bench_4_6_to_1 end condition section attached. Next, the HMA_Urban_4Lane template is 
copied and the end conditions are deleted from the copy. Finally, the Sidewalk and End 
Condition section is added to the template.

1. Select Tools > Options from the Create Template menu bar.

2. Turn off the Apply Affixes check box.

3. Set the Step Options to 0.10 for both X and Y.

4. <D> OK.

5. Expand the template library folder structure to show 4 – Components > Sidewalks 
& Bike Paths > Sidewalks.

6. <R> on the 4"_CONC_Sidewalk component and select Copy from the menu.
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7. Expand the template library folder structure to show 3 – Sections – End Conditions 
– Curb & Gutter Sections.

8. <R> on the Curb & Gutter Sections folder and select Paste.

9. <R> on the 4"_CONC_Sidewalk component, that is in the Curb & Gutter Sections 
folder, and select Rename.

10. Key in a Name (4"_CONC_Sidewalk_End-Cond for this example).

11. <D> <D> on the 4"_CONC_Sidewalk_End-Cond section.

12. <D> on the Bench_4_6_to_1 section.

13. In the Preview window, <D> and hold on the green “+”.

14. Move the pointer onto the CONC_Sidewalk_Back-Top point. Right-click and 
toggle make certain Reflect and Mirror are both off. Release the left mouse button to 
place the end condition. 

15. <D> <D> on the Benching component to display the Component Properties 
window.

16. Set the Parent Component to CONC_Sidewalk-4”.

17. <D> Apply.

18. <D> Close.

Setting up the parent/child relationships for the section will make it easier to continue 
the process when the sections are added to the template. Each Curb & Gutter section 
has two Curb components (one for a normal cross slope and one to match the cross 
slope of the driving lanes) and the sidewalk/end condition section has to be attached to 
each. By setting the parent/child relationship in the section, when the section is placed 
in the template, only one component will have to be edited to make the template work 
properly.
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Next, the HMA_Urban_4Lane template is copied and the existing end conditions are 
removed.

19. Select Tools > Options from the Create Template menu bar.

20. Toggle on the Apply Affixes check box.

21. <D> OK.

22. Expand the template library folder structure to show 1 – Templates.

23. <R> on the HMA_Urban_4Lane template and select Copy from the menu.

24. <R> on the 1 – Templates and select Paste from the menu.

25. <R> on the HMA_Urban_4Lane1 template and select Rename from the menu.

26. Key in a Name (12345_ HMA_Urban_4Lane for this example).

27. <D> <D> on the 12345_ HMA_Urban_4Lane template.

28. Toggle on the Display All Components check box. This will show components 
currently hidden by Display Rules.

29. Move the pointer into the Template View window (but not on a component) and <R>.

30. Select Delete Components from the menu.
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31. Position the pointer near the component(s) to be deleted, <D> and hold. Drag 
through the component(s). Release the left mouse button to complete the process.

Important! Be careful not to touch components that are to be kept. The Delete 
Components command is only in effect through one drag operation. 
Once the left mouse button is released, the command must be picked 
again to delete more components.

Note: If a component is deleted by mistake, select Edit > Undo (or Ctrl+Z) to 
replace the deleted components.

To complete the template, add the sidewalk/end condition section and make the 
sidewalk component a child of the curb.

32. Expand the template library folder structure to show 3 – Sections – End Conditions 
– Curb & Gutter Sections.

33. Make certain Apply Affixes is toggled on.

34. <D> on the 4"_CONC_Sidewalk_End-Cond section.

35. In the Preview window, <D> and hold on the green “+”.

36. Move the pointer into the Template View window and <R> while still holding the left 
mouse button. This displays a right click menu. When the right click menu is 
displayed, the left mouse button can be released.

37. Select Mirror (using either the left or right mouse button).
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38. Move the pointer onto the RT_Curb-Back-Top point and release the left mouse 
button to place the section.

39. <D> <D> on the RT_CONC_Sidewalk-4" component.

40. In the Component Properties dialog box, set the Parent Component to RT_C/
G_Type2-IIB.

41. <D> Apply.

42. <D> Close.

43. Repeat steps 38 through 41 on the corresponding components on the left side.

44. <D> <D> on the RT_Curb_Gutter-top point.

45. Change the Value of Constraint 2 (the Slope constraint) to 5.00%.

46. <D> Apply.
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47. <D> Close.

48. Repeat steps 43 through 46 on the LT_Curb_Gutter-top point (the slope Value will 
be -5.00% on this side).

Changing the slope constraint will imitate a supered condition causing the normal curb 
and its child components not to be displayed. It will activate the display of the supered 
curb. These steps will form the pavement into a “V”. This will make it easier to place 
the remaining sidewalk/end condition sections. The pavement will be rotated back to 
its normal position after the sections are placed.

49. Using the same section in the Preview window, <D> and hold on the green “+”.

50. Move the pointer onto the RT_Curb-Back-Top1 point and release the left mouse 
button to place the section.

51. <D> <D> on the RT_CONC_Sidewalk-4"1 component.

52. In the Component Properties dialog box, set the Parent Component to RT_C/
G_Type2-IIB1.

53. <D> Apply.

54. <D> Close.

55. Repeat steps 50 through 53 on the corresponding components on the left side.

56. <D> <D> on the RT_Curb_Gutter-top point.

57. Change the Value of Constraint 2 (the Slope constraint) to -2.00%.

58. <D> Apply.

59. <D> Close.

60. Repeat steps 43 through 46 on the LT_Curb_Gutter-top point (the slope Value will 
be 2.00% on this side).
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The template is now complete.

Adding a Subgrade Component to a Template

The HMA_Crowned_B10 template will be modified by creating a new component. This 
component, representing lime treated subgrade, will be 1’ thick and the width of the ABC 
component that is already in the template.

1. Expand the template library folder structure to show 1 – Templates.

2. <R> on the HMA_Crowned_B10 template and select Copy from the menu.

3. <R> on the 1 – Templates and select Paste from the menu.

4. <R> on the HMA_Crowned_B101 template and select Rename from the menu.

5. Key in a Name (12345_ HMA_Crowned_B10 for this example).

6. <D> <D> on the 12345_ HMA_Crowned_B10 template.

7. Move the pointer into the Template View window (but not on a component) and <R>.

8. Select Add New Component > Constrained from the menu.

9. In the Name field of the Current Component area, key in a name for the new 
component (Lime_Treated_Subgrade in this example).
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10. Use the drop down menu to select the desired Style (D_Subbase for this example). 

11. Move the pointer onto the LT_SubBase_EOP‐Top point and <D>.

12. Continuing to the right, <D> on each point across the bottom of the existing ABC 
component. 

13. <D> the same number of new points (in this case 7) below the ABC component.

14. <R> in the Template View window (but not on a component).

15. Select Finish from the menu.

All of the points are contained in the new component. Editing the point constraints will 
move each point to its proper location.
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16. <D> <D> on the point LT_3 to display the Point Properties dialog box.

17. Select SubGrade_EOP-Top from the Name drop down menu.

18. Append LT_ to the name so that it reads LT_SubGrade_EOP‐Top.

19. Under Constraint 1 (the Horizontal constraint), set the Parent 1 to 
LT_SubBase_EOP-Top.

20. Set the Value to 0.

21. Under Constraint 2 (the Vertical constraint), set the Parent 1 to LT_SubBase_EOP-
Top.

22. Set the Value to -1.

23. <D> Apply.

24. <D> Close.

25. Repeat steps 16 through 24 for each of the remaining points. Choose an appropriate 
name for each of the points. The Parent 1 is the same for the Horizontal and the 
Vertical constraint. The parent point is the point directly above the edited point. The 
Values for the constraints are the same for all points.
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The completed template is shown below.

Section Summary:

 Components are the building blocks for Sections and Templates.

 There are 5 methods of creating components, but only 3 types of components: General, 
Null and End Conditions.

 Component Properties allow the editing of names, styles, etc. and help define how the 
components react in different situations.

 Component Properties for End Condition components contain the target information.

 Components are made up of Points.

 Points are constrained to other points to define the shape of the components and therefore 
the template. Changing the constraints may affect more than one point, since the 
constrained point may also be a parent of another point.

 There are many different types of Constraints and it is very important to use the correct 
ones when creating a new point.

 Display Rules and Parent/Child components can be used to turn on and off components 
during modeling based on the occurrence of other components, or the result of a 
mathematical expression derived from the differences between points (horizontal, vertical, 
slope, etc.)

 Start a new template with the most complete example available that fits your design needs.

 Standard templates may be copied and modified by changing component properties and/or 
point properties.

 Standard sections may be copied into a new template to create a project-specific design.

 Standard components may be copied into a new template to create a new section.

 Even if your design requires a template that is not completed, many of the components and 
sections are found in the standard template library and may be used to create new 
templates.
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Chapter Summary:

 The default template library is located in the C:\Workspace\Workspace‐
CDOT_V8i\Standards‐Global\InRoads\Templates folder

 The CDOT template library contains several categories of templates in various stages of 
development, including: Components (the building blocks), Sections (multiple 
components forming partial templates, such as all the lifts for a lane), and Finished 
Templates (multiple components that form a complete typical section).

 When evaluating the typical sections needed for a project, you should look first to the 
standard template library to save time and effort in building your typicals.

 For non-standard and more complex typicals, the building blocks and /or tools are available 
to create your own templates to accomplish your design.



Page 282 Colorado Department of Transportation

Chapter 9 - Typical Sections A Practical Guide for Using InRoads V8i SS2



Colorado Department of Transportation   Page 283

A Practical Guide for Using InRoads V8i SS2 Chapter 10 - Roadway Modeling

Chapter 10 - Roadway Modeling

Roadway Modeling is the process of creating a 3D design surface or surfaces of your proposed roadway 
project. The modeling process utilizes the roadway typical sections discussed in the last chapter and applies 
these sections to a corridor (a path representing the location of your project). As the typical sections are 
“pushed” along this path, end condition components “tie-in” to the existing surface (or any other targets you 
specify) to create your cut and fill sideslopes. Template points are then connected to created 3D longitudinal 
breakline features along the corridor. Triangulation creates planar surfaces between breakline feature points 
from which elevations can be interpolated. The resulting 3D surface is known as the proposed model. InRoads 
Roadway Designer is the interface between engineering design data and the proposed surface model.

Chapter Objectives:

 To understand how roadway modeling is accomplished using CDOT standard design 
criteria and InRoads XM.

 To learn how to create a preliminary model of your project.

 To further define your model by introducing right and left turn lanes, ramps, acceleration 
lanes, etc. 

 To learn how CDOT establishes superelevation design criteria to maintain vehicle stability 
at the designed speed for each curve on your project. 

 To learn how to vary pavement or subgrade depths over a specified range.

 To learn different methods of editing your design model to correct sideslope problems or fit 
your design to real world conditions.

 To learn how to create a 3D design surface of your project.
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Roadway Designer

Roadway Designer is a new interactive approach to modeling with templates in InRoads, allowing you to see 
the results of your the results of your design simultaneously in plan, profile, and cross section before creating 
your proposed surface.

Roadway Designer is a tool used to:

 Specify the project path (horizontal and vertical alignments or surface features)

 Identify the templates to be used for modeling

 Control template locations along the project path and define transitions

 Define paths for points that don’t parallel the centerline, such as tapers

 Define superelevation

 Create the design surface – a 3D model of the proposed design

Section Objectives:

♦ To utilize Roadway Designer as a tool to input design data for modeling purposes.

♦ To understand the full functionality of Roadway Designer and its tools.

♦ To use and interpret plan, profile, section and superelevation diagram information in 
Roadway Designer’s Standard and Superelevation modes.

♦ To understand what data is needed to before using Roadway Designer for 
modeling. 

♦ To understand what data is created by Roadway Designer and where it is stored.

♦ To learn what commands are available on Roadway Designer’s menu.

♦ To learn how to process Roadway Designer data to create a preliminary view of your 
design in plan, profile and cross section.

♦ To learn how to create a corridor.

♦ To learn when and how to add template drops to your corridor.

♦ To edit template drops and synchronize templates drops with the template library 
changes.

♦ To understand how Point Controls work and when to use them.

♦ To add point controls to your design to minimize template drops.

♦ To understand the CDOT process of adding superelevation to your roadway.

♦ To utilize the Superelevation Table Wizard to calculate the initial superelevation.

♦ To edit the results of the Superelevation Table Wizard to meet your project’s design 
criteria.

♦ To understand when and how to use Secondary Alignments.

Introduction to Roadway Designer

Roadway Designer Prerequisites

Before running Roadway Designer, you must first have:
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 A horizontal and vertical alignment that defines your proposed location (the project 
centerline and profile grade).  You can also use a surface feature to define the path.

 An existing surface or surfaces.  These provide the targets for your end conditions. If your 
target(s) are not surfaces, these targets must also be loaded.

 One or more templates to define the typical section of the proposed design.

Starting Roadway Designer

From the InRoads Explorer menu, select Modeler > Roadway Designer to open the 
Roadway Designer dialog box.

Working Modes

In the Roadway Designer dialog box, you can see the results of your model run and work with 
your data using two different two modes: Standard and Superelevation. 

Standard Mode

Standard mode includes views for plan, profile and cross section. 

○ Plan Display – shows the corridor’s path, template drops, transition zones, 
perimeter of the active surface and limits of the active corridor. You can double-
click a transition zone to edit template transitions (see Design Consideration – 
Template Transitions later in this chapter.

○ Profile Display – shows the corridor’s vertical path along with the active surface. 



Page 286 Colorado Department of Transportation

Chapter 10 - Roadway Modeling A Practical Guide for Using InRoads V8i SS2

○ Cross Section Display – shows the cross section surfaces and components at the 
current station. You can hover over a point or component to get additional 
information (name, offset, elevation, style, constraints, material, slope, width, etc.) 
Double-clicking the cross section display activates the Edit Station command, 
which allows you to interactively edit any station along the corridor. Points and 
components can be edited at the single station to correct any problems along the 
alignment (see Modifying Single Station Template Drops in this chapter).

Superelevation Mode

Superelevation Mode adds a fourth view, the Superelevation diagram. Use the Display 
Superelevation button shown in the diagram below to toggle between superelevation 
and standard mode. When Display Superelevation is on, a color-coded superelevation 
diagram is shown. This diagram displays station/cross slope control lines for superelevated 
points in the template. You can right-click to interactively edit superelevation in this view.

InRoads uses extensive color coding in both standard and superelevation modes to 
illustrate design parameters in plan, profile, cross section and superelevation views. 

♦ The plan display shows a color-coded representation of cross-slope along the corridor. 
The colors vary as the template cross-slope changes through superelevation transitions.

♦ The cross section display shows a color-coded view of the template backbone along 
with the cross slope annotations.
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♦ The profile display shows a color-coded view of all points on the template backbone. 
You can right-click to control which points are displayed, which allows for interactive 
viewing of superelevation transitions in vertical sag curves.

For more information on superelevation and color coding, see the Superelevation section in this 
chapter.

Roadway Designer Menu Structure

File Menu

All Roadway Designer data is stored in an InRoads Roadway Designer (IRD) file, which is 
stored as a *.ird file on the hard drive. You should first create an IRD file for your project 
before any work is done in Roadway Designer. 

♦ File > New: Creates a new IRD file to store all Roadway Designer data for your 
project. 

♦ File > Open: Opens an existing IRD file. You can also open the IRD file using the 
File > Open command from the InRoads Explorer menu.

♦ File > Save: Saves changes to the IRD file.

Important! While working in Roadway Designer, you are working in your computer’s 
memory and you should periodically save your IRD file. If you do not 
Save changes to your IRD file, you will be asked to save upon exiting from 
the Roadway Designer dialog, as you will lose changes otherwise. 
Therefore, it is important to save often!

♦ File > Save As: Allows you to specify a file name and folder location for your IRD 
file. The first time you save, you are prompted with the File > Save As dialog box.

♦ File > Import RWL: Translates a previous InRoads version RWL file (InRoads V8.5 
and earlier) to the new IRD format. You must specify both the RWL file and the 
template library file (TML) used in conjunction with the RWL file (or translate the 
TML file first and then load the corresponding ITL file). This is useful if you are 
migrating project data from a previous version of InRoads to the V8.9 version.

Note: Be careful! This is not a one-to-one conversion and many items needed for 
Roadway Designer are not translated. You must open the converted IRD file and 
make necessary changes. You may consider creating a new IRD from scratch and 
entering the existing project information. Discuss your options with your project 
manager before proceeding.

♦ File > Close: Closes the Roadway Designer dialog box. You can also choose the 
Close button in the upper right.

Corridor Menu

This section introduces the Corridor menu.
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Note: All of the commands found on the Corridor pull-down menu can also be accessed 
on the Corridor button bar located directly below the pull-down menus.

The Corridor menu is used to setup the following data, which is then used in the modeling 
process:

♦ Corridor > Corridor Management: Creates a corridor – either a horizontal and 
vertical alignment or surface feature defining the “path” of your project.

♦ Corridor > Template Drops:   Specifies a start/stop station range for applying the 
various templates along the corridor. The area along the corridor between different 
templates is know as the template transition zone.

♦ Corridor > Point Controls: Used to set up and manage horizontal and vertical 
controls for points in a template for widening lanes, introducing ramps, maintaining 
right-of-way, etc. Point controls are also used for superelevation controls.

♦ Corridor > End Condition Exceptions: Options for modifying end conditions 
(e.g. cut and fill sideslopes) along a station range without introducing additional 
template drops and editing template transitions. There are two different types of End 
Condition Exceptions:

○ Overrides – to replace the end condition on the right and/or left side

○ Transitions – to smooth out rapidly changing end conditions over a station range

♦ Corridor > Display References: Used to display alignments and surface features in 
the Roadway Designer plan and cross section views. Graphics cannot be referenced.

♦ Corridor > Secondary alignments: Used to specify alignments that 'kink' the 
template. The template is run perpendicular to the mainline until it reaches the 
secondary alignment, then it becomes perpendicular to it.

♦ Corridor > Key Stations: Similar to event points on an alignment, Key Stations are 
special stations where you want to drop a template and display a cross section (utility, 
culvert or railroad crossings, drive entrances, intersections, etc.). Unlike event points, 
which are stored in the ALG file, Key Stations are stored in the IRD file. 

♦ Corridor > Create Surface: Creates a surface (DTM) or surfaces from the roadway 
design data. You can create a separate surface for each corridor, including subgrade 
surfaces, or you can create one merged surface by combining multiple corridors in the 
design.

Superelevation Menu

See the Superelevation section later in this Chapter.

Tools Menu

♦ Tools > Parametric Constraints: Used to override labeled point constraint values 
over a station range without requiring additional template drops. Parametric constraints 
are commonly used to vary such criteria as pavement thickness, sidewalk width and 
cross slopes over a station range in the corridor.

♦ Tools > Target Aliasing: Allows you to override the end condition target defined in 
the template and specify additional surfaces or corridors as targets in a prioritized 
order.
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♦ Tools > Curve Widening: Used in widening projects to add horizontal point 
controls to move points on curves further away from the centerline when widening 
lanes or edges.

♦ Tools > Vertical Gore Tool: Allows you to create surface features representing the 
min/max elevation range of a ramp’s vertical alignment to meet cross slope rollover 
and other design criteria. These features can be shown on the profile to help design 
gore area cross slopes and match them to the mainline and the ramp cross slopes.

♦ Tools > Design Input Report (ird file): Generates an XML report from your 
Roadway Designer setup data. After selecting this command, choose one of the style 
sheets (XSL files) from the Roadway folder in the Report Browser to format the 
report. 

♦ Tools > Results Report: Generate XML reports of the roadway design results. After 
selecting this command, choose one of the style sheets (XSL files) from the 
Roadway folder in the Report Browser to format the report.

♦ Tools > Options: Used to set up additional processing and display options for 
Roadway Designer. This includes options for dropping templates at specified event 
points, displaying references and template transitions in plan view, and displaying cut 
and fill volumes in cross section view.

These concepts are explained in more detail later in this chapter. Additional information can be 
found by reviewing the topic Roadway Designer Overview in the InRoads Online Help.

Processing your data

Roadway Designer processes your templates along all specified stations of the corridor. Each 
view display (plan, profile and section) shows the results of your processed model at each 
station along the corridor. This allows you to preview the results of your model prior to creation 
of the 3D design surface. 

Once you have set up your Roadway Designer data and saved the IRD file, you will need to 
process the data along the corridor in order to model the project. You can process Roadway 
Designer data using several different options including:

 “Stepping through” the stations on your corridor using the station navigation buttons (first 
station, previous, next and last station) as shown below. 

Note: This processes your model one station at a time. You can see the results of your 
template drops and other setup options at each station in the plan, profile and  
section views. The station interval is set up in Template Drops.
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 Dragging the current station locator along your corridor in plan or profile displays.

Note: The model is processed along the range you drag the station locator. You can 
double-click anywhere along the corridor in the plan view and the current station 
locator will “jump” to that location. Processing starts from this location. 
Processing is “skipped” in between. The skipped area is shown as two yellow lines.

 Selecting Process All to process all stations along the corridor

Creating and Managing Corridors

A CDOT corridor consists of a designated length of roadway and the area within the roadway’s 
right-of-way, including all assets such as buildings, trees, guardrails, etc.

The corridor defined by InRoads is represented by the horizontal and vertical alignments and 
all features generated from the typical sections used to create design models (dtm’s).  A surface 
feature can also be used as a substitute for alignments.

Introduction to Corridors

Creating a corridor is the first step in the InRoads Roadway Designer process. A corridor is a 
way to associate a horizontal and vertical path for the centerline and profile grade and define 
limits along the path for modeling purposes. A corridor consists of either:

 A horizontal and vertical alignment or 

 A surface feature. 

The type of project will typically dictate the type of corridor you choose: 

 New highway or roadway projects will typically have proposed horizontal and vertical 
alignments established for the roadway centerline and profile grade.
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 If you’re modeling a ditch or other corridor based on a surface feature, use the surface 
feature option. For example, overlay projects may have a surface feature representing the 
existing centerline provided by Survey (however, this surface feature may also be imported 
into the geometry project as an alignment). 

After designating the path, you assign a name for this path, which is known as the corridor. The 
corridor is the path along which you will drop templates to model the roadway. Your design can 
consist of one corridor or multiple corridors (e.g. a mainline and ramps). After the design is 
complete, you can create a separate surface for each corridor or one surface from multiple 
corridors.

All of the Roadway Designer data is saved with the corridor (template drops, point controls, 
superelevation, parametric constraints, etc.) The corridor is then saved to the IRD file.

Note: Before creating a corridor, you must have your geometry project loaded (or surface if 
you’re using a feature to define the corridor).

Creating Corridors

To create a corridor:

1. Select Modeler > Roadway Designer from the main InRoads menu.

2. From the Roadway Designer menu bar, select Corridor > Corridor Management or 

<D> the Corridor Management icon  from the button bar.

3. In the Manage Corridors dialog box, key in a Name for the corridor.

4. Select the Type from the drop down menu. The most common type used is Alignment.

5. Select the Horizontal Alignment the drop down menu. 

6. Select the Vertical Alignment the drop down menu. 
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Note: If Feature is selected for the Type (step 4), select the Surface and Feature for steps 5 
and 6. 

7. Key in the PI Rounding Tangent. Typically this will be 0. This is used to control the 
template’s orientation as it approaches a curve-less PI in order to prevent overlapping of 
template drops.

Note: Specifying a PI Rounding Tangent does not affect alignments with curves at all 
PIs. It also does not affect alignment stationing.

To limit the corridor length along an alignment or feature:

8. Toggle on the Station check box.

9. Key in the Start station.

10. Key in the Stop station.

Note: The target button  can be used to select the Start and Stop stations from the 
MicroStation view window.

11. <D> Add to create the Corridor.
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12. Select File > Save to save the IRD file with the new corridor.

Template Drops

Template drops are used to specify which templates are used, their locations, and their interval 
for a particular corridor. Template drops establish the station ranges for roadway transitions.

Introduction to Template Drops

Template drops are defined whenever the typical section of the roadway changes or where the 
template drop interval changes. Typical section changes include:

 Lane transitions (e.g. two to four lane transition).

 A rural section with shoulders to an urban section with curb and gutter.

 An undivided section to a divided highway section.

Template drop interval changes include:

 Areas where additional definition is needed in the model (e.g. rapidly changing terrain).

 Areas where cross sections are needed at more frequent intervals than the standard template 
drop interval.

The following examples illustrate when it is appropriate to add template drops.

Typical Section Change Example

Two lane to four lane transition between station 105+00 and 110+00.

Station Interval Template

100+00.00 25 12345_HMA_2Lane

105+00.00 25 12345_HMA_2Lane

110+00.00 25 12345_HMA_4Lane
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Interval Change Example

Rapidly changing terrain between stations 150+00 and 160+00 where 5 foot drops are needed.

Even though the same four lane template is specified at station 110+00, 150+00, 160+00 and 
200+00, there are no superfluous entries because of interval change between stations 150+00 
and 160+00. 

The following examples illustrate when it is not appropriate to add template drops.

Typical Section Change

Two lane to four lane to four lane urban section.

The fourth entry at station 150+00 is not needed because there was no change to the typical 
section or interval between stations 110+00 and 200+00. It is considered a superfluous entry in 
the table.

200+00.00 25 12345_HMA_4Lane

205+00.00 25 12345_HMA_2Lane

Station Interval Template

100+00.00 25 12345_HMA_2Lane

105+00.00 25 12345_HMA_2Lane

110+00.00 25 12345_HMA_4Lane

150+00.00 5 12345_HMA_4Lane

160+00.00 25 12345_HMA_4Lane

200+00.00 25 12345_HMA_4Lane

205+00.00 25 12345_HMA_2Lane

Station Interval Template

100+00.00 25 12345_HMA_2Lane

105+00.00 25 12345_HMA_2Lane

110+00.00 25 12345_HMA_4Lane

150+00.00 25 12345_HMA_4Lane

200+00.00 25 12345_HMA_4Lane

205+00.00 25 12345_Urban_4Lane

Typical Section Change Example

Two lane to four lane transition between station 105+00 and 110+00.

Station Interval Template
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Creating Template Drops

Template Drops are created as follows:

Note: The template library must be opened prior to selecting the Template Drops 
command. You can only select templates from the loaded ITL file.

1. From the Roadway Designer menu bar, select Corridor > Template Drops or <D> the 

Template Drops icon  from the button bar.

2. In the Template Drops dialog box, select the Corridor using the drop down menu.

3. Key in the starting Station for the template (the start station of the corridor will be selected 
by default).

4. Key in the Interval for the template drops.

5. Expand the Template Library folder to show the contents of the 1 – Templates folder.

6. Highlight the desired template.

7. <D> the Add button.

8. Repeat steps 3 through 7 above to add additional template drops.

9. <D> Close to dismiss the Template Drops dialog box.

Note: If a template, station or interval is incorrect, highlight the entry, make the change 
and then choose Change.

The templates are copied from the template library (ITL file) to the roadway design file (IRD 
file). 
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Important! There is no dynamic link between templates in the library and template drops. 
Changes to templates in the roadway design file (IRD) will not affect templates 
in the template library (ITL). Likewise, changes to templates in the template 
library are not automatically updated in the roadway design file. 

Therefore, the following are two options for editing templates that are used in the modeling 
process.

Editing a Template from the Template Drops Dialog Box

You may want to modify a standard template through an entire template drop station range 
without modifying the template in the template library. This allows you to use the standard 
template at another drop location without having to create a separate template in the library. 

Note: This type of edit is usually the exception rather than the rule and is not often done. 
However, there may be special situations that warrant this type of edit, which is 
accomplished by editing the template directly from the Template Drops dialog 
box. 

Important! These modifications will only be used for the station range highlighted. 
The changes in the template are not carried over to the template library. 
Instead, the modified template resides in the IRD file only. 

To modify a template in this manner:

1. In Template Drops, highlight the desired template in the Current Template Drops area.

2. <D> the Edit button. The Editing Roadway Designer Template Drop dialog box appears.

3. Modify the template as described in Chapter 2 Defining Templates in this document.

4. <D> OK to complete the edit.
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Templates that have been modified will be shown in red in the Current Template Drops section 
of the Template Drops dialog box. Also, the Revised in field will read IRD.

Updating A Template From the Template Library

All changes made to a template in the template library must be updated in the Roadway 
Designer. This is accomplished by synchronizing the template from the library with the 
template in the Template Drops dialog box.

Templates within the template drops list that do not match those in the template library will be 
shown in red. The Revised In column indicates where the template was changed. Templates 
modified using the Create Templates dialog box have ITL in the Revised In column. Those 
modified in the Roadway Designer have IRD. 

To update a template drop to match the Template Library:

1. Highlight the desired template in the Current Template Drops area.

2. <D> the Synchronize with Library button.
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3. If the selected template drop was modified in the Roadway Designer dialog box, a warning 
message will be displayed. 

4. Select Yes to change the template to match the Library. Select No to leave it as modified.

Note: To an IRD edited template elsewhere, you can copy it back to the ITL file using the 
Template Library Organizer.

After templates are synchronized with the library, the template text changes from red to black 
in the Templates Drop box.

Important! When templates in the IRD file are synchronized with the ITL file, 
template transitions are re-established and the transitions must be re-
defined if they were previously edited. For more information on editing 
template transitions see Design Consideration – Template Transitions later 
in this chapter.

You may see other color coded text in the Current Template Drops section of the Template 
Drops dialog box. The table below is a summary:

For practice on creating corridors and template drops, see Lab 4 – Corridors and Template 
Drops in the InRoads Lab Guide.

Item Color Indication

Station text Red Alignment geometry has been modified and 
the station is no longer valid

Template text Red The template was modified in the template 
library and doesn’t match the template in 
Roadway Designer

Template text Blue The template does not exist in the template 
library

Template Library Red The template library from which the template 
was placed is not the template library cur-
rently open
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Point Controls

Point Controls are used to override the template point constraints and redefine the location of 
points relative to an alignment, feature, or other corridor point. Using Point Controls will 
reduce the number of templates required for modeling, especially for corridors varying in lane 
and/or median width. There are many uses for point controls, including:

 Divided highways that follow different horizontal and vertical alignments.

 Introduction of right and left turn lanes.

 Introduction of ramps, acceleration lanes, etc.

 Following existing surface features for an overlay project.

 Superelevation of template points.

 Placement of independent ditches (ditches that follow a different path from the centerline).

 Maintaining sideslopes within right-of-ways.

Introduction to Point Controls

Point Controls are defined in the Roadway Designer. Use Point Controls when you want to 
vary the location of template points without having to create multiple templates and multiple 
template drops in your corridor. For example, when introducing a right turn lane, instead of 
creating multiple right-turn lane templates and template drops for all the intermediate transition 
points, you could instead use Point Controls to assign the right lane point to follow a separate 
right turn alignment. You can also follow stations and offsets from the mainline alignment (for 
linear transitions) using either Point Controls or Parametric Constraints (see the section, 
Parametric Constraints, later in this chapter).

Note: Point Controls override the point constraints defined in the template.

Point Controls are defined and managed in Roadway Designer by selecting Corridor > Point 
Controls from the Roadway Designer menu bar. 
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There are a number of options that determine how the point will be controlled. These options 
are:

 Mode – Three modes are available, Horizontal, Vertical, and Both.

♦ Horizontal – This option moves the point in the Left/Right plane. The point is moved 
closer to or further from the control based on other settings in the point control dialog 
box. A horizontal control affects any horizontal-type constraint. It does not override a 
vertical constraint, so slopes and vertical offsets are maintained.

Example: A right turn lane that maintains the thru lane cross slope but develops 
through tapers or reverse curves.

♦ Vertical – This option moves the point in the Up/Down (elevation) plane. A vertical 
control modifies a Vertical, Vector‐Offset, and Slope constraint.

Example: Points that follow the mainline horizontal (lanes, edges, etc.) but rotate 
off the mainline vertical alignment in superelevation.

♦ Both – This option moves the point in both planes. A Both control overrides all point 
constraints.

Example: A divided highway where one set of lanes follows the mainline and the 
other set has its own horizontal and vertical alignment.
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 Control Type – This determines the element type that the point will follow. Additional pull 
down menus are displayed based on the Mode selected. 

 The choices are:

♦ Alignment – The point follows the specified horizontal and/or vertical alignment. This 
option is available for all modes.

Example: A right edge point following a right turn lane alignment with a reverse 
curve.

♦ Feature – The point follows the specified feature horizontally and/or vertically. This 
option is available for all modes.

Example: An edge point following an existing edge of pavement feature for an 
overlay project.

♦ Style – The point follows a feature or alignment with the specified style horizontally 
and/or vertically.

Example: An edge point following multiple edge of pavement features for an 
overlay project where the features have different names but the same style.

If more than one feature at the same station uses the specified style, the point follows 
the feature that was created first. A Range can be specified when searching for a style. 
This is a maximum horizontal distance from the point’s original location to search for 
the style. This option is available for all modes. When specifying the range:

○ A negative range searches to the left.

○ A positive range searches to the right. 

○ A zero value finds the closest style. 
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♦ Corridor Point – The point follows a template point used in another corridor. The 
specified point is followed horizontally and/or vertically. This option can be used with 
all three modes.

Example: A shoulder point in the mainline corridor following an edge point in a 
separate ramp corridor. This can be accomplished “live” in the Roadway Designer 
without having to create a surface from the controlling corridor. This is usually 
defined over a specified station range.

♦ Superelevation – This option is used by the Superelevation Wizard to create the point 
controls for superelevation. It is also used for point controls on manually created 
superelevation control lines or those imported from a previous versions of InRoads. 
This option is only used with the Vertical mode.

Example: Edge points following superelevation control lines representing the 
points’ cross slope. The control lines are those displayed on the superelevation 
diagram view in the Roadway Designer.

♦ Elevation Difference – This option adds or subtracts the elevation of the specified 
vertical alignment to the elevation of the corridor’s vertical alignment. This option can 
be used to create superelevation without using the wizard by building a vertical 
alignment to represent the elevation changes for the point. This option is only used 
with the Vertical mode. These alignments are often called vertical difference 
alignments.

Example: Edge points following independent “difference” vertical alignments in 
superelevation. 

Note: These are not the same as Superelevation Control Lines created using the 
Superelevation Wizard or the Create Single Control Line command. For more 
information on how vertical point controls work in superelevation see the 
Superelevation section later in this Chapter.

♦ Elevation and Grade – This option starts the point at a specified elevation. It then 
follows the specified grade to the end station. This option is only used with the Vertical 
mode.

Example: A ditch point that follows an independent vertical path (starting 
elevation and grade) from the mainline vertical alignment. 

Note: If the ditch point is constrained horizontally but not with a slope, the 
foreslope varies. If the ditch is constrained with a slope, but not 
horizontally, the foreslope is kept and the width varies to meet the new 
elevation.
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 Station Limits –   These set the beginning and ending stations for the control. The stations 
default to the length of the controlling element and its location relative to the corridor 
alignment stationing.

 Horizontal Offsets – This is used to move the point a specified distance to the left or right 
of the control element. If the Start offset and Stop offsets are different, the point location 
varies linearly between the start and stop. 

 Vertical Offsets – This is used to move the point a specified distance above or below the 
control element. If the Start offset and Stop offsets are different, the point location varies 
linearly between the start and stop.

Note: If a separate alignment is not available for a point to follow, you can also vary the 
point by following horizontal and/or vertical offsets from the mainline alignment. 
This is useful for linear lane transitions (e.g. right turn lanes). However, if more 
complicated geometry for the lane is required (like a reverse curve), a separate 
alignment is needed.

 Priority – This determines which control is used on a point with conflicting point controls. 
When there is a conflict, the control with the lower priority is used.

Note: Orange stations in the Point Controls list indicate points with overlapping or 
conflicting controls. The Control with the lowest priority is used.

Red stations indicate an invalid station. The station may not exist because of changes to 
the alignment or the stations were keyed-in incorrectly. This could also mean that the 
alignment is missing.

The following table summarizes the control types available for each Point Control mode:

Note: Once point controls are established, process the model to see the results.

Point Control Types

Horizontal Vertical Both

Alignment X X X

Feature X X X

Style X X X

Corridor Point X X X

Superelevation X

Elev. Difference X

Elev. & Grade X
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Important! Even though point controls override template point constraints, the constraints 
still play a role in the final result. By default, point controls override the 
constraint that most closely matches the control type. For example, a vertical 
control will override a vertical or slope constraint rather than a horizontal 
constraint. 

While it is generally accepted best practice to fully constrain all points (with 
the exception of the centerline) in standard templates, there are situations 
where the constraints may need to be released in order to achieve the desired 
results with your point control. For example, if the point is horizontally and 
slope constrained and you assign a vertical control, the slope will change to 
meet the control. However, if the point has only a slope constraint and you 
assign a vertical control, the point will change horizontally by sliding along the 
slope constraint until it reaches the vertical assigned by the control. 

Adding Point Controls

To add a Point Control:

1. Select Corridor > Point Controls from the Roadway Designer menu bar or <D> the 
Point Controls button from the button bar.

2. Select the Point to control using the locate  button and selecting the point from the cross 
section display, or select the point from the drop down menu.

3. Toggle on the desired Mode.

4. Select the Control Type to control from the drop down menu.
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5. Use the drop down menus and key-in fields to specify the controlling element. The options 
change based on the Control Type selected as shown below.

6. If you wish to limit the control within the default length of the controlling element, use the 
Start and Stop Station Limits.

7. In the Horizontal Offsets area, key in the desired Start offset.

8. Key in the desired Stop offset.

9. In the Vertical Offsets area, key in the desired Start offset.

10. Key in the desired Stop offset.

11. Key in the Priority for the control.

12. <D> the Add button to complete the control.

13. Repeat steps 2 through 12 for additional controls.

14. <D> the Close button to dismiss the Point Controls dialog box.

Editing Standard Point Controls

1. Select Corridor > Point Controls from the Roadway Designer menu bar or <D> the 
Point Controls button from the button bar.

2. Highlight the desired control in the Horizontal and Vertical Controls area.

3. Make the desired changes using the menus in the upper part of the dialog box.
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4. <D> the Change button to accept the changes.

Note: You can temporarily disable a point control without deleting it by toggling off Enable 
in the control list.

Superelevation

Superelevation modifies a template through a curve so that vehicles can maintain stability at 
the designed speed. Once you establish your template drops and make necessary template edits, 
you are ready to add superelevation to your roadway (if needed).

For basic superelevation terminology, refer to the Glossary located in the InRoads online Help 
under Supplemental Information > General. 

Introduction to Superelevation

The InRoads superelevation commands compute the necessary super rate and determine how 
the road will transition from normal crown to full superelevation as well as the locations of 
these transitions for each curve in the corridor, based on your design criteria. 

To establish superelevation on your roadway you will:

a. Use the Superelevation Table Wizard to establish your initial superelevation for the 
roadway. This saves time and effort when creating the initial superelevation point 
controls and control lines.

b. Edit the superelevation point properties as necessary to override the Wizard setting and 
tailor the superelevation to your project’s design criteria. 

The Superelevation Menu

The Superelevation Menu is used to set up superelevation design criteria. Commands 
include:

♦ Superelevation > Create Superelevation Wizard: Used to step through the 
process of entering superelevation criteria. There are three available methods to input 
the data: AASHTO, Fixed Length or Table. CDOT uses the Table method. After running 
the wizard, superelevation control lines are automatically created and assigned to 
template points (through Point Controls) to determine how the points (edges, lanes, 
etc.) will rotate in super.
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♦ Superelevation > Create Single Control Line: An alternate method of setting up 
superelevation criteria by manually creating superelevation control lines, which 
controls the cross slope of template points in superelevation. This is also useful if you 
need to change the cross slope of the roadway when you’re not truly in superelevation, 
such as matching the vertical grade of the main roadway for an approach road.

♦ Superelevation > Apply Shoulder Rollover Lock: Allows you to create special 
superelevation control lines and assign point controls to shoulder points, which 
determine how shoulders will rotate in super. CDOT does not use rollover locks in 
standard situations, since the shoulders are fully superelevated.

♦ Superelevation > Import Superelevation: Allows you to import an ASCII 
superelevation file (pipe delimited format) to create superelevation control lines and 
assign point controls.

♦ Superelevation > Import Superelevation from Alignment: Allows you to 
import superelevation data from an InRoads alignment created in previous versions of 
InRoads (version 8.5 and earlier). This creates superelevation control lines matching 
the previous super table.

♦ Superelevation > Superelevation Report: Allows you to generate an XML 
report of the superelevated points and/or their corresponding control lines. 

Note: The Superelevation Table Wizard (CDOT’s preferred method of setting up 
superelevation criteria) is explained below. For information on other methods or 
the concept of superelevation in general, refer to Superelevation Overview in the 
InRoads Online Help file.

The Superelevation Wizard

The Superelevation Wizard steps you through the process of entering your superelevation 
criteria. This criteria includes selecting the appropriate CDOT superelevation rate table. 

Note: CDOT uses the Table method to calculate superelevation rates. This method 
complies with AASHTO guidelines and incorporates CDOT’s superelevation 
standards by utilizing custom superelevation tables located in the CDOT 
workspace.

The CDOT superelevation tables specify maximum superelevation rates, along with spiral 
transition lengths, for a range of curve radii. The tables are text files, which can be opened in 
Notepad or any word processor. They are categorized by a maximum superelevation rate and 
a design speed. For example, a table named 06_55.sup contains CDOT standards for a 6% 
maximum superelevation rate at 55 mph design speed. 

An example table is shown below:
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For more information on superelevation rate tables, see Superelevation Rate Table (.sup) 
Descriptions in the InRoads Online Help.

Additional superelevation criteria that is set via the Wizard includes:

♦ The pivot point location (e.g. centerline, inside edge),

♦ The range point locations (to designate the fully superelevated portion of the template),

♦ The station range for different design criteria and

♦ The number of lanes to be superelevated.
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The illustration below shows an example of pivot and range point locations for a template 
cross slope as it rotates through superelevation. In this example, the template pivots about 
the crown point and the range points (the top of gutter points) define the range of points 
that will rotate to full super.

 

 

The Wizard stores this information in superelevation Sections. These Sections are just a set of 
super criteria applied to a station range along the corridor. If the super criteria change at any 
point along the corridor, you will end one section and start another. 

Superelevation Wizard Results

When finished, the wizard automatically creates:

 The superelevation control lines for each point superelevated on the template and
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 The vertical point controls for these points.

The four Roadway Designer views are updated as follows:

 The plan display shows a color-coded diagram that represents the cross-slopes for the 
components within the template backbone.

 The cross section display shows a color-coded view of the template backbone along with 
the cross slope annotations.

See the illustrations below for more information on how to interpret superelevation color 
coding in these views:
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♦ Yellow, orange and red indicate slopes to the left as noted in the table below..

  

♦ Green, teal and blue indicate slopes to the right as noted in the table below.
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♦ White indicates a cross slope less than 0.5%.

  

 The profile display shows color-coded grade lines for all points on the template backbone. 
However, you can right-click to control which template points are displayed (i.e. the left 
and right edges of roadway).
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 The superelevation diagram shows the control lines that represent a percent cross slope.

The control lines in the superelevation diagram view are the graphical representations of 
cross slope over a station range (stationing or length along the x-axis and cross slope on the 
y-axis). A horizontal line represents a constant cross slope along a station range, whereas a 
sloped line represents a linear change in cross slope along a station range.

An infinite number of control lines can be assigned to an infinite number of points in a 
corridor. The control lines can be created to control any change in cross slope between two 
points in the template (i.e. sidewalk, gutters, etc.)

The control lines are colored in the diagram for visual clarification only. Unlike the plan, 
profile and cross section views, the line colors do not correlate to any superelevation 
values.

The Wizard automatically creates the vertical point controls that correspond to each 
superelevation point control line. You can open the Point Controls dialog box to review the 
vertical point controls created by the Superelevation Wizard. 

The Wizard also calculates superelevation rates for each curve on the horizontal alignment and 
stores these in the geometry project (ALG file). The superelevation section definitions (the 
point controls and control line information) are stored in the IRD file.
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Calculating the Initial Superelevation

To use the Superelevation Wizard:

1. Select Superelevation > Create Superelevation Wizard > Table from the 
Roadway Designer menu bar.

2. In the Table Wizard dialog box, select the desired super table. These are located in the 
C:\Workspace\Workspace‐CDOT_XM\Standards‐Global\InRoads\Superelevation 
Tables\ folder.

Note: If the curves need different design speeds or maximum super rates (i.e. different 
tables), highlight the curves to load from this table, then select Load Values 
From Table. Repeat for each curve that needs a different table. 

3. <D> the Load Values From Table button.
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The rate values are read from the table and updated for each horizontal curve set listed in 
the dialog box or highlighted.

4. <D> Next.

5. <D> the ADD button on the Superelevation Section Definitions pane. This displays the 
Add Super Elevation Section dialog box.

 

6. Use the drop down menu or the target  button to select the Crown Point.

7. Use the drop down menu or the target button to select the Left Range Point.

8. Use the drop down menu or the target button to select the Right Range Point.
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Note: The range points define the points at the outermost edge of the fully superelevated 
portion of the template. In the example below, these are the left and right edge of 
pavement points on the CDOT HMA_Crowned_B10 template.

9. Select the desired Number of Lanes, either 2 or 4.

10. Key in the desired Runoff Length Multiplication Factor.

Note: This is typically only used when there are more than four lanes.

11. Set the Station limits, if needed.

Note: Station limits are used to define superelevation section criteria limits. If superelevation 
design criteria change (such as different pivot points, range points or different number 
of lanes), then you must create a new section to specify the different criteria. However, 
using multiple tables along the alignment does not require multiple sections.

12. <D> OK.
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13. Repeat steps 5 through 12 to add additional sections if any super design criteria changes.

14. <D> Next on the Superelevation Section Definitions pane. This displays the 
Superelevation Controls pane.

Note: This box lists point controls that are created automatically when you go through the 
Wizard. The point controls determine the vertical location (by defining a cross slope) 
of template points (those at and inside the range points) while rotating in 
superelevation. Use the Edit button to make changes in the control lines as needed. Use 
the Delete button to remove unnecessary point controls, like lane line points that may 
be control by constraints set in the template.

15. <D> Finish. This completes the superelevation, and dismisses the Superelevation Wizard.
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The Wizard creates superelevation control lines and uses point controls to assign them to the 
template points within the superelevation range.

You will need to process your design to see the superelevation results. Each point control 
corresponds to a control line on the superelevation diagram. 

The superelevation control lines are displayed on the superelevation diagram view in Roadway 
Designer. The control lines represent the percent cross slope (vertical axis) at each station 
(horizontal axis) for each point that is superelevated in the super range.

Controlling Superelevation Displays

You can set which control lines are displayed in the superelevation diagram:
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1. Right-click in the superelevation diagram and select Superelevation Display List.

2. In the Available Superelevation list, select the control for the line you want to display.

Note: You can press the Ctrl or Shift keys and select multiple point controls to 
display more than one control line.
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3. <D> Apply.

The superelevation diagram is updated with the control line display.

Editing Superelevation

After the Wizard has calculated the initial superelevation, you may need to edit some of the 
superelevation criteria like a point’s cross slope or max super rate, the normal crown, runoff or 
full super locations, etc. You can do this in the superelevation diagram using one of the 
following methods:

♦ Editing superelevation point properties (via dialog box settings).

♦ Graphically moving superelevation points (using dynamic settings).

♦ Editing Curve Set Stations (in table format).

Editing Superelevation Point Properties

1. From the Roadway Designer, <D> on the Display Superelevation button if you’re not 
already viewing the superelevation diagram.
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2. <D> <D> on the point to edit in the superelevation diagram. This displays the 
Superelevation Point Properties dialog box.

3. Change the Name, Station, Cross‐Slope, Type, or Constraints as desired.

4. <D> Apply after the desired changes are made.

5. <D> Close to dismiss the Superelevation Point Properties dialog box.

Moving Superelevation Control Points

1. From the Roadway Designer, <D> on the Display Superelevation button if you’re not 
already viewing the superelevation diagram.
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2. Right-click on the superelevation control line point to edit and select Move Point.

3. In the x+xx,x% field, enter the desired station and cross slope to move the point.

Note: Use the syntax <Station, Cross Slope> when keying in the Dynamic Settings box. 
Express the cross slope as either a % or decimal (e.g. 334+25,5% or 
334+25,.05).

Editing Curve Set Stations

Another option for editing superelevation is to use the Edit Curve Set Stations tool. To use 
this tool:

1. From the Roadway Designer, <D> on the Display Superelevation button if you’re not 
already viewing the superelevation diagram.

2. Right-click in the superelevation diagram control line view. 

3. Select Edit Curve Set Stations from the right-click menu while your cursor is in the 
super diagram view. 
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4. Use the Curve Set controls to select the desired curve and verify the desired Section 
Name is correct from the drop down menu.

5. <D> on the Show Curve Set Information button to display curve data in the lower 
right corner of the dialog box.

6. Data for other curves within the super section can be added or removed from the list by 

using the  and  buttons to the right of the data area. Use the top buttons for data 
before the current curve, use the bottom ones for after the current curve. 

Note: Red stations denote points outside the current curve set.

7. Stations and Cross Slopes in white cells can be modified. Press the Tab key to move to 
the next editable field.

8. Reverse Crown stations are edited by toggling off the Constrained check box. If the 
Constrained check box is toggled back on, the station will revert back to its original 
value.
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Note: Changing previously constrained stations may result in kinks in the control line.

9. <D> Apply to accept the changes.

10. <D> the Undo button to discard any changes, if desired.

Removing Superelevation

If you make a mistake after running the initial superelevation setup (after running the Wizard) 
or when editing superelevation and you want to start over with the Wizard, you can remove the 
superelevation point controls and control lines. When removing super you have two options, 
you can either:

 Remove individual superelevation point controls or

 Remove the entire superelevation section (all point controls for all curves within that 
section).
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To remove super:

1. Right-click in the superelevation diagram control line view and select 
Superelevation Display List...

2. To delete just one control line, select the associated point controls from the list of 
Available Superelevations.

Note: You can press the Ctrl key and select multiple point controls to delete more 
than one control line.

3. Select Delete.
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4. To delete all control lines for a superelevation section, select the Section from the 
Superelevation Section list (all point controls should highlight).

5. Select Delete.

For additional practice modifying superelevation, see Lab 5 – The Superelevation Wizard in the 
InRoads Lab Guide

Secondary Alignments

When modeling your roadway, you may need to apply your template perpendicular along two 
different alignments. For example when modeling an intersection, you want to drop the 
template perpendicular to the centerline alignment, but also to the intersection return edges on 
the outside. In this case, you can specify the intersection return as a secondary alignment and 
have the template “bend” perpendicular when it encounters the this alignment (see the 
illustration below). 

Secondary alignments may be applied in two ways:

 They modify the angle of the part of the template outside secondary alignment and change 
the width to the specified template point to the secondary alignment when specified with 
Point Controls.

 They modify the angle of the part of the template outside secondary alignment but do not 
change the template width when specified with Corridor > Secondary Alignments.
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In the intersection illustration below, the green line represents the template placement in 
relation to the corridor alignment (the light blue line) and the secondary alignment (the 
orange line). This secondary alignment was assigned using Point Controls.

To specify a secondary alignment:

1. Select Corridor > Secondary Alignments.

2. Select the Secondary Alignment from the drop down list.
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3. Specify a Start and Stop station range for InRoads to treat the alignment as secondary 
and “bend” the template.

4. Specify any Start and Stop Offsets from the alignment.

5. Select Add.

The alignment will only be treated as secondary through the station range specified.

Note: You can only have one secondary alignment per station range.

Note: To have the template widen and ‘kink’, create a point control as previous defined and 
toggle on the Secondary Alignment option.

Section Summary:
♦ Roadway Designer is an interactive design modeling tool which allows you to see the 

results of your design and then make edits before creating your proposed 3D surface. 

♦ Before running Roadway Designer, you must have a horizontal or vertical alignment, 
an existing surface and one or more templates.

♦ The results of this interactive and iterative design process are shown in Roadway 
Designer’s plan, profile and cross section views.

♦ Design data for modeling is stored in the IRD file.

♦ A corridor defines a path for your project and can be defined with a horizontal and 
vertical alignments or with a surface feature.

♦ Templates Drops specify which templates are applied where along the corridor for 
modeling purposes.

♦ If templates are changed in the ITL file, then the template drops must be synchronized 
with the library to see the changes update in Roadway Designer.

♦ Point Controls are used to vary a template point by assigning the point to follow a 
different path.

♦ Establishing Point Controls can effectively reduce the number of templates and 
template drops required for modeling, especially when introducing turn lanes, ramps, 
etc.

♦ A point can be controlled using horizontal point controls, vertical point controls or 
both.

♦ There are several different types of controls that a point can follow including horizontal 
and/or vertical alignments, horizontal and/or vertical surface features, a feature style 
assigned to multiple features, or a point in another corridor.

♦ Superelevation is added to your roadway model using the Superelevation Table 
Wizard.

♦ Superelevation mode adds a fourth view to the Roadway Designer – a superelevation 
diagram control line view.

♦ The Superelevation Wizard automatically creates vertical point controls for certain 
backbone template points (lanes, edges, shoulders, etc.) as well as the super control 
lines for each of these points.

♦ The super control lines are displayed in the superelevation diagram control line view.
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♦  Superelevation can be edited by either editing point properties, graphically moving the 
super control line points, or editing a Curve Set table.

♦ Secondary alignments are used when you want to “bend” the template so that it is 
applied perpendicular to the secondary alignment (ramps, intersections, etc.).

Advanced Corridor Tools

You can take advantage of a couple of InRoads’ advanced corridor tools in certain design situations:

 If you need to vary template points frequently over several different station ranges, you can 
use Parametric Constraints, which saves time creating multiple templates and template 
drops.

 If you are working with multiple target surfaces or corridors, or designing a divided 
highway that may tie to multiple surfaces, then you can use Target Aliasing to set priority 
tie-ins.

Section Objectives:

♦ To learn how and when to use Parametric Constraints to vary template points.

♦ To learn how to assign labels to point constraints.

♦ To learn how to assign multiple surfaces and corridors as end condition targets using 
target aliasing.

Parametric Constraints

Parametric Constraints are another method of modifying template points during processing in 
Roadway Designer. These override the value of a point’s constraints for the specified station 
range. This option is only available on point constraints that have been assigned constraint 
labels in the template library (as shown below).
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Parametric Constraints are defined in the Roadway Designer and can be used to move labeled 
points in a template without having to edit the points in the template library. 

Some examples of when you could use parametric constraints include:

 Varying lift or subgrade depths over a specified station range or

 Introducing linear lane transitions using station/offset values (this can also be done with 
horizontal Point Controls).

If you wanted to increase the thickness of a lift (e.g. HMA_Lift1), you could edit every point in 
the lift component on the template and change the vertical constraint value. This would be 
tedious and time consuming, especially if you had multiple template drops (you would have to 
edit the same points on every template used). 

Instead, you could assign an “asphalt depth” label to each vertical point constraint in the 
template Point Properties. Then, you just have to set up one parametric constraint entry to vary 
this label constraint over a specified station range. When the template is outside this range, it 
will revert to the thickness as defined in the template. 

Any point constraint that has been assigned a label can be varied using parametric constraints. 
The workflow example below illustrates how to introduce a linear lane transition by varying an 
edge of pavement point from 12 to 24 feet from the centerline over a 250 ft. station range
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Defining a parametric constraint:

1. Select Tools > Parametric Constraints from the Roadway Designer menu bar. This 
displays the Parametric Constraints dialog box.

2. Select the Constraint Label that you want to vary from the drop down menu.

Note: The label must first be assigned to the point constraint in the template library. If 
you assign the label after establishing template drops, you must synchronize the 
template.

3. Key in the Start Value.

4. Key in the Stop Value.

5. In the Station Limits area, key in or select the Start station.

6. Key in or select the Stop station.

7. <D> Add.

8. Repeat steps 2 through 7 above to create additional parametric constraints. <D> Close 
when finished.
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Editing parametric constraints

1. From the Parametric Constraints dialog box, highlight the desired entry. The data entry 
fields are populated with the data from the selected entry.

2. Enter the desired data into the data entry fields.

3. <D> Change to complete the modification.

Note: You can Export parametric constraint values to a text file and edit them in a text editor 
or a spreadsheet program like Excel. After editing the values, you can Import them 
back in to Parametric Constraints.

To delete a parametric constraint:

4. From the Parametric Constraints dialog box, highlight the desired entry. 

5. <D> Delete to remove the entry from the list.



Colorado Department of Transportation   Page 333

A Practical Guide for Using InRoads V8i SS2 Chapter 10 - Roadway Modeling

Target Aliasing

Target aliasing is used to redefine the end condition targets assigned in the template library. 
Multiple targets can be prioritized, and the software attempts to solve the next target should the 
higher priority fail. Target Aliasing creates a prioritized list of surfaces, surface features, and/or 
corridor solutions that the current corridor can tie to. For example:

 When you want to tie into multiple targets, as in when you are modeling across adjacent 
existing surfaces and need to tie to whichever is present at a given location. 

 When you want to tie to one surface if it is available, but a secondary surface if it is not. 
This may occur in the case of a divided highway being modeled as two corridors where you 
would like one set of lanes to tie to the other design surface if it’s close enough and to the 
existing if it’s not. This can be accomplished by creating the first design surface and using 
it as an alias for the existing, or both corridors can be modeled at the same time by using 
the corridor as the alias for the existing surface.

Target aliasing can also be used to remap the active surface. In many cases, a template can be 
simplified by only targeting active surface. However the active surface can easily change. By 
hard mapping the target alias to the existing surface of choice, you can mitigate opportunities to 
process the wrong active surface. Also, this allows you to see multiple surfaces in the cross 
section display window.

Defining a target alias:

1. Select Tools > Target Aliasing from the Roadway Designer menu bar. This displays the 
Target Aliasing dialog box.

2. Select the desired Target. The target list is built from targets defined in the template’s end 
condition components.

3. In the left pane of the Target Aliasing dialog box, highlight the first target to be solved for. 

Note: This list will change based on the target selected in step 2.

4. <D> Add to move the selected item to the right pane.

5. Repeat steps 3 and 4 to add additional items. 

6. <D> OK to complete the process.
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Changing target aliasing 

The items selected, as well as their order can be modified. To make changes in Target Aliasing:

1. Select Tools > Target Aliasing from the Roadway Designer menu bar. This displays the 
Target Aliasing dialog box.

2. Select the desired Target. 

3. Select the desired alias from the right pane of the Target Aliasing dialog box.

4. <D> the Move Up or Move Down buttons to change the order of the alias list.

5. <D> the Remove button to delete the alias from the list.

6. <D> OK to complete the changes.

The template end condition will seek the first target in the alias list. If it fails to intercept the 
first target, the end condition will seek the second target and so on. If the Use Closest option is 
toggled on, the closest of the listed aliases that is encountered is used as the target.

Section Summary:
♦ Parametric constraints can be used to vary points in a template without having to edit 

the points in the template library.

♦ In order to set up parametric constraints you must first assign a label to the point’s 
constraints in the template library. The label is used as the constraint variable.

♦ Parametric constraints are useful to varying pavement lift or subgrade depths or for 
introducing linear lane transitions.

♦ Target Aliasing is used to create a prioritized list of surfaces, surface features, and/or 
corridor solutions for target tie-ins.

♦ Target Aliasing is useful when you are tying into multiple adjacent existing surfaces.

♦ Target Aliasing is also used to set up priorities for divided highways tie-ins (to either 
the existing surface or adjacent lane surface).

Design Considerations

There are other design considerations that need to be addressed such as: 

 How to handle transitions between different templates on your corridor.
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 How to smooth out end condition transitions or replace end conditions over a station range.

 How to modify a single template drop to fit real a world condition

Section Objectives:

♦ To learn how to review and edit template transitions for proper point connections 
between templates on your corridor.

♦ To learn when you should edit template transitions.

♦ To understand the two different types of end condition exceptions.

♦ To learn how to modify end conditions and create end condition overrides and 
transitions without introducing template drops.

♦ To learn how to make a single station template edit to correct minor sideslope 
problems.

Template Transitions

Template transitions occur when two different templates are specified in the Template Drops 
dialog box. The transition occurs along the entire length between template drop stations. 
Template transitions are shown color coded in the plan view of the Roadway Designer.

After entering your template drops, the Roadway Designer’s plan view is updated to show the 
template transition range (the station range between different templates in the template drop 
list). The actual drop stations appear as orange lines in plan along the corridor. The template 
transition range is color coded as follows: 

♦ Red – None of the points between the two templates are connected.

♦ Yellow – Like named points have been connected by the software, but some points 
remain unconnected. A typical cause is a different number of points between templates.

♦ Light Blue – The transition has been reviewed by the user, but there are points still 
unconnected.
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♦ Dark Blue – All of the template points are connected.

Note: End condition points are not connected by this process; they are automatically 
connected.

InRoads automatically connects like point names between the two different templates, so it 
would be unusual to see a red template transition since CDOT uses standard point names 
contained in the template library. Therefore most template transitions will initially appear dark 
blue or yellow. Other points, however, must be manually connected. 

You can review and manually connect points by double-clicking on the colored template 
transition zone in the Roadway Designer plan view. This opens the Edit Transition dialog box. 
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After connecting the points in this dialog, you can preview how the templates transition will 
behave from start to end by using a transition “slider bar”. If your transition doesn’t preview 
correctly, you may need to release some point constraints. For example, if you’re transitioning 
from a two lane to a four lane template, the outer-most edge points may have horizontal 
constraints that need releasing in order to “widen” out for the additional lanes. You can edit 
point constraints directly from this dialog box, just like you do in the template editor.

If you missed some point connections after this process, your transition will appear light blue in 
plan view. Repeat the process until all points are connected and the transition appears dark 
blue. 

Note: You may want to review the transition initially and then wait on making any manual 
point connections if you plan to later synchronize template library changes to the IRD 
file. After reviewing the transition, it will appear light blue as a reminder that you need 
to set the transition after all template changes are complete.

Important! Synchronizing the template library to the IRD file will overwrite your template 
transitions and you will lose any edits previously made. Always wait until all 
template changes have been synchronized with the IRD file before editing 
template transitions.
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To edit a template transition:

1. Locate the transition in the plan view of Roadway Designer and <D> <D> in the colored 
area. This displays the Edit Transition dialog box.

2. <D> on a bold ‘+’ sign then <D> on the desired connection point on the other template.

Note: Unconnected points appear bold. If you’re unsure how points are to be connected, 
hover over the point to get a point name read-out.

Note: The second point selected could have other points connected to it.
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3. The orientation of the two templates can be changed to make it easier to see. <R> on the 
desired template and select Move Template.

4. Repeat steps 2 and 3 until all points are connected.

5. To change a connection, <R> on the desired connection line and select Delete. The 
connection is removed and can be relocated as described above.

6. <D> OK to complete the transition. The Edit Transition Midpoint dialog box is displayed.

7. Modify point constraints to make the transition work properly. <R> on the desired point 
and select either, Edit Point or one of the Delete Constraint options (usually a 
horizontal constraint needs to be deleted).

Note: You can also add or edit point constraints from this dialog box, just like you do in the 
template editor. The constraint release or edits apply only to the transition range.

8. Repeat step 7 as needed.
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9. Use the Transition slider at the bottom of the dialog box to test the transition.

10. To change point connections, select Cancel in the Edit Transition Midpoint dialog box to 
return to the Edit Transition dialog box.

11. When editing is complete select the OK button. This dismisses the Edit Transition 
Midpoint dialog box.

The transition color in the Roadway Designer plan view changes to dark blue when all points 
are connected.

End Condition Exceptions

End Condition Exceptions are used to modify end conditions through a station range along the 
corridor without requiring the creation of additional template drops. This is a powerful tool that 
allows you to “fine tune” areas where end conditions may have rapidly changing sideslopes or 
areas where sideslopes may fall outside of right-of-way boundaries. Roadway Designer allows 
you to preview the end condition exception edits via the cross section view before creating your 
design surface. This means you don’t have to perform tedious surface features edits to achieve 
these results. 

Types of End Condition Exceptions

End Conditions Exceptions fall into two categories:
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 End condition overrides – the end condition slope and/or width is overridden, or replaced, 
with the edited end condition or a completely new end condition for the specified station 
range. 

Example 1: Overriding a 6:1 sideslope from the template with a 3:1 override sideslope 
through a 300 ft. station range where the 6:1 sideslope falls outside the right-of-way 
limits.

Example 2: Replacing a v-bottom ditch from the template with a flat bottom override 
ditch through a specified cut range along the corridor.

 End condition transitions – used to “smooth out” an end condition over a station range 
where the sideslope is changing due to terrain conditions. This is similar to template 
transitions except the transition occurs on an end condition component.

Example: Smoothing out a fill slope that changes back and forth between a 6:1 and a 
3:1 slope over a 200 ft. station range. This is replaced with a gradual 6:1 to 3:1 
transition over the same interval.

End condition exceptions are specified on either the right or left side. If you only need the 
exception on the left side, for example, you can maintain the template end condition on the 
right side. Or, you can set up different exceptions on the right and left side depending on the 
terrain conditions and sideslope behavior. 

There is also a Backbone Only option that removes end conditions from the station range 
specified, which is useful in bridge or culvert areas.

InRoads uses a color coding system in Roadway Designer’s plan view to denote the two 
different types of exceptions:

♦ Light Blue – represents end condition overrides.

♦ Dark Blue – represents end condition exceptions.

Note: End condition exceptions are shown on the outside of the corridor to distinguish 
them from template transitions zones. which are shown inside. 

Defining End Condition Exceptions

Defining an end condition exception is a two part process:

a. Adding the exception entry by specifying the station range and designating it as a left/
right override or left/right transition.

b. Editing the exception to modify the behavior of the end condition (this is similar to 
editing a point on a template and/or editing a template transition).

Follow the steps below to define an end condition exception:

1. Select Corridor > End Condition Exceptions from the Roadway Designer menu bar, 
or <D> on the End Condition Exceptions button from the button bar to open the End 
Condition Exceptions dialog box.
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End Condition Transitions

To define an End Condition Transition, first add the entry:

1. In the End Condition Exceptions dialog box, key in the Start station or use the locate station 
button and select the station from the plan view.

Note: You can use the Ctrl key to select the station from the drawing file.

2. Key in the Stop station.

3. Toggle on the desired transition side (Left Transition or Right Transition).

4. <D> Add. The data is listed in the End Condition Exceptions area of the dialog box.

Next, edit the entry to define the transition: 

5. Highlight the desired entry in the End Condition Exceptions list.
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6. <D> Edit. The Edit Transition dialog box is displayed.

7. Follow steps 2 through 11 in the Template Transitions section to complete the transition. 

Note: You may need to set a point as Infinite through the transition range by right-clicking 
and editing the point in the Edit Transition Midpoint dialog.

End Condition Overrides

To modify or completely change an end condition through specified station range, first add 
the entry:

1. In the End Condition Exceptions dialog box, key in the Start station or use the locate station 
button and select the station from the plan view.

Note: You can use the Ctrl key to select the station from the drawing file.

2. Key in the Stop station.

3. Toggle on the desired override side (Left Override or Right Override).
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4. <D> Add. The data is listed in the End Condition Exceptions area of the dialog box.

Next, edit the entry to define the override:

5. Highlight the desired entry in the End Condition Exceptions list.

6. <D> Edit. The Override dialog box is displayed.
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7. Edit the end condition. This dialog box works just like the Create Template dialog box (see 
the Defining Templates chapter in this document) except that only the end condition can be 
modified.

Note: All of the templates from the loaded template library are available for use when 
editing the override. Therefore, if you want to replace the end condition, you can 
delete the current end condition while in the Override box and then drag and drop a 
new end condition from the library onto your template. 

Deleting or modifying end conditions through this command does not delete them 
from the template in the template library. It is best practice to create or modify the 
end condition that you wish to use as the override first in the library.

Important! Even though the Override dialog shows only the first station of the edit 
range, you may encounter multiple sideslope requirements over the course 
of the override. Therefore, be certain to include both cut and fill sideslopes 
if both will be encountered.

8. <D> OK to complete the edit.

Backbone Only Exceptions

There is an option to turn off the end condition without having to edit the exception. This works 
for both transitions and exceptions, though in a slightly different manner. To create a Backbone 
Only exception:

1. In the End Condition Exceptions dialog box, key in the Start station.

2. Key in the Stop station.
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3. Toggle on the desired override or transition side.

4. Toggle on Backbone Only.

5. <D> Add. The data is listed in the End Condition Exceptions area of the dialog box.

Note: If a transition is selected, the end condition is deleted from all template drops between 
the Start and Stop stations, excluding the Start and Stop stations. 

If an override is used, the end condition is deleted from all template drops between the 
Start and Stop stations, including the Start and Stop stations.

Modifying Single Station Template Drops

There may be instances where an end condition needs to be modified at only one station instead 
of a range of stations. This occurs when:

 A sideslope ties at an odd location due to existing terrain conditions or 

 Where you want to tie a sideslope to a specific location (like an existing ditch) or 

 Where you want to pull a sideslope inside the right-of-way at just one station. 
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In these cases, you can modify a single station template drop. The figures below illustrate an 
example where you would want to edit a single station template to modify the location of the 
sideslope.

      

Single station template drops can be modified within the Roadway Designer section view. 
Changing a template in this manner creates a new entry in the Template Drops dialog box. The 
data for the changed template is stored in the IRD file as shown below.

Synchronizing this template drop will not change the template back to its original condition. To 
remove the edit, you must highlight it in the template drops and select Delete. 

Important! Modifying templates in this manner should be done sparingly to correct minor 
problems at single locations. Stations modified in this manner will not be 
processed by designer, in effect ‘freezing’ them in time and space. For 
example, changing the alignment will no longer change this template drop!

Note: For larger scale edits over a defined station range along the corridor, use other 
Roadway Designer tools like End Conditions Exceptions, Parametric Constraints, 
Point Controls, etc.



Page 348 Colorado Department of Transportation

Chapter 10 - Roadway Modeling A Practical Guide for Using InRoads V8i SS2

To edit a single template drop:

1. Select the station to edit with the Station Indicator.

2. Double-click in the section view. The Edit Template At Station Only dialog box appears.

3. This dialog box works just like the Create Template dialog box (see the Defining 
Templates chapter in this document). All points and components can be modified, deleted, 
or replaced.

Example of Modifying Single Template Drop

In this example a template drop is cutting a ditch in the middle of an area of fills. This 
example demonstrates how to remove the ditch from this template drop. 

1. Station 360+50 is selected with the Station Indicator.

2. Double-click in the section view to display the Edit Template At Station 360+50 Only 
dialog box.

3. <R> on the LT_Top-Of-Cut point.
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4. Select Move Point from the right click menu.

5. Move the point to the desired location and <D>. Because it is an end condition, it will 
snap to the existing surface.

Note: For reference, the original end condition component location displays in light blue.
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6. <D> OK to accept the change. The modification is reflected in the Roadway Designer 
section view.

Section Summary:
♦ Template transitions occur between different templates in the template drop list.

♦ Template transition zones are color-coded in plan view to indicate the status of point 
connections between templates.

♦ InRoads automatically connects like point names between two different templates. 
Other points must be manually connected.

♦ Edit the template transition to manually connect the template points.

♦ Synchronizing the template library to the IRD file will overwrite your template 
transitions and you will lose any edits previously made. Generally wait until all 
template changes have been synchronized with the IRD file before editing template 
transitions.

♦ End Condition Exceptions allow you to “fine tune” end conditions without creating 
additional templates or template drops.

♦ There are two types of end condition exceptions: end condition overrides and end 
condition transitions.

♦ End condition overrides replaces the template end condition with a modified one or a 
completely new end condition from the template library.

♦ End condition transitions are used to “smooth out” an end condition over a station 
range where the sideslope is changing due to terrain conditions.

♦ End condition exceptions are color coded in plan view to indicate either overrides or 
transitions.

♦ Modify a single station template to correct minor sideslope tie-in problems.

♦ When you edit a single station from the Roadway Designer cross section view, a new 
entry is created in the Template Drops box and stored in the IRD file.

♦ Deleting a single station template drop will change the template back to its original 
condition and the changes will be lost.
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Generating Design Surfaces

The goal of the roadway modeling process is to create a 3D terrain model or surface of your proposed design. 
Roadway Designer provides numerous tools necessary to input the engineering data to create, preview and 
modify your design interactively so that you can see the results of the modeling process and make necessary 
edits before creating the final design surface. After the interactive design iterations are complete, you’re then 
ready to generate the design surface.

Section Objectives:

♦ To understand the concept of surface features and components.

♦ To understand the difference between triangulated and untriangulated features.

♦ To understand how to use the Create Surface command to take your Roadway 
Designer data to a 3D surface.

♦ To learn how to create a design surface from a single corridor.

♦ To understand the difference between a finished grade surface and alternate surfaces 
and learn how to create alternate surfaces.

♦ To learn how to create one surface from multiple corridors.

Elements of a design surface

A design surface contains both features and components including:

 Triangulated Features – Unless specified in the component, the topmost set of points in the 
template are triangulated and used to create the finished grade surface.

 Untriangulated Features – Those features below the finished grade surface are stored 
within the dtm as untriangulated features. They can be displayed in plan, cross sections, or 
profiles, but are not used in creating the surface.

 Components – These are the material definitions built into the template. They are used to 
adjust end area volume calculations. Components can also be shown on cross sections.

♦ You can create vertical components (like pavement lifts or walls), and show these “true 
vertical” components on your cross sections since they are not part of the triangulated 
network when you generate a design surface. 

♦ When calculating end area volumes, you can choose to exclude component volumes 
from the mass ordinate volume if you want separate material volumes for each 
component.

When creating a design surface, you have the option of creating:

 A single surface – the finished grade from topmost set of template points.

 Separate finished and alternate surfaces – e.g. for subgrade surfaces.

 A multiple corridor surface – combining design surfaces from multiple corridors (mainline, 
ramps, crossing streets, etc.) into one surface.

The Create Surface command

Use the Create Surface command to create a proposed surface or surfaces from the data stored 
in the Roadway Designer IRD file. 
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This command contains several options including:

 Surface Name – when the surface is created, you have the opportunity to give it a name. 
The name becomes the name of the resulting surface. If you toggle on New Surface for 
Each Corridor, the Corridor name instead becomes the surface name. 

 Create Surfaces From – select the corridor(s) used to create the design surface(s).

 Clipping Options – if running multiple corridors, use this option to determine how the 
surfaces will be clipped in overlapping regions. This option is used in conjunction with 
Target Aliasing. The corridor that uses Target Aliasing will be used to clip the other 
corridor. 

 Empty Design Surface – if the surface has already been created, turn this option on to delete 
all features from the current surface before re-creating it. This ensures you don’t have left-
over, duplicate or bogus features in your surface. 

 Create Alternate Surfaces – toggle on this option if you’ve assigned template subgrade 
points to an alternate surface name. In addition to the finished surface, the alternate 
surface(s) are created.

 Triangulate Surface – turn this option on to automatically triangulate surface feature points 
to create the triangulated network (in addition to adding the features and components to the 
surface). If this option is turned off, you can triangulate the surface later using the 
Surface > Triangulate Surface command.

 Remove Loops – turn this option on to eliminate loops on features or overlapping features 
that may cause surface problems. Loops/overlaps occur with non-colinear alignments and 
can occur with secondary alignments (e.g. intersection returns).
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 Add Exterior Boundary – turn this option on to automatically create an exterior boundary 
for the design surface(s). An exterior boundary defines the limits of triangulation. No 
triangles will form outside the exterior boundary, thereby eliminating bogus or bad 
triangles from forming in corners or concave areas. After turning this option on, specify a 
feature Style for the boundary, which controls it’s display properties.

Single corridor surface

Use the Create Surface command to create the design surface (DTM) from the selected 
corridor(s).

To create a design surface:

1. Select Corridor > Create Surface form the Roadway Designer menu bar or <D> the 
Create Surface button from the button bar.

2. Key in a Name for the surface.

3. The following check boxes should be toggled on, except in special circumstances: Empty 
Design Surface, Add Exterior Boundary, Triangulate Surface, and Remove Loops.

4. Set the Exterior Boundary Style to Exterior Boundary.

5. Toggle on other options as needed.
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6. Select the corridors to be modeled from the Create Surface(s) From area.

7. <D> Apply. The design dtm is created and a Results window is displayed.

8. The Results report contains point control information and other settings used in the 
corridor. Save and/or Print the Results file as desired.

9. <D> Close on the Results dialog box.

10. <D> Close on the Create Surfaces dialog box.

Alternate surfaces

Typically, when a design dtm is created from Roadway Designer only the finished grade is 
constructed as a triangulated model. The subsurface points are stored in the design dtm as 
untriangulated points. To create surface from subsurface points (or a combination of finished 
grade and subsurface points) the Alternate Surface option is used. This option requires that you 
first assign an alternate surface name to the point via the template point properties before using 
Roadway Designer for modeling.

Note: A template point can belong to the finished grade surface plus one alternate surface. 

To create an Alternate Surface:

Assign the alternate surface name to the template points

Note: If these steps were done before the corridor was created, skip to step the Create Design 
Surfaces section below.

1. Select Modeler > Create Template from the InRoads menu bar.
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2. <D><D> on the desired template from the Template Library pane of the Create Template 
dialog box.

3. <D><D> on the desired point. 

4. Toggle on the Alternate Surface check box.

5. Key in the Name for the Alternate Surface.

Note: Use the same name for all points used to create the alternate surface. After it is keyed in 
the first time in a template, it is available in the drop-down list for other points.

6. <D> the Apply Button.

7. <D> Close.

8. Repeat steps 3 through 7 to add additional points to the alternate surface.

9. Select File > Save from the Create Template menu and Close the Create Template 
dialog box.

10. Select Modeler > Roadway Designer from the InRoads menu bar.

11. Select File > Open from Roadway Designer menu bar and open the desired IRD file.

12. Select Corridor > Template Drops.

13. Synchronize the entries as needed.

14. Close the Template Drops dialog box.
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Create the Design Surfaces

1. Select Corridor > Create Surface.

2. Toggle on the Create Alternate Surfaces check box.

3. Make the other settings as desired.

4. <D> Apply. The alternate surface(s) are created along with the finished grade surface. It is 
stored in its own DTM.

Multiple corridor surface

With InRoads XM, ramps and crossing streets can be combined into a single model (DTM). To 
use the clipping options with combined surfaces, Target Aliasing must be used (see Target 
Aliasing section in this chapter). 

To create a combine corridor:

1. Select Modeler > Roadway Designer from the InRoads menu bar.

2. Select File > Open from Roadway Designer menu bar and open the desired IRD files.

3. Select Corridor > Create Surface.

4. In the Create Surface(s) From area, highlight the corridors for the combined surface.



Colorado Department of Transportation   Page 357

A Practical Guide for Using InRoads V8i SS2 Chapter 10 - Roadway Modeling

5. <D> the Clipping Options button.

6. In the Clipping Options dialog box, <D> in the Clipping Option column to select the 
desired method. The corridor that uses Target Aliasing will be used to clip the other 
corridor using one of the following methods:

○ Clip All – All components and features are removed from the clipped corridor in the 
overlap area. This option is mainly used for intersections.

○ Clip End Conditions Only – Only the end condition components and features are 
removed from the clipped corridor in the overlap area. This option is mainly used 
for entrance and exit ramps.

○ Clip None – All components and features from both corridors are retained.

7. <D> OK to return to the Create Surface dialog box.

8. Make the other settings as desired.
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9. <D> Apply. The combined surface is created.

10. <D> Close to dismiss the Create Surface dialog box.

Section Summary:
♦ A design surface is composed of triangulated and untriangulated features as well as 

components.

♦ Triangulated features are the linear features that result from the topmost set of points in 
the template and are used to create the finished grade surface.

♦ Untriangulated features are linear features that result from the points below the 
finished grade do not contribute to the triangulated network, unless they are specified 
as an alternate surface. Additional untriangulated features can come from 
components, such as barriers, where Component Properties are set to Exclude from 
Triangulation.

♦ Components are typically material definitions that can be shown on cross section and 
used in volume calculations. They can also be shown in plan view, where you can 
dynamically rotate the view to visually analyze the components in 3D.

♦ Use the Create Surface command to process your Roadway Design data to a 3D design 
surface.

♦ When using the Create Surface command, you have the option to create a finished 
grade surface from one corridor (with or without alternate surfaces) or a merged 
surface by combining corridors.

♦ To create an alternate surface, you must first assign an alternate surface name to the 
template point.

♦ A point can belong to the finished grade surface plus one alternate surface.

♦ Alternate surfaces typically are used for subgrade surfaces and you can create as many 
alternate surfaces as you like. Each point, however, can only be part of one alternate 
surface.

Chapter Summary:

 Roadway modeling is the process of creating a 3D design surface or surfaces of your 
proposed roadway by applying roadway typical sections along a corridor and tying the 
template end conditions into an existing surface or other target. 

 Roadway Designer is the tool used to accomplish the modeling process in InRoads.

 The initial design is created using CDOT design criteria and engineering data as input 
information to the modeling process.

 Several tools allow you to refine your model by creating transitions, introducing lanes, 
ramps, etc.

 CDOT’s superelevation design criteria is used to add superelevation to your design.

 You can model, review, and edit your design in an interactive and iterative process until 
you have successfully refined your roadway design.

 Some of the refinements you can make include modifying transitions, adjusting lift depths, 
adjusting sideslopes to fall within right-of-ways, replacing end conditions where needed 
and correcting sideslope problems at specific locations.
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 Once you model is finalized, you can create a 3D design surface from the Roadway 
Designer data.
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Changes in template design and the data stored in the DTM have made it necessary to change the Create Cross 
Section dialog box.  At the same time, the dialog box layout has been redesigned.  To display a set of Cross 
Sections:

Chapter Objectives:

 Demonstrate the process of creating and displaying cross section

 Illustrate how to annotate a set of cross sections

 Describe updating cross sections

Creating and Displaying Cross Sections

While completing the following steps, pay particular attention to the preferences and settings used to create and 
display cross sections.  Understanding what preferences and settings to use whill save a lot of time.

1. Select Evaluation > Cross Section > Cross Sections from the InRoads bar menu.

2. From the Create Cross Sections dialog box, <D> the Preferences button.

3. From the Preferences dialog box, highlight the desired preference and <D> Load.

4. <D> Close to dismiss the Preferences dialog box.

5. Toggle on the surfaces to include in the cross sections.

6. Select Include from the dialog box explorer.
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7. Verify that Components is toggled on.

8. Toggle on other options as desired.

Note: The user does not have the option to choose which features are displayed from this 
dialog box.  All features from the selected surfaces that can be displayed will be 
displayed.

Note: Annotate runs the Annotate Cross Section command using the preference specified in 
the Surface Properties for the annotation preference. 

Note: Volumes runs the End Area Volumes command using the Tools > Options > General > 
Preferred Preference as the preference for the volumes command.

9. Select Controls > Limits from the dialog box explorer.

10. Set the Station Limits as desired.

11. Select Controls > Critical Sections from the dialog box explorer.
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12. Toggle on the desired critical sections.

13. <D> Apply, then <D> in the view window to place the cross sections.

14. <D> Close to dismiss the Create Cross Sections dialog box.

Annotating Cross Sections

1. Select Annotate Cross Section > General from the dialog box explorer.  

2. From the Annotate Cross Sections dialog box, <D> the Preferences button.

3. From the Preferences dialog box, Highlight the desired preference and <D> Load.

4. <D> Close to dismiss the Preferences dialog box.

5. Select the desired Cross Section Set from the drop down menu or use the target button.
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6. Toggle on the surface(s) to annotate.

7. Select Points from the dialog box explorer.

8. Toggle on Include Points to display point annotation.

9. Select Segments > General from the dialog box explorer.
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10. Toggle on Include Segments to display segment annotation.

11. Select Features > General from the dialog box explorer.

12. Toggle on Include Features to display feature annotation.

13. Select Features > Annotate from the dialog box explorer.
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14. Highlight the features to annotate.

Note: Only features that are currently displayed in the cross sections can be annotated.

15. <D> Apply to annotate the cross sections.

16. <D> Close to dismiss the dialog box.

Updating Existing Cross Sections

Cross sections retain their association with the surfaces and features they display
and therefore they can be updated as desired.  Update Cross Section is used for three general 
situations; when the currently displayed data has changed, when new data is needed, and when 
currently displayed data needs to be removed from the sections.  The process for updating cross 
sections is described below.

1. Select Cross Sections > Update Cross Section from the InRoads bar menu.

2. On the General leaf, select the Cross Section Set to be updated using the drop down menu 
or <D> the “target” button then <D> on the desired cross section.  

3. Toggle on the desired Mode.  These are:

♦ Refresh - used to update existing cross section data.

♦ Display On -  used to add additional data to the cross sections.

♦ Display Off - used to remove data from the cross sections.

4. Set the Station Range as desired.  To update the whole cross section set, toggle off Station 
Range.  To update part of the set, toggle on Station Range  and key in the desired Start and 
Stop stations.



Colorado Department of Transportation   Page 367

A Practical Guide for Using InRoads V8i SS2 Chapter 11 - Cross Sections

5. Features that fall above or below the cross section grid are not usually displayed.  To 
display those features, toggle on Show Features Outside Elevation Range.

6. Select the Surfaces leaf.

7. Highlight the surface(s) to be updated.

8. To update the components in a design surface, select the Surfaces leaf.
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9. Highlight the surface with the components to be updated.

10. Select the Components leaf.

11. In the Component list, select the desired component(s).  To select all of the  components, 
<R> in the Component list and <D> Select All.
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To add or modify surface features in the cross sections, select the Crossing Features and/or the 
Projected Features leaves.  Crossing features generally run parallel to the alignment.  Typical 
crossing features are pavement features in the design surface, right of way lines, or utility lines.  
Projected features generally run perpendicular to the alignment.  Typically, these are drainage 
structures or utility lines.

To display or update Crossing Features: 

12. Select the Crossing Features leaf.

13. In the Surface list, select the desired surface(s).

14. In the Feature list, select the desired features(s).  To select all of the  features, <R> in the 
Feature list and <D> Select All.

To add or modify projected features:

15. Select the Projected Features leaf.

16. In the Surface list, select the desired surface(s).

17. In the Feature list, select the desired features(s).  To select all of the  features, <R> in the 
Feature list and <D> Select All.
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The Bandwidth sets the distance fromthe cross section station that data can be used for display.  
To set the Bandwidth:

18. Toggle on Redefine.

19. Key in the desired Ahead and Back values.

After making all of the desired settings:

20. <D> Apply to execute the command, then <D> Close to dismiss the Update Cross 
Section dialog box.

Important! Always use this command to turn off features displayed from a design surface 
before running Roadway Modeler and recreating the same surface. 
Otherwise, the features will not be recognized by the new surface and cannot 
be turned off or updated later.

Chapter Summary:

 Use the predefined preferences before changing the dialog box settings.

 Cross section annotation and volume data can be displayed when cross sections are 
generated.  These options use the surface Preference and the Preferred Preference. 

 Annotate Cross Section is used to add text data to the cross sections.

 Update Cross Section is used to redisplay modified data, add new data, and remove 
unwanted data from cross sections. 
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The changes in templates and surface data have made it necessary to change end area volumes as well.  The use 
of components stored in the design surface allows the program to calculate volumes with greater accuracy than 
previously.  To calculate End Area Volumes:

Chapter Objectives:

 Calculate basic end area volumes.

 Create an end area volume report.

 Add unsuitable material to calculations.

 Add a volume exception.

 Generate a Mass Haul diagram.

Calculating Volumes

1. Select Evaluation > Cross Sections > Cross Sections from the InRoads menu bar.

2. Select the End-Area Volumes folder from the dialog box explorer.

3. Select the General leaf from the dialog box explorer.

4. Select the desired Cross Section Set from the drop down menu.

5. Toggle on the desired surfaces.

6. Toggle on Cubic Yards in the Imperial Units area.

7.  Toggle on Create XML Report if desired.
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8. Toggle on Station Limits if desired.  If used, key in Start Station and Stop Station.

9. Select Classification leaf from the dialog box explorer.

10. To change the status of a material, <D> in the Mass Ordinate cell of the desired material.  
Include adds the material to the volume calculation, Exclude does not add the material to 
the volume calculation.

11. Select Annotation leaf from the dialog box explorer.
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12. Toggle on or off the desired objects.

13. <D> Apply to calculate the volume.  Cut and fill areas and volumes are displayed under 
each cross section.

14. <D> Close to dismiss the dialog box.

Volume Reports

End Area Volume XML Report

If Create XML Report was toggled on in  Step  7 above, a Bentley InRoads Report Browser 
window is displayed.  This window uses style sheets to determine the layout of the data.  To 
select a style sheet:

1. Select Tools > Style Sheet Root from the Bentley InRoads Report Browser menu bar.  
The Browse For Folder dialog box is displayed.

2. Navigate to: C:\Workspace\Workspace‐CDOT\Standards‐Global\InRoads\XML Style 
Sheets\

3. <D> OK.  The style sheet folder structure is displayed in the left pane of the Bentley 
InRoads Report Browser.

4. <D> on the Evaluation folder to expose its style sheets.
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5. <D> on the desired end-area volume style sheets to format the data in the right pane.

The formatted data can be copied and pasted into Excel or Word.

Unsuitable Material

InRoads has the option to modify end area calculations for unsuitable material (like topsoil and 
muck).  There are two options for determining the area of unsuitable material: by feature and by 
station extents.  If both are used, the station extents override the feature method.

Unsuitable Material by Feature

Before using this option a closed shape feature(s) must be created that defines the area of the 
material.  The feature(s) do not have to reflect the actual elevation of the surface.  It can be 
placed in its own surface at a zero elevation.  To use the Unsuitable Material by Feature option:

1. Repeat steps 1 through 10 under Calculating Volumes.

2. Select the Unsuitable Material by Feature leaf from the dialog box explorer.

3. Select the desired Surface from the drop down menu.

4. Key in the desired Depth.

5. Highlight the desired features from the Available Closed Features area.



Colorado Department of Transportation   Page 375

A Practical Guide for Using InRoads V8i SS2 Chapter 12 - Volumes and Mass Haul Diagram

6. <D> Add.  The data is added to the Unsuitable Materials list.

7. <D> Apply to calculate the volumes.  The area of unsuitable material is shown on the 
cross sections.

Note: Unsuitable material located under fill is included in the Mass Ordinate calculation. 
This occurs because materials removed from under fills must be replaced with 
embankment material.

8. <D> Close to dismiss the End‐Area Volumes dialog box.

Unsuitable Material by Station

There are no prerequisites for using this option.  To use the Unsuitable Material by Station 
option:

1. Repeat steps 1 through 10 under Calculating Volumes.

2. Select the Unsuitable Material by Station leaf from the dialog box explorer.

3. Select the Start Station using the drop down menu.

4. Select the Stop Station using the drop down menu.
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5. Select the Style using the drop down menu.

6. Key in the Cut Depth

7. Key in the Fill Depth.

8. <D> Add.  The data is added to the Unsuitable Materials list.

9. <D> Apply to calculate the volumes.  The area of unsuitable material is shown on the 
cross sections.  The calculations and displays are the same as those used for the Unsuitable 
Material by Feature option.

10. <D> Close to dismiss the End‐Area Volumes dialog box.

Volume Exceptions

Volume exceptions are used to remove the amount of earthwork calculated for an area where no 
work is done but is present in the design model (in the area of a bridge, for example).  Using a 
volume exception allows the user to create a single design dtm for the project and still account 
for areas where no earthwork will take place.  

The cross section set must have a cross section at the beginning station of the exception and the 
ending station of the exception.  Horizontal Event Stations or Key Stations (from Roadway 
Designer) can be used to include these stations if they do not fall on normal intervals.  To set up 
a volume exception:

1. Repeat steps 1 through 10 under Calculating Volumes.

2. Repeat the steps under Unsuitable Material by Feature and/or Unsuitable Material by 
Station, if needed.

3. Select the Volume Exceptions leaf from the dialog box explorer.

4. Select the Start Station from the drop down menu.  This is the last station where a volume 
will be calculated before the exception.

5. Select the Stop Station from the drop down menu.  This is the last station where no volume 
will be calculated at the end of the exception.
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6. <D> Add.  This adds the data to the Volume Exception area.

7. <D> Apply to calculate the volumes.  Below is an example of an End-Area Volume 
Report with an exception.

8. <D> Close to dismiss the End‐Area Volumes dialog box.
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Creating a Mass-Haul Diagram

A mass-haul diagram looks like a profile but the “ground line” represents the amount of earthwork. It is, in 
fact, using the Mass Ordinate for the data line. Set up the End Area Volumes dialog box as desired. To display 
a Mass Haul diagram:

1. Select End-Area Volumes from the dialog box explorer.

2. Toggle on Plot Mass Haul Diagram.

3. Select Mass Haul Diagram from the dialog box explorer.

4. <D> the Preferences button.

5. Select the desired preference then <D> Load and Close.

The mass-haul diagram is generated when the end-area volumes are calculated.

6. <D> the Apply button.
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7. After the end-area volumes are calculated, you are prompted to identify the location for the 
mass haul diagram.

8. <D> to identify the location of the lower left corner of the diagram. Below is an example of 
a mass haul diagram.

Reading and Using a Mass Hual Diagram

A mass haul diagram illustrates the accumulated algebraic sum of the cubic yards of earthwork 
on a project. These diagrams are used as an aid in balancing earthwork, computing haul 
distances, and calculating quantities.

The mass haul diagram is laid out with Stations running horizontallly and cubic yards of 
earthwork running vertically. Items of interest in the diagram are:
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 Mass Line - This is the data line of the mass haul diagram. It is a graphic representation of 
the Mass Ordinate that is displayed on cross sections and in the end area volume report.

♦ Excavation - This is shown by a rise in the data line when read going up station.

♦ Embankment - This is shown by a drop in the data line when read going up station.

 Point of Maximum Earthwork - This is where the volumes change from a net excavation 
to a net embankment.

 Point of Minimum Earthwork - This is where the volumes change from a net embankment 
to a net excavation.

 Base Line - This indicates the limits of an area of balanced earthwork (where excavation 
and embankment have equal values). The arrow indicates the direction of haul.

 Borrow (or Waste) - This indicates an area where additional material will have to be 
brought in from off-site in the case of borrow. Waste indicates an area where excess 
material must be disposed of.

It is up to the designer to indicate the Base Lines, Point of Maximum Earthwork, Point of 
Minimum Earthwork, and areas of Borrow or Waste on the mass haul diagram. Other items that 
can be added to the diagram are haul volumes for each base line, volumes for areas of borrow 
and waste, and sheet estimate volumes.

Chapter Summary:

 Surfaces are compared based on their Type property.  There must be an Existing and at 
least one Design type surface loaded to calculate volumes.

 The end area volume report can be created when the volumes are calculated.

 Unsuitable material locations can be defined based on a station range or a closed feature.  
Volumes within these areas are adjusted to account for the removal of this material.

 Volume exceptions ignore earthwork quantities through a given cross section range.  This 
allows the user to calculate a single quantity for the project  instead of separate quantities 
between each area of no construction.

 The Mass-Haul Diagram command uses the raw data from the end area volume report to 
create its data line.

 Choose the Mass-Haul preference that best suits the amound of earthwork on the job. Small 
jobs can use the CDOT - 1000 preference (1000 Cu. Yds. per major grid) while large jobs 
should use the CDOT - 10000 preference (10,000 Cu. Yds. per major grid). 

 When reading a mass haul diagram, if the data line rises that indicates a net excavation 
(cut) area. A dropping data line indicates an area of net embankment (fill).
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Reports are a method of taking data stored in the various InRoads files and presenting it in a readable format.  

Chapter Objectives:

 To describe where the data used to generate reports is stored.

 To present commonly used reports.

 To create various reports and use different report styles.

 To learn how to change the basic format of XML Reports.

Where Reports Come From

Command Generated Reports

Some reports are generated automatically as part of a command’s execution.  These are 
typically displayed in a Results window.  An example of this type of report comes from 
processing a corridor in Roadway Designer. 

The data in the Results window can be saved by selecting the Save As button.  The saved file 
is in Plain Text format and can be opened in Notepad, Wordpad, or Word.  The data can also 
be printed by selecting the Print button.

Command generated reports are enabled/disabled by toggling on or off the Report Lock.  The 
Report Lock is under Tools > Lock on the InRoads menu bar or on the button bar.
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the format of command generated reports is set in the program and cannot be changed.

Review Reports

Review reports are generated by reviewing data (usually horizontal or vertical geometry).  
These are displayed by selecting Geometry > Review Horizontal, Review Vertical or 
Review Geometry Point from the InRoads menu bar or by <R> on the desired alignment 
and selecting Review.
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The format of alignment review reports can be modified in a limited manner by selecting the 
Mode. The modes available for horizontal alignments are Alignment, Element, and Curve Set.  
The modes for Vertical alignments are Alignment and Element.  The data displayed is based on 
the mode is as follows:

 Alignment – Data pertaining to all elements of the alignment is displayed.

 Element – Data pertaining to a single element of the alignment is displayed.  Element data 
is accessed using the First, Last, Next, and Previous buttons in the report dialog box.

 Curve Set –Data pertaining to all of  the arc elements is displayed.

The data in the Review window can be saved by selecting the Save As button.  The saved file 
is in plain text (TXT) format and can be opened in Notepad, Wordpad, or Word.  The data can 
also be printed by selecting the Print button.

XML Reports

With the exception of the End Area Volume report, which is created from the command’s 
dialog box, XML reports are accessed from Tools > XML Reports from the InRoads menu 
bar.
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The reports are displayed in the Bentley InRoads Report Browser.  XML Style Sheets are used 
to format the data.  The report format is changed by selecting the desired style sheet from the 
style sheet list on the left side of the dialog box.

Commonly Used Reports

There are many reports and formats that can be generated from InRoads.  Some of the more common reports 
used by CDOT are described in this section.

End Area Volume Reports

The End Area Volume report presents data generated by InRoads in a tabular format.  This 
report is generated from the End Area Volumes command.  A set of cross sections with an 
existing surface and a design surface is required to create this report.  Create an End Area 
Volume report using the following steps:

1. Select Evaluation > Cross Section > Cross Sections from the InRoads menu bar.

2. Select End-Area Volumes > General from the dialog box explorer.
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3. Toggle on Create XML Report.

4. Make the other settings in the End Area Volumes dialog box as desired.  These options are 
explained in Chapter 12 -Volumes and Mass Haul Diagram.

5. <D> Apply.  The Bentley InRoads Report Browser is displayed.

6. Select the desired style sheet from the Evaluation folder.

The following style sheets are used with the End Area Volume report:
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♦ BasicEndAreaVolumeBalanceStation.xsl – This style sheet shows calculated and 
adjusted areas and volumes, a grand total, and highlights balanced stations.

♦ BasicVolume.xsl - This style sheet shows calculated and adjusted areas and volumes 
and a grand total.

♦ EndAreaVolume.xsl – This style sheet displays the same information as the 
BasicEndAreaVolumeBalanceStation.xsl style sheet with added quantities information 
for cut and fill included.

♦ EndAreaVolumePageTotals.xsl - This style sheet shows calculated and adjusted areas 
and volumes, Added Quantities volumes, a grand total, and page totals
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♦ EndAreaVolumeStationRange.xsl - This style sheet shows calculated and adjusted 
areas and volumes, Added Quantities volumes, and Station Range Totals.  The station 
range is set to 700 feet.

♦ MultipleMaterialVolumes.xsl - This style sheet shows calculated and adjusted areas 
and volumes.  It also calculates quantities for existing substrata surfaces.

♦ Volumes.xsl - This style sheet shows calculated and adjusted areas and volumes and 
the areas and volumes for component materials and unsuitable material.

 

Station Base and Station Offset Reports

These reports are used to calculate the offset distance between two horizontal alignments, a 
horizontal alignment and a surface feature, or two surface features.  They operate in a similar 
manner. They both measure from the alignment or feature selected on the General leaf (in the 
From area) to the specified alignment or feature.  Measurements are made perpendicular to the 
“From” alignment or feature.  Stationing for the Station Base report is controlled by the “From” 
alignment or feature.  The specified alignment or feature (identified on the Horizontal 
Alignments and Features leaves) control stationing for Station Offset reports.

The Station Base and Station Offset Reports are useful in determining gore stations and 
distances to the right of way.    To create a Station Base or Station Offset report (the station base 
report is used in this example) follow the steps below:
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1. Select Tools > XML Reports > Station Base from the InRoads menu bar.

2. On the General leaf of the Station Base Report dialog box, select the desired Horizontal 
Alignment.  In this example SH 86 is used.

3. Select the Include leaf.

4. In the Horizontal Points area, toggle on On-Alignment.

5. Toggle on Interval.
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6. In the Interval field, key in 100.

7. Select the Horizontal Alignments leaf.

8. In the Include field, key in the desired alignment name (Off Ramp in this example) 
and press the Tab key.

9. <D> Apply. This displays the Bentley InRoads Report Browser.
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10. In the Bentley InRoads Report Browser, select the StationBaseSingle.xsl from the  
StationOffset folder in the left pane.

11. Review the report in the left pane.

The important columns are:

♦ Column 1 – This is the station on the “From” alignment.  This is where the 
measurement originates.

♦ Column 4 – This is the station on the alignment selected on the Horizontal Alignments 
leaf.  It is the point measured to.

♦ Column 5 – This is the distance measured.

Other style sheets that are used with the Station Base and Station Offset reports are:
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♦ StationBaseCoordinates.xsl – This style sheet displays the “From” alignment station, 
the offset distance, and the X, Y, and Z  coordinates of the specified alignment.  The Z 
coordinate is the specified alignment’s vertical alignment.

Note: The vertical alignment listed under Specified Alignment Coordinates is the 
the child of the Active Alignment.  The data in the Z column comes from the 
vertical alignment attached to the Specified Alignment.

♦ StationBaseVerticalClearance.xsl - This style sheet displays the “From” alignment 
station, the offset distance, and the elevation difference between the “From” vertical 
alignment and the specified vertical alignment.  This report is useful when defining 
vertical alignments for merging alignments.

Geometry Reports

A geometry report can be used with a large number of style sheets to produce legal 
descriptions, calculate areas, and review alignment data.  These reports can be generated for a 
single alignment or multiple alignments. To create a geometry report:

1.  Select Tools > XML Reports > Geometry from the InRoads menu bar.  This displays 
the Geometry Reports dialog box.

2. In the Include field of the Horizontal Alignments area, key in the desired alignment 
name.  An “*” can be used to select all of the alignments in the geometry project.

3. In the Include field of the Cogo Points  area, key in the desired point name.  An “*” can 
be used to select all of the cogo points in the geometry project.

4. Toggle on Include Vertical Alignments, if desired.

5. Toggle on Include Vertical Event Points, if desired.
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6. Toggle on Include Horizontal Event Points, if desired.

7. Toggle on Interval and key in a value, if desired.  With the Interval toggled off, data is 
collected at alignment cardinal points only.  When the Interval is toggled on, data is 
collected at the interval along the alignment and at the cardinal points.

8. <D> Apply to create the report.  The Bentley InRoads Report Browser is displayed.

Most of the style sheets in the Geometry and CDOT folders can be used with geometry reports.  
Some useful style sheets are shown in the illustration below as they appear in the style sheet 
explorer.
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Examples of the style sheets highlighted above are shown here.  These are by no means the 
only style sheets that should be used.  They are, however, representative of the type of 
geometry report formats.

♦ Area.xsl – This style sheet displays the area in square feet, the area in acres, and the 
length of the perimeter for closed alignments.
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♦ HorizontalAndVerticalAlignmentReview.xsl - This style sheet displays information on 
all selected horizontal and vertical alignments.  The format is the same as the geometry 
Review Reports (show previously).  This report lists the data for the horizontal 
alignment followed by the data for its vertical alignments.

♦ ListCoordinatesStation.xsl - This style sheet displays the X, Y, and Z values along the 
selected alignment at the specified interval.  The Z coordinate comes from the vertical 
alignment.
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♦ CDOT Permanent Easement Description.xsl - This style sheet was designed 
specifically for CDOT.  It displays the alignment in the proper format for a permanent 
easement.  This report is meant to be saved as a text file and completed in Word.

Formatting XML Reports

When viewing a Command or Review report, things like precision, station format, and slope 
format must be set prior to creating the report.  With XML reports, data formatting can be 
changed after the report is generated.

To change the data format in an XML report:

1. Create the desired report as described above.

2. In the Bentley InRoads Report Browser, select Tools > Format Options from the menu 
bar.

3. In the Format Options dialog box, make the desired changes using the drop down menus.  
Changes appear in the report as they are made.  The illustration below shows the various 
options available.

4. <D> Close to dismiss the Format Options dialog box.
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Chapter Summary:

 Reports come from executing a command (like processing Roadway Designer), reviewing 
geometry, or creating XML reports.

 Some commonly used reports are End Area Volumes, Station Base and Station Offset, and 
Geometry reports.

 Using the Format Options with the Bentley InRoads Report Browser allows you to make 
minor changes to the format of the generated report.
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Plan sheets are used to convey design information to various entities involved with the project.  These include 
various design disciplines within CDOT, design and construction contractors outside of CDOT, and the general 
public who may be impacted by the project.  Typically, plan sheets are issued at three stages of the project; FIR 
(Field Inspection Review), FOR (Final Office Review), and AD (Advertisement).

CDOT uses the concept of model files and sheet files to create plan sheets.  Model files contain design data and 
sheet files contain the border and information relative to the border.  For more information on sheet files and 
model files, consult the CDOT Sheet File Creation and CDOT Working with Model Files and Sheet Files 
workflows.  Using the model file and sheet file concept greatly reduces the time required for preparing because 
the model data is updated automatically and only the relevant information in the sheet border needs to be 
changed.

The InRoads Plan and Profile Generator automates the process of creating sheet files and attaching the model 
files to them.

Chapter Objectives:

 Discuss the resources required to run the Plan and Profile Generator

 Describe the Plan and Profile Generator preferences

 Discuss user input required on the Plan and Profile Generator tabs

 Discuss editing sheet station extents

 Discuss moving reference files within the sheet border

Required Resources

Prior to running the Plan and Profile Generator, certain InRoads and MicroStation resources must be loaded 
and/or set.  The MicroStation resources required are:

 JPC#_Prof.dgn – The sheet profiles generated from the command are placed in this file. 
This file should be opened when starting Plan and Profile Generator.

 General.cel – This cell library contains the default sheet border (SHEET_Design-Sheet ) 
and north arrow used by the command to create the P&P sheets.  It must be attached to the 
JPC#_Prof.dgn and the Seed Host File (explained later) for the Plan and Profile Generator 
to operate correctly.  The General.cel library is located in the following folder:

C:\ Wokspace\Workspace-CDOT_XM\Standards-
lobal\MicroStation\cells\General.cel

 Plan Drawing Files – Design drawing files and survey topo files are used to create the plan 
portion of the sheets.  These should be located in the proper folders within the project’s 
directory structure.

 Plot Scale – Before running the Plan and Profile Generator command, determine the final 
plot scale of the drawings being created. Current preferences exist for 20, 40, 50, 100, 200, 
and 500 scale plots.  This should match the Annotation Scale of the drawings used to create 
the sheets.
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Note: Annotation Scale does not affect graphic elements displayed by InRoads.  The 
scale factor of the elements is determined by the Factors settings in the InRoads 
Options dialog box (Tool > Options  then <D> the Factors tab).

The following InRoads resources are required:

 Horizontal Alignment - Plan view limits are defined relative to a horizontal alignment 
(length and right/left offsets). Therefore, a project specific Geometry Project must be 
loaded into memory.

 Digital Terrain Models - Profile view limits are determined by the vertical relief of 
profiled DTM’s. At least one project specific DTM must be loaded into memory.

 InRoads Scale Factors - The Global Scale Factor controls text size, cell scale, and linestyle 
scale.  It must be set to match the Plan & Profile Generator preference (horizontal scale) 
selected.  Select Tools > Options then <D> the Factors tab to set the desired scale (or use 
the Global Scale Factor add-in).

Opening Plan and Profile Generator 

The Plan and Profile Generator dialog box is assceesed by selecting Drafting > Plan and Profile 
Generator from the InRoads menu bar.

Plan and Profile Generator Preferences

Preferences control various settings within the Plan and Profile Generator dialog box.  They define the clipping 
boundary for the plan view, set the vertical exaggeration for the profiles, and define sheet layouts.

Developed Preferences are:

 100 Scale Double Plan – 100 scale (plot factor) double plan sheet

 100 Scale Full Plan Sheet – 100 scale (plot factor) plan sheet

 100 Scale Full Profile 10x – 100 scale (plot factor) full sheet profile with 10 times vertical 
exaggeration applied

 100 Scale Double Profile 10x – 100 scale (plot factor) double profile sheet with 10 times 
vertical exaggeration applied

 100 Scale Full Profile 1x - 100 scale (plot factor) full sheet profile with 1 times vertical 
exaggeration applied

 100 Scale Full Profile 2x - 100 scale (plot factor) full sheet profile with 2 times vertical 
exaggeration applied

 100 Scale P&P (1x Vert) - 100 scale (plot factor) plan & profile with 1 times vertical 
exaggeration applied

 100 Scale P&P (2x Vert) - 100 scale (plot factor) plan & profile with 2 times vertical 
exaggeration applied

 100 Scale P&P (5x Vert) - 100 scale (plot factor) plan & profile with 5 times vertical 
exaggeration applied

 100 Scale ROW Plan Sheet

The preferences listed above have been duplicated for 20, 40, 50, 200, and 500 scales where it is appropriate.
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Note: Selecting a preference does not set the Global Scale Factors.  Setting the Global Scale 
Factors is described above in Required Resources.

Plan and Profile Generator Tabs

The Plan and Profile Generator dialog box contains nine tabs that control various settings used with the 
command.  The Main, Plan Controls, Profile Controls, Sheet Layout, Border and Title and Symbols and Details 
tabs require user input prior to executing the command.  Settings on the Sheet Index tab are used during the 
editing process to relocate the plan and profile views within the sheet border.

The tabs requiring user input are described below.

Main Tab

The settings on this tab determine the type of sheet being created (Plan and Profile, Plan only, 
or Profile only).  It also specifies the alignment and station extents used for the sheets.  The 
toggles along the left side of the tab determine the sheet type.  They are set by the preference 
selected and require no user input.

On the right side of the tab, the horizontal alignment and station limits are defined by the user.  
To set these options:

1. Select the desired Horizontal Alignment using the drop-down menu.  The active 
alignment is set by default.

2. In the Station Limits area, key in the Start station.

3. Key in the desired Stop station.
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The Length option determines the station extents for each sheet.  This is set by preference 
selected.

Plan Controls Tab

The settings on this tab determine the width of the plan area and the model files used for the 
sheets.  The key in fields at the top of the tab set the width of the plan area.  These are set by the 
selected preference and require no user input.  Model files make up the plan portion of the 
sheet.  To select model files:

1. <D> on the Plan Controls tab.

2. <D> the Model Files button.  This displays the Open Model File dialog box.

3. Navigate to the desired directory.  Typically, this will be:

♦ C:\Projects\JPC#\Dicipline\Drawings\Reference Files\ for design data

♦ C:\Projects\JPC#\ROW_Survey\Drawings\Reference Files\ for existing data

4. Highlight the desired files.

5. <D> Open. This dismisses the Open Model File dialog box and adds the selected files to 
the Model Files list box.
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6. Repeat steps 1 through 4 to add additional files.

To remove a file from the Model Files list:

7. Highlight the desired file.

8. Press the Delete key.

Profile Controls Tab

The settings on this tab determine the size and placement (within the dgn file) of the sheet 
profiles.  All options except Set Name, Vertical Alignment, Surface, and Profile Elevation 
Shifts are defined by the preference and require no user input.  To set the Set Name, Vertical 
Alignment, Surface, and Profile Elevation Shifts:

1. <D> on the Profile Controls tab.

2. In the Set Name field, key in the desired Name  (the default Set Name is the active 
horizontal alignment at the time the dialog box was opened).

3. Select the desired Profile Preference from the drop down menu.
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4. Select the desired Vertical Alignment from the drop down menu.

5. Select the desired Corridor from the drop down menu.

6. Toggle on the desired Surface(s).  The existing ground surface should be selected for 
display and highlighted.  The highlighted surface is used to determine profile shifts when 
the elevation changes in data will not fit inside the profile window.

7. Toggle on the desired Profile Elevation Shift.  This determines the horizontal location 
where a profile shift can occur.  

♦ Shift at Major Stations are at 500 foot intervals

♦ Shift at Minor Stations are at 100 foot intervals

♦ Shift Where Needed is at the closest even station

♦ Do Not Shift allows the profile to be as large as necessary to contain the data.  The 
profile window may overlap the plan area with this option.

Sheet Layout Tab

This tab controls how the sheet files are made and how the borders are laid out in the files.  The 
only field on this tab that requires user input is the Host File field.  To edit the Host File field:

1. <D> on the Profile Controls tab.

2. <D> the  button for the Host File.  The Save As dialog box is displayed.
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3. Navigate to the C:\Projects\JPC#\Dicipline\Drawings\ directory 
(C:\Projects\12345\Design\Drawings\ for this example).

4. In the File name field, key in the desired Name (12345DES_PnP.dgn for this example).

5. <D> Save.  This dismisses the Save As dialog box and inserts the data into the Host File 
field.

v

Border and Title Tab

This tab is used to specify the border cell for the plan sheets.  To specify a border cell:

1. <D> the Border and Title tab.

2. Select the desired cell using the Name drop down menu.  The default cell is 
SHEET_Design‐Sheet (which is used in this example).
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Symbols and Details tab

This tab is used to specify the North Arrow cell for the plan sheets.  To specify a North Arrow 
cell:

1. <D> the Symbols and Details tab.
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2. Select the desired cell using the Name drop down menu.  The default cell is 
SHEET_North‐Arrow (which is used in this example).

Executing the Command

There is minimal user input in executing the Plan and Profile Generator command but a lot 
happens on the screen.  The user input required and a description of the command’s processing 
is given below.

User Input

1. <D> Apply.  This can be done from any tab in the dialog box.

2. <D> the location in the MicroStation view window for the lower left corner of the profile 
set.

Command Processes

Once the location for the profile set has been identified, The command works through the 
following processes:

♦ A new profile set is created.  This set contains one or more profiles for each sheet 
(sheets with an elevation shift will contain more than on profile). This information is 
on the Profile Controls tab.

♦  A copy of the Seed Host File is created.  The name in the Host File field is used for this 
file. This information is on the Sheet Layout tab.

♦ Plan view reference limits are established and a Clipping Boundary is created.   This 
information is on the Plan Controls tab.
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♦ The Model Files and sheet profile(s) are attached as reference files.  This information is 
on the Plan Controls tab (model files)and the View Layout tab (reference location 
within the sheet border).

♦ The sheet border cell is placed in the generated drawing.  This information is on the 
Border and Title tab.

♦ The North arrow is placed in the generated drawing.  This information is on the 
Symbols and Details tab.

♦ Match Lines and Stations are placed in the generated drawing.  This information is on 
the Match Lines tab.

♦ With the exception of the first step, these steps are repeated for each sheet created.

♦ After the last sheet is created, the Sheet Index tab of the Plan and Profile dialog box is 
populated with data on each sheet.

Viewing Sheets

The Sheet Index tab can be used to navigate between plan and profile sheets easily.  To dusplay 
a sheet in MicroStation:

1. <D> the Sheet Index tab.

2. Highlight the desired sheet from the Sheet Index list (sheet 3 in this example).

3. <D> the Show Sheet button.  The highlighted sheet is opened in the MicroStation 
session. 
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VDF File

The View Definition File (*.vdf) save the dialog box settings made for the Plan and Profile 
Generator.  This file can be used to recreate a set of plan sheets as originally laid out, or as a 
starting point for a new plan set.

Saving a VDF File

To save the *.vdf file:

1. <D> the Sheet Index tab.

2. <D> the Save button. This displays the Save VDF File dialog box

3. In the Save VDF File, Navigate to the desired folder (C:\Projects\12345\Design\InRoads for 
this example).

4. In the File Name field, key in the desired name.
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5. <D> Save.  This creates the file and closes the Save VDF File dialog box.

Loading a VDF File

To load a *.vdf file:

1. <D> the Sheet Index tab.

2. <D> the Open button.  The Open VDF File dialog box is displayed.

3. Navigate to the folder containing the *.vdf file.

4. Highlight the desired file.
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5. <D> Open.  This dismisses the Open VDF File dialog box and updates the the Plan and 
Profile Generator dialog box.

Editing Sheets

The Plan and Profile Generator creates the sheet extents based on the length of the alignment 
divided by the length of a sheet.  This can result in important design features on the edge of a 
sheet or split between sheets.  The example below illustrates how to adjust the sheet extents.

In this example, the project starts at station 204+00 and ends at station 260+00.  Running the 
Plan and Profile Generator has yielded the following sheet extents:

 12345DES_PnP1.dgn – 204+00.00 to 210+00.00

 12345DES_PnP2.dgn – 210+00.00 to 224+00.00

 12345DES_PnP3.dgn – 224+00.00 to 238+00.00

 12345DES_PnP4.dgn – 238+00.00 to 252+00.00

 12345DES_PnP5.dgn – 252+00.00 to 260+00.00
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On sheet 12345DES_PnP3.dgn, there is an intersection approximately 200’ (2” paper scale).  
The illustration below shows this sheet.

By centering the intersection in the sheet, the intersection design will be displayed on a single 
sheet and the total number of plan sheets can be reduced to 4.  To accomplish this, follow the 
steps below:

1. Open the profile drawing used for the first Plan and Profile Generator run 
(12345_DES_Prof.fgn in this example).

2. Using MicroStation, delete the existing profile set.

3. Using InRoads, display the Plan and Profile Generator dialog box.

Note: If InRoads has been closed since the first set of plan sheets were created, load the VDF 
file as described above.

4. Select the Sheet Index tab.
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5. Note the Sheet Rotation of sheets 1 and 2.  This is required in a later step.

6. Select the Main tab.

7. Toggle on Use Plan Views.

8. Highlight the desired Plan Views from the list (3 in this example)

9. <D> the Edit button.  The Edit Plan View dialog box is displayed.

10. In the Edit Plan View dialog box, key in 218+00.00 for the Start station.  This shifts the 
intersection 600’ (6” in paper units) to the right, moving it to the center of the sheet.

11. Key in 232+00.00 for the Stop station.  This makes the sheet 1400’ (14” in paper units) 
long.
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12. <D> Apply.  The Adjust Plan Views dialog box is displayed.

13. In the Adjust Plan Views dialog box, toggle on Adjust all views to maintain view 
lengths.  This changes the stationing on the other sheets to match with the changes on 
sheet 3.

14. <D> Ok.  

15. A message is displayed reading, “Update view name in corresponding sheets?”.  <D> 
Yes.  This changes the view names to match the modified sheet extents.

16. Back in the Edit Plan View dialog box, <D> Close to dismiss the dialog box.

17. On the Plan and Profile Generator Main tab, highlight 1 in the Plan Views list.

18. Press the Delete key.

19. <D> Yes in the Confirm Single View Delete dialog box.
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20. <D> OK in the This view exists on sheet 1 message window.

21. Highlight 1 in the Profile Views list.

22. Press the Delete key.

23. <D> Yes in the Confirm Single View Delete dialog box.
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24. <D> OK in the This view exists on sheet 1 message window.

During this process the data for the first sheet has changed.  This change is the result of a 
problem with the software.  It is corrected by editing the Plan Views entry.

25. Highlight Index 1 in the Plan Views list.

26. <D> the Edit button.

27. In the Edit Plan View dialog box, key in 204+00.00 for the Start station.  

28. Key in 218+00.00 for the Stop station.  

29. Key in 105^00’00” in the Rotation field.  This is the angle noted in step 5 above.
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30. <D> Apply.  The Adjust Plan Views dialog box is displayed.

31. In the Adjust Plan Views dialog box, toggle on Do not adjust any other views.  This 
changes the first sheet only.

32. <D> Ok.  

33. A message is displayed reading, “Update view name in corresponding sheets?”.  <D> 
No.  This changes the view names to match the modified sheet extents.

34. Back in the Edit Plan View dialog box, <D> Close to dismiss the dialog box.

35. <D> Apply.  This can be done from any tab in the dialog box.

36. <D> Yes in the, “DO you want to regenerate Profile Views?” message.

37. <D> the location in the MicroStation view window for the lower left corner of the profile 
set.
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The dgn files are recreated using the new data. The illustration below shows the placement 
of the intersection.

38. Save the VDF file as explained above.
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Moving Reference Files

Curves on the alignment can cause the plan reference files to display partially outside of the 
sheet border.  If the curve is not too severe, the reference files can be brought inside the border 
by repositioning them. 

Continuing the example above, sheet 12345DES_PnP4.dgn has its plan reference files partially 
outside of the sheet border.  They need to be moved .6” (paper units) down to fit within the 
border.  To adjust the plan reference file location:

1. Display the Plan and Profile Generator dialog box.

Note: If InRoads has been closed since this set of plan sheets were created, load the VDF file 
as described above.

2. Select the Sheet Index tab.

3. Highlight 4 in the Sheet Index list.
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4. <D> the Show Sheet button to display the sheet in the MicroStation view window.

5. In the Sheet Views area of the Sheet Index tab, highlight 4 Plan from the list.

6. <D> Edit.  The Edit Sheet Views dialog box is displayed.

7. In the Edit Sheet Views dialog box, key in 7.90 in the Anchor Y field.
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8. <D> OK.

9. <D> the Regenerate Sheet button to update the dgn file.

10. <D> Yes in the “This sheet border and its data will be deleted and re‐created. Do you 
wish to continue?” message box.

The sheet is redisplayed with the reference files in their new location.  The illustration 
below shows the finished sheet.

11. Save the VDF file as explained above.

12. <D> Close to dismiss the Plan and Profile Generator dialog box.

Chapter Summary:

 Resources required to run the Plan and Profile Generator include an empty DGN files for 
the profiles and sheet borders,  DGN files containing plan data, cell library containing cells 
called by the command, and InRoads ALG and DTM files for the project.
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 The Plan and Profile Generator preferences are used to make most of the required setting 
changes.

 The Main, Plan Controls, Profile Controls, Sheet Layout, Border and Title and Symbols 
and Details tabs require user input.  

 Important design elements should be located in the middle of the plan sheet if possible.  
Sheet station extents are edited to reposition these elements within the sheet border.

 There are times when the plan reference file need to be moved inside the sheet border.  This 
is done on the Sheet Index tab in the Sheet Views area.
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It is not unusual for a project to require more detail than a surface generated by Roadway Designer can provide. 
Nor is it unusual to need a surface that cannot be easily created using templates. A few of the many examples 
that may require an additional level of detail include:

 Intersections

 Interchanges

 Divided highways

 Bridge abutments

 Borrow pits

 Pedestrian refuges

 Ponds

 Parking areas

Rather than try to build a final surface by using typical sections alone, then merging or running many corridors 
at once to build a parking lot, for example, you can build breakline features for your surface using multiple 
methods. With this approach, you can use a variety of tools to contribute to the model. Instead of trying to force 
one workflow (e.g. Typical Sections and Modeling) to create everything, use individual commands designed 
specifically to create or modify features, combining their resulting breaklines for your overall model.

Section Objectives:

 To learn techniques for refining a design DTM, such as a composite model made up of 
more than one design surface.

 To accomplish project-specific design scenarios by manipulating individual features.

 To learn how to manipulate features for grading in areas that don’t lend themselves to the 
Roadway Modeling process, such as slopes around bridges, borrow pits or ponds.

 To learn where the Surface Creation and Editing tools fit into the overall CDOT Design 
process and how they can be used to your advantage.
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Locks

Before working with features, there are lock settings that should be understood: Feature Filter, 
Feature Highlight, Pen/Pencil, Delete Ink, Locate Features / Locate Graphics and Point 
Snap/Element Snap/No Snap. Suggestions on when to use each are listed below. For 
additional details on the locks, see the InRoads Online Help.

Feature Filter

Feature filters can be created to segregate the features listed in InRoads dialog boxes. For 
example, you can create a filter based on any number of criteria, such as whether or not a 
feature is triangulated. When you toggle on the lock, only features that meet the active filter 
criteria are shown in dialogs, and therefore available for editing. This can be handy, for 
example, when you are working with a surface containing hundreds or thousands of features, 
but you only want to see/edit edges of oil. Set up a filter to look for only features with ‘oil’ in 
the name, then toggle the lock on. 

Filters are stored in your XIN file and standard filters already exist for your use.

Feature Highlight

When the Feature Highlight lock is toggled on, any command that includes a feature list field 
will highlight the feature in plan view when it is selected in the list, whether it is displayed or 
not. This is a good check to visually verify the feature you want to display and / or edit.

Important! Turning on the Feature Highlight lock slows the opening of dialog boxes that 
include feature lists.

Pen / Pencil

             

When the features you are editing are displayed with Pen/Pencil set to Pencil, the modified 
features are kept ‘up-to-date’ in the graphics file. If set to Pen, original graphics are left in 
place and modified features are added, resulting in multiple graphical copies of features, 
although the DTM only contains the most recent update.

Delete Ink

When Delete Ink is toggled on, the Pen setting acts very much like Pencil, as all previous 
versions (Pencil or Pen) of a feature are deleted when the feature is modified.
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Locate Graphics  / Locate Features

                                                                        

Several of the commands described in this chapter are dual purpose. They can create features or 
they can create graphics. Likewise, they can use graphics or features as input. On most 
commands, you will note this difference when you Apply the command and it prompts for 
either features or elements, based on this lock’s setting. For others, the current Locate mode is 
shown at the top of the dialog box, some also have a Generate Graphics Only toggle.

Point Snap

                 

When using Partial Delete or Break Feature, the Point Snap limits the selected points to 
existing points on the feature. In other words, no new points are added at the beginning and end 
of the break. Element Snap has no effect on surface editing tools. For information on how the 
snaps affect geometry, see the InRoads Online Help.

Feature Properties

The Feature Properties command (Surface > Feature > Feature Properties) provides a 
list of all of the features contained in the surface and the style assigned to each feature. Use this 
dialog box for a variety of functions including:

 Changing feature properties like Name, Description, Point Type, Point Density Interval, 
etc.

 Making a non-triangulating feature part of the triangulated network, or vice-versa.

 Assigning the feature a parent name or secondary style for filtering purposes.

In addition, you can select List Points to generate a report on basic feature information along 
with the feature’s length and coordinate information for each vertex on the feature. This is 
helpful when checking a feature’s elevation.

Note: If the feature’s Style doesn’t exist in the current XIN, it will display red in the list.
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Creating Features

There are many options within InRoads that assist in CDOT’s design process besides typical sections and 
roadway modeling. Using these tools, you can build surfaces from scratch or add to previously created surfaces 
(design or existing).

Section Objectives:

 To be able to create new features from scratch.

 To develop an understanding of when each of the feature creation commands should be 
used.

 To learn techniques that will help refine existing surface models by adding features.

Import Surface from Graphics

MicroStation graphics can be imported into a surface to form features. If you are comfortable 
drawing with MicroStation, you might find it useful to first draw what you want in the design 
file, then import the graphics as features as opposed to creating the features from scratch. This 
is especially useful in situations where the graphics are relatively simple, or when you want the 
new feature to take on the elevations of a known surface so you do not have to worry about 
setting the z-coordinate manually. You can also use this command to create a “flat” feature, 
then use Generate Longitudinal Feature (GLF) to add elevations. See the Generate 
Longitudinal Feature section in this chapter for details.

1. Draw the graphics with MicroStation.

2. Select File > Import > Surface > From Graphics.

3. Specify the Surface where the feature is being imported.
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Note: If the surface has not been created, you may type the name in and it will be created 
when you Apply.

4. Specify the Load From option.

Note: To use a selection set, choose the Single option. When you Apply, you’ll be asked 
if you want to use the active selection set.

See the InRoads Online Help for information on the other options in this dialog.

5. <D> Apply and follow the prompts to load your feature(s) into the surface.

Accessing Design Surface commands

While there are many commands in InRoads that create features, several of them are grouped 
under Design Surface. You can access them from the Surface > Design Surface pull-
down menu, or from the Design Surface toolbar. Most are described in the following section.
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Generate Longitudinal Feature

Generate Longitudinal Feature (GLF) is used to create and/or modify 3D MicroStation 
elements or features in a DTM. It is an extremely powerful tool that allows much easier 
manipulation in 3D than MicroStation alone.

When using this command to create a new feature, one of the easiest methods is to draw the 
feature in plan view with MicroStation without regard to the elevation, then use GLF to copy 
the element, creating a feature while adding elevations at the same time. 

In this example, a drain line is added to the bottom of a pond. The design calls for the drain to 
start at a fixed elevation and proceed at a longitudinal grade along the prescribed route.

1. Use MicroStation to draw the drain line in the plan view.

2. Select Surface > Generate Longitudinal Feature.
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The Main tab

1. Specify the Surface where a feature is being added or modified.

Note: The Exterior Arc is used when the new feature is horizontally offset from the original. 
In this case, it is set to 5^. When the copy is offset to the outside of a corner, the 
resulting feature will fan out from the corner in 5^ increments, giving the effect of a 
fillet. The smaller the setting, the smoother the fillet.

Reference Feature

This category is for specifying how many vertices will be created in the resulting feature. 
Either Interval, Stroke Tolerance or both must be toggled on.

Interval is a master-unit setting that determines how often along the reference feature or 
element a new vertex is created.

1. In this case, the Interval is toggled on and set to 10. In general, this setting should 
reflect a similar interval to the surrounding features. Here, the pond bottom has a 
similar interval.

2. Toggle on Stroke Tolerance. This option has two functions: 

○ First, if the reference element contains a curve or arc, this setting is used to stroke 
the curve or arc into a series of vertices. See the InRoads Online Help for more 
information.

○ Second, it ensures the creation of a vertex at each occurrence of a vertex in the 
reference.

Longitudinal Feature

1. Set the Mode to New.

Longitudinal Feature options are available or not depending upon two things:

○ If Generate Graphics Only is toggled on or off – if on, several of the feature 
settings do not apply, since only graphics result from the command. In this case, it 
is toggled off.

○ If the Mode is New or Modify – if Modify, several of the feature settings do not 
apply, as they are already established for the feature or element being modified.

2. Key in a Name for the new feature.

3. Assign the new feature a Feature Style.

Hint: If there is already a feature using the desired style, save time by selecting it as the 
Name to populate the Feature Style field, then type over the name with your new one.

4. Select a Point Type from the drop-down.

5. For Point Density key in 0. 
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Note: Point Density is a densification factor applied to the feature when it is triangulated. 
Fixed vertices are not added to the feature using this option – but triangulation 
vertices are. This setting can be added or changed after the fact in Feature 
Properties.

Note: The Duplicate Names area is only applicable if you have chosen a name that 
already exists in the surface. The options are:

○ Append: The feature added is appended to the end of the named feature. As points 
are added, there is rubberbanding in the graphics file to show which end of the 
feature is being appended. If it is not the desired end, use Surface > Edit 
Surface > Reverse Feature Direction to first change the orientation of the 
original feature

○ Replace: The old feature is removed and the new one added in its place

○ Rename: A numeric suffix is added onto the name and used for the new feature

6. Toggle off Exclude from Triangulation.

Note: Toggle this option on if the feature is a utility, right-of-way, or some other 
breakline that you want to show on profiles and cross sections but do not want 
to affect the triangulation.

7. Toggle off Remove Loops.

Note: If Remove Loops is on, this option will remove the loops when you are 
copying a feature or element with horizontal offsets that would result in loops 
in interior corners.

8. Toggle off Triangulate Surface.

Note: Toggle on Triangulate Surface if it’s desired to see results of re-triangulation 
after each feature is added or modified.
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The Controls Tab

On this tab, the horizontal and vertical location of the new or modified feature is set. For details 
on each of the options, see the InRoads Online Help.

1. For the Horizontal Start and Stop Offsets key in 0, since the drain line has been drawn in 
the correct horizontal location.

2. Set the Vertical Method to Elevation/Longitudinal Slope. Here, the beginning of the drain 
line starts at 5142 and will slope at -1%.

3. <D> Apply. 

Note: You are prompted to identify Primary and Reference elements or features based on 
the Locate Graphics / Locate Features lock settings. This lock may be toggled in 
the middle of the command, so you can identify a Primary Feature, then toggle to 
Locate Graphics and identify a Reference Element.

Remember, the Primary element or feature is what you are copying or modifying and the 
Reference is for:

♦ Applying the interval

♦ Specifying what the result is perpendicular to, and 

♦ Stroking

For a situation such as the drain line created here, the original element is both the Primary 
and Reference. 

4. <D> on the drain line for the Primary element and <D> to accept.

5. <D> on the drain line for the Reference element and <D> to accept.
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Note: Once the Primary and Reference are identified and accepted, the Identify 
Location prompt is shown. When the copy or modification is horizontally offset, it 
is necessary to <D> on the side of the desired result. When it’s not horizontally 
offset, you can accept anywhere.

6. Since there is no horizontal in this case, <D> anywhere in the view to finalize the result.

7. View the triangles (Surface > View Surface > Triangles) and contours (Surface > 
View Surface > Contours) to see the results. 

Here, you’ll notice that there are triangles cutting across the corners, causing some erroneous 
contours. See the process for Place Features in this chapter for a suggestion on how to combat 
this situation and further enhance the surface.
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Place Feature

The Place Feature command is used to create individual 3D features in a DTM. This is 
useful in various situations, such as adding a utility to a DTM, controlling triangulation in a 
specific area, or just adding a breakline for a portion of the design. 

In this example, a breakline is added to enhance the triangulation of a sloped bottom pond. 
Notice how the contours do not follow the shape of the pond bottom in the corners.
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Displaying the triangles shows why; in the corners the triangles have all three points touching 
the edge of the pond bottom, with nothing projecting to the drain line in the middle of the pond. 
Breaklines can help resolve this issue, resulting in a better surface model.

1. Select Surface > Design Surface > Place Feature.

2. Specify the Surface to add the feature to in the drop-down list.

Note: If it is a brand new surface, the name can be typed in here and the surface is created 
when the command is applied.

Note: The Feature area of the dialog is automatically populated with information from 
the first feature in the active surface. This is the area where the new feature 
information is entered.

3. Either key in a Name or choose one from the drop-down. 

Note: See the Duplicate Name information below regarding what happens if an existing 
feature name is chosen.
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4. Enter a Description (optional).

5. Choose a Feature Style from the drop-down list that matches the feature being created. 
These styles are stored in CDOT’s XIN file.

Hint: If there is already a feature using the desired style, save time by selecting it as the 
Name to populate the Feature Style field, then type over the name with your new one.

6. Set the Point Type to Breakline.

♦ In general, this command is used to create breakline features, although you can also 
create Random, Contour, Interior or Exterior features.

♦ Random features do not show up on cross sections or profiles. 

Note: The Duplicate Names area is only applicable if you have chosen a name that 
already exists in the surface.

○ Append: The feature added is appended to the end of the named feature. As points 
are added, there is rubberbanding in the graphics file to show which end of the 
feature is being appended. If it is not the desired end, use Surface > Edit 
Surface > Reverse Feature Direction to first change the orientation of the 
original feature.

○ Replace: The old feature is removed and the new one added in its place.

○ Rename: A numeric suffix is added onto the name and used for the new feature.

7. Toggle off Exclude from Triangulation.

Note: Toggle this option on if the feature is a utility, right-of-way, or some other 
breakline that you want to show on profiles and cross sections but do not want to 
affect the triangulation.

8. Toggle off Triangulate Surface.

Note: Toggle this option on if it’s desired to see results of re-triangulation after each 
feature is added.

9. Toggle off all options under Dynamic Settings and Intervals.

Note: These options are intervals, not actual values. For example, if you set the Distance 
interval to 100, the vertices of the feature being placed are locked into multiples 
of 100 master units apart. This is useful if the breakline represents pipe that must 
be placed in fixed lengths, for example.

10.  <D> Apply to open the Set Elevation dialog box and begin the process of entering the 
feature.
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The Set Elevation Box

A second dialog appears when the command is applied. This dialog allows the elevation of the 
cursor to be overridden for each vertex. 

1. Toggle off both Specify Elevation and Elevation from Surface.

♦ If you toggle on Specify Elevation the elevation of each vertex can be entered.

♦ If you toggle on Elevation from Surface each vertex pulls its elevation from the listed 
surface. This surface does not have to be the same as the to which the feature is being 
added. An Elevation Adjustment is also allowed for adding the feature a specified 
distance above or below the listed surface. This is useful for specifying coverage for a 
utility.

♦ If you leave both toggles off the elevations are taken from the cursor location 
(element’s elevation if you snap to something or active depth if you do not).

2. Snap to the drain line end, then the pond bottom, to pick up the elevations and place the 
feature.

Note: Additional features can be added as necessary. 
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3. Triangulate the surface (Surface > Triangulate Surface) when done, and view the contours 
to see any improvement.

       

This process is iterative and a choice must be made as to the value of continual refinement to 
the DTM, the goal being not to pass the point of diminishing returns.
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Generate Transverse Feature

The Generate Transverse Feature command creates a new feature that consists of lines at 
a specified interval connecting two known features. The lines are perpendicular to, and the 
interval is specified along, a reference feature. You can also work in Graphics Only mode and 
identify MicroStation elements as either of the known or the reference lines.

Transverse features are useful when triangulation is not forming the slopes between the two 
known features as you need. For example, if one feature has less points that the other, there 
may be large, irregular triangles formed, or if one or both of the known features have concave 
areas where triangles are cutting across and touching only one of the features.

In the diagram below, notice the sideslopes in the fill area are created with triangles that are not 
perpendicular to the centerline. This could happen in cases where you create the sideslope after 
the backbone model is formed or when you’re using Surface Edit tools to create a new model.

1. Choose Surface > Design Surface > Generate Transverse Feature.
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2. Specify the Surface to add the feature to in the drop-down list.

Note: If it is a brand new surface, the name can be typed in here and the surface is created 
when the command is applied.

3. For Exterior Arc, key in 5^.

Note: The Exterior Arc is used when the reference feature has exterior corners between 
the two known features. In this case, it is set to 5^. When the transverse feature is 
created to the outside of a corner, the resulting feature lines will fan out from the 
corner in 5^ increments, giving the effect of a fillet. The smaller the setting, the 
smoother the fillet.

Reference Feature

This category is for specifying at how many locations that transverse lines will be created in the 
resulting feature. Either Interval, Stroke Tolerance or both must be toggled on.

4. Set the interval to 25. In general, this setting should reflect a similar interval to the 
surrounding features. 

Note: Interval is a master-unit setting that determines how often along the reference 
feature or element a new transverse line is created.

5. Toggle on Stroke Tolerance and set to 0.01.

Note: Stroke Tolerance has two functions:

♦ First, if the reference element is a curve or arc, this setting is used to stroke the curve or 
arc into a series of vertices. See the InRoads Online Help for more information.

♦ Second, it ensures the creation of a vertex at each occurrence of a vertex in the 
reference feature or element.

6. Toggle Generate Graphics Only off. If on, several of the feature settings do not apply since 
only graphics result from the command. 

7. Key in a new Name for the transverse feature you’re creating.

8. Choose a Feature Style that matches the feature being created. These styles are stored in 
CDOT’s XIN file. 

Hint: If there is already a feature using the desired style, select it as the Name to populate 
the Feature Style field, and then type over the name with your new name.

9. Set the Point Type to Breakline.

♦ In general, this command is used to create breakline features, although you can also 
create Random, Contour, Interior or Exterior features.

♦ Random feature do not show up on cross sections or profiles. Use breaklines for that 
purpose, even though they do not have to be triangulated.

For details on other options, see the InRoads Online Help.
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10. <D> Apply and follow the prompts and <D> to identify the Primary, Secondary and 
Reference lines. 

Note: These can be either graphics or features as specified by the Locate Graphics / 
Locate Features lock. Here, the POSS is the Primary Feature (where the 
transverse lines are coming from), the Fill slope is the Secondary Feature (where 
the transverse lines are going) and the POSS is the Reference (what the transverse 
lines are perpendicular to, and where the interval is measured).

      

Notice in this case, you may need to add additional features to “catch” each of the vertices 
in the new toe of slope.
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Fillet Features

The Fillet Features command is used to create a 3D fillet between two existing elements or 
features. The result can be either a new feature or a graphic element, depending upon the 
Generate Graphics Only toggle. While it can be used anytime a fillet is needed, one of the 
most common uses is to create a return for a driveway. Intersection returns are typically 
handled with templates. See the Roadway Modeling chapter for additional details.

Note: This command produces a 3D linestring or feature, not a true arc.

Note: The Multi-Center Curve command can also be used in this situation, creating a 
horizontal and vertical alignment for the 3D return, followed by running a template for 
the return.

To create a driveway fillet:

1. Select Surface > Design Surface > Fillet Features.

2. Select the Destination Surface where you want the fillet placed. In this case, it’s the 
proposed model.

3. Set the Radius desired for the fillet.

4. For Interval key in 5. 

5. Toggle off Stroke Tolerance.

Note: The Interval and Stroke Tolerance determine the density of the vertices in the 
resulting feature. 

6. Specify the Name of the feature. 

Hint: If you choose a name that exists already, it will populate the Feature Style and the 
Point Type so you don’t have to. You can then type over the existing name with a new one.

7. Select Reference Features 1 from the drop-down list or use the target locator button to 
graphically select the feature.
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8. Repeat for Reference Feature 2.

Note: Reference Feature 1 and 2 are the features from which you are creating the fillet. 
The order in which you select the features determines the direction of the resulting 
fillet feature (direction is from 1 to 2).

For details on the other options, see the InRoads Online Help.

9. <D> Apply and when prompted, identify the quadrant where you want the fillet.

10. Accept with a <D>.
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Generate Sloped Surface

The Generate Sloped Surface (GSS) command can be used anywhere you need to 
generate a slope extending from a known feature or graphic element to a surface. In this case, it 
is used to create a sideslope for a pond.

1. Select Surface > Design Surface > Generate Sloped Surface.

Note: The Current Locate Mode is determined by the Locate Features / Locate Graphics 
lock.

2. Set the Source Surface to the surface where the origin of the slope is located.

3. Set the Intercept Surface to the surface that you are intercepting with the slope. 

Note: You can also tie into an elevation, such as when you want to bench the slope at an 
elevation.

4. Set the Destination Surface to the surface where the slopes are placed. The surface can 
exist already, or you can type in the name of a new one and it is created when you Apply.

5. Key in the values for the Cut and Fill Slopes.

Note: For the Cut and Fill Slopes, there is a percentage and a To: option. Use this when 
you want to transition between two sideslopes.
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6. Toggle off Apply to Both Sides.

Note: Use Apply to Both Sides when you want slopes extending from both sides of the 
feature or element, such as when you are creating a ditch.

For details on the other options, see the InRoads Online Help.

7. <D> Apply and when prompted, identify the feature you’re sloping from.

8. When prompted, <D> to identify the beginning point of the sideslope, then <D> again for 
the ending point. Optionally, you <R> to use the entire feature, as shown here.

9. <D> to accept the sideslope on the side of the original feature where you want the 
sideslopes to be formed.
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Apply Template

Apply Template basically allows you to use any MicroStation element or InRoads feature as 
the horizontal and vertical control for creating a DTM from a template, without having to set up 
a corridor using Roadway Designer. This is very useful, for example, when creating: 

 Sideslopes from a pond or pit that are more complex than Generate Sloped Surface is 
capable of producing 

 Walls created without Designer, such as the terraced walls under an interchange bridge

While the same templates can be used for Roadway Designer’s Template Drops and the 
Apply Template command, keep in mind that Apply Template cannot transition between 
different templates or use any of the other advanced modeling options available in Designer 
such as Point Controls and Parametric Constraints. 

In this example, a pond is being modeled from a known bottom (created previously with 
Generate Longitudinal Feature). The sideslope of the pond is set to slope up to a certain 
elevation, berm and then proceed in cut until interception with the existing ground.

Note: Most CDOT end condition templates are created with the Target listed as Active 
Surface. If this is the case for the template being used with Apply Template, be 
certain the correct surface is active before Applying.

1. Select Surface > Design Surface > Apply Template.

2. Toggle off Generate Graphics Only, or the command will not create features.

3. Specify the Design Surface.
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Note: The Design Surface is where the resulting features are placed, not the target 
surface for the template.

4. Toggle off Mirror and Reflect.

Note: The direction of the graphic or feature determines the direction the template is run. 
If necessary, you can reverse the direction (for a graphic, use Change Element 
Direction; for a feature, use Reverse Feature Direction) or you can Reflect 
the template. If you want to run the template down both sides of the graphic or 
feature, select Mirror.

5. Select your template from the library and set the other options as shown.

For details on the other options, see the InRoads Online Help.

6. <D> Apply and identify the graphic or feature the slopes are coming from (in this case, 
the pond bottom).

Note: You are prompted based on your Locate Graphics / Locate Features toggle for 
either a Primary Element or a Primary Feature.

7. <D> on the bottom of the pond to identify it as the Primary.

8. Next, you are prompted for the Reference. <D> on the bottom of the pond as the reference.

Note: The template is applied perpendicular to the Reference, and the interval is applied 
to the Reference. In this case, the bottom of the pond is both the Primary and the 
Reference. An example of when they might not be the same is when you are 
applying the template to an edge of pavement, but you want the results 
perpendicular to the centerline alignment.

9. You are then prompted to identify the beginning (and subsequently the end) of the pond 
bottom or if you Reset <R>, the entire feature is used. In this case, <R> to identify the 
entire pond bottom. Notice also there is tracking so you can see the direction of the feature.

10. <D> to accept the solution and the sideslopes are created.

Note: When the Triangulate Surface option is toggled on, the features created by Apply 
Template are incorporated into the triangulated DTM. 

11. View the triangles or contours to see the results.
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Project Line to Surface

The Project Line to Surface command is useful when you need to know where a certain 
slope intercepts a surface before creating a sideslope. It can also be used for line-of-site studies. 
The input for the command is a MicroStation graphic to start from and the result of this 
command is a MicroStation line; no features are used or created.

1. Select Surface > Design Surface > Project Line to Surface.

2. Set the Surface to the one you want to intercept.

3. Key in a Slope of the resulting line.

4. Toggle on Dynamics.

5. <D> Apply.

6. When prompted, snap to the element you’re sloping from.

Note: In the direction defined by the location of the cursor, a line extends until it 
intercepts the given surface. A <D> creates the line as an element. If you want to 
come from the same point in a different direction, you can continue to move your 
cursor and <D> wherever necessary.

In this case, multiple points are checked along the element to see where the slope 
intercepts. The endpoints of these lines could be joined with a linestring and loaded as a 
feature for the toe of slope, or you can now use Generate Sloped Surface to create the 
features after identifying the desired slope with the Project Line to Surface command.
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Section Summary:

 Design surfaces do not have to be created from Roadway Designer alone.

 Commands that create features allow you to enhance a surface created with other tools or 
create a new surface from scratch.

 Templates can be used with surface manipulation commands without using Roadway 
Designer or setting up corridors.

 Features resulting from these commands can be used in combination with Roadway 
Designer, such as for Point Controls or horizontal and verticals control for a corridor.
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Modifying Features

There are many options within InRoads that assist in manipulating design models by changing current features. 
These tools are used when creating surfaces from scratch, such as ponds or parking lots, or when modifying 
previously created models such as roadways developed with Roadway Designer.

Section Objectives:

 To be able to modify horizontal and vertical locations of existing features.

 To develop an understanding of when each of the feature editing commands should be 
used.

 To learn techniques that refine existing surface models by modifying features.

Accessing Edit Surface Commands

While there are many commands in InRoads that modify features, several of them are grouped 
under Edit Surface. You can access them from the Surface > Edit Surface pull-down 
menu, or from the Edit Surface toolbar. Most are described in the following section.
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Generate Longitudinal Feature

Generate Longitudinal Feature (GLF) is used to create and/or modify 3D MicroStation 
elements or features in a DTM. It is an extremely powerful tool that allows much easier 
manipulation in 3D than MicroStation alone.

When using this command to modify existing features, several of the options are not available, 
as they are already set for the feature (such as Name, Style, etc).

For information on using GLF, see the Generate Longitudinal Feature topic in the 
Creating Features section of this chapter.
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Set Slope Along Feature

The Set Slope Along Feature command is used when you need to modify elevations of 
points in a feature by defining a slope along the feature, but you do not want to modify the XY 
location of any of the points. For example, use this command when you need to ensure a drain 
line slopes to a low point on the feature.

In this example, a low point is needed in the middle of a return.

1. Select Surface > Set Slope Along Feature.

2. Set the Surface to the surface containing the feature you are changing.

3. Select the Feature from the drop-down list, or use the Locate button to select the feature 
graphically.

For this example:

4. Set the Back and Ahead Points to the points you want to hold constant.

5. Set the Target to the point you want to assign a new elevation.

6. In the Target section, toggle on Lock for the Point and Elevation and key in the elevation.

Note: When setting the target, you have the option of locking two of several inputs to 
create the desired results. In this case, we want the Target Point locked (so a new 
point is not created), and we want the Elevation locked for that point. All points 
between the Back and Ahead are adjusted in elevation to accommodate the 
modified point.
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7. <D> Apply to modify the feature.

For details on using the other Target options, see the InRoads Online Help.
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Drape Surface

Drape Surface is used when you want to force a graphic element or a feature (based on the 
Locate Graphic / Locate Feature toggle) to take on the elevations of an existing DTM. This 
command increases the number of vertices, since not only are the original vertices assigned the 
elevations of the surface, but a vertex is added everywhere a triangle is crossed. The exception 
is when Drape Vertices Only is on, in which case only the original vertices are assigned new 
elevations.

The Destination Surface determines the elevations and is where the new feature is created if 
the Destination and Features Surfaces are not the same. (If they are the same, the feature is 
modified.)

In the following example, the outer perimeter of a pond is known, so to begin modeling the 
pond, this perimeter must first be draped onto the existing surface. If the perimeter was draped 
as a feature, it would then reside in the existing surface model. Since the pond is modeled in a 
separate surface, it is draped as a graphic, then imported.

1. Set the Locate Graphics / Locate Features toggle to Locate Graphics.

2. Draw the perimeter of the pond with MicroStation if it doesn’t already exist.

3. Select Surface > Design Surface > Drape Surface.

4. Set the Input Mode to Single.

Note: You can use a Level or Fence from the drop-down. You can also use a 
MicroStation selection set by having it active first, then choosing Single.
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5. Toggle off Destination Level and Delete Original Graphic.

Note: If Destination Level is toggled on, the new draped graphic is created on that level. 
If not, it is created on the level of the original graphic, which may or may not be 
deleted based on the Delete Original Graphics toggle.

6. For Scale key in 1.

Note: The Scale is used to exaggerate the display of the results. It does not affect the 
actual elevations if creating a feature.

7. For Elevation Adjustment key in 0.

Note: Elevation Adjustment is used when you want to add or subtract a set amount from 
the elevation of each vertex. For example, you can use this to drape an 
underground utility to 6’ below the existing ground.

8. <D> Apply and <D> on the graphic to drape.

9. <D> to accept the results and the new graphic is created.

Important! If you want to drape a feature onto one surface but have it placed in another, 
you can use the Drape Vertical option in Generate Longitudinal Feature 
or Import Surface from Graphics with the Drape option.

The draped graphic may now be imported or used with either Generate Sloped Surface or 
Apply Template.
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Edit Feature Point

Edit Feature Point is useful when you need to edit or delete one vertex of a feature at a time. 
For example, if you have a spike in a surface caused by a zero-elevation point that was 
accidentally included in a breakline, use this command to delete it.

1. Select Surface > Edit Surface > Edit Feature Point.

2. Set the Surface to the surface that contains the feature you want to edit 

3. Select the Feature that you want to edit. 

4. Select the feature Point that you want to edit.

Note: You can step through the points, or you can use the Locate button to choose the 
point graphically. When the point is active, there is a target symbol identifying it in 
the MicroStation view. If the Center View option is toggled on, MicroStation will 
center the current view on the selected point.

5. Change the Northing, Easting and/or the Elevation by keying in new values or by using 
the appropriate Locate button and setting the values graphically.

6. Select the More >> button to access additional options for setting the location of the active 
point. These options are similar to those found on the Set Slope Along Feature 
command.

Note: You can edit more than one point in a feature before you choose Apply, but changes are 
not made in the surface or reflected graphically until you do.

7. <D> Apply to edit the point(s).

For details on the other options, see the InRoads Online Help.
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Delete Feature Point

The Delete Feature Point is useful when you want to delete Random points in a DTM that 
are outside of an elevation range. For example, if you have several points with a zero elevation, 
you can use this command to get rid of them all at once without having to find and delete them 
individually.

Note: The features containing the points that are out of the Range to Keep specified must be 
highlighted before choosing Apply. Only Random point features are shown in the 
dialog, and you can use Feature Filters to further limit the features shown.

Reverse Feature Direction

The Reverse Feature Direction command is very much like the Change Element 
Direction command in MicroStation. It is useful when you have a feature running in one 
direction and you would like it to run in the other. For example, if you are using the feature for 
the horizontal and vertical control in a corridor (in place of a horizontal and vertical alignment) 
and the feature was built in the opposite direction you want your model created.

1. Select Surface > Edit Surface > Reverse Feature Direction.

2. When prompted, <D> to identify the feature. 

3. Once highlighted, the name of the feature is shown in the message field and you can Accept 
<D> or Reject <R> the feature. Reject it and the next closest feature is highlighted for you 
to Accept or Reject.

Note: There is no dialog box for this command, so be sure to read the prompts.
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Delete Feature

The Delete Feature command allows you to remove one or more features from a surface. In 
the dialog box, the list of features is controlled by the Feature Filter lock, so you can segregate 
out just the features you want to see, if necessary.

1. Choose Surface > Edit Surface > Delete Feature.

Note: If there is a fence active, you can choose from Ignore, Inside or Outside options. 
These modes act like the Clip option in MicroStation. If a feature extends out both 
sides of the fence, using the Inside option results in a feature with a gap.

2. In the feature list, <D> to highlight the feature or features you want to delete. <R> on the 
list for a menu that allows you to Select All, Select None or Invert Selection. 

o

Note: Select All can be accessed with <CTRL> A and Select None with <CTRL> N 
without right-clicking.

3. <D> Apply and the feature or features selected are deleted from the surface.

4. Select Results to see how many feature points were removed with the action. (Results will 
only show points deleted from Random, Breakline and Interior Features, even though other 
types may be deleted.)

Note: If you want to delete all the features in a surface, <R> on the surface in the Explorer 
portion of the InRoads menu and select Empty. 
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Partial Delete

The Partial Delete command works much like the MicroStation Partial Delete, except it 
works with features. The MicroStation display of the feature is also updated if it was originally 
displayed in Pencil Mode.

1. Select Surface > Edit Surface > Partial Delete.

2. When prompted, <D> on the feature to identify it.

3. <D> to Accept the feature or <R> to Reject the feature when it highlights and its name 
appears in the prompt field.

4. <D> on a Starting point for the delete.

5. <D> on an Ending point for the delete.

The results are one feature with a gap where you partially deleted it. To make two features out 
of the gapped feature, see the following Break Feature command.

Note: There is no dialog box for this command, so be sure to read the prompts.

Important! When you Partial Delete a feature, a point is added at each end of the delete. 
If you want to only retain original points in the feature, turn the Snap lock to 
Point Snap and the starting and ending points of the deletion are forced to fall 
on existing vertices.

Break Feature

Break Feature quite simply make two features out of one. The second feature has the same 
name as the first with a counter appended on the end. This command does not leave a gap, but 
rather leaves the two features with a common point where they meet. If the feature already has 
a gap, you can break the feature at either end of the gap to get two features.

1. Select Surface > Edit Surface > Break Feature.

2. <D> the feature you want to break.

3. Accept <D> if the correct feature name is shown, Reject <R> if not.

4. Once the feature is accepted, a tracking line is displayed from the feature to your cursor. 
Locate the point where you want to break the feature and <D>.

Note: There is no dialog box for this command, so be sure to read the prompts.

Important! When you break a feature, a point may be added to each feature at the break 
point. If you want to only retain original points in the feature, turn the Snap 
lock to Point Snap and the break point is forced to fall on an existing vertex.
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Join Features

The Join Features command is very similar to the MicroStation Create Complex Chain 
command. It allows you to select two or more features to combine into one. Where it differs 
from the MicroStation command is in how the features are accepted. In MicroStation, you can 
select that next line with the accept of the current one. In joining features, you much select and 
accept each feature before moving on to the next one.

Use the Join Feature command when you want to combine more than one feature to use as 
the basis of a Roadway Designer Corridor, the Apply Template command, or as a target for 
an end condition, for example.

1. Select Surface > Edit Surface > Join Features.

2. <D> on the first feature, and <D> again to accept if it is the one that highlights and whose 
name is listed in the prompt field.

Note: The first feature selected determines the name of the resulting combined feature.

3. <D> on the second feature and <D> again to accept.

The second feature is deleted as it becomes part of the original feature.

4. Continue to identify features and accept them until you have all the features you want 
combined.

Important! When the feature do not touch, they are joined with a straight line closure. If 
the features overlap, they will still overlap after combining (i.e. they are not 
trimmed automatically). Since overlaps may cause DTM tolerance problems 
when triangulating, you can Trim or Partial Delete the features prior to 
joining. For more information about these commands, see their sections in this 
chapter.
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Trim Features

The Trim Features command is similar to the Trim command in MicroStation. It allows you to 
trim a single feature or groups of features based on a cutting feature or cutting element. You can 
use Trim Features after combining features from different models where there is overlap, for 
example.

1. Select Surface > Edit Surface > Trim Features.

Note: Notice the current Locate Mode, which is controlled by the Locate Graphics / Locate 
Features lock. This determines whether you can identify a graphic element or a feature 
as the cutting element.

2. Select the Surface where the features reside. 

Note: If you are clipping with a feature, it must reside in the same surface. If it does not, 
you can display it graphically, then use the Locate Graphics toggle.

3. In the feature list, highlight one or more features using the <Shift> or <Ctrl> keys 
when necessary. <R> on the list for a menu that allows you to Select All, Select None or 
Invert the current selection. (You can use Feature Filters to narrow the list of features.)

Note: Select All can be accessed with <CTRL> A and Select None with <CTRL> N 
without right-clicking.

4. In the Elevation section:

♦ Select Do Not Change when you want all features to retain their original elevations. 

♦ Select Match at Intersection when you want the feature being clipped to adjust their 
elevations at the clip point to match that of the clipping feature or element.
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5. Select one of the Mode options. The Mode refers to how many trims you want to make on 
each feature. 

♦ One Section is typical, when you want to trim the end of a feature back to another. 

 

♦ Use To One Side when you want to only keep the portion of a feature that is on one 
side of another. For example, if you have a wetland feature and a ROW feature that 
overlap back and forth, and you’re only concerned with the wetland if it’s inside of 
your ROW. Highlight the wetland feature in your feature list, then identify the ROW as 
the clipping feature. With the mode set to To One Side, you’ll be able to keep all parts 
of the wetland that are on one side of the ROW.
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6. <D> Apply and select the clipping graphic or feature.

7. <D> to Accept the clipping graphic or feature.

8. <D> on the side you want to delete.

Extend Features

The Extend Features command is similar to the Extend Line command in MicroStation. It 
allows you to extend a single feature or groups of features until interception with another 
feature or graphic element. 

1. Select Surface > Edit Surface > Extend Features.

2. Select the Surface where the feature(s) you are extending reside. If you are extending to a 
feature, it must reside in the same surface. If it does not, you can display it graphically, then 
use the Locate Graphics toggle.

3. In the feature list, highlight one or more features using the <Shift> or <Ctrl> keys 
when necessary. <R> on the list for a menu that allows you to Select All, Select None or 
Invert the current selection. (You can use Feature Filters to narrow the list of features.)

Note: Select All can be accessed with <CTRL> A and Select None with <CTRL> N 
without right-clicking.

4. In the Elevation Section

♦ Select Do Not Change when you want the features to extend at the same slope as the 
last segment of the feature. 

♦ Select Match at Intersection when you want the feature being extended to match the 
elevation of the feature or element to which it’s being extended.

5. <D> Apply and select the graphic or feature to which you’re extending.

Note: The Locate Graphics / Locate Features lock determines whether you can identify a 
graphic or a feature.
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6. <D> to Accept the graphic or feature.

Intersect Features

The Intersect Features command is similar to the Extend Elements to Intersection 
command in MicroStation. It allows you to extend two features until they intercept, and 
optionally change the elevation of the second to match that of the first at the intersection point.

.

1. Select Surface > Edit Surface > Intersect Features.

2. Select the Surfaces and Features you are intersecting. If you are not matching elevations, 
the order does not matter.

3. <D> Apply.

4. You are prompted to accept the intersection to keep. If there is more than one intersection, 
you can move your cursor to see additional intersections and <D> to keep the one you 
want.
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Delete Triangle

The Delete Triangle command allows you to delete one or more triangles from a surface. It is 
useful when the triangulation routine creates triangles that you do not wish to keep. Sometimes, 
this is most obvious when creating contours which are derived from the triangles.

1. Select Surface > Edit Surface > Delete Triangle.

2. Select the Surface where the triangles exist.

3. <D> Apply.

If you are deleting one triangle:

4. <D> on the same triangle twice, and <D> to Accept.

If you are deleting a series of adjacent triangles:
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5. <D> on a starting point and move the cursor, drawing a line across the triangles you want 
to delete.

6. <D> to end the selection.

7. <D> again to accept the highlighted triangles as the ones to delete.

Note: The triangles do not have to be displayed. When you select them, they highlight. If you 
drag the cursor across a series of triangles, they are temporarily displayed; only the 
highlighted ones when you accept are actually deleted.

Important! If you delete triangles and the surface is re-triangulated, the triangles are re-
created. To make certain the deletions are permanent, you can either add an 
exterior if the triangles are on the edge of the model as shown in this example, 
or add an interior if they are on the inside.
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Copy Portion of Surface

The Copy Portion of Surface command is for copying features from one surface into 
another. You can combine two surfaces by copying all features, or you can selectively choose 
features to copy.

When copying an exterior from one surface to another, keep in mind there can only be one 
exterior in a surface and the last exterior added will be the exterior used in the surface.

1. Select Surface > Edit Surface > Copy Portion of Surface.

2. Specify the Source Surface where the feature currently resides.

3. Specify the Destination Surface where the features are going. If the surface does not exist, 
you can key in the name and it will be created when the command is applied.

4. In the feature list, highlight one or more features to copy using the <Shift> or <Ctrl> 
keys when necessary. <R> on the list for a menu that allows you to Select All, Select None 
or Invert the current selection. (You can use Feature Filters to narrow the list of features.)

Note: Select All can be accessed with <CTRL> A and Select None with <CTRL> N 
without right-clicking.

5. <D> Apply to copy the features.

For details on other options, see the InRoads Online Help.
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Merge Surfaces

The Merge Surfaces command combines two surfaces. It is most useful for creating an ‘as-
designed’ model, since it removes the portion of an Original surface that overlaps a Design 
surface. After using this command, you can create contours for the combined model showing 
what the surface should look like after the design is built.

1. Select Surface > Edit Surface > Merge Surfaces.

2. Specify the Original and Design surfaces.

3. Specify the Destination Surface where the combined model is created. 

Note: If the surface does not exist, you can key in the name and it will be created when 
the command is applied. While you can replace the existing surface with the 
combined, it is not recommended.

4. <D> Apply and the surfaces are combined and the resulting merged surface is triangulated 
as shown in these before and after cross sections.

For details on other options, see the InRoads Online Help.
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Note: Multiple merges typically begin to bog down the surface. This is not a good option for 
combining several surfaces, such as for the different models that may be created in 
designing an interchange. Use either Copy Portion of Surface or run multiple 
corridors at once with Roadway Designer.

Resolve Crossing Segments

The Resolve Crossing Segments command assists in correcting crossing linear features in 
a surface. When two linear features cross at the same elevation, a point is assumed at the 
crossing and the surface triangulates as normal. When the features cross but at different 
elevations, the software cannot triangulate the area since triangles cannot cross linear features. 
This command resolves those situations.

1. Select Surface > Utilities > Resolve Crossing Segments.

2. Key in the Delta Tolerance. This is the maximum difference in elevation you allow this 
command to correct. Anything larger and the crossing will be reported as unresolved.

3. If you have several crossings and there is a dominant feature or features, you can create a 
Feature Filter, toggle on Use Dominant Feature and select it from the list. 

For example, if you have several drives that cross edges of pavement, you can set up a filter 
to filter everything but the edge of pavement features. In that case, anywhere there is a 
crossing within the specified vertical tolerance, the crossing is resolved by adding a point at 
the elevation of the edge of pavement.

4. Select one of the Match Elevation options.

Note: If the crossing does not involve an edge of pavement, or if it involves two edges of 
pavement, the Match Elevation toggle controls, forcing the new point to take on 
the elevation of the High feature, Low feature, or the Median elevation between.

5. <D> Apply and the crossing segments that meet the Delta Tolerance criteria are resolved. 
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6. Select Results to see a report of which feature crossings were resolved and which were left 
unresolved.

For details on other options, see the InRoads Online Help.

Note: If the crossing features are in an existing ground surface, you should report the problem 
to the Survey group for correction.

Generate Grade Contour

The Generate Grade Contour command is a great tool for finding a path down a sideslope 
that meets a certain longitudinal grade. For example, if you need to create a haul road into a pit 
or an access road down a sideslope and you are required to meet a certain longitudinal grade, 
this command helps designate the path.

Here, it is used to traverse the sideslope of a pond, helping define the path of an access road.

1. Generate Grade Contour is an Application Add-in, so toggle it on before starting.

2. Select Surface > Utilities > Generate Grade Contour.

3. Select the Surface from the drop-down.

4. Key in the longitudinal Slope desired.

5. Key in the Maximum Distance for the path created.

6. Key in (or use the Locate button to define) the starting Direction. 

Note: The direction does not actually define a fixed direction for the resulting path. It just 
lets the command know the general direction you want the path to take (i.e. to the 
right or left around the pond in this example).

7. Toggle on Dynamics to see the path before accepting it.

8. <D> Apply.

9. Move your cursor along the slope and a path dynamically follows. 
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10. <D> where you want the path to start.

The result is a 3D MicroStation linestring that follows the defined longitudinal slope, traversing 
the surface selected. Vertices are created for the linestring at each crossing of a triangle. You 
can now import the graphic as a horizontal and vertical alignment using File > Import > 
Geometry from Graphics, refine the alignments as necessary, and use them in Roadway 
Designer to create the access road.

Compress Surface

When working with features in a surface, you are often deleting portions of features or deleting 
points in features. These points are marked for deletion in the surface and are no longer 
triangulated, but are not actually removed from the surface. Since they cannot be recovered, 
they are taking up space and memory unnecessarily and should be periodically removed from 
the surface using Compress Surface. This command not only removes points that have been 
deleted with surface editing commands, but also removes any duplicate Random points, or 
Random points that are duplicates of other type points.

1. Select Surface > Utilities > Compress Surface.

2. Select the Surface you want to compress from the drop-down menu.

3. <D> Apply and the points are removed.

Section Summary:

 Features can be manipulated within a surface using tools similar to MicroStation editing 
tools.

 Point elevations, slopes of features and location of features or individual points can all be 
modified.
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 There are tools available for modifying features one at a time, and also for modifying 
groups of features.

Chapter Summary:

 Create and Edit feature tools allow you to design surfaces that do not fit the mold of a 
typical section following a horizontal and vertical alignment.

 Using these tools with surfaces created by Roadway Designer allow you to refine and 
enhance your designs that do fall into the category of templates following a horizontal and 
vertical alignment.

 Using each InRoads Surface Creation or Surface Editing tool for what it does best allows 
you to be more efficient in your design process.

 The Surface Creation and Editing tools can be an integral part of the CDOT design process 
when used to their full potential.
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