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Chapter 5 - CDOT MicroStation Workflow

Now that you are comfortable working in a MicroStation design file, you are ready to learn how CDOT 
specifically uses MicroStation in the project process. This section concentrates on how CDOT creates model 
file graphics by utilizing the CDOT Menu. It also covers the sheet file creation process. Once your sheets are 
created, you will learn how to annotate, dimension and plot the sheets.

Chapter Objectives:

• Describe the differences between “Sheet” files and “Model” files.

• Discuss the workflow for adding data to model files based on the specialty group

• Discuss the workflow for adding data to sheet files based on the specialty group

• Discuss the benefits of using single source data for project design

• Describe using the Create Project Utility program

• Describe the use of the PCF file

• Discuss the CDOT Project Directory Structure

• Describe how to create new model files

• Discuss working with reference files and raster images

Creating a CDOT Project

This chapter is a general overview of the entire CDOT workflow to complete a CADD project 
using MicroStation. You will learn how to set up a CDOT project and create your design model 
file and reference other discipline’s files.
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CADD Workflows 

Model files vs. Sheet files

To understand how CDOT uses MicroStation for design and drafting, you first need to 
understand the difference between Model files and Sheet files. Model files contain the design 
graphics. These are the working files for your design. Each group has at least one Model file, 
but can have multiple model files for different types of graphics. For example, the Roadway 
Design group can have a model file for plan graphics and another model file for profile 
graphics. The Traffic group may have separate model files for signs, signals and lighting.

Sheet files are the files that will be plotted for the creation of a plan set. Sheet files reference 
model file graphics. A reference is just a MicroStation file attached to your active file (the file 
you have opened). You can reference multiple model files to create a sheet file. For example, a 
Bridge general layout sheet may reference the existing survey/topo model, the proposed 
roadway design model and the proposed bridge model to show all of the needed information on 
the sheet. A Plan Profile sheet (shown below) references the proposed roadway design model 
and the profile model. 

Sheet files typically do not contain design graphics since they are referenced in from the model 
files. You can’t modify the model file reference graphics in a sheet file; they are there for 
information only. The sheet files, however, do contain the border and associated information 
(bar scale, north arrow, etc.) along with text and dimensions, which can be modified since these 
elements are placed directly in the sheet.
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For more information on References, see the section Referencing Other’s Work in this chapter.

Model File Workflow for Survey/ROW 

To create existing model files, the Survey/ROW group uses MicroStation and InRoads Survey 
to reduce the electronic fieldbook data and create model files for ROW, survey planimetrics 
and existing topographics. These existing model files can then be referenced by Design and 
specialty groups as a base for creating the proposed model files.
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Model File Workflow for Roadway Design 

To create proposed design model files, the Roadway Design group references the existing 
survey/topo and ROW models to begin the design. MicroStation and InRoads are then used to 
create the proposed graphics in various model files – plan, profile, intersection, etc.  
Occasionally, other specialty group model files are needed by Design, so these model files may 
be attached as reference files.



Colorado Department of Transportation   Page 63

A Practical Guide for Using MicroStation V8iSS2 Chapter 5 - CDOT MicroStation Workflow

Model File Workflow for Specialty Groups

Each specialty group references the Roadway Design group’s proposed model file to begin 
their design. MicroStation and other specialty programs are used to create the graphics in 
separate model file(s) for each group. When a specialty group references Design’s model file, 
they can choose to reference the existing model file(s) from the Survey/ROW group as well.  
This way, both existing and proposed graphics can be displayed in the specialty group’s model 
file, if needed.
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Sheet File Workflow for Roadway Design

To create sheets (specifically plan or plan/profile sheets in this example), the Design group 
creates a new MicroStation design file for each sheet. Then, the proposed model file is 
referenced into the sheet file. Since the proposed model also has the existing model file 
referenced, the survey graphics can be displayed in the sheet. The sheet file view is rotated, if 
needed, so graphics appear horizontal. Then, only the portion of graphics needed for the sheet 
is “clipped” out from the reference. The border, north arrow, bar scale and Resident Engineer 
information is then placed directly in the sheet file via the CDOT Menu. Many generic sheet 
files also contain a border, which can be edited. The sheet can be annotated with MicroStation 
text and the reference graphics dimensioned, if required. Unlike reference graphics, text and 
dimensions are placed directly in the sheet file and, therefore, can be edited in the sheet.

Other sheets such as detail, title, general notes, etc. have specific requirements, but use the 
same general premise of referencing the model file(s) to the sheet file. Typical Section sheets 
are an exception to the rule, since graphics are created directly in the sheet file using the CDOT 
Typical Section Program. 
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Sheet File Workflow for Specialty Groups

Specialty groups create a separate MicroStation design file for each sheet, and then reference 
their own model file(s) into the sheet file. Since this model file can also have Roadway Design 
and ROW/Survey’s model files referenced, these graphics can be displayed in the sheet. The 
sheet file view is rotated, if needed, so graphics appear horizontal. Then, only the portion of 
graphics needed for the sheet is “clipped” out from the reference. The border, north arrow, bar 
scale and Resident Engineer information is then placed directly in the sheet file via the CDOT 
Menu. Many generic sheet files also contain a border, which can be edited. The sheet can be 
annotated with MicroStation text and the reference graphics dimensioned, if required. Unlike 
reference graphics, text and dimensions are placed directly in the sheet file and, therefore, can 
be edited in the sheet.

Other sheets such as detail, tab, and note sheets have specific requirements.
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Single Source Project Data

There are two methods of setting up a project that can be used to effectively manage a single 
source of project data:

♦ Create the project in ProjectWise (Preferred Method)

♦ Create the project on the Project Managers computer

Project set-up on ProjectWise

ProjectWise is a document management system primarily for use with the MicroStation and 
InRoads software. Other software such as the Microsoft Office Suite can also be integrated into 
the ProjectWise environment. ProjectWise provides a secure environment where project 
information can be stored. ProjectWise allows for file check-in/check-out for editing and read 
only access for checked out files.

For information about using ProjectWise, once the project has been created, refer to:

ProjectWise User Guide.pdf

Project set-up on the Project Managers Computer

If the project is to be stored on the project manager’s computer, use the Create Project Utility to 
create the proper directory structure. for more information on using the Create Project Utility, 
refer to:

CDOT Project Creation and PCF File Management

contact your IT administrator for help in creating a shared drive for a locally stored project. 
Adminstrator privileges are required to setup a shared drive.

For references to work properly, everyone will need to map to the shared drive using the same 
drive letter and path.

The PCF file

The Project Configuration File, created by the utility, defines a specific directory that 
MicroStation defaults to when opening up a DGN file or referencing model files. PCF files are 
extremely useful when multiple users are accessing the same project directory across the 
network, or when DGN files are moved from one directory to another.

http://www.coloradodot.info/business/designsupport/cadd/cadd-workflows/v8-xm/cdot-project-creation-and-pcf-file-management.pdf
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Working in a server environment

If multiple users are accessing the same project directory, the PCF file will need to be 
distributed to everyone on the team accessing the project directory. Each member of the team 
should have their own copy of the PCF file and it should be saved to the same location, 
C:\Program Files\Workspace-CDOT\Standards-Local\Projects. The PCF is also 
useful for managing references. If a reference file is moved, you should never have to reattach 
it. You can use the PCF to manage the reference locations.

When team members are sharing the Project Manager’s machine, the PCF file will need to be 
edited. See the Workflow CDOT PCF Management for more information.

The CDOT Project Directory Structure

The Project Creation utility creates the project directory structure on the server or PM’s 
computer. All CDOT projects should follow this structure to ensure the accurate sharing of 
information between groups within the Department as well as outside consultants. The CDOT 
Project Directory’s top level designates the project code. Below this folder is a set of 
standardized sub-directories for each CDOT specialty group. Under each specialty group folder 
is a sub-directory structure unique to that specialty group.
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For more information about the CDOT project directory structure, see the CDOT CADD 
Manual, Chapter Three – Project Directory Structure, section 3.2 – Directory Structure. 
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Training Project Directory

For this training class, you will create a project directory structure with an example Job Project 
Code (JPC) of 12345 shown below. The Roadway Design group’s sub-folder is shown 
expanded to show an example of a group’s sub-folder structure.

Training files

The training lab files for CDOT CADD courses can be accessed from the Windows Start Menu. 
Select Start > All Programs > _CDOT_CADD_Information > V08.11.XX-XM > 
Training Files > Insert training files on my computer. A link is also available on the 
Training page of the CDOT CADD web site. 

CDOT file naming convention

Model files and Sheet files need standard, informative, and unique names to allow easy 
identification of the specialty group responsible for the file and the type of information 
contained within the file. All CDOT CADD drawings created should follow this naming 
convention so the data can be easily identified and shared by all users. 
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The CDOT file naming convention contains the Job Project Code, a specialty group identifier, 
short standardized file name, an optional annotation scale identifier, an optional description, 
and file extension. 

An example of a MicroStation design file would look like the following:

12345DES_Model100US285.dgn

12345 indicating the CDOT Project Number, DES indicates it is Roadway Design’s model file 
and 100 indicating it uses a 1”=100’ annotation scale, US285 is a description identifying the 
highway this model depicts. .DGN is the default extension for MicroStation design files.

Note: A seventh segment is used on Working Files. This segment should be the initials of the 
designer or engineer who is working on the file. 
Example: JS12345DES_Model100.dgn where JS, are the initials of the designer or 
engineer (in this example, JS stands for “John Smith”). 

For more information about the CDOT project directory structure, see the CDOT CADD 
Manual, Chapter Four – File Naming Convention.

 

Auto-populated files

In addition to creating the project directory structure, the Project Creation Utility also creates 
several auto-populated drawing files that have the CDOT standard file names already assigned 
The # symbol is used for the counter. When creating a new file, one option is to open the 
appropriate auto-populated file in MicroStation, select File > Save As and then rename the 
file.
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The diagrams below shows an example of auto-populated files automatically created for the 
Roadway Design group.

  

What files go where?

As you’ve learned there are two main types of CADD files for a CDOT project: Model files, 
which contain graphics for referencing into sheets, and Sheet files which generally contain 
either references to model files or non-design related items such as general notes, special 
symbols, quantities, sheet borders, etc.
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Working Model files

Working files (or sketch files) are model files containing graphical data created during the 
design workflow.  These files should be placed in the "Working" folder in each group’s 
sub-folder. The file name should include the designer's initials. These files are not to be 
considered final design files, and should not be referenced to sheet files or other 
reference model files. An example of a working file would be: //12345/Design/Working/
JS_12345Des_Model100.dgn

Reference Model files

The most up-to-date model files which are available to other groups for referencing, that 
only have the most current non-sketch or working information in them, should be placed in 
the group’s Drawing > Reference_Files folder. The designer’s or engineer’s initials 
should be removed after moving this file.

Sheet files

Sheet files are typically stored in a group’s Drawings folder, as shown. 
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Plot files

When sheet files are plotted to PDF, the plot files are placed in the project’s Plot_Sets 
folder. Sub folders for AD, FIR, FOR and ROW are available.

For more information, see the CDOT CADD Manual, Chapter Three – Project Directory 
Structure, section 3.2.2 – Group Sub-Directory Structure.
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See also:

○ CDOT CADD Manual, Chapter Four – File Naming Convention, section 4.2 
File Types

○ CDOT Directory Structure Workflow.

The CDOT Workspace

The CDOT Workspace is a custom environment designed to facilitate CADD productivity and 
direct the user to CDOT-specific standards, workflows and processes. The CDOT Workspace is 
a complex set of configuration files, MicroStation and InRoads resource files, workflow 
documents, and many other customized tools, all designed to work together to increase 
productivity and efficiency, and allow for a standardized project plan set output. Some of the 
items in the workspace include:

• Seed files (starter files that contain MicroStation settings for creating new files)

• Cell libraries (standard details, symbols, notes, etc.)

• DGN libraries (standard level structures, text styles and dimension styles)

• Line style resource files (custom line styles)

• Font resource files (special fonts)

• Plot drivers (for plotter configuration and PDFs)

• Pen tables (for special plotting preferences for certain graphics)

• InRoads preference files (for controlling InRoads graphical displays)

• InRoads templates (for standard typical sections)

• CDOT configuration files (to set the correct MicroStation resource files and other standard 
files located on the user's computer)

• Workflow documents (CDOT standardized procedures for specific MicroStation and 
InRoads tasks)

• CDOT Group Menus (access to tools and applications which provides a simple, efficient 
method of applying CDOT’s CADD standards to every project)

The installation of the Workspace will be controlled and maintained by the Information 
Technologies (IT) Department. You can manually update the workspace at any time by 
selecting the Start > All Programs > CDOT_CADD_Information > Update 
MicroStation-InRoads Standards.  
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The CDOT workspace and configuration files are located on each user’s computer in the 
C:\Workspace folder.

The Select Group Environment Utility

The Select Group Environment utility automatically attaches the correct level libraries needed 
for working on a CDOT project. This utility also provides CDOT users additional MicroStation 
resources unique to their group (group-specific cells, seed files, linestyles, levels and 
symbology, etc.) The utility must be run prior to starting MicroStation in order to set up tools 
specific to that user’s group.

There are two group options: Bridge and xxMulti-Discipline. The multi-discipline environment 
enables MicroStation to have all the cell libraries, level libraries and filters, available at 
anytime with out having to load these items individually. The Bridge option loads just the 
specific files needed for the Bridge group.

The Select Group Environment Utility can be run from the user’s computer through the Start 
button Start > All Programs > _CDOT_CADD_Information > Select Group 
Environment. You MUST exit MicroStation prior to running this utility.

For more information on the Select Group Environment, see the CDOT CADD Manual, 
Appendix F - Select Group Environment Utility.

For more informattion on the CDOT Workspace in general, see the CDOT CADD Manual, 
Chapter Two - CDOT Workspace.
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Configuration releases

The IT Department is responsible for updating your computer when the CDOT workspace and 
configuration is updated. For a detailed description on what’s in the new configuration release, 
see the CDOT Configuration ReadMe workflow.
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You can also access this workflow and others (in PDF format) from the CDOT workspace in 
the CDOT Notes sub-folder.

The CDOT Level Structure

Thirteen Specialty Group Design File Level Libraries (DGNLIBs) are available for use within 
CDOT.  The level libraries are attached to the MicroStation design file via the Select Group 
Environment utility and provide the CDOT approved standard discipline levels for use when 
placing graphics. You can not create, edit or delete levels within the CDOT Workspace – you 
must use the levels provided in the DGNLIBs. Likewise, you can not modify the level's 
symbology, thereby maintaining “ByLevel” status for standardization purposes. ByLevel 
symbology is used by default for all level libraries and is the required standard for plan set 
creation.  CDOT has adopted an “existing vs. proposed” leveling scheme, whereas with the use 
of pen tables, all existing design data will plot gray scale.  Level duplication across disciplines 
has been avoided wherever possible.

Level libraries (DBNLIBs) are stored in the CDOT workspace (C:\Workspace\Workspace-
CDOT_XM\Standards-Global\MicroStation\DGNlib).
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For more information about the CDOT level structure and a list of all discipline level libraries, 
see the CADD Manual, Chapter 5 – Drafting Standards, section 5.3 – Design File Level 
Libraries. You can link to a specific group to review its standard level structure.

Level naming convention

The standard CDOT level naming convention shown below is used to allow for easy filtering of 
levels in MicroStation’s Level Display or Level Manager. 
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Levels and configuration releases

When a new configuration is released, it is not unusual for the CDOT Standards and 
Configuration committee to add, change or delete levels from the level libraries.  If you’re 
working on a project, you will need to update the used levels in a design file to the new 
configuration standards. Each new configuration release includes a comma separated variable 
(CSV) file that maps old levels to new levels. You will need to apply this level mapping to all 
existing files that you wish to update to the new configuration. Refer to the CDOT Level Update 
workflow for more information.

Creating a new CDOT Model file

When you’re ready to create a new model file to begin your work, you have two options:

• Create the new file from an auto-populated file

• Create the new file from a seed file

Creating a model file from an auto-populated file

Auto-populated files are created by the Project Creation utility. The model files are created in 
the group’s \Drawing\Reference_Files folder. You can rename these files and save them to the 
project’s \Design\Working folder to create your new model file.

Creating Model files from seed files

A seed file is a “starter” file.  It has all CDOT standard settings for each specialty group. Seed 
files are either 2D or 3D, so make sure you choose 3D when creating model files.
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See the CDOT CADD Manual, Chapter Five – Drafting Standards, section 5.2 – Seed files 
for more information.

CDOT default settings

When a new file is created from a seed file or auto-populated file, there are several settings 
already established that conform to the CDOT standards. Two important settings include 
Working Units and Angle Readout.

Working Units

The working units in either a 2D or 3D file determine the measurement system for the design 
file.  Working units are defined as:

• Master Units:Sub Units

• MU:SU

You set a design file’s working units for any desired measurement system.  For typical imperial 
units (English), you could set Master Unit to feet and Sub Units to inches.  The working units 
would then be expressed as 1:12.  If you set Master Units to Feet and Sub Units to tenths of a 
foot, your units would be expressed as 1:10. 

CDOT standard Working Units

CDOT standard working units are 1:12 and expressed as:

? Master Units = Survey Feet (’)
? Sub Units = Survey Inches (”)

There are two types of unit definitions for imperial feet – survey and international.  These 
have a slightly different conversion factor from metric.  CDOT uses the survey foot 
definition.
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The working units settings are found under Settings > Design File > Working Units.

Entering data
When you enter data for lengths, distances, etc. you use the format for working units: 
MU:SU.  You can enter data in just master units, just sub units, or both. For example, if your 
working units are 1:12 (feet and inches), and you want to place a line with a length of 1 foot 
1 ½ inches, you could enter the length as:

♦ 1.125

♦ 1: 1 1/2

♦ :13 1/2

Note: You can use either fractions or decimals when entering data.

Coordinate Readout

Use Settings > Design File > Angle Readout to determine how MicroStation values are 
displayed.  This is helpful, for example, when you measure graphics. The CDOT standard 
coordinate and angle readouts are shown below.  These settings are copied over from the seed 
file.
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You can set your linear values to readout in master units, sub units or both. Angles can readout 
in either degrees-minutes-seconds (DD MM SS) or decimal degrees (DD.DDDD) with up to 8 
decimal place accuracy.

Referencing other’s work

A Reference is a file that is attached to your active file, so that you can see the file’s graphics.  
Reference graphics are not actually in your active file, but serve as background data.  You 
cannot modify reference graphics from the active file.  You can, however, copy graphics from 
the reference model to the active model and then modify them, if desired.  Using references is a 
good way to copy a large number of graphics from model to model.

The proper use of MicroStation References is critical to achieving two key components of the 
CDOT MicroStation workflow:

1. Maintaining a single source for project data.

2. Sharing graphical data between specialty groups.

References allow multiple users to work on different parts of a project at the same time.  
Multiple users can access the same reference from a central location (e.g. project directory on 
the PM’s computer). Specialty groups can interact throughout the design process by referencing 
other discipline-specific model files. The data exchange between disciplines is “real time” 
when using MicroStation References. 

References are useful in the plan set creation phase.  You can “build” the sheets by referencing 
in the individual model files (survey/topo, design, utilities, etc.) Each discipline’s Master 
Model file can reference other discipline’s model files, as needed. The Master Model file can 
then be referenced into a newly created sheet file. You can also reference in details and show 
these at a different scale on the same sheet.

Attaching References

To attach references, select References from the Primary toolbar. In the References dialog box, 
select Tools > Attach. 
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Different reference file attachment methods are available to help control reference 
manipulations and displays. These include:

• No nesting

• Live nesting

• Copy attachments  

Nested References

References can be attached nested — meaning you can attach a reference’s reference.

The Nested Depth option determines how many reference levels deep you can attach.  In the 
example below, if the reference BridgeModel is attached to BridgePlanSheet01 with No 
Nesting, only the Bridge Model graphics are attached. If the nested depth is set to 1, you would 
attach BridgeModel01 and DesignModel01. If the nested depth is set to 2, you would attach 
BridgeModel01, DesignModel01, Survey/Topo and UtilityModel01.

The Live Nesting option allows you to dynamically update a reference’s sub-references after 
the reference is attached.  You can change your Live Nested Depth and your references will 
automatically update without having to detach and reattach the reference.
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The Copy Attachment Option

The Copy Attachment option allows you to dynamically make all nested references upper-level 
references. This way, you can manipulate and control each reference display individually, if 
needed. You can switch between nested references and the copy attachment at any time.

Working with Raster Attachments 

When you attach a reference, you have the option to Display Raster References. If the reference 
has a raster image attached (e.g. aerial photo), you can choose to attach the raster with the 
reference. You can toggle the raster reference on/off from the Reference dialog box.

For more information on working with raster references, see the CDOT Raster Manager 
workflow.

Reference Levels

You can control each reference’s levels just like the master file levels. The Level Display box 
shows a list of all attached references to the Master file. Select the reference and then turn the 
reference level on/off.

Geographic Tools

A geographical coordinate system uses a series of numbers to locate specific spots on the face 
of the earth. There are many of these coordinate systems in use today. Many of the data files 
that can be used by MicroStation have a geographical coordinate system attached. MicroStation 
has a number of tools to apply and reproject coordinate systems so that data with different 
systems can be used to create a unified data model.
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Geographic Tools

To access the geographic tools,:

1. Select Tools > Geographic > Open Aas ToolBox.

This displays the Geographic toolbox.

Attaching a Geographic Coordinate System

To attach a geographic coordinate system to a drawing:

1. Select  Select Geographic Coordinate System from the Geograpic toolbar. This 
displays the Geographic Coordinate System dialog box.

2. From the Geographic Coordinate System dialog box, select the From Library icon. This 
displays the Select Geographic Coordinate System dialog box.
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3. On the Select Geographic Coordinate System dialog box, select the Library tab.

4. Select the desired coordinate system from the Library list.

Note: The commonly use coordinate systems are located in the Colorado - Projected 
(northing, easting, ...) folder.

5. <D> Ok to attach the coordinate system to the file.

Geographic Coordinate Sysrems and Reference Files

The active file and files referenced to the active file can each have a coordinate system 
attached. These do not have to be the same coordinate system. MicroStation has the ability to 
reproject the reference file so the data representing the same point in each file is in the same 
place in the view.

Note: Both the active file and the reference must have a coordinate sysetem attached in order 
for the reprojection to take place.

When attaching a reference file witha different coordinate system:

1. Attach the reference file as normal.
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2. In the Reference Settings dialog box, highlight Geographic - Reprojected in the 
Orientation list.

3. Complete the attachment process as normal.

Geographic Coordinate Sysrems and Image Files

Many image files have geographic coordinate systems attached in the header or as a seperate 
file. These can also be attached and reprojected to the active file’s coordinate system. This is 
accomplished through Raster Manager.

To reproject an image file:

1. Select the Raster Manager from the Primary Tools toolbar. This displays the Raster 
Manager dialog box
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2. In the Raster Manager dialog box, select File > Attach > Raster. This displays the 
Attach Raster Reference dialog box.

3. Navigate to the desired file, highlight it, and <D> Open. this displays the Raster 
Attachment Options dialog box.

4. In the the Raster Attachment Options dialog box, expand the Geometry tab.

5. Make the desired settings to Geo Priority and GeoCS from Model.

Note: Attachment for Geo Priority and Inherited for GeoCS from Model will work 
for most files.

6. <D> Attach to complete tehe attachment.

If the coordinate system attached to the raster file is different than that attached to the active 
file:
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7. <R> on the file in Raster Manager and select Coordinate System > Select From 
Library from the menu.

8. In the Select Geographic Coordinate System dialog box,  Select the Library tab.

9. Highlight the desired coordinate system.

10.  <D> Ok to make the change.
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Reprojecting a File With a Different Coordinate System

There may be times when the coordinate system attached to a file needs to be changes and the 
data in the file reprojected to the new coordinate system. To make this change:

1. Make a copy of the file to be changed.

2. Verify that the copy is open in MicroStation.

3. Select  Select Geographic Coordinate System from the Geograpic toolbar. This 
displays the Geographic Coordinate System dialog box.

4. From the Geographic Coordinate System dialog box, select the From Library icon. This 
displays the Select Geographic Coordinate System dialog box.

5. On the Select Geographic Coordinate System dialog box, select the Library tab.
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6. Select the desired coordinate system from the Library list.

Note: The commonly use coordinate systems are located in the Colorado - Projected 
(northing, easting, ...) folder.

7. <D> Ok to attach the coordinate system to the file. The Geographic Coordinate System 
Changed dialog box is displayed.

There are two options in the The Geographic Coordinate System Changed dialog box:

♦  Correcting the Geographic Coordinate System - do not reproject the data - The data 
maintains its xyz coordinates from the old coordinate system. In effect, this moves the 
data’s “real world” location in relation to the new coordinate system.

♦ Reproject the data to the new Geographic Coordinate System - This option changes 
the xyz coordinates of the data to reflect the same “real world” coordinates in the new 
coordinate system.
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8. Select the desired option and <D> OK.

This completes the change to the coordinate system.
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