CDOT Level Update for V03.02
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This document guides you through updating the MicroStation levels that were changed, deleted,
and renamed from the Configuration Releases prior to V03.02. All drawing files created under
the V03.01 and prior Configuration Releases will need to be updated to the current CDOT
standard levels. See CDOT Configuration Readme.pdf file located in the level library section.

Converting Levels in MicroStation as a Batch Routine

1. From the MicroStation Manager, Open a drawing file

2. Itis recommended that a new project folder is created for the translated data to insure
the original project data is not lost. Using the same JPC# number appended with a “—
(initials)”. Once the data is verified the original data can be backed up to disc and

deleted. The “—(initials)” then can be dropped from the project folder. The example
used for this workflow will be 12345-NLJ.

3. Select Utilities > Batch Converter.

‘E:?_: C:\Projects\12345\Design\Drawings\12345DES_Plan#
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4. Change the Default Destination to the temporary project folder.

=) [untitled] - Batch Convert g [m|

Fil=  Edit
= | "'f'_-’} A

Default Dutput Format |48 -
E)efaultDestinatinn | c:hprojectsh 12345 =Y | g
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5. Navigate to the temporary project folder and <D> OK.

F% Select Destination Directory

Directony:
|

o \projects’,
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£ projects
q
£ 12345-HLJ |
2eUT_High-Flains
3 Batch Processes
£3 Bentley
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6. <D> the Add Files or Directories to Convert icon.

?—j[untitled] - Batch Convert
File Edit
& W ok r

Default Dutp, Add Files or Directories to Convert

Diefault Destination | c:\projectsh12345-MLI QL g

Conversion Tazks

# ¢ | Source To Destination J
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7. Using the Add Files or Directories dialog box, files or entire directories can be
added to the list of Selected Files to be processed. Check On Include
Subdirectories prior to specifying entire folders to a convert process. <D> to
highlight the folder name, then <D> Add. <D> Done when you are finished adding

files and/or folders.

E--fj_Select Files and Directories to convert

Files: Directories:

| chprojectsh,

= et
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1 12345
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Selected Files
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8. Select Edit > V8 Save Options... from the Batch Convert dialog box

Ea’-;'i [untitled] - Batch Convert

File | Edit
_1[ Add Files... &
Add Active File
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9. Inthe Save As V8 Options dialog box, <D> the Browse for CSV remapping file
icon. A standard CSV file is located in the configuration which is already set up to
remap all of the previous versions’ levels to the standard CDOT MicroStation VV03.00

levels.

Save As V8 Options

References | Filter |

SV File [

sl§sl] =k nljwk

|Br0~.v5e for CSV remapping fie

Cancel |

10. If not already there, browse to C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\Tables\Level_Translation. Select the file
V0302_Level Update.csv. <D> OK.

-

Select Remapping CSV File

File Directory

Files:

Directories;

|VDSD2_LeveI_U pdate.caw
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11. In the Save As V8 Options dialog box, check on the option to Apply Level

Mapping. <D> OK.

Save As VB Opticns

Remap | References | Filter|

CEY File | WO30Z_Level_Update cav

I~ Apply Level Mapping |

) o o

Cancel

12. <D> the Process Batch Convert Job icon when all files and directories have been

added to the conversion tasks list.

= [untitled] - Batch Convert

File Edit

O d Dy

Drefault Dutput Format

Process Batch Convert Job

Default Destination | c:projectsh1 2345-NLIY

LConversion Tasks

# | Source To Destination I
2 cohprojectsh 123454, e chprojectsh]2345-MLJN :
13. <D> Convert.
_Fé Files to Convert
# /| Source Format | Destination To Status Time. -
1 chprojectsh123454Bridge’Dr.. \12345BRDG_Maodel.c ¥E c:hprojectsh] 2345-MLI4Bnd.. 4 12345BRDG_Maodel.dg W7 Pending
2 c\projectsh] 2345 Bridge\Dra.. 41 Z345BRDG_Prof.d V8 cr\projectsh1 2345-NLI\Bridg. \1Z345BRDG_Praf.dg V7 Pending
3 cih\projectsh123454Bri. ACU12345BRDG_Model. don W& cohprojectsi12345-NLIN ACUN2345BR0G_Model dogi W7 Pending
4 cihprojectsh123454Br ACLN 23458 idgebodelt . dgn W& chprojectsi12345-0.\CU12345BrdgeModeldl.dgn W7 Pending
6 cih\projectsh12345\Constr. 4 12345C0NST_SAQ01.d W& c:hprojectsi12345-NLINCon. N 234500NST_SAQ071. W7 Pending =
B cih\projectsh123. A12345DES_EattworkQuant.don W8 chprojectsi1234. 412345DES_EarthworkQuant dgn W7 Pending
7 cihprojectsh123454Des. NT2346DES_GenMote.dgn W8 cohprojectsh12345-NLIY A123460ES_GenlNote.dan W7 Pending
8 ci\projectsh12345\Design. \12346DES_Plan## dgn W8 cAprojectsi12345-NLIND e \12346DES_Plant#.dan W7 Pending
9 ch\projectsh12345\Design. \12346DES_Plan01.dgn W8 chpojectsi12345-NLIND e A12346DES_Plan01.dgn W7 Pending
10 cih\projects\12345\Design.. \123450ES_Plan02.dgn V8 chprojects\12345-NLIND e, \12345DES_Planl2.dgn V7 Pending
1 rojectst 123454 Design... v 12345DES_Plan03.dgn VB rojectst12345-NLIDe. \123450ES_Plan03.dgn W7 Pending
12 cih\projects\12345\Design.. \123450ES_Plan04.dan V8 shprojectst12345-NLID e, \123450ES_PlanDd.dgn W7 Pending
13 cih\projects\12345\Design.. \123450ES_Plan05.dan V8 chprojects\12345-NLIND e, A12345DES_Planl5.dgn V7 Pending
14 chprojects\12345\Design.. \123450ES_Plan0B.dan Y8 ch\projectsh12345-NLIND e, A1 2345DES _PlanlB.dan W7 Pending
15 rojectsh123454Design... \12345DES_Plan07.dan W& rojectsh12345-NLIYD e, W1 2345DES_Plan07.dan Y7 Pending
16 chprojects\123454Design... \12345DES_Plan08.dan Y& Aprojectsh1 2345-MLIAD e, \123450E5_Plan08.dgn W7 Pending
17 chprojects'123454Design... \12345DES_Plan09.dan Y& c:hprojectsh12345-MLID e, \12345DES_Plan09.dgn W7 Pending
18 rojectst123454Design.. \12345DES_Plan10.dan Y& rojectst12345-NLIYD e, V1 2345DES_Planl0.dgn Y7 Pending
13 chprojects\123454Design... \12345DES_Plan1.dan Y& :hprojectsh1 2345-MLID e, \2345DES_Pland 1.dgn %7 Pending
20 chprojects\123454Design... \12345DES_Plan12.dan Y& c:hprojectsh12345-MLID e, \12345DES_Pland 2.dgn W7 Pending
21 chprojects\123454Design... \12345DES_Plan3.dan Y& c:hprojectsh12345-MLIND e, \2345DES_Pland 3.dgn W7 Pending
22 chprojects\1 23454 Desigr.. \1 2345DES_Planl4.dgn VB crhprojectsh1 2245-NLIND e, A1 2345DES_Planl 4.dgn Y7 Pending
23 chprojects\1 2345 Design.. \12345DES_PlaniG.dgn V8 ch\projectsh1 2345-NLIADe. 12345DES_Plani5.dgn Y7 Pending
24 chprojects\1 2345 Design.. \12345DES_PlaniB.dgn V8 c\projectsh1 2345-NLIADe. 12345DES_Planl B dgn Y7 Pending
25 ch\projects\1 2345 Design.. \12345DES_Plan] 7.dgn V8 c\projects\1 Z345-NLINDe. 12345DES_Planl 7.dgn W7 Pending
26 chprojectsi123454Design. A1 2345DES_Plani8.dgn W chprojects\12345-NLIND e, A12346DES_PlanlB.don W7 Pending
27 chprojectsh123454Design. \12345DES_Plan19.dgn W chprojectsi12345-NLIND e A12346DES_Planl9.don W7 Pending
R ~Anriectl 19 MFL N esion Y12UANFS. Pland dan WA cAnmiectsV12URNLI A Y1294RNES Plan? dan W7 Pendinn j
I Caonvert I Cancel
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14. The conversion process runs and the status column will be updated from Pending to
Converted once completed.

15. When all the files have been converted <D> Done.

E:j Files to Convert
# | Source Format | Destination To Status Time: o
1 cihprojectst1 234548 idoehDr. A1 2345BR0G_Model.c V8 chprojectst12346-HLJNBAd . A1 2346BRDG_Model dc V7 Converted 03
2 cihprojectst1 234548 ridoetDia.. 41 2345BRDG_Prof di V8 chprojectst12346-MLJNBrdg. A1 2345BR0OG_Prof.dor V7 Converted oo
3 cohprojectsh 123454800, ACU2345BR0G_Model. dgn W8 cihprojectsh1 2345-MLJ4 . ACUT23458RDG_Model dg V7 Converted 0.2
4 cihprojectsh 12345481 MCU 123458 idgebodel0l dan W8 cihprojectsh12345-M. ACU12345BnidgeModel0l.dgn W7 Converted 0.1
5 cohprojectsy12345\Constr.. \12345C0NST_SAQO1.d W8 cihprojectst12345-HLJACon, A 2345C0ONST_SAQOT 7 Converted 01 =
B cihprojectsh123.. 1 2345DES_EarthworkQuant.don - 8 chprojectst 1234, A 2345DES_EarthworkQuant.dan Y7 Converted 02
7 cihprojectsh123454Des. AN 23450ES_GenlMate.dan V8 ohprajectsh] 2345-MLJY. W 123450ES_GenlMate.dan V7 Converted 0.2
8 cihprojectsh] 23455\Design.. \12345DE5_Plantt.dan V8 ohprajectsh 2345-MLJNDe. A1 2345DES_Plantti.dan V7 Converted 01
9 cihprojectst12345\Design.. \12346DES_Plan01.dgn 3 chprojectst12345-ML)NDe. N1 2346DES_Plan0l.dgn V7 Converted 03
10 chprojectst123455Design.. N1 2346DES_Plan02.dgn 3 cihprojectst12345-MLJNDe. N1 2346DES_Plan02 dgn W7 Converted 03
11 chprojectst123464Design.. N12346DES_Plan03.dgn V3 cihprojectst12346-HLJNDe. N1 2346DES_Plan03.dgn V7 Converted o2
12 cihprojectst123465Design.. N1 2346DES_Plan04.dgn 8 chprojectst12346-HLJNDe. N12346DES_Plan04.dgn V7 Converted 02
12 chprojectst123465Design.. N12346DES_Plan05.dgn 8 cihprojectst12246-ML)NDe, N12346DES_Plan05.dgn V7 Converted 02
14 cihprojects\ 12345 Design.. \123450ES_PlanlB.dgn V8 cihprojectsh12345-MLJ0e. N12345DES_Plan0E.dgn W7 Converted 0.2
15 ciprojectsy12345 \Design.. \123450ES_Plan07.dgn V8 cihprojectsh12345-MLJ0e. N12345DES_Plan07.dan W7 Converted 0.2
16 chprojectsh 23454 Design.. \123450ES_Plan08.dgn W8 chprajectsh 2345-MLJNDe. A1 2345DES_Plan08.dgn W7 Converted 0z
17 chprojectsy 23454 Design.. \123450ES_Plan09.dgn W8 chprajectsh] 2345-MLJNDe. A1 2345DES_Plan03.dgn W7 Converted 03
18 chprojectsy123454Design.. V1 2345DES_PlanlO.dgn V8 o:hprajectsh] 2345-MLJNDe. N1 2345DES_Plan10.dgn 7 Converted 0.z
19 chprojectsy123454Design.. \123450ES_Planl 1.dgn V8 ohprajectsh] 2345-MLJNDe. N1 2345DES_Plan1l.dgn V7 Converted 0.2
20 cihprojectst1234565Design.. N1 2346DES_Plan12.dgn V3 chprojectst12345-ML)NDe. M12346DES_Plan12.dgn V7 Converted o2
21 cihprojectst123464Design.. N1 2346DES_Plan13.dgn V3 cihprojectst12345-MLINDe. N1 2346DES_Plan13.dgn V7 Converted 02
22 cihprojectst123465Design.. N1 2346DES_Planl4.dgn V8 chprojectst12346-HLJNDe. N12346DES_PlanT4.dgn V7 Converted 02
23 cihprojectst12346\Design. N1 2346DES_Plan1b.dgn V8 chprojectst12346-HLJNDe. N12346DES_Plan1G.dgn V7 Converted 02
24 cihprojects\12345\Design.. \123450ES_Plan16.dgn V8 cihprojectsh 1 2345-MLJ0e, N12345DES_Plan1E.dgn 7 Converted 0.2
25 cihprojects\12345\Design.. \123450ES_Plan17.dgn V8 cihprojectsh12345-MLJ0e. N12345DES_Plan17.dgn V7 Converted 0.2
26 ciprojects\12345 Design.. \12345DES_Plan18.dgn Y8 cohprojectst 2345-MLJDe. N1 2345DES_Plan18.dan W7 Converted 0.2
27 chprojectsh1 23454 Design.. \123450ES_Plan9.dgn W8 chprajectsh] 2345-MLJNDe. A1 2345DES_Plan13.dgn 7 Corverted 0.z
D ehrenineteh DU N asian 41 PURNES Pland dan W0 ~hrrainctshd DML A PUENES Dland don W7 Frruearbad n> j
I Done I |

16. Take time to verify your data. The translation will only build folders and copy the
translated data. You will need to copy all missing folders and data from you original
project to the translated project folder. When folders and data have been verified,
either delete or archive your original project folder and rename the translated project
folder by removing your initials. This step will ensure that all references will
display.
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Converting Levels in MicroStation

1. From the MicroStation Manager, Open a drawing file.

2. Select File > Save As.

FZ C:\Projects\12345\Misc

File | Edt Element Setting:
[ New... Ctri+N
—Z Open... Ctrl+ 0
Close Ctri+w
= save Ctri+5
% Save As... |
Compress 2
Save Settings  Ctrl+F
E Reference
- Raster Manager
E Models
4 Import 4
¢ Export 4

3. Enter a new name into the Files: field to rename the current open drawing file, then
<D> Options.

Save As

12345DES_Plan07.dan
123450E5_Plan02.dan
123450E5_Plan03.dan
123450E5_Plan0.dan
123450E5_Plan11.dan
123450E5_Planl 2.dan

12245DE5_Plan1 3.dan

Select Format To Save:

MicroStation V8 DG Files [F.dan]

=l

x|

| Diirectaries:
12348DES_PlanlZa.dgn I C:AProjectsh1 234550 esigniDrawingsh
12345DE5_FlanD2.dgn ;] = O
12345DES_Plan03.dgn [~ Projects
12345DE5_Flan04.dgn J (= 12345
12348DES_Plan05.dgn [ Design
12348DES_Plan0B.dgn = Drawings

21 Cross_Sections
=1 Reference_Files
£ Tahs

Dirives:
E:

=]

Cancel

Options

[l

Version 03.03

Page 7 of 10

Updated March, 2008



CDOT Level Update for V03.02.pdf

4. Inthe Save As V8 Options dialog box, <D> the Browse for CSV remapping file
icon. A standard CSV file is located in the configuration which is already set up to
remap all of the previous versions’ levels to the standard CDOT MicroStation V03.01
levels.

Save As V8 Options ‘

References | Filter |

CSV File [ 'a

|Br0~.'u5e for CSV remapping file

sl§sl =k nljxk

OK Cancel |

5. Navigate to C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\Tables\Level_Translation. Select the file
V03.02_Level _Conversion.csv. <D> OK.

Select Remapping CSV File

File Directory
Files: Directories:

[%03.02_Lewvel Conversion.cay . ATableshLevel Translation'

W03.02_Level_Conversion. cav I I = Ch
[~ Program Files
= workspace-CDOT
(7= Standards-Global
[ MicroStation
[=r Tables
= Level_Tramslation

Cancel
List Fileg of Type: Dirives:
Remapping Files [ cav] v| |§ C: ] m
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6. Inthe Save As V8 Options dialog box, check On the option to Apply Level

Mapping. <D> OK.

F= Save As V8 Options

Remap | Rieferences | Filtell

CSY File [W0300_To_ %0301 csv

r
-
-

W i&pply Level Mapping

Qi

Cancel |

7. <D> OK in the Save As dialog box. The CSV file will execute and the previous
levels will be converted to the updated levels in the V03.01 configuration release.

12245DE5_Plan07.dan
12245DE5_Plan03.dan
12345DE5_Plan09.dgn
12345DE5_Plan10.dgn
12345DES_Planl1.dgn
123450E5_Plaml 2.dan

123450DE5_Plan1 3.dgn L]
Select Format To Save:
MicroStation W8 DGM Files [*.dgn] VJ

Save As
Direckary
Directaries:
[12345DES_PlanlZa.dgn CAProjectsh12345\DesigniDrawingsh,
12345DE5_FlanD2 dgn :] = C:A
12345DES_Plan03.dgn [ Projects
123450E5_Plan04.dgn J (= 12345
12345DES_Plan05.dgn [ Design
12345DES_Plan0E.dgn = Drawings

£ Cross_Sections
7 Reference_Files
21 Tabs

Drives:
=2

(=

Cancel

il

Options

Note: Once the new file is created, there will be two files with the same data. From
windows explorer delete the old file and rename the newly created file to the old
name. This will allow all reference file calls to be correct and will eliminate having

duplicate data
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Compressing the Model File

8. After the level updates have been made to the drawing files created in previous
versions, select File > Compress Design > Options.

-
|~ ]
Edtt Element Settings Took U
3 New... Ctri+N
— @ Open... Ctr+0
4 Close CtrisW
e save Ctri+S
Save As...
[ Compress »  Design
Save Settings Ctri+F Options
E Reference
: Raster Manager

9. Inthe Compress Design Options window, all options should be checked on except
Delete Text Elements Containing Only Spaces. <D> the Compress button, then

<D> OK.
= Compress Options E] =

Select Action Aliag I
Delete Emphy Cell Headers EMPTY_CELL
Delete Erpty Text Element EMPTY TE=T
] Delete Text Elementz Containing Only Spaces  SPACE_TEXRT |
[w] Delete Unuzed Mamed Shared Cells SE_N.-’-‘-.HED
Delete Unuzed snonymous Shared Cells SC_AMOM
Delete Unuzed Line Styules LIMESTYLES
Delete Unuzed Dimenzion Shles DIMSTYLES
Delete Unuged Text Shles TEXTSTYLES
Delete Unuged Levels LEVELS
Delete Unugzed Mested Attachment Levels LEVELTAELES

Compress (H] % l Cancel Apply
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