CDOT Level Update for \V04.00.00
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This document guides you through updating the MicroStation levels that were changed, deleted,
and renamed from the configuration releases prior to VV04.00.00. All drawing files created under
the V03.02.03 and prior configuration releases will need to be updated to the current CDOT
standard levels. See CDOT Configuration Readme.pdf file located in the level library section.

The current version of MicroStation XM (V08.09.04.88) has a default setting that only allows
files to be added individually. In order to add files by calling out sub-directories, the user must

make an adjustment to the Workspace Preferences.

1. From the MicroStation Manager, Open a drawing file.

2. Select Workspace > Preferences.

File Edit Element Settings Tools Utilities

NCHS L2 e

Waorkspace

Customize

Window He

3. Select the category Look and Feel and toggle OFF the Use Windows File Open
Dialogs button. <D> OK and to close the preference dialog box.

#b Preferences [CDOT User]

W Name for preferences | Default Preferences

base Set Look and Feel Preferences.

ook and Fesl Single Click: Locked &
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osition Mapping 5

Raster Manager Layout: _Regular hd
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Spelling View Tool Size:  Small (16x 16) hd

Tags Dialog Fort:  Microsoft Sans Serf, 9

Task Navigation

Text

[~ Auto-Focus Tool Settings Window
W Bordedess lcons

I W Use Windows File Open Dialogs I

View Options

™ Al modeless dialogs use same transparency

Focus ttem Description

Cancel
Defaults

Fort...

[~ Transparent dialogs become opaque when receiving focus

Faor more options, click on the category list at left.

]

The function to add a directory path is functioning improperly. You are able to batch process by
selecting the files by drilling down to the lowest folder levels. The other sections of this
document work as advertised. If you need help with this document please feel free to submit a

help ticket and we can walk you through the process.
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Converting Levels in MicroStation as a Batch Routine

1. From the MicroStation Manager, Open a drawing file.

2. Itis recommended that a new project folder is created for the translated data to
insure the original project data is not lost. Using the same JPC# number
appended with a “—(initials)”. Once the data is verified the original data can be
backed up to disc and deleted. The “—(initials)” then can be dropped from the
project folder. The example used for this workflow will be 12345-NLJ.

3. Select Utilities > Batch Converter.

Version 04.00.00

M C:\Projects\12345\Design\Drawings\12345DES_PnP01.¢

File Edit Element Settings Toolsl Utlities BWorkspace Window

DN di@ sds a2t

M View 1 - Top

Connect Web Browser
HIML Authaor. ..
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Cell Selector

Image
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Saved Views
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Design Histor L
Batch Converter...

Batch Process...
Standards Checker
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Archive
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4. Change the Default Destination to the temporary project folder.

” [untitled] - Batch Convert

(= [ E)

File Edit

ﬁ ! = |:| L\i‘@ x i“ Frocess Selection Only

Default Output Format |V -

] Defautt Destination | C:\Projects' 12245

[ Apply to Selection |
3] | )

Conversion Tasks

# ’| Source | To | Destination

5. Navigate to the temporary project folder and <D> OK.

M Select Destination Directory x|
Directory:
I

chprojects’ 123450l

e

L proiecis
= 123451 1

IS C o [ =

6. <D> the Add Files or Directories to Convert icon.

ﬂ [untitled] - Batch Convert

File Edit

ﬁ i = |j Hﬁip( ﬁ' Process Selection Only

Default Cutput Add Files or Directories to Com.rert|

[ Apply to Selection ]

Default Destination | C:\Projects’12345-NLJ\ Q
Conversion Tasks
# ’| Source |To |Destinatior| |
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7. Using the Add Files or Directories dialog box, files or entire directories can be
added to the list of Selected Files to be processed. Check On Include
Subdirectories prior to specifying entire folders to a convert process. <D> to
highlight the folder name, then <D> Add. <D> Done when you are finished

adding files and/or fold

ers.

M Select Files and Directories to convert

Files:

Directories:

c:\projects’,

Eq

List Files of Type:
DGN Files [*.dgn]

et
= projects
£3 00000

£ 56566
£ 994999
1 Garage
3 QC Output

Drives:

Done

Cancel

v| [S¢C

Selected Files

I|7 Include Subdirectories I

= Help

c\projectst 12345 - NLIVY

[ i

8. Select Edit > V8 Save Options... from the Batch Convert dialog box

M [untitled] - Batch Convert

it Add Files. ..
j Add Active File

=[5] x|

V8 Sawe Options...

V7 Sawve Options...
Log File Options...

Cirl+u
Cirl4D

-
- ey to Selecton |
rojects’ 12345 - NLJ\ Q
To Destination |
Ve chprojects’ 12345 - NLI
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9. Inthe Save As V8 Options dialog box, check On the option to Apply Level
Mapping. <D> OK.

P Save As V8 Options ||
Remap | References | Fitter
CSV File | V040000_Level_Update csv Q=0

x

Note: If the file is not auto populated, navigate to C:\Program
Files\Workspace-CDOT\Standards-
Global\MicroStation\Tables\Level Translation. Select the file

V040000 Level Conversion.csv. <D> OK.

10. <D> the Process Batch Convert Job icon when all files and directories have
been added to the conversion tasks list.

&L [untitled] - Batch Convert = %|

Fle Edit
(3] ) _s =
Default Output Format: [VE :
(LIETALIL LIUpuUt marmEt; Procors RatebiCoarvert dob
Default Destination cgrmm—l Q ;

Conversion Tasks
# /| Source Tao Destination |
1 C:AProjects\ 12345\, Ve cprojectst 1234500
< N
Version 04.00.00 Page 5 of 9 Updated February, 2009




CDOT Level Update for V04.00.00.pdf

11. <D> Convert.

M Files to Convert

Cancel

# /| Source Format | Destination To Status .
1  C)\Projects’\ 1234512345 DesignSheet.dgn Ve c\projectsi12..\12345_DesignSheet.dgn V8 Pending |
2 CM\Projects\12345'\B0%=butment 1.dgn Va c\projects’12345nl\B0S-abutment 1.dgn V8 Pending

3  CM\Projects'\12345\D7-50.dgn Ve c\projects’12345nl\D7-50.dan Ve Pending

4 CAProjects'12345\D7-504.dagn Ve c\projects\ 123450l \D 7-50A.dgn VL] Pending

5 CA\Projects\12345\D7-51.dan Va c\projects’123450\D7-51.dan VB Pending

& C’\Projects\12345\D7-514.dgn Vi c\projects’ 1234500 7-51A.dgn Ve Pending

7 CMProjects\12345\W12-52 dgn Vi c\projects’ 1 2345n\W12-52 dan Ve Pending

8 C’\Projects\12345\W12-53 dgn Va c\projects’ 1 2345n\W12-53 dan Ve Pending

5 C’\Projects\12345\W15-50 dgn Va o \projects’ 1 2345n"\W15-50.dan Ve Pending

10 C’\Projects\12345"W15-51 dgn Va c\projects’ 123450l \W15-51 dan WE Pending

11 C\Projects\12345\W15-52 dgn Ve c\projects’ 123450l \\W15-52 dan Ve Pending

: of

12. The conversion process runs and the status column will be updated from Pending

to Converted once completed.

13. When all the files have been converted <D> Done.

# Files to Convert

Daone

|

H# /| Source Format | Destination To Status o
1 CA\Projects'12345\12345_DesignSheet dan Ve chprojects’ 12, \12345_DesignSheet.dan VB Converted _|
2 C)\Projects’12345'\B0S-abutment 1.dgn ) c\projects’ 123450\ B0%-abutment 1.dgn W8 Converted
3 CA\Projects\12345\D7-50.dgn VL] chprojects' 1234500 7-50.dan VL] Converted
4 CAProjects’12345\07-50A dgn Ve cprojects’ 1234500 \D7-50A.dgn Ve Converted
5  Ci\Projects’12345\D7-51.dgn E] cprojects’12345nN\D7-51.dan VL] Converted
6 C\Projects’\12345\D7-51A dgn Ve cprojectsh 123450 \D7-51A.dgn Ve Converted
7 Ci\Projects\12345\W12-52 dan e ch\projects’12345n\W12-52 dan VL) Converted
8 C\Projects\12345'W12-53.dan Va cprojects’ 1 23450"\W12-53.dan Ve Converted
3 C/\Projects\12345\W15-50.dan e c\projects’ 123451\ 15-50.dan VL) Converted
10 C:\Projects'12345\W15-51 dgn Va cprojects’123450"W15-51.dan VL] Converted
11 C:\Project=\12345\W15-52 dgn ) c\projects’ 123450\ 15-52 dan Ve Converted
-
4] >

14. Take time to verify your data. The translation will only build folders and copy
the translated data. You will need to copy all missing folders and data from you
original project to the translated project folder. When folders and data have been
verified, either delete or archive your original project folder and rename the
translated project folder by removing your initials. This step will ensure that all

references will display.
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Converting Levels in Individual MicroStation Drawings

1. From the MicroStation Manager, Open a drawing file.

2. Select File > Save As.

M C:\Projects\12345\Design\Drawings\12345DES_PnP01.dgn (3D -1

File Edit Element Settings Tools Utlities Workspace Window Help CDo

1 Mew... Ctrl+M

" Open... Ctrl+0
Close Crl+w

L] Save ] +5
Compress r
Save Settings Ctrl+F

3. Enter a new name into the Files: field to rename the current open drawing file,
then <D> Options.

# Save As - C:\Projects\12345\Design\Drawings\

x|

Savein: | Drawings

E3)

|| z

3D - VB DGN

MName
Cross_Sections
Reference_Files
Tabs

] 12345DES _EarthworkQuant#...
] 12345DES_GenlNote##.dgn
] 12345DES_Plan##.dgn

] 12345DES_PnP01.dgn

] 12345DES_PnP02.dgn

] 12345DES_PrP03.dgn

4] 12345DES_PnP04.dgn

M 12345DES_PnP0S5.dgn

] 12345DES_PnPO06.dgn

] 12345DES_PrP07.dgn

] 12345DES_PrP03.dgn

] 12345DES_PnP09.dgn

81 173450FS PRR1N Aan

a

-

Save |

Cancel

I Options

[~

MicroStation V8 DGN Files (*.dgn) -

File name: ‘12345DES?PnPD1a.dgn

Save as type:
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4. Inthe Save As V8 Options dialog box, check On the option to Apply Level
Mapping. <D> OK.

M Save As V8 Options ||
Remap | References | Fitter

CSV File | V040000_Level_Update csv QN

Apply Fart Mapping
Apply Line Style Mapping

Apply Color Mapping
Apply Weight Mapping

Note: If the file is not auto populated, navigate to C:\Program
Files\Workspace-CDOT\Standards-
Global\MicroStation\Tables\Level _Translation. Select the file
V040000 Level Conversion.csv. <D> OK.

5. <D> OK in the Save As dialog box. The CSV file will execute and the previous
levels will be converted to the updated levels in the VV04.00.00 configuration

release.
# Save As - C:\Projects\12345\Design\Drawings\ ﬂ
Savein: I .. Drawings j @ _? - ' 3D - VB DGN

Name ~ |-l |

.. Cross_Sections

. Reference_Files

. Tabs
12345DES_EarthworkQuant##...
12345DES_GenlNote . dan
12345DES_Plan##.dan
L] 12345DES_PnPO1.dgn
12345DES_PrP02.dan
12345DES_PnP03.dgn
12345DES_PrP04.dan
12345DES_PrPOS5.dan
12345DES_PrP0S.dan
12345DES_PrP07.dan
12345DES_PrP0S.dan
12345DES_PrP0S.dan

m 17346NFS PR 10 Ann d
File name: [12345DES_PrP01a.dgn =
Saveastype:  |MicroStation V8 DGN Files ("dgn) -l Cancel
Options |
VA

Note: Once the new file is created, there will be two files with the same data.
From windows explorer delete the old file and rename the newly created
file to the old name. This will allow all reference file calls to be correct
and will eliminate having duplicate data
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Compressing the Model File

1. After the level updates have been made to the drawing files created in previous
versions, select File > Compress > Options.

M C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn (:

Edit Element Settings Tools Ufiliies Workspace Window Help CDOT Help

_‘! Hew. .. Cirl+M m
Cpen... Cirl+0
i Close Clrl+w
f0 save Cirl+5
Save As
Compress
Save Settings Cirl+F

2. Inthe Compress Options dialog box, all options should be checked on except
Delete Text Elements Containing Only Spaces. <D> the Compress button,

then <D> OK.
M Compress Options = ﬂ
Select Action Alias
Delete Empty Cell Headers EMPTY_CELL
Delete Empty Text Elements EMPTY_TEXT
] Delete Text Blements Containing Onby Spaces  SPACE_TEXT
Delete Unused Named Shared Cells SC_MNAMED
Delete Unused Anomymous Shared Cells SC_ANON
Delete Unused Line Styles LINESTYLES
Delete Unused Dimension Styles DIMSTYLES
Delete Unused Text Styles TEXTSTYLES
Delete Unused Levels LEVELS
Delete Unused Mested Attachment Levels LEVELTABLES
Delete Unused Multidine Styles MLINESTYLES
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