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Document Conventions 
There are several conventions that are used throughout this document to indicate 
actions to be taken or to highlight important information.  The conventions are as 
follows: 

 

Item     Meaning 

View Perimeter a command name or a file that you are to select 

Tools > Options a command path that you are to select – usually from the 
pull-down menus 

Key in entering data with the keyboard 

Document name style used when referring to another document 

Note:  text information about a command or process that you should 
pay particular attention to 

Emphasis an important word or phrase 

1. Numbered Steps actions that you are to perform as part of the lab activities 

<D> or Data press the data button on the mouse 

<R> or Reset press the reset button on the mouse 

<T> or Tentative press the tentative button on the mouse 
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Getting Started 

Introduction 
The document is designed for use in an instructor-led classroom environment, 
but will be useful for new users to refer back to as they begin applying the 
learned techniques to their projects.  However, it is not meant to be a software 
reference guide or to replace the on-line help available through InRoads. 

The lab activities are written to provide the students with step-by-step 
instructions for the main focus of the chapter, with additional challenge labs in 
many of the chapters for those who finish early or want to dig deeper into the 
topics. 

Prerequisites 
Before attending this course, you should know how to: 

In MicroStation 

 Use the ‘select group’ utility 
 Use the ‘project creation’ utility 
 Use the standard CDOT project directory structure 
 Understand the concept and practice of selecting a ‘project’ in the 

MicroStation Manager interface. 
 Use the basic file management tools in MicroStation (open, copy, 

new, rename) 
 Use the view manipulation commands in MicroStation (zoom in/out, 

fit, pan, recall saved view(s), turn levels on/off 
 Manipulate MicroStation References – display on/off, turn 

references levels on/off 
 How to work in a 3D MicroStation file. View rotation, active depth, 

view depth, depth lock. 
 Use the tentative (snap) button on the mouse for precision graphics 

location 

In InRoads 

 Use the InRoads locks 
 Create, review and modify basic horizontal and vertical alignments. 
 Create and modify typical sections. 
 Create basic decision tables. 
 Create roadway definitions and template transitions. 
 Run Roadway Modeler. 
 Have a general understanding of feature based DTM's. 
 Generate and update cross sections. 
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CDOT CADD Resources 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & 
Engineering Innovation Web site. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: 

http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 

The website (presently only available to CDOT) provides CDOT users with 
up to date information, tools, and resources related to CADD and the 
Colorado Engineering Software Transition (CEST) project.  

This website is a valuable resource for CADD users and includes links to: 

CADD Library -- provides links to manuals, newsletters, standard details, 
Tips and Tricks etc. 

CADD Manual -- documents standardized procedures for the exchange of 
information. The Manual also addresses software issues, tools, techniques, 
standards and procedures, etc. which will aid the user in the efficient 
production of CDOT plan sets. 

CDOT Workflows -- step-by-step CDOT-specific procedures for certain 
tasks that you may encounter when working in MicroStation or InRoads on 
a CDOT project. 

Issues Logs -- to determine the status of submitted requests. 

Requests and Support -- provides CADD help solutions where you can 
submit questions or requests, obtain InRoads, InRoads Survey and 
MicroStation support, and link to IT Services for support. 

Training -- sign up for training classes or review online computer-based 
training (CBT) for MicroStation, InRoads and InRoads Survey. 

Training files 
The training lab files for this course will be available after you complete the 
training.  Your computer will have a training files icon in CDOT 
Customization Group accessed from the Windows Start menu.  A link is also 
available in IT Services on the CADD & Engineering Innovation website.  The 
icon and link perform the same self extracting zip process to install the training 
files on your machine. 

It is highly recommended that you install the training files and continue 
practicing with MicroStation and InRoads by completing the lab exercises 
contained in this course guide, especially if you do not plan to start work on a 
MicroStation/InRoads project soon. 

 

http://internal/cadd/�
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Files used by InRoads 
InRoads uses several different files to store parameters driving the design and 
display of InRoads graphics, as well as to store the design data. These files are 
loaded into memory during a design session and with some exceptions must be 
saved if they have been modified. The typical files used in a project are shown 
below. 

File Ext. Format Comes From * Contains Method of Saving 

Preferences 

(CDOT-
preferences.ini) 

.ini ASCII CDOT Standard M Units 

Precision Readout 

Command preferences 

** 

Styles 

(CDOT-
styles.ini) 

.ini ASCII CDOT Standard M Geometry Styles 

Controls symbology of 
alignments and cogo points. 

** 

Digital Terrain 
Models 

.dtm Binary Existing - from 
Survey 

Design - created 
by InRoads 

S Topographic information for 
ground surface. Used for 
contouring, profiles, cross 
section, etc. 

Must be saved before 
exiting. May use 
File>Save As>*.dtm 

Geometry 
Project 

.alg Binary Survey 

Copied and 
added to during 
design 

S Horizontal alignments 

Vertical alignments 

Superelevation  

Cogo points 

Must be saved before 
exiting. May use 
File>Save As>*.alg 

Typical 
Section Library 

.tml Binary CDOT 
Standard** 

Make copy for 
project use so 
you can edit 

M Templates 

Tables: Decision, Cut/Fill, 
Material 

TC (transition control) 
Names 

Must be saved before 
exiting. May use 
File>Save As>*.tml 

Roadway 
Library 

.rwl Binary Created for each 
project 

S Roadway Definitions 
(Station & Template setups, 
etc.) 

Must be saved before 
exiting. May use 
File>Save As>*.rwl 

Project  .rwk ASCII Created for each 
project 

S List of files used in project. The project file saves 
all the individual files 
using File>Save or 
Save As. NOTE: Files 
saved are only those 
listed in the .rwk. 

* M=Multiple Project Use, S=Single Project Use 

** CDOT configuration does not allow modification of standards, preferences 
or styles. 
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Project File Structure 
The sample project in this document uses the standard CDOT file structure with 
12345 = CDOT JPC number. 
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Starting InRoads 
If you are using a machine that has both MicroStation and AutoCAD loaded, or 
more than one version of MicroStation, you must tell InRoads which CAD 
platform to use before starting InRoads. 

Choose Start > All Programs > Bentley Civil Engineering > Select CAD 
Platform and select MicroStation V8, then choose OK. 

 

There are three main methods of starting InRoads: 

a. Choose Start > All Programs > Bentley Civil Engineering > Bentley InRoads 
and MicroStation will start and allow you to choose the design file, then 
InRoads will start. 

b. Choose the Desktop icon for InRoads if one is available on your machine. 
MicroStation will start and allow you to choose the design file, then InRoads 
will start. 

c. If you already have MicroStation open, you can choose the InRoads icon from 
the MicroStation main toolbar. 
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Project Defaults 
InRoads loads a preferences file and a styles file when it starts. You may create 
Project Defaults to have InRoads load your CDOT customized files 
automatically. If you do not, it will load the default files out of the InRoads 
product directory and you will have to load yours (CDOT-preferences.ini and 
a CDOT-styles.ini) through a project file (.rwk) or individually.  

The Project Defaults also set the path that InRoads will use to open or store 
data files that you load or save. These paths are not absolute; they are just the 
starting point to which InRoads defaults. 

Multiple Project Defaults may be created and stored on a machine, and you 
can switch between them when switching between projects. 

The Project Defaults are found on the InRoads menu under File > Project 
Defaults as shown below. 

Important!: Throughout the Advanced Roadway 
Modeling lab exercises, it is critical that you set 
the correct Project Defaults configuration name. 
Each lab exercise requires that you load the 
correct InRoads data files, which are located in 
separate sub-folders. 
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1. Alignment Creation 
There are several methods for creating horizontal and vertical alignments using 
InRoads. This chapter explores these methods which include: 

 Using the Horizontal Curve Set tools with text input 
files (@ files) 

 Using Horizontal Elements to create alignments without 
PIs 

 Using Coordinate Geometry (Cogo) 
 Importing alignments and cogo points (.ics files, 

graphics) 

In addition you’ll learn how to assign geometry styles to your alignments and 
geometry points as well as generate reports based on alignments and features. 

Text Input Files and Alignments 
You learned how to create alignments with Horizontal and Vertical Curve Set 
tools in the Roadway Design using InRoads class. These tools allow you to 
interactively create your alignment by placing PIs for your tangents, then 
placing curve sets by specifying the radius, degree of curve or pass through 
points for simple or compound curves (with or without spirals). 

     

To automate the process of placing PIs, you can use text input files (also know 
as @ files), which store your precision keyins for PI locations. 
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Creating text input files 
You can use any word processor (including Windows Notepad) to create a 
text input file. Just make sure you save the file as ASCII text. Text Input 
files store any MicroStation keyin which can later be processed in sequence. 
When laying out alignment PIs, valid keyins include: 

 xy=<x,y,z> or <easting,northing,elevation> 
 ne=<n,e,e> or <northing,easting,elevation> 
 di=<distance,direction> 
 so=<station,offset,elevation,alignment> where 

alignment is the name of the alignment that your 
offsetting from.  

 

Place each keyin on separate line, then save the file. You can then process 
the entire sequence of keyins in one step by reading the text input file while 
the Add PI command is active. 

Processing text input files 
To process the file, select the Add PI command, then keyin: 
@ <path\filename> 

The keyins stored in the file are processed in order, the geometry is created 
in active alignment of the geometry project, and the graphics are placed in 
the design file. 

 

Advantages of text input files 

Text input files allow you to: 

 Document your alignment 
 Easily edit your alignment by changing your stored 

keyins and then reprocessing the text file  
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Horizontal Element Tools 
There are 14 tools that can be used to create horizontal element alignments. 
One of the greatest advantages of the horizontal element alignments is that they 
do not have to be continuous. For example, you can create elements that have 
the most constraints, then join them together with unconstrained tangents and 
curves. 

 

When creating elements, you have three basic constraint options. Fixed 
elements are those with no degrees of Freedom. You know exactly where the 
element is going to be located and you, in effect, lock it in place. Fixed 
elements are not locked in length, however, and expand or shrink to be tangent 
with adjacent elements.  

 

Floating elements are established with a pass-through point and a radius (for 
curves) and with a pass-through point or a bearing for lines. 
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Elements that connect two fixed entities and have no known location (just a 
radius for the curves) are said to be free elements. They are often used to 
connect fixed elements, such as tangents connecting two fixed curves. 

 

To create a horizontal element alignment, first give the alignment a name 
description and style, then use a combination of the element commands to 
define the alignment.  

Coordinate Geometry (COGO) 
InRoads has a series of coordinate geometry commands built into the software. 
There is no need to exit and start another product in order to use them.  

 

Cogo points and alignments are in most cases interchangeable with horizontal 
edit points and alignments. There are a few key differences, however: 

 Cogo points are always numbered as you go 
 Cogo points can stand alone, such as when locating a 

fire hydrant or sign 

There are several toolbars devoted to coordinate geometry that will be used to 
either: 

 Define an alignment (figure) with Cogo commands or 
 Import Alignments and Cogo Points (.ics files) 
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Define an alignment (figure) with COGO commands 
You can define points for the alignment using one of the following tools: 

 Tools >Customize >Cogo Points 

 

 

 
Use New Cogo Point to store individual points by coordinates or by 
station and offset from an existing alignment  

 Locate (includes Traverse) 
 
Use Traverse commands to input cogo points by 
distance, direction, angle or chord from previous point. 
Use Add to Cogo Buffer or Radial options to define 
only cogo points. Use Insert Before or After Alignment 
to add new points to an existing alignment. 
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 Use other Locate commands to locate cogo points based 
on other points or alignments. For example, you can 
locate a new point based on the intersection of a 
direction from an existing cogo point to an alignment. 

 

When you have created the points you want, chain them together by storing 
an alignment: 

 Geometry >Utilities >Create/Edit Alignment by 
Cogo Points 

If you need to define easements, for example, you can use  
Geometry > Utilities to parallel existing alignments: 

 Alignment > Parallel Horizontal by Element or 
 Alignment > Parallel Horizontal by Station 
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Importing alignments and cogo points 
You can import alignments and cogo points by several methods. Before 
importing, however, you should check your InRoads preferences using: 

 Tools >Options >General and  
 Tools >Options >Geometry 

The most critical option is the northing/easting field if you’re bringing in 
any kind of ASCII data.  

 

You also want to check your lock settings. Turning Write lock on makes the 
import displays permanent and turning Report lock on (during some 
imports) opens a Results box that shows what is being imported. 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 14 

Read in the data using File >Import > Geometry. Import options include: 

 

 ICS for loading in cogo input files. 
 From Graphics for importing graphics as cogo points, 

alignments, or event points. 
 INR for loading ASCII inr files that were saved from 

InRoads. 
 Vertical from Surface for creating a vertical alignment 

that follows a DTMs elevations. 
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Styles 
Each alignment is assigned one style name. However, there are four available 
types of styles. For an alignment you will typically need at least three of them: 
points, lines and arcs. You may also need the fourth: spirals. Each of the 
styles must be created with the same name that you assign to the alignment. 

For cogo points that stand alone, such as a fire hydrant point, you only need to 
create a point style. 

Use Geometry >View Geometry >Geometry Style Manager to view your 
available CDOT geometry styles. 

 

Assign the new style to your alignment using Geometry >Active Geometry. 
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Display the alignment using either: 

  Geometry >View Geometry >Active Horizontal to 
display the alignment with no annotation, or  

 Geometry >View Geometry >Horizontal Annotation 
to display with annotation  

 

From the Main tab, select the alignment in the Annotate box, turn on the 
display options, then select the Annotate tab and choose the items for 
annotation. 

 

Note: If you do not want to assign the style to the alignment, you 
can display the alignment using the Active Style. 
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Generating Reports 
Several different types of geometry reports can be generated in InRoads with 
the following commands: 

 Geometry >Review Horizontal to generate a standard 
horizontal alignment report 

 

 Geometry >Review Vertical to generate a standard 
vertical alignment report 
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 Tools >Reports >Geometry to generate various 
DBAcess reports (Area, Coordinates, Traverse, 
Alignment, etc.) on alignments and points in the 
geometry project 
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 Tools >XML Reports to generate station/offset, 
clearance, stakeout and legal description reports 

 

 Tools >Run Macro to generate an intersecting 
alignments report 
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Lab 1.1 – Right Turn Lane 

Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 1.1. 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH52 

1. Set File of Type to Geometry Projects (*.alg). 

2. Highlight 12345 SH52.alg and then select Open. 

3. Cancel the Open dialog box. 

 
 

 

 

In this activity, you will create a right turn lane for West-bound 
SH52 to turn onto 71st Street. Your goal is to create a 300 foot turn 
lane that parallels SH52, with a symmetrical, 300’R reverse curve 
taper. You will be using the Horizontal Element tools to create the 
alignment. 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 24 

Copy the main alignment parallel 
The first step is to copy SH52 parallel to for the main part of the turn lane 
alignment that is offset 45’. Then, you will make another parallel copy, 
offset 33’ to serve as the starting alignment for the reverse curve. (The 
current outside lane line is 33’ from the centerline.) 

 

 

 

1. Choose Geometry > Utilities > Parallel Horizontal by Station. 

 

 

2. When prompted to Identify the Alignment, Data Point <D>on 
SH52. 
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3. When prompted to: 

 Identify first Station/Key in Station, key in 12000 
 Identify second Station/Key in Station, key in 12300 
 Identify location/Key in Offset, key in – 45 

Note: The negative is because the copy is on the left side of SH52. 

 Accept/Reject, <D>to accept the copy. 

The parallel copy is a new alignment, automatically assigned the 
name 1. 

Copy SH52 again for the approach to the turn lane. 
 

 

 

1. Choose Geometry > Utilities > Parallel Horizontal by Station. 

2. When prompted to Identify the Alignment, Data Point <D> on 
SH52. 

3. When prompted to: 

 Identify first Station/Key in Station, key in 12300 
 Identify second Station/Key in Station, key in 12500 
 Identify location/Key in Offset, key in – 33 

Note: The negative is because the copy is on the left side of SH52. 

 Accept/Reject, <D> to Accept the copy. 
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The parallel copy is a new alignment, automatically assigned the 
name 2. 

 

Copy alignment 2 into alignment 1 
Since you want to create one alignment, you will copy alignment 2 
into alignment 1. 

1. In the InRoads Explorer menu under the Geometry tab, right-click 
on alignment 1 and choose Set Active. 

 

2. Choose Geometry > Horizontal Element > Copy Element. 
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3. When prompted to Identify the Alignment, Data Point <D> on 
alignment 2. 

 

4. When prompted to: 

 Identify first Element, <D> on alignment 2. 
 Identify last Element, <D> on alignment 2 again. 

The first and last elements are the same in this case, since alignment 
2 consists of only 1 element. 

 Identify a point, Key in 0 
 Accept/Reject, <D> to accept the location. 

Alignment 2 is now a part of alignment 1, although there is still a gap 
between them. 

5. In the InRoads Explorer menu under the Geometry tab, right-click 
on alignment 2 and choose Delete.  
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6. When prompted, to delete it from the geometry project, select Yes. 

 

At this point, you will change the name of the alignment. 

7. Choose Geometry > Rename Geometry. 

 

8. Set the Type to Horizontal Alignment. 

Since 1 is the active alignment, it should show up in the From 
category automatically. If not, double-click it in the listing. 

9. In the To category, 

 Key in the Name WB SH52 to 71st RT turn-H 
 Key in the Description RT turn lane alignment 
 Select the Style ALG_OTHER. 
 Choose Apply. 

 

10. When prompted to rename the alignment, select Yes. 

 

11. Close the dialog. 
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Create a curve using Horizontal Elements 
If you want to maintain the 300’ turn lane length, you must start the 
reverse curve at the current end of the 300’ section. To do this, you 
will create a separate curve and move it to the proper location. 

1. Choose Geometry > Horizontal Element > Add Fixed Curve. 

 

 

2. Set the Mode to By Two Points and Radius. 

3. At the bottom of the dialog, key in the Radius 300 

4. Apply. 
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5. When prompted to: 

 Identify first point, <D> in a clear area away from the 
alignment for the first point. As shown in the previous 
diagram. 

 Identify second point, <D> a short distance away from 
the first point to define the curve. 

 Accept/Reject, <D> to Accept the new curve. 
 Reset <R> and Close the Add Fixed Curve dialog. 

1 
2 
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Move the curve into the proper location. 
1. Choose Geometry > Horizontal Element > Connect Elements. 

  

 

2. When prompted to: 

 Identify element, <D> on the curve near the beginning. 
 Identify alignment, <D> on the 300’ section of turn 

lane, near the end. 
 Accept/Reject <D> to Accept. 

 

1 

2 
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Close the gap with a Free Curve 
To finish the reverse curve, you will now close the gap using the 
Free Curve command. 

1. Choose Geometry > Horizontal Element > Add Free Curve. 

 

 

2. Key in a Radius of – 300 

The negative is because the curve goes to the left. 

3. Choose Apply. 

4. When prompted to: 

 Identify first element, <D> near the end of the curve 
you just created. 

 Identify second element, <D> on the element which 
was formerly alignment 2. 

 Accept/Reject <D> to Accept. 
 <R> then Close the Add Free Curve dialog. 
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Track the alignment 
1. In the InRoads Explorer menu under the Geometry tab, right-click 

on alignment SH52-H and choose Set Active. 

2. Select Utilities > Tracking > Horizontal Alignment. 

3. <D> on the new turn lane alignment. 

4. Move your cursor back and forth, noting the offset. When you select 
a second alignment in the tracking command, the offset shows the 
distance between the active alignment and the chosen one. 

 

5. <R> out of the tracking command. 

6. Save your geometry project. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data file. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 1.2 – Horizontal Alignment for Ramp A 

Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 1.2. 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry projects 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight SH119 NB.alg and then select Open for the North bound 
alignment. 

4. Highlight SH119 SB.alg and then select Open for the South bound 
alignment. 

5. Highlight SH52.alg and then select Open for the highway 52 
alignment. 

6. Cancel the Open dialog box. 

Create a new geometry project for the interchange 
geometry 

1. Select File > New. 

 

2. On the Geometry tab: 

 Set Type to Geometry Project. 
 Key in a Name of 12345 SH119 SH52 

Interchange. 
 Key in a Description of Ramp alignments for 

SH119 and SH52. 

3. Select Apply, then Close. 
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Copy the roadway alignments for reference 
1. Select Geometry > Copy Geometry. 

 

2. Select the Horizontals tab: 

 Set the From Geometry Project to 12345 SH119 NB. 
 Double-click the Alignment SH119 NB-H. 
 Toggle on Include All Children. 
 Set the To Project to 12345 SH119 SH52 Interchange. 

If the To Alignment name doesn’t show up, double-click the 
alignment again in the From category. 

 Choose Apply. 
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3. Repeat this process to copy the SH119 SB alignment, and again to 
copy the SH52 alignment. 

 

View the associated alignments 
1. In the InRoads Explorer menu, right-click and View SH119 SB, 

SH119 NB and SH52. 
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2. Station any of the alignments you would like. (Geometry > View 
Geometry > Stationing). 
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Create a new alignment slot for ramp A 
1. Make certain your interchange geometry project is active. 

2. Select File > New. 

 

3. Set Type to Horizontal Alignment. 

4. Key in a Name of RampA-H 

5. Key in a Description of RampA from SH119 NB to SH52 

6. Set Style to ALG_OTHER. 

7. Select Apply, then Close. 
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Develop ramp using Elements 
First you’ll set a tangent at the beginning of the ramp and another, 
separate one at the end of the ramp. 

1. Select Geometry > Horizontal Element > Add Fixed Line. 

 

 

2. Set the Mode to By Two Points. 

3. Choose Apply. 

4. Key in so=128111.83,24,0,SH119 NB-H 

5. Key in so=128257.83,36,0,SH119 NB-H 
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6. <D> to accept the new tangent which defines the taper at the 
beginning of the ramp. 

 

7. <R> to stop the next tangent. 

Note: If you Reset twice, and the dialog pops back up, you’ll need 
to Apply Again. 

8. Key in so=10944.56,0,0,SH52-H 

9. Key in di=140,S40^06'58.54"W 
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10. <D> to accept the tangent that defines the end of the ramp. 

 

11. <R> twice, then Close the command. 

12. Now, you will modify each of the tangents. The first one is not long 
enough, so you will lengthen it to 500’. The second tangent is placed 
in the wrong direction, so you will transpose it. 
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13. Select Geometry > Horizontal Element > Edit Element. 

 

 

The first element is automatically highlighted.  

14. Set the Define From to Start. 

15. Change the Length to 500 

16. Choose Apply. 
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17. Select Next (or Last) to go to the second tangent. 

 

Notice the Direction is SW. 

18. Select Transpose. 

 

Notice the Direction changes to NE. 

19. Close the Edit Element dialog. 
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Add Curves 
Next, you’ll add curves between the two alignments. In this example, 
you know the radii of the curves, so you will add them to each 
current tangent, then close the gap between the curves with a new 
tangent. 

Since you want to maintain the current lengths of the tangents, you 
cannot use the Add Floating Line or the tangent length is adjusted. 
Instead, you will place the curves by themselves, then connect them 
to the existing tangents. 

1. Choose Geometry > Horizontal Element > Add Fixed Curve. 

 

 

2. Set the Mode to By Two Points and Radius. 

3. Key in a Radius of 4000 

4. Place the two points anywhere in the area. You do not need to place 
the curve at the end of the tangent. 
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5. <D> to Accept the curve. 

 

6. <R> to bring the dialog back up. 
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7. Repeat the process, but change the Radius to -3500 for the next 
curve. (It’s a curve to the left, so don’t forget the negative sign). 

 

8. Close the Add Fixed Curve dialog. 

Next, you’ll connect the curves to their respective tangents. 

9. Select Geometry > Horizontal Elements > Connect Elements 

 

10. Pick the beginning of the first curve with a <D> for the element. 

11. Pick the end of the first tangent with a <D> for the alignment. 
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12. If the curve moves to the correct location, Accept it with another 
<D>. 

 

13. Repeat the process to move the second curve to the second tangent. 

 

14. Connect the curves with a tangent. 
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15. Select Geometry > Horizontal Elements > Place Free Line. 

 

16. <D> on the 4000’ radius curve. 

17. <D> on the -3500’ radius curve. 

 

The tangent between the two curves is added to the alignment. 
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Set the stationing on Ramp A 
1. Select Geometry > Horizontal Curve Set > Stationing. 

 

2. For the Starting Station, key in 3281+11.83 to match the 
stationing of SH119 NB at the beginning of the ramp. 

3. Select Apply. 

4. Close the dialog. 

5. Save the geometry project. 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data file. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Challenge Lab 1.3 – Creating an alignment with 
Horizontal Elements 

In this activity, you will create a horizontal alignment using the Horizontal 
Element tools. 

 

Given: 12345 71st.alg – This geometry project contains the 
horizontal alignment for 71st Street. 

Diagram showing pertinent information about the 
alignment. 

 

Required: Hotel-H – You will create alignment for the Hotel 
Access road that starts perpendicular to the 71st-H 
alignment at station 602+00. It has a 60’ initial tangent, 
then reversing 150’ radius curves and ends at the 
coordinates shown. 
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Preliminary set-up 
1. Start MicroStation InRoads and open the file 

12345DesignModel01.dgn. 

2. Select File >Project Defaults. 

3. Set the Configuration Name to 1.3 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

4. Select Apply. 

Important!  Verify your dialog box appears as shown: 

 

5. Open the appropriate data files (refer to Given statement). 
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Create the alignment 
1. Using the information provided, create the alignment with horizontal 

element tools. 

Alignment Hotel-H begins 
at Station 602+00 on 
Alignment 71st-H and is 
perpendicular at that point 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 58 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 59 

Lab 1.4 – Creating horizontal and vertical alignments 
from graphics 

In this activity, you will use a 3-dimensional graphic element to create 
horizontal and vertical alignments. The example you will use is an outline of 
a median in SH52. Since you initially are given a 2-dimensional outline, you 
must add elevations by draping the outline on the surface of SH52 prior 
importing the outline to create horizontal and vertical alignments. 

 

 

 

 

 

Median 1 is 
in this area Median 3 is 

in this area 

Median 2 is 
in this area 
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Start MicroStation InRoads 
2. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

3. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

4. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 1.4 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load the SH52 DTM 

4. Select File > Open. 

5. Set File of Type to Surfaces (*.dtm). 

6. Highlight SH52 top.dtm and then select Open. 

7. Do not cancel out of the dialog box. 

Load geometry project for SH52 

8. Set File of Type to Geometry Projects (*.alg). 

9. Highlight 12345 SH52.alg and then select Open. 

10. Cancel the Open dialog box. 

Attach the median reference 
11. In MicroStation, select File > Reference. 

 

12. In the References dialog box, select Tools > Attach. 

13. In the Attach Reference dialog, set the directory path to 
C:\Projects\12345\Miscellaneous. 
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14. Highlight the file 12345DesignMedian01.dgn. 

 

15. Set the other options as shown. 

16. Select OK. 

17. Window in on the first median outline near the beginning of SH52. 
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Drape the median onto the SH52 surface 
Assign elevations to the graphic by draping it onto the SH52 surface. 

1. View the contours for SH52 top  
(Surface > View Surface > Contours). 

 

2. Toggle on View 8. 

 

3. Set the Locate lock to Locate Graphics. 
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4. Select Surface > Design Surface > Drape Surface. 

 

 Set the Destination Surface to SH52 top. 
 Set Input Mode to Single. 
 Set Destination Level to DES_ROADWAY_Misc. 
 Apply. 
 When prompted to Identify Element, <D> on the 

median outline in View 1 (the Top View). 
 <D> to accept. 

5. Close the Drape Surface box. 
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Notice in View 8, you can see that the outline has been draped onto 
the surface. 

 

6. Select References. 

 

7. Toggle off the Display of the Reference File. 
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Import the median as an alignment 
1. Select File > Import > Geometry. 

 

2. Select the From Graphics tab: 

 Set Type to Horizontal and Vertical Alignment. 
 Key in a Name of SH52 median 01 
 Key in a Description of Alignment for median 

Start 100+00 
 Set Style to ALG_Other. 
 Make sure the Geometry Project is set to 12345 SH52. 
 Set the other options as shown. 
 When prompted to Identify Element, <D> on the 

median outline. 
 <D> to accept. 
 <R> when done. 
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3. Check your geometry project in the InRoads Explorer window. 

 

You now have horizontal and vertical alignments for the median. 

4. Close the Import Geometry box. 

Evaluate the alignments 
1. View the Horizontal Alignment. 

2. View triangles for SH52 top. 

3. Window in and notice where there are vertices in the alignment.  

When you import a graphic, it creates a PI everywhere there was a 
vertex in the original element. When you drape an element, it picks 
up a vertex everywhere there is a triangle crossing, plus it segments 
any arcs. That’s why in the curves there are more PIs. 

4. Review the vertical alignment. 

Notice the VPIs are at all different elevations. 

5. Repeat this process for the other medians. 

6. Save the geometry project. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data file. 

1. From MicroStation, select File > Exit 

2. If prompted to save data files select Yes. 
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Lab 1.5 – Create an alignment using Cogo commands 

Start MicroStation InRoads 

1. Select Start > All Programs > Bentley Civil Engineering > Bentley 
InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 1.5 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 

 

Load data files 

Load geometry project for SH52 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH52.alg and then select Open. 

4. Cancel the Open dialog box. 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 71 

Create an alignment for 71st Street using Cogo 
commands 

 
The finished alignment appears as shown. Refer to this diagram as needed. 

 

7112 7111 

7110 

7113 

7120 7132 

7131 

7130 

7133 

7140 

7100 
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Preliminary set-up 

Create a new geometry project for 71st Street 

1. Select File > New. 

 

On the Geometry tab: 

 Set Type to Geometry Project. 
 Key in a Name of 12345 71st Street 
 Key in a Description of Alignments for 71st  
 Select Apply, then Close. 
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Copy the roadway alignments for reference 

2. Select Geometry > Copy Geometry. 

 

3. Select the Horizontals tab 

 Set the From Project to 12345 SH52. 
 Double-click the Alignment SH52-H. 
 Toggle on Include All Children. 
 Set the To Project to 12345 71st Street. 

Note: If the To Alignment name doesn’t show up, double-click the 
alignment again in the From category. 

 Choose Apply. 
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View SH52 for reference 

 

4. Right-click SH52-H in the InRoads Explorer menu and choose View. 

Station the alignment if desired. 

5. Right-click on 12345 71st Street in the InRoads Explorer menu and 
choose Set Active. 

 

Set locks 

6. Toggle on Report lock. 

7. Toggle on Write lock. 
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Note: Throughout this exercise, you can choose the cogo 
commands from the pull-down menu or from one of the 
cogo toolbars. To access the toolbars choose Tools > 
Customize and toggle on Cogo Points and Locate. 

 

If, at any time, you make a mistake and need to delete a cogo point, 
you can use Geometry > Cogo Points Delete. 

 

Key in the number of the points you want to Delete, or choose Filter 
and you can pick them from a list of available points. 

 

Once selected, choose Apply, then confirm to delete the selected 
points. 
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Establish the POB for 71st Street 
1. Select Geometry > Cogo Points > New. 

 

 

 Set the Define By to Northing/Easting. 
 Key in the name 7100 
 Key in a Northing coordinate of 290197.3900     
 Key in an Easting coordinate of 135445.7850 
 Key in a Description of POB 71st 
 Select a Style ALG_PRO. 

2. Select Apply. 
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The cogo point is created and a Results box will appear confirming 
that the point was established. 

 

Note: Do not close the Results box, just slide it over to the side. It 
appears because the Report lock is on, and will continue to 
re-appear with every command if you close it. If you leave it 
open, it creates a running list of everything you have done 
with Cogo commands. 

3. Close the New Cogo Point dialog. 
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Establish the PI for the first curve using a distance and 
direction from the POB 

1. Select Geometry > Traverse. 

 

 

 Set the Method to Direction. 
 Set Insert Point to Cogo Buffer. 
 For the Occupied Point, key in 7100 or toggle on 

Point Snap and use the Target Button to choose the 
point graphically. 

 For the Direction, key in N  0 33 14.23 E 

Notes: Alternate formats for direction input include:  
N  0^33'14.23" E or N  0-33-14.23 E 
 
If you want to see the two decimal place precision readout in 
the dialog box, change your Angular precision under 
 Tools > Options. 

 Set the Distance Type to Horizontal Distance. 
 Key in a Horizontal Distance of 345.98 
 Key in a Foresight Point 7110 
 Key in a Description PI 71st 
 Select a Style ALG_PRO. 
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2. Select Apply. 

 

The second point is created. On your screen, you should see a 
reference line showing the point from which the new one was 
located. It is not visible here and won’t be on your screen after you 
zoom in, out or update. The Results box also shows the point was 
created. 

 

3. Close the Traverse dialog. 
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Establish the point where the alignment crosses SH52 
1. Select Geometry > Locate > Intersection. 

 

 

 Set the Type to Direction/Alignment. 
 Key in the name 7110 
 Key in the Direction N 16 53 08.54 E 
 Set the Alignment Name to SH52-H. 

2. Select Apply. 

3. When the Locate Results box appears, 

 

 Key in a Point Name 7120 
 Key in a Description 71st crossing with SH52 
 Select a Style ALG_PRO. 
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4. Select Accept. 
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Establish the North side of SH 52 
For the North side of SH52, you will establish the end point first, 
then use directions from point 7120 and the POE to determine the PI 
for the curve. 

1. Select Geometry > Cogo Points > New. 

 

 Set the Define By to Northing/Easting. 
 Key in the name 7140 
 Key in a Northing coordinate of 291351.9891      
 Key in an Easting coordinate of 135964.7757 
 Key in a Description of POE 71st 
 Select a Style ALG_PRO. 

2. Select Apply. 
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Establish the PI for the curve North of SH52 using 
directions from two known points. 

1. Select Geometry > Locate > Intersection. 

 

2. Set the Type to Direction/Direction. 

3. In the Direction 1 category, 

 Key in the name 7120 
 Key in the Direction N 16 51 35.36 E 

4. In the Direction 2 category, 

 Key in the name 7140 
 Key in the Direction S 58 34 54.02 W 

5. Select Apply. 
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6. When the Locate Results box appears, 

 

 Key in a Point Name 7130 
 Key in a Description PI 71st 
 Select a Style ALG_PRO. 

7. Select Accept. 

 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 85 

Create PCs and PTs and CCs for the two curves on 71st 
1. Choose Geometry > Locate > Fit Curve. 

 

 

2. Set the Solve By option to Points of Intersection 

 For Point 1, key in 7100 
 For Point 2, key in 7110 
 For Point 3, key in 7120 
 For the Radius, key in 1016 

3. Select Apply. 
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4. When the Locate Results box appears, 

 

 Key in a Point Name of 7111 

The Point Name of 7111 is a seed name. In this case, the PC will be 
7111, the CC 7112 and the PT 7112. 

 Select a Style ALG_PRO. 

5. Select Accept. 
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6. Repeat for the second curve, using Points of Intersection 7120, 
7130 and 7140 and a radius of 450 as shown. 
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Create a name for the new alignment in the geometry 
project 

1. Select File > New. 

2. Select the Geometry Tab. 

 

 Set the Type to Horizontal Alignment. 
 Key in the name 71st ST-H 
 Key in a Description of 71st Street Horizontal 
 Select the Style ALG_PRO. 
 Leave the Curve Definition set to Arc 
 Select Apply. 

3. Close the dialog. 
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Create the alignment from cogo points 
1. Select Geometry > Utilities > Create/Edit Alignment by Cogo 

Points. 

 

2. Click in the Alignment Definition field and key in (7100 7111 
C7112R 7113 7120 7131 C7132R 7133 7140) 
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3. Choose Apply. 

 

Since the Report lock is on, the Results box will appear showing the 
alignment you just created. 

 

4. Close the dialogs. 

7112 7111 

7110 

7113 

7120 7132 

7131 

7130 

7133 

7140 

7100 
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5. Save the Geometry Project. 

 

Station the alignment 
For the stationing of 71st Street, you know that you want the station 
where the alignment crosses SH52 to be 600+00. You will next use 
the Stationing command to accomplish this. 

1. Toggle on Point Snap. 

 

 

2. Select Geometry > Horizontal Curve Set > Stationing. 

 

Note:  The Starting Station is 0+00. If you knew the starting station, 
you could key it in. However, you will instead let InRoads 
calculate the starting station from the stationing of a known 
point. 
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3. Select the larger target button next to the Name and Coordinate 
information. 

4. Data point <D> in the design file near the point where SH52 and 71st 
cross. 

 

7120 should show up in the Name field. (You could have also just 
keyed in 7120, since you know the number of the point where the 
alignments cross. 

5. Key in 600+00 for the Starting Station. 

6. Choose Apply. 

 

Note:  The Stating Station is ‘backed out’ from the crossing point. 

7. Save the geometry project again. 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All 

2. Select the MicroStation Delete command 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit 

2. If prompted to save data files select Yes. 
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Lab 1.6 – Importing a text file for alignments 
In this activity, you will create horizontal and vertical alignments using an 
@ (‘at’) file. This is a text file that contains key-ins. You run the @ file 
while in a command and it is just like typing all of the key-ins interactively. 
Any MicroStation or InRoads key-in commands can be used in an @ file. 

 
 

SH119 SB 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 1.6 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 

 

Load data files 

Load the existing surface 

4. Select File > Open. 

5. Set File of Type to Surfaces (*.dtm). 

6. Highlight 12345 Exist01.dgm and then select Open. 

7. Cancel the Open dialog box. 
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Create geometry slots for SH119 SB 
You will now create a geometry project and alignments slots for State 
Highway 119 South Bound. 

Create a new geometry project 

1. Select File > New. 

On the Geometry tab: 

 Set Type to Geometry Project. 
 Key in a Name of 12345 SH119 SB 
 Key in a Description of SH119 Southbound H, V 

and Super Alignments 
 Select Apply. 

 

Create a new alignment slot for 119 Southbound 

2. Set Type to Horizontal Alignment. 

3. Key in a Name of SH119 SB-H 

4. Key in a Description of SH119 Southbound Horizontal 

5. Set Style to ALG_PRO. 
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6. Select Apply. 

 

7. Close the New dialog box. 
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Develop the Horizontal Alignment using an @ file 
You’ll use the Horizontal Curve Set tools to create the SH119 SB alignment. 
However, instead of keying in coordinates or bearings and distances, you’ll 
use a text or script file to store your entries. 

Create the script file (the @ file) 

1. From the Windows Start Menu select  
Start > All Programs > Accessories > Notepad 

2. In Notepad, enter in the following MicroStation keyins for the 
alignment PIs (use one line per keyin): 

NE=289184.6080,132631.7364 

NE=289525.5179,132919.9741 

NE=290191.7996,133506.8008 

NE=291156.9336,134231.0714 

NE=293286.1622,136058.1053 

NE=293612.6184,136330.6524 

 

3. In Notepad, Select File > Save As. 

 

4. Set the Save in folder to C:\ 

 

5. Key in a File Name of SH119SBPIs.txt 

6. Make sure the Save as Type option is set to Text Document (*.txt). 

7. Select Save. 

8. In Notepad, select File > Exit. 
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Create the alignment PIs using the script file 

9. Set the Snap lock to No Snap. 

 

10. Select Geometry > Horizontal Curve Set > Add PI. 

11. In the Key-in box, key in @C:\SH119SBPIs.txt 

 

Note:  The @ symbol is used to designate a MicroStation script file. 
The directory must be typed in exactly specifying where the 
script file was stored in order to be executed. For ease of 
typing, you stored the file in the c:\ directory. Normally, this 
file would be stored in your project directory. The NE= 
keyins from the script file are processed in order and the 
alignment is created. 

12. <R> to exit the Add PI command. 

13. From the InRoads Explorer, click the Geometry tab, right-click on 
the SH119 SB-H alignment and select Fit. 
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Create the alignment curves 

14. Select Geometry > Horizontal Curve Set > Define Curve. 

The first set of tangents highlight (on south end of alignment). 

15. In the Horizontal Curve section of the dialog box (lower half): 

 Set Define by to Radius. 
 For Radius 1 key in 14000 
 Set all other options as shown. 

  

16. Apply. 

17. Select Next. 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 103 

18. Repeat the process and set the following radii for the remaining 
curves (don’t forget to Apply after each curve): 

 Curve 2: For Radius 1 key in 14000 
 Curve 3: For Radius 1 key in 14062 
 Curve 4: For Radius 1 key in 14000 

19. Close the Define Curve dialog. 

Set the beginning station 
The beginning station is set to match the stationing of the existing 
alignment. 

1. Choose Geometry > Horizontal Curve Sets > Stationing. 

2. Set the Starting Station to 226768.93 

 

3. Choose Apply. 

4. Close the Stationing dialog box. 
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Save geometry project 
1. Select File > Save > Geometry Project. 

2. On the resulting dialog, make certain the Active project is  
12345 SH119 SB and the file name is 12345 SH119 SB.alg. 

 

3. Choose Save. 

4. Cancel the Save As dialog box. 

Create a profile of the horizontal showing existing 
1. Select Evaluation > Profile > Create Profile. 

2. Select Preferences, highlight the 2x Vertical preference, then Load 
and Close. 
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3. On the Main tab: 

 Verify that Alignment is SH119 SB-H. 
 Key in a Set Name of SH119 SB Working 
 Toggle on the surface 12345 Exist01. 

 

4. Apply and then <D> for the location of the lower left corner of the 
profile. 

 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 106 

Create a slot for the vertical alignment 
1. Select File > New. 

2. Select the Geometry tab 

 Set Type to Vertical Alignment. 
 Key in a Name of SH119 SB-V 
 Key in a Description of SH119 Southbound 

Vertical 
 Set Style to ALG_PRO_Vert. 

 

3. Select Apply. 

4. Close the dialog box. 
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Develop the Vertical alignment using an (@ file) 

Create the script file 

1. Start Notepad 

2. In Notepad, enter in the following MicroStation keyins for the 
alignment PIs (use one line per keyin): 

SE=2269+50.00,5160.057 

SE=2276+00.00,5174.084 

SE=2290+00.00,5161.110 

SE=2315+75.00,5148.220 

SE=2320+00.00,5138.694 

SE=2323+80.00,5137.140  

 

3. In Notepad, Select File > Save As. 

 Set the Save in folder to C:\ 
 Key in a File Name of SH119SBVPIs.txt 
 Make sure the Save as Type option is set to Text 

Document (*.txt). 

4. Select Save. 

Create the vertical PIs using the script file 

5. Select Geometry > Vertical Curve Set > Add PI. 

6. On the Dynamic Settings box, choose Apply. 

7. Click in the MicroStation key-in field and key in  
@C:\SH119SBVPIs.txt 

The keyins from the script file are processed in order and the 
alignment is created. 

8. Reset twice, then Close the Add Vertical PI dialog to stop the 
command. 
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9. Window around the beginning of the profile to see the vertical 
alignment (red graphic). 

 

Add curves to the vertical alignment 

10. Select Geometry > Vertical Curve Set > Define Curve. 

The first set of tangents highlight (on left end of alignment). 

11. In the Vertical Curve section of the dialog box (lower half): 

 Set Calculate by to Length of Curve. 
 For Length key in 900 
 Set all other options as shown. 

 

12. Apply. 

13. Select Next. 

14. Repeat the process and set the following radii for the remaining 
curves (don’t forget to Apply after each curve): 

 Curve 2: For Length key in 210 
 Curve 3: For Length key in 440 

 Curve 4: For Length key in 340 
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15. Close the Define Curve dialog. 

 
The four curves appear blue on the profile. 

Annotate the vertical alignment 
1. Select Geometry > View Geometry > Vertical Annotation. 

2. Select Preferences, highlight the Proposed preference and Load. 

 

3. Verify that the horizontal and vertical alignments and profile set are 
as shown. 
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4. Apply the command. 

 

The vertical alignment is displayed and annotated with the proposed 
preference. 

5. Window in to take a closer look at the vertical alignment on the 
profile. 

 

6. Close the Vertical Annotation box. 

Save the geometry project 
1. Select File > Save > Geometry > Geometry Project. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data file. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 1.7.1 – Using .ics files to create horizontal and 
vertical alignments – SH119 NB 

 

 

 
 

SH119 NB 
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Start MicroStation InRoads 

1. Select Start > All Programs > Bentley Civil Engineering > Bentley 
InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 113 

Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 1.7.1 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH119 SB 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH119 SB.alg and then select Open. 

4. Do not cancel out of the dialog box. 

Load the existing DTM 

5. Set File of Type to Surfaces (*.dtm). 

6. Highlight 12345 Exist01.dtm and then select Open. 

7. Cancel the Open dialog box. 

View SH119 Southbound for reference 

 

1. Right-click on SH119 SB-H in the InRoads Explorer menu and select 
View. 
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Create geometry project for SH119 NB 
1. Select File > New 

2. On the Geometry tab: 

 Set Type to Geometry Project. 
 Key in a Name of 12345 SH119 NB 
 Key in a Description of SH119 Northbound H, V 

and Super Alignments 

 

3. Select Apply, then Close the New dialog box. 
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Develop Horizontal Alignment given an ics file 
Instead of using the Horizontal Curve Set tools to create the State Highway 
119 North Bound alignment, or using a script file (@ file), you’ll import an 
ICS file that stores COGO coordinates and commands to create the 
alignment. 

Import the ICS file to create the alignment 

1. Toggle on the Report lock. 

 

2. In InRoads, select File > Import > Geometry. 

3. Select the ICS tab. 

4. Click in the Filename field and select Browse. 

5. Set the Look in folder to 
C:\Projects\12345\Design\InRoads\1.7.1 

6. Choose the file SH119 NB bearing distance.ics and then select 
Open. 
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7. Select the Preview button. 

The Preview function uses Notepad to open the file. This file 
contains COGO commands for storing PIs as well as commands for 
joining the points to create the alignment with curves. Finally, it will 
plot the alignment using the specified geometry style. 

 

8. When finished reviewing the .ics file, select File > Exit from 
Notepad. 
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9. Select Apply to import the ICS file. 

Notice the Results dialog telling you what has happened with the .ics 
file. This dialog appears because the Report lock is on. 

 

10. Close the Results box. 

11. Close the Import Geometry box. 
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View the alignment 
1. From the InRoads Explorer, select the Geometry tab. 

2. Expand the 12345 SH119 NB geometry project to find the  
119 alignment. 

 

The ICS import command automatically creates the alignment slot 
name and imports the data to create the alignment.  ICS files do not 
function well with alphanumeric names for the alignment, so here 
you are using 119 and will change it with Rename Geometry in a 
later step. 

3. Right-click on the 119 alignment and select View. 

4. Fit the view. 

 

5. Notice that the alignment has problems – it is far too long for this 
project so you must review the alignment and then look at the .ics 
file to find out the problem. 
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Review the Alignment 

1. From the InRoads Explorer, right-click on the alignment and select 
Review. 

 

2. Look at the first tangent. The length is obviously suspect. 

  

3. Close the Review Horizontal Alignment dialog box. 
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Delete the alignment graphics 
1. Select MicroStation’s Delete Element command. 

2. <D> on the SH119 NB-H alignment graphic to delete it. 

 

Delete this graphic 
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Correct the error in the .ics file 

Open the file in Notepad 

1. Select File > Import > Geometry. 

2. On the ICS tab, Browse to select the 
C:\Projects\12345\Design\InRoads\1.7.1\ 
SH119 NB bearing distance.ics ICS file again if it is not already 
selected. 

3. Select Preview. 

In Notepad, notice the first tangent length under the Locate 
Direction command is 7177.325. That is obviously an error. Upon 
investigation, you discover that the decimal is in the wrong place and 
the figure should be 717.7325. 

  

4. Change the first tangent to 717.7325 

5. In Notepad, select File > Exit and then select Yes to save changes. 
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Run .ics file again 

6. Select Apply to re-import the alignment. 

The alignment is replaced in the geometry project with the updated 
alignment from the ICS file. 

Notice in the Results box that the alignment and cogo points were 
deleted. This is because of the Del Figure and Del Coordinate 
commands that are at the top of the .ics file. 

 

7. Close the Results box. 

8. Close the Import Geometry box. 
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View the Alignment 
1. From the InRoads Explorer, select the Geometry tab. 

2. Right-click on the 119 alignment and select View. 

3. Fit the view. 

Notice that the alignment now displays correctly. 

 

 

SH119 South Bound

SH119 North Bound
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Rename the alignment 
Since the alignment is now correct, you can rename it to the 
appropriate name. After renaming it, if the .ics file needs to be run 
again, you must manually delete the alignment first. 

1. Select Geometry > Rename Geometry. 

2. Set the Type to Horizontal Alignment. 

3. Set the From to 119. 

4. Under the To category, key in SH119 NB-H 

 

5. Choose Apply. 

 

6. Select Yes when asked if you want to make the change and write it to 
disk. 

7. Close the Rename Geometry dialog. 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 126 

Save geometry project 
1. Select File > Save > Geometry Project. 

Create a profile of the horizontal showing the existing 
ground 

1. Select Evaluation > Profile > Create Profile. 

2. Select Preferences, highlight the 2x Vertical preference, then Load 

On the Main tab: 

 Verify that Alignment is SH119 NB-H. 
 Key in a Set Name of SH119 NB-H Working 
 Toggle on the surface 12345 Exist01. 

 

3. Apply and then <D> for the location of the lower left corner of the 
profile. 

4. Close the Create Profile box. 
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Update the Profile with the CL of SH119 SB 

Copy the SB alignment into the NB project 

1. For reference, you will next display the vertical alignment elevations 
of SH119 SB onto the profile of SH119 NB. In order to do this, both 
horizontals have to be in the same geometry file. Therefore, you will 
first copy the southbound alignment into the northbound geometry 
project. 

2. Select Geometry > Copy Geometry. 

 

3. Select the Horizontals tab. 

 Set the From Geometry Project to 12345 SH119 SB. 
 Highlight the alignment SH119 SB-H. 
 Set the to Geometry Project to 12345 SH119 NB. 

4. Select Apply, then Close. 
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Project the SB Vertical onto the NB Profile 

5. Select Evaluation > Profile > Alignments to Profile. 

 

6. Verify that the Profile Set is SH119 NB-H Working. 

7. <D> in the Alignment to Project field and select Filter. 

 

8. Highlight SH119 SB-H on the left and select Add. 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 129 

9. Select OK. 

 

10. Apply, then Close the Alignments to Profile box. 

11. Zoom in to the beginning of the profile. 

 

 

The profile is updated with the South Bound centerline vertical 
alignment. This command can be used to project any vertical 
alignment onto the profile of another horizontal. 

SH119 SB 
Centerline
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Develop the Vertical using an .ics file 
Instead of using the Vertical Curve Set tools or a script file, you’ll 
create the vertical alignment for SH119 NB by importing an ICS file. 

1. Verify that the SH119 NB-H horizontal alignment is active. 

 

2. Select File > Import > Geometry. 

3. Select the ICS tab. 

4. Click in the Filename field and select Browse. 

5. Set the Look in folder to 
C:\Projects\12345\Design\InRoads\1.7.1 

6. Choose the file SH119 NB V.ics and then select Open. 
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7. Select the Preview button. 

 

The ICS file contains commands for creating a vertical alignment 
similar to those used to create the horizontal. 

8. When you’ve finished review the ICS file, select File > Exit from 
Notepad. 

9. Select Apply to import the ICS file. 

 

The Results box, detailing all of the vertical geometry, appears since 
the Report lock is on. 

10. Close the Results box. 

11. Close the Import Geometry box. 
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Rename the alignment 
After renaming the vertical alignment, if the .ics file needs to be run 
again, you must manually delete the alignment first. 

1. Select Geometry > Rename Geometry. 

2. Set the Type to Vertical Alignment. 

3. Set the From Vertical Alignment field to 119. 

4. Under the To category, key in SH119 NB-V for Name. 

5. Set Description and Style as shown. 

 

6. Choose Apply, then Yes when asked if you want to make the change 
and write it to disk. 

 

7. Close the Rename Geometry dialog. 

8. Save the Geometry Project. 
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View the alignment 
1. From the InRoads Explorer Geometry tab, expand the SH119 NB-H 

horizontal alignment to see the vertical alignment that you just 
imported. 

2. Right-click on the SH119 NB-V alignment and select View. 

 

3. Window in on the SH119 NB-H Working profile to see the vertical 
alignment. 
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Annotate the vertical alignment 
1. Select Geometry > View Geometry > Vertical Annotation. 

2. Select Preferences, highlight the Proposed preference and Load. 

3. Verify that the horizontal and vertical alignments and profile set are 
as shown. 

 

4. Apply the command. 

 

The SH119 NB vertical alignment is displayed and annotated with 
the proposed preference. 
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Save geometry project 
1. Select File > Save > Geometry Project. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Challenge Lab 1.7.2 – Create .ics files for SH52 
Horizontal and Vertical alignments 

In this activity you will develop .ics files and import them to create a horizontal 
and a vertical alignment for SH52. You will be given information about the 
alignments in electronic form to minimize the typing. 

 
 

SH52 
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Start MicroStation InRoads 

1. Select Start > All Programs > Bentley Civil Engineering > Bentley 
InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Design\Working. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 1.7.2 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry projects for SH119 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH119 NB.alg and then select Open. 

4. Highlight 12345 SH119 SB.alg and then select Open. 

5. Do not cancel out of the dialog box. 

Load SH119 DTMs 

6. Set File of Type to Surfaces (*.dtm). 

7. Highlight 12345 SH119 NB top.dtm and select Open. 

8. Highlight 12345 SH119 SB top.dtm and select Open. 

9. Do not cancel out of the box. 

Load the existing DTM 

10. Highlight 12345 Exist01.dtm and then select Open. 

11. Cancel the Open dialog box. 
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Create a new geometry project for 12345 SH52 
1. Select File > New and set the Geometry tab as shown: 

Note: The entire Description is SH52 H, V, and Super 
Alignments. 

 

Create an ics file for the SH52 horizontal alignment 
1. Start Notepad and open the file SH52coordinates.txt. 
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This file lists the Coordinates for the key points in SH52.  

2. Using this information, your .ics file handout and what you have 
learned about .ics files, edit this file to make it into an .ics file that 
will create the horizontal alignment for SH52. For visual reference, 
you can use the picture below.  

Note:  Name the alignment 52 instead of SH52-H until you have it 
imported correctly. 

 

CC 5002 

PT 5203 
POB 5200 

PC 5204 

PT 5206 

POE 5207 

CC 5205 

PC 5201 
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3. When you are ready to test your file, select File > Save As and save 
the file. Name it SH52 HA coord.ics 

 

Import your .ics file for SH52-H 

1. In InRoads, select File > Import > Geometry. 

2. On the ICS tab, import the file SH52 HA coord.ics from the 
C:\Projects\12345\Design\InRoads\1.7.2 folder. 

The alignment is created and set active in the geometry project. If 
Auto Plot is toggled on in the .ics file, the alignment is automatically 
displayed along with the points used to form it. 

 

SH52 Horizontal Alignment 
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3. If something went wrong with your .ics file, you can Preview it from 
the Import dialog. This opens it in Notepad where you can make 
edits, Save them, Close the file and try the import again.  

Note: If your .ics file does not contain Delete commands for the 
alignment and points at the beginning of the file, you will 
have to manually delete these prior to importing again. 

Rename the alignment 
Once you have the .ics file completed, you can rename the alignment 
to the appropriate name. After renaming it, if the .ics file needs to be 
run again, you must manually delete the alignment first. 

1. Select Geometry > Rename Geometry and rename the alignment 
from 52 to SH52-H 
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Save geometry file 
1. Select File > Save > Geometry Project. 

2. Make certain the Active Project and File Name are set to 12345 
SH52. 

 

Set the stationing of the horizontal alignment 
1. Select Geometry > Horizontal Curve Set > Stationing. 

2. Window in on the end of the SH52-H alignment in your design file 
and note that it ends at cogo point 5207. 

 

Note: You will set the beginning station by assigning a station to the 
end point. InRoads will then back out what the beginning 
station needs to be. Here, you want the end station to be 
135+00. 

3. In the Stationing dialog, key in 13500 for the Start Station. 

4. Key in 5207 for the Name. 
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5. Choose Apply. 

The beginning station is now 99+84.26. 

 

6. Close the Stationing dialog. 
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Station horizontal alignment 
1. Select Geometry > View Geometry > Stationing and station the 

alignment using the Proposed-100 Ft Interval preference. 

 

2. Zoom in to the beginning of the alignment and take a look at the 
stationing. 
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Generate report of horizontal alignment 
1. Select Geometry > Review Horizontal. 

2. Review the report. 

3. Save a copy of the text file and name it SH52-H Report.txt 

 

4. Save the geometry project (File > Save > Geometry Project). 
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Create a profile of SH52-H 
1. Select Evaluation > Profile > Create Profile 

 Use the 2x Vertical preference. 
 Use a Set Name of SH52 Working 
 Toggle on the surfaces 12345Exist01, SH119 SB top and 

SH119 NB top. 

 

Note:  The two SH119 surfaces have not yet been combined, so you 
will still see the right side of SH119 SB extended to form the 
target for SH119 NB. 
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Create an ics file for the SH52 vertical alignment 
1. Start Notepad and open the file SH52vertical.txt. 

 

 

2. This file lists the vertical PIs and curve Lengths in SH52. Using this 
information, your .ics file handout and what you have learned about 
.ics files, edit this file to make it into an .ics file that will create the 
vertical alignment for SH52. For visual reference, you can use the 
following picture.  

Note:  Name the alignment 52 instead of SH52-V until you have it 
imported correctly. 
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3. When you are ready to test your file, select File > Save As and save 
the file. Name it SH52 VA.ics 

 

Import the .ics file 

1. In InRoads, select File > Import > Geometry. 

2. On the ICS tab, import the file SH52 VA.ics from the 
C:\Projects\12345\Design\InRoads\1.7.2 folder. 

3. If something went wrong with your .ics file, you can Preview it from 
the Import dialog. This opens it in Notepad where you can make 
edits, Save them, Close the file and try the import again.  

4. Since you cannot delete the vertical alignment from within the .ics 
file, you must first Delete the erroneous one if it was created. 
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View the SH52 vertical alignment 
1. View the alignment from the InRoads Explorer Geometry tab.  

 

2. Window in on the SH52 Working profile to see the vertical 
alignment. 
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Rename the alignment 
You can now rename it to the appropriate name. After renaming it, if 
the .ics file needs to be run again, you must manually delete the 
alignment first. 

1. Select Geometry > Rename Geometry and rename the alignment 
from 52 to SH52-V. Set the other options as shown. 

 

2. Save the geometry project. 
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Generate Vertical Clearance reports 
In order to create a vertical clearance report between alignments, 
both must reside in the same geometry project. Here, you’ll 
temporarily copy SH119 NB-H into the current geometry project to 
create the report. 

Copy the alignment 

1. Select Geometry > Copy Geometry and copy the SH119 NB-H 
alignment from project 12345 SH119 NB to the current project 12345 
SH52. Be sure to toggle on Include All Children. 

 

Generate the Clearance Report 
Use a macro to generate the clearance report between SH52-H and 
SH119 NB-H. 

1. Select Tools > Run Macro. 

2. Select the macro IntersectingAlignmentStnRpt.dll. 

3. Select Open. 



 Chapter 1 Alignment Creation 

 

Advanced Roadway Modeling  Page 155 

4. Set the dialog box as shown. 

 

5. Click in the File name field, the select Save As… 

6. In the Save As File name box, key in SH52 and SH119 NB 
clearance.txt 

7. Select Save. 

8. Select Preview to view the report. 

 

Note:   This may not be the tightest clearance due to girders, supers, 
etc. 
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9. Repeat this process and copy SH119 SB-H into the SH52 project. You 
can highlight both NB and SB to generate one report showing both 
clearances. 

 

 

10. Save the geometry project (File > Save Geometry Project). 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Challenge Lab 1.8 – Creating an ics file for Ramp A 
vertical 

In this activity, you will create an .ics file for RampA’s vertical alignment. 
The vertical is controlled by SH119 NB at the beginning, so it must match 
the elevations of the widened SH119 NB initially. The given information 
here has been or will be created in other activities in this class. It is provided 
so you can concentrate on the area of interest. 

Given: 12345 SH119 NB top.dtm – This DTM has already been 
modeled and widens to meet the horizontal for RampA. 

12345 SH52 71st intersection.dtm – This is the DTM 
the ramp will tie into at the other end. 

12345 SH119 SH52 Interchange.alg – This geometry 
project contains the horizontal alignment for RampA. 

PI and Vertical Curve information for the portion of 
RampA that is not controlled by SH119 NB. 

 

Required: RampA-V – You will create an ics file for RampA-V 
based on a report of the elevations from SH119 NB at 
the beginning, then use the VPI and curve data for the 
rest of the vertical. 
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SH119 SB-H 

SH119 NB-H 

RampA-H 

SH119 widened to begin 
RampA. Since the cross 
slopes match here, you 
will use the verticals from 
the Shoulder feature from 
SH119 to pull the 
elevations for the 
beginning of RampA’s 
vertical. 
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Preliminary set-up 
3. Start MicroStation InRoads and open the file 

12345DesignModel01.dgn. 

4. Select File >Project Defaults. 

5. Set the Configuration Name to 1.8 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

6. Select Apply. 

Important!  Verify your dialog box appears as shown: 

 

7. Open the appropriate data files (refer to Given statement). 
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Create a profile of RampA 
On the profile of RampA, you will show the feature from SH119 NB 
top that indicates the elevations you must match when creating the 
vertical alignment. 

1. Profile the Ramp A Horizontal Alignment. 

2. Show Surfaces: 12345 Existing01, SH119 NB top, SH52 71st 
intersection. 

3. On the Feature tab, toggle on Projected Features and highlight 
only SH119NBRT_Ramp_Shoulder. 

 

Notice the feature at the beginning of the profile, showing where the 
ramp is vertically at that horizontal location. You could annotate the 
feature with elevations, but in this case there’s a better method of 
getting that information. You will generate a report showing the 
exact elevations, which you can use as part of the vertical alignment 
for the ramp. 

Since you’ll be using a report to generate the elevations, you don’t 
need to leave the feature projected onto the profile and can toggle it 
off with the Update Profile command. 
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Create a report with station elevation information 
In the report, you’ll need station information every 25 feet along 
RampA, with the corresponding elevations for the Shoulder feature 
from SH119 NB. 

1. Select Tools > XML Reports. 

 

2. Select the Station Offset tab. 

 Choose the From Horizontal Alignment RampA-H. 
 Under the Features category, Set the Surface to SH119 

NB top. 
 Highlight the feature SH119NBRT_Ramp_Shoulder. 
 Toggle on Station Base. 
 Set the Interval to 25. 
 Toggle on Station Limits and set the Stop station to 

3285+75 
 Since you know that the ramp will only be controlled by 

SH119 NB up until that station, you can stop the report 
there. 
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3. Select Save. 

 

4. When prompted for a file name, key in RampA vertical.xml, then 
Save. 

5. When the Report Browser starts, it will format the data according to 
a default style sheet as shown on the left. Try selecting different style 
sheets to see if you can find the data needed. Remember, you’re after 
25’ stations along RampA along with corresponding elevations of the 
shoulder from SH119 NB.  

Notice none of the reports gives you that information exclusively, 
however select the StationBaseCoordinates style sheet and you’ll 
see that it contains the needed information. 
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To create the vertical alignment that matches the widened ramp, you 
can use this station and elevation information, but it will need to be 
formatted into an .ics input file and you want 3 decimal precision on 
the elevations. 

6. Select Tools > Format Options and change the Elevation precision. 

 

7. Highlight the data as shown, then right-click and select Copy. 

8. Close the Report Browser. 

9. Open Notepad and paste the data. 

10. Beginning with this information, create an .ics file to build the 
vertical alignment. Additional information needed to complete the 
alignment is shown below. 

Additional PVIs   Curve Length 

3288+50.0000 5160.990 500 

3294+00.0000 5183.190 200 

POE 

3296+42.1000 5188.180  
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11. After you have created and imported the .ics file, annotate the 
vertical alignment on the profile of RampA-H. 

 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit >Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File >Exit. 

2. If prompted to save data files select Yes. 
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2. Templates, Transitions and Superelevation 
In this chapter you will learn how to build more complex templates, then model 
with these templates by using independent control and setting up transitions in 
the Roadway Library. You will also explore some of the more advanced 
features of Roadway Modeler and learn how to manually edit superelevation 
tables. 

Template Overview 
Working with and creating templates (also known as typical sections) was 
covered in the Roadway Design Using InRoads training class. The following is 
a short overview of templates from this class: 

The library 
Templates are stored in a typical section library along with cut/fill tables, 
material tables, and decision tables. The CDOT typical section library has 
some standard CDOT typical sections that can be copied and modified for 
each project. 

Only one template library can be loaded at a time, so use the Copy Typical 
Sections command to copy templates from various libraries into your project 
library as needed. 

The Template Editor 
The template Editor is your interface for creating new or modifying existing 
typical sections. It is accessed by selecting Modeler >Define Typical 
Sections. On the Templates tab, highlight the template your wish to modify 
and choose Edit. You may also copy a template or crate a new one from this 
tab. 

Templates are built by layer, zone and segment. Template segments are 
built with a horizontal width and slope, which can be defined in various 
formats. You can also specify the segment fixity, to determine if the 
segment will vary in width, slope or both. 

The following diagram is an overview of the options available in the 
Template Editor when building a template. 
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The Layer tab

LAYERS 
Template layers are created for each surface you 
wish to define. The layer names are used to name a 
corresponding surface created during a Roadway 
Modeler run.  
Multiple layers can be used in a single template to 
define finished grade, and several subgrades.  
In order for the template to transition properly, the 
layers must be built in the same order in every 
template, and identical names must be used for like 
layers in different templates.  
The first template in the roadway definition must 
contain all layers used through the model. 
Subsequent templates cannot introduce new layers. 
The main layer projects to intersection with the 
existing terrain.  
Subgrades project into either the main layer, or the 
layer processed just previous to the current one.  
In superelevation, use cut and fill segments to 
project to other layers if you don’t want these 
segments to superelevate. 
Only the active template layer may be modified. It is 
shown in red with the active segment highlighted in 
green. All other layers in the template are shown in 
black. Horizontal and Vertical Offsets from the 
center may be set for the individual layers.  
New is used to add layers (Key in the layer name 
first, then choose add, then set offsets), Delete to 
delete a layer and all corresponding segments, and 
Update to change a layer’s name, description or 
offsets. 
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The Segment tab

SEGMENT 
View selects the portion of the template to be shown 
in the dialog box.  
Zone specifies which of the six parts of the template 
is active for editing: Left or Right Backbone; Left or 
Right Cut; Left or Right Fill. 
A template consists of a left and right side, each 
containing a backbone, cut and fill.  
Each of these portions or zones of the template 
contains up to 255 segments 
The last fill section is negative and the last cut 
section is positive.  
 If you are strictly using tables for sideslope 
calculations, the templates itself does not have to 
have any cut and fill definitions. 
The hinge point is the point between the backbone 
and the cut and fill segments and is also known as 
the POSS (Point of Slope Selection).  
Upon dropping the template, the software checks the 
hinge point to determine where to use the cut or the 
fill section.  
If a decision table is specified for the particular 
template drop, it is used regardless of the hinge 
point location. 
Edit Mode has four options for manipulating 
template segments. Add After allows you to use the 
Add button to add a segment after the active (green) 
segment. Add Before adds the segment before the 
active one. Global allows you to edit any of the Input 
parameters for the currently active segment. All 
other segments retain their current slopes and 
lengths. Local also allows editing of the active 
segment, but changes the next segment’s slope and 
length so that all other segments maintain their 
relationship to the centerline. 

FIXITY 
Segment fixity is shown for the active segment. 
Options include:  
Fixed for no horizontal or vertical transition control;  
Variable Slope for when you want this segment’s 
slope to vary to accommodate either horizontal or 
vertical transition control ;  
Variable Width for when you want this segment’s 
width to vary to accommodate either horizontal or 
vertical transition control ; and  
Variable Slope and Width for when you are 
defining both horizontal and vertical controls.  
Note: The variable segment does not have to be the 
segment next to the transition control point. 

INPUT 
In the input section, you have six options for specifying the slope and width. 
The DX and DY options are for the current segment, while the X and Y 
options are the overall coordinates based on the grid defined by the center 
of the template being 0,0. Specify the values in master units. If you prefer 
using ratios for the slopes, either H/V or V/H may be specified. After the 
slope and width are entered using two of these parameters, select New to 
add the segment to the active layer. It is added before or after the currently 
active segment depending upon the Edit Mode option you have set. 
Previous and Next step you through the template’s active section. Delete 
removes the currently active segment. 

TC NAMES 
TC or Transition Control names are assigned to the end point (farthest 
from the centerline) of the specified segment. The box lists all TC names 
defined in the loaded template library. CDOT has standard TC names that 
are located in the seed typical section library. Many of the predefined 
templates already have been assigned TC names. 
Create new TC names using New TC. To assign a TC name, highlight the 
segment using Next and Previous, highlight the TC name to assign, and 
choose Update. 
Use TC names for several purposes: controlling the symbology of transition 
control lines, controlling template transitioning, reporting and independent 
control. 
The symbology of the resulting TC line is control by the Feature Style 
assigned to the TC name. 
By assigning a unique TC name to a point on the template, you can control 
the point’s path. To do so, independent control is established for the point in 
question. 
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The Mirror Tab 

Mirror allows you to develop only one side of a 
symmetrical template, then copy either the whole 
template (all layers) or one layer to the opposite 
side. This copies the backbone, cut and fill sections 
of the template. TC names are copied as well, so 
you should edit them once the copy is complete. 
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The Superelevation tab

Superelevation  
Set Range One (or Two) allows you to 
”point and click“ the two points on the 
active layer between which you want the 
segments to rotate with superelevation. 
Each point is known as a range point; 
there are no super begin and end points 
per se. Super One Range points are used 
when only one series of segments are 
supered; Use Super One and Super Two 
Range points when two separate series of 
segments are supered, such as in a 
divided highway. 
Set Pivot also allows you to ”point and 
click,“ to define the pivot point for the 
specified range. The pivot point can be 
coincident with either of the range points 
or any point in between, but cannot fall 
outside the range 
Set Crown also allows you to ”point and 
click,“ to define the crown point for the 
specified range. The crown point is the 
point at which the super rates are 
calculated and show in the Build 
Application Station Dialog. 
 
Do Not Superelevate Segment allows 
you to define a segment that will not 
rotate during super (e.g. a near vertical 
pavement segment). To use, highlight the 
segment with Previous or Next, then 
toggle on this option. 
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Roadway Libraries 
Roadway libraries store station and template setups, called roadway definitions. 
Only one library can be loaded at any given time, but each library can contain 
multiple definitions. In addition to setting which template is used where, the 
roadway definition establishes other modeling criteria like how the sideslopes 
are calculated, what the template interval is and how the transitioning between 
templates occurs. 

Independent control is established in the roadway library as part of the roadway 
definition. Unique TC names on the template are assigned a path to follow 
other than that of the centerline.  
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Creating roadway definitions 
The following diagram is an overview of the options available in the Define 
Roadway dialog box used when creating roadway definitions. 

 

MODE 
Both — The template is applied to 
both the left and right sides of the 
alignment. 
Left (or Right) — Only the portion 
of the template to the left (or right) 
of the centerline is applied. 
Left and Right — At first glance, 
this appears to be the same as the 
Both option, but it allows you to 
specify different templates (or 
tables) to be used on the left side 
of the alignment versus the right.  
Depending upon which of the 
options you select, either the “Both” 
column or “Left” and “Right” 
columns of the dialog box are 
active. 

USE TRANSITION TEMPLATE 
When on, the software linearly interpolates and applies 
intermediate templates between entries in your roadway definition 
list. When off, the transition occurs during the interval between 
normal drops. 

CATCH POINT 
This option determines how the 
software calculates sideslopes. 
Choices are Backbone only, 
Cut/Fill Table, Material Table, 
Decision Table or Template. You 
can alternate choices by specifying 
different set-ups at different 
stations. 

HORIZONTAL BENCH  
Specifies the reference elevation 
for calculating the elevation of 
benches that don’t follow the 
vertical alignment. (Only available 
with Cut/Fill or Material Tables) 

DITCH/SHOULDER (CUT/FILL TABLE ONLY) 
Shoulder First — Applies the shoulder option (from the fill table) to 
see if the end of the shoulder is above ground. If so, it places the 
shoulder and a fill slope. 
Ditch, Last Segment — Places the ditch defined in the cut table, if 
any portion of the last segment is below grade. 
Ditch, Last Point — Places a ditch only if the last point on the ditch 
is below grade. 
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Template transitions 
Roadway definitions determine the transition lengths between two 
templates. If the two templates are farther than one template interval apart, 
the transition length is determined by the Use Transition Template toggle in 
the roadway entry. If it is toggled on, the transition will occur between the 
two stations listed for the template in each roadway entry. If the toggle is 
off, the transition will occur between the last drop of the first template and 
the first drop of the second template.  

To accomplish an immediate transition, specify a very small distance 
between the template drops. The distance must be large enough for a 
triangle to be formed, and 0.001 is the InRoads-recommended smallest. 

  

 

The example above shows the effect of the Transition Template toggle. In 
both diagrams, the template interval is 10; at station 1+200, the narrower 
template was dropped. At 1+250, the wider template was dropped. With 
Transition Template off, the transition occurred in the last 10m (left 
diagram). With Transition Template on, the transition occurred over the full 
50m (right diagram). 

  

 

 

 

The example above shows an immediate transition. To accomplish this, a 
template was dropped at 1+249.9, just prior to the 1+250 station where the 
template changes. This forces the transition to occur in the last 0.1m.  It is 
recommended that Transition Template be toggled off for these small 
transitions. 

During the transitioning of templates, transition control lines are drawn by 
connecting like-named points on each template. These lines become 
breaklines in the DTM, and have a feature name that corresponds to their 
TC name. The transition control lines that are joined must be in the same 
zone of the template. In other words, TC lines cannot cross the centerline or 
hinges. 

Offsets can augment the available transitioning in cases where a TC line 
needs to cross the centerline. For example, if a left turn bay crosses into a 
median, the centerline can be offset to the left, allowing the lane to remain 
continuous through the transition. While more than one template is required, 
it does avoid creating a template whose centerline is in the middle of a lane. 
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Independent Control  

Typical Section Setup 
Independent control can greatly enhance the use of templates by allowing 
you to vary widths and slopes of backbone segments during Roadway 
Modeler runs without using a second template. The first step of defining 
independent control is to set up your template. 

Tip: Independently controlled points in the template must be 
within the backbone. 

TC Names 
The points in a template are controlled using TC names. This requires that 
unique names be used to designate the points. There are certain cases when 
you may want the names to be the same. For example, if you are setting a 
grade that you want both sides of a template to follow, the same name can 
be used on both and they are controlled with one independent control setup. 
Another case of using the same names is when you are controlling 
horizontal transition and want a main layer and subgrade(s) to follow the 
same setup. However, in most cases the names will be unique, and the same 
name for horizontal control can not be used on both sides of the template. 

 Tip: The TC names used for independently controlled points must 
be assigned to each template used in the area being 
controlled. 

Fixity 
The template may also be edited to tell the variable segment how it can vary. 
While the independent control will work without this step, you are leaving it 
to the software to determine how the segment varies as well as which one to 
vary. It is better to establish this using the fixity options. 

Tip: When a variable segment is used outside the station range of 
independent control, it is treated as fixed. 

The choices for fixity include fixed, when you do not want the segment to 
change because of independent control, variable slope for independent 
vertical control, variable width for independent horizontal or vertical control 
and variable slope and width for independent horizontal and vertical control. 
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 Variable Slope Variable Width Variable Slope & 
Width 

Independent Vertical 
Control 

 
YES 

 
YES 

YES 
(width is held constant) 

Independent Horizontal 
Control 

 
NO 

 
YES 

YES 
(slope is held constant) 

Independent Horizontal & 
Vertical Control 

 
NO 

 
NO 

 
YES 

This table describes valid horizontal and/or vertical controls for different 
types of variable template segments. 

Tip: The variable segment does not have to be adjacent to the 
independently controlled point. 

Independent Control Definitions 
Independent Control is setup and stored in the roadway library, with the 
individual roadway definitions. In order to define the controls, you must 
have the geometry file loaded with the alignment active that is to be used 
with Roadway Modeler, the template library must be loaded and the 
roadway library. The geometry file should also contain any alignments you 
plan to assign to different points on the template. 

Tip: The alignment that is to be used with Roadway Modeler 
must be active when creating independent control setups. 

The independent control setup in the roadway definition is the critical link 
between the TC names on the template and the path you want them to 
follow. 

There are two types of controls – horizontal and vertical. They can be used 
individually, or in combination. 

Use Horizontal controls when the separate path is defined by a separate 
horizontal alignment or by stations and offsets from the mainline. Horizontal 
controls are used in conjunction with variable width template segments, 
typically for items such as lane widenings or turn lanes. 

Use Vertical controls when the separate path is defined by a separate 
vertical alignment, a vertical difference alignment, or by vertical offsets 
from the mainline vertical. 

 A Vertical difference alignment is an alignment whose elevations 
are based on offsets from a mainline vertical rather than true 
elevations. It is used for superelevation in some cases. 

Use Horizontal and Vertical controls when you want to hit a certain 
location regardless of the slope or width required. 

 

Template Segment 
H & V Controls 
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Horizontal and Vertical Control dialog box  
 

Toggle on Use Horizontal 
Control when the path is 
defined by a separate 
horizontal alignment, or by 
stations and offsets from an 
alignment. When used by 
itself, Horizontal Control 
typically defines control for a 
variable-width template 
segment, such as a lane 
widening. 
 
Toggle on Use Vertical 
Control when the path is 
defined by a separate 
vertical alignment, or an 
elevation and grade. You 
can also define a difference 
alignment. (See explanation 
at right.) If the variable 
segment in the template is 
variable width, the slope is 
held constant, and the 
elevation defined by the 
independent control is used 
to compute the width of the 
segment. If the template 
segment is variable slope, 
the width is held constant 
and the slope is defined by 
the independent control 
elevation. 
 
Toggle on both Horizontal 
and Vertical Control when 
a variable slope and width 
segment is defined in the 
template. Any of the three 
Vertical Control options is 
valid for use in this situation. 

Use Elevation & Grade to 
define a specific starting 
elevation and longitudinal 
grade for a variable slope or 
variable width segment.  
 
Use Vertical Alignment to 
define the path for variable 
slope or variable width 
segments in the template, such 
as a center median or an 
independent ditch. 
 
Use Vertical Difference to 
specify a vertical alignment 
whose elevations are the 
vertical distance between it 
and the centerline vertical 
alignment as the elevation. 
Difference Alignments are 
typically used in defining 
superelevation by vertical 
alignment, and the 
Superelevation Vertical 
Control Alignments 
command creates them 
according to your 
superelevation  
criteria. 

Select the Transition Control Name from the list. This is the 
name that is also specified for the control point in the template. 

Set the elevation and 
grade if the Vertical 
Control Define By 
option is set to 
Elevation & Grade. 

To control the TC name with 
alignments, select horizontal and 
vertical alignments from the list 
boxes. If you use offsets from the 
alignment, specify them as well. 
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Tips: If you temporarily want to omit an independent control 
setup, toggle the entry off, but leave it in the list. That way 
you won’t have to re-create it if you decide to use it again. 

 The stationing in the independent control setup is the 
stationing of the mainline, not the stationing of a control 
alignment. It is important that the mainline is active when 
you enter the dialog. 

Independent Control Special Cases 
The previous discussion included the work flow for independent control that 
accomplishes most of the design cases you need. There are a couple of other 
situations that you may run into, however. 

Centerline control 
When the typical section you are running needs to vary completely from the 
horizontal and/or vertical alignment, you can independently control it. This 
occurs when you are running a ditch alongside a road and want the 
stationing to match the mainline and the slopes to be perpendicular to the 
mainline, even though the alignment may not be parallel. It is also 
sometimes used when modeling each side a divided highway separately, but 
relating both sides to the same alignment. 

To accomplish centerline control, use the TC name Centerline when 
defining the independent control setup. Keep in mind that the name 
Centerline is automatically assigned to the center of each layer in the 
template, so one entry controls all layers. Since the entire template is being 
offset, there are no variable segments or additional TC names to assign to 
the template. 

Tip: When independently controlling the centerline, one entry 
controls all layers 

 Subgrade control 
Whether or not you control the main layer centerline of the template with 
independent controls, there are times when you may need to individually 
control the centerline of subgrade layers in a template. Since they are 
automatically assigned the TC name Centerline (just like the main layer), 
you cannot directly control them separately. 

However, there is a workflow that allows separate control of the centerlines. 
If you create a TC name that exactly matches the name of the layer you want 
to control, you can assign independent control to that TC name and it will 
control the center of the subgrade. You do not assign the TC name to the 
template. See the following workflow for details. 

 

Tip: Both of these special case techniques are required in some 
instances, such as a cut-out that must match the 
superelevation on the existing road. 
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Superelevation 

Setting up superelevation to match hand-calcs 
InRoads superelevation uses AASHTO 2001 superelevation tables. Since 
CDOT has adopted the AASHTO 2004 standards, some editing will need to 
occur in the superelevation. You can code templates to create the 
superelevation; you can have InRoads calculate the super, then manually 
edit the Application Stations; and you can calculate the superelevation in a 
spreadsheet that can then be exported to a text file and imported into 
InRoads. You will be using the latter two methods in you lab activities. 

Troubleshooting 
What do you do when things won’t work? This section is designed to give 
you a feel for troubleshooting common problems with Corridor Modeling. 
While not an all-inclusive process, the thought patterns suggested here can 
help diagnose and solve other problems as well. 

There are several things that can go wrong when modeling, and with 
experience you will learn to narrow down the troubleshooting workflow 
based on the symptoms. To start you off, however, the following is a list of 
items that must be input correctly to get the desired results from corridor 
modeling. 

General problems 

Surface 
 The existing surface must be loaded, have triangles, and fall within 

the range of your alignments. 

Alignments 
 The horizontal and vertical alignment must be active and contain no 

discontinuities. 
 It occasionally causes a problem when the horizontal and vertical do 

not start at the same station; if not, try using station limits and 
starting inside the shorter alignment. 

Typical Section Library 
 The templates used in the roadway definition must be identical in 

name to those in the library. 
 All tables referenced by the roadway definition must be identical in 

name to those in the loaded template library. 
 If a table is not used for the intercept option, the template must 

contain cut and fill for both sides. 
 Subgrades must contain both a left and right backbone even though 

they can be completely offset to one side of the template. The 
exception is if the template is run right or left only. 
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 Roadway Definition 
 The roadway definition must be established and contain templates 

found in the current template library. 
 The names of the templates must be identical (case included) to those 

in the template library. 
 The roadway definitions must define the intercept type for every 

entry.  
 If tables are used, they must reside in the template library. Their 

name in the roadway definition must be identical to that in the 
template library. 

 If “No roadway entry found” message occurs, check to see that the 
roadway definition stations start prior to the horizontal/vertical 
alignments. 

Sideslope problems 
 If sideslopes are not correct, check: 
 Are the slopes defined properly in the template or table? 
 Do the slopes tie correctly, then continue? Make certain the exterior 

boundary option is on under Roadway Modeler. 

Transition problems 
 If cross section cut between template drops in transition areas do not 

correctly show the transition, check to see if the TC lines transition 
properly. If not, assign appropriate TC names to adjacent templates 
and re-model. If so, add the TC lines to the proposed DTM and re-
triangulate. 

Independent Control 
If the control does not work at all after running Roadway Modeler: 

 Make certain the TC name assigned to the template is the same one 
in the independent control setup 

 Make certain the TC name assigned is unique (if applicable) 
 Check the stationing on the independent control setup. Is it correct? 

It should reflect the mainline stationing, not that stationing of a 
control alignment. 

 Are offsets being used? If so, they should be from the alignment, not 
from the TC point location. 

 If you get an error “Exterior Boundary Crossing Itself”, check to see 
if you are using the same TC name on each side of the centerline in 
your template, then using the name for independent horizontal 
control. Independent horizontal control points must be unique to one 
side of the template. 
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 If the transition control works, but the offsets or transitions are not 
correct, check the offsets listed in the independent control setup (they 
are from the mainline alignment). Also, check the offsets in the 
roadway definition and in the template itself.  

 If the transition control works, but the transition occurs at the wrong 
station, check the stationing listed in the independent control setup. 
(The alignment you are using to model the roadway should be active 
when setting up independent control. 
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Lab 2.1 – Using the template editor 
In this activity, you will create templates from scratch for practice using the 
template editor. 

 

SH119 SB 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 2.1 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH119 SB 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH119 SB.alg and then select Open. 

4. Do not cancel out of the box. 

Load the existing DTM 

5. Select File > Open. 

6. Set File of Type to Surfaces (*.dtm). 

7. Highlight 12345 Exist01.dtm and then select Open. 

8. Cancel the Open dialog box. 

Create a typical section library for SH119 SB 
You will first create typicals for SH119 SB. For this model, there are 
initially two templates needed. One template will be used to create the 
roadway and a 6:1 sideslope for the median. The second will be used to 
create the roadway and a 10:1 sideslope for the median. After creating the 
templates, you will set up the transition so that the median becomes 
shallower through the overpass area. 

Naming convention 
You will be creating several templates and will name them according to the 
roadway, the number of lanes on either side of the centerline and a 
description of the template. For example, the first template: 

 is for SH119 Southbound,  
 has 2 lanes on the left of the centerline and no lanes to 

the right,  
 and has a 6:1 median slope. 

The template name, therefore, is: 

SH119 SB 2L-0L 6:1 Median 
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Copy a standard typical section library 

1. Select File > Open  

 Toggle the Files of type option to Typical Section 
Libraries (*.tml). 

 Open Base TML.tml. 

2. Cancel the dialog. 

3. Select File > Save As. 

 Toggle the Save as type to Typical Section Libraries 
(*.tml). 

 Key in 12345 SH119 SB for the File name. 
 Choose Save. 

4. Cancel the Save As dialog. 

5. Select Modeler > Rename Typical Section Library. 

 

6. In the To Name field, key in 12345 SH119 SB 

You may change the description if desired. 

7. Choose Apply, then Close the Rename box. 
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Develop the first median template (6:1 median slope) 

 

This typical will be used to model the Southbound portion of the roadway. 
Since the Northbound portion will tie into the median when it is run, the right 
side of this template is an extended sideslope that does not tie to the existing 
ground. Instead, it will be used as a target for the median slope from the 
Northbound. 

Name the template 

1. From the Define Typical Section dialog box, select New. 

 

2. Key in the Name SH119 SB 2L-0L 6:1 Median 

3. Key in a Description RT side extended for NB target 

Southbound 
with extended 
slope 

Northbound 
with slope tying 
into Southbound 
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4. Apply, then Close the New box. 

 

Create the left backbone 

5. Highlight the template and select Edit. 
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6. On the Layer tab: 

  Key in the Name SH119 SB top 
 Key in a Description of finished grade 
 Select New. 

 

7. Select the Segment tab: 

 

 Set Zone to Left Backbone. 
 Set Edit Mode to Add After. 
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8. For the First Segment (Laneline1): 

 Key in a Slope of -2% 

Don’t forget to use the percent sign and make the slope negative 

 Key in a Width of 12 
 Highlight the TC Name LT_Laneline. 
 Select New. 

 

9. For the Second Segment: 

 With the Slope still set to -2% and the Width set to 12, 
highlight the TC Name LT_Shoulder. 

 Select New. 

10. For the Third Segment: 

 With the Slope still set to -2% and the Width set to 12, 
highlight the TC Name LT_Edge-of-Pavement. 

 Select New. 
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11. For the Fourth Segment (POSS): 

 

 Key in a H/V of -6  

Don’t forget the negative sign 

 Key in a Width of 12 
 Highlight the TC Name LT_POSS. 
 Select New. 
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Build the Right Backbone 

12. Select the Segment tab: 

 Set Zone to Right Backbone. 
 Set Edit Mode to Add After. 

13. For the First Segment: 

 Key in a Slope of 2% 

On the right side, the slope is positive 

 Key in a Width of 4 
 Highlight the TC Name RT_Edge-of-Pavement. 
 Select New. 

14. For the Second Segment (POSS): 

 Key in a H/V of -6 

Don’t forget the negative sign 

 Key in a Width of 12 
 Highlight the TC Name RT_POSS. 
 Select New. 
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Create the Median slope on the right side 

15. Create the extended sideslope that will become the target for the 
Northbound Modeler run: 

 Key in a H/V of -6 
 Key in a Width of 100 
 Select New TC. 

 

 Key in the name RT_Median_TMP 
 Key in a description Temporary Median Point 
 Select a Feature Style default. 

Note: This feature will not be used in the final model, so the 
default style will be fine. 

 Apply, then Close the New box. 
 Highlight the TC Name RT_Median_TMP (it will be at 

the bottom of the list since you just created it). 

16. Select New. 

 

You set the width very large in order for the North-bound template to 
intercept it later.  

17. Select Close. 
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Develop the second median template (10:1 median slope) 
The second template for SH119 SB is identical to the one you just created, 
except it has a 10:1 median slope for use in the overpass area. 

Since you have a template so similar, you will copy it and modify the 
median slope. 

Copy the 6:1 median slope template 

1. From the template list, highlight the SH119 SB 6:1 Median template 
and select Copy. 

 

2. In the To section: 

 Key in a Name of SH119 SB 2L-0L 10:1 Median 
 Key in a Description of RT side extended for NB 

target 
 Apply, then Close. 

Edit the 6:1 template to create a 10:1 median slope on the right side 

3. Highlight the SH119 SB 10:1 Median template and choose Edit. 
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4. On the Segment tab:. 

 Set Zone to Right Backbone 
 Set Edit Mode to Global. 
 Select Next until you’ve reached the RT_Median_TMP 

segment (last segment). 
 In the H/V field, key in -10, then press Tab. 

The segment updates to the new slope. 

5. In the Edit Template dialog box, select Close. 

6. In the Define Typical Sections box, select Close. 

7. Select File > Save > Typical Section Library. 

Create a Roadway Library for SH119 SB 
1. Select File > New. 

2. Select the Roadway Library tab. 

3. Key in a Name of 12345 SH119 SB 

4. Key in a Description of Southbound roadway definitions 

 

5. Apply, then Close the dialog box. 

Create a Roadway Definition slot 
1. Select Modeler > Define Roadway. 

2. Select New. 

3. Key in a Name of SH119 SB 
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4. Key in a Description of Median varies 6:1 to 10:1; RT side 
extended for NB target 

 

5. Apply, then Close. 

Create the Roadway Definition for transitioning 
templates 

1. Select Edit. 

2. In the Edit Roadway dialog box, select New. 

 First entry: 6:1 median template 
 The station defaults to the beginning of the alignment. 

3. Set Mode to Both. 

4. Key in an Interval of 10 

5. Toggle on Use Transition Template. 

6. For Template, choose SH119 SB 2L-0L 6:1 Median. 

7. For Catch Point choose Backbone Only. 

8. Apply. 
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Second entry: 6:1 median template (begin transition to shallower 
sloped section under bridge) 

9. Key in a Station of 2292+00 

10. For Template, choose SH119 SB 2L-0L 6:1 Median. 

11. For Catch Point choose Backbone only. 

12. Apply. 

  

 Third entry: 10:1 median template 

13. Key in a Station of 2293+00 

14. For Template, choose SH119 SB 2L-0L 10:1 Median. 

15. For Catch Point choose Backbone only. 

16. Apply. 

 Fourth entry: 10:1 median to begin transition back 

17. Key in a Station of 2300+00 

18. For Template, choose SH119 SB 2L-0L 10:1 Median. 

19. For Catch Point choose Backbone only. 

20. Apply. 

As you add entries to the 
Roadway Definition, watch 
for the list to build in the 
Edit Roadway box 
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Fifth entry: 6:1 median  

21. Key in a Station of 2301+00 

22. For Template, choose SH119 SB 2L-0L 6:1 Median. 

23. For Catch Point choose Backbone only. 

24. Apply. 

25. Select Close. 

The entries should appear as follows in the Edit Roadway dialog 
box: 

 

26. Close the Edit Roadway dialog box. 

27. Close the Define Roadway box. 
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Save roadway library 
1. Select File > Save > Roadway Library. 

2. On the Save As dialog, 

 Verify that the name is 12345 SH119 SB.rwl 
 Select Save, then Cancel the dialog box. 

 

Model SH119 SB 
1. Select Modeler > Roadway Modeler. 

2. Set the Main tab as shown. 
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3. On the Advanced tab  

 Toggle off Apply To under Superelevation. 
 Key in SB119SB for Left and Center. 
 Key in SB119 SB for the Right Prefix. 

Note:  Left and Right prefixes cannot be identical; therefore you 
will use a space in the Right one. 

 Set all other options as shown. 

  

4. On the Layer Controls tab, make sure Use Layer Controls is turned 
off. 

5. Select the Main tab again and then select Apply. 

The SB 119 corridor is modeled with the backbone on West (left) 
side and large sideslopes on East (right) side as defined in the 
template. 

6. Close the Roadway Modeler box. 

7. Fit the view. 

Use a space 
before “SB” for 

Right Prefix 
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Note: Make sure that Expand Clipping Planes is turned on in the 
Fit View Settings box. 

 

8. Zoom in to the beginning of the alignment to see the TC lines. 

 

TC line for the expanded 
sideslope. It will not be 
used in the final model. 

SH119 NB 

SH119 SB 
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Save the SB 119 finished surface 
1. Choose File > Save As. 

2. Set the Save as type to Surfaces (*.dtm). 

3. Make certain you’re in the 2.1 sub-folder. 

4. Set Active to SH119 SB top. 

5. Verify that the File name is also SH119 SB top. 

 

6. Select Save. 

7. Cancel the dialog box. 

Generate Cross Section along SH119 SB 
1. Change the Text Scale Factor to 40 under Tools > Options > 

Factors. 

2. Select Evaluation > Cross Section > Create Cross Section. 

3. Select Preferences, highlight the Stacked 20 per column 
preference and Load. 
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4. Close the Preferences box. 

5. Set the Main tab as shown.  

 Make sure that alignment SH119 SB-H is selected and  
 Turn on the 12345 Exist01 and SH119 SB top surfaces.  
 Key in the Set Name SH119 SB Working 

 

6. Apply. 

7. <D> anywhere in a clear area to plot the cross sections. 
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8. Window in and take a look at the some of the cross sections. 

Note: The minor grid lines have been turned off in the diagram 
below for clarity purposes. 

 

Use Cross Section Viewer to review sections 
1. Select Evaluation > Cross Section > Cross Section Viewer. 

2. Set Cross Section Set to SH119 SB Working and the other options as 
shown. 

3. Select Run. 

Note: Watch for the 6:1 to 10:1 transition between stations 
2292+00 and 2293+00. 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 2.2 – Modeling with Superelevation and 
Independent Controls 

In this activity, you will model 71st Street with lane widening using 
horizontal controls. You will also set up Superelevation to match hand 
calculations, and modify the templates and super so that left lanes at the 
intersection will match the cross slope of the turn lane from SH52. 

 

 
 

71st Street 
South of SH52 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 2.2 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for 71st Street 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 71st.alg and then select Open. 

4. Do not cancel out of the box. 

Load the template library for 71st Street 

5. Set File of Type to Typical Section Libraries (*.tml). 

6. Highlight 12345 71st.tml and then select Open. 

7. Do not cancel out of the box. 

Load 71st Street DTM 

8. Set File of Type to Surfaces (*.dtm). 

9. Highlight 12345 SH52 top.dtm and select Open. 

10. Do not cancel out of the box. 

Load the existing DTM 

11. Highlight 12345 Exist01.dtm and then select Open. 

12. Cancel the Open dialog box. 
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Review Data 

View 71st Street horizontal 

1. Select Geometry > View > Active Horizontal. 

Review the typical section for 71st street 

2. Select Modeler > Define Typical Section. 

 

3. Highlight the template 71st 2L – 2L and select Edit. 

4. Select the Segment tab and set the Zone to Right Backbone. 
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5. Use the Next button to review the segments in the backbone. 

 

Notice the inside segment is a tiny variable width segment that you 
will set up to expand, creating an additional lane on the inside. 

6. Close the Edit Template box. 
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Create a Roadway Library for 71st street 
1. Select File > New. 

2. Select the Roadway Library tab. 

 

3. Key in a Name of 12345 71st  

4. Key in a Description of 71st Street Roadway Definitions 

5. Apply. 
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Develop roadway definitions 
1. Select Modeler > Define Roadway. 

2. Select New. 

 

3. Key in a Name of 71st 594+15 to 600+00  

4. Key in a Description of 71st Street South of SH52 

5. Apply, then Close. 

6. Highlight the definition you just created and select Edit. 
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7. In the Edit Roadway dialog box, select New. 

 

8. Keep the initial default station. 

9. Set Mode to Both. 

10. Key in an Interval of 10 

11. For Template, choose 71st 2L – 2L. 

12. For Catch Point choose Backbone Only. 

13. Apply. 

14. Close the Roadway Entry box. 

15. Close the Define Roadway box. 
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Widening 
71st Street begins with two 11’ travel lanes to match with existing 
and transitions to a section with an 11’ and a 12’ lane on both sides 
of the alignment. In the next steps, you’ll set up independent control 
to establish the transitions. 

 

1. Select Modeler > Define Roadway. 

2. Edit the roadway definition. 

3. Select the Horizontal and Vertical Controls tab. 

4. For the first entry, 

Two 11’ travel lanes 

Transitioning to 
Two 11’ travel lanes 

on the inside and 
Two 12’ travel lanes 

on the outside 
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 Set the Control Name to LT_Laneline. 
 Toggle on Use Horizontal Control. 
 Toggle on Templates at Vertices. 
 Toggle off Use Vertical Control. 
 Select the horizontal alignment 71st-H. 

Under Station Limits: 

 Set the Start station to 595+00 

Note: This is the station where you want the inside lane to begin 
widening. 

 Set the End station to 597+50 

Note: This is the station where you want the inside lane to be the 
full width. 

 Key in a Start offset of -0.01 
 Key in a Stop offset of -12 

5. Select New. 

6. For the second entry, 
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 Change the TC name to RT_Laneline. 
 Change the offsets to positive. 

7. Select New. 
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8. For the third entry, 

 

Under Station Limits 

 Set the Start station to 597+50 
 Set the End station to 600+00 
 Key in a Start offset of 12 
 Key in a Stop offset of 12 

9. Select New. 
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10. For the fourth entry, 

 

 Change the TC name to LT_Laneline. 
 Change the offsets to negative. 

11. Select New, then Close. 

 

12. Save the roadway library. 
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Superelevation 
The superelevation must match the existing cross slopes at the beginning of 
the alignment and the longitudinal slope of SH52 at the intersection. This 
superelevation has already been worked out in a spreadsheet which you can 
view in your project files (71st-S.txt).  

 

You can also view the text version of this spreadsheet (71st-V.txt) which 
will be imported to form the superelevation transition table. The text file is a 
pipe-delimited export of the spreadsheet. 

1. Select File > New and create a new Superelevation Alignment for 
71st Street. 
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2. Select Modeler > Superelevation > Build Transitions. 

 

3. Select the ASCII tab. 

4. Select Browse and choose the 71st-S.txt file from the 
C:\Projects\12345\Design\InRoads\2.2 folder. 

5. Select Open. 

6. Go back to the Main tab to see the table you imported. 

 

7. Choose Save, then OK. 
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Copy the current typical 
In the approach to SH52, the left lane of 71st ties into the right turn lane of 
SH52. Since the SH52 turn lane is at -1%, you will force the left lane of 71st 
to match this cross slope. At station 598+20, you want the super of the left 
travel lane ‘locked’ at -1%. Since the 71st Street template is being supered 
at the end to match the longitudinal grade of SH52, you will override the 
super for the outside lane by switching to a template with a different slope 
and super range point on the left. 

1. Select Modeler > Define Typical Sections. 

 

2. Highlight 71st 2L – 2L and select Copy. 

 

3. In the To field, key in the Name 71st 2L – 2L LT to match 
SH52. 

4. For the Description, key in Left to match SH52 turn lane. 
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5. Apply, then Close the dialog. 
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Edit the new template. 
You goal is to set the superelevation range point at the Left Laneline. 
However, since the Left Laneline is only 0.01’ away from the Centerline, it 
is very difficult to set the range point at the correct location. In the next 
series of steps, you’ll widen the segment to make it easier to establish the 
range point. 

1. On the Segment tab, 

 

 Set the Zone to Left Backbone. 
 Set the Edit Mode to Global. 
 Use Previous or Next to make sure you’re sitting on the 

Left Laneline. 
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 Change the width from 0.01 to 10 and Tab. 
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2. Select the Superelevation tab: 

 Clear the Superelevation, then set: 
 Set Range points at the Left Laneline and at the Right 

Edge-of-Pavement. 
 Set Pivot at the Centerline. 
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3. Change the width of the segment back to 0.01 

 

4. Change the Slope of the other two segments on the left backbone  
to -1% 

 

5. Close the dialogs and Save the typical section library. 
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Add the transition to the roadway definition 
1. Select Modeler > Define Roadway. 

2. Choose the roadway definition and Edit. 

3. Select New and add the following entries to transition to the 
template with the different left range point. Make CERTAIN Use 
Transition Template is toggled OFF. 

 598+19.99 71st 2L – 2L 

 

 598+20.00 71st 2L – 2L LT to match 52 

 

4. Close the dialogs and save your roadway library. 

Note:  We are only modeling the south side of SH52. If you model 
both sides, you will need to switch back to the original 
template on the other side of SH52. 
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Model South 71st street 
1. Select Modeler > Roadway Modeler. 

2. Select Preferences and Load the CDOT preference. 

3. Set the Main tab as shown, limiting the Modeler run to the south 
side of SH52. 
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4. Set the Advanced tab as shown. In the Superelevation section, 
makes sure Apply To is toggled on and select First Layer.  

Important!   Don’t forget the space in the Right prefix. 
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5. Select Apply. 

 

6. Zoom in to the alignment to see the TC lines. Note the transitions 
from two to four lanes. 

7. Save the new surface. 

Generate Cross Section along 71st street 
1. Select Tools > Options and set the Text Scale Factor to 40. 

2. Select Evaluation > Cross Section > Create Cross Section. 

3. Select Preferences, highlight the Stacked 20 per column 
preference and Load. 

4. Close the Preferences box. 

5. Set the Main tab as shown.  

 Make sure that alignment 71st-H is selected and  
 Turn on the 71st top surface.  
 Key in the Set Name 71st Working 
 Apply. 

6. <D> anywhere in a clear area to plot the cross sections. 
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Review sections 
1. Select Evaluation > Cross Section > Cross Section Viewer. 

2. Set Cross Section Set to 71st Working and the other options as 
shown. 

3. Select Run. 

4. Annotate slopes on the sections to see how the left lane stays at  
-1% rather than going into super at the end of the model run. 

 

5. Review the surface by viewing contours and/or triangles. 

Note that the returns are obviously not in place. You will be 
modeling them in a later chapter. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 2.3 – Templates, Transitions, and Superelevation 
In this activity, the roadway is a multi-lane divided typical with curb and gutter, 
and raised medians. One approach to modeling this type of situation is to work 
out the details in steps. This makes it much easier to trouble-shoot when there 
are problems with the model. 

To start, you will create a simple model with one lane on either side of the 
centerline and use it to work out the details of the superelevation. Once that’s 
done, you will model again with a multi-lane template and use independent 
control to widen the roadway. 

In a later activity, you will be modeling the raised medians and including them 
in the surface created here. 

 

SH52 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 2.3 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH52 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH52.alg and then select Open. 

4. Do not cancel out of the box. 

Load the template library for SH52 

5. Set File of Type to Typical Section Libraries (*.tml). 

6. Highlight 12345 SH52.tml and then select Open. 

7. Do not cancel out of the box. 

Load SH119 NB and SH119 SB DTMs 

8. Set File of Type to Surfaces (*.dtm). 

9. Highlight 12345 SH119 NB top.dtm and select Open. 

10. Highlight 12345 SH119 SB top.dtm and select Open. 

11. Do not cancel out of the box. 

Load the existing DTM 

12. Highlight 12345 Exist01.dtm and then select Open. 

13. Cancel the Open dialog box. 
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Develop a basic template (backbone only) 
You’ll create a basic cross slope template for working out 
superelevation. This template has a single 44’ lane on each side of 
the CL. 

 

Create the template name 

1. Select Modeler > Define Typical Section. 

2. Create a template named SH52 BB with a description SH52 BB 
Only for Super 

 

Create the layer name 

3. Set the Layer tab as shown, then select New. 
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Build the backbone only template 

4. Select the Segment tab and build the template using the typical 
diagram. 

 

Set the superelevation range and pivot points 

5. Select the Superelevation tab. 

6. Under the Superelevation One section, choose Set Range. 

7. <D> near the LT_Bike-Lane point for the first range point. 

8. <D> near the RT_Bike-Lane point for the second range point. 

9. Select Set Pivot. 

10. <D> near the crown point to place the pivot point 

Note: If you get a range or pivot point in the wrong location, 
choose Clear under Superelevation One and start over. 
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11. Close the Edit Template box. 

12. Close the Define Typical Section box. 

13. Save the typical section library. 

Create a Roadway Library for SH52 

1. Select File > New > Roadway Library. 

 

Create a Roadway Definition  
1. Select Modeler > Define Roadway. 

2. Create the new definition as shown: 
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Create the station/template entry for this definition 
1. Edit the SH52 BB entry. 

2. In the Edit Roadway dialog box, select New and create a single 
station/template entry as shown: 

 

3. Save the roadway library. 
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Superelevation 

Create a Superelevation slot 
1. Make sure that the SH52-H horizontal alignment is active 

(Geometry > Active Geometry or InRoads Explorer). 

2. Select File > New > Geometry. 

3. Create new Superelevation geometry as shown: 

 

Calculate rates 
The first curve in SH52 has a design speed of 30mph and a 
maximum super rate of 4%. 

1. Select Modeler > Superelevation > Rate Calculator. 

2. Set the Method to Table. 

3. Click in the Rate Table field, clear out the current entry and select 
Browse. 

4. Set the Look in folder to C:\Program Files\Workspace-
CDOT\Standards-Global\InRoads\Superelevation 
Tables\AASHTO 2001\ 

5. Select the file 04_30.sup, then select Open. 
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6. Set the dialog box as shown: be sure to toggle on only the first curve 
in the bottom of the box. 

 

7. Select Compute to compute the rates for the first curve. 

The second curve in SH52 has a design speed of 50mph and a 
maximum super rate of 6%. 

8. Click in the Rate Table field and select Browse. 

9. Set the Look in folder to C:\Program Files\Workspace-
CDOT\Standards-Global\InRoads\Superelevation 
Tables\AASHTO 2001\ 

10. Select the file 06_50.sup, then select Open. 
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11. Set the dialog box as shown, be sure to toggle on only the second 
curve in the bottom of the box. 

 

12. Select Compute to compute the rates for the second curve. 

From your hand calculations, you know that the first curve should in 
fact be 2.80% super. 

13. Highlight the first curve and choose Edit at the bottom of the dialog. 

14. Change the super rates to 2.8% 

 

15. Choose Apply. 

16. Close the Edit Superelevation Rates dialog. 

17. Close the Calculate Super Rates box. 
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Build Transitions 
1. Select Modeler > Superelevation > Build Transitions 

2. Verify that the Main tab is set as shown: 

 

3. Verify the Controls tab is set as shown. Toggle off Apply Rounding 
to Linear Transitions. 
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4. Back on the Main tab, select Compute. 

5. Select OK when asked to rectify overlaps, as you will be adjusting 
the entries below and taking care of any problems. 

 

6. Close the Results box (save the contents of the box in your project 
folder using File > Save if desired.) 

Rates are computed and shown in the bottom of the dialog box. 
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Adjust transitions 
The rates used are from the AASHTO 2001 green book and not up to 
2004 standards.   

You will need to adjust the rates so that they match the 2004 
standards. You’ll do this by editing the rates based on the following 
superelevation hand calculations. 

Station 
Left 
Rate Mode 

Right 
Rate Mode 

     
99+94.00 0.11% Linear -0.11% Linear 
100+79.00 2.80% Linear -2.80% Linear 
103+57.00 2.80% Linear -2.80% Linear 
103+79.00 2.00% Linear -2.00% Linear 
104+87.00 -2.00% Linear -2.00% Linear 
115+21.00 -2.00% Linear -2.00% Linear 
116+64.00 -2.00% Linear 2.00% Linear 
117+14.00 -3.40% Linear 3.40% Linear 
128+47.00 -3.40% Linear 3.40% Linear 
130+41.00 -4.96% Linear -0.50% Linear 
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1. Highlight the first entry in the Build Superelevation Transitions 
dialog box, which you will modify to match the cross slope at the 
beginning of the model. 

2. Select Edit. 

 

3. Change the Station to 99+94 (the beginning of construction). 

For the beginning of construction, the super must match that of the 
existing roadway. 

4. Key in the Left rate of 0.11% from the spreadsheet. 

5. Key in the Right rate of -.11% 

6. Set both left and right Modes to Linear. 

7. Select Apply. 

8. Choose Next to go to the next superelevation application station. 

9. Choose Delete twice to delete the next two entries (99+84.26 and 
100+02.20) since you will transition from the beginning station to 
the full super. 

10. Change the 100+17.34 station to 100+79 

11. Set both Left and Right Modes to Linear. 

12. Key in the rates from the spreadsheet (previous page) for this station, 
then Apply. 
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13. Continue adjusting the rates until you’ve entered all the stations  
from the spreadsheet (don’t forget to Apply after each entry). 

14. You will Delete the last two entries 

Note:  The final entry is at 130+41, where SH52 will be 
transitioned back to the existing cross slopes and 
construction ends. 

Your adjusted rates should appear as shown below (the first few 
stations has scrolled off the list in this picture). 

 

15. Close the Superelevation Transition box. 

16. In the Build Superelevation Transitions box, select Save, then OK 
to save the changes and close the box. 

17. Save the geometry project. 
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Model SH52 with superelevation 
1. Select Modeler > Roadway Modeler. 

2. Select Preferences and Load the CDOT preference. 

3. Set the Main tab as shown: 
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4. Set the Advanced tab as shown. In the Superelevation section, 
makes sure Apply To is toggled on and select First Layer.  

For the prefixes, set the Left to SH52, Center to SH52 and Right to 
SH 52 

Note: Be certain to use the space! Modeler will not allow left and 
right prefixes to be the same, and if you enter the same one, 
the right will be replaced with Right_ 

  

5. Select the Main tab again. 

6. Select Apply. 

The SH 52 corridor is modeled with the typical section as defined 
(backbone only) and with superelevation. 
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7. Zoom in to the beginning of the alignment to see the TC lines. 

 

Evaluate SH 52 basic model 

Generate Cross Section along SH 52 

Set the Text Scale Factor 

1. Select Tools > Options. 

2. Select the Factors tab and set the Text Scale Factor to 40 
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Generate cross section using features instead of triangles 

3. Select Surface > Surface Properties. 

4. On the Advanced tab, toggle on Use Features Only for the SH52 
top surface. 

  

5. Select Apply, then Close. 

Generate the sections 

6. Load the Stacked 20 per column preference and cut sections along 
the SH52-H alignment showing the 12345 Exist01 and SH52 top 
surfaces. Key in the Set Name as shown: 
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7. On the Features tab, toggle off Include Features. 

8. Apply the command and <D> to define the location of the cross 
section set. 

Annotate Sections with slopes 
Annotate the sections to show the cross slopes to check superelevation. 

1. Select Evaluation > Cross Section > Annotate Cross Section. 

2. Set the Main tab as shown: 

 

3. On the Segments tab, make sure Slope is toggled on under the 
Symbology section. 

4. Apply. 
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Review the sections 
1. Select Evaluation > Cross Section > Cross Section Viewer. 

2. Set Cross Section Set to SH52 Working and the other options as 
shown. 

3. Select Run. 
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Model with median template and independent control 
Now that the superelevation is worked out for SH 52, you’ll model with a 
template that includes a median width, turn lanes, sidewalk, etc. (see lane 
sketch on next page). 

Review the typical section SH52 CG 
1. Select Modeler > Define Typical Section. 

2. Highlight the template SH52 CG and select Edit. 

Select the Segment tab. Using the Next and Previous buttons, 
review the template Zones Right Backbone, Right Cut, and Right 
Fill. 

3. Set the Zone back to Right Backbone. 

4. Highlight the first RT_Laneline segment – first segment after the 
centerline (use the Previous button, if necessary). 

The segment appears dashed. Note that this segment’s Fixity is set to 
Variable Width for independent control, which you’ll set up next. 

 

 

5. Close the Edit Template box. 

6. Close the Define Typical Sections box. 
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Set up independent control  
You’ll use independent control with stations and offsets to define the 
width of road, which changes as noted in the following lane sketch. 
Later, you’ll be adding a median that will vary in width and also will 
vary to form left turn lanes. 

 
          
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 

 

Notice that the outside three segments are always the same  
(12’, 12’ 5’).  Therefore, you can use the Lanline to control the 
widening. 

Laneline 
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Create a Roadway Definition 

1. Create a new Roadway Definition with the Name SH52 CG and 
Description SH52 with median widening and CG.  

 

2. In the Define Roadway box, highlight the SH52 CG roadway 
definition that you just created and select Edit. 

3. Select the Horizontal and Vertical controls tab. 
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H&V Entries 

First Entry 

 

4. Set the following options: 

 Transition Control Name to LT_Laneline. 
 Toggle on Use Horizontal Control. 
 Toggle on Templates at Vertices. 
 Toggle off Use Vertical Controls. 
 Set Horizontal Alignment to SH52-H. 
 Keep the default Start station . 
 Set Stop station to 104+37.56 
 Set Start offset to -3 
 Set Stop offset to -15 
 Select New. 
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Second Entry 

 

5. Set the following options: 

 Change the Transition Control Name to RT_ Laneline. 
 Change the offsets to positive. 
 Select New.
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Third Entry 

 

6. Set the following options: 

 Set Start station to 104+37.56 
 Set Stop station to 113+79.86 
 Set Start offset to 15 
 Set Stop offset to 15 
 Select New. 
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Fourth Entry 

 

7. Set the following options: 

 Change the Transition Control Name to LT_ Laneline. 
 Change the offsets to negative. 
 Select New. 
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Fifth Entry 

 

8. Set the following options: 

 Set Start station to 113+79.86 
 Set Stop station to 116+46.58 
 Set Start offset to -15 
 Set Stop offset to -9 
 Select New. 
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Sixth Entry 

 

9. Set the following options: 

 Change the Transition Control Name to RT_ Laneline. 
 Change the offsets to positive. 
 Select New. 
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Seventh Entry 

 

10. Set the following options: 

 Set Start station to 116+46.58 
 Set Stop station to 120+00.00 
 Set Start offset to 9 
 Set Stop offset to 9 
 Select New. 
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Eighth Entry 

 

11. Set the following options: 

 Change the Transition Control Name to LT_ Laneline. 
 Change the offsets to negative. 
 Select New. 
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12. When done, you should have 8 entries: 

 

13. Choose File > Save > Roadway Library. 
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Create the Roadway station/template entries 
1. Select the Main tab. 

2. In the Edit Roadway dialog box, select New. 

  

3. Keep the beginning station as is. 

4. Set Mode to Both. 

5. Key in an Interval of 10 

6. For Template, choose SH52 CG. 

7. For Catch Point choose Template. 

8. Apply. 

9. Close the Roadway Entry box. 

10. Close the Define Roadway box. 

11. Save the roadway library. 
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Model SH 52 with independent control and 
superelevation 

1. Select Modeler > Roadway Modeler. 

2. Select Preferences and Load the CDOT preference. 

3. Set the Main tab as shown: 
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4. Set the Advanced tab as shown. In the Superelevation section, 
makes sure Apply To is toggled on and select First Layer. 

 

5. Select Apply. 

6. Close the Modeler. 

Update Cross Sections 
1. Select Evaluation > Cross Section > Update Cross Section. 

2. Set the Cross Section Set to SH52 Working. 

3. Set Mode to Refresh. 

4. Select the Surface SH52 top. 

5. Apply, then Close. 

The cross sections are updated to show the new template and 
independent control for varying the median. 
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Annotate Sections with slopes 
1. Select Evaluation > Cross Section > Annotate Cross Section. 

2. On the Main tab: 

 

 Set Cross Section Set to SH52-H Working. 
 Set Surface to SH52 top. 
 Under Annotate, toggle on Segments and toggle off 

Points and Features. 
 Set the other Main tab options as shown. 
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3. On the Segments tab, make sure Slope is toggle on under the 
Symbology section. 

4. Apply. 

 

Review sections 
1. Select Evaluation > Cross Section > Cross Section Viewer. 

 

2. Set Cross Section Set to SH52 Working and the other options as 
shown. 

3. Select Run. 
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Model with a spill gutter 
Through the first curve of SH52, you will transition to a spill gutter on the high 
side of super. First, you will copy the template and change the gutter to spill, 
then you will set up the transition in the roadway definition. 

Copy and modify the template 
1. Select Modeler > Define Typical Section. 

 

2. Highlight the template SH52 CG and select Copy. 

 

3. In the To Name field key in SH52 CG Spill 

4. Key in a Description of SH 52 with lanes, Curb and Spill 
Gutter 

5. Apply, then Close the Copy Template box. 
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6. Highlight the new template and choose Edit. 

7. Select the Segment tab and set the Zone to Left Backbone. 

 

8. Use the Next button to step through the segments in the backbone 
until you get to the gutter (TC name LT_Curb-Flowline). 

9. Set the Edit Mode to Global. 

10. Change the Slope to +4.17% 

11. Select Update. 
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12. Close the Edit Template dialog. 

13. Close the Define Typical Sections dialog. 

14. Save the Typical Section Library. 

Edit the Roadway Definition 
You will set up the roadway definition to start the model with the spill 
gutter, carry it through to station 104+07, then transition over 50 feet to the 
catch gutter template. 

1. Select Modeler > Define Roadway. 

2. Select the SH52 CG roadway definition. 

3. Select Edit. 

4. In the Edit Roadway dialog box, select Edit. 

 

5. Change the Template to SH52 CG Spill. 

6. Select Apply. 

7. Select Close. 
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In the Edit Roadway dialog box, select New. 

 

8. Key in a Station of 104+07  

9. For Template, select to SH52 CG Spill. 

10. Keep Catch Point set to Template. 

11. Apply. 

 

12. Key in a Station of 104+57 

13. For Template, choose SH52 CG. 

14. Apply. 
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15. Close the Roadway Entry box. 

 

16. Close the Define Roadway box. 

17. Save the roadway library. 
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Model SH 52 with spill gutter to catch gutter transition, 
independent control and superelevation 

1. Select Modeler > Roadway Modeler. 

2. Select Preferences and Load the CDOT preference. 

3. Set the Main tab as shown: 
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4. Set the Advanced tab as shown. In the Superelevation section, 
makes sure Apply To is toggled on and select First Layer. 

 

5. Select the Main tab again. 

6. Select Apply. 
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Update Cross Sections 
1. Select Evaluation > Cross Section > Update Cross Section. 

 

2. Set the Cross Section Set to SH52 Working. 

3. Set Mode to Refresh. 

4. Select the Surface SH52 top. 

5. Apply, then Close. 

6. Save the SH52 top surface. 

Annotate Sections with slopes 
1. Select Evaluation > Cross Section > Annotate Cross Section. 

2. On the Main tab: 

 Set Cross Section Set to SH52 Working. 
 Set Surface to SH52 top. 
 Under Annotate, toggle on Segments and toggle off 

Points and Features. 
 Set the other  Main tab options as shown. 

3. On the Segments tab, make sure Slope is toggle on under the 
Symbology section. 

4. Apply. 
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Review results 

Review the sections 

1. Select Evaluation > Cross Section > Cross Section Viewer. 

2. Set Cross Section Set to SH52 Working and the other options as 
shown. 

3. Starting at the beginning, step through a few sections to see the 
gutter transition from spill to catch. 

4. Close the Cross Section Viewer. 

Review the surface. 

5. View contours and/or triangles for SH52 top. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Challenge lab 2.4 – Model the right turn lane from 
SH52 onto 71st 

Given: 12345 Exist01.dtm 

 12345 Sh52.alg 

 12345 SH52.tml 

 12345 SH52.rwl 

 

Required: Add a right turn lane for SH52 EB to turn onto 71st. 
Start the turn lane at 114+50, with the full width attained 
at 116+00. The turn lane continues to the intersection at 
119+00, where you will transition to a template with not 
C/G. 
 
The turn lane needs to be at a -1% slope, even though 
SH52 is in a 3.4% super at the intersection. You will 
need to transition the slope of the turn and bike lanes to 
follow the -1%. 
 
A transition from Spill to Catch Gutter was previously 
completed, so begin with the SH52CG roadway 
definition. 

 

 

 

114+50 
Start Right 
Turn lane 

116+00 
Right Turn lane 
Full width 

119+00 
C/G Ends 
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Preliminary set-up 
1. Start MicroStation InRoads and open the file 

12345DesignModel01.dgn. 

2. Select File>Project Defaults. 

3. Set the Configuration Name to 2.4 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

4. Select Apply. 

Important!  Verify your dialog box appears as shown: 

 

5. Open the appropriate data files (refer to Given statement). 
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Note: If you need additional assistance with this lab, follow the 
steps below. 

Create the narrow right turn lane template 
For the turn lane onto 71st Street, you will copy SH52 CG to create  
SH52 CG RT. Since this is a new lane, you will create a template with a 
very narrow turn lane to begin the transition, then create a template with the 
full width (12’) turn lane. 

Copy the template 

1. Select Modeler>Define Typical Section. 

 Highlight the template SH52 CG then select Copy. 
 In the To Name field key in SH52 CG Start RT 
 Key in a Description of SH 52 with lanes, Curb 

and Gutter and RT turn 

2. Apply, then Close the  Copy Template box. 

Add the narrow turn lane segment 

3. Highlight the SH52 CG Start RT template that you just copied. 

4. Select Edit. 

5. Select the Segments tab. 

 Set the Zone to Right Backbone. 
 Set the Edit Mode to Global. 
 Use the Next button to highlight the RT_Edge-of-

Pavement segment. 
 Highlight the TC Name RT_Turn. 
 Select Update. 
 Set the Edit Mode to Add After 
 Key in a Slope of -2% 
 Key in a Width of .01 
 Select the TC Name RT_Edge-of-Pavement. 

6. Select New. 

7. Close the Edit Template dialog box. 
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Create a 12’ wide turn lane template 
Now, you’ll create the full width turn lane template. 

Copy the template 

1. Highlight the template SH52 CG Start RT then select Copy. 

 In the To Name field key in SH52 CG 12’ RT 
 Key in a Description of SH 52 with lanes, Curb 

and Gutter and 12’ RT turn 

2. Apply, then Close the Copy Template box. 

Modify the right turn lane segment 

3. Highlight the SH52 CG 12’ RT template that you just copied. 

4. Select Edit. 

5. Select the Segments tab. 

 Set the Zone to Right Backbone. 
 Set the Edit Mode to Global. 
 Use the Next button to highlight the RT_Edge-of-

Pavement segment. 
 Key in a Width of 12 

6. Press your Tab key to update the segment. 

The template segment widens from .01 to 12’. 

7. Close the Edit Template dialog box. 

Create the Roadway Definition  
Copy the previous roadway definition and add the turn lane transition. 

1. Select Modeler>Define Roadway. 

2. Select the SH52 CG roadway definition. 

3. Select Copy. 

 Key in a Name of SH52 CG RT 
 Key in a Description of SH52 with median 

widening, CG and RT turn 

4. Select Apply, then Close. 

5. In the Edit Roadway dialog box, select Edit 

6. Select New. 
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First entry 

7. Key in a station of 114+49.99 

8. For Template, choose to SH52 CG. 

9. Keep Catch Point set to Template. 

10. Apply. 

Second Entry 

11. For the next entry, key in a Station of 114+50 

12. For Template, choose SH52 CG Start RT. 

13. Apply. 

Third Entry 

14. Key in a Station of 116+00 

15. For Template, choose SH52 CG 12’ RT. 

16. Apply. 

Fourth and fifth entries 

17. Continue adding the following entries. 

 119+00.00 SH52 CG 12’ RT 
 119+00.01 SH52 No CG 12’ RT 

18. Close the Roadway Entry box. 

19. Close the Define Roadway box. 

20. Save the Roadway Library. 
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Vary the right turn lane slope 
The turn lane on SH 52 occurs in the superelevated area, but you 
want the turn lane to slope in the opposite direction to tie into 71st 
street. There are several ways to accomplish this task, one of which 
is to use a rollover lock with the superelevation. 

You know the superelevation is 3.4% at it’s max, which is in the turn 
lane area. You know you want the turn lane (and bike lane) to be at -
1%. That translates to an algebraic difference of 4.4%. Since you are 
‘rolling’ two segments (turn and bike), you will set the first segment 
to a maximum algebraic difference of 4.4%. The second segment 
references the first, so its algebraic difference is 0.0%. 

1. Select Modeler>Superelevation>Build Transitions. 

2. Highlight the 116+64 entry and choose Edit. 

3. Under Rollover Locks, 

 Toggle on Segment 1 Percent Difference  
and enter 4.4 

 Toggle on Segment 2 Percent Difference  
and enter 0.0 

4. Apply. 

5. Choose Next. 

 Make the same changes to this full super entry and 
choose Apply. 

6. Choose Next. 

 Again, make the same changes to this full super entry 
and choose Apply. 

7. Do not change the last entry. 

8. Close the Superelevation Transition dialog. 

9. Save, then OK the Superelevation Transition dialog. 

10. Save the geometry project. 
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Model SH 52 with the right turn lane  
1. Select Modeler>Roadway Modeler. 

2. Select Preferences and Load the CDOT preference. 

3. On Advanced tab in the Superelevation section, makes sure 
Apply To is toggled on and select First Layer. 

4. Select the Main tab again. 

5. Select Apply. 

Cut Cross Sections 
6. Select Evaluation>Cross Section>Create Cross Sections. 

 Show the Existing and the new surfaces. 

7. Apply, then Close. 

Annotate Sections with slopes 
8. Select Evaluation>Cross Section>Annotate Cross Section. 

9. On the Main tab be sure to: 

 Set Cross Section Set to SH 52 Working. 
 Set Surface to SH52 top. 
 Under Annotate, toggle on Segments and toggle off 

Points and Features. 

10. On the Segments tab, make sure Slope is toggle on under the 
Symbology section. 

11. Apply. 
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Review sections 
12. Select Evaluation>Cross Section>Cross Section Viewer. 

13. Set Cross Section Set to SH52 Working and the other options as 
shown. 

14. Select the section 118+00 and review the slopes. 

If everything worked correctly, the travel lanes will be in full super 
(3.4%) and the bike and turn lanes will be at -1%. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

15. From MicroStation, choose Edit>Select All. 

16. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

17. From MicroStation, select File>Exit. 

18. If prompted to save data files select Yes. 
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Challenge lab 2.5 – Model SH52 median with gutter 
transitions from spill to catch 

Given:  12345 Exist01.dtm 
12345 SH52 top 
12345 SH52.alg (w/median geometry) 
12345 SH52.tml w/ SH52 Median CG; SH52 Median 
CG Spill 

 

Required:  Model the Curb and Gutter for Median 1, using a catch 
gutter on the high side of super on SH52 and a spill 
gutter on the low side. 
 
The given geometry is based on Horizontal and Vertical 
alignment locations as shown below. 
 
Save the median model as SH52 Median 1.dtm 
 
If you have time, repeat the process for Median 3 

 

H&V Alignments 
defined at gutter pan 
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Preliminary set-up 
1. Start MicroStation InRoads and open the file 

12345DesignModel01.dgn. 

2. Select File>Project Defaults. 

3. Set the Configuration Name to 2.5 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

4. Select Apply. 

Important!  Verify your dialog box appears as shown: 

 

5. Open the appropriate data files (refer to Given statement). 
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Note: If you need additional assistance with this lab, follow the 
hints below. 

Model the median 

Review Curb and Gutter typicals 
1. Review the typical SH52 Median CG, which is a catch gutter 

template just for modeling the median. 

2. Also review the typical SH52 Median CG Spill, which is a spill 
gutter template just for modeling the median. 

Create a Roadway Definition slot for the median 
Set up roadway definition so catch to spill transition occurs around 
ends of median with catch on the high side (left) and spill on the low 
side (right). 

1. Select Modeler>Define Roadway. 

2. Select New. 

3. Key in a Name of SH52 Median 01 

4. Key in a Description of SH52 Median starting at sta 100+00 

5. Apply, then Close. 
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Create the Roadway Definition for catch to spill 
transitioning around median 

1. Highlight the SH52 Median 01 roadway definition. 

2. Select Edit. 

3. In the Edit Roadway dialog box, select New. 

First Entry 

4. Keep the beginning station at 0+00 

5. Set Mode to Left. 

6. Key in an Interval of 5 

7. Toggle on Use Transition Template. 

8. Under the Left Column: 

 Set Template to SH52 Median CG Spill. 
 For Catch Point choose Backbone Only. 

9. Apply. 

Second Entry 

10. Key in a Station of 5+00 

11. Maintain all other settings and Apply. 

Third Entry 

12. Key in a Station of 5+30 

13. Set Template to SH52 Median CG. 

14. Apply. 

Fourth Entry 

15. Key in a Station of 10+20 

16. Apply. 

Fifth Entry 

17. Key in a Station of 10+40.30 

18. Set the Template to SH52 Median CG Spill. 

19. Apply 
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Model SH 52 median with catch/spill gutters 
1. Select Modeler>Roadway Modeler. 

2. Select Preferences and Load the CDOT preference. 

3. In the Superelevation section of the Advanced tab, makes sure 
Apply To is toggled off. 

4. Select Apply. 

5. Zoom in to the alignment to see the TC lines. 

6. Cut sections to see the median. 

7. Save the new surface if you are happy with it.  
SH52 Median 1.dtm 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit>Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File>Exit. 

2. If prompted to save data files select Yes. 
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3. Decision Tables 

Overview of Decision Tables 
Decision tables are made up of a series of records, each similar to a segment of 
a template, that defines a sideslope. A table can have more than one definition, 
and can have multiple targets — making it a very powerful tool in defining 
complex sideslopes.  

Template backbones are still used, but the decision tables take over at the hinge 
points to calculate sideslopes. The tables can also used with 3D graphical 
elements or features to calculate sideslopes, such as from ditch bottoms or 
walls. 

Decision tables are stored in the typical section library. CDOT has one default 
decision table stored in CDOT-Typical Sections.tml. When this file is copied 
into the project directory, the decision table may be copied and modified as 
needed. 
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Parts of a Table 
Decision tables are made up of a series of records that define a sideslope 
condition. The records use transition control (TC) names to define the 
beginning and ends of the segments in the sideslopes, with each record defining 
a slope and width as well as the criteria under which the segment will be 
successful. The decision tables are processed perpendicular to a linear control, 
which can be either a template backbone, a 3D graphical element, or a DTM 
feature.  

 

Records 
A record is a single line in a decision table made up of a starting TC name, 
an ending TC name, a slope and a width (along with other criteria discussed 
later). The TC names have two purposes: they define the symbology of the 
longitudinal feature resulting from running the table, and they also provide a 
method for the table to back-track to a previous location in the sideslope.  

Target Blocks 
A target block is a series of records that, together, seek the same target. For 
example, you can create several records that make up cut and fill scenarios, 
but all seek the same existing ground surface, or target. Within the target 
block, you can backtrack if one solution, such as a shallow fill slope, fails, 
and the next solution will be attempted.  

Processing occurs from the top down, evaluating each record in turn. The 
target block continues processing until one segment meets the target. Once a 
segment meets the target, the block is successful and no other records within 
that target block are evaluated. Any records that were not lost to 
backtracking prior to hitting are placed along with the successful record. 
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Tip: A target block is successful if one of the records in the block 
meets its target. 

If no records in a target block meet the target, the block is unsuccessful and 
all records in the block are discarded. If a record in the target block meets 
the target, the block is successful. In either case, the table looks to see if any 
other target blocks exist in the group (see below). If so, the next target block 
in line is processed (unless it is marked Attach After). 

Groups 
One or more target blocks making up a mutually exclusive sideslope 
condition form a group. Only one group in a decision table can be 
successful, since all processing stops when a group is successful.   

An example of mutually exclusive sideslopes broken into groups includes: 
testing with one group to see if a design surface is met, and with another 
group to see if the original ground surface is met, such as the case of a 
divided highway run at separate times. 

Tip: A group is successful if its last target block is successful. 
(Previous target blocks may also be successful.) 

Other previous target blocks may be successful also, but the last one must 
be. Once a group is successful, the processing ends at the current location.  

If the last target block in a group is unsuccessful, all previously successful 
records are discarded and the processing starts over again with the next 
group in the table. If there are no more groups, the decision table fails and 
no sideslope is created at this location. 
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Running a decision table with Roadway Modeler 
The most common use of decision tables is to define sideslopes along a 
roadway corridor. This is done using Roadway Modeler, just like using 
template, cut/fill table or material table sideslopes.  

In the roadway definition, the Catch Point is set to Decision Table and a 
decision table entered. Decision tables are listed in the roadway definition 
editor, so they are selected without having to remember the name and key it in.  
When the roadway is modeled, the decision table picks up at the hinge point 
with its calculations and the cut and fill portions of the template are ignored.  

 

In some situations, a different decision table is needed on each side of the 
roadway. For these times, the roadway definition mode is set to Left and Right 
and a different decision table listed for each. You can also specify a decision 
table for one side and one of the other sideslope alternatives (cut/fill or material 
table, or template) for the other. 

Decision table results 
The results of running decision tables with Roadway Modeler are twofold. 
First, a DTM is created just like when the sideslopes are calculated with 
templates. Second, graphical elements are created longitudinally by connecting 
like TC points in the tables from template drop to template drop. These 
longitudinal lines are actually the features that are part of the resulting DTM, 
and are named according to the TC names in the table. 

Tip: In order to see the features created by Roadway Modeler, 
the TC name’s Feature Style must have the 3D 
Plan/Display toggled on and the Transition Control Lines 
Display option must be turned on in Roadway Modeler (on 
the Advanced tab.) 



 Chapter 3  Decision Tables 

 

Advanced Roadway Modeling  Page 301 

Building a Decision Table 
After creating several decision tables you will no doubt come up with your own 
methods for developing them. Many times, existing tables are copied and 
modified to fit new conditions, saving time in the creation and testing process. 
The following steps define a good path to follow when starting out with 
decision tables, and one that you can modify to fit your needs as your 
proficiency increases.  

The building of a decision table is an iterative process and may require trial and 
error. When starting with the path outlined, keep in mind your initial division of 
target blocks and groups may need to be amended as additional variables are 
uncovered in the design process.1 

1. The best method of starting a decision table is to sketch the desired 
sideslope results. When completing the sketch or sketches, try to 
think of as many existing conditions as possible, and the sideslopes 
that will best fit the conditions. Typically, you will need sideslopes 
for both cut and fill (at a minimum).  

2. The next step in building the table is to break the sideslope 
conditions into groups, or mutually exclusive designs. In a very 
simple table only one group may be necessary, since both cut and fill 
can be addressed in the same group, or even the same target block.  

Tip: When breaking sideslopes into groups, keep in mind only 
one group is successful at any given location, so a group 
must contain a complete sideslope definition.3 

3. After determining the different groups required, break each group 
into target blocks. A target block is allowed only 1 “hit”, so one 
must be developed for each instance a target is reached in a 
sideslope. For example, you may have a fill slope extend to the 
existing ground (target 1), then continue and place a ditch at the toe 
of slope, coming back and intercepting the same existing ground 
again (target 2). 

4. With the preliminary work done, the next step is to create the table. 
Since decision tables may be very complex, it’s always a good idea 
to test the table as you go. Build one group (or even one target block) 
and display the table or test it on a small section of roadway where 
you know it should work. This will help spot problems when it’s 
easier to determine the cause. 
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The Decision Table Interface 
Decision tables are stored in template libraries. They are built record by record 
through a dialog interface, which can also be used to edit the table later. When 
developing each record, criteria are used to determine how the record will react 
under certain conditions. Each of the criteria is described below. 

 

Start TC Name — This is the beginning name of the record. The TC Name 
must exist in the current template library, but it may be created “on-the-fly” 
by selecting New TC name on the Decision Table Record dialog. The TC 
names are used to determine backtracking and the name and style of the 
features resulting from application of the table. 

Tip: The beginning TC name does not have to be Hinge.  
 

End TC Name — The end TC name also determines the name of the 
resulting feature, and serves as a starting point for subsequent records. 

The TC Name must exist in the current template library, but it may be 
created “on-the-fly” by selecting New TC Name on the Decision Table 
Record dialog. 

Slope — This is the slope of the segment created by the current record. It is 
used in all instances with two exception: when the target type is Align XYZ, 
the slope will be variable to meet the horizontal and vertical alignments 
specified. In this case, the slope can be set to 0%, as it will be ignored. The 
same is true when the target if Feature XYZ 
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Width — If the target is reached prior to full width, the segment stops 
(assuming seek intersection is turned on — see Seek Intersection). 
Otherwise the full width is used to place the segment. In segments seeking a 
target, a width greater that ever needed must be used. In other words, the 
segment does not project further than the width, like template cut and fill. 

New Group — This toggle is used to denote the record as the first one in a 
group. The first record in a table must be the first in a group, and the first 
record in a group must begin a new target block. 

Seek Intersection — With seek intersection toggled on, the segment stops 
if the specified target is met. If the toggle is off, the segment extends to full 
width even if it passes through the target. 

Start Repeat Cycle — The start repeat option is useful when repetitive 
records occur in a table, such as in benching situations. Turn the toggle on 
and then key in a number, which specifies the number of times the current 
record and all subsequent records in the block are repeated until an 
intersection is met, or until all repetitions of the records are placed.  

The last record in a table cannot be part of a repeat cycle, so an extra 
“dummy” group may need to be included. 

Attach After Intersection— In some situations, a target block is only 
needed if the previous block is successful. This is the case in toe-of-slope 
ditches. The target block containing the ditch is needed if the previous fill 
slope target block successfully reaches its target.   

This keeps the ditch from being placed if the fill slope fails. This option is 
often used when multiple targets are met with one group, but the subsequent 
target blocks are only used if the previous is successful. 

Construct Point — Also called Generate Point, this option determines 
whether or not the point (if part of a successful solution) will be used as a 
DTM point in the resulting model.  

This option is typically on. Examples of where it should be toggled off 
include determining a variable slope for right-of-way by placing a record at 
0% slope for the right-of-way width, then placing a second record at a near 
vertical to intercept the DTM. The point resulting from the first record 
should not be part of the DTM. 

New Target — Toggling this option on indicates that the record is the first 
one in a target block. It is turned on, even if the record itself is not seeking 
an intersection. All subsequent records seek this target (if Seek Intersection 
is on) until the next New Target record. 

Target Type — There are several target types available: Surface, Fixed 
Elevation, Alignment Elevation, Alignment XYZ, Alignment XY, Feature 
XY, Feature XYZ and Feature Elevation. Each of these options is discussed 
in detail later. 
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Target — After choosing the target type for the block of records, this field 
is used to specify what the target is: the DTM name, alignment name(s) or 
elevation. 

Tip: With Align Z, you must specify the Horizontal alignment it 
belongs to, even though it is not actually used for the 
horizontal location. 

Elevation Adjustment — This option is used if the desired target needs to 
be met at an offset. An example is a toe-of-slope ditch where the fill slope 
continues to a desired offset under the DTM.  

The adjustment is calculated by offsetting the surface if the target is a DTM, 
so the actual intercept point may not be the same depth as the elevation 
adjustment. 

It is beneficial to display the decision table during the building process to 
check the records for problems with slopes and connectivity. Display a 
decision table using Utilities >Display Decision Table from the main 
decision table dialog. 

Tip: The display uses the attached color table and beginning with 
color 1, changes colors with each target block. Within the 
target block, if there is backtracking, each record displays 
with a different line style, beginning with line style 0. 
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Target Options 
One of the most powerful parts of a decision table is the ability to seek an 
intersection with targets other than DTMs. With this benefit, you can 
accomplish the equivalent of independent control outside the backbone of your 
template, along with other equally complex sideslopes.  

The eight available targets are: Surface, Align XY, Align XYZ, Align 
Elevation, Feature XY, Feature XYZ, Feature Elevation, and Fixed Elevations. 
Each of the options is described below. 

 

Surface 
Surfaces or Digital Terrain Models (DTMs) are the most common targets for 
decision tables. Even if other targets are used, the sideslope ultimately 
intercepts a DTM (in most cases). The decision table is more flexible than 
the template or other table options, even in seeking a surface. It allows 
specific DTMs to be targets, thus removing the one DTM limitation of 
template and cut/fill table sideslopes.  

Allowing the choice of different surfaces requires loading DTMs prior to 
creating the decision table. It also means in order to use a decision table on 
multiple projects, the surfaces either need to be named identically, or the 
decision table needs to be edited to specify project-specific surface names. 

Using multiple surfaces within one sideslope condition is useful when 
cutting through different materials. For example, if you have enough data to 
form a surface for rock, it is specified as the initial target in the decision 
table and different sideslope or benching options used. Once the rock 
surface is intercepted, the next target can be the existing ground surface, 
using different sideslopes. 
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Multiple surfaces are also used when there is more than one surface where 
the sideslope can terminate. This occurs in several situations, such as when 
two adjacent DTMs form the existing ground surface. Two groups are used 
in the decision table, identical except for the surface name. It also occurs 
when running a roadway model that ties into a proposed surface in one area 
and the existing terrain in another, such as a divided highway where the two 
travel ways are run independently. 

Alignment Elevation 
The vertical alignment option, called Alignment elevation, allows you to 
target an elevation based on a vertical alignment. The slope specified in the 
table is constant and the elevation of the vertical controls the width of the 
segment, widening or shortening it as necessary. The segment cannot widen 
past the width specified for the record, so it must be large enough to take 
care of all situations.  

Since the horizontal location of the target is calculated, the same vertical 
alignment can used for both sides of the alignment if desired. It is created 
under the mainline horizontal on the main profile grid. If different 
alignments are needed, the TC names must be unique on each side and a 
different alignment created. 

This option is used in several situations, including independent ditches that 
require a constant foreslope, but whose grade is best defined by a vertical 
alignment. It is also used in divided highway situations where the median 
slopes are constant and two different profile grade lines are used. 

Alignment XY 
The horizontal alignment option, called Alignment XY, allows you to target 
a xy location based on a horizontal alignment. The slope specified in the 
table is constant and the location of the horizontal controls the width of the 
segment, widening or shortening it as necessary. The segment cannot widen 
past the width specified for the record, so it must be large enough to take 
care of all situations.  

Since the horizontal location of the target is specified by an alignment, the 
same alignment cannot be used for both sides of the road.  

Alignment XYZ 
The horizontal and vertical alignment target (Alignment XYZ) is the only 
target that ignores the slope specified in the record. When this target is used, 
the sideslope is formed from the starting point of the record directly to the 
location of the combined horizontal and vertical alignments. Even though 
the slope is ignored, the width must still be large enough to encompass all 
situations. 
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If the desired result is to join to a 3D graphic element, the element must be 
used to create a horizontal and a vertical alignment. This is accomplished 
with File >Import >Geometry and choosing the From Graphics tab. Set the 
type to Horizontal and Vertical Alignment.  

Tip: Whether the alignments are created from scratch or from 
graphics, the direction of the alignment does not matter. 

Examples where the Alignment XYZ option is used include: 

 independent ditches that do not have a constant sideslope, but rather 
a defined horizontal path, 

 divided highways that have separate profile grade lines and separate 
horizontal alignments, and 

 urban areas where slopes are designed to match existing 
topographic features next to the roadway, such as a curb line of a 
parking lot.  

Feature XY 
The Feature XY option is similar to the Align XY target, but rather than 
using an alignment, a DTM feature is used.   

Feature XYZ 
The Feature XYZ option is similar to the Align XYZ target, but rather than 
using alignments to define the exact location for the target, a DTM feature is 
used. 

Feature Elevation 
The Feature Elevation option is similar to the Align Elevation target, but 
rather than using an alignment, a DTM feature is used to determine the 
target elevation. 

Fixed Elevation 
The fixed elevation target allows sideslopes to stop at a certain elevation, 
then proceed with another target block and target. The most common 
example is horizontal benching. If the benching is repetitive after reaching 
the first elevation (i.e. the subsequent benches are the same height and 
width), it is more efficient to switch to a DTM target and use Start Repeat 
option. 

When to use a new target 
The new target option is toggled on whenever you are changing targets 
and/or when the previous target block has already hit its target. For example, 
when creating berms at the top of cut, or toe-of-slope ditches, your initial 
DTM target may be the same as the DTM intercepted with the ditch or 
berm. In instances where the additional target is only used if the previous 
one is successful, the Attach After Intersection option is also toggled on.  
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Application of decision table with graphic elements 
Decision tables are used for more than just corridor modeling. There are 
often times when a decision table is needed to calculate sideslopes in areas 
where it is not convenient to run a template, such as gores, ditches, and 
intersection returns. In these instances, the decision table can be run against 
a 3D MicroStation element or a DTM Feature using the Apply Decision 
Table command on the Design Surface toolbar or under Surface >Design 
Surface.  

 

This command functions in a very similar manner to using decision tables 
with roadway modeler. The table is applied perpendicular to the element or 
feature at a user-defined interval, and can be applied to either side. 

Dialog options 
The Apply Decision Table dialog has several options, described below. 

Decision Table — The decision table must be selected from the list box, 
which shows decision tables available from the current template library. If 
there are no decision tables in the current library, the command will not 
activate. 

Reference Feature Interval — This option determines how often the 
decision table is processed or “dropped”. It can be likened to the template 
interval when using Roadway Modeler. If the option is toggled off, the 
decision table will be processed according the Stroke Tolerance option. 
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Stroke Tolerance — If toggled on, this option serves two purposes, both 
of which densify the decision table interval as applied.   

First, it forces the decision table to be applied to all vertices of the graphic 
element, in addition to the reference feature interval. Second, it “strokes” 
any curves, arcs or curvestrings in the graphic element. This is accomplished 
by segmenting the element based on chord height. The value is the tolerance 
in master units of the chord height used to segment or stroke curve, arc, or 
curvestrings. 

Exterior Arc — This is the angle used to determine the number of “drops” 
around an exterior corner. The smaller the arc, the smoother the toe line. 

Direction — The decision table is applied to the left, right, or both sides of 
the feature or element. Left and right are determined by either the direction 
the element was created (when the Reset for Entire element option is used) 
or by the direction of the start and end data points (when the Data for 
Beginning, Data for Ending option is used). 

Decision table results 
When applying the decision table, there are several options for the format of 
the results. Graphics are generated longitudinally, connecting TC names (if 
the Display option is turned on for each TC name used in the decision table). 
The symbology of the lines is controlled by the TC name as it is when 
decision tables are used with Roadway Modeler. The exception to this is 
the Final Intersection Name as described below. 

In addition, a DTM can be built from running the decision table, similar to 
using Roadway Modeler. The creation of the surface and various options 
are controlled by the following toggles: 

Generate Graphics Only — When toggled off, this option adds 
longitudinal features from the TC lines to the specified Design Surface as 
breaklines.  

If you are testing a decision table, for example, you may only want the 
graphics from this command and can toggle this option on. 

Triangulate Surface — Once the linear features are added to the surface 
(see above), the surface can be triangulated. If more than one run is used 
(for example, if you are running one table on the right side of an element 
and another on the left), this option can be left off, and the surface 
triangulated after all runs are complete. 

Add Primary Feature to Surface — The primary feature is not included 
in the surface generated by running the decision table, unless this toggle is 
on. Unless the element used as the primary feature is already a part of the 
surface, you will typically want this option on. 
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Duplicate Names — If the Generate Graphics Only options is toggled 
off, you have options on what to do when the software runs into features that 
are named the same as the ones created by this command (the features are 
named according to the TC names).  

 Append combines the features into one,  
 Replace deletes the original feature,  
 Rename assigns a suffix to the feature name, and  
 Modify changes the portion of the feature that is 

duplicated. 

Final Intersection Feature Name — The name used here will be the 
transition control name assigned to the final intersection point when the 
decision table is run. The feature name specified must exist as a TC name in 
the typical section library. If this entry is left blank, the TC name specified 
by the table is used.  

Remove Loops — Toggle the Remove Loops option on and the software 
attempts to uncross any overlaps caused by sharp curves or interior corners 
in the original element. 

Applying the command 
Before Applying the command, you must set the Locate Feature/Locate 
Graphics toggle to the desired option. The command works under either, 
depending upon whether the source is a feature or graphic element. The 
prompts change depending on the toggle, asking for either features or 
elements. 

When the command is applied, it prompts for the primary feature (or 
element), which is identified graphically. The option is then given to Reset 
for the entire element, in which case the direction the element was created is 
the determining factor in what is left and what is right. The other option is to 
data point for the beginning, then the end of the area you want to apply the 
table, in which case the left and right are determined by the beginning and 
end points. 
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Troubleshooting 
It is easiest to troubleshoot decision tables as they are being built, but 
sometimes that is not possible. In cases where you run into a decision table that 
doesn’t work, try the following options to diagnose the problem. 

Tip: If your decision table is not working correctly, a backbone 
will still be created when you use Roadway Modeler. If 
Roadway Modeler does not run, your problems are not 
typically with a decision table. 

Display the table 
Displaying the decision table can often uncover problems that would be 
otherwise hard to diagnose. Look for the proper slopes, and the division of 
groups and target blocks. You may want to display the decision table at the 
hinge point of your backbone in a cross section where the slopes are not 
working properly. This is very beneficial in determining which, if any, of 
the sideslopes should have met the target. 

Check connectivity 
 Make certain that the TC names are used correctly so that any planned 
backtracking can take place. 

Draw the table 
Go through the table step-by-step, drawing and labeling TC names for each 
record. Be certain to note what is toggled on and what is toggled off. 

Check the “rules” 
Remember, the last target block in a group must succeed in order for the 
group to succeed, even if previous target blocks are successful. You may 
need to divide a group into two groups if there are two mutually exclusive 
target blocks, since the last one will likely fail when the first is successful. 
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Lab 3.1 – Create a decision table for variable slopes 
In this activity, you will create a decision table from scratch to intercept the 
DTM at multiple slopes. The criteria for determining which slope to use is the 
depth of cut or the height of fill. 

You will run the decision table along the 71st Street corridor. 

 
 

71st Street 



 Chapter 3  Decision Tables 

 

Advanced Roadway Modeling  Page 314 

Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellandous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown.  

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 3.1 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for 71st Street 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 71st.alg and then select Open. 

4. Do not cancel out of the box. 

Load the template library for 71st Street 

5. Set File of Type to Typical Section Libraries (*.tml). 

6. Highlight 12345 71st.tml and then select Open. 

7. Do not cancel out of the box. 

Load the roadway library for 71st Street 

8. Set File of Type to Roadway Libraries (*.rwl). 

9. Highlight 12345 71st.rwl and then select Open. 

10. Do not cancel out of the box. 

Load the existing DTM 

11. Set File of Type to Surfaces (*.dtm). 

12. Highlight 12345 Exist01.dtm and then select Open. 

13. Cancel the Open dialog box. 
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Create a decision table 
1. The following criteria must be met for your sideslopes: 

Cut Slopes 
Slope 6:1 where Cut is 5’ or less 

Slope 4:1 where Cut is 5’ to 10’ 

Slope 3:1 where Cut is 10’ to 15’ 

Slope 2:1 where Cut is over 15’ 

Fill Slopes 
Slope 6:1 where Fill is 5’ or less 

Slope 4:1 where Fill is 5’ to 10’ 

Slope 3:1 where Fill is 10’ to 15’ 

Slope 2:1 where Fill is over 15’ 

2. Sketch the decision table before proceeding. 
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Create a name for the decision table.  
1. On the Design Roadway toolbar, select Define Typical Sections. 

 

2. Select the Decision Tables tab.  

 Select New. 
 Enter the Name:  Variable Cut and Fill. 
 Enter the Description: Variable slope in cut and fill 

3. Select Apply, then Close. 
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Define the cut slopes. 
1. Select Variable Cut and Fill from the available list. 

 

2. Select Edit. 
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Define the first record  

3. Select Add After. 

 

4. First, set the Target information: 

 Toggle on  New Target. 
 Toggle on New Group. 
 Toggle the Target Type to Surface. 
 Toggle the Surface to Existing01. 

5. Next, set the Segment Information: 

 Start TC Name:   POSS. 
 End TC Name:  Top-of-Cut. 
 Slope:  1:6  
 Width:  30  (which corresponds to a 5’ depth) 
 Toggle on: Construct Point and Seek Intersection. 
 Toggle off:  Attach After … and  Start Repeat Cycle. 

6. Choose Apply. 
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Define the second record while in the Decision Table Record dialog 

 

7. First, set the Target information: 

 Toggle off New Target. 
 Toggle off New Group. 

This segment is part of the same target block and therefore must not 
have either of these toggled on. 

8. Next, set the Segment Information: 

 Start TC Name:   POSS. 
 End TC Name:  Top-of-Cut. 
 Slope:  1:4  
 Width:  40  (which corresponds to a 10’ depth) 
 Toggle on:  Construct Point and Seek Intersection. 
 Toggle off:  Attach After … and Start Repeat Cycle. 

9. Choose Apply. 
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Define the third record 

 

10. First, set the Target information: 

 Toggle off  New Target. 
 Toggle off New Group. 

This segment is part of the same target block and therefore must not 
have either of these toggled on. 

11. Next, set the Segment Information: 

 Start TC Name:   POSS. 
 End TC Name:  Top-of-Cut. 
 Slope:  1:3  
 Width:  45  (which corresponds to a 15’ depth) 
 Toggle on:  Construct Point and Seek Intersection. 
 Toggle off:  Attach After … and Start Repeat Cycle. 

12. Choose Apply. 
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Define the fourth and final record in the cut group 
Be certain to use a large width, since the last record must be able to 
catch when all previous records have failed. 
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Define the first record in the fill group 

 

13. First, set the Target information: 

 Toggle on  New Target. 
 Toggle on New Group. 
 Toggle the Target Type to Surface. 
 Toggle the Surface to Existing01. 

14. Next, set the Segment Information: 

 Start TC Name:  POSS. 
 End TC Name:  Toe-of-Fill. 
 Slope:  -1:6  
 Width:  30  (which corresponds to a 5’ height) 
 Toggle on:  Construct Point and Seek Intersection. 
 Toggle off:  Attach After … and Start Repeat Cycle. 

15. Choose Apply. 



 Chapter 3  Decision Tables 

 

Advanced Roadway Modeling  Page 325 

Define the other fill records from the table 
Don’t forget, the fill slopes must be negative. 

 

16. Choose Close on the Edit Decision Table dialog. 

Note:  The cut and fill are in separate groups so they can easily be 
distinguished when editing or reviewing the table. However, 
they could also be in the same group as long as they are in 
the same target block. 

17. Close the Define Typical Section dialog. 

Save the decision table 
The decision table is stored in the typical section library. 

1. Choose File > Save > Typical Section Library. 
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Create a new roadway library entry 
You will modify the existing roadway definition to use the decision 
table created in the previous steps. 

1. Select Modeler > Define Roadway. 

 

2. From the Define Roadway dialog box, 

 Highlight the new roadway definition, 71st 594+15 to 
600+00. 

 Select Edit. 
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3. Select the first station in the list and select Edit. 

 Set the Catch Point to Decision Table. 
 In the Name field and select Variable Cut and Fill from 

the drop-down list. 

 

4. Select Apply. 

5. Select Next to move to the next station entry in the list. 

6. Continue for all the stations setting: 

 Catch Point to Decision Table and Name to Variable 
Cut and Fill 

 Apply after each, then choose Next. 

7. When complete, select Close to dismiss the Roadway Entry dialog 
box. 

8. Select Close to dismiss the Edit Roadway dialog box. 

9. Select Close to exit the Define Roadway box. 

Save the roadway definition 
1. Select File > Save > Roadway Library. 

The file 12345 71st.rwl is saved to the hard disk. 
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Run Roadway Modeler 
1. Select Roadway Modeler. 

2. On the Main tab, select the data to be used by Roadway Modeler.  

 

 Under the Roadway list select 71st 594+15 to 600+00. 
 Under the Original Surface list highlight only 12345 

Exist01. 
 For the station limits, set the Stop station to 600+00. 

3. Select Apply. 

The templates are applied along the alignment for the backbone, 
using the decision table to determine the sideslopes. 

4. Select Close to dismiss the Roadway Modeler dialog box. 
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Save your new surfaces 
1. Save the finished grade surface created with Roadway Modeler to 

the hard disk. 

View the results of Roadway Modeler 
1. Zoom in or out as needed with MicroStation to visually review the 

display of the Transition Control (TC) lines.   
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Display the triangles for the proposed surface 
1. Select Surface > View Surface > Triangles. 

2. Set the Surface to 71st top. 

3. Select Apply then Close. 

4. Use the MicroStation View Control commands to take a closer look 
at the display.  (Try rotating a view to see the variable slopes.) 

 

5. Use MicroStation Delete Element to delete the triangle display 
(graphic group lock on). 

View contours for the proposed surface 
1. Select Surface > View Surface > Contours. 

 Set the Surface to Finished Grade. 
 Select Preferences and load Proposed 10’ Mjr. – 2’ 

Minor. 

2. Select Apply. 

3. Use MicroStation View commands to take a closer look at the 
contours. 

4. Use MicroStation Delete Element command to delete the contour 
display. 

Remember that the contour display is a graphic group. 
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Challenge 
Notice the areas near the intersection where the sideslopes ‘jump’ back and 
forth from a 4:1 to a 3:1 and back to 4:1. 

 

 

 

Suppose you decide that the slopes should remain 4:1 through this area. 
How would you go about forcing the slopes? 

Create Cross Sections 
1. Create cross sections showing the new surface along with the 

existing surface. 

2. Run the Cross Section Viewer. 

Watch for the sideslopes to change as defined by the decision table. 

3. Close the Cross Section Viewer dialog. 

4:1 

4:1 

3:1 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 3.2 – Using a decision table to ‘catch’ another 
surface 

In this activity, you will create a target surface for a decision table to catch. 
SH119 SB will be modeled with an extended backbone on the median side to 
provide a target for the decision table. Then, you will create a table that catches 
this extended backbone where it can, and the existing ground where it cannot. 

If you completed lab 2.1, you created identical templates. Here, you’ll only 
review them before modeling. 

 
 

SH119 SB will be 
modeled with an 

extended backbone 
on the median side 

You will create a decision table 
for SH119 NB that intercepts 
the extended backbone OR the 
existing ground 

Through the overpass 
area, both sides of the 

median will go to a 
shallower, 10:1 slope. 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 



 Chapter 3  Decision Tables 

 

Advanced Roadway Modeling  Page 335 

Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 3.2 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH119 SB 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH119 SB.alg and then select Open. 

4. Do not cancel out of the box. 

Load the template library for SH119 SB 

5. Set File of Type to Typical Section Libraries (*.tml). 

6. Highlight 12345 SH119 SB.tml and then select Open. 

7. Do not cancel out of the box. 

Load the roadway library for SH119 SB 

8. Set File of Type to Roadway Libraries (*.rwl). 

9. Highlight 12345 SH119 SB.rwl and then select Open. 

10. Do not cancel out of the box. 

Load the existing DTM 

11. Set File of Type to Surfaces (*.dtm). 

12. Highlight 12345 Exist01.dtm and then select Open. 

13. Cancel the Open dialog box. 
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Review the current setup for SH119 SB 
1. Select Modeler > Define Roadway and review the roadway 

definition. 

 

Notice there are two templates used; the 6:1 median and the 10:1 
median.  

2. Edit the entries and notice that the Catch Point is set to Backbone 
Only for all entries.  

3. Select Modeler > Define Typical Sections. 

 

Notice each of the two templates has an extended slope in the right 
backbone, which will provide the target for the decision table on the 
Northbound side. 
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Model SH119 SB 
1. Select Modeler > Roadway Modeler. 

2. Set the Main tab as shown. 
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3. On the Advanced tab  

 Toggle off Apply To under Superelevation. 
 Key in SB119SB for Left and Center. 
 Key in SB119 SB for the Right Prefix. 

Note:  Left and Right prefixes cannot be identical; therefore you 
will use a space in the Right one. 

 Set all other options as shown. 

  

4. On the Layer Controls tab, make sure Use Layer Controls is turned 
off. 

5. Select the Main tab again and then select Apply. 

The SB 119 corridor is modeled with the backbone on West (left) 
side and large sideslopes on East (right) side as defined in the 
template. 

6. Close the Roadway Modeler box. 

7. Fit the view. 

Use a space 
before “SB” for 

Right Prefix 
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Note: Make sure that Expand Clipping Planes is turned on in the 
Fit View Settings box. 

 

8. Zoom in to the beginning of the alignment to see the TC lines. 

 

TC line for the expanded 
sideslope. It will not be 
used in the final model. 

SH119 NB 

SH119 SB 
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Save the SH119 SB finished surface 
1. Choose File >  Save As. 

2. Set the Save as type to Surfaces (*.dtm). 

Note: Make certain you’re in the 3.2 sub-folder. 

3. Set Active to SH119 SB top. 

4. Verify that the File name is also SH119 SB top. 

 

5. Select Save. 

6. Cancel the dialog box. 

Generate Cross Section along SH119 SB 
1. Change the Text Scale Factor to 40 under Tools > Options > 

Factors. 

2. Select Evaluation > Cross Section > Create Cross Section. 

3. Select Preferences, highlight the Stacked 20 per column 
preference and Load. 
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4. Close the Preferences box. 

5. Set the Main tab as shown.  

 Make sure that alignment SH119 SB-H is selected and  
 Turn on the 12345 Exist01 and SH119 SB top surfaces.  
 Key in the Set Name SH119 SB Working 

 

6. Apply. 

7. <D> anywhere in a clear area to plot the cross sections. 
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8. Window in and take a look at the some of the cross sections. 

Note: The minor grid lines have been turned off in the diagram 
below for clarity purposes. 

 

Use Cross Section Viewer to review sections 
1. Select Evaluation > Cross Section > Cross Section Viewer. 

2. Set Cross Section Set to SH119 SB Working and the other options as 
shown. 

3. Select Run. 

Note: Watch for the 6:1 to 10:1 transition between stations 
2292+00 and 2293+00. 
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Load files for SH119 NB 
Now that the target is ready, you will continue with the Northbound median 
decision table. 

Load geometry project for SH119 NB 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH119 NB.alg and then select Open. 

4. Do not cancel out of the box. 

Load the template library for SH119 SB 

5. Set File of Type to Typical Section Libraries (*.tml). 

6. Highlight 12345 SH119 NB.tml and then select Open. 

7. Cancel the Open dialog box. 

Review Data 
8. Make SH119 NB-H the active horizontal alignment 

9. Review the template in SH119 NB.tml. 
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Create a Roadway Library for SH119 NB 
1. Select File > New. 

2. Select the Roadway Library tab. 

3. Key in a Name of 12345 SH119 NB 

4. Key in a Description of Northbound roadway definitions 

 

5. Apply, then Close the New box. 

Create a Roadway Definition slot 
1. Select Modeler > Define Roadway. 

2. Select New. 

3. Key in a Name of SH119 NB. 

4. Key in a Description of LT side ties to SB surface 

 

5. Apply, then Close. 
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Create the Roadway Definition for one template 
1. Select Edit. 

2. In the Edit Roadway dialog box, select New. 

 Keep the default beginning station. 
 Set Mode to Both. 
 Key in an Interval of 10 
 For Template, choose SH119 NB 0L – 2L. 
 For Catch Point choose Backbone Only. 

 

3. Apply. 

4. Close the Roadway Entry box. 

5. Close the Define Roadway box. 
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Save roadway library 
1. Select File > Save > Roadway Library. 

2. In the Save As dialog box, verify that the File name is set to 
SH119 NB.rwl 

3. Select Save, then Cancel the dialog box. 

 

Model SH119 NB (backbone only) 
1. Select Modeler > Roadway Modeler. 

2. Set the Main tab as shown. 
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3. Set the Advanced tab as shown.  

Note: Don’t forget to key in the alignment name prefixes. The Left 
and Right prefixes must be unique, so include a space before 
the N for the Right Prefix (e.g. SH119 NB).  

 

4. Select Apply. 

The SH119 NB corridor is modeled with the backbone only on both 
the East and West sides. A new surface SH119 NB top is created. 

5. Close the Roadway Modeler box. 
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6. Zoom in to the alignment to see the TC lines. 
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Generate Cross Section along SH119 NB-H 
You’ll create cross sections wide enough to show the SH119 SB 
surface. 

1. Set the Scale Factors to 40 

 

2. Select Evaluation > Cross Section > Create Cross Section. 

3. Select Preferences, highlight the Stacked 20 per column 
preference and Load. 

4. Close the Preferences box. 
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5. Set the Main tab as shown.  

 Make sure that alignment SH119 NB-H is selected and  
 Key in the Set Name as shown. 
 For the Left and Right offsets, key in -160 and 160 
 Turn on the 12345 Exist01, SH119 SB top and SH119 NB 

top surfaces. 

 

6. Apply. 

7. <D> anywhere in a clear area to plot the cross sections. 

Review sections 
1. Select Evaluation > Cross Section > Cross Section Viewer. 

2. Set Cross Section Set to SH119 NB-H working . 
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3. Select Run. 

The cross sections show the backbone surface of the SH119 NB 
alignment as it relates to the Existing and SH119 SB finished 
surfaces (minor gridlines removed below for clarity purposes). 
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Create a decision tables for sideslopes on the left 
You’ll now create sideslopes for the left (West) side of SH119 NB to 
tie into either the existing surface with a 3:1 slope or the SH119 SB 
median surface with a 6:1 slope or a 10:1 slope. 

1. Create a sketch for your decision table. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Select Modeler > Define Typical Section. 

3. Select the Decision Table tab. 

4. Select New. 

5. Key in a Name of SH119 NB 6:1 intercept with SB 

6. Key in a Description of 6:1 to SH119 SB or 3:1 to existing 

 

7. Apply, then Close the New box. 

8. Select Edit. 

9. In the Edit Decision Table box, select Add After. 
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First record 

10. The first record is for the -6:1 median sideslope that seeks the  
SH119 SB surface where there is not enough room to tie into the 
existing ground.  

 Set the dialog box as shown: 

 

 Apply. 
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Second Record 

11. The second record is for a 3:1 “wide” median situation where you’re 
seeking the existing ground (new group) with a 3:1 cut slope.  

 Set the dialog box as shown: 

 

 Apply. 
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Third Record 

12. The third record is for a 3:1 “wide” median situation where you’re 
seeking the existing ground with a 3:1 fill slope.  

 Set the dialog box as shown: 

 

 Apply. 

13. Close the Decision Table Record dialog. 

The Decision Table should appear as shown. 

 

14. Close the Edit Decision Table dialog. 
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Copy and Edit the table to create a 10:1 table 
1. Highlight the new decision table and choose Copy. 

2. Change the name and description to indicate a 10:1 slope as shown. 

 

3. Choose Apply, then Close. 

4. Edit the copied decision table to have a -10:1 slope for the median. 

5. Save the Typical Section Library. 
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Edit roadway definition 
Change the roadway definition to model your sideslopes. Use the 
decision table for the left side and model the right side backbone 
only. 

1. Select Modeler > Define Roadway. 

2. Highlight the SH119 NB definition and select Edit. 

3. In the Edit Roadway box, highlight the station/template entry and 
select Edit. 

4. Set Mode to Left and Right. 

5. Under the Left column: 

 Set Template to SH119 NB 0L – 2L. 
 Set Catch Point to Decision Table. 
 Set Name to SH119 NB 6:1 intercept with SB. 

6. Under the Right column: 

 Set Template to SH119 NB 0L – 2L. 
 Set Catch Point to Backbone Only. 

 

7. Apply. 

8. Close the Roadway Entry dialog. 
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9. From the Edit Roadway box, Select New to add new entries as 
shown: 

Note: Don’t forget to Apply after each new entry. 

Station Left Template / Catch Point Right Template / Catch Point 

1292+90 SH119 NB 0L – 2L SH119 NB 0L – 2L 

 SH119 NB 6:1 intercept with SB Backbone Only 

1293+00 SH119 NB 0L – 2L SH119 NB 0L – 2L 

 SH119 NB 10:1 intercept with SB Backbone Only 

1300+90 SH119 NB 0L – 2L SH119 NB 0L – 2L 

 SH119 NB 10:1 intercept with SB Backbone Only 

1301+00 SH119 NB 0L – 2L SH119 NB 0L – 2L 

 SH119 NB 6:1 intercept with SB Backbone Only 

10. After the last entry, Apply, then Close the Roadway Entry box. The 
entries should appear as shown. 

 

11. Close the Edit Roadway box. 

12. Save the Roadway Library. 
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Re-Model SH119 NB with sideslopes on the left 
1. Delete the TC lines from the previous model run. 

2. Select Modeler > Roadway Modeler. 

3. Set the Main tab as shown. 
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4. Set the Advanced tab as shown. 

 

5. Select Apply. 

The SH119 NB corridor is modeled with the sideslopes from the 
decision table on West (left) side. 

6. Zoom in to the alignment to see the TC lines. 

 

TC line showing point 
where NB decision 
table ‘catches’ the 
extended slope from 
SB. 
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Update cross sections 
1. Select Evaluation > Cross Section > Update Cross Section. 

2. Set the dialog box as shown. 

 

3. Apply. 
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Window in on the SH119 NB working cross section set and review 
cross sections. Note the 3:1 sideslope on the left that ties to the 
existing ground. 

 

The 6:1 sideslope on the left that ties to the SB119 finished surface.  

 

Also note the change to the -10:1 slope under the proposed SH 52 
bridge. 

 

10:1 slope to 
South Bound

6:1 slope to 
South Bound

3:1 slope to 
Existing
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Save the SH119 NB finished surface 
1. Choose File > Save As. 

2. Set the Save as type to Surfaces (*.dtm). 

3. Set Active to SH119 NB top. 

4. Set the File name to 12345 SH119 NB top. 

5. Select Save. 

 

6. Cancel the dialog box. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 3.3 – Using a decision table to intercept an 
existing feature 

In this activity, the left side of SH119 NB uses a decision table to tie into a 
surface created by modeling SH119 SB (which establishes the median). On the 
right side you will create a different decision table to tie into features in the 
existing terrain. This technique can be used for tying into existing ROW, an 
existing ditch bottom, etc. 

 

 
Note: SH119 NB is always in a fill situation, which makes the 

table somewhat simpler than if it passed through both cut 
areas and fill areas. 

 

SH119 NB 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 3.3 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH119 NB 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH119 NB.alg and then select Open. 

4. Do not cancel out of the box. 

Load the template library for SH119 NB 

5. Set File of Type to Typical Section Libraries (*.tml). 

6. Highlight 12345 SH119 NB.tml and then select Open. 

7. Do not cancel out of the box. 

Load the roadway library for SH 119 NB 

8. Set File of Type to Roadway Libraries (*.rwl). 

9. Highlight 12345 SH119 NB.rwl and then select Open. 

10. Do not cancel out of the box. 

Load the SH119 SB DTM 

11. Set File of Type to Surfaces (*.dtm). 

12. Highlight 12345 SH119 SB top.dtm and select Open. 

13. Do not cancel out of the box. 

Load the existing DTM 

14. Highlight 12345 Exist01.dtm and then select Open. 

15. Cancel the Open dialog box. 
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View Features for tie-in 
The diagram below shows the different features that you want to tie 
into. Your goal is to tie into the feature closest to the POSS, which 
will determine the order of the records and groups in the decision 
table. 

1. View the features Terrain 1552, 1335, 1283 and 1409 from the 
surface TRNARM Exist01. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 1409 

1552 
1335 

1283 
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Sketch the table 
2. Sketch the different scenarios you will run into with the sideslopes. 

Each scenario should represent one complete sideslope and therefore 
one group in the table. Study the features you’re tying into carefully 
to determine the order the records will need to be in the table. 
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Challenge 
If you would like to test your decision table skills, create the table without 
referring to the following steps. Run it on the right side of SH119 NB and 
check your results. If you need more practice before tackling a decision 
table on your own, continue with the steps below. 

Build the table 
1. Select Modeler > Define Typical Section. 

2. Select the Decision Table tab. 

 

3. Select New. 

 

4. Key in the name SH119 NB RT intercept exist ftrs. 

5. Key in the description RT side to intercept feature in 
Existing surface 

6. Select Apply. 

7. Make certain the new table is highlighted and select Edit. 
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First record 

8. Choose Add After and set the options for the first record as shown. 

 

 

Second record: 
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Third record: 

 

 

Fourth record: 
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Fifth record 

9. For the fifth record, you will use a new group that seeks to intercept 
the existing ground at a -3:1 sideslope in areas where you are not 
intercepting an existing feature. 

 

Your decision table should look like the one below. 

 

10. Close the open dialogs. 

11. Save the Typical Section Library. 
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Update the Roadway Definition 
1. Select Modeler > Define Roadway. 

 

2. Highlight SH119 NB and choose Edit. 

You want the sideslope on the right to tie into the existing features 
up to the point that the modeling starts using the ramp template. 
Since this occurs at station 1285+82.30, you will use the new 
decision table for the first entry in this definition. In a later exercise, 
you will be adding to this roadway definition to transition into the 
ramp. 
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3. Highlight the first entry and select Edit. 

 

4. In the Right column, change the Catch Point to Decision Table. 

5. For the Name, select SH119 NB RT intercept exist ftr. 

6. Choose Apply. 

7. Close the open dialogs. 

8. Save the roadway library. 

Run modeler 
1. Run Roadway Modeler on SH119 NB from the beginning of the 

alignment up to station 1285+82.30 
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2. Review the SH119 NB features in plan to see that they follow the 
existing features. 
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3. Cut cross sections for the same station range as the model and review 
the sideslopes. Alternately, you can update the previously cut 
sections. 

4. Show: SH119 SB top, SH119 NB top, TRNARM Exist01. 

 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Challenge Lab 3.4 – Create decision table to develop 
wall between ramp and NB 119 

Given:  12345 Exist 01.dtm 
12345 SH119 NB top.dtm 
12345 RampA.rwl 
12345 RampA.tml 

 The following sketch: 

 

 

 

 

Required: Build a table for the left side of the ramp 
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Preliminary set-up 
1. Start MicroStation InRoads and open the file 

12345DesignModel01.dgn. 

2. Select File>Project Defaults. 

3. Set the Configuration Name to 3.4 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

4. Select Apply. 

Important!  Verify your dialog box appears as shown: 

 

5. Open the appropriate data files (refer to Given statement). 
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Build the table 
1. Since the area prior to the beginning of the wall will use a variable 

slope and triangulate between the SH119 NB and RampA, you do 
not have to include anything in the table except the wall. The wall 
will fail in the areas prior to where it is necessary, allowing for the 
variable slope. 

2. Save your .tml 

Update the Roadway Definition 
1. Update roadway definition to use the decision table to create a wall 

on the left side. 

2. Save .rwl. 

Model with the table 
1. Run Roadway Modeler between stations 3285+83 and 3296+00 

to create the ramp with the wall on the left side. 

 

Create cross sections 
2. Create Cross Sections of SH119 NB. 

 Show SH119 NB top, SH119 SB top, RampA. 

3. Save RampA surface when you are satisfied with the results. 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit>Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File>Exit. 

2. If prompted to save data files select Yes. 
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4. Feature Modeling and Manipulation 

Overview 
It is not unusual for a project to require more detail than a surface generated by 
Roadway Modeler can provide. Intersections, interchanges, and divided 
highways are but a few of the many examples. In these cases, it is often a first 
inclination to merge surfaces and build the model in phases. While this is 
sometimes a viable solution, the surfaces do not always merge properly and 
after many merges it’s not unusual for a surface to refuse to merge further. 

Another option to consider is using a feature modeling approach. Rather than 
try to build a final surface by continual merges, build breaklines for your 
surface. With this approach, you can use almost any tool you need to contribute 
to the model. Instead of trying to force one command (e.g., Modeler) to create 
everything, use individual commands to produce only their proficiency, and 
then combine their resulting breaklines for your overall model.  

Also, since features within a DTM are editable, you can create the composite 
model as described above, but instead of waiting until the end and doing your 
“cleanup” with MicroStation, you can add the features to the model as they are 
created. Then, using the Surface Edit tools, you can do any cleanup necessary. 
The surface edit tools are similar to MicroStation commands, except they work 
directly with the DTM data.  

Techniques 
The techniques shown here can be used in one of two ways. With the wire-
frame method, they are used to generate MicroStation graphics which will later 
be loaded into a single surface. This method typically required some “cleanup” 
work to be completed with MicroStation. Several of the commands have an 
option to “Generate Graphics Only”, which is useful for this method when 
you do not want to build the model as you go. 

The second method is used to build the model as you go. Each of the 
commands is used to create breaklines in a DTM in addition to the graphical 
elements. Then, instead of using MicroStation for the cleanup, you can use the 
Surface Editing tools (as described in the next section) to fine-tune the DTM 
directly. 
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Roadway Modeler 
Anything that can be defined with a typical section and a horizontal and 
vertical alignment can be modeled with Roadway Modeler. What do you 
get from Roadway Modeler that can be used for feature modeling? 
Features, of course. These breaklines are easily generated and can often 
form the basis for your overall model. When creating and assigning TC 
names, keep in mind that it will be much easier to build an accurate model if 
you can easily tell what the elements represent. Do this by assigning proper 
TC names when building templates. You may need to run Modeler several 
times to develop all of the necessary features. 

Generate Sloped Surface 
This command, found under Design Surface, creates breaklines in the 
graphics file and optionally in the surface that form slopes from a 
MicroStation element or a feature. For example, you can create a sideslope 
around a building pad, or slopes from a detention pond bottom to an existing 
DTM. The results of the command are MicroStation elements forming the 
toe of slope and transverse lines from the original element to the toe at each 
point a slope is calculated. These elements can also be created as features in 
the resulting DTM.  

   

Tip: When only the toe of slope is required for the wire-frame, 
turn off all options except Toe-of-slope. 
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Decision Tables 
Decision tables are used with great results in computing sideslopes during 
Roadway Modeler runs, but they can also be used to generate slopes from 
a graphic element. With Design Surface > Apply Decision Table you can 
use a decision table from the loaded template library to create slopes from 
one or both sides of a graphic element or feature to the target or targets 
listed in the table.  

 

You have a choice of results when using this command. You can either use 
the graphics as part of your overall wire-frame model, or you can toggle off 
the Generate Graphics Only option and the features are added to the 
specified surface as breaklines.   

A decision table can achieve some of the same results as the Generate 
Sloped Surface command, but it allows more flexibility in the sideslopes 
themselves, since the decision table can try various sideslopes, seek multiple 
targets, etc. 
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Generate Longitudinal Feature 
The Generate Longitudinal Feature command is a useful tool for drawing 
3D elements. It allows you to draw a MicroStation element without regard 
to the elevation, then execute this command to copy it and define horizontal 
and/or vertical offsets from the original element. The vertical definition can 
include offsets from the original element, desired actual elevations of the 
ends of the element, an elevation and slope along the element, etc. This is 
great for developing 3D breaklines with certain slopes, such as the bottom of 
a special ditch, the perimeter of a parking lot, or the bottom of a detention 
pond. 

   

Again, this command can either create only MicroStation elements (by 
turning on Generate Graphics Only), or it can add the resulting features to 
the specified DTM as breaklines. 

3D Alignment 
If you find it easier to define horizontal and vertical alignments to set the 
elevations and grades of your proposed breaklines, then View > 3D 
Alignment is for you. It allows you to “combine” the horizontal and vertical 
alignment to form a 3D linestring. Using this option, you can create the 
horizontal alignment, profile it, then use the vertical edit or vertical design 
tools to generate the necessary elevations.  

If you prefer to draw with MicroStation, use File > Import > Geometry 
from Graphics to load the initial alignments from your MicroStation file. 

While the 3D Alignment command does not create breaklines directly, you 
can use File > Import > Surface > From Graphics to load the features as 
breaklines into the composite model or File > Export > Geometry to 
Surface. 
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Graphics  
In addition to the InRoads commands that are available, you can also use 
MicroStation tools to develop 3D breaklines. While the InRoads tools are 
often more flexible in defining the z-coordinate, there are times when these 
commands work just as well. 

Feature Editing Tools 
If you choose to build the DTM as you go while using the Design Surface 
Tools, there is a series of tools available for use in editing, including many 
you’ll recognize as similar to graphical editing tools — Partial Delete, Trim, 
Extend and Intersect to name a few. In addition, there are some very handy 
tools designed specifically for editing features. Two examples include Edit 
Feature Point, which allows the editing of individual points in a feature, and 
Set Slope Along Features, which allows you to set the slope (directly or 
indirectly with elevations) between any two points in a feature, with the 
intermediate points adjusting to accommodate the slope. 

 

You can also edit features in cross sections and affect individual sections or a 
range of sections. This is most useful when the features are longitudinal along a 
corridor. 

The tools used for editing features in plan are predominately found on the Edit 
Surface and Design Surface toolbars. 
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Creating Master Proposed Models 

Cleanup 
If you’re careful when building the different features, then cleanup will not 
be too difficult. However, if the model requires two or more runs of 
Roadway Modeler, you often have duplicate lines where the modeler runs 
intersect or are adjacent. It is very important to make certain there are not 
duplicate breaklines in the model; care should be taken to cleanup or trim 
back any unnecessary overlaps. You may also need to use Generate 
Longitudinal Feature, Fillet Features or others to “join” two Roadway 
Modeler runs, such as for creating returns in intersection areas. 

 

If you build the model as you go, adding features to the surface, then the 
cleanup is accomplished by editing features rather than graphics.   
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Feature modeling tips  
When building feature-based models with MicroStation graphics, there are 
several tips that can help ensure good results.    

 Correct bad elements or features by copying them with Generate 
Longitudinal Feature using no horizontal or vertical offsets. This 
can sometimes correct problems such as small overlaps that are 
difficult to find in an element or feature.     

 Use Maximum Segment Length and/or Point Density Interval 
when importing the graphics. Long, narrow triangles can cause 
tolerance problems when triangulating wire-frames. This is not 
unusual in TC lines created by Roadway Modeler, especially when 
they are very close together horizontally, such as the two lines 
defining the face of a curb. This is sometimes corrected by simply 
setting a maximum length between the points on a breakline.     

 Check the DTM before triangulating by reviewing crossing segments 
or mismatched elevations. Choose Surface > View Surface > 
Crossing Segments and specify whether you want to see crossing 
and/or mismatched elevations on crossing segments. The problem 
areas are noted with the desired symbol and a report. Any problems 
can be corrected prior to triangulation. 
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Lab 4.1 – Using Feature-editing tools to create a 
detention pond 

In this activity, you will create a proposed digital terrain model without using 
Roadway Modeler. Instead, you will use a combination of feature creation 
and editing tools to develop the breaklines for a pond. 

 

Pond area 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 4.1 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load the existing DTM 

1. Select File > Open. 

2. Set File of Type to Surfaces (*.dtm). 

3. Highlight 12345 Exist01.dtm and then select Open. 

4. Cancel the Open dialog box. 

Set Locks 
1. Toggle Locate Features/Locate Graphics to Locate Graphics. 

Create a surface for the pond 
1. Select File > New. 

  

2. Select the Surface tab: 

 Key in the name: 12345 pond 
 Key in the description: Pond training example 

3. Select Apply and Close the New dialog. 
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Display the pond graphics 
1. Toggle on the display for the 12345DesignPond01.dgn reference 

file. 

 

The pond you are going to create is beside a new roadway SH52. 
The toe of slope for the roadway is the boundary for the pond on the 
South side, with the existing ROW limiting the size on the North and 
other existing features dictating the basic shape of the pond. The 
graphic that you just toggled on shows what has previously been 
determined as the outer limit of the pond. 
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Set the elevations of the boundary 
In this case, you are going to start with the known outside of the 
pond, so you must first set the elevations of this boundary. You will 
do this by draping the graphic element onto the existing topo. 

1. Select Surface > Design Surface > Generate Longitudinal 
Feature. 

2. Select the Main tab: 

 Select 12345 pond as the Surface. 
 Toggle on Interval and set it to10 
 Toggle on New for the Mode. 
 Key in the feature Name Pond top 
 Set the Feature Style to default. 
 Set the Point Type to Breakline. 
 Leave the Point Density Interval set to 0 
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3. Select the Controls tab 

 Set the Horizontal Method to Offset from Primary 
Feature. 

 Set both offsets to 0.00 
 Set the Vertical Method to Drape. 
 Set the Drape Surface to 12345 Exist01. 
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4. Apply, then Identify and Accept the pond outline as the Primary 
Element. 

 

 

 

 

5. Identify and Accept the same shape again as the Reference 
Element. 

 

6. Reset <R> for the Entire shape. 

7. <D> anywhere for the Location. 

Note: If your Horizontal Offsets were not 0, you would be telling 
InRoads which side to offset by moving your cursor to that 
location before <D>; since they are both 0, it does not matter 
where you identify the location. 

The shape is draped on the existing model, but placed in the new 
surface. 

 

<D> on the line to 
identify, then <D> to 
accept 
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Review the feature 
1. Select Surface > Feature > Feature Properties. 

 

2. Set the Surface to 12345 pond. 

3. Highlight the Pond top feature and choose List Points. 

Note:  If you do not see the Pond top feature in the surface, go back 
and try the Generate Longitudinal Feature command 
again. 

 

4. You should see all different elevations for the feature. If you have a 
feature listed, but the elevations are not in the range shown, use 
Surface > Edit Surface > Delete Feature to delete the feature, then 
try again. 
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Create a target for the pond bottom 
In this series of steps, you will create features from the two lines at either 
end of the pond. The one on the West side represents the 5144 elevation and 
on the right end 5141. These features will then be triangulated to form a 
‘dummy’ surface that can be used as a target to create the pond bottom. 

1. Select File > New. 

 

2. Select the Surface tab: 

 Key in the name: dummy pond bottom 
 Key in the description: Pond training example 

3. Select Apply and Close the New dialog. 
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4. Select Surface > Design Surface > Generate Longitudinal 
Feature (GLF). 

5. Select the Surface dummy pond bottom. 

6. Set the other criteria as shown to create a new feature. 
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7. Apply. 

8. Select the West linestring with a data point <D> 

The linestring highlights and you are prompted to Accept/Reject. 

9. <D> to accept. 

You are prompted to Identify Reference Element. 

10. Select the same linestring again with a <D> and press <D> to 
Accept when the linestring highlights. 

A tracking line appear and you are prompted to Identify Beginning 
(Reset for Entire Element). 

 Reset to copy the entire element. 
 <D> for the location. 

Note: Since the horizontal offsets are 0.00, the location of the data 
point does not matter. If there were horizontal offsets, the 
data point would tell the software which way to make the 
copy, similar to a MicroStation copy command. 

The shape is made into a feature at elevation 5144 in the surface 
dummy pond bottom. 

Review the feature 
1. Select Surface > Feature > Feature Properties. 

2. Set the Surface to dummy pond bottom. 

3. Highlight the 5144 feature and choose List Points. 

You should see all 5144 elevations for the feature. 
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4. Repeat this process to create a feature in the same surface for the 
East line, which should be set to an elevation of 5141. 

You should now have two features in dummy pond bottom. 

 

5. Select Close to dismiss the GLF dialog box. 

6. Turn off the reference with the original pond graphics. 

 

 

7. Triangulate the dummy pond bottom surface. 
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Define the pond side slopes 
This series of steps takes you through creating sideslopes from the 
new top-of-pond outline down to the target DTM.  

Make the lock settings 

1. Set the Locate mode to Features. 

  

Since the source for the slopes is the feature created for the bottom of 
the pond, you must first change the Locate mode. 

2. Select the Surface > Design Surface > Generate Sloped Surface 
(GSS). 

3. Set the following parameters on the Main tab: 

 Source Surface: 12345 pond. 
 Intercept Surface:  dummy pond bottom. 
 Destination Surface:  12345 pond. 
 Interval: 10 
 Cut Slope: 50% 
 Fill Slope: -50% 
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4. In the Feature category: 

 Turn off Generate Graphics Only. 
 Toggle off Tic Marks and Source. 
 Toggle on Transverse. Key in transverse for the 

Name and set the Feature Style to default. 
 Toggle on Catch Point. For Catch Point key in toe and 

set the Feature Style to default. 
 Set the Point Type to Breakline. 
 Set the Point Density Interval to 10.000  

5. On the Advanced tab, set the Exterior Arc:  5^00’00.00” 
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6. Select Apply to run the GSS command. 

 You will be prompted to Identify Feature. 

7. Place a data point on the closed feature that represents the top of 
your pond. 

 
The entire pond top will highlight and you will be prompted to 
<Accept/Reject>  

8. <D> in an area away from the shape to accept the pond bottom. 

 When prompted to Identify beginning/Reset for Entire,  

9. <R> to run side slopes around the entire complex shape. 

Top of pond 
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10. When prompted for Location, <D> inside the shape, so the 
sideslopes will go in instead of out. 

  
 Graphics will appear as shown. 

11. <R> and then select Close to dismiss the dialog box. 

Evaluate the pond surface  
1. Triangulate the pond surface. 
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2. View the contours for the pond surface. 

 

 Use a 1ft interval for the contours. 
 Toggle Write lock off before you display the contours. 
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Save the pond surface to the hard disk 
1. Select File > Save As. 

 

 Set the Save as type to Surfaces (*.dtm). 
 Set the Active Surface:  12345 pond. 
 Verify the Name is: 12345 pond.dtm 

2. Select Save. 

3. Cancel the Save As box. 

Calculate the pond’s capacity 
1. Select Tools > Application Add-ins, toggle on Hydrology and 

Hydraulics Add-in (if it’s not already on) and choose OK. 

 

The command for calculating the pond volume is located on this  
add-in. 
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Compute the volume of water your pond will hold for a range of 
water elevations. 

2. Select Evaluation > Hydrology and Hydraulics > Compute Pond 
Volumes. 

 

3. Set the Surface to pond. 

4. Set the Method to Incremental. 

5. Set the Minimum Water Elevation to 5142 

6. Set the Maximum Water Elevation to 5147 

7. Set the Interval to 0.5 

8. Select the Target button and place a <D> in the middle of your pond 
toward the lower end. 
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9. Apply and the volume is calculated for the range of elevations you 
entered. A report is shown with the incremental volumes. 

 

10. Save the report to your hard drive if desired. 

11. Close the Compute Pond Volumes dialog. 

Challenge 
If you would like a challenge on this activity, complete the following 
steps. Otherwise proceed to Clean-up your design file. 

1. Add a micro pool of your own design at the deep end of the pond. 

2. Add a trickle channel from the upper end down to the micro pool. 

3. Zoom in close to the upper end of the pond and look at the pond toe 
line. Clean up the problems in the corner using Edit Feature Point. 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 4.2 – Using feature editing tools to clean up a 
surface from Roadway Modeler 

In this activity, you will go beyond Roadway Modeler in creating a surface. In 
previous activities, SH52 was modeled with superelevation and independent 
control. The medians were draped onto this surface, imported as horizontal and 
vertical alignments, and a Curb and Gutter template run on them to transition 
from a catch gutter on the high side to a spill gutter on the low side. 

Here, you will start with these surfaces and create a combined model for a 
‘final’ SH52. 

 
 

SH52 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 4.2 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH52 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight SH52.alg and then select Open. 

4. Do not cancel out of the box. 

Load SH52 DTMs 

5. Set File of Type to Surfaces (*.dtm). 

6. Highlight SH52 top.dtm and select Open. 

7. Highlight SH52 Median 1.dtm and select Open 

8. Highlight SH52 Median 3.dtm and select Open. 

9. Do not cancel out of the box. 

Load the existing DTM 

10. Highlight 12345 Exist01.dtm and then select Open. 

11. Cancel the Open dialog box. 
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View features for the first median surface 
1. Select Surface > Update 3-D/Plan Surface Display and set the 

options as shown for all features. 
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Correct errors in the median surface 
1. Window in very tight around the first portion of the median. 

 

Since the template was run around such a tight curve on the median, 
there are some features that overlap. In the next steps, you will use 
Edit Feature Point to correct the problem. 

2. Select Surface > Edit Surface > Edit Feature Point. 

 

3. Set the Surface to SH Median 1. 

4. Select the target button next to the feature name and choose the 
inside feature SH52Median_Curb_Back. 

5. Use the DVD-type controls (< > , etc.) to select one of the ‘bad’ 
points and choose Delete. 

Overlapping 
points in 
features 
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6. Continue using this command to delete or fix the other bad points. 
 

 

 

7. Continue correcting the problems with the other features. 
 

 

8. Triangulate the surface when done. 

9. Save the surface. 

10. View features for SH52 Median 3. 

 

11. Delete the graphics for the SH52 horizontal alignment if you have 
them displayed. 
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12. View features for SH52 top. 

 

 

13. Graphically review the features to see how the medians fall on the 
SH52 surface. 
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14. When done, toggle off all feature displays. 
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Combine surfaces 

Copy surface features to create a combined surface 
Use Copy Portion of Surface to copy the SH52 top and median features 
from each surface into a new combined surface. 

1. Select Surface > Edit Surface > Copy Portion of Surface. 

2. Set Source Surface to SH52 top. 

 Set Destination Surface to SH52top w medians. 
 Set Duplicate Names to Rename. 
 Apply. 

 

3. Set Source Surface to SH52 Median 1. 

 Set Destination Surface to SH52top w medians. 
 Set Duplicate Names to Rename. 
 Apply. 
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4. Set Source Surface to SH52 Median 3. 

 Set Destination Surface to SH52 top w medians. 
 Set Duplicate Names to Rename. 
 Apply. 

 

5. Save the SH52 top with medians surface. 
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Display the new surface 

1. Delete all the graphics from previous Modeler runs, and the SH52 
alignment is you haven’t already. 

2. Select Surface > Update 3D/Plan Display. 

 Toggle the Mode to Display On. 
 Highlight the Surface SH52top w medians. 
 Toggle on Features and everything else off. 
 Select ALL to highlight all the features. 

 

3. Choose Apply. 
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Partial Delete centerline 
Use Partial Delete to partially delete CL in areas where median crosses. 

1. First, make the surface SH52top w medians active. 

2. Select Surface > Edit Surface > Partial Delete. 

3. Follow the prompts to delete the portions of the Centerline from 
SH52 that fall within the median. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Repeat for the other median. 

5. There are also areas where the outside feature of the median is a 
duplicate with one of the lane lines. In these cases, you should also 
Partial Delete the lane line to avoid tolerance problems when 
triangulating. 

6. Save the surface. 

Partial 
Delete from 
here 

To here 
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Correct errors in the combined surface 
 

 

 

1. Window in to the first portion of the right turn lane. 

Notice how the turn lane feature transitions back further than it 
should. 

2. Select Surface > Edit Surface > Edit Feature Point. 

3. Set the Surface to SH52 top w medians. 

4. Select the target button next to the feature name and choose the 
feature for the turn lane. 

5. Use the DVD-type controls (< > , etc.) to select one of the extra 
points and choose Delete. 
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6. Continue using this command to delete the unnecessary points. 

 

 

 

7. Save the surface. 

Triangulate SH 52 
1. Right-click on the surface in the InRoads Explorer menu and choose 

Triangulate. 

 

2. Save the surface. 
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Create Cross Sections 
1. Set the Scale Factors to 40 

2. Create cross sections along SH52, showing the surfaces SH52top 
with medians and 12345 Exist01. 

 

Review sections 
1. Select Evaluation > Cross Section > Cross Section Viewer. 

2. Set Cross Section Set to the set you just cut. 

3. Select Run. 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 4.3  Creating Intersection returns using a  
3-Centered Curve 

In this activity, you will start with two roadways previously modeled – SH52 
and 71st Street. Starting from there, you will create the horizontal and vertical 
geometry for a 3-center curve in one of the quadrants. Using that geometry, you 
will model the return with Roadway Modeler, then combine the DTMs for 
SH52, 71st and the return. 

 

SH52 

71st Street 

3-center 
curve return 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 4.3 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH52 and 71st Street 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH52.alg and then select Open. 

4. Highlight 12345 71st.alg and then select Open. 

5. Do not cancel out of the box. 

Load the template library for the SH52 and 71st intersection 

1. Set File of Type to Typical Section Libraries (*.tml). 

2. Highlight 12345 Intersection.tml and select Open. 

3. Do not cancel out of the box. 

Load SH52 and 71st Street DTMs 

4. Set File of Type to Surfaces (*.dtm). 

5. Highlight 12345 SH52top w medians.dtm and select Open. 

6. Highlight 12345 71st top.dtm and select Open. 

7. Do not cancel out of the box. 

Load the existing DTM 

8. Highlight 12345 Exist01.dtm and then select Open. 

9. Cancel the Open dialog box. 
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Create a new geometry project for the intersection 
1. Select File > New. 

 

On the Geometry tab: 

 Set Type to Geometry Project. 
 Key in a Name of 12345 intersection 
 Key in a Description of Intersection of SH52 and 

71st 

2. Select Apply. 
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Copy alignments into project 
Copy the horizontal and vertical alignments for SH 52 and 71st street 
into the intersection project as follows: 

Copy the alignments 

1. Select Geometry > Copy Geometry. 

2. Select the Horizontals tab. 

3. In the From section: 

 Set Geometry Project to 12345 SH52. 
 Select the Target Button next to Horizontal Alignment 

and <D> on the SH52-H alignment. 
 Toggle on Include children (to copy the verticals). 

 

4. In the To section, set Geometry Project to 12345 intersection. 

5. Apply. 
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6. In the From section: 

 Set Geometry Project to 12345 71st. 
 Select the Target Button next to Horizontal Alignment 

and <D> on the 71st-H alignment. 
 Toggle on Include children (to copy the verticals). 

 

7. In the To section, set Geometry Project to 12345 intersection. 

8. Apply. 

9. Close the dialog box. 

You now have SH52-H and 71st-H in the intersection geometry 
project. 
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Create Horizontal and Vertical for SW return 
For the returns, you will use a different method for the SW and SE 
quadrants. For the SW, you will use the Multi-Center Curve command to 
create a three-centered curve. This command creates a horizontal and a 
vertical alignment for the return, which you can modify, if necessary (for 
drainage, for example). You can then either generate a feature directly from 
the alignments or run Modeler to create features. 
 

 

 
 
 
 
 
 

You will be creating the return geometry at the edge of pavement. However, 
this command uses the intersecting horizontal and vertical alignments to 
create the new geometry. Therefore, you need to find out either the cross 
slope from the centerline to the edge of pavement, or the vertical difference 
from the centerline to the edge of pavement.  

Typically, the cross slope might be the easiest to determine. However, SH52 
is in a 3.4% super, and the edge of pavement is at the end of the turn lane, 
which has a -1% cross slope. Therefore, you will need to use a vertical 
difference. You have a similar situation on 71st, since the two left lanes are 
at different cross slopes as they approach SH52. 

One method of finding this information is by using a report to determine the 
vertical difference between the alignment and the feature. 

New return geometry 
will be based on CL 

horizontal and 
verticals … 

But must represent 
horizontal and 

vertical of edge. 
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1. Select Tools > XML Reports. 

 

2. Choose the Clearance tab. 

3. Set the From Horizontal Alignment to SH52-H. 

4. In the Features category, set the Surface to SH52 top w medians. 

5. Highlight the feature SH 52RT_Edge-of-Pavement. 
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6. Choose Save (or Save As) and key in a name SH52 RTeop 
clearance 

 

When you Save, the report automatically appears. The format, 
however, is not exactly what you need. 

7. On the left of the Report Browser dialog, choose the format 
ClearanceVerticalOffsets.xsl. 

8. To increase the number of decimals on the offset, choose Tools > 
Format Options and set the Elevation to 3 decimals. 

9. Scroll down in the report to the area approaching the intersection, 
stations 117+00-119+00 and note the vertical difference in the far 
right column. It should read 0.952 at an offset of 50’. 

10. Repeat the procedure to determine the vertical difference for the Left 
Shoulder of 71st Street. You know the return will meet the shoulder 
at approximately station 598+50, so you can see from the report that 
the vertical difference at that point is -.101 and the offset is 23’. 

 

11. Select Geometry > Utilities > Multicenter curve. 

12. Set Curve Type to Three Center. 

13. Set Define By to Offsets at PCC/PCC. 

14. Select Alignments. 
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15. In the Alignment Definition box: 

 In the Name field key in SW return 
 In the Description field, key in SH52 and 71st SW 

return 
 Toggle on Create Vertical Alignment. 
 Set the other options as shown. 

 

 Select OK. 

16. Set the Widths, Radii and Offsets as shown. 
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17. Apply the command. 

 

18. When prompted <D> to identify SH52 as the first alignment. 

19. When prompted <D> to identify 71st as the second alignment. 

20. When prompted <D> to define the SW quadrant for the return. 

21. <D> to accept. 

1. First alignment SH52 

2. Second alignment 71st 

3. <D> in this area 
for quadrant  
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The return alignment is created and plotted in the design file. 

 
 

 

 

22. Save geometry project (Select File > Save > Geometry Project). 

Width 1 = 50’ 

Radius 1 = 180’ 

Radius 2 = 65’ 

Radius 3 = 180’ 

Width 2 = 23’ 

Vertical offset = 0.95 

Vertical offset = -0.101 
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Create a profile of the new horizontal 
Next, you’ll profile the return alignment and show the existing,  
SH 52 and 71st  street surfaces. 

1. Select Evaluation > Profile > Create Profile. 

 

2. Select Preferences, highlight the 2x Vertical preference, then Load. 

On the Main tab: 

 Verify that Alignment is SW return. 
 Key in a Set Name of SW return working 
 Toggle on the surfaces 12345Exist01, SH52 top w 

medians and 71st top. 
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3. Apply and then <D> for the location of the lower left corner of the 
profile. 

 

Display vertical alignment 
1. Select Geometry > View > Active Vertical. 

At this point, if you need to, you can make changes to the vertical 
alignment for drainage requirements, etc. Any of the vertical 
alignment editing tools can be used. 

 

Save the intersection geometry project 
1. Select File > Save > Geometry Project. 

Since you have a horizontal and vertical alignment, you can run a 
template to create the curb and gutter through the return. 

SH52 

71st 

Existing 

SW return 
Vertical  

SH52 

71st 

Existing 
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Review the SW return template 
1. Select Modeler > Define Typical Sections. 

2. Highlight and Edit SW return. 

 

Notice it is a template consisting only of the segments from the 
gutter out, with no cut and fill. This return consists of such a 
combination of a tight return and long enough fill slopes that if you 
model the fill slopes coming from this template, they would overlap 
before tying into the existing ground. Therefore, you will model 
Backbone Only and use another method to join the Toes-of-Fill. 
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Create a Roadway Library 
1. Create a roadway library and a roadway definition to run Modeler 

for the return. Set the Interval to 5 and the Catch Point to 
Backbone Only. 

 

Model the return 
1. Select Modeler > Roadway Modeler. 
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2. Set the Main tab as shown: 
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3. Set the Advanced tab as shown 

 

4. Apply. 
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5. Save the SW return top surface. 

 

 

Combine features from Modeler run on return with 
other surface 

You have now modeled SH52, 71st Street and the SW return. The 
rest of the process of creating the intersection will be handled using 
feature editing tools, so the next step is to combine all of the models 
into one. 

1. Select Surface > Edit Surface > Copy Portion of Surface. 

2. Set Source Surface to SH52 top w medians. 

3. Set Destination Surface to SH52 71st intersection. 

4. Set Duplicate Names to Rename. 

5. Toggle off the Exterior Boundary. 
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6. Apply. 

7. Repeat this process using the source of 71st ST top, then the source 
of SW return top, making certain to toggle off Exterior Boundary 
each time. 

 

 

When done, all three surface should be combined into SH52 71st 
intersection. 
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8. Save the new intersection surface. 

 

9. Use MicroStation to Delete all of the feature graphics that are 
currently in your design file. 

10. Select Surface > Update 3D/Plan Display. 

11. Set the Mode to Display On. 

12. Highlight the surface SH52 71st intersection. 

13. Toggle on Features. 

14. Select All. 

 



 Chapter 4  Feature Modeling and Manipulation 

 

Advanced Roadway Modeling  Page 453 

15. Apply. 
 

 

 

In lab 4.4, you will start with a set of files that matches what you just 
did, and from there complete the intersection. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 4.4  Creating Intersection returns using Fillet 
Features  

In this activity, you will start with two roadways previously modeled – SH52 
and 71st Street. These roadways have been combined, along with the DTM for 
the SW quadrant of the intersection.  Starting from there, you will create 
features for the SE quadrant using Fillet Features. 

 

SH52 

71st Street 
Fillet Feature 
return 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 4.4 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load the SH52 & 71st intersection DTM 

1. Select File > Open. 

2. Set File of Type to Surfaces (*.dtm). 

3. Highlight 12345 SH52 71st intersection.dtm and select Open. 

4. Do not cancel out of the box. 

Load the existing DTM 

5. Highlight 12345 Exist01.dtm and then select Open. 

6. Cancel the Open dialog box. 
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View the features 
1. Select Surface >Update 3D/Plan Surface Display and display all 

the features in the intersection surface. 

 

Model the SE return 
1. Ensure that Write lock is on in Pencil Mode. 

2. Ensure that Locate Feature/Locate Graphics is set to Locate 
Features. 
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3. Select Surface > Design Surface > Fillet Features. Set the dialog as 
shown. Use the target button to graphically choose the features. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Reference feature 2 
71 RT_POSS 

Reference feature 1 
SH 52RT_POSS 
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4. Apply and move your cursor to see the options for filleting the two 
POSS features. 

 When the fillet is in the quadrant you want, <D> to 
accept it. 

5. Change the Reference Features, Feature Name and Feature Style 
as shown. 
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6. Apply and Accept with a <D> to fillet the Edges of Pavement. 

 

Save the Intersection Surface 
1. Save the intersection surface by right-clicking it in the Explorer 

menu and selecting Save. You will need to choose the Surfaces tab 
first. 

 

After choosing Save, the message will appear as shown below, 
letting you know the surface has been saved to the hard drive. 

 

You can save your surface using this method at any time. 
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Model the Fill slopes 
1. Continue using the Fillet Features command to fillet the fill slopes in 

the SE quadrant. 
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2. Repeat for the fill slopes in the SW quadrant. 

 

 

 

3. Again, Save the intersection surface. 

4. In the next lab, you will clean up the intersection. 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 4.5  Cleaning up the Intersection 
In this activity, you will start with a DTM that contains the features from  
SH52 top w medians, 71st top, SW Return top, and the features created with 
Fillet Feature. In effect, all features have been created that you need for the 
intersection, and you will now ‘clean up’ the features to form the completed 
model. 

 

 

SH52 

71st Street 

Fillet Feature 
return 

3-Centered 
Curve return 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Design\Working. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 4.5 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load the SH52 & 71st intersection DTM 

1. Select File > Open. 

2. Set File of Type to Surfaces (*.dtm). 

3. Highlight 12345 SH52 71st intersection.dtm and select Open. 

4. Do not cancel out of the box. 

Load the existing DTM 

5. Highlight 12345 Exist01.dtm and then select Open. 

6. Cancel the Open dialog box. 

View the features in the intersection surface 
7. Select Surface > Update 3D/Plan Surface Display and display all 

the features in the intersection surface. 
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Clean up the features in the intersection 
1. Select Surface > Edit Surface > Partial Delete. 

2. Select the 71 RT_POSS feature and Accept it (Read your prompts). 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Track off the end of the feature and <D> to identify the Starting 
Point. 

4. Snap to the 71st Street end of the POSS radius to identify the Ending 
Point. 

71st RT_POSS 

Start Partial 
Delete Here 

End Partial 
Delete Here 
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5. Continue using Partial Delete to clean up all the features as shown. 

 

6. Save the intersection surface. 

Notice the Bike lane ends on the East side of the intersection. You 
would prefer that it transition into the shoulder, so you will next edit 
the feature to force the transition. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Bike Lane 
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7. Select Surface > Edit Surface > Edit Feature Point. 

 
 

8. Edit the SH52RT_Turn feature as by changing the coordinates of the 
end point. 
 

 

 

9. Save the intersection surface. 

Triangulate and review the surface 
Next, you will triangulate the surface and review it to see if there are 
any problems. Since you have not yet created an exterior boundary, 
there will be triangles in all concave areas of the perimeter. Don’t 
worry about those, just review the surface inside the perimeter for 
problems. The exterior will later be added to limit the trianglization. 

1. Triangulate the surface (Surface > Triangulate). 

2. Save the intersection surface. 
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Use GLF to create taper between two different width 
lanes 

The right turn lane from SH52 onto 71st street transitions from a 12’ 
lane to an 11’ one. The goal is to hold the -1% cross-slope through 
the transition, so you will next add a breakline to further define the 
surface. Since you have the inside edge (SWCenterline), you can use 
Generate Longitudinal Feature to copy it while at the same time 
tapering the offset and maintaining the -1% slope. 

1. Choose Surface > Design Surface > Generate Longitudinal 
Feature. 

 Select the Main tab and set the dialog as shown. 
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 Select the Controls tab and set the dialog as shown. 
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2. Apply, then <D> on the SWCenterline to Identify the Primary 
Feature. 

 

3. <D> again to Accept. 

4. Repeat and identify the same feature as the Reference. 

5. When prompted to Identify Beginning/Reset for Entire, <R> (right-
mouse click) to copy the entire feature. 

6. <D> to Accept the new feature on the intersection side. 

 

SWCenterline 
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7. Close the Generate Longitudinal Feature command. 

8. Use Partial Delete to trim the feature as shown. 

 

 

 

9. Save the intersection surface. 
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10. Triangulate and review the surface again. 
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11. Save the surface when you are satisfied. 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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5. Interchange Modeling 
In modeling the interchange, you will be putting all your previous modeling 
techniques together to create a master model of different surfaces. You’ll be 
using Roadway Modeler with independent controls, superelevation, etc. for 
the roadways, the feature modeling techniques used previously in creating 
intersections and the feature modeling techniques used to create the pond (this 
time used for walls). 

Overall, the modeling of the interchange will be a recap on everything you’ve 
done in this course. 
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Lab 5.1  Separating bridge area features from 
roadway features 

In previous activities, you have modeled SH52 without taking into account that 
it actually contains a bridge. In this activity, you will take the previously  
modeled SH52 and ‘cut out’ the bridge area to create two new surfaces: SH52 
without the bridge, and a surface for the bridge itself. Although the bridge 
surface is not an actual representation of the bridge, you may want to use it later 
for visualization purposes only. 

 

 
 

Bridge area 
where SH52 

crosses SH119 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\MIscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 5.1 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load the SH52 & 71st intersection DTM 

1. Select File > Open. 

2. Set File of Type to Surfaces (*.dtm). 

3. Highlight 12345 SH52 71st intersection.dtm and select Open. 

4. Do not cancel out of the box. 

Turn on bridge outline 
The outline of the bridge is in your design file, but it is on a level that has 
been frozen. 

5. Open the Level Display dialog. 
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6. Toggle the View Display option to Global Freeze. 

7. Toggle on BRDG_TOOLS_Outline-Bridge. 

  

8. Close the Level Display dialog. 
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View the Intersection surface 
1. Select Surface > Update 3D/Plan Surface Display and view all the 

features. 
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Create a surface with the bridge features 
1. Choose the MicroStation Fence command. 

2. Toggle the Fence Type to Element. 

3. Select the bridge outline. 

Copy features into a bridge surface 
1. Select Surface > Edit Surface > Copy Portion of Surface. 

 

 Set the Source Surface to SH52 71st intersection. 
 Key in the Destination Surface SH52 Bridge 
 Set the Fence Mode to Inside. 
 Select All to highlight all the features. 

2. Choose Apply. 



 Chapter 5  Interchange Modeling 

 

Advanced Roadway Modeling  Page 490 

View the bridge features 
1. Select Surface > Update 3D/Plan Surface Display. 

 

2. Turn the Display Off for all of the SH52 71st intersection features. 

3. Turn the Display On for all of the SH52 Bridge features. 
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Delete these features out of SH52 71st intersection 
1. First, you’ll make a copy of the surface, then cut the bridge features 

out of the new surface. 

 Select Surface > Copy Surface. 

 

 Select SH52 71st intersection as the From Surface. 
 Key in a name SH52 71st intersection no brdg 
 Key in a description of Intersection surface with 

bridge cut out 
 Apply. 

2. Select Update 3D/Plan Surface Display. 

 

 Turn off the display of the SH52 Bridge surface features. 
 Turn on the display of the new ‘no brdg’ surface 

features. 
 Make certain the Fence Mode is set to Ignore. 
 Close the dialog. 
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3. With the same fence you used before, Select Surface > Edit Surface 
> Delete Features. 

 

 Set the Surface to SH52 71st intersection no brdg. 
 Set the Fence Mode to Inside. 
 Select All to highlight all the features. 
 Choose Apply. 

 

 Select OK when prompted. 

 

The features in the area of the bridge are cut out of the surface. 
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Trim Features 
1. Use Surface > Edit Surface > Partial Delete to trim out the toes of 

slope. You do not need to be precise with this part, as the toes will be 
edited later when this surface is combined with the ramps, walls, etc. 

Review the surface 
1. Use any of the displays you would like to review the surface. 

However, keep in mind that triangulation will not honor the gap 
between the features and will triangulate across the bridge area. 
Therefore, when using the surface displays, be sure to say No when 
prompted to re-triangulate the model. 
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2. Save the two new surfaces you just created. 

 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 5.2  Modeling a mainline and introducing a ramp 
In previous activities, you have built horizontal and vertical alignments, created 
and modified templates, set up independent controls, created decision tables 
and modeled. Here, you’ll be combining these procedures to create a model of 
SH119 NB that intercepts the SH119 SB surface on the left side and features 
from the existing DTM on the right. In addition, you will widen SH119 NB to 
introduce RampA. In the next activity, you will model RampA and eventually 
put the surfaces together with others to form the completed interchange model. 

 

SH119 NB 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 5.2 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH52 & SH 119 interchange 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH119 SH52 interchange.alg and then select 
Open. 

4. Do not cancel out of the box. 

Load the template library for SH119 NB 

5. Set File of Type to Typical Section Libraries (*.tml). 

6. Highlight 12345 SH119 NB.tml and then select Open. 

7. Do not cancel out of the box. 

Load the roadway library for SH 119 NB 

8. Set File of Type to Roadway Libraries (*.rwl). 

9. Highlight 12345 SH119 NB.rwl and then select Open. 

10. Do not cancel out of the box. 

Load the SH119 SB DTM 

11. Set File of Type to Surfaces (*.dtm). 

12. Highlight 12345 SH119 SB top.dtm and select Open. 

13. Do not cancel out of the box. 

Load the existing DTM 

14. Highlight 12345 Exist01.dtm and then select Open. 

15. Cancel the Open dialog box. 
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Add a ramp to SH119 NB  
In the following steps, you will take the basic SH119 NB template and 
modify it to introduce RampA. In addition, there are several additional 
typicals needed through the area. Refer to the following lane sketch showing 
the various transitions. 

 

1281+11.82 RampA introduced 

1281+84.59 RampA 6’ wide;         
 Shoulder narrowed to 6’ 

1285+82.30 RampA becomes 
independent model 

1288+05.00 SH119 NB and 
RampA introduce Z-slope 

1291+90 SH119 NB introduces  
8’ Backslope 

1292+87 Begin wall 
Wall modeled with decision table 
from Ramp; intercepts 3:1 slope 
from SH119 NB 

Hatched area represents variable 
slope which is determined by 
triangulation from SH119 NB to 
RampA 
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Copy the SH119 NB 0L - 2L template 
The basic SH119 NB template is given in the typical section library. (It is a 
mirror image of the SH119 SB template that was created in a previous 
activity.) Here, you will copy and modify it to create the template 
introducing the turn lane. Initially, the turn lane starts out as a 0.01-width 
segment. 

1. Select Modeler > Define Typical Section. 

 

2. Highlight the template and choose Copy. 

 

3. In the To Name field, key in SH119 NB 0L - 2L w 0.01’ Ramp 

4. In the Description field, key in Ramp A for widening 

5. Apply, then Close the box. 
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Edit the template to add the ramp segment 

6. In the Define Typical Section box, highlight the template you just 
copied and select Edit. 

7. Select the Segment tab. 

8. Set Zone to Right Backbone. 

9. Set Edit Mode to Add After. 

10. Use Next to highlight the segment RT_Shoulder. 

  

 

Use Next>  to 
highlight this segment 
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11. Key in a Slope of -2.0% 

12. Key in a Width of .01 

13. Select a TC name of RT_Ramp_Shoulder. 

 

14. Select New. 

15. Close the Edit Template box. 

Copy the SH119 NB 0L - 2L w 0.01’ Ramp template 

16. Highlight the template you just edited and select Copy. 

 

17. In the To Name field, key in SH119 NB 0L - 2L w 6’ Ramp 

18. In the Description field, key in Ramp A 6’ 

19. Apply, then Close the box. 
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Edit the template to widen the ramp segment 

20. In the Define Typical Section box, highlight the template you just 
copied and select Edit. 

21. Select the Segment tab. 

22. Set Zone to Right Backbone. 

23. Set Edit Mode to Global. 

24. Use Next to highlight the 0.01’ segment RT_Ramp_Shoulder. 

 

25. Key in a Width of 6 

26. Change the Fixity to Variable Width. 
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27. Select Update to modify the segment. 

 

28. Use Next to highlight the segment RT_Edge-of-Pavement. 

29. Key in a Width of 6 

30. Press the Tab key to update the segment. 

 

31. Close the Edit Template box. 
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Note: Other templates needed for modeling are already in the 
typical section library. 

32. Review the templates. 

 

0L – 2L Gore Used beginning where RampA 
becomes independent 

0L – 2L Gore2 Used where the Gore Shoulder is 6’ 
wide 

0L – 2L Gore2a Used beginning beyond RampA 
where the Z-slope is reintroduced 

0L – 2L Gore3 Used where the Gore Shoulder tapers 
away 

0L – 2L 8’ Backslope Used beginning at station 1291+90; 
contains the large 3:1 slope which 
will provide the target surface for the 
wall decision table that will be run 
with RampA 

33. Save typical section library. 
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Create a new SH119 NB roadway definition  
In the following steps, you will create a new roadway definition that 
uses a decision table on the left to intercept the surface from SH119 
SB at a 6:1 slope, transitioning into and out of a 10:1 slope in the 
bridge area. On the right, it will use independent control to widen for 
RampA and uses the other typicals through the ramp area. It also 
widens to provide a target for the decision table used to create a 
retaining wall between SH119 NB and RampA. 

1. Make certain SH119 NB is the active horizontal alignment. 

2. Select Modeler > Define Roadway. 

3. In the Define Roadway box, select New. 

 

4. Key in the Name SH119 NB w Ramp widening 

5. Key in the Description of Median varies on left / RampA 
widening  

6. Edit the definition. 
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First, you will establish independent control to widen for RampA by 
assigning the RT_Ramp_Shoulder to follow the RampA alignment. 

7. Select the Horizontal and Vertical controls tab. 

 

8. Set the following options: 

 Transition Control Name to RT_Ramp_Shoulder. 
 Toggle on Use Horizontal Control. 
 Toggle on Templates at Vertices. 
 Toggle off Use Vertical Controls. 
 Set Horizontal Alignment to RampA-H. 
 Key in a Start Station of 1281+84.59 
 Key in an End Station of 1285+82.30 
 Select New. 
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9. Select the Main tab. 

10. Select New and add the following entries. 

Station Left 
Template 

Left 
Catch 

Right Template Right Catch 

1265+58.61 0L – 2L DT 6:1 0L – 2L DT RT intercept exist ftr 
1281+11.81 0L – 2L DT 6:1 0L – 2L DT RT intercept exist ftr 
1281+11.82 0L – 2L DT 6:1 0L – 2L w 0.01 Ramp A DT RT intercept exist ftr 
1281+84.59 0L – 2L DT 6:1 0L – 2L w/6’ Ramp A DT RT intercept exist ftr 
1285+82.29 0L – 2L DT 6:1 0L – 2L w 6’ RampA DT RT intercept exist ftr 
1285+82.30 0L – 2L DT 6:1 0L – 2L Gore BB Only 
1288+04.99 0L – 2L DT 6:1 0L – 2L Gore 2 BB Only 
1288+05.00 0L – 2L DT 6:1 0L – 2L Gore 2a BB Only 
1289+67.00 0L – 2L DT 6:1 0L – 2L Gore 3 BB Only 
1291+89.99 0L – 2L DT 6:1 0L – 2L Gore 3 BB Only 
1291+90.00 0L – 2L DT 6:1 0L – 2L 8’ Backslope BB Only 
1292+90.00 0L – 2L DT 6:1 0L – 2L 8’ Backslope BB Only 
1293+00 0L – 2L DT 10:1 0L – 2L 8’ Backslope BB Only 
1300+90.00 0L – 2L DT 10:1 0L – 2L 8’ Backslope BB Only 
1301+00.00 0L – 2L DT 6:1 0L – 2L BB Only 
 

 

11. Save Roadway Library. 
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Model SH119 NB 
1. Run Modeler to create the new SH119 NB top surface. 

 Main tab setup: 
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 Advanced tab setup: 
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2. Save the SH119 NB top surface. 

3. Create a set of cross sections and review. 

 Show SH119 NB top, SH119 SB top and Exist01. 

 

Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 5.3  Modeling Interchange Ramp A 
In this activity, you will model RampA for the SH119 SH52 interchange. The 
alignments were built in previous activities, as was the decision table. Similar 
templates have been built also, so the templates are provided here. 

 

RampA 
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Start MicroStation InRoads 
1. Select Start > All Programs > Bentley Civil Engineering > Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Design\Working. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File > Project Defaults. 

2. Set the Configuration Name to 5.3 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for SH119 & SH52 interchange 

1. Select File > Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 SH119 SH52 interchange.alg and then select 
Open. 

4. Do not cancel out of the box. 

Load the template library for Ramp A 

5. Set File of Type to Typical Section Libraries (*.tml). 

6. Highlight 12345 RampA.tml and then select Open. 

7. Do not cancel out of the box. 

Load SH119 DTMs 

8. Set File of Type to Surfaces (*.dtm). 

9. Highlight 12345 SH119 NB.dtm and select Open. 

10. Highlight 12345 SH119 SB.dtm and select Open. 

11. Do not cancel out of the box. 

Load the existing DTM 

12. Highlight 12345 Exist01.dtm and then select Open. 

13. Cancel the Open dialog box. 
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Create a Roadway library 
1. Select File > New and choose the Roadway Library tab. 

 

2. Name: 12345 RampA 

3. Description: RampA roadway definitions 

4. Create a Roadway definition with the following entries. 

Station Left 
Template 

Left Catch Right 
Template 

Right Catch 

3281+11.83 1L – 0L DT RampA wall 1L – 0L DT intercept exist ftr 
3288+04.99 1L – 0L DT RampA wall 1L – 0L DT intercept exist ftr 
3288+05.00 1L – 0L w 

Z slope 
DT RampA wall 1L – 0L DT intercept exist ftr 

 

The decision table on the left will create a wall that intercepts the 3:1 
slope from SH119 NB. The decision table on the right is a copy of 
the one created for SH119 NB that intercepts features from the 
existing DTM. 

5. Save the roadway library. 
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Set up the Superelevation 
The Superelevation for RampA must match the cross slope from 
SH119 NB at the point where the ramp becomes independent, super 
through the curves, then match the longitudinal slope where it ties 
into SH52. This superelevation has been worked out already and is in 
a text file that you will import to create the superelevation table. 

1. Select File > New > Geometry. 

 

2. Toggle the Type to Superelevation. 

3. Key in the Name RampA-S 

4. Key in a Description RampA Superelevation 

5. Select Apply, then Close the dialog. 



 Chapter 5  Interchange Modeling 

 

Advanced Roadway Modeling  Page 521 

6. Select Modeler > Superelevation > Build Transitions. 

7. Select the ASCII tab. 

 

8. Browse to find the file RampA-Super.txt. 

9. Select Open. 

10. Select the Main tab. 

 

Notice the superelevation starts at a 2% super to match SH119 NB, 
then transitions into and out of a 2.7% super for the curve, then 
transitions to a 0.16% super to match the grade of SH52. 

11. Select Save, then OK. 

12. Save the .alg. 
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Run Roadway Modeler 
1. Run Modeler for the ramp, beginning at station 3285+83 (where the 

ramp alignment takes over from the mainline and ending at station 
3296+00, where the ramp ties into SH52. 

 Set the Main tab as shown: 
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 Set the Advanced tab as shown: 

 

2. After modeling, Save the RampA surface. 
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Create Cross Sections to review 
1. Create cross sections along the SH119NB alignment and show 

SH119 NB top, SH119 SB top, 12345 Exist01, RampA top. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

RampA splitting from SH119NB 
The gap between them will be a variable 
slope created by triangulating between 
the two when the surfaces are later 
combined. 

Sideslope ties 
into an existing 
feature 

Slope formed by 
SH119 NB 

Wall created by 
decision table 
intercepting slope 
from SH119 NB 
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Review the DTM 
2. Using triangles, contours, etc., review your new surface. 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit > Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File > Exit. 

2. If prompted to save data files select Yes. 
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Lab 5.4 – Creating walls with feature tools 
In this activity, you will use a combination of feature tools to create the walls 
under the SH52 overpass on SH119 NB. The wall geometry has been provided 
so that you can concentrate on the feature modeling. 

 

 
 

Walls under 
SH52 overpass 
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Start MicroStation InRoads 
1. Select Start >All Programs >Bentley Civil Engineering >Bentley 

InRoads 

or 

Double-click on the InRoads icon on your desktop. 

 

2. In the MicroStation Manager Dialog box: 

 Set the directory to 
C:\Projects\12345\Miscellaneous. 

 Select the file 12345DesignModel01.dgn. 
 Make sure the Workspace and all other options are set 

as shown. 

 

3. Select OK. 
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Set Project Defaults 
1. Select File >Project Defaults. 

2. Set the Configuration Name to 5.4 

Important! Be sure to select the correct configuration name to 
ensure that you load the correct files. 

3. Select Apply. 

Important!  Verify your dialog box appears as shown: 
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Load data files 

Load geometry project for the walls 

1. Select File >Open. 

2. Set File of Type to Geometry Projects (*.alg). 

3. Highlight 12345 Walls.alg and then select Open. 

4. Do not cancel out of the box. 

Load the template library for the walls 

5. Set File of Type to Typical Section Libraries (*.tml). 

6. Highlight 12345 Walls.tml and then select Open. 

7. Do not cancel out of the box. 

Load SH119 DTMs 

8. Set File of Type to Surfaces (*.dtm). 

9. Highlight 12345 SH119 NB top.dtm and select Open. 

10. Highlight 12345 SH119 SB top.dtm and select Open. 

11. Do not cancel out of the box. 

Load the existing DTM 

12. Highlight 12345 Exist01.dtm and then select Open. 

13. Cancel the Open dialog box. 
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Set Locks 
1. Toggle on Write lock. 

2. Toggle Locate Features/Locate Graphics to Locate Graphics. 

 

Create new surface for walls 
1. Select File >New 

2. On the Surface tab, 

3. Key in SH119 NB Walls 
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View the wall alignments 
Next, you will view the alignments representing the horizontal location of 
the walls 

1. Select Geometry >View Geometry >Horizontal Annotation. 

  
 

2. Set the dialogs as shown, being sure to toggle on Complex in the 
Display category. 

 

 

Wall D-16-I 

Wall D-16-J 

Wall D-16-H 
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View the target 
The model SH119 NB top that you created previously contains a 3:1 
sideslope in the area of the walls.  

3. View the triangles for SH119 NB top. 

 

 
 

Since the bottom of the first wall (H) begins at the elevation of this 
3:1 sideslope, you will first drape the alignment onto the SH119 NB 
model. 

Target area 
for draping 
the wall 
bottom 
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4. Select Surface >Design Surface >Generate Longitudinal 
Feature. 

5. Set the dialogs as shown. 

 

 

6. Select Apply. 
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7. When prompted, identify and accept wall H as both the Primary and 
Reference Elements. 

8. Reset <R> to use the whole wall, and 

9. Data <D> to accept the location. 

10. If there were horizontal offsets, you would be identifying the side of 
the wall to offset. Since they are set to 0 this time, you can <D> 
anywhere for the location. 

 

 
 

Wall H is the 
primary and 
reference element 

Bottom of wall H 
after being 
draped onto the 
target surface 
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Create the top of the wall 
The top of the wall is at elevation 5164, and is 1’ wide. 

1. Toggle the Locate Features/Locate Graphics lock to Locate 
Features. 

 

2. Delete the triangle display to make it easier to see and pick the wall. 
You can also delete the outline of the original wall. 

3. Back in Generate Longitudinal Feature, 

 Set the Main tab as shown: 
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4. Set the Controls tab as shown: 

 

Notice the 0.01 Horizontal Offsets. This ensures that there is ‘room’ 
to triangulate the face of the wall, since you cannot have a true 
vertical in a DTM. 

5. Apply and identify the wall feature as the Primary and Reference 
Features. 

Note: The pictures here show rotated views.  However, it is much 
better to work in plan view (top) and use a rotated view for 
reference/visual checks. 

6. Reset <R> to copy the entire feature. 
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7. When prompted for the location, be certain to <D> on the East side 
of the wall outline. This is identifying the side of the feature to put 
the new copy on and you need to make certain the top of the wall is 
offset to the inside. 

 
In the top view, it is difficult to see the two features, since they are so 
close together, but if you zoom in close enough, you should be able 
to see both. 
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Create the back of the top-of-wall 
The top of the wall is 1’ wide, so set up the GLF dialog as shown. 
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8. Apply and this time identify the Top of the wall as the Primary and 
Reference Features. Read your prompt to be certain you are 
choosing the correct feature. 

9. When prompted for location, be certain to <D> on the East side of 
the wall. 

 

 

Using a decision table along a feature 
The bottom of the next wall (I) is set horizontally, but not vertically. 
The goal is to have a 4:1 slope between the Top of Wall H, which 
you just created, and the bottom of wall I. On method of 
accomplishing this is by using a decision table that seeks a horizontal 
alignment.  

In the next series of steps, you will create a decision table to 
accomplish this. 
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Create a decision table 
1. Create the table name and description. 

 

This table requires only one record, since the only slope you are 
interested in is from the top of Wall H to the bottom of Wall I.  

2. There is not a TC name for the Bottom of Wall, so you will need to 
create one. You can use the feature style Breakline. 
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3. Save the typical section library. 

4. Apply the decision table. 

Next, you will apply the decision table to the feature for the top back 
of the previous wall. In previous uses of decision tables, you have 
run them using Roadway Modeler and a template. This time, you 
will simply apply the table to the feature, which will act like the 
Hinge point in a template. 

Apply the decision table 
1. Select Surface >Design Surface >Apply Decision Table. 

 

2. Apply and identify the top back of wall H as the Primary and 
Reference Features. 
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Notice the ends of the wall D-16-I were not created, as they are not 
perpendicular to the top of wall D-16-H. From this perpendicular 
point, you want to tie into the 3:1 target surface anyway, so you will 
drape each end of the wall onto the surface. 

3. Since the ends of the wall are still graphical, set the Locate Feature 
back to Locate Graphics. 

 

4. Select Surface >Design Surface >Generate Longitudinal 
Feature. 
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5. Set the dialog as shown. 

 

 

6. Apply and identify Wall D-16-I as the Primary and Reference 
Elements. 



 Chapter 5  Interchange Modeling 

 

Advanced Roadway Modeling  Page 545 

7. When prompted to Identify Beginning, Snap to the point where the 
bottom of wall feature ends. 

8. When prompted to Identify Ending, Drag your cursor out to the end 
and <D>. 

9. <D> anywhere for the location, since the Horizontal Offsets are 0. 

  

Ending 

Beginning 
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10. Repeat the process for the other end of the wall. 

 

 

11. Notice that the features don’t quite tie in elevation. Use  
Surface > Edit Surface > Edit Feature Point to modify the latest 
feature to match the original bottom of wall I. 
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Join features  
The bottom of D-16-I now consists of 3 separate features. Before 
proceeding, you will join them to make one feature. 

1. Select Surface >Edit Surface >Join Features. 

2. Identify and Accept each feature in turn starting with the Southern-
most feature. 

Note:  You must Accept each feature before identifying the next. 

 
 

5. <D> to Identify 
6. <D> to Accept 

3. <D> to Identify 
4. <D> to Accept 

1. <D> to Identify 
2. <D> to Accept 
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Finish the walls 
In the next series of steps, you will be repeating this process to create 
the rest of the walls. As you go through, if you need to delete a 
feature, use Surface >Edit Surface >Delete Feature. 

 

If you need to rename or review the elevations of a feature, use 
Surface >Feature >Feature Properties. 
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With what you have learned creating the previous wall features, 

1. Use GLF to copy D-16-I Bottom to create D-16-I Top at elevation 
5174. 

2. Use GLF to create D-16-I Top Back 1’ off from the top of wall. 

 

3. Create a decision table to model the D-16-J Bottom at a 4:1 slope. 
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4. Use GLF to drape ends of wall D-16-J onto SH119 NB top.dtm. 

 

5. Notice the ends do not match as well here. Use Edit Feature Point to 
set the elevation of the points that are lower than the bottom of the 
wall to the approximate elevation of the bottom of the wall. 

 

6. Join features for D-16-J Bottom. 
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7. Use GLF to copy feature to create D-16-J Top and D-16-J Top Back 
at elevation 5183.67 

 

8. Save the surface. 
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9. Triangulate the surface and review. 
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Clean-up your design file for the next lab 
Important!  Do not skip this step. You will need a clean design file 

for the next lab. 

1. From MicroStation, choose Edit >Select All. 

2. Select the MicroStation Delete command. 

All graphics placed in the file should now be deleted. 

Exit InRoads and MicroStation 
Important!  Do not skip this step. You must exit in order to start the 

next lab session with new data files. 

1. From MicroStation, select File >Exit. 

2. If prompted to save data files select Yes. 
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