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Disclaimer 
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Document Conventions 
There are several conventions that are used throughout this document to indicate 
actions to be taken or to highlight important information.  The conventions are as 
follows: 

 

Example Item     Meaning 

View Perimeter a command name or a file that you are to select, including 
directory path 

Name: field name, button or icon in a dialog box 

Dialog Header dialog box name 

Tools > Options a command path that you are to select - usually from the 
pull-down menus 

Dialog Area heading for separated areas within a dialog box 

Tab heading for tabs found within dialog boxes 

Key in entering data with the keyboard or items selected from 
drop-down list 

Document name style used when referring to another document 

Note:  text  information about a command or process that you should 
pay particular attention to 

Concept:  text detailed definition of a concept, procedure or process 

Emphasis an important word or phrase 

Prompt user prompt 

1. Numbered Steps actions that you are to perform as part of the lab activities 

<D> or Data press the data button on the mouse 

<R> or Reset press the reset button on the mouse 

<T> or Tentative press the tentative button on the mouse 
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Terms and Abbreviations 
Right-of-Way (abbr. ROW)  

1) The limits of the rights of way possessed by an entity. 

2) That specialty unit within CDOT engaged in the determination, acquisition, 
monumentation, documentation and management of CDOT rights of way. 

Survey (abbr. SURV) 

1) The observation, measurement and integration of boundary, physical and 
documentary evidence pertaining to land features, rights and restrictions. 

2) That part of the specialty unit within CDOT engaged in the activities involved 
in the practice of Land Surveying. 
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Getting Started 

Chapter Introduction 
In this chapter you will be introduced to the overall course contents, goals, 
schedule, and organization and the training directory structure.  

Course Overview 
These instructor led training sessions are targeted to ROW/Survey groups 
focusing on InRoads geometry functions applicable to ROW plat generation. 

The intent of this training is to provide an increased knowledge base and skill set 
to ROW/Survey relating to InRoads geometry. This is in addition to the initial 
class training received from InRoads Geometry Fundamentals. The intent is to 
introduce additional tools for surveyors to facilitate land parcel information and 
aid in the development of geometry for the right-of-way process.  

The course will also train in the development of alignment diagrams and right of 
way plats. These additional tools  equip surveyors in the development of 
documents for the right-of-way plat process. 

This course will address: 

 Creating Geometry entities 
 Creating Parcels, parcel closure & description generation 
 Creating ROW Plan sets 

Foundation 

Intended Audience 
The intended audience for this course is CDOT Survey and Right-of-Way Plans 
personnel who have completed the InRoads Survey Data Reduction class, the 
InRoads Geometry Fundamentals class and require further training on the use of 
the InRoads geometry tools specific to Right-of-Way development 

Prerequisites 
The attendees must have a basic understanding of MicroStation prior to 
attending this course. Additionally, they must have attended the 2-day course 
Fundamentals of InRoads Geometry or otherwise have a genuine understanding 
of fundamental InRoads geometry. 

It is assumed the student is familiar with the InRoads interface and coordinate 
geometry in general. 

Duration and Format 
8 hours of InRoads geometry training focused on ROW parcels and 8 hours 
focused on plan sheet development. Format is instructor lecture and 
demonstration followed by hands-on lab exercises for students. 
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Focus 
 The Relationship and interaction of exporting InRoads 

Survey data to InRoads Geometry data files 
 Development of InRoads geometry in the form of Cogo 

points, Alignments, and Parcels 
 Development of property information for the generation of 

right-of-way plans 
 Geometry annotation, MicroStation reference files, 

automation tasks for tabular/textural data in plan sheets. 

Goal 
 Provide additional and available technologies to the survey 

and right-of-way staff to perform project tasks utilizing 
InRoads geometry tools. 

 The purpose of this course is to provide CDOT personnel 
with an understanding of how to use specialized geometry 
features in InRoads. That understanding will aid them in the 
analysis of property data along with the design and 
development of right-of-way plans. 

Introductions & Schedule 

Instructor 
Introduction of Instructor(s) and brief summary of credentials. 

Students 
Introduction of students and a brief summary of student knowledge as it relates 
to MicroStation and InRoads and/or geometry. 

Student Interests 
Query as to specific interests of individual students and the class as a whole. 

Schedule 
Establish schedule for class breaks, lunch, and course termination. 
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CDOT CADD Resources 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & Engineering 
Innovation Web site. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: & Engineering Innovation web page is available at: 

http://internal/cadd/http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 

The website (presently only available to CDOT) provides CDOT users with up 
to date information, tools, and resources related to CADD and the Colorado 
Engineering Software Transition (CEST) project.  

 

http://internal/cadd/
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This website is a valuable resource for CADD users and includes: 

CADD Library  
The CADD Library page provides links to manuals, newsletters, standard details, 
etc. One extremely useful link is to the Tips and Tricks section for MicroStation 
and InRoads. This information changes daily, so check back often. 



  Chapter 1-Getting Started 

 

ROW Geometry & Plans  Page 5 
 

CADD Manual 
The CDOT Computer Aided Design and Drafting (CADD) Manual outlines 
CDOT’s use of Bentley’s MicroStation and InRoads software. It documents 
standardized procedures for the exchange of information between CDOT 
regions, specialty groups, and consultants working on CDOT projects. The 
Manual also addresses software issues, tools, techniques, standards and 
procedures, etc. which will aid the user in the efficient production of CDOT plan 
sets. 

The CDOT CADD Manual and the associated electronic files contained in the 
CDOT configuration are used in the generation of electronic plans by both 
CDOT internal designers and the consulting firms doing business with CDOT. 
The electronic version of the Manual provides hyperlinks to each chapter as well 
as context sensitive index and search functions. You can also print chapters or 
the entire manual. 

The CDOT CADD Manual can be accessed several different ways including: 

 From the CDOT internal CADD web site home page link; 
 From the CDOT Design and Construction Project Support Page (external 

web site); 
 From the CDOT Menu (Help > CADD Manual). 
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CDOT Workflows 
There are several standardized MicroStation and InRoads workflows that CDOT 
has developed to assist you. These workflows are step-by-step CDOT-specific 
procedures for certain tasks that you may encounter when working in 
MicroStation or InRoads on a CDOT project. Many of these workflows are 
referenced throughout the course. 

In addition to accessing the workflows from the CDOT CADD Web site Home 
page link CDOT Work Flow, you can also access workflows: 

 From the Windows Start menu  
(Start > All Programs > _CDOT_CADD_Information > Workflows); 

 From the CDOT Menu (Help > Workflows). 

New workflows are typically added with CDOT configuration updates, so check 
back often. 
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Issue Logs  
Check the Issue Logs to determine the status of submitted requests. 

Requests & Support 
The Requests & Support page provides CADD help solutions where you can: 

 Learn how to get help; 
 Submit a questions; 
 Submit a request (e.g. request a new MicroStation level or InRoads 

preference), as well as  
 Obtain InRoads, InRoads Survey and MicroStation support.  

There is also a link to IT Services for hardware support, “how to” instructions, 
installation, training files, and work space setup. 

 

 

Training 
Use the Training link to obtain information regarding how to sign up for 
training classes.  You can also review online computer-based training (CBT) for 
MicroStation, InRoads and InRoads Survey. 
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Scope of Training Data 

Training Data Set 
This training is a continuation of the course InRoads Geometry for ROW and 
will use the same data files. 

State Highway No. 86 - Elbert County 
This project has progressed to the point of having property information, design 
reference lines, proposed right-of-way limits, and easements developed. This 
data set will be used to generate the necessary data for development of Survey 
Control Diagrams and Right-of-Way parcels. 

Training Directory Structure 
All class work files will be in the C:\Projects\12345 folder, which has a 
combination of design and survey sub-folders and data files. 

The sample project in this document uses the standard CDOT file structure with 
12345 = CDOT Project Code (sub account). 
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Training Workflow 

 

The project data for this training session is based on Colorado S.H. 86. The 
overall workflow will consist of: 

InRoads Geometry 
 Exporting an InRoads Survey Fieldbook to geometry 
 Importing the design centerline into the ROW geometry project 
 Creation of Cogo points 
 Creation of alignments by various methods 
 Creation of parcels (closed alignments) 
 Defining parcels by inputting deed information 
 Generating parcels for ROW takes and remainders 
 Annotation of Parcel information 
 Generation of legal descriptions using XML 

MicroStation Plans Generation 
 Creation of ROW plans using MicroStation reference file commands 
 Creation of ROW plans using the InRoads Plan &Profile Generator 

command 
 Generation of geometry output for use in coordinate tables 
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The area shown in the above graphic shows the Summit Business Park land 
division. This area will be used to demonstrate typical InRoads geometry 
commands that can be applied for a variety of uses and in varying situations. 
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Working with InRoads 

Chapter Introduction 
In this chapter you will receive detailed information about the training directory 
structure, specific lab files, and MicroStation resource files.  Additionally you will 
work with InRoads Project Defaults to identify default directories for opening and 
saving InRoads resource and data files. 

Lab 1 - Getting Started in InRoads  

InRoads operation 
1. There are three main methods to Start InRoads: 

Choose Start > All Programs > Bentley Civil Engineering > Bentley InRoads. 
MicroStation will open allowing you to choose the design file; once the design 
file opens InRoads will start. 

Choose the Desktop icon for InRoads if one is available on your 
machine. MicroStation will open n allowing you to choose the 
design file; once the design file opens InRoads will start. 

If you already have MicroStation open, you can choose the InRoads icon from 
the MicroStation main toolbar. 
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2. In the MicroStation Manager dialog box, go to the Workspace group 
section and change the User field to CDOT USER, the Project field to 
12345 and the Interface field to CDOT.  

 

This workspace setup should load the correct MicroStation environment 
(including toolbars) when the selected MicroStation file is opened. 

3. Navigate to the ROW_Survey\Drawings\Reference_Files folder.  

 

4. <D> the filename 12345ROW_Model.dgn 
                              (JPC#Right Of Way_ Model ) 

5. <D> OK to open the file. 
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6. Save the CADD file settings: 

From the Main MicroStation pull-down menu Select File > Save Settings 

By completing the above step, the attachments of level and cell libraries are 
cataloged with the specific MicroStation file, and will remain attached during 
subsequent MicroStation sessions. 

 

Software Application: 
InRoads was used to enter the CAD file.  Using InRoads vs. InRoads Survey 
allows access to the full range of geometry commands available. By itself, 
InRoads Survey does provide somewhat limited geometry functions. By 
enabling InRoads initially, the full range of geometry functions is available to 
the user.  Additionally, the functions of InRoads Survey are also required 
because a fieldbook will be used to export survey data to a geometry project. 
This data will serve as a foundation for establishing existing property and land 
lines.  Once the electronic fieldbook has been exported, InRoads Survey will no 
longer be necessary. 

7. Verify InRoads and InRoads Survey are both operating: 

 

Note:  The title bar for the InRoads interface is labeled: Bentley InRoads 2004 
Edition denoting that InRoads is running. Additionally the functions of 
InRoads Survey are apparent in the menu and workspace bars.  
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If Either InRoads or InRoads Survey needs to be enabled: 

8. Select Tools > Application Add-Ins, and enable the appropriate 
application by selecting the application and <D> OK 

 

Note:  From this point forward, unless specifically instructed to use 
MicroStation commands, all references to the selection of icons, tools, or menu 
pull-downs, refer to the InRoads interface. 
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Lab 2 - Default directories and resource files 

Introduction 
Defined default locations for both general InRoads resource files and project 
specific data files make it easier to conform to graphics standards and assist in 
navigating to the correct project directories when loading or saving data files. 

Setting project defaults 
1. Select File > Project Defaults (from the InRoads interface). 

The CDOT environment is configured to read MicroStation variables defined 
when the project creation utility is run.  These variables are automatically read 
when MicroStation is launched.  Selecting the appropriate ‘Project’ in the 
MicroStation Manager dialog identifies the specific project folder referred to by 
the variable $(MS_DEF)  

2. Select CDOT ROW_Survey Discipline from the drop-down 
Configuration Name: list and <D> Apply, and <D> Close 

  

Note:  Choosing the appropriate discipline from the Configuration Name 
selection list will modify directory paths as configured by CDOT.  If necessary, 
<D> the Import button and select the file: 
C:\Projects\12345\Project_Configuration\CDOT-Disciplines_V3_01.reg to 
populate the Configuration Name drop-down list. 
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Survey Feature Filters 

Chapter Introduction 
Survey data will be used as a foundation for our initial geometry. Exporting the 
survey field book to an InRoads geometry project will generate alignments along 
linear items and Cogo points at all survey shot locations. 

Lab 3 – Working with Survey Data 

Introduction 
The goal of this exercise is to export observations from an InRoads Survey 
fieldbook to a Geometry Project creating Cogo points and alignments. 

The fieldbook for this project, 12345SURV_Fieldbook.fwdcontains control 
monuments, found monuments, and general topography observations. While this 
is all valid information, it is desirable to work with a subset of the survey 
information such as pavement centerlines, control lines, or other specific entities 
by excluding terrain strings and other topographic information that does not 
relate to the development of ROW geometry. Working with a subset of the 
information increases efficiency by working with a smaller data set and freeing-
up additional resources for other operations. Exporting a portion of a survey 
fieldbook can be accomplished by using Survey Feature Filters when creating 
the InRoads geometry project. 

Load project data 
Note:  If not working with survey data and using this training guide for 
design or other purposes, you may jump to the next section and use 
(load) the geometry project 12345 ROW_lab 4.alg as found in the 
‘Completed Lab Files’ folder located in the root training directory 
C:\12345\ 

1. Load the Fieldbook 12345SURV_Fieldbook.fwd from the 
\ROW_Survey\InRoads\Field_Books directory. 
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2. <D> Open 

3. <D> Cancel 

Once the fieldbook has loaded, InRoads will automatically fit the extents of the 
fieldbook to the MicroStation screen. 

4. To verify the survey data, turn on dynamic shot numbers, codes, and 
notes. 

 

  

5. Use the MicroStation Fit View command to get an indication of the 
survey information contained in the fieldbook. 

 

Note:  The Fit View command only works if data has been written to 
graphics.  If only field book data is in view, you must zoom manually. 

 

6. Take a few minutes to zoom in and navigate around the MicroStation 
screen to investigate the survey data displayed as it relates to the 
project layout. 
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Notice the various survey control, ROW and property monuments.  Pavement 
shots, and general topography shots are seen representing terrain breaks, signs, 
culvert ends, and other features. 

It is desirable to filter unrelated topography information from our electronic 
fieldbook prior to exporting it to the right of way geometry project. 
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Lab 4 - Filtering the Survey Data 

Introduction 
The goal is to write only the information important to establishing ownership 
and right of way parcels to a geometry project.  The use of Survey feature filters 
will assist in sorting the data.  

A survey feature filter affects commands for: 

 Electronic fieldbook data 
 Survey data to surface 
 Survey data to geometry 
 Survey data to graphics 
 Viewing of dynamic survey data 

When a Survey feature filter is activated, the displayed contents of the electronic 
fieldbook will update along with the associated graphics display. The dynamic 
graphics display can be used as a preview of the data being written to graphics, a 
DTM, or to the geometry project. 

Using survey feature filters 
1. Use MicroStation view commands to display any portion of the 

project area. This display can be used as a ‘preview’ of our 
Fieldbook filter. 

 

2. Select Survey > Fieldbook Data 

3. <D> on the Filter icon. 

 

Create the Roadway Centerlines survey feature filter. 

4. In the Survey Feature Filter dialog, <D> Save As 

5. In the Save Filter As dialog, enter Roadway Centerlines 

6. <D> OK 
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7. Toggle None for the Start With option. 

8. Select the Numeric Code Property. 

9. Enter a Value of 1313 

10. Toggle Include for the Mode option. 

11. <D> Add Rule 

 

12. Enter a Value of 1316 

13. <D> Add Rule 

 

Page 20  ROW Geometry & Plans 



 Chapter 3-Survey Feature Filters 

 

14. Continue this process to add the following Rules: 
1317-1326, 1332, and 1335 

15. <D> Save 

16. <D> OK 

 

17. On the main InRoads dialog for Locks, Toggle On the Feature Filter 
Lock 
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Notice that 2 things happen: 
 The Fieldbook Data Pane, when opened, will update to 

display only the data that passes the filter.  

 

 Also the MicroStation graphics will update to reflect the 
current contents of the fieldbook (if Automatic Refresh is 
toggled on under Tools>Survey Options). If not, select 
Survey > Regenerate Graphics 

  

When a fieldbook is exported to graphics, geometry, or a DTM, only the survey 
shots that pass the filter will be exported.  
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In this case, additional information is desired for the development of right-of-
way. 

18. If closed, select Survey > Survey Feature Filter to re-open the 
survey feature filter dialog 

Create the Right of Way survey feature filter. 

19. Make sure the Roadway Centerlines filter is selected. 

 

20. In the Survey Feature Filter dialog, <D> Save As 

21. In the Save Filter As dialog, enter Right of Way 

22. <D> OK 

 

23. Toggle None for the Start With option. 

24. Select the Alpha Code Property. 

25. Enter a Value of 5?? 

Note:  The “??” in the key-in value is used as a wild card value when 
searching for data.  The value of “5??” will return the range of 
codes 500-599. 

26. Toggle Include for the Mode option. 

27. <D> Add Rule 
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28. Enter a Value of 10?? 

29. <D> Add Rule 

 

30. <D> Save 

31. <D> OK 

The MicroStation display updates to display only the survey codes that pass the 
filter. 

Note:  The filter Right of Way includes codes for both property 
information and roadway centerline information. 
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Now that a Survey Feature Filter is active, it will be applied when exporting 
survey data to geometry. 
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Lab 5 - Exporting a Filtered InRoads Survey Fieldbook 
to Geometry 

Introduction 
When exporting a Fieldbook to graphics, a DTM, or to a geometry project, only 
the items active in the Fieldbook are exported. Using a Survey Feature filter 
allows control of which survey data gets exported. 

If not already set. 

1. Survey > Fieldbook Data 

2. Select the Survey Feature Filter 
icon.  

3. Select the filter Right of Way 

4. <D> OK to close the Survey Feature Filter dialog.   

5. Toggle On the InRoads Feature Filter lock 

  

6. Select Survey > Survey Data to Geometry 

7. Key-in the Geometry Project Name 12345_ROW.  A new 
Geometry Project will be created by that name. 

 

8. <D> the Filter button - this is another way to access the Survey  
Feature Filter dialog and to review the filters Rules prior to 
exporting. 
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9. <D> OK to close the Survey Feature Filter dialog as it was used for 
review and is not required to be open. 

10. <D> Apply on the Survey Data to Geometry dialog.  The geometry 
project is created, the cogo points are created, and horizontal and 
vertical alignments are generated. 

11. Examine InRoads explorer to verify geometry data was created 

 

12. The survey fieldbook is no longer needed, <R> 
12345SURV_Fieldbook and choose Delete from the fly-out list.  
This will remove it from memory. 
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13. Toggle Off the InRoads Feature Filter lock 

 

.
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Geometry Display 

Lab 6 – Displaying InRoads Geometry 

Introduction 
A graphic review of both the alignments and Cogo points created will assist in 
verifying the fieldbook information exported as expected. 

1. Select Utilities > Saved Views 

2. To make it easier to verify the import of geometry information, we 
need to turn off the display of right-of-way information.  To do this 
we will use a saved view named Geometry Verify.  This view turns 
has all ROW_* levels turned off.  Highlight Geometry Verify and 
<D> Apply.   

3. <D> Close to dismiss the Saved View dialog box. 

When we need to see the ROW information in later steps, we will recall 
it using a different Saved View named ROW Reference. 

 

4. Select Geometry > View Geometry > Horizontal Annotation to 
view all alignments. 

5. Select the Main tab. 

6. Toggle on the Alignments mode. 

7. Input an asterisk (wild-card) into the Annotate field to identify all 
alignments. 

8. Display Points As: Cell 
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9. Select the Annotate tab. 

10. Toggle on Points 

 

11. View all alignments, <D> Apply 

12. Repeat the display command for Cogo points by turning on the radio 
button for Points (in the Main tab).  Again input an asterisk in the 
Annotate field 

13. <D> Apply 
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14.   Use MicroStation view commands to zoom into the graphics to 
review the display of alignments and Cogo points. 
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Annotation symbology used when viewing points and alignments can be 
changed by applying the active style.  The following steps demonstrate 
how this works.    

15.   In the Main tab, select the drop-down list for the Apply Style: field 
and select Active.  In the Annotate: field type in 105.  Only the 
annotation of point 105 will be affected when the command is 
executed.   

 

16. In the Active Styles tab, select the drop-down list for the Point: field 
and select Cogo_Label-Name_Desc_N_E. 
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17.  <D> Apply.  For this demonstration, do not overwrite the Current 
Style with the Active Style.  In practice, this would be the way to 
assign (or reassign) a Geometry Style to Cogo points. 

18. Use MicroStation view commands to zoom into the graphics to 
review the display of point 105. 

 

 

 

 

 

Note:  When Lab 6 is complete, InRoads Survey is no longer required. If you 
wish to simplify the interface, it can be removed by selecting Tools > 
Application Add-Ins and toggling it off 
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Lab 7 - Saving a Geometry Project 

Introduction 
InRoads is Memory based, not Disk based. The file(s) seen in the InRoads 
Workspace pane are copies from the disk drive and reside in the computer’s 
memory. Any changes to these files (or creation of new data files) require saving 
back to the disk drive. 

Before proceeding, save the Geometry Project to disk to eliminate the 
possibility of data loss in the event you close or otherwise exit InRoads. 

1. <R> on the Geometry Project 12345_ROW and select Save As from 
the fly-out menu. 

 

2. Select the drop-down list for the Active: field and select 
12345_ROW from the list. 

3. Verify this name is populating the File Name: field. 
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Note:  By default it should be saved to the folder: 
C:\Projects\12345\ROW_Survey\InRoads\Geometry\ as this was the 
path for geometry files defined in the Project Defaults configuration file. 

4. <D> on the Save in: field to verify the folder path. 

 

5. After the correct folder location is identified, <D> Save 

6. Close the Save As dialog.   

Notes:  

• When the Geometry Project is saved to the hard drive it takes 
on an extension of .alg 

• The directory folder for geometry already contains four 
geometry projects.  12345_DESIGN.alg contains design 
centerline information and will be used to facilitate 
development of the right of way plans. 

• The Geometry Styles associated with the exported fieldbook 
are derived from the Survey Feature Table definition at the 
time geometry is exported from InRoads Survey. 

• Geometry styles can be assigned (or reassigned) to alignments 
in the Geometry > Copy Geometry dialog.  No equivalent 
command exists for Cogo Points.  However, a Geometry Style 
can be assigned to alignments or Cogo points when using the 
horizontal annotation command to view geometry information.  
Refer to page 33 for a demonstration of using Active Styles 
when viewing alignments and Cogo points.     
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Lab 8 – Copying Geometry 

Introduction 
The current geometry project contains only information exported from the 
fieldbook.  Another geometry project, 12345_DESIGN contains the design 
centerline alignment and is needed for development of right of way for this 
project.  

Copy geometry information between geometry projects 
The design section has developed a horizontal alignment representing the 
construction reference line for this project.  Multiple geometry projects can be 
loaded into memory simultaneously and be accessed as needed. However, it is 
much easier (and sometimes necessary) to have the appropriate geometry 
information contained in a single geometry project. To that end, copy the design 
reference line from the geometry project 12345_DESIGN to the geometry 
project 12345_ROW.  In order to copy geometry from one project to another, 
they must both be loaded into memory. 

1. File > Open and load the geometry project 12345_DESIGN 

 

 

There is a single horizontal alignment needed from the 12345_DESIGN 
geometry project. It is named C_Centerline 
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2. Select Geometry > Copy Geometry 

3. Select the Horizontals tab. 

Note:  The dialog is divided into 2 sections. The top half of the dialog being 
the geometry project being copied from, with the lower half being the geometry 
project being copied to.  Alignments being copied can be assigned a new name, 
description, or style during the copy process. 

4. In the To section, set the Geometry Project to 12345_ROW  

5. <D> Apply 
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Example Only – Do not execute this workflow 

Cogo points can be copied by selecting the Cogo Points tab.  The sample Cogo 
points shown are not required and are shown as an example only.  

Select the Cogo Points tab. 

Input point numbers, a range of point numbers, or an asterisk in the Point: field 
to select the desired Cogo points 

Select Rename in the Duplicate field 

The rename toggle instructs InRoads to reassign the imported Cogo point 
number/name if an identical point exists in the destination geometry project. A 
seed name can be specified, otherwise the seed name defined under              
Tools > Options [Geometry] will dictate the initial name. Overwrite will do just 
that, it will replace an existing Cogo point with the copied point if the names are 
identical. 

 

Unload the Geometry Project 12345_DESIGN 
The geometry project 12345_DESIGN is no longer needed, remove it from 
memory. 

6. <R> on the geometry name 12345_DESIGN and select Delete from 
the fly-out menu 
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Defining the active geometry project 
The geometry project 12345_ROW should be the active geometry project. By 
default any geometry viewing or creation commands operate on the active 
geometry project. The active geometry project is indicated by a red box next to 
the name. Deleting the active project leaves InRoads in the state of no active 
project being defined. If 12345_ROW is not so indicated: 

7. <R> on the geometry project name 12345_ROW and select Set 
Active from the fly-out menu. 

8. For orientation purposes, display the graphics and stationing for 
alignment C_Centerline 

Hint:  

 Define C_Centerline as the active horizontal alignment 
 Select Geometry > View Geometry > Active Horizontal 
 Geometry > View Geometry > Stationing 

Note:  The global scale factor and selected preference influence the display of 
geometry and stationing.
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Cogo Commands 

Chapter Introduction 
Prior to generating the proposed right-of-way geometry, the public land survey 
lines (section lines), existing right-of way, and existing parcels will be developed. 
Additionally the reference line alignment vertices will be sent to the Cogo buffer. 

Objectives 
When completed you will have learned: 

 Creating Cogo points graphically 
 Creating Cogo points by coordinate input 
 Writing geometry vertices to the Cogo buffer 
 Geometry Snaps – review only 
 Cogo point intersection commands 
 Create alignments with Cogo Points 
 Create parallel and offset alignments 
 Create parcels 

Lab 9 - Creating Cogo Points 
Working with a subset of the project, create and store Cogo points for project 
development 

 

1. Use the MicroStation Fit command to view the extents of the project. 

2. Since the Saved View Geometry Verify was used earlier to validate 
information.  We want to display project information contained in a 
different saved view, ROW Reference.  To do this, use the command 
Utilities > Saved Views.  Highlight the view named ROW 
Reference and <D> Apply.  This exercise will be working in the 
Summit Business Park area outlined above.  
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3. Use the MicroStation Window command to zoom into this area. 

 

  

117 

105 

120 

Cogo point 105 was created by the fieldbook export. The locations marked as 
117 & 120 are required to establish section lines that are necessary for the 
development of right of way. These 2 Cogo points will be created in the 
following exercises. 

Cogo point creation by graphic input 

1. Use MicroStation to window into the location for point 117 

 

2. From the InRoads interface, select Geometry > Cogo Points > New 

This self-explanatory dialog furnishes access to the basic functions of working 
with Cogo points. 
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3. Enter the Name: 117 

4. <D> the selection button to interactively define the coordinates. 

5. Snap <T> & then <D> to the CAD graphics at the section corner. 

6. Verify the coordinates that were identified match those shown in the 
Northing and Easting fields below. 

7. Key-in a Description as shown. 

8. Select the Style RW_Working-exist 

9. <D> Apply 

  

The Cogo point is created & posted to the MicroStation screen. 
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If Report lock is on, a Results dialog opens. 
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Cogo point creation by coordinate input 
In the New Cogo Point dialog, define Cogo point 120 which is located 
south of Summit Business Park 

10. Notice the Name field automatically increments. Replace the number 
118 with 120 

11. From another source, the SE Corner of Section 14 (future point 120) 
has been determined as having the coordinate values of: 
North =1,553,239.97 
East = 3,279,699.86 
Enter those values. 

12. Enter the appropriate Description and Style as shown. 

13. <D> Apply 
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Editing Cogo Points - Example Only – Do not execute this workflow 

Once created, Cogo points can be modified. 

Select Geometry > Cogo Points > Edit 

Change data as necessary and select Apply 

 

Note:  Remove Shared Point Name refers to Cogo points that may be used for 
dual purposes such as a common point in crossing alignments. Removing the 
shared point name allows the user to modify the Cogo point location without 
modifying the associated (secondary) alignment. 

Note:  The Edit Cogo Point dialog cannot be used to rename a Cogo Point.  To 
accomplish renaming, copy the Cogo point to the needed name and delete the 
original point. 

Copying Cogo Points 
Select Geometry > Cogo Points > Copy to duplicate a Cogo point 

Complete the From: and To: fields and <D> Apply. The point is 
duplicated. 

 

ROW Geometry & Plans  Page 45 
 



Colorado Department of Transportation 

 

Deleting Cogo Points 

Select Geometry > Cogo Points > Delete to remove Cogo point(s). 

 

All points listed in the Selected field will be deleted from the Cogo Buffer 
when Apply is selected.  

Valid input to the Delete field includes: 

 Individual Cogo points 
 A range of points (117-120) 
 Single character wild cards (11%) 
 All Cogo points (*) or multiple characters (1*) 
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Centering a MicroStation View on a Cogo Point 
Select Geometry > Cogo Points > Center Point 

You are prompted to Identify point/Key in point name 

In the MicroStation Key-in window, key-in 120  <Enter> 

You are prompted to Select a View 

<D> in any MicroStation view 

The MicroStation view is repositioned to center the specified Cogo point 

 

Note:  The above command will not change the display volume of the 
MicroStation screen.   You may be required to zoom in or out to achieve 
desirable results. 
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Lab 10 – Alignment to Cogo Buffer 

Chapter Introduction 
Horizontal and vertical alignments must be assigned a name at the time of 
creation.  Naming can be defined by the user or assigned by InRoads using a 
user specified seed name. While the overall alignment must be assigned a 
unique name, the vertices (PI’s, PC’s, PT’s, etc) of said alignments can exist in 
three states, as: cogo points, named points, or unnamed points. 

Name assignments 

Alignments 
Alignment names are created and stored in a geometry project: 

 Using a combination of numbers or letters 
 Alignments may or may not contain any data 
 For some geometry commands, naming is automatic and 

renaming may be desirable 

Alignment Vertices 
Vertices along a horizontal alignment exist by one of three ways: 

 Cogo Points 
 Alpha or Numeric named geometry points (not stored in 

Cogo Buffer) 
 Unnamed geometry points (not stored in Cogo buffer) 

Cogo Points 
Cogo Points must be assigned an identifier at time of creation, these can be: 

 Numeric 
 Alpha characters 
 A combination of numbers or letters 
 User specified or incrementally assigned by InRoads 

 

Note:  In order to chain Cogo points together as an alignment (figure), the 
selected Cogo points must be defined by numbers only. Alpha or alphanumeric 
Cogo point names are not acceptable.  
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Writing Alignment Points to the Cogo Buffer 
As they relate to the Cogo buffer, InRoads reserves geometry point names. These are 
reserved as Cogo point ID’s in the event the named geometry points are written to 
the Cogo buffer. If the alignment containing the named geometry points is written to 
the Cogo buffer, the naming between geometry points and cogo points is 
synchronized. 

Note:  The following workflow operates on the active horizontal alignment.  Verify 
the active horizontal alignment is C_Centerline prior to executing the following 
steps. 

1. Select Geometry > Review Horizontal to review alignment 
C_Centerline 

 

The information in parenthesis shows the identifier of the vertices either as Cogo 
points or as named or unnamed geometry points.  In this case, the alignment 
C_Centerline was created as unnamed geometry points. 

Note:  The assignment of geometry names at time of creation (or editing) is 
controlled by: Tools > Options [Geometry] tab, as shown on the next page. 
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Write the vertices for alignment C_Centerline to the Cogo buffer.  Doing so will 
facilitate the generation of additional geometry for the development of the 
project. 

2. Select Geometry > Horizontal Curve Sets > Events 

The Horizontal Events dialog opens. 
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3. Set the radio button for Alignment Point to Cogo: On 

Note:  The seed name field only applies to unnamed geometry points.  If names 
are already assigned to the alignment, the assigned names will be used 
regardless of input into the Seed Name field. The active alignment 
C_Centerline does not have geometry point names assigned so input here is 
desired. If no seed name is defined here, the next available Cogo point number 
would be used and incrementally increased. 

Reviewing the Cogo buffer indicates that the range of number from 121-1007 
are unused. For simplicity, set point number 200 as the initial Cogo point ID to 
assign to the alignment vertices (more on reviewing the Cogo buffer in the 
following lab). 

 

4. Key-in 200 as the Seed Name 

5. Key-in design ref line in the Description field 

6. Select ALG_PRO as the geometry style to assign to the new Cogo 
points 

7. <D> Apply 

 

The Cogo points are created & posted to the MicroStation screen. 

 

 

8. Review the Cogo Buffer to verify the results by <D> on the Cogo 
Buffer 
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Remember to periodically save the Geometry Project. 

9. <R> on the Geometry Project name 12345_ROW, <D> Save 
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Lab 11 – Reviewing Cogo Points 

Chapter Introduction 
Cogo points can be reviewed in the InRoads feedback pane by placing a data 
point <D> on the Cogo Buffer. Note the feedback pane can be expanded or 
scrolled to view coordinate values. The columns can also be repositioned by 
<D> and dragging to reposition. The columns can also be sorted in either 
ascending or descending order by placing a <D> on the column headings. 

Quick Review of Cogo Buffer 
1. <D> on the Cogo Buffer. 

 

The contents of the Cogo buffer are displayed in the feedback pane. 

Note:  Cogo points can be assigned either numbers or names. When alpha 
characters are used, names are case sensitive; RL_10 is not the same point as 
rl_10. 

2. Reposition and sort the feedback pane as you see fit. 
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Detailed Review of Geometry Points 
The Review Geometry Points command can be used to review individual 
geometry points.  This dialog can also be used to generate ASCII output files of 
said points. 

3. Select Geometry > Review Geometry Points 

This dialog can be used to evaluate individual Cogo points (or named geometry 
points) by navigating with the provided buttons. 

 

4. <D> the Report button. 

 

This Results dialog will list both Cogo points and named geometry points 
(named alignment vertices not stored as Cogo points).  
This is signified by the name of the command used to generate this report 
Review Geometry Points, not Cogo points. Named geometry points are not 
written to the Cogo buffer automatically. However they are reserved. 

As with all InRoads Results dialogs, the Save As.. command will write the 
displayed data to an ASCII file for documentation, reformatting, and other 
purposes. 
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Creating Cogo Points 

Chapter Introduction 
InRoads geometry snaps allow the user added functions to ensure geometry point 
locations and direction criteria are selected at defined geometry locations. The 
following chapters involve creating Cogo points and alignments. Using geometry 
snaps will ensure specific locations are selected. 

Lab 12 - Geometry Snaps 
InRoads geometry snaps are analogous to MicroStation snaps such as the 
keypoint snap. When enabled, the software only allows selection at specific 
locations. 
 

In this lab the geometry inverse command is used for illustration.  Geometry 
snaps can be applied when creating alignments, using traverse commands or 
almost any geometry related command. 

Geometry snaps are accessed from the InRoads Locks toolbar. 

 

They are also available under Tools > Locks 

 

1. <D> on the Geometry lock icon in the InRoads Locks toolbar. 

<D> on the Lock icon to cycle through the three geometry snap modes: 

 Geometry snap off           
 Point snap - locks to Cogo points or alignment vertices  
 Element snap - select tangents for direction definition   
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2. Position the MicroStation view as shown below 

 

To explore the Geometry Point snap use the inverse command to report distance 
and direction between cursor locations. 

3. Select Geometry > Utilities > Inverse Direction 

4. Begin with the Geometry 
Snap off     

After selecting the inverse command you are prompted to Identify Initial 
Point/Key in Initial Point 

5. <D> near Cogo Point 117 & then <D> near Cogo point 105 
(see following graphic for point locations) 

 

Dynamic graphics will appear and both the MicroStation and InRoads 
command fields will report the results. A question mark indicates that a specific 
Cogo point has not been selected. In this case, the bearing and distance readout 
reflects the values between the data <D> points given. Not between defined 
geometry points. 

6. Toggle On the Geometry Point snap        to select defined geometry. 

7. <D> near Cogo Point 117 & then <D> near Cogo point 105 
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InRoads reports the bearing and distance between points 117 & 105. 

8. Move the cursor around the MicroStation view. 
Note how the cursor ‘snaps’ between specific geometry vertices.  

 

105 
117 

120 

9. Toggle Off all geometry snaps  

Notes:   

• Geometry snaps, if enabled, operate whether the related graphics are 
visible or not. 

• After initializing the Inverse Direction command, point numbers can also 
be keyed into the MicroStation key-in window to inverse between point 
numbers. 

Challenge lab 
When using the geometry inverse command, issuing a second data point in the 
MicroStation view will draw a line between the identified locations and post the 
bearing and distance to the MicroStation File. 
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Try it 

 

 

Note:  As standard practice, the geometry snap should be left in the off position 
to avoid undesirable results. For example, if the geometry point snap is left on 
and a new Cogo point is created by keying-in or graphically selecting the 
desired position, once applied, the new point will be created at the nearest 
existing geometry point, not at the specified location.  
 

The geometry snap element will be covered in following exercises.
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Lab 13 - Cogo Point by Traverse 
Development of the right of way for the project requires the establishment of the 
West ¼ corner for Section 13 which lies South of the project reference line near 
the Northeast corner of the Summit Business Park development. Use the 
Traverse command to establish the West ¼ corner from point 105. 

 

105 

S 00-37-05 E 
2,643.99’ 

W ¼ Corner (119) 

The West ¼ corner has been determined to lie south of the NW corner of section 
13 (Cogo point 105) at: 

 S 00-37-05 E  
 2,643.99 feet 
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1. Select Geometry > Traverse 

The Traverse dialog opens.  

There are three ways for establishing the foresight point (Method):  

 Angle/Direction (angle or deflection angle from backsight point) 
 Direction            (bearing and distance) 
 Curved               (curve tangent, chord or radial information) 

2. Select Method: Direction  

There are four options for creating a new geometry point or element (Insert 
Point): 

 To Cogo Buffer 
 Before Alignment  (adds courses at beginning) 
 After Alignment     (adds courses at end) 
 Radial                     (adds Cogo points from common occupied point) 

3. Select Insert Point: To Cogo Buffer 

 

Page 60  ROW Geometry & Plans 



 Chapter 6-Creating Cogo Points 

 

The dialog is divided into 3 other distinct sections: 

 Course - direction/distance to travel 
 Occupied Point - point of origin 
 Foresight Point – point being established 
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4. Occupied Point: Key-in 105 (the coordinates for point 105 will 
display) 
or use the selection button in conjunction with the geometry point 
snap to graphically select point 105. 

5. Course Direction: Key-in S 0 37 05 E 

6. Course Horizontal Distance: Key-in 2643.99 

7. Foresight Point Name: 119 

Note: If point 119 already exists, the next available point number 
would be used. 119 would not be overwritten. 

8. Enter a description and choose the appropriate geometry style 

<D> Apply 

                                       

 

Point 119 is created and will become the next occupied point. 

 

Note:  A known problem is that the InRoads feed-back pane does not always 
synchronize correctly. If you do not see newly created geometry here, use 
Geometry > Review Geometry Points to verify point 119 was created. 
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From the newly created point 119, traverse to the east establishing point 121 on 
the South right-of-way line of S.H. No. 86. Said point lying at N 89^12’18” E, a 
distance of 30’ (RW width) + 660.53’ (ROW length). 

 121 

119 

9.  Complete the dialog as shown below. 

 

Notice the previous foresight point has become the occupied point. Also note 
math operations can be used in the input fields.  Once you [tab] from the field, 
the math operation computes. Experiment using +, -, *, /  

10. <D> Apply  

Point 121 is created. 
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7. Creating Alignments 

Chapter Introduction 
In this chapter you will expand on previous training to create alignments by 
chaining Cogo points together.  This methodology, commonly referred to as the “PI 
Method”, uses the Geometry>Horizontal Curve Set tools.   

Lab 14 - Horizontal Alignments from Cogo Points 

Objectives 
Connect the 3 Cogo points established along the west line of Section 13 to form 
an alignment that represents the centerline of County Road 303. Once 
established, this alignment can be used for establishing the right of way limits 
for said road.  

Creating a new alignment 
Create an alignment by chaining Cogo points 120, 119, and 105 together which 
represents the west line of section 13. 

1. Set the MicroStation View to show the subject area. 

  

105 

119 

120 

2. Select Geometry > Utilities > Create/Edit Alignment by Cogo 
Points 

A warning message may appear which indicates that the active alignment may 
have illegal (unassigned) point names.  
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Recall that the alignment C_Centerline was created with unnamed geometry 
points (you can verify this with Geometry > Review Horizontal).  In a previous 
exercise the alignment points were written to the Cogo buffer. Doing so created 
Cogo points for the alignment vertices but did not associate the created Cogo 
points back to the alignment. You are presented with two options: 

Selecting No: The identified alignment continues to exist using unnamed 
geometry points, which is OK and the Create/Edit Alignment by Cogo Points 
dialog will open. 

Selecting Yes: InRoads will associate the Cogo points created back to the 
alignment vertices.  Either solution is OK, ultimately it is at your discretion 
which to choose. 

3. For informational purposes, Select <D> Yes  

The Create/Edit Alignment dialog opens. 

 

As seen in the dialog above, the alignment C_Centerline is defined as having 
Cogo point numbers assigned at its vertices. The letter C indicates the Cogo 
point identified is the Center of a curve.  The letters R or L indicate the curve 
direction (Right or Left). 

Entering a value in the Name field and pressing [tab] will blank the dialog and 
allow the creation of a new alignment. 
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4. Use the following: 

 Name: West Line of Sec 13 
 Description: CL CR 303 

Note:  In this instance CL CR stands for Center Line of County 
Road 303.  Do not confuse the L and R used in the description with 
the L and R used to indicate the curve direction, as described on the 
previous page. 
 

 Style: RW_Sec-Line_ex 

 

5. <D> Start 

The dialog will collapse and you are prompted to Identify Point 

6. <D> near the points on the screen starting on the south end.   
Continue to graphically select points to define the alignment.  
Graphics will display showing the alignment location.  By default, 
the alignment will pass through the points nearest the data point 
without the geometry point snap enabled. 

7. <R> when finished selecting points graphically, the dialog will 
redisplay. 

8. <D> Stop  

The dialog will populate with the Cogo Points selected. 

Page 66  ROW Geometry & Plans 



 Chapter 7-Creating Alignments 

 

 

 

Note:  Cogo points can be deleted, inserted, cleared, or edited directly in the 
Alignment definition section of the Create/Edit Alignment dialog.  If desired, 
the entire definition can be input through the use of the keyboard. If using the 
keyboard, data must be included in parenthesis. Additionally, a space is 
required adjacent to the parenthesis. 

If any points were selected by mistake, they can be edited.  Using the cursor and 
keyboard, simply replace the accidental input(s). 
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9. <D> Apply the horizontal alignment is created and displayed. 

 

Notes:    

 Alignments are directionally based. If the above workflow 
was followed, the created alignment runs South to North.  
This becomes important when offsetting the alignment to 
either the left or right (left is input as a negative number) 

 Alignment direction can be ascertained by: reviewing the 
alignment, by tracking, or by displaying stationing 

 Alignment direction can be ‘reversed’ by using the 
Geometry > Transpose command 

 Alignments created by chaining Cogo points can be edited 
using the Geometry > Horizontal Curve Set tools 
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Challenge Lab: 
Reopen the dialog for creating alignments by chaining Cogo points: 

 Create new alignments 
 Experiment with deleting or adding Cogo point numbers in 

the dialog 
 <D> the Help button and investigate adding curved elements 

to an alignment 
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Cogo Intersections & Parcels 

Chapter Introduction 
The following exercises employ a combination of geometry commands to define 
the boundary of the Summit Business Park land division and lots. 
These will include: 

 Establishing Cogo points by intersecting alignments 
 Establishing Cogo points by traversing 
 Establishing Cogo points by offset intersections 
 Establishing the subdivision boundary as an alignment 
 Creation of parcel(s) by inputting deed information 
 Reviewing parcel closure 

Geometry  
All property information that relates to right of way must be created as a 
component of a geometry project for InRoads to assist in the development of 
right of way parcels.  This includes public land survey lines (section lines), deed 
limits, existing and proposed right-of-way, easements and other parcel 
information.  

 

Essential Concept: Parcels are simply alignments that are closed. 
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Lab 15 - Cogo Intersection Commands 

Introduction 
Development of right of way information can be facilitated using Cogo 
intersection commands.  These Cogo points can then in-turn be used to define 
alignments (parcels).  While this is a potential workflow, it is not necessary to 
first create Cogo points.  It is simply one solution to establish required geometry 
information. 

In order, create Cogo points for: 

A) The intersection of the design reference line and the west line of 
section 13   
Alignment-Alignment intersection 

B) The NE corner of Summit Business Park 
Alignment-Alignment intersection using Offsets 

C) A right of way point on the east side of County Road 303  
Direction-Alignment intersection 

D) The NW corner of Summit Business Park 
Station & Offset 

E) The SW corner of Summit business Park 
Traversing 

F) The SE corner of Summit business Park 
Direction-Direction intersection 

 

A 

C 

B 

D 

F E 

ROW Geometry & Plans  Page 71 
 



Colorado Department of Transportation 

 

Before Beginning: 
Grouping Cogo point numbers together is desired. All Cogo points for these 
exercises are to start with point number 300 and automatically increment. 

1. Select Tools > Options > [Geometry] 

2. Input a Seed Point Name of 300 

3. <D> Apply 

4. <D> Close 

 

Exercise A 
Establish a Cogo point at the intersection of the project reference line with the 
west line of section 13. Two alignments exist representing these features: 
C_Centerline & West Line Sec 13 

1. Select Geometry > Locate > Intersection 

The Intersection dialog opens.  The Type selection list defines typical Cogo 
intersection commands.  

2. Select Type: Alignment/Alignment 
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3. Complete the dialog as shown below. 

 

Note:  In addition to selecting the alignments to intersect, offsets can be 
defined. A negative sign (-) indicates an offset to the left. 
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4. <D> Apply - a results dialog opens if report lock is enabled. 

5. Key-in a Description, and choose a Style as shown. 

 

Note:  If it is possible for the intersection command to provide another 
solution, selecting the Reject button will display the alternative results.  Results 
are shown numerically in the dialog and dynamically on in the MicroStation 
screen. 

6. <D> Accept -  a Cogo point is created at the intersection. 
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Exercise B 
Use the intersection command to establish point 301 at the intersection of the 
south right of way of S.H. 86 and the west right of way of CR 303. 

 

301 

7. Select Geometry > Locate > Intersection 

8. Complete the dialog as shown. 
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Notice the negative offset defined for Alignment 2. The alignment representing 
the west line of section 13 runs south to north. A negative offset indicates a 
distance to the left. 

9. <D> Apply 

10. In the Location Results dialog, Key-in: 

  Seed Name: 301 
 Description: Existing RW @ CR 303 
 Style: RW_ROW-Line_Exist 

 

11. <D> Accept - to create point 301. 
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Exercise C  
Use the intersection command to establish point 302 on the east right of way of 
county road 303. 

 

Previously 
established 
Point 121 

302

119 

12. Geometry > Locate > Intersection 

13. Complete the dialog as shown below: 

Type: Direction/Alignment 

Name: 119 (origin point) 

Direction: a 119 121 (computes the bearing from point 119 to 121) 

Alignment: West Line of Section 13 

Offset: 30.00 (to the right - positive) 

 

ROW Geometry & Plans  Page 77 
 



Colorado Department of Transportation 

 

14. <D> Apply 

The Locate Results dialog appears. 

15. Seed name should reflect 302, if not, key it and a description in, and 
select a style. 

  

16. <D> Accept - to create cogo point 302. 
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The limits of the adjacent subdivision, Summit Business Park, will be 
established.  We had previously defined the NE corner of the plat at Cogo point 
301.  

Establishing the plat boundaries will be done in the following order: 

 Establish the NW corner by Station and offset 
 Establish the SW corner by bearing & distance 
 Establish the SE corner by intersection 
 Create an alignment representing the subdivision boundary 

 
Exercise D 

1. Use MicroStation to view the NW corner of the subdivision 
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Establish a Cogo point at the NW corner of the subdivision. 

 

  

303 

A Cogo point is necessary at station A 414+48.30, 100.09’ RT 

The stationing for establishing point 303 is relative to the reference line 
C_Centerline. The letter ‘A’ indicates this location falls within a station equation 
range. 

2. Set C_Centerline as the active horizontal alignment.  
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3. Select Geometry > Horizontal Curve Set > Events 

The Horizontal Events dialog is multi-functional; it provides the ability to enter: 

 Event points relative to a horizontal alignment  
 Generates points in the Cogo buffer 
 Generates Cogo Points based on alignment vertices 

4. In the Add As section: radio button on Cogo Point 

5. Set Define By to: Single Station               

 Single Station - defines a location by station, offset definition 
 Single Point - defines locations by coordinate values 
 Multiple Stations -  defines locations at a specified intervals and 

offsets 

6. Key-in a Seed Name: 303 

7. Enter a Description and select a Style as shown. 

8. Key-in Station: A 414+48.30 

9. Key-in Offset 100.09 

10. <D> Apply - to create the Cogo point. 

  

11. <D> Close to close the Horizontal Events dialog. 

The cogo point is created. 
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Alternative Solution 
Select Geometry > Cogo Points > New 

The Define By field can be toggled between Northing/Easting and 
Station/Offset. 
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Exercise E 
Create a Cogo point to establish the SW corner of Summit Business Park by 
bearing and distance.  The corner lies S 0° 34' 04.55" E, 1822.75 feet south of 
the NW corner of the plat. 

 

1. Select Geometry > Traverse 

2. Input the data values as shown below.  

 

3. <D> Apply - to create a Cogo point at the Southwest corner of the 
plat. 
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Exercise F 
Three of the four corners for the plat Summit Business Park are created.  Only 
the SE corner remains.  Establish the SE corner by intersection. 

 

Establish point at 
SE corner of SBP 

304 SW corner

301 NE corner ( also on 
the west line of CR 303)

303 NW corner 

Alignment  
West Line of Section 13 
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Criteria for establishing the SE corner: 

 The south line of the plat bears N 89 55 40.5 E 
 The east line of the plat is parallel to the west line of Section 13 

4. Select Geometry > Locate > Intersection 

5. Set Type: Direction/Direction 

Direction 1  

 Name: 304 
 Direction: Key-in N 89 55 40.5 E 

Note:  The selection button on the dialog can be used to populate the Name 
(coordinate) fields.  To select Cogo points the point snap must be toggled on.  

. Turn this lock off after use. 

 

Direction 2 

 Name: 301 
 Direction: Key-in  S 0 36 36.66 E (SE or NW will both work) 

 
Note:  The Angular Precision set by Tools > Options > [Precision] affects 
the display of Direction input fields throughout InRoads.  CDOT 
Preferences set the Angular Precision to 0, therefore an input of N 0 36 
36.66 W will be reformatted by InRoads as N 0 36 37 W.  The actual input 
will be used in the calculation. 
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Note:  The selection button on the dialog can be used to populate the Direction 
field.  

The required direction is parallel to the west line of section 13 

To use the selection button for direction definition: 
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 Toggle on the Element lock   
 <D> on the selection button  
 <D> on the west line of the SW ¼ of Section 13 

<D>

The direction of the identified geometry line populates the dialog. 

 

6. Make sure both offsets are set to zero 

7. <D> Apply  

The Locate Results dialog appears. 

Enter: 

 Seed Name: 305 
 Description: SE Cor SBP @ CR 303 
 Style: RW_ROW-Line_ex 
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8. <D> Accept - to create a Cogo point at the Southeast corner of the 
plat. 

 

 

9.  Toggle the geometry snap  Off        

Note:  It is good practice to leave geometry snaps off except when explicitly 
required. 
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Lab 16 - Creating a Closed Alignment 

Introduction 
The plat of Summit Business Park has the 4 corners defined by Cogo points.  
Creating a closed alignment using the PI Method to represent the boundary of 
the plat will facilitate right of way creation. 

Create a new horizontal alignment named Summit Business Park 

1. Select File > New > [Geometry] 

2. Type: Horizontal Alignment 

3. Name: Summit Business Park 

4. Description: SW of int. of RL & CR 303 

5. Style: RW_Property-Bndry-Line_ex 

6. Curve Definition: Arc 

7. <D> Apply 

 

8. Set the active horizontal alignment: Summit Business Park  
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9. Select Geometry > Horizontal Curve Set > Add PI 

10. You are Prompted to: Identify Alignment End 

 

11. Toggle On the geometry Point snap   

12. Select the plat corners in a counter-clockwise direction 

13. <D> near the SW corner of the plat (defines the POB) 

14. <D> near the SE corner of the plat 

15. <D> near the NE corner of the plat 

16. <D> near the NW corner of the Plat 

17. <D> near the SW corner of the plat (defines the POE) 

18. <R> to cancel point selection, <R> to terminate the command 

19. Toggle Off the geometry point snap  
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20. Select Geometry > Review Horizontal to verify the contents of the 
alignment. 

  

Notice the lack of point 
names (or Cogo numbers) in 
the parentheses.  Also note 
the parcel area information is 
displayed. 

 

 

The population of the 
name/number field is 
contingent on the settings 
under Tools > Options > 
[Geometry] at time of 
geometry creation. 
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Geometry Verification 
As seen above, the Cogo points selected to define the alignment are not 
necessarily a part of the definition of the alignment.  To rectify this, 2 possible 
solutions exist.  Firstly, the Create/Edit Alignment by Cogo Points command 
could have been used to generate the alignment initially.  Secondly, this same 
command can be used to assign and verify the alignment. 

21. Select Geometry > Utilities > Create/Edit Alignment by Cogo 
Points 

  

22. <D> Yes 

 

The alignment is associated with the selected Cogo Points. 

23. Edit points as necessary. 

24. <D> Apply – verify results by reviewing the alignment. 
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Lab 17 - Parcel Creation by Deed 
Introduction 

Lot number 1 lies at the Northeast corner of the Summit Business Park plat. 
Right of way acquisition will occur along the northerly limits of the plat. A 
parcel needs to be created from the deed information for lot 1. 

 

To create the parcel (closed alignment) for lot 1, the InRoads command 
Geometry > Traverse could be used.  Another solution is to use the Traverse 
Edit command.  Traverse Edit is another Application ADD-In command and 
must be enabled.  In addition to allowing traversing, the traverse edit command 
reports on parcel closure and provides adjustment commands. 

1. Using InRoads, select: Tools > Application ADD-Ins… 

2. Toggle On the Traverse Edit Add-in 

3. <D> OK 
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Before using the Traverse Edit command, create an alignment to store 
Lot number 1. 

4. File > New > [Geometry] 

Select the Geometry tab and input: 

5. Type: Horizontal Alignment 

6. Name: Summit BP Lot 1 

7. Description: Lot 1 of Summit Business Park 

8. Style: RW_Property-Bndry-Line_ex 

9. <D> Apply 

 

10. Select Geometry > Utilities > Traverse Edit 

The Traverse Edit dialog opens.  

11. Set the fields for the Geometry Project and Horizontal Alignment 

12. Key-in : 301 for the Starting Point (Cogo point 301 is located at the 
NE corner of lot 1). 
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Lot 1 is described as: 

Commencing at the West ¼ corner of Section 13, Township 8 South., Range 64 
West.  Thence along said section line N 0-37-05 W, 154.14 feet. Thence 
departing from said section line S 89-22-55 W, 30.00 feet to the westerly right-
of-way line of County Road 33 and the Point of Beginning. 

1) Thence S 0-36-32 E, to the northerly right of way line of Summit 
Business Park Road, 384.92 feet. 

2) Thence along said right of way line, S 89-23-57 W, 98.15 to a point 
of curvature.  

3) Thence N 81-49-50 W, 64.65 feet along the chord of said curve, 
having a 200.00’ radius to the right. 

4) Thence N 73-03-36”W, 129.63 feet. Thence departing from Summit 
Business Park Road, N 0-34-22 W to the southerly right of way line 
of S.H. 86, 416.94 feet. 

5) Thence along said right of way line, S 74-45-58 E, 296.65 to the 
point of beginning. 
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POB 
Point 301 

 

13. <D> the Add After button on the Traverse Edit dialog. 

14. Set Type: Linear 

15. Input the Direction and Distance for the first course as shown. 

 

16. <D> Apply - the course is added to the alignment. 
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17. Input the second Course. 

 

18. <D> Apply - the second course is added to the alignment. 

 

19. Input the third course – change Type: Circular 
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20. <D> Apply - the third course is added to the alignment. 

 

Notice as courses are entered, the parent dialog displays closure results. 

21. Input the fourth course and <D> Apply 
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22. Input the fifth course and <D> Apply 

 

23. Input the sixth and final course and <D> Apply 

 

Review Closure Results in the parent dialog. 
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24. <D> Apply to create the alignment. 

 

Note:  The Report button on the dialog can be used to summarize the alignment. 
The report can be written to a text file. 

Notice the Adjustments button on the Traverse Edit dialog is dithered.  If the 
alignment contains circular elements, adjustments are not enabled. 
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Challenge Lab: 
• Edit the record containing the curve by <D> on it and selecting Edit 

• Change the record type to Linear 

• Input the chord Direction and an incorrect chord distance, <D> 
Apply 

 

• Close the Edit Element dialog 

• <D> on the Adjustments button 

 

• Select the appropriate Method 

• <D> OK to apply the selected adjustment 

Notice the columns for Unadjusted and Adjusted values.  As the various radio 
buttons for method are selected, the adjusted values update providing a preview 
of potential solutions. 
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Lab 18 - Right of Way Parcels 
InRoads has a utility to create additional parcels (closed alignments) from 
existing parcels and crossing alignments.  As illustrated below, lots 1-4 have 
been created and the proposed right of way indicates required right of way 
acquisition along the northerly limits of the lots. 

 

Existing ROW 

Proposed ROW 
S.H. 86 South ROW 

The command used for this exercise is another application ADD-In and is added 
to the Geometry > Utilities menu.  The Create Right-of-Way menu item is a 
subset of the Lot Creation application. 

 

If you do not see the Create Right-of-Way option, go to Tools > Applications 
Add-Ins and activate Lot Layout Add-In.  
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Parcels have been created for Lots 1-4 and stored in the Geometry Project 
12345_SummitBP.  Load this geometry project from the folder: 
C:\Projects\12345\ROW Survey\InRoads\Geometry 

1. File > Open – Open the Geometry folder noted above. 

2. Load the 12345_SummitBP.alg file. 

  

 

3. Select Geometry > Utilities > Create Right-of-Way 
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Dialog Settings: 

Alignment (selected) - Original parcels impacted by ROW acquisition 

Cogo Points - If enabled, will create Cogo points at the intersection of the 
proposed right of way and existing lot lines 

Right of Way - If enabled, creates parcels representing the acquisition area 

Remainder - If enabled, creates parcels representing the remainder of the 
selected lots 

4. Complete the Cogo Points section as shown. 

 

5. Complete the Right-of-Way section as shown. 
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6. Complete the Remainder section as shown. 

 

7. <D> on the Filter button. 

 

8. Under the Available column, select Summit BP Lot 1-4. 

9. <D> the Add button. 

10. <D> OK 
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The parcels are added to the list. 

 

11. <D> Apply - you are prompted to identify the Right of Way 
Alignment. 

12. <D> on the alignment S.H. 86 South ROW - parcel previews will 
highlight. 
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S.H. 86 South ROW 

 

13. <D> inside any acquisition parcel to define which side of the 
identified alignment the acquisition parcels lay - the parcels and 
Cogo points are then created 
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Lab 19 - Annotation of Closed Parcels 
Parcel information can be annotated in the MicroStation drawing using InRoads 
geometry commands. 

1. Select Geometry > View Geometry > Closed Areas 

2. <D> the Preferences button. 

3. Load the settings for proposed parcels. 

 

4. Define the acquisition parcels for annotation (use the filter). 

5. Toggle On the desired information in the Annotate section, <D> 
Apply 

  

6. Repeat steps 2-5 for the Remainder parcels using the Property-
Existing Preference. 
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7. Toggle on all the Annotate radio buttons, <D> Apply - the graphics 
refresh. 

 

Notes:  

• Annotation will only be applied to alignments that are closed.  
Parcels that have closure errors are ignored 

• There are saved preferences in the View Closed Area dialog for 
existing vs. proposed annotation 

• The number of decimal places carried out in the annotation is 
controlled by Tools > Options on the Precision tab 

• Selecting the Dual Dimension radio button will annotate in both 
square feet and square meters 
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Challenge Exercise – Transforming a parcel 
Use the TravEdit command to generate a parcel (alignment) for lot 5 of Summit 
Business Park.  The graphic below shows the required courses to create said 
parcel.  Once created, use the Transform command to move and rotate the parcel 
so that the NE line of Lot 5 coincides with the SW line of Lot 4. 

 

POB 

Create a Horizontal Alignment to store Lot 5. 

1. Select File > New > [Geometry] – Horizontal Alignment 
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2. Select Geometry > Utilities > Traverse Edit 

Assume a starting location (this may be based on a call-out, existing 
geometry point, or an assumed location). 

Key-in a Starting Point of: - DO NOT INPUT COMMAS 
N = 1,556,000.00 
E = 3,277,600.00 

Enter clockwise courses beginning with the NW corner of Lot 5. 

 

 

 

3. Select Add After and input: 
S 62-33-49 E, 638.13 
S 41-40-12 W, 92.80 
S 88-10-38 W, 492.83 
N 01-49-28 W, 379.21 

4. <D> Apply to create the parcel once all courses have been entered 
and verified by reviewing the closure results. 
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The parcel is created to the west of the true location.  It also has a slight 
rotation.  

Use the Transform command to relocate and rotate the parcel.  Do so in 2 
steps. First move the parcel, and then rotate it to align with Lot 4. 

5. Select Geometry > Utilities > Transform 

 

6. Identify the Alignment to transform 

7. Identify the coordinate values for both the Original & Destination 
Points 

8. <D> Apply 
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B 

C 

A 

The parcel is relocated but a rotation is evident. 

Continuing to use the transform dialog. 

9. Set the Original Point and Destination Point to the same value ( 
the point to rotate about) 

10. Identify the value of rotation required by key-in or by using the 
selection icon to graphically pick points A, B, & C shown above to 
define the rotation angle.  
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11. <D> Apply 

The parcel (alignment) is transformed. 

 

Verify the results with reports, display, annotation, or other means. 

Note:  Relocating and rotating the parcel could have been accomplished in a 
single operation if so desired.
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 XML Reports 

Chapter Introduction 
Two types of reporting are currently available within InRoads.  The older version 
which is based on DBAccess reports is being discontinued with an upcoming 
release of InRoads.  The old format is being replaced with a reporting utility based 
on the eXtensible Markup Language or more commonly referred to as XML.  Like 
the HTML language used for web development, XML reporting is based on tags 
and attributes which delineate elements of data. Formatting of XML data is 
accomplished through the use of XSL, or style sheets and displays in a web browser 
page. 

Lab 20 - Parcel Descriptions 
XML reporting is another Application ADD-In. Select the InRoads Tools menu 
to determine if XML reporting is activated. 

1. Select the Tools menu item to check the available menu items. 

 

2. If XML Reports is not visible, select Tools >Application Add-Ins.  
Toggle on the XML Report Add-In. 

 

3. Select Tools > XML Reports 
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4. <D> the Legal Description Tab. 

5. <D> in the Closed Alignments field. 

6. <D> the Filter button and add Summit BP Lot 4 as a selected 
alignment. 

7. At the bottom of the dialog, input the file name: 
C:\Projects\12345\ROW_Survey\InRoads\Reports\SBP Lot 
4.xml 

Note: You can also select the Save As button to define the path and 
filename. 

8. <D> Save 

 

An XML file and a report is created with format and display from an InRoads 
default style sheet. 
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9. <D> on the various report styles (*.xsl) displayed in the left panel 
and notice the change to the format and contents of the displayed 
report. 

10. In the Report display, select Tools > Format Options 

 

11. <D> Acres/Hectares: Set to 5 decimal places - the report updates. 

 

12. Change any of the fields in the Format Options dialog and notice 
the report interactively updates. 
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13. In the Report display, select File > Save As… 

Save As:  

Path: C:\Projects\12345\ROW_Survey\InRoads\Reports 

File Name: SBP Lot 4.xml 

14. <D> Save 

 

Reports can also be recalled for reformatting, etc. 

15. Select File > Open from the report browser. 

16. Open the SBP Lots 1-4.xml file from the folder: 

C:\Projects\12345\ROW_Survey\InRoads\Reports 
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17. <D> on the category Geometry and style sheet Area.xsl 

 

Note:  Lot areas and perimeter distances are reported. 

18. In the category Geometry, access style sheet List Coordinates 

 

The report is redisplayed to display alignment coordinates. 

19. While viewing the xml report, <R> on the screen - a fly-out menu 
appears. 
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20. <D> on Export to Microsoft Excel 

 

Excel will launch and display the results. 

 

 

Note:  The output to Excel will only contain data from individual alignments 
based on the location in the xml report the fly-out menu was activated. 

To view the source information the xml report was generated from: 
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21. In the Report browser, select Raw-xml.xsl in the left panel 

 

What you see are the xml tags and attributes which define the report contents. 
Formatting of this data for display is accomplished through the use of xsl, or 
style sheets.  Style sheets can be developed by the user for customized reports or 
formats. 

Other formats: 

In the category DataCollection access style sheet ListCoordinatesSDR33 

 

Experiment with other style sheets such as HorizontalElementsSDR33 as well as 
other style sheets in the Geometry category. 

 

 



                                                                                                                         Appendix A – Importing Cogo Points  
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Appendix A 

Importing Cogo Points 

Importing Cogo Points from Graphics 
Graphic elements can be imported to generate geometry. Some of the valid 
element types are: lines, linestrings, cells, text, shapes, etc. Refer to the InRoads 
help topic Import Geometry 

To import Cogo points from a graphics file; 

Identify graphics using a selection set or a MicroStation fence 

 

Select File > Import > Geometry > [From Graphics] Type – Cogo Points 

 

<D> Apply 



 Appendix A – Importing Cogo Points 

Verify the results 
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Importing Cogo Points from ASCII 
To import Cogo points from an ASCII file; 

Select File > Import > Geometry > [ASCII] Type – Cogo Points 

 

 

 
- See following page for a separate discussion on Cogo Points from InRoads Help -



 Appendix A – Importing Cogo Points 

From the InRoads help topic – Importing Geometry from ASCII 

Coordinates should be input as decimal numbers and have the same units of 
measure as the master units of the currently active graphics file. If the data file 
contains point IDs, they should be input as integer numbers. All columns may be 
separated by blanks or tabs. Records contained in the file having no data or 
beginning with a semicolon (;), exclamation point (!), or asterisk (*) are ignored.  

The ASCII files are free format, so the first line of each file specifies the order 
of the columns of information. The column order can vary from one file to the 
next as long as the first line indicates the contents of each column. As points are 
loaded, they are checked to verify that they all fall within the current design 
plane.  

You can select the following format types from the Types box on the ASCII tab 
of the Import Geometry dialog box:  

Cogo Points 
X_CRD  easting (required)  
Y_CRD  northing (required) 
Z_CRD  elevation  
POINT_TXT  name  
FEATURE  preference  
STATION  station number  
STA_EQN  station equation  
OFFSET  offset  
DUMMY  

The following is typical of the format used for an ASCII point file:  

{ FEATURE POINT_TXT Y_CRD X_CRD Z_CRD   
ESP 1000         9202.984    2425.017     52.230   
ESP 1001         9221.065    2415.948     51.984   
ESP 1002         9239.307    2407.651     51.730   
ESP 1003         9257.879    2400.100     51.466   
ESP 1004         9276.719    2393.293     51.204   
ESP 1005         9295.811    2387.244     50.938   
*ENDOF LINE   
ESP 1006         9352.376    2374.042     50.373   
ESP 1007         9372.199    2371.057     50.305   
ESP 1008         9392.131    2368.864     50.236   
ESP 1009         9412.127    2367.496     50.187   
*ENDOF LINE   
*EOF  
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Importing Cogo Point from ICS 
From the CDOT manual: Roadway Design Using InRoads – Importing 
Geometry from text files 

Text files may be imported from several formats, the easiest of which to create 
is an .ics file. (Interactive Coordinate geometry Subsystem) This file type was 
first used with a product of the same name many years ago, but is still in use 
with InRoads today. It is basically a list of cogo commands along with the input 
for those commands. 

If you have a text file of coordinates, you can create an .ics file by adding a 
Store command at the top and formatting the file similar to the one shown 
below. 

 

Choose File > Import > Geometry > [ICS] 

Browse to find the file then choose Apply.  

 

The cogo points will be added to the active geometry project. You may then use 
Geometry > Utilities > Create/Edit Alignment to join the points, forming an 
Alignment and Geometry > Horizontal Curve Sets > Define Curves to add 
curves to the alignment.  You can also accomplish these same tasks within the 
.ics file.  See the Bentley Help topic Alpha Cogo.
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Appendix B 

Geometry Options 
Project geometry parameters are defined by the user. 

1. Select Tools > Options > [Geometry]  

 

Geometry Defaults 
 Plotting Height - default elevation assigned to geometry points 
 Seed Alignment Name - initial name assigned to alignments 
 Seed Point Name - initial Cogo point name or alignment vertices 

name 
 Curve Definition - arc, chord, length of curve definitions 
 Angular Mode - Bearings or Azimuth settings 
 Point Names During Edits - horizontal alignment vertices 
 Do not assign - creates unnamed points 
 Assign - creates sequential alignment vertices names based on the 

seed point name 

Note:  Alignment vertices defined with alphanumeric characters are not 
entered into the Cogo buffer by default.  The Horizontal Event Point command 
can be used to send alignment key points to the Cogo buffer. 
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Units and Format 
2. <D> Units and Format 

 

 

InRoads does not recognize or use the unit definition associated with the host 
MicroStation file. The units defined under the units and format tab define the 
units of measure for InRoads data. For commands that utilize distance or area 
parameters, InRoads looks to the settings in this dialog to determine if the 
distance or area defined is imperial or metric units. 

 Units Linear - Imperial or Metric 
 Units Angular - Degrees, Grads, or Radians 
 Format Angular - Degrees, Minutes, Seconds or Decimal Degrees 
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3. <D> Precision 

 

The precision tab defines the number of decimal places displayed in dialogs. It 
also defines the number of decimal places displayed when posting information 
to the MicroStation screen or when writing data to an ASCII file. 

Note:  The settings in the precision tab only effect display settings. It does not 
define computational parameters. 
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4. <D> Affixes 

 

a. Set Type to: Point 

 

Used for Cogo points and alignment vertices annotation commands. 

b. Set Type to: Circle 

 

Used for horizontal curve annotation commands.  
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c. Set Type: Line 

 

Used for annotating horizontal alignment segments. 

d. Set Type: Spiral 

 

Used for spiral curves. 

e. Set Type: General 

 

Used by miscellaneous commands. 

An example of a command that uses the Affixes specified under Type: General 
is Tools > Tracking > Tracking. 

 
With this command, Station and Offset information can be displayed for select 
locations.  Prefixes or suffixes used as part of the display of this information are 
controlled by the settings under Type: General.  

 
In this example, the Station prefix setting is ‘Sta=’ and the Right prefix setting is 
‘Rt.’.
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Appendix C 

Horizontal Regression Analysis 
Regression analysis can be used to facilitate the development of horizontal 
alignments by creating a ‘best-fit’ alignment through defined points. 

1. Create a horizontal alignment to store the results in. 

2. Select Tools > Application Add-ins to enable the command. 

 

3. Select Geometry > Horizontal Regression > Add Regression 
Point  The Add Horizontal Regression Points dialog will appear. 
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4. <D> in the Include field so the Filter button becomes activated. 

 

5. <D> the Filter button.  The Geometry Selection Filter dialog will 
appear. 

 

6. Create a selection of centerline points to be used for analysis. 

 

7. <D> the OK button in the Geometry Selection Filter dialog. 
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8. <D> the Apply button.  The dialog will minimize allowing you to 
graphically define the first and second points to define initial course 
for evaluation. 

 

9. <D> the first point in the MicroStation view and <D> second point in 
the view to define the direction of the analysis.  The Add Horizontal 
Regression Points dialog will reappear. 

10. <D> the Close button. 

First Point 

Second Point 

Direction of 
Analysis 
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Select Geometry > Horizontal Regression > Edit/Review Regression 
Points  The Edit / Review Horizontal Regression Points dialog will appear. 

 

11. Refine the selection of points to be used for analysis by using the Ctrl and 
Shift keys or using the Select button to define a selection area. 

 

12. <D> the Edit button.  The Edit Horizontal Regression Point dialog will 
appear. 

13. <D> the radio button Yes to Include in Analysis. 

 

14. <D> the Apply then Close buttons.  Leave the Edit / Review Horizontal 
Regression Points open for further edits. 

15. Select Geometry > Horizontal Regression > Single Element Regression 
Analysis  The Single Horizontal Element dialog will appear. 
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16. Select Element Type: Linear or Circle 

 

17. <D> Compute to view the results in the MicroStation view. 

 

18. <D> Save to create the alignment element. 
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19. <D> the Report button to view a summary. 

 

20. Review the results. 
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