
 
 

IINNRROOAADDSS  GGEEOOMMEETTRRYY  FFOORR  RROOWW  AANNDD  
RROOWW  PPLLAANN  DDEEVVEELLOOPPMMEENNTT  UUSSIINNGG  

MMIICCRROOSSTTAATTIIOONN  
  

DDooccuummeenntt  22  ooff  22  
 

 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

  



Colorado Department of Transportation 

 Page ii 

This document has been prepared for: 

Colorado Department of Transportation 
4201 E. Arkansas Ave. 
Denver, CO 80222 
 

This document has been prepared by: 

Bohannan Huston, Inc. 
Main Office:  
Courtyard I 
7500 Jefferson St. NE  
Albuquerque, NM  87109 

Bohannan Huston, Inc. 
Denver Office: 
Meridian One 
9785 Maroon Circle 
Suite 140  
Englewood, CO  80112-5919 

The Envision Group, Inc. 
8517 Excelsior Dr. 
Suite 102 
Madison, WI 53717                 
 

 
Copyright 

Many of the designations used by manufacturers and sellers to distinguish their products are claimed as trademarks.  
MicroStation and InRoads are trademarks of Bentley Systems Incorporated.  Where other designations appear in this book, 
and the authors were aware of a trademark claim, the designations have been capitalized. 
 
Disclaimer 

Notice of Disclaimer: The Colorado Department of Transportation (CDOT) provides documents on an “as is” basis.  All 
warranties and representations of any kind with regard to said documents are disclaimed, including the implied warranties of 
merchantability and fitness for a particular use.  Under no circumstances will CDOT, or any of its officers or employees be 
liable for any consequential, incidental, special or exemplary damages even if appraised of the likelihood of such damages 
occurring.  CDOT does not warrant the documents against deficiencies of any kind.  The use of any of these documents for 
work which is under contract with CDOT, does not relieve the contractor from any obligation assumed by the contract, or 
from complete and proper fulfillment of the terms of the contract, nor does it entitle the contractor to compensation for 
damages or loss which could be attributed to such use. 
 
Notice 

This training manual cannot be reproduced or copied without the express written consent of CDOT. Any further sale or re-
publication of this training manual without CDOT’s express consent is prohibited. 
 
While every precaution has been taken in the preparation of this book, Bohannan Huston, Inc., The Envision Group, Inc. and 
the Colorado Department of Transportation assume no responsibility for errors or omissions, or for damages resulting from 
the use of the information contained herein.  This information is subject to change without notice 
 
Software Versions 

The software products referred to in this publication are furnished under a license and may only be used in accordance with 
the terms of such license. This document intended for use with the following software versions:  
 

MicroStation® version 08.05.02.55 
InRoads® version 08.05.00.00 – Service Pack 5 

 
0408 – Version 03.02 CDOT Configuration 

 
 
 



 Document Conventions 

 

Document Conventions 
There are several conventions that are used throughout this document to indicate 
actions to be taken or to highlight important information.  The conventions are as 
follows: 

 

Example Item     Meaning 

View Perimeter a command name or a file that you are to select, including 
directory path 

Name: field name, button or icon in a dialog box 

Dialog Header dialog box name 

Tools > Options a command path that you are to select - usually from the 
pull-down menus 

Dialog Area heading for separated areas within a dialog box 

Tab heading for tabs found within dialog boxes 

Key in entering data with the keyboard or items selected from 
drop-down list 

Document name style used when referring to another document 

Note:  text  information about a command or process that you should 
pay particular attention to 

Concept:  text detailed definition of a concept, procedure or process 

Emphasis an important word or phrase 

Prompt user prompt 

1. Numbered Steps actions that you are to perform as part of the lab activities 

<D> or Data press the data button on the mouse 

<R> or Reset press the reset button on the mouse 

<T> or Tentative press the tentative button on the mouse 
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1. Getting Started 

Introduction 
In this chapter you will be introduced to the overall course contents, goals, 
schedule, and organization and the training directory structure.  

Course Overview 
Instructor led training session targeted to the survey group with a focus on 
MicroStation and InRoads functions applicable to ROW plat generation. 

This second day of this course will provide further education to the surveyors as it 
relates to the development of alignment diagrams and right of way plats. The intent 
is to introduce additional tools to the surveyors to facilitate development of 
documents for the right-of-way plat process. 

Items addressed in this course will be: 

 Creating ROW Plan sets 
 Using MicroStation tools 
 Using InRoads Plan and Profile Generator command 

Foundation 

Intended Audience 
The intended audience for this course is CDOT Survey and Right-of-Way Plans 
personnel who have completed the InRoads Survey Data Reduction class, the 
InRoads Geometry Fundamentals class and InRoads Geometry training for 
ROW and require further training on the use of the InRoads geometry tools 
specific to Right-of-Way development. 

Prerequisites 
The attendees must have a basic understanding of MicroStation prior to 
attending this course. Additionally, they must have attended the 2-day course 
Fundamentals of InRoads Geometry or otherwise have a genuine understanding 
of fundamental InRoads geometry. 

It is assumed the student is familiar with the InRoads interface and coordinate 
geometry in general. 

Duration and Format 
8 hours focused on plan sheet development. Format is instructor lecture and 
demonstration followed by hands-on lab exercises for students. 

Focus 
Geometry annotation, MicroStation reference files, automation tasks for 
tabular/textural data in plan sheets. 
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Goal 
The purpose of this course is to provide CDOT personnel with an understanding 
of how to use both MicroStation and InRoads tools to facilitate right of way plat 
development.  

Introductions & Schedule 

Instructor 
Introduction of Instructor(s) and brief summary of credentials. 

Students 
Introduction of students and a brief summary of student knowledge as it relates 
to MicroStation and InRoads and/or geometry. 

Student Interests 
Query as to specific interests of individual students and the class as a whole. 

Schedule 
Establish schedule for class breaks, lunch, and course termination. 
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CDOT CADD Resources 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & Engineering 
Innovation Web site. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: 

http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 

The website (presently only available to CDOT) provides CDOT users with up 
to date information, tools, and resources related to CADD and the Colorado 
Engineering Software Transition (CEST) project.  

 

http://internal/cadd/
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This website is a valuable resource for CADD users and includes: 

CADD Library  
The CADD Library page provides links to manuals, newsletters, standard details, 
etc. One extremely useful link is to the Tips and Tricks section for MicroStation 
and InRoads. This information changes daily, so check back often. 



  Chapter 1-Getting Started 

 

Plan Development for ROW  Page 5 
 

CADD Manual 
The CDOT Computer Aided Design and Drafting (CADD) Manual outlines 
CDOT’s use of Bentley’s MicroStation and InRoads software. It documents 
standardized procedures for the exchange of information between CDOT 
regions, specialty groups, and consultants working on CDOT projects. The 
Manual also addresses software issues, tools, techniques, standards and 
procedures, etc. which will aid the user in the efficient production of CDOT plan 
sets. 

The CDOT CADD Manual and the associated electronic files contained in the 
CDOT configuration are used in the generation of electronic plans by both 
CDOT internal designers and the consulting firms doing business with CDOT. 
The electronic version of the Manual provides hyperlinks to each chapter as well 
as context sensitive index and search functions. You can also print chapters or 
the entire manual. 

The CDOT CADD Manual can be accessed several different ways including: 

 From the CDOT internal CADD web site home page link; 
 From the CDOT Design and Construction Project Support Page (external 

web site); 
 From the CDOT Menu (Help > CADD Manual). 
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CDOT Workflows 
There are several standardized MicroStation and InRoads workflows that CDOT 
has developed to assist you. These workflows are step-by-step CDOT-specific 
procedures for certain tasks that you may encounter when working in 
MicroStation or InRoads on a CDOT project. Many of these workflows are 
referenced throughout the course. 

In addition to accessing the workflows from the CDOT CADD Web site Home 
page link CDOT Work Flow, you can also access workflows: 

 From the Windows Start menu  
(Start > All Programs > _CDOT_CADD_Information > Workflows); 

 From the CDOT Menu (Help > Workflows). 

New workflows are typically added with CDOT configuration updates, so check 
back often. 
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Issue Logs  
Check the Issue Logs to determine the status of submitted requests. 

Requests & Support 
The Requests & Support page provides CADD help solutions where you can: 

 Learn how to get help; 
 Submit a questions; 
 Submit a request (e.g. request a new MicroStation level or InRoads 

preference), as well as  
 Obtain InRoads, InRoads Survey and MicroStation support.  

There is also a link to IT Services for hardware support, “how to” instructions, 
installation, training files, and work space setup. 

  

 

Training 
Use this link to sign up for training classes.  You can also review online 
computer-based training (CBT) for MicroStation, InRoads and InRoads Survey. 
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Scope of Training Data 

Training Data Set 
This course is a continuation of the training set out in InRoads Geometry for 
ROW and will use the same data files. 

State Highway No. 86 - Elbert County 
This project has progressed to the point of having property information, design 
reference lines, proposed right-of-way limits, and easements developed. This 
data set will be used to generate the necessary data for development of Survey 
Control Diagrams and Right-of-Way parcels. 

Training Directory Structure 
All class work files will be in the C:\Projects\12345 folder, which has a 
combination of design and survey sub-folders and data files. 

The sample project in this document uses the standard CDOT file structure with 
12345 = CDOT Project Code (sub account). 
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Training Data 

 

The project data for this training session is based on Colorado S.H. 86. The 
overall workflow will consist of: 

MicroStation Plans Generation 
 Creation of standard ROW plan sheets 
 Generation of coordinate and parcel information lists using XML 

reporting and Excel spreadsheets 
 Creation of ROW plans using MicroStation reference file commands 
 Creation of ROW plans using the InRoads Plan & Profile Generator tool 
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CDOT Standard Sheet Borders 
Standard sheets are delivered with the CDOT configuration.  They are 
stored the folder: C:\Program Files\Workspace-CDOT\Project 
Template\ROW_Survey\Drawings   
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2. Working with MicroStation 

Chapter Introduction 
In this chapter you will receive detailed information about the training directory 
structure, specific lab files, and MicroStation resource files.  Additionally you will 
work with InRoads Project Defaults to identify default directories for opening and 
saving InRoads resource and data files. 

Lab 1: Creating files and placing cells 

Introduction 
Standard sheets for Survey and ROW plans were copied into the project 
directory for use in training.  Prior to beginning, use Windows Explorer or My 
Computer to review the training directory contents. 

Navigate to C:\Projects\12345\ROW_Survey\Drawings 

 

C:\Projects\12345\ROW_Survey\Drawings\Reference_Files 
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MicroStation Operation 
There are three easy methods to Start MicroStation 

 Choose Start > All Programs > MicroStation > MicroStation V8 and 
MicroStation will start and allow you to choose the design file, once the 
design file opens InRoads can be loaded as needed. 

Choose the Desktop icon for MicroStation if one is available 
on your machine. MicroStation will start and display the 
MicroStation Manager interface. 

 If Windows Explorer is open, <D> <D> on a *.dgn file will launch 
MicroStation. 

Use one of the above methods to start MicroStation. 

1. In the MicroStation Manager dialog box, go to the Workspace group 
section and change the User field to CDOT USER, the Project field to 
12345 and the Interface field to CDOT.  

 

This workspace setup should load the correct MicroStation environment 
(including toolbars) when the selected MicroStation file is opened. 
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2. Navigate to the folder ROW_Survey\Drawings  

3. <D> on file 12345ROW_TitleSht.dgn 

4. <D> OK in the MicroStation Manager dialog box to open the file. 

 

 

 

Your graphics window should appear as shown. 
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Notes:  The file names and directory structure used in this course 
are based on current information.  As the CDOT configuration 
develops and directory structure and file naming conventions are 
standardized, these may change. 

             The default Model scale for CDOT plan sheets is 1:100.  For 
sheets that are text based such as title sheets, and tabulation 
sheets, the Model scale is set to 1:1. Using the annotation scale 
lock synchronizes both graphics and text placed in the drawing.  
For drawings at other scales, the model properties will require 
modification.  See the instructor if additional information is 
required. 

Insert the Region, Designer information in the upper-left corner of the sheet. 

5.  The CDOT Menu should open by default when MicroStation is launched.  If 
for any reason the CDOT Menu is not open, you can open it from the Main 
Tool frame. 
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6. From the CDOT Menu <D> on Group Display>Select All. 

 

     

7. Select  ROW Survey in Group Display 

8. Set the Status to Proposed 

9. Select Borders PLS 

10. Select the Survey Supervisor Kevin Williams 

11. Select the Settings icon to get the Active Setting dialog box 
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12. In the Active Settings dialog box  set Active Scale to 1.00 and Active 
Angle to 0.00 

    

13. <D> Apply 

14. <D> Close 
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15. Place the cell at the upper-left corner of the sheet as shown 
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Challenge Exercises 

 Verify the coordinates at the lower left corner of the sheet (tentative 
snap).  Should be at 0,0,0 
 

 
 
 Determine the length and height of sheet (measure tools or AccuDraw).  

Should be 11 x 17 
 Investigate the levels the graphics are on (level display, element 

information, or pop-up information) 

Lab 2: Editing Text 
Formatting has been defined for standard sheets.  Text fields indicated with an 
‘X’ indicates the user needs to input project or sheet specific information. 

1. Window into the top center of the title sheet. 

 

2. Select the Edit Text command. 

 

3. <D> on the FEDERAL AID PROJECT NO. XXXXXXXXX text string. 
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4. In the Text Editor dialog box, correct the project identifier text and change to 
STA 086A – 039 as shown. 

 

5. <D> on the MicroStation screen to execute the edit. 

 

6. Optional – complete edits to the other project identification text. 

Challenge Exercises 

 Add another line of text that matches both the text and symbology of the 
existing text 

 

 Complete the upper right-hand corner of the sheet as shown 
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 Use the Edit Text command to complete the scale bar 
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Lab 3: Vicinity Map - Vector 

Introduction 
Vicinity maps can be referenced to the title sheet. These maps can be in the form 
of vector files (CADD elements) or raster files (images). 

The CDOT standard procedure is to use county maps that have been translated 
from GIS information, these maps can be found on the shared drive at: 
\\public\CADD County Maps\. The county of interest should be copied to your 
project location drawings folder and can be attached as a reference file to the 
Title Map. The local map can be edited as desired without affecting the original. 

For training purposes, a vicinity map has been stored in the References folder. 

Review the vicinity map. 

1. Open the MicroStation file Elbert.dgn 
this file is located in: 
C:\Projects\12345\Design\Drawings\Reference_Files 

 

This file contains a Saved View to assist in attaching it as a reference file. 

2. Select Utilities > Saved Views from the MicroStation pull-down menu. 

Plan Development for ROW  Page 21 
 



 

3. <D> on the saved view by the name of plan 

4. <D> Apply 

 

The MicroStation view updates to the limits of the saved view.  <D> Close. 

 

5. Use other MicroStation view commands to investigate the contents of the 
drawing. 

Open the MicroStation Level Display dialog to investigate level stratification by 
choosing, Settings > Level > Display.  Note all information resides on GIS_* 
levels. 
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6. Turn level displays on and off to verify data stratification, then Close the 
Level Display dialog. 

Attaching a vicinity map as a reference file 
Attach the vicinity file as a reference file to the title sheet. Once attached, move, 
scale, and constrain the display limits. 

Reopen the title sheet: 12345ROW_TitleSht.dgn. Once open: 

1. Select File > Reference from the MicroStation menu bar. 

2. In the References dialog box, select Tools > Attach 

 

3. <D> the file Elbert.dgn from the ….Design\Drawings\Reference_Files 
directory. 
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4. <D> OK 

 

 

5. Key-in the Logical Name: Vicinity  

6. Key-in the Description: GIS locator map for title sheet 

7. Select the plan option in the Orientation section of the dialog box. 

8. GIS maps have been designed to be inserted at a scale factor of 1:5280 
(Master : Reference).  Enter that value for the Scale option. 

9. <D> OK 
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In the MicroStation view window, the limits of the saved view dynamically 
display relative to the location of the cursor. 

 

10. <D> in the MicroStation view window area to attach and display the contents 
of the reference file. 
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11. Select the MicroStation Fit command. 

 

Move the reference file to align with the title sheet. 

12. Select Tools > Move in the References dialog. 
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13. <D> at point A and then <D> at point B to move the attached reference file. 

 

B A

Execute additional move commands to reposition the reference file as necessary. 

14. <R> to exit the Move References command. 

15. Zoom into the Project Location Map area of the Title Sheet. 

 

Constrain the display limits of the reference file (clip boundary) 

16. Select Tools > Clip Boundary from the Reference File dialog.  
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17. In the Tool Settings dialog. Set method to Element 

 

18. <D> on the shape representing the limits of the location map display. 

 

19. <D> a second time (anywhere on the screen) to accept the displayed solution. 

Select this 
element 
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20. Use the MicroStation command Modify Element command to resize the 
shape identified to define the clip boundary. 

 

The reference file clip boundary will reconfigure with the shape modifications. 

Note:   The exercise just completed used an existing MicroStation shape 
to define reference file clipping boundaries.  The same process can be 
followed by using a MicroStation Fence to define (and redefine) the 
reference file clip boundary. 

Challenge Exercises: 
 Move the shape used to define the reference file limits.  What happens to 

the graphics limits displayed? 
 Use the References dialog to move the vicinity map after it has been 

clipped. 
 Delete the shape used to define the reference file limits. What happens?  

(select undo, to restore the shape) 
 Turn levels on and off for the reference file attachment 
 Constrain the reference file display using a fence block 
 Try using a circular fence to define the clipping limits 
 Define a clip mask within the reference file limits 
 Modify elements in the file Elbert.dgn, what happens to the graphics 

displayed in the vicinity map? 
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Lab 4: Locator Map – Raster Reference File 
Attach a raster reference file for the locator map. Once attached, move, scale, 
and constrain the display limits. 

In the CADD file for the title sheet: 

1. Remove the reference file (Elbert.dgn) from the previous exercise by 
selecting Tools > Detach from the References dialog box.   

 

2. Select File > Raster Manager from the MicroStation menu bar. 

3. Select File > Attach in the Raster Manager dialog. 

 

4. Browse to the …\Drawings\Reference_File folder and select the file 
Raster locator map.jpg 

5. Key-in the Logical Name Locator 

6. Key-in the Description Raster location map 

7. <D> OK 
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8. As in the previous lab, <D> to define the lower left and upper right corners 
that define the desired limits for the reference file. 

The raster reference file is attached to the title sheet 

 

9. In the Raster Manager dialog, select Edit > Clip 
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10. Follow the MicroStation prompts to define the clip of the raster so it appears 
approximately as shown. 

 

Challenge Exercises: 
In either of the reference file dialog(s): 
 Experiment with the settings under File >…. 
 Experiment with the settings under Edit >…. 
 Experiment with the settings under Display >…. 
 Experiment with the settings under Settings >…. 
 Change the raster reference gamma display value to 0.5  

(settings > Attachment > Display/Print) 
 Redefine the reference file limits to exactly match the locator boundary 

area 
 Turn on the display of the vector reference file 
 Turn off the display for the raster reference file 
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Lab 5 – Annotation 

Introduction 
Annotate the locator map using the MicroStation place note command.  First 
select the correct symbology using the CDOT Menu. 

1. Activate the Drafting Group Display. 

2. <D> Text button in Drafting area. 

3. Set the Title Text Type (button labeled T in Drafting area). 

4. Set the Justification to Left Top  

5. Select .14” 100% Place Note as shown. 

 

 

The correct settings and symbology are now set and the MicroStation Place 
Note command should automatically execute with the correct Text Style 
specified in the Place Note dialog. 
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6. Select the Dimension Style CDOT 1 

 

Expands or 
contracts 
the dialog 

7. Expand the Place Note dialog and note the available options.  Make sure the 
options selected match those shown below. 

  

8.  Key-in the required text as shown. 

 

9. Follow the MicroStation prompts to place the leader line and text (the first 
<D> will define the location of the arrow). 
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Repeat for the end of project information. 

10. Key-in the required text as shown. 

 

Follow the MicroStation prompts to place the leader line and text 

 

11. Select File > Save Settings 
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Challenge Exercises: 
 Insert a scale bar cell and/or north arrow (General.cel) 
 Input a basis of bearing note 
 Replace the information in the top-left corner of the sheet (ROW.cel) 
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3. Tabulation Sheets 

Chapter Introduction 
The following sheets are available in the training directory. These files are located 
at:  
C:\Projects\12345\ROW_Survey\Drawings 

 

 ROW Monumentation 12345ROW_Mon##.dgn 
 ROW Monumentation 12345SURV_MonRcrd##.dgn 
 ROW Ownership 12345ROW_Ownership##.dgn 
 ROW Plans 12345ROW_Plan##.dgn 
 ROW Plans 12345ROW_TabProp01.dgn 
 ROW Plans 12345ROW_TabProp02.dgn 
 ROW Plans 12345ROW_TabProp03.dgn 
 ROW Plans 12345ROW_TabProp04.dgn 
 ROW Plans 12345ROW_TabProp##.dgn 
 ROW Title 12345ROW_TitleSht.dgn 
 Land Survey Control Diagram-Title sheet 12345SURV_TitleLSCD##.dgn 
 Land Survey Control Diagram-Plan sheet 12345SURV_PlanLSCD##.dgn 
 Project Control Diagram – Title sheet 12345SURV_TitlePCD##.dgn 
 Project Control Diagram – Plan sheet 12345SURV_PlanPCD##.dgn 
 ROW Borders 12345ROW_Cnty-24x18_##.dgn 
 ROW Borders 12345ROW_Cnty-24x36_##.dgn 
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 Chapter 4 – Reference Files and Plan Sheets 

Lab 6 – Land Survey Control Diagram Plan Sheet 
In this sheet, coordinate information will be input in a tabular format. 

Return to the MicroStation manager dialog. 

1. Select File > Close (if MicroStation is currently open). 

  

2. <D> the filename 12345SURV_PlanLSCD##.dgn 

3.  Select File > Rename from the MicroStation Manger dialog. 

4. Replace ##.dgn with 3B.dgn 

5. <D> OK 

  

6. The renamed file is highlighted, <D> OK to open the file. 

7. Zoom/Window into the upper-right corner of the sheet. 
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8. Edit the text as shown using Edit Text command. 

 

9. Use the MicroStation Fit command to view the entire sheet. 

 

In this sheet, place coordinate information representing a Project Coordinate 
Summary Table. This coordinate information will be extracted from InRoads 
using the reporting utility XML. 
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Using XML to report on Coordinates 
Use InRoads and XML reporting to insert a Project Coordinate Summary Table. 
Report on points 100-120. 

 

10. If not already running and loaded: 

• Launch InRoads & Load the Geometry Project 12345_ROW.alg 
from C:\Projects\12345\ROW_Survey\InRoads\Geometry 

11. Select Tools > XML Reports from the InRoads interface. 

 

Note:  XML Reports is an Application Add-in for InRoads.  If XML 
Reports is not available in the InRoads Tools menu bar, select Tools > 
Application ADD-Ins… and enable the XML Report ADD-In.  
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12. In the XML Reports dialog, <D> the Geometry tab and identify Cogo points 
100-120 

13. <D> Save As 

 

14. From the Export dialog box, navigate to the 
12345\ROW_Survey\InRoads\Reports folder and input the file name 
12345_PCST01.xml 
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15. <D> Save.  The report browser will open to a default report style. 

Excel in MicroStation 
Tables can be created in MicroStation by linking information that is contained in 
an Excel spreadsheet.  There are several advantages to using the linked 
spreadsheet method.  Some of these are: 

 Text formatting in the spreadsheet is retained by MicroStation 
 Graphics (borders, girds, etc) are retained from the Excel file 
 Updates to the Excel file are reflected in the MicroStation file 

In the xml report browser: 

16. <D> the CDOT folder. 

17. <D> the CDOT_ListCoordinates.xsl style sheet. 

18. <R> on the report in the coordinate list area as shown.  A fly out menu will 
appear. 

 
 

19. Select Export to Microsoft Excel from the fly-out menu. 

Excel should automatically launch if it is installed on the PC being used. 
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20. Make changes to the data or add formatting and save the spreadsheet to the 
…\ROW_Survey\InRoads\Reports\ directory. 

 

21. Select the range of information desired in the MicroStation file. 
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22. <R> on the spreadsheet data and select Copy from the fly-out menu. 

 

RETURN TO MICROSTATION 

 

23. Select Edit > Paste Special from the MicroStation menu bar. 

 

24. <D> the Linked Microsoft Office Excel Worksheet option. 

25. <D> Paste 

Note:  By choosing linked, updates made to the Excel file can be passed 
back to the MicroStation file through updating.  Selecting embedded 
does not provide this dynamic ability.   

26. In the Paste OLE dialog box, set Paste as to Link, Method to By Size, and 
input a Scale of 5 
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Note:    At this time, we do not fully understand the correlation between 
the scale and resulting text size. For this example, 5 seemed to produce 
reasonable results.  Once placed, the text height can be measured and the 
bounding shape of the linked Excel table can be scaled up or down 
accordingly to achieve required text size. 

 

Note:    Entering a <D><D> on the table in MicroStation will launch the 
Excel application.  If the Excel file is edited (either from MicroStation or 
outside the CAD application) select Edit > Update Links from the 
MicroStation menu bar to refresh the linked MicroStation graphics. 

Challenge Exercises: 
 Cut and paste data from the xml report into a Microsoft Word document 
 Cut and paste data from the xml report into a Notepad document 
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Land Survey Control Diagram Title Sheet – Challenge 
Exercise 

Introduction 
The title sheet can be created as the previous sheets have been.  Challenge 
exercises are provided for this first sheet.  When working through the lab, keep 
in mind the same process can be utilized for other sheets. 

Land Survey Control Diagram Title Sheet – Sheet 1 

1. Create (rename) the MicroStation file provided in the training directory 
folder. The sheet 12345SURV_TitleLSCD##.dgn 
should be renamed 12345Surv_TitleLSCD03.dgn 

 

  

Exercises: 
 Use the MicroStation viewing commands to investigate the sheet 

contents. 
 Edit text, insert cells, or place text as appropriate for a Land Survey 

Control Diagram sheet. 
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Lab 7 – Tabulation Properties Sheet 
In this sheet, information will be updated using Microsoft Excel. 

Return to the MicroStation manager dialog. 

1. Select File > Close (if MicroStation is currently open). 

 

2. <D> the filename 12345ROW_TabProp01.dgn 

3. <D> OK 

 

 
 

4. <D> <D> anywhere within the grid to open up XLS link in Excel. 
 
Note:  When a linked excel file is opened and modified in Excel a hatched 
pattern displays in your MicroStation view.  This is to indicate that the file is 
being accessed from an outside program. 
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5. Insert data into Excel.  (sample data is provided below) 
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Parcel No: 1  
Owner: Dianne M. McNamara & Ronald Eggleston 
Address: 5937 Highway 86 
               Elizabeth, CO  80107 
Location: SE 1/ 4 Sec 9 
Area of Parcel: 20,995 s.f. 
                         (0.51 acre) 
Net Area: 20,995 s.f. 
                         (0.51 acre) 
Left: 1,709,693 s.f. 
         (39.25 acre) 
 

6. Save and Exit in Excel; the MicroStation file will update. 

   
 

7. To update MicroStation without exiting Excel: Save project in Excel, select 
Edit>Links from the MicroStation pull-down, and in the Links dialog <D> 
Update Now. 
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4. Reference Files for Plan Sheets 

Chapter Introduction 
Two approaches can be used to assemble plan sheets.  In the first part of this 
chapter the ‘manual’ method of attaching reference files will be used.  This is 
followed by using the InRoads sheet generation command known as the Plan and 
Profile Generator. 

The following labs are designed to illustrate workflows.  The contents of the 
reference files are not important to this process and may not accurately reflect the 
contents and layout of a final plan sheet. 

Lab 8 – MicroStation Reference files  
This lab will relocate the border sheet to align with the design graphics. 

Moving border sheets to align with design information 
In the previous chapter graphics were moved to align with the title sheet. This 
may suffice for information that is not coordinate dependent but is not an 
acceptable practice in the generation of engineering drawings.  The following 
workflow will result in a product that conforms to CDOT standards.   
This first lab uses the ‘manual’ method for designing a plan set layout and 
assembling the plan sheets.  A following lab will use the InRoads Plan and 
Profile generator command to ‘automate’ the process. 

The process for this lab is: 

 Define the plan sheet limits, rotation, and size(s) 
 Create a sheet file containing a border for each plan sheet 
 Attach the appropriate reference files 
 Rotate sheets normal to the MicroStation view for ease of use 
 Define reference file clip boundaries 
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1. Open the MicroStation file 12345ROW_Model.dgn 

  

2. Select the MicroStation Fit command to expand the view to show all 
graphics. 

 

3. Select Element > Cells to verify the ROW cell library is attached. 
If not, select File > Attach from the Cell Library dialog and attach ROW.cel 
from the cell library list. 
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4. <D><D> rapidly on the cell name RWPL Cuts to identify this as the 
‘Placement’ cell and activate the place cell command. 

5. In the Place Active Cell dialog, set the X and Y scale to 300, and Active 
Angle to 0.  A Z scale of 1.0 should be used.  An X and Y scale of 300 is 
used because this reflects the scale the survey control diagram sheets will be 
developed at. 
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About this cell: 

This cell was created to facilitate the planning of eventual sheets.  It contains 
text characters that can be edited to indicate sheet name, rotation, & scale.  The 
outer line-work depicts the maximum display limits for graphics as it relates to 
the border sheet. The inside shape reflects ½ inch inside this maximum limit. It 
also reflects the maximum limits that would be displayed if the sheet was 
created with the Plan and Profile generator command within InRoads.  The 
‘dots’ in the vertical lines represent ½ of the sheet height and assist in centering 
planimetrics information on the sheet.  All information is written to the 
MicroStation level DRAFT_INFO_No-Plot. 
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6. <D> to place the cell in the MicroStation file, move as necessary.  These 
graphics will define the limits for the plan sheet when referenced back to the 
border. 

 

The above graphics approximately represent the required limits for the first 
sheet.  Position the sheet limit cell as you see fit. 

7. Use the Edit Text command to complete the text at the bottom of the sheet.  
This will assist in managing the sheets as reference files. 

 

8. <D> on the text at the bottom of the layout sheet. 
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9. Replace the appropriate sheet information in the Text Editor as follows: 
LSCD03C 
00-00-00 
1”=300’ 

 

10. <D> anywhere to accept the change. 

11. Use the MicroStation Copy command to duplicate the graphics for the 
second sheet. 

12. Use the MicroStation Rotate command to align the graphics for the second 
sheet (345 degrees, -15 also works). 

 

Replace the appropriate sheet information at the bottom of the copied sheet.   

13. In the Text Editor enter: 
345-00-00 

 

14. Continue planning the sheet layout for the remainder of the project. 
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Complete a few sheets to understand the concept. It is not the intention of this 
lab to complete the layout for the entire project. 

Note: 

Sheets at other scales could also be laid-out at this time.  For instance, 
Monumentation or right of way plan sheets at a scale of 1”=100’ 

 

A major benefit of this workflow is that the eventual limits and orientation of 
sheets are determined early in the process. These sheet limits can be used to 
identify proper positioning, size, and rotation of text and tables. This is in 
addition to acting as a guide for attaching the planimetrics to the border sheets. 

Assembling the plan sheets 

15. Open the MicroStation file ….ROW_Survey\Drawings\ 
12345SURV_PlanLSCD3B.dgn 
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This is a file that you will be using to assemble drawing 4 of this plan subset.  
This will be accomplished by aligning a cell representing the border with the 
planimetrics. The current graphics will not be used. 

16. Delete the border sheet graphics contained in the MicroStation file. 

This sheet will be developed at a scale of 1:300. The MicroStation model 
properties require modification so that the annotation scale matches the plot 
scale. 

17. Open the Models dialog. 

 

18. <D> the Edit Model Properties icon. 

   

19. <D> the drop-down list and select CUSTOM, then input 300:1 
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20. <D> OK 

21. <D> Yes in the Alert dialog. 

 

22. Attach the file used in the geometry training portion of this course from the 
…\ROW_Survey\Drawings\Reference_Files folder; 

 12345ROW_Model.dgn 

23. Select File > Reference 

24. From the References menu select Tools > Attach 

 

25. Highlight the file 12345ROW_Model.dgn and <D> OK 
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The Reference Attachment Settings dialog appears for the 
12345ROW_Model.dgn file. 

26.Enter a Logical Name and Description as shown. 

27.<D> OK  

 

The file is now attached. 

 

 

28. Close the References dialog. 

29. Select the MicroStation Fit command. 

30. Window or Zoom into the beginning of the project. 
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Note the graphics placed previously to indicate sheet limits. 

31. Place the cell called ROW Plan border sheet from the CDOT Menu.   

32.  
 

33. <D> Settings to and change the Active Scale to 300 and <D> Apply 
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34. Place the sheet border cell so the lower-left corner coincides with the corner 
indicated on the sheet limits cell placed previously. 

35. <D> in the upper left corner of the plan sheet to place supervisor contact 
information.. 
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36. In the Reference dialog, identify the reference file and select  
Tools > Clip Boundary  

  

37. In the Set Reference Clip Boundary dialog, select the Element Method. 
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38. <D> on the shape inset ½ inch from the border. 

  

<D> 

39. <D> anywhere to accept the clip. 

The plan sheet display limits are now constrained to a desirable limit. 

40. Turn off level DRAFT_INFO_No-Plot  in the reference file 
12345ROW_Model.dgn to turn off the sheet lay-outs (Select Settings > 
Level Display). 
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Make appropriate edits to the title block and add any sheet specific information 
necessary. 

  

Using the tentative (snap) button <T> to query coordinate values that correctly 
reflect project coordinates.  Additionally an InRoads command, such as 
tracking, will verify the graphics are coordinately correct. 

Once the first sheet is done, the second sheet is much easier.  It is easier because 
the sheet file can be duplicated with the reference files already attached. Moving 
the border sheet and redefining the clipping boundaries will define subsequent 
sheets. 

41. Select File > Save as, input name 12345ROWSURVPLlanSheetLSCD3D.dgn 

 

42. <D> OK 

Note:   The Save As command will automatically save the current 
drawing to the hard drive, then copy and rename to the specified file 
name and open the new drawing. 

43. Place a MicroStation fence over an area that would encompass the next sheet 
in the set. 
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Fence 

44. In the References dialog, identify the 12345ROW_Model.dgn file and 
Select Tools > Clip Boundary  

45. In the Set Reference Clip Boundary dialog, select the Fence Method. 

 

46. <D> on the MicroStation screen to accept the new clip boundary. 

 

47. Turn On the level DRAFT_INFO_No-Plot in the reference file 
12345ROW_Model.dgn to turn the sheet lay-outs back on. 

48. Use the MicroStation Move command to relocate the border sheet. Also 
Rotate the border sheet to align with the predefined sheet limits. 
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Rotate the MicroStation view so that the sheet is normal to the view. 

49. Key-in rv=0,0,15  (rotate view = value) for this 3D file 
rv=15  if in a 2D file. 

50. <D> on the MicroStation screen to initialize the rotation. 

Note:    The above key-ins vary based on the dimension of the 
MicroStation file, 2D or 3D. When working in a 3D file, the key-in is: 
rv=0,0,15 (rotate view=x-value, y-value, z-value).  Rotation is specified 
in relative to the Z axis as that is the axis perpendicular to the view.  
Also, rotating a MicroStation view simply rotates the viewing of the 
graphics. The coordinate system is still relative to the graphics and any 
coordinate or alignment information extracted will be correct. 

  

Define a reference clip boundary, as you did earlier. 

51. In the Reference dialog, identify the reference file and select  
Tools > Clip Boundary  
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52. In the Set Reference Clip Boundary dialog, select the Element Method. 

  

53. <D> on the shape inset ½ inch from the border. 

 

<D> 

54. <D> anywhere to accept the clip. 

55. Update information in the title block of the sheet as necessary. 

56. Select File > Save Settings 

This same procedure can be repeated to complete the remainder of the sheets. 
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5. InRoads Plan & Profile Generator 

Chapter Introduction 
In the previous reference file exercises, manual methods were employed to 
assemble plan sheets.  As delivered, the InRoads software contains various drafting 
utilities. One of these is a routine referred to as the Plan and Profile Generator, or 
PnP for short.  The PnP can be used to automatically generate plan sheets based on 
user defined criteria such as sheet scale, naming, and the selection of files to be 
incorporated. 

InRoads Plan and Profile generator can be used for: 

 Creating Roadway plan sheets depicting both plan and profile views on a 
single sheet. 

 Full plan view sheets  (suitable for Roadway or Right-of-way plans) 
 Double plan views on a single sheet 
 Full profile view sheets 

Preparing to run the Plan & Profile command 
Project specific parameters need to be defined prior to command execution: 

 Verification of Border Cell 
 Location of a MicroStation seed file 
 Location for sheet output (project directory) 
 Length along the alignment that will display in plan view 
 Left and right offsets from a horizontal alignment for plan view display 

Required Resources 
A number of resources are required for this command to operate fully. 

Horizontal Alignment 
Plan view limits are defined relative to a horizontal alignment (length and 
right/left offsets). Therefore, a project specific Geometry Project must be loaded 
into memory.  A specific horizontal alignment will need to be specified to use as 
a basis for sheet creation. 

Digital Terrain Models 
Required for profile views only – not relative to this exercise. 

Cells 
Cells are used to place the border sheet along with north arrows for the drawing.  
The cells used are in the cell library, General.cel and must be attached for the 
Plan and Profile Generator to operate correctly. 
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Border Sheet 
A Cell is used to generate the border sheet and is placed in each drawing 
created. 

Source cell library: C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\cells\General.cel  

Cell Placed for ROW: SHEET_ROW-Plan-Sheet 

Scale 
Before the P&P command is run, the user needs to determine the final plot scale 
of the drawings being created. Current preferences exist for 20, 40, 50, 100, 200, 
300, and 500 scale plots for plan sheets, double plan sheets, plan and profile 
sheets, or ROW sheets. This is reflected on specific tabs within the command. 
See the following section for additional information. 
 

Station Lock – Warning! 
Before running the Plan and Profile Generator command.  Disable the Station 
lock in the InRoads Locks tool bar. Failing to do so will result in truncated 
sheets. 
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Lab 9 – Project Specific Plan Sheets 

Introduction 
The following exercise will step through creating a full plan view depicting right 
of way plan sheets (sheet subset 5) at a scale of 1”100’. The plan sheets will be 
centered along the design alignment for the project S.H. 86. 

Open a MicroStation File 

1. Open the MicroStation file 12345ROW_Model.dgn 
from the …\Survey_ROW\Drawings\Reference_Files folder. 

Note:    The MicroStation file opened is immaterial and only acts as an 
interface to InRoads. New plan sheets will be created and the 
open drawing will not be impacted. 

2. Load the geometry project 12345_ROW if not already in memory 

3. Select Tools > Options [Factors] and set the global scale factors to 100 then 
<D> Close to dismiss the Options dialog box. 

4. <R> on the alignment C_Centerline and select Set Active from the fly-out 
list. 

 

5. Select Drafting > Plan and Profile Generator… 
from the InRoads interface. 

By default, the dialog will populate with the CDOT preferences (100 horiontal 
scale by 1x vertical exageration Plan & Profile sheet). 

Note:    Drafting notes is an InRoads Application Add-In. If the Drafting 
category is not shown in the InRoads menu bar, select Tools > 
Application Add-Ins and enable Drafting Production Add-In. 

6. Select the Preferences button (at the bottom of the Plan and Profile 
Generator dialog). 
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7. Select the preference named - 100 Scale ROW Plan Sheet 

8. <D> Load  

9. <D> Close 

 

Preferences developed for ROW are: 

• 100, 200, and  300 scale full plan view ROW Sheets 
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Main Tab 
By default, the active horizontal alignment and the begin/end station limts for 
said alignment will populate the dialog. 

 

10. Load the appropriate Preference (if not done in step 6) 

11. Select the appropriate Horizontal Alignment  
(the sheet will be centered on the defined alignment). 

12. Redefine start and stop station limits to: 

 Start: 314+56.59 
 Stop: B 450+00.00 

 

Note:   The ‘B’ in the ‘stop’ station defined above is required as it 
indicates the stop station falls within a station-equation range. 
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Length defines the length along the alignment that will fit in a plan view.  1450 
feet is the default for a 100 scale 11” x 17” plotted sheet.  

 

Changing Scale: 
A 200 scale plot will display 2,900 feet along the alignment in plan view, a 300 
scale plot will display 4,350 feet.   

If something other than 100 scale is desired, the user must proportionally 
change: 

 Main tab – modify Length 
 Plan Controls tab – modify Width Left, & Width Right 
 View Layout tab – modify Scale 
 Symbols and Details – modify Scale 
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Plan Controls tab 
13. Select the Model Files button to pick the Drawing files (references) for 

display in plan view.  

14. Select the file 12345ROWModel01.dgn in the Open Model File dialog. 

15. <D> Open 
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Width Left and Width Right define plan view limits perpendicular from the 
reference line (left is negative). 

 

The Boundary Chords setting will create a clipping limit that will fit the 
extents of the plan window area. This reference file clipping edge should be 
considered a “first pass limit” and may have to be edited on curved portions of 
the corridor path in locations where the desired limits extend beyond this 
“calculated” clipping limit. This plan limit editing, along with any shifting of the 
plan window position, is accomplished on the Sheet Index tab after the sheets 
have been created or through the use of the MicroStation references dialog. 

Model Files & Levels 
The Model files selected will be attached as reference files. The attached files 
will have all levels turned on that contain data. If additional data (levels) are 
added to the referenced files after the sheets are created, the user is required to 
turn on the appropriate levels through the use of the references dialog box. 

Additionally, the files referenced will have the design file ‘Default’ model 
attached. The user should not use any model space other than ‘Default’. 

Profile Controls tab 
No action required 
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Sheet Layout tab 
 

 

16. <D> the … button next to Host File to identify the path and initial sheet 
name for the new drawing set. The Host File refers to the new 
MicroStation plan drawings that will be created by this tool. The last 
number, “1”, will be automatically incremented as each new sheet is 
created.  Set to the project directory, i.e. 
…..ROW_Survey\Drawings\ 12345ROW_Plan01.dgn 

17. <D> Save in the Save As dialog. 
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18. The Seed Host File is the ‘prototype’ file used to create the Host files and 
should be set to: 
C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\Seed\3D-Seed_CDOT.dgn 

19. Make sure the Level and Symbology options in the Clipping Boundary 
section display SHEET_Clip-Boundary. 

View Layout tab 
This tab sets location (origin) for the plan views relative to the border sheet.  No 
user input is required in this dialog. 

 

Note:    The Location of the Plan position is computed from the outside 
edge of the border sheet in paper (plotted) units. 
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Border and Title tab 
The only user input on this tab is to ensure the correct cell is specified for the 
border sheet. No other user input is required in this dialog unless creating sheets 
at a scale other than 1”=100’.  

Source cell library: C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\cells\General.cel  

Cell Placed: 

20. Verify Cell Name: SHEET_ROW-Plan-Sheet 
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Symbols and Details tab 
No user input is required in this dialog unless modifications to the stored 
preference are required. 

  

 

The North Arrow position set by the Location in Paper Units and is set to the 
upper right corner of the sheet. This is a rough placement and will likely have to 
be moved for clarity and conflicts on many sheets. Once the sheets are 
constructed each sheet should be checked for optimum cell position. 
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Match Lines tab 
No user input is required in this dialog. Match lines are not being used for ROW 
sheets. 

  

Executing the Plan & Profile Command 
Once the Apply command is executed, the workflow process for this command 
follows the following sequence: 

A)  Plan view reference limits are established. 

B) New drawing files are created based on the host file name. 

C) Each new drawing file has 3 items generated. 

1. Plan views 

2. Border sheet placed as a cell in each generated drawing 

3. North arrow placed on each sheet 

D) The Plan and Profile dialog (sheet index tab) will populate with 
sheets created and sheet limits. 
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Sheet Index tab 
Nothing is required by the user on this tab prior to executing the PnP command. 
A summary of sheets created is displayed after successful execution of the 
command. 

21. <D> Apply, the routine will run and MicroStation will cycle through the 
sheets as they are created – be patient and wait for the command to complete. 

The Sheet Index tab will display a list of sheets created and MicroStation will 
display the last sheet created. 

 

22. Select Save As from the Sheet Index tab to store a project specific View 
Definition File (VDF). A VDF file allows sheet definitions to be recalled 
and modified in subsequent MicroStation/InRoads sessions if necessary. 

23. Name the file 100 scale ROW plan sheets.vdf 

24. <D> Save 
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Displaying sheets 
By highlighting a specific sheet in the Sheet Index tab and selecting Show 
Sheet, MicroStation will open the selected drawing. 

25. Identify Sheet 1 and <D> Show Sheet 

 

MicroStation opens the identified sheet 
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26. Identify Sheet 2 and <D> Show Sheet 

27. Use the MicroStation Modify command to adjust the clipping shape to any 
new location. 

28. <D> Show Sheet to redefine the clipping limits after modifying the clipping 
shape. 

  

Note:    Other modification tools such as insert vertex and delete vertex 
can be used also. 

 

Clipping Shape 
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Standard MicroStation References commands can also be applied. 

29. Use the MicroStation Modify command to adjust the clipping shape to any 
new location. 

 

30. Select File > References from the MicroStation menu bar. 

31. Highlight the 12345ROW_Model.dgn file. 

32. Select Tools > Clip Boundary from the References dialog. 

 

33. Set the Method to Element 

34. <D> on the modified clipping shape in the MicroStation view. 

35. <D> to accept the command. 

 

Clipping Shape 

Modified shape 
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Notes:    

 The clipping boundary is now defined by the identified shape. 
Using any MicroStation command to modify this shape will 
automatically update the reference file clipping boundary.  This 
shape is on the level GEN_SHEET_Clip-Boundary.  This level is 
configured as a non-plotting level.  

 Deleting the clipping boundary shape will result in the reference 
file display limits reverting to the initial limits defined by the 
PnP command. 

 Regenerating a sheet from the PnP Sheet Index tab will also 
cause the sheet to revert to the reference file display limits 
initially defined by the PnP command. 

 

After the Plan and Profile Generator has been run, each sheet should be 
reviewed for: 

• North Arrow position (move the cell using MicroStation move 
command) 

• Plan view Clipping limits  

• Title block information 
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Main tab – After running the P&P command 
Once the command has been run, the Geometry Project field will populate and 
the Plan and Profile view limits display. 

 

Double clicking on a specific Plan View sheet opens an Edit Plan View dialog. 
Sheet limits can be modified numerically and reference files can be added or 
removed. 

 

Page 88  ROW Geometry & Plans 



 Chapter 5 – Plan and Profile Generator 
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Challenge Exercises: 
 Modify the last sheet to add 500’ to the stop station 
 Modify any sheet to change the left and/or right offsets 
 Add or subtract from the model file list 
 Modify the station limits on the first sheets and ‘adjust’ adjacent sheets 
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