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Document Conventions 
There are several conventions that are used throughout this document to indicate 
actions to be taken or to highlight important information.  The conventions are as 
follows: 

 

Example Item     Meaning 

View Perimeter a command name or a file that you are to select, including 
directory path 

Name: field name, button or icon in a dialog box 

Dialog Header dialog box name 

Tools > Options a command path that you are to select - usually from the 
pull-down menus 

Dialog Area heading for separated areas within a dialog box 

Tab heading for tabs found within dialog boxes 

Key in entering data with the keyboard or items selected from 
drop-down list 

Document name style used when referring to another document 

Note:  text  information about a command or process that you should 
pay particular attention to 

Concept:  text detailed definition of a concept, procedure or process 

Emphasis an important word or phrase 

Prompt user prompt 

1. Numbered Steps actions that you are to perform as part of the lab activities 

<D> or Data press the data button on the mouse 

<R> or Reset press the reset button on the mouse 

<T> or Tentative press the tentative button on the mouse 
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1. Getting Started 

Course Overview and Introduction 
This course focuses on coordinate geometry (cogo) and alignments as they relate to 
Bentley’s InRoads suite of software. Geometry data models are commonly referred 
to as Alignment Geometry projects (ALG’s). The purpose of this manual is to 
familiarize the user with the commands and functions of the InRoads suite of 
software necessary to evaluate, validate, and annotate both Horizontal and Vertical 
geometry. Additionally, tools to create and modify Horizontal geometry will be 
covered. 

Items addressed in this course will be: 

 The InRoads Environment 
 Understanding terminology 
 Project defaults and Geometry Options 
 Understanding Geometry Projects 
 Exploring Horizontal Geometry 
 Exploring Vertical Alignments 
 Creating Geometry entities 
 Editing Geometry 
 Geometry Reports 

Foundation 

Intended Audience 
This course is for those who want to gain a better understanding of InRoads 
geometry tools through the use of display, reporting, and annotation tools. It is 
also for those who may have the need to generate or make modifications to 
geometry entities and for those who wish to create profiles or cross sections 
relative to alignments. 

Prerequisites 
The attendees must have a basic understanding of MicroStation prior to 
attending this course. It is assumed the student has a fundamental understanding 
of coordinate and alignment geometry. 

Duration 
Overall length of this training section is 16 hours. Format is instructor lecture 
and demonstration followed by hands-on lab exercises. 
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Focus 
 The display, annotation, and evaluation of both Horizontal and 

Vertical alignments. 
 The generation of and editing of Horizontal Alignments. 

Goal 
 The purpose of this course is to provide CDOT personnel with an 

understanding of how to use the geometry features in InRoads. This 
understanding will aid in the analysis of geometry developed by 
others and allow users to create and edit geometry as necessary. 

Introduction 
Introduction of course goals and content 

Instructor 
Introduction of Instructor(s) and brief summary of credentials 

Students 
Introduction of students and a brief summary of student knowledge as it relates 
to MicroStation and InRoads and/or geometry. 

Student Interests 
Query as to specific interests of individual students and the class as a whole. 

Schedule 
Establish schedule for class breaks, lunch, and course termination. 

About this document 
The document is designed for use in an instructor-led classroom environment, 
but will be useful for new users to refer back to as they begin applying the 
learned techniques to their projects.  This document is not meant to be used as a 
software reference guide or a replacement to the on-line help available through 
InRoads. 

The lab activities are written to provide the students with step-by-step 
instructions on the main focus of the chapter.  Additional challenge labs are 
included in many of the chapters and are available for those who finish early or 
want to dig deeper into the topics.
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Fundamental Concepts 

Software Terminology 
Understanding the difference between InRoads and MicroStation 

InRoads  
InRoads is something of a generic term, it refers to a Suite of Software offered 
by Bentley Systems, Inc. A brief summary follows: 

InRoads - Commonly used term to define the suite of software (InRoads Suite) 

InRoads - Site and corridor modeling tools. 

InRoads Site - Specific module designed with a focus on site design (a sub-set 
of InRoads with limited corridor modeling tools) 

InRoads Survey - Specific module designed for the reduction of survey data.  
(Limited commands from InRoads Site are included) 

InRoads Rail - InRoads with additional functions unique to the design of 
railways. 

InRoads Bridge - InRoads with additional functions unique to the design of 
structures. 

MicroStation - A CADD platform that provides the ‘graphics engine’ for 
InRoads. 

MicroStation 
MicroStation is necessary to run any of the software applications in the 
InRoads software suite. InRoads does not possess a CADD (graphics display) 
engine which is a fundamental necessity for the operation of the software. 
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CDOT CADD Resources 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & Engineering 
Innovation Web site. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: 

http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 

The website (presently only available to CDOT) provides CDOT users with up 
to date information, tools, and resources related to CADD and the Colorado 
Engineering Software Transition (CEST) project.  

 

http://internal/cadd/�
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This website is a valuable resource for CADD users and includes: 

CADD Library  
The CADD Library page provides links to manuals, newsletters, standard details, 
etc. One extremely useful link is to the Tips and Tricks section for MicroStation 
and InRoads. This information changes daily, so check back often. 
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CADD Manual 
The CDOT Computer Aided Design and Drafting (CADD) Manual outlines 
CDOT’s use of Bentley’s MicroStation and InRoads software. It documents 
standardized procedures for the exchange of information between CDOT 
regions, specialty groups, and consultants working on CDOT projects. The 
Manual also addresses software issues, tools, techniques, standards and 
procedures, etc. which will aid the user in the efficient production of CDOT plan 
sets. 

The CDOT CADD Manual and the associated electronic files contained in the 
CDOT configuration are used in the generation of electronic plans by both 
CDOT internal designers and the consulting firms doing business with CDOT. 
The electronic version of the Manual provides hyperlinks to each chapter as well 
as context sensitive index and search functions. You can also print chapters or 
the entire manual. 

The CDOT CADD Manual can be accessed several different ways including: 

 From the CDOT internal CADD web site home page link; 
 From the CDOT Design and Construction Project Support Page (external 

web site); 
 From the CDOT Menu (Help > CADD Manual). 
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CDOT Workflows 
There are several standardized MicroStation and InRoads workflows that CDOT 
has developed to assist you. These workflows are step-by-step CDOT-specific 
procedures for certain tasks that you may encounter when working in 
MicroStation or InRoads on a CDOT project. Many of these workflows are 
referenced throughout the course. 

In addition to accessing the workflows from the CDOT CADD Web site Home 
page link CDOT Work Flow, you can also access workflows: 

 From the Windows Start menu  
(Start > All Programs > _CDOT_CADD_Information > Workflows); 

 From the CDOT Menu (Help > Workflows). 

New workflows are typically added with CDOT configuration updates, so check 
back often. 
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Issues Logs  
Check the issues log to determine the status of submitted requests. 

Requests & Support 
This page provides CADD help solutions where you can: 

 Learn how to get help; 
 Submit a questions; 
 Submit a request (e.g. request a new MicroStation level or InRoads 

preference), as well as  
 Obtain InRoads, InRoads Survey and MicroStation support.  

There is also a link to IT Services for hardware support, “how to” instructions, 
installation, training files, and work space setup. 

 

 

Training 
Use this link to find out how to sign up for training classes.  You can also review 
online computer-based training (CBT) for MicroStation, InRoads and InRoads 
Survey. 
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Overall Scope 

Training Data 

SH 86 Elbert County 
This same data set was used for the InRoads Survey Data Reduction instruction. 
This data was chosen to provide geometry developed by the survey process to 
use as a reference for evaluation of existing conditions and the creation of 
subsequent geometry. 

 

Note:  It is important the student recognizes that the tools presented in the 
following exercises can be applied to any discipline.  
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Training Directory Structure 
All class work files will be in the C:\Projects\12345 folder which has a 
combination of design and survey sub-folders and data files. 

The sample project in this document uses the standard CDOT file structure with 
12345 = CDOT Project Code (sub account). 
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2. Working with InRoads 

Lab 1: Getting Started in InRoads  

InRoads Operation 
1. There are three main methods to Start InRoads: 

• Choose Start > All Programs > Bentley Civil Engineering > Bentley InRoads and 
MicroStation will start and allow you to choose the design file, once the design file 
opens InRoads will start. 

• Choose the Desktop icon for InRoads if one is available on your 
machine. MicroStation will start and allow you to choose the design 
file, once the design file opens InRoads will launch. 

Note:    If MicroStation is already open, you can choose the InRoads icon 
from the MicroStation main toolbar. 

  

               

 

2. Use one of the first two methods listed above to initialize InRoads which 
will open the MicroStation Manager window.
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Once MicroStation or InRoads has launched, you will be presented with the 
MicroStation Manager dialog. 

3. In the MicroStation Manager dialog, go to the Workspace group section 
and change the User field to CDOT USER, the Project field to 12345 and 
the Interface field to CDOT.  

 

 

This workspace setup should load the correct MicroStation environment when a 
MicroStation file is opened.  The Project field sets the PCF file that defines a 
specific directory that MicroStation defaults to when opening up a DGN file or 
referencing model files. PCF files are extremely useful when multiple users are 
accessing the same project directory across the network, or when DGN files are 
moved from one directory to another.  For more information regarding the PCF 
please refer to the CDOT Notes document titled “CDOT PCF Management.pdf” 

Note:   Each discipline has developed unique directory stuctures to meet 
specific needs. If necessary, you can use Windows Explorer to easily 
investigate the directory stucture developed for a specific discipline.  
Note the various folders for drawings, InRoads information, 
correspondence, etc. 

4. Navigate to the file folder \12345\Design\Working by double clicking 
the directory folders. 

Note:   CDOT standards stipulate Users to prefix any files in the Working 
directory with their own initials.  For training purposes use FML 
(First, Middle, Last) for uniformity. 
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5. The file FML_12345DesignModel01.dgn will show in the MicroStation 
Manager dialog. <D> OK to open the file. 

 

 

Note:   From this point forward, unless specifically instructed to use 
MicroStation commands, all references to the selection of icons, 
tools, or menu pull-downs refer to the InRoads interface. 
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Lab 2: The InRoads Interface 
Remember, InRoads is running on top of MicroStation. This means the InRoads 
interface can be moved outside the MicroStation environment to another screen and 
that the InRoads interface may hide MicroStation dialog boxes.  

 

 There are four main parts to the InRoads Interface, the Menu Bar, Work Space 
toolbar, Information Window, and Status Bar. 

 

 

 

 

 

 

 

 

 

 

 

Menu Bar 

 

 

 

 

 

 

 

 

 

 

 

 The Menu Bar pull-down menus are used to access commands, 
settings, and toolbars. 

 An arrow (>) in the pull down will expand to a submenu. 

Menu Bar 

Work Space 
toolbar 

Status 
Bar 

Information 
Window 
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 3 successive periods(…)  indicate a dialog by that name will open 
 Pull-down menus will vary with the application add-ins that you are 

using. 

Work Space toolbar 

 

 The Workspace Bar is used to manage and separate the different file 
formats of the program. 

 Right clicking is allowed in the Workspace Bar. The active shortcut 
menu will vary depending on which Tab is selected.   

 The Workspace Bar can be undocked as shown or docked to either 
side or bottom of the InRoads interface. 

 To switch between tabs use the scroll arrows or right click to open a 
shortcut menu. 
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Information Window 

 

 The Information Window information varies depending on the type 
of data selected. 

 Right clicking is allowed in the Information Window. The active 
shortcut menu will vary depending on the selected feature. 

Status Bar 
  

 

 Located in the lower left corner of the InRoads Interface, the status 
bar is used for observing the file processing information.  The status 
of an active command can also be observed from this status bar. 
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Toolbars 
Toolbars can be opened and docked in the InRoads interface. Toolbars in 
InRoads can be customized to fit the user’s workflow or personal preference. 

From the pull-down menu, select Tools > Customize. The Customize dialog 
will appear. 

 

 

 

Toolbars are activated by clicking on the desired menu item and are immediately 
added to the InRoads interface. 

 

 

If time permits, open the View Geometry toolbar, pause the cursor over the 
icons, and note the Tool Tips that appear on the screen. 
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Options 
Options relative to geometry are found in the menu bar under Tools > Options 
[Geometry] tab. 

 

Dialog Items 
 Plotting Height: The default elevation geometry will be drawn in 

MicroStation if an elevation is not specified for the geometry 
element. 

 Seed Alignment Name: Initial name assigned to newly created 
geometry unless otherwise specified. 

 Seed Point Name: Initial name assigned to new cogo points. 
 Curve Definition: Horizontal – Arc or Chord definitions 

                               Vertical – Parabolic or Circular 
 Measure: Along arc or along chord for curve definition 
 Degree of Curve Length: Specifies central angle that subtends this 

distance 
 Unit Station Length: Distance between major station intervals 
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 Define Transitions: Defines spiral transitions by Length or Spiral 
constant. 

 Spiral Definition: Defines default method for defining spiral 
transitions 

 ICS Coordinate Sequence: Defines input order of 
Northing/Easting’s for ICS batch input files. 

 Vertical Angle Reference: Defines vertical angle measurement in 
ICS files. 

 Angular Mode: Specifies orientation for angles 
 Point Name during Edits: Defines whether names are assigned to 

geometry points during creation or editing. 
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Locks Toolbar 
There are several locks that are used by InRoads in addition to the MicroStation 
locks. These locks will be used throughout the course.  

The locks toolbar is shown below. 

 

 

 

 
 

 

Filter Name – Lists the name of the Feature Filter that is currently active. It has 
no affect if the Feature Filter lock is off. If the Feature Filter lock is o n, it will 
limit dialog boxes to showing only the features that pass the filter. Feature 
Filters are stored in the CDOT-Preferences.ini file and are accessed by using 
the drop-down arrow next to the name. 

Feature Filter lock – If on, activates the current filter. If off, has no affect and 
all surface features are shown in boxes that list features (shown here in the off 
position). 

Feature Filter List
Feature Filter Lock

Style Lock 
Pen/Pencil Mode

Delete Ink Lock

Write Lock Toggle 

Locate Graphics/Features

Snap Element/Point/No 
Station Lock

Report Lock 
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Style lock – The Style lock, if on, forces many of the Surface View commands 
to display the requested data (triangles, contours, etc.) without bringing up the 
dialog box.  The preference used is the one associated with the surface under 
Surface > Surface Properties. Style lock also forces the Cross Section 
Annotation command to use the named symbology associated with the feature 
for annotation properties.  If off, the Style lock has no affect (shown here in the 
off position). 

 

Pen/Pencil (shown in Pencil) Delete Ink (shown off) Write lock (shown on) 

These three locks work together. 

Write lock – If Write lock is off, the displays will be temporary. Zooming in or 
out, updating the view, etc. will cause the added graphics to disappear. 

If Write lock is on, there are two modes – Pen and Pencil.  

If the Pencil mode is selected, the graphics are updated whenever the same 
display command is selected again. For example, if you display the contours, 
then change to a different preference and display again, the old contours are 
deleted and new contours are displayed.   

If Pen mode is selected there are two options. If Delete Ink is off, the graphics 
are not updated when the same display command is selected again.  Instead, 
another copy is placed in the design file.  If Delete Ink is on, the graphics are 
treated like Pencil mode and the old ones are removed before new ones are 
placed. 

 

Locate Features  /Locate Graphics   

There are several commands in InRoads that will work on either DTM Features 
or on MicroStation graphical elements (Drape Surface, for example). These 
commands will “look” for features if toggled to Locate Features and for 
MicroStation elements if it is set to Locate Graphics. It is shown here in 
Locate Graphics mode. 
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Point Snap has three modes: Off   Point Snap  and Element Snap  

Off – No affect 

Point Snap – Some geometry commands (especially cogo commands) will lock 
onto the nearest geometry point’s coordinates when you select something 
graphically. This is useful when you need to identify a PC or PT, for example. 
Also, some DTM editing commands, such as Partial Delete Feature, will lock 
onto the vertices or points that make up the feature. 

Element Snap – In Geometry when commands require a distance or a bearing, 
the Element Snap can be used.  An existing geometry element needs to be 
identified (such as part of an existing alignment) and it will read the elements 
length or bearing (whichever is required). 

 

Station lock – Locks you onto even stations in the event that the alignment you 
are using does not start on an even station. The station will be determined by the 
interval you are using. For example, if you are stationing an alignment at 100 ft. 
intervals, the displays will show even 100 ft. stations. This affects not only 
station displays but virtually everything that uses a stationing interval, such as 
cross sections, profiles and modeling. 

 

Report lock – Some commands will return information to you if this lock is on. 
For example, if you store a cogo point and the Report lock is on, a Results box 
will pop open showing the coordinate and point number of the new point.  The 
box can be moved out of the way, it will keep a running list of messages, which 
can be saved to a text file if desired. 
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Lab 3: Default Directories and Resource Files 
Setting default directories and resource files provides the user with quick access to 
project folder for opening files and then saving them to the correct location.  It also 
ensures the correct CDOT InRoads resource files will be used. 

Objectives Lab 3 
After completing this exercise you will know how to: 

• Import and export Project Default settings. 

1. Select File > Project Defaults.  The Set Project Defaults dialog 
appears. 

 



 Chapter 2-Working with InRoads 

InRoads Geometry Funamentals  Page 25 

2. <D> the Import button.  The Open dialog will appear. 

3. Select C:\Projects\12345\Project_Configuration\12345GEO.reg and 
<D> Open 

 

4. 12345GEO should be active in the Configuration Name field 

 

Notes: The blank Default Directory Paths are files that are not used by 
the particular InRoads application. 
At your place of work, depending on the local configuration, you 
may have to map to network or shared drives to access default 
directory paths and project data.  
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5. <D> Apply 

6. <D> the Close button on the Set Project Defaults dialog. 

The default locations for both general InRoads resource files and project specific 
data files are now defined.  This will make it easier to conform to graphics 
standards and assist in navigating to the correct project directories when loading or 
saving data files. 

7. Select the Preferences tab on the Workspace bar and verify that the 
correct InRoads Project resource files are loaded. 
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Geometry Data from Survey 
Survey data will be used as a foundation for our initial geometry work. The 
survey staff exports linear elements from the survey fieldbook as alignments and 
Cogo points at all survey shot locations. 

This data may be used for: 

 Establishing the centerline of existing roadways 
 Flow-lines of existing stream or other drainage 
 Locations of existing retaining walls or bridge geometry 
 Locations of existing signs or utilities 
 Existing pavement limits or curb and/or gutter locations 

The goal is to review some of the geometry data the survey staff produces. 

The Geometry Project 
The geometry project, commonly referred to as the ‘ALG’ file,  is the data file 
that stores horizontal and vertical alignments, superelevation alignments 
(stations where the super transitions occur and the corresponding slopes), and 
cogo points (called the cogo buffer). 

The hierarchical relationship between the data stored in a geometry project is 
illustrated below. 

Generic Geometry Project 
 

 

 

 

 

 

 

 

 

 

 

Multiple geometry projects can be loaded into memory. However, only one 
geometry project can be active at a given time. Within the active geometry project, 
a single horizontal and a single vertical alignment can be active at any given time. 

Geometry 
Project 

Horizontal 
Alignment 

Vertical 
Alignment 

Vertical 
Alignment 

Superelev. 
Alignment 

Superelev. 
Alignment 

COGO 
Buffer 

Horizontal 
Alignment 

Horizontal 
Alignment 
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Sample Roadway Design Geometry Project 
 

 

 

 

 

 

 

 

 

 

A typical design geometry project may contain horizontal alignments for the 
mainline, side roads, ditches, or alternative designs. Each horizontal alignment 
may have associated vertical alignments and superelevation solutions. 

12345Design 

Design_01 
30mph 

Vertical 
Option 1 

Vertical 
Option2 

Vertical 
Option3 

Superelev 
30mph 

COGO 
Buffer 

Design_02 
40mph 

SR 256 
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Sample Survey Geometry Project 
(Exported from a Fieldbook) 

 

 

 

 

 

 

 

 

 

Sample Cogo Buffer Contents 

 

 

A typical geometry project generated from a survey fieldbook will contain Cogo 
points for each point surveyed. These Cogo points are indexed with the shot 
number recorded in the field during collection.  In addition to the Cogo points, 
horizontal and associated vertical alignments are created for each linear feature 
surveyed in the field such as; edge of oil, ditch or stream shots, or centerline 
shots.  These alignments inherit their name from a combination of the survey 
collection code and an incremental index number. 

12345 
Survey 

13182 
(horizontal) 

COGO 
Buffer 

13193 
(horizontal) 

13164 
(horizontal) 

13182 
(vertical) 

13164 
(vertical) 

13193 
(vertical) 
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Sample Right of Way Geometry Project 
 

 

 

 

 

 

 

 

 

 

 

 
A typical Right of Way geometry project may contain only Cogo points and 
horizontal alignments.  The horizontal alignments may represent existing or 
proposed ROW limits, easement limits, section lines, and parcels.  A parcel is 
defined as an alignment that closes on itself. 

 

12345 
ROW 

Proposed 
Centerline 

Existing 
RW_South 

Proposed 
RW_North 

Proposed 
RW_South 

Parcel 
J.W.Wood 

COGO 
Buffer 

Existing 
RW_North 

 

Existing 
Centerline 

AC-11 
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Lab 4: Loading Geometry 
As previously illustrated, all geometry, whether it’s horizontal, vertical, cogo 
points, or superelevation solutions, is stored in a single digital container called a 
Geometry Project. To put it another way, individual horizontal, vertical, or cogo 
points cannot be written to disk by themselves, only within a geometry project. The 
same is true for loading data; only geometry projects can be loaded, not individual 
alignments. 

Start with the geometry that was created in the survey data reduction portion of this 
project. This geometry project contains all objects collected in the field. Linear 
objects such as pavement lines, breaklines, streamlines, etc are stored as horizontal 
alignments. In addition to survey shots along linear objects, all shots at features 
such as signs, utilities, ground shots, trees, etc. are written to the cogo buffer and 
stored as individual points. 
It will be necessary to load the geometry data from the survey (ROW) directory 
structure versus the design directory as information from the survey phase of the 
project is being accessed. Because data from the survey is being accessed, it should 
not be modified in any way. 

In subsequent exercises you will learn how to copy Geometry Projects in their 
entirety and also how to selectively copy information (alignments and cogo points) 
between separate Geometry Projects. 

Loading Survey Geometry 
1. Select File > Open and set Files of type to Geometry Projects.   

2. Navigate to the directory path  C:\Projects\12345\Design\InRoads  

3. <D> the geometry project 12345_Design.alg  

4. <D> Open then Cancel.  The Open dialog will close.    
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5. Check the InRoads interface to ensure the data loaded.  You should see 
something similar to the below screen capture. 

 

6. Expand the screen display of the geometry project by selecting the + 
(plus) symbol located to the left of the geometry project name. 

7. Look to the right side of the InRoads pane. Scroll to view the columns 
of information to the right. Here you will see: 

 Horizontal Alignment name 
 Description 
 Windows user ID of the person who created the alignment 
 Revision date 
 Access Mode 
 Associated geometry style 
 Integrity 
 Curve definition Arc or Chord 
 Beginning station value 
 Ending station value 
 Number of associated vertical alignments 
 Number of associated superelevation definitions 

8. <D> on any of column headings to sort ascending or descending.  

9. <D> and hold down/slide the mouse button on any of the column 
heading to reposition the columns either to the left or right. 
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10. <D> on the Cogo Buffer. Notice the detail screen to the right showing 
the contents of the Cogo buffer. Also notice the columns showing 
Northing, Easting, and Elevation by adjusting the view pane. 

11. <D> on the first horizontal alignment listed. Notice the associated 
vertical alignment. 

 

Note: Only one horizontal alignment can be active at a time. Being 
active specifies the alignment to be modified, displayed, or 
defined by default in dialog boxes. 
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12. Select Geometry > Active Geometry.  The Active Geometry dialog 
will appear. 

 

13. Set Type to Horizontal Alignment 

14. <D> on alignment Side Road 

15. <D> Apply then Close 

Notice in the InRoads explorer pane that the alignment called Side Road shows 
a red indicator box signifying that it is the active alignment. 
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Reviewing & Viewing Geometry 

16. Select Geometry > Review Horizontal for a textual display of the 
active alignment. When reviewing an alignment, a temporary dynamic 
display is shown in MicroStation representing the location of the 
alignment being reviewed. 

 

From the top of the dialog down: 

• Active Geometry Project selection box 
• Horizontal Alignment selection box 
• Project Name: being displayed 
• Description for the geometry project (if any) 
• Alignment name 
• Description of the alignment (if any) 
• Geometry Style associated with the Horizontal alignment 
• Element definition (linear or circular) 
• Vertices type, point name/number, station value, northing, 

easting 
• Tangent Bearing and Distance or Curve data 

17. Review this display for alignment information such as Cogo point ID 
assignments, bearings, distances, northing, easting, etc. 

18. <D> the Close button. 

19. Select Geometry > View Geometry > Active Horizontal to write the 
alignment to the MicroStation file.  

20. Select Geometry > Fit Alignment to reposition the MicroStation view 
to the limits of the active alignment. 

 In the MicroStation key-in field, type in an alignment name or <R> 
(press the right mouse button) in a MicroStation view to fit the active 
alignment. 
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21. In the Workspace Bar <R> (right-click) on the active alignment name.  
Note the Active, View, Fit, and Review commands are available from 
the short-cut fly-out menu.   

 

22. Experiment using this fly-out menu with any alignment 
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Reviewing the Cogo Buffer 
23. In the Workspace Bar <R> on the Cogo Buffer and select Review...  

The Review Geometry Points dialog will appear. 

 

 

24. <D> the Next > button to review the information about subsequent 
points.  Notice the available navigation buttons First, Previous, Next, 
and Last 
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25. <D> Report to list all Cogo points stored in the active geometry 
project. 

 

Saving InRoads Results 
Note:  The buttons on the right side of the Results dialog allow you to 

save or display this report.  These options exist in many InRoads 
dialogs. 

They are: 

 Close - closes the Results dialog 
 Save As - saves the contents of the dialog to an ASCII (text) file 
 Append - appends to an existing ASCII file. 
 Display - allows the user to select a location in the MicroStation 

drawing to place the dialog contents as text. It will use the active text 
and element settings when writing the text to the CADD file. 

 Print - sends the contents to the default system printer. 

26. <D> the Close button in the Results dialog 
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27. In the Mode section of the Review Geometry Points dialog, toggle 
the radio button to Alignment.  Notice how the Alignment drop-down 
list is activated. 

28.   Select SH86 in the Alignment drop-down list. 

 

29. <D> the Report button again to review the vertices of the selected 
alignment. Note the Point Name column is not showing point numbers 
or names (other than point 1000) indicating this alignment was created 
as unnamed geometry points. 

 

30. <D> the Close button in both the Results and Review Geometry Points 
dialogs 
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Note: The previous steps used the short-cut fly-out menus, all actions 
can also be found under the Geometry pull-down menus. 

 

 
Graphics clean-up 

At anytime during these labs you can delete all visible graphics in your 
MicroStation file using the element selection tool or a fence. Note that 
you are deleting the graphical display of data, not the data itself. The 
graphics can be redisplayed using the InRoads display commands shown 
in previous sections. 

Note:   The screened topography and the graphics used as training guides 
are either locked graphics or are attached as a reference file. 
These graphics will be used in future labs. 
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Alignment Information 
Multiple Geometry Projects can be loaded into memory simultaneously.  
However, only one geometry project, horizontal, and vertical alignment can be 
active at any given time. 

31. Use the previously covered commands to display the horizontal 
alignments SH 86 & Side Road 

32. Use the review command to investigate the alignments 
 

 What is the beginning station value for: 
 
SH 86   _______________ 
 
Side Road  ________________ 
 

 What is the overall length of: 
 
SH 86  _______________ 
 
Side Road ________________ 
 

 What is the shortest radius used in: 
 
SH 86 ________________ 
 
Side Road ________________ 
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Lab 5: Toolbars 
The InRoads Interface can be populated with toolbars for easy access to commands.   

The pull-down menus can be used to select the correct tool, but it may be more 
convenient to use toolbar icons.  All InRoads toolbars can be customized to fit your 
workflow or personal preferences.  

Opening Toolbars 
1. From the pull-down menu select Tools > Customize. The Customize 

dialog will appear. 

 

2. Under the Toolbars tab, check that the boxes for Review Geometry 
and View Geometry are selected.  When checked on, the toolbars 
become active in the graphics file immediately 

3. <D> the Close button in the Customize dialog 
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4. Dock, Undock and Resize the toolbars until you are comfortable 
repositioning them.  Notice how toolbars can be docked in the InRoads 
interface but not MicroStation’s. 

 

5. From the pull-down menu, select Geometry > View Geometry look 
at each command and the associated image. Notice the correlation of 
the graphics between the pull-down menu and the toolbar.   

 

 

6. Place the cursor over an icon in any toolbar. A Tool Tip will appear at 
the lower right of the cursor, additionally a description of the command 
shows in the status field. 

 The tool tip feature is controlled in the Customize dialog (Tools > 
Customize) box via the Show Tool Tips checkbox and is turned on 
by default. 
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Global Scale Factors 
Global scale factors are used to determine the size of displayed text, cells, and 
linestyles. The global scale factor function can be found under Tools > Options 
[Factors] tab. However, enabling the command directly from the menu bar is 
more efficient. 

7. Select Tools > Application Add-ins to display a list of available 
InRoads commands and functions that can be added to the InRoads 
interface. 

 

Selecting an item will display a description.  The command category shows both 
the menu location and the InRoads product(s) it can be activated with. 

8. Toggle on Global Scale Factor  <D> OK and close the dialog 

9. Select Tools > Global Scale Factors… 

 

10. Verify all three scale settings are set to 100 

11. <D> Apply then Close 

These settings are multipliers for displayed graphics.  Generally the values 
should be set to correspond to the plotting scale factor. As with most 
MicroStation or InRoads commands, you have the option of either enabling or 
disabling the lock symbol to input values universally or individually. 

Note:  Digital Terrain Models are not a core topic of this course. However, it is worth 
noting that Global Scale Factors apply to all InRoads data displayed. This 
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includes the display of features from a DTM. While possible to ‘regenerate’ 
plan view topography by displaying the features from a survey-supplied DTM, 
this is NOT an accepted workflow.  The reason for this is because any 
attributes collected in the field are processed by InRoads Survey. These 
attributes (rotation, Q & Z reports, etc) are not stored in the DTM and the 
resulting graphics will be incomplete and/or incorrect without being evident. 
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Geometry Terminology and Attributes 

Geometry Project 
Is a data warehouse that stores: 
 Cogo point information in the following format:  name, x, y, and z 
 Horizontal alignments 
 Vertical alignments 
 Superelevation definitions 

Geometry Styles 
Geometry Styles are saved settings that can be assigned to a geometry alignment 
or cogo point.  The Geometry Style definition stores how the alignment or cogo 
point will be displayed in the CAD file.  Geometry Styles can be assigned to 
Points, Lines, Arcs, and Spirals; each style will have settings for planimetrics 
and annotation display.  The Geometry Styles are defined in the Geometry 
Style Manager dialog box. 

Geometry Style Manager – Overview 
The Geometry Style Manager creates, edits, and deletes the Geometry Styles for 
Points, Lines, Arcs, and Spirals.  The style definition is based on WYSIWYG 
(what you see is what you get) display in the dialog box.  The symbology 
section of the dialog controls the planimetric and annotation display. 

 Select Geometry > View Geometry > Geometry Style Manager 
 Overview by Instructor 

 

Note: See appendix A for additional information on this topic. 
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Geometry Point Symbology 
Geometry Point Symbology is a saved setting for horizontal and vertical 
alignment keypoints (vertices).  Each vertex will be defined in the alignment as 
1of 33 possible alignment keypoints such as: POB, PC, PI, PT, TS, PVT, PVT, 
etc.  Each Geometry Point can be saved as a point Symbol Font or Cell 
definition depending on the annotation settings. 

Geometry Point Symbology Manager - Overview 
 Select Geometry > View Geometry > Point Symbology 
 Overview by Instructor 

 

Note: See appendix B for additional information on this topic. 
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Lab 6: Alignment Attributes Assignment 
The geometry Name, Description, and Style are assigned to an alignment or 
Cogo point when they are created. These attributes can be queried by utilizing 
the review geometry command. 

Alignment Attributes 
1. Select Geometry > Review Horizontal… 

 

2. By using the selection box labeled Horizontal Alignment:  
Compare the settings for the alignment SH 86 with the attributes for 
alignment Side Road. Note the changes in Description & Style. 
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Cogo Point Attributes 
3. Select Geometry > Review Geometry Points… to review Cogo point 

names, descriptions, and style assignments. 

Note: This dialog is used to review both alignments and Cogo points 
based on the Mode setting. 

 

4. This information can also be seen in the InRoads explorer pane. 
<D> on the Cogo Buffer and notice the description(s) and Style(s) as 
displayed in the feedback pane. 

 

Note:  If the Style assigned to the data is not a valid name when 
displaying an alignment or Cogo point (not existing in the 
Geometry Style Manager), a Style by the name Default will be 
used. 
The Default CDOT Style for all geometry elements has the same 
properties as the defined style ALG_Proposed. 
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3. Geometry Annotation 

View Horizontal Annotation 
Depending on the options selected, the user can define which alignments or Cogo 
points are annotated.  This dialog is accessed by selecting:  
Geometry > View Geometry > Horizontal Annotation 
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Main Tab 

Method Section 

 Automatic: Acts upon the entire length of the alignment 
 Interactive: Allows the user to select individual alignment 

components 

Mode Section 

 Points: Toggle to operate on Cogo points 
 Alignments: Toggle to operate on alignments and alignment 

keypoints 

Display Section 

 Point As: Cell or Text (see lab exercise 9 for additional information) 
 Elements: 
 Attach Tag: Non-graphic attributes assigned in MicroStation 
 Complex: ‘Chains’ reference line graphics as a single entity 
 On Alignment Points: Display of POB, PC, PT, etc. 
 Off Alignment Points: Center of curves and PI’s 
 Tangent: Curve tangents 
 Subtangents: Spiral curve tangents 
 Radials: Radial lines to center of curve 
 Chords: Circular curve chords 
 Annotate Duplicates: Labels points common to multiple alignments 

Additional Items 

 Apply Style field: Options for over-riding geometry symbology 
 Annotate field: Input field for needed alignments or Cogo points 
 Key-in specific names 
 Use of wildcards (%, *) allowed 
 <D> in Annotate field, the Filter button activates 
 Selected: Alignments or Cogo points to be displayed and/or 

annotated 
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Annotate Tab 

 

 Points: Text on/off for alignment keypoints or Cogo points 
 Elements: Text on/off for Bearing & Distance annotation 
 Dual Dimension:  Imperial and Metric annotation 
 Use Alternates: On/off for using alternate geometry styles 
 Table: Label geometry components with index numbers and writes 

annotation to a binary file for further processing 

Note: See Appendix A for additional information on the above topics. 
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Active Styles Tab 
Active styles can only be selected when Active is selected from the Main tab of 
the dialog under Apply Style. 

 

 Point – Temporary override of Geometry Point definition 
 Line - Temporary override of Geometry  Line definition 
 Curve - Temporary override of Geometry Curve definition 
 Spiral - Temporary override of Geometry Spiral definition 
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Tabling 
This tab is used to format and assign numbers when Table is selected from the 
Annotate tab of the dialog. 

 

 Lines – Defines the Prefix and Seed Number for lines. 
 Circles – Defines the Prefix and Seed Number for circles. 
 Spirals – Defines the Prefix and Seed Number for spirals. 
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Lab 7: Geometry Display 
Options for displaying horizontal alignments are available when using the 
Horizontal Annotation dialog. 

1. Select Tools > Global Scale Factors and set all the scales to 100  

2. Using the MicroStation menus, select Utilities > Saved Views tools to 
open the saved views dialog. 

3. <D> on the name POB, <D> Apply for view 1, <D> Close 
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4. Display alignment SH 86 from the Geometry Project 12345_Design by 
right-clicking <R> on the alignment name and selecting View from the 
fly-out menu. 

 

 

The alignment display is based on the geometry style assigned to the 
alignment. This display method is suitable but does not allow the user any 
options or allow annotation of the geometry. The next steps illustrate how to 
customize the graphics display for geometry elements. 



Colorado Department of Transportation 

 

Page 58  InRoads Geometry Fundamentals 

5. Select Geometry > View Geometry > Horizontal Annotation 

 

6. Key-in SH 86 in the Annotate field and Tab from the field. 

7. Set options for the Display section of the dialog as shown in the above 
screen shot.  

8. Select the Annotate tab. 

 

9. Check on Elements and Use Alternates.  Toggle all other checkboxes 
off. 
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10. <D> the Apply button. This will write alignment SH 86 to the 
MicroStation Screen and annotate the alignment. 

 

Note how Bearing and Distance annotation is displayed along the tangents. 
If the alignment contains horizontal curves, curve data is displayed. 
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11. Return to the View Horizontal Annotation dialog 

12. <D> the Annotate tab, Toggle on Points, <D> Apply 

 

 

Notice that in addition to annotation for tangents and curves, alignment vertices are 
annotated. 
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13. On the Main tab, click the Help button and review the descriptions for 
the various components that can be displayed. 

 

14. Experiment displaying an alignment with Points and Elements turned 
on or off on both the Main tab and the Annotate tab. 

15. Experiment displaying the various components available in the display 
portion of the dialog. 
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Lab 8: Selection of Geometry for display and/or 
Annotation 

Methods for defining geometry elements for display and/or annotation. 

1. Select Geometry > View Geometry > Horizontal Annotation 

2. <D> the Main tab 

3. Set Mode to Alignments 
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4. Set the Apply Style to Alignment 

5. <D> in the Annotate field.  The Filter button becomes active 

 

6. <D> the Filter button.  The Geometry Selection Filter dialog will 
appear. 
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Note:  Available alignments are shown on the left, Selected (for display 
or annotation) alignments are shown on the right.  This makes it 
possible to select multiple alignments for display or annotation. 

7. Add-> alignments SH 86, Side Road to the Selected field by selecting 
the names in the Available list <D>, and <D> ADD-> (or <D><D> on 
the names) in the Geometry Selection Filter dialog. 

Note:    The data in this dialog can be sorted by clicking <D> on the 
column headers. Multiple selections of alignments can be made 
through the use of the <CTRL> or <Shift> keys. 

 

8. When done identifying the desired alignments in the Filter dialog, <D> 
OK – the Selected geometry is populated in the Selected field 
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9. <D> Apply, the selected alignments will display in MicroStation 

10. Review results in MicroStation 
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Lab 9: Display or Annotation of Cogo Points 
1. In the Main tab of the View Horizontal Annotation dialog, 

set Mode to Points 

 

 Cogo points can be selected for display and/or annotation 
 

Note:   Whether you are annotating Points or Alignments, keep in mind 

that the element selection button can be used to graphically 
identify the geometry of interest. This is universally true in 
InRoads whenever the selection button is displayed. 
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2. <D> the Annotate field to activate the Filter button 

3. <D> the Filter button. The Geometry Selection Filter dialog will 
appear. 

 

4. Select points 1001-1005 & 1010 from the Available field and add them 
to the Selected field. 
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5. <D> the OK button. The points populate the Selected field 
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6. <D> the Apply button in the View Horizontal Annotation dialog. 

 

7. Experiment displaying various Alignments and Points with the 
assorted settings. 

 

Note: Remember to toggle on Points in the Annotation tab if you need 
to see Cogo Point numbers, Northing, and Easting. Keep in mind 
annotation settings are derived from the Geometry Style 
Manager Type: Points for the assigned Geometry Style. 
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Lab 10: Alignment Stationing 
The default station at the beginning of a newly created horizontal or vertical 
alignment is 0+00. This value can be changed as shown later in this lab. 

One of the easiest methods for determining assigned stationing values is through 
the alignment review commands. 

1. Make 12345_Design  the active geometry project by right-clicking on 
this geometry name and selecting Set Active from the fly-out menu. 

 

2. Right-click on the alignment SH 86 and select Review from the Fly-out 
menu.  The Review Horizontal Alignment dialog will appear. 

 

 

Note:   Fly-out menus can be access from either the workspace or 
feedback panes. Also note that selecting an alignment for review 
switches it to being the active alignment. 
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3. Investigate the stationing assigned to horizontal Alignment SH 86 

 Initial station value is: _____________________________ 

 

4. Review the Vertical alignment SH 86 V associated with horizontal 
alignment SH 86. 

 Is the stationing for the horizontal and vertical alignments 
synchronized? 
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Lab 11: Displaying Stationing 
Display stationing and alignment keypoints. 

1. Prior to displaying the stationing, display the lifework for the 
horizontal alignment  SH 86 

Hint:    Right-click on the alignment name in the InRoads explorer 
window and select View from the fly-out menu. 

2. Select Geometry > View Geometry > Stationing.  The View 
Stationing dialog will appear. 

 

3. <D> the Preferences button. 

Note:  The Preferences dialog is used to load preset settings for a 
particular tool.  In the View Stationing dialog the preference is 
setting the interval and symbology of the display graphics. 

4. Load the Preference Proposed–100 Ft Interval. 
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5. <D> Proposed-100 Ft Interval 

6. <D> Load then Close button. 

 

7. In the Symbology portion of the dialog, select or de-select the 
alignment components for display. Loading the preference sets the 
default interval for major stations. 

8. <D> Apply to display the stationing. 
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The View Stationing dialog is populated with the predefined settings from the 
stored preferences. Notice the interval field and settings under the symbology 
section. The display toggles define what will display; the name column reflects 
the InRoads named symbology defining graphical attributes for displayed items. 

There are several standard CDOT preferences to choose from, depending upon 
the type of alignment stationed and station interval. Choose the appropriate 
preference and <D> Apply to see the stationing. 
Keep in mind that text size is dependent on the Global Scale factor active at time 
of display. Select Tools > Options [Factors] if necessary. 

9. Change the Global Scale Factor and redisplay stationing. 

10. Experiment displaying stationing using various CDOT preferences 
until presets becomes familiar. 

11. Experiment with the various tabs and settings in the View Stationing 
dialog and investigate changes made when stationing is redisplayed. 
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Lab 12: Defining Stationing 
Upon creation, alignments are defined with a beginning stationing of 0+00. 
Stationing can be redefined from any location along the alignment.  Additionally, 
station equations can be incorporated.  

1. Select Geometry > Horizontal Curve Set > Stationing. By default, 
this dialog displays the beginning station value of the active alignment. 

 

2. Select Synchronize Starting Stations in the Vertical and 
Superelevation Alignments field. 

3. Set the beginning station of alignment SH 86 by keying in 
125+25.36 and choosing Apply. 

4. Verify the change has been applied by redisplaying the stationing 
using Geometry > View Geometry > Stationing and click Apply.  
Also, check the beginning station value of any associated vertical 
alignments by using the review command. 



Colorado Department of Transportation 

 

Page 78  InRoads Geometry Fundamentals 

 

Notes:  

 The options for Vertical and Superelevation Alignments should 
be considered carefully.  Do Not Update will leave the stationing of 
vertical and superelevation application stations as is, Synchronize 
Starting Stations will update their stationing to match that of the 
horizontal and Maintain Station Difference will keep any difference 
(delta) in the current starting stations. 

 InRoads does not require a ‘+’ when keying in a station.  The plus 
sign will be added automatically. 

 Any point along the alignment can be specified as the location for 
the input stationing value. The alignment location defined by either 
name or the northing and easting fields is the location the input 
stationing will propagate from. 

 

5. Set the beginning station of alignment SH 86 by keying in 32062.24 
and choosing Apply. 
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6. Verify the change has been applied by redisplaying the stationing.  
Select Geometry > View Geometry > Stationing then click Apply. 
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Lab 13: Station Equations 
If there are inequalities in the alignment, station equations may be required. These 
equations can be either gap or overlap equations.  

1. From MicroStation Select Utilities > Saved Views.  Apply saved view 
Station Equation. Once applied, close the Saved View dialog 

 

 

At the PT of the curve a station equation is necessary to tie to previous work. The 
values are:  
Back   = 356+45.30 
Ahead = 356+40.30 
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2. Select Geometry > Horizontal Curve Sets > Stationing.  The 
Stationing dialog will appear. 

 

3. Verify SH 86 is the horizontal alignment. 

4. At the bottom of the dialog, choose New.  In the resulting box, enter 
the Back Station and the Ahead Station as shown below.  

 

5. <D> Apply  
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6. <D> Cancel to close the Add Station Equation dialog. The station 
equation will be shown in the parent dialog 

 

7. <D> Close in the Stationing dialog 

8. Redisplay the stationing for alignment  SH 86 
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Notes: 

 The ahead station must be prefixed with an equation name. The 
name must consist of at least one alpha character. 

 An alignment can contain multiple station equations. 
 Annotation of stationing lying within the range of a station equation 

will be prefixed with the equation name. If the prefix is undesirable, 
toggle on Drop Station Equation Name in the View Stationing 
dialog and redisplay the stationing. 
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Lab 14: Horizontal Alignment Tracking 
Two methods exist for receiving interactive information relative to a horizontal 
alignment. Both methods report on stationing, offset, elevation, etc.  One 
method reports the elevation of the active surface, the other reports the elevation 
of the active vertical alignment. 

Horizontal Alignment & Surface Elevation Tracking 
1. Recall Saved View Side Road 

 

In addition to reporting on station and offset information relative to the active 
alignment, the following method will report on information relative to the active 
surface. 

2. Select File > Open and load the surface  
12345SURV_Surface_Existing.dtm from the 
C:\Projects\12345\ROW_Survey\InRoads\DTM  folder.  

3. Select Tools > Tracking > Tracking to track both the active horizontal 
alignment and information relative to the active surface 

4. Select Activate to initialize the command. Slide the cursor along the 
alignment to interactively update the display in the Tracking dialog.  If 
a <D> (data point) is entered in the design file the information toggled 
on is displayed graphically 
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Note:   Select the Symbology button in the Tracking dialog to examine 
the attributes assigned to annotation placed in the MicroStation 
design file. 

Horizontal & Vertical Alignment Tracking 
The second method tracks the station and offset relative to the active horizontal 
alignment along with the elevation of the active vertical alignment.  Station, 
Offset, and Elevation information is displayed in the message field of the 
InRoads interface.  

1. Select Tools > Tracking > Horizontal Alignment to track the active 
horizontal alignment. 
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2. The results display in the status bar of the InRoads interface. 
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Note:   The readout interactively reflects the location of the cursor 
relative to the active alignment. If a second horizontal alignment 
is selected with a data point, <D> the offset displayed will be 
relative to the two alignments perpendicular to the active 
alignment. 
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Inversing Between Alignments - Overview 
Another useful geometry utility is Geometry > Utilities > Inverse Direction.  
This command can be used to interactively inverse between data <D> points 
identified graphically. 

Enabling the geometry point snap will lock data points to defined alignment or 
Cogo keypoints. Executing a second graphic data point will post the inversed 
data to the MicroStation file. 
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Transforming Alignments - Overview  
Entire geometry projects, individual alignments, or Cogo points can be 
transformed by moving, scaling, or rotating selected items. 

The transform command is found under the pull-down menu 
 Geometry > Utilities > Transform 

 

 

Shown above is the transformation of alignment Alternate B.  The alignment has 
been moved 100 feet east and 100 feet north as indicated in the delta coordinate 
values defined in Original Point & Destination Point fields.  Additionally the 
alignment has been rotated 22 degrees clockwise. The point of rotation is about 
the coordinates defined in the Original Point fields.  

Note:   This command does not create a copy of the specified alignment. 
It will transform the original alignment specified. Use the 
Geometry > Copy Geometry command prior to use if a copy 
is desired. 
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4. Geometry Management 
When the Survey/ROW group exports geometry from an InRoads Survey 
Fieldbook, the Geometry Style assigned to the geometry element is based on the 
InRoads Feature Style assigned to the surveyed element. If the associated Geometry 
Style is not found, the Style Default is used. After exporting, the user can change 
the geometry style associated with existing geometry and apply appropriate 
symbology. This is true if working with geometry generated from field survey 
information or from geometry created in the design process. 

As standard procedure, CDOT may wish to direct each discipline to maintain 
independent geometry projects for specific projects. By doing so, the various 
disciplines would be responsible for maintaining their data and also be responsible 
for coordinating with other workgroups to ensure everyone is working with the 
correct foundation geometry. 

Possible scenarios: 

• When Survey exports the fieldbook to a geometry project it is stored in: 
Drive:\JPC#\ROW\InRoads\Geometry\ as JPC#FB2006_02_06_A.alg 
    (FieldBook A dated February 06, 2006 or otherwise named) 

• Design may have use for selective items such as the centerline of road, 
fences, utilities, etc. as alignments and/or Cogo points, but not need or want 
alignments and Cogo points for every single observation taken in the field. 
For efficiency, not to mention segregation of data, the roadway design 
discipline may wish to store the alignments they develop in: 
Drive:\JPC#\DESIGN\InRoads\ as JPC#Design.alg (or otherwise named) 

• Hydraulics or Traffic may desire alignments for drainage structures, 
waterways, or pavement design or marking. There may be no need for 
Design or Survey to access this data and vice versa.  

Segregating geometry by discipline specific geometry projects lessen the 
possibility of loss of data through the regeneration of data.  If the survey staff 
collects additional data or otherwise makes edits to the electronic fieldbook, 
they will have to re-export (regenerate) the Geometry Project to provide current 
information. In doing so, the possibility exists to over-write geometry created 
by other means.  
Additionally, allowing individual disciplines the ability to create geometry as 
needed eliminates the task of managing who has read/write access to a single 
‘master’ geometry project and when access would be available. 
However, it does raise the issue of communication. If the disciplines are 
dependent on geometry information developed by others, it is imperative that 
down-stream users of that information are consulted and notified of relevant 
changes. 
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Lab 16: Copy a Geometry Project 
Goals are to: 

 Access a Geometry Project created by the Survey/ROW discipline. 
Once accessed, rename and save a copy of the geometry project. 

 Save the renamed Geometry Project in the Design project folder (vs. 
the Survey folder) 

 Rename horizontal alignment names, add/modify descriptions, and 
review the geometry styles assigned to the alignments. 

1. Select File >  Open set the Files of Type to Geometry Projects 

 

2. Navigate to the directory path 
C:\Projects\12345\ROW_Survey\InRoads\Geometry 

 

3. <D> the Geometry Project 12345SURV_Fieldbook.alg 

4. <D> the Open then Cancel button. The Open dialog will close. 
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At this point, a ‘copy’ of the survey geometry project is loaded into memory. The 
following steps will rename the geometry project and save this copy in the Design 
discipline folder. 

Note: Loading a file into InRoads makes it the active entity by default. 

5. Select Geometry > Copy Geometry 
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6. On the Projects tab, in the From section select: 
12345SURV_Fieldbook 

7. In the To: field key in  
FB-Working Copy 

8. In the Description: field key in Copy of Survey data  

9. <D> the Apply then Close buttons. 

10. Verify the copy is created by checking the InRoads Explorer pane. 

 

11. In the InRoads explorer window, <R> on FB-Working Copy geometry 
project and select Save As… from the shortcut list.  The Save As 
dialog will appear. 
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12. Save FB-Working Copy to the C:\Projects\12345\Design\InRoads 
folder.    If necessary, use the drop-down arrow in the Active field and 
reselect the desired name to ensure the saved file name will match the 
active surface name. 

13. <D> the Cancel button. The Save As dialog will close. 

Note:   Ensuring that the saved Geometry name in the project folder 
matches the Geometry name displayed in InRoads explorer will 
minimizes confusion. 
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14. The original Geometry Project generated by the survey staff is no 
longer required.  In the InRoads explorer window, <R> on the 
Geometry Project name 12345SURV_Fieldbook and select Delete 
from the fly-out menu.  

 

 

Note:  This will ‘unload’ the geometry project from memory. It does not 
delete the original or copy from the hard drive. 

15. <D> Yes and verify the geometry project is removed from memory 
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Lab 17: Renaming Alignments 
In the case of the geometry project copied in the previous exercise, the 
horizontal alignment names (and geometry styles) were assigned when the 
survey fieldbook was exported based on the InRoads Survey feature table (FWF 
file).  These attributes are assigned based on the feature coding assigned in the 
field. These names accurately reflect the coding used in the field, but could 
benefit from more intuitive naming.  

Our goals are to: 

 Modify the alignment names assigned to some the roadway 
centerline shots, add descriptions, and assign appropriate Geometry 
Styles. 

Graphics clean-up 
Before continuing with this lab, delete all visible graphics in your 
MicroStation file using the element selection tool or a fence. Note that 
you are deleting the graphical display of data, not the data itself. The 
graphics could be redisplayed using the InRoads display commands 
shown in previous sections. 

Note:   The screened topography and the training guides are either 
locked graphics or in an attached reference file, you will not be 
able to delete these graphics and will use them for orientation. 

Renaming Horizontal Alignments 
1. Recall the MicroStation saved view Survey Alignments 
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2. Display alignments 13205 & 131979 
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3. Select Geometry > Rename Geometry.  The Rename Geometry 
dialog will appear. 

4. From the Type: drop-down list select: 
 Horizontal Alignment 

 

5. In the From section verify FB-Working Copy is the active Geometry 
Project. 

6. In the From section list locate and <D> on alignment 131979. 

Note:  This alignment represents the centerline of existing pavement. 

7. In the To section key in the Name: Ex CL Seg A 

8. In the To section key in the Description:  
Ex centerline segment A 

9. In the To section set the Style: ALG_EXISTING 
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10. <D> the Apply button a confirmation dialog will appear 

 

11. <D> the Yes button. 

12. Rename the centerline alignment 13205 as follows: 

Note: You can use the dialog selection icon    to graphically identify 
the alignments for renaming 

 13205 
 Name: Existing CL Seg B 
 Description: Ex centerline segment B 
 Style: ALG_EXISTING 

Caution:  Profile or Cross Section sets that were created based on the 
original alignment names will lose their linkage to the 
alignment names after renaming of the alignments.  Geometry 
renaming should be accomplished prior to the generation of 
Profile or Cross Section sets. 

13. When done renaming the alignments close the Rename dialog and 
check the InRoads explorer window to verify the results. 
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Geometry Utilities  

Transposing Alignments 
Transposing an alignment reverses the direction of that alignment. Tangent 
sections are reversed and left-hand curves become right-hand curves. The 
beginning stationing value is retained; however, any station equations previously 
defined are deleted.  Associated vertical alignments are also reversed.  
You may find the need to transpose an alignment if it was surveyed in a 
direction opposite from the direction you wish to design (up-stream vs. down 
stream). Other instances may be if you create an alignment by importing from 
graphics. InRoads will generate the alignment in the direction the MicroStation 
graphic was drawn which is not necessarily in the direction of ‘up-station’. Or 
you may simply create an alignment in the wrong direction using any of the 
InRoads geometry commands. 

The transpose alignment command is found under the pull-down menu 
Geometry > Utilities > Transpose  

 

The command executes once the alignment (s) for transform are chosen and Apply 
is selected. The user will have to redisplay any associated stationing or annotation 
of the transformed alignment(s). 
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Transposing an alignment 
1. Use the review tools to evaluate both of the renamed horizontal 

alignments. What direction are the tangents running? 

Notice that the alignment Existing CL Seg A runs northwest and that alignment 
Existing CL Seg B runs southeast?  
Alignments created by exporting an electronic fieldbook assume the direction of 
the data collection. 

Both alignments should run in a Southeasterly direction. 

2. Select Geometry > Utilities > Transpose  

 

3. Select alignment Existing CL Seg A for transposing <D> Apply 

4. Review the alignment to verify the transposition 

 

 

5. Save the geometry project FB-Working Copy 



 Chapter 4 - Geometry Management 

 

InRoads Geometry Funamentals  Page 103 

Renaming Vertical Alignments 
Two horizontal alignments have been renamed, a description has been added 
and the alignments are assigned an appropriate geometry style.  Horizontal 
alignments are ‘parent’ alignments which can contain ‘child’ vertical 
alignments. 

1. In the Workspace bar under the Geometry tab check the horizontal 
alignments for associated vertical alignments by expanding the + icon. 

 

2. Select Geometry > Rename Geometry.  The Rename Geometry 
dialog will appear. 

3. From the Type: drop-down list select: 
Vertical Alignment 
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4. In the From section verify FB-Working Copy is the active Geometry 
Project 

5. In the From section verify Existing CL Seg A is the active Horizontal 
Alignment 

6. In the From section list locate and <D> on alignment 131979  

Note:  This alignment represents the vertical elevations of existing 
pavement. 

7. In the To section key in the Name: Existing Pavement 

8. In the To section key in the Description: Surveyed elevations 

9. In the To section set the Style: ALG_EXISTING_Vert 

10. <D> Apply then <D> Yes button. 

11. Rename the vertical alignment associated with the horizontal 
alignment Existing CL Seg B 

Note: You can use the dialog selection icon    to graphically identify 
the alignments for renaming. 
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12. In the To section key in the Name: Existing Pavement 

13. In the To section key in the Description: Surveyed elevations 

14. In the To section set the Style: ALG_EXISTING_Vert 

 

15. <D> Apply then <D> Yes button. 

16. <D> Close the Rename Geometry dialog. 
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These changes have been made in a copy of the geometry project that was 
exported from the survey fieldbook. In this copy, some key horizontal and 
vertical alignments have been renamed, described, and assigned appropriate 
geometry styles to conform to CDOT standards with a naming convention that is 
more intuitive. 

This is a good time to save the Geometry Project to disk. 

17. <R> on the geometry project FB-Working copy and select Save As 
from the fly-out menu 

 

The Geometry Project should be stored in the folder:  
C:\Projects\12345\Design\InRoads 
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5. Exploring Vertical Alignments 

Lab 18: Reviewing Vertical Alignments 
Reviewing vertical alignments is similar to reviewing horizontal alignments.  The 
Review Vertical Alignment dialog allows you to easily change between multiple 
Geometry Projects, Horizontal, and Vertical alignments. 

1. Select Geometry > Review Vertical 

 

2. The review dialog can also be opened with the right-click fly-out 
menus 
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Lab 19: Creating Profiles 
Prior to graphically displaying a vertical alignment a profile must be created.  These 
are referred to as profile sets in InRoads. A profile set can be created using a 
horizontal alignment, a MicroStation element, or interactively to define the 
horizontal (plan) location the vertical information is extracted from.  Upon creation, 
a profile can display DTM surfaces, vertical alignments and DTM features. Once 
created, a profile set can be refreshed to display additional data, turn the display or 
data off, or to redraw the graphics based on current DTM information. 

Prior to creating a profile set, load the DTM 12345Surv_Surface_Existing  
if not already loaded.  This surface will be used to display an existing 
ground-line. 

1. Select File > Open 

 

2. In the Workspace Bar under the Geometry tab, verify that 
12345_Design is the active Geometry Project and that the horizontal 
alignment SH86 is the active alignment. 

Hint:  <R> on the name and select Set Active from the fly-out menu. 
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3. Select Evaluation > Profile > Create Profile the Create Profile dialog 
will appear. 

 

Dialog items: 

 Create - Window and Data creates the profile grid and displays DTM 
surface profile(s) as identified in the Symbology category. Multiple 
surfaces may be shown on one profile if they are identified for 
display here.  The Window Only option creates an empty profile 
window.  The Data Only option adds data to an existing profile 
window 

 Set Name - Multiple profiles may be displayed in a single 
MicroStation file. InRoads tracks specific profiles by Set Names.  By 
default the set name is populated with the active horizontal 
alignment name. This field is user definable by inputting a name of 
their choosing. 

 Source - Horizontal location of profile extraction. Options are: 
 Alignment – extracted at location of horizontal alignment 
 Graphics – at location of user identified graphics 
 Multipoint – interactive user defined points 
 ASCII – a text file containing station and elevation information 
 Preferences - There are several CDOT preferences for the different 

vertical exaggerations.  Choose Preferences and Load to establish 
the dialog settings.  
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4. <D> the Preferences button.  The Preferences dialog will appear 

5. <D> the predefined settings for 2x vertical 

    

6. <D> the Load then Close buttons 

7. Verify that Alignment SH86 is identified 

8. Verify that in the Symbology portion of the dialog, 
12345SURV_Surface_Existing is selected for Display 
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9. <D> the Controls tab and note the vertical exaggeration specified 

 

10. <D> the Apply button.  The Create Profile dialog will temporarily 
minimize. 

11. You are prompted by MicroStation to ‘Identify location’. <D> in the 
MicroStation view.  The Profile window will be placed and the Create 
Profiles dialog will restore. 

 

Note:    For convenience, we are displaying the profile in our current 
drawing.  Standard practice dictates that separate drawings 
should be created for profile and cross section display.  Consult 
the directory structure and file naming convention for your 
specific discipline to determine standards relating to profile 
display. 
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Viewing Vertical Alignments 
12. Select Geometry > View Geometry > Active Vertical to display a 

graphic of the active vertical alignment 

 Alternately in the Workspace Bar under the Geometry tab you can 
<R> on the Vertical Alignment and select View just as you did with 
Horizontal Alignments. 

 
  

Note:   Annotation size for the index elevations and stationing text is 
generated based on the global scale factor defined for text.  The 
text size specified should be set based on the ultimate plotting 
scale.  To change text size on a profile, delete the displayed 
profile, change the global scale factor, and regenerate the profile 
display. 
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Annotating Vertical Alignments 
Similar to horizontal stationing, annotation of vertical alignments is 
accomplished much the same way.   

13. Select Geometry > View Geometry > Vertical Annotation to view 
vertical alignment annotation 

 

14. Verify the appropriate Horizontal, Vertical Alignments, and Profile 
Set  are correctly identified 

15. Click Apply 
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16. Take some time and investigate the remaining tabs along the top of the 
View Vertical Annotation dialog and the individual settings for each. 

17. <D> the Points tab. Note the settings in the Symbology portion of the 
dialog. By default, Symbology for a Proposed alignment loads. 
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18. <D> the Preferences button. 

 

19. <D> the name Existing. 

20. <D> the Load then Close buttons. 

21. Note the change in the defined Symbology 

 

22. <D> the Apply button from the View Vertical Annotation dialog. 
Review the results in the MicroStation drawing. The content of the 
graphics should remain the same, however, different levels, color, 
style, and weight are utilized 

23. Continue to Load and Display additional preferences as practice 

24. Investigate what levels the elements are being placed on.  The various 
preferences determine the location of graphics. 
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Lab 20: Updating Profiles 
When a profile is created the user has the option to display items such as: multiple 
surfaces, profile lines offset from the horizontal alignment, and features such as 
underground utilities and pipes. 
If there are changes that need to be made to a profile after it is created, update the 
profile for either surface line or features that exist in those surfaces. 

1. From the pull down menu Evaluation > Profile > Update Profile.  The 
Update Profile dialog will appear. 

 

2. Verify SH 86 is the active Profile Set 

3. In the Mode section toggle the radio button Display On 

4. In the Objects section toggle the radio button Offsets and Features 

5. In the Surfaces section <D> 12345SUR_Surface 

6. <D> the ALL button next to the Crossing Features category. 
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7. <D> the Apply button.  Using MicroStation viewing tools locate a 
crossing culvert. 

 

Note:    Profile and cross section displays are drawn at true horizontal 
scale.  A vertical distortion will be applied to cells displayed in 
profiles or cross section views based on the vertical scale applied 
to the grid.  DTM features displayed in these graphics are 
configured to display at their true horizontal (x-direction) sizes. 
Therefore, prior to displaying features in either profiles or cross 
sections the global scale factor for cells should be set to 1. 

 

Note:   Prior to correcting the scale for the culverts, two classes of elements 
displayed on profiles needs to be discussed. 
 

One – True scale items such as culverts 
Two – items represented by text such as utility crossings, flow-lines, ROW, etc. 
 
For item 1:  
The global scale factor for cells should be set to 1 and a subset of the dtm crossing 
features should be displayed (or refreshed in this case). This is accomplished with 
the use of feature filters. 

For Item 2:  
The global scale factor should be set equal to the plot scale. 

See the following page for information on updating a profile to refresh 
the graphics. 
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Refreshing a Profile Display 
First, take care of refreshing the display of the true-scale items such as the culverts. 

8. Select Tools > Global Scale Factors 

 

9. Key in the field Cell: 1 

Note:  You may need to Unlock the icon to allow modification to the cell 
scale only. By doing so, when you update the profile, the cells 
will draw at their true sizes. Leaving the Text and Line Style 
fields set the 100. This allows annotation and other commands to 
remain unaffected by the scale factor that was input specific for 
cells. 

10. <D> the Apply then Close buttons in the Scale Factor dialog 

11. In the main InRoads interface, select the filter CELL_True-Scale from 
the drop-down list. Also toggle ON the Feature Filter lock 
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12. Close and reopen the Evaluation > Profile > Update Profile dialog 

 

13. Verify SH 86 is still the active Profile Set.  Use the target button next 
to the Profile Set to graphically change the active profile set. 

14. In the Mode section toggle the radio button Refresh 

15. In the Objects section toggle the radio button Offsets and Features 

16. <D> the surface name 12345SURV_Surface 

17. <D> the ALL button next to the Crossing Features category 

18. <D> the Apply button.  
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19. Using MicroStation viewing tools, locate a crossing culvert and review 
the results 

 

20. Use MicroStation Measuring tools to verify pipe size(s) 

21. From the Locks toolbar select CELL_Plot-Scale filter from the pull 
down list. 

 

Note:  Verify that the feature filter is toggled on. 

22. Change the InRoads Scale Factor to 100. 

 

Note:  This is the desired plot scale change accordingly. 
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23. Close and reopen the Evaluation > Profile > Update Profile dialog 

 

24. Verify SH 86 is still the active Profile Set.  Use the target button next 
to the Profile Set to graphically change the active profile set. 

25. In the Mode section toggle the radio button Refresh 

26. In the Objects section toggle the radio button Offsets and Features 

27. <D> the surface name 12345SURV_Surface 

28. <D> the ALL button next to the Crossing Features category 

29. <D> the Apply button.  

30. Turn off the Feature Filter lock 
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Lab 21: Annotating a Feature in a Profile 
Features that have been displayed in profiles (or cross sections) can be annotated 
with information extracted from the surface model. 

1. Using MicroStation commands, window into any culvert displayed in 
the profile created in the previous lab. 

2. From the Locks toolbar select CELL_PLOT-Scale filter and verify the 
feature filter is toggled on. 

 

3. Select Evaluation > Profile > Annotate Feature in Profile.  The 
Annotate Feature In Profile dialog will appear 
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4. <D> the Apply button and review the results 

 

5. <D> the Points tab  

6. Check ON the Description 
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7. <D> the Apply button and review the results in your profile. 

 

8. Experiment with enabling other options in the Point tab and 
redisplaying the annotation 

Challenge Exercise:  
Update your profile to show projected features. Annotate the projected features. 
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Lab 22: Annotating a Profile 
In addition to annotating vertical alignments, profiles can be annotated with both 
existing and design information. 

1. Select Evaluation > Profile > Annotate Profile 

 

2. <D> the Apply. The existing and proposed grades annotate the profile. 
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3. Take some time and review the tabs along the top of the Annotate 
Profile dialog. Investigate the remaining tabs and the individual 
settings for each. 

4. Now go back and <D> the Selection tab. 

 

Note:  The dialog shows two categories; Available and Selected.  
Available lists the items that can be annotated in a profile, 
Selected identifies the items chosen for annotation along with 
precision and other settings. 
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5. <D> the item Cut Depth from the Available list 

6. <D> the ADD-> button.  Cut Depth will be added to the Selected list. 

 

7. <D> the item Fill Height from the Available list. 

8. <D> the ADD-> button.  Fill Height will be added to the Selected list. 

9. <D> the Apply button and review the profile display. 

Note:  You may have to zoom out to view the additional annotation. 
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Lab 23: Vertical Alignment Tracking 
Vertical alignments can be interactively queried similar to horizontal alignments. 

Tracking Vertical Alignments in Profile View 
1. Select Tools > Tracking > Vertical Alignments 

2. Move the cursor inside the Profile Set window and review the output in 
the InRoads Status bar. 

 

Note:  As you move your cursor in the profile view InRoads displays 
vertical alignment information in the status field.  There is not an 
option to write this information to the MicroStation file. 
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Tracking Vertical Grades in Plan View - Review 
1. Select Tools > Tracking > Horizontal Alignment 

 

2. Move the cursor along the active horizontal alignment and review the 
readout in the InRoads Status bar. 

 

 

Results displayed are the station and offset relative to the active horizontal 
alignment. The elevation is relative to the active vertical alignment.
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6. Creating Geometry 
There are multiple methods for creating horizontal geometry in InRoads.  

These methods are: 

 Horizontal Curve set commands 
 Importing from graphics 
 Horizontal Element commands (overview only) 
 Importing from an ASCII file (overview only) 
 Importing from an ICS file (overview only) 
 Joining Cogo Points together (covered in Geometry for ROW 

course) 
 Traversing commands (covered in Geometry for ROW course) 
 Creating parallel/offset alignments 

Options 
A review of the geometry options from Chapter 2 

Options relative to geometry are found from the menu bar under 
Tools > Options [Geometry] tab. 
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Dialog Items 
 Plotting Height: The elevation for drawing horizontal geometry 
 Seed Alignment Name: Initial name assigned to newly created 

geometry unless specified otherwise. 
 Seed Point Name: Initial name assigned to new cogo points. 
 Curve Definition: Horizontal - Arc or Chord definitions, Vertical -      

Parabolic or Circular 
 Measure: Along arc or along chord for curve definition 
 Degree of Curve Length: Specifies central angle that subtends this 

distance 
 Unit Station Length: Distance between major station intervals 
 Define Transitions: Defines spiral transitions by Length or Spiral                 

constant 
 Spiral Definition: Defines default method for defining spiral 

transitions 
 ICS Coordinate Sequence: Defines input order of 

Northing/Easting’s for ICS batch input files. 
 Vertical Angle Reference: Defines vertical angle measurement in 

ICS files. 
 Angular Mode: Specifies orientation for angles 
 Point Name During Edits: Defines whether names are assigned to 

geometry points during creation or editing. 

About geometry point names 
Alignment key-points (PC, PI, PT, CC, etc) exist in one of three states: 

 Unnamed  
 Named 
 Cogo Points 

 

Reviewing an alignment displays the geometry point name.  The above 
screenshot shows both named and unnamed points. 
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If Point Name During Edits is set to Named; alignment key-points are 
generated with a name based on the next available ID as specified in the 
Seed Point Name field.   The specified seed point name can be alpha, 
numeric, or alphanumeric characters. The assigned name is also reserved 
in the Cogo buffer. However the point is not written to the Cogo Buffer 
automatically. 

Writing the active alignment keypoints to the Cogo Buffer 

Select Geometry > Horizontal Curve Set > Events 

 

In the above example, all alignment key-points that were not previously 
assigned a name are written to the Cogo buffer beginning with the ID 
number of 200 

 

 

Note:  The command Geometry > Utilities > Assign Names can be used 
to add, delete, or rename geometry points 
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Typical Workflow 
A predefined workflow for creating geometry is not dictated by InRoads.  
However, a common workflow might be: 

1. Create or open an existing geometry project 

2. Create horizontal alignments (or Cogo points) 

3. Assign stationing for alignments 

4. Define alignment station equations, if any 

5. Define alignment key-points (unique points of interest) 

6. Review alignments 

7. View created alignments 

8. Display stationing for alignments 

9. Annotate created alignments 

Graphics clean-up 
Before continuing with the labs, delete all visible graphics in your 
MicroStation file using the element selection tool or a fence. Note that 
you are deleting the graphical display of data, not the data itself. The 
graphics could be redisplayed using the InRoads display commands 
shown in previous sections. 

Note:   The screened topography and the training guides are either 
locked graphics or in an attached reference file, you will not be 
able to delete these graphics and will use them for orientation. 
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Lab 24: Create New Geometry 

Create a new geometry project 
1.  From the pull-down menu File > New 

  

2.  <D> the Geometry tab 

3.  For the Type, choose Geometry Project 

4. In the Name field, key in 12345_Geometry Training 

5. In the Description field, key in Geometry Training class 
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Note:  The lower portion of the New dialog displays geometry projects 
that are currently loaded into memory 

6. <D> Apply 

Note:  InRoads created the geometry project and made it the active 
geometry project. Any horizontal alignments created will be 
placed in the active geometry project. 

7. Verify that the Geometry Project has been created 

 

 

Note:  This creates the Geometry Project where all new alignment data 
will be stored. At this point, it is held in RAM (Random Access 
Memory). When saved to the hard drive, the default extension will 
be ALG, as was assigned to previous geometry projects. 
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Create a New Horizontal Alignment 
8. Continue to use the New dialog. 

 Type:  Horizontal Alignment 
 Name:  Design Alt 1 
 Description:  Alignment by PI method 
 Style:  ALG_PRO 
 Curve Definition:  ARC 

 

9. <D> the Apply then Close buttons 
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10. Verify the horizontal alignment is created in the active geometry 
project. 

11. From the MicroStation pull-down menu Utilities > Saved Views 

12. From the Saved Views dialog <D> saved view name SH 86 ALT 1 

 

13. <D> the Apply button. 

Points A-M represent the required location of alignment PI’s.  
Horizontal curve set commands will be used to create the horizontal 
alignment. The steps will be to construct the tangents, then insert curves 
between the tangents once constructed. 
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Notes:    

 The following exercises will step you through creating an alignment 
using the Horizontal Curve Set, or PI method. While this exercise is 
roadway based, the tools and logic apply to any new alignment 
whether it is for drainage-ways, utilities, pavement marking, bridge 
geometry, parcels, or any other purpose.  

 For orientation screened graphics and curve radius values are shown 
for the alignment that will be created. 

Horizontal Curve Set commands 
The Horizontal Curve Set commands present an easy way to create alignments. 
They consist of five primary commands described below and may be accessed 
from a toolbar (shown) or from the pull-down menu under  
Geometry > Horizontal Curve Set. 

                 

 

 

 

 

 

Add PI is used to create a PI that begins a new alignment, or to add a PI onto either 
end of an existing alignment thereby extending it. 

Insert PI is used to add a PI to an existing alignment between two existing PIs. 

Define Curve 

Delete PI 

Move PI 

Insert PI 

Add PI 
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Move PI is used to change the location of a PI previously established. 

Delete PI is used to remove a PI from an existing alignment. For removing more 
than one PI, you must choose and Accept each one individually. To remove all PIs 
associated with an alignment, but leave the alignment name, right-click on the 
alignment name in the Explorer menu and choose Empty. 

Define Curve is used to either establish curves or to edit curves previously defined. 

Stationing for establishing stationing or station equations along an alignment 

Events are used to establish unique locations relative to an alignment, Cogo points, 
or the assignment of Cogo points along an alignments keypoints. 
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Lab 25: Create Alignment Tangents 
In this lab you will create an alignment using the Horizontal Curve Set, or PI 
method. Begin by inputting the tangent sections of the alignment by selecting 
locations graphically. This is accomplished by issuing a <D> at the desired 
location. Once the tangents are in place, curves between these tangents will be 
defined. 

1. Before beginning, verify the proper alignment is Active. This is 
necessary as any geometry entered will be populated in the active 
alignment. 

 

Design Alt 1 should be the active alignment. If not, several options exist to define it 
as the active alignment. 

 Right-click <R> on the horizontal alignment name and select Set 
Active from the fly-out menu 

 From the pull-down menu, select Geometry > Active Geometry 
and use the resulting dialog to set the active alignment. 
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2. To clear the MicroStation view turn the reference Display Off for the 
12345SURV_Topo100Scale01.dgn in the References dialog box. 

 

3. Select Geometry > Horizontal Curve Set > Add PI.  You are 
prompted in the MicroStation status bar to Identify Alignment End. 

4. <T> and <D>at point A (tentative or snap, and Data point). 
The alignment interactively displays as you move the cursor. 
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5. Continue to issue a series of points <T> & <D> through points B-M 

 

6. <R> (reset) when complete. 

7. If the alignment created does not pass through points A-M, use the 
Insert, Move, or Delete PI commands from the Horizontal Curve Set 
tools to correct the locations. 

8. Review the new alignment Geometry > Review Horizontal… 
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Summary of PI locations 

PI NORTHING EASTING BEARING DISTANCE STA. 
A  1,558,417.74  3,267,409.40     0+00.00 
B  1,558,457.06  3,268,756.14  N 88°19'39.62" E  1,347.31'  13+47.30 
C  1,558,469.66  3,270,669.73  N 89°37'21.60" E  1,913.63'  32+60.94 
D  1,558,050.59  3,272,645.47  S 78°01'28.88" E   2,019.69'  52+80.63 
E  1,556,982.55  3,276,540.43  S 74°39'56.80" E   4,038.75'  93+19.38 
F  1,556,716.98  3,277,527.47  S 74°56'25.98" E   1,022.14'  103+41.51 
G  1,555,931.76  3,280,408.64  S 74°45'18.96" E   2,986.25'  133+27.77 
H  1,555,939.60  3,282,135.29  N 89°44'23.81" E  1,726.67'  150+54.44 
I  1,555,699.32  3,283,343.64  S 78°45'12.06" E   1,232.01'  162+86.44 
J  1,554,474.27  3,288,508.48  S 76°39'23.63" E   5,308.14'  215+94.58 
K  1,553,821.34  3,290,431.45  S 71°14'44.01" E   2,030.79'  236+25.37 
L  1,553,315.19  3,291,416.57  S 62°48'22.55" E   1,107.55'  247+32.92 
M  1,553,346.54  3,293,367.43  N 89°04'46.05" E  1,951.11'  266+84.03 

 
Note:   Results may vary based on the specific PI locations defined by 

the user. 
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Defining Horizontal Curves  
Define Horizontal Curve Set – is used to create a curve between alignment 
tangents or to revise an existing curve definition. The Previous and Next 
buttons can used to step sequentially through the alignment. The Select button 
can be used to graphically identify an alignment location for editing.  As 
alignment components are selected, they highlight in the MicroStation view.  

 

The Radius 1: field is for input of the radius of a single circular curve. Leading and 
Trailing Transition fields are for the input of spiral curve radii. 
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The Curve Calculator is used to compute curve data for circular or spiral curves. 
In addition to deflection angle, one other curve criteria must be defined and locked 
prior to selecting the Compute button. The curve solutions can be passed to the 
parent dialog by selecting OK. 

  

 

The Design Calculator is used to compute or look up curve data to meet design 
criteria 

. 
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Lab 26: Define Alignment Curves 
1. Select Geometry > Horizontal Curve Set > Define Curve.  The first 

two tangents A-B and B-C highlight. 

2. Key in Radius 1: 21120 

 

3. <D> the Apply button.  The curve is created and displays. 
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4. <D> the Next> button.  Tangents B-C and C-D highlight 

5. Key in Radius 1: 3000  

6. <D> the Apply button. 

7. Repeat steps 4-6 for the curves at locations: 
D  Radius = 11,000.00 
E   Radius = 3,000.00 
F   Radius = 3,000.00 

For the first 5 curves, radii were input to define the curves. For the curve located at 
point G, the degree of curve is the known component (along with the external 
deflection angle). Use the Curve Calc…. button to solve the curve data. 

8. <D> the Next> button to define the curve at point G. 

9. <D> the Curve Calc… button 

10. Set Compute: to Simple Curve 

11. Calculate based on a 5 degree 30 minute 17 second curve 

12. Key-in 5 30 07 for the DOC: – Lock the field (if locked, unlock the 
Radius option, only 2 fields should be locked) 

   

 

13. <D> Compute: 

Notice the changes that occur in the dialog. 
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14. <D> OK the Curve Calculator dialog will close and the calculated 
radius will be populated in the Radius 1 field in the parent dialog. 

 

15. <D> Apply, the curve will be created 
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The next curve (location H) will also be developed using the degree-of-curve. 
However a short-cut will be used to generate the input for the Radius 1 field 

16. <D> Next to select the tangents on either side of point H 

 

17. In the Radius 1: Field Key-in D 2-23-14 

 

18. Press the keyboard <TAB> key to leave the field. The radius (2400.10) 
will compute for the selected location. 
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19. <D> Apply to form the curve 

20. If time permits, complete the remainder of the curves as noted in the 
drawing and listed below: 
I   Radius = 15,000.00 
J   Radius =   5,000.00 
K  Radius =  3,000.00 
L   DOC =  3-34-52 

21. Review the alignment data select Geometry > Review Horizontal 
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Lab 27: Alignment Stationing 
The default station value assigned to the start of a new alignment is 0+00.  
Redefine the beginning station to 100+00.00 

1. Select Geometry > Horizontal Curve Set > Stationing 

2. Key in Starting Station: 100+00  

3. <D> the Apply button. 

 

4. Verify your results using both of these methods: 

 Geometry > Review Horizontal 
 Tools > Tracking > Horizontal Alignments 
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5. Select Geometry > View Geometry > Stationing 

 

6. <D> the Preferences button. 

7. <D>the saved preference name Proposed-100 Ft Interval 

8. <D> Load and Close 
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9. <D> the Apply button from the View Stationing dialog.  Stationing is 
displayed.  

 

10. Experiment with changing the global scale factor value for text and 
redisplaying the stationing. 
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Lab 28: Annotating an Alignment 

In addition to Stationing, alignment information such as tangent distance, direction, 
and curve data is required. 

1. Select  
Geometry > View Geometry > Horizontal Annotation 

 

2. Verify settings and display alignment information 

3. Review the results in MicroStation 
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Challenge Exercise: 

1. Use Geometry>Copy Geometry to Copy alignment Design ALT 1 to 
a new Horizontal alignment named Design ALT 1 Modified 
 

2. to the copied alignment: 

 Move an alignment PI 
 Redefine one or more horizontal curves 
 Define alignment stationing as ending at station 382+00 
 Redisplay stationing at a 500 foot interval 
 Introduce 2 station equations. One overlap and one gap. 
 Revert the alignment to a simple PI at point B (remove the curve 

definition) 
 Transpose the direction of the alignment 
 Create a profile showing the existing ground profile along the copied 

alignment with a 2x vertical exaggeration. 
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Lab 29: Horizontal Alignment from Graphics 
Alignments can be created from existing MicroStation graphics. In this exercise a 
chained MicroStation element will be used to create an alignment. 

1. From the MicroStation pull-down menu select Utilities > Saved Views 

2. From the Saved Views dialog <D> saved view name Holder 
Driveway 

 

3. <D> the Apply button 
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4. Select File > Import > Geometry.  The Import Geometry dialog will 
open 

Horizontal Alignments, Horizontal and Vertical Alignments, Cogo 
Points or Event Points can be imported from MicroStation graphics. If 
the alignment has curves, it is recommended to toggle on Resolve Gaps 
and Nontangencies. If the alignment was drawn as a series of lines 
and/or arcs that have not been chained together as complex elements 
toggle on All Selected Elements Added to Single Alignment (you 
must define a Fence or Selection Set of the elements). 

After specifying the Name, the Description and the Style, choose 
Apply. If you created a Selection Set or defined a fence prior to 
initializing the command, you will be asked to Accept the contents. If 
this was not done, you’ll be asked to identify the element. In either case, 
after accepting, an alignment or alignments will be added to the 
geometry project specified in the Target section. 

5. On the From Graphics tab select Type: Horizontal Alignment 

 Name: Holder Driveway 
 Description: Driveway at Sta 190+80 RT 
 Style: ALG_SECONDARY 

6. <D> the Apply button.  The Import Geometry dialog will minimize 
allowing you to see more of your MicroStation view 
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7. When prompted to Identify Element <D> on the MicroStation graphic 
drawn in the center of the driveway 

8. <D> again to accept the highlighted graphics in the MicroStation view 

9. <R> in the MicroStation view to terminate the command.  The Import 
Geometry dialog will restore.  The MicroStation graphics have been 
imported as an alignment 

Note:  The geometry name field increments for additional selection(s) 

10. <D> the Close button to close the Import Geometry dialog 

11. Verify the alignment was created 

 

12. Review the alignment Geometry > Review Horizontal 

 

13. Time permitting, display the alignment graphics, stationing, and curve 
information. 
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Lab 30: Extend Alignment 
The alignment Holder Driveway does not intersect the reference line alignment 
Design Alt 1.  Standard practice necessitates the driveway alignment to 
commence at the main-line reference line. 

1. Select Geometry > Utilities > and hold 

Note:  The commands for Trim and Extend Alignment are dithered 
meaning they are not enabled.  These 2 commands are an 
extension of the Horizontal & Vertical Elements command set 
which must be enabled. 

 

2. Select Tools > Application ADD-Ins 
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3. Enable Horizontal and Vertical Elements Add-In 

4. Once enabled, Select Geometry > Utilities > Extend Alignment 

5. At the prompt: Identify Alignment to extend to, <D> on the alignment 
Design Alt 1 

6. At the prompt: Identify Alignment to extend, <D> on the alignment 
Holder Driveway 

7. <D> to accept the presented solution 

 

Note:  The alignment-alignment intersection is now the initial point of 
the driveway alignment. Because the alignment was edited 
(extended) from its beginning, the initial station value was 
recalculated and is assigned a station value of -0+12.41. The 
negative value is due to the original points in the alignment 
retaining their assigned station locations. 

8. From the pull-down menu  
Geometry > Horizontal Curve Set > Stationing define the driveway 
beginning station as 3+25 

Challenge Exercises: 
 Display stationing at a 100 foot interval for Holder Drive 
 Display alignment annotation for Holder Drive 

Recall saved view Drive @ 180+00 
 Import the graphics representing the driveway centerline into an 

alignment named Drive 180+00 
 Use the command Geometry > Utilities > Trim Alignment to remove 

the portion of the driveway alignment that lies north of the main-line 
reference line. 

Note:   When using the trim alignment command, when prompted to 
select alignments, the order the alignments are selected is not 
important. However, the location of the data point in response to 
Identify portion to clip, will determine both the alignment and 
the portion that will be eliminated. 



Colorado Department of Transportation 

 

Page 162  InRoads Geometry Fundamentals 

Lab 31: Saving Geometry 
Alignments cannot be saved individually. They are saved when the geometry 
project is saved.  Due to the fact InRoads works on geometry that is loaded in 
memory, the geometry project must be saved at appropriate times. 

Geometry projects can be saved using several methods including: 

1. From the pull-down File > Save > Geometry Project.  The Save As 
dialog will appear with the Save as type set to Geometry (*.alg). 

2. Verify you are in the correct project directory. 
C:\Projects\12345\Design\InRoads\ 

Note:  If the geometry project is already saved, then perform a Save 
operation instead of a Save As (see below). 

 

3. The file name should match the Active name at the bottom of the Save 
As dialog.  If necessary, use the drop-down arrow in the Active field 
and reselect the desired name to ensure the saved file name will match 
the surface name. 

Note:  Geometry projects have both an internal name that appears in the 
dialog boxes in InRoads and a name on the hard drive that has an 
.ALG extension. Ensuring that the saved Geometry name in the 
project folder matches the Geometry name displayed in InRoads 
explorer will minimize any confusion. 

4. <D> the Save button and then the Cancel button.  The file will be 
saved to disk and the Save As dialog will close. 
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5. Option 2 -Right-click on the Geometry Project in the Explorer menu 
and chose Save. The selected geometry project is saved. 
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Horizontal Elements - Overview 

 
The Horizontal Element tools allow you to create alignments without knowing the 
PI information.  They may be accessed from the toolbar shown above, or from the 
pull-down under Geometry > Horizontal Elements. Access to these tools is 
enabled as an application add-in (Tools > Application Add-Ins). 

There are several advantages to this method.  One of the greatest advantages of the 
horizontal alignments is that they do not have to be continuous.  For example, you 
can create elements that have multiple constraints, leaving gaps between them, and 
then join them together with unconstrained tangents and curves. 

Another advantage is the ease with which reverse and compound curves are created, 
as well as curves greater than 180 degrees. 

When creating elements, you have three basic placement options for linear elements 
and the same three options for circular elements. These options are: 

Fixed placement is used when you know exactly where the element is going to be 
located and you, in effect, lock it in place using a combination of coordinates, pass-
through points, bearings or radii. When using the fixed placement options, the 
resulting elements are not tangent or coincident with any existing elements. This 
placement option is used to place standalone elements. 

Floating placement is used to establish elements coincident and tangent to an 
existing element with a pass-through point and a radius (for curves) and with a 
pass-through point or a bearing for lines. They force the alignment to be coincident 
and tangent at the end where they join and will lengthen or shorten the element they 
are being attached to as necessary to meet the criteria specified. They will only 
ensure tangency and coincidence at the end where they are attached to an existing 
element. The floating placement options will not connect two existing elements. 

Free placement is used to connect two existing elements. It ensures coincidence 
and tangency at both ends where it connects to the existing elements. The existing 
elements may lengthen or shorten as necessary, but will not change locations. 

Once an element is placed and accepted, it is treated the same as any other element 
no matter the placement method 

To create a horizontal element alignment, first create an alignment name, assign a 
description and style, then use a combination of the fourteen commands to define 
the alignment. (The fifteenth command is for checking and correcting problems 
with the integrity of the alignment, described below.) 
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Check Integrity 
The Check Integrity command on the Horizontal Element toolbar allows you 
to check the coincidence and tangency of horizontal alignments.  The Element 
tools allow you to place the different components of the alignment in whichever 
order you wish, therefore it is not uncommon for elements to be “out of order”.  
This is one of the situations where Check Integrity can help, since you can 
check the integrity and make changes to elements to correct any integrity 
problems. 
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Horizontal Event Points - Overview 
Horizontal Event points are points associated with an alignment that are not 
actually a part of the geometry of the alignment the way a PC, PT, or PI are.  They 
are used for points that need to be annotated with stations and offsets, for points 
where you need special sections cut or for points where you want to be certain 
Roadway Modeler drops a template. 

Select Geometry > Horizontal Curve Sets > Events. 

 

Horizontal Event Points may be added as either Station and Offset (they move 
with the alignment if it is relocated or re-stationed) or as Northing and Easting 
(they remain fixed by coordinate values. The station and offset values relate back to 
the alignment and update as the alignment shifts).   This dialog can also be used to 
create Cogo points or to assign Cogo points at alignment vertices. 



 Chapter 6 – Creating Geometry 

 

InRoads Geometry Funamentals  Page 167 

Cogo Commands - Overview 
Coordinate geometry commands are delivered with InRoads. There is no need to 
exit, start, or launch another product to access them.  These commands provide an 
alternative method for creating horizontal alignments.  One of the main differences 
in creating the Cogo alignments (sometimes referred to as figures) and other 
alignments is that Cogo alignments require that the points be established first, then 
joined together to form the alignments. 

Once created, Cogo points and alignments are, in most cases, interchangeable with 
other horizontal points and alignments. There are a few key differences, however: 

 Cogo points are always numbered as you go (beginning with the seed 
number established in Tools > Options > Geometry or with the next 
available number.. 

 Cogo points can stand alone, such as when locating a fire hydrant or 
signs. 

There are several toolbars devoted to coordinate geometry described here.  These 
same commands may be found under the Geometry heading on the pull-down 
menu. 

Cogo Point commands 

 

Use the Cogo Points commands to create, edit, copy, delete, or navigate to 
Cogo points. These commands can be accessed through tool bars or by selecting 
Geometry pull-down menu. 

Cogo Traverse commands 
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The Traverse commands can be used to generate Cogo points from known 
locations by inputting distance and bearing to the point being constructed 
(Direction Traverse). It may also be used for locating points by Angle or 
Deflection.  Additionally, alignments and radial points can be created based on 
the statues of the Insert Point. 

Cogo Intersection Commands 

 

 

The Intersection commands can be used to generate point locations based on 
known points, alignments, stationing, and/or offsets. 



 Chapter 6 – Creating Geometry 

 

InRoads Geometry Funamentals  Page 169 

Create/Edit Alignment by Cogo Points 

    

Alignments are created by chaining existing Cogo points together using the 
Create/Edit Alignment command.  It is not necessary to create the alignment 
name prior to using this command; it may be entered here, along with a 
Description and Style. The points defining the alignment are listed in the 
Alignment Definition. The alignment can be defined graphically by selecting 
the Start button or the definition (or edits) can be keyed into the Alignment 
Definition field. 

See the Bentley Help or InRoads Reference Guide for additional information on 
InRoads Cogo. 
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Geometry from Text Files -Overview 
Text files may be imported in several formats, one of the easiest is to create an .ics 
file (Interactive Coordinate geometry Subsystem). This file type was first used with 
a product of the same name many years ago, but is still in use with InRoads today. 
It takes the format of commands along with the input for those commands. 

For example a text file of coordinates can be formatted in an .ics file by adding a 
Store command at the top and formatting the file similar to the one shown below. 

 

Choose File > Import > Geometry > ICS. Browse to find the file, and then 
choose Apply.  

 

The cogo points will be added to the active geometry project. You may then use 
Geometry > Utilities > Create/Edit Alignment to join the points, forming an 
Alignment and Geometry > Horizontal Curve Sets > Define Curves to add curves 
to the alignment.  You can also accomplish these same tasks within the .ics file.  
See the Bentley Help topic Alpha Cogo. 
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ICS Geometry - Overview 
ICS is the acronym for the “Interactive Coordinate Geometry Subsystem (also 
referred to as ‘Cogo classic’). ICS allows the user to use an ASCII format file to 
input and/or generate Cogo points. One of the benefits of using an ICS file is the 
documented history of commands used to generate Cogo points and the ability to 
edit and re-run the ICS command file. 

A simple ICS may look like: 

 

This input format is similar to other alphanumeric Cogo software. 

 

Additional data can be incorporated into an ICS file to include a preference 
name (!fname) as stored in your wysiwig.ini file and a description 
(*description). 

A full list of available ICS commands and command format can be found in 
appendix C and in the InRoads Help menu by searching for “ics”. 

 

store 1 3351.824242 3921.504545 277.828485 !default *bmk1 
store 2 3353.077879 3920.851212 278.283333 !default *bmk2 
store 3 3353.636970 3920.560000 278.486061 !default *bmk3 
store 4 3356.213939 3919.217879 277.382424 !default *bmk4 
store 5 3357.152727 3918.728788 277.376364 !default *bmk5 

store 1000 3339.577 3225.237 
locate direction 1000 1001 N25-56-26.4E 46.806 
locate angle 1000 1001 1002 212^47'55.3" 196.801 
locate angle 1001 1002 1003 205^37'27.1" 27.817 
locate angle 1002 1003 1004 223^37'59.9" 49.787 
locate angle 1003 1004 1005 205^24'32.3" 248.527 
locate angle 1004 1005 1006 208^24'10.5" 47.488 
locate angle 1005 1006 1007 240^34'12.5" 142.520 
locate angle 1006 1007 1008 145^52'21.2" 98.809 
locate angle 1007 1008 1009 215^31'58.3" 38.494 
locate angle 1008 1009 1010 264^38'35.3" 36.027 
locate angle 1009 1010 1011 195^46'57.3" 122.322 
store figure boundary (1000-1011 1000) 
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Lab 32: Creating Parallel Horizontal Alignments 
Offset alignments can be created to generate geometry for elements such as right-
of-way limits, easement limits, under-drains, retaining walls, bridge decks, etc. 

For this exercise generate right-of-way limits for the mainline road and the side 
road. The Side Road has a right-of-way width of 60’ (30’ on each side of 
centerline).  The mainline alignment has a total right-of-way width of 150’ being 
50’ feet north of the reference line and 100’ south. At the intersection of the right-
of-way lines a radius of 15’ is required. 

 

The workflow will consist of using an assortment of geometry commands: 

 Copying Geometry - between Geometry Projects 
 Multi-Center Curve – radius returns 
 Parallel Horizontal Alignment -  offset alignments 
 Join Alignments – connecting separate alignments 
 Join Elements – simplifying geometry 
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Copying Horizontal Alignments 
Alignments will be created relative to both the mainline alignment (SH 86) and 
the side road alignment (Side Road). These two horizontal alignments reside in 
two different geometry projects. To work efficiently, they should reside in a 
single geometry project. 

 

1. Select Geometry>Copy Geometry  
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2. Copy the alignment Side Road from geometry project 12345_Design 
to the geometry project 12345_Geometry Training 

Note:    Also copy alignment SH 86 as SH 86 ALT 1 if you feel the 
mainline alignment created by an earlier lab exercise may be 
problematic. 

3. Verify the alignment was copied  

 

4. Set the Geometry project 12345_Geometry Training as Active causing 
newly created geometry to populate this project 
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Multi-Center Curves 
Begin by creating the radius returns north of the mainline alignment. 

1. Select Geometry > Utilities > MultiCenter Curve 

 

2. Choose One Center 

Input: 

 Width 1: 30 
 Width 2: 50 
 Radius: 15 

3. <D> the Apply button.  Follow the prompts. 

4. In the MicroStation view <D> on the Side Road alignment 

5. <D> on the SH 86 alignment 

6. <D> in the Northwest quadrant, <D> to accept and create an alignment 
representing the radius return 

7. Repeat steps 3-5 & <D> in the Northeast quadrant 

New alignments will be assigned names based on the seed alignment 
name specified in Tools > Options [Geometry]. 
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Two new alignments are created, 1 & 2 

 

Note:    Your stationing graphics may appear at a different location than 
shown above. 
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Offset Alignments by Station 
Create the 50’ offset alignment for the mainline alignment.  

8. From the MicroStation pull-down menu, select Utilities > Keyin. The 
key-in browser is needed to input the desired station limits and offset 
distances. Without this, they could be defined graphically. 

 

9. From the InRoads pull-down menu  
Geometry > Utilities > Parallel Horizontal by Station. Following the 
prompts. 

10. In the MicroStation view <D> on the mainline alignment. 

11. Identify First Station/Key-in Station: Key-in 224+00 

12. <D> the Run button (or <enter>) 

 

13. Identify Second Station/Key-in Station: Key-in 224+93.20 

14. <D> the Run button. 

15. Identify Location: key-in -50 (50’ to the left) alignment 3 is created 
and displayed. 
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16. Repeat the Geometry > Utilities > Parallel Horizontal by Station 
command to the east of the sideroad. 

 Station limits of: 225+86.76 to 227+00, 50’ left of US 86 Alt 1 

Note:   The station limits can be graphically selected by issuing a data 
<D> point in the MicroStation view. The offset distance can also 
be graphically selected but using the key-in field allows a 
specific distance to be input. 

Alignment 4 is created and displayed. 

 

17. Re-execute the command to create the alignments along the Side Road 
north of the radius returns. 
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Join Alignments  
The Join Alignment command connects continuous and non-continuous 
geometry components together to form a single alignment.  This command 
operates by either connecting the components with a straight line segment or by 
paralleling an alignment to define the configuration of the created geometry.  

Join alignments 3, 1, & 5 to create the Northwesterly right-of-way limits.   

 

18. Select Geometry > Utilities > Join 

  

19. Check on Delete Original Alignments. By doing so, the first alignment 
identified (3) will become the final alignment name and alignments 1 
and 5 will be deleted upon completion of the command. 

20.  <D> the OK button and follow the prompts 

21. Identify Initial Alignment: <D> on alignment 3 

22. Identify Alignment to Parallel/Skip:  <D> alignment 1 to parallel 
(overlay) this alignment. 

If a reset <R> is issued in the above step, a tangent line would be created 
from the end of alignment 3 to the beginning of alignment 5.  By selecting 
the alignment representing the radius return, a curved section is generated 
at a zero offset to alignment 1 

23. Identify Next Alignment: <D> on alignment 5 
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24. Accept or Reject: <D> to accept the dynamic display 

25. Reset <R> <R> twice to terminate the command 

 

Alignment 3 is now the combination of the alignments 3, 1, & 5. 
Alignments 1 & 5 are removed from the geometry project.. 
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26. Join alignments 6, 2, & 4 to create the northeasterly right-of-way 
limits.   

 

Once the above step is completed, alignments 3 and 6 define the right-of-
way limits on the north side of the intersection. 
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Offset Alignments by Elements - overview 
Choose Geometry > Utilities > Parallel Horizontal by Element 

Parallel by element differs from by Station in that you can select the 
limits of the alignment to offset by selecting, <D>, alignment 
components (tangent or curve) to define the desired limits. 
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Creating Vertical Alignments – Overview 

Creating Profiles 
A profile of the horizontal alignment showing the existing surface ground line is 
required before creating the design profile - the vertical alignment.   

Select Evaluation > Profile > Create Profile. 

 

Multiple surfaces may be shown on one profile by selecting them in the 
Symbology category. You may also show features that cross the alignment and 
projected features on the profile.  These may be toggled on from the Features 
tab before creating the profile. 
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Creating Vertical Alignments 
A geometry project must be loaded prior to creating a vertical alignment. The 
vertical alignment must be created as a child to a parent horizontal alignment.  

Once the geometry project is loaded (and the parent horizontal is active), you may 
create a new alignment name. Choose File > New > Geometry and set the Type to 
Vertical Alignment.  Enter the Name, Description and select a Style. 

   

<D> Apply after filling in the appropriate information.  Once a profile set is 
created, the Vertical Curve Set or Vertical Element tools can be utilized to enter 
vertical alignment data. 
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Vertical Curve Set Commands 
The Vertical Curve Set commands make up an easy way to create alignments. 
They consist of five primary commands described below. 

                      

 

 

 

 

 

Add Vertical PI – Add Vertical PI is used to create a PI that begins a new 
alignment, or to add a PI onto either end of an existing alignment. 

Insert Vertical PI – Insert Vertical PI is used to add a PI to an existing alignment 
between two existing PIs. 

Move Vertical PI – Move Vertical PI is used to change the location of an existing 
vertical PI. 

Delete Vertical PI – Delete Vertical PI is used to remove a PI from an existing 
alignment. For removing more than one PI, you must choose and accept each one 
individually. To remove all PIs associated with an alignment, but leave the 
alignment name, right-click on the alignment name in the Explorer menu and 
choose Empty. 

Define Vertical Curve – Define curve is used to create a curve at a PI on an 
alignment, or to revise an existing curve on an alignment. The Previous and Next 
buttons are used to step through the alignment. The tangents forming the PI where 
the curve is to be defined will be highlighted graphically. 

Vertical Event Points – This last icon is used to define unique and specific 
locations relative to the active vertical alignment for supplemental template drops, 
cross section locations, design constraints, etc. 

Dynamics – The Dynamics dialog allows you to set intervals for placement of the 
vertical PIs.  It locks your cursor into the desired station, elevation and/or grade 
intervals. 

 

Define Curve 

Delete Vert. PI 

Move Vert. PI 

Insert Vert. PI 

Add Vert. PI 
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Selecting Geometry > Vertical Curve Set > Define Curve provides multiple 
choices for defining vertical curves. 

 

The Design Calculator is used to compute or look up curve data to ensure your 
design criteria are met.  

 

Keyins – There are additional keyins that can be useful when creating a vertical 
alignment, including: 

SE=station,elevation  (SE=34500,8421) 

DG=distance,grade  (DG=1500,-2.5%  or  DG=1500,-.025) 

 

Instructor demonstration – time permitting 
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7. Creating Cross Sections 
Cross Section Sets 

Cross sections can be created at specified intervals, as single sections at 
specific locations, or skewed to the reference alignment. 

1. Evaluation > Cross Sections > Create Cross Section 

Cross Section Main Tab 

• Cross sections created relative to alignment Source Design Alt 1 
• Sections created every 50’ – Interval 
• Sections will be160’ wide centered on reference line – Offsets 
• One surface will display in sections – Symbology 
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Cross Section Controls tab, allows: 

• Station limits constraints 
• Vertical constraints  
• Vertical Exaggeration 
• Supplemental sections 

 

2. <D> Apply, <D> identify location for cross section set display in the 
CADD file 
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Updating Cross Sections 
When a cross section set is created the user has the option to display items such as: 
multiple surfaces, profile lines offset from the horizontal alignment, and features 
such as underground utilities and pipes. 
If there are changes that need to be made to a profile after it is created, update the 
profile for either surface line or features that exist in those surfaces. 

1. From the pull down menu Evaluation > Cross Section > Update 
Cross Section.  The Update Cross Section dialog will appear. 
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Individual Cross Sections 
Cross sections can be created at individual locations. Beneficial for evaluating 
specific points of interest such as roadway intersections, access points, drainage, 
utility, or sign locations. 

 

 

Source toggled to Single Station 

 

Cross Section generation options – Set Source to:  
 Graphics – Select a MicroStation graphic to create cross sections 

perpendicular to selected object 
 Multipoint – Creates cross sections relative to user selected <D> 

points 
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Skewed Cross Sections 
Cross sections can be generated that are created skewed to the reference 
alignment. 

1. Evaluation>Cross Sections>Create Cross Sections 

 

Cross Section Custom tab 

 Type - Skewed 
 List of sections to be created - Station | Type 
 Station, Offsets, and Skew angles can be keyed-in 
 <D> on Station , Type entry to review location details 
  Cross section list can be stored to ASCII (Control) file for recall 
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The skew angle is computed in a clockwise direction. A perpendicular cross 
section has a skew angle of zero. 

 

Caution:    Skew angles between 90 and 270 degrees will create cross   
sections facing ‘down station’. 

 

 

 

Note:   End area computations will not include skewed cross sections in 
earthwork computations.
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8. XML Reports - Overview 
Two types of reporting are currently available within InRoads. The older version 
which is based on DBAccess reports is being discontinued with an upcoming 
release of InRoads. The old format is being replaced with a reporting utility 
based on the eXtensible Markup Language or more commonly referred to as 
XML.  Like the HTML language used for web development, XML reporting is 
based on tags and attributes which delineate elements of data.  

Another advantage of the XML reports is their use of a style sheet (.xsl) file to 
format the report.  The programming of the format is very familiar to HTML, so 
if you’re familiar with HTML programming, you can create your own style 
sheets or modify the predefined ones. 

Generating an Alignment Report 
Select Tools > XML Reports. (If the XML Reports command is not available on 
your pull-down menu in InRoads, first toggle XML Reports on in Tools > 
Application Add-ins.)  Choose the tab associated with the type of report you 
wish to create, and specify the criteria on which to report. 
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Select Save As and specify a name for the .xml file that will be created.  The 
Tools > View XML Reports command is automatically executed, and a default 
format chosen for your report.  
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Other formats may be chosen from the list of styles sheets presented 
along the left of the screen. 
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Choose Tools > Format Options from the XML report browser. 

 

You can change any of the formats or precisions shown and it will 
automatically change the report. 

 

While viewing the xml report, <R> on the screen - a fly-out menu 
appears. 

 

<D> on Export to Microsoft Excel - Excel will launch and display the 
results 



 XML Reports - Overview 

 

InRoads Geometry Funamentals  Page 197 

 

Note: The output to Excel will only contain data from individual 
alignments based on the location in the xml report the fly-out 
menu was activated. 
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To view the source information the xml report was generated from: 

In the Report browser, <D> Raw-xml.xsl in the left panel 

 

What you see are the xml tags and attributes which define the report contents. 
Formatting of this data for display is accomplished through the use of xsl, or style 
sheets.  Style sheets can be developed by the user for customized reports or formats. 
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Appendix A - Geometry Style Manager 
The attributes for Geometry Styles are set in the Geometry Style manager. 
These settings are stored in the CDOT-Styles.ini file. This file and/or settings 
are often referred to as the WYSIWYG editor or file, What You See Is What 
You Get. While this is generally true, you should display the graphics to the 
MicroStation screen to verify the formatting. 

1. Select Geometry > View Geometry > Geometry Style Manager 

If not already set in the dialog; 

 

2. Set Type to Points 

3. Set Name to Default 

Type: Points refers to alignment keypoints or Cogo points.  
Name:  Represents a Geometry Style by the name of Default 

A display of the current definition of this combination is displayed in the 
center of the dialog. 

Note: The field Text Character for Point as Text.  Defines the 
symbology for Cogo point locations if displayed as text. More 
detail on this in subsequent exercises. 

Note: For the remainder of this exercise: 
Always <D> No or Cancel If prompted to save changes to the 
Geometry Styles. 
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4. Change Type to Lines 

 

5. Change the Type to Arcs 
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6. Change the Type to Spirals 

 

The above steps displayed the 4 types of geometry components Points, 
Lines, Arcs, & Spirals. The preview pane displays the graphics and text 
contents and formatting. 

7. Switch the Name field to the different Geometry Styles, including 
those prefixed with ALG_ and investigate the change to the Arc 
annotation for these ALG_ styles. 

Change the Type back to Arcs 

 

The Symbology portion of the dialog displays the MicroStation settings for 
the line-work and text. 

8. <D> on Text, then <D> on the Edit button 
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The settings for the text symbology display showing the Named 
Symbology and subsequent attributes for the annotation such as level, 
font, justification, text size, etc. 

9. <D> Cancel to close the Text Symbology dialog 

10. <D> on Line, then <D> on Edit again 

 

The dialog shows the MicroStation settings for line-work display. 

11. <D> Cancel to close the Line Symbology dialog 

12. Use the MicroStation command Copy and pause the cursor over the 
graphics for alignment SH 86 that were displayed in a previous 
exercise. 
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The MicroStation fly-out indicates that the alignment was written to the 
level ALG_Proposed_Hor-Alignment indicating that the geometry 
style ALG_Pro was used.  
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Alignment Alternatives 
The previous section illustrates the display symbology and text settings for the 
annotation of alignments.  Notice in the previous exercise that the bearing and 
distance along tangents are labeled along the element. If the text does not fit 
along the tangent line, an alternative alignment symbology can be specified. 
This alternate alignment can specify different symbology for annotation. These 
‘secondary’ alignments (specifications) are defined in the Alternate field of the 
Geometry Style Manager dialog. 

1. If not already open, select Geometry > View Geometry > Geometry 
Style Manager 

2. Set Type field to: Lines 

3. In the pick-list for Names: <D> on ALG_EXISTING   

 

Note: In the Alternate Style field, the geometry style ALG_PRO-Alt 
is specified.  InRoads will use the geometry style specified in the 
Name field for all geometry display. The exception is if the 
initial Geometry Style specified has the Orientation (text) is set 
to Along, and the Bearing/Distance text does not ‘fit’ along the 
tangent, InRoads will use the Alternate Style specified. Without 
an alternative style defined, InRoads would not display any text 
for said element. 

 

Note: As configured for CDOT, alternate styles have been developed 
for all reference-line alignments. The alternate styles specify 
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that bearing and distance labels are Stacked vs. Along and are 
orientated to the MicroStation drawing plane. 

 

           Along                                                   Stacked 

 



Colorado Department of Transportation 

 

Page 206  InRoads Geometry Fundamentals 

4. <D> in the Name field and note that all alignments prefixed with 
ALG_ or RW_ have alternate geometry styles defined. 

 

 

 

Note: Alternate styles are defined for Type:Lines only. The definitions 
for Points, Arcs, and Spirals are configured for Stacked text by 
default. 
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Geometry Style Overrides 
1. Select Geometry>View Geometry>Horizontal Annotation 

2. <D>  the Active Style tab 

These fields allow the user to define display characteristics other than the 
geometry style associated with the alignment. They are available for input only 
when the Apply Style field on the Main tab is set to Active. 

 

3. <D> the Main tab 

4. Set Style: Active 
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5. <D> the Active Styles tab 

 

The fields are now available for population with any combination of geometry 
styles. This operates as a temporary override for geometry display. Once the 
user selects the Apply button to initialize annotation, an alert dialog box offers 2 
options. 

 

 

 

Selecting Yes will assign the Active geometry style to the selected geometry 
element(s). Selecting No will simply display the geometry element with the 
Active styles. 

6. <D> No and view the results in MicroStation to see the display 
properties selected. 

Choosing No in the above step allows us to temporary over-ride the display 
properties of the geometry without modifying the style assigned to the geometry. 
This should not be dismissed as trivial as you may be working with geometry 
supplied by others and do not wish to modify their work. 
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Appendix B - Geometry Point Symbology Manager 

Point Symbology  
As covered in the previous section, attributes for Geometry Styles (line-work 
and text annotation) are set in the Geometry Style manager and these settings 
are stored in the CDOT-Styles.ini file. 
Working in conjunction with the Geometry Style Manager is the Geometry 
Point Symbology Manager which defines attributes for alignment vertices 
such as: POB, PC, PI, PT, TS, PVT, PVT, etc. 

1. Close any dialog boxes open from the previous exercise 

Select Geometry > View Geometry > Point Symbology 

 

 

 

2. Select the Preferences Button and load the preference CDOT 

Note:  The above step is not generally required; however some users 
have experienced the CDOT preference not being loaded by 
default. This is being attributed to a minor software problem and 
loading/reloading the preference ensures correct operation of the 
software. 
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Geometry Point Dialog Attributes: 
 Type: 33 alignment vertices definitions 
 Abbreviation: Text label assigned when viewing stationing 
 Font: Font resource file containing ‘text’ 
 Character: Specifies character to use from the font resource file 

(Point as Text in Geometry Style Manager - points) 
 Cell: Cell to be placed from the attached cell library 

(Point as Cell in Geometry Style Manager - points) 
 Scale: Scale factor applied to cells or font 

(leave set to 1 as the Global Scale Factor accounts for this) 
 Rotate: Specifies if the cell or font rotate to the alignment direction 
  

Note: The bottom portion of the dialog contains input fields to populate 
the point symbology definitions. 

 

Cell Selection 
3. In MicroStation, Select Element > Cells to initialize the Cell Library 

dialog. 

 
This is not a necessary step but done to illustrate the interaction between 
the Geometry Point definition and a MicroStation cell library. Notice that 
the Geometry Point definitions call the cells ALG_KeyPI or 
ALG_KeyPT cells for placement along an alignment. 

4. <D> on the ‘X’ in the upper right-hand corner of the Cell Library 
dialog to close it.
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Appendix C – ICS 
InRoads contains an alphanumeric interface for running Interactive Coordinate 
Geometry Subsystem (ICS) commands.  This interface is also referred to as Cogo 
Classic and can be used to run batch runs of geometry commands. 

ICS can be accessed through the Windows start menu by selecting  
Start > All Programs > Bentley InRoads > Bentley Cogo Classic 
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ICS files can also be imported into the InRoads graphical interface by selecting 
File > Import > Geometry [ICS] tab 
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Control Commands 
CREATE PROJECT   name  description 
LOAD PROJECT        name 
SAVE PROJECT        fname 
AUDIT FILE          mode file.ext 
mode:  0 - opens an existing file of the specified name so that data  
                can be added to the end of the file 
        1 -  opens a new file of the name specified 
       -1 -  closes the existing file 
 
OUTPUT FILE         mode file.ext 
mode:  0 -  records all input and output records in the output file 
            1 -  suppresses recording of input and only records output 
               -1 -  closes the existing file 
 
AUTO PLOT           preference /z /!fnam 
     This command turns on the graphic auto plot lock and sets the active 
     preference for automatically plotting points and figures in the design 
     file.  Issuing the command again with fnum equal to 0 will turn the 
     auto plot lock off in the graphic environment. 
     Example:     AUTO PLOT 0 !ALIGN1      # turns auto plot lock on and 
                                           # sets the active preference to ALIGN1 
                  AUTO PLOT 0              # turns off auto plot lock 
 

Parameter Commands 
SET HEIGHT         HtFS1 hi1 htBS1 /htFS2 /hi2 /htBS2 
SET PARAMETER      dir 
     0 = north azimuth      1 = bearing 
SET PROTECTION  set prot 
     0 = Point Protection ON 1 = Point Protection OFF 
SET REFERENCE 
     Sets the vertical angle reference:  v = horizon    z = zenith 
SET SEQUENCE       seq 
     Sets the coordinate sequence:   x = x,y,z    n = n,e,e 
SET TOLERANCE      dtol /atol 
     Sets a distance tolerance dtol and angle tolerance atol for the 
     following conditions: 
         - Colinearity of points on tangents 
         - Curve and spiral symmetry 
         - Curve and spiral tangency with subtangents 
         - Figure continuity at tangent points 
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Report Commands 
ANGLES                 pBS pOC desFS 
     Computes and reports angles from pBS at pOC to points in desFS. 
AREA DIRECTION         des 
     Computes and reports the area and boundary courses of the closed figure 
     defined by des. 
DESCRIBE ALIGNMENT    Hfg /x /sBEG /sEND 
     Lists the following alignment data for Hfg at interval x: 
         - coordinates and station of PC, PI, PT, CC 
         - distances and directions of tangents 
         - PI deflection angles 
         - curve data 
 
DESCRIBE VERT ALIGN   sBEG /sEND 
     Describes the active vertical alignment, including points of vertical  
     inflection, curvature, tangency, high and low points, and grades. 
 
DISTANCE               des 
     Computes and reports distances between points in des. 
 
INVERSE DIRECTION     des 
     Computes and reports distances and directions between points in des. 
 
LIST COORDINATES      des /mode 
     Lists the coordinates of each point in des. 
 
LIST FIGURES           des  
     Lists the figures and figure descriptions in des. 
 
TRAVERSE ANGLES  des 
     Computes and reports the lengths and the interior angles of lines in  
     the traverse defined in des. 
 
STATIONS AND OFFSETS  desAL2 /x /sBEG /sEND 
     Computes and lists the stations and offsets of points in desAL2 from  
     the active horizontal alignment. 
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Point Commands 
STORE               n c1 c2 /z /p /!fnam   -OR-   p c1 c2 /z /-cno /!fnam 
     Stores point n with coordinates c1, c2, and z.  If optional p is 
     specified, n takes its value.  If optional -cno is specified as 
     -1, -2, or -3 the coordinate c1, c2, or z is modified, respectively. 
 
DELETE COORDINATES  des 
     Deletes points in des from the .tdp project file. 
 
DEFINE Z            p z 
     Defines the elevation of point p. 
 
POINT DESCRIPTION   des *description 
     Defines the alpha description for the known point(s) in des. 

Figure Commands 
STORE FIGURE        nfg des /pAL sAL 
     Defines the figure nfg in the .tdp file as the list of points in des. 
 
DELETE FIGURE       fg 
     Deletes the figure descriptions (but not points) from the .tdp project 
     file. 
 
FIGURE DESCRIPTION  des *description 
     Defines the alpha description for the known figure(s) in des. 
 

Locate Commands 
ANGLE RESECTION        p1 p2 p3 ang1 ang2 /n 
EXTEND ARC             pPC pCC nPT [arc] 
LEVEL RUN              pBS rBS 
LOCATE ANGLE           pBS pOC nFS ang [dis] /vaFS /[off] /vaBS pVB 
LOCATE DEFLECTION      pBS pOC nFS defl [dis] /vaFS /[off] /vaBS /pVB 
LOCATE DIRECTION       p n dir [dis] /va /[off] 
LOCATE FROM ALIGNMENT  n sn /[off] /rod 
     Locates a point n along the active alignment at station sn at an 
     optional offset off and rod reading rod.   
           rod = rod reading if Level Run is active 
           rod = elevation if Level Run is non-active 
      
LOCATE LINE            p1 p2 n [dis] /va /[off] /Mdis 
TANGENT                n1 pCC1 [r1] n2 pCC2 [r2] /dir /ext 
TANGENT OFFSET         n pOF p1 p2 
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Transformation Commands 
COMPUTE TRANSFORM      desFROM desTO 
     This command is initially used to set the rotation/translation values 
     to be used in the transformation process.  The "desFROM" values are 
     two points that are located in the relative coordinate system.  The 
     "desTO" values are two points in the rotated/translated coordinate 
     system that directly correspond with the two points in the relative 
     coordinate system.  The relationship between these two sets of points 
     is that the measured distance must be exactly the same between each 
     set of points (no scaling allowed). 
 
TRANSFORM COORDINATES  des 
     This command can be executed at any time, on any set of points/figures, 
     AFTER the Compute Transform command has been processed.  This command 
     works with points or figures. 
 
Divide Commands 
DIVIDE ARC      pPC pPT pCC div /n 
     Divides a clockwise arc with center pCC into div equal segments between 
     pPC and pPT.  Stores the resultant coordinates as n, n+1, etc. 
DIVIDE FIGURE   des div /n 
     Divides the figure des into div equal parts.  Stores the resultant  
     coordinates as n, n+1, etc.   
DIVIDE LINE     p1 p2 div /n 
     Divides line p1 p2 into div equal parts.  Stores the resultant 
     coordinates as points n, n+1, etc. 
 

Intersect Commands 
ARC ARC INTERSECT       n pCC1 [r1] pCC2 [r2] pID 
ARC LINE DIRECTION      n pCC [r] p dir pID /[off] 
ARC LINE POINTS         n pCC [r] p1 p2 pID /[off] 
CURVE SPIRAL            n [r] pCC pID pTS dirBT [ls] [dc] 
CURVE SPIRAL POINTS     n [r] pCC pID pTS pSIT pSC 
DIRECTION INTERSECT     n p1 dir1 p2 dir2 /[off1] /[off2] /va1 /va2 
FIGURE ARC INTERSECT    n fg pCC r pID /[offg] 
FIGURE FIGURE INTERS    n fg1 fg2 pID /[off1] /[off2] 
FIGURE LINE INTERSECT   n fg p dir pID /[offg] /[off] 
LINE SPIRAL             n p1 p2 pID pTS dirBT [ls] [dc] 
LINE SPIRAL POINTS      n p1 p2 pID pTS pSIT pSC 
POINTS DIRECTION INTER  n p1 p2 p3 dir /[off1] /[off2] /va 
POINTS INTERSECT        n p1 p2 p3 p4 /[off1] /[off2] 
SPIRAL SPIRAL           n pTS1 dirBT1 [ls1] [dc1] pTS2 dirBT2 [ls2] [dc2] /pID 
SPIRAL SPIRAL POINTS    n pTS1 dirBT1 [ls1] [dc1] pTS2 pSIT pSC2 /pID 
 

Curve Commands 
FIT CURVE      pBT pPI pAT nPC nCC nPT /[r]   -OR-   pPC pOC pPT 
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Alignment Commands 
SET ALIGNMENT        Hfg /pAL /sAL /Vfg 
     Activates a horizontal alignment and optionally defines the stationing. 
 
CLEAR ALIGNMENT 
     Clears the active alignment, and makes the active alignment Cogo. 
 
POINTS ON ALIGNMENT  x /n /[off] /sBEG /sEND /odd 
     Locates and lists coordinates of points n, n+1, etc. at each interval x 
     along the active alignment at an optional offset off between sBEG and sEND 
     with odd defining station lock on or off. 
            odd = 1   -  Station Lock on  
            odd = 0   -  Station Lock off 
 
FIT ALIGNMENT        nTS pBT pPI [dc] [ls1] [ls2] defl sign 
 

Parallel Commands 
PARALLEL LINE     p1 p2 [off] /n1 n2 
     Locates points parallel with the line p1 p2 at an offset distance off, 
     and stores them as n1 and n2. 
 
PARALLEL FIGURE   des /[off] /n /nfg /dz 
      
     Locates a new parallel figure to des at an offset distance off, and  
     stores points of the new figure as n, n+1, etc. and the new figure 
     as nfg with an elevation difference of dz. 
         For an open figure:                  For a closed figure: 
             +off = to the right                   +off = external 
             -off = to the left                    -off = internal 
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COGO Parameter Abbreviations 

ang  - angle p - known point 

atol - angle tolerance pAL - point on the alignment 

arc - arc distance pAT - point of the ahead 
tangent 

-AL - alignment pBS - point of the backsight 

c1,c2 - coordinates 1 and 2 pBT - point of the back tangent 

cid - spiral curve 
identification; this 
parameter is not used by 
Simple Spiral, key in any 
number from 0 to 999. 

pID - known point that 
indicates which 
intersection is to be 
chosen; positive is near, 
negative is far from the 
pID. 

-cno - the field number of a 
coord to change in an 
existing point 

pOC - occupied point OR point 
on the curve 

-CC - center of curve pOF - point that 
perpendicularly offsets the 
pt. to be calculated 

dc - degree of curve pVB - point of the vertical 
backsight 

defl - deflection angles PC - point of curvature 

delta - delta angle PI - point of intersection 

des - point or figure 
description 

PT - point of tangency 

desc - alpha description r# - curve radius 

dir - direction rBS - rod reading of the 
backsight 

dirBT - direction to the back 
tangent 

rod - rod reading or elevation 

dis - distance s - station 

div - number of divisions sAL - station on the alignment 

dtol - distance tolerance sBEG - beginning station 

dz - elevation difference sEND - ending station 

ext - externality seq - coordinate sequence  
(x or n) 

fg - figure sign - sign of angle 

fnam - feature name sn - station 

fname - file name SC - spiral to curve point 

fnum - feature number SIT - point of spiral 
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intersection 

-FS - foresight TS - tangent to spiral point 

Gdis - geodetic distance va - vertical angle 

Hfg - horizontal figure vaBS - vertical angle to 
backsight 

hi# - height of instrument vaFS - vertical angle to 
foresight 

ht# - height of target Vfg - vertical figure 

ls# - spiral arc length x - station distance 

Mdis - measured distance z - elevation 

mode - input/output mode 

n - unknown point 

name - name of file 

nfg - unknown figure 

odd - station lock on/off 

off - offset 

offg - offset from figure 

 
[ ] - parameters shown in the square 
brackets utilize the Input Combined 
Grid Factor 

 

Abbreviations for the ICS input commands 

Abbrev. Command Comment 

an r angle resection  

an angles  

a a i arc arc intersect  

a d area directions  

a f audit file  

a l d arc line direction  

a l p arc line points  

a p auto plot assigns feature name/number 
to all of the following 
commands, i.e.: a p house 
store 1 100 200 300 
      2 101 202 303 
loc ang 1 2 30. 100. 

c a clear alignment  

c g f combined grid factor  

c pr create project  

c s p curve spiral points  
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c s curve spiral  

c t compute transform  

def z define z  

del c delete coordinate  

del f delete figure  

des a describe alignment  

des v describe vertical  

di a divide arc  

di f divide figure  

di i direction intersect  

di l divide line  

dis distances  

exi exit  

ext a extent arc  

f ar i figure arc intersect  

f al fit alignment  

f c fit curve  

f d figure description  

f f i figure figure intersect  

f l i figure line intersect  

i d inverse direction  

i f input file  

l a locate angle  

l c list coordinate  

l de locate deflection  

l di locate direction  

l fi list figure "list figure (point des, 
i.e. 1-4) -1" 
lists all figures that 
points in the parentheses 
are located in. 

l fr a locate from alignment  

l l locate line  

l pa load parameters  

l pr load project  

l r level run  
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l s p line spiral points  

l s line spiral  

o f output file  

pa f parallel figure  

pa l parallel line  

pl c plot curve  

pl l plot line  

pl p plot point  

pl s plot shape  

po de point description  

po di i point direction intersect  

po i points intersect  

po o a points on alignment  

sa pa save parameters  

sa pr save project  

se a set alignment  

se d set display "set display 0" turns 
scrolling off and "set 
display 1" turns scrolling 
on 

se h set height  

se pa set parameters  

se r set reference  

se s set sequence  

se t set tolerance  

sp s spiral spiral  

sp s p spiral spiral points  

s a o station and offset  

s f store figure  

s store  

t a traverse angle  

t c transform coordinates  

t o tangent offset  

t tangent  
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