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Document Conventions 
There are several conventions that are used throughout this document to indicate 
actions to be taken or to highlight important information.  The conventions are as 
follows: 

 

Example Item     Meaning 

View Perimeter a command name or a file that you are to select, including 
directory path 

Name: field name, button or icon in a dialog box 

Dialog Header dialog box name 

Tools > Options a command path that you are to select - usually from the 
pull-down menus 

Dialog Area heading for separated areas within a dialog box 

Tab heading for tabs found within dialog boxes 

Key in entering data with the keyboard or items selected from 
drop-down list 

Document name style used when referring to another document 

Note:  text  information about a command or process that you should 
pay particular attention to 

Concept:  text detailed definition of a concept, procedure or process 

Emphasis an important word or phrase 

Prompt user prompt 

1. Numbered Steps actions that you are to perform as part of the lab activities 

<D> or Data press the data button on the mouse 

<R> or Reset press the reset button on the mouse 

<T> or Tentative press the tentative button on the mouse 
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Course Overview and Introduction 
The main purpose of the InRoads Survey program is to process raw survey data and 
then output it to a useable format. In InRoads Survey the user can add, delete, and 
edit the survey data to correct errors or omissions in the field coding and equipment 
settings.  

When InRoads Survey is started, two applications are launched: The CAD platform 
(MicroStation) for viewing the data and generating the basemap (*.DGN file), and 
InRoads Survey for manipulating the survey data. The survey data is stored 
information and the CAD platform enables the user to see that “data”.  

Items addressed in this course will be: 

 Setting up InRoads Survey 
 Importing Survey Data 
 Working with the Survey Data Fieldbook 
 Working with the Survey Feature Table 
 Exporting the Fieldbook 
 Survey data in InRoads 
 Working with Surface Models (DTM) 
 Working with Geometry Data (ALG) 

Foundation 

Intended Audience 
The intent of this course is to provide education to the survey staff as it relates to 
importing, correcting, and processing field data. 

Prerequisites 
The attendees must have a basic understanding of MicroStation prior to 
attending this course. 

Duration 
Length of training for the Survey reduction, processing, and quality control is 32 
hours. 
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Focus 
 CDOT survey process 
 CDOT standards and conventions  
 Importing and editing field data  
 Exporting a basemap drawing, surface, and alignments 

Goal 
 Provide the survey staff the work process for Colorado DOT. 

Introduction 
Introduction of course goals and content. 

Instructor 
Introduction of Instructor(s) and brief summary of credentials. 

Students 
Introduction of students and a brief summary of student knowledge as it relates 
to MicroStation and InRoads Survey. 

Student Interests 
Query as to specific interests of individual students and the class as a whole. 

Schedule 
Establish schedule for class breaks, lunch, and course termination. 
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Fundamental Concepts 

Software Terminology 
Understanding the difference between InRoads Survey, InRoads, and MicroStation. 

InRoads 
The name InRoads is a somewhat generic term that refers to a customizable 
Suite of software offered by Bentley Systems, Inc. The name InRoads, without 
an additional defining name, refers to a basic software suite that contains site 
and corridor modeling tools. A brief summary of the add-on/stand-alone 
modules follows: 

InRoads Site – Specific module designed with a focus on site design (a sub-set 
of InRoads with limited corridor modeling tools) 

InRoads Survey – Specific module designed for the reduction of survey data.  
(Limited commands from InRoads Site are included) 

InRoads Rail – InRoads with additional functions unique to the design of 
railways. 

InRoads Bridge – InRoads with additional functions unique to the design of 
structures. 

MicroStation 
A CADD platform that provides the ‘graphics engine’ for InRoads. 

PowerDraft 

A Bentley CADD platform that is a sub-set of MicroStation. 
(Limited database linkage and elimination of visualization features) 

PowerSurvey 

InRoads Survey combined with PowerDraft  
(bundled together for a reduced price with all the functions of InRoads Survey) 
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InRoads Survey vs. InRoads 

InRoads Survey is a software application designed for the processing of survey data 
gathered by electronic data collectors.  InRoads Survey ‘reduces’ this raw survey 
data to MicroStation graphics, surface models, and geometry projects as COGO 
points and alignments. InRoads Survey has a limited number of the commands 
available in the Bentley Systems, Inc.’s InRoads Site and InRoads modules. 

MicroStation 

MicroStation is necessary to run the software applications of the InRoads software suite. InRoads 
software does not posses a CADD (graphics display) engine, a fundamental necessity for the 
software’s operation.  

Note: Adding additional InRoads functions (Application Add-Ins) to 
your interface will be covered in the following pages.

InRoads Survey Functions 

Survey data reduction 

Editing survey data (fieldbook)

Exporting data for data 
collectors 

Graphic display of survey data

Generating DTM’s from 
survey data 

Limited to creating Geometry 
from survey data 

Some Cogo tools 

Limited DTM  
editing/modification tools 

Limited site design tools  

Not available 

Multipoint Profile method only 

Not available 

Earthwork by grid method 
only 

Not available 

Not available 

 

InRoads Functions 

Not available 

Not available 

Not available 

Not available 

DTM creation from varied 
sources 

Comprehensive geometry 
creation & modification 
tools 

Access to full Cogo tools 

Comprehensive DTM 
editing/modification tools 

Assorted site design tools 

Corridor modeling tools 

Generation of Profiles 

Generation of Cross 
Sections 

Assorted earthwork 
computations 

Plan/Profile sheet 
generator 

Hydrology tools 
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Survey Terminology 

During this class a number of files will be created.  Some of the files will be 
resource files to help follow standards and generate consistent graphics.  Other 
files will be generated from the field data.  Below is a list of file types utilized in 
class. 

FWD – FieldWorks Data 
This files combines individually imported raw field data files and stores them in 
one file. In a *.FWD file the user can view, edit, and add survey data. 

FWF – FieldWorks Feature Table 
This file defines the graphic properties of features coded in the data collector.  
The Feature table sets how the coded items will be displayed in the CADD file, 
including line symbology, cell placement, and text sizes. 

FXP – FieldWorks eXtended Preferences 
This file contains additional preferences that only apply to the Survey software, 
these include: audit trail, point seed numbers, and resolving code errors. 

INI – INItialization 
There are two INI files that will be used.   
The CDOT-Preference.ini file settings control the symbology of the graphics 
from DTM and ALG files and other similar settings.  The CDOT-Styles.ini file 
controls the display format of geometry styles (alignments and COGO). 

DTM – Digital Terrain Model 
These files contain features: random, break lines, exterior, interior, and contour. 
Each feature is individually identifiable and contains a unique identifier that is 
used for controlling triangulation settings and parameters used for plan view, 
profile, and cross section displays. The files can include data on underground 
and/or overhead utilities, landlines, and other data not directly related to the 
surface model. 

ALG – ALiGnment 
These files store the horizontal and vertical geometry components that define an 
alignment in a Geometry project. The components can consist of lines, arcs, 
curves, and points. Multiple alignments can be stored in one geometry project 
but only one alignment can be active at a time. 

RWK – Projects 
These files contain the paths to different types of Inroads files. This allows the 
user to open just one RWK file to load a survey, surface, and geometry project 
at the same time. If the directory structure on a computer changes, the .RWK file 
is an ASCII file that can be opened and changed with a text editor such as 
Notepad. 

TIW – Text Import Wizard 
Custom setup for importing varying formats of ASCII data.  The setup can be 
saved and reused in the future.  An example imported format would Point Name, 
Northing, Easting, Elevation, and Code. 

TEW – Text Export Wizard 
Custom setup for exporting varying formats of ASCII data.  The setup can be 
saved and reused in the future.  An example exported format would Point Name, 
Northing, Easting, Elevation, and Code. 
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CDOT CADD Resources 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & Engineering 
Innovation Web site. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: 

http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 

The website (presently only available to CDOT) provides CDOT users with up 
to date information, tools, and resources related to CADD and the Colorado 
Engineering Software Transition (CEST) project.  

 

 

http://internal/cadd/�


 Concepts 

 

 

This website is a valuable resource for CADD users and includes: 

CADD Library  
The CADD Library page provides links to manuals, newsletters, standard details, 
etc. One extremely useful link is to the Tips and Tricks section for MicroStation 
and InRoads. This information changes daily, so check back often. 
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CADD Manual 
The CDOT Computer Aided Design and Drafting (CADD) Manual outlines 
CDOT’s use of Bentley’s MicroStation and InRoads software. It documents 
standardized procedures for the exchange of information between CDOT 
regions, specialty groups, and consultants working on CDOT projects. The 
Manual also addresses software issues, tools, techniques, standards and 
procedures, etc. which will aid the user in the efficient production of CDOT plan 
sets. 

The CDOT CADD Manual and the associated electronic files contained in the 
CDOT configuration are used in the generation of electronic plans by both 
CDOT internal designers and the consulting firms doing business with CDOT. 
The electronic version of the Manual provides hyperlinks to each chapter as well 
as context sensitive index and search functions. You can also print chapters or 
the entire manual. 

The CDOT CADD Manual can be accessed several different ways including: 

 From the CDOT internal CADD web site home page link; 
 From the CDOT Design and Construction Project Support Page (external 

web site); 
 From the CDOT Menu (Help > CADD Manual). 
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CDOT Workflows 
There are several standardized MicroStation and InRoads workflows that CDOT 
has developed to assist you. These workflows are step-by-step CDOT-specific 
procedures for certain tasks that you may encounter when working in 
MicroStation or InRoads on a CDOT project. Many of these workflows are 
referenced throughout the course. 

In addition to accessing the workflows from the CDOT CADD Web site Home 
page link CDOT Work Flow, you can also access workflows: 

 From the Windows Start menu  
(Start > All Programs > _CDOT_CADD_Information > Workflows); 

 From the CDOT Menu (Help > Workflows). 

New workflows are typically added with CDOT configuration updates, so check 
back often. 
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Issues Logs  
Check the issues log to determine the status of submitted requests. 

Requests & Support 
This page provides CADD help solutions where you can: 

 Learn how to get help; 
 Submit a questions; 
 Submit a request (e.g. request a new MicroStation level or InRoads 

preference), as well as  
 Obtain InRoads, InRoads Survey and MicroStation support.  

There is also a link to IT Services for hardware support, “how to” instructions, 
installation, training files, and work space setup. 

 

 

Training 
Use this link to sign up for training classes.  You can also review online 
computer-based training (CBT) for MicroStation, InRoads and InRoads Survey. 

Directory Structure 
Review directory structure in Chapter 3.2 of CADD Manual to see where files are 
located for ROW Survey (design and plan sets) 

Note that the model files for ROW Survey are located in 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files.  Model files contain 
graphics for the designfile and are referenced by other groups.  Since everyone 
places their design graphics at the same coordinates, they may be referenced so that 
each group can see one another’s work.
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Section 1 - Overview 

Chapter 1 Getting Started with InRoads Survey 

InRoads Survey Interface 
Remember, InRoads Survey is running on top of MicroStation. That means the 
InRoads interface can be moved outside the MicroStation environment to 
another screen and that the InRoads interface may hide MicroStation dialog 
boxes.  

 There are four main parts to the InRoads Survey Interface, the Menu Bar, 
Work Space toolbar, Information Window and Status Bar. 

  

Menu Bar 

Work Space 
toolbar 

Information 
Window 

Status 
Bar 



Colorado Department of Transportation   

 

Page 12  InRoads Survey 

Menu Bar 

 

 

 The Menu Bar pull-down menus are used to access commands, 
settings, and toolbars. 

 An arrow > in the pull down will expand to a submenu. 
 … In the pull down will open a dialog by that name. 
 The pull-down menus will vary with the application add-ins that 

are loaded. 

Work Space toolbar 

 

 The Workspace Bar is used to manage and separate the different 
file formats of the program. 

 Right clicking is allowed in the Workspace Bar. The active 
shortcut menu will vary depending on which Tab is selected.   

 The Workspace Bar can be undocked as shown here but it is not 
recommended. 

 To switch between tabs use the scroll arrows or right click to open 
a short cut menu. 
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Information Window 

  

 The Information Window varies depending on which Workspace 
Bar tab is selected. 

 Right clicking is allowed in the Information Window. The active 
shortcut menu will vary depending on what feature was selected. 

Status Bar 

 

 Located in the lower left hand corner of the InRoads Survey 
Interface, the status bar is used for file processing feedback and 
tool descriptions. 
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Project Defaults 
Setting project defaults prior to working on any project will save time navigating to 
directories and will ensure the correct InRoads resources are loaded. 

 

Dialog Items 
 Configuration Name – Select from the drop down to change the 

current project directories and resources. 
 Default Preferences 

In this section the user enters specific file names with extension names 
(types) InRoads will be using. The different file types and their uses are 
as follows: 

 Preferences (*.ini) – The main file used to define the symbology 
and dialog preferences. 

 Styles (*.ini) – File used to store geometry symbology. 
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 Survey Feature Table (*.fwf) – File used by Survey to store 
symbology 

 Survey Preferences (*.fxp) – File used by Survey to store extra 
settings specific to the survey application. 

 *Turnouts (*.txt) – File used to define turnouts. 
 *Drainage Structures (*.dat) – File used by Storm and Sanitary 

software. 
 *Rainfall Data (*.idf) (*.rtc) - File used to calculate rainfall. 
 *Drafting Notes (*.dft) – File used by InRoads drafting tools. 
 *Pay Items (*.mdb) – File used to calculate pay items and 

quantities. 
 Default Directory Paths. 

This section defines directory paths for loading and saving files inside 
InRoads. 

 Project Default Directory: - default location for opening, saving, 
importing, and exporting general files. 

 Projects (*.rwk) – default location of Project’s files. 
 Surfaces (*.dtm) – default location of Surface files. 
 Geometry Projects (*.alg) – default location of Geometry Project 

files. 
 *Typical Sections Libraries (*.tml) – default location of Typical 

Sections Library files. 
 *Roadway Libraries (*.rwl) – default location of Roadway Library 

files. 
 Survey Data (*.fwd) – default location of Survey Data files. 
 *Drainage (*.sdb) – default location of Drainage files. 
 Sheet Style (*.xsl) – default location of Sheet Style files for XML 

reports. 
 XML Data (*.xml) – default location of XML Data files. 
 *Quantity Manager (*.mdb) – default location of Quantity 

Manager Files. 

* Files and directories that do not impact survey applications. 
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Toolbars 
Toolbars can be opened and docked in the InRoads interface. Toolbars in 
InRoads Survey can be customized to fit the users workflow or personal 
preference. 

 From the pull-down menu, select Tools > Customize. The Customize 
dialog will appear. 
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Survey Toolbar 

 

 

 

Delete Survey Data 
Survey Data to Surface 

Survey Data to Geometry 
Inverse Survey Data

Transform 
Survey Data 

Open Fieldbook 
Open Feature Table 

Active Survey Lock 
Open Survey Feature Filter 
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View Survey Data Toolbar 

 

 

Planimetrics
Symbols

Names
Codes

Elevations
Errors

Notes 
Networks 

Refresh View 

Regenerate Graphics 
Fit View 

Find Point in View

Write Survey  
Data to Graphics 



 Chapter 1 -Getting Started with InRoads Survey 

 

 

Locks Toolbar 

 

 

 

Docked Toolbars 

  

Locate Graphics/Features

Snap Element/Point/No 
Station Lock 

Report Lock 

Feature Filter List
Feature Filter Lock 

Style Lock 
Pen/Pencil Mode

Delete Ink Lock

Write Lock Toggle 

Locks

View Survey Data

Survey 
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Survey Options - General Tab 
Survey Options dialog controls additional settings required by Survey.  The 
Survey options can be modified by the user and are stored as an FXP file.  Some 
of the main aspects of this dialog are the control of planimetric scale and the 
Fieldbook Audit Trail file which tracks changes to the fieldbook and features 
table. 

 From the pull-down menu, select Tools > Survey Options [General].  

 

Dialog Items 
 Chord Height: Controls the curve stroking of elements when saved to 

graphics, surfaces, and alignments.  The smaller the value, the greater 
number of vertices generated. 

 Point Seed: Seed number used when adding points to the survey 
fieldbook. 

 Figure Seed: Seed number used when saving linear planimetrics to a 
geometry project. 

 Cell Scale: Scale factor used when writing survey feature Cells to 
graphics. 

 Text Scale: Scale factor used when writing survey feature Text to 
graphics. 

 Line Scale: Scale factor used when writing survey feature Line Styles to 
graphics. 
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 Fieldbook Audit Trail File Name: Text file that saves all edits from the 
fieldbook and feature table.  The file will show the edits Before and 
After. 

 File Options 
 Resolve Code Errors – If checked, all code errors found while 

importing will be taken care of by the Resolve Code Error dialog. 
 Log Code Errors – Will open the Results dialog at the end of the 

import allowing the errors to be saved to a text file. 
 Save Computed Coordinates – If checked, any computed 

coordinates will be saved to the fieldbook as individual points. 
 Add/Edit Audit Trail – If checked, displays the Results dialog 

after each edit is made.  Even with it unchecked the file will still 
keep track of edits. 

 View Options 
 Automatic Refresh – If checked, will regenerate the displayed 

graphics after each edit. 
 Segregate Text by Feature Level – If checked, will save the 

symbols, point names, codes, notes, errors, and elevations to the 
same level as the survey feature. 

 Planimetric Settings 
 Use Custom Operations – If checked, all Custom Operations 

from the Survey Feature Table will be displayed. 
 Use Symbols – If checked, all symbols from the Survey Feature 

table will be displayed. 
 Use Cells – If checked, all Cells from the Survey Feature table will 

be displayed. 
 Include Custom Operations, Symbols and Cells in Single Cell – 

If checked, all items will be combined into a single cell called 
NULL. 

 Attach Default Tags – If checked, a default InRoads tag will be 
defined and attached to the MicroStation graphic when written to a 
design file. 

 Attach Attribute Tags – If checked, a tag, with attribute 
information and values will be attached to the MicroStation 
graphic when written to a design file. 
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Survey Options - Units Tab 
Survey Options Units tab controls how raw, linear, and angular, survey data is 
read by the Fieldbook.  The Survey units set in this dialog box have priority over 
InRoads units options set elsewhere when processing or manipulating Survey 
data. 

From the pull-down menu, select Tools > Survey Options > [Units]. 
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Survey Options - Symbology Tab 
Survey Options Symbology tab controls view planimetrics such as Symbols, 
Point Names, Codes, Elevations, Errors, and Notes.  There are two types of 
settings for each planimetric display.  For the dynamic display of graphics the 
settings are opened with the Edit View button.  For the design graphics written 
to the file the settings are opened with the Edit button. 

 From the pull-down menu, select Tools > Survey Options > 
[Symbology].  
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Lab 1: Getting Started in InRoads Survey 

Objectives Lab1 
After completing this exercise you will know how to: 

 Create a new design file for use with Topo collection. 
 Verify the correct MicroStation resources are in place for topo data 

reduction and exporting. 

1. From the CDOT Select Group Environment V3.01 dialog select  
xxMulti-Discipline 

 

2. <D> the OK button.  The dialog will close and the Workspace will be set. 

Note:  By following these steps the correct MicroStation resources, such 
as the level and cell definitions have been defined. 

3. Double-click on the InRoads Survey desktop button    or select  
Start > All Programs > Bentley Civil Engineering > Bentley InRoads 
Survey.  
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4. In the MicroStation Manager dialog go to the Workspace group section 
and change 
User: CDOT User 
Project: 12345 
Interface: CDOT 

  

In this class, the project name 12345 will be used as the 5 digit project code.This 
workspace setup will load the most current CDOT MicroStation environment. 
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5.  In the MicroStation Manager dialog path to the directory:  
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\ 

6. Select the file 12345SurveyTopo##Scale##.dgn from the MicroStation 
Manager dialog. 

 

Note:  The purpose of the files with “##” symbols are for creating new 
files with the correct naming convention. 

7. <D> OK the MicroStation Manager dialog will close and open the file. 

Note:  Be patient, MicroStation will first load the DGN file and will 
work as the CAD engine.  InRoads Survey will then load and will 
run on top of MicroStation. 

8. Once both programs are loaded the Tip of the Day dialog may open 
containing a different tip each time the program is started.  To suppress 
this dialog in the future uncheck Show Tips on Startup.  To access the 
Tip of the Day dialog in the future, select Help > Tip of the Day 

9. <D> the Close button on the Tip of the Day dialog. 
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10. From the MicroStation pull-down  menu  File > Save As The Save As 
dialog will appear. 

11. Path to the folder C:\Projects\12345\ROW_Survey\Working 

 

12. Replace the ## symbols with 100 scale and 01 model.  
Type in Files: 12345SurveyTopo100Scale01.dgn 

 

13. <D> the OK button the Save As dialog will close and MicroStation will 
open the file 12345SurveyTopo100Scale01.dgn 

Note:  As shown at the beginning of this lab the steps for selecting the 
appropriate Group defined what MicroStation resources will be 
loaded.  Before proceeding in InRoads, the level definition files 
Topo.dgnlib and ROW.dgnlib need to be attached. 
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14. From the MicroStation pull-down menu, select:  
Settings > Level > Manager.  The Level Manager dialog will appear.  
Look for [Topo] and [ROW] in the Level Name. 

 You can also use the Level Manager button from the Primary 
Toolbar to open the Level Manager dialog. 

 

 

 If one of the DGN libraries is not loaded close MicroStation and 
use the Select Group Environment utility to select the  
xxxMulti-Discipline environment. 

15. Close the Level Manager dialog. 
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16. Verify that the cell library CDOT-Topo cells.cel is attached.  From the 
MicroStation pull-down menu, select Element > Cells the Cell Library 
dialog box will appear. 

 You can also use the Cell Library button from the Primary 
Toolbar to open the Cell Library dialog.  

 

 

17. From the Cell Library dialog select the File pull down menu and pick 
Topo.cel from the list of cell libraries. 

 If the Topo cell library is not loaded close MicroStation and use 
the Select Group Environment utility to select the  
xxxMulti-Discipline environment. 

18. Close the Cell Library dialog. 

19. From the Main MicroStation pull-down menu, select  
File > Save Settings 

Note:  From this point forward, unless specifically instructed to use 
MicroStation commands, all references to the selection of 
buttons, tools, or menu pull-downs refer to the InRoads interface. 
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Lab 2: Setting Project Defaults 
Setting default directories and resource files provides the user with quick access 
to project folders for opening files and then saving them to the correct location.  
It also ensures the correct CDOT InRoads resource files will be used. 

Objectives Lab 2 
After completing this exercise you will know how to: 

 Copy and create a new Project Default. 
 Import and export Project Default settings. 

1. From the InRoads pulldown select File > Project Defaults the Set 
Project Defaults dialog will appear. 
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2. <D> the Import button.  The Open dialog will appear. 

3.  Path to the folder C:\Projects\12345\Project_Configuration 

4. Select the file CDOT_Disciplines_V3_01.reg  

5. <D> the Open button.  The Open dialog will close and default project 
settings are imported. 
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6. From the drop down list Configuration Name select the discipline  
CDOT ROW_Survey Discipline 

 

Note:  The Default Directory Paths that are left blank are files that are 
not used by InRoads Survey. 

7. <D> the Apply button. 

Note:  The settings that have been created are stored in the Windows 
registry on your PC. To share this Project Default setup with 
other project staff export to a Registry file (REG). 

8. <D> the Close button on the Set Project Defaults dialog. 
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9. Select the Survey and then the Preferences tab on the Workspace bar 
and verify that the correct InRoads Project resource files are now loaded. 
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Lab 3: Toolbars 
Toolbars can be added from the pull-down menus.  All InRoads Survey toolbars 
can be customized to fit your workflow or personal preferences. Start by 
opening Toolbars that will be used in class. 

Objectives Lab 3 
After completing this exercise you will know how to: 

 Open an InRoads Survey toolbar. 
 Dock, undock, and resize toolbars. 

1. From the pull-down menu select Tools > Customize. The Customize 
dialog will appear. 

 

2. Under the Toolbars tab check that the boxes for Locks, Survey, and 
View Survey Data are selected.  The toolbars will appear. 

3. <D> the Close button.  
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4. Dock, Undock, and Resize the toolbars to become comfortable with the 
procedure.  Notice how you cannot dock the toolbars into the 
MicroStation environment. 

  

5. From the pull-down menu, select Survey > View Survey Data look at 
each command and the image to the left; now look at the View Survey 
Toolbar.  Notice the correlation of the graphics.   

 This should help with recognizing button graphics more quickly. 

   

6. Move your cursor over a button and hover. A Tool Tip will appear at the 
lower right of your cursor.   

 This feature is controlled in the Customize dialog box Show Tool 
Tips checkbox and is turned on by default. 

 

Locks 

View Survey Data

Survey 
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Lab 4:  InRoads Survey Options - Overview 
The Survey Options dialog contains added preferences specific to the Survey 
commands.  The file loaded from the Project Defaults Dialog is 
CDOT-Survey_Preferences.fxp 

Objectives Lab 4 
After completing this exercise you will know how to: 

 Create an Audit Trail file. 
 Setup up the Survey Options General tab. 

1. From the pull-down menu, select Tools > Survey Options the 
Survey Options dialog will appear. 

 

The first setting to look at will be the Audit Trail.  The Audit Trail is useful for 
keeping track of any changes made to the Survey Fieldbook or Survey Feature 
Table. 

2. Under the General tab move your cursor to the Fieldbook Audit Trail 
File Name: field and <D>.  The Browse  button will become active. 
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3. <D> the Browse  button.  The Save dialog will appear.  Verify the 
correct directory. 
C:\Projects\12345\ROW_Survey\InRoads \Field_Books 

 

4. Key in ”UserInitials”_FieldBookEdits 

5. <D> the Save button.  The Save dialog will close. 

6. Check the box Add/Edit Audit Trail in the File Options section.  All 
edits made will now be saved to the RBM_FieldBookEdits.log file. 

  

Note:  The Log file is a text file that can be opened and printed from 
Notepad. 
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7. <D> on the Units tab. Take a minute to review the settings and verify 
they are the same as the dialog below. 

 

8. <D> on and review the tabs Symbology, Corrections, and Observation 
Standard Deviation. 

9. From the Survey Options dialog <D> the Save then OK button. 

Note: The setup will not need to be done each time InRoads Survey is 
started.  To demonstrate that, Exit out of the program. 

10. From the InRoads Survey pull-down menu, select File > Exit.  Nothing 
should need to be saved.  If InRoads asks to save a file choose No. 

11. From the MicroStation pull-down menu, select  
File > Save Settings. This will ensure when the file is opened in the next 
lab the cell library will be attached and view settings saved. 

12. From the MicroStation pull-down menu, select File > Exit.  By default 
MicroStation is always saving the design file so there is no reason to 
save the file.  This will exit completely out of MicroStation. 
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Chapter 2 Working with InRoads Survey – Overview 

Fieldbook Data dialog 
The Fieldbook Data dialog in InRoads Survey allows the user to manage survey 
data.  In addition to viewing the station and observations, the dialog allows editing 
and adding points to the fieldbook. 

 From the pull-down menu, select Survey > Fieldbook Data… 
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Dialog Items 

  Survey Options - opens the Survey Options dialog box. 

 

  Survey Feature Filter - opens the Survey Feature Filter dialog box. 
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  Report - opens the Save dialog box to generate a report. 

Note:  The report is generated based on what stations/observations are 
selected prior to clicking the report button.  To generate a report 
on the entire fieldbook select all the Stations in the fieldbook 
then click the Report button. 

  Find/Replace Codes - opens the Point Code Find and Replace 
dialog box. 

 

  Select Figure – will only locate the nearest planimetric feature or 
chainage.  The fieldbook will highlight the start of the chainage.  

 Duplicates – filters only duplicate points found in the Stations or 
Observations.  To view duplicate points select it from the drop down 
box. 

Duplicate Points General Rules: 

Rule # 1 
If a Point Name is duplicated in a Station Setup then the two points are 
averaged. 

Station 764 

Observation 2000 

Observation 2000 

Observation 2001 

Observation 2002 
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Rule #2 
If a Point Name is duplicated in two different Station Setups the points are not 
averaged and each point is used. 

Station 764 

Observation 2000 

Observation 2001 

Observation 2002 

Station 766 

Observation 2000 

Observation 3001 

Observation 3002 

Note:  For more information on how duplicate points are handled in 
InRoads Survey select the Help    button.  
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Stations 
The top half of the dialog is the Stations or Instrument setup point. 

Chainage 
Chainage commands are a useful way to locate displayed planimetric features.    
Use the buttons First  ,  Previous  ,  Next  ,  and Last   to 
conveniently follow a chain. 

Observations 
The bottom half of the dialog is the Observations or topo shots from the 
corresponding instrument setup. 

 

Stations

Observations

Chainage 
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Lab 5 Opening Survey Data 
Start by viewing a survey fieldbook that is already complete. 

Objectives Lab 5 
After completing this exercise you will know how to: 

 Open a MicroStation file. 
 Open an existing Survey Fieldbook. 

1. Double-click on the InRoads Survey desktop button    or select Start 
> All Programs > Bentley Civil Engineering > Bentley InRoads 
Survey.  

2. In the MicroStation Manager dialog go to the Workspace group section 
and change 
User: CDOT User 
Project: 12345 
Interface: CDOT 
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3. From the Working folder select the file 
12345SurveyTopo100Scale01.dgn 

4. <D> the OK button or double click the filename. 

5. From the InRoads Survey pull-down File > Open.  The Open dialog will 
appear. 

 

6. From the Open dialog change the Files of Type to Survey Data (*.fwd). 

 

Note: Notice how the directory folder changed to Field_Books when the 
Files of type changed.  This is one of the benefits of setting up 
the Project Defaults for each discipline. 

7. Select the file 12345SURVFieldbook01.fwd 

8. <D> the Open then Cancel buttons. 

Note:  InRoads is Memory based, not Disk based. The file(s) in the 
Workspace pane are copies from the disk drive and reside in the 
computer’s memory. Any changes to these data files (or creation 
of new data files) requires them to be saved back to the disk 
drive. 
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CAD vs. Fieldbook Viewing 
Take a look at the InRoads Survey interface; notice the two files loaded in the 
Survey tab.  The file with the red box around the button is the active file.  Any 
commands that are selected will use the active file. 

Objectives 
After completing this exercise you will know how to: 

 View a fieldbook in the Survey Information Window 
 View the survey data in the MicroStation view. 
 Fit the Survey data in a MicroStation view. 
 Use the shortcut menus in the Interface. 

 

 

9. Use your cursor and <D> on the default Survey fieldbook Book 1.  
Notice how the red box moved to Book 1 

10. Now use your cursor and <D> on 12345SURVFieldbook01 and make 
that the active book again. 



 Chapter 2–Working with InRoads Survey- Overview 

  

 

11. Fit the survey data to the view from the pull-down Survey > Fit View. 

 

 

12. Use the MicroStation viewing tools to zoom to the west end of the 
project. 

 

Windowed Area 
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13. Investigate the viewing options of the Survey data.  From the pull-down 
menu toggle the display on and off for 
Survey > View Survey Data > Planimetrics 
Survey > View Survey Data > Symbols 
Survey > View Survey Data > Names 
Survey > View Survey Data > Codes 
Survey > View Survey Data > Elevations 
Survey > View Survey Data > Errors 
Survey > View Survey Data > Notes 
Survey > View Survey Data > Networks. 
  Ignore Write Survey Data to Graphics for now. 

 

                                                                  Symbols                                           Names 

 

                                                                Codes                                                 Notes 

14. Also practice viewing different combinations of data using the View 
Survey toolbar.  Ignore Write Survey Data to Graphics for now. 

 

Note:  The survey data that is viewed is dynamic.  Nothing is actually in 
the MicroStation design file.  Control of the size of the dynamic 
text for Point Name, Elevation, and Code etc. from the Survey 
Options Text Symbology tab. 
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15. From the pulldown menu Survey > Find Point in View the Find Point in 
View dialog will appear. 

16. Type in the field Point Name: 3686 Radius: 50 

 

17. <D> the Apply button.  The MicroStation view is updated and zoomed 
into point number 3686. 

18. <D> the Close button in the Find Point in View dialog. 

19. Toggle on View Planimetrics, View Symbols, View Codes and View 
Elevations. 
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20. From the pull-down menu, select Tools > Survey Options the Survey 
Options dialog will appear. 

21. Select the Symbology tab. 

 

22. In the Survey Options dialog select the Text Point Elevations 

23. In the Precision drop down list select .123.  Then select the Save button.  
The elevations will update in the MicroStation view. 

24. Review your results. 
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25. Set the Elevation precision back to .12 

 

26. <D> the Save and OK buttons.  The Survey Options dialog will close. 
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27. Use the MicroStation view commands    to zoom in, out, 
and pan the view. 

 

Note:  Notice how the text changes size and remains legible based upon 
the zoom ratio. 

28. <D> MicroStation Fit View.  In the lower left hand corner of 
MicroStation the status bar states No Elements Found.  

Note:  MicroStation Fit View command does not work because graphics 
displayed are dynamic graphics, not graphics written to the 
CADD file.  

29. From the pull-down menu, select Survey > Fit View or use Fit View 
button    from the View Survey toolbar. 

30. Continue to Pan, Zoom and Fit the survey data until it is comfortable.   

31. Continue to toggle Survey display data on and off as needed. 
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32. Explore the InRoads interface.  <D> the “+” (expand) button next to the 
Survey data 12345SURVFieldbook01.fwd.   

33. The workspace bar will display the Station names. Select the Station 
name at the top CO RD 33. When the Station name is selected the 
Observations from that Station will display in the Information Window 
pane. 

  

 
 

34. Continue to explore the 12345SURVFieldbook01 Survey Data.  
Experiment right clicking in the different areas of the interface to find 
different useful shortcut menus.  

   

Observations 
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Lab 7 Viewing the Fieldbook Data 
Open and explore some of the basic features of the electronic fieldbook.  The 
Fieldbook will be covered in greater detail later in the manual. 

Objectives Lab 7 
After completing this exercise you will know how to: 

 Open the Fieldbook dialog. 
 Find points in the Fieldbook dialog. 
 Use the shortcut menus in the Fieldbook dialog. 
 Use the Select Figure button. 
 Use the chainage tool in the Fieldbook dialog. 

1. <D> the Fieldbook    button from the Survey toolbar.  The Survey 
Fieldbook will appear. 

 

 

2. Take a minute to review the electronic Fieldbook. 
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3. In the column headers of the Stations <R> on the Station Name.  The 
Fieldbook Custom View dialog will appear. 

 

Note:  This dialog allows the order of the columns to be customized in 
the Fieldbook. 

4. In the Mode section of the dialog <D>on the Observation radio button. 

5. Select Target Height in the Selected: section on the right side. 

 

6. <D> the Move Up button until Target Height rests under the Code. 

 

7. <D> the OK button.  The Fieldbook Custom View dialog will close. 
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8. Resize the Fieldbook so the column change for Target Height is in the 
view. 

 

9. From the View Survey toolbar turn on only View Planimetrics   , 
View Symbols  , and View Names  .  Turn off all other View 
Survey Data commands. 

10. Select Station Name CO RD 33 in the top half of the Fieldbook Data 
dialog.  Notice that the bottom half of the dialog updated with the 
observations collected from that instrument setup. 
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11. Select Point Name 2222 in the bottom half of the Fieldbook Data 
dialog. 

 Use dialog scroll bars or 
 Intelli-mouse wheel or 
 Page Up or Page Down keys or 
 Up or Down arrow keys 

 

12. Right click on Point Name 2222 to access the shortcut menu.  Select 
Center from the available list.  Look in your MicroStation view Point 
Name 2222 is centered in view 1. 

Note:  Center only centers the point to the active view zoom ratio.  It 
may be necessary to zoom in closer and re-center from the 
shortcut menu. 

Added Practice 

 Find and Center Station Setup GAP 27_33  
Point Name 107 

 Find and Center Station Setup Found monuments  
Point Name 1088_2 
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13. From the pulldown menu Survey > Find Point in View the Find Point in 
View dialog will appear. 

14. Type n the field Point Name: 2336 Radius: 50 

 

15. <D> the Apply button.  The MicroStation view is updated and zoomed 
into point number 2336. 

16. <D> the Close button in the Find Point in View dialog. 
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17. From the Fieldbook Data dialog <D> the Select Figure button.  The 
Fieldbook Data dialog will contract allowing more screen space to make 
a selection. 

 

18. Select <D> at the start of the fence line.  The Fieldbook Data dialog will 
expand with point name 2336 selected. 

 

Click Here 
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19. In the Fieldbook Data dialog <R> point name 2336 to access the 
shortcut menu and select Highlight Observations.  Notice at the start of 
the line segment the Box-X in MicroStation View 1. 

 

Note:  In the middle of the Fieldbook Data dialog there is an option to 
follow a chainage.  A chainage is a good way to follow a 
planimetric feature in the fieldbook and in the view. 
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20. Use the chainage buttons  
First    Previous    Next    and Last   to follow the fence line 
chain.  Notice the Highlighted Box-X that follows each point along the 
chain.  As the point continues outside the current view the point becomes 
centered in the MicroStation view. 

21. When the end of the chainage is reached <D> the OK button. 

 

Added practice 

From the west end of the project. 

 Follow the chainage for a code 1310 Edge of Oil 
 Follow the chainage for a code 6001 Terrain Breakline 

Note: When having difficulty locating any chains try selecting the line 
segment instead of the start or end points. 
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22. Close the Fieldbook Data dialog by clicking the X in the upper right 
hand corner of the dialog. 
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Chapter 3 Feature Codes and Control Codes 
The Survey Feature Table (FWF) file controls how a feature is displayed in the 
design file, written to a DTM, or exported to Geometry.   
There are two main types of graphic displays: lines and cells. Additionally, there 
are a few codes that place text through the use of Custom Operations. The Feature 
table also controls the associated symbology for the graphics such as level, color, 
style, and weight. 

Extensive effort has been made to ensure the correct symbology is used in the 
Feature table. Changes to the Feature table file will be made only by the CDOT 
CADD Manager. Any suggested changes should be submitted to the CADD 
Manager. 
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Feature Table dialog 
The Survey Feature Table controls how each surveyed feature is displayed 
graphically.  Each feature in the Feature Table can be displayed as Lines, Cells, 
Text, or Symbols.  The feature definitions have been standardized by CDOT and 
should only be modified by the CADD manager. 

 From the pull-down menu, select  
Survey > Feature Table…[Feature Styles] 
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Feature Styles 

Dialog Items: 

  Add Feature – opens the Feature Add dialog. 

 

  Delete Feature – deletes a selected feature. 
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  Edit Feature – opens the Feature Edit dialog for the highlighted 
feature. 

 

  Copy Feature – opens the Copy Feature Style dialog.  Prior to 
selecting the button, select the feature to be copied  

 



 Chapter 3–Feature Codes and Control Codes - Overview 

  

 

  Find Feature – opens the Find Feature dialog.  Find Feature dialog 
can quickly find an exact feature based on a specific value. 

  

 Alpha Code 
 Feature Definition 
 Numeric Code 

  Show Active Codes Only – will display only codes that are currently 
found in the active fieldbook. 
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Show Feature Styles with Properties 

 

 Place a Cell at the Point 
Filters to show only the codes using cells for planimetrics. 

 Place Symbol at Point 
Filters to show only the codes using symbols for planimetrics. 

 Attributes 
Filters to show only the codes using attributes for data collection. 

 Custom Operations 
Filters to show only the codes using custom operations in the 
feature definition. 

 Attach Tag 
Filters to show only the codes attaching tags or non graphical data 
to the feature definition. 
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Feature Table Name and List 

 

 Gray or dithered text represents codes not currently used in the 
active fieldbook. 

 Black or bold text represents codes used in the active fieldbook. 
 Column headers can be sorted ascending or descending by 

selecting the column title. Columns can also be resized using the 
vertical bar separating the titles. 

Feature Table Name

Feature Table List
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Reports 

  Report – opens the Feature Table Report dialog.  This 
dialog can generate a report based on the list portion of the dialog. 
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Feature Edit 
The Feature Edit dialog controls the symbology of each survey shot collected in 
the field.  Each feature can have only one numeric code; options settings define 
whether a line or a cell is placed at the point.  Additional information can be 
added using the Attributes and Custom Operations tabs. 

 

Feature Edit Dialog Items 
 Definition 

Description of the surveyed feature, both Alpha and Numeric characters 
are allowed.  The Survey Definition is used as the description when 
saved as a Surface and Geometry project. 

 Numeric Code 

Associates a numeric code with the Survey Feature Style.  The numeric 
code can not be reused in the same Feature Table. 



Colorado Department of Transportation   

 

Page 72  InRoads Survey 

 Point Type 
 Random 

Regular or spot elevations.   These points do not have a direct 
relationship with adjoining points other than a linear interpolation. 
For example: high or low elevations, topography shots such as 
trees, valves, signs, etc. 

 Breakline 
Breaklines are comprised of linear features where a change in 
grade may occur. For example: curb lines, a roadway crown, edge 
of pavement, ditches, ridges, toe of slope, etc.  
A breakline must contain at least 2 points and will restrict 
triangulation from crossing.  

 Interior 
Interior boundaries are comprised of a closed shape. They define 
obscure areas (voids) in a surface model.  Triangulation does not 
occur inside interior boundaries thereby eliminating any 
contouring, surface modeling, or volume computations within said 
interior feature. Multiple interior boundaries can exist in a surface 
model. 
For Example: Bodies of water, building pads, areas not surveyed, 
etc. 

 Exterior 
By definition, an exterior boundary must be a closed shape. It 
defines the limits of the data InRoads can work with.  Only one 
exterior boundary can exist in a surface model.   
For example: limits of survey data or limits of slope intercepts for 
a new design. 

 DNC ( Do Not Contour) 
DNC shots will collect the X,Y, and Z position of the feature but 
when it comes time for InRoads to triangulate the DTM the DNC 
points will be left out.  Think of underground utilities or a shot on 
the top nut of a hydrant.  If these shots were part of the 
triangulation there would be incorrect valleys and spikes in the 
DTM. 
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 Style 
When saving Survey features to a Surface or Geometry project a named 
Feature Style is associated during the export.  This style corresponds to a 
Named Symbology in the Preference INI file. 

 Alpha Code 
Alpha codes are used as an additional way to collect the survey data in 
the field.  Alpha feature codes are not to be used as part of the CDOT 
collection. 

 Draw Line to Previous Same Code 
Controls planimetric line work for the specific feature.  This option is 
used in conjunction with the control code ST. 

 Draw Connecting Line 
Controls planimetric line work for the specific feature.  This option is 
used in conjunction with the control codes JPT, JNC, and – (dash). 

 Place a Cell at the Point 
Controls the planimetric placement of cells for features.  The symbology 
and cell name is controlled in the Symbology Section for Cell. 

 Scale Cell to Ground 
Overrides all scale factors for cell placement to a value of 1. 

 Attach Tag 
Attaches a MicroStation tag value to the feature when written to the 
design value, such as DTM type, Point name, Preference, and 
Description.  To review attached tags use the Review Tags button from 
the Main toolbar in MicroStation. 
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 Symbology Line 
Controls the Level, Color, Style, and weight of lines or arcs for each 
feature written to graphics.  To modify the symbology highlight the 
symbology Line and <D> the Edit button. 

 

 Symbology Text 
Controls the symbology, text size, and font for any text displayed with 
custom operations.  To modify the symbology highlight the symbology 
Text and <D> the Edit button. 

 



 Chapter 3–Feature Codes and Control Codes - Overview 

  

 

 Symbology Cell 
Controls the cell name, size, rotation, and symbology for placement.  To 
modify the symbology highlight the symbology Cell <D> the Edit button. 

 

 Symbology Symbol 
A symbol is a custom font character, similar to a True Type Font 
Wingdings.  Symbols can be used in addition to any cells being placed.  
CDOT does not currently use any Symbols.  The font, size and 
symbology can be controlled.  To modify the symbology highlight the 
symbology Symbol <D> the Edit button. 
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Attributes tab 
Attributes are used to help further define or control survey features in the field.  
Attributes can be collected in numeric or alpha data.  As an example, additional 
information such as size, flow, and silt levels in a culvert pipe can be added to a 
single shot in the field.  Any Attributes that do not have any field information 
will be viewed in the fieldbook as a status “A”.  Attributes that have a value will 
show up in the fieldbook with a status “V”. 

 

As shown above they can also help control placement of a cell by 
defining the rotation. 
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 Add 

Opens the Add Attribute dialog that can create Alpha and Numeric 
Attributes.  One survey feature can have more than one Attribute.  Alpha 
Attributes can store both alpha and numeric data such as “MH1024”.  
Numeric Attributes can store only numeric data such as “1024”. 

 

 Delete 

Deletes the selected attribute from the list.   

Note:  There is no modify or edit command when working with 
Attributes.  In order to make a change delete and recreate the 
attribute. 
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Custom Operations tab 
Custom operations can be thought of as a script file or a list of commands that 
should be run on a certain survey feature.  It can be used to control graphic 
types, symbology, text, placement, and run math functions.  Use MicroStation 
and InRoads key-ins to enter commands right into the dialog.  There is also the 
option to Copy and Paste from other sources.  To view examples of custom 
operations <D> the Help button. 
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Control Codes 
Control Codes tab in the Feature Table dialog lists the codes that work with 
survey planimetric lines, arcs, and shapes.  There are additional control codes 
that work with survey shots and triangulation in a digital terrain model.  Each 
code has an example below. 
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Intersection Control Code example 
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 Start 

Alpha ST | Numeric 1 

Control Code Start begins planimetric lines; there is no code for end.  To 
end a line, restart the figure and the previous line will discontinue. See 
the example below for feature code 1316.02. 
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 Close 

Alpha CL | Numeric 2 

Control Code Close will create a closed shape from the last shot to the 
first shot of the feature.  Closed shapes in InRoads can be used as Interior 
or Exterior DTM point types.  Closed shapes in MicroStation will 
become linestrings. 

 

 

Note: Only a survey feature with a point type Breakline will honor the 
Close control code when it is pushed to a surface. 
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 Point of Curvature 

Alpha BC | Numeric 3 

Control Code Point of Curvature identifies the beginning of the curve.  
The incoming tangent of the curve controls the degree of curve. 

 Point of Tangency 

Alpha EC | Numeric 4 

Control code Point of Tangency identifies the end of the curve.  The 
outgoing tangent of the curve controls the degree of curve 

 

Note:  If a single point on arc is taken then the tangent lines are ignored 
and the curve is generated by the three points PC, POC, and PT. 

Note:  If more than one point is taken on the arc then the tangent lines 
are used when calculating the PC and PT of the curve.  CDOT 
has standardized using the control code NT non-tangent to 
follow all BC and EC shots.  Coding with NT will not add 
calculated PC’s and PT’s to the linear features.  The PC’s and 
PT’s will be observed points as in the field. 
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 Exclude from Triangulation 

Alpha X | Numeric 5 

Control code Exclude from Triangulation identifies points that will not 
(and should not) be used to generate surface contours.  Any point not 
resting on the terrain should be excluded from triangulation.  Points that 
are coded with “X” could include such items as fire hydrants, manhole 
inverts, benchmarks and control points, valve boxes, and other similar 
features. 

 



 Chapter 3–Feature Codes and Control Codes - Overview 

  

 

 Random 

Alpha RND | Numeric 6 

Control code Random overwrites DTM point types set in the Survey 
Feature table.  For example Breaklines become Random types and 
Do Not Contour point types become Random points Excluded from 
triangulation. 

 Rectangle 

Alpha RECT | Numeric None 

Control code Rectangle will draw a rectangle based on two points shot in 
the field and a measured distance.  The two points collected in the filed 
define the direction of the baseline and the measured distance defines the 
width.  The previous two points collected in the filed define the direction 
of the baseline.  To turn left of the baseline use a negative number (-15); 
to turn right of the baseline use a positive number (15).  Each added 
point using the Rectangle command will be considered a derived point in 
Survey. 

 

 
Note: Only a survey feature with a point type Breakline will honor the 

Rectangle control code when it is pushed to a surface. 
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 Close Rectangle 

Alpha CLR | Numeric 7 

Control code Close Rectangle will draw a trapezoid based on three points 
shot in the field.  The last two points become the baseline and the fourth 
point generated will be 90 degrees to the baseline. 

 

Note: Only a survey feature with a point type Breakline will honor the 
Close Rectangle control code when it is pushed to a surface. 
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 Nontangent Curve 

Alpha NT | Numeric 8 

Control code Nontangent Curve identifies a curve that will be nontangent 
to either the incoming or outgoing tangent lines.  This control code 
works in conjunction with BC or EC. 
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 Join Point 

Alpha JPT | Numeric None 

Control code Join Point will draw a connecting line to the specified point 
number in the fieldbook using the current feature style. 
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 Join Nearest Code 

Alpha JNC | Numeric None 

Control code Join Nearest Code will locate the closest code specified and 
draw a connecting line using the current feature style. 
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 Distance 

Alpha DIST | Numeric None 

Control code Distance will continue to draw lines based on measured 
distances and direction.  The previous two points collected in the filed 
will define the direction the next point will be calculated from. The angle 
will always be a 90 degree deflection angle, turned looking forward from 
the last point collected or calculated.  To turn left of the baseline use a 
negative number (-25) to turn right of the baseline use a positive number 
(10).  Each point using the Distance command will be considered a 
derived point in Survey and will also be used in calculation of DTM 
surfaces and ALG geometry alignments. 

Note: Attention should be paid to the elevations assigned by this method 
that the surface is only as good as this info is. There may be 
work-arounds for these instances, but if accurate info is needed, 
the effort should be made in the field to collect actual data. 

 

 

 

Note: Only a survey feature with a point type Breakline will honor the 
Distance control code when it is pushed to a surface. 
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 Template 

Alpha TMPL | Numeric None 

Control code Template defines multiple survey features that are uniform 
in distance and elevation from a baseline.  Using the template control 
code will lessen the number of shots needed in the field. 
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 Cross Section 

Alpha XS | Numeric None 

Control code Cross Section allows any uniform set of corridor shots to be 
collected efficiently.  Start by collecting the start of each new feature, 
and then continue to collect the shots in a crossing pattern. 

 

Note: When the raw data is imported into the field book it will convert 
the code XS to the correct feature code.   

 Add to Adjustment Set 

Alpha ADJ | Numeric None 

Control code Add to Adjustment Set defines a sideshot of an unknown 
point to be included to the adjustment set data. 
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Legend Options 
Legend option tab will generate a legend from the selected features in the list.  It 
will generate two columns.  The first column will represent the line, cell, text, or 
symbol placement and the second column will contain the corresponding 
description.  The Legend Option is not currently part of the CDOT workflow. 

 From the pull-down menu, select  
Survey > Feature Table…[Legend Options] 
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 Lab 8 Viewing Survey Feature Table 
The Survey Feature Table controls how the graphics are displayed on the screen.  
These settings are the CDOT standard changes should not be made to the file.  
However, it is a good to understand what controls the display of the survey data 
and how the data is interpreted.  

Objectives Lab 8 
After completing this exercise you will know how to: 

 Open the feature table dialog. 
 Find feature codes quickly using the Find Feature command. 
 Use the Show Active Codes Only command. 
 Use the Feature Styles with Properties option to narrow a lookup. 
 Review Custom Operations for a feature. 
 Review Control Codes settings. 

 

1. Launch InRoads Survey if it is not already; 

a. Open 12345SurveyTopo100Scale01.dgn from the 
Working folder. 

b. Open 12345SURVFieldbook01.fwd from the Field_Books 
folder. 

2. From the InRoads Survey pull-down menu, select  
Survey > Feature Table.  The Feature Table dialog will appear. 
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3. Take a minute to scroll through the list of survey codes.  Using the scroll 
bars on the side or using your roller on the mouse. 

 Scroll through the list notice how some of the features are bold.  
The bold features represent codes that are used in the current 
fieldbook. 

4. Move your cursor to the Feature Table and hold on the gray line in the 
gray title bar between Feature Definition and Alpha Code.  Your cursor 
will change appearance to a vertical line and arrows, allowing each 
column in the Feature Table to be resized.  

 

5. Move the cursor to the Feature Table and Select on the column heading 
Feature Definition.  This will resort all the definitions in ascending or 
descending order. 

 
 

Added practice 

 <D> on the Numeric Code column twice to sort the codes in 
ascending and descending order. 
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6. In the Feature Table dialog <D> the Find Feature button .  The Find 
Feature dialog will open.  This tool will quickly jump to the found code 
in the Feature Table. 

 

7. Change the Find By: drop-down box to Numeric Code. 

8. Key-in the known numeric code for Power Pole 4375 

9. <D> the Find Next button. The Feature Table will highlight numeric 
code 4375. 

 

Added practice 

 Find the Numeric Code: 3011 
 Find the Feature Definition: Flow Line of Stream-River 

10. <D> the Close button in the Find Feature dialog. 
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11. <D> the Show Active Codes Only button.  This toggle button will filter 
out all of the unused feature codes to efficiently view only the active 
codes. 

 

12. Review the points collected in the active fieldbook. 

13. Toggle off the Show Active Codes Only to see all the available codes 
again. 
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14. In the Show Feature Styles with Properties section check on Attributes. 
Notice how the feature list filters and displays only the survey features 
that have an attribute defined. 

 

15. Uncheck the Properties to see all the codes again before continuing. 
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16. Select the Control Codes tab and review.  Control Codes helps in the 
creation of planimetrics. 

 

17. <D> the Cancel button.  The Feature Table dialog will close not saving 
any changes. 
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Chapter 4 Exporting the Fieldbook – Overview 

Write Survey Data to Graphics dialog 
Writing Survey data to graphics creates the MicroStation design file (DGN) 
basemap.  Once the file has been saved to a MicroStation design file there no longer 
is a link between the InRoads Survey fieldbook and MicroStation graphics.  If there 
are changes that need to be made to the graphics, modify the InRoads Survey 
fieldbook and then re-export the graphics. 

 

Dialog Items: 
  Planimetrics – if checked Planimetrics such as lines, arcs, and cells 

will be saved to the design file 

  Symbols – if checked a tic mark representing the location of the shot 
will be saved to the design file. 

  Names – if checked the point name of the shot will be saved to the 
design file. 

  Codes - if checked the point code of the shot will be saved to the 
design file. 

  Elevations – if checked the point elevation of the shot will be saved 
to the design file. 

  Errors – if checked any errors in the fieldbook will be saved to the 
design file. 

  Notes – if checked any notes in the fieldbook will be saved to the 
design file. 

  Network – if checked any traverse legs will be saved to the design 
file. 

  Apply – will save the checked items to the design file 

  Filter- will allow the user to include or exclude any feature 
codes by a set of rules.  Only the feature codes that pass through the filter 
will be saved to the design file. 
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Note:  The symbology for Symbols, Points, Elevations, Notes, Errors, 
and Codes is controlled in the Survey Options dialog. 

Planarize 
 Elevation – if checked all points will place at a defined elevation. 

Curve Stroking Modes 
Curves generated from Survey are chorded arcs based on the Chord Height 
distance in the Survey Options dialog.  MicroStation will generate a number of 
small line segments to represent the arc.  There are three settings for generating 
arcs in 2D and 3D graphics. 

 Horizontal and Vertical 

The curve is created by multipoint splines in the x, y, and z directions.  In 
extreme variations in elevations unwanted sag or crest of a curve may 
occur. 

 Horizontal Only 

The curve is created by multipoint splines only in the x and y directions.  
The elevations or z values of the points are interpolated linearly between 
points. 

 Do Not Stroke 

The curve is not created.  It will be represented as linear elements 
between points. 
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Survey Data to Surface dialog 
Writing Survey data to surface creates the Digital Terrain Model (DTM).  Each 
feature is triangulated based on the Point type set in the Survey Feature Style.  The 
intelligence built in to the feature comes from the Preference Style setting in the 
Survey Feature Table. 

 

Dialog Items: 
 Surface Name 

Key-in field to create a new empty surface for export from survey.  If a 
surface has already been created, choose it from the dropdown arrow. 

 Description 

Each feature in the DTM will be unique.  When the feature is pushed to 
the DTM it will use one of the following options from the Feature table 
for the description. 

 Use Feature Definition 
 Use Attributes 
 Use Codes 

 Tolerance 

Tolerance will set the minimum distance between points.  If there are any 
points closer than the minimum, the points will be dropped from the 
surface.  If the value is set to 0 then tolerance is ignored and all points 
will be used in the surface. 

 Maximum Segment Length 

Maximum Segment Length defines the point density of an element.  If 
points were taken every 100 feet and the segment length was set to 25 
feet then the result would be three additional points used in the 
triangulation. 
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Curve Stroking Mode 
Curve Stroking Mode defines a curve horizontally and vertically.  Curves 
in InRoads are defined by short line segments from the Survey Options 
dialog Chord Height. 

 Horizontal and Vertical 
The curve is created by multipoint splines in the x, y, and z directions.  If 
extreme variations in elevations exist, unwanted sag or crest of a curve 
may occur. 

 Horizontal Only 
The curve is created by multipoint splines only in the x and y directions.  
The elevations or z values of the points are interpolated linearly between 
points. 

 Do Not Stroke 
The curve is not created.  It will be represented as linear elements 
between points 

Always Use: 
Defines what each feature style name will be in the surface.  CDOT has 
defined a Style for each survey feature that corresponds to an InRoads 
Feature Style.  By default if it is unchecked the feature style will be 
assigned in the following order. 

 Style – Preference Style name defined in the feature table. 
 Alpha Code 
 Numeric Code 

Triangulate Surface 
If checked the Triangulate Surface dialog will appear after the surface 
has been exported. 
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Triangulate Surface dialog 
This dialog will appear when check triangulate surface in the Survey to Surface 
dialog. Exporting Survey data to Surface without triangulating it will result with the 
data in the surface, but the triangle network will not exist yet. 

 

Dialog items: 
 Surface – drop down box shows the active surface by default, other 

surfaces selectable 
 View Triangles – displays the dynamic triangles in the MicroStation 

view as the surface is triangulated. 
 Extended Data Checks - checks DTM integrity (during triangulation) as 

to crossing breaklines and miss-matched elevations 
 Maximum Length - maximum length any one triangle segment (leg) can 

span during the triangulation process. If set to 0, triangle legs can extend 
to any length. Used to constrain triangulation to prevent unnecessary 
‘surface’ data. 

  Target button – define a distance by picking two points in a 
MicroStation view 
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 Load Tagged Graphics – scans the design file for any InRoads tagged 
data and loads the elements into the surface. 

 Delete Surface Contents – empties the surface prior to adding any 
tagged elements 

 Results – readout of triangulation outcome 

  More – opens the Surface Properties dialog 
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Multiple Feature coding and the DTM 
 Rule #1 Multicoded linear features to be triangulated 

Survey linear features that are also DTM point type breaklines will be 
moved to the Surface.  When duplicate points are triangulated, one will 
be dropped and will create a shared triangulation point. 

 

VIEW SURFACE FEATURES 
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 Rule #2 Multicoded linear features with random points to be triangulated 

Survey linear features and random points will be moved to the Surface.  
However, when duplicate points are triangulated the breakline will 
override and the random point will be dropped entirely from the surface. 

The only way to keep this from happening is to exclude the random point 
from triangulation with a control code “X”.  This will allow the feature to 
remain part of the surface. 

 

VIEW SURFACE FEATURES 
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 Rule #3 Multicoded linear features excluded from triangulation with 
random points to be triangulated 

Survey linear features that are excluded from triangulation and random 
point types will be moved to the Surface.  When duplicate points are 
triangulated the linear feature will remain and the random point will be 
used for triangulation. 

 

VIEW SURFACE FEATURES 
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Survey Data to Geometry dialog 
Saving Survey Data to Geometry creates a Geometry Project (ALG) which can 
contain multiple horizontal and vertical alignments from any planimetric linear 
feature.  Any single point such as property corners or trees will also be saved to 
the same Geometry Project and placed into the Cogo buffer. 

 

Dialog Items: 
 Project Name 

Key-in field to create a new empty Geometry Project for export from 
survey.  If a Geometry Project has already been created, choose it from 
the drop down arrow.  

 Description 

Each alignment in the Geometry Project will be unique.  When the 
alignment is pushed to the Geometry Project it will use one of the 
following options from the Feature table for its description. 

 Use Feature Definition 
 Use Attributes 
 Use Codes 

Curve Stroking 
Curve Stroking mode defines a curve horizontally and vertically.  Curves 
in InRoads are defined by short line segments from the Survey Options 
dialog Chord Height. 

 Horizontal and Vertical 
The curve is created by multipoint splines in the x, y, and z directions.  In 
extreme variations in elevations unwanted sag or crest of a curve may 
occur. 

 Horizontal Only 
The curve is created by multipoint splines only in the x and y directions.  
The elevations or z values of the points are interpolated linearly between 
points. 

 Do Not Stroke 
The curve is not created.  It will be represented as linear elements 
between points 
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Lab 9: Exporting Survey Data to Graphics Overview 
InRoads Survey can export the fieldbook in 3 different formats. These formats 
are CAD graphics, Surfaces, and Alignments.  Begin by exporting graphics to a 
MicroStation DGN file. This will create a basemap to be used and referenced by 
the designers. 

Objectives Lab 9 
After completing this exercise you will know: 

 What to modify in Survey Options prior to exporting. 
 How to export a Survey Fieldbook to a design file. 
 The difference between CAD and Fieldbook viewing. 
 How to work with Survey levels and level filters. 

 
 

1. Launch InRoads Survey if it is not already; 

a. Open 12345SurveyTopo100Scale01.dgn from the 
Working folder. 

b. Open 12345SURVFieldbook01.fwd from the Field_Books 
folder. 

2. Disable the display of any dynamic graphics shown on the screen. 
Toggle on View Planimetrics button   turn off any other symbols, 
names, codes, etc. that may have enabled. 

3. Verify the 12345SURVFieldbook01.fwd fieldbook is active.  The 
fieldbook that is active has the red box around the fieldbook button. 

4. To modify the scale as it relates to cells, text, and linestyles go to  
Tools > Survey Options > [General]. The Survey Options dialog will 
appear. 
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5. Set the Scales for Cell, Text, and Line as shown below. 

 Cell Scale:100 
 Text Scale:100 
 Line Scale:100 

 

6. <D> the Save then OK buttons.  The Survey Options dialog will close. 
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7. Once the settings are complete, to write the survey data to graphics, go to 
the pull-down Survey > View Survey Data > Write Survey Data to 
Graphics… the Write Survey Data to Graphics dialog will open. 

 

Note:  By default if having any dynamic graphics still toggled on, those 
same components would be toggled on in the Write Survey Data 
to Graphics dialog. 

8. Set Curve Stroking: Horizontal Only 

9. <D> the Apply button. The graphics will be created in the design file. 

10. Watch the Status Bar as the graphics are written to the design file. 

11. <D> the Close button in the Write Survey Data to Graphics dialog.  

12. Toggle off all View Survey buttons. 
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13. From the InRoads Survey pull-down  
Survey > Find a Point in a View the Find a Point in a View dialog will 
appear. 

 

14. Key-in Point Name: 2336 

15. Key-in Radius: 50 

16. <D> the Apply button.  The MicroStation view will center to shot 
number 2336. 

 

Note: The graphics displayed are MicroStation elements written to the 
design file.  The graphics become independent from the survey 
data.  There is no linkage from the MicroStation graphics back to 
the survey data.  Therefore it is important to remember that if 
changes to the survey data are made, the survey data will need to 
be rewritten to the CAD file after editing. 
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17. To demonstrate this concept, use MicroStation tools to manipulate the 
displayed survey graphics. 

18. Delete, move, or otherwise modify the on-screen graphics. 

19. Review the survey fieldbook    to verify data integrity. 

20. Toggle on dynamic display of Planimetrics   . Notice the location of 
the fieldbook data vs. the modified MicroStation graphics. 

 

21. Toggle off dynamic display of Planimetrics   . 

22. From the MicroStation Primary Tools toolbar <D> the Level Display 
dialog.  The Level Display dialog will appear. 
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23. From the filters pull-down select the Topo > Fence filter. 

 

24. Practice turning ON and OFF the fence levels in MicroStation. 
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25. From the filters pull-down select the Topo filter.  This will help when 
viewing only the levels that pertain to the survey data. 

 

Added practice: 

 Sort the Name, Number, and Used columns by clicking on them. 
 Right click on the level names to view the level popup options. 

Practice using these shortcuts. 

26. Close the Level Display dialog. 
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Lab 10: Exporting Survey Data to Surface Overview 
Exporting to a surface DTM will create a triangulation network used for 
displaying contours, features and spot elevations. 

Objectives Lab 10 
After completing this exercise you will know: 

 How to export a Survey Fieldbook to a Surface DTM file. 
 How to triangulate a surface. 
 How to set surface property for display. 
 How to save a Surface. 

1. Verify the 12345SURVFieldbook01 fieldbook is active. The active 
fieldbook will have a red box around the fieldbook button. 

2. From the pull-down menu, select File > New.  The New dialog will 
appear. 

3. Select the Surface tab. 

4. Key in the surface Name: 12345SURVSurface01 

5. Key in the Description: CDOT Surface Overview Training 

Note:  Key in any additional file information in the Description field of 
the dialog, such as Date, User, and Design file name. There are 
up to 64 characters available in the Description field. 

6. Keep the Maximum Length set to 0.00 

7. Set Preferences: Existing 10’ Mjr – 2’ Minor 

 

8. <D> the Apply then Close buttons. 
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9. From the pulldown menu Survey > Survey Data to Surface.  The 
Survey Data to Surface dialog will appear. 

 

10. Pick 12345SURVSurface01 in the Surface Name field. 

11. Set the Description to Use Feature Definition 

12. Keep the Tolerance and Maximum Segment Length set to 0.00 

13. Set the Curve Stroking Mode to Horizontal Only 

14. Check Always Use: Style 

15. Check Triangulate Surface 

 

16. <D> the OK button. 

Note:  An alert dialog will appear notifying that the surface will be 
appended.  This is alright to do so because this Surface was 
created with no data in the Surface. 

 

17. <D> the Yes button. 
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18. The Alert dialog will close and the Triangulate Surface dialog will 
appear. 

 

19. Leave all settings unchecked. Maximum Length should be set to 0.00. 

20. <D> the Apply button.  The Results section of the dialog should look 
similar to the image below. 
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21. <D> the More button. The Surface Properties dialog will appear. 

 

22. Verify the correct surface is being used 12345SURVSurface01. 

23. Review the section for Data Range.  The Easting, Northing, and 
Elevation values should fall within the project limits. 
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24. <D> the Advanced tab. 

25. In the Cross Sections Section select  
Symbology: T_Existing Ground 

26. In the Profiles section select  
Symbology: T_Existing Ground 

 

27. <D> Apply then Close buttons in the Surface Properties dialog. 

28. <D> the Close button in the Triangulate Surface dialog. 

29. Use the Workspace pane scroll arrows to view the Surfaces tab. 

  

30. Verify 12345SURVSurface01 is the active surface.  
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Note: To change the active surface from the pull-down menu 
Surface > Active Surface; highlight the surface name and 
 <D> the Apply button. 

31. From the pull-down File > Save > Surface.  The Save As dialog will 
appear with the Save as type set to Surfaces (*.dtm). 

32. Verify the correct project directory. 
C:\Projects\12345\ROW_Survey\Working 

 

33. The file name should match the Active name at the bottom of the Save 
As dialog.  If necessary, use the drop-down arrow in the Active field and 
reselect the desired name to ensure the saved file name will match the 
surface name. 

Note:  Ensuring that the saved Surface name in the project folder 
matches the Surface name displayed in InRoads explorer will 
minimize any confusion. 

34. <D> the Save then Cancel buttons.  The file will be saved to disk and 
the Save As dialog will close. 
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Lab 11: Exporting Survey Data to Geometry Overview 
These steps show how to export the electronic fieldbook to a Geometry Project or 
ALG file.  Exporting to an ALG file will create horizontal and vertical alignments.  
InRoads refers to all exported topographic strings as alignments. InRoads will also 
write all survey shot locations to the Cogo buffer.  The alignments and Cogo points 
will then be available for use for Right-Of-Way or design purposes. 

Objectives Lab 11 
After completing this exercise you will know: 

 How to export a Survey Fieldbook to a Geometry Project. 
 How to view the geometry project in the InRoads interface. 
 How to save a Geometry Project. 

1. Verify the 12345SURVFieldbook01 fieldbook is active.  The fieldbook 
that is active has the red box around the fieldbook button. 

2. From the pull-down menu, select File > New.  The New dialog will 
appear. 

3. Select the Geometry tab. 

 

4. From the type pick list verify the Type: Geometry Project 

5. Key in the geometry Name: 12345SURVGeometry01 

6. Key in the Description: CDOT Geometry Overview Training 

Note:  Key in any additional file information in the Description field of 
the dialog, such as Date, User, and Design file name. There are 
up to 79 characters available in the Description field. 
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7. <D> the Apply and Close buttons. 

8. From the pull-down menu, select  
Survey > Survey Data to Geometry.  The Survey Data to Geometry 
dialog will appear. 

 

9. In the Project Name: select from the list 12345SURVGeometry01 

10. Set the Description: to Use Feature Definition 

11. Set the Curve Stroking: to Horizontal Only 

 

 

12. <D> the Apply button. 

13. An alert dialog will appear notifying that the Geometry will be 
appended..  

 

14. <D> the Yes button. 

15. <D> the Close button in the Survey Data to Geometry dialog. 
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16. Use the Workspace pane scroll arrows to view the Geometry tab. 

 

17. Verify 12345SURVGeometry01 is the active Geometry Project.   

Note:  To change the active Geometry from the pull-down menu 
Geometry > Active Geometry then highlighting the desired 
geometry project name and <D> the Apply button. 

18. From the pull-down File > Save > Geometry Project.  The Save As 
dialog will appear with the Save as type set to Geometry (*.alg). 

19. Verify the correct project directory. 
C:\Projects\12345\ROW_Survey\Working 

 

20. The file name should match the Active name at the bottom of the Save 
As dialog.  If necessary, use the drop-down arrow in the Active field and 
reselect the desired name to ensure the saved file name will match the 
surface name. 
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Note:  Ensuring that the saved Geometry name in the project folder 
matches the Geometry name displayed in InRoads explorer will 
minimize any confusion. 

21. <D> the Save and then the Cancel button.  The file will be saved to disk 
and the Save As dialog will close. 

22. Exit InRoads File > Exit 

23. From the MicroStation pull-down select, File > Save Settings 

24. Exist MicroStation File > Exit 

The existing fieldbook has been exported and created 3 specific files from the 
Survey data. The MicroStation Design file (DGN), an InRoads Surface 
(DTM), and InRoads Geometry Project (ALG). 

In the next section a fieldbook will be created from scratch and then look at the 
entire process in more detail.  This was merely an overview to help getting 
familiar with the product and to begin to be familiar with the overall workflow. 
The next sections will work as reinforcement of the workflow process. 
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Section 2 - Workflow 

Chapter 5 Importing Data 

Resolving Code Error dialog 

 

Dialog Items: 
 Change To – field used to type the new correct feature code 
 Suggestions – pick list of codes that nearly matches.  Only available 

when using Alpha feature codes. 
 Log File Name – specifies a text file name and directory that can save 

out the code errors that are found. 

  Retry – rechecks the Change To field to make sure the 
updated code is correct. 

  Ignore – the current code that has an error will be ignored 
during import. 

  Ignore All – all codes that have errors will be ignored and 
will be added to the fieldbook. 

  Features – opens the Feature Table dialog. 

  Browse – opens the Save As dialog.  The Browse button only 
becomes active when the Log File Name field is selected. 
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Resolving Code Errors options 

Suggestions 
 Choose one of the Suggestions: to change the code. 
 <D> the Retry button.  The code will be corrected and processed.  The 

dialog will then move on to the next code error.  Continue correcting 
code errors until complete. 

 

Manually Correct 
 Key in the correct code in the Change To: field. 
 <D> the Retry button.  The code will be corrected and processed.  The 

dialog will then move on to the next code error.  Continue correcting 
code errors until complete. 
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Ignore 
 When unsure of the correct code <D> the Ignore button. 
 The code will be ignored.  The dialog will then move on to the next code 

error.  Continue ignoring code errors until complete. 
 The Results dialog will appear showing what codes still have errors.  

This report can be saved as a text file to the project directory or 
dismissed. 

 

Ignore All 
 When unsure of all the correct codes <D> the Ignore All button. 
 All codes will be ignored.  The Resolve Code Error dialog will then 

close.  
 The Results dialog will appear showing what codes still have errors.  

This report can be saved as a text file to the project directory or 
dismissed. 
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Saving Error Results 

 

Dialog items: 
  Save As – opens the Save As dialog.  This will create a text 

file that can be opened in Notepad. 

  Append – opens the Append dialog allowing the user to add 
additional errors to the end of an existing file. 

  Display – will write the text to graphics.  The text will be 
displayed using the active text style. 

  Print – opens the Print Setup dialog.  The file will be printed 
and will not save the file to disk. 

Finding Points in a MicroStation View 
Find point in View command will locate a specified point in the active fieldbook 
and center the point in the active MicroStation view. 

 From the pull-down menu, select Survey > Find Point in View… 

 

Dialog items: 
 Point Name – key-in field to enter point numbers. 
 Radius – view ratio around the specified point. 

  Target button – select point from the MicroStation view 

  Apply – executes the locate and centers the point to the view 
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Lab1: Managing Survey Files 
In Section 1 of the training a fieldbook, design file, surface model, and geometry 
project were created.  Consider that work to be out of date and those files will 
need to be managed in the Working directory. 

1. Open Windows Explorer and path to the directory 
C:\Projects\12345\ROW_Survey\Working 

2. Rename the working file with your initials and date YYYY-MM-DD for 
example RBM12345SurveyTopo100Scale01_2007-05-04.dgn 

Note: Eventually when the design file has been finalized it will be 
moved to the ROW_Survey\Drawings\Reference_Files\ 
directory for use by the rest of the project team. 
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Lab 2: Importing Control Files 

1. Double-click on the InRoads Survey desktop button    or select  
Start > All Programs > Bentley Civil Engineering >  
Bentley InRoads Survey.  

2. In the MicroStation Manager dialog go to the Workspace group section 
and change 
User: CDOT User 
Project: 12345 
Interface: CDOT 
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3. In the MicroStation Manager dialog path to the directory:  
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\ 

4. Select the file 12345SurveyTopo##Scale##.dgn from the MicroStation 
Manager dialog. 

 

Note:  The purpose of the files with “##” symbols are for creating new 
files with the correct naming convention. 

5. <D> OK the MicroStation Manager dialog will close and open the file. 
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6. From the MicroStation pull-down menu File > Save As the Save As 
dialog will appear. 

7. Path to the folder C:\Projects\12345\ROW_Survey\Working 

 

8. Replace the ## symbols with 100 scale and 01 model.  
Type in Files: 12345SurveyTopo100Scale01.dgn 

 

9. <D> the OK button the Save As dialog will close and MicroStation will 
open the file 12345SurveyTopo100Scale01.dgn 
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10. Once MicroStation and InRoads opens. From the InRoads pull-down 
menu, select File > New.  The New dialog will appear. 
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11. Select the Survey Data tab. 

12. Key in the Name: 12345SURVFieldbook01 

 

13. <D> the Apply button. The new fieldbook will appear below. 

14. <D> the Close button. 

15. From the Workspace bar the 12345SURVFieldbook01 will be active. 
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16. From the pull-down menu, select File > Import > Survey Data. The 
Import dialog will open. 

 

17. Change the Look in: folder to 
C:\Projects\12345\ROW_Survey\Survey\Raw_Data 

18. Verify the Files of type: CDOTCTL (*.CTL) 

• Importing the CTL file first is only needed if the field books 
being imported are conventional files.  GPS (positional) files 
do not require the CTL file. 

Note:  The Files of type: drop-down box works as a filter.  Allowing to 
the files that have the particular file extensions to be viewed.  
This allows InRoads Survey to utilize a specific import wizard 
for each file type. 

19. Select the project control file 12345CTL.CTL to be imported. 
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20. <D> the Options button.   

 This is the same dialog that can be opened from  
Tools > Survey Options 

 

21. Verify the Cell, Text, and Line Scales are all set to 100 

22. Verify Fieldbook Audit Trail File Name is still set from Section 1. 
(C:\Projects\12345\ROW_Survey\InRoads\ 
Field_Books\”UserInitials”_FieldBookEdits) 
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23. <D> the Save then OK buttons.  The Survey Options dialog will close. 

24. <D> the Import button.  The Import dialog will remain open allowing  
additional files to be imported. 

 

25. <D> the Close button. 

Note:  Upon closing, InRoads Survey executes the import routine. 

26. From the pull-down menu, select Survey > Fieldbook Data….  Take a 
minute to review the imported Survey control data that is now contained 
in the electronic Fieldbook. 
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27. While the Fieldbook Data dialog is open, also look at the MicroStation 
view and displayed graphics. 

 

28. Practice changing the display graphics using the View Survey Data 
toolbar. 

 

29. Continue to practice zooming and panning using the MicroStation view 
border buttons. 

 

30. Close the Fieldbook Data dialog. 

31. Fit View from the View Survey Data toolbar. 
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It is up to the user to determine when to save the data in InRoads Survey.  Until 
now the fieldbook is being stored in memory. If something was to cause 
InRoads to close, your data would be lost.   

32. File > Save > Survey Data the Save As dialog will open. 

 

33. Verify the directory location: 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books 

Prior to saving this new fieldbook steps are needed to ensure correct file 
management of multiple fieldbooks. 

34. In the Save As dialog select the file 12345SURVFieldbook01 so it 
highlights. 

35. <R> the filename and select Rename from the popup menu. 

36. Change the file name to 12345SURVFieldbook02 
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37. Choose the Active: 12345SURVFieldbook01 at the bottom of the dialog. 

38. Verify the File Name: 12345SURVFieldbook01.fwd 

 

39. <D> the Save button.  The file will be saved to disk and will show in the 
dialog. 

 

40. <D> the Cancel button.  The Save As dialog will close. 
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Lab 3: Importing Data collector files 

Importing SDR files 

1. From the Workspace bar select and highlight 12345SURVFieldbook01 
and <R> to view the shortcut menu. 

 

2. <D> Import… The Import dialog will appear. 

 This is a same as using the pull-down menu  
File > Import > Survey Data. 

3. Change the Look in: folder to 
C:\Projects\12345\ROW_Survey\Survey\Raw_Data 

4. Change the drop-down arrow Files of type: Sokkia SDR (*.sdr) 
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5. Select the file 12345AAAIR.sdr from the filtered list of files. 

6. <D> the Import button.  The Import dialog will remain open allowing 
additional files to be imported. 

7. <D> the OK button in the SDR Tolerance error dialog. 

 

8. <D> the Close button. 

9. Select the Fieldbook    button from the Survey toolbar.  The Survey 
Fieldbook will appear. 

 

10. Take a minute to review the observations from Station Name 2000 that 
was imported into the electronic Fieldbook. 

 

11. Close the Fieldbook dialog <D> the X in the upper right hand corner of 
the dialog. 
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Resolving Code errors 
From the Tools > Survey Options dialog the choice was made to resolve any 
code errors when the data is imported. There are a couple of ways to handle 
code errors. 

12. From the pull-down menu, select File > Import > Survey Data.  The 
Import dialog will open. 

13. Change the Look in: folder to 
C:\Projects\12345\ROW_Survey\Survey\Raw_Data 

14. Verify the drop-down arrow Files of type: Sokkia SDR (*.sdr) 

 

15. Select the file 12345BBBIR.sdr from the filtered list of files. 

16. <D> the Import button.  Only one file can be selected at a time.  The 
Import dialog will remain open allowing for additional files to be 
imported. 

17. <D> the OK button in the SDR Tolerance dialog box. 
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18. <D> the Close button.  The imported SDR files will be processed. 

Note:  There are code errors with these files; the Resolve Code Errors 
dialog will appear. 

 

19. Key-in Change To: 1699 

20. <D> the Retry button.  The code will be processed and the next error will 
appear.   
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Continue this process for the next three code errors. 

21. Key-in Change To: 5182 <D> the Retry button. 

 

22. Key-in Change To: 4210.08 ST <D> the Retry button. 

 

23. Key-in Change To: 4274 <D> the Retry button.  The 
Resolve Code Error dialog will close and Survey will process the data. 
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24. From the pull-down menu, select File > Import > Survey Data.  The 
Import dialog will open. 

25. Change the Look in: folder to 
C:\Projects\12345\ROW_Survey\Survey\Raw_Data 

26. Verify the drop-down arrow Files of type: Sokkia SDR (*.sdr) 

27. Select the file 1234500CCCIR.sdr from the filtered list of files. 

 

28. <D> the Import button.  The Import dialog will remain open allowing 
for additional files to be imported. 

29. Continue to import the remaining SDR files  
1234500DDDIR- 123450EEEIR 

 If a previously imported SDR file was selected the following 
dialog will appear. 
 

 
 
<D> the No button and go back and select a different file. 
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Importing Trimble DC file 

30. From the Workspace bar select and highlight 12345SURVFieldbook01 
and <R> to view the shortcut menu. 

 

31. <D> Import… The Import dialog will appear. 

 This is a same as using the pull-down menu  
File > Import > Survey Data. 
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32. Change the Look in: folder to 
C:\Projects\12345\ROW_Survey\Survey\Raw_Data 

33. Change the drop-down arrow Files of type: Trimble DC (*.dc) 

 

34. Select the file 12345FFFIR.dc from the filtered list of files. 

35. <D> the Import button.  The Import dialog will remain open allowing 
for additional files to be imported. 

36. <D> the Close button.  If errors are present in the input files, the Resolve 
Code Errors dialog will appear. 

 

37. <D> the Ignore All button.  The Resolve Code Error dialog will close 
and Survey will process the data.  The code errors will be corrected later 
in the manual. 
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38. The Results dialog will appear <D> the Save As button.  The Save As 
dialog will open. 

 

39. Key-in the File name: ResolveCodeErrors_All.txt 

40. <D> the Save button.  The Save As dialog will close. 

 

41. <D> the Close button in the Results dialog. 

42. Select the Fieldbook    button from the Survey toolbar.  The Survey 
Fieldbook will appear. 
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43. Take a minute to review the observations from Station Name 
12345FFFIR that was imported into the electronic Fieldbook. 

 

44. Locate Station Name: 12345CCCIR Point Name: 13619.  Notice the 
code is red, representing an error. 

 

Note:  While the Fieldbook Data dialog is open, look at the 
MicroStation view and displayed graphics. 
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45. Locate the same point in View 1 using one of the following methods. 

 <R> Point Name to view the Fieldbook shortcut list and select 
Center 
or 

 From the pull-down menu, select  
Survey > Find Point in View 

 

 

Note:  The code errors will be corrected in the fieldbook later in the lab. 

46. Close the Fieldbook dialog and any other dialogs. 
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Lab 4: Importing ASCII files 
In the following steps an ASCII file will be imported.  To import ASCII files the 
Text Import Wizard (TIW) will be used.  This format created for importing text 
can be saved and recalled for future use. 

 

NOTEPAD SCREEN SHOT 
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1. From the pull-down menu, select File > Import > Survey Data.  The 
Import dialog will open. 

2. Change the Look in: folder to 
C:\Projects\12345\ROW_Survey\Survey\Raw_Data 

3. Change the drop-down arrow Files of type: Text File (*.*)  
All the files in the directory will be shown. 

4. Select the file 12345TestHoles.xyz 

 

5. <D> the Import button.  The Text Import Wizard dialog will appear. 
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6. Change the entry field Start Import at Row: 7 and Tab out of the field. 
This will ignore the header information in the file. 

7. Verify the Record Format radio button is set to Uniform. 

8. Verify the Original Data Type radio button is set to Delimited. 

 

9. <D> the Next > button.  The Step 2 of 3 dialog will appear. 
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10. In the Delimiters section of the dialog check on the Comma delimiter 
field as this defines what separates our columns of data.  Verify the rest 
of the dialog is set as shown below. 

 

11. <D> the Next > button.  The final Step 3 of 3 dialog will appear. 
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12. Select the header of the first column labeled Skip.  The column will 
highlight as shown below. 

13. From the Column Data Format drop-down box select Point Name 

 

14. Select the second Skip column header then select Easting from the 
Column Data Format drop-down box. 

15. Select the third Skip column header then select Northing from the 
Column Data Format drop-down box. 

16. Select the fourth Skip column header then select Elevation from the 
Column Data Format drop-down box. 

17. Select the fifth Skip column header then select Code from the Column 
Data Format drop-down box. 
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18. <D> the Save As button.  The Save As dialog will appear. 

19. Key in File name: ASCII Import ENEc 

  

20. <D> the Save button.  The Save As dialog will close. 

21. The Save Format to File Types dialog will appear.  Verify 
Format Name: ASCII Import ENEc 
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22. <D> the Yes button.  The Save Format to File Types dialog will close 
and the Step 3 of 3 dialog will reappear. 

Note:  The Text Import Wizard has been created for future use. 

23. In the Step 3 of 3 dialog <D> the Cancel button.  The Step 3 of 3 dialog 
will close and the Import dialog will reappear. 
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24. In the Import dialog change the  
Files of type: ASCII Import ENEc (*.xyz) 

Note: The extension for the filter (*.xyz) came from the original file 
extensions that was imported. 

25. Select the file 12345TestHoles.xyz 

 

26. <D> the Import then Close buttons. 

27. <D> Ignore All in the Resolve Code Error dialog and then close the 
dialog.   

Note:  The Resolve Code Error dialog continues to open because the 
entire file is processed each time a file is imported. 

28. <D> the Close button in the Results dialog. 
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29. Review the data that was imported Survey > Fieldbook Data… 

 

30. Locate the file that was imported into the Fieldbook Data dialog.  As 
files are imported to the fieldbook they will always append to the active 
fieldbook. 
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31. Select Point Name 20006 in the fieldbook. 

32. <R> Center Point Name 20006 to the MicroStation view. 

Note:  The center command from the shortcut menu works with the 
current zoom ratio and will not zoom into the point. 
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33. Save the Survey fieldbook.  From the Workspace Bar <R> on 
12345SURVFieldbook01 select Save from the shortcut menu. 

 

 The Status Bar will show that it was saved. 
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Chapter 6 Fieldbook Edits 

Fieldbook Data dialog 

 

 Status Codes 
 N – The point has a Note 
 E – The point has been Edited 
 F – The point is Fixed or has been keyed in 
 A – The point has an Attribute associated to the Survey Feature 
 V- The point has a Value for an associated Attribute 
 I – The point has been Inserted into the fieldbook 
 C – The point has been adjusted 
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Find Observation dialog 

 

Dialog items: 
 Station – key-in field used to locate Station point numbers in the active 

fieldbook. 
 Point Name - key-in field used to locate Observation point numbers in 

the active fieldbook. 
 Code - key-in field used to locate Alpha or Numeric codes in the active 

fieldbook. 
 Fence Mode – used to constrain a lookup area.  If a fence is placed in the 

design file then the item will be activated so a fence mode could be 
selected. 

 Target Height – locates survey shots based on a target height range 
 Minimum 
 Maximum 

 List – points found based on the selection criteria. 
 Use the Shift and Ctrl keys to select multiple points in the list. 

 Apply – locates the points in the active fieldbook and places them in the 
list section. 

 Edit – opens the Edit Observation dialog for the selected point numbers. 
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Edit Observation dialog 
When editing points in the electronic fieldbook the original raw imported data is 
not edited.  The Edit Observation dialog allows the fields that are not grayed 
out to be edited.  After the point has been edited the point will show an “E” in 
the Status column of the fieldbook.  Edits will also be tracked in the Audit Trail 
file. 

 

Dialog items: 
 Point Name – assigned point value in the fieldbook. 

 Use the arrows to easily cycle through the points. 
 Type – definition of the point in the fieldbook 

 Computed – point is defined from measured distances and angles. 
 Fixed – point is defined from keyed in values for Northing 

Easting, and Elevation. 
 Geometry – point is defined from the Cogo buffer point name. 

 Horizontal Observation – measured value 
 Vertical Observation – measured value 
 Slope Distance - measured value 
 Code – feature and control codes 
 Target Height - measured value 
 Notes – any notes added to the shots in the field 
 Attributes – any additional information collected for the point 
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Lab 5: Correcting Fieldbook Code Errors 
Code errors are codes that are not found in the Survey Feature table including 
feature and control codes.  From the document that was generated from Resolve 
Code Errors ResolveCodeErrors_All.txt those errors will begin to be corrected. 

 

 

1. <D> the Fieldbook    button from the Survey toolbar.  The Survey 
Fieldbook will appear. 

2. From the Fieldbook dialog select the Find / Replace Codes    
button.  The Point Code Find a Replace dialog will appear. 

 

3. Select the Next Error button.  The command will look in the current 
fieldbook and return the first code error it finds. 

 

This error has an incorrect Control Code for Close. 

NOTEPAD SCREEN SHOT 
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4. Type the correction in the field Replace with: 6001.00210 CL 

 

5. <D> the Replace button.  The code in the fieldbook will be updated.  
The dialog will automatically locate the next code error 675. 

6. <D> the Close button in the Point Code Find and Replace dialog. 

7. In the Fieldbook Data dialog <R> any Point Name in the observation 
section of the dialog.  From the shortcut menu Select Find.  The Find 
Observation dialog will appear. 
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8. Key-in the Code: 675 then select the Apply button. 

 

The Code 675 was missed typed into the data collector the correct code for these 
shots should be 6075.  Using the Find Observation dialog, multiple codes can 
be found and edited together.  

9. Select the first point in the list then hold down the Shift key select the 
last point in the list.   

 

Note:  Use the Shift and Ctrl keys on the keyboard to select and deselect 
multiple points in the Find Observation list. 
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10. <D> the Edit… button.  The Edit Observation dialog will appear. 

 

The Code error 675 is highlighted red indicating the error. 

11. Type the correct Code: 6075 Tab key out the code field the code text will 
change to black indicating an acceptable code was entered. 

 

12. <D> the Apply then Close buttons to accept the change for all the 
selected points. 

13. Open the Find Observation dialog. <R> on a point name Observations in 
the Fieldbook Data dialog and select Find from the popup menu. 
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14. Key-in the Point Name: [13995-13997] 

15. <D> the Apply button.  The point names in that range will appear in the 
list. 
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16. Select the point name 13995 and <R> from the popup menu select 
Center.  The point 13995 will center to the MicroStation View 1. 
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17. From the Find Observation dialog select the Edit button.   The Edit 
Observation dialog will appear. 

 

18. Type in the Code: 1330.50 BC NT 

 

19. <D> the Apply button. 



 Chapter 6 - Fieldbook Edits 

 

 

20. <D> the Next    button at the top of the dialog, stop at point 13997. 

 

21. Type in the Code: 1330.50 EC NT 

 

22. <D> the Apply the Close buttons.  Review your results in MicroStation 
View 1. 
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23. From the Fieldbook dialog select the Find / Replace Codes    
button.  The Point Code Find a Replace dialog will appear. 
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24. <D> the Next Error button.  The command will look in the current 
fieldbook and return the first code error it finds. 

25. <D> the Close button.  The incorrect point will be located in the 
Fieldbook Data dialog. 

 

 

This error has an incorrect Feature Code for a Power Pole. 

26.  In the Fieldbook Data dialog <R> on the point name 8697 from the 
popup menu select Center. The point name will be centered to the 
MicroStation View 1. 
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27. Again in the Fieldbook Data dialog <R> on the point name 8697 from 
the popup menu select Edit.  The Edit Observation dialog will appear for 
point 8697. 

 

28. Type in the Code: 4375 

 

29. <D> the Apply then Close buttons.  In the MicroStation View 1 the 
point has been updated and a power pole cell is at the location. 
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30. From the Fieldbook dialog select the Find / Replace Codes    
button.  The Point Code Find a Replace dialog will appear. 

 

31. Select the Next Error button.  The command will look in the current 
fieldbook and return the first code error it finds. 

 

This error has an incorrect Control Code for Start. 

32. Type the correction in the field Replace with: 6001.00210 ST 
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33. <D> the Replace button.  The code in the fieldbook will be updated.  
The dialog will automatically locate the next code error   
5177 3'X3'STEEP HILL 

34. <D> the Close button in the Point Code Find and Replace dialog.  The 
point name 8780 will be selected in the Fieldbook Data dialog. 

35. <R> the point name 8780 and from the popup menu select Edit.  The Edit 
Observation dialog will appear. 

This error is because of the note being entered into the code field.  The note will 
be cut and then pasted into the Notes field, where it belongs. 

36. In the Code field highlight the additional text in the code line 
“3'X3'STEEP HILL” 

37. <R> on the highlighted note and select Cut from the popup menu. 
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38. <D> in the Notes field so the field has focus. 

39. <R> in the Notes field and select Paste from the popup menu. 

 

40. In the Edit Observation dialog <D> the Apply then Close buttons. 
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41. From the Fieldbook dialog select the Find / Replace Codes    
button.  The Point Code Find a Replace dialog will appear. 

42. Select the Next Error button.  The command will look in the current 
fieldbook and return the last coding error in this fieldbook. 

 

43. <D> the Close button in the Point Code Find and Replace dialog.  The 
point name 10153 will be selected in the Fieldbook Data dialog. 

44. <D> <D> the point name 10153.  The Edit Observation dialog will 
appear. 

Again this error is because of the note being entered into the code field.  The 
note will be cut and then pasted into the Notes field, where it belongs. 

45. In the Code field highlight the additional text in the code line “ICE” 

46. <R> on the highlighted note and select Cut from the popup menu. 

47. <D> in the Notes field so the field has focus. 

48. <R> in the Notes field and select Paste from the popup menu. 

49. In the Edit Observation dialog <D> the Apply then Close buttons. 
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This should have taken care of our code errors in the fieldbook.   

50. Verify this by opening the Point Code Find and Replace dialog and 
selecting Next Error.  An alert dialog will appear stating that no errors 
exist in the fieldbook. 

 

51. Save the Survey fieldbook.  From the Workspace Bar <R> on 
12345SURVFieldbook01 select Save from the shortcut menu. 
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Lab 6: Correcting Fieldbook Control Code Errors 
Control codes are the drawing tools for InRoads Survey.  When collecting data 
in the field think of the range pole as a large pencil and using control codes 
allows you to draw the lines.  Even though CDOT has standardized on Numeric 
feature codes, InRoads Survey does allows the use of Alpha control codes.  

1. From the pulldown menu Survey > Find Point in View The Find Point in 
View dialog will appear. 

2. Key-in the Point Name: 22006 
                          Radius: 50 

 



 Chapter 6 - Fieldbook Edits 

 

 

3. Open the Fieldbook Data dialog Survey > Fieldbook Data 

 

4. From the Fieldbook Data dialog <D> the Select Observation    target 
button.  The Fieldbook Data dialog will minimize allowing more of the 
view to be displayed. 
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5. <D> point 22006 in the MicroStation View 1.  The Fieldbook Data 
dialog will restore to the screen and the point name 22006 will be 
highlighted in dialog. 

 

 

Click Here
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6. <D> <D> the point name 22006.  The Edit Observation dialog for point 
22006 will appear. 

The brick house point code is missing the control code ST to start the line work.  
Also the distance control code DIST will be utilized to complete the 
planimetrics of the house. 

 

7. Type in the Code: 4111 ST 

8. <D> the Apply button.  The line work for the house will start. 
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9. <D> the Next     button in the Edit Observation dialog stop at point 
name 22007. 

10. Type in the Code: 4111 DIST -70 -30 -20 40 CL 

11. <D> the Apply button. 

 

Note:  A positive number will place the line to the right of the two base 
line points.  A negative number will place the line to the left side 
of the two base line points. 

 

12. Locate point name 22008 in the Fieldbook Data dialog 
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13. <D> <D> the point name 22008.  The Edit Observation dialog will 
appear. 

The next edits will be to create the deck on the back of the house using two 
shots and a measured distance with the rectangle RECT control code. 

14. Type in the Code: 4127 ST 

 

15. <D> the Apply button.  The line work for the deck will start. 

16. <D> the Next     button in the Edit Observation dialog stop at point 
name 22009. 

17. Type in the Code: 4127 RECT 25 

 

Note:  A positive number will place the rectangle on the right side of the 
two base line points.  A negative number will place the rectangle 
on the left side of the two base line points. 
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18. <D> the Apply button the rectangle control code will have finished 
creating the line work.  

 

19. Locate point name 22010 in the Fieldbook Data dialog. 
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20. <D> <D> the point name 22010.  The Edit Observation dialog will 
appear. 

The next edits will be to create the shed using three shots with the close 
rectangle CLR control code. 

21. Type in the Code: 4113 ST 

 

22. <D> the Apply button.  The line work for the deck will start. 

23. <D> the Next     button in the Edit Observation dialog stop at point 
name 22012 

24. Type in the Code: 4113 CLR 
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25. <D> the Apply button the close rectangle control code will have finished 
creating the line work.  
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26. From the pulldown menu Survey > Find Point in View The Find Point in 
View dialog will appear. 

27. Key-in the Point Name: 22000 
                          Radius: 100 

 

28. Locate point name 22000 in the Fieldbook Data dialog. 
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29. <D> <D> the point name 22000.  The Edit Observation dialog will 
appear. 

The next edits will be to create the waterline along the edge of the roadway and 
then connect the waterline to the fire hydrant at the driveway entrance. 

30. Type in the Code: 4710 ST 

 

31. <D> the Apply button.  The line work for the deck will have started. 

32. <D> the Next     button in the Edit Observation dialog stop at point 
name 22002 

33. Type in the Code: 4710 JNC 4775 

 

Note:  The Join Nearest Code JNC will locate the nearest fire hydrant 
4775 feature code and connect a line to that code. 
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34. <D> the Apply button the close rectangle control code will have finished 
creating the line work. 
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35. From the pulldown menu Survey > Find Point in View The Find Point in 
View dialog will appear. 

36. Key-in the Point Name: 22003 
                          Radius: 50 
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37. From the Fieldbook Data dialog <D> the Select Figure    target 
button.  The Fieldbook Data dialog will minimize allowing more of the 
view to be displayed. 
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38. <D> the figure shown in the MicroStation View 1.  The Fieldbook Data 
dialog will restore to the screen and the point name 8026 will be 
highlighted in dialog. 

 

 

 

Note:  The point highlighted is the start of the figure you selected. 

Click Here
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39. <D> <D> the point name 8026.  The Edit Observation dialog for point 
8206 will appear. 

The figure shown in plan view has sharp edges and should be smoothed for a 
better looking basemap. 

 

40. Type in the Code: 1331.07 ST BC 

 

41. <D> the Apply button.  The line work for the figure will be smoother. 
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42. Continue to edit the rest of the Dirt Driveway figures in the area with the 
Begin Curve BC control code. 

 



 Chapter 6 - Fieldbook Edits 

 

 

43. From the pulldown menu Survey > Find Point in View The Find Point in 
View dialog will appear. 

44. Key-in the Point Name: 7026 
                          Radius: 15 

 

45. Locate point name 7026 in the Fieldbook Data dialog. 
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46. <D> <D> the point name 7026.  The Edit Observation dialog will 
appear. 

The next edits will be to rotate the culvert end sections into the direction of the 
pipe. 

47. Move your mouse to the Attributes section of the dialog and <D> the 
Value for Code 2062.  The Value field will open allowing keyboard 
input. 

 

48. Type in the Value: 270 

 

49. <D> the Apply button.  The end section cell will have rotated into the 
direction of the pipe. 

50. <D> the Next     button in the Edit Observation dialog stop at point 
name 7033 
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51. Type in the Value: 90 

 

52. <D> the Apply then Close buttons.  The end section cell will have 
rotated into the direction of the pipe. 
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53. From the pulldown menu Survey > Find Point in View The Find Point in 
View dialog will appear. 

54. Key-in the Point Name: 7734 
                          Radius: 40 

 

55. Locate point name 7733 in the Fieldbook Data dialog. 
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56. <D> <D> the point name 7733.  The Edit Observation dialog will 
appear. 

The next edits will be to change the feature code to be 3033 counter clockwise 
CCW so the planimetrics will be correct. 

57. Move your mouse to the Codes section of the dialog. 

 

58. Type in the Code: 3033.01 ST 

 

59. <D> the Apply then Close buttons.  The change in direction for the 
feature code will correct the planimetric display. 

Note: Notice that at this point the entire display of the line has 
disappeared.  To correct the remaining shots that make up this 
figure will also need to be changed to a feature code 3033. 

60. In the Fieldbook Data dialog <D> the point name 7734, then holding 
down the Shift key <D> the point name 7738.  A selection set of points 
7734-7738 have been highlighted in the fieldbook. 
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61. <R> the select point list from the popup menu select Edit. 

 

Note:  Notice that the only fields that can be edited are the ones that are 
the same. 
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62. Type in the Code: 3033.01 

 

63. <D> the Apply then Close buttons.  The planimetrics will display the 
correct direction. 

 

 

64. Save the Survey fieldbook.  From the Workspace Bar <R> on 
12345SURVFieldbook01 select Save from the shortcut menu. 
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Lab 7: Correcting Elevation Errors 
There are five shots that were collected with incorrect rod heights.  The shots 
can be located and edited as a group. 

1. <D> the Fieldbook    button from the Survey toolbar.  The Survey 
Fieldbook will appear. 

2. In the Fieldbook Data dialog <R> any Point Name in the observation 
section of the dialog.  From the shortcut menu Select Find.  The Find 
Observation dialog will appear. 
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3. Key-in the Code: 3033* 

4. Target Height 
Minimum: 10 
Maximum: 20 

5. <D> the Apply button. 

 

The shots for code 3033 were taken with the incorrect rod height.  Using the 
Find Observation dialog multiple codes can be found and edited together.  

6. Select the first point in the list then hold down the Shift key select the 
last point in the list.   

 

 

Note:  Use the Shift and Ctrl keys on the keyboard to select and deselect 
multiple points in the Find Observation list. 
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7. <D> the Edit… button.  The Edit Observation dialog will appear. 

 

 

The target height is incorrect at 16.00. 

8. Type the correct Target Height: 6.00 Tab key out the code field the code 
text will change to black indicating an acceptable code was entered. 

 

9. <D> the Apply then Close buttons to accept the change for all the 
selected points. 

10. Save the Survey fieldbook.  From the Workspace Bar <R> on 
12345SURVFieldbook01 select Save from the shortcut menu. 
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Lab 8: Adding points to the fieldbook 
The ability to add points to the fieldbook is simple to accomplish.  Points can be 
added based on computed, fixed, or from geometry locations. 
 

In this example a tree will be added to the fieldbook. 

1. In the MicroStation view Find Point Name: 8030 Radius: 30 

 



Colorado Department of Transportation   

 

Page 214  InRoads Survey 

2. In the InRoads Survey Fieldbook Locate point 8030 

 

3. <R> the point name 8030 and select Add After from the shortcut menu.  
The Add Observation dialog will appear for point 1. 
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4. Type in the Code: 3077 

 

5. <D> the Target button for the Northing Easting and Elevation.  The Add 
Observation dialog will minimize. 
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6. <D> a point in the MicroStation view in the approximate area shown in 
the screen capture.  The Add Observation dialog will reappear. 

 

7. Type in the Elevation: 6535.00 
                   Notes: Point added graphically  

 

Click Here
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8. <D> the Apply then Close buttons.  The tree will dynamically display in 
the MicroStation view. 

 

9. Save the Survey fieldbook.  From the Workspace Bar <R> on 
12345SURVFieldbook01 select Save from the shortcut menu. 
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Chapter 7 DTM Evaluation 
As part of the deliverables the survey department will be given to design will be the 
Surface DTM file.  The DTM file is to be an exact copy of what exists in the 
fieldbook.  What that means is any edits to the DTM to correct crossing breaklines 
or busted elevations is fixed in the Survey fieldbook. 

Surface Properties dialog 

 

Dialog Items 
 Surface - drop-down shows the active surface by default, other surfaces 

are selectable 
 Name – the name of the DTM as InRoads has it stored in memory (not 

necessarily the file name on disk). The surface can be renamed here by 
typing in a new name. 

 Description – user defined description 
 Maximum Length – maximum length any one triangle segment (leg) can 

span during the triangulation process. If set to 0, triangle legs can extend 
to any length. Used to constrain triangulation to prevent unnecessary 
‘surface’ data. 

 Preference – predetermined display settings – bypasses the View 
Contour dialog box if the Style lock is enabled. 

 Material – optional surface identifier, used in material (cut/fill) tables to 
define varying slopes based on material composition 

 Extended Data Checks – checks DTM integrity (during triangulation) 
for crossing breaklines and miss-matched elevations 
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  Report – generates a separate window summarizing surface 
properties.  The generated report can be printed, written to the CAD file, 
or stored as an ASCII file 

 Advanced tab – graphic display attributes related to profiles & cross 
sections for the surface 

Data File Naming & Saving 
 As noted above, a user can rename a surface in the Surface Properties 

dialog. A critical point to remember is that InRoads is a memory based 
program. The name given the file on disk can differ from the name used 
in memory. While they do not have to be the same, it is highly 
recommended that they share a common name. 

 Assigning a different name to a surface in the Surface Properties dialog 
box or by using Surface > Rename Surface simply redefines the 
surface name as it resides in memory, not on disk. 

 Renaming a surface in both memory and on disk is a two step process. 
Use one of the methods described in the preceding paragraph to rename 
the surface in memory and then use the File > Save As command, using 
the new name, to save it to disk. 
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Lab 9: Exporting Survey Data to Surface for Evaluation 
Exporting to a DTM surface will create a triangulation network used for 
displaying contours, features and spot elevations. 

1. Verify the 12345SURVFieldbook01 fieldbook is active as this is the 
survey data to be exported to a DTM.  You can tell which fieldbook is 
active by the red box around the fieldbook button. 

2. Write Survey Data to Graphics if they are not already.  The planimetrics 
will make viewing in the MicroStation model easier. 

3. From the pull-down menu, select File > New.  The New dialog will 
appear. 

4. Select the Surface tab. 

5. Key in the surface Name: 12345SURVSurface01 

6. Key in the Description: CDOT Surface Evaluation 

Note:  Key in any additional file information in the Description field of 
the dialog, such as Date, User, and Design file name. You have 
up to 34 characters even though you may not see all the 
characters in the Description field. 

7. Keep the Maximum Length set to 0 

8. Set pick list to the Preference: Existing 10’ Mjr – 2’ Minor 

 

9. <D> the Apply then Close buttons. 

10. From the pulldown menu Survey > Survey Data to Surface.  The 
Survey Data to Surface dialog will appear. 
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11. Pick from the list in the Surface Name 12345SURVSurface01 in the 
Surface Name field. 

12. Set the Description to Use Feature Definition 

13. Keep the Tolerance and Maximum Segment Length set to 0.00 

14. Set the Curve Stroking Mode to Horizontal Only 

15. Check Always Use: Style 

16. Check Triangulate Surface 

 

17. <D> the OK button.   

18. An alert dialog will appear informing you will be appending a surface.  
This is alright to do so because this Surface was created with no data in 
the Surface. 

 

19. <D> the Yes button. 
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20. The Alert dialog will close and the Triangulate Surface dialog will 
appear. 

 

21. Leave all settings unchecked. Maximum Length should be set to 0.00. 

22. <D> the Apply button.  The Results section of the dialog should look 
similar to the image below. (Numbers may not match exactly) 
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23. <D> the More button. The Surface Properties dialog will appear. 

 

24. Verify you are working with the correct surface 
12345SURVSurface01. 

25. Review the section for Data Range.  The Northing, Easting, and 
Elevation values should fall within the project limits. 
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26. In the Data Range section, change the drop down selection to Random. 

 

27. Review the Random point range.    

Note:  As part of your evaluation of the surface you are looking for a 
large error in the data such as a zero elevation, or truncated 
coordinates. 
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28. In the Data Range section, change the drop down selection to Breakline. 

 

29. Review the Breakline point range.    

Note:  Having the flexibility to review our data by type can help when 
trying to track down errors in the DTM. 
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30. On the Advanced tab choose  
Cross Sections - Symbology: T_Existing Ground 

31. On the Advanced tab choose  
Profiles - Symbology: T_Existing Ground 

 

32. <D> Apply then Close in the Surface Properties dialog. 

33. <D> the Close button in the Triangulate Surface dialog. 

34. Use the Workspace pane scroll arrows to view the Surfaces tab. 

35. Verify 12345SURVSurface01 is the active surface.  

Note: You can change the active surface from the pull-down menu 
Surface > Active Surface; highlight the surface name and 
 <D> the Apply button. 
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36. From the pull-down File > Save > Surface.  The Save As dialog will 
appear with the Save as type set to Surfaces (*.dtm). 

37. Verify you are in the correct project directory. 
C:\Projects\12345\ROW_Survey\Working 

 

38. The file name should match the Active name at the bottom of the Save 
As dialog.  If necessary, use the drop-down arrow in the Active field and 
reselect the desired name to ensure the saved file name will match the 
surface name. 

Note:  Ensuring that the saved Surface name in the project folder 
matches the Surface name displayed in InRoads explorer will 
minimize any confusion. 

39. <D> the Save then Cancel button.  The file will be saved to disk and the 
Save As dialog will close. 
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Crossing Segments 
Errors encountered during the triangulation process may be an indication of 
features that either cross, or cross and have elevations that are not identical at 
the location of intersection. Experiencing this is possible with surveying items 
without defined limits, such as edge of gravel parking lot vs. edge of abutting 
gravel drive. 

The following images will illustrate this situation. The first image represents 
features created along the crown of the crossing roadways as surveyed (or 
designed). An observation was not taken at the centerline-centerline intersection. 
Therefore, InRoads will interpolate an elevation at this location during the 
triangulation process resulting in a mismatched elevation situation. 
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This second image shows the result of instructing InRoads to correct this DTM 
error automatically. This is accomplished during triangulation by toggling on 
Extended Data Checks in the Surface > Triangulate Surface dialog. Note that 
the crossing segment in the second feature is eliminated. 
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Lab 10: Correcting Crossing Segments 
1. From the pull-down menu select,  

Surface > View Surface > Crossing Segments.   
The View Crossing Segments dialog will appear. 

 

2. Verify from the Surface drop down 12345SURVSurface01 is selected. 

3. <D> the Preferences… button.  The Preferences dialog will appear. 

 

4. Select the CDOT preference 

5. <D> the Load then Close buttons. 

6. <D> the Apply button from the View Crossing Segments dialog. 
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7. <D> the Results button.  The Results report will appear locating all 
mismatched and crossing segments. 

 

Note:  This report can be saved to the dgn file or text file if needed. 

8. Review the results. 

9. <D> the Close button on the Results dialog. 
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10. From the pull-down menu, select Survey > Find Point in View 

11. Find Point Name: 9622 Radius: 10 

  

Note:  Thr terrain breakline running left to right is crossing multiple 
other terrain breaklines.  In this particular situation a solution 
would be to break the terrain line using a Start control code. 

12. <D> the Fieldbook    button from the Survey toolbar.  The survey 
Fieldbook Data  dialog will appear. 

9622
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13. Locate point name 9631 in the fieldbook using the  
  Select Observation button from the Fieldbook Data dialog. 

 

14. <R> the point name 9631 and select Edit from the shortcut menu or 
double click the point name.  The Edit Observation dialog will appear 
for point 9631 

 

9618
9631
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15. Type in the Code: 6001.00134 ST 

 

16. <D> the Apply then Close buttons. 

17. Review your results dynamically from the fieldbook.  The terrain 
breakline was restarted so the breaklines are no longer crossing. 
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18. From the pull-down menu, select Survey > Find Point in View 

19. Find Point Name: 14260 Radius: 10 

  

Note:  The terrain breakline is overlapping slightly where the line  
zig-zags.  In this particular situation a solution would be to edit 
the XY location of the point.14 

20. <D> the Fieldbook    button from the Survey toolbar.  The survey 
Fieldbook Data  dialog will appear. 

14260
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21. Locate point name 14260 in the fieldbook using the  
  Select Observation button from the Fieldbook Data dialog. 

22. <R> the point name 14260 and select Edit from the shortcut menu or 
double click the point name.  The Edit Observation dialog will appear 
for point 14260 
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23. <D> the Target button.  The Edit Observation dialog will minimize 
allowing to select a point in the MicroStation view. 

 

24. Using MicroStation snaps set the temporary snap to Nearest. 

25. Hold down the Ctrl and Shift keys.  This will enable AccuSnap when 
using an InRoads command. 

26. Move the cursor to a point along the linestring making sure the lines are 
not overlapping. 

 

27. <D> a point in the MicroStation view to accept the point.  The Edit 
Observation dialog will reappear.  The new XYZ locations will be 
updated. 
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28. <D> the Apply then Close buttons. 

29. Review your results dynamically from the fieldbook.  The terrain 
breakline was restarted so the breaklines are no longer crossing. 
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Surface Triangles 

Lab 11 Evaluate Surface Triangles 
1. From the InRoads pull-down select,  

Surface > View Surface > Triangles.  The View Triangles dialog will 
appear. 

 

2. Verify 12345SURVSurface01 is the active surface. 

3. <D> the Preferences… button.  The Preferences dialog will appear. 

 

4. Select the Existing preference. 

5. <D> the Load then Close buttons. 
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6. <D> the Apply button.  The View Triangles dialog will minimize as the 
triangles are generated.  The dialog will reappear when it is finished. 

7. <D> the Close button in the View Triangles dialog. 

8. Using MicroStation viewing commands Fit Active to review your 
results. 
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9. From the pull-down menu, select Survey > Find Point in View 

10. Find Point Name: 7585 Radius: 20 
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11. Using MicroStation viewing commands Rotate View to review your 
results. 

12. From the tool settings dialog select Method: Isometric 

 

13. If you can not see all the triangles in the view.  Go to the MicroStation 
pulldown Settings > View Attributes and check off Clip Back and Clip 
Front then Apply and exit the dialog. 
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14. From the MicroStation pull down menu select,  
Utilities > Render > Filled Hidden Line. 

15. Place a <D> in View 1 

16. Review your results. 

 

Note:  The tree feature code 5077 that was added to the fieldbook had 
the elevation transposed.  The elevation error will be corrected 
back in the fieldbook. 
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17. Locate point name 7585 in the fieldbook using the  
  Select Observation button from the Fieldbook Data dialog. 

18. <R> the point name 7585 and select Edit from the shortcut menu or 
double click the point name.  The Edit Observation dialog will appear 
for point 7585. 

 

19. Key-in the Elevation: 6525.00 

 

20. <D> the Apply then Close buttons. 

21. From the View Survey toolbar toggle ON View Planimetrics    

22. Review your results. 

Note:  The fieldbook data is now correct when the fieldbook is re-
exported the Survey data to Surface the surface data will be 
corrected also. 

23. From the View Survey toolbar toggle OFF View Planimetrics    

24. In the MicroStation view border Rotate view to Top 
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 Surface Contours 

Lab 12: Evaluate Surface Contours 
1. From the InRoads pull-down select,  

Surface > View Surface > Contours.  The View Contours dialog will 
appear. 

 

2. Verify 12345SURVSurface01 is the active surface. 

3. <D> the Preferences… button.  The Preferences dialog will appear. 

 

4. Select the Existing 10’ Mjr – 2’Minor preference. 

5. <D> the Load then Close buttons. 
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6. <D> the Apply button.  The View Contours dialog will minimize as the 
triangles are generated.  The dialog will reappear when it is finished. 

7. <D> the Close button in the View Contours dialog. 

8. Using MicroStation viewing commands Fit Active to review your 
results. 
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9. From the pull-down menu, select Survey > Find Point in View 

10. Find Point Name: 20005 Radius: 20 

 

 
 

Note:  There is a problem with a random point in the roadway.  The test 
hole location that were imported with the import wizard has a 
busted elevation. 

20005
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11. Locate point name 20005 in the fieldbook using the  
  Select Observation button from the Fieldbook Data dialog. 

12. <R> the point name 20005 and select Edit from the shortcut menu or 
double click the point name.  The Edit Observation dialog will appear 
for point 20005. 

 

13. Key-in the Elevation: 6581.51 

 

14. <D> the Apply then Close buttons.  The elevation will be corrected for 
the final DTM export. 
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15. From the pull-down menu, select Survey > Find Point in View 

16. Find Point Name: 8000 Radius: 20 

 

 

Note:  There is a problem with the breakline.  The breakline has a bust in 
the rod height. 

8000
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17. Locate point name 8000 in the fieldbook using the  
  Select Observation button from the Fieldbook Data dialog. 

18. <D> the point name 8000 then hold down the Shift key and select point 
name 8002.   

 

19. <R> the selected list and select Edit from the shortcut menu.  The Edit 
Observation dialog will appear. 
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20. Key-in the Target Height: 13.27 

 

21. <D> the Apply then Close buttons.  The elevation will be corrected for 
the final DTM export. 

22. Save the Survey fieldbook.  From the Workspace Bar <R> on 
12345SURVFieldbook01 select Save from the shortcut menu. 
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Profiles 
Another method to evaluate a DTM is by extracting profiles across the surface. 
These 2D line drawings give the user the ability to extract vertical views from 
any triangulated DTM at any location or vertical distortion. 

The profile command in InRoads Survey is limited to creating profiles by 
interactively selecting the needed location in the MicroStation view. 

The profile command in InRoads is more robust allowing the user to define the 
profile location by interactively selecting points (Multipoint), by Alignment, 
Graphics, or by locations defined in an ASCII file. 
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Multipoint Profile as Section check 
1. From the pull-down menu, select Survey > Find Point in View 

2. Find Point Name: 13121 Radius: 80 

 

Note:  Using the Multipoint Profile command will be used to evaluate 
key areas such as this culvert crossings. 

3. Using MicroStation Level Display, Turn OFF all Terrain levels as shown 
above. 

4. From the pull down menu select, Tools > Global Scale Factors…  The 
Scale Factors dialog will appear. 

 

 If Global Scale Factors is not an option go to the InRoads pulldown 
menu and select: 
Tools > Application Add-Ins > Global Scale Factors Add-In 
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5. <D> the Lock button.  The button display will change showing as 
unlocked. 

 

6. Key-in scale Cell: 1 

7. <D> the Apply then Close buttons. 

8. From the pull down menu select,  
Evaluation > Profile > Create Profile.  The Create Profile dialog will 
appear. 

 

9. <D> the Preferences… button.  The Preferences dialog will appear. 
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10. Select the preference name 5x Vertical 

11. <D> the Load then Close buttons. 

12. On the [Main] tab key-in Set Name: DTM Chk1 

13. Verify 12345SURVSurface01is checked in the Symbology section. 

 

14. <D> the [Features] tab. 
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15. Check the Crossing Features box. 

16. <D> the [Controls] tab. 

17. Check Off the Window Clearance Apply box. 

18. Check ON the Display Planimetrics box. 

 

19. <D> the Apply button.  The dialog will minimize allowing you to select 
points in the MicroStation view. 
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20. <D> a point in the MicroStation view at the north end of the and center 
of the road.. 

 There is no need to hold down on the Left mouse button. 

21. Move the cursor, a line will begin to generate 

 

22. <D> a second point perpendicular across the roadway crossing the 
culvert, as shown above. 

23. <R> to quit defining profile extraction vertices. 

24. <D> a location in the MicroStation view to draw the profile.  The Create 
Profile dialog will reappear and the Profile is generated in the view. 

2 Data point

1 Data point

3 Data point 
Profile Location 
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25. Review your results. 

26. Continue to Create Profiles at key locations. 

 Culvert Crossings 
 Driveway Entrances 
 Centerlines 

When finished: 

27. Using MicroStation Delete button.  Delete all DTM Check profiles. 

28. Save the Survey fieldbook.  From the Workspace Bar <R> on 
12345SURVFieldbook01 select Save from the shortcut menu. 
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Final Export and save 
The fieldbook has been corrected until there are no more visible errors.  Now the 
fieldbook will be exported to a DGN, DTM, and ALG files. 

Lab 13: Exporting Survey Data to Graphics 

Managing Drawings in the Reference Files folder 
The files in the Reference Files folder are for other disciplines to reference.  
Other disciplines are to reference in the 01 model file.  There are already 01 files 
in the Reference Files folder that are out of date.  The new Survey Fieldbook 
that is exported will become the new 01 file. 

1. Open Windows Explorer 

2. Navigate to the folder 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\ 

 

3. Rename each file 12345SurveyTopo* with a 01 counter and rename it to 
02. 

Note:  The next steps will create these model files with an updated 
InRoads Survey fieldbook. 
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Creating new 01 model files 

4. From the MicroStation pulldown menu select File > Open the Open 
dialog will appear. 

5. In the MicroStation Manager dialog path to the directory:  
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\ 

6. Select the file 12345SurveyTopo##Scale##.dgn from the Open dialog. 

 

Note:  The purpose of the files with “##” symbols are for creating new 
files with the correct naming convention. 

7. <D> OK the MicroStation Manager dialog will close and open the file. 

8. From the MicroStation pulldown menu File > Save As the Save As 
dialog will appear. 
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9. Replace the ## symbols with 100 scale and 01 model.  
Type in Files: 12345SurveyTopo100Scale01.dgn 

10. <D> the OK button the Save As dialog will close and MicroStation will 
open the file 12345SurveyTopo100Scale01.dgn 

11. Verify the 12345SURVFieldbook01 fieldbook is active.  You can tell 
which fieldbook is active by the red box around the fieldbook button. 

12. To modify the scale as it relates to cells, text, and linestyles go to Tools > 
Survey Options > [General]. The Survey Options dialog will appear. 

13. Set the Scales for Cell, Text, and Line as shown below. 

 Cell Scale:100 
 Text Scale:100 
 Line Scale:100 

 

Note:  Segregate Text by Feature Level, should be checked on, this will 
save the symbols, point names, codes, notes, errors, and 
elevations to the same level as the survey feature. 

14. <D> Save then OK the Survey Options dialog will close. 
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15. Once the settings are complete, to write the survey data to graphics, go to 
the pull-down select, 
Survey > View Survey Data > Write Survey Data to Graphics… the 
Write Survey Data to Graphics dialog will open. 

 

Note:  By default if you had dynamic graphics still toggled on, those 
same components would be toggled on in the Write Survey Data 
to Graphics dialog. 

16. Check only the Planimetrics box. 

 

17. Set Curve Stroking: Horizontal Only 

18. <D> the Apply button. The graphics will be created in the design file. 

19. <D> the Close button. The Survey fieldbook planimetrics has been 
written to graphics. 

20. Verify all View Survey Data buttons are toggled display off. 
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21. From the MicroStation view border Fit the design file. 

22. Review your results. 

23. From the CDOT Menu pull-down select Add On’s > Stratify Survey.  
The Stratify Survey dialog will appear. 

 

Notes:  

o Under Existing Files, the Append option will add or merge the 
new data into an existing file. A new file will be created if the file 
does not already exist. 

o Under Existing Files, the Overwrite All option will create a new 
file, deleting any previously existing file. 

o Under Existing Files, the Overwrite None option will disable the 
processing option for a file if the file already exists. 

o The Process option Adjust Planimetrics will resize the 
planimetrics text (if necessary) and convert the grouped text 
strings to view independent cells in order to allow for viewing 
this text in any 3D view. 
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24. Verify the JPC, Scale, and Sheet Number entries are correct.  Altering 
any of those values will automatically alter the output file names.  If the 
Attach check box in the Contours section is grayed out, the contour file 
does not exist.  You may edit the name specified in the File Name field 
to enter the name of an existing contour file. 

25. <D> OK button to start the process. 

26. As the data is being moved to the appropriate reference file a Processing 
Status dialog provides an update on the progress.  You may <D> Cancel 
at any time to stop the processing, if necessary. 
 

 

27. When completed, a Processing Completed message is displayed.  <D> 
OK to exit the program. 
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28. The fieldbook data has now been stratified into separate reference files. 
The planimetrics will be in the master design file with all of the symbols, 
names, codes, etc., attached as reference files. To view these attachments 
select File > Reference from the MicroStation pull-down menu. 
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Lab 14: Exporting Survey Data to Surface 
 

Managing Drawings in the Reference Files folder 
The files in the Reference Files folder are for other disciplines to reference.  
Other disciplines are to reference in the contour model file.  There is already a 
contour file in the Reference Files folder that is out of date.  The new Survey 
Fieldbook that is exported will become the new contour file. 

1. Open Windows Explorer 

2. Navigate to the folder 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\ 

 

3. Rename the file 12345SURVContour100Scale2_10.dgn  with a counter 
02. 

4. From the MicroStation pulldown menu select File > New from the pull-
down menu.  The New dialog will appear. 

5. Navigate to the file folder Reference_Files by double clicking the 
directory folders. 

6. At the bottom of the dialog box verify that the seed file is set to 
Roadway_Design_3D.dgn.  
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7. Key in the file to be created: 
12345SURVContour100Scale2_10.dgn 

8. <D> the OK button in the New dialog.  The New dialog will close and 
the file 12345SurveyTopoCodes100Scale01.dgn will open. 

  

9.  Verify the 12345SURVFieldbook01 fieldbook is active.  You can tell 
which fieldbook is active by the red box around the fieldbook button. 
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Survey Data to Surface 

10. From the InRoads pull-down menu, select File > New.  The New dialog 
will appear. 

11. Select the Surface tab. 

12. Key in the surface Name: 12345SURVSurface01 

13. Key in the Description: CDOT Surface Final 

Note:  Key in any additional file information in the Description field of 
the dialog, such as Date, User, and Design file name. You have 
up to 34 characters even though you may not see all the 
characters in the Description field. 

14. Keep the Maximum Length set to 0 

15. Set pick list to the Preference: Existing 10’ Mjr – 2’ Minor 

 

16. <D> the Apply then Close buttons. 

17. From the pulldown menu Survey > Survey Data to Surface.  The 
Survey Data to Surface dialog will appear. 
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18. Pick from the list in the surface name 12345SURVSurface01 in the 
Surface Name field. 

19. Set the Description to Use Feature Definition 

20. Keep the Tolerance and Maximum Segment Length set to 0.00 

21. Set the Curve Stroking Mode to Horizontal Only 

22. Check Always Use: Style 

23. Check Triangulate Surface 

 

24. <D> the OK button.   

25. An alert dialog will appear informing you will be appending a surface.  
This is alright to do so because this Surface was created with no data in 
the Surface. 

 

26. <D> the Yes button. 

27. The Alert dialog will close and the Triangulate Surface dialog will 
appear. 
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28. Leave all settings unchecked. Maximum Length should be set to 0.00. 

29. <D> the Apply button.  The Results section of the dialog should look 
similar to the image below. 

 

30. <D> the More button. The Surface Properties dialog will appear. 

 

31. Verify you are working with the correct surface 
12345SURVSurface01. 

32. Review the section for Data Range. The Northing, Easting, and 
Elevation values should fall within the project limits. 



 Chapter 8 Exporting the Fieldbook 

 

 

33. On the Advanced tab choose  
Cross Sections - Symbology: T_Existing Ground 

34. On the Advanced tab choose  
Profiles - Symbology: T_Existing Ground 

 

35. <D> Apply then Close in the Surface Properties dialog. 

36. <D> the Close button in the Triangulate Surface dialog. 

37. Use the Workspace pane scroll arrows to view the Surfaces tab. 

 

 

38. Verify 12345SURVSurface01 is the active surface.  
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Note: You can change the active surface from the pull-down menu 
Surface > Active Surface; highlight the surface name and 
 <D> the Apply button. 

39. From the pull-down File > Save > Surface.  The Save As dialog will 
appear with the Save as type set to Surfaces (*.dtm). 

40. Verify you are in the correct project directory. 
C:\Projects\12345\ROW_Survey\InRoads\DTM 

 

41. The file name should match the Active name at the bottom of the Save 
As dialog.  If necessary, use the drop-down arrow in the Active field and 
reselect the desired name to ensure the saved file name will match the 
surface name. 

Note:  Ensuring that the saved Surface name in the project folder 
matches the Surface name displayed in InRoads explorer will 
minimize any confusion. 

42. <D> the Save then Cancel button.  The file will be saved to disk and the 
Save As dialog will close.  
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Exterior Boundary 
Errant triangles can be eliminated by controlling the maximum triangle length. 
However this can cause problems in areas of the DTM where data density 
varies. A more refined method is to add an exterior boundary that constrains the 
triangles to fall within the limit of the exterior boundary. 

This process will involve several steps, they are: 

 Delete unwanted triangles from the model 
 Display the perimeter of the model (active triangle limits) 
 Import the displayed perimeter into the DTM as an exterior 

feature. 
 Verify the results 

43. Using MicroStation Delete.  Delete all triangles from the DGN file. 

44. Using MicroStation Window Area button center the graphics to  
View 1 Top rotation. 
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45. From the pull down menu select,  
Surface > View Surface Perimeter.  The View Perimeter dialog will 
appear. 

 

46. <D> the Preferences… button.  The Preferences dialog will appear. 

47. Select CDOT from the Preferences dialog 

48. <D> the Load then Close buttons in the Preferences dialog. 

49. <D> the Apply button in the View Perimeter dialog. 

50. Review your results. 

 

Note:  The perimeter will be used as a reference line as triangles are 
deleted. 

51. Verify Write Lock    is toggled OFF.  
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 OFF 

52. Redisplay the triangles Surface > View Surface > Triangles.  The View 
Triangles dialog will appear. 

53. <D> the Apply button in the View Triangles dialog. 

 

Note:  Make a mental note of the display where triangles need to be 
removed. 

54. Use the MicroStation view border button to Refresh the view.  The 
temporary triangles will disappear. 

55. From the InRoads pull down menu select,  
Surface > Edit Surface > Delete Triangles.  The Delete Triangle dialog 
will appear. 

 

56. Check on View Triangles 

57. <D> the Apply button.  The Delete Triangle dialog will minimize 
allowing you to select a point in the view. 

58. <D> a point in the MicroStation view off to the side of the surface limits. 
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 There is no need to hold down on the Left mouse button. 

 

59. Move the cursor, a line will begin to generate 

60. Sweep the cursor over the surface model to dynamically highlight 
surface triangles 

Note:  The line highlights triangles as they are crossed. Highlighted 
triangles will be removed from the surface model once a data 
point <D> is given to establish the endpoint of the line 
(selection).  

61. <D> a second point to define the line at the point shown above. 

62. <D> a point in the view to accept and delete the triangles. 

63. Continue drawing lines to remove undesirable triangles from other areas 
of the surface. 

64. <R> when you have completed deleting triangles from this zoom ratio.  
The Delete Triangle dialog will reappear. 

Note:  You can write triangles to the display as MicroStation graphics 
at any time. Do not re-triangulate the surface before defining an 
exterior boundary as deleted triangles will be re-established.  

Note:  If the triangles are redisplayed, keep in mind, displayed triangles 
are a reflection of what InRoads has in memory at a specific 
point in time. If triangles are deleted (from memory) the 

Second Data point

First Data point 
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MicroStation graphics displayed will not reflect this change until 
the triangles written to graphics are redisplayed (refreshed). 
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65. Use MicroStation to view border button to Window into an area of the 
survey. 

66. From the View Survey toolbar toggle display ON for Symbols  

 If your symbols are not displaying make sure the level is turned on. 

 

Note:  Triangles should only span between known (collected) points. 
The above graphic shows a group of triangles that should be 
eliminated. 

67. Continue to Pan along the file and Deleting triangles.  Don’t be 
concerned that the model may not be perfect for this training. 

When you have finished: 

68. <D> the Close button in the Delete Triangle dialog. 

69. From the View Survey toolbar toggle display OFF for Symbols  

70. Verify Write Lock    is toggled ON.  

 ON 

71. Redisplay the perimeter Surface > View Surface > Perimeter.  The 
View Perimeter dialog will appear. 

72. <D> the Apply button in the View Perimeter dialog. 
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73. Review your results. 

 

Note:  This closed shape represents the edge of the surface (triangles) 
spatially correct (location and elevation). Importing this shape 
into the DTM will act as an exterior boundary to constrain the 
triangulation process. 
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74. From the InRoads pull down menu select, File > Import > Surface.  The 
Import Surface dialog will appear. 
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75. <D> the [From Graphics] tab. 

76. Set the following dialog items: 

 Surface: 12345SURVSurface01 
 Load From: Single Element 
 Elevations: Use Element Elevations 
 Key-in Seed Name: Exterior1 
 Feature Style: T_Exterior Boundary 
 Point Type: Exterior 

 

77. <D> the Apply button.  The Import Surface dialog will minimize 
allowing you to select the perimeter element. 
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78. <D> on the surface Perimeter graphics displayed in MicroStation View 1. 

 

79. <D> again to accept this element.  The Import Surface dialog will 
reappear. 

80. <D> the Close button in the Import Surface dialog. 

81. From the pull down menu select, Surface > Triangulate Surface. The 
Triangulate Surface dialog will appear. 

 

82. <D> the Apply button in the Triangulate Surface dialog. 
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83. <D> the More button on the Triangulate Surface dialog.  The  
Surface Properties dialog will appear. 

84. Review your results. 

 

Note:  The surface now has Exterior point data, your numbers will not 
match exactly. 

85. <D> the Close button in the Surface Properties dialog. 

86. <D> the Close button in the Triangulate Surface dialog. 



Colorado Department of Transportation   

 

Page 286  InRoads Survey 

87. Redisplay the triangles Surface > View Surface > Triangles.  The View 
Triangles dialog will appear. 

88. <D> the Apply button in the View Triangles dialog. 

89. Review your results. 

 

90. Save the Surface DTM file <R> right click on 12345SURVSurface01 
select Save from the shortcut menu. 
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 Contour Files 
Contour information will be saved to separate files for ease of referencing and 
level control.  Each scale and contour interval will have a unique name. 

91. From the pull-down menu select, Tools > Options.  The InRoads 
Options dialog will appear. 

 



Colorado Department of Transportation   

 

Page 288  InRoads Survey 

92. <D> the Factors tab. 

 

Note:  The values shown here will be applied to all commands that 
display text, cells, or line styles. 
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93. Verify the Text, Cell and Line Style Scale Factors to 100 

94. <D> the Apply then Close buttons. 

95. From the pull-down menu select,  
Surface > View Surface > Contours.  The View Contours dialog will 
appear. 

 

96. Verify the active Surface: 12345SURVSurface01 

97. <D> the Preferences button. 

 

98. Select the preference Existing 10’ Mjr – 2’ Minor 

99. <D> the Load then Close buttons. 
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100.<D> the Apply button.  The View Contours dialog will temporarily 
minimize as the surface is processed and the contours are generated the 
dialog will reappear when the contours have been generated. 

101.Review your results. 
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Lab 15 Exporting Survey Data to Geometry - FINAL 
1. Verify the 12345SURVFieldbook01 fieldbook you want to export is 

active.  You can tell which fieldbook is active by the red box around the 
fieldbook button. 

2. From the pull-down menu, select File > New.  The New dialog will 
appear. 

3. Select the Geometry tab. 

 

4. From the type pick list verify the Type: Geometry Project 

5. Key in the geometry Name: 12345SURVGeometry01 

6. Key in the Description: CDOT Geometry Final 

Note:  Key in any additional file information in the Description field of 
the dialog, such as Date, User, and Design file name. You have 
up to 34 characters even though you may not see all the 
characters in the Description field. 

7. <D> the Apply and Close buttons. 

8. From the pull-down menu, select  
Survey > Survey Data to Geometry.  The Survey Data to Geometry 
dialog will appear. 
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9. In the Project Name: select from the list 12345SURVGeometry01 

10. Set the Description to Use Feature Definition 

11. Set the Curve Stroking to Horizontal Only 

 

12. <D> the Apply button. 

13. An alert dialog will appear informing you will be appending a Geometry.  

 

14. <D> the Yes button. 

15. <D> the Close button in the Survey Data to Geometry dialog. 

16. Use the Workspace pane scroll arrows to view the Geometry tab. 
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17. Verify 12345SURVGeometry01 is the active Geometry Project. 

Note:  You can change the active Geometry from the pull-down menu 
Geometry > Active Geometry then highlighting the desired 
geometry project name and <D> the Apply button. 
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18. From the pull-down File > Save > Geometry Project.  The Save As 
dialog will appear with the Save as type set to Geometry (*.alg). 

19. Verify you are in the correct project directory. 
C:\Projects\12345\ROW_Survey\InRoads\Geometry 

 

20. The file name should match the Active name at the bottom of the Save 
As dialog.  If necessary, use the drop-down arrow in the Active field and 
reselect the desired name to ensure the saved file name will match the 
surface name. 

Note:  Ensuring that the saved Geometry name in the project folder 
matches the Geometry name displayed in InRoads explorer will 
minimize any confusion. 

21. <D> the Save and then the Cancel button.  The file will be saved to disk 
and the Save As dialog will close. 
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Lab 16 Saving an InRoads Project file RWK 
Project file stores the location of multiple InRoads files.  RWK files allow the 
user to open just one RWK which could load a survey, surface, and geometry 
project.  The RWK can be opened and edited in Notepad incase there are 
changes in the directory structure. 

1.  From the pull-down menu, select File > Save > Project.  The Save As 
dialog will appear. 

 

2. Key-in the File name: 12345Project.rwk 

3. <D> the Options… button.  The Project Options dialog will appear. 
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4. From the Surfaces tab check the Add and Update boxes for Surface 
Name 12345SURVSurface01. 
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5. From the Geometry Project tab check the Add and Update boxes for 
Geometry Name 12345SURVGeometry01. 

 

6. From the Survey tab check only the Add box for Survey Name 
12345SURVFieldbook01. 

 

Note:  By only selecting the Add check box for the Survey tab the file 
will act as read only when opened and saved with the RWK file 
in the future. 

7. <D> the OK button.  The Project Options dialog will close. 
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8. <D> the Save then Cancel buttons.  The Save As dialog will close. 
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Lab 17 Directory Clean up 
1. Open Windows Explorer Windows + E 

2. Navigate to the folder C:\Projects\12345\ROW_Survey\Working 

3. Delete any old or duplicated files for the Working directory. 
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 Additional Exercises 

 

 

Additional Exercises 

Surfaces 

Locks 
 

Locks Toolbar 

 

 

 

Locate Graphics/Features

Snap Element/Point/No 
Station Lock 

Report Lock 

Feature Filter List
Feature Filter Lock 

aStyle Lock 
a Pen/Pencil Mode

Delete Ink Lock

Write Lock Toggle 
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1. Open a new working MicroStation model file. 

2. Open an InRoads Surface. 

3. Verify Write Lock    is toggled ON. The Write Lock is on if the two 
mode buttons to the left of the Write Lock button are colorized. Write 
lock ON – Display and Write mode – graphics show on screen and are 
written to the CAD file. 

 ON 

 Write lock OFF – Display Only mode – Note the two mode 
buttons to the left of the Write Lock button are dithered.  Graphics 
show on screen but are not written to the CAD file.  With Write 
lock off, graphics are written to the CAD display only.  Any 
commands that require the view to refresh will eliminate the 
graphics. 

 OFF 

4. Verify both the Feature Filter Lock    and Style Lock    are 
toggled OFF.  The Locks are toggled OFF when the button appears 
darker. 

OFF 



 Additional Exercises 

 

 

5. From the InRoads pull down menu select,  
Surface > View Surface > Triangles.  The View Triangles dialog will 
appear. 

 

6. <D> the Apply button.  The View Triangles dialog will minimize as the 
triangles are generated.  The dialog will reappear when it is finished. 

Note:  The triangles displayed are not using the correct element 
attributes for color and level.  Using the Pencil mode will erase 
the current displayed triangles and redisplay the correct element 
attributes for existing triangles. 

 

7. <D> the Preferences… button.  The Preferences dialog will appear. 

 

8. Select the Existing preference. 
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9. <D> the Load then Close buttons. 

 

10. <D> the Apply button. 

Note:  Notice how the old triangles are “erased” and the new triangles 
are redrawn using the loaded existing preference. 



 Additional Exercises 

 

 

Advanced Locks 
These are only generalized steps to guide you.  Ask your instructor if you have 
any questions. 

11. Using MicroStation Delete.  Delete all triangles from the DGN file. 

12. Toggle the Write lock from Pencil    mode to Pen    mode. 

 

13. Display the triangles using Preference Existing. 

14. Redisplay the triangles using Preference Proposed. 

Note:  You should end up with two sets of triangles.  Pen mode can be 
used for other display operations such as perimeter and contours. 

 

When you have finished: 

15. Using MicroStation Delete button.  Delete all triangles from the DGN 
file. 

16. From the MicroStation pull down menu select,  
File > Compress > Design 

17. Verify your Locks toolbar is set back to Pencil    mode. 
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Global Scale Factor 
InRoads annotation (text, cells, and linestyles) is controlled with configurable 
scale settings. In the case of contour labeling, text size is driven by 2 factors.  
The text size specified in the View Contours dialog box and the active settings 
(multiplier) defined through the use of a Global Scale Factor. 

1. Open a new working MicroStation model file. 

2. Open an InRoads Surface. 

3. From the pull-down menu select, Tools > Options.  The InRoads 
Options dialog will appear. 

 



 Additional Exercises 

 

 

4. <D> the Factors tab. 

 

Note:  The values shown here will be applied to all commands that 
display text, cells, or line styles. 
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5. Set the Text, Cell and Line Style Scale Factors to 100 

 

6. <D> the Apply then Close buttons. 



 Additional Exercises 

 

 

7. From the pull-down menu select,  
Surface > View Surface > Contours.  The View Contours dialog will 
appear. 

 

8. Verify the active Surface: 12345SURVSurface01 

9. Load the CDOT Preference 

10. <D> the Apply button.  The View Contours dialog will temporarily 
minimize as the surface is processed and the contours are generated the 
dialog will reappear when the contours have been generated. 



Colorado Department of Transportation   

 

Page 310  InRoads Survey 

11. Review your results. 

 



 Additional Exercises 

 

 

12. From the pull-down menu select, Tools > Options.  The InRoads 
Options dialog will appear. 

13. <D> the Factors tab. 

14. Set the Text, Cell and Line Style Scale Factors to 50 

 

15. <D> the Apply then Close buttons. 
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16. <D> the Apply button in the View Contours dialog.  Notice the change 
in the annotation size. 

 

Note:  The Global Scale Factor dialog is frequently used. It can be 
added to the interface for easy access. 



 Additional Exercises 

 

 

17. From the pull down menu select, Tools > Application Add-Ins, the 
Applications Add-ins dialog will appear. 

18. Check on Global Scale Factor Add-In.  

 

Note:  The Description section of the dialog will give details where to 
find the added command in the pull down menus. 

19. <D> the OK button.  The Application Add-ins dialog will close. 

20. From the pull down menu select, Tools > Global Scale Factors...  The 
Global Scale Factors dialog will appear. 

 

Note:  The Scale Factors dialog can remain open saving space and time. 

21. Key-in the Text, Cell, and Line Style Scale Factors dialog to 100 

 

22. <D> the Apply button.   
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View Surface Display Constrained 
Most surface display commands have the option to display within the limits of a 
fence place in a MicroStation model. 

1. Open a new working MicroStation model file. 

2. Open an InRoads Surface. 

3. From the InRoads pull down menu select,  
Surface > Update 3-D/Plan Surface Display.  The  
Update 3-D/Plan Surface Display dialog will appear. 

 

4. Select the Mode: Display On radio button. 

5. Verify 12345SURVSurface01 is the active surface. 

6. Check Perimeter box 

7. Check Contours box. 

8. <D> the Apply buttons.  The Contours and Perimeter graphics will be 
displayed to the design file. 



 Additional Exercises 

 

 

9. Using MicroStation view commands window into a portion of the 
surface. 
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10. From the MicroStation Main toolbar <D> the Place Fence button. 

11. From the Tool Settings dialog select Fence Type: From View 

 

12. <D> a point in View 1.  The Fence will appear around the edge of the 
view border. 



 Additional Exercises 

 

 

13. From the InRoads pull down menu select,  
Surface > Update 3-D/Plan Surface Display.  The  
Update 3-D/Plan Surface Display dialog will appear. 

 

Note:  Notice this time Fence Mode became active and the mode is set 
to Inside. 

14. <D> the Apply button.  The triangles will display inside the fence. 
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15. Using MicroStation view commands zoom out from the triangles and 
review your result 

 

16. <D> the Close button in the Update 3-D/Plan Surface Display dialog. 



 Additional Exercises 

 

 

View Contour Settings 
1. Open a new working MicroStation model file. 

2. Open an InRoads Surface. 

3. Using MicroStation Delete button.  Delete all Contours in the drawing. 

4. From the pull-down Surface > View Surface > Contours.  The View 
Contours dialog will appear. 

5. Verify the active Surface: 12345SURVSurface01 

 

6. <D> the Preferences… button.  The Preferences dialog will appear. 

 

7. Select the Preference Existing 10’Mjr – 2’ Minor 

8. <D> the Load then Close buttons 
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Note:  Notice the change in the Interval and Minors per Major 
settings. 

9. <D> the Apply button. 



 Additional Exercises 

 

 

10. Review your results. 
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11. <D> the Advanced tab in the View Contours dialog. 

 

12. Select the drop down field Label: Majors and Minors in the Label 
Contours section. 

13. <D> the Apply button. Review your results. 



 Additional Exercises 

 

 

14. Continue to display contours using different settings in the  
Label Contours section. 

 

Note:  Ask your instructor if you have a question on any of these 
settings. 

When you have finished: 

15. Load the Preference Existing 10’Mjr – 2’ Minor  

16. Redisplay the contours. 
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 Profiles from existing alignments 
1. Open a new working MicroStation model file. 

2. Open an InRoads Surface. 

3. Open an InRoads Geometry Project. 

InRoads Survey only allows for multipoint profiles.  To create profiles from an 
existing alignment InRoads needs to be added.   

4. From the InRoads pull down menu select Tools > Application Add-ins.  
The Application Add-ins dialog will appear. 

 

5. Select the InRoads application and select the OK button.  InRoads 
application will be added to the interface. 



 Additional Exercises 

 

 

6. From the InRoads pulldown menu select  
Geometry > Active Geometry.  The Active Geometry dialog will 
appear. 

 

7. Select the Type: Horizontal Alignment 

8. <D> the Target    button.  The Active Geometry dialog will minimize 
allowing you to select the centerline in the MicroStation view. 

9. <D> the centerline of the road.  The centerline of road will highlight and 
the Active Geometry dialog will reappear. 

 

10. <D> the Apply then Close buttons.  The Horizontal Alignment name 
will be active. 
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11. From the pull down menu select, Geometry > Fit Alignment 

12. <R> in the MicroStation View 

13. From the pull down menu select,  
Geometry > View Geometry > Active Horizontal 

 

Note:  The above graphic is where the profile will be extracted. 



 Additional Exercises 

 

 

14. From the pull down menu select, Tools > Global Scale Factors…  The 
Scale Factors dialog will appear. 

 

15. <D> the Apply then Close buttons. 

16. From the InRoads pulldown menu select  
Evaluation > Profile > Create Profile.  The Create Profile dialog will 
appear. 

 

17. <D> the Preferences… button.  The Preferences dialog will appear. 

 

18. Select the preference name 5x Vertical 
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19. <D> the Load then Close buttons. 

20. On the [Main] tab key-in Set Name: DTM Chk Alignment 

21. Set the Radio button to Alignment 

22. Verify 12345SURVSurface01 is checked in the Symbology section. 

 

23. <D> the Apply button.  The dialog will minimize allowing you to select 
the location of the profile in the MicroStation view. 

24. <D> a location in the MicroStation view to draw the profile.  The Create 
Profile dialog will reappear and the Profile is generated. 



 Additional Exercises 

 

 

25. Review your results. 

 

26. Continue to generate profiles along the remainder of the centerline. 

When finished: 

27. Using MicroStation Delete button.  Delete all DTM Check profiles. 
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Cross Sections 
1. Open a new working MicroStation model file. 

2. Open an InRoads Surface. 

3. Open an InRoads Geometry Project. 

InRoads Survey does not  display cross sections.  To create cross sections from 
an existing alignment InRoads needs to be added. 

4. From the InRoads pull down menu select Tools > Application Add-ins.  
The Application Add-ins dialog will appear. 

 

5. Select the InRoads application and select the OK button.  InRoads 
application will be added to the interface. 



 Additional Exercises 

 

 

6. From the InRoads pulldown menu select  
Geometry > Active Geometry.  The Active Geometry dialog will 
appear. 

 

7. Select the Type: Horizontal Alignment 

8. <D> the Target    button.  The Active Geometry dialog will minimize 
allowing you to select the centerline in the MicroStation view. 

9. <D> the centerline of the road.  The centerline of road will highlight and 
the Active Geometry dialog will reappear. 

 

10. <D> the Apply then Close buttons.  The Horizontal Alignment name 
will be active. 
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11. From the pull down menu select, Geometry > Fit Alignment 

12. <R> in the MicroStation View 

13. From the pull down menu select,  
Geometry > View Geometry > Active Horizontal 

 

Note:  The above graphic is where the profile will be extracted. 



 Additional Exercises 

 

 

14. From the pull down menu select, Tools > Global Scale Factors…  The 
Scale Factors dialog will appear. 

 

15. Change the scales to 50. 

 

16. <D> the Apply then Close buttons. 

17. From the pull down menu select  
Evaluation > Cross Section > Create Cross Section….  The Create 
Cross Section dialog will appear. 

 

18. <D> the Preferences… button.  The Preferences dialog will appear. 
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19. Select the preference name CDOT 

20. <D> the Load then Close buttons. 

21. On the [Main] tab key-in Set Name: DTM Chk Alignment 

22. Set the Radio button to Alignment 

23. Verify 12345SURVSurface01 is checked in the Symbology section. 

 

24. <D> the Apply button.  The dialog will minimize allowing you to select 
the location of the profile in the MicroStation view. 

25. <D> a location in the MicroStation view to draw the profile.  The Create 
Profile dialog will reappear and the Profile is generated. 



 Additional Exercises 

 

 

26. Review your results. 

 



Colorado Department of Transportation   

 

Page 336  InRoads Survey 

Survey 

Survey Feature Filters 
The geometry project 12345SURVGeometry01 contains horizontal and 
vertical alignments for every linear item that was surveyed. Additionally the 
Cogo buffer contains points for every survey shot collected.  While this may be 
desirable information, often it is desirable to work with a subset of the survey 
information such as pavement centerlines, control lines, or other specific 
entities. Working with a subset of the information increases efficiency by 
working with a smaller data set and freeing-up additional computer memory for 
other operations. This can be accomplished by using Survey Feature Filters 
when exporting survey data (Fieldbook) to a geometry project. 

The goal is to have a geometry project that contains only the information 
important to establishing the centerline of the existing road.  The use of feature 
filters will assist in sorting the data for: 

 Control points 
 Pavement centerlines 

1. Open a new working MicroStation model file. 

2. Open an InRoads Survey Fieldbook. 

3. From the pull down menu select Survey > Survey Feature Filter.  The 
Survey Feature Filter dialog will appear. 

 

4. Toggle the radio button Start With: None 

5. Select Properties: Numeric Code 

6. Toggle the radio button Mode: Include 

7. Key-in the Value: 1316 

8. <D> the Add Rule button.  The rule will be added to the Rules List. 



 Additional Exercises 

 

 

9. Add additional numeric rules for:  

 1318 
 1319 
 1320 

10. Select Properties: Alpha Code 

11. Toggle the radio button Mode: Include 

12. Key-in the Value: 10* 

13. <D> the Add Rule button.  The rule will be added to the Rules List. 

14. <D> the Save As button.  The Save Filter As dialog will appear. 

15. Key-in the Name: Survey Keypoints 

 

16. <D> the OK button in the Save Filter As dialog. 

 

17. <D> the OK button.  The Survey Feature Filter dialog will close. 
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Note:  The Survey Feature Filter just built is for filtering information 
contained in a Survey Fieldbook and gets saved in the Survey 
Feature Table (fwf) file vs. in the InRoads Civil.ini file as 
Feature Filters do. Therefore, it gets applied within the 
Fieldbook and not in the InRoads Feature Filter interface. 
However the Filter Lock needs to be turned on in the InRoads 
Locks toolbar for it to be active. 

18. On the Locks toolbar, toggle ON the Feature Filter Lock 

 

Note:  Notice that 2 things happen, the Fieldbook Data dialog will 
update to display only the data that passes the filter. Also the 
MicroStation display will only display survey data that passes 
the filter. 



 Additional Exercises 

 

 

Importing multiple files 
To speed up the process of importing multiple files you can create a Group file. 
This.is a simple text file that points to the file location and import wizard to use.    
When it is available these are the steps for using Group Files on import. 

 From the pull-down menu, select File > Import > Survey Data.  The 
Import dialog will open. 

 Change the drop-down arrow Files of type: Group of Files (*.*) 
 Select the file LoadSDR_files.txt from the unfiltered list of files. 

 The Group of files option is a handy way to load multiple files at 
one time.  The file is a simple ASCII text file that shows the file 
location and import type.  Below is a screen shot of the file opened 
in Notepad.  This file would need to be created prior to using it on 
a different project. 

 

 

 In the Import dialog <D> the Import button. 
 <D> the Close button.  All the files listed in the text file will be 

imported. 

NOTEPAD SCREEN SHOT 
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Generating Feature Table Reports 

1. <D> the Feature Table    button from the Survey toolbar.  The 
Survey Feature Table will appear. 

2. Toggle off and uncheck any Survey Feature list filters from the 
Feature Table dialog as shown below. 

 

3. <D> the Report button.  The Feature Table Report dialog will appear. 



 Additional Exercises 

 

 

4. Explore the tabs Header and Body tabs. 

  

5. <D> the Save As button.  The Save As dialog will appear. 

 

6. Type the File name: CDOTFeatureReport.rpt 

7. <D> the Save then Cancel buttons.   

8. Use Notepad to review the report. 
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Metric Survey Data to Imperial Survey Data 
1. Open a new working MicroStation model file. 

2. Once MicroStation and InRoads opens. From the InRoads pull-down 
menu, select File > New.  The New dialog will appear. 

 

3. Select the Survey Data tab. 

4. Key in the Name: 12345SURVFieldbook01 

5. Select the Apply button. The new fieldbook will appear below. 

6. <D> the Close button. 



 Additional Exercises 

 

 

7. From the Workspace bar the 12345SURVFieldbook01 should be 
active. 

8. From the pull-down menu, select File > Import > Survey Data. The 
Import dialog will open. 

 

9. Change the Look in: folder to 
C:\Projects\12345\ROW_Survey\Survey\Raw_Data 

10. Verify the Files of type: Sokkia SDR (*.sdr) 

11. <D> the Options button. 

12. Verify the Cell, Text, and Line Scales are all set to 100 
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13. Select the Units tab. 

14. Change the Linear Format Units: Meters 

 

15. <D> the Save then OK buttons.  The Survey Options dialog will close. 

16. In the Import dialog select the data collector file you will be importing. 

17. <D> the Import the Close buttons.   

18. From the pull-down menu, select Survey > Fieldbook Data.  Take a 
minute to review the imported Survey control data that is now contained 
in the electronic Fieldbook. 



 Additional Exercises 

 

 

19. From the pull-down menu, select Tools > Survey Options the Survey 
Options dialog will appear. 

20. Select the Units tab. 

21. Change the Linear Format Units: US Feet 

 

22. <D> the Save then OK buttons.  The Survey Options dialog will close. 

23. From the pull-down menu, select Survey > Fieldbook Data.  Take a 
minute to review the transformed Survey data that is now contained in 
the electronic Fieldbook. 

Note:  The file has now been converted to US Feet Units. 

24. From the pull-down menu, select File > Save > Survey Data the Save 
As dialog will appear. 

25. <D> the Save and Cancel buttons.  The Save As dialog will close. 
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Exporting Survey Data to Sokkia SDR file 
Exporting the fieldbook out to a SDR format would be required if you wanted to 
use the points and stake them out in the field. 

1. Verify the 12345SURVFieldbook01 fieldbook you want to export is 
active.  You can tell which fieldbook is active by the red box around the 
fieldbook button. 

2. From the pull-down menu, select File > Export > Survey Data.  The 
Export dialog will appear. 

3. Change the directory to:  
C:\Projects\12345\ROW_Survey\InRoads\Field_Books 

4. Select the down arrow for Export as type: review the available file 
formats available. 

5. Select from the list Export as type: Sokkia SDR33 (*.sdr) 

6. Key-in the new file name 12345SURVFieldbook01.sdr 

 

7. <D> the Export button.  The Export dialog will close. 



 Additional Exercises 

 

 

8. Open Windows explorer Windows + E 

9. Open and review the file in Notepad. 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\ 
12345SURVFieldbook01.sdr 

 

 

Note:  This file is ready to be uploaded into the data collector.  If you 
need to import this file back into InRoads Survey for any reason 
you will need to add survey header information into file. 

NOTEPAD SCREEN SHOT 
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Exporting Survey Data using Text Export Wizard 
Exporting the fieldbook out to another format would be required if you wanted 
to use the points and stake them out in the field. 

1. Verify the 12345SURVFieldbook01 fieldbook you want to export is 
active.  You can tell which fieldbook is active by the red box around the 
fieldbook button. 

2. From the pull-down menu, select File > Export > Survey Data.  The 
Export dialog will appear. 

3. Change the directory to:  
C:\Projects\12345\ROW_Survey\InRoads\Field_Books 

4. Select the down arrow for Export as type: review the available file 
formats available. 

5. Select from the list Export as type: Text File (*.*) 

6. Key-in the new file name 12345SURVFieldbook01.txt 

 

7. <D> the Export button.  The Export dialog will close and the  
Text Export Wizard dialog will appear. 



 Additional Exercises 

 

 

 

8. Key-in Number of Columns: 7 

9. Key-in Delimiter: , 

10. Key-in File Header: CDOT Survey Training “Initials” “Date” 

11. Key-in File Tail: Exported Fieldbook 12345SURVFieldbook01.fwd 

 

12. <D> the Next > button.  The final Step 2 of 2 dialog will appear. 
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13. Select the header of the first column.  The column will highlight as 
shown below. 

14. From the Data Type radio button select String: Export 

15. Justification Left 

 



 Additional Exercises 

 

 

16. Select the second column header then select Point Name from the Data 
Type radio button. 

 Justification: Left 

17. Select the third column header then select Northing from the  
Data Type radio button. 

 Justification: Left 
 Precision: 2 

18. Select the fourth column header then select Easting from the  
Data Type radio button. 

 Justification: Left 
 Precision: 2 

19. Select the fifth column header then select Elevation from the  
Data Type radio button. 

 Justification: Left 
 Precision: 4 

20. Select the sixth column header then select Code from the  
Data Type radio button. 

 Justification: Left 

21. Select the seventh column header then select Point Description from the 
Data Type radio button. 

 Justification: Left 

 

22. <D> the Save As button.  The Save As dialog will appear. 
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23. Key in File name: ASCII Export.tew 

 

24. <D> the Save button.  The Save As dialog will close. 

25. The Save Format to File Types dialog will appear.  Verify 
Format Name: ASCII Export 

 

26. <D> the Yes button.  The Save Format to File Types dialog will close 
and the Step 2 of 2 dialog will reappear. 

27. In the Step 2 of 2 dialog <D> the Cancel button.  The Step 2 of 2 dialog 
will close. 



 Additional Exercises 

 

 

28. From the pull down menu select, File > Export > Survey Data 

29. In the Export dialog change the  
Export as type: ASCII Export (*.txt) 

30. Path to the directory: 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books 

 

31. <D> the Export button.  The Export dialog will close. 

32. Open Windows explorer Windows + E 

33. Open and review the file created in Notepad. 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\ 
12345SURVFieldbook01.txt 

 

 

 

NOTEPAD SCREEN SHOT 
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Exporting DC File from TGO 
 

The workflows for exporting a DC file that will include the notes and attributes 
can be found on the CDOT CADD Library web page 

 

 

 



 Additional Exercises 

 

 

The three files are: 

Example TGO DC file.dc 

Work flow for Attributes into InRoads.pdf 

Work flow for establishing a CDOT code library.pdf 
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Merging InRoads Survey Fieldbook files 
When a project is using more then one fieldbook for a particular job it is 
possible to merge those fieldbook files together.   

Items to address prior to merging fieldbooks: 

 There can not be duplicate point names between the fieldbooks. 
 If you are using figure strings make sure they are not going to conflict 

with the figure strings in the other fieldbook 

 

1. Open a new working MicroStation model file. 

2. Open an InRoads Survey Fieldbook. 

 

3. From the InRoads pulldown menu select File > Import > Survey Data 
The Import dialog will appear. 

 



 Additional Exercises 

 

 

4. Select the Files of type: Field book (*.fwd)  

5. Select the fieldbook name you want to import. 

 

6. <D> the Import then Close buttons.  The fieldbook files are now 
merged.
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