LAB 24 - Land Survey Control Diagram Plan
Sheet

Chapter Objectives:
e Import XML data into a MicroStation file
In this sheet, coordinate information will be input in a tabular format.

Return to the MicroStation manager dialog.

1. Select File > Close (if MicroStation is currently open).

M MicroStation Manager - C:\Projects\12345\ROW_Survey\Drawings\
Look in: Drawings - @7 E nj Ea_ #] 3D-VEDGN
R Name : Date modified  Type Size  *
e F12345ROW_Cnty-2418 #2.dgn  1/18/2008815.. MicroStation D...
RecentPlaces  F=l1334SROW Cnty-24:36_#2.dgn  1/18/2008815.. MicroStation D.. B ==
= F212345ROW_Mon##.dgn 1/18/2008815 ...  MicroStation D..
:’512345 ROW_Ownership==.dgn 1/18/2008 8:15 ...  MicroStation D...
Desktop %12345 ROW_Plan##.dgn 1/18/2008 8:15... MicroStation D...
g F412345ROW_TabProp0l.dgn 1/18/2008 815... MicroStation D...
] F412345ROW_TabProp02.dgn 1/18/2008815 ... MicroStation D...
CDOT User  23412345ROW_TabProp03.dgn 1/18/2008 815 .. MicroStation D...
i F{12345ROW_TabPropDd.dgn 1/18/2008 815 ..  MicroStation D... =
LY F212345R0W_TabPrope=.dgn 1/18/2008 815 .. MicroStation D..
Computer F=112345ROW _TitleSht.dgn 9/25/2009 817 ... MicroStation D...
_ F4123455URV_MonRerd==.dgn 1/18/2008 815... MicroStation D...
A [FZ1334550RV PlanLsCDe%.dgn  1/18/; . Microbtation D..
N;"or‘c E..a-lmi‘suR\f_FlanPCNﬁ.dgn 1/18/. «  MicroStation D...
F123455URV_Title SCD#2.dgn 1/18/2008 815 .. MicroStation D...
F123455URV_TitlePCD##.dgn 1/18/2008 815 .. MicroStation D...
‘ n »

Fle name: 12M5SURV_PlanL SCD#8 dgn - User: [CDOTUser =]

Fesoftype:  |AlFes() v] [ Cancel | Project: (12345 -

|| Open as read-only Options Interface: ’CDm'—'|

2. <D> the filename 12345SURV_PlanLSCD##.dgn
3. Select File > Save As from the MicroStation Manger dialog.

4. Key-in 12345S5URV_PlanLSCD3B.dgn
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5. <D> Save

M Save As - C:\Projects\12345\ROW_Survey\Drawings\ [
Save in: ). Drawings - 6 1’ B v
R MName = Date modified Type »
e | Reference_Files F123455URV_PlanLSCD##.dgn
Recent Places || Tabs F234123455URV_PIanPCD#%.dgn
) F12345ROW_Cnty-24x18_#=.dgn T24123455URV_TitleLSCD2#.dgn
- F2112345ROW_Cnty-24:36_##.dgn FZ123455URV_TitlePCD#2.dgn
Desktop _:‘!12345ROW'Mnn==.d_gn .
F2412345ROW_Ownership##.dgn
a"_ F212345ROW_Plan=%.dgn
i F2112345ROW_TabProp0l.dgn
CDOT_User  EZ12345ROW_TabProp02.dgn
e ;..’letiSROW_TamepDB.dgn
1,,&_‘. F23412345ROW_TabProp04.dgn
Computer  =J12345ROW_TabProp## .dgn
F2412345ROW_TitleSht.dgn
[ F21123455URV_MonRerd22.dgn
.,
MNetwork
File name: I 123455URV_PlanLSCD3B dgn - I Save
Save astype: [McmStation V& DGN Files (".dgn) '] Cancel

6. Zoom/Window into the upper-right corner of the sheet.

7. Edit the text as shown using Edit Text command.

Land Survey ControlDiagram

Plan Sheet

Project Number: STA 086A-039

Project Location: SH 86 CORRIDOR PE

Project Location: COUNTY RD. 25 & 27 & 33

Project Code:

Last Mod. Date

Subset Sheets

Sheet No.

12345

09-25-09

3 of X.XX

3B
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8. Use the MicroStation Fit command to view the entire sheet.

" M View1 - Top == Eon )

Land Survey Control Diagram
Plan Sheet
Project Number: STA 086A-039
Project Location: SH 86 CORRIDOR PE
Project Location: COUNTY RD.25 & 27 & 33

|

|Project Code:]Last Mod. Date Subset Sheets Sheet No.
|__12345 09-25-09 3 of XXX 3B
cﬂ'.&j@@.ii&-’éuu:ﬂ-@_ﬂﬂ:&]ud@’:v’&@-‘ - E

In this sheet, place coordinate information representing a Project Coordinate Summary Table.
This coordinate information will be extracted from InRoads using the reporting utility XML.

Using XML to report on Coordinates

Use InRoads and XML reporting to insert a Project Coordinate Summary Table. Report on
points 100-120.

B4 Bentley InRoads XM Edition [F=8|Eol ==
<Unnamed:> rEE 8N H X & E

FHle Suface Geometry Drainage Survey Evaluation Modeler Drgfting Tools Help |

B MA@ <Unamed> y KIBREIAY B el S L
MName Description Style No *

=-&n Geometry Projects A0 %100 Section Corner T_Section Cor... 1558
102 Quarter Section Corner T_Quarter Sect... 1558
103 Quarter Section Corner T_Quarter Sect... 1555
‘xﬁ 104 Quarter Section Corner T_Quarter Sect... 1555
105 Section Corner T_Section Cor... 1558
106 Quarter Section Corner T_Quarter Sect... 1558
‘..,“1 107 Quarter Section Corner T_Quarter Sect... 1555
‘x'. 108 Quarter Section Corner T_Quarter Sect... 1555 =
< | 1 | »

Extracts cross sections along an alignment or a linear graphics entity

9. If not already running and loaded:

o Launch InRoads & Load the Geometry Project 12345 ROW.alg from
C:\Projects\12345\ROW_Survey\InRoads\Geometry

10. Select Tools > XML Reports from the InRoads interface.
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11. In the XML Reports dialog, <D> the Geometry folder and identify Cogo points Z00-120

H Geometry Report f=) @
Horizortal Alignments Cogo Points
Include: ﬂ Include:  §100-120 i]

s ! ]
Name Description  Style Name Style - Filter
100 T_Section Comer
102 T_Quarter Section Co... |_
103 T_Quarter Section Co... |
104 T_Quarter Section Co...
105 T_Section Comer T
106 T_Quarter Section Co...
107 T_Quarter Section Co... ~
[ Include Vettical Alignments [ interval: (50,00 #|
@) All Active Limits
[Include Cant Alignments [] Station
@ Al Active
o tait 0+00.00 Y
nclude Vertical Event Points T = = E]]
[ Include Horizontal Event Poirts 5

12. <D> Apply. The report browser will open to a default report style.
13. <D> the CDOT Folder.

14. <D> the CDOT_ListCoordinates.xsl style sheet.

| 0] Bentley InRoads Report Browser - C:\Users\PCALLA~1\AppData\Local Temp\RPTROC2 xmi (E=3 fop ==
File Tools Help

|c — LOOT_XM\StandardsClobal'In R

(£3 Cant

& cooT
A COOT Adne Description xe
A} COOT Ar Rights Easement Description sl . .
A]) COOT Fes Parcel Descrintion x5l List Coordinates Report
A CDOT Pamanert Eassment Descrpbon xel
Aj] COOT Siope: Easement Description xsl Report Created: 9/25/2009
Af] CDOT Temporary Easement Description sl Time: 12:32pm
Aj] COOT Uity Easement Description xs!
A} COOT_ListCoordnates xsi

i
i

&) COOT_Morumentation_Clesrance xd Project: 12345 ROW
Aj] CDOT_Morumentation_ListCoordnates xsi Description:
51 Cearance C\Proj
— " . C\Projects\12345
S Eu:;“nﬂedm Filg Hoing: \ROW_SurveylinRoads\Geometry\12345_ROW alg
'ﬂ Evaluation Rm";:f‘ peallahan 9/25/2009 12:00:21 PM
Geometry L :
=3 Ics
|21 Images i
= s Cogo Points
] LegalDescription
=1 LightRaiManufacturing fﬂm MORTH ()  EAST ()  ELEV (f) DESCRIPTION
|23 Obsclete 100 155845741 326929523  6654.37 Section Camer
tj R“"’*‘:D’W‘ 102 155843090 326662998 665437 Quarter Section Comer

15. Select File > Save As
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16. Navigate to the 12345\ROW_Survey\InRoads\Reports folder and input the file
name 12345 PCSTO1.xml

©) Save As
Savein: Reports j ﬁ '

MName Date modif... Type Size Tags

=3
e + SBP Lot Lxml
Recent Places p—
|| SBP Lots 1-4.xml

Desktop

CDOT_User

A

[l
Computer
'™

-

Network

Save |
Cancel

Help

File name: 11 2345_PCSTOxml

Led Lo

Save as type: IXML File: (" ml)

17. <D> Save to save the file.

Excel in MicroStation

Tables can be created in MicroStation by linking information that is contained in an Excel
spreadsheet. There are several advantages to using the linked spreadsheet method. Some of

these are:
¢ Text formatting in the spreadsheet is retained by MicroStation
¢ Graphics (borders, girds, etc) are retained from the Excel file
¢ Updates to the Excel file are reflected in the MicroStation file

In the Bentley InRoads Report Browser:
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18. <R> on the report in the coordinate list area as shown. A fly out menu will appear.

0 Bentley InRoads Report Browser - C:\Users\PCALLA~1\AppData\Local\Temp)\RPTS304 xmi F=3 £on 5|
File Tooks Help
C\Workspace Workspace-COOT_XM\Standards-Global inRoads JMI ) =
=3 coot -
A} CDOT Adne Description xsl
Aj] CDOT Ar Rights Essement Description xsl
Aj] COOT Fee Parcel Description xsl
CDOT Pemmanent Eassment Description xs!
&) CDOT Slope Easemert Descrption xs ates Report
Af] CDOT Temporary Easement Descrption xsl ground
4] COOT Lkiey Easement Deseription xe - 9/25/2009
] CDOT_ListCoordnates xd Select Al 2 390m
Aj] CDOT_Monumentation_Clearance sl Paste |e
Aj] CDOT_Menumentation_ListCoordnates xs! =
] Create Shortcut
] Custom D Add to Favorites...
JE1 DatsCobection i
= 1ew Jource
= Evalaation ! eometry\12345_ROW alg
ill s Encoding 3
Bl 0:21 PM
—~ ? Print...
|20 tersecting Abgrement Stations i i e
= LegalDescription Cogo Print Preview...
| LightRaiManufactusng Refresh
151 MapCheck P
|3 Obsolete N Append to Existing POF ELEV (f) DESCRIPTION
] RoadwayDesign —
& schenim Convert to Adobe POF 6654 37 Section Comer
2] Stakecut Customize Menu 665437 Q
= uarter Section Comer
{51 SetionDfiset - Export to Microsoft Excel AT U =T .
| ill Forms. 4
RoboForm Toolbar
Save Forms
Properties

19. Place the cursor over the corrdinates (the bottom half of report) and select Export to
Microsoft Excel from the fly-out menu.

Excel should automatically launch if it is installed on the PC being used.

(0 = D (& ﬁ s Bookl [Compatibility Mode] - Microsoft Ex... =
-~ - -Home;| Insert | Page I.z| Formul _:_Data | RwiewJ \"leu_r | Develo| | Projec!‘| Acroha_| @ - o X
'-3 %  Calibri -S| G % Al iz 47~
;aste % |B_I__I_:II_£ Avl — §| EE' Mumber | Styles | Cells @r da-
| P 2 [ETeAT] |[EmER] M < 2
| Clipboard ™ Font P Alignment T Editing |
T — o
[ A B _ C T E | F | 6
1 [POINTINORTH (ft) EAST(ft)  ELEV (ft) DESCRIPTION
2 |INAME

3 | 100 1558457.41 3269295.23 06654.37 Section Corner

4 102 1558430.9 3266629.98 6654.37 Quarter Section Corner
5 103 1555770.83 3266639.57 6615.17 Quarter Section Corner
6 104 1555781.53 3269304.03 6627.27 Quarter Section Corner
7 105 1558527.87 3279643.18 6585.79 Section Corner

8 106 1558562.81 3282329.69 6505.88 Quarter Section Corner
9 | 107 1555920.99 3282335.45 6545.91 Quarter Section Corner
10| 108 1555884.03 3279671.7 6623.76 Quarter Section Corner

M 4 » ¥| Sheetl ~Sheet? ~Sheet3 . ¥ /
Ready | 7] |
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20. Make changes to the data or add formatting.

A B (& D E

1 | PROJECT COORDINATE SUMMARY TABLE

2 POINT NAME PROJECT COORDINATES

3 NORTH (ft)  EAST (ft) ELEV (ft) DESCRIPTION

4 100 1558457.41 326592595.23 6654.37 Section Corner

5 102 1558430.9 3266629.98 6654.37 Quarter Section Corner

6 (103 1555770.83 3266639.57 6615.17 Quarter Section Corner

7 104 1555781.53  3269304.03 6627.27 Quarter Section Corner

8 105 1558527.87 3279643.18 6585.79 Section Corner

9 106 1558562.81 3282329.69 6505.88 Quarter Section Corner

10 |107 1555920.99 3282335.45 6545.91 Quarter Section Corner

11 (108 1555884.03 3279671.7 6623.76 Quarter Section Corner
12

21. and save the spreadsheet to the ...\ROW_S

urvey\InRoads\Reports\ directory.

(%) Save As

P
L)v[;. <« 12345 » ROW_ Survey » InRoads » Reports

‘ Organize ~ f28 Views ~ B New Folder

Folders Name

J. ROW_Survey
| Correspondence
| Drawings
\. InRoads
\. DTM
|| Field_Books
i Geometry
Ji Legals
.. Reports

. Research

I Survey

-

File name:  Project Coordinate Summary

vl"f”Search

Date modified Size »

Type

Mo items match your search,

Save as type: [Exl:el 97-2003 Workbook (*.xls)

Authors: CDOT User
[] Save Thumbnail

4 Hide Folders

Tags: Add atag

Tools v [ Save | [ Cancel
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22. Select the range of information desired in the MicroStation file.

’__‘\ W9~ @ 5 Project Coordinate Summaryxls [Compatibil.M - = X
—Ly Home|| Insert | Page La| Formul | Data | Review | View | Develol| Project!| Acroba | @ - = x
= % ||| calibri i1 - | == S o, il E T
Paste 5 qg Ll l_E _= = ’ﬂ_"l Number = Styles | Cells E" i
- F B[O A |iE & (2| % 7 sl
Clipboard ™ Font P Alignment M Editina
| Al ~( ] PrROJECTCOMEM ~[12 ~[A X $ - % 0 F
= = = Bz | -H- AW e
1 PROJECT COORDINATE SUMNM ARV TADLE | !
2 [POINTNAME PROJECT COORDINATES | & | cut
3 NORTH (ft)  EAST (ft) ELE 12 Copy
4 |00 1558457.41 3269295.23 6 b Paste
5 |102 1558430.9 3266629.98 6 Paste Special...
6 |103 1555770.83 3266639.57 5 Insert...
7 |104 155578153 3269304.03 6 | peiete..
g8 |105 1558527.87 3279643.18 6  (iear Contents
9 |106 1558562.81 3282329.69 6 Filter = ]
10 |107 1555920.99 3282335.45 6 Z
11 |108 1555884.03 32796717 6 " ’
12 ] ] ] od Insert Comment
M 4> ] sheet1 /Sheet2 “Sheets /¥ NN %8| Format Cels...
L Average: 1209588.523 Count: 47  Sum: 38706832.72 |_|E Pick From Drop-down List...
Mame a Range...
@, Hyperlink...

23. <R> on the spreadsheet data and select Copy from the fly-out menu.

RETURN TO MICROSTATION

24. Select Edit > Paste Special from the MicroStation menu bar.

M1 Paste Special 22

Picture of Microsoft Office Excel 2003 W
Embedded Microsoft Office Excel 2003 W
Linked Microsoft Office Excel 2003 Work:|=
Text To Design File
Rich Text to Design Fle
Linked Text To Design File ¥

[ Paste I [ Cancel l

25. <D> the Linked Microsoft Office Excel 2003 Worksheet option.
26. <D> Paste

Note: By choosing linked, updates made to the Excel file can be passed back to the
MicroStation file through updating. Selecting embedded does not provide this
dynamic ability.
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27. In the Paste OLE dialog box, set Paste as to L/nk, Method to By Size, and input a
Scale of 10

M Paste OLE Object [o] @ ==

Object: Microsoft Office Excel 2003 Work
Paste asi [ Link )

Method: | By Size -

("] Display asicon
] Transparent Background
(] Rotate With View
Scale: | 10.0000
Size: (42.917x 20.937) "

Note: At this time, we do not fully understand the correlation between the scale and
resulting text size. For this example, 10 seemed to produce reasonable results.
Once placed, the text height can be measured and the bounding shape of the linked
Excel table can be scaled up or down accordingly to achieve required text size.

PROJECT COORDINATE SUMMARY TABLE
POINT NAME PROJECT COORDINATES ELEV (ft) DESCRIPTION
NORTH (ft)  EAST (ft)

100 1558457.41 3269295.23 6654.37 Section Corner

102 1558430.9 3266629.98 6654.37 Quarter Section Corner
103 1555770.83  3266639.57 6615.17 Quarter Section Corner
104 1555781.53 3269304.03 6627.27 Quarter Section Corner
105 1558527.87 3279643.18 6585.79 Section Corner

106 1558562.81 3282329.69 6505.88 Quarter Section Corner
107 1555920.99 3282335.45 6545.91 Quarter Section Corner
108 1555884.03 3279671.7 6623.76 Quarter Section Corner

Note: Entering a <D><D> on the table in MicroStation will launch the Excel application.
If the Excel file is edited (either from MicroStation or outside the CAD
application) select Edit > Update Links from the MicroStation menu bar to
refresh the linked MicroStation graphics.
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