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Chapter 15 - Tab Sheets

Once the design is completed, pay quantities can be gathered and entered into summary sheets. There are many 
methods of calculating quantities and many formulae used.  Once the quantities have been computed, they are 
entered into tab sheets and linked to MicroStation sheet border file for printing.  This module describes the 
process of entering calculated quantities into the tab sheet and attaching the sheet to the sheet border for 
printing.

Files Used

Three files are used to create the final tab sheet for printing.  These are:

 Trnsport_Itemlist.csv –This file contains the list of pay item codes from the Colorado 
Department of Transportation Master Item Code Book (Spec Year 05).  This file is located 
in the C:\Workspace\Workspace‐CDOT_XM\Standards‐Global folder and is automatically 
updated by ServerCop.

 JPC#SPEC_Tabulation of ???.xls – This is the file where the quantity data is entered.  The first 
part of the file name is the project code and the three to four letter abbreviation of the 
specialty group.  The last part of the name describes the type of data to be entered.  For 
example, the 88888DES_Tabulation of Guardrail.xls contains quantities and pay items 
related to guardrail.  These files are located in the C:\Projects\JPC#\Group\Drawings\Tabs 
folder.

 JPC#SPEC_TabMisc##.dgn – This file contains the sheet border for the printable tabulation 
sheet.  This file can be modified to contain project specific information (project code, RE 
cell, etc.).  It can also be copied if more tabulation sheets are required. This file is located in 
the C:\Projects\JPC#\Group\Drawings\Tabs folder.

Entering Data into the Spreadsheet

The process of inputting data into the spreadsheet is similar for all of the tab sheets.  The examples below use 
the DES_Tabulation of Surfacing.xls.

1. Open the DES_Tabulation of Surfacing.xls file.

2. <D> the Surfacing Sheet tab at the bottom of the Excel window.  This is where all the 
work in this file is performed.



Page 420 Colorado Department of Transportation

Chapter 15 - Tab Sheets A Practical Guide for Using InRoads XM

3. Verify that the text on line 1 to the right of the buttons is black.  Red text indicates that the 
pay item list file is not found in the specified location.

Note: If the text is red, the location of the pay item list file must be specified.  To specify 
the location:

4. <D> the Update / Browse for Pay Item File button.  This displays the Update / Browse 
for Pay Item File dialog box.

5. In the Update / Browse for Pay Item File dialog box, <D> the Browse for Pay Item File 
button. This displays the Open dialog box.
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6. In the Open dialog box, navigate to the location of the pay item list file, highlight it and 
<D> Open.

7. In the Update / Browse for Pay Item File dialog box, <D> the Return to Excel button to 
dismiss the Update / Browse for Pay Item File dialog box.

The next step is to add pay items to the spreadsheet.  Adding pay items automatically updates 
the Surfacing Sheet with the proper number of columns in the correct order.  The pay items do 
not have to be selected in order, they will be sorted by the program each time a new pay item is 
added.  To add pay items:

8. <D> the Data Entry button.  This displays the Surfacing Data Entry dialog box.
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9. Select the desired pay items from the list.  Multiple pay items can be highlighted by 
holding the Ctrl key then selecting the pay items. (Note: holding the Ctrl key and dragging 
through several items will deselect previously selected items.)

10. <D> the Add Items button to update the spreadsheet with the selected pay items.

11. <D> Close to dismiss the Surfacing Data Entry dialog box.

12. Additional items can be added as explained in steps 8 through 11.  The columns are 
resorted, keeping the column contents with the proper pay item.

Note: Pay items, like hot mix asphalt, activate an additional field above the table to 
specify the number of lifts used for construction.  The default value for this field is 
1.  To specify a different number of lifts:

13. <D> in the Number of Lifts cell below the desired pay item.

14. Use the drop down menu to select the desired number (from 1 to 5).
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The table is updated, adding the specified number of columns under the pay item heading.  
The lift columns are numbered from bottom to top, with the first lift named Bottom and the 
last lift named Top. The middle lifts are named Lift 2 through Lift 4.

Each Asphalt pay item also has an irregularity factor that is applied to the total quantity for the 
Bottom lift.  The default value is 5%.  To change the irregularity factor:

15. <D> in the % Irreg to Apply cell below the desired pay item.

16. Key in the desired percentage.

Note: If the value is deleted from the function line before entering the new value, enter 
either; the whole number percentage value with the “%” sign, or the decimal 
equivalent without the “%” sign.  Entering the whole number value without the 
“%” sign will result in a value 100 times larger than the desired value.

Next, quantity data is added to the sheet.  The spreadsheet does not do any calculations.  
Quantity calculations must be done prior to entering the data into the spreadsheet.  To add 
quantity data to the spreadsheet:

17. <D> in the first available From cell ( on row 10 if this is a new sheet).

18. Key in the desired starting (From) Station number for the quantity and press the Tab key.  

Note: The “+” sign is automatically inserted into the station number if it is not keyed in. 
Also, stations are rounded to the nearest whole station. 

19. Key in the desired ending (To) Station number for the quantity and press the Tab key.  
Continue pressing the Tab key until the cursor is in the desired pay item column.

20. Key in the quantity.  Tab to additional columns that have quantities for the station extents 
entered and key in their values.

21. Repeat steps  18 through 20 for each set of station extents.

The quantities are automatically totaled and the irregularity factors are applied as each entry is 
made.
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If there are a large number of station extents to enter, additional lines to the table may be 
required.  To add additional lines:

22. <R> on a row number that is within the table (below the headings) that is blank and select 
Insert from the menu.  This adds a row above the selected row number.  

To add multiple rows:

23.  Highlight the number of blank rows to be added. 

24. <R> and select Insert from the menu. The additional rows are added above the highlighted 
rows.

Preparing the Spreadsheet for Linking 

Once the data is entered into the Surfacing Sheet, it can be prepared for linking to the MicroStation sheet 
border file.  If the table is small enough to fit within the sheet border, then no further processing is required.  
However, if the table is too long and/or too wide, additional actions are required to make tables that fit the sheet 
borders.

Dividing Long Sheets

Sheets with too many rows are divided to create sub tables of data and an additional sheet totals 
table.  To create the sub tables:

1. <D> the Divide Sheet button.  This displays the Sheet Rows dialog box.

2. Key in the desired number of rows of data to be included on each sheet.
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3. <D> the OK button.  

The number of data lines in the master sheet is divided by the number of lines specified for 
each sub sheet and new worksheet are created and populated with data from the Surfacing 
Sheet table. These are named Sub Sheet 1, Sub Sheet 2, etc. and it is the tables on the sub sheets 
that are linked to the MicroStation sheet border files.  Additionally, the Sub Sheet Totals 
worksheet is created which contains a table with the sub sheets’ total lines and a grand total.

Note: If the table needs to be re-divided, delete the Sub Sheet and Sub Sheet Totals 
worksheets prior to executing the command.  Failure to do so could result in erroneous Sub 
Sheets and Sub Sheet Totals.

Dividing Wide Sheets

There is no command to automatically divide sheets by the number of columns.  Ideally, the 
number of columns that can fit in a border should be determined before data entry.  That 
number is then divided into the total number of pay items to determine how many xls files will 
be needed.  The desired xls file should then be copied the required number of times. 

However,  if the table id deemed to be too wide after data is entered, use the following 
procedure:

1. Determine the number of columns that will fit on the sheet.

2. Save the original file.

3. Select File > Save As from the menu bar.  Name the new file the same as the original, 
changing the end number to make it unique.

4. Reopen the original file.

5. On the Surfacing Sheet worksheet, <D> the Data Entry button.

6. In the Data Entry dialog box, <D> the Delete a Pay Item already placed in sheet 
button.  This displays the Delete Item dialog box.

7. From the Delete Item dialog box, highlight the first pay item to be removed from the first 
sheet.

8. <D> the Delete Item button.  This removes the pay item column and any data in that 
column from the Surfacing Sheet worksheet.

9. Repeat steps 7 and 8 until only the pay items for the first sheet are left.



Page 426 Colorado Department of Transportation

Chapter 15 - Tab Sheets A Practical Guide for Using InRoads XM

10. Save and close the original file.

11. Open the copied file.

12. Repeat steps 5 through 9, deleting the pay items that appear on the original sheet.

13. Repeat steps 1 through 12 if a third or subsequent sheets are required.

If sheets need to be divided by both length and width, divide them by width first.  This is 
because the Sub Sheets are not automatically updated by the addition or deletion of pay items. 

Preparing the Excel Document

Once the data is entered and the sheets divided,  the tables can be linked to the MicroStation 
sheet borders.

1. Once the data is entered into the tab sheet, Highlight the information you would like to 
link to the MicroStation file and copy to the clipboard by right clicking within the high-
lighted area and selecting Copy.

Linking Excel Documents

1. Open the MicroStation tabulation file.  These files are located in the …\Drawings folder of 
each specialty group within the project directory.
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2. From the MicroStation file menu, select Edit > Paste Special.  In the Paste Special 
Dialog Box, <D> Linked Microsoft Office Excel 2003 Worksheet and <D> Paste.

3. This brings up the Paste OLE Object dialog box.  Select Link in the Paste as: option, By Size 
as the Method: and enter a Scale of 8.5.

4. The Arial font is the default font used in the standard CDOT Excel tab sheet documents.  
The Arial 10 pt font in Excel is equivalent to CDOT Standard Text (.07”), and the Arial 12 
pt font is equivalent to CDOT Title Text (.10”) for a 1”=1’ drawing when the Excel file is 
placed at a Scale of 8.5 as noted above.  

Note: To insert a standard spreadsheet into a border that in not at a 1”=1’ scale, multiply 
the scale of the Border by 8.5 to calculate the scale for the Excel link.
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5. The limits of the selected Excel data to be placed in the MicroStation sheet will display in 
the MicroStation Window.  Select the origin point for the Excel File and <D> to place the 
file. The location of the link can easily be adjusted after it is placed.

Note: The link will display with hatching which indicates that the Excel file containing 
the linked data is currently open.  If you close out of your Excel file, the hatching 
will go away.
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Note: Do not resize the linked window with the handles, as the text size will also resize 
and will not plot as desired.

6. Hover over the linked image to display the location of the Excel file.

7. Double click the link to open the Microsoft Excel document.  Edit the Excel file, close the 
file, and the updates will be displayed in the MicroStation file.

Updating Document Link Source and Properties

1. If an Excel document has been moved or renamed, you will need to update the existing 
link.  This is also the case for MicroStation files with links that were created with the Create 
Project Directory program.  These files are linked to the Excel files in the standard template 
directory and need to be updated to link to the Excel files in the Project Directory Structure.
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2. From the MicroStation menu, select Edit > Links…

3. This will bring up the Links dialog box.  Select an available document link and <D> 
Change Source.
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4. This brings up the Change Source dialog box.  Navigate to and select the correct Excel file 
and <D> Open.

5. Once a new source is chosen the Links dialog box will return.  Continue to select additional 
documents to update the link or <D> Close to exit the Update Links Dialog box.

Note: Select either to have the link update manually or automatically by selecting the 
method you prefer.  If a Manual update is chosen, <D> Update Now button to 
update the file manually.
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