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Chapter 4 - Surface Fundamentals (Under
Development)
A digital terrain model (DTM) is a mathematical representation of topography that includes points and
triangles and is often referred to as a surface. The triangles allow the DTM to provide elevation information at
any location by interpolating the elevations of the three points making up the triangle in question.
Using Delauney’s criteria, InRoads calculates the smallest triangles possible for a given set of point data.
Delauney’s criteria states that any triangle formed may be circumscribed and no other point will fall within the
circle. Linear features must sometimes violate Delauney’s criteria in order to hold a constant slope between
points. In other words, linear features will not allow triangles to cross them.
You may load as many DTMs as you need into memory when using InRoads. It is typical to have several
DTMs loaded, since you will have an original and several design surfaces (such as multiple finished grades or
alternative surfaces). At any given time, only one surface is active, meaning it will be the default when using
any command requiring a surface.
When a digital terrain model is saved to the hard drive, it takes on an extension of DTM.

Chapter Objectives:



To learn what a DTM is and how it is used in the CDOT design process.



To learn how to manipulate DTMs after they have been created.

To learn the capabilities of an intelligent DTM and what it means for a DTM’s use in
design.
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Introduction to DTMs
Before working with either existing or design surfaces, a basic understanding is needed of what is contained in
a surface. This section introduces you to the different DTM point types and the purpose of these points. It also
explains the concept of intelligent features in a surface and the proper use of features styles and named
symbologies associated with these features.

Section Objectives:



To become familiar with the point types used in a DTM and how they affect triangulation.



To learn the basics of how a DTM is created.

To learn the make-up of an intelligent DTM including how Features, Styles and Named
Symbologies work together.

DTM Point Types
Everything that is used in a DTM is a feature, and each feature is assigned a point type. The
point type determines how the feature reacts during triangulation. Random points triangulate to
the closest point around them, while the other, linear, features will not allow triangles to cross
meaning they hold a constant slope between their points.
The following point types can be used in an InRoads’ DTM.

Random
 Normal topo shots
 Often used for spot shots, local highs and lows
Breakline
 Used to represent linear features such as ditches, ridges, and edges of pavement, and named
accordingly





No triangles cross breaklines — they take precedence over random points
Must have at least two points to form a breakline (lines, linestrings, curvestrings and
complex chains are acceptable for import)
Can be densified or thinned

Contour Points
 Use when data comes from contours, e.g., digitized from aerial maps
 Work much like breaklines with a constant elevation
 Converts lines, linestrings, curvestrings and complex chains into DTM points
 Can be densified or thinned
 Inferred breaklines
 Only used with contour points
 Generated by the software
 Eliminate flat spots by forcing a slope on every triangle
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Interior
 Used to model holes in your surface where there is unknown survey data or areas you do
not want considered in the DTM



Requires at least three points to model a closed shape




No triangles are formed inside an interior boundary
You can have more than one interior boundary per surface, but they can not overlap

Exterior
 Define limits of triangulation
 Requires at least three points to model a closed shape
 There is only one exterior boundary per surface
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Surface Triangulation
In order for a surface to be used for contouring, modeling, etc., it must be triangulated. The
original ground surface received from Survey will already be triangulated, however, if any
changes or edits are made to a surface it will have to be triangulated again before the changes
show up in displays of the surface either in Plan, Profile or Cross Section.
To triangulate a surface:
1. Select Surface > Triangulate Surface

Note: A surface may also be triangulated by right-clicking it in the InRoads Explorer menu
and selecting Triangulate from the list of available commands.
2. Choose the Surface from the drop-down list
The Maximum Length prevents the formation of any triangles with a leg longer than what is
specified. This is useful for eliminating long, slender extraneous triangles that often appear
around the edges of a surface, but care must be taken that the value entered is not small enough
to prevent the formation of ‘good’ triangles in the middle of the surface. If the value is set to
0.00, it is ignored and all triangles are formed.
Extended Data Checks evaluate the surface for crossing or overlapping features. Leave this
toggle off for faster processing unless you receive an error when triangulating.
The Features category is used when you are loading graphics to create the surface at the same
time you're triangulating. For details on these options, see the InRoads Online Help.
3. Apply and the surface is triangulated.
4. Results show you the numbers of points and triangles formed, as well as the elapsed time.
For more information, <D> the More button to access the Surface Properties dialog box.
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Intelligent DTMs
InRoads’ digital terrain models are intelligent models. By using Feature Names, Feature
Styles and Named Symbologies as described below, the models will know what types of
features can be displayed in which views as well as the symbology to use for displays.

Feature Names
Everything in a DTM is a feature and every feature must have a unique name. Often, when
creating new features, you will be asked to supply a Seed Name. This seed name is used as the
base for a unique feature name. For example, if you use creek as the Seed Name, and you load
more than one (with a level or selection set, for example) the second will be named creek1,
third creek2, etc.
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A feature can be either triangulating, such as breaklines representing ditches, centerlines, etc.
or it can be non-triangulating, such as utilities that are below or above the ground surface.
These types of non-triangulating features can be shown on cross section, profiles and in plan
view without affecting the triangulated network.
Feature names are stored within the DTM.

Feature Styles
Feature Styles are assigned to features in the DTM. They control where and what the features
is “allowed” to display, as well as assigning a named symbology. For example, when you
assign a feature style to a feature, you are determining if it can be displayed in plan using lines,
points and/or annotation; if it can be displayed in sections using points and/or annotation, etc.
Feature Styles are stored in CDOT-Preferences.ini.

Named Symbology
Named Symbologies are just what they sound like — setups, such as color, weight, line style,
font that can be saved by name. They even go one step farther allowing these setups to share a
name while establishing different symbologies for plan, cross sections and profiles. This way,
one entity that uses a named symbology can still display using different setups in plan vs. cross
section vs. profile. Just about anywhere you assign symbology, you can use a named
symbology instead. CDOT named symbologies are setup to use ByLevel symbology.
Named Symbologies are stored in CDOT-Preferences.ini.

Creating a DTM
In the CDOT Process, the existing ground DTM is provided by Survey and proposed DTMs are
created by InRoads tools such as Roadway Designer. However, there may be times when you
may have to create or supplement one of these DTMs. If so, the data used to create the DTM
may be in one of several formats. The most common formats are described below.

ASCII (text) Files
ASCII data can be loaded from several different formats. Using File > Text Import Wizard,
you can specify the format for your data. This wizard takes you through the import process step
by step. Some commonly used formats include:





x,y,z
northing, easting, elevation
station, offset, elevation (baseline alignment required)

Note: These formats can have additional columns for ‘pen-up, pen-down’ to define separate
linear elements in one file, for feature names, features styles, etc.
See the InRoads Online Help for additional information.
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Surface from graphics
Graphical data is sometimes used to generate existing or proposed surfaces using 
File > Import > Surface > From Graphics. When using graphics, some key points are
listed below.



Elevations may be taken from the element or from surface (if the surface has been
triangulated already).



Elevations may be taken from text if you’re loading random points that are graphically
displayed in the correct location, with text listing the elevations.



Linear features that contain curves can be densified using the chord height tolerance (set
under Tools > Options > Tolerances).



Linear elements can be densified by setting a maximum segment length or a point density
interval.



Points on linear elements can be thinned upon input using the Thin (and Tolerance) option.

See the InRoads Online Help for additional information.
In the Surface Editing Tools chapter of this document, you will find additional information on
creating features using a variety of tools.
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Section Summary:
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Random points are for local high/low topo shots.





Each feature in a DTM has a unique name.




Feature Styles and Named Symbologies are stored in CDOT-Preferences.ini.

Linear features in a DTM ensure a constant slope between the feature points.
Exterior and Interior features limit the location of triangles (an exterior forms a boundary
and an interior forms a hole).
Features are named to make them intelligent.
Styles control where a feature can display and assign it a named symbology for it’s
graphical attributes.
You can supplement a DTM with data from text files (ASCII) or from MicroStation
graphics.
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DTM Utilities
There are several DTM utilities that allow you to manipulate the DTM after it has been created, both internally
in InRoads memory and externally on the hard drive.

Section Objectives:


To learn how to manipulate a DTM as a whole.

Active Surface
When you access commands in InRoads that require a surface, they always default to the Active
surface. In most cases, you can simply use a drop-down in the command's dialog box to change
to a different surface. However, in some circumstances you are not given that opportunity. Two
examples include:




when Style lock is on and you use a View Surface command, and
when you use Apply Template with a template whose end condition seeks the Active
Surface.

In these cases, you must first set the Active surface.
1. Select Surface > Active Surface.

2. From the list of loaded surfaces, highlight the one you want.
3. Choose Apply.
4. Choose Close.
An alternate method is to right-click on the surface in the workspace or explorer portion of the
menu and select Set Active.
Note: The active surface is shown in the menu with a red box around the surface icon.
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Copy Surface
InRoads’ surfaces have a name that is used in all the dialog boxes (the internal name) and a
name that is used on the hard drive (the external name). Although it is recommended, these two
names are not required to match. However, you cannot have two surfaces loaded that are seen
as being the same. Therefore, if you copy a surface on the hard drive, InRoads does not realize
that it is a separate surface. If you load the original and the copy, it will assume you’re loading
the same surface twice and will ask if you want to overwrite the first one loaded. Instead of
making the copy in this manner, use the Copy Surface command inside InRoads.
1. Select Surface > Copy Surface.

2. Select the Surface you want to copy with the drop-down list in the From category.
3. In the To category, specify a Name, Description and Preference for the copy. (This is the
internal name.)
4. Choose Apply.
5. Choose Close.
The new surface should now be saved to the hard drive. See the section on Saving Surfaces for
additional details.
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Delete Surface
The Delete Surface command removes a surface from memory, but does not affect the surface
on the hard drive. If you are using the Create Surface option within Roadway Designer, you do
not have to delete the surface. Instead toggle on Empty Surface and it will remove the data
from the surface before creating the new model. The Delete Surface command should be used
when you are through with a surface but are not ready to exit InRoads, or if you want to re-use
the name of a surface, but do not need its current contents.
1. Select Surface > Delete Surface.

2. Select the Surface you want to remove from memory from the list of loaded surfaces.
3. Toggle on Delete Surface Contents Only if you want to keep the name and other surface
attributes but not the features.
4. Choose Apply.
5. Choose Close.
An alternate method is to right-click on the surface in the workspace or explorer portion of the
menu and select Close to completely remove the surface from memory, or Empty to remove
only the contents.
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Rename Surface
The Rename Surface command is used to change the internal name of a surface. It also allows
you to change the Description and Preference associated with a surface.
1. Select Surface > Rename Surface.

2. Select the Surface you want to rename from the drop-down list in the From category.
3. Key in the new name in the To category.
4. Change the Description and/or Preference as desired.
5. Choose Apply.
6. Choose Close.
The surface should be saved to the hard drive after making the change.
Important!
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Do not use the rename command to make a copy of a surface. For example, do
not rename a surface and then try to load the original surface again. InRoads
still sees the surfaces as the same and will not allow both to be loaded. Instead,
use Surface > Copy Surface.
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Save Surface
Surfaces can be saved using several methods including:



Choose File > Save > Surface
The active surface is saved.



Right-click on the Surface in the Explorer menu and chose Save

The surface you highlighted is saved.
If the surface has never been saved, either of the above methods will bring up the Save > As
box as shown below.

1. Choose File > Save As
2. Set the Files of Type to *.dtm
3. Choose the Active surface you want to save
4. The File name field should populate with the active surface name. If you want the hard
drive name to be different, key in the File name
5. <D> Apply.
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Note: Surfaces have both an internal name that appears in the dialog boxes in InRoads and a
name on the hard drive that has a .dtm extension. It is recommended that these names
be the same, and care should be taken to make certain you have chosen the correct
surface name to match the file name you specify. Otherwise, you could accidentally
save over a file on the hard drive with the wrong surface.
The surface may also be saved as part of the project or RWK file.

Section Summary:
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The active surface is the default one used in many commands, but can typically be changed
with a Surface drop-down option in the command.



If Style lock is on, the active surface is more critical for View commands, since the
command only works on the active surface.



Surfaces can be renamed, but InRoads still sees the surface as the same one.



Surfaces can be copied, in which case InRoads sees them as different surfaces.
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Chapter Summary:



Intelligent DTMs are critical to the CDOT design process.



Existing and proposed DTMs are used to compute volumes.

Existing DTMs are created by survey and provide the basis for modeling proposed
surfaces.
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