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LAB 6 - Profiles and Vertical Alignments

Once the horizontal alignment is defined, then the profile and vertical alignment can be created. Profiles are a 
graphic representation of a surface along the path of the horizontal alignment. Profiles are also used to create 
and display vertical alignments.

Chapter Objectives:

 Review an existing vertical alignment.

 Create a profile.

 Update the profile with a variety of features.

 Display profile annotation data.

 Use vertical alignment tracking.

 Create a new vertical alignment.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Design.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

Lab 6.1 - Reviewing Vertical Alignments

Section Objectives:

♦ Examine the Review Vertical Geometry window.

♦ Explore the functionality of the dialog box.

Reviewing vertical alignments is similar to reviewing horizontal alignments.  The Review 
Vertical Alignment dialog allows you to easily change between multiple Geometry Projects, 
Horizontal, and Vertical alignments.
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1. Select Geometry > Review Vertical.

2. The review dialog can also be opened with the right-click fly-out menus.

Section Summary:
♦ Reviewing vertical alignments works the same as reviewing horizontal alignments.

Lab 6.2 - Creating Profiles

Prior to graphically displaying a vertical alignment a profile must be created.  These are 
referred to as profile sets in InRoads. A profile set can be created using a horizontal alignment, 
a MicroStation element, or interactively to define the horizontal (plan) location the vertical 
information is extracted from.  Upon creation, a profile can display DTM surfaces, vertical 
alignments and DTM features. Once created, a profile set can be refreshed to display additional 
data, turn the display or data off, or to redraw the graphics based on current DTM information.
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Section Objectives:

♦ Examine the profile dialog box.

♦ Select profile Preferences.

♦ Display vertical alignment annotation.

Prior to creating a profile set, load the DTM 12345Surv_Surface_Existing if not already 
loaded.  This surface will be used to display an existing ground-line.

1. Select File > Open.

2. In the workspace bar under the Geometry tab, verify that 12345_Design is the active 
geometry project and that the horizontal alignment SH86 is the active alignment.

Note: To make something active, <R> on the name and select Set Active from the fly-out 
menu.
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3. Select Evaluation > Profile > Create Profile the Create Profile dialog will appear.

4. <D> the Preferences button.  The Preferences dialog will appear.

5. <D> the predefined settings for 2x vertical.

   

6. <D> the Load then Close buttons.

Note: Load preferences before making any other menu settings. Loading Preferences 
resets all menu settings to those predefined in the preference.

7. Note the Exaggeration specified.
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8. Verify that in the Surfaces portion of the dialog, the Display box is checked for surface 
12345SURV_Surface_Existing.

9. <D> the Source leaf. Verify that the SH 86 alignment is selected.

10. <D> the Apply button.  The Create Profile dialog will temporarily minimize.
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11. You are prompted by MicroStation to ‘Identify location’. <D> in the MicroStation view.  
The Profile window will be placed and the Create Profiles dialog will restore.

Note: For convenience, we are displaying the profile in our current drawing.  Standard 
practice dictates that separate drawings should be created for profile and cross 
section display.  Consult the directory structure and file naming convention for 
your specific discipline to determine standards relating to profile display.

Viewing Vertical Alignments

12. Select Geometry > View Geometry > Active Vertical to display a graphic of the 
active vertical alignment.
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♦ Alternately in the Workspace Bar under the Geometry tab you can <R> on the Vertical 
Alignment and select View just as you did with Horizontal Alignments.

 

Note: Annotation size for the index elevations and stationing text is generated based on 
the global scale factor defined for text.  The text size specified should be set based 
on the ultimate plotting scale.  To change text size on a profile, delete the displayed 
profile, change the global scale factor, and regenerate the profile display.

Annotating Vertical Alignments

Similar to horizontal stationing, annotation of vertical alignments is accomplished much the 
same way.
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13. Select Geometry > View Geometry > Vertical Annotation to view vertical 
alignment annotation.

14. Verify the appropriate Horizontal, Vertical Alignments, and Profile Set are correctly 
identified.

15. Click Apply.
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16. Take some time and investigate the remaining tabs along the top of the View Vertical 
Annotation dialog and the individual settings for each.

17. <D> the Points tab. Note the settings in the Symbology portion of the dialog. By default, 
Symbology for a Proposed alignment loads.

18. <D> the Preferences button.

19. <D> the name Existing.

20. <D> the Load then Close buttons.
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21. Note the change in the defined Symbology.

22. <D> the Apply button from the View Vertical Annotation dialog. Review the results in the 
MicroStation drawing. The content of the graphics should remain the same, however, 
different levels, color, style, and weight are utilized.

23. For practice, continue to Load and Display additional preferences.

24. Investigate what levels the elements are being placed on.  The various preferences 
determine the location of graphics.

Section Summary:
♦ Use the Preferences to make the major settings in the Create Profile and Vertical 

Alignment Annotation dialog boxes.

♦ View Active Vertical only displays the geometry elements that make up the vertical 
alignment.

♦ Vertical Alignment Annotation displays the geometry elements and text data that 
describe the alignment.

Lab 6.3 - Updating Profiles

When a profile is created the user has the option to display items such as: multiple surfaces, profile lines offset 
from the horizontal alignment, and features such as underground utilities and pipes. However, the Create 
Profile command does not allow the user to specify which features are displayed.
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The Update Profile command should be used to add, remove, or update data within an existing profile set.  This 
command allows the user to specify which features will be affected by the command and can also be used to 
update and surface data that has changed since the profile was created.

Section Objectives:

♦ Use the Update Profile command to add features to the display.

♦ Illustrate how Global Scale Factors affect cell size.

♦ Examine how Feature Filters affect dialog box lists.

1. From the pull down menu Evaluation > Profile > Update Profile.  The Update Profile 
dialog will appear.

2. <D> the Crossing Features leaf.

3. Verify SH 86 is the active Profile Set.

4. In the Mode section toggle the radio button Display On.

5. In the Surfaces section <D> 12345SUR_Surface.
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6. <R> in the Crossing Features list and select All from the menu.

7. <D> the Apply button.  Using MicroStation viewing tools locate a crossing culvert.

Note: Profile and cross section displays are drawn at true horizontal scale.  A vertical 
distortion will be applied to cells displayed in profiles or cross section views based 
on the vertical scale applied to the grid.  Some DTM features displayed in these 
graphics are configured to display at their true horizontal (x-direction) sizes. 
Therefore, prior to displaying features in either profiles or cross sections the global 
scale factor for cells should be set to 1.
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Note: Two classes of elements can be displayed on profiles; 1) True scale items such as 
culverts and 2) items represented by text such as utility crossings, flow-lines, 
ROW, etc.

For item 1:

The global scale factor for cells should be set to 1 and a subset of the dtm crossing 
features should be displayed (or refreshed in this case). This is accomplished with 
the use of feature filters.

For Item 2:

The global scale factor should be set equal to the plot scale.

Note: See the following page for information on updating a profile to refresh the 
graphics.

Refreshing a Profile Display

First, take care of refreshing the display of the true-scale items such as the culverts.

8. Select Tools > Global Scale Factors.

9. Key in the field Cell: 1.

Note: You may need to Unlock the icon to allow modification to the cell scale only. By 
doing so, when you update the profile, the cells will draw at their true sizes. 
Leaving the Text field at 100 and Line Style field set to 1. This allows annotation 
and other commands to remain unaffected by the scale factor that was input 
specific for cells.

10. <D> the Apply then Close buttons in the Scale Factor dialog

11. In the main InRoads interface, select the filter CELL_True-Scale from the drop-down list. 
Also toggle On the Feature Filter lock.
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12. Close and reopen the Update Profile dialog.

13. Verify SH 86 is still the active Profile Set.  Use the target button next to the Profile Set to 
graphically change the active profile set.

14. In the Mode section toggle the Refresh radio button.

15. <D> the Crossing Features leaf.

16. <D> the surface name 12345SURV_Surface.
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17. Select all of the Crossing Features listed.

18. <D> the Apply button.

19. Using MicroStation viewing tools, locate a crossing culvert and review the results.

20. Use MicroStation Measuring tools to verify pipe size(s).

21. From the Locks toolbar select CELL_Plot-Scale filter from the pull down list.
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Note: Verify that the feature filter is toggled on.

22. Change the InRoads Scale Factor to 100 for cells.

Note: This is the desired plot scale change accordingly.

23. Close and reopen the Update Profile dialog.

24. Verify SH 86 is still the active Profile Set.  Use the target button next to the Profile Set to 
graphically change the active profile set.

25. In the Mode section toggle the radio Refresh button.

26. <D> the Crossing Features leaf.

27. <D> the surface name 12345SURV_Surface.

28. Select all of the Crossing Features listed.

29. <D> the Apply button.

30. Turn Off the Feature Filter lock.
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Section Summary:
♦ Update Profile is the better tool to use when adding features to a profile.  With Update 

Profile the user can choose which features to display.  With Create Profile, all features 
that can be displayed (based on feature style settings) are displayed.

♦ There are two types of feature cells used in profiles; true scale cells that use a global 
scale factor of 1 and plot scale cell that use a global scale factor the same as the plot 
scale.

Lab 6.4 - Annotating a Feature in a Profile

Features that have been displayed in profiles (or cross sections) can be annotated with 
information extracted from the surface model.

Section Objectives:

♦ Annotate the true scale features in the profile.

1. Using MicroStation commands, window into any culvert displayed in the profile created in 
the previous lab.

2. From the Locks toolbar select CELL_PLOT-Scale filter and verify the feature filter is 
toggled On.

3. Select Evaluation > Profile > Annotate Feature in Profile.  The Annotate Feature In 
Profile dialog will appear.
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4. <D> the Apply button and review the results.

5. <D> the Points branch.

6. Check On the Feature Description.

7. <D> the Apply button and review the results in your profile.

8. Experiment with enabling other options in the Point tab and redisplaying the annotation
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Challenge Exercise:

Update your profile to show projected features. Annotate the projected features.

Section Summary:
♦ Only features displayed in the profile can be annotated.

♦ Set the global scale factor for text to the plot scale before executing the command.

Lab 6.5 - Annotating a Profile

In addition to annotating vertical alignments, profiles can be annotated with both existing and 
design information.

Section Objectives:

♦ Add Existing and proposed elevation information to the profile.

♦ Add Cut Depth and fill height information to the profile.

1. Select Evaluation > Profile > Annotate Profile.
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2. <D> Apply. The existing and proposed grades annotate the profile.

3. Take some time and review the leaves of the Annotate Profile dialog. Investigate the 
remaining tabs and the individual settings for each.

4. Now go back and <D> the Selection leaf.

Note: The dialog shows two categories; Available and Selected.  Available lists the items 
that can be annotated in a profile, Selected identifies the items chosen for 
annotation.

5. <D> the item Cut Depth from the Available list.
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6. <D> the Add button.  Cut Depth will be added to the Selected list.

7. <D> the item Fill Height from the Available list.

8. <D> the Add button.  Fill Height will be added to the Selected list.

Note: Make sure that Existing and Proposed remain in the 1 and 2 slots. To move a 
selected item, highlight the item and <D> the Move Up or Move Down buttons

9. <D> the Apply button and review the profile display.

Note: You may have to zoom out to view the additional annotation.

Section Summary:
♦ Annotate Profile is used to place existing surface elevations and vertical alignment 

elevations on the profile set.

♦ Other data related to profiles can also be displayed.
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♦ When displaying additional data, make sure Existing and Proposed stay at the top of 
the list.

♦ Change the settings on the Frame leaf to move additional data closer to the profile 
window.

Lab 6.6 - Vertical Alignment Tracking

Vertical alignments can be interactively queried similar to horizontal alignments.

Section Objectives:

♦ Examine Vertical Alignment tracking in the profile.

♦ Examine the vertical alignment data in Horizontal Alignment tracking.

Tracking Vertical Alignments in Profile View

1. Select Tools > Tracking > Vertical Alignments.

2. Move the cursor inside the Profile Set window and review the output in the InRoads Status 
bar.

Note: As you move your cursor in the profile view InRoads displays vertical alignment 
information in the status field.  There is not an option to write this information to 
the MicroStation file.
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Tracking Vertical Grades in Plan View - Review

3. Select Tools > Tracking > Horizontal Alignment.

4. Move the cursor along the active horizontal alignment and review the readout in the 
InRoads Status bar.

Results displayed are the station and offset relative to the active horizontal alignment. The 
elevation is relative to the active vertical alignment.

Section Summary:
♦ Tracking is used to gain information that is related to the horizontal and vertical 

alignments.

Lab 6.7 - Create a vertical alignment

Vertical alignments define an elevation path for the proposed design to follow.  It is stored under the parent 
horizontal alignment.

Section Summary:
♦ Create a new vertical alignment slot.

♦ Add PIs to the vertical alignment .

♦ Define the vertical curves.

Create a slot in the active geometry project for your vertical alignment.

1. Select File > New.

2. Choose the Geometry tab.

3. Toggle the Type to Vertical Alignment and set the following:

4. Key in SH 86 V Alt1 for the Name.
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5. Key in Alternate vertical alignment for the Description.

6. Set the Style to ALG_PRO_Vert.

7. Verify that the Curve Definition is set to Parabolic.

8. Select Apply then Close

9. Set up your MicroStation windows so the entire profile is visible in one window, then open 
another MicroStation window and Zoom in to the beginning of the profile as shown.

        

Next, add PVIs to the Vertical Alignment.

10. Verify that the Write Mode is set Pencil.
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11. Select Geometry > Vertical Curve Set > Add PI.

12. Select Apply.

13. For the first PVI, snap to the beginning of the ground line in the window where you are 
zoomed in.

14. In the MicroStation key in field, enter the following commands: (Be certain to use the % 
sign in your key-in.)

♦ dg=900,-3.76%

♦ dg=400,1.03% 

♦ dg=425,-4.29%
♦ se=11725,6574.78 
                               

The dg= key-ins place additional vertical PIs at the specified distance and grade. The last 
one again places a vertical PI at the station and elevation specified.

15. <R> twice to exit, then Close the Add Vertical PI dialog box.

16. Update the view.
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The vertical alignment is displayed permanently in the design file. Because Pencil mode is 
active, the tangents will automatically update when the curves are added. 

17. Select Geometry > Vertical Curve Set > Define Curve.

The Define Vertical Curve dialog box is automatically displayed ready to accept input for 
the first curve on the vertical alignment. To step to other curve sets, you can use Previous 
and Next, or First and Last.

18. Under the Vertical Curve category, 

♦ Set Calculate By to Length of Curve.

♦ Key in 300 for the Length.

19. Select Design Calc.
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20. Click in the Table Name and Browse to the C:\Program Files\Workspace-CDOT\ 
Standards-Global \ InRoads\Design Checks folder and choose the file Vertical 
Design Checks.txt.  

21. Verify that the length of curve meets your design criteria.

22. Choose Cancel when done.  You do not want to accept the minimum curve, just verify 
that yours meets the criteria.
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23. Select Apply

24. Select Next to move to the second intersection of tangents.

♦ Set Calculate By: to Length of Curve.

♦ Key in 250 for the Length.

25. Select Design Calc.

26. Verify that the length of curve meets your design criteria.

27. Choose Cancel when done.

28. Select Apply.

29. Close the Define Vertical Curve Set dialog.

Section Summary:
♦ Vertical alignments are defined in the profile window.

♦ Vertical PIs can be added by data point or key in.

♦ The Define Curve dialog box can also be used to adjust PI stations and elevations.
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Chapter Summary:

 Use the review vertical alignment command to examine vertical alignment data when a 
profile is not required.

 Profiles are required to view vertical alignments graphically.

 Use Update Profile to add, remove, or revise data in a profile set.

 Annotate Feature in Profile only affects features displayed in the profile.

 Annotate Profile is used to display existing surface and vertical alignment elevations in the 
profile.

 Vertical Alignment Tracking displays Station, Offset, Elevation, and Grade information in 
the InRoads main dialog box.

 Typically, vertical alignments are defined by locating all of the VPIs then placing the 
curves.
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