LAB 7 - Building Components

This lab demonstrates the various methods of creating components, setting component and point properties,
and illustrating how point constraints work. There are three basic options used to create components; simple,
constrained/unconstrained, and end condition.

Chapter Objectives:

Build a simple component

Build a constrained component

Build an end condition component

Demonstrate the commonly used constraints; horizontal, vertical, slope, and vector/offset

Before beginning this lab, verify that the following files are loaded:

C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences\CDOT _Civil.xin

C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg
C:\Projects\12345\Design\InRoads\12345 existing ground.dtm
C:\Projects\12345\Design\InRoads\12345DES.ird
C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 7.1 - Build A Simple Component

Use the simple option to build a regular closed shape component with horizontal and slope constraints such as
those used for building pavement components.

1.

4.
5.

Open MicroStation and InRoads using the 12345DES_Model.dgn file found in the direc-
tory C:\Projects\12345\Design\Drawings\Reference_Files.

Select File > Open from the InRoads menu bar.

Select the C:\Projects\12345\Design\InRoads\DES12345_Templates.itl from the
available files.

<D> Open then <D> Cancel the Open dialog box.

Select Modeler > Create Template from the InRoads menu bar.

Setting up Template Options makes point placement easier. For this lab, affixes will be turned
off so that the component can be used on either side of the template. The step value will be set
so to a small value so that when creating a template, components will snap to the correct points.
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6. Select Tools > Options from the Create Template menu bar.

=

h Create Template
File Edit Add

Template Librany:

7. Toggle off Apply Affixes.

Ternplate Library Organizer...

l

|

(O C:\Projects12 Apply Feature Mame Override... |
N

Dynamic Settings

8. Setthe X and Y Step Options to O.10.

9. <D> OK.

f"! Template Options

Naming Options
Components
Seed Name;

@ From Style

Specify:

Poaints
Seed Mame:

Step Options

A 010 Yioo010

[ Cancal

[ Preferences...

Sope:  (.000%

The next series of steps creates a new project specific folder to store the components that will
be created in the lab. Creating project specific folders in the template library makes easier to

find project specific components.

10. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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11. <D> <D> on the 4 - Components folder to expand the folder.

.
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12. <R> on the 4 — Components and select New > Folder from the right click menu.

H Create Template
File Edit Add Tools
Template Library Currert T
= C\Projects’. 12345\ Design’InFoads\DES 12345 _Templates i Name
“EZ Point Mame Lisg L ;
[0 1- Templates .
1 2 - Sections - Pavement
£ 3 - Sections - End Conditions
=1
& New 3 I Folder I
(=
Sicd Ot Ctrl-X Remplite |
;I Em Copy Ctrl-C
(=] Pay g S
2 sd Paste Ctrl-V
54 Delete Del
Renarme F2

13. Key in 12345 Components for the folder name.

Components are the building blocks of templates. Create a pavement component using the
Simple option. This option is used because it automatically sets up the constraints of the

component.

14. <R> on the 12345 Components folder and select New > Template from the right

click menu.

15. Key in CONC_Lane _12"x12’for the component name.

5] 4 - Components
[C7] Aggregate Bases
(7] Bamiers & Misc Components
[ Curb & Gutter Componerts
[ End Conditions
[ Pavements
[ Sidewalks & Bike Paths
[ Subbases

|CCI NC_Lane_12"x12
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16. <D> on the Dynamic Settings button to display the Dynamic Settings tool settings box.

+-&E+I"IEH (

Dynarnic Settings =

kS 0.00 Step: 0.10

i
Point Mame:

0.00 Step: 010

Point Style: |

Apply Affixes
|hs= - |

| Set Chynamic Origin |

17. <R> In the Template View window and Select Add New Component > Simple from
the right click menu.

I Add New Component » I Simple I

Constrained

Set Dynamic Origin Ctrl-D

Unconstrained
Null Point
End Condition

Aot OM o b .

The next steps define the style that the component will use, the point names, and the origin of
the component.

18. In the Current Component area, key in CONC _Lane_127x12’into the Name field.
19. Set the Style to D_CONC_Pvmt_12in using the drop down menu.
20. Key in 1 for the Thickness.
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Note: This is where the values of all the constraints are set. If needed, these values can
be modified later.

Curre

Slope: -2 00%
Thickness:
Width: 12.00

21. Move the pointer into the magenta square (this is the template origin and is usually at the
coordinate 0,0). Adjust the pointer location until the Dynamic Settings readout is 0.00 for
both X and Y.

22. <D> to place the element.
[l Dynamic Settings &l

X |0.00 Step: 0.00
|
\& -0.00 Step: .00

Point Name:

Point Style:

Apply Affixes
| )

I Set Dynamic Origin

23. <D> <D> on the origin.

24. Select Conc_Centerline-Top from the Name drop down menu.
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25. <D> Apply.

!.‘"! Point Properties =
Hame: Conc__Centedine-Top ﬂl Fohy I
Feature Hame Crveride Chos |
Surface Feature Style: | = '

_E-er'tedne P ——
Altemate Surface:
Hend >
Help
Member of:
COMC_Lane_12%1Z
Constraints
Carsiraird 1 Constraint 2
Type Mone - [ Mone -
Labed:
Style Constraint

26. <D> Next and rename the remaining points as shown below using the Name pull-down
menu.

4;-;:”-::. Centerline-Top

Conc_Lamsling-Top

ABC Centerline-Top
ABC Laneline-Tap

This completes the creation of a simple, closed shaped component with horizontal and slope
constraints.

Lab 7.2 - Build a Constrained Component

In addition to building regular closed shape components, irregular and/or open shaped components can be
created using the contrained or unconstrained options for adding components. They can also be used to build
linear, non-end condition components. Use the constrained option to define horizontal and/or vertical
constraints (such as a horizontal or vertical offset from another point). Use the unconstrained method to define
points that don’t depend on other points for their placement.
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1. <R>onthe 12345 Components folder and select New > Template from the right
click menu.

2. Keyin CONC_Shoulder_127x8’for the component name.

3. <R>Inthe Template View window and Select Add New Component > Constrained
from the right click menu.

Add New Component 3

Set Dynaric Origin Ctrl-D

Unconstrained

Mull Point
End Condition

4. Inthe Current Component area, key in CONC_Shoulder_127x8’into the Name field.
5. Set the Style to D_CONC_Pvmt_12in using the drop down menu.

]
Name:§ CONC_Shoulder_12"x8'

Style: D_COMC_Pvmt_12in -

When placing constrained or unconstrained components, each point of the component must be
placed individually. Use the Dynamic Settings dialog box is to enter point names, styles, and
locations.

6. Select Conc_Laneline-Top from the Point Name drop down menu on the Dynamic Settings

dialog box.
Dynamic Settings =]
X |0.00 Step: 010
Y- 0.00 Step: 0,10
Paint Mame:
Poirt Style:  [p_LANELINE |
Apply Afixes
r—
| Set Dynamic Crigin |

7. Move the pointer on to the template origin and <D>.

8. Dynamic Settings dialog box, Select Conc_EOP-Top from the Point Name drop down
menu.

9. Change the key in mode to hs= (horizontal distance and slope).
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10. Key in 8,-.02in the key in field. This is the horizontal distance and slope from the

11.
12.
13.

14.

previously placed point.

Dynamic Settings (=]
kS he2 Step: 010
\Y;—|-D.E~E~ Step: 010
Paint Mame:

Puoint Style: | D_EOF = |

Apply Afices

O

| Set Dymamic Origin |

w
n

Press the Enter key to place the point.

Select ABC_EOP-Top from the Point Name drop down menu.

Change the key in mode to dI= (horizontal and vertical distance from the last entered

point).

Key in 0,-1 in the key in field. This is the horizontal distance and vertical distance from

the previously placed point.

Dynamic Settings &
X 812 Step: D0
\Y;—|-3.I}3 Step: D10
Paint Mame:
Pairt Style: | D_EOP - |
Apply Affees

| Set Dymamic Origin |

15. Press the Enter key to place the point.

16. Select ABC_Laneline-Top from the Point Name drop down menu.

17. Change the key in mode back to hs= (horizontal distance and slope).
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18. Key in -8,-.02in the key in field.

19. Press the Enter key to place the point.

Dynamic Settings 8

¥ -0.03 Step: 010
y. |03 Step: 0,10
Point Name: ABC_Laneline-To -

Point Style: O EOP =

Apply Afixes

| Set Dymamic Origin |

20. <R> anywhere. This dialog box is where you define if the shape is closed or not.

21. Verify that Closed Shape is toggled On.

22. Select Finish from the right click menu to complete the component.

v Closed Shape Ctrl-L
Mirror Ctrl-M
Undo Last ESC
Cancel
Set Dynarnic Origin Ctrl-D

You should now understand how to create a constrained, closed shaped component. By
reviewing the steps above, now you should also be able to also create unconstrained and open
shaped components simply by choosing different options from the dialog boxes that were
introduced.

Lab 7.3 - Build an End Condition Component

In theses next steps you will use the end condition option to create a linear component that can seek a target.
This lab will focus on the point property called End Condition is Infinite. Once you understand the steps to
evaluate the effects of this property on and end condition, use the same steps to test the effects of other end
condition point properties. Many of these properties determine how the component will behave when a target

is found.

1. Create a new template as described in the previous lab and name it 6to1_Fill.
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2. <R> In the Template View window and Select Add New Component > End
Condition from the right click menu.

Add Mew Component L Simple

Set Dynarnic Crigin Ctrl-D Constrained

Unconstrained

Mull Point

End Condition

3. Keyin 6 to 1 Fillfor the Name.
4. Select D_Toe-of-Fill for the Style.

Additional component properties are required for end conditions. These determine what the
end condition attempts to tie to (the Target) and the order in which it is processed (the Priority).

5. <D> on the Target Type drop down menu. Examine the options available.

[eroethee ] [Spiexvz ]

Suface uface
evation
Feature XY
Feature Blevation
| Feature XYZ
B - Alignmert XY
Offzets Alignment Elevation
Alignment X7
_ Style XY
Dack, £iN [ERC FINiS Shie BElewation
Style XYE

6. Select Surface from the Target Type drop down menu.

7. <D> on the Surface drop down menu. Notice that either Active or a particular surface can
be selected.

8. Select Active from the drop down menu. This will allow the end condition to solve
regardless of the surface specified in Roadway Designer.

9. Key in I for the Priority.

Cume

MName Style:

Target Type: Priority:

Surface Benching Count:
Herzontal Vertical

Offsets: 000 0.00 Rounding Length 0.00
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Note: This example illustrates an end section with one component. When there are
several components defined in an end condition, they are evaluated in order of
their assigned priority. A component with a priority of 1 will be evaluated before a
component with a priority of 2.

Next, additional point properties, such as point names, will be defined for the end condition.
Use the Dynamic Settings dialog box to finish defining these properties.

10. In the Dynamic Settings dialog box, select POSS for the Point Name.
11. Move the pointer on to the template origin and <D>.

12. In the Dynamic Settings dialog box, toggle on End Condition is Infinite. This option
allows a component to “stretch” until a target is found.

13. Select Toe-of-Fill for the Point Name.
14. Change the key in mode to hs-=.
15. Key in 12,-.1667. and press Enter. (This value could also be typed in as 12,-1.6).

Dynamic Settings (=]

X 0.67 Step: 0.00
¥. 430 Step: 0.00

| Check for Interception

| Place Paoirt at Interception

| End Condition is Infinite

Do Mot Construct

Poirt Mame: Toe-of-Fil -
Poirt Style: D_Toe-of-Fil -

Apply Affices

hs= ~ W12-1667

| Set Chynamic Crigin |

16. <R> and select Finish from the right click menu.

The steps above created a component that will seek a target at a -1:6 slope for a horizontal
distance up to 12 feet. However, because the option End Condition is Infinite was toggled On,
the component ignores the horizontal distance criteria and will seek a target beyond the 12 foot
limitation.
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17. In the Create Template dialog box, <D> the Test button located to the bottom right of the
Template View window as shown below.

Toe-of-Fill

2

Test. ..

18. In the Test End Conditions dialog box, <D> the Draw button.

P "

;hTestEndCDnditiDns = |[-E= @

| Werify Features |
| Help |

Ayailable T argets:

<hchiver-Suface

Ilze Surface Slope:
00003

I Diraw I | Reset |

19. Move the pointer up and down in the view area to see how the end condition performs.

Note: The dotted line in the Test End Condition view window shows the component at
the defined slope and length. As the proposed surface moves beyond the limits of
the defined component, the result of the End Condition is Infinite toggled On is
that the end condition solution expands beyond the original limits of the
component. <D> Close.
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20.
21.
22,
23.
24.

25.

26.

<D> <D> on the Toe-of-Fill point.
Toggle off End Condition is Infinite.
<D> Apply and <D> Close.

<D> Test.

In the Test End Conditions dialog box, <D> Draw and notice how the end condition
behaves.

<D> Close.

Note: When the End Condition is Infinite option is Off, the end condition solution is
limited to the limits of the originally defined component.

Select File > Save the Create Template dialog box.

Lab 7.4 - How Point Constraints Work

Point constraints are used to form a relationship between points. This relationship is used to change the shape
of the components based on events that occur within the corridor. The following steps will demonstrate how to
assign and modify point controls, and how to evaluate a component by making changes to point controls.
change, create the impact of

1.
2.

Verify the Create Template dialog box is open.
Open the folder 4 — Components > Aggregate Bases > Shoulders.

<D> <D> on the ABC_Outside_Shoulder component.

| ormparients
5 Aggregate Bases
[ Curb & Gutter
- . . . [] |

) = W= = e W [ [

x

== ABC_Outside_Shoulder

<D> <D> on the ABC_Hinge-Top point.

In the Point Properties dialog box, notice that this point has both a Horizontal and Slope
constraint.
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6.

10.

11.

Change the Slope constraint to None and <D> Apply. This will allow the point to move
up and down independent of any other point.

._h" Point Propetties

Name: ABC_Hings-Top - #| [
Feature Mame Overide: | AEC Hinge-Top

Surface Feature Shile: [0 HINGE - |

L
L
Alternate Surface: |_
L

Member aof:
ABC_Outzide_Shoulder

Congtraints

<D> Close.

Notice in the Create Template view window how the point symbol (+) changes from red to
yellow. This color change means the point has changed from fully constrained to partially
constrained.

ABC Hinge-Top

h

_thC Hinge-Top
)

SubBase_Hinge-Top
SithB3

SubBase_Hinge-Top

| Test... | | Test... |
<R> on the ABC_Hinge-Top point and select Move Point from the menu.

Note: The Move Point command will not appear in the menu if the point is fully
constrained.

Because the point still has a Horizontal constraint, it will only move up and down while
maintaining the 12 foot offset from the constraint point, ABC_Shoulder-Top.

<R> to exit the Move command.
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12.
13.

14.
15.
16.

17.

18.
19.

20.
21.

22.

<D> <D> on the Subbase_Hinge-Top point.

Notice that Subbase_Hinge-Top is constrained both horizontally and vertically to
ABC_Hinge-Top. Therfore, if ABC_Hinge-Top moves, Subbase_Hinge-Top will follow
according to what is entered in the constraint Value: field. The next few step will
demonstrate how this works.

<D> Close.
<R> on the ABC_Hinge-Top point and select Move Point from the menu.

Notice how the point Subbase_Hinge-Top stays 0.5 feet directly below point ABC_Hinge-
Top. This is because the point has a Horizontal constraint of O and a Vertical constraint of -
0.5. from ABC_Hinge-Top.

<R> to exit the Move command.

The point ABC_EOP-Top is also fully constrained by ABC_Hinge-Top. The difference with
this point it that it that the second constraint is by Vector-Offset instead of Vertical.

<D> <D> on the ABC_EOP-Top to look at the Vector/Offset constraint.

Notice that this type of constraint uses two parent points instead of one. The slope between
the two parent points determines the “vector” at which the point will be placed.

<D> Close.

Move the point ABC_Hinge-Top again and notice how the point ABC_EOP-Top moves
with it. The Vector/Offset constraint forces the point ABC_EOP-Top to maintain the same
slope defined by ABC_Shoulder-Top and ABC_Hinge-Top.

<R> to exit the Move command.

The next few steps demonstrate how ABC_Hinge-Top behave with a vertical constraint and
without a horizontal constraint.

23.
24.

<D> <D> on the ABC_Hinge-Top point.

Change the None constraint back to Slope.
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25.

26.

217,
28.

29.

30.

31.
32.

Set the Parent 1 to ABC_Shoulder-Top and change the Horizontal constraint to None.

B Doint Properties =)
Name: ABC_Hinge-Top - 4
Feature Mame Ovenide: | ABC Hinae-Tor [ Closa |
Suiface Featwre Stle:  [n HINGE = T

= | ¢ Previous |
Alvernate Surface:
Mest »
Help
Member of;
ABC_Dutside_Shoulder
Constraints
Constraint 1 Conslraint 2
Type: INone vI Slope =
Patent 1: ABC_Shoulder-Top = ﬂ
Value: -2.00%
<D> Apply.

Note: When you click Apply, the two constraints will switch places. This is because the
None constraint will always end up as Constraint 2.

<D> Close.

Move the point ABC_Hinge-Top again an notice that now the point only moves to teh
left and right. The Slope constraint forces it to maintain a -2.0% slope from the point
ABC_Shoulder-Top.

<R> to exit the Move command.

Reset the point ABC_Hinge-Top back to its original setup. <D> <D> on the point, change
the None constraint back to Horizontal, and set Parent 1: to ABC_Shoulder-Top.

<D> Apply.

<D> Close.

Chapter Summary:

Use a simple component to quickly generate an unconstrained closed shape. Lab 7.1 -Build
A Simple Component showed how to modify point names in using the Point Properties
dialog.

The next lab, Lab 7.2 -Build a Constrained Component, demonstrated how to create a

constrained component from scratch using the Dynamic Settings dialog box and various
methods for the key-in.
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e Lab 7.3 -Build an End Condition Component explored the special features of an end
condition component. For end condition components there are additional options in the
Dynamic Settings dialog box which determine how end condition points in relation to a
target.

e InLab 7.4 -How Point Constraints Work several constraint options were explored
including Horizontal, Vertical and Vector-Offset. This lab demonstrated how changing the
constraint method affects the points position and how points react to the Parent it is
constrained to.
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