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LAB 23 - Terraced Walls

This lab covers how to use Surface Design and Editing tools to create a terraced wall under a bridge. For more 
information on the commands shown here, please see the Surface Editing chapter of A Practical Guide for 
Using InRoads XM.

In this scenario, three terraced walls are to be used under the SH52 bridge over SH119. Horizontal alignments 
have already been defined for the three walls along with verticals for the tops of the walls. A template will be 
created and run along the top wall to seek the other two walls and create the slopes between them.

Chapter Objectives:: 

 To learn to use additional Surface Design tools.

 To expand your knowledge of templates by creating a special case terraced wall template.

 To learn how to use templates without setting up a corridor in Roadway Designer.

Lab 23.1 - Open Data Files

If you have not exited since the last lab, you can skip this section.

1. Open MicroStation and InRoads using the C:\Projects\12345\Design\Working 
\CU12345DES_Model.dgn file.

2. Verify the correct XIN file is loaded.

3. Select File > Open from the InRoads menu.

4. Open C:\Projects\12345\Design\InRoads\12345 SH119.dtm, 12345 SH52.dtm, 
12345DES_Templates.itl and 12345 SH119 SH52 interchange.alg. 

5. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.dtm.

Lab 23.2 - Create Components for the Wall and Slope

The three walls are very similar and therefore one set of components can be created and used 
multiple times in the final template. To start, components are created that will be run off of Wall 
D-16-E and will ‘find’ or ‘target’ Wall D-16-F. This is used in areas where there is a terrace.

1. Delete any MicroStation graphics currently in the design file.
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2. Select Geometry > View Geometry > All Horizontals.

3. Fit the view.

4. Window around the terraced wall area to the left of SH119.

Note: The wall names in the illustration below are for information only. The walls are not 
labeled in your file.
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Note: Walls D-16-E, D-16-F and D-16-G will be created using a terraced wall template.

5. Select Modeler > Create Template.

6. Verify the template library is 12345DES_Templates.itl.

Note: Since there are no similar template to the one needed, a new one is created.

7. Expand the library folder structure for Components > Barriers & Misc Components > 
Walls.

8. Right-click on the Walls folder and select New > Template.

9. While the name is highlighted, type over it with Terrace_Wall.

10. Select Tools > Dynamic Settings.

11. Toggle Apply Affixes off.



Page 458 Colorado Department of Transportation

LAB 23 - Terraced Walls Labs for InRoads XM

12. For X and Y Step, key in 0.1.

13. Right-click in the template view and select Add New Component > End Condition.

14. Under Current Component, key in Finds next wall align for the Name.

15. Set the Style to D_Wall-Retaining.

16. Set the Target Type to Alignment XYZ.

17. Set the Horizontal Alignment to Wall D-16-F.

18. Set the Vertical Alignment to Wall D-16-F.

Note: Since the template will start at Wall D-16-E, Wall D-16-F is the next wall 
alignment. With a target of Alignment XYZ, the component will use a variable 
slope to ‘find’ the horizontal and vertical alignment.

19. In the Dynamic Settings box, key in Wall_E_Top-Front for the Name.

20. Select D_Wall-Retaining for the Style.

21. <D> on the origin point (0,0).

22. Back in the Dynamic Settings box, change the name to Wall_F_Top-Front.
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23. <D> on a point down and to the right of the first point as shown.

24. <R> and <D> Finish to complete the component.

25. Edit the second point, Wall_F_Top-Front. (Either double-click the point or right-click and 
choose Edit.)

26. For the Slope Constraint, set the Value to 50.00%.

27. For the Horizontal Constraint, set the Value to 15.00.

Note: Because the target for this end condition is both a horizontal and a vertical 
alignment, these values are actually ignored when the template is run. However, it 
gives a more accurate picture to use realistic values.

28. <D> Apply, then Close.
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29. Fit the template.

In the following series of steps, another component is added to create the face of the wall, a 
25% slope to the next wall and a flat top for the next wall.

30. Right-click in the template view and select Add New Component > Unconstrained.

31. Right-click again and make certain all options are toggled off.

32. <Esc> to dismiss the menu if everything was already off.

33. Under Current Component, key in Wall face and terrace for the Name.

34. Set the Style to D_Wall-Retaining.

35. In the Dynamic Settings box, select D_Wall-Retaining for the Style.
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36. Key in 1 for the Point Name.

Note: This is just a temporary seed name to place points. You will later rename the 
points.

37. <D> on the Wall_E_Top-Front point to start the component.

38. <D> to create two additional points similar to what is shown.

Note: Do not worry about getting them exact. The slopes and distances will be set with 
constraints.

39. <D> on the Wall_F_Top-Front point for the final point in this component.
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40. Right click and select Finish.

41. Edit the point 11 just inside the Wall_F_Top-Front point. 

Note: This point will create the flat top on Wall F.

42. Key in Wall_F_Top-Back for the Name.

43. Set Constraint 1 to Horizontal.

44. Set Parent 1 to Wall_F_Top-Front.

45. Key in a Value of 1.00. 

46. Set Constraint 2 to Vertical.

47. Set Parent 1 to Wall_F_Top-Front.
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48. Key in a Value of 0.00.

49. <D> Apply, then Close.

50. Edit the point 1 below Wall_E_Top-Front.

Note: This point will become the location where the face of the wall is intercepted by the 
25% backfill slope.

51. Key in Wall_E_Backfill for the Name.

52. Set Constraint 1 to Horizontal.

53. Set Parent 1 to Wall_E_Top-Front.

54. Key in a Value of 0.1. 

Note: This will force a small slope on the front face of the wall to allow triangulation.

55. Set Constraint 2 to Slope.

56. Set Parent 1 to Wall_F_Top-Back.
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57. Key in a Value of -25.00%.

58. <D> Apply, then Close.

Note: Since the horizontal and slope constraints have two different parent points, the 
location of this point varies when either of the parents moves.

59. <D> Test.

60. Under Available Targets, <D> on the wall alignment.

61. <D> Draw.
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62. Move your cursor into the template view to see how the components react.

Note: The original component has a variable slope, while the Wall face and terrace 
component maintains all slopes. It should also be noted that there is no need to 
display the original component. Also, if the original component fails the Wall face 
and terrace component should not display either. Both of these situations will be 
taken care of next.

63. <D> Close on the Test End Conditions box.

64. Edit the Wall_F_Top-Front point.

65. Toggle on Do Not Construct.
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66. <D> Apply, then Close.

Note: The Finds next wall align component disappears. However, the portion of the Wall 
face and terrace component that contains the Wall_F_Top-Front point remains. 
This is because Do Not Construct only affects end condition components.

67. Edit the Wall face and terrace component. (Double-click the component or right-click on 
the component and choose Edit.)

68. Set the Parent Component to Finds next wall align.

69. <D> Apply, then Close.



Colorado Department of Transportation   Page 467

Labs for InRoads XM LAB 23 - Terraced Walls

Note: Now, if the Finds next wall align end condition fails, neither component is used.

70. Test the template again to see the difference. 

Note: Now, only a dashed line is shown initially, indicating when the end condition fails, 
nothing is displayed. When the end condition succeeds, only the Wall face and 
terrace is displayed.

71. <D> Close on the Test End Conditions box.

72. Save the template library.

Lab 23.3 - Create a Component for the Wall Face

In the areas where a perpendicular application of the template from the upper wall alignment 
would not find the next wall, the template should create a wall face. This situation will be 
covered in a new template and combined with the other template later. 
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1. Right-click on Walls folder again in the library and select New > Template.

2. While the name is highlighted, type over it with Wall_Face.

Note: Since the face of the wall will eventually be attached to the Wall_Top-Front points 
which are set to Do Not Construct, the face of the wall must be made up of a non-
end condition component. However, the face of the wall must also be an end 
condition so it will stop when it intercepts the target surface. Therefore, the same 
theory is used for the face as for the terrace: an end condition that doesn’t display is 
used along with a ‘regular’ component that does display.

3. Right-click and select Add New Component > End Condition.

4. Under Current Component, key in Finds active surface for the Name.

5. Set the Style to D_Wall-Retaining.

6. Set the Target Type to Surface.

7. Set the Surface to <Active>.

8. Set the Priority to 2.

Note: Since this component is to be used only where the terraced wall doesn’t work, it 
will need to be second in priority.

9. In the Dynamic Settings box, key in Wall_E_Top-Front for the Name.
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10. Select D_Wall-Retaining for the Style.

11. <D> on the origin point (0,0).

12. Back in the Dynamic Settings box, change the name to Wall_E_Backfill.

13. <D> on a point down and to the right of the first point as shown.

14. Right click and select Finish.

15. Edit the second point, Wall_E_Backfill.

16. Change the Slope Constraint to Vertical and set the Value to -5.00

17. For the Horizontal Constraint, set the Value to 0.1.

18. Toggle on End Condition is Infinite.
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19. Toggle on Do No Construct.

20. <D> Apply, then Close.

21. Fit the template.

Note: The line forming the component disappears, but the points are still there.

22. Right-click in the template view and select Add New Component > Unconstrained.
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23. Right-click again and make certain all options are toggled off.

24. <Esc> to dismiss the menu if everything was already off.

25. Under Current Component, key in Wall face for the Name.

26. Set the Style to D_Wall-Retaining.

27. <D> on the Wall_E_Top-Front point to start the component.

28. <D> on the Wall_E_Backfill point.

29. Right click and select Finish.

30. Edit the Wall face component.

31. Set the Parent Component to Finds active surface.
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Note: Now, if the Finds active surface end condition fails, neither component is used.

32. Test the template. 

Note: Only a dashed line is shown initially, indicating when the end condition fails, 
nothing is displayed. When the end condition succeeds, only the Wall face is 
displayed. The template is ‘fit’ to the view, so the slope seen here is not indicative 
of the final slope.

33. <D> Close on the Test End Conditions box.

34. Save the template library.

Lab 23.4 - Create the Final Wall Template

Next, these templates are combined to create the final wall template.

1. Right-click on Walls folder again in the library and select New > Template.
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2. While the name is highlighted, type over with 3_Terraced-walls.

3. Highlight, but do not make active, Terrace_Wall.

4. Drag the Terrace_Wall template from the preview and drop it on the origin of the new 
template.

5. Highlight, but do not make active, Wall_Face.

6. Drag the Wall_Face template from the preview and drop it on the origin, making certain 
the Wall_E_Top-Front point turns white.

7. <D> Test.

8. <D> on the <Active>-Surface under Available Targets.

9. <D> on Draw.
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10. Move your cursor into the template view.

Note: The wall face appears, indicating that when the first option, the Wall face and 
terrace, fails, the wall face alone will be created.

11. <D> on the Wall D-16-F alignment under Available Targets.

12. <D> on Draw.

13. Move your cursor into the template view.

Note: The wall face and terrace appear.
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14. <D> Close on the Test End Conditions dialog.

There are two Wall_E_Backfill points in the template, so one was renamed with a suffix. In the 
model, only one of these points will be used at any given location and together, they should 
form just one breakline. This is accomplished with Feature Name Overrides.

15. Select Tools > Apply Feature Name Override.

16. Highlight the two Wall_E_Backfill points

17. Key in Wall_E_Backfill for the Feature Name Override.

18. <D> Apply, then Close.

Note: The names turn red in the template view, indicating the names have been 
overridden.

19. Save the template library.

20. Highlight the 3_Terraced-walls template in the list at left.
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21. Drag and drop the template from the preview onto the Wall_F_Top-Front point, making 
certain the point turns white.
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22. Edit the two backfill points for Wall F and rename the points to Wall_F_Backfill and 
Wall_F_Backfill1.

23. Rename the Wall_F_Top-Front1 point to Wall_G_Top-Front.
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24. Rename the Wall_F_Top-Back1 point to Wall_G_Top-Back.

25. Select Tools > Apply Feature Name Override.

26. Highlight the two Wall_F_Backfill points

27. Key in Wall_F_Backfill for the Feature Name Override.

28. <D> Apply, then Close.
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29. Highlight, but do not make active, Wall_Face.

30. Drag the Wall_Face template from the preview and drop it on Wall_G_Top-Front, making 
certain the Wall_G_Top-Front point turns white.
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31. Change the new Wall_E_Backfill2 point to Wall_G_Backfill.

32. At the bottom of the Template Library list at left, select the Active Template tab.

33. Expand the Components list.
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34. Right-click on Finds next wall align1 and select Edit.

Note: Since this component was created from the original one, it is still seeking the Wall 
F alignments. Here, you’ll change it to seek Wall G.

35. Change the Horizontal and Vertical Alignments to Wall-D-16-G.



Page 482 Colorado Department of Transportation

LAB 23 - Terraced Walls Labs for InRoads XM

36. <D> Apply, then Close.

37. Save the template library.

38. At the bottom of the Template Library list at left, select the Library tab.

39. Test the 3_Terrace-walls template.

40. <D> Close on the Test End Conditions dialog.

41. <D> Close on the Create Template dialog.

Lab 23.5 - Create the Terraced Wall Surface

In this section, the template is used to create a surface representing the terraced walls. The 
template is run along a graphic element created from the horizontal and vertical alignment for 
Wall E using the Apply Template command. As an alternative, Roadway Designer could be 
used. 

1. Delete the alignment graphics in the file.

Important! If the original graphics remain in the file, you are likely to accidentally 
identify them when selecting the path for the template, so it is best to 
delete the original alignment display. The original graphics are at elevation 
0. The graphic you are creating is 3D.

2. Select Geometry > View > 3D Alignment.

Note: This command creates a 3D linestring, taking the X and Y coordinates from the 
specified horizontal alignment and the Z coordinate from the specified vertical 
alignment.

3. Select the Horizontal and Vertical alignments Wall-D-16-E.
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4. Toggle on Station Limits.

5. Leave the Start Station set to 0+00.00.

6. Key in 1+98.35 for the Stop Station.

Note: This is the station at the end of the second curve in the wall alignment. From that 
point on, the wall will be created with the ramp.

7. Under Include Cardinal Points, toggle on Horizontal and Vertical.

8. Key in 1.00 for the Interval.

Note: This is how often a vertex is created on the resulting linestring.

9. <D> Apply, then Close.
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10. Fit the view.

 

Note: The 3D linestring is shown here in plan and in a rotated view. It forms the origin 
point for the wall template.

11. Make 12345 SH119 the active surface.

Note: The SH119 surface has a 3:1 slope from the bottom of the ditch that creates a 
‘target’ for the walls.

Important! Since the template was created to search for the active surface, SH119 
must be active.
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12. Set the Locate Features / Locate Graphics toggle to Locate Graphics.

13. Select Surface > Design Surface > Apply Template.

14. Key in 12345 walls E F G for the Design Surface.

Note: The design surface does not have to exist. It is created when the command is 
applied.

15. Set the Reference Feature Interval to 10.00.

16. Toggle on Stroke Tolerance.

Note: The Value does not matter unless the reference graphic has an arc in it. Using View 
3D Alignment creates a linestring that does not contain arcs.

17. Highlight the 3_Terraced_Walls template in the 4 Components/Barriers & Misc 
Components/Walls folder.

18. Set Duplicate Names to Replace.

19. Toggle on Remove Loops.

20. Toggle off Generate Graphics Only.
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21. Toggle on Triangulate Surface.

22. <D> Apply.

23. <D> on the 3D alignment graphic to identify the Primary Element.

24. <D> anywhere in the view to accept.

25. <D> on the 3D alignment graphic again to identify the Reference Element.

26. <D> anywhere in the view to accept.

27. <R> to apply the template to the entire element.
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Note: Temporary graphics appear showing the resulting feature locations.
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28. <D> anywhere in the view for the location.

Note: The Results dialog appears showing any end condition failures. Above, you see the 
plan and rotated views of the graphics. There may be failures at either end of the 
graphics, since the alignment actually begins slightly underground.

29. Save the wall surface to the c:\Projects\12345\Design\InRoads folder.

30. Review the surface by displaying triangles and/or contours.

Note: If the view is rotated, return to a top view when done.

31. Set the active alignment to SH52-H.
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32. Select Evaluation > Profile > Create Profile.

33. Toggle on 12345 existing ground for interchange, 12345 SH52, 12345 SH119 and 12345 
walls E F G.

34. Select the Controls branch.

35. Set the Station Limits to 106+00 to 109+00.

36. <D> Apply.

37. <D> a clear area in the design file for the location of the profile.
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38. Window in to see the wall surface.

Note: Since templates can also contain non-triangulating and closed shape components, 
walls, footers, leveling pads, etc. can be created as part of the template if desired.

Note: The features developed here can be combined with features from the other models 
to create an overall interchange model.

Chapter Summary:

 Templates can be used to create features for surfaces other than roadways.

 Templates can be used without Roadway Designer by ‘running’ them on a 3D elements or 
features.

 Using targets other than surfaces can greatly expand the capability of templates, allowing 
them to create features for a variety of design applications.
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