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LAB 1 - Getting Started in InRoads for Bridge 

Chapter Objectives:

 Setup a project with the correct resources including the creation and maintenance of an 
InRoads project file

 Identify and load the correct resources and files needed for bridge design

 Develop an understanding of what InRoads tools to use as they relate to real world design 
processes

Note: The *.zip file of the data set for these labs can be downloaded from the website 
Labs_for_Bridge_Essentials.  The zip file should be extracted to the C:\Projects\ 
directory.  If the labs will not be worked through sequentially,  the data for each lab is 
also found in the Miscellaneous directory of the data set.  To use the files from 
theMiscellaneous directory, copy the files in each specific lab folder following the 
instructions found in the *.doc file.

Lab 1.1 - Purpose of Bridge Essentials Labs

The Bridge Essential labs have been developed to demonstrate how InRoads tools can be used 
to facilitate the design and detailing processes of bridges and structures. These labs are 
intended as a supplement to the reference material and labs developed for the standard 
MicroStation and InRoads courses. 

The labs are based on students having a basic understanding of MicroStation. A basic 
understanding of InRoads is preferable, but not required. Some of the basic InRoads concepts 
are covered in these labs only to explain more specific details as they relate to the Bridge 
workflow. However, for concepts that are not specific to the Bridge workflow, refer to the 
reference material for MicroStation and InRoads to gain a fundamental understanding of the 
CDOT engineering software environment.

For those with little or no experience with InRoads, use the links below to access standard 
MicroStation and InRoads reference material related to this lab.

From A Practical Guide for Using MicroStation XM 

♦ Chapter 1 - Introduction to CDOT - This chapter documents helpful CADD resources 
available to the student and links to those resources.

♦ Chapter 2 - Getting Started in MicroStation- This chapter documents the basics of the 
MicroStation interface including mouse mechanics, the MicroStation Manager 
window, and description of the toolbars.

♦ Another important chapter for the student to understand is Chapter 3 - Levels. Use this 
link if you are not familiar with how levels are organized and how to use them.

http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/Labs for Bridge Essentials/Labs_for_Bridge_Essentials.htm
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter01_Introduction to CDOT.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter02_Getting_Started_in_MicroStation.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter03_Levels.pdf
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From A Practical Guide for Using InRoads XM 

♦ Chapter 1 - Getting Started in InRoads describes where to find and store files used in 
InRoads, how to setup a project directory, and best practices for setting up InRoads to 
automatically use the correct InRoads files and point to the correct InRoads folders.

♦ Chapter 2 - InRoads Options provides instruction on what Locks are and how to use 
them in addition to setting up the display precision for reports and setting the scale 
factors for how InRoads displays text, cells, and line styles.

1. Use the following link to see what other training material, including reference material and 
labs, is available for your use: Manuals, Training Materials, and Resources.

Lab 1.2 - Review of the Project Directory Structure

Project Setup
Setting up a project directory is generally performed by the Project Manager. However, a 
standard project directory structure can also be used to store data that is not part of a formal 
project. Benefits of setting up a standard project directory in these cases include:

 Ensures that predictable MicroStation and InRoads resources are being used to develop the 
data

 Facilitates the transfer of data to/from other project participants, entities, or storage areas

 Reduces need for support and associated downtime

The standard project directory structure is suitable for small and large projects, projects in a 
network environment or stand alone projects, and even projects in the ProjectWise 
environment. By using this standard directory structure, Bridge users will be able to find the 
data they need from other specialty groups and in return specialty groups will be able to find 
the data supplied by bridge.

The next few steps will illustrate how to create a project directory for a stand alone project.

Note: Because a stand alone project does not have a project code use a project code of 
00001 as the project number.

1. Follow the steps outlined in the section “Creating the Project Directory” found in Chapter 
1 - Getting Started in InRoads of A Practical Guide for Using InRoads XM to create the 
project folder.

http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_InRoads_XM/InRoads_Reference-Chapter01_Getting Started in InRoads.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_InRoads_XM/InRoads_Reference-Chapter02_InRoads Options.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/CADD Manuals and Training Index.htm
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter02_Getting_Started_in_MicroStation.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter02_Getting_Started_in_MicroStation.pdf
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2. Open Windows Explorer and navigate to the new 00001 project folder.

3. Expand the Bridge folder.

The folders highlighted in the image above are the folders that will be most often used during 
this course and the normal design process. 

In addition to these folders, files in the ROW_Survey\InRoads and Design\InRoads folders 
will be used as a basis for bridge and structure design.

 The topographic survey file will be found in the ROW_Survey\InRoads folder.

 The proposed roadway alignment and surfaces will be found in the Design\InRoads folder.

Lab 1.3 - InRoads Terminology

The following steps will show how the user how to use the Help system that comes with the 
product to find definitions to unfamiliar terminology.



Page 10 Colorado Department of Transportation

LAB 1 - Getting Started in InRoads for Bridge Bridge Essentials Using InRoads XM

1. Launch InRoads Help by going to Help > Contents in the InRoads application window.

2. On the Contents tab, click on Supplemental Information > Glossary.

3. Look up the following terms in the Glossary:

a. Original Surface and Design Surface

b. Digital Terrain Model

c. Perimeter

d. Geometry Project

e. Alignment

f. Corridor

g. Project and RWK

Lab 1.4 - Understanding How Project Design Data is Stored

This section will help you understand how the different design features, such as surfaces, 
alignments, and typical sections, relate to InRoads file types. Managing InRoads data will be a 
lot easier if you have a good understanding of this relationship. The following table shows how 
InRoads file types relate to design elements.

Additional information on how these file types in the section “InRoads XM Resource 
Locations” found in Chapter 1 - Getting Started in InRoads of A Practical Guide for Using 
InRoads XM. 

The next few steps illustrate a practical application of how to manage InRoads data in the 
project directory structure. There are several files located in the \Miscellaneous directory of 
project 12345 that need to be moved to the project 00001. 

Design Element
InRoads 

File

Surfaces - Topographic (existing) or proposed design *

Alignments *.alg

Typical sections (templates) *.itl

Modeling (corridors) *.ird

Control how graphics look (preferences) *.xin

InRoads project *.rwk

http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_InRoads_XM/InRoads_Reference-Chapter01_Getting Started in InRoads.pdf
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4. Open Window Explorer and navigate to the directory \12345\Miscellaneous.

5. Move all the files that begin with 00001 to the correct folders in the \00001 project 
directory.

Note: Each discipline has a standard acronym. Use this acronym to determine the folder 
the file should be placed in (e.g. BRDG is the acronym used for the bridge group).

Note: The contents of these files are irrelevant. Only the filenames are important in this 
exercise.

6. Identify the one file that should not be used from the project directory structure because it 
is not a standard file.

Note: Notice that there is only one geometry (*.alg) file for bridge. A good practice is to 
store all alignments in one geometry file. There are only a few situations that 
would require using more than one geometry file.

Using Project Defaults
InRoads Project Defaults are a way to improve the process of loading and saving InRoads files 
by setting a default path to the project folder where the resource should be located. This is 
accomplish by using another file type with the extension *.reg.   

1. Launch MicroStation and set the Project Workspace to 00001. 
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Note: You will need to revisit the MicroStation Manager window to set the project 
workspace to 12345 for subsequent labs.

2. Open the file 00001BRDG_Model.dgn from the directory 
C:\Projects\00001\Bridge\Drawings\Reference_Files.

3. Launch InRoads by clicking on the  icon.

4. Follow the steps in the workflow CDOT InRoads XM Project Defaults Management to 
import the standard CDOT project defaults and set the Configuration Name to CDOT 
Bridge Discipline.

5. Click Apply and then Close the Project Defaults dialog box.

http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Workflows/V8 XM/CDOT InRoads XM Project Defaults Management.pdf
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6. From the InRoads interface, select File > Open. Notice how InRoads now defaults to the 
Bridge folder of the project.

There are two keys to getting project defaults to work correctly:

 Load the correct pcf file by choosing the correct project workspace in the MicroStation 
Manager window

 Set the project default configuration name to CDOT Bridge Discipline

Lab 1.5 - Requesting InRoads Design Data

Before starting a Bridge project, you will need to load InRoads data files that have been created 
by other groups. The following is a list of these InRoads data files. Request the files from the 
appropriate contact person in each group.

The files should be copied into the Bridge\InRoads folder. The responsible group should 
update the Bridge group if any changes are made to these files, including:

 Additional/new survey data

 Revised alignments (horizontal and vertical)

 Revised typical sections

 Additional work at approach to structures

Lab 1.6 - Using the Bridge Toolbar to follow a Workflow

Design Element
InRoads 

File
Responsible 

Group

Existing surface * Survey

Proposed (design) surface * Roadway Design

Proposed (design) alignments *.alg Roadway Design

Roadway Typical Sections (if needed) *.itl Roadway Design
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Not all InRoads tools are relevant to Bridge design and detailing processes. In addition, some 
tools are used more often than others. The purpose of the Bridge toolbar is to organize the most 
commonly used InRoads tools in a concise, sequential order and make them easily accessible.

The toolbar is not intended to be complete at this time but has been created to introduce bridge 
designers to the toolbar concept. With input from the bridge group, it is expected that the 
toolbar will change over time according to the needs of the group.

The toolbar needs to be loaded manually. Once loaded, the toolbar resides in the registry of the 
computer and only needs to be loaded again if it changes. 

1. Load the Bridge Design toolbar by selecting Tools > Customize. The Customize dialog 
box will appear.

2. Click n the Import tab and choose Browse.

3. Select the CDOT Bridge.tbr file from the C:\Workspace\Workspace-
CDOT_XM\Standards-Global\InRoads\Interface directory.
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4. Click on Import.

5. Click on the Toolbars tab

6. Check on CDOT Bridge in the Toolbars: area. The CDOT Bridge toolbar will appear on 
the screen

7. Close the Customize dialog box.
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8. Click on the title bar of the CDOT Bridge menu to make it active.

9. Hover over the Project Defaults icon. A tool tip appears to indicate what tool the icon 
represents.

10. An explanation of what the tool does also appears in the lower left of the InRoads 
application window.

For now, the toolbar is divided into the following sections:

a. Project Defaults - Used to set the default paths to InRoads files

b. View Surface - Used to evaluate a surface including displaying the contours or surface 
features

c. Review Horizontal Alignments - Used to display and annotate horizontal alignments 
and generate alignment reports

d. Profiles and Vertical Alignments - Used to generate and annotate profiles

e. Cross Sections - Used to generate and annotate cross sections
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The Project Defaults tool was explained in this lab. The other tools on this toolbar will be 
explained in the next lab.

11. Now that you understand how to create a project and manage the data within a project 
directory structure, Delete the project 00001.

Chapter Summary:

 Using the standard project directory structure will make it easier to manage project data 
and facilitate the correct usage of InRoads resources.

 Using Project Defaults will make it easier to save and retrieve InRoads files to/from the 
correct project folders.

 Using the Bridge Toolbar will reduce the amount of time looking for the correct InRoads 
tool. In addition, the toolbar is workflow based, allowing the user to quickly find the 
correct tool based on the design stage being worked on.
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