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LAB 4 - Templates and Corridors

This lab demonstrates the use of templates and corridors to create a surface model (dtm) that can then be used 
to calculate earthwork and other quantities.  This method of design is well suited for linear construction sites 
such as ditches/channels and walls.

In this exercise, a template is created that contains a cast-in-place reinforced concrete channel liner, the 
excavation required to build the liner, and backfill to complete the construction.  Below is a sketch of the 
template.

Note: The slope paving shown in the illustration above has been omitted for this lab.

Chapter Objectives:

 Build a template showing the excavation, channel liner, and slope paving.

 Create a corridor that follows an alignment.

 Review design data in Roadway Designer.

 Generate design surfaces from the template and corridor.

The following files are used in this lab:

 C:\Projects\12345\Bridge\Drawings\Reference Files\12345BRDG_Model-Drain.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345_Drain

 C:\Projects\12345\Bridge\InRoads\12345_Drain.alg

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl
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Lab 4.1 - Construct the Channel Liner

The ditch liner is a closed shape component that defines the design channel.  The wall of the channel liner are 4 
inches thick and the bottom is 6 inches thick.  The left side rises 6 inches above the existing ground, while the 
right side is flush with the existing ground.  This component is not included as part of the triangulated surface 
model because it does not define the area of excavation.

Section Objectives:

♦ Copy the standard template library into the project folder.

♦ Create a new template in the project template library.

♦ Construct a new channel liner component for the  template.

♦ Edit point properties to define the shape of the liner.

♦ Edit the component properties to exclude the line from triangluation.

1. Start MicroStation and InRoads opening the 12345BRDG_Model-Drain.dgn file. 

2. In the main InRoads dialog box, verify that the CDOT_Civil.xin is loaded.

3. From the InRoads menu bar, select File > Open.

4. Navigate to the C:\Projects\12345\ROW_Survey\InRoads\DTM\ directory and 
open the 12345_Drain file

5. Navigate to the C:\Projects\12345\Bridge\InRoads\ directory and open the 
12345_Drain.alg file.
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6. Navigate to C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Templates\ and open the CDOT_Template-Library.itl file.

7. Navigate to C:\12345\ROW_Survey\InRoads\DTM\ and open 12345_Drain.

8. <D> Cancel to dismiss the Open dialog box.

9. In the InRoads Explorer pane, <D> the Templates tab.

10. <R> on CDOT _Template-Library and select Save As from the right click menu.

11. In the Save As dialog box, navigate to the C:\Projects\12345\Bridge\InRoads\ folder.

12. Key in 12345BDRG_Templates.itl for the file name.
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13. <D> Save then <D> Cancel.

14. From the InRoads menu bar, select Modeler > Create Templates.  This displays the 
Create Template dialog box.

15. From the Create Template menu bar, select Tools > Dynamic Settings.

16. In the  Dynamic Settings dialog box, key in 0.10 for both the “X” and “Y” Step.

17. Toggle on Apply Affixes.

The Dynamic Settings dialog box is used to enter data while constructing a component.
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18. In the Template Library Explorer area of the Create Template dialog box, expand the 
folders to show the contents of the 1-Templates folder.

19. <R> on the 1-Templates folder and select New > Template from the right click menu.

20. Key in 12345_Channel-Liner for the template name.

Because the channel liner is a unique shape, there are no components in the library that can be 
used.  Therefore, it will be built as a new component.  The channel liner is first “sketched in” as 
an Unconstrained component.  Then constraints are applied to the component points to define 
the proper shape.

21. <R> in the Template view and select Add New Component > Unconstrained from 
the right click menu.

22. In the lower center of the dialog box, data fields are displayed that apply to the new 
component.  In the Name field, key in Channel Liner.
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23. Select D_CONC_Pvmt from the Style drop down menu.

24. In the Dynamic Settings dialog box, <D> on the Point Name drop down arrow, and select 
Conc_Centerline-Top from the menu.  This automatically sets the Point Style as well.

25. Move the cursor onto the Template Origin (the magenta square) so that the readout in the 
Dynamic Settings dialog box is X: 0.00 Y: 0.00, then <D>.

26. In the Dynamic Settings dialog box, <D> in the Point Name field and key in Ditch-
Bottom. 

27. Set the Point Style to D-DITCH-Bottom.

28. Move the cursor into the Template View to the right of the origin and <D> to place the 
RT_Ditch-Bottom point.  The “RT_” is added to the name because Apply Affixes is on.

29. Key in Wall_Inside-Top for the next point.

30. Set the Point Style to D_CONC_Pvmt.

31. <D> above the RT_Ditch-Bottom point.
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32. Use the diagram below to name and place the remaining points.

33. After the last point is placed, <R> in the Template View and select Finish from the right 
click menu.

This completes the basic outline of the channel liner.  Next, constraints are assigned to the point 
to form the exact shape desired.

34. <D><D> on the RT_Ditch-Bottom point.  This displays the Point Properties dialog box.

35. In the Point Properties dialog box, set the Constraint 1 Type to Horizontal.

36. Set the Constraint 2 Type to Vertical.
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37. Set the Parent 1 for both constraints to Conc_Centerline-Top.

38. Key in 2.00 for the Constraint 1 Value.

39. Key in 0.00 for the Constraint 2 Value.

40. <D> Apply.

The RT_Ditch-Bottom point symbol changes to red and the point move to be 2 feet to the right 
of the Conc_Centerline-Top point.

41. <D> Next> to move to the RT_Wall_Inside-Top point.

42. Set the Constraint 1 Type to Horizontal.

43. Set the Constraint 2 Type to Vertical.

44. Set the Parent 1 for Constraint 1 to RT_Ditch-Bottom.

45. Set the Parent 2 for Constraint 1 to RT_Wall_Outside-Top.

46. Key in 0.00 for the Constraint 1 Value.

47. Key in -0.04 for the Constraint 2 Value.
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48. <D> Apply.

49. <D> Next> to move to the RT_Wall_Outside-Top point.

50. Set the Constraint 1 Type to Horizontal.

51. Set the Constraint 2 Type to Vertical.

52. Set the Parent 1 for both constraints to RT_Ditch-Bottom.

53. Key in 0.34 for the Constraint 1 Value.

54. Key in 0.04 for the Constraint 2 Value.
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55. <D> Apply.

The Vertical constraint is temporary, in order to position the point.  The final Constraint 2 is 
now set.

56. Set the Constraint 2 Type to Project to Surface.

57. Set the Parent 1 for Constraint 2 to Up.

58. Select 12345_Drain for the Constraint 2 Value.
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59. <D> Apply.

60. <D> Next> to constrain the RT_Outside-Bottom point.

61. Set the Constraint 1 Type to Horizontal.

62. Set the Constraint 2 Type to Vertical.

63. Set the Parent 1 for  Constraint 1 to  RT_Wall_Outside-Top.

64. Set the Parent 1 for  Constraint 2 to RT_Ditch-Bottom.

65. Key in 0.00 for the Constraint 1 Value.

66. Key in -0.50 for the Constraint 2 Value.

67. <D> Apply then <D> Next> to constrain the LT_Outside-Bottom point.

68. Set the Constraint 1 Type to Horizontal.

69. Set the Constraint 2 Type to Vertical.

70. Set the Parent 1 for  both constraints to LT_Ditch-Bottom.

71. Key in -0.34 for the Constraint 1 Value.

72. Key in -0.50 for the Constraint 2 Value.

73. <D> Apply then <D> Next> to constrain the LT_FG point.

This point will also have a temporary vertical constraint to position the point then it will be 
changed to a Project to Surface constraint.

74. Set the Constraint 1 Type to Horizontal.
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75. Set the Constraint 2 Type to Vertical.

76. Set the Parent 1 for  Constraint 1 to  LT_Wall_Outside-Bottom.

77. Set the Parent 1 for  Constraint 2 to LT_Ditch-Bottom.

78. Key in 0.00 for the Constraint 1 Value.

79. Key in 0.00 for the Constraint 2 Value.

80. <D> Apply

81. Set the Constraint 2 Type to Project to Surface.

82. Set the Parent 1 for Constraint 2 to Up.

83. Select 12345_Drain for the Constraint 2 Value.

84. <D> Apply then <D> Next> to constrain the LT_Wall_Outside-Top point.

85. Set the Constraint 1 Type to Horizontal.

86. Set the Constraint 2 Type to Vertical.

87. Set the Parent 1 for  both constraints to  LT_FG.

88. Key in 0.00 for the Constraint 1 Value.

89. Key in 0.50 for the Constraint 2 Value.

90. <D> Apply then <D> Next> to constrain the LT_Wall_Inside-Top point.

91. Set the Constraint 1 Type to Horizontal.

92. Set the Constraint 2 Type to Vertical.

93. Set the Parent 1 for  Constraint 1 to  LT_Ditch-Bottom.

94. Set the Parent 1 for  Constraint 2 to LT_Wall_Outside-Top.

95. Key in 0.00 for the Constraint 1 Value.

96. Key in -0.04 for the Constraint 2 Value.

97. <D> Apply then <D> Next> to constrain the LT_Ditch-Bottom point.

98. In the Point Properties dialog box, set the Constraint 1 Type to Horizontal.

99. Set the Constraint 2 Type to Vertical.

100.Set the Parent 1 for both constraints to Conc_Centerline-Top.

101.Key in -2.00 for the Constraint 1 Value.

102.Key in 0.00 for the Constraint 2 Value.

103.<D> Apply.
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This completes the point editing for the channel liner component.  To complete the component 
properties are edited.  The component property to exclude the channel liner from triangulation 
will be turned on.  This will allow the design surface to triangulate properly so that it represents 
the actual area of excavation on this project.

104.<D><D> on the line that makes up the channel liner.  This displays the Component 
Properties dialog box for the channel liner.

105.In the Component Properties dialog box, toggle on Exclude from triangulation.

106.<D> Apply then <D> Close.

The channel liner points and component is still included in the dtm created later.  They can still 
be included in the cross section display and have volume data calculated.  However, the 
channel liner component will not affect the earthwork volume calculations.

107. Select File > Save from the Create Template menu bar.

Section Summary:
♦ Copying the standard template library is necessary because the standard template 

library is overwritten at login if it has been changed.
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♦ Templates store the information used to create design dtms.

♦ A dtm can contain triangulated and untriangulated data.

♦ Point constraints locate points in relation to other points.

♦ The Project to Surface constraint is used to make the point follow the “target” surface.

Lab 4.2 - Create the Excavation Components

The Excavation components comprise the triangulated part of the template which will be used to compute 
earthwork volumes in a later lab.  Two end condition components are used, the left one has a 2 to1 slope, the 
right one has a 0.5 to 1 slope.

Section Objectives:

♦ Build the two end condition components.

♦ Move a component to a new location.

♦ Test the template.

The first end condition component to be added is the right side end condition.  It begins at the 
center bottom of the channel liner, runs to the RT_Wall_Outside-Bottom point, then up at a 0.5 
to 1 slope to intercept the existing ground surface (12345_Drain).

1. <R> in the Template View of the Create Template dialog box and select Add New Com-
ponent > End Condition from the right click menu.

2. In the Current Component area, Key in 0.5_to_1-Cut in the Name field.

3. Set the Style to D_Top-of-Cut.

4. Verify that the Target Type is set to Surface and set the Surface to 12345_Drain.

5. In the Dynamic Settings dialog box Point Name field, select Conc_Centerline-Top.  
Then edit the name to read Conc_Centerline-Bottom.
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6. Set the key in type to XY= and key in 0,-0.5 in the key in field.  Then press the Enter key.  
This places the first point at the center bottom of the ditch liner.

The next point is placed on top of the RT_Wall_Outside-Bottom point.  The new point is 
merged with the existing point retaining the existing point’s properties.

7. In the Dynamic Settings dialog box, toggle off  Check for Interception.

8. Move the cursor into the Template View and place it over the RT_Wall_Outside-Bottom 
point.  

9. When the point symbol turns white, <D> to place the new point.

10. In the Dynamic Settings dialog box, toggle on Check fo Interception.

11. Toggle on End Condition is Infinite.

12. In the Point Name field, select Top-of-Cut from the drop down menu.
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13. Set the key in type to HS= (horizontal distance and slope)and key in 1,1:0.5 in the key in  
field.  Then press the Enter key.

14. <R> in the Template view and select Finish from the right click menu.

15. This completes the right end condition.

The left side end condition is added similarly to the right side.  However, it cannot be placed 
directly on top of the existing points.  If it were placed on to the existing points, the software 
would interpret them as part of a single end condition and the template would not function 
properly.

Therefore, the left end condition will be built in an open area then moved to its proper location.

16. <R> in the Template View of the Create Template dialog box and select Add New 
Component > End Condition from the right click menu.

17. In the Current Component area, Key in 2_to_1-Cut in the Name field.

18. Set the Style to D_Top-of-Cut.

19. Verify that the Target Type is set to Surface and set the Surface to 12345_Drain.

20. In the Dynamic Settings dialog box Point Name field, select Conc_Centerline-Top.  
Then edit the name to read Conc_Centerline-Bottom.

21. Move the cursor into an open area of the Template View, to the left of the origin, and <D> 
to place the new point.

22. In the Dynamic Settings dialog box, toggle off  Check for Interception and End 
Condition is Infinite.
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23. Key in Wall_Outside-Bottom for the Point Name.

24. Select D_Conc-Pvmt for the Point Style.

25. Verify that the key in type is set to HS= and key in -2.34,0 in the key in  field.  Then press 
the Enter key.  This creates the bottom under the channel liner.

26. In the Dynamic Settings dialog box, toggle on Check for Interception.

27. Toggle on End Condition is Infinite.

28. In the Point Name field, select Top-of-Cut from the drop down menu.

29. Key in -1,-1:2 in the key in  field.  Then press the Enter key.

30. <R> in the Template view and select Finish from the right click menu.

This completes the left end condition.  Now it is moved to its proper location.
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31. <R> on the LT_Conc_Centerline-Bottom point and select Move Point from the right 
click menu.

32. Move the cursor (and the component) on to the Conc_Centerline-Bottom point and <D> to 
move the left end condition to its proper location.

This completes this portion of the template.  The illustration below shows the template at this 
stage.

  

The template can now be tested to see how it will perform in a corridor.

33. <D> the Test button under the right corner of the Template View.  This displays the Test 
End Conditions dialog box.  
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34.  <D> the Draw button. 

35.  Move the cursor up and down in the view area.  Notice that the walls of the liner and the 
cut slopes extend up to meet the ground line so long as it is above the inside bottom of the 
liner.

36.  <D> Close to dismiss the Test End Conditions dialog box.

37.  Select File > Save from the Create Template menu bar.

Section Summary:
♦ End conditions are special components that do not use a constraint to intercept a 

surface.

♦ End conditions that share a common starting point are considered a single component 
and only one of the lines will be used.

♦ To create two end conditions that start at the same point, the second component must 
be created in a different location then moved to the correct spot.

♦ Test templates with end conditions to be sure they behave as expected prior to using 
them in a corridor.
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Lab 4.3 - Adding Backfill Components

The final components for the template are the backfill components.  These are used to calculate the the volume 
of embankment material used to fill in the trench excavation behind the channel liner.  These components will 
not be used to create the triangulated surface, but can still be displayed in cross sections and have volumes 
calculated for them.

Section Objectives:

♦ Add Backfill components

1. <R> in the Template View of the Create Template dialog box and select Add New Com-
ponent > Unconstrained from the right click menu.

2. In the Current Component area, key in Backfill for the Name.

3. Select D_SHOULDER-Embankment for the Style.

4. <D> on the RT_Wall_Outside-Bottom point.

5. In the Dynamic Settings dialog box, select Top-of-Cut for the Point Name.

6. <D> in an open area near the RT_Top-of-Cut point.

7. In the Dynamic Settings dialog box, key in Wall_Outside-Top.

8. Set the Point Style to D_CONC_Pvmt.

9. <D> in an open area near the RT_Wall_Outside-Top point.

10. <R> and select Finish from the right click menu.
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11. <R> on the RT_Top-of-Cut1 point and select Add Constraint > Full Constraint from 
the right click menu.

12. <D> on the RT_Top-of-Cut point to identify it as the parent.

13. In the Add Full Constraint dialog box, key in 0.00 for the values of both the Horizontal 
Offset and Vertical Offset.

14. <D> OK.

15. Repeat steps 11 through 14 for the RT_Wall_Outside-Top1 point, using 
RT_Wall_Outside-Top as the parent.

Placing the backfill points directly on top of the existing points would cause the line between 
RT_Wall_Outside-Top and RT_Top-of-Cut to match the existing ground instead of creating a 
single segment between the two points.

The steps to create the left side backfill are the same as those above.

16. Repeat steps 1 through 15 for the left side, using the corresponding points from the left of 
the existing template.

The final step to complete the template is to exclude the backfill components from 
triangulation.

17. <D><D> on the RT_Backfill component line.  This displays the Component Properties 
dialog box.

18. Toggle on Exclude from triangulation.
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19. <D>Apply then <D> Close.

20. Repeat steps 11 through 13 for the LT_Backfill component.

21. Select File > Save from the Create Template menu bar.

22. <D> Close on the Create Template dialog dox to dismiss the window.

This completes the template.  It is now ready to use to create a design surface model (dtm).

Section Summary:
♦ Points added on top of other points do not have to be defined in the dynamic Settings 

dialog box.

♦ Points added on top of other points are merged with the existing points and take on the 
properties already defined.

Lab 4.4 - Creating the Corridor for the Channel

With the completed template and the horizontal and vertical alignments from a previous lab, a corridor can be 
defined that is used to create the design surface model. A corridor contains two basic parts: a path over the 
existing terrain, and a typical section of the design.  In this example, a horizontal and vertical alignment define 
the path of the corridor and the template built above defines the typical section.

Section Objectives:

♦ Create a corridor base on a horizontal and vertical alignment.

♦ Add a template drop to the corridor.

♦ Review the corridor in Roadway Designer.

♦ Create a design surface from the corridor.

The first step in creating a design surface is to create the corridor.
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1. Select Modeler > Roadway Designer from the InRoads menu bar.  This displays the 
Roadway Designer dialog box.

2. From the Roadway Designer menu bar, select Corridor > Corridor Management or 

select the corridor management button   from the button bar.

3. In the Manage Corridors dislog box, key in 12345BRDG_Channel for the Name.

4. Verify that the Type is set to Alignment.

5. Verify that Channel _Flowline is set for the Horizontal Alignment.

6. <D> Add the <D> Close to dismiss the Manage Corridors dialog box.
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Next, the template drop is added to the corridor.

7. Select Corridor > Template Drops from the Roadway Designer menu bar of <D> the 

Template Drops  button from the button bar.

8. In the Template Drops dialog box, key in 5.00 for the Interval.

9. Expand the folder in the Library Templates area to show the contents of the 1- 
Templates folder.

10. Highlight the 12345_Channel-Liner template then <D> Add.

11. <D> Close to dismiss the Template Drops dialog box.

Notice that the template is now displayed in the template view of the Roadway Designer dialog 
box.  The design can now be reviewed in Roadway Designer.
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12. Use the station indicator arrows to move back and forth through the design corridor.  The 
sideslopes should tie to the existing ground and the design channel flowline should be at or 
very near the existing flowline athe the beginning and end of the corridor.

13. Select Tool > Options from the Roadway Designer menu bar.  The Roadway Designer 
Options dialog box is used to turn on or off various design data displays.

14. Toggle on Cut and Fill Values and Net Volume.

15. <D> OK.
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16. Scroll through the corridor again.  Notice the cut and fill volume data displayed at the 
bottom of the template view.

Finally, a surface (dtm) is created from the corridor.  With a design surface, annotated cross 
sections can be created for plan sets and various volume reports can be generated.

17. Select Corridor > Create Surface from the Roadway Designer menu bar of <D> the 

create surface  button from the button bar.

18. In the Create Surface dialog box, key in 12345_Channel-New for the Name.

19. Select Proposed for the Default Preference.

20. Toggle on Empty Design Surface, Add Exterior Boundary, and Triangulate.

21. Select Exterior Boundary for the boundary’s Style.
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22. <D> Apply.  This creates the design surface.

23. <D> Close to dismiss the Create Surface dialog bix.

24. Select File > Save from the Roadway Designer menu bar.

25. In the Save As dialog box, navigate to the C:\Projects\12345\Bridge\InRoads\ 
directory.
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26. Key in 12345_Channel for the File name.

27. <D> Close on the Roadway Designer dialog dox to dismiss the window.

28. In the InRoads Explorer, <D> the Surfaces tab at the bottom.

29. <R> on the 12345_Channel-New surface and select Save from the menu.

30. In the Save As dialog box, navigate to the C:\Projects\12345\Bridge\InRoads\ 
directory.

31. Use the Active drop down menu and select 12345_Channel-New.  This places the 
surface’s name in the File name field.



Colorado Department of Transportation   Page 117

Bridge Essentials Using InRoads XM LAB 4 - Templates and Corridors

32. <D> Save then <D> Cancel to dismiss the dialog box.

The design surface is now ready for use generating cross sections, volumes, and reports.  

Section Summary:
♦ Corridors are most commonly created along horizontal and vertical alignments.

♦ The origin of the template follows the corridor path ( horizontal and vertical alignment 
or surface feature).

♦ Template Drops define which template is used and how often it is applied.

♦ Once the corridor and templated drops are defined, the design can be reviewed and 
edited in the Roadway Designer dialog box.

♦ A design surface (dtm), based on the corridor and templated drops, can be created from 
Roadway Designer.

Chapter Summary:

 Templates and corridors are used to create a design surface (dtm) of roughly parallel 
features.

 Templates define the “typical section” of the design surface.

 Templates are defined by points.  Points are located using offsets from other points known 
as constraints.

 Acomponent is a series of related points that define the area of a specific material.

 Components are included in the design dtm, but do not have to make up the triangulated 
model.

 Corridors define the path, in relation to the existing ground, that the template will follow.

 The design model can be reviewed and edited in the Roadway Designer dialog box prior to 
creating a dtm.
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