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LAB 8 - Evaluating Bridge Design Surfaces

In this lab you will evaluate the excavation and backfill surfaces you created in the previous lab by computing 
cut and fill volumes. InRoads provides different methods for computing volumes. In this lab, you will work 
with three different methods.

Chapter Objectives:

 Learn how to compute Triangle volumes.

 Learn how to set default XSL style sheets to format InRoads reports.

 Learn how to compute Grid volumes as a check for the triangle volumes.

 Learn how the grid interval affects grid volume results.

 Learn how to compute End Area Volumes from cross section graphics.

The following files are used in this lab:

 C:\Projects\12345\Bridge\Working \CU12345BRDG_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345 SH119

 C:\Projects\12345\Design\InRoads\12345 SH119 SH52 Interchange.alg

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for interchange

Note: The following files were created in the previous lab “Feature Based Modeling.” If 
these files don’t exist in the location identified below then they can also be copied from 
the directory C:\Projects\12345\Miscellaneous\BRDG-08

 C:\Projects\12345\Bridge\InRoads\12345 backfill for pier footer

 C:\Projects\12345\Bridge\InRoads\ 12345 excavation for pier footer

Lab 8.1 - Open Data Files

1. Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

2. Verify the correct XIN file is loaded.

3. Select File > Open from the InRoads menu.

4. Open C:\Projects\12345\Design\InRoads\12345 SH119, 12345 backfill for pier footer, 
12345 excavation for pier footer, and 12345 SH119 SH52 interchange.alg. 

5. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.
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Lab 8.2 - Compute the Pier Excavation Volume

The triangle is the most accurate method of computing volumes in InRoads. It compares 
existing and design surfaces to compute cut, fill and net volume between the surfaces. Since 
you have created an excavation surface for the pier footer, you can use the triangle method to 
compare this surface to the existing ground surface and compute the amount of cut needed for 
the excavation of the footer. 

The grid method provides a quick check against other volume methods to ensure volume 
accuracy. The smaller you set the grid interval, the more accurate the volume results. You’ll use 
the grid method to check your triangle volume.

1. Delete any MicroStation graphics currently in the design file.

2. Select Evaluation > Volumes > Triangle Volume.

3. Set Mode to Entire Surface.

Note: You have the option to compute volumes on a portion of the surface using a 
MicroStation fence or shape. Areas outside of the smaller of the two surfaces are 
ignored.

4. Set Original Surface to 12345 existing ground for interchange.

5. Set Design Surface to 12345 excavation for pier footer.

Note: Cut and Fill Factors are swell and shrinkage factors that you can apply to the volumes 
depending on the classification of material.

6. <D> Add.

7. <D> Apply.
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8. If you receive a warning message that a default style sheet has not been selected for the 
Triangle Volume report, select OK after receiving this message. You will set a default style 
sheet in this lab.

Note: The Bentley InRoads Report Browser automatically starts, allowing you to select 
a style sheet (i.e. a report template) to format the report. All available report style 
sheets are organized in folders and listed on the left-hand side of the report 
browser. The right-hand side shows the report XML data.

9. In the Report Browser, select the Evaluation folder.
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10. Select the TriangleVolumes.xsl style sheet.

Note: The XML data is formatted using this report style sheet.

11. In the Report Browser window, select Tools > Format Options.

12. In the Format Options dialog box, set Cubic Units to 0.12 precision.

13. <D> Close.
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Note: The report automatically updates with the new formatting.

14. Record your results:

Cut:  __________________ cu yd.

Note: Any fill that is listed should be negligible.

15. Right-click on the TriangleVolumes.xsl style sheet and select Set Default Triangle 
Volume.

Note: The next time you run the Triangle Volume command, InRoads will automatically 
use this style sheet without you having to select it. You can always select another 
style sheet from the Report Browser to change the report formatting at any time.

16. Close the Triangle Volume Report by select the X in the upper right corner of the Report 
Browser.

17. In the Triangle Volume command, <D> Close.

Next, you will check your triangle volumes by computing grid volumes.

18. Select Evaluation > Volumes > Grid Volume.

19. Set Original Surface to 12345 existing ground for interchange.

20. Set Design Surface to 12345 excavation for pier footer.
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21. For Grid Interval Key in 2.0.

22. <D> Apply.

Note: For this command, the volume results appear in the dialog box instead of a report.

23. Record your results in the table below.

24. For Grid Interval Key in 1.0.

25. <D> Apply.

26. Record your results in the table below.

27. For Grid Interval Key in 0.5.

28. <D> Apply.

29. Record your results in the table below.

Note: As you decrease the size of the grid interval, your grid volume should approach the 
triangle volume results with increased accuracy. If your 0.5 grid interval volume 
does not compare favorably to your triangle volume, see your instructor.

30. <D> Close on the Grid Volume dialog box.

Lab 8.3 - Compute the Pier Backfill Volume

In this section, you will use the same volume commands to compute your backfill quantities.

1. Select Evaluation > Volumes > Triangle Volume.

2. Set Mode to Entire Surface.

3. Set Original Surface to 12345 backfill for pier footer.

4. Set Design Surface to 12345 SH119.

Interval = 2.0 Interval = 1.0 Interval = 0.5

Cut Volume cu yd. cu yd. cu yd.
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Note: The backfill surface is set as the original surface in order for the results to display 
as a “fill” volume.

5. <D> Add.

6. <D> Apply.

Note: Since you previously selected a default style sheet for this command, you do not 
get the warning message and the report is automatically generated using the 
TriangleVolumes.xsl style sheet.

7. Record your results:

Fill:  __________________ cu yd.

8. Close the Triangle Volume Report by select the X in the upper right corner of the Report 
Browser.

9. In the Triangle Volume dialog box, <D> Close.

Next, you will check your triangle volumes by computing grid volumes.
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10. Select Evaluation > Volumes > Grid Volume.

11. Set Original Surface to 12345 backfill for pier footer.

12. Set Design Surface to 12345 SH119.

13. For Grid Interval key in 0.25.

Note: An acceptable grid interval depends on the size of your surfaces, the variation and 
relief in your surfaces, whether or not your surfaces were surveyed, how they were 
surveyed, etc. You may need to try a few grid intervals based on these variables 
before converging on a good net number. For our two surfaces, an interval of 0.25 
should provide accurate results.

14. <D> Apply.

15. Record your results:

Fill:  __________________ cu yd.

Note: Your grid volume results should compare favorably to your triangle volume 
results. If not, see your instructor.

Lab 8.4 - Compute End Area Volumes

You may also want to use the End Area Volumes command as another check of your triangle 
volumes or if your contractor requires end area volumes for his work. The End Area method 
requires that you have a set of cross sections cut showing the surfaces from which you want to 
compute volumes. The volumes are calculated from the cross section graphics instead of 
comparing DTM data, as with the Triangle and Grid methods. 

In this section you will compute the end area volume for your pier footer backfill. In order to do 
so, you must first cut a set of cross sections along the pier. You can either cut cross sections on 
a graphic or an alignment, so you will copy the pier centerline element from the reference file 
into the active bridge model file.
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1. If your reference file is not turned on, select File > Reference and toggle on the display 
of the 12345BRDG_Model_D-16-DU file.

2. Window in on the pier centerline.
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3. Select MicroStation’s Copy command.

4. Snap to the end of the line to identify it to copy.
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5. Snap to the same end to copy it to the active file in the exact same location.

6. Turn off the display of the reference file.

Note: Only the pier centerline element is now shown in the view.

7. Before cutting cross sections, set the text scale factor to be used for the cross section text. 
Select Tools > Options.

8. Select the Factors tab.

9. Unlock the three factors and for Text Scale Factor key in 40.
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10. <D> Apply, then <D> Close.

11. Select Evaluation > Cross Section > Create Cross Section.

12. Select Preferences and select the Stacked 20 per column preference.

13. <D> Load, then <D> Close.

14. On the General branch, toggle off the 12345 excavation for pier footer and Default 
surfaces. Make sure all other surfaces are toggled on.

15. For Set Name, key in Pier.

16. For Interval, key in 10.
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17. On the Source branch, toggle on Graphics and in the Alignment field, key in Pier 
centerline.

Note: The End Area Volume command requires an alignment in order to compute 
volumes. Specifying a name here will automatically create an alignment along the 
pier centerline element.

18. <D> Apply.

19. <D> the pier centerline.

20. <D> to Accept.

21. <D> in a clear area for the lower left corner of the cross section set.
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22. Window in on one of the cross sections to see the three surfaces.

       

Note: Since you added the pier features to the backfill surface in the last lab, the pier and 
footer will be excluded from the backfill quantities, but the area of the pier that 
falls above the SH119 surface will be shown as cut and should be ignored.
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23. Select the InRoads Explorer Geometry tab and note that you now have an active Pier 
centerline alignment created by the Cross Section command.

You’re now ready to compute the end area volumes from the cross section graphics and new 
pier centerline alignment.

24. Select Evaluation > Volumes > End Area Volumes.

25. On the General branch, toggle off the 12345 existing ground for interchange surface and 
make sure the 12345 SH119 and 12345 backfill for pier footer surfaces are toggled on.

26. Set Cross Section Set to Pier.

27. Set Imperial Units to Cubic Yards.

28. Toggle on Create XML Report.

29. <D> Apply.

30. If you receive the Report Browser warning message, select OK since the End Area 
Volume command does not yet have a default style sheet set.
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31. In the Report Browser, select the EndAreaVolume.xsl style sheet under the Evaluation 
folder to format the report.

Note: If your report lists cubic feet, select Tools > Format options and toggle on 
Convert to Cubic Yards.

32. Read your fill volume from the Grand Total line of the report and record your results:

Fill:  __________________ cu yd.

Note: The End Area Volume results should compare favorably to your Triangle Volume 
results for backfill (within a few cubic yards). If not, see your instructor.

33. Close the End Area Volume report (click the X in the upper right corner).

34. <D> Close on the End Area Volume dialog box.

Chapter Summary:

 Triangle volumes provide accurate cut and fill quantities.

 The Triangle Volumes command compares surfaces to compute volumes.

 The Grid method is useful to check triangle volumes.

 The accuracy of the Grid Volumes is controlled by the grid interval.

 Many factors affect the selection of an appropriate grid interval. Select an interval that 
converges on a net number favorable to the triangle results. 

 The smaller the grid interval, the more accurate the grid volumes.

 End Area Volumes are computed from cross section graphics instead of comparing DTMs.

 The End Area Volume results should compare favorably to the Triangle volume results.
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