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Document Conventions

There are several conventions that are used throughout this document to indicate actions to be taken or to 
highlight important information. The conventions are as follows:

Item
 

Meaning

View Perimeter a command name or a file that you are to select

Tools > Options a command path that you are to select – usually from the pull-down 
menus

Document Name the name of a document that is not hyper linked

Emphasis style used when referring to important word or phrases

Hyperlink style used when you have a direct link to another document on the web

Key in entering data with the keyboard

Quote style used to indicate an external source quotation

Note: text information about a command or process that you should pay 
particular attention to

1. Numbered Steps actions that you are to perform as part of the lab activities

<D> or Data press the data button on the mouse

<R> or Reset press the reset button on the mouse

<T> or Tentative press the tentative button on the mouse
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LAB 1 - Getting Started in InRoads for Bridge 

Chapter Objectives:

 Setup a project with the correct resources including the creation and maintenance of an 
InRoads project file

 Identify and load the correct resources and files needed for bridge design

 Develop an understanding of what InRoads tools to use as they relate to real world design 
processes

Note: The *.zip file of the data set for these labs can be downloaded from the website 
Labs_for_Bridge_Essentials.  The zip file should be extracted to the C:\Projects\ 
directory.  If the labs will not be worked through sequentially,  the data for each lab is 
also found in the Miscellaneous directory of the data set.  To use the files from 
theMiscellaneous directory, copy the files in each specific lab folder following the 
instructions found in the *.doc file.

Lab 1.1 - Purpose of Bridge Essentials Labs

The Bridge Essential labs have been developed to demonstrate how InRoads tools can be used 
to facilitate the design and detailing processes of bridges and structures. These labs are 
intended as a supplement to the reference material and labs developed for the standard 
MicroStation and InRoads courses. 

The labs are based on students having a basic understanding of MicroStation. A basic 
understanding of InRoads is preferable, but not required. Some of the basic InRoads concepts 
are covered in these labs only to explain more specific details as they relate to the Bridge 
workflow. However, for concepts that are not specific to the Bridge workflow, refer to the 
reference material for MicroStation and InRoads to gain a fundamental understanding of the 
CDOT engineering software environment.

For those with little or no experience with InRoads, use the links below to access standard 
MicroStation and InRoads reference material related to this lab.

From A Practical Guide for Using MicroStation XM 

♦ Chapter 1 - Introduction to CDOT - This chapter documents helpful CADD resources 
available to the student and links to those resources.

♦ Chapter 2 - Getting Started in MicroStation- This chapter documents the basics of the 
MicroStation interface including mouse mechanics, the MicroStation Manager 
window, and description of the toolbars.

♦ Another important chapter for the student to understand is Chapter 3 - Levels. Use this 
link if you are not familiar with how levels are organized and how to use them.

http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/Labs for Bridge Essentials/Labs_for_Bridge_Essentials.htm
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter01_Introduction to CDOT.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter02_Getting_Started_in_MicroStation.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter03_Levels.pdf
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From A Practical Guide for Using InRoads XM 

♦ Chapter 1 - Getting Started in InRoads describes where to find and store files used in 
InRoads, how to setup a project directory, and best practices for setting up InRoads to 
automatically use the correct InRoads files and point to the correct InRoads folders.

♦ Chapter 2 - InRoads Options provides instruction on what Locks are and how to use 
them in addition to setting up the display precision for reports and setting the scale 
factors for how InRoads displays text, cells, and line styles.

1. Use the following link to see what other training material, including reference material and 
labs, is available for your use: Manuals, Training Materials, and Resources.

Lab 1.2 - Review of the Project Directory Structure

Project Setup
Setting up a project directory is generally performed by the Project Manager. However, a 
standard project directory structure can also be used to store data that is not part of a formal 
project. Benefits of setting up a standard project directory in these cases include:

 Ensures that predictable MicroStation and InRoads resources are being used to develop the 
data

 Facilitates the transfer of data to/from other project participants, entities, or storage areas

 Reduces need for support and associated downtime

The standard project directory structure is suitable for small and large projects, projects in a 
network environment or stand alone projects, and even projects in the ProjectWise 
environment. By using this standard directory structure, Bridge users will be able to find the 
data they need from other specialty groups and in return specialty groups will be able to find 
the data supplied by bridge.

The next few steps will illustrate how to create a project directory for a stand alone project.

Note: Because a stand alone project does not have a project code use a project code of 
00001 as the project number.

1. Follow the steps outlined in the section “Creating the Project Directory” found in Chapter 
1 - Getting Started in InRoads of A Practical Guide for Using InRoads XM to create the 
project folder.

http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_InRoads_XM/InRoads_Reference-Chapter01_Getting Started in InRoads.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_InRoads_XM/InRoads_Reference-Chapter02_InRoads Options.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/CADD Manuals and Training Index.htm
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter02_Getting_Started_in_MicroStation.pdf
http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_MicroStation_XM/MicroStation_Reference-Chapter02_Getting_Started_in_MicroStation.pdf
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2. Open Windows Explorer and navigate to the new 00001 project folder.

3. Expand the Bridge folder.

The folders highlighted in the image above are the folders that will be most often used during 
this course and the normal design process. 

In addition to these folders, files in the ROW_Survey\InRoads and Design\InRoads folders 
will be used as a basis for bridge and structure design.

 The topographic survey file will be found in the ROW_Survey\InRoads folder.

 The proposed roadway alignment and surfaces will be found in the Design\InRoads folder.

Lab 1.3 - InRoads Terminology

The following steps will show how the user how to use the Help system that comes with the 
product to find definitions to unfamiliar terminology.
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1. Launch InRoads Help by going to Help > Contents in the InRoads application window.

2. On the Contents tab, click on Supplemental Information > Glossary.

3. Look up the following terms in the Glossary:

a. Original Surface and Design Surface

b. Digital Terrain Model

c. Perimeter

d. Geometry Project

e. Alignment

f. Corridor

g. Project and RWK

Lab 1.4 - Understanding How Project Design Data is Stored

This section will help you understand how the different design features, such as surfaces, 
alignments, and typical sections, relate to InRoads file types. Managing InRoads data will be a 
lot easier if you have a good understanding of this relationship. The following table shows how 
InRoads file types relate to design elements.

Additional information on how these file types in the section “InRoads XM Resource 
Locations” found in Chapter 1 - Getting Started in InRoads of A Practical Guide for Using 
InRoads XM. 

The next few steps illustrate a practical application of how to manage InRoads data in the 
project directory structure. There are several files located in the \Miscellaneous directory of 
project 12345 that need to be moved to the project 00001. 

Design Element
InRoads 

File

Surfaces - Topographic (existing) or proposed design *

Alignments *.alg

Typical sections (templates) *.itl

Modeling (corridors) *.ird

Control how graphics look (preferences) *.xin

InRoads project *.rwk

http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Manuals and Training/A_Practical_Guide_for_Using_InRoads_XM/InRoads_Reference-Chapter01_Getting Started in InRoads.pdf
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4. Open Window Explorer and navigate to the directory \12345\Miscellaneous.

5. Move all the files that begin with 00001 to the correct folders in the \00001 project 
directory.

Note: Each discipline has a standard acronym. Use this acronym to determine the folder 
the file should be placed in (e.g. BRDG is the acronym used for the bridge group).

Note: The contents of these files are irrelevant. Only the filenames are important in this 
exercise.

6. Identify the one file that should not be used from the project directory structure because it 
is not a standard file.

Note: Notice that there is only one geometry (*.alg) file for bridge. A good practice is to 
store all alignments in one geometry file. There are only a few situations that 
would require using more than one geometry file.

Using Project Defaults
InRoads Project Defaults are a way to improve the process of loading and saving InRoads files 
by setting a default path to the project folder where the resource should be located. This is 
accomplish by using another file type with the extension *.reg.   

1. Launch MicroStation and set the Project Workspace to 00001. 
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Note: You will need to revisit the MicroStation Manager window to set the project 
workspace to 12345 for subsequent labs.

2. Open the file 00001BRDG_Model.dgn from the directory 
C:\Projects\00001\Bridge\Drawings\Reference_Files.

3. Launch InRoads by clicking on the  icon.

4. Follow the steps in the workflow CDOT InRoads XM Project Defaults Management to 
import the standard CDOT project defaults and set the Configuration Name to CDOT 
Bridge Discipline.

5. Click Apply and then Close the Project Defaults dialog box.

http://www.dot.state.co.us/DesignSupport/CADD and Engineering Innovation/Workflows/V8 XM/CDOT InRoads XM Project Defaults Management.pdf
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6. From the InRoads interface, select File > Open. Notice how InRoads now defaults to the 
Bridge folder of the project.

There are two keys to getting project defaults to work correctly:

 Load the correct pcf file by choosing the correct project workspace in the MicroStation 
Manager window

 Set the project default configuration name to CDOT Bridge Discipline

Lab 1.5 - Requesting InRoads Design Data

Before starting a Bridge project, you will need to load InRoads data files that have been created 
by other groups. The following is a list of these InRoads data files. Request the files from the 
appropriate contact person in each group.

The files should be copied into the Bridge\InRoads folder. The responsible group should 
update the Bridge group if any changes are made to these files, including:

 Additional/new survey data

 Revised alignments (horizontal and vertical)

 Revised typical sections

 Additional work at approach to structures

Lab 1.6 - Using the Bridge Toolbar to follow a Workflow

Design Element
InRoads 

File
Responsible 

Group

Existing surface * Survey

Proposed (design) surface * Roadway Design

Proposed (design) alignments *.alg Roadway Design

Roadway Typical Sections (if needed) *.itl Roadway Design
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Not all InRoads tools are relevant to Bridge design and detailing processes. In addition, some 
tools are used more often than others. The purpose of the Bridge toolbar is to organize the most 
commonly used InRoads tools in a concise, sequential order and make them easily accessible.

The toolbar is not intended to be complete at this time but has been created to introduce bridge 
designers to the toolbar concept. With input from the bridge group, it is expected that the 
toolbar will change over time according to the needs of the group.

The toolbar needs to be loaded manually. Once loaded, the toolbar resides in the registry of the 
computer and only needs to be loaded again if it changes. 

1. Load the Bridge Design toolbar by selecting Tools > Customize. The Customize dialog 
box will appear.

2. Click n the Import tab and choose Browse.

3. Select the CDOT Bridge.tbr file from the C:\Workspace\Workspace-
CDOT_XM\Standards-Global\InRoads\Interface directory.
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4. Click on Import.

5. Click on the Toolbars tab

6. Check on CDOT Bridge in the Toolbars: area. The CDOT Bridge toolbar will appear on 
the screen

7. Close the Customize dialog box.
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8. Click on the title bar of the CDOT Bridge menu to make it active.

9. Hover over the Project Defaults icon. A tool tip appears to indicate what tool the icon 
represents.

10. An explanation of what the tool does also appears in the lower left of the InRoads 
application window.

For now, the toolbar is divided into the following sections:

a. Project Defaults - Used to set the default paths to InRoads files

b. View Surface - Used to evaluate a surface including displaying the contours or surface 
features

c. Review Horizontal Alignments - Used to display and annotate horizontal alignments 
and generate alignment reports

d. Profiles and Vertical Alignments - Used to generate and annotate profiles

e. Cross Sections - Used to generate and annotate cross sections
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The Project Defaults tool was explained in this lab. The other tools on this toolbar will be 
explained in the next lab.

11. Now that you understand how to create a project and manage the data within a project 
directory structure, Delete the project 00001.

Chapter Summary:

 Using the standard project directory structure will make it easier to manage project data 
and facilitate the correct usage of InRoads resources.

 Using Project Defaults will make it easier to save and retrieve InRoads files to/from the 
correct project folders.

 Using the Bridge Toolbar will reduce the amount of time looking for the correct InRoads 
tool. In addition, the toolbar is workflow based, allowing the user to quickly find the 
correct tool based on the design stage being worked on.
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LAB 2 - Reviewing Roadway Design Data

Chapter Objectives:

 Develop an understanding of the roadway design data.

 Learn InRoads’ tools that are used to display and evaluate surfaces.

 Learn InRoads’ tools that are used to display and evaluate alignments.

The following files are used in this lab:

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\Bridge\Working\12345BRDG_Model-Drain.dgn

 C:\Projects\12345\Design\InRoads\12345 SH52

 C:\Projects\12345\Design\InRoads\12345 SH119 SH52 interchange.alg

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for interchange

Lab 2.1 - Requesting InRoads Design Data

See Section 1.5 Requesting InRoads Design Data to determine which InRoads data files are 
needed to start your work. The labs assume that you have been provided the appropriate 
InRoads data files from the responsible groups noted in Section 1.5.

Lab 2.2 - Using InRoads Surface and Geometry Tools

This section covers how to use surface and geometry viewing, annotation, tracking, and 
reporting tools to review InRoads data that is provided to the Bridge group by the Roadway 
Design group. A “working” file will be used to view geometry, cross sections, and profiles.

1.  Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

Note: The standard filename for working files includes the user’s initials in front of the 
filename. In this case, “CU” stands for CDOT User.

2. Delete any MicroStation graphics currently in the design file.

3. Verify the correct *.xin file is loaded.

4. Select File > Open from the InRoads menu.

5. Open C:\Projects\12345\Design\InRoads\12345 SH52 and 12345 SH119 SH52 
interchange.alg. 

6. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.
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Review the surfaces

1. Select Surface > View Surface > Contours.

2. Select Preferences.

3. Highlight the Existing 5’ Mjr – 1’ Minor preference.

Note: The Preference controls the interval of the contours, number of minors per major 
contour, labeling, levels the contours are displayed on, etc.

4. <D> Load, then Close.

5. Set the Surface to 12345 existing ground for interchange.

6. <D> Apply.
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7. Review the contours and zoom into the proposed bridge area.

8. Use MicroStation to Delete the contours when done reviewing.

Note: The contours are a graphic group, so make certain graphic group lock is on.

9. Select Preferences from the View > Contours dialog.

10. Highlight the Proposed 5’ Mjr – 1’ Minor preference.
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11. <D> Load.

12. Switch the surface to 12345 SH52.

13. <D> Apply.

14. Close the Preferences dialog.

Note: Loading the preference changes the contour settings so this display uses the 
proposed symbology.

15. Review the contours and window in as shown.
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Note: In this case, the design model does not have sideslopes in the area where the 
proposed bridge will be located.

16. Close the View Contours dialog.

17. Use MicroStation to Delete the contours when done reviewing.

18. Select Surface > Update 3D/Plan Surface Display.

Note: This command is useful since it provides access to most surface viewing 
commands in one dialog, and it allows you do delete the displays without using the 
MicroStation Delete command.

19. Toggle Display On and highlight the existing ground surface.

20. Toggle on Perimeter.

21. <D> Apply.

22. Fit the MicroStation view to see the perimeter of the surface.
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Note: The perimeter of the existing ground is useful to review the limits of the survey.

23. Repeat for the SH52 surface.

Note: You can highlight more than one surface at a time. These were done separately to 
more easily tell which surface is which.

24. Toggle Display Off.
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25. Highlight both surfaces.

26. <D> Apply.

27. Toggle Display On.

28. Toggle on Contours.

29. Toggle off Perimeter.

30. Highlight the existing ground surface.

31. <D> Apply.

32. Review the contour display.
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33. Toggle Display Off.

34. <D> Apply.

Note: You are not given a choice on the preference when using this command for 
displays, but you were able to delete the perimeter and contours without using the 
MicroStation delete command.

35. <D> Close.

Review alignments using Viewing, Tracking and 
Stationing

The following InRoads tools will be used in this lab to review alignments that are created by 
the Roadway Design group.

♦ Geometry > View Geometry > All Horizontals which displays all horizontal 
alignments in the active geometry project with no annotation.

♦ Tools > Tracking > Tracking which displays the Station and Offset for a specific 
point, along with surface data.

♦ Tools > Tracking > Horizontal Alignments which provides a readout of the 
Station, Offset and Curve radius (if applicable) for a specific point, along with 
elevation of the active vertical alignment.

♦ Geometry > View Geometry > Active Horizontal which displays only the 
active horizontal with no annotation.

♦ Geometry > View Geometry > Horizontal Annotation which displays the 
specified alignment or alignments along with annotation of the tangent and curve data.

♦ Geometry > View Geometry > Stationing which displays station for the 
specified horizontal alignment.

1. Select Geometry > View Geometry > All Horizontals.

2. Fit the MicroStation view.
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Note: This geometry file contains horizontal and vertical alignments for SH119 NB and 
SB, SH52, Ramps A-D, and several walls.

3. In the Explorer part of the InRoads menu, <D> on the Geometry tab and <D> on the ‘+’ 
next to the geometry project to expand the list of alignments. 
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Note: You may need to use the arrows to scroll across to see the Geometry tab.

 

4. Right-click on SH52-H and select Set Active if it’s not already.

Note: The active alignment has a red box around its icon.
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5. Select Tools > Tracking > Tracking.

6. <D> Activate.

7. Move your cursor in the vicinity of the wall alignments as shown.

Note: The readout of Station, Offset, etc is shown in the dialog box. Using this command 
gives you a readout of the stationing on the alignment, the perpendicular offset to 
your cursor location the coordinates of your cursor location, and the Elevation 
(along with other data) of the active surface at your cursor location. 
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8. Snap to the end point of the wall alignment as shown.

Note: You may snap using <T> <D> just as you would in MicroStation or if you want to 
use AccuSnap, hold down your <Ctrl> and <Shift> keys on your keyboard. This 
is true whenever you need to use AccuSnap within an InRoads command.

Note: The readouts are written to the design file. The text is written perpendicular to the 
alignment being tracked and is top-left justified on the point where you snapped.

In the next series of steps you’ll attach a reference file containing the SH52 bridge pier and 
abutment graphics and then use these graphics to obtain additional tracking information.

9. Select File > Reference from the MicroStation menu.

10. Select Tools > Attach.
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11. Select C:\Projects\12345\Bridge\Drawings\Reference_Files\12345BRDG_Model_D-16-
DU.dgn.

12. <D> OK to accept the default reference settings.

13. Close the Reference dialog box.

Note: Abutment and Pier centerlines are shown in the file.
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14. Window in on the area shown to see the abutment centerline.

15. Select Tools > Tracking > Tracking.

16. <D> Activate.
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17. Move your cursor in the vicinity of the abutment graphic as shown.

18. Select MicroStation’s Intersection snap mode.
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19. Snap to the intersection of the abutment centerline and the SH52 centerline alignment.
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Note: The readouts are written to the design file. Note that the abutment centerline is 
located at station 108+73.63 on the SH52 alignment. Tracking is a convenient tool 
for obtaining station locations of abutment centerlines or backfaces. 

20. <D> Close to exit the Tracking command.

21. Delete the readout with MicroStation.

22. Turn off the display of the bridge reference file.
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23. Select Tools > Tracking > Horizontal Alignments.

.

Note: The Station, Offset, Elevation and curve Radius is shown in both the InRoads and 
MicroStation message fields. Using this command gives you a readout of the 
stationing on the alignment, the perpendicular offset to your cursor location and the 
elevation of the active vertical alignment associated with the horizontal you’re 
tracking (as opposed to the DTM elevation in the Tracking command).

24. Make Wall D-16-L active.

25. Track the Alignment with Horizontal Alignment Tracking.

26. Toggle Point Snap on.

27. Track the alignment and note that the cursor only tracks from the beginning, ending and 
angle points or PIs of the alignment.
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Note: This can be used to easily check the stationing of the angle points for the wall to 
see if the wall segments are of even lengths.

28. Toggle Point Snap back to No Snap.

Next, you will station an alignment. The Text Scale Factor is applied to all text, ticks and 
offsets created by InRoads and may be changed at any time. 

29. Choose Tools > Options > Factors.

Note the default settings.

30. <D> the lock icon to unlock the three settings so they can be set individually.
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31. Change the Text Scale Factor to 50.

32. <D> Apply.

33. <D> Close.

Note: If you Apply without saving a preference, the change only remains active until 
you exit InRoads.

34. Select Geometry > View Geometry > Stationing.

35. Toggle the Horizontal Alignment to SH52-H.

Note: The Horizontal Alignment defaults to the active alignment. Changing it here also 
changes the active alignment.
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36. Load the preference PROPOSED-100 Ft Interval.

37. <D> Apply.

38. Select Tools > Options > Factors and set the Text Scale Factor to 100. (Don’t forget 
to Apply.)
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39. <D> Apply on the Stationing dialog, then Close.

Note: Since you are in Pencil mode, the second set of stationing replaces the first set.

Note: The display of the stationing on the alignment honors the Text Factor as you can 
see. In general, you use a text factor equal to the scale you plan to plot. When 
reviewing data that you do not plan to plot, as you are here, you may choose a 
different text scale to make the text more legible in the file.

40. Use MicroStation to Delete the Stationing.

Note: The stationing is made up of graphic groups, making it easier to delete.

41. Choose Geometry > View Geometry> Horizontal Annotation.

42. In the Horizontal Alignments Include field, select the SH52-H alignment.

You may either:
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♦ Use the target button next to the Include field and graphically pick the alignment,

  

♦ Type the alignment name in the Include field (wildcards are allowed), or
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♦ <D> in the Include field and choose Filter to pick the alignment from a list and select 
Add and then OK.

   

43. <D> Apply and the alignment is annotated.

44. Window in and review the annotation.
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Note: You may also <D> Interactive and then choose one piece of any alignment at a 
time to annotate (whether or not it is currently active or displayed).

45. Choose Geometry > Review Horizontal.

Note: You can also right-click on the horizontal in the Explorer portion of the menu and 
choose Review.

Note: The Review lists all the information about the active horizontal alignment. This 
report can be saved as a text file, displayed in the design file or printed if necessary. 
You can also switch to a different alignment using the drop-down list at the top of 
the dialog.

Important! The Print command allows the report to be printed to any printer that can 
be accessed on the current machine.

46. <D> Close when you are finished evaluating the alignment.

47. Choose Geometry > Review Vertical.
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Note: You can change Geometry Projects, Horizontal Alignments, or Vertical 
Alignments using the drop-down list at the top of the Review dialog. You can also 
use the target buttons to graphically identify alignments.

Note: The Review lists all the information about the active vertical alignment. In this 
case, the vertical is the top of wall elevation.

48. <D> Close when you are finished evaluating the alignment.

49. Continue to review other alignments as desired.

50. Select Tools > XML Reports > Geometry.

51. Select the SH52-H alignment.

As described earlier, you may either:

♦ Use the target button next to the Include field and graphically pick the alignment,

♦ Type the alignment name in the Include field (wildcards are allowed), or

♦ <D> in the Include field and choose Filter to pick the alignment from a list.

52. Toggle on Include Vertical Alignments.

53. Toggle on Active.
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54. Toggle all other options off.

55. <D> Apply.

Note: When you create a report using one of the XML Report commands, an *.xml data 
file with the results is created in the user’s Local Settings\Temp folder. This XML 
file is formatted in the Report Browser using an XSL style sheet, or format. Most 
reports have a default format, but you can choose between other formats as desired.

56. In the Report Browser that appears, available formats are listed on the left side. Choose the 
format: Geometry > HorizontalAndVerticalAlignmentReview.xsl.

Note: All XML reports use this same browser, so the folder structure at left lists all 
different types of reports. Here, you are looking at an alignment, so you choose a 
report format from the Geometry folder. If you are reporting on Stations and 
Offset, you would use formats from the StationOffsets folder, and so on.
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57. Review the report.

Note: If you right-click a format and choose Style Sheet Help, a dialog will pop up 
describing the data required to complete that particular format.

Important! Just like in the Review command, reports may be printed directly from this 
dialog. Select File > Print to access this function.

58. Choose Tools > Format Options. 

Note: Much of the formatting of the report can be modified on the fly by changing the 
settings in this dialog box.
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59. Change the Northing Easting Precision to show four decimals.

60. <D> Close on the Format Options dialog.

61. Close the Report.
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62. Back in the Geometry Report dialog, <D> in the Include field and key in Wall* to select 
all the Wall alignments.

63. <D> Apply.

In the Report Browser, note the reports now shows each of the wall alignments.

64. Close the Report Browser when you’re done reviewing the report.

Lab 2.3 - Using InRoads Evaluation Tools

Next, you will be creating profiles and cross sections to analyze geometry and surface data 
provided by Roadway Design. This includes annotating information on the profiles and cross 
sections. For this annotation the text scale factor is applied to all the text, ticks and offsets for 
the cross sections as well as profiles. 
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Note: Each time you create profiles or cross sections, you create a new set and it is given 
a name, which by default is derived from the alignment name with a counter on the 
end. Later, you will use this set name when identifying the profile or section set to 
view, annotate, etc.

1. For this example, set the Text Scale Factor to 40.

2. Choose Evaluation > Profile > Create Profile.

3. <D> Preferences and Load the 2x Vertical preference.

4. <D> Close on the Preferences dialog.
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5. In the Surfaces area, toggle on both the existing ground and SH52.

6. <D> on the Source branch on the left of the dialog.

7. Make certain Alignment is toggled on and set to Wall D-16-L. 
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8. <D> on the Include branch.

Note: If you want to display crossing features on your profile like pipes or utilities, 
toggle on Crossing Features. These features must first exist in the surface(s) 
you’re profiling. The feature’s style controls if the feature can be shown on the 
profile.

Note: If you want to show features that fall outside the profile window, toggle on 
Projected Features. This will show the orthogonal projection of the features onto 
the profile. You also have the option of specifying a Bandwidth to either side of the 
profile to project the features.

9. For this exercise, leave these options toggled off.

10. <D> on the Controls branch and toggle off all Controls.
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Note: The Elevation option is used to set absolute values for the left axis. With it off, the 
left axis elevations are determined by the high and low elevations of the surfaces. 
The Station option allows you to create a partial profile. With it off, the entire 
alignment is profiled. The Window Clearance option is used when you want to add 
grid to the top or bottom of the profile for annotation, which we do not need here.

11. <D> Apply and <D> a clear area in your design file when prompted to Identify Location.

Note: This is the location of the lower left corner of the profile grid, so make certain there 
is room above and to the right of the point you select. You do not need to click near 
the horizontal alignment.

The profile is displayed with the two surfaces showing. Offsets can also be shown on the 
profile.

12. Use MicroStation to delete the profile.

13. Under General, highlight the existing ground surface and choose Properties.

14. On the Advanced tab of Surface Properties, set Offset 1 to -1.50 and the Symbology to 
D_Surface1.

Note: A negative offset is to the left of the alignment.
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15. <D> Apply.

16. Toggle the Surface to 12345 SH52 and select Properties.

17. On the Advanced tab, Set Offset 1 to 1.00 and the Symbology to D-Surface3.

18. <D> Apply then Close.

19. Choose Offsets on the Profile dialog.

20. Set the Surface to 12345 SH52 and toggle on Offset 1.
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21. Set the Surface to 12345 existing ground for interchange and toggle on Offset 1.

22. <D> Apply and <D> a clear area in your design file when prompted to Identify Location.

23. Window in close to the ground surface on the profile.

Note: The profile now shows two lines for the existing ground and two lines for the 
proposed. The existing ground is shown at the wall centerline and 1.5’ in front of 
the wall. The proposed ground is shown at the wall centerline and 1.0’ behind the 
wall. You can use profile offsets to set the bottom of wall elevations (e.g. if the toe 
of wall is 1.5 feet in front of the wall face, you can copy that offset line down by 
1.5' (or whatever the vertical exaggeration requires) to get the top of the footing. 
Dropping it 3 feet will provide the minimum bottom of footing).

24. <D> Close on the Profile dialog.



Colorado Department of Transportation   Page 55

Bridge Essentials Using InRoads XM LAB 2 - Reviewing Roadway Design Data

25. Select Geometry > View Geometry > Active Vertical.

You may instead want to display and annotate the vertical alignment.

26. Select Geometry > View Geometry > Vertical Annotation.

27. Load the Other preference.
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28. <D> Apply.

29. Review the annotation on the profile. You may need to change the Text Scale Factor using 
Tools > Options > Factors. If you <D> Apply again, the original annotation is deleted 
and the new annotation is placed.

30. <D> Close when done.

31. Right-click on the SH52-H alignment in the Explorer part of the InRoads menu and choose 
Set Active.

32. Create a profile for this alignment using the same steps as shown above, except only toggle 
on the existing ground surface.

33. View the vertical annotation, using the Proposed preference.
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Note: When more than one profile exist in the MicroStation file, you can tell InRoads 
which one to use for annotation by selecting it from the drop-down list or by using 
the target button and selecting it graphically. 

The vertical alignment for SH52 does not currently show the location of the bridges. This can 
be accomplished using Event Points as shown below.

34. Verify SH52-H is still active.

35. Select Geometry > Horizontal Curve Set > Events.

36. Toggle on Add Vertical Event Points.

Important! Adding event points results in a modification to the *.alg file. In order to 
make this type of edit, you will need write access to the alignment file 
being used in the geometry project. This file is typically located in the 
Design group’s InRoads folder and often has restricted access. If direct 
access is not granted, someone fron the Design group will need to add the 
event points for you. Either way, communication with the Design group is 
critical. 
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37. <D> the Snap icon on the MicroStation Status bar and choose Intersection.

38. <D> the Target button in the Locate By field on the dialog.

39. Hold down your <Ctrl> and <Shift> keys on your keyboard and move your cursor to the 
intersection of the SH52 and Wall D-16-K alignment.

Note: <Ctrl> and <Shift> can be held down any time you want to use AccuSnap within 
an InRoads command. 
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40. When the two alignments highlight with a yellow X at the intersection, <D> to select the 
location.

The coordinates of the intersection are entered in the dialog.

41. <D> Apply to add the event point.



Page 60 Colorado Department of Transportation

LAB 2 - Reviewing Roadway Design Data Bridge Essentials Using InRoads XM

42. Repeat this process for the location of the intersection of SH52 and Wall D-16-L.

43. <D> Close when you have both Event Points located.

44. View the vertical annotation for SH52, again using the Proposed preference.

Note: The last used preference remains active in a dialog until another one is selected or 
you close InRoads, so you should not need to load it this time. 
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The locations of the intersecting alignments are annotated on the profile as Event Points.

Next, you will create cross sections. 

45. For this example, set the Text Scale Factor to 40.

46. Choose Evaluation > Cross Section > Create Cross Section.
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47. Load the Stacked 20 per column preference.

48. Set the Offsets to -200 and 200.

49. Toggle on both surfaces.

50. <D> on the Include branch at left.
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51. Toggle on Components.

52. <D> on Controls > Plan Display.

53. Toggle on the Planimetric option in the Symbology branch.

Note: The planimetric option displays a MicroStation element showing where each cross 
section is cut.

54. <D> Apply.
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55. <D> in a clear area in the design file. Like the profile, you are identifying the lower left 
corner for the display, so make certain you are in an area that is clear above and to the right 
of your <D>.

56. Fit your MicroStation view and notice the planimetric lines. You can see that by default, 
cross sections are cut perpendicular to the active alignment. In a later section, you will 
learn to cut the cross sections on a skew.

57. Use MicroStation to delete the cross sections and the planimetric lines in the plan view.

58. <D> on Controls > Limits.

59. Toggle on Station.

60. Set the Start Station to 116+00.00.

61. Set the End Station to 111+50.00.

62. <D> Apply.
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63. <D> in a clear area in the design file.

64. Fit your MicroStation view and notice the planimetric lines. 

Note: Using the Station Limits allows you to cut sections for just a portion of the 
alignment.

You can zoom in and out of the cross sections to review them, or you can use a viewer that will 
automatically zoom into a selected cross section.
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65. Choose Evaluation > Cross Section > Cross Section Viewer.

The viewer allows you to view cross sections by set. If you have more than one set of 
sections in the file, you can use the drop-down to choose the set you want to view, or you 
can use the target and <D> inside one of the sections. If you are zoomed out far enough, 
you will see a box drawn around the set of sections currently shown in the Viewer.

66. <D> on any one of the sections in the list.

67. With only one MicroStation view open, the Viewer automatically uses it to zoom into the 
section selected. If you have more than one MicroStation view open, you are prompted to 
select the view with a <D>.

68. Change the Zoom factor to 1.0000 and choose another section.

69. <D> Run.

Just as before, with only one MicroStation view open, the Viewer automatically uses it to 
zoom into the sections, but this time it automatically scrolls through the entire set. If you 
have more than one MicroStation view open, you are prompted to select the view with a 
<D>.

Note: <Esc> on your keyboard stops the viewing process.

70. <D> Close on the Cross Section Viewer.

71. Window in to any one of the sections.
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Note: The lifts, curb and gutter, etc. are components, which were turned on before 
cutting sections. Design surfaces are made up of these components, as well as 
features and triangles.

72. Select Evaluation > Cross Section > Update Cross Section.

73. Set the Cross Section Set to SH52-H.

74. Set the Mode to Display Off.

75. Select the Components branch at left.

76. Highlight the 12345 SH52 surface.

77. Right-click in the component list and <D> Select All.

78. <D> Apply, then Close.

Note: The cross sections now show only the triangulated surface for SH52. Components 
may be turned on and off as desired using this procedure.
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79. Use MicroStation to Delete the cross section set and the planimetric lines.

Note: Sections can be cut along any alignment, not just a highway alignment.

80. Using what you have learned, cut 25’ sections along Wall-16-L that are 20’ wide on either 
side.

 

81. Review the sections.

82. Use MicroStation to Delete the cross section set and the planimetric lines.

Chapter Summary::

 Surfaces may be reviewed graphically by viewing the perimeter, triangles and/or contours 
among other surface displays.

 Horizontal alignments may be viewed graphically along with their stationing and 
annotation.

 Horizontal alignments may also be tracked as a review tool.

 Reports for horizontal alignment can be generated with the Review commands or with the 
XML Report command.

 With a horizontal alignment and surface, you can generate a profile and annotate a vertical 
alignment.

 With a horizontal alignment and surface, you can generate a set of cross sections to review 
the data.
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Alignments are reference points that are used to relate the design world to the real world. The coordinates that 
make up the alignment are located at the construction site and measurements for design elements are taken 
from these coordinates.

In this lab, a horizontal and vertical alignment is created that represents the new flowline for a drainage 
channel. The new flowline must match the existing flowline horizontally and vertically at the beginning and 
end of the alignment as well as at an inlet structure in the middle.

Chapter Objectives:

 Import a horizontal alignment from a graphic element.

 Add a horizontal curve to the alignment.

 Create a profile.

 Define a vertical alignment.

The following files are used in this lab:

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\Bridge\Drawings\Reference Files\12345BRDG_Model-Drain.dgn

 C:\Projects\12345\Bridge\Drawings\Reference Files\12345BRDG_Prof.dgn

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345_Drain

Lab 3.1 - Draw Graphic Elements for the Horizontal Alignment

There are numerous methods for entering horizontal alignment data into InRoads. Most of 
these methods are designed for survey and roadway geometry. Because this lab is not 
concerned with roadway geometric design criteria, the alignment can be laid out graphically 
then imported into inRoads.

Section Objectives:

♦ Create MicroStation graphic elements that represent the alignment.

♦ Create a complex chain from those elements.

♦ Import the graphic as a horizontal alignment.

♦ Change the direction of the alignment, if needed.

1. Start MicroStation and InRoads using the 12345BRDG_Model-Drain.dgn file.

2. In the main InRoads dialog box, verify that the CDOT_Civil.xin is loaded.

3. From the InRoads menu bar, select File > Open.

4. Navigate to the C:\Projects\12345\ROW_Survey\InRoads\DTM\ directory and 
open the 12345_Drain file
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5. Using the MicroStation view controls, zoom into the area shown in the illustration below.

6. From the CDOT Menu, select the Geometry group.

7. <D> the Proposed button.

8. Verify that the Type is set to Horizontal.

9. Highlight Alignment from the item list. This activates the Place SmartLine command.
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10. <T> then <D> on the points shown in the illustration below.

Points 1 and 2 are on the flowline of the existing channel. Point 3 is in the center of the top side 
of the inlet structure.
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11. <R> to exit the Place SmartLine command. The result is a linestring placed as shown 
below.

12. Zoom out to see the channel below the inlet.
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13. <T> then <D> on the points shown in the illustration below.

This line will match the new channel to the existing channel below the inlet.

14. <R> to exit the Place SmartLine command. The result is a linestring placed as shown 
below.

In order to create an alignment from these elements must match up end to end. The 
MicroStation Extend Elements to Intersection is used to accomplish this.
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15. From the MicroStation Main toolbar select the Extend Elements to Intersection 
command.

16. <D> on the first linestring near the inlet.

17. <D> the second linestring near the end closest to the inlet.

Note: If you are having trouble selecting the correct lines, the green terrain lines can be 
deleted to get them out of the way.
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The MicroStation Create Complex Chain command is used to join the two linestrings into a 
single element which can be imported into InRoads as a horizontal alignment.

18. From the MicroStation Main toolbar select the Create Complex Chain command.

19. <D> on each line, then <D> in a blank area to accept the elements.

20. <R> to exit the Create Complex Chain command.

This completes the linestring that will be used for the alignment. Next, the linestring is 
imported into InRoads.

Section Summary:
♦ MicroStation graphic elements can be used to create InRoads alignments.

♦ Multiple elements can be joined to create a single element which is easier to import 
into a single alignment.

Lab 3.2 - Create a Geometry Project and Import a Horizontal 
Alignment

Section Objectives:

♦ Create a new InRoads geometry project.

♦ Import the chain into InRoads.

The first step is to create a Geometry Project. This is the file that holds the horizontal and 
vertical alignment data.

1. Start MicroStation and InRoads (if they are not already started) and open the 
12345BRDG_Model-Drain.dgn file.

2. If InRoads was already opened, save and close any InRoads data files that are open.

3. From the inRoads menu, open the C:\Projects\12345\ROW_Survey\InRoads\DTM\ 
12345_Drain file.
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4. From the InRoads main menu, select File > New.

5. In the New dialog box, <D> the Geometry tab.

6. Set the Type to Geometry Project.

7. Key in 12345-Drain for the Name.

8. Key in New channel project for the Description.

9. <D> Apply then <D> Close to dismiss the dialog box.

10. On the InRoads Explorer, <D> the Geometry tab.

11. <R> on the 12345-Drain geometry project and select Save from the right click menu.
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12. In the Save As dialog box, navigate to the C:\Projects\12345\Bridge\InRoads\ 
folder.

13. At the bottom of the dialog box, use the Active drop down menu to reselect the 12345-
Drain geometry project. This will automatically fill in the name field so that the name on 
the hard drive matches what is shown in InRoads.

14. <D> Save then <D> Cancel to dismiss the dialog box.

Next, the horizontal alignment is created from the graphic element drawn above.

15. From the InRoads menu bar, select File > Import > Geometry.

16. In the Import Geometry dialog box, verify that the From Graphics tab is selected.

17. Set the Type to Horizontal Alignment.

18. Key in Channel_Flowline for the Name.

19. Key in Channel alignment for project 12345 for the Description.

20. Set the Style to ALG_PRO. 
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21. <D> Apply. The Import Geometry dialog box minimizes.

22. <D> on the linestring then <D> in a blank area to accept the element.

23. <R> to end the command. The Import Geometry dialog box is redisplayed.

24. <D> the Close button to dismiss the dialog box.

The linestring has now been added to the 12345-Drain geometry project. Next, the direction of 
the alignment must be determined. The alignment should run from north to south. The direction 
of the alignment is determined by the direction of the linestring (or complex chain). To check 
the direction of the alignment use the review command.

25. In the InRoads explorer, expand the 12345-Drain geometry project to show the 
Channel_Flowline alignment. 

26. <R> on the Channel_Flowline alignment and select Review from the right click menu.

27. Move the Review Horizontal Alignment dialog box so that the Channel_Flowline 
alignment is visible.
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28. In the Review Horizontal Alignment dialog box, toggle the mode to Element. This 
causes the first element of the alignment to highlight.

29. <D> Close to dismiss the Review Horizontal Alignment dialog box.

If the element highlights as shown in the image above, the alignment is running the wrong way.

To change the direction of the alignment:

Important! Complete steps 30 through 33 only if your alignment starts at the south end, as 
illustrated above.
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30. From the InRoads main menu bar, select Geometry > Utilities > Transpose.

31. In the Transpose dialog box, <D> the “target” button then <D> on the alignment. <D> in a 
blank area to accept.
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32. The alignment name appears in the Selected list. <D> the Apply button.   <D> Close to 
dismiss the Transpose dialog box.

33. Review the alignment again. The north most element highlights indicating the alignment 
now runs in the desired direction.

34. <D> Close to dismiss the Review Horizontal Alignment dialog box.

To smooth the intersection between the last two segments of the alignment, a horizontal curve 
is added to the alignment.

35. From the InRoads menu bar, select Geometry > Horizontal Curve Set > Define 
Curve.
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36. The first PI highlighted does not need a curve because that segment of the alignment is 
there to match the existing flowline. <D> the Next button to move to the next PI.

37. In the Radius 1 field, key in 315. This radius is a design decision made by the engineer.

38. <D> Apply. The MicroStation graphics are updated to show the radius.

39. <D> Close to dismiss the Define Horizontal Curve Set dialog box.

40. In the InRoads explorer, <R> on the 12345-Drain geometry project and select Save 
from the right click menu.

Section Summary:
♦ The Geometry project holds horizontal and vertical alignment data.

♦ Use the same name for the geometry project when saving it as used when it was 
created.

♦ When importing a horizontal alignment from graphics, the direction of the element 
determines the direction of the alignment.
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Lab 3.3 - Creating a Vertical Alignment

A vertical alignment controls the elevation of the template as it is placed along the corridor. 
Vertical alignments are typically built in a profile window.

Section Objectives:

♦ Create a profile along the new horizontal alignment.

♦ Create a vertical alignment placeholder.

♦ Add data to the vertical alignment

In order to add data to a vertical alignment, a profile window is required.

1. From the MicroStation menu bar, select File > Open.

2. Navigate to the C:\Projects\12345\Bridge\Drawings\Reference Files\ folder 
and select the 12345BRDG_Prof.dgn file.

3. From the InRoads menu bar, select Evaluation > Profile > Create Profile.

4. In the Create Profile dialog box, <D> the Preferences button.

5. In the Preferences dialog box, select 10x Vertical.
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6. <D> Load then <D> Close to dismiss the Preferences dialog box.

Using the 10x vertical exaggeration makes it easier to see elevation changes in relatively flat 
terrain.

7. Verify that the 12345_Drain surface is the only selected surface.

8. <D> Apply then <D> in the MicroStation view window. The profile is drawn in the dgn. 

9. <D> Close to dismiss the Create Profile dialog box.

10. In MicroStation, zoom in on the profile so that the elevations between 4680 and 4700 are 
visible.

With the profile window created, the vertical alignment data can be entered. The first step in 
this process is to create a vertical alignment placeholder for the Channel_Flowline horizontal 
alignment.
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11. On the InRoads menu bar, select File > New.

12. In the New dialog box, <D> the Geometry tab.

13. Set the Type to Vertical Alignment.

14. Key in Channel_Flowline-V for the Name.

15. Set the Style to ALG_PRO_Vert.

16. <D> Apply then <D> Close to dismiss the New dialog box.

17. On the InRoads menu bar, select Geometry > Vertical Curve Set > Add PI.

18. In the Add Vertical PI dialog box, <D> the Add button.
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19. <T> then <D> on each of the points indicated in the illustration below.

20. <R> <R> to exit the Add Vertical PI command. <D> the Close button to dismiss the 
Add Vertical PI dialog box.

The illustration below shows the completed vertical alignment.

21. In the InRoads explorer, <R> on the 12345-Drain geometry project and select Save 
from the right click menu.

Section Summary:
♦ A vertical alignments is a child of a horizontal alignment.

♦ Vertical alignment data is entered within a profile window.

♦ A profile window can be exaggerated vertically to emphasize elevation changes.

♦ Vertical PIs can be placed by tentative snapping to elements within the profile window. 
The SE=station,elevation key in can also be used to place vertical PIs.

Chapter Summary:

 Horizontal and vertical alignments are used to define the location or path of construction.

 Horizontal PIs can be placed by tentative snapping to elements within the drawing window. 
The xy=easting coordinate,northing coordinate,elevation(optional) key in can also be used 
to place horizontal PIs.
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 A profile window displays the elevations of the existing ground under the horizontal 
alignment.

 Profiled are the entry point for vertical alignment data.

 Save the geometry project after data is entered. This file does not save automatically.
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This lab demonstrates the use of templates and corridors to create a surface model (dtm) that can then be used 
to calculate earthwork and other quantities.  This method of design is well suited for linear construction sites 
such as ditches/channels and walls.

In this exercise, a template is created that contains a cast-in-place reinforced concrete channel liner, the 
excavation required to build the liner, and backfill to complete the construction.  Below is a sketch of the 
template.

Note: The slope paving shown in the illustration above has been omitted for this lab.

Chapter Objectives:

 Build a template showing the excavation, channel liner, and slope paving.

 Create a corridor that follows an alignment.

 Review design data in Roadway Designer.

 Generate design surfaces from the template and corridor.

The following files are used in this lab:

 C:\Projects\12345\Bridge\Drawings\Reference Files\12345BRDG_Model-Drain.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345_Drain

 C:\Projects\12345\Bridge\InRoads\12345_Drain.alg

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl
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Lab 4.1 - Construct the Channel Liner

The ditch liner is a closed shape component that defines the design channel.  The wall of the channel liner are 4 
inches thick and the bottom is 6 inches thick.  The left side rises 6 inches above the existing ground, while the 
right side is flush with the existing ground.  This component is not included as part of the triangulated surface 
model because it does not define the area of excavation.

Section Objectives:

♦ Copy the standard template library into the project folder.

♦ Create a new template in the project template library.

♦ Construct a new channel liner component for the  template.

♦ Edit point properties to define the shape of the liner.

♦ Edit the component properties to exclude the line from triangluation.

1. Start MicroStation and InRoads opening the 12345BRDG_Model-Drain.dgn file. 

2. In the main InRoads dialog box, verify that the CDOT_Civil.xin is loaded.

3. From the InRoads menu bar, select File > Open.

4. Navigate to the C:\Projects\12345\ROW_Survey\InRoads\DTM\ directory and 
open the 12345_Drain file

5. Navigate to the C:\Projects\12345\Bridge\InRoads\ directory and open the 
12345_Drain.alg file.
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6. Navigate to C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Templates\ and open the CDOT_Template-Library.itl file.

7. Navigate to C:\12345\ROW_Survey\InRoads\DTM\ and open 12345_Drain.

8. <D> Cancel to dismiss the Open dialog box.

9. In the InRoads Explorer pane, <D> the Templates tab.

10. <R> on CDOT _Template-Library and select Save As from the right click menu.

11. In the Save As dialog box, navigate to the C:\Projects\12345\Bridge\InRoads\ folder.

12. Key in 12345BDRG_Templates.itl for the file name.



Page 92 Colorado Department of Transportation

LAB 4 - Templates and Corridors Bridge Essentials Using InRoads XM

13. <D> Save then <D> Cancel.

14. From the InRoads menu bar, select Modeler > Create Templates.  This displays the 
Create Template dialog box.

15. From the Create Template menu bar, select Tools > Dynamic Settings.

16. In the  Dynamic Settings dialog box, key in 0.10 for both the “X” and “Y” Step.

17. Toggle on Apply Affixes.

The Dynamic Settings dialog box is used to enter data while constructing a component.
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18. In the Template Library Explorer area of the Create Template dialog box, expand the 
folders to show the contents of the 1-Templates folder.

19. <R> on the 1-Templates folder and select New > Template from the right click menu.

20. Key in 12345_Channel-Liner for the template name.

Because the channel liner is a unique shape, there are no components in the library that can be 
used.  Therefore, it will be built as a new component.  The channel liner is first “sketched in” as 
an Unconstrained component.  Then constraints are applied to the component points to define 
the proper shape.

21. <R> in the Template view and select Add New Component > Unconstrained from 
the right click menu.

22. In the lower center of the dialog box, data fields are displayed that apply to the new 
component.  In the Name field, key in Channel Liner.
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23. Select D_CONC_Pvmt from the Style drop down menu.

24. In the Dynamic Settings dialog box, <D> on the Point Name drop down arrow, and select 
Conc_Centerline-Top from the menu.  This automatically sets the Point Style as well.

25. Move the cursor onto the Template Origin (the magenta square) so that the readout in the 
Dynamic Settings dialog box is X: 0.00 Y: 0.00, then <D>.

26. In the Dynamic Settings dialog box, <D> in the Point Name field and key in Ditch-
Bottom. 

27. Set the Point Style to D-DITCH-Bottom.

28. Move the cursor into the Template View to the right of the origin and <D> to place the 
RT_Ditch-Bottom point.  The “RT_” is added to the name because Apply Affixes is on.

29. Key in Wall_Inside-Top for the next point.

30. Set the Point Style to D_CONC_Pvmt.

31. <D> above the RT_Ditch-Bottom point.
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32. Use the diagram below to name and place the remaining points.

33. After the last point is placed, <R> in the Template View and select Finish from the right 
click menu.

This completes the basic outline of the channel liner.  Next, constraints are assigned to the point 
to form the exact shape desired.

34. <D><D> on the RT_Ditch-Bottom point.  This displays the Point Properties dialog box.

35. In the Point Properties dialog box, set the Constraint 1 Type to Horizontal.

36. Set the Constraint 2 Type to Vertical.
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37. Set the Parent 1 for both constraints to Conc_Centerline-Top.

38. Key in 2.00 for the Constraint 1 Value.

39. Key in 0.00 for the Constraint 2 Value.

40. <D> Apply.

The RT_Ditch-Bottom point symbol changes to red and the point move to be 2 feet to the right 
of the Conc_Centerline-Top point.

41. <D> Next> to move to the RT_Wall_Inside-Top point.

42. Set the Constraint 1 Type to Horizontal.

43. Set the Constraint 2 Type to Vertical.

44. Set the Parent 1 for Constraint 1 to RT_Ditch-Bottom.

45. Set the Parent 2 for Constraint 1 to RT_Wall_Outside-Top.

46. Key in 0.00 for the Constraint 1 Value.

47. Key in -0.04 for the Constraint 2 Value.
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48. <D> Apply.

49. <D> Next> to move to the RT_Wall_Outside-Top point.

50. Set the Constraint 1 Type to Horizontal.

51. Set the Constraint 2 Type to Vertical.

52. Set the Parent 1 for both constraints to RT_Ditch-Bottom.

53. Key in 0.34 for the Constraint 1 Value.

54. Key in 0.04 for the Constraint 2 Value.
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55. <D> Apply.

The Vertical constraint is temporary, in order to position the point.  The final Constraint 2 is 
now set.

56. Set the Constraint 2 Type to Project to Surface.

57. Set the Parent 1 for Constraint 2 to Up.

58. Select 12345_Drain for the Constraint 2 Value.
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59. <D> Apply.

60. <D> Next> to constrain the RT_Outside-Bottom point.

61. Set the Constraint 1 Type to Horizontal.

62. Set the Constraint 2 Type to Vertical.

63. Set the Parent 1 for  Constraint 1 to  RT_Wall_Outside-Top.

64. Set the Parent 1 for  Constraint 2 to RT_Ditch-Bottom.

65. Key in 0.00 for the Constraint 1 Value.

66. Key in -0.50 for the Constraint 2 Value.

67. <D> Apply then <D> Next> to constrain the LT_Outside-Bottom point.

68. Set the Constraint 1 Type to Horizontal.

69. Set the Constraint 2 Type to Vertical.

70. Set the Parent 1 for  both constraints to LT_Ditch-Bottom.

71. Key in -0.34 for the Constraint 1 Value.

72. Key in -0.50 for the Constraint 2 Value.

73. <D> Apply then <D> Next> to constrain the LT_FG point.

This point will also have a temporary vertical constraint to position the point then it will be 
changed to a Project to Surface constraint.

74. Set the Constraint 1 Type to Horizontal.
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75. Set the Constraint 2 Type to Vertical.

76. Set the Parent 1 for  Constraint 1 to  LT_Wall_Outside-Bottom.

77. Set the Parent 1 for  Constraint 2 to LT_Ditch-Bottom.

78. Key in 0.00 for the Constraint 1 Value.

79. Key in 0.00 for the Constraint 2 Value.

80. <D> Apply

81. Set the Constraint 2 Type to Project to Surface.

82. Set the Parent 1 for Constraint 2 to Up.

83. Select 12345_Drain for the Constraint 2 Value.

84. <D> Apply then <D> Next> to constrain the LT_Wall_Outside-Top point.

85. Set the Constraint 1 Type to Horizontal.

86. Set the Constraint 2 Type to Vertical.

87. Set the Parent 1 for  both constraints to  LT_FG.

88. Key in 0.00 for the Constraint 1 Value.

89. Key in 0.50 for the Constraint 2 Value.

90. <D> Apply then <D> Next> to constrain the LT_Wall_Inside-Top point.

91. Set the Constraint 1 Type to Horizontal.

92. Set the Constraint 2 Type to Vertical.

93. Set the Parent 1 for  Constraint 1 to  LT_Ditch-Bottom.

94. Set the Parent 1 for  Constraint 2 to LT_Wall_Outside-Top.

95. Key in 0.00 for the Constraint 1 Value.

96. Key in -0.04 for the Constraint 2 Value.

97. <D> Apply then <D> Next> to constrain the LT_Ditch-Bottom point.

98. In the Point Properties dialog box, set the Constraint 1 Type to Horizontal.

99. Set the Constraint 2 Type to Vertical.

100.Set the Parent 1 for both constraints to Conc_Centerline-Top.

101.Key in -2.00 for the Constraint 1 Value.

102.Key in 0.00 for the Constraint 2 Value.

103.<D> Apply.
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This completes the point editing for the channel liner component.  To complete the component 
properties are edited.  The component property to exclude the channel liner from triangulation 
will be turned on.  This will allow the design surface to triangulate properly so that it represents 
the actual area of excavation on this project.

104.<D><D> on the line that makes up the channel liner.  This displays the Component 
Properties dialog box for the channel liner.

105.In the Component Properties dialog box, toggle on Exclude from triangulation.

106.<D> Apply then <D> Close.

The channel liner points and component is still included in the dtm created later.  They can still 
be included in the cross section display and have volume data calculated.  However, the 
channel liner component will not affect the earthwork volume calculations.

107. Select File > Save from the Create Template menu bar.

Section Summary:
♦ Copying the standard template library is necessary because the standard template 

library is overwritten at login if it has been changed.
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♦ Templates store the information used to create design dtms.

♦ A dtm can contain triangulated and untriangulated data.

♦ Point constraints locate points in relation to other points.

♦ The Project to Surface constraint is used to make the point follow the “target” surface.

Lab 4.2 - Create the Excavation Components

The Excavation components comprise the triangulated part of the template which will be used to compute 
earthwork volumes in a later lab.  Two end condition components are used, the left one has a 2 to1 slope, the 
right one has a 0.5 to 1 slope.

Section Objectives:

♦ Build the two end condition components.

♦ Move a component to a new location.

♦ Test the template.

The first end condition component to be added is the right side end condition.  It begins at the 
center bottom of the channel liner, runs to the RT_Wall_Outside-Bottom point, then up at a 0.5 
to 1 slope to intercept the existing ground surface (12345_Drain).

1. <R> in the Template View of the Create Template dialog box and select Add New Com-
ponent > End Condition from the right click menu.

2. In the Current Component area, Key in 0.5_to_1-Cut in the Name field.

3. Set the Style to D_Top-of-Cut.

4. Verify that the Target Type is set to Surface and set the Surface to 12345_Drain.

5. In the Dynamic Settings dialog box Point Name field, select Conc_Centerline-Top.  
Then edit the name to read Conc_Centerline-Bottom.
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6. Set the key in type to XY= and key in 0,-0.5 in the key in field.  Then press the Enter key.  
This places the first point at the center bottom of the ditch liner.

The next point is placed on top of the RT_Wall_Outside-Bottom point.  The new point is 
merged with the existing point retaining the existing point’s properties.

7. In the Dynamic Settings dialog box, toggle off  Check for Interception.

8. Move the cursor into the Template View and place it over the RT_Wall_Outside-Bottom 
point.  

9. When the point symbol turns white, <D> to place the new point.

10. In the Dynamic Settings dialog box, toggle on Check fo Interception.

11. Toggle on End Condition is Infinite.

12. In the Point Name field, select Top-of-Cut from the drop down menu.
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13. Set the key in type to HS= (horizontal distance and slope)and key in 1,1:0.5 in the key in  
field.  Then press the Enter key.

14. <R> in the Template view and select Finish from the right click menu.

15. This completes the right end condition.

The left side end condition is added similarly to the right side.  However, it cannot be placed 
directly on top of the existing points.  If it were placed on to the existing points, the software 
would interpret them as part of a single end condition and the template would not function 
properly.

Therefore, the left end condition will be built in an open area then moved to its proper location.

16. <R> in the Template View of the Create Template dialog box and select Add New 
Component > End Condition from the right click menu.

17. In the Current Component area, Key in 2_to_1-Cut in the Name field.

18. Set the Style to D_Top-of-Cut.

19. Verify that the Target Type is set to Surface and set the Surface to 12345_Drain.

20. In the Dynamic Settings dialog box Point Name field, select Conc_Centerline-Top.  
Then edit the name to read Conc_Centerline-Bottom.

21. Move the cursor into an open area of the Template View, to the left of the origin, and <D> 
to place the new point.

22. In the Dynamic Settings dialog box, toggle off  Check for Interception and End 
Condition is Infinite.
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23. Key in Wall_Outside-Bottom for the Point Name.

24. Select D_Conc-Pvmt for the Point Style.

25. Verify that the key in type is set to HS= and key in -2.34,0 in the key in  field.  Then press 
the Enter key.  This creates the bottom under the channel liner.

26. In the Dynamic Settings dialog box, toggle on Check for Interception.

27. Toggle on End Condition is Infinite.

28. In the Point Name field, select Top-of-Cut from the drop down menu.

29. Key in -1,-1:2 in the key in  field.  Then press the Enter key.

30. <R> in the Template view and select Finish from the right click menu.

This completes the left end condition.  Now it is moved to its proper location.
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31. <R> on the LT_Conc_Centerline-Bottom point and select Move Point from the right 
click menu.

32. Move the cursor (and the component) on to the Conc_Centerline-Bottom point and <D> to 
move the left end condition to its proper location.

This completes this portion of the template.  The illustration below shows the template at this 
stage.

  

The template can now be tested to see how it will perform in a corridor.

33. <D> the Test button under the right corner of the Template View.  This displays the Test 
End Conditions dialog box.  
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34.  <D> the Draw button. 

35.  Move the cursor up and down in the view area.  Notice that the walls of the liner and the 
cut slopes extend up to meet the ground line so long as it is above the inside bottom of the 
liner.

36.  <D> Close to dismiss the Test End Conditions dialog box.

37.  Select File > Save from the Create Template menu bar.

Section Summary:
♦ End conditions are special components that do not use a constraint to intercept a 

surface.

♦ End conditions that share a common starting point are considered a single component 
and only one of the lines will be used.

♦ To create two end conditions that start at the same point, the second component must 
be created in a different location then moved to the correct spot.

♦ Test templates with end conditions to be sure they behave as expected prior to using 
them in a corridor.
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Lab 4.3 - Adding Backfill Components

The final components for the template are the backfill components.  These are used to calculate the the volume 
of embankment material used to fill in the trench excavation behind the channel liner.  These components will 
not be used to create the triangulated surface, but can still be displayed in cross sections and have volumes 
calculated for them.

Section Objectives:

♦ Add Backfill components

1. <R> in the Template View of the Create Template dialog box and select Add New Com-
ponent > Unconstrained from the right click menu.

2. In the Current Component area, key in Backfill for the Name.

3. Select D_SHOULDER-Embankment for the Style.

4. <D> on the RT_Wall_Outside-Bottom point.

5. In the Dynamic Settings dialog box, select Top-of-Cut for the Point Name.

6. <D> in an open area near the RT_Top-of-Cut point.

7. In the Dynamic Settings dialog box, key in Wall_Outside-Top.

8. Set the Point Style to D_CONC_Pvmt.

9. <D> in an open area near the RT_Wall_Outside-Top point.

10. <R> and select Finish from the right click menu.
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11. <R> on the RT_Top-of-Cut1 point and select Add Constraint > Full Constraint from 
the right click menu.

12. <D> on the RT_Top-of-Cut point to identify it as the parent.

13. In the Add Full Constraint dialog box, key in 0.00 for the values of both the Horizontal 
Offset and Vertical Offset.

14. <D> OK.

15. Repeat steps 11 through 14 for the RT_Wall_Outside-Top1 point, using 
RT_Wall_Outside-Top as the parent.

Placing the backfill points directly on top of the existing points would cause the line between 
RT_Wall_Outside-Top and RT_Top-of-Cut to match the existing ground instead of creating a 
single segment between the two points.

The steps to create the left side backfill are the same as those above.

16. Repeat steps 1 through 15 for the left side, using the corresponding points from the left of 
the existing template.

The final step to complete the template is to exclude the backfill components from 
triangulation.

17. <D><D> on the RT_Backfill component line.  This displays the Component Properties 
dialog box.

18. Toggle on Exclude from triangulation.
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19. <D>Apply then <D> Close.

20. Repeat steps 11 through 13 for the LT_Backfill component.

21. Select File > Save from the Create Template menu bar.

22. <D> Close on the Create Template dialog dox to dismiss the window.

This completes the template.  It is now ready to use to create a design surface model (dtm).

Section Summary:
♦ Points added on top of other points do not have to be defined in the dynamic Settings 

dialog box.

♦ Points added on top of other points are merged with the existing points and take on the 
properties already defined.

Lab 4.4 - Creating the Corridor for the Channel

With the completed template and the horizontal and vertical alignments from a previous lab, a corridor can be 
defined that is used to create the design surface model. A corridor contains two basic parts: a path over the 
existing terrain, and a typical section of the design.  In this example, a horizontal and vertical alignment define 
the path of the corridor and the template built above defines the typical section.

Section Objectives:

♦ Create a corridor base on a horizontal and vertical alignment.

♦ Add a template drop to the corridor.

♦ Review the corridor in Roadway Designer.

♦ Create a design surface from the corridor.

The first step in creating a design surface is to create the corridor.
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1. Select Modeler > Roadway Designer from the InRoads menu bar.  This displays the 
Roadway Designer dialog box.

2. From the Roadway Designer menu bar, select Corridor > Corridor Management or 

select the corridor management button   from the button bar.

3. In the Manage Corridors dislog box, key in 12345BRDG_Channel for the Name.

4. Verify that the Type is set to Alignment.

5. Verify that Channel _Flowline is set for the Horizontal Alignment.

6. <D> Add the <D> Close to dismiss the Manage Corridors dialog box.
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Next, the template drop is added to the corridor.

7. Select Corridor > Template Drops from the Roadway Designer menu bar of <D> the 

Template Drops  button from the button bar.

8. In the Template Drops dialog box, key in 5.00 for the Interval.

9. Expand the folder in the Library Templates area to show the contents of the 1- 
Templates folder.

10. Highlight the 12345_Channel-Liner template then <D> Add.

11. <D> Close to dismiss the Template Drops dialog box.

Notice that the template is now displayed in the template view of the Roadway Designer dialog 
box.  The design can now be reviewed in Roadway Designer.
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12. Use the station indicator arrows to move back and forth through the design corridor.  The 
sideslopes should tie to the existing ground and the design channel flowline should be at or 
very near the existing flowline athe the beginning and end of the corridor.

13. Select Tool > Options from the Roadway Designer menu bar.  The Roadway Designer 
Options dialog box is used to turn on or off various design data displays.

14. Toggle on Cut and Fill Values and Net Volume.

15. <D> OK.
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16. Scroll through the corridor again.  Notice the cut and fill volume data displayed at the 
bottom of the template view.

Finally, a surface (dtm) is created from the corridor.  With a design surface, annotated cross 
sections can be created for plan sets and various volume reports can be generated.

17. Select Corridor > Create Surface from the Roadway Designer menu bar of <D> the 

create surface  button from the button bar.

18. In the Create Surface dialog box, key in 12345_Channel-New for the Name.

19. Select Proposed for the Default Preference.

20. Toggle on Empty Design Surface, Add Exterior Boundary, and Triangulate.

21. Select Exterior Boundary for the boundary’s Style.
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22. <D> Apply.  This creates the design surface.

23. <D> Close to dismiss the Create Surface dialog bix.

24. Select File > Save from the Roadway Designer menu bar.

25. In the Save As dialog box, navigate to the C:\Projects\12345\Bridge\InRoads\ 
directory.
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26. Key in 12345_Channel for the File name.

27. <D> Close on the Roadway Designer dialog dox to dismiss the window.

28. In the InRoads Explorer, <D> the Surfaces tab at the bottom.

29. <R> on the 12345_Channel-New surface and select Save from the menu.

30. In the Save As dialog box, navigate to the C:\Projects\12345\Bridge\InRoads\ 
directory.

31. Use the Active drop down menu and select 12345_Channel-New.  This places the 
surface’s name in the File name field.
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32. <D> Save then <D> Cancel to dismiss the dialog box.

The design surface is now ready for use generating cross sections, volumes, and reports.  

Section Summary:
♦ Corridors are most commonly created along horizontal and vertical alignments.

♦ The origin of the template follows the corridor path ( horizontal and vertical alignment 
or surface feature).

♦ Template Drops define which template is used and how often it is applied.

♦ Once the corridor and templated drops are defined, the design can be reviewed and 
edited in the Roadway Designer dialog box.

♦ A design surface (dtm), based on the corridor and templated drops, can be created from 
Roadway Designer.

Chapter Summary:

 Templates and corridors are used to create a design surface (dtm) of roughly parallel 
features.

 Templates define the “typical section” of the design surface.

 Templates are defined by points.  Points are located using offsets from other points known 
as constraints.

 Acomponent is a series of related points that define the area of a specific material.

 Components are included in the design dtm, but do not have to make up the triangulated 
model.

 Corridors define the path, in relation to the existing ground, that the template will follow.

 The design model can be reviewed and edited in the Roadway Designer dialog box prior to 
creating a dtm.
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This section covers how to evaluate design data for minimum clearances. Alignments, Surfaces and Features 
will be used in the evaluation. Since the alignments and surfaces represent finished grade elevation, the depth 
of the bridge structure must be taken into account as well.

Chapter Objectives:

 Learn to find the minimum clearance between crossing vertical alignments.

 Learn some of the tools available for finding areas with potential clearance issues. 

 Learn how to use MicroStation along with feature graphics to check clearances.

The following files are used in this lab:

 C:\Projects\12345\Bridge\Working \CU12345BRDG_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345 SH119

 C:\Projects\12345\Design\InRoads\12345 SH52

 C:\Projects\12345\Design\InRoads\12345 SH119 SH52 Interchange.alg

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl

Lab 5.1 - Open Data Files

1. Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

2. Verify the correct XIN file is loaded.

3. Select File > Open from the InRoads menu.

4. Open C:\Projects\12345\Design\InRoads\12345 SH119, 12345 SH52 and 12345 SH119 
SH52 Interchange.alg. 

Lab 5.2 - Intersecting Alignment Reports

1. Delete any MicroStation graphics currently in the design file.
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2. Select Geometry > View Geometry > All Horizontals.

3. Select Tools > XML Reports > Intersecting Alignment Stations.

Note: This report returns the stationing of both intersecting alignments, along with the 
coordinates of the intersection and the elevation difference between the two active 
verticals.

4. For the Horizontal Alignment, select SH52-H.

5. For the Intersecting Alignments, key in SH119* to select both NB and SB.

6. Select Apply.
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7. If the default style sheet has not been set for this report, a Report Browser message will 
appear. Select OK if it does.

8. Select the IntersectingAlignmentStations > IntersectingAlignmentStationsASCII report 
format.

Note: This report lists the stationing of each of the crossing alignments, along with the 
coordinates of the crossing point and the elevation difference. The report can be 
printed or saved as a text file if desired.

Important! The last active vertical alignment under each horizontal is used to 
determine the vertical clearance. In this case, each horizontal has only one 
vertical, so it is not a concern.

9. Right-click on the format and select Set as Default Intersecting Alignment Stations.

10. Close the Report dialog.

If this report is needed at all feature intersections rather than only at the centerline 
intersections, the following steps may be used.



Page 122 Colorado Department of Transportation

LAB 5 - Evaluating Clearances and Conflicts Bridge Essentials Using InRoads XM

11. Close the Intersection Alignment Stations Report dialog.

12. Delete all the alignment graphics.

13. Toggle on the Feature Filter Lock.

14. Set the Feature Filter to XS_Excluded from Triangulation.

Note: This filter allows only triangulated features to show in dialog boxes. In the next 
step, the features for SH52 are displayed and the non-triangulated features are not 
needed.

15. Select Surface > Update 3D Plan/Surface Display.

16. Toggle Display On.

17. Highlight the surfaces 12345 SH52 and 12345 SH119.

18. Toggle on Features.

19. In the feature list, right-click and Select All.

20. <D> on the Style header to sort by style name.

21. Holding down your <Ctrl> key, <D> on all the Cut and Fill Features, the Exterior and the 
3:1 Slope features to de-select them. All other features should be highlighted.

Note: Some of the features are de-selected because for the next series of steps, you only 
want the backbone features displayed.



Colorado Department of Transportation   Page 123

Bridge Essentials Using InRoads XM LAB 5 - Evaluating Clearances and Conflicts

22. <D> Apply.

Note: The features should be displayed in the file as shown. If not, try the previous steps 
again.

23. Close Update 3D Plan/Surface Display.

24. Select MicroStation Place Fence and place a fence around all of the features.

25. Select File > Import > Geometry.

26. On the From Graphics tab, select Horizontal and Vertical Alignment for the Type.
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27. Verify the Target Geometry Project is 12345 SH119 SH52 Interchange.

28. Toggle on Use Fence.

29. Toggle on Use Tag Data.

30. <D> Apply.

Note: All of the graphics in the fence are imported as alignment. Since they were 
displayed as features and have tags, the alignments are named the same as the 
feature names.

31. Select Tools > XML Reports > Intersection Alignment Stations.

32. For the Horizontal Alignment, select SH52-H.

33. For the Intersecting Alignments, key in SH119* to select all of the crossing alignments.

34. <D> Apply.
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Note: When an alignment is imported from graphics, the default stationing begins with 
0+00.00, so the stations shown for the imported alignments do not correspond with 
the actual stationing.

35. Close the Report dialog when finished reviewing the data.

36. Close the Intersection Alignment Stations Report dialog.

37. Select the MicroStation Place Fence command to clear the fence.

Lab 5.3 - MicroStation Measurements

1. Zoom into the bridge area.

2. On the MicroStation menu, select Measure Distance.

3. Set the Distance to Minimum Between.

4. Set the Mode to True.

5. <D> on one of the SH52 Features.
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6. <D> on one of the SH119 Features.

Note: The Minimum Distance between the features is the vertical clearance.

If you want to check the minimum clearance between the shoulder and the edge of girder, 
you will need a MicroStation graphic representing the girder placed at the correct 3D 
location in the file. There are several methods for obtaining the girder element. One method 
is to use the View 3D Alignment command in InRoads. This command combines the 
horizontal and vertical alignment to create a 3D MicroStation element. You can use this 
command to view the centerline of SH52 and apply the correct offsets for any of the 
girders.
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7. Turn off all levels except DES_Roadway_Shoulder (the SH119 shoulder lines) and 
DRAFT_LC-Center_WT-3 (roadway centerlines).

8. Select Geometry > View Geometry > 3D Alignment.

9. Set Horizontal Alignment to SH52-H and Vertical Alignment to SH52-V.

10. In the Limits section, key in 106+00 for the Start station limit and 109+00 for the Stop 
station limit.
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11. In the Offsets section, key in 52.92 for Horizontal Start and Stop. Key in -6.92 for the 
Vertical Start and Stop.

Note: For this bridge, there are 5 girders on each side of the centerline spaced at 10’-7” 
on center, making the outmost girder a horizontal offset of 52.92 feet from the 
centerline. The vertical offset to the bottom of the girder is 6.92 feet.

12. <D> Apply, then Close.

Note: The red line represents the outermost girder on the right side of the SH52 and 
placed in the file at the correct horizontal and vertical offset from the centerline.

13. On the MicroStation menu, select Measure Distance.
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14. Set the Distance to Minimum Between.

15. Set the Mode to True.

16. <D> on one of the SH52 girder (red line).

17. <D> on one of the SH119 left shoulder (left purple line).

Note: The minimum vertical distance from the girder to the shoulder is displayed in the 
tool settings box.

18. If you like, you can dynamically rotate your view to get a dynamic display (blue line) of 
where the minimum distance occurs.

19. If you rotated your view, rotate the view back to Top.

20. Delete the girder element (red line).
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21. Turn on all levels to view all SH52 and SH119 roadway features.

Lab 5.4 - Isopach Surface

1. The surfaces can also be used for a more visual look at the clearances.

2. Select Tools > Options > Factors and set the Text Scale Factor to 5.
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3. Place a MicroStation fence around the area where the bridge will be as shown.

4. Select Surface > Design Surface > Generate Isopach Surface.

5. Set the First Surface to SH119.

6. Set the Second Surface to SH52.

7. Toggle on Isopach Surface and key in 12345 D-16-DU isopach for the surface name.

Note: This surface will be created when the command is applied.

8. Toggle on Triangulate Surface.

9. Set the Fence Mode to Inside.

10. Select the Staking Tab.
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11. Set the Display Mode to Grid.

12. Set the Northing and Easting Intervals to 5.00.

13. <D> <D> on the Fill Text Symbology and set the Rotation Angle to 30^00'00", then 
<D> OK.

  

14. <D> Apply, then Close.

15. Clear the fence.

16. Fit the MicroStation view, then window into the bridge area.

Note: The text in the file denotes the difference between the two surfaces on a 5’ grid 
interval. In addition, a surface was generated with points on a 5’ grid, with each 
point’s elevation being the difference. This surface can be used to help visualize 
any potential conflicts.

17. Delete all the graphics in the design file.

18. Select Surface > View Surface > Color Coded Elevations.

19. Set the Surface to 12345 D-16-DU isopach.
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20. Set the Color Mode to Automatic.

21. Select the Color Table tab.

22. Set the Initial Color to 10.

23. Key in 1 for the Color Step.

24. Toggle on Number of Colors and key in 2.

25. Toggle on First and Last Elevation Options and set each to 26.00.

Note: The elevation is where the color will change on the display from color 10 to color 
11, indicating that everything color 10 has a clearance of less than 26 feet, while 
everything color 11 has a clearance of more than 26 feet.

26. <D> Generate.

27. <D> Apply.
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28. <D> in the design file for the location of the legend.

29. <D> Close

30. On the MicroStation menu, select Utilities > Render > Smooth.

31. <D> in the view.

32. Try other elevations to isolate potential areas of conflict.

Chapter Summary:

 The vertical clearance between InRoads alignments can be checked easily with an XML 
Report.

 Surface Features can be imported as alignments to run the same report.

 MicroStation measure commands are used to check the minimum distance between graphic 
elements.

 An isopach surface generated between two design surfaces will help determine areas of 
potential clearance issues.
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This lab covers how to use additional cross section and profile tools to review surface data.

Chapter Objectives:

 Learn how to use cross section tools to cut sections on a skew to the alignment.

 Learn how to cut sections at specific locations based on graphic elements.

 Learn how to use level filters to find specific levels or groups of levels to turn on or off.

 Learn how to update components, features or surfaces on cross sections.

 Learn how to annotate points or features on cross sections.

 Learn how to use feature filters to find specific features for displaying or annotating.

 Learn how to cut profiles along graphic elements.

The following files are used in this lab:

 C:\Projects\12345\Bridge\Working \CU12345BRDG_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for interchange

 C:\Projects\12345\Design\InRoads\12345 SH52

 C:\Projects\12345\Design\InRoads\12345 SH119 SH52 Interchange.alg

 C:\Projects\12345\Bridge\Drawings\Reference_Files\12345BRDG_Model_D-16-DU.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl

Lab 6.1 - Open Project Data

1. Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

2. Verify the correct XIN file is loaded.

3. Select File > Open from the InRoads menu.

4. Open C:\Projects\12345\Design\InRoads\12345 SH52 and 12345 SH119 SH52 
interchange.alg. 

5. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.

Lab 6.2 - Create Skewed Cross Sections from Graphics

In the previous lab, a cross section set was created based on SH52 at an even interval along the 
alignment and all sections were perpendicular. In this section, cross sections are created on a 
skew to the alignment for review purposes.

1. Delete any MicroStation graphics currently in the design file.
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2. Select Geometry > View Geometry > All Horizontals.

3. Fit the MicroStation view.

4. Zoom in to the approximate area shown.
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5. In MicroStation, select the Element Selection tool.

6. While holding down the <Ctrl> key on your keyboard, <D> on the four elements shown 
here. 

Note: This makes a MicroStation selection set from the wall alignment graphics.

7. Select Tools > Options > Factors.

8. <D> the lock icon.
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9. Set the Text Scale Factor to 40.

10. <D> Apply, then Close.

11. Make SH52-H the active alignment.
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12. Select Evaluation > Cross Sections > Create Cross Sections.

13. Toggle on the two surfaces.

14. Select the Custom > General branch.

15. Set the Type to Linestring.

16. <D> Graphics.

Note: The list of stations where the graphics cross the alignment is shown in the dialog. If 
an entry is highlighted, the information on the right shows the offsets and the skew 
angle also.

17. <D> Apply.
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18. <D> a clear area in the design file for the bottom left corner of the cross section set.

19. Review sections by zooming in or by using the Cross Section Viewer.

Note: The cross sections are created based on the graphic elements. In this case, they are 
graphical displays of alignments, but they can be graphics drawn in MicroStation 
as well. Next, elements representing bearing lines and the pier centerline are used 
to create sections.

20. Back in the Cross Section dialog, highlight the list of custom stations and choose Delete 
on the keyboard.

21. <D> Close.

22. Clear the selection set of graphics by selecting the Element Select tool and <D> in a 
clear area of your file.

Note: The graphics representing the centerline and bearing lines are currently in a 
reference file and on a level that is turned off. 

23. Select File > Reference from the MicroStation menu.
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24. Turn on the display of the BRDG_Model_D_16-DU.dgn reference.

25. Close the Reference dialog box.

Note: Bearing and Pier centerlines are shown in the file. This reference was attached in 
the previous lab.

Note: It will be easier to see the new elements if the alignment levels are turned off. To 
facilitate finding the appropriate levels, level filters are used. Level filters allow the 
segregation of levels based on predefined criteria, such as all alignment levels, all 
bridge levels, etc. When a level filter is active, the dialogs listing levels only show 
those that pass the filter, making it easier to find specific ones.

26. In MicroStation, select Settings > Level > Display.

27. Toggle View Index 1 on and all others off.

28. Set the Active Level to Default.

29. Toggle Show Level Name or Filters to Levels.
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30. Set the List Filter to Alignment

31. Scroll through the list and notice only alignment levels are displayed.

32. Right-click in the level list and choose All Off.
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Note: In the MicroStation view, notice the alignments levels are now off and the bridge 
levels are still on. 

33. Right-click in the level list and choose All On.
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Note: Level filter are used in two ways. One, as described above, they are used to 
segregate the level lists to make it easier to find the necessary levels. They can also 
be used to turn on or off all associated levels.

34. Toggle the Filter to (none).

35. Toggle Show Level Name or Filters to Filters

36. Highlight Bridge-All.

37. Fit the MicroStation view and notice that the alignment levels are now off and only bridge 
levels are on.

38. Clear any previous selection set.
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39. Make a selection set from the Pier and Bearing MicroStation graphics.

40. Select Evaluation > Cross Section > Create Cross Section.

41. In the Cross Section dialog on the Custom > General branch, set the Type to Linestring.

42. <D> Graphics.

43. In the Level Display box, toggle off the Bridge-All filter to turn all levels back on.

44. In the Create Cross Section command, <D> Apply and then <D> in a clear area of the 
file.

45. <D> Close.

Note: Three cross sections are created for the three lines in the selection set.

46. Do not close out of the Create Cross Section command.
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47. Close the Level Display box.

48. Review your new custom cross section set.

49. In the Create Cross Section dialog box, select Save As.
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50. Key in 12345BRDG_Model _D-16-DU for the file name.

51. Select Save.

Note: In the future, these sections can be re-created by loading this text (*.xsc) file rather 
than selecting the graphic elements.

52. Zoom in to the second cross section.

Lab 6.3 - Update and Annotate Cross Sections

You can update a cross section set to turn on or off the display of components, crossing 
features, projected features or surfaces. You can also refresh the display of these items if 
changes have been after creating the cross sections.

Cross section points and segments can be annotated as well. If you want to annotate specific 
points, you can choose the corresponding features for annotation. However, the features must 
first be displayed on the cross section before they can be annotated.

In this section, you will use both the Update Cross Section and Annotate Cross Section 
commands. First, to more easily see the design surface, you will toggle off the components.

1. Select Evaluation > Cross Section > Update Cross Section.

2. Verify the Section Set is the current one.

3. Set the Mode to Display Off.

4. Highlight Components at left.
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5. Highlight the SH52 Surface.

6. Right-click in the component list and <D> Select All.

7. <D> Apply, then Close.

8. Review the cross section to see that components have been turned off.

Note: To assist in evaluating the cross sections, it is often helpful to see the elevations, 
which can be annotated using Annotate Cross Sections.

9. Select Evaluation > Cross Section > Annotate Cross Section.

10. Load the preference Proposed Grades Only.
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11. Select the Set of skewed sections.

12. Toggle on the SH52 surface.

13. <D> Apply, then Close.

Note: The elevations are annotated for every point on the proposed grade.

Note: Often, a more useful option is to annotate the elevations of only certain points. This 
is accomplished by first displaying the features in the proposed model on the cross 
sections.

14. Select Evaluation > Cross Sections > Update Cross Sections.

15. Select the set of skewed sections.

16. Set the Mode to Display On.

17. Select Crossing Features.
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18. Highlight the SH52 Surface.

Note: Look in the feature list and notice that there are several features. The surface 
contains features for each of the lifts seen on the cross sections earlier. The features 
on the finished grade, which are triangulated, are the ones typically annotated in 
this case. Rather than scrolling through this list and highlighting just those, a 
feature filter is used.

19. Select Tools > Locks > Toolbar to toggle on the locks toolbar if it is not on already.

20. On the Update Cross Section box, select Filter...

21. In the feature filter list, select XS_Excluded from Triangulation and select OK.
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22. Toggle on the Feature Filter lock.

Note: The feature filter has no effect unless the lock is on.

23. In the Update Cross Section box, scroll through the list of features and note the number is 
greatly reduced.

Note: The filter chosen, XS_ Excluded from Triangulation eliminates non-triangulating 
features from any dialog box that lists features. While it is very handy, it can also 
be confusing when features that exist do not show up in the list. For that reason, the 
lock is toggled off after use. There are several pre-defined filters that can be used 
to segregate features. These filters are stored in the XIN file.
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24. Highlight the Centerline Top and the left and right Laneline-Top1 features.

25. <D> Apply.

Note: Small ‘+’ signs are shown on the cross sections. These mark the location of the 
features and can now be annotated.

26. <D> Close.

27. Toggle off Feature Filter lock.

Note: It is best to leave this lock off unless you need it.

28. Select Evaluation > Cross Section > Annotate Cross Section.
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29. Load the preference Proposed Grades Only.

30. Select the set of skewed sections.

31. Toggle on the SH52 surface.

32. Select Points and toggle off Include Points.



Page 154 Colorado Department of Transportation

LAB 6 - Working with Surfaces Bridge Essentials Using InRoads XM

33. Select Features and toggle on Include Features.

34. Select Annotate under Features.

35. Highlight the three features listed.
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36. <D> Apply, then Close.

Note: Offsets and elevations are annotated for only the three features on the proposed 
grade. The previous annotation was deleted since you displayed these graphics in 
Pencil mode.

Lab 6.4 - Creating Profiles from Graphics

In addition to cutting skewed sections based on graphic elements, profiles can also be generated 
from graphics. The main differences between the two options include:

 The bottom axis of Cross Sections list offsets from the reference line along which they are 
created (alignment, graphic, or multi-point).

 The bottom axis of a Profile lists stationing, even if the profile is cut from a graphic. For 
profiles cut from graphics or multi-points, the stationing begins at 0+00.

In this section, you will generate a profile showing existing and proposed surfaces along a the 
pier centerline graphic. Since the graphic is in a reference, you will first draw a new line the 
active file to use for profiling.

1. In MicroStation select the Place Line command.

2. Place a new line by snapping to the two end points of the pier centerline.

3. Select Evaluation > Profile > Create Profile.

4. Select General.
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5. Toggle on both surfaces.

6. Select Source.

7. Toggle on Graphics Alignment.

8. If you key in a name in the Graphics Alignment field, an alignment is created for the 
graphic element selected after choosing Apply. 



Colorado Department of Transportation   Page 157

Bridge Essentials Using InRoads XM LAB 6 - Working with Surfaces

9. <D> on the Include Branch.

Note: If you want to display crossing features on your cross section like pipes or utilities, 
toggle on Crossing Features. These features must first exist in the surface(s) 
you’re showing on the sections. The feature’s style controls if the feature can be 
shown on the cross section.

Note: If you want to show features that fall outside the cross section, toggle on Projected 
Features. This will show the orthogonal projection of the features onto the cross 
section. You also have the option of specifying a Bandwidth to either side of the 
section to project the features.

10. For this exercise, leave Crossing Features and Projected Features turned off.

11. <D> Apply.

12. <D> on the line you drew over the pier centerline element.

13. <D> to accept the element.

14. <D> a clear area in the file.
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Note: The profile is created showing both surfaces. Since there is not an alignment 
associated with this review profile, some of the post-processing commands for 
profiles, such as annotating and updating are not available. Profiles that need to be 
annotated and/or updates should be cut using an alignment, or an alignment should 
be created when the profile is cut by specifying an alignment name as noted above.

Chapter Summary:

 Custom cross sections are used to create sections that are not based on an interval or 
perpendicular to an alignment.

 The setup for custom cross section sets may be saved to a text file and loaded later to cut 
sections at the same location.

 Level filters can create a subset or group of levels to easily turn an entire group of levels on 
or off. They can also help you find individual levels more easily.

 Feature filters create a subset or group of surface features for displaying in plan, profile or 
cross section. They can also help you find individual features more easily.

 Profiles can be cut based on alignments or graphics.
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This section covers how to use Surface Modeling tools for excavation and backfills. You will also use these 
tools to create pier features.

Chapter Objectives:

 Learn how to create excavation and backfill surfaces for footers (piers, walls, etc.).

 Learn how to use the Generate Sloped Surface command to create proposed surfaces by 
intercepting existing or design surfaces.

 Learn how to profile excavation and backfill surfaces.

 Learn how to set the elevation of elements or features.

 Learn how to import MicroStation graphics into a surface.

 Learn how to create pier features and a pier surface for volume computations.

The following files are used in this lab:

 C:\Projects\12345\Bridge\Working \CU12345BRDG_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for interchange

 C:\Projects\12345\Design\InRoads\12345 SH119

 C:\Projects\12345\Design\InRoads\12345 SH119 SH52 Interchange.alg

 C:\Projects\12345\Bridge\Drawings\Reference_Files\12345BRDG_Model_D-16-DU.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl

Lab 7.1 - Open Project Data 

1. Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

2. Delete any MicroStation graphics currently in the design file.

3. Verify the correct XIN file is loaded.

4. Select File > Open from the InRoads menu.

5. Open C:\Projects\12345\Design\InRoads\12345 SH119 and 12345 SH119 SH52 
Interchange.alg. 

6. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.
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Lab 7.2 - Create an Excavation Surface for a Pier Footer

In this section, surfaces are created for the excavation and backfill for a pier footer for bridge 
D-16-DU. The primary commands used are Generate Sloped Surface and Generate 
Longitudinal Feature. For more information on either of these commands, please see the 
Surface Editing chapter of A Practical Guide for Using InRoads XM. 

In a later lab, these surfaces will be used to calculate volumes.

1. In MicroStation, select Settings > Level > Display.

2. Toggle View Index 1 on and all others off.

3. Toggle Show Level Name or Filters to Levels.

4. Highlight the 12345BRDG_Model_D-16-DU.dgn file.

Note: This is the reference file that was attached in Lab 2. If it is not listed in this dialog, 
re-attach the reference file now.
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5. Turn on the BRDG_Outline-Foundation-Footer level.
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6. Select MicroStation’s Copy tool.

7. Snap to a corner of the outline to choose it to copy.

8. Snap to the same corner to place it at the same location in the current working file.

9. In MicroStation, select File > Reference.

10. Highlight the 12345BRDG_Model_D-16-DU.dgn file and toggle the Display off.
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The new copy of the outline should still be showing in the current file.

Note: The outline is currently at elevation 0. Next, the outline must be moved to the 
appropriate elevation.

11. Select Surface > Design Surface > Set Elevation.

12. Make certain the current Locate Mode is Graphics. If not, toggle it on your Locks toolbar.

13. In the Set Elevation dialog box, set the Input Mode to Single.

14. Toggle off the Destination Level.

15. Key in 5152 for the Elevation.



Page 164 Colorado Department of Transportation

LAB 7 - Feature Based Modeling Bridge Essentials Using InRoads XM

16. <D> Apply.

17. <D> the outline.

18. <D> to Accept.

Note: The outline may disappear because elevation 5152 is not within your display 
depth. If it does, Fit your view with MicroStation.

19. Select MicroStation’s Move Parallel tool.

  

20. Toggle on Distance and key in 1.5.

21. Toggle on Make Copy.

22. <D> on the outline.

23. <D> to Accept on the outside of the footer outline.
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24. <R> to stop copying.

25. Select Surface > Design Surface > Generate Sloped Surface.

26. Verify that the current Locate Mode is Graphics. If not, toggle Locate Feature / Locate 
Graphics to Locate Graphics on the Locks toolbar.

27. Verify that Generate Graphics Only is toggled off.

28. Set the Intercept Surface to 12345 existing ground for interchange.

29. Key in 12345 excavation for pier footer as the Destination Surface.

30. Set the Cut Slope to 1:1.

Note: The ratio is automatically converted into a percentage.

31. Toggle on Triangulate Surface.

32. Toggle on Source and key in Excavation break.

33. Set the Style to Breakline.

34. Toggle on Catch Point and key in Excavation Cut.

35. Set the Style to D_Top-of-Cut.

36. Set the Point Type to Breakline.

37. <D> Apply.
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38. <D> on the outer pier outline.

39. <D> to Accept.

40. <R> for Entire (the entire element).

Important! If you <D> again instead of <R>, that location is the starting point for the 
slope and the excavation will not be completed around the pier.

41. Move your cursor to the outside until the temporary graphic looks like shown here, then 
<D> to Accept the location.

<R> out of the command.
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Note: The Generate Sloped Surface command is very useful for creating sloped surfaces 
from features or graphical elements that intercept other surfaces. The intercepts 
can be existing ground surfaces, design surfaces or even surfaces previously 
created with this command. 

42. Select Evaluation > Profile > Create Profile.

43. Toggle on 12345 existing ground for interchange, 12345 SH119 and 12345 excavation 
for pier footer.

44. Highlight 12345 excavation for pier footer and choose Properties.

45. Set the Profile Symbology to D_SURFACE_3.

46. <D> Apply, then Close.

47. Back on the Create Profile dialog box, select the Source branch
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48. Set Alignment to SH52-H

49. Select the Controls branch.

50. Set the Station Limits to 106+00 to 109+00.

51. <D> Apply.
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52. <D> a clear area in the design file for the location of the profile.

53. Window in to see the excavation surface.

54. Right-click on the 12345 excavation for pier footer surface in the Explorer part of the 
menu and choose Save.

Note: Verify the Active Surface is 12345 excavation for pier footer
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55. If the File name is blank, use the Active drop-down to again choose 12345excavation for 
pier footer and the name appears in the File name field as well.

56. Verify the Save In path is C:\Projects\12345\Bridge\InRoads.

57. <D> Save then Cancel.

Lab 7.3 - Create a Backfill surface for a Pier

Next, the surface for the backfill is created, using the same procedure.

1. Select Surface > Design Surface > Generate Sloped Surface if you previously 
closed it.

2. Verify that the current Locate Mode is Graphics. If not, toggle Locate Feature / Locate 
Graphics to Locate Graphics on the Locks toolbar.

3. Verify that Generate Graphics Only is toggled off.

4. Set the Intercept Surface to 12345 SH119.

5. Key in 12345 backfill for pier footer as the Destination Surface.

6. Set the Cut Slope to 1:1.

Note: The ratio is automatically converted into a percentage.

7. Toggle on Triangulate Surface.

8. Toggle on Source and key in Backfill break.

9. Set the Style to Breakline.

10. Toggle on Catch Point and key in Backfill.

11. Set the Style to D_Top-of-Fill.
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12. Set the Point Type to Breakline.

13. <D> Apply.

14. <D> on the outer pier outline.

15. <D> to Accept.

16. <R> for Entire (the entire element).

Important! If you <D> again instead of <R>, that location is the starting point for the 
slope and the backfill will not be completed around the pier.
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17. Move your cursor to the outside until the temporary graphic looks like shown here, then 
<D> to Accept the location.

18. <R>.

19. <D> Close on the Generate Sloped Surface dialog.

20. Right-click on the 12345 backfill for pier footer surface in the Explorer part of the menu 
and choose Save.

Note: Verify the Active Surface is 12345 backfill for pier footer

21. If the File name is blank, use the Active drop-down to again choose 12345 backfill for pier 
footer and the name appears in the File name field as well.
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22. Verify the Save In path is C:\Projects\12345\Design\InRoads.

23. <D> Save then Cancel.

24. Select Evaluation > Profile > Update Profile.

25. Verify the Profile Set is the one used in the previous section if you have more than one in 
your file. A box is drawn around the Profile Set listed.

26. Toggle Mode to Display Off.
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27. Highlight the 12345 excavation for pier footer.

28. <D> Apply.

Note: The excavation surface is no longer shown on the profile.

29. Toggle Mode to Display On.
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30. Highlight the 12345 backfill for pier footer.

31. <D> Apply.

Note: The backfill surface is now shown on the profile.

32. <D> Close on the Update Profile dialog.

Lab 7.4 - Create Pier Features

The footer and pier must be excluded from the backfill quantities. This can be accomplished by 
manually calculating the quantity and deducting it from what will be calculated from the 
surface as it exists now. Or, features may be added to the surface that take the footer and pier 
into account when InRoads computes the quantity. In the next series of steps, the second option 
is shown, creating four breaklines: bottom of footer, top of footer, bottom of pier, and top of 
pier. Since DTMs do not support overhangs or true verticals, the footer and pier are represented 
as ‘near’ verticals.
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1. Turn off the BRDG_Outline-Foundation-Footer level.

2. Delete all of the remaining plan graphics to make it easier to see the features as they are 
developed (do not delete the profile graphics).

3. Select Surface > View Surface > Features.

4. Set the Surface to 12345 backfill for pier footer.
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5. Highlight both features.

6. <D> Apply, then Close.
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7. Turn on the BRDG_Outline-Foundation-Footer level.

8. Window in to the corner of the footer.
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Note: This element represents the bottom of the footer. In the next series of steps, 
MicroStation is used to create 3 parallel copies of this element. 

9. Select MicroStation’s Move Parallel tool.

10. Toggle on Distance and key in 1.50.

11. Toggle on Make Copy.

12. <D> on the footer outline.

13. <D> to Accept inside the footer outline.

14. <R> to end the copy.

Note: This is the bottom of the pier.
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15. In the Move Parallel command, change the Distance to 0.01.

16. Make a copy of each line, to the inside.

Note: These lines represent the top of the footer and the top of pier.
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Note: There are now four concentric rectangles representing the footer and pier. In this 
case, one monolithic pier is being used; for multiple piers this procedure would be 
repeated for each.

Each of these MicroStation shapes must now be made into a feature, then moved to the correct 
elevation.

17. Select File > Import > Surface.

18. Select the From Graphics tab.

19. Set the Surface to 12345 backfill for pier footer.

20. Set Load From to Single Element.

21. Set Elevations to Use Element Elevations.

Note: All of these shapes are at the same elevations. After importing them, the proper 
elevations will be set.

22. Key in Bottom of footer for the Seed Name.

23. Set the Feature Style to Breakline.

24. Set the Point Type to Breakline.
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25. Toggle on Point Density Interval and key in 10.00 for the value.

26. <D> Apply.

27. <D> on the bottom of footer line.

28. <D> to Accept.
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29. Key in Top of footer for the Seed Name

30. <D> Apply.

31. <D> on the top of footer line.

32. <D> to Accept.
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33. Key in Bottom of pier for the Seed Name.

34. <D> Apply.

35. <D> on the bottom of pier line.

36. <D> to Accept.
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37. Key in Top of pier for the Seed Name.

38. <D> Apply.

39. <D> on the top of pier line.

40. <D> to Accept.

41. Select Surface > Design Surface > Set Elevation.
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42. If the current Locate Mode is not set to Features, toggle Locate Graphics/Locate Features 
on the locks toolbar to Locate Features.

Note: This command can set the elevation of either graphical elements or features. Since 
the shapes have already been loaded into the surface, they are already features.

43. Highlight the Bottom of footer feature.

44. Key in an Elevation of 5152.

45. <D> Apply.

46. Highlight the Top of footer feature.

47. Key in an Elevation of 5153.5.

48. <D> Apply.

49. Highlight the Bottom of pier feature.

50. Leave the Elevation set to 5153.5.

51. <D> Apply.

52. Highlight the Top of pier feature.

53. Key in an Elevation of 5180.

54. <D> Apply then Close.
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Note: Alternately, you can set the MicroStation graphics to the correct elevation using the 
Set Elevation command prior to importing the graphics as features into 
InRoads.The Set Elevation command works on either graphics or features based 
on the Locate mode.

55. Select Surface > Triangulate Surface.

56. Verify the Surface is 12345 backfill for pier.

57. <D> Apply then Close.

Note: This has basically created a footer and pier sitting in a trough. The triangles and/or 
contours may be displayed to review the surface if desired. This image shows a 
rotated view of the triangles that has been shaded using MicroStation’s Utilities > 
Render > Smooth.
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58. Save the 12345 backfill for pier footer surface to the directory 
C:\Projects\12345\Bridge\InRoads.

59. Window in to the previously displayed profile.

60. Select Evaluation > Profile > Update Profile.

Note: If there is more than one profile in the design file, make certain the correct Profile 
Set is listed.

61. Set the Mode to Refresh.

62. Highlight the 12345 backfill for pier surface.

63. <D> Apply, then Close

Note: This surface, along with the excavation surface will be used in a later lab to 
calculate volumes.
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Chapter Summary:

 The Generate Sloped Surface command is very useful for creating sloped surfaces from 
features or graphical elements that intercept other surfaces. 

 The intercepts can be existing ground surfaces, design surfaces or even surfaces previously 
created with this command.

 Features can be added to a proposed surface representing footers, piers, walls, etc.), which 
can be used for volume computations.

 MicroStation elements or surface features can be placed at the correct elevation using the 
Set Elevation command in InRoads.

 MicroStation elements can be imported as surface features using the Import Surface 
command in InRoads; if they are not at the correct elevation, the elevation can be set using 
the InRoads Set Elevation command.
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In this lab you will evaluate the excavation and backfill surfaces you created in the previous lab by computing 
cut and fill volumes. InRoads provides different methods for computing volumes. In this lab, you will work 
with three different methods.

Chapter Objectives:

 Learn how to compute Triangle volumes.

 Learn how to set default XSL style sheets to format InRoads reports.

 Learn how to compute Grid volumes as a check for the triangle volumes.

 Learn how the grid interval affects grid volume results.

 Learn how to compute End Area Volumes from cross section graphics.

The following files are used in this lab:

 C:\Projects\12345\Bridge\Working \CU12345BRDG_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345 SH119

 C:\Projects\12345\Design\InRoads\12345 SH119 SH52 Interchange.alg

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for interchange

Note: The following files were created in the previous lab “Feature Based Modeling.” If 
these files don’t exist in the location identified below then they can also be copied from 
the directory C:\Projects\12345\Miscellaneous\BRDG-08

 C:\Projects\12345\Bridge\InRoads\12345 backfill for pier footer

 C:\Projects\12345\Bridge\InRoads\ 12345 excavation for pier footer

Lab 8.1 - Open Data Files

1. Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

2. Verify the correct XIN file is loaded.

3. Select File > Open from the InRoads menu.

4. Open C:\Projects\12345\Design\InRoads\12345 SH119, 12345 backfill for pier footer, 
12345 excavation for pier footer, and 12345 SH119 SH52 interchange.alg. 

5. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.
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Lab 8.2 - Compute the Pier Excavation Volume

The triangle is the most accurate method of computing volumes in InRoads. It compares 
existing and design surfaces to compute cut, fill and net volume between the surfaces. Since 
you have created an excavation surface for the pier footer, you can use the triangle method to 
compare this surface to the existing ground surface and compute the amount of cut needed for 
the excavation of the footer. 

The grid method provides a quick check against other volume methods to ensure volume 
accuracy. The smaller you set the grid interval, the more accurate the volume results. You’ll use 
the grid method to check your triangle volume.

1. Delete any MicroStation graphics currently in the design file.

2. Select Evaluation > Volumes > Triangle Volume.

3. Set Mode to Entire Surface.

Note: You have the option to compute volumes on a portion of the surface using a 
MicroStation fence or shape. Areas outside of the smaller of the two surfaces are 
ignored.

4. Set Original Surface to 12345 existing ground for interchange.

5. Set Design Surface to 12345 excavation for pier footer.

Note: Cut and Fill Factors are swell and shrinkage factors that you can apply to the volumes 
depending on the classification of material.

6. <D> Add.

7. <D> Apply.
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8. If you receive a warning message that a default style sheet has not been selected for the 
Triangle Volume report, select OK after receiving this message. You will set a default style 
sheet in this lab.

Note: The Bentley InRoads Report Browser automatically starts, allowing you to select 
a style sheet (i.e. a report template) to format the report. All available report style 
sheets are organized in folders and listed on the left-hand side of the report 
browser. The right-hand side shows the report XML data.

9. In the Report Browser, select the Evaluation folder.
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10. Select the TriangleVolumes.xsl style sheet.

Note: The XML data is formatted using this report style sheet.

11. In the Report Browser window, select Tools > Format Options.

12. In the Format Options dialog box, set Cubic Units to 0.12 precision.

13. <D> Close.
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Note: The report automatically updates with the new formatting.

14. Record your results:

Cut:  __________________ cu yd.

Note: Any fill that is listed should be negligible.

15. Right-click on the TriangleVolumes.xsl style sheet and select Set Default Triangle 
Volume.

Note: The next time you run the Triangle Volume command, InRoads will automatically 
use this style sheet without you having to select it. You can always select another 
style sheet from the Report Browser to change the report formatting at any time.

16. Close the Triangle Volume Report by select the X in the upper right corner of the Report 
Browser.

17. In the Triangle Volume command, <D> Close.

Next, you will check your triangle volumes by computing grid volumes.

18. Select Evaluation > Volumes > Grid Volume.

19. Set Original Surface to 12345 existing ground for interchange.

20. Set Design Surface to 12345 excavation for pier footer.
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21. For Grid Interval Key in 2.0.

22. <D> Apply.

Note: For this command, the volume results appear in the dialog box instead of a report.

23. Record your results in the table below.

24. For Grid Interval Key in 1.0.

25. <D> Apply.

26. Record your results in the table below.

27. For Grid Interval Key in 0.5.

28. <D> Apply.

29. Record your results in the table below.

Note: As you decrease the size of the grid interval, your grid volume should approach the 
triangle volume results with increased accuracy. If your 0.5 grid interval volume 
does not compare favorably to your triangle volume, see your instructor.

30. <D> Close on the Grid Volume dialog box.

Lab 8.3 - Compute the Pier Backfill Volume

In this section, you will use the same volume commands to compute your backfill quantities.

1. Select Evaluation > Volumes > Triangle Volume.

2. Set Mode to Entire Surface.

3. Set Original Surface to 12345 backfill for pier footer.

4. Set Design Surface to 12345 SH119.

Interval = 2.0 Interval = 1.0 Interval = 0.5

Cut Volume cu yd. cu yd. cu yd.
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Note: The backfill surface is set as the original surface in order for the results to display 
as a “fill” volume.

5. <D> Add.

6. <D> Apply.

Note: Since you previously selected a default style sheet for this command, you do not 
get the warning message and the report is automatically generated using the 
TriangleVolumes.xsl style sheet.

7. Record your results:

Fill:  __________________ cu yd.

8. Close the Triangle Volume Report by select the X in the upper right corner of the Report 
Browser.

9. In the Triangle Volume dialog box, <D> Close.

Next, you will check your triangle volumes by computing grid volumes.
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10. Select Evaluation > Volumes > Grid Volume.

11. Set Original Surface to 12345 backfill for pier footer.

12. Set Design Surface to 12345 SH119.

13. For Grid Interval key in 0.25.

Note: An acceptable grid interval depends on the size of your surfaces, the variation and 
relief in your surfaces, whether or not your surfaces were surveyed, how they were 
surveyed, etc. You may need to try a few grid intervals based on these variables 
before converging on a good net number. For our two surfaces, an interval of 0.25 
should provide accurate results.

14. <D> Apply.

15. Record your results:

Fill:  __________________ cu yd.

Note: Your grid volume results should compare favorably to your triangle volume 
results. If not, see your instructor.

Lab 8.4 - Compute End Area Volumes

You may also want to use the End Area Volumes command as another check of your triangle 
volumes or if your contractor requires end area volumes for his work. The End Area method 
requires that you have a set of cross sections cut showing the surfaces from which you want to 
compute volumes. The volumes are calculated from the cross section graphics instead of 
comparing DTM data, as with the Triangle and Grid methods. 

In this section you will compute the end area volume for your pier footer backfill. In order to do 
so, you must first cut a set of cross sections along the pier. You can either cut cross sections on 
a graphic or an alignment, so you will copy the pier centerline element from the reference file 
into the active bridge model file.
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1. If your reference file is not turned on, select File > Reference and toggle on the display 
of the 12345BRDG_Model_D-16-DU file.

2. Window in on the pier centerline.
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3. Select MicroStation’s Copy command.

4. Snap to the end of the line to identify it to copy.
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5. Snap to the same end to copy it to the active file in the exact same location.

6. Turn off the display of the reference file.

Note: Only the pier centerline element is now shown in the view.

7. Before cutting cross sections, set the text scale factor to be used for the cross section text. 
Select Tools > Options.

8. Select the Factors tab.

9. Unlock the three factors and for Text Scale Factor key in 40.
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10. <D> Apply, then <D> Close.

11. Select Evaluation > Cross Section > Create Cross Section.

12. Select Preferences and select the Stacked 20 per column preference.

13. <D> Load, then <D> Close.

14. On the General branch, toggle off the 12345 excavation for pier footer and Default 
surfaces. Make sure all other surfaces are toggled on.

15. For Set Name, key in Pier.

16. For Interval, key in 10.
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17. On the Source branch, toggle on Graphics and in the Alignment field, key in Pier 
centerline.

Note: The End Area Volume command requires an alignment in order to compute 
volumes. Specifying a name here will automatically create an alignment along the 
pier centerline element.

18. <D> Apply.

19. <D> the pier centerline.

20. <D> to Accept.

21. <D> in a clear area for the lower left corner of the cross section set.
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22. Window in on one of the cross sections to see the three surfaces.

       

Note: Since you added the pier features to the backfill surface in the last lab, the pier and 
footer will be excluded from the backfill quantities, but the area of the pier that 
falls above the SH119 surface will be shown as cut and should be ignored.
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23. Select the InRoads Explorer Geometry tab and note that you now have an active Pier 
centerline alignment created by the Cross Section command.

You’re now ready to compute the end area volumes from the cross section graphics and new 
pier centerline alignment.

24. Select Evaluation > Volumes > End Area Volumes.

25. On the General branch, toggle off the 12345 existing ground for interchange surface and 
make sure the 12345 SH119 and 12345 backfill for pier footer surfaces are toggled on.

26. Set Cross Section Set to Pier.

27. Set Imperial Units to Cubic Yards.

28. Toggle on Create XML Report.

29. <D> Apply.

30. If you receive the Report Browser warning message, select OK since the End Area 
Volume command does not yet have a default style sheet set.
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31. In the Report Browser, select the EndAreaVolume.xsl style sheet under the Evaluation 
folder to format the report.

Note: If your report lists cubic feet, select Tools > Format options and toggle on 
Convert to Cubic Yards.

32. Read your fill volume from the Grand Total line of the report and record your results:

Fill:  __________________ cu yd.

Note: The End Area Volume results should compare favorably to your Triangle Volume 
results for backfill (within a few cubic yards). If not, see your instructor.

33. Close the End Area Volume report (click the X in the upper right corner).

34. <D> Close on the End Area Volume dialog box.

Chapter Summary:

 Triangle volumes provide accurate cut and fill quantities.

 The Triangle Volumes command compares surfaces to compute volumes.

 The Grid method is useful to check triangle volumes.

 The accuracy of the Grid Volumes is controlled by the grid interval.

 Many factors affect the selection of an appropriate grid interval. Select an interval that 
converges on a net number favorable to the triangle results. 

 The smaller the grid interval, the more accurate the grid volumes.

 End Area Volumes are computed from cross section graphics instead of comparing DTMs.

 The End Area Volume results should compare favorably to the Triangle volume results.
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Chapter Objectives:



Lab 9.1 - Under Development
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