Chapter 2 - Getting Started in MicroStation

Design File Basics

This Section identifies the basics of working in a MicroStation XM design file. This includes mouse
mechanics, opening and navigating in a design file, toolbars, views, snaps, and how to get help.

Chapter Objectives:
e Identify mouse settings and mouse mechanics
e Open an existing MicroStation design file
e (reate a new MicroStation design file
e Navigate within a MicroStation design file
e Interface introduction

e How to get help

Mouse Mechanics

There are three types of mouse “points” you can execute in MicroStation. These points
correspond to the different buttons on the mouse.

Data <D>

Reset <R>

Data point <D> - used to select tools, pull down menus, etc., identify coordinate locations,
place and manipulate elements, or confirm actions before they take place. The left button is
the default data button. Used when prompted to Accept.

Reset <R> - releases the current operation or rejects a highlighted element. The right button
is the default reset button. Used when prompted to Reject.

Tentative <D><R> - used to temporarily locate a point in space or an element. Using the
Data point and Reset buttons simultaneously is the default tentative mouse command.

Using the Mouse
Click - tap the mouse button once.
Double click - tap the mouse button twice quickly.

Snap - locate an existing point on an element by using tentative <D><R>, then a data
point <D> to accept.
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Wheel Mouse Settings

MicroStation XM supports wheel mice. You can set your middle wheel to perform several
different view control options including zoom in/out, pan radial, pan with zoom, etc. \

There are CDOT default settings for the Wheel Mouse.

Pan - this works the same way as most software packages. Once you have clicked the
middle button, you get the little hand symbol and while you hold down on the left button
the view can be moved or pulled around.

Note: This WILL NOT WORK if you override the tentative button settings.

Double Click - this will expand the viewing area to include all elements within the design
file that are currently turned on.

Roll - by rolling the mouse ball, the user can Zoom In and Zoom Out of the current view.
Alt + Roll - used to Pan Left and Pan Right.

Default configuration settings can be changed by selecting Workspace> Preferences >
Mouse Wheel.

Starting MicroStation

To start MicroStation on the Windows platform:

e From the Windows Start Button, select Start > All Programs > Bentley >
MicroStation V8 XM > MicroStation V8 XM Edition.

or
e Double-click on the MicroStation V8 XM icon located on your desktop.

MicroStation
VB XM
Edition

MicroStation will start and the MicroStation Manager dialog box will appear on your screen.
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The MicroStation Manager

The MicroStation Manager is your file management interface to MicroStation.

M MicroStation Manager - C:\Projects\12345\ ==
Look in: 12345 - @O “j =W
i Name . Size Date modified =
o Bridge 5/13/2009 3:42 PM
Recenk Flaces Construction 5/13/2002 3:42 PM
! Censultants 5/13/2009 3:42 PM
- Design 5/13/2009 3:42 PM |
Desktop Hydraulics 5/13/2009 3:42 PM F
B Landscape_Environme... 5/13/2009 3:42 PM
&l Materials_Geotechnical 5/13/2009 342 PM
CDOT User Miscellanecus 5/13/2009 3:42 PM
Planning 5/13/2009 3:42 PM
-;‘_., Plot_Sets 5/13/2009 3:42 PM
Computer Project_Configuration 5/13/2009 3:42 PM
¥ Project_Manager 5/13/2009 3:42 PM
L' Redline 5/13/2009 3:42 PM -
-
Metwork  Fga name: - [ Open User: |CDOT User -
Fescits:  (CADen Caonmar ) S = N —
Open as read-only t Intedacs: [COOT . |

By default, a MicroStation design file has an extension of .dgn. “Design file” is a generic term
used to describe all MicroStation files, regardless of their use - design, drafting, etc. In addition
to MicroStation XM DGN files, you can also open previous version MicroStation files and
AutoCAD files (.dwg or .dxf). This is designated under List Files of Type drop down.

Use the MicroStation Manager icons to move within folders, create a new folder, change the
default MicroStation Manager look, create a new file, compress a file, and see past directory

history.
Up One New Folder
Level x [ +— File History
e Frmr
t_Dlrectory
Folder Visited

In the Workspace category, select

User: Your login name

Project: Your project name - this is the same as your JPC number

Interface: CDOT for the customized CDOT interface settings
For Training purposes your workspace settings will be:

User: CDOT User

Project: 12345 (the JPC for this class)

Interface: cDOT
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Note: A more detailed discussion of the CDOT Workspace, which is set with the Project
and Interface options, will take place in the “Creating a CDOT Project” chapter.

Opening a MicroStation Design File

To open a MicroStation design file:

e Set Look in: to the drive containing your file

e Navigate to the correct directory

Set Files of type to All files (*.*) (or to the type of file you wish to open)
e Click the file name to highlight the file

e C(Click the Open button to open file

Note: MicroStation design files have a default extension of .dgn, but can have any
extension.

The CDOT Default MicroStation Interface

File Name
T Pull down Menus —
" b D e | atet = B-0- K- 030 - QT - R BF =LA
e P — e ‘*/’ o
\‘: P ; Stand%do;b;:trtgt();l;ii E—)dF;nmary cDoT \
r-a0 \ . Misc Tools Task /%
* —Tool Settings Navigation ;

‘woowe.  CDOT Menu
Main Toolbar :

Menu

View Toggles
Drawing Key-in

l Scale / Browse
AR G .
(-] - ] &

Q-0 - ~icicooroma =] T fi]2a]d]slelr]s) S

B Subcaon iy s 4 5806 o0 Wishorg L & Dwina o

Select 'I:ooI!Prompts InformationIA Snap Mode jJ }

View controls —‘

F Snap Toolbar

r
s Q- F 1=

Messages Locks
Active Level
Selection Set
Fence Mode
Workmode
Design change indicator-
Design History -
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MicroStation Interface Sections

Pull down menus

F..j C\Projects'12345\Design'\Drawings\Reference_Files\12345DE5_Model.dgn (3D - V& DGN) - Micro5t
File Edit Element | Settings | Tools Utilities Workspace Window Help CDOT Help

ﬂu_j - G F“:;j v Tool Settings ? )F'{none:' ;ﬁ

Manage

2y View1
AccuDraw
Color Table...
Color Books...

Database 3

Design File...

Drawing Scale
Level
Locks

Rendering

o0 |H|
L

Ay ——

f':?’ EI?’ View Attributes  Ctrl+B

Ll -

- v v v

Snaps

¢ Pull down menus are used to access MicroStation toolbars, settings and dialog boxes.
¢ An arrow next to a pull-down command indicates sub-menu options.

¢ ... Indicates a dialog box to open.

Toolbars

Linear Elermnents =]

8/ AMNS

¢ MicroStation’s tools for creating and manipulating your design elements are organized
into logical groupings called toolbars.

Each tool is represented by an icon on its toolbar.

Toolbars can be opened, closed and moved around the screen like dialog boxes, views
and the command window.

¢ Toolbars can be “docked”,

ﬂ C\Projects\12345 Designt\Drawings\Reference_Files\12345DES_Model.dgn (3D - V& DGM] - MicroStation V8 XM Edition (1)

File Edit Element Settings Tools Utilities Workspace Window Help CDOT Help
Nl e b 2B v v @ ? [ pone~ DESBKEPATH

= 3oy A B
=z N P Lo

Docked Toolbar
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¢ Or “floated” within the drawing workspace.

“ C\Projects'12345\Design'\ Drawings'\Reference_Files\12345DE5_Model.dgn (3D - V8 DGN) - MicroStation
File Edit Element Settings Tools Utilities Workspace Window Help CDOT Help

2 B8] b B B o | @] 2 i Lo
ME H View1-Top

k Misc. Tools E] Fl t T |b

) . _ @ . R St

+ @:;ZM-"_‘"L oating looibar
7 .

¢ Most toolbars can be accessed from the menu or from the Main toolbar.

The CDOT Main Toolbar

CDOT START

M Element Selection [ = | @ [ Menu InRoads
E (m = B Bl
Ble-ae R
Linear Elements =]
v
CAAMNS H
Points fx] o a
e o B olygons z
+ 4 I L m o
Ox v e
Patterns £z -
¥ - Ifipses |2
“i 4 N M) LD 5
ABAAIED -
Arcs (=] Tet =
Do m LR

BABC 7 A f 1, MA Al 4
A ALV aie At AF R Mt

Tags

Bo 3 7 3% B

Cells {=]

S ¥y AL EH

Groups (=]

de afNBHEO

Dimensioning (=]

1 M1 =2 o 0 )

AN

Measure fx] Manipulate £z
Change Attributes Bl Delete Medify B
==K efel Element B AP P = S e Tl

¢ The CDOT Main toolbar opens automatically when you start MicroStation. If you close
the CDOT Main toolbar and want to re-open it, select Tools > Tool Boxes from the
command window, or type CTRL T.

This opens up Tool Boxes. Tool Boxes is where you access all toolbars.
Select CDOT Main - Custom to reopen the CDOT Main toolbar.
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Tool Settings

i 5] ﬁ Place Smartline | = || & || 2
ad . = ? Segment Type: [Lines A
ag A AN =2 Seqg ¥p
/ -~ /\ e } o Vertex Type: | Shamp hd

= Rounding Radius: | 0.833
Place SmartLine ] doin Bemerts =

Tool Settings Box

¢ Many tools have parameters or settings associated with them, which are shown in the
Tool Settings dialog box. Each time you select a new drawing tool, the optional
settings will appear in the Tool Settings box.

The Primary Toolbar

Primary Tools =]

B-0-8-@-2-8-0i5-R

¢ The Primary toolbar contains commonly used MicroStation tools.
¢ This is on toolbar you’ll frequently use, so you will probably want to open and dock it.

¢ Select Tools > Primary to toggle on the Primary toolbar.

The Key-in Browser Box

ﬁl(ey-in 55
| HER-

¢ Many MicroStation commands can be accomplished by keying in the command text
(e.g. Place Line).

¢ Key-ins can also be used to input data (e.g. XY=<x,y,z> to locate a coordinate).
Note: Key-ins are not case sensitive.

¢ This is another toolbar you’ll frequently use. Select Utilities > Key-in to open, then
dock the box.

¢ When you’re ready to key in a command, set the focus in the Key-in box by data
pointing in it.

¢ After you key in the command, use the <Enter> or <Tab> key to activate the
command.
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Views
P T Prepecti 15\ Desigri D  Files\ 1234505 h 0 (30 - V& DGH) - MicioStation VB XM Edition (1) =R
Fde Edt Ewment Settings Tooh Ublites Werkspace Window Help CDOT Help

DB s DB e« @ 2 e e | —— @ -0 -EE 2R -OUE-R BT TS A
rﬂ\ﬁwl-l’w &l | M w2 - Top =regl |
+4 { T [+
7 m f
4.0 g
e Ao
Ba A, i
& se 1
e 1| 4
@3 L]
x & g
H
4
]
2
4
AR OWES - [BE ARG ld

M View3 - Top e [EE ] || M Vewd - Top ERCRE~]

3
i ; 1 &
g St el ="
L1 L ] - hY

AW SR B[] R b B R W e AR UEES R ER et E . . E

Q- -Eooam - - FIE Q- e @2 xm L5

The area where graphics are placed is called a view.
Up to eight view windows can be opened.

Open and close views from Window > Views or the Views dialog box.

* & & o

You can set different view perspectives (top, front, rotated, etc.).

“ C:\Projects\12345\Design’\Drawings'\Reference_Files\123450E5_Model.dgn (3D - V8 DGM) - MicroStation V8 XM Edition (
* File Edit Element Settings Tools Utilities Workspace | Window §Help CDOT Help

N E b8 e

M View1 - Top Tile
Arrange

’7 Scroll Bars

Task Navigation in Views
’7 View ToolBox

Dialog

. [ I Views H
[ L =

v
v
v
v
v

1 Viewl - Top
2 View 2 - Top
3 View 3 - Top
4 View 4 - Top

5 Element Info

(R I = L B R VR L

m

6 Element Selection
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You can also select Window > Views > Dialog to open the View Groups toolbar where
you can quickly turn views on or off.

‘Eﬁv‘—%@l*%um&w'é Bl G| & 7% % View
3 - O -\ ~[@coorodan | B | [i[2]3]a|5]s]7]s|[f+—— Group
Element Selection > Identify element to add to sat EL TOOI bar

¢ You can use the control buttons in the upper right-hand corner to maximize, minimize
or close a view.

Status Bar
The Status Bar is MicroStation’s command center composed of the following areas (left to
right):

Place SmartLine > Enter next vertex or reset to complete Angle = 362527 35" od | |DRAFT_WT-4

¢ Select Tool - displays the name of the active drawing tool.

¢ Prompt - displays the next user operation needed by MicroStation.

Place SmartLine > Enter next vertex or reset to complete

Select

Prompt
Tool P

¢ Information and Messages - displays current element parameter settings, error
messages, etc. A data point <D> in this area activates the Message Center.

Place SmartLine > Enter next vertex or reset to complete Angle = 362527 35" od | |DRAFT_WT-4

Angle = 36°29°27.35"

¢ Snap Mode - displays the active snap mode used in conjunction with a tentative point
or AccuSnap.

¢ Locks - displays a list of locks that you can toggle on/off.

¢ Active Level - displays the current level on which graphics are placed. A data point
<D> in this area activates the Level Manager.

Place SmartLine > Enter next vertex or reset to complete Angle = 362527 35" od | |DRAFT_WT-4

Locks

¢

o4 |@ |DRAFT_WT-4

oo

Snap Active
Mode Level
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¢ Select Set - displays number of elements in the current selection set. A data point <D>
in this area activates selection set commands.

¢ Fence Mode - displays the active fence mode setting. A data point <D> in this area
allows you to change the active fence.

¢ Workmode - a data point <D> in this area displays the current Workmode - DGN, V7,
or DWG.

A Current Workmode: DGN =] & ==

*You are in DGN Workmode.
The full functionality of MicroStation V8 is available,
including:

- DWG referencing and editing

- AccuSnap and Autolocate

- Visual Basic for Applications

- Design History

- View Volumes

- Level Fitters

- DGN Libraries

- Associations across references

¢ Changes Indicator - if a diskette icon aj is shown, the file has been modified since

G‘X” B

opened. If the icon shows a , it means the file is read only.

¢ Design History - if the icon is dimmed = , Design History is not initialized. If Design

History is initialized without committed changes, the icon will include a pencil u| .
¢ Dialog with Focus - indicates what is controlling the input focus. These include Home

| Tool Settings L 2 Key-in =, AccuDraw 2 or nothing.

¢ Digital Rights Status - File is not protected or signed.

a |DRAFT_WT-4 I k :3 el ad @ I
X 3 e a \
A
Selection Set
Fence Mode
Workmode

Changes Indicator
Design History
Dialog with Focus
Digital Rights Status

Many of these concepts will be covered in complementary modules.
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Chapter 2 - Getting Started in MicroStation

Show/Hide toolbar options

You can select which tools you want to include on any toolbar. This helps streamline your
toolbars for the way you work and lets you customize your MicroStation setup.

Primary Tools
B-0-8-8-2-8-Qu
v

Models

"R

=

References
Raster Manager
Level Manager
Level Display
Cells

AR NN

Auxiliary Coordinates
Element Information
Toggle AccuDraw
Key-in

PopSet

AR SN

Show All
List...

To show/hide tools, right click on any toolbar and toggle the tools on/off as desired. The
changes are stored in your MicroStation Workspace.

Controlling the mouse

# Button Assignments: ...\Users\CDOT User\CDOTButtonMenu.btnmenu E3
File
Buttons
Mol DA [0 shit
B Data
Button: Action:
Shift+Data pan scroll
Alt+Data match attibutes fromeursor
Cir+Reset inputmanager menu main
Cirl+5hift+Reset inputmanager cumenttask
Alt+Reset mdl keyin elementinfo element quickinfo fromcursor
¥Button 1 pan view

By default, the left mouse button is the Data button, the right is the Reset and the left and

right together is the Tentative.

Note: The middle button has been set to be the scroll wheel by default.

You can change these button assignments by selecting Workspace > Button

Assignments.

Colorado Department of Transportation

Page 25



Chapter 2 - Getting Started in MicroStation A Practical Guide for Using MicroStation XM

View Control toolbar

The View Control toolbar is located by default in the lower-left corner of the
MicroStation interface. The horizontal and vertical scroll bars also help you move around
in the view. To use the View Control toolbar and scroll bars, turn on the options under
Workspace > Preferences > View Options. To show the scroll bars, turn on Scroll
Bars on View Windows. To show the view toolbox settings, turn on Show View
Toolbox and set the location from the pull down menu.

By AQRRALAIEAINYVYR EE R YVEB2EB20R %G

Use the following View Control tools as follows:

¢ View Attributes - to set view attribute settings.

By LAIEAIANYVYR EE G VEB2EB20R %G

¢ Update View - to update a view (refresh or redraw).

o -ERROmm VR EEEvEs B w0 %G
¢ Zoom In - to increase the magnification of a view by Zoom factor.

= & =FEE RN RS FC ET e L
¢ Zoom Out - to decrease the magnification of a view by Zoom factor.

=N Q SR N EFEN T FUEY e

¢ Window Area - to increase the magnification of a view by drawing a “box” around the
area you want to see close up.

RIXX = FEE RN S FC EY e L
¢ Fit View - to show all displayable elements in a view.

- AQalE N SE O EVELB WL G
¢ Rotate View - to rotate the view (top, front, etc.)

BARQUAEP VYR LD HFVE2E2 W0 %@

¢ Pan View - to move around in the view (up, down, left, right, etc.)

SREEXI= B N RS FC E e L
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¢ Walk - to interactively walk through a 3D model.

By ARRLAEMAUIGR DR R VEB2EB2WR %G

¢ Fly - to interactively fly through a 3D model.

@-A@qumaﬂqgaauﬁv@g@zm@a%a

¢ Navigate View - to interactively navigate a 3D view.

By AR LUAaIEAIJINVMRIZL G vEB2B2wWd %G

¢ View Previous - to step back through view operations.
BrAQUumEsNvRERlEhEveEsB 2w %% G
¢ View Next - to step ahead through view operations.

GrdRumEsNvReelivasBwd s

¢ Copy View - to copy the contents from one view to another.

By ARQRLAIEAIANYVYR EEIFAVE2B 2R % G

¢ Change View Perspective - to change the Perspective Angle.

@-A@quma»w&m@uﬁﬁég@zm@a%a

¢ Set Display Depth - to set the Display Depth of a view.

SMEEFEENRNCEEE E BT L

¢ Set Active Depth - to set the Active Depth of a view.

2 WP % &

@~ AQRUmES N YRSy H:]E

¢ Show Display Depth - to see the Display Depth of the active view.

By AQRRLAIEAINYVYR DL FVEAER 8B % &

¢ Show Active Depth - to view the Active Depth of the view.

@vA@QU@@»w@m@uﬁwgngm@aaa

¢ Camera Settings - to adjust the Camera in a 3D view.

By AQRRALAIEAINYVYR EE RFVEA B % &
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¢ Render - to Render the contents within the active view.

B~ [ARQQ_OmEANYR G ﬁiﬁ,@ﬁ@ﬂmﬁ’ 9 @

¢ View Display Mode - to set the Display Mode.

S E=FEEN RN EEEN BB e 3
¢ Clip Volume - to apply Clip Volume to a view.
B AQRQUMEANNYRBELHFVEA D w0 s%s

¢ Clip Mask - to apply Clip Mask to a view.

&)

By AQRQRALAEIANYVYR EBDRATVTEAB =2 WD %YE

You can set your middle wheel to perform several different view control options including
zoom in/out, pan radial, pan with zoom, etc. These options are set under Workspace >
Preferences > Mouse Wheel.

# Preferences [CDOT User] T
Category Mame for preferences | Default Preferences

Datab

Inp:t ase Set Mouse Wheel Preferences.
| Wheel: |Zoom In/Out ] 0K
Mouse Wheel Ctrl =+ Wheel: [Pan With Zoom b ] -

peration Shift + Wheel: |Pan With Zoom b
Position Mapping = ]
Alt + Wheel: [Pan Left/Right 7]

Raster Manager

Reference -Ddauhs
Spelling Zoom In/Out Ratio: | 2.000 -

Tags Navigate Distance (Cursor/Wheel): | 3 %

Task Mavigation . . . X -
Text Mavigate Distance (Mouse): | 10 L

View Options

Focus item Description
For more options, click on the category list at left.

Setting Views for dual monitors

The default CDOT MicroStation workspace is set up to recognize dual monitor machines.
However, in case these settings are changed, follow the steps below to reset this feature.

o  Start MicroStation
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o Select Workspace > Preferences > Operation and toggle on Open Two
Application Windows.

)‘ Preferences [CDOT User] T
Category Mame for preferences | Default Preferences
Datab
Inp:t ase Set Operational Preferences.
Look and Feel | Open Two Application Windows 0K
w Save Settings on Exit I—I
[ EzElL 7] Automatically Save Design Ch " Cancal |
R omatically Save .emgn anges ]
| Compress File On Exit
Raster Manager
Reference Enterinto Untitled Design
Spelling /| Display Broken Associations with Differert Symbology
Tags o V| Beset Aborts Fence Operations
E;k Navigation V| Level Lock Applies for Fence Operations
\iew Options /| Optimized Fence Clipping
/| Display Active Level in All Views

Resource Cache: | 1024
Fort Cache: | 256

Focus item Description
For more options, click on the category list at left.

o Select File > Save Settings
o Exit, then restart MicroStation

When MicroStation starts this time, it will open two different windows.

)‘_ C:\Projects\12345 Design'\Drawings\Reference_Files\12345DE5_Model.dgn (3D - VB DGN) - MicroStation V8 XM Editio
)‘ C\Projects\12345 Designt\Drawings\Reference_Files\12345DES_Model.dgn (3D - V8 DGN) - MicroStation VB XM Editio

You can drag one window to the second monitor. (Click on the title bar and drag the
window - don’t stretch it). When you maximize the window, it will fill the screen, but
remain on the monitor where you placed it rather than trying to span the monitors. In
MicroStation, Views 1-4 open in application window 1, while Views 5-8 open in
application window 2.

You can drag most MicroStation windows from one monitor to the other, but there are
some that will not allow dragging. If you run into one, pick the Bentley logo in the upper
left corner and choose Change Screen to move the dialog box or menu to the other screen.

M View5 - Top

I Change Screen

e

—  Minimize

o Maximize
x Close Alt+F4

View Attributes
Level Display

View Save/Recall
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