Chapter 6 - Creating Your Design Graphics

In this Chapter you will learn how to use the CDOT Menu to set standards and place simple graphics. You will
also learn how to use precision drawing techniques to locate your graphics.

The CDOT Menu

The customized CDOT menu provides access to tools and applications intended to provide the
user a simple, efficient method to apply CDOT’s CADD standards to every project. These
menus direct MicroStation to place elements on discipline-defined levels for drawing
consistency.

Note: Since the CDOT Menu automatically selects the correct level for element placement
across disciplines, you must have selected the xxxMulti-Discipline group from the
Select Group Environment program.

Opening the Menu

After starting MicroStation, select the CDOT icon from MicroStation’s Main toolbar to open
the CDOT Menu. You can hover over the icon to verify the CDOT configuration release.
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Parts of the Menu
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Drop-down menus

Use the drop-down menus to make the following selections:

Group Display

Toggle on your Group to display Explorer menu selections for placing graphics. In the
Explorer menu tree some groups like Traffic ITS have “children” options that can be
expanded with the “+” symbol. Drafting is a generic group (i.e. it’s used by all groups) for
placing general text, dimensions, borders, etc. There is also an option on this menu to

select/deselect all groups.

&2 CDOT Menu
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Select All
Deselect All

CDOT Tools

The CDOT Tool’s menu allows you to launch custom add-on programs like AutoTrack,
SignCAD, Typical Section Program as well as other MDL and automation tools for
working with graphics like the Breakline tool and the ModElev tool.
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Options

This menu allows you to have the CDOT Menu appear on top of any Windows
Application, or have it reside behind other programs.

Help

This pull-down provides convenient links to the CDOT CADD web site Home page, the
CDOT CADD Manual, Support Requests and Workflows.

CDOT Menu Sections
Explorer

The Explorer Window is used to navigate through the tree structure of group options.

- Construction
- Design

- Geometry

- Hydraulics

Landscape Environmental

Status Window

The Status Window is used to select either Existing or Proposed categories/items for a
particular group. Category options change based on the Existing or Proposed status.

Status

Existing '@ Proposed

Category

Group categories for graphic placement.

Border
Border RE

Dimensions

Patteming
Symbols

Text

i
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Item

Items are the specific graphical elements that can be placed in the design file. When an
item is selected, the CDOT Menu automatically selects the proper drawing tool and selects
the appropriate level for placement (along with that level’s ByLevel symbology).

, Weight 0
", Weight 1
., Weight 2
., Weight 3
., Weight 4
., Weight 5
., Weight &
", Weight 7

Filters

Filters are used to filter types of items. There are five filters: Lines, Text, Cells, Patterns
and All. Selecting a filter shows you only those types of elements in the selection window.

Wi EY

Main Menu Help
Discipline specific help topics using the CDOT menu.

(Help,
CADD Home Page
CADD Manual
Requests Support
Workflows

About CDOT Menu...

Settings

Allows you to set the Active Angle and Active Scale before placing text, cell and pattern
items.

BT Active Settings =1 ER 5
Active Scale: P0.00 Apply
Active Angle: 0.00 I

Close
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Placing Graphics
The CDOT Drafting Menu

Linework tools

The CDOT Drafting > Linework group provides a convenient way to place basic elements
from one location. From here you can place SmartLines, Shapes, Circles, Arcs and Hatch

areas.

SmartLines are used to place a chain of connected line segments and arc segments as

individual elements or as a single line string or shape.
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Selecting the WT Weight (line weight), LC Line Code (line style), and CO Plot Color
filters sets the appropriate level. Each item in the Linework category goes on a unique
Drafting level.
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MicroStation Drawing Tools

You can also access basic drawing tools from the MicroStation Main toolbar.

Important!  Read your prompts for proper use of these drawing tools!

Linear Elements |

Elramn<in
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Tool Settings

Each time you select a new drawing tool, the optional settings will appear in the Tool Settings

box.
Linear Elements = M Place Smartline [ = || @ |[ 22
'/" //\\ /\/’ I(‘U _ﬁ/u‘ }{ :___, Segment Type: |Lines -
- Vertex Type: | Shamp -
Rounding Radius: | 0.833
V| Join Elements -

Snap lock determines if your tentative point snaps are forced onto nearby elements. If Snap
lock is on and you place a tentative point on or near an element, your cursor locks onto that
element at the location specified by the snap mode.

Snap Modes

The active snap mode determines how you will snap onto an element. Several different snap
modes are available and can be accessed from the Status bar.

Button Bar
AccuSnap
Multi-snaps

MNearest

® Keypoint
Midpoint
Center
Origin
Bisector
Intersection
Tangent
Tangent Point
Perp

Perp Point

Point On

Multi-snapl

1 Ia Multi-snap2
= Multi-snap3
o k___m____._:___

You can also access snap modes from the Snap Mode button bar.

Snap Mode =]

] <L~ @%@ X 41

Executing snaps

You can execute a snap two ways:

e Using a tentative point
e Using AccuSnap

To shap to an element using a tentative point:
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e Select the drawing tool (Place Line, Place Block, etc.)
e Set the Snap mode (if not currently active)
e <T>on the element

A large cross hair appears at the snap mode location and the element highlights. MicroStation
displays the X,Y,Z coordinates of the <T> location in the Message field.

9876.204, 92133.747, 6194.532 KeyPt

e <D> to accept the tentative

Snaps can be a one-time setting. Once you’ve executed the snap, the snap mode returns to the
default setting. One-time overrides of the default snap mode are accomplished by:

e Choosing a snap mode from the Status Bar

e Selecting Settings > Snaps

e By single clicking on snap on the Button Bar

You can change the default snap mode by:

e Selecting a new mode in the Full Locks dialog box
e Double clicking the snap mode on the Button Bar

Using AccuSnap

AccuSnap is a feature that streamlines your snaps. Instead of tentative snapping to an element,
you can AccuSnap to it. In addition, AccuSnap can give you basic element information
(element type and level).

Turning AccuSnap on/off

You can also toggle AccuSnap on/off from the Snaps Button Bar.

Snap Mode =]
@ ") PVaoE Wb aall
Toggle AccuSnap

To snap to an element using AccuSnap:
e Select a drawing tool

e Select a Snap mode

e Move your cursor across the element
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AccuSnap identifies the element type and its level with pop-up information. An icon
representing the current snap mode is displayed along with a tentative hint — a light dashed
cross hair at the closet snap point according to the selected snap mode.

=+

[ Line, Level: ALG_PROPOSED_Hor-Alignment |

Move your cursor closer to the tentative hint.

The cursor changes to a bold X and the element highlights to indicate you’re locked on to
the snap point.

o

oy

<D> to select this location.

A Tentative point is not necessary to define the temporary snap location.

Note: AccuSnap sometimes does not work correctly with Depth lock on. Therefore, if
you’re snapping to elements with Depth lock on, be sure to turn AccuSnap off and
use a Tentative snap <T> instead. This ensures that you’ll pick up the active depth
instead of the element’s depth.

Multi-Snaps

MicroStation includes three Multi-Snap modes. Multi-snaps are an ordered list of snaps. When
you choose a multi-snap with AccuSnap on, MicroStation processes the multiple snaps
according to your cursor location.

Using Multi-Snaps

From the Snaps button bar or from the Status bar, select a Multi-Snap (Multi-snapl, Multi-
snap2 or Multi-snap3)

Multi-snapl
7 '{ Multi-snap2
- Multi-snap3.

od TEOEArT_MISC_S

Move your cursor over the element until AccuSnap locates the first multi-snap option
Continue moving your cursor until the next snap option highlights
When you have locked on the correct snap point, <D> to accept

Editing Multi-Snaps

Select Settings > Snaps > Multi-snaps (or select Multi-snaps from the Snaps button on the
Status bar)
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e Select a multi-snap (1, 2 or 3)

Ao & ==l
B

E ; Multi-snap 1
[ Bisector
[ Midpoint
W Keypoirt
[ Certer
¥ Nearest

Note: You can also right-click on the Multi-snap icon and select Properties.

e Toggle on the snaps you want to include in the multi-snap
e Toggle off snaps you don’t want
e Close the Multi-snaps box

Precision keyins

Precision key-ins allow you to precisely locate elements in your design file based on its
coordinate system. You can locate data points at exact coordinates, at a delta distance from
your current location, or at a distance and direction from the current location.

xy=key-in

Use the xy= key-in to specify a point’s exact X, y and z coordinates. The syntax for this key-in
iS: Xy=<x,y,z>.

To place an element at the active depth, leave off the z value.
ax=key-in

Use the dx= key-in to specify an x distance, y distance and z distance from the current point or
from a tentative point. This key-in is sometimes referred to as the “delta” key-in, since it
locates a point at a delta distance from the current location. The syntax for this key-in is:
dx=<dx,dy,dz>.

You can leave out variables in the key-in. For example, if you only want to locate 100 feet
(assuming your master units are feet) in the y direction from the current location, key in
dx=,100. To draw planar elements at the active depth in a 3D file, leave off the z value.

The dx= key-in behaves the same regardless of the view in which you’re working. It uses the
view axis, meaning it always assigns the x axis to horizontal and the y axis to vertical in any
view (top, front, right, etc.)

di=key-in

The dl= key-in is also a “delta” key-in and works in a similar fashion to the dx= key-in. It also
locates a point at an x distance, y distance and z distance from the current point or from a
tentative point. The syntax for this key-in is dl=<dx,dy,dz>.

The difference between the di= and the dx= key-ins is dl= uses the model axis in a 3D file.
Instead of assigning every view’s x-axis to horizontal and y-axis to vertical, it uses the design
cube’s true coordinate system. For example, a front view’s horizontal axis is the x-axis and the
vertical axis is the z-axis.

The dI= key-in behaves differently based on the view in which you’re working. In a top view of
a 3D file, there is no difference between the dx= and the dI= key-ins.
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di=key-in
Use the di= key-in to specify a distance and direction along the view axis from the current

point. The syntax for this key-in is: di=<distance,direction> Like the dx= key-in, this key-in
also uses the view axis.

You can specify the direction in either DMS (degrees, minutes, seconds) or DD (decimal
degrees). This key-in also works in any angle mode (conventional, azimuth or bearing). For
DMS, use ~ for degrees, * for minutes and ” for seconds. For example, di=10,n37/19°30.27"¢
would place a point 10 feet at the specified bearing angle.

Note: When using the dx=, dl= or di= key-ins, you can place multiple points by using the
pipe symbol (above the \ on a standard keyboard). For example if you’re in the
Place Line command and key in dx=10|3, this would place three lines, 10 feet long
each, in the x direction.

AccuDraw

AccuDraw is a precision drawing tool that streamlines the placement of data points. It
basically combines the techniques of precision keyins with axis lock-type features into one
command to help you place, modify or manipulate elements.

AccuDraw is context sensitive. Its behavior changes depending on which drawing tool you’ve
selected. AccuDraw will evaluate your current position, the previous data point, the drawing
tools needs, etc. to help you place your next data point.

Starting AccuDraw

In the CDOT workspace, AccuDraw automatically loads when you open a design file. 1f you
don’t want to use AccuDraw, you can toggle it off by selecting the Toggle AccuDraw button
from the Primary toolbar.

Primary Tools =]
B0 ;ﬁvévr@v@@@

Toggle AccuDraw

The AccuDraw Compass

When you start AccuDraw, one of the first things you notice is the AccuDraw compass. The
compass shows your origin location (current drawing location) and defines your drawing plane.
There are two different drawing plane modes and, therefore, two different compasses:
rectangular and polar.

The rectangular mode allows you to enter coordinates or delta distances, relative to the origin
point, in an X,Y,Z coordinate system (like an XY=, DX= or DL= keyin). The polar mode
allows you to enter distances and angles relative to an origin point (like a DI= keyin).
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The AccuDraw Window

The AccuDraw window is where you enter your X,Y,Z or Distance and Angle values. You can
also lock the drawing axes. The window changes according to your compass mode.

# AccuDraw 3 M AccuDraw 3
I [ 0.000

™ [N 90°0'0.00
Z |6194.532

Note: To toggle the compass (rectangular and polar mode), set the focus into the
AccuDraw window and press <Spacebar>.

You can dock the AccuDraw window at the top or bottom of the MicroStation window, or you
can float the window into the view.

AccuDraw locks

You’ve seen how to lock your X,Y or Distance, Angle entries you enter in the AccuDraw
window using the <Enter> key. You can also lock “dynamically” in AccuDraw. Dynamic
entries are X,Y or Distance, Angle values that are entered automatically as you drag your
cursor. Use the following keyboard shortcuts to lock dynamic entries:

e <X>-to lock x-axis entries in rectangular mode
e <Y>-—to lock y-axis entries in rectangular mode
e <D> —to lock distance entries in polar mode

e <A>-to lock angle entries in polar mode
Smart Lock

Use AccuDraw’s Smart Lock feature to lock your cursor in one direction only (your pointer
location). For example, if you’re working in Rectangular compass mode and you only want to
move in the Y direction, lock your cursor on the Y axis, move your cursor up or down and then
press < Enter>. You can now only move in the Y direction only. Smart Lock in Polar mode
will lock your cursor to the closest 90 degree axis.

M AccuDraw (=3
[X][0.000 [
Y

Smart Lock summary:

e In Rectangular coordinates, locks X to 0O if the pointer is on the drawing plane; y-axis or Y
to 0 if the pointer is on the x-axis.

e In Polar coordinates, locks Angle to 0°, 90°, -90°, or 180° if the pointer is on a drawing
plane axis or otherwise locks Distance to its last entered value.
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Rotating the AccuDraw compass

There may be times when you do not want the AccuDraw compass to rotate with the element
being placed. Instead, you want the compass to maintain its conventional drawing plan mode
of X-axis horizontal and Y-axis vertical. In this case, press V on the keyboard to rotate the
compass back to the “view” plane.

Note: When using AccuDraw with the SmartLine tool, there is a SmartLine placement
Setting (select the drop-down arrow) called Rotate AccuDraw to Segments. Toggle
this option off if you always want the AccuDraw compass to maintain its conventional
drawing plane mode of X-axis horizontal and Y-axis vertical.

The AccuDraw keyboard shortcut V will always rotate the compass to the view in which you’re
placing elements. Therefore, in a 3D file, pressing V in a front view, rotates the AccuDraw
compass so that the X-axis is horizontal in the front view; whereas pressing V in a top view
rotates the compass so that the X-axis is horizontal in the top view, etc. Or, you can quickly
rotate the compass to a particular view by pressing the appropriate keyboard shortcut below:

e T —topview
e F —front view
e S —side view

Using these keyboard shortcuts simplifies drawing in 3D. For civil design applications,
however, most of the time you will be drawing in a top (plan) view.

Another handy rotation option is Quick Rotate (keyboard shortcut <R> <Q>). This temporarily
rotates the compass dynamically as you move your cursor. This is handy to rotate the
AccuDraw compass to match the angle of an existing element to place off of that element or
when placing cells or text.

Moving the AccuDraw Origin to your cursor location

When you tentative shap to an existing element, press O on the keyboard to move the
AccuDraw origin temporarily to the tentative location. You can then locate the AccuDraw
compass off of this tentative point by entering values in the AccuDraw window. If you accept
the tentative with a data point, you compass “sticks” in this location.

Shortcut snap modes

AccuDraw provides a shortcut alternative for selecting a few snap modes. Instead of selecting
the snap mode from the status bar or the Snaps button bar, you can use on of the following
keyboard shortcuts:

e <N>— Nearest
e <C>— Center

e <|>—Intersect
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In addition, you can press <K> to set the keypoint snap division when using AccuDraw.

M Keypoint Snap Divisor [
2 -

Deleting Elements

To delete an element:
e Choose the Delete Element command from the Main toolbar

Delete Element

e Move your cursor over the element (it will highlight)

Note: The element highlights if Identify Elements Automatically is on in AccuSnap
Settings. If this option is not on, <D> or snap to identify the element.

e <D> to accept the deletion

Note: Choose Element Select or another tool to get out of the Delete command.

Using the Undo and Redo Commands

When you delete an element, it is moved to the Undo buffer, so MicroStation actually
remembers everything that is placed in the design file, even after it’s gone. You can retrieve a
deleted element using the Undo command (Edit > Undo). The Redo command (Edit > Redo)
negates the last Undo command.

The Undo and Redo commands not only work on deleted elements, but on most graphics
commands. For example, you can place a line, use Undo to remove the line, then use Redo to
re-place the line.

The Undo buffer is virtually unlimited in size (it’s only limited by the operating system file size
limit).

The Undo and Redo commands can also be accessed from the Standard toolbar (Tools >
Standard).

Standard =]

NS, B @2

Note: Compressing the design file (File > Compress Design), or exiting the design file clears
the Undo buffer.

Compressing the design file

Select File > Compress > Design to permanently remove deleted elements from the Undo
Buffer. This will make your design file smaller and more efficient. However, you will lose
your Undo history for the design file session.
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Element Information

Use the Element Information command from the Primary toolbar to analyze an element for
general and detailed information.

Primary Tools E]
Bl-O-=-a@-2-R Ok =R

Select the element and then<D> on the command to get general information on the element’s
attributes and its properties (solid, snappable, etc.) You can change any information in the
General section to update the element. The Geometry section contains information on the
element’s geometry, including coordinates, size, etc.

# Element Info =] = =
= & «<Selection=
L line
General 2 &
Description Line Mo Sheet 2
Level DRAFT_MISC_3 Last Medified 8/6/2009 10:49 AM
Color E= Bylevel (3) E| Snappable Snappable
Line Style E= Bylevel (0) Modified Mot Modified
\wleight E=] Bylevel (1) New New
Class Primary Locked Unlocked
Template None Thickness 0.000
Transparency 0 Line Style Parameters
[Geometry 3 =
Bl Start 9860.929.92060.709.6194 532 41250
x 9860.929 100 words
¥ 92060.709 4000704
z 6194 532 Linkages 1
End 9878.856.92066_286.6194 532
Length 18.775
Direction N72°43'8 5"E
Elevation Angle N30°00"E
DeltaX 17.927
DeltaY 5577
DeltaZ 0.000
Total Length 18.775
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