Chapter 6 - Defining Horizontal Alignments

InRoads provides a number of options to create new alignments and modify existing ones. This chapter examines the most common methods for defining horizontal geometry.

Chapter Objectives:
- Outline the typical work flow for creating horizontal geometry.
- Explain how to create new geometry placeholders.
- Discuss the Horizontal Curve Set commands.
- Describe the Horizontal Element tools.
- Explain how to import an alignment from a graphic element.
- Give an overview of Cogo commands.
- Discuss some of the useful tools in the Geometry Utilities menu.

Creating Geometry

There are multiple methods for creating horizontal geometry in InRoads. These methods include: Horizontal Curve set commands, Horizontal Element commands, Importing various text files, Importing from graphics, various Cogo commands, and Creating parallel/offset alignments.

Section Objectives:
- Discuss InRoads Options that affect geometry.
- Describe how to add data to the Cogo Buffer.
- Describe the Horizontal Curve Set PI commands.
- Describe the Horizontal Curve Set Define Curve command.
- Describe the Horizontal Curve Set stationing commands.
- Give an overview of the Horizontal Element commands.
- Describe Importing an alignment from graphics.
- Give an overview of the Cogo commands.
Options

A review of the geometry options from *InRoads Options* relative to geometry are found from the menu bar under **File > Project Options** [Geometry] tab.

![Options Dialog](image)

**Dialog Items**

- **Plotting Height**: The elevation for drawing horizontal geometry
- **Seed Alignment Name**: Initial name assigned to newly created geometry unless specified otherwise.
- **Seed Point Name**: Initial name assigned to new cogo points.
- **Curve Definition**:
  - **Horizontal**: Arc or Chord definitions
  - **Vertical**: Parabolic or Circular
  - **Measure**: Along arc or along chord for curve definition
  - **Degree of Curve Length**: Specifies central angle that subtends this distance
  - **Unit Station Length**: Distance between major station intervals
- **Define Transitions**: Defines spiral transitions by Length or Spiral constant
- **Spiral Definition**: Defines default method for defining spiral transitions
- **ICS Coordinate Sequence**: Defines input order of Northing/Easting’s for ICS batch input files.
- **Vertical Angle Reference**: Defines vertical angle measurement in ICS files.
- **Angular Mode**: Specifies orientation for angles
- **Point Name During Edits**: Defines whether names are assigned to geometry points during creation or editing.
- **Default Access Modes**: Specifies if the access to the geometry data is read only or read/write.
  - **Horizontal Alignments**: Used to specify if the horizontal alignments are read only or read/write.
  - **Cogo Buffer**: Used to specify if the Cogo Buffer is read only or read/write.

### About geometry point names

Alignment key-points (PC, PI, PT, CC, etc) exist in one of three states:

- **Unnamed**
- **Named**
- **Cogo Points**

Reviewing an alignment displays the geometry point name. The above screenshot shows both named and unnamed points.

If **Point Name During Edits** is set to **Named** on the **Options > Geometry** menu; alignment key-points are generated with a name based on the next available ID as specified in the Seed Point Name field. The specified seed point name can be alpha, numeric, or alphanumeric characters. The assigned name is also reserved in the Cogo buffer. However the point is not written to the Cogo Buffer automatically.
Writing the active alignment keypoints to the Cogo Buffer

Select **Geometry > Horizontal Curve Set > Events**

In the above example, all alignment key-points that were not previously assigned a name are written to the Cogo buffer beginning with the ID number of 200.

**Note:** The command **Geometry > Utilities > Assign Names** can be used to add, delete, or rename geometry points.

**Typical Workflow**

A predefined workflow for creating geometry is not dictated by InRoads. However, a common workflow might be:

1. Create or open an existing geometry project
2. Create horizontal alignments (or Cogo points)
3. Assign stationing for alignments
4. Define alignment station equations, if any
5. Define alignment key-points (unique points of interest)
6. Review alignments
7. View created alignments
8. Display stationing for alignments
9. Annotate created alignments
10. Graphics clean-up

**Creating New Geometry**

In order to create a new alignment, you must first have a geometry project loaded. If you need to create a new one, choose `File > New > Geometry` set the `Type` to `Geometry Project` and enter a `Name` and `Description`.

Once the geometry project is loaded (and active), you may create a new alignment name. Select `File > New > Geometry` (if you have closed the dialog) and set the `Type` to `Horizontal Alignment`. Enter the `Name`, `Description` and select a `Style`.

Apply after filling in the appropriate information, then you may proceed with either the `Horizontal Curve Set` or `Horizontal Element` tools to enter the alignment data.
Horizontal Curve Set commands

The **Horizontal Curve Set** commands make up an easy way to create alignments. They consist of five primary commands described below, and may be access from a toolbar (shown) or from the pulldown under **Geometry > Horizontal Curve Set**

![Horizontal Curve Set toolbar](image)

- **Add PI** – *Add PI* is used to create a PI that begins a new alignment, or to add a PI onto either end of an existing alignment.
- **Insert PI** – *Insert PI* is used to add a PI to an existing alignment between two existing PIs.
- **Move PI** – *Move PI* is used to change the location of an existing PI.
- **Delete PI** – *Delete PI* is used to remove a PI from an existing alignment. For removing more than one PI, you must choose and **Accept** each one individually. To remove all PIs associated with an alignment, but leave the alignment name, right-click on the alignment name in the Explorer menu and choose **Empty**.
Defining Horizontal Curves

Define Horizontal Curve Set – is used to create a curve between alignment tangents or to revise an existing curve definition. The Previous and Next buttons can be used to step sequentially through the alignment. The Select button can be used to graphically identify an alignment location for editing. As alignment components are selected, they highlight in the MicroStation view.

The Radius 1: field is for input of the radius of a single circular curve. Leading and Trailing Transition fields are for the input of spiral curve radii.
The **Curve Calculator** is used to compute curve data for circular or spiral curves. In addition to deflection angle, one other curve criteria must be defined and locked prior to selecting the Compute button. The curve solutions can be passed to the parent dialog by selecting OK.

The **Design Calculator** is used to compute or look up curve data to meet design criteria.
Setting the Beginning Station

The default station at the beginning of a newly created alignment is 0+00. To change it, select Geometry > Horizontal Curve Sets > Stationing. Set the beginning station of the active alignment by keying in the desired new station and choosing Apply. The options for Vertical Alignments should be considered carefully. Do Not Update will leave there stationing as is, Synchronize Starting Stations will update their stationing to match that of the horizontal and Maintain Station Difference will keep any difference in the current starting stations, such as when the vertical alignment does not start at the beginning of the horizontal.

Note: InRoads does not require you to key in the ‘+’ when entering a station. It will add the plus sign for you based on your preferences.
Equations

If there are inequalities in your alignment, you may assign station equations. These equations can be either gap or overlap equations. To assign an equation, select Geometry > Horizontal Curve Sets > Stationing. At the bottom of the dialog, choose New. In the resulting box, enter the Back Station and the Ahead Station, with the ahead station prefixed with an equation name. When choosing a name for the equation, remember that from this point in the alignment forward, stationing will be referred to by this name preceding the station so the shorter the name, the easier it will be for key-ins, etc.

You can have multiple equations in one alignment if necessary.

Horizontal Event Points

Horizontal Event points are points associated with an alignment that are not actually a part of the geometry of the alignment the way a PC, PT, or PI are. They are used for points that need to be annotated with stations and offsets, for points where you need special sections cut or for points where you want to be certain Roadway Designer drops a template.
Select **Geometry > Horizontal Curve Sets > Events**

Horizontal Event Points may be added as either *Station and Offset* (they move with the alignment if it is relocated or re-stationed) or as *Northing and Easting* (they remain fixed by coordinate values. The station and offset values relate back to the alignment and update as the alignment shifts). This dialog can also be used to create Cogo points or to assign Cogo points at alignment vertices.

**Horizontal Elements**

The *Horizontal Element* tools allow you to create alignments without knowing the PI information. They may be accessed from the toolbar shown above, or from the pulldown under **Geometry > Horizontal Elements**.

There are several advantages to this method. One of the greatest advantages of the horizontal element alignments is that they do not have to be continuous. For example, you can create elements that have the most constraints, leaving gaps between them, and then join them together with unconstrained tangents and curves.

Another advantage is the ease with which reverse and compound curves can be created, as well as curves greater than 180 degrees.
When creating elements, you have three basic placement options for linear elements and the same three options for circular elements. These options are just for placement; once an element is placed and accepted, it is treated the same as any other element no matter the placement method.

- **Fixed** placement is used when you know exactly where the element is going to be located and you, in effect, lock it in place using a combination of coordinates, pass-through points, bearings or radii. When using the fixed placement options, the resulting elements are not tangent or coincident with any existing elements. This placement option is used to place standalone elements.

- **Floating** placement is used to establish elements coincident and tangent to an existing element with a pass-through point and a radius (for curves) and with a pass-through point or a bearing for lines. They force the alignment to be coincident and tangent at the end where they join and will lengthen or shorten the element they are being attached to as necessary to meet the criteria specified. They will only ensure tangency and coincidence at the end where they are attached to an existing element. The floating placement options will not connect two existing elements.

- **Free** placement is used to connect two existing elements. It ensures coincidence and tangency at both ends where it connects to the existing elements. The existing elements may lengthen or shorten as necessary, but will not change locations.

To create a horizontal element alignment, first give the alignment a name description and style, then use a combination of the fourteen commands to define the alignment. (The fifteenth command is for checking and correcting problems with the integrity of the alignment, described below.)

**Check Integrity**

The *Check Integrity* command on the Horizontal Element toolbar allows you to check the coincidence and tangency of horizontal alignments. The Element tools allow you to place the different components of the alignment in whatever order you wish, therefore it is not uncommon for the elements to be “out of order”. This is one of the situations where *Check Integrity* can help, since you cannot only check the integrity, but make changes to the elements to correct integrity problems.
Importing alignments From graphics

If alignments are already defined graphically or in an electronic text file, they may be imported into InRoads without having to re-enter the data.

Alignments that have already been drawn graphically may be imported using **File > Import > Geometry > From Graphics**.

![Import Geometry dialog box](image)

You can import Horizontal Alignments, Horizontal and Vertical Alignments, Cogo Points or Event Points. If the alignment has curves, it is typically best to toggle on **Resolve Gaps and Nontangencies**. If the alignment was drawn as a series of lines and/or arcs that have not been complexed, toggle on **All Selected Elements Added to Single Alignment** (you must first define a Fence or Selection Set of the elements, and the elements will import in the order of creation, even though they’re added to the same alignment).

After specifying the **Name** (which defaults if you don’t supply one), the **Description** and the **Style**, choose **Apply**. If you have first created a Selection Set or defined a fence, you will be asked to Accept the contents. If you have not, you’ll be asked to identify the element. In either case, after accepting, an alignment or alignments will be added to the geometry project listed in the **Target** section.
Cogo Commands - Overview

Coordinate geometry commands are delivered with InRoads. There is no need to exit, start, or launch another product to access them. These commands provide an alternative method for creating horizontal alignments. One of the main differences in creating the Cogo alignments (sometimes referred to as figures) and other alignments is that Cogo alignments require that the points be established first, then joined together to form the alignments.

Once created, Cogo points and alignments are, in most cases, interchangeable with other horizontal points and alignments. There are a few key differences, however:

- Cogo points are always numbered as you go (beginning with the seed number established in **Tools > Options > Geometry** or with the next available number.
- Cogo points can stand alone, such as when locating a fire hydrant or signs.

There are several toolbars devoted to coordinate geometry described here. These same commands may be found under the Geometry heading on the pull-down menu.

**Cogo Point commands**

Use the *Cogo Points* commands to create, edit, copy, delete, or navigate to Cogo points. These commands can be accessed through tool bars or by selecting Geometry pull-down menu.

**Cogo Traverse commands**
The Traverse commands can be used to generate Cogo points from known locations by inputting distance and bearing to the point being constructed (Direction Traverse). It may also be used for locating points by Angle or Deflection. Additionally, alignments and radial points can be created based on the statues of the Insert Point.

**Cogo Intersection Commands**

![Image of Cogo Intersection Commands]

The Intersection commands can be used to generate point locations based on known points, alignments, stationing, and/or offsets.
Create/Edit Alignment by Cogo Points

Alignments are created by chaining existing Cogo points together using the Create/Edit Alignment command. It is not necessary to create the alignment name prior to using this command; it may be entered here, along with a Description and Style. The points defining the alignment are listed in the Alignment Definition. The alignment can be defined graphically by selecting the Start button or the definition (or edits) can be keyed into the Alignment Definition field.

See the Bentley Help or InRoads Reference Guide for additional information on InRoads Cogo.

Section Summary:

- The data on the Options > Geometry tab is preset to CDOT standards. With the possible exception of Plotting Height and Seed names, this data should be left as is.
- Most of the commands that are used to create alignments do not add the geometry point generated to the Cogo buffer automatically. However, they can be added afterwards.
- New geometry is not written to the hard drive until the geometry project is saved.
- There are no dialog boxes associated with the Horizontal Curve Set PI commands. Prompts for these commands are displayed in the lower left corner of the MicroStation window.
- Use the Curve Calculator and the Design Calculator to compute the radius for curves.
- The beginning station and station equations for an alignment are defined using the Horizontal Curve Set > Stationing command.
- The Horizontal Curve Set > Events command is used to add stations “of importance” to the alignment and alignment points to the Cogo Buffer.
- Event points can also be used by other commands like Roadway Designer and Create Cross Sections to calculate data at those stations.
• Horizontal Element tools can be used to create unconnected alignment elements within a single alignment.
• The Horizontal Element Check Integrity tool can be used on alignments created by any method. It is especially useful for trouble shooting alignments imported from graphics.
• Cogo commands are primarily used by the ROW/Survey specialty group.

Geometry Utilities

Geometry utilities act upon existing geometry to modify that geometry or create new geometry.

Section Objectives:
• Discuss the Transpose Alignment command.
• Discuss the Inverse command.
• Discuss the Transform Geometry command.
• Discuss the

Transposing Alignments

Transposing an alignment reverses the direction of that alignment. Tangent sections are reversed and left-hand curves become right-hand curves. The beginning stationing value is retained; however, any station equations previously defined are deleted. Associated vertical alignments are also reversed. You may find the need to transpose an alignment if it was surveyed in a direction opposite from the direction you wish to design (up-stream vs. down stream). Other instances may be if you create an alignment by importing from graphics. InRoads will generate the alignment in the direction the MicroStation graphic was drawn which is not necessarily in the direction of ‘up-station’. Or you may simply create an alignment in the wrong direction using any of the InRoads geometry commands.

The transpose alignment command is found under the pull-down menu:

Geometry > Utilities > Transpose

The command executes once the alignment(s) for transform are chosen and Apply is selected. The user will have to redisplay any associated stationing or annotation of the transformed alignment(s).

Transposing an alignment

1. Use the review tools to evaluate the horizontal alignments and determine the direction they are running.

   Note: Alignments created by exporting an electronic fieldbook assume the direction of the data collection.

2. Select Geometry > Utilities > Transpose.
3. Select the desired alignment and **Apply**.

4. **Review** the alignment to verify the transposition.

5. **Save** the geometry project.

**Inversing Between Alignments - Overview**
Another useful geometry utility is **Geometry > Utilities > Inverse Direction**. This command can be used to interactively inverse between data points identified graphically. Enabling the geometry point snap will lock data points to defined alignment or Cogo keypoints. Executing a second graphic data point will post the inversed data to the MicroStation file.

**Transforming Geometry - Overview**

Entire geometry projects, individual alignments, or Cogo points can be transformed by moving, scaling, or rotating selected items. The transform command is found under the pull-down menu **Geometry > Utilities > Transform**

Shown above is the transformation of alignment Alternate B. The alignment has been moved 100 feet east and 100 feet north as indicated in the delta coordinate values defined in Original Point & Destination Point fields. Additionally the alignment has been rotated 22 degrees clockwise. The point of rotation is about the coordinates defined in the Original Point fields.

**Note:** This command does not create a copy of the specified alignment. It will transform the original alignment specified. Use the **Geometry > Copy Geometry** command prior to use if a copy is desired.
Offset Alignments - overview

Choose Geometry > Utilities > Parallel Horizontal Alignment

Items to examine are:

**Mode** - There are three modes; Specify, Interactive By Station, and Interactive By Element.

- **Specify** - This option uses the data in the From area of the dialog box to determine the length and location of the new alignment.

- **Interactive By Station** - This option identifies the length and location of the new alignment based on data clicks made in the MicroStation View window. This option can use partial elements at the beginning and end of the new alignment.

- **Interactive By Element** - This option also identifies the length and location of the new alignment based on data clicks made in the MicroStation View window. However, this option uses the full length of all elements identified.

**From** - This area is used to identify the source, length, and offset of the new alignment within the dialog box.

- **Horizontal Alignment** - This drop down menu is used to specify the source of the offset alignment.

- **Station Limits** - This option is used to specify the length of the new alignment in relation to the source alignment. When toggled off the full length of the source alignment is used.

- **Offset** - This option determines the location to the left or right for the new alignment. Positive offsets are to the right, negative offsets are to the left of the source alignment.

**To** - This area is used to specify the attributes of the new alignment.

- **Name** - The name for the new alignment is entered here. If left blank, the Seed Name from the Options dialog box is used.

- **Description** - The description for the new alignment is entered here. If left blank, no description is attached to the alignment.
- **Style** - This drop down menu specifies the style for the new alignment.

- **Copy Event Points** - When on, event points from the source that are within the extents of the new alignment are added to the new alignment.

*Note:* The new alignment’s stationing is equated to the source alignment.

**Section Summary:**
- The Transpose command is used to change the direction of the alignment. The elements remain in their original locations, but the end of the element is now the beginning.
- The Inverse command computes the distance and bearing between two alignment points.
- The Transform command is used to change an alignment from one measurement system to another.
- The Parallel Horizontal Alignment is used to copy all or part of an alignment a specified distance from its source.

**Chapter Summary:**
- New geometry is created in the hierarchical order as it is defined in the geometry project.
- The Horizontal Curve Set commands are the most common method used for creating new horizontal alignments.
- Import from Graphics is used to make geometry from MicroStation elements.
- Horizontal Element and Cogo commands can be used to create solutions where inconsistencies occur using other methods.
- Use the Parallel horizontal Alignment command to create the basis for offset control lines.
Appendix A - ICS Geometry Input

Text files may be imported in several formats, one of the easiest is to create an .ics file (Interactive Coordinate geometry Subsystem). This file type was first used with a product of the same name many years ago, but is still in use with InRoads today. It takes the format of commands along with the input for those commands.

For example a text file of coordinates can be formatted in an .ics file by adding a Store command at the top and formatting the file similar to the one shown below.

Choose **File > Import > Geometry > ICS**. Browse to find the file, and then choose **Apply**.
The cogo points will be added to the active geometry project. You may then use **Geometry > Utilities > Create/Edit Alignment** to join the points, forming an Alignment and **Geometry > Horizontal Curve Sets > Define Curves** to add curves to the alignment.

You can also accomplish these same tasks within the .ics file. See the Bentley Help topic *Alpha Cogo*.

InRoads contains an alphanumeric interface for running Interactive Coordinate Geometry Subsystem (ICS) commands. This interface is also referred to as Cogo Classic and can be used to run batch runs of geometry commands.

ICS can be accessed through the Windows start menu by selecting:

**Start > All Programs > Bentley > InRoads Group XM > Cogo Classic**
ICS Command Summary

Control Commands

CREATE PROJECT name description
LOAD PROJECT name
SAVE PROJECT fname

AUDIT FILE mode file.ext
mode: 0 - opens an existing file of the specified name so that data can be added to the end of the file
1 - opens a new file of the name specified
-1 - closes the existing file

OUTPUT FILE mode file.ext
mode: 0 - records all input and output records in the output file
1 - suppresses recording of input and only records output
-1 - closes the existing file
AUTO PLOT preference /z /!fnam

This command turns on the graphic auto plot lock and sets the active preference for automatically plotting points and figures in the design file. Issuing the command again with fnum equal to 0 will turn the auto plot lock off in the graphic environment.

Example: AUTO PLOT 0 !ALIGN1 # turns auto plot lock on and # sets the active preference to ALIGN1

AUTO PLOT 0 # turns off auto plot lock

**Parameter Commands**

- **SET HEIGHT** HtFS1 hi1 htBS1 /htFS2 /hi2 /htBS2
- **SET PARAMETER** dir
  
  0 = north azimuth 1 = bearing

- **SET PROTECTION** set prot
  
  0 = Point Protection ON 1 = Point Protection OFF

- **SET REFERENCE**

  Sets the vertical angle reference: v = horizon z = zenith

- **SET SEQUENCE** seq

  Sets the coordinate sequence: x = x,y,z n = n,e,e

- **SET TOLERANCE** dtol /atol

  Sets a distance tolerance dtol and angle tolerance atol for the following conditions:
  
  - Colinearity of points on tangents
  - Curve and spiral symmetry
  - Curve and spiral tangency with subtangents
  - Figure continuity at tangent points

**Report Commands**

- **ANGLES** pBS pOC desFS

  Computes and reports angles from pBS at pOC to points in desFS.

- **AREA DIRECTION** des

  Computes and reports the area and boundary courses of the closed figure defined by des.

- **DESCRIBE ALIGNMENT** Hfg /x /sBEG /sEND

  Lists the following alignment data for Hfg at interval x:
  
  - coordinates and station of PC, PI, PT, CC
  - distances and directions of tangents
  - PI deflection angles
- curve data

DESCRIBE VERT ALIGN sBEG /sEND
   Describes the active vertical alignment, including points of vertical inflection, curvature, tangency, high and low points, and grades.

DISTANCE des
   Computes and reports distances between points in des.

INVERSE DIRECTION des
   Computes and reports distances and directions between points in des.

LIST COORDINATES des /mode
   Lists the coordinates of each point in des.

LIST FIGURES des
   Lists the figures and figure descriptions in des.

TRAVERSE ANGLES des
   Computes and reports the lengths and the interior angles of lines in the traverse defined in des.

STATIONS AND OFFSETS desAL2 /x /sBEG /sEND
   Computes and lists the stations and offsets of points in desAL2 from the active horizontal alignment.

**Point Commands**

STORE n c1 c2 /z /p /!fnam -OR- p c1 c2 /z /-cno /!fnam
   Stores point n with coordinates c1, c2, and z. If optional p is specified, n takes its value. If optional -cno is specified as -1, -2, or -3 the coordinate c1, c2, or z is modified, respectively.

DELETE COORDINATES des
   Deletes points in des from the .tdp project file.

DEFINE Z p z
   Defines the elevation of point p.

POINT DESCRIPTION des *description
   Defines the alpha description for the known point(s) in des.

**Figure Commands**

STORE FIGURE nfg des /pAL sAL
   Defines the figure nfg in the .tdp file as the list of points in des.

DELETE FIGURE fg
   Deletes the figure descriptions (but not points) from the .tdp project file.

FIGURE DESCRIPTION des *description
   Defines the alpha description for the known figure(s) in des.
Locate Commands

ANGLE RESECTION p1 p2 p3 ang1 ang2 /n
EXTEND ARC pPC pCC nPT [arc]
LEVEL RUN pBS rBS
LOCATE ANGLE pBS pOC nFS ang [dis] /vaFS /[off] /vaBS pVB
LOCATE DEFLECTION pBS pOC nFS defl [dis] /vaFS /[off] /vaBS /pVB
LOCATE DIRECTION p n dir [dis] /va /[off]
LOCATE FROM ALIGNMENT n sn /[off] /rod
    Locates a point n along the active alignment at station sn at an optional offset off and
    rod reading rod.
    rod = rod reading if Level Run is active
    rod = elevation if Level Run is non-active
LOCATE LINE p1 p2 n [dis] /va /[off] /Mdis
TANGENT n1 pCC1 [r1] n2 pCC2 [r2] /dir /ext
TANGENT OFFSET n pOF p1 p2

Transformation Commands

COMPUTE TRANSFORM desFROM desTO
    This command is initially used to set the rotation/translation values to be used in the
    transformation process. The "desFROM" values are two points that are located in the
    relative coordinate system. The "desTO" values are two points in the rotated/translated
    coordinate system that directly correspond with the two points in the relative
    coordinate system. The relationship between these two sets of points is that the
    measured distance must be exactly the same between each set of points (no scaling
    allowed).
TRANSFORM COORDINATES des
    This command can be executed at any time, on any set of points/figures, AFTER the
    Compute Transform command has been processed. This command works with points
    or figures.

Divide Commands

DIVIDE ARC pPC pPT pCC div /n
    Divides a clockwise arc with center pCC into div equal segments between pPC and
    pPT. Stores the resultant coordinates as n, n+1, etc.
DIVIDE FIGURE des div /n
    Divides the figure des into div equal parts. Stores the resultant coordinates as n, n+1,
    etc.
DIVIDE LINE p1 p2 div /n
    Divides line p1 p2 into div equal parts. Stores the resultant coordinates as points n,
    n+1, etc.
**Intersect Commands**

ARC ARC INTERSECT n pCC1 [r1] pCC2 [r2] pID
ARC LINE DIRECTION n pCC [r] p dir pID /[/off]
ARC LINE POINTS n pCC [r] p1 p2 pID /[/off]
CURVE SPIRAL n [r] pCC pID pTS dirBT [ls] [dc]
CURVE SPIRAL POINTS n [r] pCC pID pTS pSIT pSC
DIRECTION INTERSECT n p1 dir1 p2 dir2 /[/off1] /[/off2] /va1 /va2
FIGURE ARC INTERSECT n fg pCC r pID /[/offg]
FIGURE FIGURE INTERS n fg1 fg2 pID /[/off1] /[/off2]
FIGURE LINE INTERSECT n fg p dir pID /[/offg] /[/off]
LINE SPIRAL n p1 p2 pID pTS dirBT [ls] [dc]
LINE SPIRAL POINTS n p1 p2 pID pTS pSIT pSC
POINTS DIRECTION INTER n p1 p2 p3 dir /[/off1] /[/off2] /va
POINTS INTERSECT n p1 p2 p3 /[/off1] /[/off2]
SPIRAL SPIRAL n pTS1 dirBT1 [ls1] [dc1] pTS2 dirBT2 [ls2] [dc2] /pID
SPIRAL SPIRAL POINTS n pTS1 dirBT1 [ls1] [dc1] pTS2 pSIT pSC2 /pID

**Curve Commands**

FIT CURVE pBT pPI pAT nPC nCC nPT /[/r] -OR- pPC pOC pPT

**Alignment Commands**

SET ALIGNMENT Hfg /pAL /sAL /Vfg

Activates a horizontal alignment and optionally defines the stationing.

CLEAR ALIGNMENT

Clears the active alignment, and makes the active alignment Cogo.

POINTS ON ALIGNMENT x /n /[/off] /sBEG /sEND /odd

Locates and lists coordinates of points n, n+1, etc. at each interval x along the active alignment at an optional offset off between sBEG and sEND with odd defining station lock on or off.

odd = 1 - Station Lock on
odd = 0 - Station Lock off

FIT ALIGNMENT nTS pBT pPI [dc] [ls1] [ls2] defl sign

**Parallel Commands**

PARALLEL LINE p1 p2 [off] /n1 n2

Locates points parallel with the line p1 p2 at an offset distance off, and stores them as n1 and n2.

PARALLEL FIGURE des [/off] /n /nfg /dz
Locates a new parallel figure to des at an offset distance off, and stores points of the new figure as n, n+1, etc. and the new figure as nfg with an elevation difference of dz.

For an open figure: For a closed figure:
+off = to the right +off = external
-off = to the left -off = internal
### COGO Parameter Abbreviations

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ang</td>
<td>angle</td>
<td>p</td>
<td>known point</td>
</tr>
<tr>
<td>atol</td>
<td>angle tolerance</td>
<td>pAL</td>
<td>point on the alignment</td>
</tr>
<tr>
<td>arc</td>
<td>arc distance</td>
<td>pAT</td>
<td>point of the ahead tangent</td>
</tr>
<tr>
<td>-AL</td>
<td>alignment</td>
<td>pBS</td>
<td>point of the backsight</td>
</tr>
<tr>
<td>c1,c2</td>
<td>coordinates 1 and 2</td>
<td>pBT</td>
<td>point of the back tangent</td>
</tr>
<tr>
<td>cid</td>
<td>spiral curve identification; this parameter is not used by Simple Spiral, key in any number from 0 to 999.</td>
<td>pID</td>
<td>known point that indicates which intersection is to be chosen; positive is near, negative is far from the pID</td>
</tr>
<tr>
<td>Cno</td>
<td>the field number of a coord to change in an existing point</td>
<td>pOC</td>
<td>occupied point OR point on the curve</td>
</tr>
<tr>
<td>CC</td>
<td>center of curve</td>
<td>pOF</td>
<td>point that perpendicularly offsets the pt. to be calculated</td>
</tr>
<tr>
<td>Dc</td>
<td>degree of curve</td>
<td>pVB</td>
<td>point of the vertical backsight</td>
</tr>
<tr>
<td>defl</td>
<td>deflection angles</td>
<td>PC</td>
<td>point of curvature</td>
</tr>
<tr>
<td>delta</td>
<td>delta angle</td>
<td>PI</td>
<td>point of intersection</td>
</tr>
<tr>
<td>des</td>
<td>point or figure description</td>
<td>PT</td>
<td>point of tangency</td>
</tr>
<tr>
<td>desc</td>
<td>alpha description</td>
<td>r#</td>
<td>curve radius</td>
</tr>
<tr>
<td>dir</td>
<td>direction</td>
<td>rBS</td>
<td>rod reading of the backsight</td>
</tr>
<tr>
<td>dirBT</td>
<td>direction to the back tangent</td>
<td>rod</td>
<td>rod reading or elevation</td>
</tr>
<tr>
<td>dis</td>
<td>distance</td>
<td>s</td>
<td>station</td>
</tr>
<tr>
<td>div</td>
<td>number of divisions</td>
<td>sAL</td>
<td>station on the alignment</td>
</tr>
<tr>
<td>dtol</td>
<td>distance tolerance</td>
<td>sBEG</td>
<td>beginning station</td>
</tr>
<tr>
<td>dz</td>
<td>elevation difference</td>
<td>sEND</td>
<td>ending station</td>
</tr>
<tr>
<td>ext</td>
<td>externality</td>
<td>seq</td>
<td>coordinate sequence (x or n)</td>
</tr>
<tr>
<td>fg</td>
<td>figure</td>
<td>sign</td>
<td>sign of angle</td>
</tr>
<tr>
<td>fnam</td>
<td>feature name</td>
<td>sn</td>
<td>station</td>
</tr>
<tr>
<td>fname</td>
<td>file name</td>
<td>SC</td>
<td>spiral to curve point</td>
</tr>
<tr>
<td>fnum</td>
<td>feature number</td>
<td>SIT</td>
<td>point of spiral intersection</td>
</tr>
<tr>
<td>-FS</td>
<td>foresight</td>
<td>TS</td>
<td>tangent to spiral point</td>
</tr>
<tr>
<td>Gdis</td>
<td>geodetic distance</td>
<td>va</td>
<td>vertical angle</td>
</tr>
<tr>
<td>Hfg</td>
<td>horizontal figure</td>
<td>vaBS</td>
<td>vertical angle to backsight</td>
</tr>
<tr>
<td>hi#</td>
<td>height of instrument</td>
<td>vaFS</td>
<td>vertical angle to foresight</td>
</tr>
<tr>
<td>ht#</td>
<td>height of target</td>
<td>Vfg</td>
<td>vertical figure</td>
</tr>
<tr>
<td>ls#</td>
<td>spiral arc length</td>
<td>x</td>
<td>station distance</td>
</tr>
<tr>
<td>Mdis</td>
<td>measured distance</td>
<td>z</td>
<td>elevation</td>
</tr>
<tr>
<td>mode</td>
<td>input/output mode</td>
<td>n</td>
<td>unknown point</td>
</tr>
<tr>
<td>name</td>
<td>name of file</td>
<td>nfg</td>
<td>unknown figure</td>
</tr>
<tr>
<td>odd</td>
<td>station lock on/off</td>
<td>off</td>
<td>offset</td>
</tr>
<tr>
<td>oflg</td>
<td>offset from figure</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

[ ] - parameters shown in the square brackets utilize the Input Combined Grid Factor
### Abbreviations for the ICS input commands

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Command</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>an r</td>
<td>angle resection</td>
<td></td>
</tr>
<tr>
<td>an</td>
<td>angles</td>
<td></td>
</tr>
<tr>
<td>a a i</td>
<td>arc arc intersect</td>
<td></td>
</tr>
<tr>
<td>a d</td>
<td>area directions</td>
<td></td>
</tr>
<tr>
<td>a f</td>
<td>audit file</td>
<td></td>
</tr>
<tr>
<td>a l d</td>
<td>arc line direction</td>
<td></td>
</tr>
<tr>
<td>a l p</td>
<td>arc line points</td>
<td></td>
</tr>
<tr>
<td>a p</td>
<td>auto plot</td>
<td>assigns feature name/number to all of the following commands, i.e.:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>a p house</td>
</tr>
<tr>
<td></td>
<td></td>
<td>store 1 100 200 300</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2 101 202 303</td>
</tr>
<tr>
<td></td>
<td></td>
<td>loc ang 1 2 30. 100.</td>
</tr>
<tr>
<td>c a</td>
<td>clear alignment</td>
<td></td>
</tr>
<tr>
<td>c g f</td>
<td>combined grid factor</td>
<td></td>
</tr>
<tr>
<td>c pr</td>
<td>create project</td>
<td></td>
</tr>
<tr>
<td>c s p</td>
<td>curve spiral points</td>
<td></td>
</tr>
<tr>
<td>c s</td>
<td>curve spiral</td>
<td></td>
</tr>
<tr>
<td>c t</td>
<td>compute transform</td>
<td></td>
</tr>
<tr>
<td>def z</td>
<td>define z</td>
<td></td>
</tr>
<tr>
<td>del c</td>
<td>delete coordinate</td>
<td></td>
</tr>
<tr>
<td>del f</td>
<td>delete figure</td>
<td></td>
</tr>
<tr>
<td>des a</td>
<td>describe alignment</td>
<td></td>
</tr>
<tr>
<td>des v</td>
<td>describe vertical</td>
<td></td>
</tr>
<tr>
<td>di a</td>
<td>divide arc</td>
<td></td>
</tr>
<tr>
<td>di f</td>
<td>divide figure</td>
<td></td>
</tr>
<tr>
<td>di i</td>
<td>direction intersect</td>
<td></td>
</tr>
<tr>
<td>di l</td>
<td>divide line</td>
<td></td>
</tr>
<tr>
<td>dis</td>
<td>distances</td>
<td></td>
</tr>
<tr>
<td>exi</td>
<td>exit</td>
<td></td>
</tr>
<tr>
<td>ext a</td>
<td>extent arc</td>
<td></td>
</tr>
<tr>
<td>f ar i</td>
<td>figure arc intersect</td>
<td></td>
</tr>
<tr>
<td>f al</td>
<td>fit alignment</td>
<td></td>
</tr>
<tr>
<td>f c</td>
<td>fit curve</td>
<td></td>
</tr>
<tr>
<td>f d</td>
<td>figure description</td>
<td></td>
</tr>
<tr>
<td>f f i</td>
<td>figure figure intersect</td>
<td></td>
</tr>
<tr>
<td>f f i</td>
<td>figure line intersect</td>
<td></td>
</tr>
<tr>
<td>i d</td>
<td>inverse direction</td>
<td></td>
</tr>
<tr>
<td>i f</td>
<td>input file</td>
<td></td>
</tr>
<tr>
<td>l a</td>
<td>locate angle</td>
<td></td>
</tr>
<tr>
<td>l c</td>
<td>list coordinate</td>
<td></td>
</tr>
<tr>
<td>l de</td>
<td>locate deflection</td>
<td></td>
</tr>
<tr>
<td>l di</td>
<td>locate direction</td>
<td></td>
</tr>
<tr>
<td>Code</td>
<td>Description</td>
<td>Notes</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
<td>-------</td>
</tr>
<tr>
<td>l fi</td>
<td>list figure</td>
<td>&quot;list figure (point des, i.e. 1-4) -1&quot; lists all figures that points in the parentheses are located in.</td>
</tr>
<tr>
<td>l fr a</td>
<td>locate from alignment</td>
<td></td>
</tr>
<tr>
<td>l l</td>
<td>locate line</td>
<td></td>
</tr>
<tr>
<td>l pa</td>
<td>load parameters</td>
<td></td>
</tr>
<tr>
<td>l pr</td>
<td>load project</td>
<td></td>
</tr>
<tr>
<td>l r</td>
<td>level run</td>
<td></td>
</tr>
<tr>
<td>l s p</td>
<td>line spiral points</td>
<td></td>
</tr>
<tr>
<td>l s</td>
<td>line spiral</td>
<td></td>
</tr>
<tr>
<td>o f</td>
<td>output file</td>
<td></td>
</tr>
<tr>
<td>pa f</td>
<td>parallel figure</td>
<td></td>
</tr>
<tr>
<td>pa l</td>
<td>parallel line</td>
<td></td>
</tr>
<tr>
<td>pl c</td>
<td>plot curve</td>
<td></td>
</tr>
<tr>
<td>pl l</td>
<td>plot line</td>
<td></td>
</tr>
<tr>
<td>pl p</td>
<td>plot point</td>
<td></td>
</tr>
<tr>
<td>pl s</td>
<td>plot shape</td>
<td></td>
</tr>
<tr>
<td>po de</td>
<td>point description</td>
<td></td>
</tr>
<tr>
<td>po di i</td>
<td>point direction intersect</td>
<td></td>
</tr>
<tr>
<td>po i</td>
<td>points intersect</td>
<td></td>
</tr>
<tr>
<td>po o a</td>
<td>points on alignment</td>
<td></td>
</tr>
<tr>
<td>sa pa</td>
<td>save parameters</td>
<td></td>
</tr>
<tr>
<td>sa pr</td>
<td>save project</td>
<td></td>
</tr>
<tr>
<td>se a</td>
<td>set alignment</td>
<td></td>
</tr>
<tr>
<td>se d</td>
<td>set display</td>
<td>&quot;set display 0&quot; turns scrolling off and &quot;set display 1&quot; turns scrolling On</td>
</tr>
<tr>
<td>se h</td>
<td>set height</td>
<td></td>
</tr>
<tr>
<td>se pa</td>
<td>set parameters</td>
<td></td>
</tr>
<tr>
<td>se r</td>
<td>set reference</td>
<td></td>
</tr>
<tr>
<td>se s</td>
<td>set sequence</td>
<td></td>
</tr>
<tr>
<td>se t</td>
<td>set tolerance</td>
<td></td>
</tr>
<tr>
<td>sp s</td>
<td>spiral spiral</td>
<td></td>
</tr>
<tr>
<td>sp s p</td>
<td>spiral spiral points</td>
<td></td>
</tr>
<tr>
<td>s a o</td>
<td>station and offset</td>
<td></td>
</tr>
<tr>
<td>s f</td>
<td>store figure</td>
<td></td>
</tr>
<tr>
<td>s</td>
<td>store</td>
<td></td>
</tr>
<tr>
<td>t a</td>
<td>traverse angle</td>
<td></td>
</tr>
<tr>
<td>t c</td>
<td>transform coordinates</td>
<td></td>
</tr>
<tr>
<td>t o</td>
<td>tangent offset</td>
<td></td>
</tr>
<tr>
<td>t</td>
<td>tangent</td>
<td></td>
</tr>
</tbody>
</table>