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Chapter 6 - Creating Your Design Graphics

In this Chapter you will learn how to use the CDOT Menu to set standards and place simple graphics. You will 
also learn how to use precision drawing techniques to locate your graphics. 

Chapter Objectives:

• Give an overview of the CDOT menu

• Describe the various parts of the CDOT menu in detail

• Discuss how to work with the CDOT menu and MicroStation task menus to produce plan 
graphics

• Discuss setting and using snap options

• Describe how to use AccuDraw

• Discuss deleting elements

• Discuss using undo and redo

The CDOT Menu

The customized CDOT menu provides access to tools and applications intended to provide the 
user a simple, efficient method to apply CDOT’s CADD standards to every project. These 
menus direct MicroStation to place elements on discipline-defined levels for drawing 
consistency. 

Note: Since the CDOT Menu automatically selects the correct level for element placement 
across disciplines, you must have selected the xxxMulti-Discipline group from the 
Select Group Environment program.
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Opening the Menu

After starting MicroStation, select the CDOT icon from MicroStation’s Main toolbar to open 
the CDOT Menu. You can hover over the icon to verify the CDOT configuration release.

Parts of the Menu
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Drop-down menus

Use the drop-down menus to make the following selections:

Group Display

Toggle on your Group to display Explorer menu selections for placing graphics. In the 
Explorer menu tree some groups like Traffic ITS have “children” options that can be 
expanded with the “+” symbol. Drafting is a generic group (i.e. it’s used by all groups) for 
placing general text, dimensions, borders, etc. There is also an option on this menu to 
select/deselect all groups.

CDOT Tools

The CDOT Tool’s menu allows you to launch custom add-on programs like AutoTrack, 
SignCAD, Typical Section Program as well as other MDL and automation tools for 
working with graphics like the Breakline tool and the ModElev tool.

Options

This menu allows you to have the CDOT Menu appear on top of any Windows 
Application, or have it reside behind other programs.

Help

This pull-down provides convenient links to the CDOT CADD web site Home page, the 
CDOT CADD Manual, Support Requests and Workflows.
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CDOT Menu Sections

Explorer

The Explorer Window is used to navigate through the tree structure of group options.

Status Window

The Status Window is used to select either Existing or Proposed categories/items for a 
particular group. Category options change based on the Existing or Proposed status.

Category

Group categories for graphic placement.

Item

Items are the specific graphical elements that can be placed in the design file. When an 
item is selected, the CDOT Menu automatically selects the proper drawing tool and selects 
the appropriate level for placement (along with that level’s ByLevel symbology).
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Filters

Filters are used to filter types of items. There are five filters: Lines, Text, Cells, Patterns 
and All. Selecting a filter shows you only those types of elements in the selection window.

Main Menu Help

Discipline specific help topics using the CDOT menu.

Settings

Allows you to set the Active Angle and Active Scale before placing text, cell and pattern 
items.

Placing Graphics

The CDOT Drafting Menu

Linework tools

The CDOT Drafting > Linework group provides a convenient way to place basic elements 
from one location. From here you can place SmartLines, Shapes, Circles, Arcs and Hatch 
areas.
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SmartLines are used to place a chain of connected line segments and arc segments as 
individual elements or as a single line string or shape.

Selecting the WT Weight (line weight), LC Line Code (line style), and CO Plot Color 
filters sets the appropriate level. Each item in the Linework category goes on a unique 
Drafting level.

MicroStation Drawing Tools

You can also access basic drawing tools from the MicroStation Tasks menu. Select the 
Drawing task to display the available tools.
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Important! Read your prompts for proper use of these drawing tools!

 

Tool Settings

Each time you select a new drawing tool, the optional settings will appear in the Tool Settings 
box.

Snap Lock

Snap lock determines if your tentative point snaps are forced onto nearby elements. If Snap 
lock is on and you place a tentative point on or near an element, your cursor locks onto that 
element at the location specified by the snap mode.
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Snap Modes

The active snap mode determines how you will snap onto an element. Several different snap 
modes are available and can be accessed from the Status bar.

You can also access snap modes from the Snap Mode button bar.

Executing snaps

You can execute a snap two ways:

• Using a tentative point

• Using AccuSnap

To snap to an element using a tentative point:

• Select the drawing tool (Place Line, Place Block, etc.)

• Set the Snap mode (if not currently active)

• <T> on the element

A large cross hair appears at the snap mode location and the element highlights. MicroStation 
displays the X,Y,Z coordinates of the <T> location in the Message field.



Colorado Department of Transportation   Page 101

A Practical Guide for Using MicroStation V8i SS2 Chapter 6 - Creating Your Design Graphics

• <D> to accept the tentative

Snaps can be a one-time setting. Once you’ve executed the snap, the snap mode returns to the 
default setting. One-time overrides of the default snap mode are accomplished by:

• Choosing a snap mode from the Status Bar

• Selecting Settings > Snaps
• By single clicking on snap on the Button Bar

You can change the default snap mode by:

• Selecting a new mode in the Full Locks dialog box

• Double clicking the snap mode on the Button Bar

Using AccuSnap

AccuSnap is a feature that streamlines your snaps. Instead of tentative snapping to an element, 
you can AccuSnap to it. In addition, AccuSnap can give you basic element information 
(element type and level).

Turning AccuSnap on/off

You can also toggle AccuSnap on/off from the Snaps Button Bar.

 

To snap to an element using AccuSnap:

• Select a drawing tool

• Select a Snap mode

• Move your cursor across the element

AccuSnap identifies the element type and its level with pop-up information. An icon 
representing the current snap mode is displayed along with a tentative hint – a light dashed 
cross hair at the closet snap point according to the selected snap mode.

• Move your cursor closer to the tentative hint.

The cursor changes to a bold X and the element highlights to indicate you’re locked on to 
the snap point.

• <D> to select this location.

A Tentative point is not necessary to define the temporary snap location.
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Note: AccuSnap sometimes does not work correctly with Depth lock on. Therefore, if 
you’re snapping to elements with Depth lock on, be sure to turn AccuSnap off and 
use a Tentative snap <T> instead. This ensures that you’ll pick up the active depth 
instead of the element’s depth.

Multi-Snaps

MicroStation includes three Multi-Snap modes. Multi-snaps are an ordered list of snaps. When 
you choose a multi-snap with AccuSnap on, MicroStation processes the multiple snaps 
according to your cursor location.

Using Multi-Snaps

• From the Snaps button bar or from the Status bar, select a Multi-Snap (Multi-snap1, Multi-
snap2 or Multi-snap3)

 

• Move your cursor over the element until AccuSnap locates the first multi-snap option

• Continue moving your cursor until the next snap option highlights

• When you have locked on the correct snap point, <D> to accept

Editing Multi-Snaps

• Select Settings > Snaps > Multi-snaps (or select Multi-snaps from the Snaps button on the 
Status bar)

• Select a multi-snap (1, 2 or 3)

Note: You can also right-click on the Multi-snap icon and select Properties.

• Toggle on the snaps you want to include in the multi-snap

• Toggle off snaps you don’t want

• Close the Multi-snaps box

Precision keyins 

Precision key-ins allow you to precisely locate elements in your design file based on its 
coordinate system. You can locate data points at exact coordinates, at a delta distance from your 
current location, or at a distance and direction from the current location.

xy=key-in

Use the xy= key-in to specify a point’s exact x, y and z coordinates. The syntax for this key-in 
is: xy=<x,y,z>.
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To place an element at the active depth, leave off the z value.

dx=key-in

Use the dx= key-in to specify an x distance, y distance and z distance from the current point or 
from a tentative point. This key-in is sometimes referred to as the “delta” key-in, since it 
locates a point at a delta distance from the current location. The syntax for this key-in is: 
dx=<dx,dy,dz>.

You can leave out variables in the key-in. For example, if you only want to locate 100 feet 
(assuming your master units are feet) in the y direction from the current location, key in 
dx=,100. To draw planar elements at the active depth in a 3D file, leave off the z value.

The dx= key-in behaves the same regardless of the view in which you’re working. It uses the 
view axis, meaning it always assigns the x axis to horizontal and the y axis to vertical in any 
view (top, front, right, etc.)

dl=key-in

The dl= key-in is also a “delta” key-in and works in a similar fashion to the dx= key-in. It also 
locates a point at an x distance, y distance and z distance from the current point or from a 
tentative point. The syntax for this key-in is dl=<dx,dy,dz>.

The difference between the dl= and the dx= key-ins is dl=  uses the model axis in a 3D file. 
Instead of assigning every view’s x-axis to horizontal and y-axis to vertical, it uses the design 
cube’s true coordinate system. For example, a front view’s horizontal axis is the x-axis and the 
vertical axis is the z-axis.

The dl= key-in behaves differently based on the view in which you’re working. In a top view of 
a 3D file, there is no difference between the dx= and the dl= key-ins.

di=key-in

Use the di= key-in to specify a distance and direction along the view axis from the current 
point. The syntax for this key-in is: di=<distance,direction> Like the dx= key-in, this key-in 
also uses the view axis.

You can specify the direction in either DMS (degrees, minutes, seconds) or DD (decimal 
degrees). This key-in also works in any angle mode (conventional, azimuth or bearing). For 
DMS, use ^ for degrees, ’ for minutes and ” for seconds. For example, di=10,n37^19’30.27”e 
would place a point 10 feet at the specified bearing angle.

Note: When using the dx=, dl= or di= key-ins, you can place multiple points by using the 
pipe symbol (above the \ on a standard keyboard). For example if you’re in the 
Place Line command and key in dx=10|3, this would place three lines, 10 feet long 
each, in the x direction.

AccuDraw

AccuDraw is a precision drawing tool that streamlines the placement of data points. It basically 
combines the techniques of precision keyins with axis lock-type features into one command to 
help you place, modify or manipulate elements.

AccuDraw is context sensitive. Its behavior changes depending on which drawing tool you’ve 
selected. AccuDraw will evaluate your current position, the previous data point, the drawing 
tools needs, etc. to help you place your next data point. 
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Starting AccuDraw

In the CDOT workspace, AccuDraw automatically loads when you open a design file. If you 
don’t want to use AccuDraw, you can toggle it off by selecting the Toggle AccuDraw button 
from the Primary toolbar.

The AccuDraw Compass

When you start AccuDraw, one of the first things you notice is the AccuDraw compass. The 
compass shows your origin location (current drawing location) and defines your drawing plane. 
There are two different drawing plane modes and, therefore, two different compasses: 
rectangular and polar. 

The rectangular mode allows you to enter coordinates or delta distances, relative to the origin 
point, in an X,Y,Z coordinate system (like an XY=, DX= or DL= keyin). The polar mode 
allows you to enter distances and angles relative to an origin point (like a DI= keyin). 

The AccuDraw Window

The AccuDraw window is where you enter your X,Y,Z or Distance and Angle values. You can 
also lock the drawing axes. The window changes according to your compass mode.

Note: To toggle the compass (rectangular and polar mode), set the focus into the 
AccuDraw window and press <Spacebar>.

You can dock the AccuDraw window at the top or bottom of the MicroStation window, or you 
can float the window into the view.

AccuDraw locks

You’ve seen how to lock your X,Y or Distance, Angle entries you enter in the AccuDraw 
window using the <Enter> key. You can also lock “dynamically” in AccuDraw. Dynamic 
entries are X,Y or Distance, Angle values that are entered automatically as you drag your 
cursor. Use the following keyboard shortcuts to lock dynamic entries:

• <X> – to lock x-axis entries in rectangular mode

• <Y> – to lock y-axis entries in rectangular mode

• <D> – to lock distance entries in polar mode
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• <A> – to lock angle entries in polar mode

Smart Lock

Use AccuDraw’s Smart Lock feature to lock your cursor in one direction only (your pointer 
location). For example, if you’re working in Rectangular compass mode and you only want to 
move in the Y direction, lock your cursor on the Y axis, move your cursor up or down and then 
press < Enter>. You can now only move in the Y direction only. Smart Lock in Polar mode will 
lock your cursor to the closest 90 degree axis.

Smart Lock summary: 

• In Rectangular coordinates, locks X to 0 if the pointer is on the drawing plane; y-axis or Y 
to 0 if the pointer is on the x-axis.

• In Polar coordinates, locks Angle to 0°, 90°, -90°, or 180° if the pointer is on a drawing 
plane axis or otherwise locks Distance to its last entered value.

Rotating the AccuDraw compass

There may be times when you do not want the AccuDraw compass to rotate with the element 
being placed. Instead, you want the compass to maintain its conventional drawing plan mode of 
X-axis horizontal and Y-axis vertical. In this case, press V on the keyboard to rotate the 
compass back to the “view” plane.

Note: When using AccuDraw with the SmartLine tool, there is a SmartLine placement 
Setting (select the drop-down arrow) called Rotate AccuDraw to Segments. Toggle this 
option off if you always want the AccuDraw compass to maintain its conventional 
drawing plane mode of X-axis horizontal and Y-axis vertical.

The AccuDraw keyboard shortcut V will always rotate the compass to the view in which you’re 
placing elements. Therefore, in a 3D file, pressing V in a front view, rotates the AccuDraw 
compass so that the X-axis is horizontal in the front view; whereas pressing V in a top view 
rotates the compass so that the X-axis is horizontal in the top view, etc. Or, you can quickly 
rotate the compass to a particular view by pressing the appropriate keyboard shortcut below:

• T – top view

• F – front view

• S – side view

 

Using these keyboard shortcuts simplifies drawing in 3D. For civil design applications, 
however, most of the time you will be drawing in a top (plan) view.
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Another handy rotation option is Quick Rotate (keyboard shortcut <R> <Q>). This temporarily 
rotates the compass dynamically as you move your cursor. This is handy to rotate the 
AccuDraw compass to match the angle of an existing element to place off of that element or 
when placing cells or text.

Moving the AccuDraw Origin to your cursor location

When you tentative snap to an existing element, press O on the keyboard to move the 
AccuDraw origin temporarily to the tentative location. You can then locate the AccuDraw 
compass off of this tentative point by entering values in the AccuDraw window. If you accept 
the tentative with a data point, you compass “sticks” in this location.

Shortcut snap modes 

AccuDraw provides a shortcut alternative for selecting a few snap modes. Instead of selecting 
the snap mode from the status bar or the Snaps button bar, you can use on of the following 
keyboard shortcuts:

• <N> — Nearest

• <C> — Center

• <I> — Intersect

In addition, you can press <K> to set the keypoint snap division when using AccuDraw.

Deleting Elements

To delete an element:

• Choose the Delete Element command from the Tasks menu

 

• Move your cursor over the element (it will highlight)

Note: The element highlights if Identify Elements Automatically is on in AccuSnap 
Settings. If this option is not on, <D> or snap to identify the element.

• <D> to accept the deletion

Note: Choose Element Select or another tool to get out of the Delete command.



Colorado Department of Transportation   Page 107

A Practical Guide for Using MicroStation V8i SS2 Chapter 6 - Creating Your Design Graphics

Using the Undo and Redo Commands

When you delete an element, it is moved to the Undo buffer, so MicroStation actually 
remembers everything that is placed in the design file, even after it’s gone. You can retrieve a 
deleted element using the Undo command (Edit > Undo). The Redo command (Edit > Redo) 
negates the last Undo command.

The Undo and Redo commands not only work on deleted elements, but on most graphics 
commands. For example, you can place a line, use Undo to remove the line, then use Redo to 
re-place the line.

The Undo buffer is virtually unlimited in size (it’s only limited by the operating system file size 
limit).

The Undo and Redo commands can also be accessed from the Standard toolbar (Tools > 
Standard).

 

Note: Compressing the design file (File > Compress Design), or exiting the design file clears 
the Undo buffer.

Compressing the design file

Select File > Compress > Design to permanently remove deleted elements from the Undo 
Buffer. This will make your design file smaller and more efficient. However, you will lose your 
Undo history for the design file session.

Element Information

Use the Element Information command from the Primary toolbar to analyze an element for 
general and detailed information. 
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Select the element and then <D> on the command to get general information on the element’s 
attributes and its properties (solid, snappable, etc.) You can change any information in the 
General section to update the element. The Geometry section contains information on the 
element’s geometry, including coordinates, size, etc. 
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