A Practical Guide for Using MicroStation V8i Select Series 2

Colorado Department of Transportation

CADD and Engineering Innovation
Updated May 17, 2011
This document has been prepared for the Colorado Department of Transportation by:

Colorado Department of Transportation  Bohannan Huston, Inc.
Project Development Branch  Meridian One
CDOT CADD Department  9785 Maroon Circle
4201 East Arkansas Ave., Rm 290  Suite 140
Denver, CO 80222  Englewood, CO 80112-5919
www.dot.state.co.us  www.bhinc.com

And the following Sub-consultants:

Cad Productivity Incorporated  The Envision Group
PO Box 281195  8517 Excelsior Drive
Nashville, TN 37228  Suite 205
www.cadprodinc.com  Madison, WI 53717
www.envisioncad.com

Copyright

Copyright © 2011 Colorado Department of Transportation. All Rights Reserved

Many of the designations used by manufacturers and sellers to distinguish their products are claimed as trademarks. MicroStation and InRoads are trademarks of Bentley Systems Incorporated. Where other designations appear in this book, and the authors were aware of a trademark claim, the designations have been capitalized.

The Colorado Department of Transportation (CDOT) has accepted this document. By accepting this document, CDOT assumes ownership and all responsibilities associated with this document. This information is subject to change without notice.

Disclaimer

Notice of Disclaimer: CDOT provides documents on an “as is” basis. All warranties and representations of any kind with regard to said documents are disclaimed, including the implied warranties of merchantability and fitness for a particular use. Under no circumstances will CDOT, or any of its officers or employees be liable for any consequential, incidental, special or exemplary damages even if appraised of the likelihood of such damages occurring. CDOT does not warrant the documents against deficiencies of any kind. The use of any of these documents for work which is under contract with CDOT, does not relieve the contractor from any obligation assumed by the contract, or from complete and proper fulfillment of the terms of the contract, nor does it entitle the contractor to compensation for damages or loss which could be attributed to such use.

Notice

This manual may be freely copied or distributed for the purpose of providing the Colorado Department of Transportation and Colorado customers a consistent guide to using the Bentley suite of products to meet CDOT's design and drafting standards.

Software Versions

The software products referred to in this publication are furnished under a license and may only be used in accordance with the terms of such license. This document intended for use with the following software versions:

MicroStation® version 08.11.07.443
InRoads® version 08.11.07.428
CDOT Configuration Version 05.00.00
# Document Conventions

There are several conventions that are used throughout this document to indicate actions to be taken or to highlight important information. The conventions are as follows:

<table>
<thead>
<tr>
<th>Item</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Perimeter</td>
<td>a command name or a file that you are to select</td>
</tr>
<tr>
<td>Tools &gt; Options</td>
<td>a command path that you are to select – usually from the pull-down menus</td>
</tr>
<tr>
<td>Document Name</td>
<td>the name of a document that is not hyperlinked</td>
</tr>
<tr>
<td>Emphasis</td>
<td>style used when referring to important word or phrases</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>style used when you have a direct link to another document on the web</td>
</tr>
<tr>
<td>Key in</td>
<td>entering data with the keyboard</td>
</tr>
<tr>
<td>Quote</td>
<td>style used to indicate an external source quotation</td>
</tr>
<tr>
<td>Note:</td>
<td>text information about a command or process that you should pay particular attention to</td>
</tr>
</tbody>
</table>

1. Numbered Steps  actions that you are to perform as part of the lab activities

   - <D> or Data press the data button on the mouse
   - <R> or Reset press the reset button on the mouse
   - <T> or Tentative press the tentative button on the mouse
# Table of Contents

Document Conventions .................................................. 4

### Chapter 1 - Introduction to CDOT

An Introduction to CDOT V8i SS2 Configuration ....................... 11
Reference Material .................................................................. 11
- A Practical Guide for Using MicroStation V8i SS2 .................... 11
- A Practical Guide for Using InRoads V8i SS2 ......................... 11

Lab Material ............................................................................ 12
- Labs for Using MicroStation V8i SS2 .................................. 12
- Labs for Using InRoads V8i SS2 ......................................... 13

Training Directory Structure ................................................. 13
- Training Directory Structure ............................................. 14
- How To Get Help .................................................................. 14
  - CDOT CADD & Engineering Processes & ProjectWise Website .... 14
  - CADD & Engineering Processes ........................................ 15
  - CADD Manager ............................................................. 15

### Chapter 2 - Getting Started in MicroStation

Design File Basics .................................................................. 17
- Mouse Mechanics .............................................................. 17
  - Using the Mouse ............................................................. 17
    - Wheel Mouse Settings .................................................. 18
- Starting MicroStation ......................................................... 18
- The MicroStation Manager .................................................. 19
- Opening a MicroStation Design File ..................................... 20
- The CDOT Default MicroStation Interface ......................... 20
  - MicroStation Interface Sections ....................................... 21

### Chapter 3 - Levels

Using the Level Display box ................................................. 41
- Saved views ........................................................................... 43

Working with Level Libraries .............................................. 44
- CDOT Level Libraries ......................................................... 44
- CDOT Select Group Environment ........................................ 44
- Using the Level Manager ..................................................... 45
  - ByLevel symbology ......................................................... 46
  - Setting Symbology Overrides ........................................... 48
- Working with Level Filters ................................................ 50
  - CDOT filters ..................................................................... 50
  - Setting the active level ..................................................... 52

### Chapter 4 - Working in a CDOT 3D Design Model

2D vs. 3D ............................................................................... 53
- 2D design plane ..................................................................... 53
Chapter 5 - CDOT MicroStation Workflow

Creating a CDOT Project .................................................. 59
CADD Workflows ............................................................. 60
  Model files vs. Sheet files ............................................... 60
  Model File Workflow for Survey/ROW .............................. 61
  Model File Workflow for Specialty Groups ......................... 63
  Sheet File Workflow for Roadway Design .......................... 64
  Sheet File Workflow for Specialty Groups ......................... 65
Single Source Project Data ............................................... 66
Project set-up on ProjectWise ........................................... 66
Project set-up on the Project Managers Computer .................. 66
  The PCF file ............................................................. 66
  Working in a server environment ..................................... 67
The CDOT Project Directory Structure ................................. 67
  Training Project Directory ............................................ 69
  Training files ........................................................... 69
  CDOT file naming convention ........................................ 69
  Auto-populated files .................................................. 70
  What files go where? ................................................... 71
The CDOT Workspace .................................................... 74
  The Select Group Environment Utility ............................... 75
  Configuration releases ............................................... 76
The CDOT Level Structure ................................................ 77
  Level naming convention ............................................. 78
  Levels and configuration releases ................................... 79
Creating a new CDOT Model file ........................................ 79
  Creating a model file from an auto-populated file ............... 79
  Creating Model files from seed files ............................... 79
CDOT default settings .................................................... 80
  Working Units .......................................................... 80
  Coordinate Readout .................................................... 81
  Referencing other’s work ............................................. 82
Attaching References ..................................................... 82
  Nested References ..................................................... 83
  The Copy Attachment Option ......................................... 84
  Working with Raster Attachments ................................... 84
  Reference Levels ....................................................... 84
Geographic Tools .......................................................... 84
  Geographic Tools ....................................................... 85
  Attaching a Geographic Coordinate System ....................... 85
  Geographic Coordinate Systems and Reference Files ............. 86
  Geographic Coordinate Systems and Image Files .................. 87
# Chapter 6 - Creating Your Design Graphics

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>The CDOT Menu</td>
<td>93</td>
</tr>
<tr>
<td>Opening the Menu</td>
<td>94</td>
</tr>
<tr>
<td>Parts of the Menu</td>
<td>94</td>
</tr>
<tr>
<td>Drop-down menus</td>
<td>95</td>
</tr>
<tr>
<td>CDOT Menu Sections</td>
<td>96</td>
</tr>
<tr>
<td>Placing Graphics</td>
<td>97</td>
</tr>
<tr>
<td>The CDOT Drafting Menu</td>
<td>97</td>
</tr>
<tr>
<td>MicroStation Drawing Tools</td>
<td>98</td>
</tr>
<tr>
<td>Tool Settings</td>
<td>99</td>
</tr>
<tr>
<td>Snap Lock</td>
<td>99</td>
</tr>
<tr>
<td>Snap Modes</td>
<td>100</td>
</tr>
<tr>
<td>Executing snaps</td>
<td>100</td>
</tr>
<tr>
<td>Using AccuSnap</td>
<td>101</td>
</tr>
<tr>
<td>Turning AccuSnap on/off</td>
<td>101</td>
</tr>
<tr>
<td>To snap to an element using AccuSnap</td>
<td>101</td>
</tr>
<tr>
<td>Multi-Snaps</td>
<td>102</td>
</tr>
<tr>
<td>Using Multi-Snaps</td>
<td>102</td>
</tr>
<tr>
<td>Editing Multi-Snaps</td>
<td>102</td>
</tr>
<tr>
<td>Precision keyins</td>
<td>102</td>
</tr>
<tr>
<td>AccuDraw</td>
<td>103</td>
</tr>
<tr>
<td>Starting AccuDraw</td>
<td>104</td>
</tr>
<tr>
<td>The AccuDraw Compass</td>
<td>104</td>
</tr>
<tr>
<td>The AccuDraw Window</td>
<td>104</td>
</tr>
<tr>
<td>AccuDraw locks</td>
<td>104</td>
</tr>
<tr>
<td>Smart Lock</td>
<td>105</td>
</tr>
<tr>
<td>Rotating the AccuDraw compass</td>
<td>105</td>
</tr>
<tr>
<td>Moving the AccuDraw Origin to your cursor location</td>
<td>106</td>
</tr>
<tr>
<td>Shortcut snap modes</td>
<td>106</td>
</tr>
<tr>
<td>Deleting Elements</td>
<td>106</td>
</tr>
<tr>
<td>To delete an element</td>
<td>106</td>
</tr>
<tr>
<td>Using the Undo and Redo Commands</td>
<td>107</td>
</tr>
<tr>
<td>Compressing the design file</td>
<td>107</td>
</tr>
<tr>
<td>Element Information</td>
<td>107</td>
</tr>
</tbody>
</table>

# Chapter 7 - Manipulating and Modifying Design Graphics

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Manipulate Tools</td>
<td>109</td>
</tr>
<tr>
<td>Manipulate Commands</td>
<td>109</td>
</tr>
<tr>
<td>Using the Modify tools</td>
<td>112</td>
</tr>
<tr>
<td>Drawing graphics in 3D</td>
<td>116</td>
</tr>
<tr>
<td>Active Depth</td>
<td>116</td>
</tr>
<tr>
<td>ACS Plane Lock</td>
<td>116</td>
</tr>
<tr>
<td>ACS Plane Snap</td>
<td>116</td>
</tr>
<tr>
<td>Using the CDOT Menu ModElev Add On</td>
<td>117</td>
</tr>
<tr>
<td>CDOT Custom Line styles</td>
<td>117</td>
</tr>
<tr>
<td>Setting the Scale</td>
<td>117</td>
</tr>
<tr>
<td>Changing the scale</td>
<td>117</td>
</tr>
<tr>
<td>Chapter 8 - Cells and Patterns</td>
<td></td>
</tr>
<tr>
<td>-------------------------------</td>
<td></td>
</tr>
<tr>
<td>Understanding Cells</td>
<td></td>
</tr>
<tr>
<td>Cell libraries</td>
<td></td>
</tr>
<tr>
<td>What Are MicroStation Models?</td>
<td></td>
</tr>
<tr>
<td>CDOT Cell Libraries</td>
<td></td>
</tr>
<tr>
<td>The Cell Library Dialog</td>
<td></td>
</tr>
<tr>
<td>Types of cells</td>
<td></td>
</tr>
<tr>
<td>Placing Cells with the Place Active Cell Command</td>
<td></td>
</tr>
<tr>
<td>Placing Cells with the CDOT Menu</td>
<td></td>
</tr>
<tr>
<td>More information</td>
<td></td>
</tr>
<tr>
<td>Creating Cells</td>
<td></td>
</tr>
<tr>
<td>Understanding patterns</td>
<td></td>
</tr>
<tr>
<td>Patterns toolbar</td>
<td></td>
</tr>
<tr>
<td>Placing Patterns with the CDOT Menu</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 9 - Grouping Design Graphics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temporary groups</td>
</tr>
<tr>
<td>Using Selection Sets</td>
</tr>
<tr>
<td>Using Fences</td>
</tr>
<tr>
<td>Semi-permanent groups</td>
</tr>
<tr>
<td>Creating Complex elements</td>
</tr>
<tr>
<td>Add to Graphic Group</td>
</tr>
<tr>
<td>Drop from Graphic Group</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 10 - Creating Sheets</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roadway Design group</td>
</tr>
<tr>
<td>Specialty Groups</td>
</tr>
<tr>
<td>Other sheets</td>
</tr>
<tr>
<td>More Information</td>
</tr>
<tr>
<td>Rotating Views</td>
</tr>
<tr>
<td>Rotate the Plan View with a Keyin</td>
</tr>
<tr>
<td>Rotate the Plan View by 3 Points</td>
</tr>
<tr>
<td>Rotate the Plan View by Element</td>
</tr>
<tr>
<td>Placing Borders</td>
</tr>
<tr>
<td>Using the CDOT Menu for Border Placement</td>
</tr>
<tr>
<td>Creating a Project-Specific Border Cell</td>
</tr>
<tr>
<td>Editing text on the Border</td>
</tr>
</tbody>
</table>
Measurement Tools ............................................................ 154
Measuring in 3D ................................................................. 154
Measure Distance .............................................................. 155
Measure Radius ................................................................. 155
Measure Angle ................................................................. 155
Measure Length ............................................................... 156
Measure Area ................................................................. 156
The CDOT Custom Measure XY Distance tool ...................... 158

Chapter 11 - Tab Sheets
Files Used ................................................................. 159
Entering Data into the Spreadsheet .................................... 159
Linking the Tab Sheet to a MicroStation Drawing ................. 159

Chapter 12 - Annotating and Plotting Sheets
Understanding Text and Text Styles .................................... 161
Text Styles .................................................................. 161
Text Toolbar ............................................................... 162
CDOT Menu text ......................................................... 166
Using the Greek characters font ........................................ 170
Understanding Dimensions and Dimension Styles ................ 170
Dimension Styles ......................................................... 170
Placing Dimensions using the CDOT Menu ....................... 171
Dimension toolbar ......................................................... 173
Using the Match Dimension tool ....................................... 173
Plotting .................................................................. 174
Workflows .................................................................. 174
Printer Drivers .......................................................... 174
Location of PDF files ..................................................... 175
Additional Plotting Workflows ......................................... 176
Assembling Plan Sets ...................................................... 177
Chapter 1 - Introduction to CDOT

An Introduction to CDOT V8i SS2 Configuration

This document outlines the Colorado Department of Transportation’s (CDOT) standardized CADD procedures. Topics are covered in detail and curriculum has been developed providing a foundation for CDOT users to effectively learn. The material covered is structured as a project motivated learning experience modeled after CDOT engineering workflows.

The remaining sections of this document present the reference material for each subject with supporting lab work for the student.

Chapter Objectives:

• Identify the Training Directory Structure
• Where to find MicroStation V8i SS2 and InRoads V8i SS2 reference material
• Where to find MicroStation V8i SS2 and InRoads V8i SS2 lab material
• Where to look for help

Reference Material

CDOT has developed a reference material library for the CDOT user working with the Bentley MicroStation V8i SS2 and InRoads V8i SS2 software.

• A Practical Guide for Using MicroStation V8i SS2
• A Practical Guide for Using InRoads V8i SS2

A Practical Guide for Using MicroStation V8i SS2

This guide breaks down the use of MicroStation V8i SS2 into manageable modules placing emphasis on the CDOT workflow.

♦ Getting Started in MicroStation
♦ Levels
♦ Working in a CDOT 3D Design Model
♦ Creating a CDOT Project
♦ Creating Your Design Graphics
♦ Manipulating and Modifying Design Graphics
♦ Cells and Patterns
♦ Grouping Design Graphics
♦ Creating Sheets
♦ Annotating and Plotting Sheets

A Practical Guide for Using InRoads V8i SS2

This guide breaks down the use of InRoads V8i SS2 into manageable modules placing emphasis on the CDOT design workflows.
Lab Material

CDOT has developed a lab material library for CDOT user’s working with the Bentley MicroStation V8i SS2 and InRoads V8i SS2 software.

- Labs for Using MicroStation V8i SS2
- Labs for Using InRoads V8i SS2

Labs for Using MicroStation V8i SS2

Labs have been created for MicroStation V8i SS2 placing emphasis on the CDOT workflows.

- Getting Started In MicroStation V8i SS2
- Levels
- 3D View Controls
- Creating the Project and Design Model
- Drawing Basics using the CDOT Menu
- Draw the Median Island Nose Section
- Place Guardrail Lines
- Create 3D Utility Graphics
- Create Landscape Graphics
- Create Hydraulics Graphics
- Draw a Bridge Typical Section
• Create Plan/Profile Sheet for the Intersection
• Create a Project Specific Border
• Create a 40-Scale Plan Sheet
• Create a Bridge General Layout Sheet at Different Scales
• Create a General Notes Sheets
• Create the Standard Plans List Sheets
• Create a Title Sheet
• Annotate the Intersection Plan/Profile Sheet
• Annotate the Bridge General Layout Sheet
• Printing to a Printer
• Batch Printing to PDF

Labs for Using InRoads V8i SS2

Labs have been created for MicroStation V8i SS2 placing emphasis on the CDOT workflows.
• Building Components
• Building Sections
• Modifying Templates
• Corridors & Template Drops
• Superelevation Wizard
• Point Controls, Secondary Alignments and Parametric Constraints
• Modifying Single Template Drops and Target Aliasing
• Creating Design Surfaces
• Cross Sections, Volumes and Reports
• Creating Plan Sheets

Training Directory Structure

CDOT has developed a training directory structure replicating a CDOT project directory structure for use in all training. The directory has been designed so the top level (project) directory is used to designate the job project code. During training, the project code will be 12345. Sub-directories for each CDOT specialty group are included under the project directory.
Training Directory Structure

All of the files for class are located in the C:\Projects\12345 directory. This directory structure, as well as the file names used, conforms to the CDOT standards. More information on the CDOT directory structure and file naming convention is found in the Creating a CDOT Project chapter.

How To Get Help

There are many resources available to assist you when working on your CDOT CADD project. These resources can be found on the CDOT CADD & Engineering Innovation website. See the CADD Resources chapter for detailed information on each of these options.

CDOT CADD & Engineering Processes & ProjectWise Website

The CDOT CADD & Engineering Processes & ProjectWise Website is available at: http://www.coloradodot.info/business/designsupport/cadd. The website provides CDOT users with up to date information, tools, and resources related to CADD.

This website is a valuable resource for CADD users and includes:

CADD Library

The CADD Library page provides links to manuals, newsletters, standard details, etc. One extremely useful link is to the Tips and Tricks section for MicroStation and InRoads.

CADD Manual

The CDOT Computer Aided Design and Drafting (CADD) Manual outlines CDOT’s use of Bentley’s MicroStation and InRoads software. It can be accessed several different ways including:

♦ From the Windows Start menu:
  Start > All Programs > _CDOT_CADD_Information > V08.11.XX-V8i SS2 > Workflows

♦ From the CDOT Menu: CDOT Help > Workflows

Request & Support

This page provides CADD help solutions where you can help, submit questions and requests, and obtain InRoads Survey and MicroStation support.

There is also a link to IT Services for hardware support, “how to” instructions, installation, training files, and dual monitor and work space setup.
CADD & Engineering Processes

The CDOT CADD & Engineering Processes Website is available at: http://www.coloradodot.info/business/designsupport/cadd. The website provides CDOT consultants with the latest MicroStation/InRoads configurations, CADD Workflows, manuals, training materials, resources, CADD detail library, CDOT Standards and Design Guides, and more.

CADD Manager

Contact the CDOT CADD Manager at CADDManager@dot.state.co.us for additional help or questions.
Chapter 2 - Getting Started in MicroStation

Design File Basics

This Section identifies the basics of working in a MicroStation V8i SS2 design file. This includes mouse mechanics, opening and navigating in a design file, toolbars, views, snaps, and how to get help.

Chapter Objectives:

- Identify mouse settings and mouse mechanics
- Open an existing MicroStation design file
- Create a new MicroStation design file
- Navigate within a MicroStation design file
- Interface introduction
- How to get help

Mouse Mechanics

There are three types of mouse “points” you can execute in MicroStation. These points correspond to the different buttons on the mouse.

Data point <D> - used to select tools, pull down menus, etc., identify coordinate locations, place and manipulate elements, or confirm actions before they take place. The left button is the default data button. Used when prompted to Accept.

Reset <R> - releases the current operation or rejects a highlighted element. The right button is the default reset button. Used when prompted to Reject.

Tentative <D><R> - used to temporarily locate a point in space or an element. Using the Data point and Reset buttons simultaneously is the default tentative mouse command.

Using the Mouse

Click - tap the mouse button once.

Double click - tap the mouse button twice quickly.

Snap - locate an existing point on an element by using tentative <D><R>, then a data point <D> to accept.
Wheel Mouse Settings

MicroStation V8i SS2 supports wheel mice. You can set your middle wheel to perform several different view control options including zoom in/out, pan radial, pan with zoom, etc.

There are CDOT default settings for the Wheel Mouse.

- **Pan** - this works the same way as most software packages. Once you have clicked the middle button, you get the little hand symbol and while you hold down on the left button the view can be moved or pulled around.

  **Note:** This WILL NOT WORK if you override the tentative button settings.

- **Double Click** - this will expand the viewing area to include all elements within the design file that are currently turned on.

- **Roll** - by rolling the mouse ball, the user can **Zoom In** and **Zoom Out** of the current view.

  - **Alt + Roll** - used to Pan Left and Pan Right.

Default configuration settings can be changed by selecting **Workspace > Preferences > Mouse Wheel**.

Starting MicroStation

To start MicroStation on the Windows platform:

- From the Windows Start Button, select **Start > All Programs > Bentley > MicroStation V8i (SELECTseries 2) > MicroStation V8i (SELECTseries 2)**.

  or

- **Double-click** on the **MicroStation V8 XM** icon located on your desktop.

MicroStation will start and the **MicroStation Manager** dialog box will appear on your screen.
The MicroStation Manager

The *MicroStation Manager* is your file management interface to MicroStation.

By default, a MicroStation design file has an extension of `.dgn`. “Design file” is a generic term used to describe all MicroStation files, regardless of their use - design, drafting, etc. In addition to MicroStation V8i SS2 DGN files, you can also open previous version MicroStation files and AutoCAD files (.dwg or .dxf). This is designated under List Files of Type drop down.

Use the MicroStation Manager icons to move within folders, create a new folder, change the default MicroStation Manager look, create a new file, compress a file, and see past directory history.

In the Workspace category, select

- **User**: Your login name
- **Project**: Your project name - this is the same as your JPC number
- **Interface**: CDOT for the customized CDOT interface settings

For *Training purposes* your workspace settings will be:

- **User**: CDOT User
- **Project**: 12345 (the JPC for this class)
- **Interface**: CDOT
Opening a MicroStation Design File

To open a MicroStation design file:

- Set **Look in:** to the drive containing your file
- Navigate to the correct directory
- Set **Files of type** to **All files** (*.*) (or to the type of file you wish to open)
- Click the file name to highlight the file
- Click the **Open** button to open file

*Note:* MicroStation design files have a default extension of `.dgn`, but can have any extension.

The CDOT Default MicroStation Interface
MicroStation Interface Sections

Pull down menus

- Pull down menus are used to access MicroStation toolbars, settings and dialog boxes.
- An arrow next to a pull-down command indicates sub-menu options.
- ... Indicates a dialog box to open.

Toolbars

- MicroStation’s tools for creating and manipulating your design elements are organized into logical groupings called toolbars.
- Each tool is represented by an icon on its toolbar.
- Toolbars can be opened, closed and moved around the screen like dialog boxes, views and the command window.
- Toolbars can be “docked”,

[Image of MicroStation interface showing pull-down menus and toolbars]
♦ Or “floating” within the drawing workspace.

♦ The most commonly used tools are located on the **Main**, **Colorado DOT**, and **Drawing** Task menus.

♦ The **Tasks** menu opens automatically when you start MicroStation. If you close the **Tasks** menu and want to re-open it, select **Tools > Tasks** from the Menu bar.
♦ Use the Task drop-down menu to display Tasks and toolboxes based on the menu’s hierarchy. Selecting the main task list shows all available task menus. Selecting a task menu shows all of the toolboxes within that task. Selecting a toolbox displays only the tools within that box.

**Customizing the Tasks Menu**

♦ In the CDOT workspace there is a folder called *Standards-Local*. This folder contains all the files that are specific to each individual user.
To setup the MicroStation interface with tools that are specific to the user, the User.dgnlib file has to edited. It is located in:

\Standards-Local\Customizations\MicroStation\CDOT

From within MicroStation, begin by selecting File > Open and browse to C:\Workspace\Workspace-CDOT_V8i\Standards-Local\Customizations\MicroStation\CDOT.

Change the Files of type: to DGN Library Files *.dgnlib and select User.dgnlib and click Open.

Next select Workspace > Customize. The Customize toolbox will open.
♦ To create user defined tool palettes, select the **Tools** tab and click the + next to User Tools.

![Customize window showing Tools tab with User Tools and Application Tools]

♦ Right click on **User.dgnlib** and select **New Tool Box**.

![Customize window showing right-click menu with New Tool Box selected]

♦ Give the tool box a title defining your custom toolbox, "My Tools".

**Note:** From this point, new tools can be created or existing tools can be copied into any user defined tool box.
♦ Adding existing tools by click the + next to Application Tools and then clicking the + next to MicroStation

♦ Scroll down to Linear Elements and click the + to show the available tools.
♦ Right click on *Place Smartline* and select **Copy**.

♦ Scroll back to the top and right click on *My Tools* and select **Paste** to place the tool in your new Tool Box.

♦ Do the same process and copy the Place Active Line Terminator from the Cells tools.

**Note:** A List of Key-ins can be found in the CDOT CADD Manual - 6.6.1 MicroStation Key-in References.
♦ To create a tool from scratch, right click on My Tools and select New Tool. Rename it to Annotation.

♦ In the Key-in field, replace NULL with lv=DRAFT_Text-1; word place text above
♦ Change the **Balloon Text** to **Place Annotation Above**. Balloon Text is what will display when hovering your cursor over the icon.

♦ To select an icon, click in the Icon area and then on the three dots. Change the Look for Icons in: to Applications. Click the + next to MicroStation. Scroll down to text and click the + to view the available icons. Select the Place Text icon and click OK.
♦ Under General Settings, change tool Presentation to Icon Only

Now that we have the tool box built we can add it to the tasks list. On the right, in the Tasks tab, highlight User.dgnlib.
♦ Then Left click and hold the My Tools tool box on the left and drop it to the User.dgnlib in the Tasks Section on the right.

♦ You can now see the customized tool box in the Task area.

♦ Many tools have parameters or settings associated with them, which are shown in the Tool Settings dialog box. Each time you select a new drawing tool, the optional settings will appear in the Tool Settings box.
The Primary Toolbar

- The **Primary** toolbar contains commonly used MicroStation tools.
- This is an **on toolbar** you’ll frequently use, so you will probably want to open and docked.
- Select **Tools > Primary** to toggle on the Primary toolbar.

The Key-in Browser Box

- Many MicroStation commands can be accomplished by keying in the command text (e.g., **Place Line**).
- Key-ins can also be used to input data (e.g., **XY=<x,y,z>** to locate a coordinate).
  
  **Note:** Key-ins are **not** case sensitive.
- This is another toolbar you’ll frequently use. Select **Utilities > Key-in** to open, then dock the box.
- When you’re ready to key in a command, set the focus in the Key-in box by data pointing in it.
- After you key in the command, use the **<Enter>** or **<Tab>** key to activate the command.

Views

- The area where graphics are placed is called a view.
- Up to eight view windows can be opened.
Open and close views from **Window > Views** or the **Views** dialog box.

You can set different view perspectives (top, front, rotated, etc.).

You can also select **Window > Views > Dialog** to open the View Groups toolbar where you can quickly turn views on or off.

You can use the control buttons in the upper right-hand corner to maximize, minimize or close a view.

**Status Bar**

The Status Bar is MicroStation’s command center composed of the following areas (left to right):

- **Select Tool** - displays the name of the active drawing tool.
- **Prompt** - displays the next user operation needed by MicroStation.
- **Information and Messages** - displays current element parameter settings, error messages, etc. A data point <D> in this area activates the **Message Center**.
♦ **Snap Mode** - displays the active snap mode used in conjunction with a tentative point or AccuSnap.

♦ **Locks** - displays a list of locks that you can toggle on/off.

♦ **Active Level** - displays the current level on which graphics are placed. A data point <D> in this area activates the Level Manager.

![Image of Locks]

♦ **Select Set** - displays number of elements in the current selection set. A data point <D> in this area activates selection set commands.

♦ **Fence Mode** - displays the active fence mode setting. A data point <D> in this area allows you to change the active fence.

♦ **Workmode** - a data point <D> in this area displays the current Workmode - DGN, V7, or DWG.

![Image of Workmode]

♦ **Changes Indicator** - if a diskette icon is shown, the file has been modified since opened. If the icon shows a “X”, it means the file is read only.

♦ **Design History** - if the icon is dimmed, Design History is not initialized. If Design History is initialized without committed changes, the icon will include a pencil.

♦ **Dialog with Focus** - indicates what is controlling the input focus. These include Home, Tool Settings, Key-in, AccuDraw, or nothing.
♦  **Digital Rights Status** - File is not protected or signed.

Many of these concepts will be covered in complementary modules.

**Show/Hide toolbar options**

You can select which tools you want to include on any toolbar. This helps streamline your toolbars for the way you work and lets you customize your MicroStation setup.

To show/hide tools, **right click** on any toolbar and toggle the tools on/off as desired. The changes are stored in your MicroStation Workspace.
Controlling the mouse

By default, the left mouse button is the **Data** button, the right is the **Reset** and the left and right together is the **Tentative**.

**Note:** The middle button has been set to be the scroll wheel by default.

You can change these button assignments by selecting **Workspace > Button Assignments**.

**View Control toolbar**

The **View Control** toolbar is located by default in the lower-left corner of the MicroStation interface. The horizontal and vertical scroll bars also help you move around in the view. To use the **View Control** toolbar and scroll bars, turn on the options under **Workspace > Preferences > View Options**. To show the scroll bars, turn on **Scroll Bars on View Windows**. To show the view toolbox settings, turn on **Show View Toolbox** and set the location from the pull down menu.

Use the following View Control tools as follows:

- **View Attributes** - to set view attribute settings.

- **View Display Mode** - to change the view’s rendering options.

- **Adjust View Brightness** - Changes brightness settings on rendered views.
♦ **Update View** - to update a view (refresh or redraw).

♦ **Zoom In** - to increase the magnification of a view by Zoom factor.

♦ **Zoom Out** - to decrease the magnification of a view by Zoom factor.

♦ **Window Area** - to increase the magnification of a view by drawing a “box” around the area you want to see close up.

♦ **Fit View** - to show all displayable elements in a view.

♦ **Rotate View** - to rotate the view (top, front, etc.)

♦ **Pan View** - to move around in the view (up, down, left, right, etc.)

♦ **Walk** - to interactively walk through a 3D model.

♦ **Fly** - to interactively fly through a 3D model.

♦ **Navigate View** - to interactively navigate a 3D view.

♦ **View Previous** - to step back through view operations.
♦ **View Next** - to step ahead through view operations.

♦ **Copy View** - to copy the contents from one view to another.

♦ **Change View Perspective** - to change the Perspective Angle.

♦ **Camera Settings** - to adjust the Camera in a 3D view.

♦ **Clip Volume** - to apply Clip Volume to a view.

♦ **Clip Mask** - to apply Clip Mask to a view.

You can set your middle wheel to perform several different view control options including zoom in/out, pan radial, pan with zoom, *etc.* These options are set under **Workspace > Preferences > Mouse Wheel.**
Setting Views for dual monitors

The default CDOT MicroStation workspace is set up to recognize dual monitor machines. However, in case these settings are changed, follow the steps below to reset this feature.

- **Start** MicroStation
- Select **Workspace > Preferences > Operation** and toggle on **Open Two Application Windows**.

- **Select** **File > Save Settings**
- **Exit**, then restart MicroStation

When MicroStation starts this time, it will open two different windows.

You can drag one window to the second monitor. *(Click on the title bar and drag the window - don’t stretch it)*. When you maximize the window, it will fill the screen, but remain on the monitor where you placed it rather than trying to span the monitors. In MicroStation, Views 1-4 open in application window 1, while Views 5-8 open in application window 2.
You can drag most MicroStation windows from one monitor to the other, but there are some that will not allow dragging. If you run into one, pick the Bentley logo in the upper left corner and choose Change Screen to move the dialog box or menu to the other screen.
Chapter 3 - Levels

This Section identifies the basics of working in a MicroStation V8i SS2 design file. This includes mouse mechanics, opening and navigating in a design file, tool bars, views, snaps, and how to get help.

Chapter Objectives:

- Using the Level Display box
- Describe creating and using Saved views
- Discuss how to work with Level Libraries
- Discuss using Group Environments
- Describe how to use the Level Manager
- Discuss using level overrides
- Discuss using level filters

Levels help you separate graphics in the design file and for plotting. By placing your graphics on different levels, you can easily control what graphics to display by turning the appropriate levels on or off. Levels are synonymous with layers in AutoCAD.

By using a standard level structure defined in your CADD standards, you can create a logical design file. Everyone in the organization knows exactly what graphics are on what level by referring to the CADD standards. This improves the CADD workflow efficiency.

Levels are named and numbered and you can then turn levels on or off by name or number. There is no limit to the number of levels you have in a design file.

The level on which you place graphics is known as the **active level**. When you set a level active, it is automatically turned on.

Using the Level Display box

Access **Level Display** from **Settings > Level > Display** or from the **Primary** toolbar.
The **Level Display** is used primarily to turn levels on and off in the views selected. You also have the option to turn levels on or off by selecting an element (**right-click <R>** on a level or **click** the **Change Level** button).

There are three display modes:

- **View Display** – turns levels on/off in the chosen view(s).
- **Global Display** – turns levels on/off in all views.
- **Global Freeze** – elements in selected view(s) are not displayed, cannot be plotted and graphics cannot be placed on a frozen level.

In addition to the above options there are two other view display options.

- **Apply To Open Views** - Applies the level settings to all views.
- **Apply To Selected View** - Applies the level settings to views selected by the user.

**Note:** you can also turn levels on or off with the following key-ins:

- `on=<level name or number>`
- `off=<level name or number>`
Note: <D> and drag across levels in Level Display to select multiple consecutive levels or use <Ctrl> to select non-consecutive levels. Right-click <R> on any level name to quickly turn all levels off/on.

Saved views

Once you have defined a view’s parameters (area of display, levels, etc.), you can save the view for recall later. For example, you can Zoom In on an intersection, turn on all necessary levels and then save the view. Then, no matter where you are in the design file, or what levels you’ve turned on or off, you can always return to the intersection saved view with the appropriate levels turned on.

To save a view, either:

- Access the Saved Views dialog box from Utilities > Saved Views and use the Save View icon.

- Or, use the sv=<view name,description > key-in (e.g. sv=intersection)

  You can later recall the save view from the Saved Views dialog box or use the key-in vi=<view name >.
Working with Level Libraries

So, where do the levels come from? Levels are obtained from a level library. A level library is a master template of levels, which is attached to your active design file. Libraries can be separated by type: (Bridge, Roadway Design, Survey, etc. Users can then attach multiple level libraries to an active file.

CDOT Level Libraries

CDOT level libraries are attached as a file type DGNLIB. A DGNLIB file is the same format as a DGN file (they can be opened just like a DGN file in MicroStation) but with a .dgnlib extension. Typically there are no graphics in a DGNLIB file – just level setups. DGNLIB files can also be used to store text styles and dimension styles.

The following CDOT level libraries (DGNLIB files) are currently available:

1. Alignments
2. Bridge
3. Construction
4. Drafting
5. General
6. GIS
7. Hydraulics
8. Landscape and Environmental
9. Materials and Geotechnical
10. Roadway Design
11. ROW
12. Survey
13. Topo
14. Traffic
15. Utilities

CDOT Select Group Environment

The CDOT discipline-specific DGNLIBs are automatically attached via the **CDOT Select Group Environment** program. When attached, levels from the library are available for use in the active design file. When graphics are placed on a level from the library, the level is copied from the library into the active design file.
Access the Select Group program from the _CDOT_CADD_Information program group on your computer’s Windows Start menu (Start > All Programs > _CDOT_CADD_Information > Select Group Environment). This program provides you two options: Bridge and xxMulti-Discipline. The Bridge option will attach only those libraries necessary for the Bridge specialty group. All other groups will choose the xxMulti-Discipline option, which attaches all level libraries so you can work across disciplines.

Level libraries selected via the CDOT Select Group Environment will be automatically attached to any design file opened with MicroStation after running the program. You only have to run the utility again if you need to switch groups.

Using the Level Manager

The Level Manager is used to set level properties (name, description, number, display, plot, symbologies, etc.) and is located next to Level Display on the Primary toolbar.

You can also access Level Manager from **Settings > Level > Manager.**
The Level Manager shows a list of all levels attached and the library the level is in. Additional information can be displayed by right-clicking in the column headings and turning columns on/off – information such as the level number, description, and its ByLevel Symbology.

**ByLevel symbology**

**ByLevel** symbology is the color, line style and line weight assigned to a level. When graphics are placed on that level, the elements take on the level’s symbology. The combination of naming levels and using **ByLevel** symbology is a good way to ensure CADD standards are maintained.

**Note:** CDOT has established **ByLevel** symbology for all its standard levels to conform to CDOT CADD standards. The **ByLevel** symbology is stored with the level in the level library. You should not change the **ByLevel** Symbology.
You can review a level’s **ByLevel** symbology by turning on the appropriate columns in the **Level Manager**.

![Level Manager](image1)

You can also obtain level properties by selecting **Level>Properties** from the **Level Manager**.

![Level Properties](image2)

The **Attributes** toolbar is where you can set the **Active Level** (the level on which you will place graphics), which in turn sets the **ByLevel** symbology for the graphics. After making your selection, the **Attributes** toolbar shows you a preview of the **ByLevel** symbology for that level. Hold your cursor over the symbology preview for a description of active color, style and weight.
**Note:** Unless you have specific reasons or permissions not to, you should *always* use **ByLevel** symbologies when creating elements.

![Attributes toolbar](image)

**Note:** The CDOT menu automates the process of setting the proper level and ByLevel symbology for drawing elements.

The Attributes toolbar provides other useful information. In addition to showing the active level, it also shows if the level is turned on/off (global setting – all views), if it is locked (graphics on the level can not be deleted or modified), and the ByLevel color.

![Attribute Manager](image)

### Setting Symbology Overrides

The **Level Manager** is also where you set level **Symbology Overrides**. You can set a different symbology for each level. For example, you may want to “dither out” (to show faintly, typically using a gray color) graphics on a specific level before plotting by setting color, style and weight to 0.

**Note:** If you need to override the **ByLevel** symbology of an element for a special plot, for example, you should do so by setting the **Symbology Overrides**. Do not change the **ByLevel** symbology.
Set **Symbology Overrides** under **Level > Properties**.

After setting symbology overrides (or if the ByLevel symbology has been changed), a dot appears in the **Modified** column beside the level to let you know that has been changed from the library standards. To synchronize the level back to the library standards, select Update Levels from Library.
View Attributes and Symbology Overrides

The View Attributes box (Settings > View Attributes) is where you tell MicroStation what you want to see (or not see) in a view. For example, you can turn all text in the view on or off. You can also turn off line weights (thicknesses) or line styles (solid, dashed, etc.) to show all graphics the same. If you have set Symbology Overrides in the Level Manager, you have to turn on Level Overrides in View Attributes before the override takes affect.

Symbology Overrides only affect how graphics are displayed (the element attributes are not changed, just temporarily overridden), whereas ByLevel symbology actually sets or changes the element’s attributes.

Note: More information on how to set up shaded color and grayscale printing is available in the Annotating and Plotting Sheets chapter.

Working with Level Filters

Level filters are named groups of levels that can be turned on or off as a group (e.g. all road design levels, all survey levels, all topo levels). You can filter on many criteria (name, number, etc.) to create the groups.

CDOT filters

Several pre-defined CDOT filters are available for your use. These filters are obtained from the various discipline-specific CDOT level libraries attached via the Select Group Environment program. The filters have been defined based on logical groups of levels that you normally work with (e.g. Cross Section, Profiles, Surface for the Design group, Existing, Easements, Ownership for the ROW group.)

Setting filters

Use Level Display to turn the filters on or off. Set the Show option to Filters, and then select the filter from the list. This turns the entire group of levels on/off.
When working with levels, it is often easier to work with just a subset to quickly find a level to set active or turn on/off. In this case, you can “filter down” your levels by setting the Show Option to Levels and then changing the List Filter option from (none) to the desired filter.
Filters can also be set on the Attributes toolbar when setting the active level.

Setting the active level

The active level is the level on which you will place graphics, using the level’s ByLevel symbology. There are many ways to set the active level including:

- **Double-clicking <D><D>** the level in Level Display
- **Double-clicking <D><D>** the level in Level Manager
- **Right-click <R>** in the Level Manager and choose **Set Active**
- **Using the lv=<name or number >** key-in
- **Selecting** the level from the **Attributes toolbar**

The active level appears highlighted in the Level Display and Level Manager boxes.
Chapter 4 - Working in a CDOT 3D Design Model

This chapter covers the difference between working in 2D and 3D model, and the 3D concepts you need before moving on to InRoads or other 3D applications.

**Chapter Objectives:**

- Describe the 2D design plane and the 3D design cube
- Explain how to use Active Depth in 3d drawings
- Explain how to use Display Depth in 3d drawings
- Identify the 3D seed file default depth settings

**2D vs. 3D**

**2D design plane**

In MicroStation, you can create either 2D or 3D models within a design file. In a 2D model, the working area is known as the **design plane**. A 2D design plane is similar to drawing on a sheet of paper. You have an X (horizontal) and Y (vertical) axis and all graphics placed in the 2D file are “flat”.

You can rotate the 2D design plane about its perpendicular axis (the Z axis coming out of the screen).

**3D design cube**

In a 3D model, your work area is called the **design cube**. You’re working in a volume of space with 3 axes — X, Y and Z. When you place elements, you can place them not only in the correct horizontal (X, Y) location, but also in the correct vertical (depth or Z) location to create a true 3D model of your design.
In the design cube, different view orientations can be set. These include: Top, Bottom, Front, Back, Right, Left, Isometric, and Rotated.

Think of a view as a camera location that’s taking a snapshot of your design. When you rotate a view, you’re not rotating graphics. Instead, you’re rotating the camera position (or the orientation) of how you’re looking at the graphics.

Each “face” of the design cube is a standard view (Top, Front, etc.) In addition you can set an isometric view and you can rotate any view about the X, Y or Z-axis. For most civil drafting and design work, the top view is synonymous with the plan view and the front view is synonymous with the elevation view.

Set view orientations by using either:

♦ The Rotate View command on the View Controls toolbar

♦ The vi= <view name> key-in (e.g. vi=top).
♦ The rv= <x,y,z> keyin to rotate a view about the x, y and/or z axis (e.g. rv=,-30 rotates a view 30 degrees clockwise about the z axis).
Using Active Depth

When working in a 3D design model and placing graphics in a view, at what depth are the graphics being placed? They are placed at the active depth. The active depth is a plane, parallel to your view screen, on which you’re placing elements. For example, if you are creating a topo map and manually drawing the 5000-foot contour in the top view, you first set the active depth for the top view to 5000, and then draw the contour.

To set a view’s active depth:

- Key in `az=<depth>`.  
- `<D>` to select the view of interest.

The active depth is view dependent. Therefore, you must tell MicroStation which view you’re setting the active depth in by data pointing in the view.

**Note:** For most civil work, you’ll set an active depth in the top (plan) view. The active depth is then the elevation at which you’re placing graphics. If you switch to a Front view, you’ll see the elements at the different elevations.

Active depth is synonymous with the term active z.

To check a view’s current active depth:

- Key in `az=$`  
- `<D>` in the view of interest

The current active depth is displayed in the message field.

**Note:** Use the delta key-in `dz=<depth>` to move the active depth by the delta `<depth>` amount, then `<D>` in the view. Multiple data points change the depth each time.
Using Display Depth

*Display depth* is the depth range or the “slice” of the design cube in which elements are visible. You set the display depth by specifying an upper and lower depth (elevation) range for the view.

![Diagram showing upper and lower depth limits](image)

To set a view’s display depth:

- Key in `dp=lower depth, upper depth`
- `<D>` in the view of interest

*Note:* Like active depth, display depth is also **view dependent**. So you have to tell MicroStation which view you’re setting the display depth range for by data pointing in the view (the top view in most cases). This allows you to have different display depths in different views.

**Display Depth tips:**

- Display depth limits are also known as the view’s **clipping planes**.
- A view’s active depth is always within its display depth range (i.e. you can not set an active depth outside the display depth).
- Use the key-in `dd=delta lower depth, delta upper depth` to expand the display depth by the delta amount. This moves the display depth as specified from its current location.
- The **Fit** command automatically changes a view’s display depth (expands or shrinks to fit elements currently turned on in the view).

*Note:* If you can’t see graphics in a 3D model, they may just be outside your display depth. Fit your view as a quick check.

- The current active and display depth settings are saved when you save settings (**File > Save Settings**). This determines the default depth when you open a design file.
To check a view’s display depth:

- Key in \texttt{dp=}.  
- \texttt{<D>} in the view of interest

The view’s current display depth is displayed in the message field.

<table>
<thead>
<tr>
<th>Show Display Depth</th>
<th>Select view</th>
<th>View 1: Display Depth=1000.000,15000.000</th>
</tr>
</thead>
</table>

**CDOT 3D Seed File Defaults**

The CDOT default settings for active and display depth are set in the CDOT 3D seed files for each specialty group.

**Active Depth**

The CDOT default setting for active depth is \texttt{0}.

**Display Depth**

The CDOT default setting for display depth is \texttt{-1000, 15000}.  


Chapter 5 - CDOT MicroStation Workflow

Now that you are comfortable working in a MicroStation design file, you are ready to learn how CDOT specifically uses MicroStation in the project process. This section concentrates on how CDOT creates model file graphics by utilizing the CDOT Menu. It also covers the sheet file creation process. Once your sheets are created, you will learn how to annotate, dimension and plot the sheets.

Chapter Objectives:

- Describe the differences between “Sheet” files and “Model” files.
- Discuss the workflow for adding data to model files based on the specialty group
- Discuss the workflow for adding data to sheet files based on the specialty group
- Discuss the benefits of using single source data for project design
- Describe using the Create Project Utility program
- Describe the use of the PCF file
- Discuss the CDOT Project Directory Structure
- Describe how to create new model files
- Discuss working with reference files and raster images

Creating a CDOT Project

This chapter is a general overview of the entire CDOT workflow to complete a CADD project using MicroStation. You will learn how to set up a CDOT project and create your design model file and reference other discipline’s files.
CADD Workflows

**Model files vs. Sheet files**

To understand how CDOT uses MicroStation for design and drafting, you first need to understand the difference between Model files and Sheet files. **Model files** contain the design graphics. These are the working files for your design. Each group has at least one Model file, but can have multiple model files for different types of graphics. For example, the Roadway Design group can have a model file for plan graphics and another model file for profile graphics. The Traffic group may have separate model files for signs, signals and lighting.

**Sheet files** are the files that will be plotted for the creation of a plan set. Sheet files reference model file graphics. A reference is just a MicroStation file attached to your active file (the file you have opened). You can reference multiple model files to create a sheet file. For example, a Bridge general layout sheet may reference the existing survey/topo model, the proposed roadway design model and the proposed bridge model to show all of the needed information on the sheet. A Plan Profile sheet (shown below) references the proposed roadway design model and the profile model.

Sheet files typically do not contain design graphics since they are referenced from the model files. You can’t modify the model file reference graphics in a sheet file; they are there for information only. The sheet files, however, do contain the border and associated information (bar scale, north arrow, etc.) along with text and dimensions, which can be modified since these elements are placed directly in the sheet.
For more information on References, see the section Referencing Other’s Work in this chapter.

**Model File Workflow for Survey/ROW**

To create existing model files, the Survey/ROW group uses MicroStation and InRoads Survey to reduce the electronic fieldbook data and create model files for ROW, survey planimetrics and existing topographies. These existing model files can then be referenced by Design and specialty groups as a base for creating the proposed model files.
Model File Workflow for Roadway Design

To create proposed design model files, the Roadway Design group references the existing survey/topo and ROW models to begin the design. MicroStation and InRoads are then used to create the proposed graphics in various model files – plan, profile, intersection, etc. Occasionally, other specialty group model files are needed by Design, so these model files may be attached as reference files.

![CDOT MicroStation Model File Workflow](image)
**Model File Workflow for Specialty Groups**

Each specialty group references the Roadway Design group’s proposed model file to begin their design. MicroStation and other specialty programs are used to create the graphics in separate model file(s) for each group. When a specialty group references Design’s model file, they can choose to reference the existing model file(s) from the Survey/ROW group as well. This way, both existing and proposed graphics can be displayed in the specialty group’s model file, if needed.
Sheet File Workflow for Roadway Design

To create sheets (specifically plan or plan/profile sheets in this example), the Design group creates a new MicroStation design file for each sheet. Then, the proposed model file is referenced into the sheet file. Since the proposed model also has the existing model file referenced, the survey graphics can be displayed in the sheet. The sheet file view is rotated, if needed, so graphics appear horizontal. Then, only the portion of graphics needed for the sheet is “clipped” out from the reference. The border, north arrow, bar scale and Resident Engineer information is then placed directly in the sheet file via the CDOT Menu. Many generic sheet files also contain a border, which can be edited. The sheet can be annotated with MicroStation text and the reference graphics dimensioned, if required. Unlike reference graphics, text and dimensions are placed directly in the sheet file and, therefore, can be edited in the sheet.

Other sheets such as detail, title, general notes, etc. have specific requirements, but use the same general premise of referencing the model file(s) to the sheet file. Typical Section sheets are an exception to the rule, since graphics are created directly in the sheet file using the CDOT Typical Section Program.
Sheet File Workflow for Specialty Groups

Specialty groups create a separate MicroStation design file for each sheet, and then reference their own model file(s) into the sheet file. Since this model file can also have Roadway Design and ROW/Survey’s model files referenced, these graphics can be displayed in the sheet. The sheet file view is rotated, if needed, so graphics appear horizontal. Then, only the portion of graphics needed for the sheet is “clipped” out from the reference. The border, north arrow, bar scale and Resident Engineer information is then placed directly in the sheet file via the CDOT Menu. Many generic sheet files also contain a border, which can be edited. The sheet can be annotated with MicroStation text and the reference graphics dimensioned, if required. Unlike reference graphics, text and dimensions are placed directly in the sheet file and, therefore, can be edited in the sheet.

Other sheets such as detail, tab, and note sheets have specific requirements.
Single Source Project Data

There are two methods of setting up a project that can be used to effectively manage a single source of project data:

♦ Create the project in ProjectWise (Preferred Method)
♦ Create the project on the Project Managers computer

Project set-up on ProjectWise

ProjectWise is a document management system primarily for use with the MicroStation and InRoads software. Other software such as the Microsoft Office Suite can also be integrated into the ProjectWise environment. ProjectWise provides a secure environment where project information can be stored. ProjectWise allows for file check-in/check-out for editing and read only access for checked out files.

For information about using ProjectWise, once the project has been created, refer to:
ProjectWise User Guide.pdf

Project set-up on the Project Managers Computer

If the project is to be stored on the project manager’s computer, use the Create Project Utility to create the proper directory structure. For more information on using the Create Project Utility, refer to:
CDOT Project Creation and PCF File Management

contact your IT administrator for help in creating a shared drive for a locally stored project. Administrator privileges are required to setup a shared drive.

For references to work properly, everyone will need to map to the shared drive using the same drive letter and path.

The PCF file

The Project Configuration File, created by the utility, defines a specific directory that MicroStation defaults to when opening up a DGN file or referencing model files. PCF files are extremely useful when multiple users are accessing the same project directory across the network, or when DGN files are moved from one directory to another.
**Working in a server environment**

If multiple users are accessing the same project directory, the PCF file will need to be distributed to everyone on the team accessing the project directory. Each member of the team should have their own copy of the PCF file and it should be saved to the same location, C:\Program Files\Workspace-CDOT\Standards-Local\Projects. The PCF is also useful for managing references. If a reference file is moved, you should never have to reattach it. You can use the PCF to manage the reference locations.

When team members are sharing the Project Manager’s machine, the PCF file will need to be edited. See the Workflow **CDOT PCF Management** for more information.

**The CDOT Project Directory Structure**

The *Project Creation utility* creates the project directory structure on the server or PM’s computer. All CDOT projects should follow this structure to ensure the accurate sharing of information between groups within the Department as well as outside consultants. The CDOT Project Directory’s top level designates the project code. Below this folder is a set of standardized sub-directories for each CDOT specialty group. Under each specialty group folder is a sub-directory structure unique to that specialty group.
For more information about the CDOT project directory structure, see the CDOT CADD Manual, Chapter Three – Project Directory Structure, section 3.2 – Directory Structure.
**Training Project Directory**

For this training class, you will create a project directory structure with an example Job Project Code (JPC) of 12345 shown below. The Roadway Design group’s sub-folder is shown expanded to show an example of a group’s sub-folder structure.

**Training files**

The training lab files for CDOT CADD courses can be accessed from the Windows Start Menu. Select **Start > All Programs > _CDOT_CADD_Information > V08.11.XX-XM > Training Files > Insert training files on my computer**. A link is also available on the Training page of the CDOT CADD web site.

**CDOT file naming convention**

Model files and Sheet files need standard, informative, and unique names to allow easy identification of the specialty group responsible for the file and the type of information contained within the file. All CDOT CADD drawings created should follow this naming convention so the data can be easily identified and shared by all users.
The CDOT file naming convention contains the Job Project Code, a specialty group identifier, short standardized file name, an optional annotation scale identifier, an optional description, and file extension.

![Diagram of file naming convention]

An example of a MicroStation design file would look like the following:

**12345DES_Model100US285.dgn**

12345 indicating the CDOT Project Number, DES indicates it is Roadway Design’s model file and 100 indicating it uses a 1”=100’ annotation scale, US285 is a description identifying the highway this model depicts. .DGN is the default extension for MicroStation design files.

**Note:** A seventh segment is used on Working Files. This segment should be the initials of the designer or engineer who is working on the file. Example: **JS12345DES_Model100.dgn** where JS are the initials of the designer or engineer (in this example, JS stands for “John Smith”).

For more information about the CDOT project directory structure, see the CDOT CADD Manual, Chapter Four – File Naming Convention.

### Auto-populated files

In addition to creating the project directory structure, the Project Creation Utility also creates several auto-populated drawing files that have the CDOT standard file names already assigned. The # symbol is used for the counter. When creating a new file, one option is to open the appropriate auto-populated file in MicroStation, select **File > Save As** and then rename the file.
The diagrams below shows an example of auto-populated files automatically created for the Roadway Design group.

**What files go where?**

As you’ve learned there are two main types of CADD files for a CDOT project: **Model files**, which contain graphics for referencing into sheets, and **Sheet files** which generally contain either references to model files or non-design related items such as general notes, special symbols, quantities, sheet borders, etc.
Working Model files

Working files (or sketch files) are model files containing graphical data created during the design workflow. These files should be placed in the "Working" folder in each group’s sub-folder. The file name should include the designer's initials. These files are not to be considered final design files, and should not be referenced to sheet files or other reference model files. An example of a working file would be: //12345/Design/Working/JS_12345Des_Model100.dgn

Reference Model files

The most up-to-date model files which are available to other groups for referencing, that only have the most current non-sketch or working information in them, should be placed in the group’s Drawing > Reference_Files folder. The designer’s or engineer’s initials should be removed after moving this file.

Sheet files

Sheet files are typically stored in a group’s Drawings folder, as shown.
Plot files

When sheet files are plotted to PDF, the plot files are placed in the project’s Plot_Sets folder. Sub folders for AD, FIR, FOR and ROW are available.

For more information, see the CDOT CADD Manual, Chapter Three – Project Directory Structure, section 3.2.2 – Group Sub-Directory Structure.
See also:
- *CDOT CADD Manual, Chapter Four – File Naming Convention, section 4.2 File Types*
- *CDOT Directory Structure Workflow.*

**The CDOT Workspace**

The CDOT Workspace is a custom environment designed to facilitate CADD productivity and direct the user to CDOT-specific standards, workflows and processes. The CDOT Workspace is a complex set of configuration files, MicroStation and InRoads resource files, workflow documents, and many other customized tools, all designed to work together to increase productivity and efficiency, and allow for a standardized project plan set output. Some of the items in the workspace include:

- Seed files (starter files that contain MicroStation settings for creating new files)
- Cell libraries (standard details, symbols, notes, etc.)
- DGN libraries (standard level structures, text styles and dimension styles)
- Line style resource files (custom line styles)
- Font resource files (special fonts)
- Plot drivers (for plotter configuration and PDFs)
- Pen tables (for special plotting preferences for certain graphics)
- InRoads preference files (for controlling InRoads graphical displays)
- InRoads templates (for standard typical sections)
- CDOT configuration files (to set the correct MicroStation resource files and other standard files located on the user's computer)
- Workflow documents (CDOT standardized procedures for specific MicroStation and InRoads tasks)
- CDOT Group Menus (access to tools and applications which provides a simple, efficient method of applying CDOT’s CADD standards to every project)

The installation of the Workspace will be controlled and maintained by the Information Technologies (IT) Department. You can manually update the workspace at any time by selecting the **Start > All Programs > CDOT_CADD_Information > Update MicroStation-InRoads Standards.**
The CDOT workspace and configuration files are located on each user’s computer in the `C:\Workspace` folder.

**The Select Group Environment Utility**

The *Select Group Environment* utility automatically attaches the correct level libraries needed for working on a CDOT project. This utility also provides CDOT users additional MicroStation resources unique to their group (group-specific cells, seed files, linestyles, levels and symbology, etc.) The utility must be run prior to starting MicroStation in order to set up tools specific to that user’s group.

There are two group options: *Bridge* and *xxMulti-Discipline*. The multi-discipline environment enables MicroStation to have all the cell libraries, level libraries and filters, available at anytime with out having to load these items individually. The Bridge option loads just the specific files needed for the Bridge group.

The Select Group Environment Utility can be run from the user’s computer through the Start button *Start > All Programs > _CDOT_CADD_Information > Select Group Environment*. You MUST exit MicroStation prior to running this utility.

For more information on the Select Group Environment, see the *CDOT CADD Manual, Appendix F - Select Group Environment Utility*.

For more information on the CDOT Workspace in general, see the *CDOT CADD Manual, Chapter Two - CDOT Workspace*. 
Configuration releases

The IT Department is responsible for updating your computer when the CDOT workspace and configuration is updated. For a detailed description on what’s in the new configuration release, see the CDOT Configuration ReadMe workflow.
You can also access this workflow and others (in PDF format) from the CDOT workspace in the **CDOT Notes** sub-folder.

**The CDOT Level Structure**

Thirteen Specialty Group Design File Level Libraries (DGNLIBs) are available for use within CDOT. The level libraries are attached to the MicroStation design file via the **Select Group Environment** utility and provide the CDOT approved standard discipline levels for use when placing graphics. You can not create, edit or delete levels within the CDOT Workspace – you must use the levels provided in the DGNLIBs. Likewise, you can not modify the level's symbology, thereby maintaining “ByLevel” status for standardization purposes. ByLevel symbology is used by default for all level libraries and is the required standard for plan set creation. CDOT has adopted an “existing vs. proposed” leveling scheme, whereas with the use of pen tables, all existing design data will plot gray scale. Level duplication across disciplines has been avoided wherever possible.

Level libraries (DBNLIBs) are stored in the CDOT workspace (**C:\Workspace\Workspace-CDOT_XM\Standards-Global\MicroStation\DGNlib**).
For more information about the CDOT level structure and a list of all discipline level libraries, see the CADD Manual, Chapter 5 – Drafting Standards, section 5.3 – Design File Level Libraries. You can link to a specific group to review its standard level structure.

**Level naming convention**

The standard CDOT level naming convention shown below is used to allow for easy filtering of levels in MicroStation’s Level Display or Level Manager.

```
ALG_APPROACHROAD_Hor-Alignment
```

- **DGNLIB abbreviation**: ALG
- **Main filter name or category**: APPROACHROAD
- **Secondary filter name or category (Optional)**: Hor
- **Main description word**: Alignment
- **Secondary description word (Optional)**
Levels and configuration releases

When a new configuration is released, it is not unusual for the CDOT Standards and Configuration committee to add, change or delete levels from the level libraries. If you’re working on a project, you will need to update the used levels in a design file to the new configuration standards. Each new configuration release includes a comma separated variable (CSV) file that maps old levels to new levels. You will need to apply this level mapping to all existing files that you wish to update to the new configuration. Refer to the CDOT Level Update workflow for more information.

Creating a new CDOT Model file

When you’re ready to create a new model file to begin your work, you have two options:

- Create the new file from an auto-populated file
- Create the new file from a seed file

Creating a model file from an auto-populated file

Auto-populated files are created by the Project Creation utility. The model files are created in the group’s \Drawing\Reference_Files folder. You can rename these files and save them to the project’s \Design\Working folder to create your new model file.

Creating Model files from seed files

A seed file is a “starter” file. It has all CDOT standard settings for each specialty group. Seed files are either 2D or 3D, so make sure you choose 3D when creating model files.
See the *CDOT CADD Manual, Chapter Five – Drafting Standards, section 5.2 – Seed files* for more information.

**CDOT default settings**

When a new file is created from a seed file or auto-populated file, there are several settings already established that conform to the CDOT standards. Two important settings include *Working Units* and *Angle Readout*.

**Working Units**

The working units in either a 2D or 3D file determine the measurement system for the design file. Working units are defined as:

- Master Units:Sub Units
- MU:SU

You set a design file’s working units for any desired measurement system. For typical imperial units (English), you could set Master Unit to *feet* and Sub Units to *inches*. The working units would then be expressed as **1:12**. If you set Master Units to *Feet* and Sub Units to *tenths of a foot*, your units would be expressed as **1:10**.

**CDOT standard Working Units**

CDOT standard working units are 1:12 and expressed as:

1. Master Units = Survey Feet (’)
2. Sub Units = Survey Inches (”)  

There are two types of unit definitions for imperial feet – survey and international. These have a slightly different conversion factor from metric. CDOT uses the survey foot definition.
The working units settings are found under Settings > Design File > Working Units.

![Design File Settings](image)

**Entering data**

When you enter data for lengths, distances, etc. you use the format for working units: **MU:SU**. You can enter data in just master units, just sub units, or both. For example, if your working units are 1:12 (feet and inches), and you want to place a line with a length of 1 foot 1 ½ inches, you could enter the length as:

- 1.125
- 1: 1 1/2
- :13 1/2

**Note:** You can use either fractions or decimals when entering data.

**Coordinate Readout**

Use Settings > Design File > Angle Readout to determine how MicroStation values are displayed. This is helpful, for example, when you measure graphics. The CDOT standard coordinate and angle readouts are shown below. These settings are copied over from the seed file.

![Design File Settings](image)
You can set your linear values to readout in master units, sub units or both. Angles can readout in either degrees-minutes-seconds (DD MM SS) or decimal degrees (DD.DDDD) with up to 8 decimal place accuracy.

**Referencing other’s work**

A Reference is a file that is attached to your active file, so that you can see the file’s graphics. Reference graphics are not actually in your active file, but serve as background data. You cannot modify reference graphics from the active file. You can, however, copy graphics from the reference model to the active model and then modify them, if desired. Using references is a good way to copy a large number of graphics from model to model.

The proper use of MicroStation References is critical to achieving two key components of the CDOT MicroStation workflow:

1. Maintaining a single source for project data.
2. Sharing graphical data between specialty groups.

References allow multiple users to work on different parts of a project at the same time. Multiple users can access the same reference from a central location (e.g. project directory on the PM’s computer). Specialty groups can interact throughout the design process by referencing other discipline-specific model files. The data exchange between disciplines is “real time” when using MicroStation References.

References are useful in the plan set creation phase. You can “build” the sheets by referencing in the individual model files (survey/topo, design, utilities, etc.) Each discipline’s Master Model file can reference other discipline’s model files, as needed. The Master Model file can then be referenced into a newly created sheet file. You can also reference in details and show these at a different scale on the same sheet.

**Attaching References**

To attach references, select References from the Primary toolbar. In the References dialog box, select *Tools > Attach.*

![Primary Tools](image)

![References Dialog Box](image)
Different reference file attachment methods are available to help control reference manipulations and displays. These include:

- No nesting
- Live nesting
- Copy attachments

**Nested References**

References can be attached nested — meaning you can attach a reference’s reference.

The *Nested Depth* option determines how many reference levels deep you can attach. In the example below, if the reference *BridgeModel* is attached to *BridgePlanSheet01* with *No Nesting*, only the *Bridge Model* graphics are attached. If the nested depth is set to 1, you would attach *BridgeModel01* and *DesignModel01*. If the nested depth is set to 2, you would attach *BridgeModel01, DesignModel01, Survey/Topo* and *UtilityModel01*.

The *Live Nesting* option allows you to dynamically update a reference’s sub-references after the reference is attached. You can change your *Live Nested Depth* and your references will automatically update without having to detach and reattach the reference.
The Copy Attachment Option

The Copy Attachment option allows you to dynamically make all nested references upper-level references. This way, you can manipulate and control each reference display individually, if needed. You can switch between nested references and the copy attachment at any time.

Working with Raster Attachments

When you attach a reference, you have the option to Display Raster References. If the reference has a raster image attached (e.g. aerial photo), you can choose to attach the raster with the reference. You can toggle the raster reference on/off from the Reference dialog box.

For more information on working with raster references, see the CDOT Raster Manager workflow.

Reference Levels

You can control each reference’s levels just like the master file levels. The Level Display box shows a list of all attached references to the Master file. Select the reference and then turn the reference level on/off.

Geographic Tools

A geographical coordinate system uses a series of numbers to locate specific spots on the face of the earth. There are many of these coordinate systems in use today. Many of the data files that can be used by MicroStation have a geographical coordinate system attached. MicroStation has a number of tools to apply and reproject coordinate systems so that data with different systems can be used to create a unified data model.
**Geographic Tools**

To access the geographic tools:

1. Select **Tools > Geographic > Open Aas ToolBox.**

   ![Geographic Toolbox](image)

This displays the Geographic toolbox.

**Attaching a Geographic Coordinate System**

To attach a geographic coordinate system to a drawing:

1. Select **Select Geographic Coordinate System** from the Geographic toolbar. This displays the **Geographic Coordinate System** dialog box.

   ![Select Geographic Coordinate System](image)

2. From the **Geographic Coordinate System** dialog box, select the **From Library** icon. This displays the **Select Geographic Coordinate System** dialog box.

   ![Select Geographic Coordinate System](image)
3. On the **Select Geographic Coordinate System** dialog box, select the **Library** tab.

4. Select the desired coordinate system from the **Library** list.

![Select Geographic Coordinate System Dialog Box](image)

**Note:** The commonly use coordinate systems are located in the Colorado - Projected (northing, easting, ...) folder.

5. <D> **Ok** to attach the coordinate system to the file.

**Geographic Coordinate Systems and Reference Files**

The active file and files referenced to the active file can each have a coordinate system attached. These do not have to be the same coordinate system. MicroStation has the ability to reproject the reference file so the data representing the same point in each file is in the same place in the view.

**Note:** Both the active file and the reference must have a coordinate system attached in order for the reprojection to take place.

When attaching a reference file with a different coordinate system:

1. Attach the reference file as normal.
2. In the **Reference Settings** dialog box, highlight **Geographic - Reprojected** in the Orientation list.

![Reference Settings dialog box](image)

3. Complete the attachment process as normal.

**Geographic Coordinate Systems and Image Files**

Many image files have geographic coordinate systems attached in the header or as a separate file. These can also be attached and reprojected to the active file’s coordinate system. This is accomplished through Raster Manager.

To reproject an image file:

1. Select the **Raster Manager** from the **Primary Tools** toolbar. This displays the **Raster Manager** dialog box.

![Primary Tools toolbar](image)
2. In the **Raster Manager** dialog box, select **File > Attach > Raster**. This displays the **Attach Raster Reference** dialog box.

3. Navigate to the desired file, highlight it, and **<D> Open**. this displays the **Raster Attachment Options** dialog box.

4. In the the **Raster Attachment Options** dialog box, expand the **Geometry** tab.

5. Make the desired settings to **Geo Priority** and **GeoCS from Model**.

   **Note:** Attachment for **Geo Priority** and Inherited for **GeoCS from Model** will work for most files.

6. **<D> Attach** to complete the attachment.

   If the coordinate system attached to the raster file is different than that attached to the active file:
7. <R> on the file in Raster Manager and select Coordinate System > Select From Library from the menu.

8. In the Select Geographic Coordinate System dialog box, Select the Library tab.

9. Highlight the desired coordinate system.

10. <D> OK to make the change.
Reprojecting a File With a Different Coordinate System

There may be times when the coordinate system attached to a file needs to be changed and the data in the file reprojected to the new coordinate system. To make this change:

1. Make a copy of the file to be changed.
2. Verify that the copy is open in MicroStation.
3. Select **Select Geographic Coordinate System** from the Geographic toolbar. This displays the **Geographic Coordinate System** dialog box.

4. From the **Geographic Coordinate System** dialog box, select the **From Library** icon. This displays the **Select Geographic Coordinate System** dialog box.

5. On the **Select Geographic Coordinate System** dialog box, select the **Library** tab.
6. Select the desired coordinate system from the Library list.

![Select Geographic Coordinate System](image)

**Note:** The commonly use coordinate systems are located in the Colorado - Projected (northing, easting, ...) folder.

7. <D> OK to attach the coordinate system to the file. The Geographic Coordinate System Changed dialog box is displayed.

There are two options in the The Geographic Coordinate System Changed dialog box:

- **Correcting the Geographic Coordinate System** - do not reproject the data - The data maintains its xyz coordinates from the old coordinate system. In effect, this moves the data’s “real world” location in relation to the new coordinate system.
- **Reproject the data to the new Geographic Coordinate System** - This option changes the xyz coordinates of the data to reflect the same “real world” coordinates in the new coordinate system.
8. Select the desired option and <D> OK.

This completes the change to the coordinate system.
Chapter 6 - Creating Your Design Graphics

In this Chapter you will learn how to use the CDOT Menu to set standards and place simple graphics. You will also learn how to use precision drawing techniques to locate your graphics.

Chapter Objectives:

- Give an overview of the CDOT menu
- Describe the various parts of the CDOT menu in detail
- Discuss how to work with the CDOT menu and MicroStation task menus to produce plan graphics
- Discuss setting and using snap options
- Describe how to use AccuDraw
- Discuss deleting elements
- Discuss using undo and redo

The CDOT Menu

The customized CDOT menu provides access to tools and applications intended to provide the user a simple, efficient method to apply CDOT’s CADD standards to every project. These menus direct MicroStation to place elements on discipline-defined levels for drawing consistency.

Note: Since the CDOT Menu automatically selects the correct level for element placement across disciplines, you must have selected the xxxMulti-Discipline group from the Select Group Environment program.
Opening the Menu

After starting MicroStation, select the CDOT icon from MicroStation’s Main toolbar to open the CDOT Menu. You can hover over the icon to verify the CDOT configuration release.

Parts of the Menu
Drop-down menus

Use the drop-down menus to make the following selections:

Group Display

Toggle on your Group to display Explorer menu selections for placing graphics. In the Explorer menu tree some groups like Traffic ITS have “children” options that can be expanded with the “+” symbol. Drafting is a generic group (i.e. it’s used by all groups) for placing general text, dimensions, borders, etc. There is also an option on this menu to select/deselect all groups.

CDOT Tools

The CDOT Tool’s menu allows you to launch custom add-on programs like AutoTrack, SignCAD, Typical Section Program as well as other MDL and automation tools for working with graphics like the Breakline tool and the ModElev tool.

Options

This menu allows you to have the CDOT Menu appear on top of any Windows Application, or have it reside behind other programs.

Help

This pull-down provides convenient links to the CDOT CADD web site Home page, the CDOT CADD Manual, Support Requests and Workflows.
**CDOT Menu Sections**

**Explorer**

The Explorer Window is used to navigate through the tree structure of group options.

![Explorer Window](image)

**Status Window**

The Status Window is used to select either Existing or Proposed categories/items for a particular group. Category options change based on the Existing or Proposed status.

![Status Window](image)

**Category**

Group categories for graphic placement.

![Category Options](image)

**Item**

Items are the specific graphical elements that can be placed in the design file. When an item is selected, the CDOT Menu automatically selects the proper drawing tool and selects the appropriate level for placement (along with that level’s ByLevel symbology).

![Item Options](image)
Filters
Filters are used to filter types of items. There are five filters: Lines, Text, Cells, Patterns and All. Selecting a filter shows you only those types of elements in the selection window.

Main Menu Help
Discipline specific help topics using the CDOT menu.

Settings
Allows you to set the Active Angle and Active Scale before placing text, cell and pattern items.

Placing Graphics
The CDOT Drafting Menu
Linework tools
The CDOT Drafting > Linework group provides a convenient way to place basic elements from one location. From here you can place SmartLines, Shapes, Circles, Arcs and Hatch areas.
SmartLines are used to place a chain of connected line segments and arc segments as individual elements or as a single line string or shape.

Selecting the **WT** Weight (line weight), **LC** Line Code (line style), and **CO** Plot Color filters sets the appropriate level. Each item in the *Linework* category goes on a unique Drafting level.

**MicroStation Drawing Tools**

You can also access basic drawing tools from the MicroStation Tasks menu. Select the **Drawing** task to display the available tools.
**Important!**   Read your prompts for proper use of these drawing tools!

**Tool Settings**
Each time you select a new drawing tool, the optional settings will appear in the Tool Settings box.

**Snap Lock**
Snap lock determines if your tentative point snaps are forced onto nearby elements. If Snap lock is on and you place a tentative point on or near an element, your cursor locks onto that element at the location specified by the snap mode.
Snap Modes

The active snap mode determines how you will snap onto an element. Several different snap modes are available and can be accessed from the Status bar.

You can also access snap modes from the Snap Mode button bar.

Executing snaps

You can execute a snap two ways:

- Using a tentative point
- Using AccuSnap

To snap to an element using a tentative point:

- Select the drawing tool (Place Line, Place Block, etc.)
- Set the Snap mode (if not currently active)
- \(<T>\) on the element

A large cross hair appears at the snap mode location and the element highlights. MicroStation displays the X,Y,Z coordinates of the \(<T>\) location in the Message field.
• <D> to accept the tentative

Snaps can be a one-time setting. Once you’ve executed the snap, the snap mode returns to the default setting. One-time overrides of the default snap mode are accomplished by:

• Choosing a snap mode from the Status Bar
• Selecting Settings > Snaps
• By single clicking on snap on the Button Bar

You can change the default snap mode by:

• Selecting a new mode in the Full Locks dialog box
• Double clicking the snap mode on the Button Bar

Using AccuSnap

AccuSnap is a feature that streamlines your snaps. Instead of tentative snapping to an element, you can AccuSnap to it. In addition, AccuSnap can give you basic element information (element type and level).

Turning AccuSnap on/off

You can also toggle AccuSnap on/off from the Snaps Button Bar.

To snap to an element using AccuSnap:

• Select a drawing tool
• Select a Snap mode
• Move your cursor across the element

AccuSnap identifies the element type and its level with pop-up information. An icon representing the current snap mode is displayed along with a tentative hint – a light dashed cross hair at the closest snap point according to the selected snap mode.

• Move your cursor closer to the tentative hint.

The cursor changes to a bold X and the element highlights to indicate you’re locked on to the snap point.

• <D> to select this location.

A Tentative point is not necessary to define the temporary snap location.
**Note:** AccuSnap sometimes does not work correctly with Depth lock on. Therefore, if you’re snapping to elements with Depth lock on, be sure to turn AccuSnap off and use a Tentative snap \(<T>\) instead. This ensures that you’ll pick up the active depth instead of the element’s depth.

**Multi-Snaps**

MicroStation includes three Multi-Snap modes. Multi-snaps are an ordered list of snaps. When you choose a multi-snap with AccuSnap on, MicroStation processes the multiple snaps according to your cursor location.

**Using Multi-Snaps**

- From the Snaps button bar or from the Status bar, select a Multi-Snap (Multi-snap1, Multi-snap2 or Multi-snap3)
- Move your cursor over the element until AccuSnap locates the first multi-snap option
- Continue moving your cursor until the next snap option highlights
- When you have locked on the correct snap point, \(<D>\) to accept

**Editing Multi-Snaps**

- Select *Settings* > *Snaps* > *Multi-snaps* (or select Multi-snaps from the Snaps button on the Status bar)
- Select a multi-snap (1, 2 or 3)

**Note:** You can also right-click on the Multi-snap icon and select Properties.

- Toggle on the snaps you want to include in the multi-snap
- Toggle off snaps you don’t want
- Close the Multi-snaps box

**Precision keyins**

Precision key-ins allow you to precisely locate elements in your design file based on its coordinate system. You can locate data points at exact coordinates, at a delta distance from your current location, or at a distance and direction from the current location.

**xy=key-in**

Use the \(xy=\) key-in to specify a point’s exact x, y and z coordinates. The syntax for this key-in is: \(xy=x,y,z\).
To place an element at the active depth, leave off the z value.

**dx=key-in**

Use the dx= key-in to specify an x distance, y distance and z distance from the current point or from a tentative point. This key-in is sometimes referred to as the “delta” key-in, since it locates a point at a delta distance from the current location. The syntax for this key-in is: dx=<dx,dy,dz>.

You can leave out variables in the key-in. For example, if you only want to locate 100 feet (assuming your master units are feet) in the y direction from the current location, key in dx=,100. To draw planar elements at the active depth in a 3D file, leave off the z value.

The dx= key-in behaves the same regardless of the view in which you’re working. It uses the view axis, meaning it always assigns the x axis to horizontal and the y axis to vertical in any view (top, front, right, etc.)

**dl=key-in**

The dl= key-in is also a “delta” key-in and works in a similar fashion to the dx= key-in. It also locates a point at an x distance, y distance and z distance from the current point or from a tentative point. The syntax for this key-in is dl=<dx,dy,dz>.

The difference between the dl= and the dx= key-ins is dl= uses the model axis in a 3D file. Instead of assigning every view’s x-axis to horizontal and y-axis to vertical, it uses the design cube’s true coordinate system. For example, a front view’s horizontal axis is the x-axis and the vertical axis is the z-axis.

The dl= key-in behaves differently based on the view in which you’re working. In a top view of a 3D file, there is no difference between the dx= and the dl= key-ins.

**di=key-in**

Use the di= key-in to specify a distance and direction along the view axis from the current point. The syntax for this key-in is: di=<distance,direction> Like the dx= key-in, this key-in also uses the view axis.

You can specify the direction in either DMS (degrees, minutes, seconds) or DD (decimal degrees). This key-in also works in any angle mode (conventional, azimuth or bearing). For DMS, use ^ for degrees, ’ for minutes and ” for seconds. For example, di=10,n37^19’30.27”e would place a point 10 feet at the specified bearing angle.

**Note:** When using the dx=, dl= or di= key-ins, you can place multiple points by using the pipe symbol (above the | on a standard keyboard). For example if you’re in the Place Line command and key in dx=10/3, this would place three lines, 10 feet long each, in the x direction.

**AccuDraw**

AccuDraw is a precision drawing tool that streamlines the placement of data points. It basically combines the techniques of precision keyins with axis lock-type features into one command to help you place, modify or manipulate elements.

AccuDraw is context sensitive. Its behavior changes depending on which drawing tool you’ve selected. AccuDraw will evaluate your current position, the previous data point, the drawing tools needs, etc. to help you place your next data point.
Starting AccuDraw

In the CDOT workspace, AccuDraw automatically loads when you open a design file. If you don’t want to use AccuDraw, you can toggle it off by selecting the Toggle AccuDraw button from the Primary toolbar.

![AccuDraw Toggle Button](image)

The AccuDraw Compass

When you start AccuDraw, one of the first things you notice is the AccuDraw compass. The compass shows your origin location (current drawing location) and defines your drawing plane. There are two different drawing plane modes and, therefore, two different compasses: rectangular and polar.

![Rectangular and Polar Compasses](image)

The rectangular mode allows you to enter coordinates or delta distances, relative to the origin point, in an X,Y,Z coordinate system (like an XY=, DX= or DL= keyin). The polar mode allows you to enter distances and angles relative to an origin point (like a DI= keyin).

The AccuDraw Window

The AccuDraw window is where you enter your X,Y,Z or Distance and Angle values. You can also lock the drawing axes. The window changes according to your compass mode.

![AccuDraw Window](image)

**Note:** To toggle the compass (rectangular and polar mode), set the focus into the AccuDraw window and press <Spacebar>.

You can dock the AccuDraw window at the top or bottom of the MicroStation window, or you can float the window into the view.

AccuDraw locks

You’ve seen how to lock your X,Y or Distance, Angle entries you enter in the AccuDraw window using the <Enter> key. You can also lock “dynamically” in AccuDraw. Dynamic entries are X,Y or Distance, Angle values that are entered automatically as you drag your cursor. Use the following keyboard shortcuts to lock dynamic entries:

- `<X>` – to lock x-axis entries in rectangular mode
- `<Y>` – to lock y-axis entries in rectangular mode
- `<D>` – to lock distance entries in polar mode
• <A> – to lock angle entries in polar mode

**Smart Lock**

Use AccuDraw’s Smart Lock feature to lock your cursor in one direction only (your pointer location). For example, if you’re working in Rectangular compass mode and you only want to move in the Y direction, lock your cursor on the Y axis, move your cursor up or down and then press < Enter>. You can now only move in the Y direction only. Smart Lock in Polar mode will lock your cursor to the closest 90 degree axis.

**Smart Lock summary:**

• In Rectangular coordinates, locks X to 0 if the pointer is on the drawing plane; y-axis or Y to 0 if the pointer is on the x-axis.

• In Polar coordinates, locks Angle to 0°, 90°, -90°, or 180° if the pointer is on a drawing plane axis or otherwise locks Distance to its last entered value.

**Rotating the AccuDraw compass**

There may be times when you do not want the AccuDraw compass to rotate with the element being placed. Instead, you want the compass to maintain its conventional drawing plan mode of X-axis horizontal and Y-axis vertical. In this case, press V on the keyboard to rotate the compass back to the “view” plane.

**Note:** When using AccuDraw with the SmartLine tool, there is a SmartLine placement Setting (select the drop-down arrow) called Rotate AccuDraw to Segments. Toggle this option off if you always want the AccuDraw compass to maintain its conventional drawing plane mode of X-axis horizontal and Y-axis vertical.

The AccuDraw keyboard shortcut V will always rotate the compass to the view in which you’re placing elements. Therefore, in a 3D file, pressing V in a front view, rotates the AccuDraw compass so that the X-axis is horizontal in the front view; whereas pressing V in a top view rotates the compass so that the X-axis is horizontal in the top view, etc. Or, you can quickly rotate the compass to a particular view by pressing the appropriate keyboard shortcut below:

• T – top view
• F – front view
• S – side view

Using these keyboard shortcuts simplifies drawing in 3D. For civil design applications, however, most of the time you will be drawing in a top (plan) view.
Another handy rotation option is Quick Rotate (keyboard shortcut <R> <Q>). This temporarily rotates the compass dynamically as you move your cursor. This is handy to rotate the AccuDraw compass to match the angle of an existing element to place off of that element or when placing cells or text.

**Moving the AccuDraw Origin to your cursor location**

When you tentative snap to an existing element, press O on the keyboard to move the AccuDraw origin temporarily to the tentative location. You can then locate the AccuDraw compass off of this tentative point by entering values in the AccuDraw window. If you accept the tentative with a data point, you compass “sticks” in this location.

**Shortcut snap modes**

AccuDraw provides a shortcut alternative for selecting a few snap modes. Instead of selecting the snap mode from the status bar or the Snaps button bar, you can use one of the following keyboard shortcuts:

- <N> — Nearest
- <C> — Center
- <I> — Intersect

In addition, you can press <K> to set the keypoint snap division when using AccuDraw.

---

### Deleting Elements

**To delete an element:**

- Choose the Delete Element command from the Tasks menu

  ![Delete Element Command](image)

- Move your cursor over the element (it will highlight)

  **Note:** The element highlights if Identify Elements Automatically is on in AccuSnap Settings. If this option is not on, <D> or snap to identify the element.

- <D> to accept the deletion

  **Note:** Choose Element Select or another tool to get out of the Delete command.
Using the Undo and Redo Commands

When you delete an element, it is moved to the Undo buffer, so MicroStation actually remembers everything that is placed in the design file, even after it’s gone. You can retrieve a deleted element using the Undo command (Edit > Undo). The Redo command (Edit > Redo) negates the last Undo command.

The Undo and Redo commands not only work on deleted elements, but on most graphics commands. For example, you can place a line, use Undo to remove the line, then use Redo to re-place the line.

The Undo buffer is virtually unlimited in size (it’s only limited by the operating system file size limit).

The Undo and Redo commands can also be accessed from the Standard toolbar (Tools > Standard).

Note: Compressing the design file (File > Compress Design), or exiting the design file clears the Undo buffer.

Compressing the design file

Select File > Compress > Design to permanently remove deleted elements from the Undo Buffer. This will make your design file smaller and more efficient. However, you will lose your Undo history for the design file session.

Element Information

Use the Element Information command from the Primary toolbar to analyze an element for general and detailed information.
Select the element and then `<D>` on the command to get general information on the element’s attributes and its properties (solid, snappable, etc.) You can change any information in the General section to update the element. The Geometry section contains information on the element’s geometry, including coordinates, size, etc.
Chapter 7 - Manipulating and Modifying Design Graphics

Now that you know how to place basic elements and control their placement using various locks and snap modes, you’re ready to learn how to manipulate and modify the elements you’ve placed.

Chapter Objectives:

- Identify each of the tools on the Manipulate toolbar
- Identify each of the tools on the Modify toolbar
- Discuss the use of Active Depth
- Discuss the ACS Plane lock
- Discuss the CDOT Custom Linestyles and linestyle scales
- Discuss changing an element’s symbology
- Identify the CDOT Miscellaneous Tools
- Describe MicroStation tags

Using Manipulate Tools

The **Manipulate** toolbar commands allow you to manipulate the entire element (copy, move, rotate, scale, etc.). Follow your prompts closely to properly execute the commands.

**Manipulate Commands**

Some of the more commonly used commands include:

**Copy**

Copies an element from one location to another.
Move
Moves an element from one location to another.

Scale
Resizes an element based on one of two methods:

- **Active scale**
- **3 points**

**About Element Center**, which, when used with the **Active Scale** method, allows you to scale about the element’s center with just one data point.

In the expanded tool settings box, there are two toggles that affect dimensioning not associated with elements. The **Scale Dimension Value** toggle increases the value of the dimension by the scale factor when on. The **Scale Annotations** toggle changes the size of the text by the scale factor when on.

If you like, you can create a copy or copies of the scaled element.

Rotate
Rotates an element using one of three methods:

- **Active Angle**
- **2 Points**
- **3 Points**
Like the Scale command, you can toggle on About Element Center which allows you to always rotate about the element’s center.

**Mirror**

Mirrors an element using one of three methods:

- **Vertical** — about vertical axis
- **Horizontal** — about horizontal axis
- **Line** — about line defined by two data points

In the expanded tool settings box, there is a toggle to Mirror Text. When on text is mirrored.

**Construct Array**

Copies elements multiple times in an array of two types:

- **Rectangular**
- **Polar**
- **Along Path**

**Align Elements By Edge**

Aligns the edge of one element with the edge of another element using one of the following alignment options:

- **Top**
- **Bottom**
- **Left**
- **Right**
- **Horiz Center**
- **Vert Center**
- **Both Centers**
**Stretch**

Used to stretch elements by a defined fence or cells.

**Move Parallel**

Moves or copies an element parallel to the original element using one of three modes.

- **Miter** — extends or shortens the segments while maintaining the angle of their connections
- **Round** — fills the gap with a rounded arc between the two moved elements
- **Original** — the resulting element is the same type as the original element.

The *Miter* and *Round* modes also help eliminate “loops” that sometimes form in interior corners of the offset element using the *Original* mode.

If you specify a distance, you only need to data point the direction.

With **Use Active Attributes** on, the parallel element takes on the active level, color, style and weight.

**Move To Contact**

Used to move elements until they contact another element.

**Using the Modify tools**

The *Modify* toolbar commands allow you to modify a piece or part of an element (trim, extend, partial delete), instead of manipulating it as a whole.
**Modify**

Modifies the geometry of an element. This tool works differently on different types of elements. For example, you can:

♦ Move a vertex or segment of a line, linestring or shape
♦ Scale a block or circular arc
♦ Change a circle’s radius

**Partial Delete**

Deletes part of an element. The element can be closed, or you can delete an interior portion of line, linestring, curve or arc.

**Break Element**

Breaks an element at a defined point.
Extend

Extend or shorten a line or linestring.

If Distance is off, enter a data point to define the new endpoint (i.e. dynamically extend or shorten the line or linestring).

Note: Toggle on From End to extend/shorten from the nearest endpoint that you identify. If off, the line is extended/shortened relative to the origin point, no matter where you identify the line.

Extend Two Elements to Intersection

Extends two lines, linestrings, or arcs to their intersection. If the lines or elements currently intersect, it will shorten the elements to their intersection point.

Trim to Element

Trims or extends one line, linestring or arc to intersect with another element (which does not have to be another line, linestring or arc). Normally the element to be trimmed or extended is selected first, however, a toggle in the tool settings dialog box allows you to pick the cutting/extend to element first.

Trim

Trims or extends an element at its intersection with a specified cutting element. A drop down menu in the tool settings dialog box allows you to Trim, Extend, or Extend and Trim. The Trim option will only affect elements that cross the cutting element or a line extending along the cutting element. Extend will only affect elements that do not cross the cutting element or a line extending along the cutting element. You can trim multiple elements and you can have more than one cutting element.

When identifying elements to trim, always data point on the portion of the element that you want trimmed.
You can place two cutting elements in a selection set before executing the command and trim elements between them. However, a more effective way of accomplishing this is to use the **IntelliTrim** command.

**IntelliTrim**

Trims, extends or cuts multiple elements in one operation using two different modes:

- **Quick Mode** — allows you to draw a line through multiple elements to trim (or extend) to one cutting (or extension) element
- **Advanced Mode** — allows you to select multiple cutting elements. You can trim or extend elements between or outside of the cutting elements

To extend elements, set the **Operation** to **Extend** and follow the same steps to define an extension element and then draw a line through the elements to extend.

The Operation **Cut** will break elements in two pieces at the cutting element.

**Insert Vertex**

Inserts a vertex on a line, linestring or shape. It is also used to attach a line segment onto the end of a line or linestring.

**Delete Vertex**

Deletes a vertex on a line, linestring or shape.

**Fillet**

Constructs a circular fillet (an arc) of a specified radius between to elements or two sides of a linestring or shape. You can truncate one side, both sides or neither side of the original element.

**Note:** To fillet between 3D elements, they must be co-planar.
Chamfer
Constructs a chamfer between to lines or two sides of a linestring or shape.

Note: To chamfer between 3D elements, they must be co-planar.

Drawing graphics in 3D

When drawing graphics in a 3D file, you can either draw planar graphics at a particular elevation, or you can draw 3D graphics (endpoints at different elevations).

Active Depth
To draw planar graphics at a particular depth in a 3D file, set the active depth to the desired depth <\texttt{az=depth}>, and then place the graphics. The active depth would be the elevation you want to place the graphics if you’re drawing in the top view. For example, if you want to draw the 5000 ft. contour, set <\texttt{az=5000}>, then draw the contour. All data points will be placed at a Z value of 5000 unless you snap or AccuSnap to existing elements.

ACS Plane Lock
When on, the ACS Plane lock forces all data points to the “0” elevation of the Active Coordinate System. This lock overrides the Active Z set for the drawing as well as snapping to elements of different elevations.

ACS Plane Snap
When placing new graphics by snapping on to existing elements, you’ll pick up the elements’ elevation if ACS Plane Snap if turned off. ACS Plane Snap locks all of your data points onto the view’s active depth plane. Therefore, if you want to place planar elements, but you’re snapping on to elements at different elevations, set the active depth to the desired elevation <\texttt{az=depth}>, and then turn ACS Plane Snap on.
Using the CDOT Menu ModElev Add On

Another way to set the elevation of an element in the top view of a 3D file is to move it (after it is placed) in the Z direction only. This is useful if you want to planarize elements to a specified elevation. The ModElev program is located on the CDOT Menus. Select Add On's > ModElev.

![ModElev Interface]

You can specify the elevation to planarize a single element, elements within a fence or all elements in the design file.

CDOT Custom Line styles

CDOT custom line styles are used to represent various types of graphics in the CDOT MicroStation configuration. CDOT custom line styles, unlike standard line styles, can be scaled. The line style scale should match the plot scale of the sheet file in which they will be referenced.

Setting the Scale

You should set the line style scale before placing the custom line style. The line style scale is set under Element > Line Style > Custom. In the default CDOT workspace, the custom line style scale is set to 100. You only need to change the custom line style scale if you will eventually reference this file into a sheet with a different scale.

![Line Styles Dialog]

Note: Custom line styles are assigned to levels via ByLevel symbology. The line style is automatically selected when the level is set active.

Changing the scale

If you have placed a line style at the wrong scale, you can change the scale with the keyin Change Linestyle Scale ## (where ## = the scale), and then select the element to change. Setting the linestyle scale through the linestyles dialog box?
Changing Direction

Some custom line styles are directional and depend on the direction they are drawn (e.g. Type 3 guardrail). If you place a custom line style in the wrong direction, key in `Change Direction`, and then select the element.

For more information on custom line styles, see the CDOT CADD Manual, Chapter Five – Drafting Standards, Section 5.7 – Line Styles and follow the CDOT Line Styles links.

Changing Levels and ByLevel Symbology

If you place an element on the wrong level, and thereby place it with the wrong ByLevel symbology, you can change that element to the correct level. Once changed, the graphics will take on the new level’s ByLevel symbology (as long as the element was originally placed ByLevel).
Using Element Information

You can change the level of an element using the Element Information command.

Using the Change Element Attributes tool

The Change Element Attributes command on the Change Attributes toolbar also allows you to change an element’s level.

There are two options:

- **Change**
  
  With this option, set the level you want to change to, then select the element.

- **Match/Change**
With this option, you can change an element to a level by matching another element’s level. First select the element to match, then select the element to change.

![Change Element Attributes](image)

**Note:** Be careful! If Use Active Attributes is turned on, the level you set in the Change option, or the level you match in the Match/Change option, will become the active level. If you do not want to change your active level, turn this option off.

**The CDOT Misc. Toolbar**

The CDOT Miscellaneous Tools toolbar (Add On's > Launch Miscellaneous Tools from the CDOT Menu) contains six useful tools:

**Change Active Symbology ByLevel**

If you accidentally change the active color, line style or line weight in the Change Element Attributes command, you can re-set the actives back to ByLevel symbology with the Change Active Symbology ByLevel command.

![Change Active Symbology ByLevel](image)

**Change All Elements to ByLevel Symbology**

If graphics have been placed with symbology other than ByLevel symbology, use the Change All Elements to ByLevel Symbology command. This is especially useful before plotting to ensure all graphics conform to CDOT standards.
**Shift Linestyles**

Sometimes custom line styles need to be shifted to meet in corners to avoid interference with other graphics. Use the *Shift Linestyle* tool to accomplish this.

**Change Element Direction**

The display of some custom line styles is dependent on the direction the line was drawn. Use the *Change Element Direction* tool to reverse the line so that the style is displayed as desired.

**Active Angle From 2 PTs**

Use the *Active Angle From 2 Pts* tool to set the active angle by the selection of two points.

**Active Angle From 3 Pts**

Use the *Active Angle From 3 Pts* tool to set the active angle by the selection of three points.

**Tags**

MicroStation tags are a special way of attaching information to elements drawn in the design file. For example, survey graphics contain tag information like feature name, the InRoads preference and description.
Use the **Review Tags** command on the **Tags** toolbar to obtain tag information on an element.
Chapter 8 - Cells and Patterns

Cells and patterns are groups of graphic elements that are used repeatedly. Cells are generally used as stand-alone elements, like symbols and sheet borders. Patterns are used to fill in an area, usually to denote a material type or area of interest. This chapter explains what cells and patterns are and how they are used.

Chapter Objectives:

- Describe what Cell libraries are and how cells are stored in them
- Describe how a model is made into a cell
- Discuss the cell library dialog box
- Identify the different types of cells
- Describe how to place a cell from the MicroStation and the CDOT menus
- Describe the different options available for placing patterns
- Describe how to place a patterns from the MicroStation and the CDOT menus

Understanding Cells

Cells are a permanent group of graphics. They are typically used for standard graphics (symbols, details, notes, borders, etc.), which may be used over and over on multiple projects. Cells are stored in a separate cell library file.

When you’re ready to place the cell in your design file, attach the cell library to the file. You can then place the cell out of the library multiple times, like a rubber stamp. Once the cell is placed in the design file, it is a single element that exists in the design file. You do not have to have the cell library attached to see the cell.

Cell libraries

Cell libraries are just ordinary MicroStation design files that have a .cel extension. Cells can be organized into different libraries or you can place all cells in one library. CDOT uses discipline-specific cell libraries, where each group has its own library (Design, Bridge, Traffic, etc).

Cell Library = DGN file

The cell library file contains multiple models and each cell is stored in a separate model.

Cell = Model

What Are MicroStation Models?

Models are “containers” for graphics within a DGN. Design files must have at least one model (named CDOT Default in the CDOT workspace), but can have many. Models in a DGN file are analogous to a workbook in an XLS file. Just like each workbook is a separate spreadsheet, each model is a separate set of graphics. And, you can have multiple models in a DGN just like multiple spreadsheets in a XLS file.

Note: Do not confuse Model files with MicroStation Models. They are two totally separate concepts. A Model file is a generic term used to describe any working file that contains graphics. A MicroStation Model is a separate container for graphics inside any MicroStation file – Model or Sheet file.
Models are accessed from the **Primary Toolbar**. They can be entirely different sets of graphics or different components of the same project (e.g. three separate models for plan, profile and cross sections in one project DGN file).

In almost all cases, you will work in one model – the CDOT Default model in all model files and sheet files.

The one exception is when you’re working directly in a cell library. Each cell in a cell library is actually just a separate model inside the cell library design file (cell=model). The design file containing the model (cell) can be attached to any other design file as a cell library, and then the model (cell) can be placed out of this file.
In order for models to be placed as cells, the option *Can be placed as cell* must be toggled on in the model’s properties. In the *Models* dialog box, select the *Edit Models Properties* command to turn this option on/off.

![Models dialog box]

The design file’s levels are shared among all models; however each model can have different levels turned on/off for different views. A *Global Display* or *Global Freeze* mode on the *Level Display* box carries through to all models.

Models can also be imported from other DGN files. This is a good way to copy a lot of graphics from one DGN to another, or a good way to build a cell library.

**CDOT Cell Libraries**

Many of the CDOT standard cells have been created and are stored in discipline-specific cell libraries (e.g. Design, Bridge, ROW). The appropriate cell library or libraries are attached to the discipline seed file. When you create a new file from a discipline seed file, the associated cell library is automatically attached to the new file.
The standard CDOT cell libraries are stored in the CDOT workspace in the folder C:\Program Files\Workspace-CDOT\Standards-Global\MicroStation\Cells. The discipline-specific as well as general cell libraries (used by all groups) are shown below.

### The Cell Library Dialog

To view all cells contained in a library, you can open the **Cell Library** dialog box. Select **Element > Cells**, or select **Cells** from the **Primary** toolbar.

This opens your discipline cell library (attached via your seed file) and a list of cells is shown in the **Cell Library** dialog box.
If you want to access cells from a different library, you can manually attach a library to your active design file. From the *Cell Library* dialog box, select **File > Attach File**.
When working in the CDOT workspace, the configuration automatically sets the correct path for `.cel` files. Select the library to open and then select **OK** to attach the library.
**Note:** You can only attach one cell library at a time; when you attach a library, it automatically detaches the current library and attaches the new one. Only the cells from the active library are shown in the list of cells. *However*, if you toggle on **Display All Cells in Path**, MicroStation displays cells from all of the CDOT libraries that are pathed in the CDOT configuration.

### Types of cells

Cells are either **Graphic** cells or **Point** cells. **Graphic** and **Point** cells have different properties after they are placed in the design file. The properties of each type of cell are as follows:

<table>
<thead>
<tr>
<th></th>
<th>Graphic Cell</th>
<th>Point Cell</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbology</td>
<td>Maintains active settings used when created</td>
<td>Takes on active settings when placed</td>
</tr>
<tr>
<td>Level</td>
<td>Level(s) as created (relative or absolute mode) when placed</td>
<td>Active level when placed</td>
</tr>
<tr>
<td>Snappable points</td>
<td>Keypoints</td>
<td>Cell Origin</td>
</tr>
<tr>
<td>View</td>
<td>View dependent — appears different according to the view (top, front, etc.)</td>
<td>View independent — appears as originally drawn in all views</td>
</tr>
</tbody>
</table>
**Placing Cells with the Place Active Cell Command**

You can place cells out of the cell library into your design file using the Place Active Cell command located on the Cells toolbar.

The command places either a point or graphic cell in the design file using the active placement parameters including:

- Active cell name (you can browse out to the cell library and select the cell from a list – double-click the cell to make it active)
- Active scale \( \text{as}=\langle \text{scale factor} \rangle \)
- Active angle \( \text{aa}=\langle \text{angle} \rangle \)
- Active element symbology — for point cells only
- Active level — for point cells only

Other options include:

- **True Scale** - If the cell that was created with different units than those of the active model the cell is scaled to match units of the active model. The CDOT default for this option is **On**.
- **Relative** - This option is used to place a cell on the active level rather than the level it was created on. If the cell contains multiple levels, then the additional levels are selected starting from the active level based on the difference between the level numbers. The CDOT default for this option is **Off**.
- **Mirror** - This option flips the cell along the horizontal axis, vertical axis, or both axes. The CDOT default for this option is **Off**.
- **Interactive** - This option allows the user to adjust the scale, rotation, or both with data button input from the mouse. The CDOT default for this option is **Off**.
- **Flatten** - This option places the cell in a 2D or 3D drawing at the selected view rotation. The CDOT default for this option is **Off**.
• **Scale Multi-Line Offsets** - this option adjusts the distance between multi-line elements based on the active scale. The CDOT default for this option is *Off*.

• **Scale Dimension Values** - This option changes dimension values embedded in the cell, based on the active scale. The CDOT default for this option is *On*.

• **Scale Annotations** - This option changes the size of annotation items within the cell, based on the active scale. The CDOT default for this option is *On*.

• **Association** - This creates a group from the cell and the item selected when placing the cell. The CDOT default for this option is *Off*.

**Note:** You can also place a cell by <D><D> clicking on it in the cell library dialog box. This sets the cell as the active Placement cell and automatically selects the **Place Active Cell** command. You can also <R> on the cell in the cell library dialog box and select **Place**.

---

**Shared Cells**

Cells can be placed as **Shared**. Then, when you place multiple cells in a design file, MicroStation stores the shared cell definition data once, and all other instances of the cell placement reference this definition. Shared cells keep your design file efficient by writing the cell graphics to the file only once.

**Note:** To place a shared cell, toggle on **Use Shared Cells** in the cells dialog box.
If you’re placing a sheet border cell, do not place it as shared. If you do, you will not be able to edit the cell text. If you want to remove the share status of a cell, you can do so with the **Drop Element** command. You can drop a **Shared Cell** to a Normal Cell (for text editing) or to **Geometry** (individual graphics).
Placing Cells with the CDOT Menu

The CDOT Menu streamlines the process of placing cells. After selecting the **Group**, **Status** and **Category**, a list of available cells for that category is shown in the item selection window. Just select the cell item and then place it in your file. The proper level is set active and the **Place Active Cell** command is automatically selected. The specified cell is automatically set active and placed out of the appropriate cell library.

Note: You can set the **Filter** to **Show Cells** to filter only the cell items for a category.

Cell Divide Program

The **Cell Divide** program located on the **CDOT Menu** (CDOT Menu> Cell Divide), will divide any linear or curvilinear elements with the active cell. The program allows you to specify a length and angle to place the cell along the element.
More information

For more information on cells and cell libraries, see the CDOT CADD Manual, Chapter Five – Drafting Standards, Section 5.1 Cell Libraries.

5.1 Cell Libraries

The libraries are automatically loaded through the use of configuration variable cell library lists (MS_CELLLIST) and available from the Cell Library dialog box within MicroStation. When the user opens a design (.dgn) file in MicroStation, all of the 16 cell libraries will be available for attachment from the Cell Library dialog box’s File dropdown menu. The Cell Library dialog box contains a location for selecting the Display All Cells in list. If the toggle is chosen, all cells within the workspace are available for use within the cell list. By default this toggle is not selected.

5.1.1 Types of Cells

There are two types of cells available within the CDOT workspace: Graphic cells and Point cells. The major differences include Graphic cells maintaining the symbology they were created with when placed and Point cells taking on the active symbology when placed. The one exception is when Graphic cells are created on the default layer. In this case the cell will adopt the active symbology similar to a point cell. Another difference is cell rotation. Graphic cells will remain rotated as placed while Point cells are “view independent”. View independent applies to both cells and text and means that if a view is rotated, a plan sheet for example, the cell or text will remain oriented to the view, not as rotated when placed. Graphic cells have become the main choice at CDOT and are utilized wherever possible and point cells have been removed in all but a few cases.

5.1.2 Cell Placement

Cells have been created to be placed relative to the iplot scale, or the active scale which should be equivalent to the Model Properties/Annotation Scale setting. Cells can be placed in either the Model file or the Sheet file, depending on what type of drawing is being produced. Most cells have been drawn at a 1:1 scale, based on the CDOT Seed file resolution, but there are some exceptions. The scaling exceptions are those cells discussed below. The insertion point of each cell is the coordinate 0.00 in each model. When cells are placed into a Model File, the individual Specialty Group leader is responsible for providing the base mapping, if a different scaled model is desired, the group leader should be contacted for the desired scale. The varying scaled base mapping should reside in the Specialty Group folder structure and referenced to the project plan set sheet file.

The Hydraulic (Hydraulics cell) library contains many true size cells that have been drawn true size and must be placed an active scale factor of 1 to be true scale. These cells include Plan and Elevation inlet cells and Plan and Elevation End Sections cells. The Traffic (TRAFF_General cell) library also contains many striping pavement markings that have been drawn true size and must be placed in an active scale factor of 1 to be true scale.

Creating Cells

For information on how to create a cell library and cells, see the lab Create a Project Specific Border.

Understanding patterns

You may have a need to pattern areas with a hatch, crosshatch or special pattern (concrete, rip-rap, etc.). Or, you may need to pattern linear elements like pavement lines with an asphalt pattern. For these situations, you’ll use MicroStation’s patterning tools.

Patterns toolbar

![Patterns toolbar image]
The Patterns toolbar contains tools for hatching and cross-hatching shapes or areas. You can also pattern any line, shape or area with a cell. The Pattern tools include:

**Hatch Area**

The Hatch Area command hatches a closed shape or area in the active model or a reference. Set the Spacing (in master units) and Angle of the hatch line and turn on Snappable Pattern if you later want to snap to the pattern graphics (the hatch lines in this case). If you’re patterning a curved element, key in a Tolerance or minimum distance for chording off the pattern around the curve.

Toggle on Associative Patterning if you want the pattern to update if the element is modified. In addition, broken patterns can be re-associated by re-connecting the pattern shapes.

Toggle on Associative Region Boundary to place the pattern on different level from the patterned element (useful for removing the “box” around text.

Toggle on Search For Holes when a hole element resides inside of the element to be hatched, but the two are not part of a group.

Toggle on Use Element Symbology if you want the hatching symbology to match the element’s symbology.

The icon bar at the top of the dialog box allows you to select the pattern method (how the area will be patterned), which includes (items listed in order from left to right on the icon bar):

- **Element** — a closed shape
- **Flood** — the area enclosed by a set of elements
- **Union** — area defined by the union of two or more closed shapes
- **Intersection** — area defined by the intersection between two or more closed shapes
- **Difference** — area defined by the difference between two or more closed shapes
- **Points** — an area defined by a series of data points where you dynamically define an area
- **Fence** — the area inside the fence
Cross Hatch Area

The Cross Hatch Area command uses similar settings to the Hatch Area command to cross-hatch an area.

Pattern Area

This command patterns an area or closed shape with a cell. The pattern element(s) can be in the active design file or in references.

Key in the active Pattern cell or set it in the Cells dialog box (Element > Cells). If you toggle on Display All Cells in Path, all pattern cells begin with the cell name PATTERN.
Set the active **Scale** to size the cell, the active **Angle** to determine the placement angle for the pattern graphics, and the pattern **Row** and **Column Spacing** in master units (distance between the tiled cells). The **True Scale** option will reconcile the difference between the cell model’s working units and the working units of the design file model in which it is placed (e.g. patterning with a metric cell in an imperial design file model). For this option to work, the pattern cell must be a shared cell.

Other options are the same as noted for the **Hatch** and **Crosshatch** commands.

**Linear Pattern**

**Linear Pattern** patterns with a cell along an existing linear element. You can pattern both linear and curvilinear elements. Specify the **Cell**, **Scale** and **Tolerance** just like the **Pattern Area** command. In addition, the **Linear Pattern** command has the following **Cycle** options:

- **Truncated** – places the cell for the linear pattern using the specified active scale. Based on this scale, the last instance of the pattern may be truncated.
- **Complete** – adjusts the scale for pattern cell so that only complete instances of the cell are placed along the linear element.
- **Single** – patterns with one instance of a cell on each linear segment.
- **Multiple** – adjusts the scale for pattern cell so that only complete instances of the cell are placed along each segment of the linear element.

After patterning, you can turn off **Patterns** in the **Settings > View Attributes**. Doing so will display the original linear element.
Placing Patterns with the CDOT Menu

The CDOT Menu streamlines the process of placing patterns. After selecting the Group, Status and Category, a list of available patterns for that category is shown in the item selection window. Just select the pattern item and then data point inside the region to pattern. (The CDOT Menu uses the Flood method of patterning, so you must data point inside the region to pattern). The proper pattern level is set active and the appropriate pattern command is automatically selected (Hatch Area, Cross Hatch Area, Pattern Area or Linear Pattern). If patterning with a cell, the appropriate pattern cell is automatically set active.

Note: You can set the Filter to Show Patterns to filter only the pattern items for a category.
Chapter 9 - Grouping Design Graphics

This chapter discusses the various types of element groups and how they are used.

Chapter Objectives:

- Describe the methods of creating temporary groups
- Define semi-permanent groups
- Describe how to create semi-permanent groups

There are times when it is necessary to group elements because it is more efficient to place, modify or manipulate groups of elements rather than perform repetitive commands on individual elements. Element groups can be:

- Temporary — fences and selection sets or
- Semi-permanent — graphic groups and complex elements.

Temporary groups

If you want to perform a one-time manipulation on a group of elements (i.e. copy them or delete them), create a selection set or use a fence to group the elements.

Using Selection Sets

The **Element Selection** toolbar provides various methods for temporarily grouping elements. Once grouped, elements can be modified, manipulated or deleted as a group. When elements are grouped with these tools, they are placed in a selection set and remain in the selection set until you clear the set.

When elements are added to a selection set, they become highlighted. You can set the selection set color under **Settings > Design File > Color > Selection Set Color**. You can also quickly see the number of elements in the selection set from the indicator on the **Status Bar**.

These tools include:

**Element Selection**

Selects individual elements and adds them to the selection set. You can select multiple elements by either holding down the Ctrl key or by holding down the data button and dragging across the elements.

Several methods for selecting elements including:

- **Individual** — <D> on individual elements.
- **Block** — selects all elements inside the block. You can toggle the Block option to either inside or overlap.
- **Shape** — selects all elements inside an irregular shape you draw. You can toggle the Block option to either inside or overlap.
- **Circle** — selects all elements inside a circle. You can toggle the Block option to either inside or overlap.
- **Line** — selects elements by drawing a line through the elements.

The **Mode** option gives you options for adding and removing elements from the set including:
- **New** — clears the current selection set and creates a new set.
- **Add** — places elements in the set.
- **Subtract** — removes elements from the set.
- **Invert** — toggles an element (adds a removed element or removes an added element).
- **Clear/Select All** — removes all selected elements from the current set, or adds all elements if the set is empty.

**Extended Settings**

Additional options for how elements are added to or deleted from the selection set can be used by selecting the **Show/Hide Extended Settings** arrow. This includes filtering elements based on their attributes (color, style, weight, etc.) In many cases, you can find and add elements to a set much more quickly by filtering on attributes (e.g. all elements on level Design_Guradrail_Type-3), than individually picking them with the Element Selection tool.
Using Fences

The **Fence** toolbar provides another set of tools to temporarily group elements. Once placed in the fence, the elements can be deleted, manipulated or the attributes changed. When the fence is removed, the elements are no longer grouped.

**Place Fence**

Temporarily groups elements by drawing a fence boundary around the elements. There are several types of fences you can place including blocks (drawn corner to opposite corner), shapes, and circles, also by element, view or design file.

The fence mode determines which elements will be affected by the fence. These include:

- **Inside** — to select elements entirely inside the fence.
- **Overlap** — to select elements inside or overlapping the fence.
- **Clip** — to select elements inside the fence and cut or break all elements that intersect the fence.
- **Void** — to select all elements outside the fence.
- **Void-Overlap** — to select all elements outside or overlapping the fence.
- **Void-Clip** — to select elements outside the fence and cut or break all elements that intersect the fence.

Once the elements are grouped in the fence, they can be deleted, manipulated, etc. You can use MicroStation view controls (**Zoom In, Zoom Out, Pan**) etc.) and the fence remains persistent.

To remove the fence, select the **Place Fence** command again.

**Note:** Check the fence indicator on the **Status Bar** to quickly determine is there is a fence placed in the design file.
The **Void** and **Clip** modes are two features not available with selection sets. However, there may be times when attribute filtering (not available with fences) is easier to use — especially when grouping graphics in high-density areas.

**Delete Fence Contents**

Deletes the contents of the fence based on the fence mode. Note that the **Delete Element** tool on the **Main** task menu ignores the presence of the fence and can only be used to delete individual elements.

**Saving a Fence**

A fence can be saved for use at a later time within the Place Fence tool settings dialog box. To save a fence, expand the tool settings box, then **<D>** the **Save** button. Key in a name for the saved fence. Note: a saved fence stores the location of the fence only. It does not save any of the contents of the fence.

To use the saved fence, **<D>** the **Open** button. This replaces the fence in its original position, closing any fence currently displayed.

To remove a saved fence from the list, **<D>** the **Delete** button.
Semi-permanent groups

For groups that require more frequent manipulation, it is often more efficient for the elements to remain grouped until you “ungroup” them. These groups — complex chains, complex shapes or graphic groups are created using the Groups toolbar.

Groups toolbar

Drop Element

Drop Element returns a complex element to its original graphics. In addition to breaking up complex elements, this command is also used to drop other types of groups including linestrings and cells (discuss later).

Creating Complex elements

Create Complex Chain

The Create Complex Chain command joins a series of lines, linestrings and/or arcs into one element with two end points. This command uses two methods:

- **Manual** — you graphically select each element to add to the complex chain.
- **Automatic** — adds all elements to the complex chain that are within the specified Max Gap distance (handy for numerous elements which would be tedious to pick individually).
If you toggle on **Simplify geometry**, the new element is created as a linestring instead of a complex element. The advantage is that you can more easily modify a linestring than a complex element.

The new complex chain takes on the active element attributes, regardless of the attributes of the original elements that make up the chain. Be sure to set your active element attributes before creating the complex chain.

**Complex Shape**

*Create Complex Shape* joins a series of lines, linestrings and/or arcs into one closed element. A “filler” segment is added, if needed, to close the shape. The same **Manual** and **Automatic** methods found in the *Complex Chain* command are also available on the *Complex Shape* command.

**Add to Graphic Group**

*Add to Graphic Group* creates a group of individual elements that can be named. Graphic groups are more efficient than a fence or a selection set for items that must be frequently grouped and manipulated. This command can also add elements to an existing named group or can combine groups.

After creating the graphic group, the elements behave as a group as long as the **Graphic Group** lock is on (*Settings > Locks* or **Locks** button on the **Status Bar**). If the **Graphic Group** lock is off, you can manipulate, modify or delete individual elements in the group. However, the elements retain their group status and can be manipulated again as a group if the **Graphic Group** lock is turned back on.
The Open Named Group option (magnifying glass icon) is used to manage your named groups (create new groups, add or removed elements from the group, create group hierarchies, etc.)

**Drop from Graphic Group**

Removes individual elements from a graphic group or named group. The command is also used to drop an entire group (break up the entire group into its component elements).
Chapter 10 - Creating Sheets

In this chapter, the creation and assembly of a set of plan sheets is discussed.

**Chapter Objectives:**
- Describe the workflows followed by the design group and the other specialty groups for creating plan sheets
- Discuss why and how to rotate views for creating plan sheets
- Discuss how to place sheet borders
- Describe how to edit sheet border cells
- Discuss the measuring tools.

**Roadway Design group**

*Plan or Plan/Profile sheets*

The Design group’s sheet file workflow is covered in detail in Chapter 4, The CDOT workflow. The following is a summary of the Design group’s Plan or Plan/Profile sheet workflow:

- Create a new MicroStation design file for each sheet.
- Reference into the sheet file the proposed model file with the Survey/Topo model file nested.
- Rotate the view, if needed, so graphics appear horizontal.
- Clip the references to show only what graphics are needed for the sheet.
- Place the border, north arrow, bar scale and resident engineer information cell directly in the sheet file.
- Check the sheet file’s Model Properties and verify set the Annotation Scale to the sheet’s plot scale. The default for all sheet files except Typical Section sheets is 1:100.
- Edit the border text as needed.
- Annotate with MicroStation text.
♦ Dimension reference graphics, if desired.

**CDOT MicroStation Sheet File Workflow Design Group**

**Model Files**

- From Survey/ROW
  - JPC#ROW_Model.dgn
  - JPC#SURV_Model.dgn
  - JPC#SURV_Top.dgn

- From Design
  - JPC#DES_Model.dgn
  - JPC#DES_Profile.dgn

**Sheet Files**

- JPC#DES_Plan#.dgn
- JPC#DES_Pro#.dgn

**Note:** InRoads Plan/Profile Generator automates this process and can quickly generate a set of sheets along an InRoads alignment. Use the above workflow for special situations (approach roads, intersections, etc.) or where just a few sheets are needed.

**Typical Section sheets**

Typical Section sheets are an exception to the rule, since graphics are created directly in the sheet file using the CDOT Typical Section Program. Use the following workflow to create Typical Section sheets (an example is also provided in the lab exercises):

♦ Create a new sheet file each sheet (you can use the auto-populated file JPC#DES_TypSect#.dgn).

♦ If you’re using the auto-populated file, it contains a generic border. You can either edit the border information, delete the generic border and place a project border, or replace the generic border cell with the project border cell using the **Replace Cell** command.

♦ Check the sheet file’s **Model Properties** and verify set the **Annotation Scale** to 1:10. This is already set-up if you created your file from the auto-populated file.

♦ Start the **Typical Section Program** (from the **CDOT Menu** select **Add On’s > Launch Typical Section Program**).

♦ Use the program to create your Typical Section(s). Place the sections directly inside the sheet border.

♦ Save the typical section input file from the Typical Section Program.
**Other sheets**

Other sheets like detail, title, general notes, etc. have specific requirements, but use the same general premise of referencing the model file(s) to the sheet file and are illustrated in lab exercises.

**Specialty Groups**

**Plan sheets**

The following is a summary of the Specialty group’s sheet file workflow:

- The Specialty group creates a new MicroStation design file for each sheet.
- Reference into the sheet file the Specialty group model file with the Design model and Survey/Topo model files nested.
- Rotate the view, if needed, so graphics appear horizontal.
- Clip the references to show only what graphics are needed for the sheet.
- Place the border, north arrow, bar scale and resident engineer information cell directly in the sheet file.
- Check the sheet file’s Model Properties and verify set the Annotation Scale to the sheet’s plot scale. The default for all sheet files except Typical Section sheets is 1:100.
- Edit the border text as needed.
- Annotate with MicroStation text.
- Dimension reference graphics, if desired.

---

**CDOT MicroStation Sheet File Workflow**

Specialty Groups

Model Files

From Survey/ROW

- .JPC#ROW_Model.dgn
- .JPC#SURV_Model.dgn
- .JPC#SURV_Topo##Scale##.dgn

From Design

- .JPC#DES_Model.dgn
- .JPC#DES_Prof.dgn

Specialty Groups

- .JPC#BRDG_Model.dgn
- .JPC#HYDR_Model.dgn
- .JPC#LAND_ENVI_Model.dgn
- .JPC#TRAFF_Model.dgn
- .JPC#UTIL_Model.dgn

MicroStation Text

- Text

MicroStation Dimensions

- Dimensioning

Sheet Files

- North Arrow Cell
- Border Cell
- MicroStation Cells
- Region Eng. Cell
- Bar Scale Cell
**Other sheets**

Other sheets like detail, tab, and notes sheets have specific requirements which are illustrated in lab exercises.

**More Information**

For more information on creating sheet file, see CDOT Workflows Sheet File Creation, Sheet File Creation Multiple Scales, Creating Multiple Plan Sheets, Note Sheets, and Title Vicinity Map.
See also the CDOT CADD Manual, Chapter Eight – Drawing Information, Section 8.4 Project Sheets. This contains several useful links for sheet workflows.

**Rotating Views**

It is often necessary, especially with highway design projects, to rotate a plan view so that the alignment is horizontal to the view. This is especially useful when creating plan sheets. You can accomplish this using the following methods.

**Rotate the Plan View with a Keyin**

If you know the degree of rotation, you can rotate the view using the rv= keyin (rv=X axis rotation, Y axis rotation, Z axis rotation).

**Rotate the Plan View by 3 Points**

Use this method to define a view’s new positive horizontal (X) axis and new positive vertical (Y) axis. The first two data points define the view’s new X axis and the third data point defines the direction for rotation.

**Rotate the Plan View by Element**

You can use the direction of an element to rotate a view so that the view is horizontal to the element (e.g. a horizontal alignment). Key in Rotate View Element and then <D> on the element to rotate the view.
Note: The view is rotated based on the direction the element was drawn. The positive X axis is based on the positive direction of the element.

Placing Borders

Using the CDOT Menu for Border Placement

The Border and Border RE Categories under Drafting on the CDOT Menu provide a convenient method of placing the border and related information in a sheet file.

You have the option of placing different types of border cells, as well as other cells for the bar scale, north arrow and resident engineer.

Creating a Project-Specific Border Cell

If you use the generic border in the auto-populated sheet files, or if you place a border cell in a sheet file using the CDOT Menu or the Place Active Cell command, then you will need to edit the border to specify all of the project-specific information for every sheet. This can be a time-consuming process.
Instead, you can create a project-specific border cell. Place the cell in a blank file, and then edit the cell text to fill in all of the project information (number, code, initials, etc.). You can either place this border in a blank sheet file, or replace the generic border cell with the project border cell in the auto-populated file. MicroStation’s **Replace Cell** command is handy for this.

**Editing text on the Border**

Text in the border cell can be edited using the **Edit Text** command on the **Text** toolbar. Select the text to edit, key in the new text in the **Text Editor** window, and then `<D>` to accept the edit.
Note: If you place the border cell as a Shared Cell, you must first drop the cell status to a regular cell in order to edit the cell text.

Measurement Tools

The Measure toolbar is used to measure distances, angles, radii and areas. Use Settings > Design File > Working Units to define how measurement values will display (units, precision, etc.). If you reference your model file graphics into your sheet file at 1:1, you can measure graphics in the sheet file with accurate results. Otherwise, you’ll need to measure graphics in the model file.

Measuring in 3D

Important! In a 3D file, if you want planar measurements, turn on ACS Plane Snap lock before using the appropriate measure command. Make sure AccuSnap is off if you’re snapping to points when measuring in 3D. Use Tentative snaps instead.
If you want true slope (3D) measurements, turn ACS Plane Snap lock off.

Some of the more commonly used measuring tools include:

**Measure Distance**

Measures distance using one of the following methods:

- Between Points
- Along Element
- Perpendicular
- Minimum Between

**Measure Radius**

Measures the radius of a circle or an arc, or a circular segment of a complex chain or shape, or the primary and secondary axes of an ellipse.
**Measure Angle**

Measures the angle between two lines or linestrings, or the angle between two segments of a shape.

**Measure Length**

Measures the length of an element or the perimeter of a shape.

**Measure Area**

Measures area using the same method options as the **Pattern** tools. This includes the area of a shape (Element method) or an area you dynamically define using the Points method. In addition, you can Flood an area or measure the area of the Intersection, Union or Difference between elements (see Pattern commands for an explanation of these methods).

In the expanded portion of the tool settings dialog box, the units of measure for both the area and perimeter can be set. The available units are the same as those available for working units.
**Note:** If you’re measuring the area of 3D graphics, the Points method is the only method that will provide a planar measurement. The ACS Plane Snap lock must be turned on to get planar measurements.
The CDOT Custom Measure XY Distance tool

From the CDOT Menu, select Add On's > Measure XY Distance to open this custom tool, which allows you to easily obtain *both* planar XY distances along with true 3D slope measurements *without having to check or set active depth or the depth lock*. You can use this tool the standard MicroStation Measurement tools for options shown below, including the **Perpendicular from element** option.

![XY Distance tool interface](image)
Chapter 11 - Tab Sheets

Once the design is completed, pay quantities can be gathered and entered into summary sheets. There are many methods of calculating quantities and many formulae used. Once the quantities have been computed, they are entered into tab sheets and linked to MicroStation sheet border file for printing. This module describes the process of entering calculated quantities into the tab sheet and attaching the sheet to the sheet border for printing.

Files Used

Three files are used to create the final tab sheet for printing. These are:

- **TransportItemList.csv** – This file contains the list of pay item codes from the Colorado Department of Transportation Master Item Code Book (Spec Year 05). This file is located in the C:\Workspace\Workspace-CDOT_XM\Standards-Global folder and is automatically updated by ServerCop.

- **JPC#SPEC_Tabulation of ????.xls** – This is the file where the quantity data is entered. The first part of the file name is the project code and the three to four letter abbreviation of the specialty group. The last part of the name describes the type of data to be entered. For example, the 88888DES_Tabulation of Guardrail.xls contains quantities and pay items related to guardrail. These files are located in the C:\Projects\JPC#\Group\Drawings\Tabs folder.

- **JPC#SPEC_TabMisc##.dgn** – This file contains the sheet border for the printable tabulation sheet. This file can be modified to contain project specific information (project code, RE cell, etc.). It can also be copied if more tabulation sheets are required. This file is located in the C:\Projects\JPC#\Group\Drawings\Tabs folder.

Entering Data into the Spreadsheet

The process of inputting data into the spreadsheet is similar for all of the tab sheets. See the tab sheet instructions workflow [Tabulation of Bridge](http://www.coloradodot.info/business/designsupport/cadd/manuals-training-resources/resources/).

Linking the Tab Sheet to a MicroStation Drawing

The process of linking the Tab Sheet to a MicroStation drawing is the same for any Excel spreadsheet. See the [Linking MicroStation to Excel Document](http://www.coloradodot.info/business/designsupport/cadd/cadd-workflows/v8i-ss2) instructions workflow at [http://www.coloradodot.info/business/designsupport/cadd/cadd-workflows/v8i-ss2](http://www.coloradodot.info/business/designsupport/cadd/cadd-workflows/v8i-ss2) to guide you.
Chapter 12 - Annotating and Plotting Sheets

This chapter discusses the use of text and dimensions to complete a plan sheet. It also covers printing options.

Chapter Summary:

- Discuss what Text Styles are and how CDOT Text Styles are organized
- Describe how to place text from the MicroStation menu and from the CDOT Menu
- Describe how to use Greek font characters
- Discuss how Annotation Scale affects text and dimensions
- Discuss what Dimension Styles are and how CDOT Text Styles are organized
- Discuss the plotting workflows
- Discuss assembling plan sets

Understanding Text and Text Styles

After creating the sheet file, you can now annotate the sheet using MicroStation’s text tools and dimension the drawing with the dimensioning tools.

Text Styles

Text Styles provide a method of saving and applying text attributes in MicroStation. They function similar to styles used in word processing software, saving text setups that include font, height and width, line spacing, color, etc. When you apply a style, it’s like applying a whole set of characteristics in one step. Once the style is applied, the text is linked to the style and any future changes to the style will update all text currently using the style. The text style contains attributes like font, height, width, line spacing, line length, text justification, etc.

CDOT Text Styles

CDOT text styles are saved in a DGNLIB file called CDOT-Text & Dim Styles.dgnlib, located in the C:\Workspace\Workspace-CDOT_V8i\Standards-Global\MicroStation\DGNlib\Standard folder. This file is automatically attached to any design file opened in the CDOT workspace. This way, you will always have your text styles loaded. Using Text Styles is a very effective in standardizing text throughout a project or agency.

CDOT text styles are categorized by text size (e.g. .07, .10, .14, etc.) Each style is one of two types – 100 or 80 (e.g. .07 ENG 80). 100 styles have the same text height and width. 80 styles are proportional sized – the text width is 80% of the text height.
**Text Toolbar**

The Text toolbar is used to place and edit text. When you place text, you specify a Text Style to apply to the text.
**Place Text**

Places text that you enter into the **Text Editor — Word Processor** window. The MicroStation Text Editor uses some basic word processing format options (font, bold, underline, italics, etc.), which allows for quick text manipulations. You can change these attribute per letter, word or string within a text block.

Other word processing functionality includes checking spelling prior to placing text and using **Cut, Copy** and **Paste** between MicroStation and other Windows applications.

Text is placed using active text and design file parameters including:

- Active element symbology (color, weight)
- Active level
- Active angle and
- Text style.
**Drawing Scale**

Before placing text, check the **Annotation Scale** for text under **Model Properties**. The **Annotation Scale** is set to **100**, by default, in the CDOT seed file. This should be the same as your plot scale. If you’re plotting at any other scale, change the **Annotation Scale** here. Any text that you’ve previously placed will be updated (i.e. you don’t have to delete and replace the text – it will be re-scaled automatically).
**Note:** To enable scaling of text, make sure that the Annotation Scale lock is turned on in the Place Text command before placing your text.

For more information on text, see the **CDOT CADD Manual, Chapter Five – Drawing Standards, Section 5.4 Standard Annotation.**
CDOT Menu text

Placing general text using the CDOT Menu

The CDOT Menu streamlines the text placement process by minimizing text placement options to those frequently used on CDOT drawings. Select the Drafting > Text group to place Standard or Title text. Text Justification, Spacing and size can be specified in one location. After setting these main text parameters, key-in your text in the Text Editor and then <D> to place the text in the file.
**Placing Specialty Group text with CDOT Menu**

The CDOT Menu also takes the guess work out of placing specialty group text. Select the **Group** and **Category**, and the menu shows the annotation options for the different items in that group. Select the text item and all the text options are automatically set in the **Place Text** command. Just key-in your text in the **Text Editor** and then place in the file.

**Placing User-defined Utility text**

The Utility Group on the CDOT Menu has special options for placing text that allows you to build a database of utility information and then annotate that information directly on the utility line. Each different type of utility has its own set of annotation options specific to that utility line.
To create a new Utility text annotation, select the **Category** and then select the **<New Text String >** item. You can then select from a list of pre-defined utility features, or create new ones.
After specifying the utility line features, select **OK** and then **<D>** on the line to place the text.

You can save this text information in the CDOT item list for placement again later.
Using the Greek characters font

If you need to place Greek characters on a drawing, then see the CDOT Workflow, Greek Characters.

Understanding Dimensions and Dimension Styles

**Dimension Styles**

**Dimension Styles** provide a way of saving and applying dimension attributes in MicroStation. They function similar to the text styles, saving setups that include terminators, tolerances, units, etc. When you apply a dimension style, it’s like applying a whole set of characteristics in one step. Once the style is applied, the dimension is linked to the style and any future changes to the style update all dimensions currently using the style.

CDOT Dimension styles are saved in the **DGNLIB file CDOT-Text & Dim Styles.dgnlib** located in the `C:\Workspace\Workspace-CDOT_V8i\Standards-Global\MicroStation\DGNlib\Standard` folder. This file is automatically attached to any MicroStation design file opened in the CDOT workspace. This is a very effective in standardizing your dimensions throughout CDOT.

**CDOT Dimension Styles**

There are currently three CDOT dimension styles available:

- CDOT 1 – Accuracy of 0.1234
- CDOT 2 – Accuracy of 0.12
CDOT 3 – Feet and inches.

CDOT 4 – Accuracy of 0.12 B spline Notes

CDOT 5 – Accuracy of 0

**Note:** All CDOT Dimension styles have the option **Reference scale** turned on. This allows you to dimension reference graphics actual size if the reference attachment was scaled.

**Placing Dimensions using the CDOT Menu**

The CDOT Menu streamlines the process of dimensioning elements. From the CDOT Menu Explore select **Drafting**, set the category to **Dimensions**. Five Filters represent the different dimension styles in the configuration.

![CDOT Menu Screenshot]

There are five options for each **Filter** or dimension style:

- Dimension Linear Size – Dimensions size by specifying a start and end point.
- Dimension Angle Between – Dimensions the angle between two points.
- Dimension Angle Size – Dimensions the angle between lines.
- Dimension Element - Dimensions an element (line, linestring, shape, arc, or circle).
- Label Line – Labels a line with a bearing and/or distance and labels the line.
The three accuracy options, .1234, .12 and x'-xx” allow you to specify the CDOT dimension styles CDOT 1, 2 or 3.

The menu automatically selects the proper dimension command and active level for placing the dimension.

Toggle on **Association** if you want the dimension to update if the element is modified. Associative dimensioning also works for reference elements.
**Note:** You must turn on the **Association** lock in order to activate the **Association** toggle in the dimension command.

**Dimension toolbar**

In addition to the CDOT Menu, you can also use the **Dimensioning** toolbar to place dimensions. However, the most common dimensions are on the toolbar.

**Using the Match Dimension tool**

If there are existing dimensions in the design file, you can match the dimension and then place it again using the dimension command on the toolbar.
Plotting

Workflows

CDOT has established workflows for plotting to either 11” x 17” printers or plotting to Adobe Portable Document Files (PDFs). These workflows include MicroStation Printing for single sheets or Batch Printing for printing multiple sheets or PDF files. See the CDOT Workflows for more information.

Printer Drivers

Seven CDOT printer drivers are available to select before plotting:

- CDOT-DefaultPlotter_V8i.pltcfg
- CDOT-DefaultPrinter_V8i.pltcfg
- CDOT-ROW-DefaultPlotter_V8i.pltcfg
- CDOT-ROW-DefaultPrinter_V8i.pltcfg
- CDOT-PDFDraftQuality_V81.pltcfg
- CDOT-PDFHighQuality_V81.pltcfg
- CDOT-Shaded_PlotterDriver_V8i.pltcfg

Choose one of the top four if you’re plotting to a plotter or printer. The fifth and sixth are used for plotting to PDF. Printer drivers control plotting devices, plot sizes, CDOT pen tables, etc.
**Location of PDF files**

When plotting to PDF files, they should be placed in the project’s **Plot_Sets** folder under the appropriate subfolder, for use by the reproduction department and other disciplines for reference and review. Only final submittals should be stored in this location.
Additional Plotting Workflows

Additional workflows regarding MicroStation printing include Printing AutoCAD file in MicroStation, Printing Raster Images, Shaded Color and Grayscale Printing and Printer Driver Adjustments.

CDOT Work Flow

Work Flow :

- CDOT Alignment Display in Cross Section.Ink
- CDOT Annotating Horizontal and Vertical Alignments.Ink
- CDOT Batch Printing.Ink
- CDOT Batch Processing.Ink
- CDOT Configuration ReadMe file.Ink
- CDOT Converting AutoCAD Files to MicroStation.Ink
- CDOT Creating Multiple Plan Sheets.Ink
- CDOT Directory Structure.Ink
- CDOT Displaying Features in Cross Section and Profile.Ink
- CDOT Exporting Fieldbook Files.Ink
- CDOT Greek Characters.Ink
- CDOT Level Update for V03.01.Ink
- CDOT Linking MicroStation to Excel Documents.Ink
- CDOT MicroStation Printing.Ink
- CDOT Note Sheets.Ink
- CDOT PFC Management.Ink
Assembling Plan Sets

After you’ve plotted your files for a plan set, refer to the CDOT CADD Manual, Chapter Eight – Drawing Information, for a comprehensive listing of sheets, information to include on each type of sheet, sample project sheets and a final checklist.
Index

A
Association Lock 173
Associative dimensions 172
AutoCAD 176

C
CDOT CADD Resources 165, 174, 177
CDOT Menu 166, 167, 171, 173
Copy 163

D
Design Library 161, 170
Dimension Styles 170
Dimension styles 170, 171
Dimensioning 170, 171, 173
Dimensions 170, 171, 173

M
Models 164

P
Plotting 174, 175, 176, 177

S
Scale 164, 165

T
Text 161, 162, 163, 165, 166, 167, 168, 170, 171
Text Annotation Scale 164, 165
Text Styles 161
Text styles 161

W
Workspace 161, 170