CDOT Workflow MS-24 — Assigning A Project Geographic Coordinate System (GCS)

Workflow MS-24 — Assigning A Project
Geographic Coordinate System (GCS)

These instructions are intended to be used by the specialty groups to assign the
project Geographic Coordinate System (GCS), created by Survey and assigned to
the JPC##SURV_TopoO1l1Scale### .dgn file, to MicroStation design files so that files
with non-project specific GCS can be properly projected and aligned with project
design data.

Introduction

The key to having design files and imagery properly line up with one another is in the
GCS assignments. When referencing imagery, it is important to know the GCS of the
file. Without knowing the GCS, there is no guarantee the design files and imagery
will line up with the project data.

This workflow guides you through the steps required to assign a project Geographic
Coordinate System to a project design file. This will facilitate the integration of
images, GIS data, and design files that use different coordinate systems or no
coordinate system.

CDOT Survey creates a project specific, local datum plane (project coordinate
system). The project GCS is then assigned to Survey’s MicroStation JPC##SURV _
TopoO1Scale###.dgn file. Once assigned, other specialty groups can reference this
survey file to assign the project GCS to their own design files.
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Assigning the Project GCS To A Design DGN File from

Survey’s project DGN file

The Survey project specific Geographic Coordinate System can be assigned to
design DGN files using the From File tool in the Geographic Tool Box.

1. Select Tools > Geographic> Open as Toolbox from the menu bar.
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2. This will open the Geographic toolbox. Click the Select Geographic
Coordinate System icon from the toolbox.
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3. This opens the Geographic Coordinate System dialog box. Click the
From File icon (the sixth icon from the left) to open the Select
Geographic Coordinate System Source dialog box.

Geographic Coordinate System l':’ & I“
1

] : 3 Pl
5

" s e —
Cusrent Geog'mhcf‘r *_*» System
rom File
Name:  <None>

Description
Source.

4. Inthe Select Geographic Coordinate System Source dialog box,
navigate to the projects ROW_Survey/Drawings/Reference_Files folder.

5. Select the ####SURV_Topo01Scalel00.dgn file (##### representing
the project code). In this example the 14553SURV_Topo01Scale100.dgn

is used.
4 Select Geographic Coordinate System Source - C:\Projects\InRioads 554 Practice Data Set\ROW_Survey\Drawings\Reference_Files\, g
Look in I Faference_Fles - I [ N v :‘-3 £3
- Name Date modified Type Size
';,"/ Remote_Sensing 5/4/2017 203 PM File folder
Recent Places Working 1/6/0161:25PM  Fille folder
! 14533 Proposed Lines.dgn 1/6/2016 12:33 PM Benitley MicroStati... BOKB
J%14553 CodesS05cale.dgn 10/29/2015 2229 PM  Bentley MicroStati... 950 KB
Desktop 14553 Easements.dgn 1/6/20161234PM  Bentley MicroStati... B3KB
14553 Femal8113C0252 C.dgn 10/17/20151:10 PM  Bentley MicroStati... 92 KB
= 14553 Mames30Scale.dgn 10/20/2015 2:29 PM  Bentley MicroStati... M3 KB =
Libraries % 14553 ROW Model.dgn 1/8/2016 1:16 PM Benitley MicroStati... BEKB
%5 14553ROW _Sec-Lines.dgn 2/15/201710:36 AM  Bentley MicroStati... 49KB
L™ JB145535URV Import-Surface.dgn 617/2015135PM  Bentley MicroStati.. KB
Computer - ML . . J
- % 145535URV_TopoD1Scalel00.dgn 4/20/2017 9:53 AM Bentley MicroStati... T KB
“w :
MNetwork
File name 145535URV_TopoD15cale 100.dg hd Open
Files of type: | MicraSeation DGN Fies ( dan) s Cancs |

6. Click Open to assign the GCS from this drawing.

The GCS is now assigned to the drawing.

Geographic Coordinate System EI = @
rRAPF LD
Current Geographic Coordinate System

Mame: Leopard Creek
Description:  Modified - NADB3/2011 Colorado State Plai
Source: Derived from CO83-5

Note: Repeat this process on all design files prior to working in the file.
This will ensure that all data files are coordinately correct.
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Adding Reference Files To An Assigned Project

GCS DGN File

Once the project GCS has been assigned to the design file, other files with non-
project specific coordinate systems can be referenced. Using the same steps to
reference a dgn file, with a non-project specific GCS file can be correctly oriented to
the active project specific GCS DGN file.

1. Begin by selecting the Attach Reference icon in the References dialog

box.

) References (0 of 0 unique, 0 displayed)

=
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oreferenced: e
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2. Inthe Attach Reference dialog box, navigate to the design file (it MUST
have a GCS assignment in order to be reprojected).

3. Add the file to the Selected Documents.
4. Change the Attachment method to Interactive.
5. Click OK.
Attach Reference @
Select
Documents
Folder |77 Demol h L! | DEDE|
N S
Name Desc +
# M Demal dgn 2D-5
SR 20-5
pd test |~
I-_/H UTM Control Points.dgn Uﬂv
4 T 3
Application: |AJI Applications - |
Extension: | =.dgn; *.dwg; *.dxf - |
Selected Documents IS I
Name Version Folc
L:JH UTM Control Points.dgn 1 3/8/2017
1] 3
I Attachment method: Interactive vI
Cancel
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This will open the Reference Attachment Settings dialog box.

6. In the Orientation section, select Geographic — Reprojection.

7. Set your nesting and global line style scale settings as you normally
would.

8. Click the OK button to attach the file.
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Modal: [COOT Defaut -

Logical Neme
Descrption: | Reproject reference data to Master GCS

Orientation:
Whaw Dhascription -
| Coincident Algned with Master File

Caincident - VWord Global Ongin aligned with Master Rle

Geographic - Reprojected Reproject reference: data to Master GCS

. =118
Saved Views [nons)

Mamead Fences [nons) o
4 14} 2
Detail Scake: |1"=100 v
ale (Master Ref): [ 1.000000 1.00000
Named Group: -
Revisior -
Laysl: | - |
Mested Atachments: | No Mesting *| MNesting Depth: |1
Display Ovemides: | Allaw |
Mew Level Display: [Use M5_REF_WEWLEVELD® |
Global LnaShyle Scale: | Master - |
Synchronize View: | Volume Only -
Togges
[Cldn & [fer] - < @ B [0 1[A]
Crawing Titha
Creats
ame: | D 10
Cancel |

—
e

The attach reference file has been reprojected so that data in the referenced file is in
the correct location in relation to the active file.
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Referencing GIS Shapefiles

MicroStation allows you to reference Shapefiles with a GCS. When referencing a
shapefile you will need the associated files located in the same folder. Shape (SHP)
files with a defined GCS can be referenced into the design file by using the same
steps to reference a dgn file.

9. From the References dialog box, Left Click the Attach Reference icon or
select Tools > Attach from the References menu bar. This displays the
Attach References dialog box.

1M References (2 of 3 unique, 2 displayed)

Detach Al
Aekad

Reload Al
Exchange

] m 3 ) Lipean n Mew Sassion b

L8 LG A=t

10.In the Attach References dialog box, navigate to the folder containing the
SHP file.
11.Set the Extention to All Documents.

{ TN

Select

Doouments

Falder [ GIS_shapefiles - 4B EE
#h |03 - P
Mame - -

1 & HIGHWAYS.dbf

& | HIGHWAYS.py -
# | HIGHWAYS.sbn
# | HIGHWAYS chee
# | HIGHWAYS.chp

Applicabon: I.Mﬂppiam 'J

Extenson: I.ﬁldaa.lmmt - I

12.1In the file list, select the desired SHP file(s). Only the file with the .shp
extention should be selected.
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13.1f multiple SHP file are to be attached, Left Click the Add button to place
the selected files into the Selected Documents area. This allows SHP
files in different folders to be selected at the same time.

|0

. Mame

| # | HIGHWAYS sbn

-

-

& ) HIGHWAYS, shx

4 n

|2
| Applcation: All Applicatons
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Selected Documents

MName
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14. Left Click the OK button to attach the SHP files. This will open the
Reference Attachment Settings dialog box.

Selected Documents
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0 HIGHWAYS.shp
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Attachment method: [Irvhu'u-cﬁv:

e [

Colorado Department of Transportation Page 7



CDOT Workflow MS-24 — Assigning A Project Geographic Coordinate System (GCS)

15.In the Orientation area, select Geographic — Reprojection.

16.Click the OK button to attach the file. The SHP files are automatically
reprojected and placed in the correct location, as long as the MicroStation
file has a project coordinate system assigned to it.
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Once the shapefile has been referenced, you can use the Element Information tool

to see the attribute information.

@
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Referencing Image Files

CDOT has imagery covering the state of Colorado. This imagery is in two different
coordinate systems. The greater Denver area is in NAD83 Colorado State Plane
coordinates and the rest of Colorado is in UTM coordinates. Images in either system
can be referenced into a design file. The process below attaches and reprojects the
image to the project coordinate system of a MicroStation design file.

Refer to the workflow CDOT Workflow MS 12 - Accessing Imagery Files to learn
more on how to find images within the state of Colorado.

Note: it is recommended that an individual 2D design file be created for each
set of images.

Using the From Library command allows you to select a GCS system from a library
of know systems and a list of common systems used in Colorado.

1. From the Geographic Coordinate System toolbar, Left Click the From
Library icon. This displays the Select Geographic Coordinate System
dialog box.

For images from the DRAPP database:

2. Inthe Select Geographic Coordinate System dialog box, expand the
Favorites folder will reveal a Colorado favorites list.
3. Select the C0O83/2011-CF from the list.

L]

Select Geographic Coordinate System —

Library | Seanch

= Favortes
Colorada - Prajected (northing, easting, ..
“aE 4 MR - -

=} CDOT-Projects
Library

Cancel
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For images from the NAIP database:

2. Inthe Select Geographic Coordinate System dialog box, expand the
Favorites folder will reveal a Colorado favorites list.
3. Select the EPSG 26913 from the list.

Select Geographic Coordinate System =L

Library | Search
=} Fawvortes
+ Colorada - Prajected (northing, easting, )

| DRAF & NAIF Systems - Coondinate Systema for COOT Imagery

i~

Cancel J

For images from either database, continue with step 4

4. Click OK after selecting the correct system.
It is possible a message dialog box will appear with a warning message.

Geographic Coordinate System Changed

y The units of Geographic Coordinate System EPSG:32612 are Meter, but the
\!:J Storage Units in the model are Survey Foot.

I @ Dont change the storage units. Data will be drawn in Survey Foot. I

) Change the storage units in the model from Survey Foot to Meter to
match the Geographic Coordinate System.

QK Cancel

5. Select Don’t change the storage units. Data will be drawn in Survey
Foot. Click OK to continue.

The selected GCS is now attached to the DGN file.
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Once the Library GCS has been attached to the DGN file, the raster images can be
attached.

6. Using Raster Manager, select the Attach Raster icon. From the menu
bar, File > Attach > Raster can also be used.

A Raster Manager: 0 of O listed lsuloi= [ | [ Raster Manager : 0 of O listed (o=
Disolay  Settings  Liiities |

HT ¥ FEFCN

= o e
B s e 1 70 - +
Detact | From Image Senver.. Pr—
& (g Fie Name § Erom Image Server by Coordinate System - ,;" e forty Coordinate System
4 ECWP Image Server.. | = 3 Eng Maps |
4 Eing Maps_. [ e

7. Inthe Attach Raster Reference File dialog box, navigate to the image file
to be referenced and add it to the selection set.

Attach Raster Reference File @
Select
Documents
Folder [ Demol - @ L’; | == |
# |8 - P
MName ‘ Desc “
# M pat 20-5
# I Project Coordinate System Example Files.zip Proje
7R testl.dgn test
UTN Control Points.dgn LTI =|
A= UTM_Project Image.tif il —
4 | i b
Application: [.l'-\ll Applications A4

Selected Documents, chedk mark for read-only

Mame Version Fole
L@ UTM_Project_Image.tif 1 3/8/2017
i T [

I OK I ’ Cancel

8. Click OK to continue.

Next the Raster Attachment Options dialog box will appear, here you must
set the level the image should be assigned to and a Geometry Priority setting.

9. Set Draft_Image for the level.

10.Depending on the type of image that is being referenced, the Geo Priority
options could be Raster Header (NAIP) or Sister File (DRAP). Select the
appropriate option.
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11.Click Attach to continue. The image is automatically reprojected and

placed in the correct location, as long as the MicroStation file has a project
coordinate system assigned to it.
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