Workflow OP 3 - Monumentation Sheets

This document describes the process used to assemble a Right of Way Monumentation Sheet. An InRoads
XML report is used to display the required data from the geometry project. This data is copied and pasted into
the JPC#ROW_TabMon.xIs Excel file and then linked to the MicroStation JPC#ROW_Mon##.dgn file.

Workflow Outline

Creating the InRoads XML File - The data used to create the Right of Way Monumentation sheet is stored
in an Geometry Project. The InRoads Clearance report is used to extract that data for use on the sheet.

¢ Commands Used: Tools > XML Reports > Clearance - Used to create the geometry report data
used on the Monumentation sheet.

¢+ InRoads Report Browser > Templates - Used to select the template that formats the report.
¢ Format Options - Used to set the number of decimal places shown in the report.

Copying the Report - After the report is formatted, it is copied and pasted into Excel.

¢ Commands Used: INnRoads Report Browser > Copy - Used to copy the data from the report
browser.

¢ Excel > Paste - Used to paste the report data into Excel.
¢ Protect Sheet - Used to give the user the ability to turn off the sheet gridlines.
¢ Options > View - Used to turn the gridlines off.

Creating a New Link - Once the report is in Excel and formatted, it can be linked to the MicroStation file..

o Commands Used: MicroStation > Delete - Used to remove the old link.
o Word > Copy - Used to identify the text to be linked.
o MicroStation > Paste Special - Used to create the new link in MicroStation.

Creating the InRoads XML File

The data used to create the Right of Way Monumentation sheet is stored in an InRoads Geometry Project
(*.alg). Depending on the data required, one of two different reports are used to extract the data from the
geometry project. Both reports display Point Number, Northing, Easting, and Elevation. If this is all the data
that is required, a Geometry report is used. If Station and Offset information is also required, then the
Clearance report is used.

Geometry Report

A geometry project containing the data is the only prerequisite for creating a Geometry Report.
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1.

From the InRoads menu, select Tools > XML Reports > Clearance. The Clearance Report dialog box

is displayed.
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In the Include field, key in the desired COGO point numbers then Tab to accept the keyed in information.
COGO points can be specified as a range (XXX-XXX), a list of individual points (XXX, XXX,XXX) or a
combination of both (XXX-XXX, XXX, XXX-XXX). If the required point numbers are unknown, all points can
be listed by keying an asterisk ( * ) into the Include field. The asterisk can be used in conjunction with text
to limit the list of points. For example, keying in ‘Z0* would find all points whose first two digits

were’ 1’ and ‘O

<D> Apply to start the report compilation process. The Bentley InRoads Report Browser dialog box

displays.
Eclearance Report EI =] @
: General Selected:
Horizortal Alignments
. % Cogo Points Name Description i
e Featurss 1250 Cortrol Monumert-Project  T_Control
1270 Control Monumert-Project  T_Control
1250 Control Monumert-Project  T_Control
1320 Control Monumert-Project  T_Control
1360 Control Monumert-Project  T_Control
1380 Control Monumert-Project  T_Control
1405 Control Mornument-Project T_Control
4 m 3
I Apply I IPre{erences...] I Close I I Help I

The Bentley InRoads Report Browser

The Bentley InRoads Report Browser is a modified version of the Internet Explorer web browser used
specifically for InRoads XML reports. It is launched automatically when an XML report is ran. It can also
be launched by selecting Tools > View XML Reports from the InRoads main menu. The illustrations below
use the List Coordinates report, however procedures are the same for the Clearance report.
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Selecting an XML Report Template

1. Report templates are program files that format the raw data contained within the XML file. When the
Bentley InRoads Report Browser opens, it selects a default report template for the type of report that was

created.

2. CDOT’s custom report templates are stored in the CDOT folder. <D> on the CDOT folder to display the
available templates. Two custom templates are provided for creating Monumentation sheets;
CDOT_Monumentation_ListCoordinates and CDOT_Monumentation_Clearance. <D> on the desired

template name to activate that template.

] Bentley InRoads Report Browser - C:\Projec

File Toaols Help

|E:‘\F'rngram Fileg'wiork space-COOTYWStandards-Globalk

;B CDOT Air Rights Easement Description.=sl
B CDOT Fee Parcel Description, «sl

B CDOT Permanent E azement Description. <sl
B CDOT Slope Easement Description. xsl

B CDOT Temporary E azement Description. ksl
B CDOT Utility E asement Description. ksl

i COOT ListCoordinates xsl
COOT_Morurnentation_ ListCoordinates. x|
-
: _Monumentation_Clearance. «sl

E CDOT_PropertyD ezcription. <zl

|7 Clearance

3. This updates the report layout automatically in the browser window.

e

List Coordinates Report

Repart Croated S252007
Time

r 10 18am

Project: SH No 85

Description: Elbest County

VS H. No. B6.alg

File Nama: C:\Projecis TRAINRIWROW,_S
Last Revised: cferve S232007 935 54 AM
Cogo Points
::I:FT HORTH ify EAST (f ELEV ifyy
104 3277056 40 om
105 ITMAI B om
0 Erap ik 0m
w07 2141354 0.0
08 3279699 86 om
1m 265005 79 om
123 INT206 2202 80
124 81808 39 preedin]
2% 155744277 ImeETE B2 e

Format Options

DESCRIPTION

N
13
3
3

RSECT 10

ENT to be s
ROW MONLIMENT to be set
ROW MONUMENT to be sel

1. The default precision for reporting is set to two decimal places. If a different precision is required, it can be

set using Format Options.

2. From the Bentley InRoads Report Browser, select Tools > Format Options. This displays the Format

Options dialog box.
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3. Use the pull downs to set the desired precision for the different options. For the reports discussed in this
document, the following fields are used: Northing/Easting, Elevation, Linear (for offsets), and Station.

Format Options @
Mode Precision Format Close
Morthing/Easting: 0.12 hd
Hell

Elevation: 0.12 h g
Angular: Degrees j |D j |ddd"mm'ss.s"j I Include Angular Suffix
Slope: oz ~| [son =l
Use Atemate Slope if Slope Exceeds: 0.00%

Altemate Slope: |D j |2.D:1 j
Linear: 012 -
Station: |D.12 j |ss-iss.ss j
Acres/Hectares: (K ~
Area Units: 012 =
Cubic Units: 012 »| ¥ Convert to Cubic Yards
Direction: |Bea|-ings j |D j |ddd"mm'ss.s"j
Face: Right Face =
Vertical Observation: |zenih v

4. Selecting a different precision will automatically update the column or columns in the report that uses that

format option. <D> Close to dismiss the dialog box when finished.

Copying the Report to the Monumentation Spreadsheet

1. Now that the report has been generated and formatted properly, the contents of the report can be copied
into the JPC#ROW_TabMon.xls Excel file. This file contains separate sheets for different types of
monuments. These are; ROW Markers To Be Set, Control Points To Be Set, ROW Markers To Be Reset,
Permanent Easement Markers, Aliquot Corners, and Temporary Easement Points. Because any number of
these monument types may be stored in the geometry project, it may be necessary to copy different blocks
of data from the report to paste into different sheets in the spreadsheet.

2. Open the JPCKROW_TabMon.xIs file with Excel then minimize it.

3. Go back to the Bentley InRoads Report Browser and highlight the desired data in the report.

4. Right Click on the highlighted data to display the menu. Select Copy from that menu.

Cogo Points
e NORTH () EAST {0 ELEV (f) DESCRIPTION

104 155851431 327705640 0.00 N 1/4 Corer Sec. 14
105 1558527 57 327964318 0.00 MW Cormer Sec. 13
105 1553239.97 3279699.56 0.00 SW Comer Sec. 13
107 1653924.17 I261413.94 .00 SW Comer Sec. 13

1553239.97 327969986 .00 SW Comer Sec. 13

3269305,

=

Select Al
Prink

Convert selected links ko Adobe PDF
Convert selected links ko existing POF
Conwvert seleckion ko Adobe PDF
Convert selection to existing PDF

S CORMER SECT 10
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5. Minimize the Bentley InRoads Report Browser and maximize the Excel.

6. Using the tabs at the bottom, select the sheet for the copied data.

| 32 |
133 |
| 34 |
135 |
|36
| 37 |
| 35 |
139 |
Mo NI}\RDW Markers To Be Reset,{l Permenent Easement Markers / Aliquot Carners 4/ Temparary Easement Paints / |< ]
Ready

7. <D>in cell A3 of the selected sheet. This is where the copied data will be pasted. Right click in the same
cell and select Paste from the menu that displays.

@_1 File Edit Wew Insert  Format  Tools  Data window  Help  Adobe POF

N EHRAAER S B s i Fa coe s sl mee B

=Wl el

A3 - i3
A B | c ] D | E | F | & | H
TABULATION OF R.O.W. MARKERS
1 TO BE SET BY STATE FORCES
2 | Poim No.| Norihing Easiiiyg Elevation Descriplion Station Ottsel
3 |
46| Cut
4
5 -3 copy
B % Paste
7 Paste Special...
i Inserk. ..
i Delete. ..
10
7 Clear Coptents
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8. The illustration below shows the result of this operation.

IE_] File Edit Wew Insert Format Tools Data  wWindow Help  Adobe PDF

HRRE=N" RERERT= RN Rl s N =R A |2z ool AL @ i san
Ehr W _[ERAN
A3 - A 123
A | B [ ¢ [ D | E | F [ & |
TABULATION OF R.O.W. MARKERS

1 TO BE SET BY STATE FORCES
T Poiirl No. NDI‘"'IiI'l_lI EﬂS"I'_lI Elevalion DESGI"JI_IJI'I Siation Oftsed

5| 123 | 158937908 szve17EOR 22028 ROW MOMUMENT to be set
4| 124 155340408 228130929 22028 ROW MOMUMENT to be set
5| 125 155744977 azsacves2 22028 FOW MONUMENT to be set
6 | 200  1ssezPR AR 32EP4q1Z 22028 STATE HWY DEPT MONUMENT
7 | 201 155458224 a23spovan 22028 STATE HWY DEPT MONUMENT
'8 | 202 155822858 azvasve 2 22028 FOW MONUMENT to be set
9 | 203 155737897 228057038 ZP02E  ROW MOMUMENT fo be set

10| 204 155828388 323775841 22028 FOW MONUMENT to be set

9. Because the example is a List Coordinates report, the Station and Offset columns are empty. These two
columns will be hidden in order to center the title over the data.

10. <D> and hold the mouse button on the ‘F’ column label and drag the cursor over the ‘G’ column label.
Both columns highlight.

11. Right Click on the highlighted columns (in the body of the table) and select Hide from the menu.

Eﬂ File Edit ‘iew Insert Format  Tools Data  Window Help  Adobe PDF

RN~ NS = NN AN =N -N A AN B 2= -2 A6 @ sansser

25 pigi
F2 - f
A B | C | b | E H
TABULATION OF R.O.W. MARKERS

1 TO BESET BY STATE FORCES
T Poiml No.  Norihing Easling  Elevalion Descripiion Otisel
3| 123 15592379.09 227817208 220280 ROW MONUMENT to be set

4 124 1558458408 3281809238 220280 ROW MOMUMENT to be set
? 125 155744977 3284876820 220280 ROW MONUMENT to be set f cu
5| 200 1558228 46 32824112 220280 STATE HWY DEPT MONUMENT =3 Comy
T 201 155458224 328520783 220280 STATE HWY DEPT MOMUMENT (T4 Paste
? 202 155822858 327487621 220280 ROW MOMUMENT to be set Paste Special...
E 203 1957378597 32805707238 220220 ROW MOMUMENT to be set Insert
10| =204 15562683 88 328375641 220280 ROW MONUMENT to be set Delete
% Clear Conkents
13 7| Format Cells...
E Column Width, ..
15 | Hidle |
% Unhide
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12.

13.

14.

15.

The Station and Offset columns vanish and the title is centered over the remaining columns.

IE_’] File Edit Yiew Insert Format  Tools Data  Window Help  Adobe POF

NN RERENI= RN N =N AR 2 = -2l
P o Mg
F2 - B
A | B | [ | D | E
TABULATION OF R.O.W. MARKERS

1 TO BESET BY STATE FORCES
T Poinl No. | Norihing Easling  Elevalion Descriplion
3| 123 1559279.08 2327917208 220280 ROW MOMUMENT fo be set

4 124 1552494 02 328180929 220280 ROW MOMUMENT fo be set
? 125 185744977 228467082 220280 ROW MOMUMENT fo be set
? 200 1656228 48 328241120 220280 STATE HWY DEPT MOMUMENT
T 201 155458234 228520783 220280 STATE HWY DEPT MOMUMENT
? 202 1558226 52 327467621 220280 ROW MOMUMENT fo be set
E 203 185727587 228057028 220280 ROW MOMUMENT fo be set
10| 204 15568263 88 228375841 2R02E0 ROW MOMUMENT fo be set

11

Before the sheet can be linked to the JPC#ROW_Mon##.dgn file, the grid lines need to be turned off. If

they are left on, they will appear in a print of the dgn file.

Select Tools > Protection > Protect Sheet to maintain the new sheet formatting. This will display the

Protect Sheet dialog box.

Toggle on Protect worksheet and contents of locked cells near the top of the dialog. In addition toggle
on Select locked cells, and Select unlocked cells under Allow all users of this worksheet to:. <D> OK

to accept the changes and dismiss the dialog box.

Protect Sheet

Protect waorksheet and contents of locked cells |

Password ko unprobect sheet:

Allow all users of this worksheet ko

Select locked cells ~
Select unlocked cells
Format cells

Format columns
Format rows

Insert columns
Insert rows

Insert hyperlinks
Delete columns
Delete rows hd

I [0]4 I Cancel

<[<
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16. Select Tools > Options from the Excel menu.

] Fie

Edit

Wiew Insert  Formakt

Tools IQata Window  Help  Adobe PDF

N ER oG R LZ g v i PR IR Y X
-£ =7 L Q‘,,] _ ;i Research...  Alk+Click
S - P ] .
17 - A ‘@) Error Checking. ..
A B | c Shared Warkspace... E | H |
TABULAT Share Workbook. ..

q TOBES Protection 3

2 | Poim No.  Norihing Easiing Odline Collaboration — » |eription

3 123 1558379.08 32791720 Formula Auditing » ENT to be st

4 124 155845408 32818083 ) EMT to be sst
— Customize. ..

] 125 155744977 3284676, FMT to be set
— Cpkions...

G 200 1566228 48 3282411 - PT MOMUMENT

7 201 155458224 3285207 - Y rerrre o EPT MONUMENT

8 202 1558228 .58 227467621 220220 ROW MONUMENT to be set

9 203 155737897 2280570280 220280 ROW MOMNUMENT to be set

10 204 156626388 328375841 220280 ROW MONUMENT to be set

11

17. From the Options dialog box, select the View tab.

18. In the Windows Options area, toggle off Gridlines. <D> OK to accept the changes and dismiss the dialog

box.
Options
Lolor International Save Error Checking Spelling Security
Wiew _Callculation E.dit : Genetral Transiticn Custarn Lisks Chart
Shiow
Startup Task Pane Formula bar Skatus bar ‘Windows in Taskbar
Camments
) Mone %) Comment indicator onky ) Comment & indicator
Ohjects
) Show all {7 Show placeholders ) Hide all
‘Window options
[ Page breaks R & column headers Horizontal scroll bar
[ Formulas Cutline symbols ‘Wertical scroll bar

aridiines color:

Aukomatic

Zero walues

|

sheet kabs

[6]4

Cancel

19. The left most column in the JPC#ROW_Mon##.dgn file can hold 50 rows of data (not counting the two
title rows). Other columns can hold 41 rows of data. If there are more rows of data than a column can hold,

the sheet can be copied and the duplicate data deleted from the sheets.

MS- 8
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20. To make a copy of a sheet, right click on the sheet tab (at the bottom of the window) and select Move or
Copy from the menu.

42 112 165744877 228375644 220280  RAOWMOMUMENT o be set
43 119 1656282 88 228520783 220230  AOW MOMUMENT o be set
44 120 1566228 48 328057038 220280  ROW MOMUMENT o be set
45 123 1529379.08 3278 Insert... ¥ MOMUMENT to be set
46 124 153549408 32341 Delete WY MOMUMENT to be set
47 123 152744977 3284 Rename WY MOMUMENT to be set
45| =200 1556223 48 328 MOMUMENT to be set
— Maove or Copy...
43| 204 1554522 34 3285 W MOMUMERNT to be set
— Select All Sheets
50| =202 1650223 58 2274 - WWMOMUMENT to be set
&1 202 1557373897 2230 O M MOMUMENT to be set
a2 20 =) view Cade W MOMUMENT o be set
M 4 » vl ROW Markers To Be e Y OO PO T BeSet / ROW Markers To Be Reset [
Feady

21. In the Move or Copy dialog box, toggle on Create a copy. <D> OK to create the copy and dismiss the
dialog box.

Move or Copy

Move selected sheets
To book;
12345 _ROWMonumentakionShee [

Before sheek:

RO Markers To Be Set ~
Conkrol Points To Be Set

Ry Markers To Be Reset
Permenent Easement Markers
Aliquat Corners

Tempoatrary Easement Painks W

[w]iCreate a copy

22. The Copy of the sheet is named with (2) appended to the sheet name. The sheets can be renamed by right
clicking on the tab and selecting Rename from the menu. Key in the new name and press the Enter key to
accept the change.

23. In the original sheet, delete all the data below row 52 for the long column, below row 43 for the short
columns (the long column can hold 50 rows of data and there are two rows of headings).

24. In the copied sheet, delete the data from rows 3 through 52.

Linking the Spreadsheet to the MicroStation Sheet File

Once the data has been copied to the spreadsheet and the sheets formatted, they can be linked to the
MicroStation sheet border.

1. Open JPC#ROW_Mon##.dgn in MicroStation then minimize it.

2. Inthe JPC#ROW_TabMon.xls file, highlight the data to be linked. Be sure to include only columns and
rows with data (including the two title rows).
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3. From the Excel menu, select Edit > Copy (or right click in the highlighted area and select Copy from the
menu).

@ Microsoft Excel - 12345R0W_TabMon.xls
@_1 File § Edit IEiew Insert  Format  Tools Data ‘Window Help  adobe PDF

RN ¥} Undo Paste Chrl+2 TAES . fl ¥ . % ¥ . -'Lal illlﬂ
-L"_ 7 4 | Cut Chrl+
E10f=2 Copy Chrl+C UMEMT to be set
ﬂlﬂ Office Clipboard... | ] | E F
Paste Chl+Y N OF ROMW. MARKERS
T BY STATE FORCES

Paske Special, ..

1

2 | Poind Clear + | Elevation Descriplion

3 12 Delete. .. 220280  ROW MOMNUMENT to be set
4 12 Delete Sheet 220280 ROV MOMNUMENT to be set
L& 12 220280  ROW MORMUMENT to be set

Move or Copy Sheet. ..

b 20 220280  RBOYW MOMNUMENT to be set
7 | 2pd3 End. CrHF | 220280 ROW MONUMENT to be set
g8 20 Replace... Chrl+H 220280  ROW MONUMENT to be set
g 2CI| ¥ | 220220  ROW MOMUMENT to be set

204 1550263 86 2328375841 220280  ROW MOMNUMENT to be sst

—_ =
— |

4. Maximize the MicroStation window. From the MicroStation Menu select Edit > Paste Special.

1] Microsoft Excel - 12345R(
Ded & &

File § Edit JElerment Settings

®

g
li;! N Set Mark,
o

+F

Paste Chrl+v

=

Paste Special. ..
j' Show Cliphoard

5. The Paste Special dialog box is displayed. Select Linked MicroSoft Office Excel Worksheet from
the list and <D> Paste.

Paste Special

Picture of Microsoft Office Excel'workshe <

Linked Microzoft Office Excel Worksheet

Linked Text Ta Design File
Bitmap to Design File j

I Paste I Cancel |
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6. In the Paste OLE dialog box, set the Method to By Size.

7. Inthe Scale field, key in 9.25.

P2 Paste OLE - 5
Object: Microsoft Office Excel Work sheet
P i x

Method: § By Size 'l
[ Display as icon

Size: [78.854 » 56.252) "

8. An outline of the linked file is now attached to the cursor.

9. With AccuDraw active, <T> to the no-plot line in the middle of the sheet. Press the ‘O’ key to identify this
point as the origin on the link placement.

10. Move the cursor along the line, away from the sheet border, then key in the desired value in the AccuDraw
tool setting box. This should be 4” for a table with the Station and Offset columns and 4.5” for a table
without. <D> to accept the location.

FZPaste OLE =]
Shest Revisions Object: Micrasolt Offie Excel Workshest
Pasteas’ Link hd
Method: By Size -
I Display as icon
Scale: [100000
3. Key in distance Siae: (61,655 1 56.252) "
N TER] S
|
|
|
i
i

‘
|

| 2. Move cursor —z~
‘ |
‘

4. <D> to place

BN Z
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