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CDOT WORKFLOW IR 22 – Migrating Corridors
From InRoads SS2 To InRoads SS4
This document guides you through the process of migrating projects whose corridor designs
were started in InRoads V8i Select Series 2 into OpenRoads (InRoads V8i Select Series 4).

Overview
The workflow for migrating corridors to OpenRoads follows these steps:
Check corridor dependencies to determine the various building blocks used in the SS2 corridor.
Import terrain models from DTM formatted files to OpenRoads terrain models.
Import required geometry from ALG files to OpenRoads geometry.
Import corridor IRD files to OpenRoads corridors.
Review and adjust imported corridors to insure no data loss.
Perform all remaining corridor design using the Select Series 4 tools.
Maintain synchronized copies of geometry (horizontal and vertical alignments) in the ALG file for
1use in plans production activities.
Also included in this document are recommended best practices for each step of the process
and a description of potential errors and pitfalls.

Statement of Need
A variety of projects have been started in InRoads V8i Select Series 2 and these projects
currently exist in a variety of stages of development.
In the near future, new replacement computers are expected in Design office and these new
computer’s operating system will be Windows 10. Bentley has not certified InRoads V8 Select
Series 2 for use on Windows 10.
This document describes the process of migrating current InRoads projects from the Select
Series 2 version to the Select Series 4 version and what potential challenges or problems may
arise from the migration.

Colorado Department of Transportation
Page 1

CDOT WORKFLOW IR 22 – Migrating Corridors From InRoads SS2 To InRoads SS4

Definitions Used in This Document
ALG Geometry – as used in this document, ALG Geometry refers to the traditional InRoads
SS2 geometry tools and file formats. Most of these tools are available in Select Series 4.
Civil Cell – Civil cells are used in OpenRoads to store a collection of civil elements (geometry,
templates, and terrain models) as a single object which can be placed, repeatedly, as a single
object into a design. For example, civil cells can be created which model an entire intersection
and then dropped onto a road design.
Corridor Object – the DGN element which is the container for roadway corridors in
OpenRoads.
DTM – as used in this document designates the legacy terrain model format which normally has
a file extension of DTM.
IRD – the files used in Select Series 2 for storing of road corridor designs. After import, the IRD
data becomes an OpenRoads corridor object.
OpenRoads – Since the migration in question here amounts to migrating files from traditional
InRoads technology to OpenRoads technology, in the remainder of this document the term
“OpenRoads” is used to designate the Select Series 4 files or technology.
SS2 – This refers to the InRoads V8i Select Series 2 version of the software. In the remainder of
this document the term “SS2” is used to designate the Select Series 2 files or technology.
Terrain Model – The OpenRoads format of terrain models which are stored in DGN files.

Example Dataset
Project 19495 is used as an example only throughout this document.

Additional Information
Please refer to the CDOT Workflow IR 18 – Using InRoads SS2 and SS4 with MicroStation
SS4 document for more information on how to set up a MicroStation DGN file so that it will open
MicroStation by itself, MicroStation and InRoads SS4, or MicroStation and InRoads SS2, as well
as setting up Project Defaults for your project.
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Section I. Check Corridor Dependencies
Before a corridor can be imported from SS2 to OpenRoads, any required dependencies, such
as alignments and surfaces, must be imported into DGN files. In this section of the workflow a
DGN file is set up for the first corridor to be imported and then the dependencies required for the
corridor are identified.
In this example, the corridor that is to be imported is named “US 50 Proposed 2 Lane”.
1. Navigate to the Design\Drawings\Reference Files for the project.
2. Create and open a new DGN file which will later contain the imported corridor. Use the
2D-Seed_CDOT.dgn seed file. Name the file using the corridor name. In the example
shown below, the new file is named 19495DES-Corridor- US 50 Proposed 2
Lane.dgn.

3. If available, assign the project specific geographic coordinate system created by Survey
and assigned to the JPC##SURV_Topo01Scale### .dgn file, to MicroStation design files
so that files with non-project specific GCS can be properly projected and aligned with
project design data. (Menu: Tools > Geographic > Select Geographic Coordinate
System). See Workflow MS 24 – Assigning A Project Geographic Coordinate System
(GCS) for more information on attaching a project geographic coordinate system.
This file will now be used for reviewing the corridor dependencies in this section and for
importing the SS2 corridor in Section IV.
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4. If the InRoads Explorer is not visible then right click and hold in the drawing area until
the popup menu opens. Then click on Explorer Show/Hide.

5. Then in InRoads Explorer menu, click on Tools > View XML Reports. This opens the
Bentley Civil Report Browser.

6. In the Bentley Civil Report Browser, expand the Corridor Modeling folder in the left
pane and left click on the Complete Corridor Dependency Report.xls. The report will
be blank until an SS2 corridor file is opened.
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7. In the report menu, click on File > Open. The Open dialog box is displayed.

8. In the Open dialog box, navigate to the folder containing the desired IRD file. This will
typically be the project’s \Design\InRoads folder.
9. Left Click on the desired IRD file so that it is highlighted.In this example, the file named
19495.ird from the …\19495\Design\InRoads folder.
10. Left Click the Open button. This dismisses the Open dialog box and opens the file in the
Bentley Civil Report Browser.
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11. After the IRD is opened then the report will list every corridor in the IRD file and the
associated dependencies. The corridors are sorted alphabetically. Locate the desired
corridor in the report. In this example the corridor named US50_Proposed_2 lane is
used.
From this information we will make note of the following:
a) The corridor Horizontal Alignment name. US 50 Proposed_2 lane.
b) The corridor Vertical Alignment name. US 50 Segment 2 Final.
c) All alignments needed for point controls, except for superelevation. Superelevation
is handled automatically as we will see later. In this example the following alignments
are used for point controls:
I.
II.
III.

x_Ditch 534+00
x_Ditch 548+00
x_Ditch 561+00

d) Surfaces needed for target aliasing. The following surfaces are used in this example:
I.
II.
III.

Existing Ground Rev – This is the Active Surface.
100 yr Floodplain – A stand-alone surface.
Appch_559+80-RT – Created from an adjacent corridor.

The above items are identified in the illustration below.
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Best Practices – Corridor Dependencies
•

•
•

When creating new DGN files for use in OpenRoads, always start with a
2D seed file (with exceptions for terrain model files and survey files).
OpenRoads will create a companion 3D model as needed. It works much
better when the 2D elements (such as geometry) and 3D elements (such
as terrain elements) are in separate models.
Terrain model files and survey files should be created using a 3D seed file
for each dataset.
It is a good idea to make a print (paper or PDF) of the dependency report
to serve as a checklist of sorts. Target aliases in particular can become an
iterative process because of the differences in how SS2 and OpenRoads
function. In SS2, the proposed surfaces for adjacent corridors would
generate a DTM and the DTM could be used as a target alias. In
OpenRoads, it is better practice to allow target alias to seek the adjacent
corridors directly. Thus, it becomes iterative as additional corridors are
added and target aliases are patched up

Potential Errors and Problems – Corridor Dependencies
•

•

It will regularly occur that the named DTM files from the dependency
report will not exist in the SS2 data. This can occur because the DTM file
was renamed after the corridors are finished.
Target Aliases will often need to be rebuilt in OpenRoads. More details on
target aliasing is outlined in Section IV.
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Section II. Import DTMs to Terrain Models
At minimum, the DTM files used for existing ground must be imported to OpenRoads. If there
are other surfaces which serve as targets for corridors (rock surfaces for example) these must
also be imported to OpenRoads. Also, surfaces which are used by target alias may need to be
imported to OpenRoads.
If target aliases exist in which one corridor targets a DTM which was made from another
corridor, it is better practice to import the adjacent corridor then rebuild the target alias in
OpenRoads to use the corridor instead of the surface. For more information in Target Aliasing
see Section V. Import the Approach Corridor.
The importing of DTM files is very simple. It requires only selecting the DTM file and choose an
OpenRoads feature definition which is assigned to the imported surface.
In the following exercise, the primary existing ground DTM will be imported to an OpenRoads
terrain model. The import process needs to be repeated for all required surfaces listed in the
dependency report. The following workflow shows only one file being imported but the same
process is repeated for all required surfaces. When importing terrain models, remember that it is
best practice to have only one OpenRoads terrain model per DGN file.
1. Navigate to the Design\Drawings\Reference Files for the project.

2. Create and open a new DGN file which will later contain the imported terrain
model. Use the 3D-Seed_CDOT.dgn seed file. Name the file JPC#
ExistingTerrainModel.dgn. In this example the new file is named
19495ExistingTerrainModel.dgn.
3. Assign the project specific geographic coordinate system created by Survey
and assigned to the JPC##SURV_Topo01Scale### .dgn file, to MicroStation
design files so that files with non-project specific GCS can be properly
projected and aligned with project design data. (Menu: Tools > Geographic >
Select Geographic Coordinate System). See Workflow MS 24 – Assigning A
Project Geographic Coordinate System (GCS) for more information on
attaching a project geographic coordinate system.
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4. From the Tasks menu, expand the Civil Tools task.

5. Under the Civil Tools task, expand the Terrain Model tasks.

6. In the Terrain Model tasks, left click Create from File button. This displays the
Select Files To Import dialog box.

7. In the Select Files To Import dialog box, navigate to the desired project
directory. Typically, this will be the \ROW_Survey\InRoads\DTM folder.
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8. Highlight the desired DTM file then left click OK. In this example, Existing
Ground Rev.dtm is used. This displays the Import Terrain Model(s) dialog box.

9. In the Import Terrain Model(s) dialog box, set the Feature Definition to Terrain
Perimeter > Existing Border.
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10. Set the Import Option to Import Terrain Only. This imports only the terrain
model and not the Features. Triangles and break lines are automatically
created as components of the terrain model element.
11. In the Geographical Coordinate Systems area, choose the appropriate Source
coordinate system. In this example there is no coordinate system available.
12. Left click the Import button.

13. Once processing is complete, close the Import Terrain Model(s) dialog box.
14. Fit View to see the imported terrain model.
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Best Practices – Import DTM
•
•
•
•

•

Use 3D seed files when starting a new DGN that contains a terrain model.
Generally, store only one terrain model per DGN file, unless they are small. This is
for better performance.
Assign a geographic coordinate system to the DGN file before importing the DTM
file. This allows transforming the DTM on the fly during the import process.
When importing the DTM file, use a feature definition which displays the boundary
only to start. Thus, there will be minimal delay in draw time. DTM files which contain
very large numbers of triangles or dense contours will take a while to draw if the
feature definition shows these by default. After the DTM is imported and the
boundary looks OK, then the feature definition can be changed.
There is usually not a need to import both the terrain model and the features. (step
10 above) Ordinary features, such as triangles and break lines are automatically
created as components of the terrain model element.

Potential Errors and Problems – Import DTM
•
•

Picking the wrong feature definition for the terrain model, but this is easily changed in
the properties of the terrain model after import.
Choosing a feature definition at import which displays triangles or contours by default
could be slow to draw on screen if the imported DTM is very large.
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Section III. Import ALG to OpenRoads Geometry
At minimum, the horizontal and vertical alignments used for corridors and the alignments used
for point controls for the alignment must be imported from the ALG file to OpenRoads geometry
which is stored in a DGN file. The alignments and corridors used to model intersections in SS2
are covered in Section V. Import the Approach Corridor.
There is a slight difference in recommended file management practices when moving corridors
forward from SS2 to OpenRoads. When developing an OpenRoads corridor using OpenRoads
tools from the beginning it is desired to keep alignments in a separate DGN file(s) from the
corridor file. However, when migrating a corridor from SS2, there is a quirk in the software that
requires the required alignments exist in the DGN file where the IRD file will be imported.
Therefore, in Section I. Check Corridor Dependencies we created a corridor file and in this section,
we will import the alignments to that corridor file.
In this exercise, the horizontal and vertical alignments reported in the previous section must be
imported first so that the corridor can be imported in the next section. We also need to import
the alignments used by point controls.

1. Open the corridor file created previously in Section I, 19495Des-CorridorUS50-2Lane.dgn for this example.
2. Attach the terrain model DGN file created in Section II as reference file. In
this example, 19495ExistingTerrainModel.dgn is used.
3. Select the attached terrain model and using the context toolbox, set the
terrain model as the Active Terrain.

Note: IN this exercise, we will only use the existing ground terrain model.
Attach all DGN files which contain terrain models listed as target alias
dependencies.
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4. After the terrain model is set as active, OpenRoads will automatically create
the required 3D model, which can be reviewed in the Models manager.
(Menu: File > Models)

5. From the Tasks menu, expand the Civil Tools task.

6. Under the Civil Tools task, expand the General Geometry task.
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7. In the General Geometry tasks, left click the Import Geometry button. This
displays the Import Geometry dialog box.

8. In the Import Geometry dialog box, select the desired ALG file then left click
Open. In this example, the 19495.alg file is used.
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9. After selecting the ALG file, the Import Geometry dialog box opens. Expand
Alignments then expand the desired geometry style items. In this example
ALG_PRO is used.

10. Left click the check box for the desired alignments ( US 50
Proposed_2_Lane for this example). This also toggles on its vertical
alignment for importing. This is the horizontal and vertical alignment listed in
the dependency report.
11. Repeat steps 9 and 10 for any other geometry required (for point controls,
etc.). For this example, the following alignments are used: from
ALG_Existing: 17735_LT EOP and 17735_RT EOP, from ALG_Other:
x_Ditch 534+00, x_Ditch 548+00, x_Ditch 561+00 and x_GrWide 560+xx
which are listed in dependency report as required for point control. Some of
these have associated vertical alignments and some do not. Be sure that
the vertical alignments are also selected, if there is one.
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12. At the bottom, make sure that the Create Civil Rules check box is toggled
on. This allows editing of the alignments using the OpenRoads rules
mechanisms later if needed. If this box is turned off then the alignments are
imported as plain graphic elements.
13. Click Import.

The alignments are imported. The centerline for the roadway is in the middle part of the
terrain model and the other alignments are scattered throughout along the centerline.
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14. At this point, notice that there appears to be duplicate elements shown in
the view. This is because the 3D model created by OpenRoads is
automatically referenced to the 2D model. In Reference Manager, turn off
the display of Default 3D for better clarity in the view.

15. Select the mainline horizontal alignment element and open Element
Information.
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16. Note that the alignment name matches the name in the ALG file and the
Feature Definition matches the style name used in the ALG file.
17. With the centerline still selected, hover the cursor on the alignment until the
context toolbox opens and click on the Horizontal Geometry Report icon.

The report can be used to verify the import was successful. Also, a review of the start
and end stations shows that the centerline length is about 3.7 miles long. This is fine for
the alignment but we will want to be watchful after the corridor is imported to see if it
performs well when editing and is stable. Generally, we will want to keep corridor
lengths to less than 2 miles for best computer performance. We will keep this in mind
when we get to the next section.
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18. Close the alignment report.
19. With the centerline still selected, hover the cursor on the alignment until the
context toolbox opens and click on Open Profile Model.

20. The prompt reads Select or Open View. Open View 2 then left click in that
view.

In the profile view, you should see two data lines. One is a solid line style. This is
the proposed vertical alignment. The color of the proposed vertical alignment is
dependent of the feature definition assigned to the geometry.The other is green
and dashed line style. This is the existing ground surface.
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21. In the Profile View (View 2 in this example), Select the vertical alignment
element and Open Element Information.

22. Notice that the Name and Feature Definition for the vertical alignment also
match the ALG file.
23. Select the vertical alignment and using the context menu, Open the Profile
Report.

24. At this point, we should have all the geometry we need to start migrating
the SS2 IRD corridor to an OpenRoads corridor.
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Best Practices – Import ALG
•

•

•

•

Once alignments are imported to OpenRoads, make all future edits in OpenRoads. It
is possible to continue to use the InRoads ALG geometry tools for centerline
geometry and periodically import again to OpenRoads geometry. However, such a
process is not recommended because the potential for error is fairly large.
The ALG file needs to stay in synch with the OpenRoads geometry because the ALG
file is later used for plans production purposes (sheeting and annotation). Thus,
periodically the alignments need to be exported to ALG (or by using the auto export
option in OpenRoads).
Work on geometry not used in corridor modeling (right of way and such) can be done
using ALG geometry tools and traditional InRoads workflow. While designers will
eventually need to migrate all geometry to OpenRoads, in the short term, the
learning curve can be flattened a bit by continuing to use the ALG geometry for
things which do not directly serve as a corridor horizontal or vertical alignment.
It is a good idea to generate an alignment and profile report after import to insure a
successful import occurred. There are no known bugs in the software related to
import of geometry but a review is still a good idea.

Potential Errors and Problems – Import ALG
•

•

•

•

Imported geometry will exist in the form of a PI based alignment for all imported
geometry.
• This means that the alignment will be defined as a series of PI coordinates and a
curve radius at each PI.
• Thus, geometry which may have been built in the ALG file as a “fixed”, “float” or
“free” solution (using the InRoads Horizontal Elements tools) will exist in
OpenRoads as a PI rule. Preserving the “fixed”, “float” or “free” rules will require
rebuilding the alignments from scratch using the OpenRoads tools. The cost
benefit ratio of doing so will not usually make it worthwhile.
It will often occur that when the designer starts the IRD import in the next section that
additional dependencies will be reported because they were overlooked. If that
happens then simply stop the IRD import and return to repeat the ALG import.
Described above, to import additional alignments.
Keep in mind that the import process creates a link between the OpenRoads
geometry and the ALG file. If Auto-Export is used then all changes to alignments are
immediately reflected in the ALG file for later use in plans production. This applies
also the deletion. Delete the OpenRoads geometry will also delete the alignment in
the ALG file.
Make sure that the ALG file used to import OpenRoads geometry is loaded before
editing the geometry element. This is especially important if the Auto-Export option is
used. If the original ALG file is not available, Auto-Export will write to the active ALG
file, which will be Default if no other ALG file is loaded.
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Section IV. Import Select Series 2 Corridors to OpenRoads
After the horizontal and vertical alignments have been imported from ALG to OpenRoads
geometry, and the necessary surfaces have been imported from DTM files, the corridors (IRD
files) from Select Series 2 can be imported to OpenRoads corridors.
The process is straightforward for a single corridor but can become complex for an entire project
because of the repetitive nature of things and the fact that an SS2 project may contain many
corridors.
The IRD import can only process one corridor at a time. Files which contain multiple corridors
will require repeating the import until all corridors have been processed. Thus, for a complete
project, the designer can expect to repeat the workflow starting at Section I multiple times.

Prerequisites:
•
•

•

All geometry used by the imported corridors as centerlines must exist in OpenRoads
geometry, hence the requirements of the previous section.
Geometry used for point controls and other corridor adjustments must also exist in
OpenRoads. Thus, importing more alignments than just the centerlines and vertical
alignments are required.
Surfaces (DTM) used for target aliases must exist in OpenRoads. The best practice
in SS4 is to use the corridor as a target alias and not the surface created from that
corridor.

1. Continue in the corridor file, 19495Des-Corridor-US50-2Lane.dgn, for this
example.
2. Set the Active Level to DES_ROADWAY_Misc. During the corridor import
below, the superelevation elements will be placed on the active level.
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3. From the Tasks menu, expand the Civil Tools task.

4. Under the Civil Tools task, expand the Corridor Modeling task.
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5. In the Corridor Modeling tasks, left click the Import IRD button.

6. Click the ellipsis in the dialog to pick the IRD file.

7. Navigate to the project Design/InRoads folder, then choose file desired IRD
file. In this example 19495.ird is selected.
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8. After picking the IRD, click the drop-down arrow for the corridor and choose
the corridor name to be imported; US50_Proposed_2_Lane in this example.
(Note: this list is not in alphabetical order.)

9. Set the Design Stage to 0-Functional as shown below. Note: this can be
changed later. Using a low design stage is a good idea since we are not
sure how dense the model might be and how well it might perform after
importing.

10. After filling in the dialog, click thru the prompts on screen. A list of additional
missing dependencies may open. This list will point out any alignments we
overlooked when importing as discussed in Section III as well as any missing
secondary alignments or surfaces used for target aliasing which have not
been imported.
11. If any Point Control alignments were overlooked, then click NO at bottom
right and refer to Section III to import additional alignments from the ALG file.
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12. As shown in the illustration below, there are two missing Secondary
Alignments. These are accompanied by a note which reads “the .alg file
containing this alignment needs to be included in the .ird directory”. These
alignments need to be imported as well.
13. After reviewing the report, add the needed data.

14. Click Yes to continue the import.
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15. After the import, notice the following:
a. The OpenRoads corridor object will display as a shape which
parallels the centerline. The various template drop objects will also
show as shapes, and superelevation objects.

At this point you may wish to turn off the level which contains the
superelevation. These will be reviewed later, but for now, they may get in the
way.
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16. Open view 5 for display of the 3D model. After the view is open, in View
Attributes, change the model to CDOT-Default-3D.

17. In view 5, it is often useful to also change the rendering mode from
wireframe to a rendered view. Click the second button in the view 5 title
bar and choose Illustration Shadows as the rendering mode.
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18. It is also useful to turn on the default lighting and adjust the intensity
upwards.

19. Zoom in and rotate view 5 to inspect the 3D model.

20. The density of the model is fairly sparse. This is a function of the design
stage we chose, which purposely degrades the density for better
performance. Later, the design stage can be changed to provide maximum
density for the final model.
21. We can also inspect the model using the OpenRoads cross-section view. In
Tasks > Corridor Modeling, click on Open Cross-section View.
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22. At the first prompt pick the corridor object.

23. Open an empty view then left click in that view. This displays the dynamic
cross section viewer.

Note: Missing end conditions are caused by Target Aliases to design surfaces. These
Target Aliases will be rebuilt to use the corridor. This is explained in Section V below.
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If the end conditions are not showing, then follow the steps below:

24. In Tasks > Corridor Modeling, click on Define Target Alias.

25. At the first prompt, pick the corridor in the 2D view (View 1)

26. In the Target Alias dialog, select the terrain model we imported earlier and
click Add button.
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27. Then click OK. The corridor will update and end conditions will be
computed.

Note: The target alias issue should not occur if all the required surfaces are available
and have been imported to OpenRoads terrain models. However, it will often be the
case that the target alias list will contain targets to other corridors and thus the designer
can often expect to need to rebuild the target alias list for most projects.
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Best Practices – Import IRD
•
•

•

Import only one corridor per DGN file.
Very long corridors may need to be split for better computer performance which is
accomplished by:
• Copy the DGN file containing the corridor after the corridor is imported and
verified.
• In the original corridor DGN, delete some of the template drops at the end or
change their station limits so that the total length of the corridor is less than 2
miles.
• In the copy of the corridor DGN, delete some of the template drops from the
beginning, or change the station limits so that the 2nd corridor begins where the
1st corridor ends.
Target aliases which target another corridor will behave better in OpenRoads if the
OpenRoads targets are adjusted after creating the other corridors. While it is
possible to import the DTM files which result from the SS2 corridors, these DTM files
are a snapshot of the last state of the SS2 design and thus will not be useful if any
changes need to be made.

Potential Errors and Problems – Import IRD
The following are ramifications of importing corridors from Select Series 2 to OpenRoads.
•

•
•

Imported corridors should be reviewed in detail to ensure that the same result exists
in OpenRoads as was designed in SS2. The import is generally found to be reliable
but minor glitches are often seen. The following are items which will need review
and potentially will need to be corrected:
• Template drops should be checked – the templates are normally fine but some
errors have been experienced with single station drops.
• Review the details for secondary alignments, key stations, parametric
constraints, curve widening, end condition exceptions and external references.
• Review point controls details.
• Review end condition exceptions details.
• Review the 3D model to ensure that the same results are found in OpenRoads
as exists in Select Series 2. Attached the Select Series 2 surface as a reference
file can help in this review.
• Check/correct clipping where one corridor overlaps another.
As seen in this section target aliases will merit special consideration during the
import of IRD files.
Note that in the exercise above the corridor was imported using a design stage of “0Functional” which is the lowest density of model. Such low density will often give an
appearance that somethings are not working properly. For example, the point
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•

control at 561+00 left will not solve at all at this low density. The solution is to adjust
the design stage to “3-Final” at some point during the review process.
It is possible that the imported corridors will display gaps when the end conditions
change abruptly, for example at the point where slope changes from 4:1 to 2:1.
OpenRoads has newer capabilities for solving these areas than existed in SS2. The
gaps will have existed in SS2 as well. The solution is to edit the template drops and
assign feature name overrides on the end conditions.
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Section V. Import the Approach Corridor
As seen in Section IV, there can be dependencies to other corridors which exist in SS2. In the
case of the previous exercise there is a dependency to an approach corridor. In this section an
OpenRoads corridor is created for the approach. The workflow will be similar to previous
exercise:
•
•
•
•
•
•

Create a new DGN
Check corridor dependencies.
Attach the terrain models as reference.
Import required geometry
Import the IRD
Check and correct the OpenRoads corridor as needed.

Once the approach corridor is completed, the designer will need to go back to the mainline
corridor to adjust the target aliases.
Below are the Dependencies, from the dependency report, for this example:
Horizontal Alignment:

appch_559+80-RT

Vertical Alignment:

appch_559+80-RT

Point Control Alignments:

appch_559+80-rad-LT
appch_559+80-rad-RT

Target Aliases:

Existing Ground Rev
US50_Proposed_ML-A

Corridor clipping:

US50_Proposed_3 lane
US50_Proposed_2 lane

The target aliases will be adjusted after import similar to previous section.

1. First, Create and open a new DGN file which will later contain the imported
corridor.
2. Navigate to the Design\Drawings\Reference Files for the project.
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3. Create and open a new DGN file which will later contain the imported corridor. Use
the 2D-Seed_CDOT.dgn seed file. Name the file JPC#Des-Corridor-Appch
Corridor-Name.dgn. In this example the new file is named 19495Des-CorridorAppch_559+80_RT.dgn.

4. If available, assign the project specific geographic coordinate system

created by Survey and assigned to the JPC##SURV_Topo01Scale### .dgn
file, to MicroStation design files so that files with non-project specific GCS
can be properly projected and aligned with project design data. (Menu:
Tools > Geographic > Select Geographic Coordinate System). See
Workflow MS 24 – Assigning A Project Geographic Coordinate System
(GCS) for more information on attaching a project geographic coordinate
system.
5. Attach the existing ground terrain model DGN file created in Error!
Reference source not found.Section II as a reference file. In this example
the 19495ExistingTerrainModel.dgn is used.
6. Select the attached terrain model, and using the context toolbox, set the
terrain model as the active terrain.
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7. From the Tasks menu, expand the Civil Tools task.
8. Under the Civil Tools task, expand the General Geometry task.
9. In the General Geometry tasks, left click the Import Geometry button. This
displays the Import Geometry dialog box.

10. In the Import Geometry dialog box, select 19495.alg file then left click Open.
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11. After selecting the ALG file, the Import Geometry dialog box opens. Expand
Alignments then expand ALG_Secondary.

12. Select the horizontal and vertical alignments for the approach;
appch_559+80-RT in this example.
13. Expand ALG_Existing and select the point control horizontal and vertical
alignments; appch_559+80-rad-LT and appch_559+80-rad-RT in this
example.
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14. Make sure that the Create Civil Rules checkbox is toggled on and click
import.

15. This would also be a good time to attach the main corridor (US 50 2 lane
corridor in this example) as a reference.

16. In Tasks > Corridor Modeling click on the Import IRD icon.
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17. Then import the approach corridor from the same IRD we used in Section
IV.

In the 3D model, the relationship between the two corridors will start to become
apparent.

18. In Tasks > Corridor Modeling, click on Define Target Alias.
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19. At the first prompt, pick the approach corridor in the 2D view (View 1)

20. In the Target Aliasing dialog, add the mainline corridor (US50 in this
example) and existing terrain model in the order shown below.

21. Click OK
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22. This updates the end conditions as in previous exercise.

Switch back to the mainline (US 50) corridor to add the clipping references.
23. Open the mainline corridor file, in this example, 19495Des-Corridor-US502Lane.dgn is used.
24. Attach the approach corridor as reference. In this example, 19495DesCorridor-Appch_559+80_RT.dgn is used.
25. In Tasks > Corridor Modeling, click on the Add Clipping Reference icon.
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26. At the first prompt, pick the mainline corridor (US 50) which is the corridor to
be clipped.

27. Then at the second prompt, pick the referenced approach corridor which is
the clipping element.

28. Then Reset (right click) to stop picking. The corridor will be clipped.
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29. The corridor will be clipped.
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Best Practices – Additional Corridors
•

As indicated by the previous two sections, migrating a project from SS2 to
OpenRoads is a repetitive and iterative process whereby:
• Corridor 1 is imported and checked, especially for target aliases.
• Corridor 2 is imported and checked.
• Return to corridor 1 to add clipping and target aliases as needed.
• Corridor 3 is imported and checked.
• Return to corridors 1 and 2 to add clipping and target aliases as needed and so
on…

Potential Errors and Problems – Import IRD
•

For corridors around intersections, such as the approach corridor shown in this
section, it is possible, perhaps even likely, that inconsistencies in elevation will be
discovered between corridors. An example of this can be seen in the last image
above. A variety of things can cause this such as:
• The designer makes an error and imports the wrong geometry (Error! Reference
source not found.)
• The SS2 corridors are actually in error.
• The SS2 corridors are insufficiently dense. This could happen in older projects
since the needs of construction plans at the time may not have required a
detailed model of the intersection area.
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Section VI. Other Considerations
Intersections
Intersections which were modeled in Select Series 2 using the corridor tools and workflows in
Select Series 2 are importable as corridors as described in Section V. After import, the resulting
OpenRoads model should be expected to match the models created in Select Series 2.
However, OpenRoads provides more robust tools for modeling of intersections and other nonlinear entities, such as Civil Cells. Therefore, it may be desired to replace the Select Series 2
models in these areas with better OpenRoads models.
Further, some projects may be in an early stage of development where these non-linear areas
have not yet been modeled. In these cases, the OpenRoads tools will provide better results
than Select Series 2 and should be used.
The workflow shown in this document will produce an equivalent model as existed in SS2. The
quality of the imported model will match the quality as created in SS2. Keep in mind that during
the time of the SS2 design usage, the required deliverables for plans were cross-section sheets,
not 3D models. The quality of the corridor models needed to satisfy needs of cross-sections
may not be adequate to support the needs of rigorous 3D workflows such as Automated
Machine Guidance.
Because of such potential inadequacies in the 3D models in intersections, it may be expected
that some additional modeling effort will be required in the intersections. These intersection
modeling workflows will be covered in a future training document.

Plans Production
Plan and profile sheets
Production of plan and profile sheets will continue to be done using the same workflows as were
used in SS2. The InRoads tools needed for these workflows are still included in the InRoads
SS4 (OpenRoads) installation.
The only new requirement for supporting these plans production workflows is that any
alignments and profiles used in plans production must be exported from OpenRoads to the ALG
file and any terrain models which need to be shown in profiles need to be exported to DTM.
This is easy to accomplish as follows:

1. In InRoads Explorer, create or open the ALG file to be used for plans
production.
2. Set the ALG file as active.
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3. Then in Tasks > General Geometry click on the Export to Native command.

4. When the export command starts, pick the alignments to be exported. The
active vertical alignment for the alignment is also exported.
It is only necessary to export alignments which will be used for creating the sheets or
need to be annotated as a horizontal or vertical alignment.

5. To export OpenRoads terrain models to DTM, go to Tasks > Terrain Model
and click on Export to File.

6. Pick the terrain model to be exported and supply a file name.
7. Alternative: If the only need for the terrain model is to show the ground line
on profile sheets, then use the export geometry command and export the
existing ground profile(s) to ALG.
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Cross-section sheets
The only new requirement for cross-section sheets is that the OpenRoads 3D model needs to
properly prepared before creating cross-sections. Preparation includes making sure that the
appropriate levels are turned off or on and that all required reference models are attached.
Whatever is visible (whether active file or reference file) is shown on the cross-sections.
Producing cross-section sheets in OpenRoads uses tools which are very similar to InRoads SS2
tools. The tools are found in Tasks > Corridor Modeling. Additional training for these tools is
available in other course of study.

From left to right these tools are:
• Create Cross-sections – creates the cross-sections (with a sheet border if
desired) according to preferences stored in XIN file. The SS2 preferences should
work with minimal adjustment.
• Annotate Cross-sections – creates annotations on the cross-sections according
to preferences in the XIN file.
• End Area Volumes – Compute and annotate volumes according to preferences
in the XIN file.
Details on cross sections are provided in the Roadway Design Using InRoads SS4 training
material.
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File Management
It is advisable that designers make some adjustments to the way that files are created and
referenced. The following are recommendations which will need to be adopted, if not already:
• Use 2D DGN files for nearly all work. The exceptions are that survey files and
terrain model files should exist in 3D DGN files. This recommendation is made
because OpenRoads works best when the geometry and 3D models exist in
separate dgn models.
• Generally, only one terrain model exists in a single DGN. This is for computer
performance purposes.
• Only one corridor should be placed into a DGN file. If a corridor is more than 2
miles long then it should be split into multiple corridors in separate DGN files with
no file containing more than 2 miles of corridor length. This is for computer
performance purposes.
• In general, DGN files need to be more highly segregated, with alignments existing
alone (except as described in Section III), other geometry in separate files, survey
in separate files, and so on. The degree of segregation needs to be worked out
more or less as a standard which is used as standard operating procedure by all.
• It was a common practice in the past for InRoads users to treating DGN files as
disposable, because data was stored in separate files (DTM, ALG, IRD, etc) and
the DGN facilitated viewing the data. This is not true in OpenRoads and will
require a period of adjustment.
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