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Course Overview

In this course you will learn how to create edge of pavement geometry and learn about rules and relationships that existing between civil 
geometry elements.



Why is this Class Important? Pavement Edge Geometry is Fundamentally Important.

Everyone understands the importance of baselines to highway or corridor geometry. It’s right in the name: it’s the base for all the other 
geometry. Regardless of whether the baseline is the centerline or a different element, most of the horizontal and 3D corridor geometry is 
directly defined from the baseline.

Everyone understands that roadways are never uniform along their full length. Lanes are added or dropped, shoulders narrowed or widened, 
medians added or changed. 

Pavement Edge Geometry is Related to the Baseline

Pavement Edge Geometry can sometimes be independent from the baseline, but is generally dependent on and defined from the corridor 
baseline. There is an engineering relationship between the baseline and the pavement edges, even when the edges vary. 

Consider an edge of pavement in an urban setting. The edge may start two lanes away from the centerline then widen to three lanes wide for 
a turn lane. After the side road the three lane edge may taper back to two lanes wide. Implicit is two or three lanes from the baseline.

Pavement Edges are Critical for Sheets and Modeling

In addition to the general requirement of showing pavement edges on plan sheets, varying pavement edges such as those shown in the 
image below are generally used as geometric controls for corridors and template points. Rather than having to switch and transition between, 
say, two-lane and three-lane templates, the baseline and pavement edge features are used to control the width of the road using a single 
template.
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Civil Geometry and Design Intent

In the primitive days of CAD, the software immediately forgot that there was a relationship between the baseline and the pavement edge. A 
change to the baseline provided no update to the edge. The edge would have to be updated or redrawn manually. Given this inherent re-work, 
there was a tendency to postpone creation of the edges and other dependent geometry.

The civil geometry tools are a rule based set of geometry tools to create rules and relationships between geometric elements as they are 
created and edited. Because the civil geometry tools remember and honor the relationships between geometric elements, changes to the 
baseline automatically update all dependent geometry. We call this honoring the Design Intent. There is no waste and, therefore, no reason to 
defer creation of independent geometry.

Because the civil geometry tools remember and honor relationships, re-work is minimized when the project undergoes its inevitable re-
engineering. In the example shown below, when the centerline geometry is moved or changed the edge of pavement geometry and driveway 
geometry also moves and updates based on the rules and relationships.
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Exercise 1: Civil Geometry Features vs. Plain Graphics

Description
In this exercise we will learn about Civil Geometry Features and how they differ from just plain graphic CAD elements.

Skills Taught
 Reviewing Civil Geometry Features and Plain CAD Graphics

 Rules and Relationships with Civil Geometry Features

 How the software understands geometry
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Open the Design File 

1. Start the software.

2. Set the Workspace and Workset

The workspace and workset define standards that are used by the software. The Workspace and Workset used for this training are 
installed during the software installation.

a. TySelect Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet drop-down 
menu.

Open the first file.

a. Select Browse.

b. Browse to the folder where you unzipped the dataset files and select the file GraphicsVsFeatures.dgn [Metric - 
GraphicsVsFeatures.dgn].

Note: If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to OpenSite Designer. 
Clicking Yes will align the file to the software you are using (OpenRoads Designer or OpenRail Designer). This will have zero impact 
for training. Note that in production, upgrading the file will make the file read-only in OpenSite Designer. Full information is available at 
Bentley Communities - Product Realignment.

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
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Explore Simple “Tee” Intersection

In this exercise we will demonstrate the fundamental advantage of civil geometry features: intelligent rules and relationships.

1. Zoom to the “tee” intersections on the left portion of the drawing.

The four lines - two tees - at the left of the view illustrate the fundamental advantage of civil geometry features: intelligent rules and 
relationships.

Both Tees’ “side roads” are drawn Perpendicular using the Perpendicular Snap. The difference is the civil geometry side road centerline 
(red element) “remembers” that it was drawn perpendicular to the “main” line. 

2. Using the Element Selection tool, adjust the endpoints of the white graphics in the lower 
intersection. While the lines can be moved independently, they do not remember that they 
originally had a perpendicular snap relationship. This is how plain graphics behave.

3. Using the Element Selection tool, click on the upper side road (red element) of the upper 
intersection. Note the Perpendicular glyph displayed near where the lines intersect.

4. Move any of the endpoints of the blue or red lines civil geometry elements. Note that the 
lines remain perpendicular. Civil geometry is designed to honor the engineering relationship 
between elements.
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5. Zoom to the road in the drawing.

The mainline pavement edges are offset from a centerline. In this case the centerline and northern edge of pavement are civil geometry 
features and the southern edge of pavement (while) is a plain graphic element.

6. Using the Element Selection tool, select the curve of the centerline (red element).

7. Move the right endpoint of the centerline. What happens?

The Civil Geometry Features behave in an exemplary Civil Engineering manner by remembering their relationship or design intent. The 
edge of pavement remains parallel to the centerline and the side road intersection updates to intersect the new edge of pavement. The 
plain graphics do nothing.
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8. Select the centerline of the south side road and move the south end point to the left.

What Happens?

Other than the point (handle) you moved, nothing happens. No relationships are remembered: they cannot be maintained.

9. Select the centerline of the north side road and move the end of the north end point to the left.

What Happens?

The Civil Geometry Features all maintain the relationships they were built with (civil geometry remembers the original design intent). The 
side road centerline slides along and remains perpendicular to the centerline, the edges of the side road remain parallel to their centerline 
and the arcs remain tangent to their roads.
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10. Change the Offset to the north Edge of Pavement.

The value of relationships can be changed using the heads up display. For example, text manipulators are used to change values such as 
Offset distances.

a. Select the north edge of pavement.

b. Click on the Offset Text Manipulator at the midpoint of the element and key in a different offset value.

The Offset may be positive or negative. This is consistent with the engineering standard of negative offsets being to the left of the 
baseline and positive to the right. This does imply that the reference has a direction. All features do, in fact, have a direction, based on 
how it was drawn (in most cases). The heads up prompt will provide live readings of station or offset as appropriate.

TIP: There are three offset text manipulators shown along the element. Changing the text manipulator at the midpoint keeps the 
element parallel. Changing one of the text manipulators near the end of the element results in a taper.

This is the fundamental principle of the civil geometry tools, relationships remain intact and updates are automatic. There are three ways to 
impart rules/relationships or design intent; Civil Geometry Tools, Snaps, and Civil AccuDraw. In this exercise we experienced the first two. The 
Civil Geometry Offset tool created a relationship between the centerline and the edge of pavement. A snap created a relationship to keep the 
side road perpendicular to the edge of pavement.

Note: Two tools were used to create the pavement edges: Single Offset Entire Element and Simple Arc Between Elements. We will explore 
these later in this course.
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Dissecting a Relationship

Much of what we’ll be doing later in this class is placing Offsets and Tapers. Before we do, we’ll take a look at one in depth.

1. Zoom to the two features on the right side of the drawing (to the right of the “road”).

2. Using the Element Selection tool, click on the Offset Taper (blue line). 

As with any Civil Geometry Feature, clicking on the taper 
shows the rules defining it and the manipulators to edit it.

Note the flexibility in editing from the heads up display. 

3. Change the Offsets and the Start and End Stations. Observe 
how the corresponding values change.

Tapers are surprisingly complex, largely due to their differing 
Design Intent: are the Offset values the primary relationship 
or is the Taper Ratio the primary relationship?

The heads up display does not indicate which rule was used 
to create the taper. However, the Properties dialog exposes 
additional information about the taper as well as editing 
capabilities that transcend beyond the heads up display.

4. With the Taper selected, click Home > Primary > Properties 
to open the Properties dialog.
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The Properties dialog provides another way to edit the feature’s geometry. Note that the 
Transition Offset Rule group shown to the right has fields for all the heads up display 
manipulators (and more).

Among the properties not shown explicitly in the heads up display is Method.

5. Expand the Transition Offset Rule category.

6. Click on Method to see its options:

These different represent different relationships/”Design Intent”. Is the engineering constrained by the Offset Values, or is the Taper Ratio 
the overriding requirement?

This indicates the taper’s Design Intent is Ratio-dominant.

7. Click on the Ratio Text Manipulator and change the value to 1:-5. Observe what happens.

Like many of the geometry tools, the Offsets and Tapers tools consists of a palette of tools with “overlapping” 
functionality. Generally one of the tools has all the settings visible and all the prompts enabled. The other 
tools are streamlined for intent and speed, with some settings preset and some hidden.

 Single Offset Entire Element is the simplest. It presets the End Offset equal to the Start Offset, the 
Start Station locked to the start of the source feature, and the End Station locked to the end of the 
source feature. 

 Single Offset Partial unlocks the Start and End Stations, allowing the user to define Starts and Ends different from the source 
geometry, using keyins (Stations and Lengths) and Snaps. Snaps are valuable because they create relationships to other objects.

 Variable Offset Taper and Ratio Offset Taper unlocks the Offsets as well. They can provide the same geometry, but reflect a difference 
in constraint priority: are the Offset Values primary, or is the Taper’s Ratio the priority. This will affect the manner in which the geometry 
is updated when the engineering changes.
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Exercise 2: Create Pavement Edges from Centerlines

Description
In this exercise we will demonstrate the fundamental advantage of Civil Geometry Features: Civil Geometry remembers your design intent.

Skills Taught
 How the software understands geometry

 Feature Definition Toolbar

 Offsets and Tapers
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Ensuring Standards

In this exercise, we will be using multiple tools to create Edges of Pavement geometric elements. Using the Feature Definition Toolbar allows 
a “Set it and Forget It” adherence to standards. We will set the Active Feature Definition to Road_EdgeOfPavement and all new features 
created will be assigned that Feature Definition until we say otherwise. 

1. Open Beyond_CL.dgn [Metric - Beyond_CL.dgn] 

We are going to create pavement edges along the red 
centerlines.

2. Click Geometry > General Tools > Standards > Feature 
Definition Toolbar.

3. In the Feature Definition pull-down, select Linear > 
Pavement > Road_EdgeOfPavement. 

4. Enable the Use Active Feature Definition toggle.

5. Enable the Persist Snaps toggle. 

 When enabled, the Persist Snap rule will be remembered and will be maintained when elements are modified. When disabled, you can 
snap to place some geometry but the Persist Snap rule will not be remembered. There may be times when this is desirable, but 
leaving it set, is a good default practice.
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Create Offsets

We will now use the simplest of the Offset tools - Single Offset Entire Feature - to create Pavement Edges 11’ [3.5m] from the East-West road 
and 18’ [6m] from the North-South road.

1. Click Geometry > Horizontal > Offsets and Tapers > Single Offset Entire Element. 

a. Review the Tools Settings dialog. The Feature Definition 
should read “Use Active Feature”. If not, make sure the 
Use Active Feature Definition toggle is set.

Consider the Name. Clear explicit Names can be used to 
provide information to designers and reviewers that may 
not be apparent from the graphic context. Clear Names are 
also useful when reviewing the data in tabular mode via the 
OpenRoads Model Explorer or in Reports.

Major Features should have clear explicit names. For 
example, the full Northbound Outside Edge of Pavement of 
Alden Parkway should have a clear name like 
AldenPrkwy_NBEoP. 

A complex feature like that is generally made up of a 
collection of individual elements. The Complex By Element 
tool is the primary way to group the individual elements into 
a coherent whole. It provides an opportunity to Name the 
new complex feature. 

Saving a few seconds by accepting default Names at this 
point is generally okay, especially if the elements will be 
made part of a well-named Complex Feature later.

Names can always be changed via the Properties dialog.
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b. Disable the Use Spiral Transitions option.

This option is used when offsetting a feature with a spiral in it. A true “parallel” spiral is not mathematically possible.

 When Disabled, the result is “closest to parallel” but is a chorded linestring.

 When Enabled, the end points are offset by the exact distance and a new spiral placed between them. Note that this new spiral is 
not mathematically parallel to the original spiral. 

Other Settings can be set in the dialog or at the heads up prompts. 

2. At the Locate Element heads up prompt, click on the curve of the East-West road centerline. 

Clicking the curve ensures that the entire complexed feature is offset. If you click on the tangent, only the tangent is offset.

3. At the Enter Offset prompt, type 11 [3.5] and press the Return key to lock the value.

4. Left click to accept the value.

5. At the Mirror prompt, press the Down Arrow key until Yes is displayed.

Mirror is for speed: it creates an identical feature on the other side of the Reference element, both ruled to the Reference element. It does 
NOT create any relationship between the two offsets.

6. Place a data point (left click) to place the two offsets.
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7. Confirm your Work

a. Select one of the new pavement edges.

b. Review the heads up display and the Properties. Make changes if necessary.
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Confirm the Relationships

1. Set undo mark for the current state of the file.

Before doing something you will likely want to reverse with Undo, a mark can be set in the file marking its current state. 

a. Select Set Mark from the Quick Access menu above the ribbon menu.

Note: if the Set Mark tool is not shown in your Quick Access menu, you can Type Mark in the Key-in tool.

2. Select the northern edge of pavement.

3. Change the value of the middle Offset manipulator, by either the handle or the text 
manipulator.

Notice that the Pavement Edge remains parallel (single or constant offset).

4. Change the value of the end Offset manipulator, by either the handle or 
the text manipulator.

What happens?
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Changing a Start or End Offset does not change the Offset at the other end: you get a variable offset taper.

Note that the Taper Text Manipulator is editable: you can “round it off” to an even ratio but of course this will adjust the end offset value.

5. Select the centerline.

6. What happens when you move the end 
point of the centerline of East-West road? 

7. Select Undo to Mark from the Quick Access menu above the ribbon menu to undo any changes that were made to the centerline or 
edges of pavement.

8. Use Geometry > Horizontal > Offsets and Tapers > Single Offset Entire Element to add pavement edges to the North-South road at an 
18’ [6m] offset.
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Exercise 3: Curb Returns

Description
We now have two roads intersecting at a T. We will now add smart curb returns.

Skills Taught
 Simple Arc Between Elements
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Simple Arc Between Elements = Curb Return

1. Zoom to where the two centerlines intersect.

2. Click Geometry > Horizontal > Arcs > Arc Between Elements > 
Simple Arc.

The Feature Definition should read “Use Active Feature”. If not, 
make sure the Use Active Feature Definition toggle is set.

3. Place an arc in the north quadrant.

a. At the Locate First Element prompt, click on an Edge of 
Pavement.

b. At the Locate Second Element prompt, click on the other Edge of 
Pavement.

The Enter Through Point is looking for a data point, a snap, or a 
typed Radius value to locate the curve.

Given two lines, there are four sectors a arc can occupy. 
OpenRoads needs to know the sector to place the arc. The next 
data point will define which sector the arc is placed. If you are 
using a known Radius, type it in before placing a data point.

c. Type 25 [10] and press the Return key to lock the radius value. 

d. Move the cursor to different sides of the intersection and observe the different arcs than can be created. When the correct sector is 
shown, click to select the sector.

e. At the Trim/Extend Option prompt, press the Down Arrow key until Both is displayed. Both edges of pavement will be trimmed to their 
intersection with the arc.

f. Left click (data point) to place the arc and trim the edges
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g. Notice that the North-South road edge of pavement has disappeared where 
it is needed for the other side.

It is actually still there. The software remembers the original element and 
has created a new interval which is a subset of the original element. When 
we place an arc on the other side of the intersection we will still be able to 
select the original element.

This is important because the original element was created as an offset to 
the centerline and we want to maintain that relationship and be able to 
adjust that offset value if necessary.

4. Place an arc on the south quadrant.

a. At the Locate First Element prompt, click on the other East-West road Edge 
of Pavement.

b. .At the Locate Second Element prompt, move the cursor to where the North-South road Edge of Pavement used to be. Click when the 
edge of pavement highlights.

The software remembers the tools last settings. We locked the Radius last 
time. This time the prompt is Select Construction Sector. We can type in a 
new value if needed. We can also press the End key to unlock the Radius 
and locate a Through Point.

c. At the Select Construction Sector prompt, if the radius is still 25’ [10m], 
simply click in the appropriate sector.

d. At the Trim/Extend Option prompt, press the Down Arrow key until Both 
is displayed

e. Place a data point to place the arc and trim the edges.

Note that the North-South Road Edge of Pavement has reappeared where 
it is needed for the other side.
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5. Review the Interval element by selecting the 
west edge of pavement south of the intersection.

As shown in the left image, observe that only the 
interval element from the arc to the end of the 
alignment is highlighted in bold. The offset 
values for the edge of pavement are shown but 
they are grayed out and cannot be edited. That is 
because the offsets are to the original edge of 
pavement. This is an interval derived from the 
original edge of pavement.

a. Right click while the interval is highlighted. 
The original element is activated and 
highlights (see right image). The offset text 
manipulator fields can now be used to adjust 
the offset.

Tip: Selecting a modified element (i.e interval 
element) and then doing a right click will give you 
access to the base element..

6. Confirm your Work

a. Select Set Mark.

b. What happens if a road centerline is moved?

c. What happens if the pavement edge offsets 
are changed?

d. What happens if an arc radius is changed?

e. Select Undo to Mark to undo the confirmation changes.
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Exercise 4: Turn Lanes - Partial Offsets and Tapers

Description
In this exercise we will add a lane at the south end and then taper that lane back down to zero width at a controlled distance before the 
intersection. We’ll introduce Partial Offsets and Tapers. 

Skills Taught
 Single Offset Partial

 Variable Offset Taper

 Ratio Offset Taper

 Turn Lane at an Intersection

Our engineering goal here is to provide a minimum distance between an end of 
a drop lane taper and the intersection. Cars may make a left turn at the 
intersection and we want to make sure traffic merging is finished some 
distance before the intersection.

We could place a “dumb” offset to mark the end of the taper, but using “smart” 
construction elements allows us to very easily change the buffer length, with all 
dependent geometry automatically updating.

We will define the taper end at the station represented by the construction line. 

Note that the process is identical to snapping to a “hard point” in a topo file.
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Using Construction Elements

1. Select the line labeled End Taper in the drawing.

This is a construction element that has been defined to be 120’ [35m] 
from the center of the intersection. We will use this construction element 
to define where a lane taper ends. By using this construction element to 
control the position of the taper we can easily adjust the distance 
between the taper and the intersection.

This is possible because of civil geometry remembers the relationships 
(design intent) created between elements. It remembers to update 
dependent features, using the relationships they were created with.

How were the construction elements constructed?

a. The construction line at the intersection is snapped to the centerline of the East-West road and perpendicular to the North-South road. 
Perpendicular was established using the Line From Element tool with a skew angle of 90 degrees. These relationships ensure the line 
will be at the intersection and perpendicular to the North-South road even if the geometry changes.

b. The construction line labeled End Taper was created with the Single Offset Entire Element so it has a relationship to always be parallel 
to the first line at a specified (and editable) offset distance.
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Place the Turn Lane Taper

Tapers can be engineered in many ways. They can be completely dependent on the elements they are between or they can control the 
position of the ahead feature. It all depends on the engineering requirements - the design intent.

Tapers can be defined where the Start and End Offsets are primary constraints or where the Taper Ratio is the primary constraint. Your design 
intent depends on the engineering requirements. By picking the corresponding tool, you communicate your Design Intent.

1. Select Geometry > Horizontal > Offsets and Tapers > Variable Offset Taper.

The Feature Definition should read “Use Active Feature”. If not, make sure the Use Active 
Feature Definition toggle is set.

2. At the Locate Element heads up prompt, click the right pavement edge of North-South Road. 

3. At the Start Parameters prompt, you are presented with the Left and Right arrows . 
These indicate that you have multiple options. Press the Left or Right Arrow key on the 
keyboard until the Start Offset is visible.

Whenever you see the double arrows , slow down and use caution. It means you are 
being prompted for more than one item, and only one item is displayed at a time in the 
prompt. You will at some point click without checking all the options and get something you 
don’t want. Fortunately, it’s easy to fix a mistake via the heads up display or Properties 
dialog. Undo also works. The Tool Settings dialog shows all options (typically).

4. Type 0 and press the Return key to lock the value so that the first end of the taper will begin 
at the edge of pavement.

Notice the Padlock icon in the heads up prompt indicating the Start Offset value is locked. 
Press the End key on the keyboard to Unlock a value.

5. Press the Left or Right Arrow key until Distance: Start Distance is visible. Ensure that the Distance: Start Distance field is NOT Locked. If 
necessary, press the End key to unlock the value.
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6. Snap to the left end of the line labeled End Taper in the drawing and left click to define the start location of the taper.

In this situation we are defining this taper in the reverse direction of traffic flow, thus this first point where the taper intersects the edge of 
pavement is actually the end of the taper in regards to the direction of traffic flow.

You are now presented with the End Parameters prompt. The Left and Right arrows  again indicate that you have multiple options. 
It is asking for two parameters, but has three options: the End Offset and the End Station (via Distance: End Distance and Distance: 
Length prompts). 

Note: If you are getting fewer options, you may have an option locked. You can clear it in the Settings dialog.

7. Press the Left or Right Arrow key to scroll to the End Offset field. 

8. For End Offset, type 12’ [3.6m] and press the Return key to lock the value.

9. Press the Left or Right Arrow key to verify that End Offset and End Distance are not locked.

10. Press the Left or Right Arrow key to scroll to the Distance: End Length field.

11. For End Length, type 100’ [30m] and press the Return key to lock the value.

The length could have also been established by snapping to a construction graphic or other civil geometry element.

12. The location of the cursor determines which of multiple taper options will be constructed. Move the cursor south of the End Taper 
construction line and east of the edge of pavement to construct the taper in that direction.
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13. Click to create the taper.

14. At the Mirror prompt, press the Down Arrow key until No is displayed.

15. Place a data point to finish the taper.

16. Confirm your Work

a. Select Set Mark.

b. Select the taper element.

Notice the snap glyph near the End Taper construction line showing the 
relationship the taper has with that element.

c. What happens if the taper length changes?

d. What happens if the offset changes?

e. Select the End Taper construction line.

f. What happens if the offset from the intersection changes?

g. Select Undo to Mark to undo the confirmation changes.
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Place the Turn Lane Edge of Pavement

1. Click Geometry > Horizontal > Offsets and Tapers > Single Offset Partial.

The Feature Definition should read “Use Active Feature”. If not, make sure the Use Active 
Feature Definition toggle is set.

2. At the Locate Element heads up prompt, click the centerline of North-South Road. 

The edge of pavement could have also been used as the reference element. However, the 
new edge of pavement will eventually replace the original edge of pavement in this area so 
offsetting from the centerline makes the heads up display a little “cleaner” afterwards.

Start Parameters is asking you for two things: Start Offset and Start Distance (Station). For 
this feature, we want the offset and starting position to be related to the taper endpoint rather 
than keyed in values.

3. At the Start Parameters prompt, ensure that the both values are unlocked.

HINT: Use the arrow keys to cycle through the prompts and the End key to clear locks.

4. Snap to the end of the south end of the Taper element.

The pavement edge is linked to the taper and drawn to your cursor at the offset of the taper.

You are now presented with the End Parameters prompt. It is only asking for one item: the End 
Distance, but it is available in two forms, selectable by the Left and Right arrows : the End 
Distance (Distance along the reference) or the Length of the offset.

5. Use the Left or Right Arrow and the End key to clear any Locks for both settings.

6. At the End Parameters prompt, place a data point near the south end of the road.

We will place a curb return later, so the exact beginning point is not critical.

The Offset is locked, only the End Station is ruled to the feature.

7. At the Mirror prompt, press the Down Arrow key until No is displayed.

8. Place a data point to place the turn lane edge.
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Trim the Original Edge of Pavement

The turn lane and taper represent a new edge of pavement, replacing the original to its interior. We can use “CAD” tools to modify Civil 
Geometry Features. We’ll use Trim to Element here to trim the original pavement edge.

1. Select Drawing > Modify > Trim to Element.

HINT: This tool is still on the OpenRoads Modeling workflow ribbon, but on a different tab named Drawing.

2. At the Trim to Element > Identify elements to modify prompt, click the portion of the North-South road edge of pavement to be kept (the 
part north of the taper). 

3. At the Trim to Element > Identify cutting element prompt, click the taper.

4. Explore the Relationships of the Turn Lane and Taper

a. Set an Undo Mark.

b. Test the behavior of the geometry when you move and edit things.

c. Select the taper and notice that the beginning offset is not defined. Remember 
it is snapped to the edge of turn lane element.

d. When finished testing the geometry, Undo to the mark.
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Exercise 5: Turn Lanes - Offsets and Tapers - Independent

Description
In the previous exercise, we established relationships with existing graphics. Those graphics can represent existing topological features or 
restrictions on design. You can use graphics such as the construction lines to provide a visual representation of Engineering Criteria. The 
callout graphics in the previous exercise were essentially that: markers for adjustable lane and taper lengths.

In this exercise, we’ll add a turn lane and taper without external references. 
We’ll use the properties of the features themselves.

Skills Taught
 Single Offset Partial

 Variable Offset Taper

 Ratio Offset Taper

 Turn Lane at an Intersection
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Place the Turn Lane

1. Click Geometry > Horizontal > Offsets and Tapers > Single Offset Partial.

The Feature Definition should read “Use Active Feature”. If not, make sure the Use Active Feature Definition toggle is set.

2. At the Locate Element heads up prompt, click the centerline of North-South road. 

The Start Parameters prompt is asking you for two things: Start Offset and Start Distance (Station). Make sure both are correct.

3. At the Start Parameters prompt, press the Left or Right Arrow until Start Offset is visible.

4. At the Start Offset prompt, type 30 [9] and press the Return key to lock the value.

5. Press the Left or Right Arrow until the Distance: Start Distance prompt appears. Type 0 and press the Return key to lock the value to the 
start (0 distance along) the centerline. 

The Alt key can also be used to lock the Offset to the Start of the reference element.

6. Left click to accept the Start Parameter values. If the dynamic display is showing you something you 
don’t expect, you might have a value wrong.

The cursor should now have a line at the given offset extending to it. 

You are now presented with the End Parameters prompt. It is only asking for one item: the End 
Station, but it is available in two forms, selectable by the Left and Right arrows : the End Station 
(Distance along the reference) or the Length of the offset.

7. Press the Left or Right Arrow until Distance: Length is visible.

8. When the Display prompts for Distance: Length, type 180 [55] and press the Return key to lock the 
value. 

9. Left click to accept the End Parameter values.

10. At the Mirror prompt, press the Down Arrow key until No is displayed.

11. Left click to finish placing the southbound turn lane edge.

12. Confirm the expected behavior by selecting the taper and changing the Length text manipulator.
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Place the Turn Lane Taper

This time we’ll let the length and ratio of the taper determine the end of the taper, rather than a fixed end point like we did on the right side of 
the road.

1. Click Geometry > Horizontal > Offsets and Tapers > Ratio Offset Taper.

The Feature Definition should read “Use Active Feature”. If not, make sure the Use Active Feature Definition toggle is set.

2. At the Locate Element heads up prompt, click the centerline of North-South road. 

3. At the Start Parameters prompt, press the Left or Right Arrow key a couple of times to make 
sure that neither the Start Offset and Start Distance (Station) are locked. The End key will 
unlock a value. We want to have a Snap define our relationship.

4. Snap to the north end of the Turn Lane pavement edge created in the previous exercise.

5. You are now presented with the End Parameters prompt. The Left and Right arrows 
indicate that you have multiple options. It is asking for two parameters, but has three 

options: the Ratio and the End Station (via Distance: End Distance and Distance: Length). 

6. Press the Left or Right Arrow key to scroll to the Ratio field.

7. For Ratio type 1:5 (plus or minus sign determines the direction of the taper) and press the 
Return key to lock the value. 

8. Press the Left or Right Arrow key to make sure the Distance fields are not locked.

9. Place a data point near the original pavement edge. The exact length of the taper is not 
important as we will be trimming the lines in the next exercise.

10. At the Mirror prompt, press the Down Arrow key until No is displayed.

11. Place a data point to place the taper.

12. Confirm the expected behavior by selecting the taper and looking for the snap glyphs or by moving changing the offset or length of the 
turn lane.
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Trim the Taper and Original Edge of Pavement

The turn lane and taper represent a new edge of pavement, invalidating the original to its interior. We can use “CAD” tools to modify Civil 
Geometry Features. We’ll use Trim to Intersection here to trim the taper and the original pavement edge.

1. Click Drawing > Modify > Trim to Intersection.

HINT: This tool is still on the OpenRoads Modeling workflow ribbon, but on a different tab named Drawing.

2. At the Trim to Intersection > Identify first element to modify prompt, click the original pavement edge North of the taper which is the 
section of the edge of pavement you want to keep.

3. At the Trim to Intersection > Identify second element to modify prompt, click on the taper. 
south (part you want to keep) of the intersection. 

If you click in the wrong places, you will cut off the wrong side of an element. Undo and 
retry.

4. Confirm the modeling.

a. Set a mark so you can undo after testing the geometry behavior.

b. Click on the pavement edge north of the taper. Note the Trim glyph.

c. Click on the taper. Note the Trim glyph.

d. What happens if you change the new turn lane Offset?

e. What happens if you change the Taper Ratio?

Note: you may need to right-click to enable the Ration text manipulator.

f. What happens if you change the mainline edge of pavement offset from 18’ [6m] to 30’ 
[9m]? Observe the relationships being honored. 

g. Undo to the mark.

The procedure above has two edges, the main lane and the turn lane, both ruled to the 
centerline. They will both update if the centerlines moves. 
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An alternative design would be to rule the turn lane to the main edge. This way the turn lane edge will automatically update if ether or both of 
the centerline and main lane edge change geometry.

Both methods are valid. The model should be built based on how you want the geometry to update. What is the Design Intent? Which is the 
primary engineering consideration? Which method will be easier to manage for a large product or with multiple designers over a long period of 
time? Civil geometry will remember how you build it. The choice is yours.
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Exercise 6 - Placing Curb Returns

Description
So far we’ve created simple single-radius curb returns. Engineering designs often call for geometry more complex than that. The Arc Between 
Tools can handle any requirement. 

In this exercise we will add curb returns where the North-South road intersects 
the ramps.

Skills Taught
 Understanding the Civil Geometry data structure

 Simple Arc

 3 Center Arc

 Add Spiral Transitions to a Simple Arc
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Place a Simple Curb Return

1. Zoom to the south end of the North-South road.

2. Click Geometry > Horizontal > Arcs > Arc Between Elements > Simple 
Arc.

The Feature Definition should read “Use Active Feature”. If not, make 
sure the Use Active Feature Definition toggle is set.

The east-west lines are ramp baselines along the their northern 
pavement edges. We will use these to define the curb return arcs.

3. At the Locate First Element prompt, select the eastern Ramp edge of pavement.

4. At the Locate Second Element prompt, select the North-South road edge of 
pavement.

5. At the Select Construction Sector prompt, type 50 [15] and press the Return 
key to lock the value.

6. Position the cursor to construct the arc in the correct sector and left click.

7. At the Trim/Extend Option prompt, press the Down Arrow key until Both is 
displayed.

8. Place a data point to place the arc and trim the edges.

Note that the ramp edge is not trimmed. It is in a reference file whose contents 
cannot be modified.
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Understanding the Tools

The civil geometry tools are designed to handle even the most complex engineering. The User Interface is designed for simplicity and speed. 
While there may be 15 variables required to handle the most complex fillet, for a Simple Curve for a fillet only the radius is required. Requiring 
the user to fill out 15 parameters would be grossly inefficient. Look at the Arc Between Elements tools. The menu shows six tools that create 
different combinations of arcs, spirals, and tapers. While the data structure is exactly the same for all of these, each tool only asks for its 
required options.

The last tool in the list, Arc Between Elements, is the most complete and includes options for forward and 
back tapers and Back and Ahead transitions including multi-center curves and spiral-curve combinations.

The other tools are essentially the same tool but have some options preset and hidden. For example the 
Simple Arc tool assumes (presets) no tapers and transitions and hides those options. The Spiral Arc 
Spiral tool hides the taper options but shows the transition options and presets them to a spiral type 
transition.

The important thing to understand is that no matter which tool is used, the arc element created has the 
same data structure. You can always change ANY of the options in the Properties dialog no matter which 
tool was used to create the arc. For example, if an arc is created with the Simple Arc tool and later needs 
to be changed to a Spiral-Arc-Spiral curve, simply open the Properties and change the Back and or 
Ahead Transition from None to Spiral.
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Place A Complex Curb Return

1. Click Geometry > Horizontal > Arcs > Arc Between Elements > 3 Center Arc.

There are a lot of options with this tool. On tools with many options, setting some or all of them in the Tool Settings dialog may be easier 
than just using the heads up display. Some settings may not even appear on the heads up prompt and may have to be set in the dialog. 
The heads up display is designed for the most efficient input of common options. For example with this tool the transition Method option is 
not shown in the heads up display. If you want to define a transition by deflection angle or offset distance you will need to change that 
option in the dialog.

Keep in mind: Like any geometry tool, if you make an input mistake, you can fix the settings in the Properties dialog or use Undo.

2. Use the dialog to set the following:

 Trim/Extend = Both

 Radius = 75 [25] and Lock it

 Loop = Disabled (enable this for loop ramp geometry)

 Back Transition Type = Curve

 Back Transition Method = Length

 Back Transition Radius = 125 [40]

 Back Transition Length = 50 [15]

 Ahead Transition Type = Curve

 Ahead Transition Method = Length

 Ahead Transition Radius = 125 [40]

 Ahead Transition Length = 50 [15]
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3. At the Locate First Element prompt, select the western Ramp edge of pavement.

4. At the Locate Second Element prompt, select the North-South road edge of pavement.

5. At the Select Construction Sector prompt, position the cursor to construct the 3-center curve in the correct sector and left click.

6. At the Trim/Extend Option prompt, press the 
Down Arrow key until Both is displayed.

7. Place a data point to create the arc.

The civil geometry element structure for 
curves is designed to model the full breadth of 
engineering needs. Remember that the 3 
Center Arc tool is streamlined specialization 
for the full Arc Between Elements tool. Simple 
Arc, which only “asks” for Radius, uses the 
same data structure.

What this means is that regardless of the tool 
used, you can edit the curve to any required 
geometry specification. 

Back and Ahead Transitions can be None, 
Spiral, Curve, and Arc Ratio. There can be 
Back and Ahead Offset values. Transition 
Curves and Spirals can be defined by multiple 
Methods including length, deflection, offset, A-
Value and RL-Value. RL-Value is the radius x 
length and the A-Value is the square root of 
the RL value.

8. Review the Properties of the just-placed 
curve.
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Add Spiral Transitions to a Simple Arc

1. Review the Properties for the arc on the east side of the intersection.

2. Add a 35’ [10m] spiral to the back and ahead transitions of the arc.

a. Expand the Back Transitions section.

b. Change the Type to Spiral.

c. Set the Method to Length.

d. Set the Length to 35’ [10m].

e. Repeat the steps above to define a 35’ [10m] spiral for the Ahead 
transition.
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Exercise 7 - Create a Cul-de-Sac

Description
In this exercise you will learn how to create Cul-de-Sac 
geometry.

Skills Taught
 Place Circle

 Simple Arc Between Elements
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Place the Circle Geometry for the Cul-de-Sac

1. Zoom to the west end of East-West road.

2. Select Geometry > Horizontal > Arcs > Circle.

3. At the Enter Center Point prompt, snap to the west end of the centerline.

4. At the Enter Through Point prompt, type 35 [10] for the Radius and press the Return key to lock the value. 

5. Place a data point anywhere to place the circle.
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Define Transition from Road to Cul-de-Sac

1. Select Geometry > Horizontal > Arc Between Elements > Simple Arc.

The Feature Definition should read “Use Active Feature”. If not, make sure the Use Active Feature Definition toggle is set.

2. At the Locate First Element prompt, click the circle.

3. At the Locate Second Element prompt, click on the north Edge of Pavement.

4. At the Select Construction Sector prompt, prompt, type 20 [7] and press the 
Return key to lock the value.

5. Position the cursor to construct the arc in the correct sector and left click.

6. At the Trim/Extend Option prompt, press the Down Arrow key until Both is 
displayed.

7. Place a data point to place the arc and trim the edges.

8. Repeat the steps above for the southern side of the cul-de-sac.

9. What happens if you move the Centerline?
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Exercise 8 - Create a Driveway Perpendicular to the Centerline

Description
If you are widening or rehabilitating a road and are obligated to tie into existing driveways, how do you build your driveways? There are a 
variety of ways. In this exercise, we’ll build a driveway that is perpendicular to the road.

Skills Taught
 By Angle From Element to create a line perpendicular to another 

element

 Single Offset Entire Element

 Simple Arc

 Reinforcing using snap and geometry construction tools to define 
design intent
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Place the Driveway Centerline

As can be expected, there are several ways to define the driveway centerline. We could use the Place Line between Points with a 
perpendicular snap. We can set the length of the driveway with an offset from the road. We could use Civil AccuDraw to locate the driveway. 
However, we’ll use a tool tailored a little more specifically to our need Line from Element By > Angle from Element. It provides a little more 
control from the centerline element: skew angle and length.

1. Zoom to the midpoint of the curve in East-West road.

2. Set the active Feature Definition to Alignment > Geom_Baseline_Driveway in the Feature Definition Toolbar.

3. Select Geometry > Horizontal > Lines > Line from Element > 
By Angle From Element.

4. At the Locate Element prompt, click on the north EOP of East-
West road.

5. At the Enter Start Point prompt, place a data point near the 
midpoint of the curve in East-West road. Any nearby location is 
okay.

6. At the Enter Skew prompt, press the Left or Right Arrow key 
until Skew is displayed. Type 90 and press the Return key to 
lock the value. Click to accept the value.

7. Press the Left or Right Arrow key again so that Start Distance 
is displayed. Type 0 and press the Return key to lock the 
value. 

8. Place a data point to locate the start point.

9. At the Enter End Distance prompt, type -20 [-6] and press the 
Return key to lock the value.

10. Place a data point to place the line.

11. Confirm the relationships of the line by clicking on it and 
reviewing the heads up display. Move the Line by dragging the 
move point.
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Create the Driveway Edges of Pavement

1. In the Feature Definition pull-down, select Linear > Pavement > Road_EdgeOfPavement.

2. Click Geometry > Horizontal > Offsets and Tapers > Single Offset Entire Element. 

3. At the Locate Element prompt, click on the driveway centerline.

How wide is your driveway? Offset is equal to half this distance.

4. At the Enter Offset prompt, type 6 [2] and press the Return key to lock the value. 

5. Click to accept the value.

6. At the Mirror prompt, press the Down Arrow key until Yes is displayed.

7. Place a data point to place the two offsets.

Connect the ends. It’s a driveway back, so an offset for curves is not necessary.

8. Click Geometry > Horizontal > Lines > Line Between Points. 

9. At the Enter Start Point prompt, snap to the left back endpoint.

10. At the Enter End Point prompt, snap to the right back 
endpoint.
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Add the Curb Returns

1. Click Geometry > Horizontal > Arc Between Elements > Simple Arc.

The Feature Definition should read “Use Active Feature”. If not, make sure the Use Active Feature Definition toggle is set.

2. At the Locate First Element prompt, click a driveway edge.

3. At the Locate Second Element prompt, click on the East-West road edge of pavement.

4. Set the Radius to 5 [1.5] and press the Return key to lock the value.

5. Position the cursor such that the arc is being created in the correct sector and click to place the arc.

We’re going to add curb returns to driveways. We will not trim the road edge of 
pavement. The Trim/Extend prompt options are Both/None/Back/Ahead. Back 
means the first element selected, Ahead means the second. Whenever you are 
trimming only one element, sequence is important. It is a good practice to have a 
consistent pattern to which element you pick first which is the Back element. If 
you always pick the side road first, then you always pick Back to trim only the side 
road. Note that you can always fix the Trim/Extend setting in the Properties 
dialog.

6. Set the Trim/Extend option to Back.

7. Place a data point to place the arc and trim the edge.

8. Repeat the process for the other side of the driveway.

9. Experiment with the driveway. You can change the anchor point, skew angle, length, arc radii, etc. All relationships remain intact.
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Exercise 9 - Create a Driveway Tied to Existing Driveway Centerline

Description
Here we build a new driveway that is perpendicular to the road and tied to an existing driveway centerline.

Skills Taught
 Single Offset Entire Element

 Single Partial Offset

 Create a line perpendicular to another element using snaps

 Intersection Snap

 Perpendicular Snap

 Trim to Intersection

 Simple Arc

 Reinforcing using snap and geometry construction tools to define design 
intent
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Define the Back of the Driveway

This is the location where the new driveway will intersect the existing driveway.

Two common “backs of driveway” are Right-of-Way lines or offsets from the roadway edge or centerline. We will offset the road centerline in 
this exercise.

1. Zoom to the left end of the curve in East-West road.

2. Select Geometry > Horizontal > Offsets and Tapers > Single Offset Partial.

The Feature Definition should read “Use Active Feature”. If not, make sure the Use Active Feature Definition toggle is set.

3. At the Locate Element heads up prompt, click the centerline of East-West road. 

4. Set the Start Offset to 30 [9] and press the Return key to lock the value.

5. Make sure the Distance: Start Distance option is not locked.

You may have to click the End key to unlock the Start position.

6. Once you’re sure both values are correct, place a data point to the left of the 
driveway centerline (dash-dot line). Exact position is not required because we will be 
trimming it to the driveway sides.

7. Make sure that the End Station and the Length are unlocked.

8. Place a data point to the right of the driveway centerline. Exact position is not 
required because we will be trimming it to the driveway sides.

9. Set Mirror to No.

10. Place a data point to place the offset element.
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Place the Driveway Centerline Perpendicular to the Road

1. Set the Feature Definition to Alignment > Geom_Baseline_Driveway in the Feature Definition Toolbar.

2. Click Geometry > Horizontal > Lines > Line Between Points. 

3. Left-click on the Intersection Snap icon to make it active.

A single click on the snap icon makes it active for only one 
snap action and then the active snap reverts to the 
previously active snap.

A double click on the snap icon makes it the new active snap 
and it will stay active until changed.

4. At the Enter Start Point prompt, snap to intersection of the 
existing driveway centerline and the road offset (the 
driveway back line). 

5. Left-click on the Perpendicular Snap icon to make it active.

6. At the Enter End Point prompt, snap to the north edge of pavement.
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Place the Driveway Sides

1. In the Feature Definition pull-down, select Linear > Pavement > Road_EdgeOfPavement.

2. Define edges of the driveway

a. Place the edges of the driveway using the Geometry > Horizontal > Offsets and Tapers > Single Offset Entire Element tool.

 Offset = 6 [2]

 Mirror = Yes

3. Trim the Back Corners

a. Select Drawing > Modify > Trim to Intersection. 

b. At the Identify first element to modify prompt, click the left side of the driveway.

c. At the Identify second element to modify prompt, click the back of the driveway.

d. At the Identify first element to modify prompt, click the right side of the driveway.

e. At the Identify second element to modify prompt, click the back of the driveway.

4. Add Arcs to the Driveway

a. Use the Geometry > Horizontal > Arc Between Elements > 
Simple Arc tool to place 5 [1.5] radius arcs at the ends of the 
driveway. Do NOT trim the road edge of pavement.
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Test the Driveway Geometry

1. Select Set Mark.

2. Confirm the rules by clicking on the elements. Note 
that there is less “flexibility” as the. centerline is 
constrained by the snaps - to the existing driveway 
and the perpendicular requirement. 

There is still a lot of adjustments that can be made. 
The offset of the driveway back can be changed or the 
road itself can be moved and the relationships still 
honored. 

3. Can you change the offset to the back of the 
driveway?

HINT: This is an interval element created when it was 
trimmed to the driveway sides. Select the element and 
then right click to get to the base element!

4. You can also remove the Snaps by dragging the 
appropriate edit handle. Keep in mind that you will 
lose the relationship of the snap. However, snaps can 
also be established by dragging an element handle 
and snapping to a new element.

5. Select Undo to Mark to undo the confirmation 
changes.
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Exercise 10 - Create a Driveway Matching Existing Driveway Sides

Description
Here we build a new driveway, matching the edges of an existing driveway.

Skills Taught
 Single Offset Entire Element

 Single Partial Offset

 Using a Zero Offset as a copy/match tool

 Trim to Intersection

 Simple Arc

 Reinforcing using snap and geometry construction tools to define design 
intent.
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Define the Back of the Driveway

This is the location where the new driveway will intersect the existing driveway.

Instead of defining the back of driveway as an offset from the centerline as we are doing in this exercise, it could also be defined by an existing 
or proposed right of way line.

1. Zoom left of the previous driveway where there are two parallel dash-dot lines that represent the edges of an existing driveway.

2. Define the back of the driveway

 Use the Geometry > Horizontal > Offsets and Tapers > Single Offset Partial tool.

 Define the back of the driveway offset 50’ [15m] from the centerline of the road.

3. Place the sides of the driveway.

 Use the Geometry > Horizontal > Offsets and Tapers > Single Offset Entire Element 
tool.

 Use an offset of 0 to create the new sides of the driveway exactly on top of the existing 
edges of the driveway.

 Repeat for both sides of the driveway
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4. Trim the back corners of the driveway.

 Use the Drawing > Modify > Trim to Intersection tool.

 Trim both corners at the back of the driveway.

5. Add the arcs

 Use the Geometry > Horizontal > Arc Between Elements > Simple Arc tool.

 Add arcs between the driveway and edge of the roadway for both sides of the driveway.

 Use a 5’ [1.5m] radius.

 Only trim the edges of the driveway, not the edge of the roadway.

6. Test the driveway.

 Remember to use Set Mark and Undo!

 What happens if you change the back of driveway offset?

 What happens if you move the road centerline?
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Exercise 11 - Understanding Rules and Relationships

Description
This exercise exercises your ability to change the geometry rules that define design intent relationships.

Skills Taught
 Creating Complex Elements

 Reviewing the Civil Model

 Simplify

 Deactivate Reference Rules

 Deactivate Rules

 Activate Rules

 Remove Rules



Copyright © 2021 Bentley Systems, Incorporated 58DO NOT DISTRIBUTE - Printing for student use is permitted

Creating Complex Elements

At this point we have wonderful, obedient, well-behaved edges of pavement, all defined by 
individual elements. They are as powerful as they need to be, but they have one 
shortcoming: individual elements are not particularly good for data management. Designers 
generally want to work with the length of a road’s edge of pavement, not six little 
subsections.

The Complex By Element tool is used to group individual elements into logical, complex 
(grouped) elements. It’s worth noting that the Complex By Element tool conveys no new 
powers upon the elements, which are as powerful as they can be. Complex By Element 
simply groups them together. 

While horizontal work has benefits by Complexing the Geometry, for Profile work it’s almost 
mandatory.

Profiles benefit dramatically from Complexed Horizontal Geometry. Vertical Geometry 
generally doesn’t “stop” because its horizontal path changed from a tangent to a curve. 

Complex By Element has two Methods: Manual and Automatic. 

 Manual - You click each element in the correct order to add it to the group. Manually selecting which elements to complex together is 
often required on a complex project and projects with intersecting roadways. We will see why in the following exercises.

 Automatic - You click the first element and the software finds the next element and keeps adding elements whose ends are within a 
specified Maximum Gap distance of one another.

Names of the complex elements are important. Rule of Thumb: if it’s important enough to complex, it’s important enough to name. It only takes 
a few seconds.
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Manually Defining Complex Elements

The task is to group the individual edge of pavement elements along the North-South road. 

1. Zoom the drawing so that both the North-South and East-West roads are visible.

We will use the manual Complex by Element method in this exercise. If the automatic method is used, the complex element would include 
all connecting elements (including the intersection curb returns, the East-West road, and the cul-de-sac) shown in purple in the left image 
below. The manual method allows individual element to be selected and grouped. For the North-South road that should be the elements 
shown in green in the right image.



Copyright © 2021 Bentley Systems, Incorporated 60DO NOT DISTRIBUTE - Printing for student use is permitted

2. Select Geometry > Horizontal > Complex Geometry > Complex By Element.

The Feature Definition should read “Use Active Feature”. If not, make sure the Use Active Feature Definition toggle is set.

Note that the resulting Complex Feature will be assigned the Feature Definition specified here, overriding the Feature Definition of the 
individual components, which may be different.

3. Set the Method to Manual.

4. Set the Name to a meaningful name such as: North-South-Rd_LtEoP.

5. At the Locate First Element prompt, click on the curb return on the southwest 
corner of North-South road.

Note: The Manual method assumes that the side of element’s midpoint that you 
pick is the Starting side. Direction is determined from your click. The direction is 
indicated with an arrow.

The tool trusts that you pick the side you intend: it will allow a segment to have a 
direction opposite of an adjacent segment.

6. Make sure that the direction of the selection arrow is pointing toward the north.

7. At the Locate Next Element prompt, click the next pavement edge (the turn lane) 
for the east side of the North-South road. 

Make sure to pick the element to keep the direction pointed toward the north.
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8. At the Locate Next Element prompt, click the next pavement edge (the taper) for 
the east side of the North-South road.

Make sure to pick the element to keep the direction pointed in the proper direction.

9. At the Locate Next Element prompt, click the next pavement edge (the original side 
of the road) for the east side of the North-South road.

10. Make sure to pick the element to keep the direction pointed toward the north.
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11. At the Locate Next Element prompt, click the next pavement edge (the original side 
of the road on the NORTH side of the intersection) for the east side of the North-
South road.

This time we are selecting a non-adjacent element! Complex elements can have 
gaps. This allows all of the edge of pavement to be grouped in a single element 
even though it has a gap at the intersection.

In most modeling situations there would be a match line at the intersection but the 
match line would be an individual element, not part of the edge of pavement.

Make sure to pick the element to keep the direction pointed toward the north.

12. After the last element is selected, at the Locate Next Element prompts, click away 
from any element (click nothing). This ends the Complexing and the complex 
element is created.

13. Select the new complex element and observe the manipulators.

The manipulators are grayed out because they are for a base element that the 
selected complex element is dependent upon. Right-click to activate the base 
element.
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Automatically Defining Complex Elements

1. Select Geometry > Horizontal > Complex Geometry > Complex By Element.

The Feature Definition should read “Use Active Feature”. If not, make sure the Use Active Feature Definition toggle is set and the active 
Feature Definition is set to Road_EdgeOfPavement.

2. Set the Method to Automatic.

3. Set the Name to a meaningful name such as: North-South-Rd_RtEoP.

Any elements whose endpoints are closer than the Maximum Gap distance will be Complexed. If 
there are multiple elements within the Maximum Gap, you will be prompted to select the “branch” 
to connect.

4. At the Locate First Element prompt, click on the curb return on the southeast corner of North-South 
road. 

NOTE: The side of element’s midpoint that you pick is the starting side and adjoining elements will 
be located from the opposite end of the element. Direction is determined from your click. The 
direction is indicated with an arrow.

OpenRoads will link all the elements within the Maximum Gap limits. It will highlight the elements it will complex.

5. At the Accept Complex prompt, left-click to end the complexing and create the complex element.

The four edge of pavement elements on the right side of the road are complexed into a single element.
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Reviewing the Civil Model

1. Open the Home > Primary > Properties dialog.

2. Select the right edge of pavement complex element 
created in the previous exercise.

3. Observe the manipulators.

Notice that some manipulators are shown in gold/yellow 
text indicating they can be edited.

Other manipulators are grayed. These manipulators are 
for base elements that the selected complex element is 
dependent upon. Right click to activate the base element 
and its manipulators become editable.

4. The top section of the properties dialog shows a tree view 
of the elements that make up this complex element. 
Explore this element tree.
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5. Open the Home > Primary > Explorer dialog.

6. Select the OpenRoads Model tab.

7. Expand OpenRoads Model > Linear Geometry. 

This is where the linear geometry features are shown grouped by Feature Definition. The 
Alignment features such as the centerline geometry are in OpenRoads Model > 
Alignments.

8. Expand the Road_EdgeOfPavement header. 

All of the simple and complex features that use the Road_EdgeOfPavement feature are 
listed.

9. Expand the North-South-Rd_RtEoP Complex Element. 

10. Explore the tree structure that defines the ultimate element from all of its dependencies.

Having a basic understanding of this tree structure which illustrates the relationships 
between geometry elements is beneficial.

Notice that there are a number of elements with default naming such as RdEoP19. As 
discussed earlier in the class giving meaningful names to all of these intermediary 
geometry elements may not be practical. However, the more meaningful naming you can 
provide the easier it is to understand the geometry when reviewing in the OpenRoads 
Model and in reports. At a minimum make sure to give your final complex elements 
meaningful names.
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Managing Geometry Rules

We started the class by saying civil geometry is intelligent and contains engineering rules and snaps - the relationships - between elements. 
Rules always exist but sometimes our needs change and we need to forget some rule here or there, either temporarily or permanently. In this 
section you will learn how to manage, deactivate and activate civil geometry rules.

1. Zoom to the two crossing lines east of the North-South road.

2. Complete a Line-Arc-Line complex geometry.

a. Set the active Feature Definition to Alignment > Geom_Baseline.

b. Select the Geometry > Horizontal > Arcs > Arc Between Elements > 
Simple Arc tool.

c. Disable the Radius option.

d. Following the prompts, identify the first element, second element, 
and a point that the arc passes through.

e. Use the Geometry > Horizontal > Arcs > Complex Geometry> 
Complex by Element tool to complex the line-arc-line into a single 
complex element.

3. Review the Complex Element

a. Select the line-arc-line element created in the previous step.

b. Review the rules. 

 Observe the direction and length of the tangents are not directly 
editable. These are base elements.

 Observe the end points of the lines. Recall there are two 
tangents that crossed one another.

c. Move one of the end points and observe how the arc maintains the 
pass through point.
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4. Simplify the complex, multi-element geometry

Simplify is a tool that “liberates” a feature from dependency on another 
feature or features. It maintains “smart” Civil rules, but they are free-
standing geometry rules rather then rules that depend on other 
elements. 

A common example is that you may have a ramp with geometry derived 
from two through lanes. Simplifying the ramp allows you to make 
intelligent edits not constrained to the through lanes.

a. Select the Geometry > Common Tools > Simplify Geometry tool.

b. Select the line-arc-line element.

c. Right click (reset) to simplify the element.

d. Set the Maintain Copy of Base Elements option to No.

e. Select the line-arc-line element to review the rules.

 Observe that the original crossing line elements are no longer part of the element. The geometry has been simplified to its most 
basic form. There are two tangents with a common point of intersection.

 Move one of the end points and observe that the arc now maintains a fixed radius, not the pass through point. Again, the geometry 
has been simplified to its most basic form.

5. Define edge of pavements

a. Set the active Feature Definition to Linear > Pavement > 
Road_EdgeOfPavement.

b. Use the Geometry > Horizontal > Offsets and Taper > Single Offset 
Entire Element tool to define edges of pavement 20’ [6m] on both 
sides of the centerline.

c. Select one of the end point of the centerline and verify that the 
edges of pavement move with the centerline.
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6. Deactivate Reference Rules so that an edge of pavement does not update when the element it depends on changes.

a. Select Geometry > General Tools > Civil Toggles > Deactivate 
Reference Rules.

b. Select the southern edge of pavement.

c. Right click (reset) to deactivate the rules.

d. Select the southern edge of pavement and notice that the offset 
manipulators are grayed out because the reference rules (between 
this element and another reference element) have been disabled.

e. Select the centerline and move one of the end point of the centerline to a new location. Notice that the northern edge of pavement 
follows but the southern does not because its rule to what it references is deactivated.

f. Select Geometry > General Tools > Civil Toggles > Activate Rules.

g. Select the southern edge of pavement.

h. Right click (reset) to activate the rules.

As soon as the rule is activated the relationship is evaluated and the 
geometry heals to once again conform to its rules.
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7. Deactivating the Rules (not Reference Rules) on an element essentially makes it a read only element that cannot be changed.

a. Select Geometry > General Tools > Civil Toggles > Deactivate 
Rules.

Notice the icon is a closed lock. Deactivating the rules locks the 
element so that it cannot be updated.

b. Select the centerline.

c. Right click (reset) to deactivate the rules.

d. Select the centerline. Notice that the radius text manipulator is grayed out and the element cannot be edited. Also, there are no 
manipulators to move the geometry.

e. Select Geometry > General Tools > Civil Toggles > Activate Rules.

Notice the icon is an open lock. Activating the rules unlocks the 
element so that it can be updated.

f. Select the centerline.

g. Right click (reset) to activate the rules.

h. Select the centerline. Notice that the radius manipulator is 
available to edit the element.

8. Rules can also be completely removed from an element.

a. Select Geometry > General Tools > Civil Toggles > Remove Rules.

b. Select the centerline.

c. Right click (reset) to remove the rules.

d. Select the centerline. Notice there are no rules. This is essentially 
a plain cad graphic now. Although it does still have a Feature 
Definition that defines its appearance and includes it in the OpenRoads model.

TIP: Plain graphics can be assigned rules using the Geometry > General Tools > Design Elements > Create Civil Rule Feature tool.
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Skills Assessment

The questions below will test your retention of the skills covered in this course.

1. When placing civil geometry elements rules and relationships are automatically created.

a. True 

b. False

2. When enabled, the Persist Snap command will create snap rules that will be remembered and maintained when elements are modified.

a. True 

b. False

3. Using the civil geometry offset tools allows the edge of pavement geometry to be dependent on the centerline geometry so if the 
centerline geometry changes the edge of pavement geometry automatically updates.

a. True

b. False

4. Civil geometry rules can be de-activated or removed at any time.

a. True

b. False

5. Which tools can be used to trim civil geometry elements (select all that apply).

a. Trim To Intersection

b. Extend Trim to Elements

c. Trim to Element

d. Trim Civil Geometry

e. Trim/Extend option when placing arcs.
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Skills Assessment - Answers

The answers to the skills assessment questions are highlighted below. 

1. When placing civil geometry elements rules and relationships are automatically created.

a. True 

b. False

2. When enabled, the Persist Snap command will create snap rules that will be remembered and maintained when elements are modified.

a. True 

b. False

3. Using the civil geometry offset tools allows the edge of pavement geometry to be dependent on the centerline geometry so if the 
centerline geometry changes the edge of pavement geometry automatically updates.

a. True

b. False

4. Civil geometry rules can be de-activated or removed at any time.

a. True

b. False

5. Which tools can be used to trim civil geometry elements (select all that apply).

a. Trim To Intersection

b. Extend Trim to Elements

c. Trim to Element

d. Trim Civil Geometry

e. Trim/Extend option when placing arcs.
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Summary

In this course you learned how to create edge of pavement geometric elements using the civil geometry tools. You have learned about rules 
and relationships, how to create, review and edit civil geometry elements.
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