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Navigating the Interface
This course is suitable for the 2021 Release 1 version of:

OpenRoads Designer CONNECT Edition
OpenSite Designer CONNECT Edition
OpenRail Designer CONNECT Edition

About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos for

this course are available on the LEARNserver and through CONNECT Advisor.

 This PDF file includes bookmarks providing an overview of the document. Click on a bookmark to quickly jump to any
section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are
specified first and the metric values second with the metric values enclosed in square brackets.
For example: 12.0’ [3.4m].

 This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or
Training-Metric WorkSet delivered with the software.

 The terms “Left-click”, “Click”, “Select” and “Data” are used interchangeably to represent pressing the left mouse
button. The terms “Right-click” and “Reset” are also used interchangeably to represent pressing the right mouse
button. If your mouse buttons are assigned differently, such as for left-handed use, you will need to adjust accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can also 
submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter experts are 
available to help.

Course Level: Fundamental

http://learn.bentley.com
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Course Overview

This course is designed for all users just getting started with the software. You will learn how to open a file, working with the ribbon interface, 
reviewing civil data, setting up views, working with models and analyzing civil data. 

Skills Taught
 Selecting a WorkSpace and WorkSet

 Opening a File

 Understanding the Ribbon Interface

 Setting Up User Preferences - Working Units and Mouse Button Assignments

 Using Element Selection

 Viewing Tooltips

 Selecting a Feature to Review and Edit Geometry

 Adjusting Manipulators and Other Settings

 Using the Civil Context Menu

 On-screen Heads-Up Prompts

 Understanding On-Screen Heads-Up Prompts

 Using Explorer and Properties

 Setting up Views

 Working with 2D and 3D Models

 Defining Profile Models and Cross Section Models

 View Controls

 Viewing Display Styles

 Analyzing Civil Data



Exercise 1: Getting Started with the Interface

Description
In this exercise, you will learn how to start the software and review the interface.

Skills Taught
 Starting the Software

 Selecting a WorkSpace and WorkSet

 Opening a Design File (.DGN)

 Reviewing the Ribbon and Workflows

 Customizing the Ribbon

 Searching the Ribbon

 Quick Access Toolbar

 BackStage and Help

 Design File Settings - Working Units

 User Settings - Mouse Button Assignments
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Start the Software

In this section, you will learn how to start the software and open a file.

1. Start the software.

2. Set the WorkSpace and WorkSet.

The WorkSpace and WorkSet define standards that are used by the software, and the ones used for this training are installed during the 
software installation. 

Typically, the WorkSpace contains organizational standards and the WorkSet contains project standards.

a. Select Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial from the WorkSet drop-down menu.

3. Open a Design File. 

a. Select Browse.

b. Browse to C:\Bentley Training\Navigating the Interface or other folder 
where you unzipped the dataset files. 

c. Select the file named Geometry.dgn and click Open.

Note: If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to OpenSite Designer. 
Clicking Yes will align the file to the software you are using (OpenRoads Designer or OpenRail Designer). This will have zero impact 
for training. Note that in production, upgrading the file will make the file read-only in OpenSite Designer. Full information is available at 
Bentley Communities - Product Realignment.

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
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d. After the file is open, the interface and design file should look similar to that shown below.

 This dataset models a small highway project and this file contains the 
projects geometric elements. All of the other civil data you see displayed 
is referenced from other project related files (Terrain Models, Corridors, 
etc).

 Projects generally federate and reference data by type, segment, and/or 
phase. This results in a full data-rich experience while maintaining easy 
manageability. 
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Review the Ribbon and Workflows

The main section of the interface is the Ribbon toolbar located at the top of the screen. The Ribbon toolbar is your primary access to tools. 
In this section, you will learn how to review and use the Ribbon.

1. Review the Ribbon.

a. Review each area of the Ribbon by selecting each tab.

 The Ribbon functions in a similar manner to the Ribbon found in MicroSoft Office Products. Tools can be accessed by a variety of 
Ribbons and are arranged by Workflows, which are selected from a pull-down in the upper left corner of the software.

 The Ribbon tools displayed are dependent on the Workflow selected. For example selecting the OpenRoads Modeling Workflow will 
present a new set of tools.

2. Change the Workflow.

a. Select the OpenRoads Modeling Workflow* from the pick list in the upper left corner if it is not 
already active. *[Select OpenSite Modeling or OpenRail Modeling if you are using those products]

b. Notice how picking a different Workflow presents a different set of tools on the Ribbon. The ribbon 
menu will now show the corresponding tools that are part of the OpenRoads Modeling Workflow. 
The tools are organized into Ribbon Tabs and Ribbon Groups.
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Note: Your Ribbon may vary from the image depending which version of software you have installed.

Each Workflow groups similar tools under Ribbon Tabs. They will vary a bit, depending on software used - OpenSite, OpenRoads or OpenRail 
Designer. Some tools, such as Element Selection, are on all the tabs. Common Tabs include:

 Home - Common tools such as Attributes, Explorer, Attach Reference Tools, Models, Level Display and Element Selection.

 Terrain - Terrain Creation, Editing, and Analysis tools.

 Geometry - Horizontal and Vertical Geometry Review, Creation, and Management tools, including Standards and Civil AccuDraw.

 Site Layout - Tools for the Integrated Automated Site Optimization platform.

 Corridors - Template, Corridor, and Superelevation and Reviewing and Modeling tools.

 Drawing Production - Saved views, notes, text, annotations, and plans production (cross section, plan, and profile) tools.

 Model Detailing - Civil Cells, Linear and Surface Templates, and other 3D tools.

 Drawing - Commonly used MicroStation drawing tools. A more complete set of MicroStation tools are available in the Drawing, 
Modeling (3D only) or Visualization (3D only) workflows.

 View - Commonly used view control tools.

3. Click on each of the Ribbon Tabs and notice how each tab has a different set of tools.

4. Double-click on any of the Ribbon Tabs. Notice the Ribbon tools will minimize and collapse. This is useful for when you need more screen 
space or you don’t want to view all of the Ribbon tools.

 You can also use the carret in the upper right corner to expand and minimize the Ribbon.

5. Uncollapse the Ribbon and select Home. Use the mouse wheel to navigate between the tabs. This is useful to quickly navigate between 
each Tab.
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Customize the Ribbon

There are many options to customize the ribbon. You can add or remove tools, change the group button size and pin/unpin groups. To 
customize the ribbon simply right click in any area of the ribbon to access the customize menu. In this section, you will review some of the 
customize ribbon options.

1. Review the Ribbon Tab options.

a. Select the Home tab.

b. Right-click on the tab to access the ribbon tab options.

c. Experiment with turning off some of the options and notice how the ribbon tabs change.

2. Review the Ribbon Group options.

a. Select the Primary ribbon group.

b. Right-click to access the ribbon group options.

c. To customize the Ribbon Groups shown in a Ribbon Tab, right click in the empty area of the ribbon.
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Search Ribbon

A Search Ribbon tool is available at the right side of the title bar. To find a tool, type the command in the Search Ribbon field and a search will 
be performed across all ribbon menus. In this section, you will learn how to use the Search Ribbon to find tools and commands.

1. Use the Search Ribbon to find a tool.

a. Key in Arc in the Search Ribbon field.

b. Notice the results of the ribbon search are displayed in a dialog below the Search Ribbon field.

c. Hover over Arc Between Points.

The search results expand, showing where the Arc Between Points tool is located in the 
ribbons: OpenRoads Modeling -> Geometry -> Horizontal -> Arcs. You may have different or 
additional paths.

 If you click on one of these “Breadcrumbs”, the Ribbon will update to the appropriate 
Workflow and Tab.

 If you click on the tool, it opens the tool without changing the Ribbon.

d. In the Search Results dialog, Left-click Arc Between Points to open the tool.

e. Right-click to close the Arc Between Points toolbox.
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Quick Access Toolbar: Save, Save Settings, Undo and More

This section discusses the Quick Access Toolbar options. 

1. Review and explore the tools in the Quick Access Toolbar.

To the right of the Workflow list in the title bar, the Quick Access Toolbar contains common tools like Open File, Save, Save Settings, 
Compress File, Undo, Redo, Print, Explorer and Properties. These tools are always available, independent of the active workflow.

Open is used to open a file.

Save is used to save the file. Design File changes are automatically written to the file on the hard drive or server after every action. You 
generally do not need to manually Save or set a periodic Autosave. This is typically only used when working with other file formats 
such as: .dwg, .dxf, etc.

Save Settings is used to save “non-data” settings, such as view window positions, level display status, and other interface 
customizations (like column order in lists). 

Compress Options are used to adjust settings for compressing a file. Compressing a DGN file reduces its size and clears the undo 
buffer.

Undo will undo a previous action or command.

Redo will redo a previous action or command.

Set Mark allows you to set a milestone to Undo to. When you’re about to try something “experimental”, set a mark, and when you’re 
through “experimenting” you can go to the Quick Access Toolbar and click Undo to Mark. 

Print is used to print the file.

Customize Quick Access ToolBar is used to add or remove tools from the Quick Access Toolbar.



Copyright © 2021 Bentley Systems, Incorporated 11DO NOT DISTRIBUTE - Printing for student use is permitted

BackStage and Help 

In this section, you will learn how to access the BackStage and review the various Help resources.

1. Review the BackStage and Help Contents.

a. Open the BackStage by selecting the File tab. 

 Notice the familiar options on this screen such New, Open, Save, Save Settings, Settings, Help, etc. While some of these “File” tools 
are available from the Quick Access Toolbar, the bulk of the File capabilities are here. 
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b. In the BackStage, select Help.

 These are the available Help Resources.

 If you need to know what version of software you are running, 
click on the About button.

c. Select and review Help Contents.

 Help Contents is a link to live online Help

 The Help Contents button opens the familiar interface of 
Indexed, Searchable and Hyperlinked topics.

d. Close the Help Contents after reviewing.

2. Review Bentley Institute (i.e. LEARNserver).

a. Select Bentley Institute.

 Your browser will open to the Bentley LEARNserver page.

b. Review the LEARNserver.

 While the CONNECT Advisor serves up courses that are 
hosted on the LEARNserver (learn.bentley.com), you are 
encouraged to go the LEARNserver directly. Training can be 
found by Product Type and is organized into Learning Paths.

c. Close the LEARNserver page.

3. Review the OpenSite/OpenRoads/OpenRail Designer Community.

a. Select OpenRoads Designer Community. 

b. Select Wiki, Select OpenRoads | OpenSite Wiki 

 This will take you to the main page where you can see links to training and support topics.

 Bentley Communities provide product and discipline-based wiki’s, forums, and interactive opportunities for solutions. User 
questions are posted and answered in a short time frame. Bentley Colleagues and users provide a broad range of solutions to 
common questions. Videos and white papers are prevalent. Because material can be posted much more quickly than through the 
LEARNserver, it is a great resource for new and experienced users.
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c. Close the Wiki page.

d. Click the arrow in the upper left corner to return to the main interface.

Tip: The <ESC> key can be used to navigate back to the main interface as well.
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Design File Settings - Review Working Units

Working units are derived from the seed file that is chosen when a new file is created. You should always be aware of the proper working units 
for your project. In this section, you will learn how to review the Working Units of the design file.

1. Review Working Units.

a. Access the BackStage by clicking on the File tab.

b. Select Settings > File > Design File Settings

c. Select the Working Units category. This will display the Linear Units and the 
Advanced Settings.

 Observe that Format is set as MU. This displays the Master Unit value 
which is set to US Survey Feet with an accuracy readout of 3 decimal 
places.

 The Labels shown do not affect measurements, but may be used with 
coordinate readout, labeling and dimensioning.

 The Advanced Settings define the real world units of resolution. In this case 
US Survey Foot.

2. Adjust Linear Units accuracy to 4 decimal places.

a. Select the Accuracy pulldown and set the accuracy to 4 decimal places.

b. DO NOT click OK yet.
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User Settings - Button Assignments

User settings allow you to control the operation of the software without affecting other team members settings. One of the more common User 
Settings adjusted are the Button Assignments. In this section, you will learn how to change the Button Assignments.

1. Sometimes it’s necessary to change the functionality of the mouse buttons. The default button mappings were designed assuming you 
have a two button mouse. Some users have a three button mouse so a common change users like to make is to map the middle button to 
function as the tentative snap button (we will talk about snaps later in the course).

2. Review and change the mouse button assignments (If you have a two button mouse disregard the next steps).

a. In the BackStage navigate to Settings > User and select Button Assignments.

b. Select Remap Buttons 

c. In the Button Mappings dialog, select Tentative and then move your cursor to the 
Button Definition Area. 

d. Press the middle mouse button. Now the middle mouse button will be used for 
Tentative functions such as snapping to elements.

e. Click OK to close the Button Mappings dialog.

f. Click Save to save the changes.

g. Click the arrow in the upper left corner to return to the main interface.
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Exercise 2: Using Element Selection to Explore Civil Elements and Features

Description
In this exercise, you will learn how the Element Selection tool can be used to get different types of information from civil data. 

Skills Taught
 Reference File Display

 Element Selection

 Tooltips

 Selecting a Feature to Review and Edit Geometry

 Adjusting Manipulators and Other Settings

 Civil Context Menu

 On-screen Heads-Up Prompts
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Reference File Display

To begin this exercise, lets turn off some reference files to display only the geometric elements stored in this design file.

1. Turn Off Reference files.

a. Click Home > Primary > Attach Tools > References

The References dialog opens. You use this dialog to attach/detach and manage reference files.

b. In the References dialog, select Corridor-SR97.dgn

c. Hold down <Shift> and select Corridor-Bridge.dgn, the other references will be selected.

d. Toggle OFF the display of the selected references by clicking the Display button and then close the References dialog.
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Element Selection

The Element Selection tool is a core tool. It is used to select a single element or multiple elements. In this section, you will learn how to use the 
Element Selection tool.

1. Practice using the Element Selection tool.

a. Select the Element Selection tool and left-click the London Rd. alignment (red north-south graphic) to select it.

 When the element is selected it will highlight in the view.

 Selected element(s) are considered to be a Selection Set.

b. Notice in the status bar the Active Selection Set indicator reflects how many elements are in the selection set (in this case only 1).

The Status Bar features the “prompt” on the left side of the status bar. The text in the prompt lets the user know what the current tool is 
and what to do next. In the example shown, the active tool is Element Selection and the prompt is Identify element to add to set.

c. Set the Element Selection mode to Add, then select the Route 97-Extension alignment (red west-east graphic). This element will be 
added to the selection set.

d. Select the Clear button to de-select the elements.

e. Select the Select All button. All elements in the active model (not in reference files) will be selected and highlight.

f. Select Clear to de-select all elements.

This will reset the Element Selection mode back to the default mode of Individual and New.
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Tips:

 When the Element Selection tool is active, the Tool Settings dialog has options for the selection Method (Individual, Block, Shape, 
Circle and Line) and Mode (New, Add, Subtract, Invert, Clear and Select All). Extended settings can be accessed via the drop arrow to 
select elements by MicroStation attributes like level, color, line style, etc. 

 Multiple elements can be selected by a window selection by dragging the cursor, left-to-right for ‘inside’ the window, right-to-left for 
‘inside and overlapping’ the window. The <Ctrl> key can be pressed to add or remove elements from the selection set.

 Sometimes multiple elements lie within the location area of the cursor. Right-clicking (reset button) will cycle through elements that lie 
in the tolerance circle. 

 Selected element(s) are considered to be a Selection Set. To clear a Selection Set, click in an area where no elements are located (‘in 
space’) or by clicking the Clear mode button in the Tool Settings dialog.
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Tooltips

All civil data (terrain, geometry, corridors, etc.) is stored and managed in the .DGN file. A major component of the civil data is the Feature 
Definition which controls the name and symbology of civil graphical elements. A civil graphical element is known as a Feature, and a primary 
property of the Feature is the Feature Definition. When you hover your cursor over civil data in the .DGN file a tooltip with important 
information about the Feature will be displayed (Feature Type, Feature Name, Feature Definition, Level, etc.). 

In this section, you will learn how to get information from the tooltips.

1. Review 2D and 3D Features using via the tooltips.

a. Click the Element Selection tool. 

b. Make sure the 2D view is active by left-clicking in View 1.

c. Hover your cursor over the London Rd. alignment (red north-south graphic) in the 
active view to see a tooltip.

 Tooltips are pervasive throughout Bentley software. They almost always show the 
object Type and the Level it is on. 

 We can see that this element is a Feature with a name of LondonRd and a 
Feature Definition of Alignment\Geom_Baseline. 

 You can also see that this is a Complex Element on the Level Geom_Centerline.

 You can see that the name of the Active Profile is LondonRd.

 A primary property of horizontal geometry is the Active Profile. A horizontal alignment can have multiple vertical alignments but 
only ONE can be active at a given time.
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Selecting a Feature to Review and Edit Geometry

Selecting (single click on) a Feature displays editable text and element manipulators. It allows you to see geometry values, relationships and 
other properties instantly. Different controls show up depending on the tools used to create the Feature. You can instantly infer the Design 
Intent with which it was created. It is also a very robust editing interface. 

1. Review geometry manipulators, rules and relationships.

a. Continuing with the Element Selection tool, click on the 2D View to make it active.

b. Click on the Ramp B alignment. Notice drag handle arrows, editable text manipulators, snap indicators, etc. are displayed for each 
element clicked.

c. Click on arrows and circles to move, click on text to key in new values. The arrows and circles are known as Drag handles and the 
editable text is known as Text manipulators.

Manipulators are presented as follows: 

Text manipulators - These can be clicked to make them editable, which lets you type in new values. 
Examples of this are the distance and direction text manipulators in the previous image. 

Drag handles - These are handles that you can click and drag to redefine the element. 

 An arrow shaped drag handle - redefines the point with one or more directions constrained. In the 
previous example, the parallel arrows (that are parallel to the line) are constrained to change the 
distance only; the arrows that are perpendicular to the line are constrained to change the direction 
only. 
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 A circular shaped drag handle - moves the points without constraint. 

 Interval drag handle (not shown) - This type of drag handle is present any time one of the MicroStation Modify commands are used on 
a civil element. This drag handle is used to change the location of the interval end point. 

Snap icons - If a point was created by a snap, the manipulator is shown as a circle with the appropriate 
snap icon next to it. 

 Hovering over the end point reveals the drag handles, which can then be used normally as described 
above. Utilizing a revealed handle removes the snap and applies a new constraint to the point. 

Civil AccuDraw constraint - A point that was created with a Civil AccuDraw constraint will show the 
appropriate Civil AccuDraw information in the form of text manipulators. Hovering over the point will 
reveal the drag handles which can then be used normally as described above. Utilizing a revealed 
handle removes the AccuDraw constraint and applies a new constraint to the point. 
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Adjusting Manipulators and other Settings

The manipulators and other design file settings can be edited to suit your preferences in the BackStage. In this section, you will learn how to 
adjust the size and color of the manipulators and also how to adjust the formatting and accuracy of geometry.

1. Change the size and color of the manipulators.

a. Activate the BackStage by clicking File in the ribbon menu.

b. Select Settings > User > Preferences

c. Click on View Options - Civil.

 The Manipulator Settings group is used to adjust how the Heads 
Up Display looks.

d. Change the Manipulator Size to 20.0

e. Change the Normal Color [255,0,255]

f. Change the Manipulator Font to Tahoma.

g. Click OK to save any changes.

h. Click the arrow in the upper left corner to return to the main ribbon 
interface.

i. In View 1, select the Ramp B alignment and notice the manipulator 
sizes, colors and text font have now changed.

Also, note the formatting and accuracy of the geometry values and 
the station formatting and precision.

 The linear geometry formatting and accuracy is defined in 
Design File Settings > Working Units. 

 The angular formatting and accuracy is defined in Design File 
Settings > Angular Readout. 
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 Station formatting and precision is set in Design File Settings > Civil Formatting.

2. Adjust the formatting and accuracy for linear geometry, angular readout and station formatting.

a. Navigate to the BackStage view.

b. Select Settings > File > Design File Settings to access the Design File 
Settings dialog.

c. Select Working Units

d. Set the Accuracy to be 2 decimal places

e. Select Angular Readout

f. Set the Accuracy to 0 decimal places.

g. Select Civil Formatting

h. Set the Station Settings Precision to be 2 decimal places.

i. Click OK to complete.

j. Press <ESC> to return to the main screen.
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k. Select the Ramp B alignment and note how the settings have now changed.

l. Left-click anywhere in empty space to clear the selection.
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Civil Context Menu

The Civil Context Menu is a shortcut menu to other tools that can be used with a selected element. In this section, you will learn how to access 
the Civil Context Menu.

1. Access and review the Civil Context Menu.

a. Click on the 2D View to ensure it is active.

b. Click on the long red east-west road named Route97-Extension so that it 
is selected.

c. Leave the cursor on (or move the cursor back to) the selected feature. A 
semi-transparent Civil Context Menu appears.

Tip: If the cursor is on a manipulator, it thinks you want to use the 
manipulator rather than use the Civil Context Menu. You will need to hover over the feature in an area free of controls and 
manipulators. Zooming in closer may help.

d. Move the cursor into the Civil Context Menu. It will lose its transparency; you will be able select a tool.

 Tools available depend on the Feature Type.

 Note that all tools shown in the Civil Context Menus are available from a Ribbon location as well.

e. Click Properties tool.

A “temporary dialog” with some editable fields. 

f. Move the cursor onto the dialog to keep it visible and review the Properties.

g. Change the Feature Name to Route97.

 Note any field that is gray cannot be edited or changed.
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On-Screen Heads-Up Prompts

All civil tools display on-screen heads-up prompts, which accept the inputs needed to create each element or object. Dynamic feedback is 
displayed while you are creating elements. It is another way of providing useful information while maintaining focus on the work. In this 
section, we will explore some of the on-screen prompts when creating elements.

1. Review on-screen heads-up prompts.

a. Select Geometry > Horizontal > Lines > Line Between Points

b. In the toolbox settings dialog set the Feature Definition to Alignment > 
Geom_Baseline.

c. The Name field is automatically populated with the default name GeomBL.

d. Follow the on-screen heads-up prompts attached to your cursor:

 Enter Start Point: Left-click anywhere in View 1.

 End Point: Distance: Key in 500 and press <Enter> to lock the value.

 Use the left or right arrow key to navigate to the Direction field.

 Key in N75:00:00:E and press <Enter> to lock the value.

 Left-click to complete the command.

As you can see information can be entered directly from the on-screen heads-up prompts attached to your cursor. You will also notice 
the toolbox settings dialog will appear when you choose a tool or command. You have the option of using the toolbox settings dialog or 
the heads-up on-screen prompts to enter values.

Important information when working with on-screen prompts:

 <Enter> or <Tab> is used to lock values. <End> is used to unlock values.

 The left and right arrows are used to navigate to other fields in the command. 

 <ESC> can be used to exit out of a tool or command completely. Right Click or Reset can be used to cancel a command.

 Left-click is used to advance to the next on-screen prompt in most tools. 
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Exercise 3: Element Properties and Explorer

Description
In this exercise, you will learn how to review the properties of elements and how to use Explorer to review civil data stored in the design file.

Skills Taught
 Navigating the Explorer’s interface

 Opening and Reviewing Properties

 Reviewing some Features properties



Copyright © 2021 Bentley Systems, Incorporated 29DO NOT DISTRIBUTE - Printing for student use is permitted

Opening and Reviewing Properties

The Properties tool is used to get detailed information about an element. Properties work similarly to manipulators in that they display the 
design intent and rule data as well as other detailed information. Most data in the property pane can be edited to change the element 
definition. In most Workflows, the Properties tool is available in the Home tab and Primary group. In this section, you will learn how to use the 
Properties tool to review an element’s properties.

1. Open and dock the Properties dialog.

a. Click on Home > Primary > Properties.

b. To dock the dialog, drag it by the title bar to a “docking glyph ”.

 New and experienced users want fast access to it. Experienced users generally have it docked, but collapsed. This way, the dialog 
is never more than a mouse movement and a single click away.
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c. Once you find a setting that you like, you can save by clicking the Save Settings tool.

2. Review the properties of an element.

a. Click the Element Selection tool.

b. Click on the Route 97 alignment. Review the Properties dialog.

 The dialog has a top panel that contains an object tree view - an expandable hierarchy that 
shows the parent, children, and dependencies of the graphic.

 Clicking on an element in the top panel will highlight it in the drawing if applicable. Right 
clicking objects provide context menu items.

 The bottom panel contains the element properties, grouped by Expandable and Collapsible 
Groups.

 Gray text is read-only. Other text may be editable or have a pull-down for item selection.

3. Expert Tip: Try using the spacebar to activate the popup shortcut menu. You can get directly to 
the Properties tool via the Primary button.

a. Press <Spacebar>, a popup menu will appear.

b. Select the Primary button, from here you can select Properties.

4. Close the Properties panel.
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Open the Explorer

The Explorer is an essential tool when working with the software. The Explorer dialog allows you to manage and control project content. It is a 
single interface that provides browsing function for Items, OpenRoads Model, Sheet Index, OpenRoads Standards, Drainage and Utilities 
Model and Survey. One of the key tools in Explorer is the OpenRoads Model which is used to manage and organize civil project data that is 
stored in the design. In this section, you will learn how to open Explorer and review the layout.

1. Open the Explorer and review the tools.

a. From the ribbon menu click Home > Primary > Explorer. 

b. Expand and review each group by pressing the panel’s down arrow.

 The Groups may be organized by Panel or by Tab:

 If you want to change its looks or behavior, go to File > Settings > User and click Explorer 
Settings 

 File - Displays data related to dgn file such as Display styles, element template, text styles, 
levels, models and so on.

 Items - Displays non-graphical business data in a DGN file in hierarchical order. 

 OpenRoads Model - Displays civil objects stored in the design file, objects such as 
Alignments, Terrain Models, Corridors, and so on.

 Sheet Index - Allows you to manage sheet indexing. A sheet index is an organizes and 
named collection of sheet models from one or more design files. 

 OpenRoads Standards - Used to create, edit or review horizontal and vertical geometry 
design standards, feature information, civil cells, annotation, and graphical filters. 

 Drainage and Utilities Model - Displays all the drainage and utilities data stored in the design file.

 Survey - Displays all survey data that is stored in the design file.
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Explore the OpenRoads Model

The OpenRoads Model group displays civil content in categories such as Alignments, Terrain Models, Corridors, and so on. Expanding each 
category lists items within that category or further sub-categories. It is usually a good idea to have the OpenRoads Model open so that you 
can clearly see the civil data stored in the design file. In this section, you will learn how to review Alignments using the OpenRoads Model.

1. Review the Alignments via Explorer.

a. Click the small arrow next to Alignments to expand the list to the Alignment Feature 
Definitions used in the Active Design file.

b. Click the small arrow next to Geom_Baseline to the expand the list.

 Clicking on a Feature will highlight it in the View. Select Complex Element: LondonRd, 
observe that the London Rd. alignment is selected and highlighted in View 1 (or any 2D 
model). 

This is an example of how Explorer can be used to locate and select an alignment in the 
design file.

Notice the bottom portion of the OpenRoads Model panel shows the other civil data that is 
referenced into this design file.
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2. Accessing tools via the right-click menu.

a. Right-click on Complex Element: London Rd. to review other tools related to the alignment. Different object types offer different tools.

b. Click Zoom to or Zoom. Both center the alignment in the active 2D View.

c. Experiment with using the Isolate tool to isolate the London Rd. alignment. Notice how isolate turns everything off except the isolated 
alignment. Select Clear Isolate when done. Left-click in the view to de-select the alignment.
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Exercise 4: Navigating Multiple Views and Models

Description
Design Files often have multiple views and models in one file. In this exercise, you will explore the multi-model 2D/3D design file foundation.

Skills Taught
 Reviewing the 2D and 3D Models and Views

 Views and View Groups

 Defining Profile Model View and Cross Section Model Views

 2D & 3D View Controls

 Profile Model & Cross Section Model View Controls

 Viewing Display Styles

 Analyzing Civil Data
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Models and Views Overview

The software often requires multiple models and views in one file. Understanding how to work with models and views is an essential skill for 
anyone working with the software. If you are opening up a file with civil data in it, expect to see multiple models and views. Multiple models are 
used to create and manage horizontal, vertical, 3D and cross section data:

 2D Model is used for Horizontal Geometry. 

 Profile Model is used for Vertical Geometry.

 3D Model is used for 3D Geometry, Corridors, Survey Data and Terrain Models. 

 Cross Section Model is used for Cross Sections.
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To begin this exercise, turn ON all the reference files so that you can see all the civil data for the project.

1. Turn ON Reference files.

a. Click Home > Primary > Attach Tools > References

The References dialog opens. You use this dialog to attach/detach and manage reference files.

b. In the References dialog, select Corridor-SR97.dgn 

c. Hold down <Shift> and select Corridor-Bridge.dgn, the other references will be selected.

d. Toggle ON the display of the selected references by clicking the Display button.

e. Close the References dialog.
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Review the Models and Views

Most Design Files contain a 2D and 3D Model, often named Default and Default-3D. 2D Elements such are horizontal geometry are created, 
stored and managed in a 2D Model. 3D Elements are created, managed and stored in the default 3D Model. In this section, you will learn how 
to review the 2D and 3D models.

1. Open the Models dialog.

a. Click OpenRoads Modeling > Home > Primary > Models.

 This file has a 2D Model named Default and a 3D Model named Default-
3D. 

 There is always one Active Model. It is indicated by the green highlight.

b. Leave the dialog open.

2. Review Models and Views.

a. Right-click in View 1 and hold down the right mouse button. A menu will 
appear with commonly used commands as well as special view controls. 

b. Click on the 2 Views Plan/3D item.

 View 1 and View 2 will appear tiled (side by side).

 View 1 is the Default 2D model view and View 2 is the Default-3D model 
view.

c. Select the Fit View tool and click in each view to fit the view.
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d. Click on each of the Title Bars of the open Views to make them active. 

 The Model dialog will reflect the Active Model, updating as each view is clicked. 

 Note the View Title Bar lists the view number, the name of the model it is viewing and the model 2D or 3D status via an icon for 
2D  or 3D .

 The applications main title bar lists the name of the file and the Active Model 2D or 3D status in this format: Filename [2D/3D - 
(generation)]. 

 When clicking a view and making it active, its model becomes the Active Model. The main title bar is consistent with this.
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e. Review the contents of each view. View 1 is the Default 2D model view and the other is View 2 Default 3D model view.

 The Active View Title Bar is darker than inactive views. 

 The View Number (1 through 8) and the Model’s Name.

Note: If the views in your file differ from what is described here, turn on 
additional Views. Remember that you may have to point them to the 
appropriate Model via View Attributes > View Setup > Model
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Views and View Groups

The software supports up to eight simultaneous view windows. The View Controls and behavior will differ depending on the model type, but 
any view can view any model. In this section, you will learn how to work with multiple views.

1. Working with multiple views.

 The current file should have multiple Views open. It is important to know which of the open views is the active view.

 Views can be opened or closed from the View Toggles from the Manage View Groups toolbar. In the Training and Examples 
WorkSpace, it is docked in the lower left corner.

 The OpenRoads Modeling Workflow View tab also has the same View Toggles available.

a. Click on any of the 8 View Toggles.

 Notice that Views Open or Close at your touch. They will open in different positions and may or may not show any graphics.

b. Close all the Views except for Views 1 and 2.

 Any of eight available Views can view any model in the .DGN file. Each view is independently customizable in representation and 
perspective. Views can have different attributes enabled and levels can be turned on and off independently from other views. 
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2. Review Model views using the View Groups

 View Groups allow managing multiple views with their varied models and settings. At the left side of the status bar on the bottom, a 
pull-down lists the pre-defined Models. Multi-Model Views is generally the default view group most useful for civil design projects: both 
2D and 3D models will be shown with this setting.

a. From the View Groups list, select the Default view group.

b. Select the Default-3D Views

c. Select the Multi-Model Views to return to the 2D and 3D model view setup.
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Profile Models and Cross Section Models

So far, we have discussed 2D and 3D models. Now lets take a look at Profile Models and Cross Section Models. Profile Models are used to 
display and create profile data and Cross Section Models are used to display Dynamic Cross Sections. In this section, you will learn how to 
define a Profile Model view and a Cross Section Model view.

1. Set up Model views for Plan, Profile, Cross Section and 3D Model.

a. Right-click in View 1 and hold down the right mouse button.

b. Click on the 4 Views Plan/Profile/XS/3D item.

c. Follow the on-screen prompts:

 Select OK to create a Dynamic Profile View.

 Locate Plan Element: In View 1, select the London Rd. alignment (red north-south graphic).

 Select or Open View: Click in View 5

 Select OK to create Dynamic Cross Sections

 Select Corridor or Alignment: In View 1, select the London Rd. alignment (red north-south 
graphic). 

 Follow the heads-up prompts, key in the values shown below and press <Enter> to lock the 
value, left-click to accept to move to the next prompt.

 Select or Open View: Click in View 7. Press <ESC> to exit the command.
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Notice we have 2 new model views that appear: A Profile Model view and a Cross Section Model view. Profile Models and Cross 
Section models are special models only to view profiles and cross sections. 

A Profile Model is used to create, edit and view vertical geometry. The Profile Model View has some unique characteristics:

 A Profile Model corresponds to one and only one horizontal alignment.

 A Profile Model can display multiple profiles but only one can be active at any given time.

 Associated horizontal geometry name is in the title bar of the view.

 Elevation labels on left edge of the view and Station labels along bottom of the view.

 This is a true profile space whose coordinates are station, elevation instead of X,Y.

 The background colors indicate curvature of the horizontal alignment.

 Normal background = straight

 Cyan background = curve

 Magenta background = spiral

 When using the vertical commands the cursor gives simultaneous feedback of location both in plan and profile.
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A Cross Section Model is used to display the dynamic cross section views. The dynamic cross sections are “live” references taken 
directly from the 3D model. 

The Cross Section Model view has some unique characteristics:

 Associated horizontal geometry or corridor name is in the title bar of the view.

 Elevation labels on left edge of the view and Offset labels along bottom of the view.

 Cross section station navigator tool at the top of the view window.

 This is a true cross section space whose coordinates are station, offset and elevation.
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View Controls

In this section, you will learn how to use the view controls to zoom, pan, and fit views.

Views, by default, have a View Control toolbar located at the top of each view window.

The exact tool layout varies by the type of Model that the View is displaying: 2D, 3D, Profile, Cross Section, etc.

The images shown above are the 2D, 3D, Profile and Cross Section view controls.

 Hovering over an icon will display its name.

 Note that view tools remain active until you right-click to exit them or until you click another tool.

1. Practice using Zoom In and Zoom Out in the 2D and 3D Views.

a. Left-click in the 2D or 3D View.

b. Select the Zoom In button to zoom in.

c. Select the Zoom Out button to out.

d. Select Fit View.

e. Click in the 2D or 3D View to set the focal point.

f. Use the mouse wheel to Zoom In and Zoom out of the view.

2. Practice using the Pan tool.

a. In 2D or 3D, select the Pan tool.

b. Left-press, pan to the left, right, up and down.

c. Fit the view when done.
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View Controls - Profile Model and Cross Section Model

Profile and Cross Section Model views have additional view controls such as Horizontal and Vertical Exaggeration. Horizontal and Vertical 
Exaggeration is often desirable when viewing vertical geometry and cross sections.

1. Review and change the default Profile Model Exaggeration. 

a. In the Profile Model view, select the View Attributes.

b. Navigate to Civil > Exaggeration. Notice the default vertical 
exaggeration is set to 10.

c. From the drop-down list. Set the Exaggeration to 20.

This option exaggerates the view vertically by a factor of 20. 

Horizontal exaggeration and vertical exaggeration can be achieved 
using the mouse wheel.

2. Let’s take a look at how to change horizontal and vertical exaggeration using the mouse wheel.

a. Click in the Profile Model view.

b. Position your cursor somewhere in the middle of the view to set the focal point.

c. Use your mouse wheel to zoom in and out. Note this functions the same as it does in the 2D and 3D views.

d. Press <Ctrl> and use the mouse wheel to adjust the horizontal exaggeration.

e. Press <Shift> and hold then use the mouse wheel to adjust the vertical exaggeration.

The cross section view controls function in a similar manner as the profile view controls.
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3. Review and change the Cross Section Model Exaggeration. 

a. In the Cross Section Model view, select the View Attributes.

b. Navigate to Civil > Exaggeration tab. Notice the default 
exaggeration is set to 1.

c. From the drop-down list. Set the Exaggeration to 2.

4. Horizontal and Vertical Exaggeration can also be set using the mouse 
wheel. Let’s take a look at how to change horizontal and vertical 
exaggeration.

a. Click in the Cross Section view.

b. Position your cursor somewhere in the middle of the view to set 
the focal point.

c. Use your mouse wheel to zoom in and zoom out. Note this 
functions the same as it does in the 2D and 3D views.

d. Press <Ctrl> and use the mouse wheel to adjust the horizontal 
exaggeration.

e. Press <Shift> and use the mouse wheel to adjust the vertical exaggeration.

5. Review the Cross Section View Properties.

a. Select the View Properties drop-down list.

 Cross Section View Properties feature additional options 
for viewing the cross sections as you navigate the cross 
sections. Here you will see options to:

 Fit Section - Fits the full width of the cross section into 
view.

 Center Backbone - Centers the view around the cross 
section backbone.

 Center on Current Offsets - Centers and holds the 
current view.
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6. Navigate Cross Sections by Station

a. Using the cross section navigator buttons at the top of the view 
select the First Station button. This will move the current cross 
section station to the first cross section. 

b. Use the Next Station button to advance the cross sections to 
station 53+00.00.

Notice as you advance from station to station the cross section 
view is slightly zoomed out to fit the full width of the cross section.

This is an example of the View Properties being set to Fit Section. 

7. Sometimes it’s necessary to zoom into a specific focal point on the 
cross sections and navigate the cross sections zoomed and centered 
around this point. Let’s take a look at how to accomplish this.

a. Set the cross section View Properties to Center on Current Offsets.

b. Place your cursor near the top of the cross section pavement at the zero offset.

c. Using your mouse wheel, Zoom In so until the side slopes fit within the view window.

d. Use the Next Station and Previous Station buttons to navigate through the cross sections. Notice the cross sections will remain 
zoomed and centered around the focal point.

8. Now lets learn how to navigate to a single station at 72+25.

a. Select the drop-down arrow next to the station, a key-in window will appear. Type in 72+25 and press <Enter>. 

b. The cross section view will now advance to station 72+25.

9. Expert Tip: Right-click in the cross section view to access other useful cross section tools such as Place 
Horizontal Temporary Dimensions, Place Vertical Temporary Dimensions and Locate Station By Datapoint.
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Rotating 3D Views

This section will explore the View Rotation tool. It behaves differently depending on whether the view is looking at a 2D or 3D model. 

1. Rotate the 3D View to Top View.

a. In the View 2 (3D View) View Control toolbar, left-press (a long left-
click) on the View Rotation tool and select Top View from the list. 

 The view will now be rotated to Top View.

2. Rotate the 3D View to Isometric View.

a. In the View 2 (3D View) View Control toolbar, left-press (a long left-
click) on the View Rotation tool and select Isometric from the list. 

 The view will now be rotated to Isometric View.

Views can be rotated dynamically by using the Rotate View tool with 
the Dynamic method tool setting.

3. Rotate the View Dynamically.

a. In View 2, left-press on the View Rotation tool and select Rotate 
View

b. In the Tool Settings dialog, ensure the method is set to Dynamic. 

c. Rotate View 2 by clicking the left mouse button and moving the 
cursor. Click when rotated to your liking. 

Note: You can click to initiate the rotation or click-drag to rotate 
dynamically. You can Snap to an object to make it the center of 
rotation.

d. Reset (Right-click) to end the command.
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4. Rotate View 1 in 2D.

a. In the View Control toolbox click View Previous to return to previous rotations.

 For 2D rotation, there are fewer options: Dynamic, 2 Points or Unrotated. 

a. In View 1, click the View Rotation tool.

b. Experiment with rotating this view.

c. When done, use the Unrotated Method to return to a 
normal “North Up” rotation.

d. From the Quick Access Toolbar select Save Settings.

 The next time the file is opened the views will be arranged as they were when a Save Settings was last applied.
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View Display Styles 

Display Styles allow you to provide instant rendering of that data from wireframe to photorealistic Display Styles. Below shows the 3D model 
displayed 3 different ways (Upper left is Wireframe, lower left is Transparent, upper right is Smooth). In this section, you will learn how to 
change the 3D model display using Display Styles.
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The data in a view can be displayed in many ways: from linework-only (Wireframe) 
to photorealistic rendering (Smooth).

You can change the Display Style to predefined modes via the view toolbar.

Note: Display Styles are generally used more in 3D Models.

Illustration > Ignore Lighting is very useful. It provides a realistic look without having 
to adjust lighting. It still shows linework, which allows visual evaluation of 
engineering. For example, the lines shown at corridor template drops allow you to 
immediately confirm template spacing.

Other realistic Display Styles, such as Smooth and Transparent rely on the View’s 
Lighting value. You’ll likely want to brighten the view by moving the slider to the 
right.

1. Experiment with changing different Display Styles (Wireframe, Transparent, 
Illustration).

a. In the 3D View, left-press on the Display Style List and pick Wireframe.

b. Review the other Display Styles: Smooth and Transparent.

c. Adjust the lighting if necessary using Adjust View Brightness tool.

d. Set the 3D Model Display Style Illustration > Ignore Lighting
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Analyzing Civil Data

Knowing how to analyze civil data and information is an important skill needed for designing and reviewing projects. In this section, you will 
learn how to review coordinates and how to get station/offset/elevation information from civil elements.

1. Review Coordinates 2D.

a. In the lower right section of the Status Bar, right-click the Show/
Hide tools area.

b. Toggle ON the Running Coordinates. Notice the XY 
coordinates now appear in the lower right section of the Status 
Bar.

c. Click in View 1 and move your cursor around.

d. Review the Running Coordinates in the status bar.

e. Snap to the beginning point of the London Rd. alignment.

(Snap is performed by pressing the middle mouse button). 

f. Review the XY coordinates.

2. Review Coordinates in 3D.

a. Click in View 3, Default-3D and move your cursor around.

b. Review the Running Coordinates in the Status Bar.

c. Snap to the beginning point of the London Rd. alignment feature in the 3D Model.

d. Review the XYZ coordinates.
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3. Review Offsets and Elevations in Cross Section View.

a. Click in the Cross Section View and move the cursor around. Notice how the running coordinates display offset and elevation in the 
Status Bar.

b. Using the station navigation tools at the top of the view window, navigate to station 50+00.00.

c. Snap to the centerline point (zero offset) and review the offset/elevation.

d. Snap to other points on the cross section and review the offset and elevation information.
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4. Use the Analyze Point tool to get station/offset/elevation information.

a. Select Home > Model Analysis and Reporting > Civil Analysis > Analyze Point

b. Locate Element to Analyze Point: Select the London Rd. alignment.

c. Move your cursor along the horizontal alignment and note the station/offset/elevation information is being displayed dynamically as 
you move your cursor.

d. Click in View 5 Profile Model and move your cursor along the profile. Note the station/elevation values and the vertical tracking bar in 
the profile view. Also, note that as you are tracking along the profile a crosshair graphic moves along the relative location in View 1.

 As you can see this tool is useful for getting station/offset/elevation information from civil elements.

5. Use Analyze Point to get information at a specific point along the alignment. 

a. Zoom to the intersection of Church Rd. and London Rd.

b. Continuing with the Analyze Point tool. 

c. Snap to the end point of the Church Rd. alignment. (Snap is 
performed by pressing the middle mouse button). 

 Note the Station, Offset and Z on Snap (this is the active 
profile elevation).

 Note the vertical tracking locater in the profile model 
view.

 Note the status bar mirrors the civil information from the 
cursor prompt.

d. Right-click to remove the snap.

Congratulations! You have now completed this course.
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Skills Assessment

The questions below will test your retention of the skills covered in this course.

1. A design file can contain multiple models and views.

a. True 

b. False

2. The WorkSpace and the WorkSet define the standards and configurations used by the software.

a. True 

b. False

3. The Element Selection tool can be used to not only select civil elements but it can also be used to access tool tips, the civil context menu 
and geometry text manipulators and drag handles

a. True 

b. False

4. The OpenRoads Model is used to manage and browse civil data stored in the design file.

a. True 

b. False

5. The Cross Section Model displays a "live" references slice from the 3D model.

a. True 

b. False

6. Profile Models and Cross Section Models Views can be exaggerated horizontally and vertically

a. True 

b. False
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7. Display Styles can be used to change the presentation of the 3D Model view.

a. True 

b. False
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Skills Assessment - Answers

The answers to the skills assessment questions are highlighted below. 

1. A design file can contain multiple models and views.

a. True 

b. False

2. The WorkSpace and the WorkSet define the standards and configurations used by the software.

a. True 

b. False

3. The Element Selection tool can be used to not only select civil elements but it can also be used to access tool tips, the civil context menu 
and geometry text manipulators and drag handles

a. True 

b. False

4. The OpenRoads Model is used to manage and browse civil data stored in the design file.

a. True 

b. False

5. The Cross Section Model displays a "live" references slice from the 3D model.

a. True 

b. False

6. Profile Models and Cross Section Models Views can be exaggerated horizontally and vertically

a. True 

b. False
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7. Display Styles can be used to change the presentation of the 3D Model view.

a. True 

b. False
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Summary

The goal of this course was to get you familiar with working with the interface, how to interact and review civil data and how to view and work 
with models and views. 

Upon completion of this course you have now acquired the following skills:

 Selecting a WorkSpace and WorkSet

 Opening a File

 Understanding the Ribbon Interface

 Setting Up User Preferences - Working Units and Mouse Button Assignments

 Reference File Display

 Using Element Selection

 Viewing Tooltips

 Selecting a Feature to Review and Edit Geometry

 Adjusting Manipulators and Other Settings

 Using the Civil Context Menu

 On-screen Heads-Up Prompts

 Understanding On-Screen Heads-Up Prompts

 Using Explorer and Properties

 Setting up Views

 Working with 2D and 3D Models

 Defining Profile Models and Cross Section Models

 View Controls

 Viewing Display Styles

 Analyzing Civil Data
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