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QuickStart for Corridor Modeling - Road
This course is for the 2021 Release 1 version of:

OpenRoads Designer CONNECT Edition
OpenRail Designer CONNECT Edition

About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos 

for this course are available on the LEARNserver and through CONNECT Advisor.

 This PDF file includes bookmarks providing an overview of the document. Click on a bookmark to quickly jump to 
any section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. 
For example: 12.0’ [3.4m].

 This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or
Training-Metric WorkSet delivered with the software.

 The terms “Left-click”, “Click”, “Select” and “Data” are used interchangeably to represent pressing the left mouse 
button. The terms “Right-click” and “Reset” are also used interchangeably to represent pressing the right mouse 
button. If your mouse buttons are assigned differently, such as for left-handed use, you will need to adjust 
accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can also 
submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter experts are 
available to help.

Course Level: Fundamental

http://learn.bentley.com


Copyright © 2021 Bentley Systems, Incorporated 2DO NOT DISTRIBUTE - Printing for student use is permitted

Corridor Modeling Overview

Corridor Modeling allows the user to create a dynamic, intelligent and powerful 3D model of their design. The 3D model is then 
used to create cross sections, terrain models and generate corridor quantities. A corridor is created first in 2D by assigning a 
horizontal and vertical alignment to the corridor and then assigning a template to the corridor at a defined interval along the 
horizontal alignment. Once the template is assigned to the corridor a 3D model is created. 

A template represents the transverse geometry or typical section along the corridor. Templates are made up of points and 
components and are stored in a template library. When a corridor is processed the template points create 3D linear features 
(edge of pavement, shoulder, curb, sidewalk, cut/fill lines etc.) along the corridor and the template components create the 3D 
material meshes (i.e. pavement, shoulder, curb & gutter, sidewalk, side slope grading etc.) along the corridor.
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Corridor Modeling Workflow:

1. Create a 2D dgn file (all corridor information is stored in a dgn file). 

 Corridors always start in 2D. The 3D model is generated automatically.

2. Attach existing terrain model dgn as a reference file.

3. Attach geometry dgn as a reference (horizontal and vertical geometry are required to create a corridor).

4. Create a corridor.

5. Add a template drop(s) to the corridor.

6. Assign horizontal and vertical controls to adjust template points (as needed).

7. Assign superelevation (as needed).

8. Review the 3D model.

9. Review the dynamic cross sections.
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Course Overview

In this course you will learn how to create a 3D model of London Rd. using the Corridor Modeling tools. London Rd. is a 
simple 2 lane road with paved shoulders. The existing terrain and geometry will be provided as a starting point.
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Exercise 1: Getting Started

Description
In this exercise, you will learn to start the software, select the proper WorkSpace & WorkSet, create a 2D dgn file, attach reference files, set 
the active terrain model and define 2D & 3D Model Views.

Skills Taught
 Start the Software

 Select WorkSpace & WorkSet

 Create a 2D dgn file for the corridor

 Attach Existing Terrain and Geometry Reference Files

 Set Active Terrain Model

 Define 2D & 3D Model Views
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Start the Software and Create the Corridor File

In this section, you will start the software, set the proper workspace and create a new 2D dgn file. When working with 
Corridor Modeling always start in 2D.

1. Start the software.

2. Set the WorkSpace and WorkSet.

The WorkSpace and WorkSet define standards that are used by the software, and the ones used for this training are installed during the 
software installation. 

Typically, the WorkSpace contains organizational standards and the WorkSet contains project standards.

a. Select Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet drop-down 
menu.

3. Create a new 2D file.

a. Select New File.

b. Browse to C:\Bentley Training\QuickStart for Corridor Modeling_Roads or other folder where you unzipped the dataset files.

c. In the File name field, key-in Corridor-London.dgn [Metric-Corridor-LondonRd.dgn].

d. Set the Seed to 2D Imperial Design.dgn [Metric-2D Metric Design.dgn] and click Save.

Note: If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to OpenSite Designer. 
Clicking Yes will align the file to the software you are using (OpenRoads Designer or OpenRail Designer). This will have zero impact for 
the training courses. However, note that in production, upgrading the file will make the file read-only in OpenSite Designer. Full 
information is available at Bentley Communities - Product Realignment.

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
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Attach Reference Files and Define 2D & 3D Views

In this section, you will learn to attach an existing terrain model and a geometry file as reference files. Recall Terrain Models and 
Geometry are stored in dgn files. You will need these files to create a corridor. You will also learn how to Set the Active Terrain Model.

1. Activate the OpenRoads Modeling workflow from the pick list in the upper left corner of the screen.

2. Attach the existing terrain model file

a. From the ribbon menu select Home > Primary > Attach Tools > References

b. Select Attach Reference 

c. Select the file Terrain_Existing.dgn [Metric-Terrain_Existing.dgn]

d. Set Attachment method to Coincident World.

e. Select Open to attach the file.

3. Attach Geometry.dgn [Metric-Geometry.dgn] using the steps described in 2a. through 2e.

4. Click in View 1 to make it active and select Fit View.

5. Select the Element Selection tool from Home > Selection > Element Selection

6. Set the Element Selection tool to individual mode by selecting the individual and new icons.

Notice in View 1 the green shape, this shape represents the terrain model boundary (for the purpose of this course the terrain model 
triangles are undisplayed for clarity). You need to set the terrain model active in order to use it with the corridor. 
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7. Click anywhere on the terrain model green shape. Hover your cursor at this location for a few seconds until the context sensitive menu 
appears.

8. Select Set As Active Terrain Model.

Note: Setting the Terrain Model active will automatically create a 3D Model if one does not already exist in the active design file.

9. Set up the 2D and 3D Views 

a. Press F9

 Notice the view windows will now have a 2D View and a 3D View. Even though this is a 2D dgn file, you have the ability to have 2D 
Models and 3D Models in the active dgn file. 

 View 1 is the Default 2D model and View 2 is the Default-3D model (created automatically when you set the terrain model active). 

 This view setup is typically desirable when working with corridors. Any time there is 3D information associated with elements, it will 
be displayed in the Default-3D model.

TIP: Always pay attention to which model is the active model.

b. Alternatively, you can Right-click in View 1 and hold down the right mouse button to access special view control tools. 

c. Select View Control > 2 Views Plan/3D
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Exercise 2: Create Corridor

Description
In this exercise, you will create a corridor for London Rd. and assign template drops to the corridor. You will also learn 
how to view the corridor in 2D & 3D and view the corridor cross sections.

Skills Taught
 Create a Corridor

 Open the Template Library

 Create a Template Drop

 Review the Corridor in 2D & 3D

 Create Dynamic Cross Sections
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Create a Corridor for London Rd.

In this section, you will create a corridor along London Rd. This road is a 2 lane rural road with 12’ lanes and 8’ 
shoulders.

1. Click anywhere in View 1 to make it active.

2. From the ribbon menu select Corridors > Create > New Corridor

a. Select the London Rd. centerline geometry

b. Set the Feature Definition to Final in the Create Corridor dialog

Feature Definitions for Corridors, control the accuracy and display settings of the Corridor. In 
this course you are going to use Final but other Feature Definitions are available. See 
Appendix A for more information on Corridor Feature Definition properties.

c. In the Name field key in: LondonRd (The name may already be present from when you 
selected the centerline geometry, if so skip this).

d. Right click to accept the active profile.

e. Left click to accept and create the corridor.

Once the Corridor is created the Create Template Drop tool will appear automatically and 
the heads-up display will be prompting you to select a template. The Create Template Drop 
tool is used to assign a template(s) to the corridor at a defined interval along the roadway 
alignment. 

3. Add a template drop to the corridor
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a. Following the heads up prompts, press ALT and the Down Arrow on your keyboard to browse the templates in the template library. 

b. The Pick Template window will appear.

c. In the Pick Template window, click the + to expand the template library folders.

d. Select Templates and click the + to expand the folder.



Copyright © 2021 Bentley Systems, Incorporated 12DO NOT DISTRIBUTE - Printing for student use is permitted

e. Expand the folders to Rural > Concrete Pavt w/Concrete Shoulders > Undivided > 2 Lanes

f. Select the 2 Lanes template.

g. Click OK and Left click to accept.

h. Following the heads up prompts (after each prompt, Left click to accept values and move to next prompt):

 Start Station: Press ALT to lock to Start

 End Station: 80+22 [6+196]

 Drop Interval: 10 [3]

The template drop has been assigned and the corridor is now created.
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Notice there are now corridor elements drawn in the 2D and 3D views. The Corridor Object is created in the 2D view and the Corridor 
Model is created in the 3D view.
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There are 2 essential parts to a corridor, the Corridor Object and the Corridor Model. 

The Corridor Object is a 2D closed shape with perpendicular handles along its edge making it easy to identify and select. This shape 
stores all of the data entered when the corridor is created. The shape is stored in the 2D model named Default and is a Construction 
Class element so its display can temporarily be turned off when desired.

The Corridor Model is made up of 3D elements and components that are automatically created in a 3D model named Default-3D when 
the corridor is processed. The 3D model is automatically referenced to the 2D model but the 3D reference display can be turned on or off 
as needed. Also, the Default-3D model should never be created or edited manually or the corridor will not function properly. Always let 
the software create and manage the 3D Model.

The Corridor Object is always created in the Default 2D model (View 1) and the Corridor Model is created automatically in the Default-
3D model (View 2). 

4. Turn off the display of the 3D model reference in the 2D view.

a. Select the References tool (Home > Primary > Attach Tools > References)

b. Select the Corridor-LondonRd.dgn [Metric-Corridor-LondonRd] Notice the Default-3D name in the model column.

c. Click the Display Reference icon at the bottom of the window to turn off the file.

d. Close the References window.
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Review the Corridor in 2D view

In View 1 notice there is a 2D closed shape that is drawn along the 
corridor, this is the Corridor Object. The Corridor Object has properties 
of the corridor assigned to it that can be adjusted as needed.

1. Review Corridor Properties.

a. Select the Element Selection tool.

b. To access the corridor properties, select the Corridor Object or 
Corridor Handle.

c. Hover your cursor over the corridor object or one of the corridor 
handles for a few seconds. A context sensitive toolbar will 
appear, giving you access to other corridor tools.

d. Select the Corridor Properties icon on the toolbar to review the 
properties of the corridor.

Note that the Use Active Profile is set to True. This means the 
corridor will use the active profile associated to the horizontal 
alignment. If you need to use a different profile other than the 
active profile, set the Use Active Profile to False and select the 
desired profile next to the Profile Name field.
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Notice in View 1, the closed dashed shape drawn along the corridor. This shape represents the Template Drop along the corridor. It has 
the properties of the template drop assigned to it that you can adjust as needed.

2. Review Template Drop Properties.

a. To access the Template Drop Properties, select the Template Drop.

b. Hover your cursor over the boundary for a few seconds. A context sensitive toolbar will appear, giving you access to other template 
tools.

c. Select the Template Properties icon on the toolbar to review the properties of the template drop.

If you need to make changes to the template drop, the adjustments can simply be made in the dialog. 
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In addition to the Corridor Object and Template Drop displayed in 2D you will see additional linear features (edge of pavement, edge of 
shoulder, ditch lines, etc.) that were created as part of the corridor creation process. These linear features are created automatically in 2D and 
3D views.
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Review the 3D Corridor Model

The corridor modeling process builds the 3D Model of the corridor by default. Generally, you will be working in the Default 2D model 
most of the time. In this section you learn how to review the 3D model view.

1. Click anywhere in View 2 Default 3-D to make it active.

2. Select the Fit View 

3. Select the Zoom In tool at the top of the view window to zoom in closer to the 3D Model.

4. Select the View Rotation tool at the top of the view window.

5. Left click and hold the left mouse button to begin view rotation. Slowly move your mouse up and down or side to side to rotate the view.

6. Release the left mouse button and Right click to reset.

7. Use the wheel mouse button to zoom in and zoom out to review the 3D model.
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Dynamic Cross Sections

In this section, you will learn to view cross sections using the Dynamic Cross Sections tool. Cross sections are created 
directly from the 3D Model and can be viewed with the Dynamic Cross Sections tool. The interval of the cross sections 
is based on the template drop interval and any critical sections defined in the corridor feature definition. Dynamic Cross 
Sections are always created perpendicular to the alignment that is being used with the Corridor.

1. Select the Element Selection tool.

2. From the ribbon menu select Corridors > Review > Dynamic Sections > Open Cross Section View tool.

3. In View 1, Locate and select the LondonRd Corridor

4. Open View 7 by selecting the view 7 button from the bottom of the screen. View 7 window will appear.
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5. Click in View 7, a cross section should now appear.

Note that Dynamic Cross Sections are displayed in specially defined cross section model views. Any view can be defined to display the 
dynamic cross sections. 

6. In the upper left portion of the window select the down arrow next to View Properties.

7. Set the Vertical Exaggeration to 5.

8. Navigate through the cross sections by pressing the single right arrow to move to the next cross section.

9. Add a template drop to the corridor
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10. Experiment with navigating the cross sections forward and backward using the left and right arrows. Also, notice in plan view that a light 
blue line is displayed showing the current location the cross section is being displayed at.
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Exercise 3: Modify the Corridor

Description
In this exercise, you will learn how to modify the corridor and review the modifications.

Skills Taught
 Create Parametric Constraints

 Corridor Objects

 Create Point Controls
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Create Parametric Constraint

In this section, you will learn how to use the Create Parametric Constraints tool to override template point constraint 
values. The Create Parametric Constraints tool gives users the ability to vary pavement thickness, ditch widths, slopes, 
etc. between any station range along a corridor. In this section, you are going to adjust the pavement base depth using 
the Create Parametric Constraints tool.

1. From the ribbon menu select, Corridors > Edit > Edits > Create Parametric Constraint

The following dialog box will appear.

Notice the field called Constraint Label, this is where you pick the parametric constraints you want to modify or adjust. In this exercise you 
will be adjusting the pavement base depth (Pavt 2 Depth). The constraint labels are created and assigned in the actual template that is 
currently assigned to the corridor. Each Constraint Label has a default value and by utilizing the Create Parametric Constraint tool you 
can easily modify or override the default values over a station range without having to create a new template or make modifications to the 
template. 

2. Modify the pavement base depth (Pavt 2 Depth)

a. Follow the heads up prompts (after each prompt, Left click to accept values and move to next prompt):

 Locate Corridor: Select the corridor 

 Start: Press ALT to lock to start

 End: Press ALT to lock to end
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 In the Create Parametric Constraints dialog, press the down arrow to display the list of available Constraint Labels that you can 
adjust and select Pavt 2 Depth

Notice the default value for Pavt 2 Depth is currently set to -0.500 [-0.15]. You are now going to change it to -1.0 [-0.30].

 Start Value: -1.0 [-0.30]

 Stop Value: -1.0 [-0.30]

3. Review the cross sections and the corridor to ensure the changes have been applied.

a. Observe on the cross sections you now have green boxes that appear along the bottom of the cross section. The green boxes indicate 
the locations where the pavement base depth was adjusted.
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b. Select the Corridors > Edit > Corridor Objects tool. This tool lets you review and modify overrides that have been applied to the 
corridor.

c. When prompted to Locate Corridor, Select the Corridor. The Corridor Objects window will appear.

d. Select Parametric Constraint on the left side of the dialog. In the middle of the dialog notice the constraint label (Pavt 2 Depth) is listed 
with start and stop values and also the start and end stations. If at any time you need to modify the values you can do it here. To 
change a value all you have to do is click in one of the fields and enter a new value

e. Close the Corridor Objects dialog box.
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Create Point Control

Point Controls can be assigned to corridors to force the cross section template points to follow other information than what is set in the 
template. Point controls override the default location of template points. In this section you will create point controls for the edge of shoulder 
points: EOS_L and EOS_R. By default, the shoulder width is 8’ wide, you will use the Create Point Control tool to taper the shoulder from a 4’ 
[1.2 m] to 8’ [2.4 m].

1. In View 1, Zoom In to the beginning of the corridor, notice the edge of shoulder geometric elements drawn in the geometry file.
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2. Create a point control for point EOS_R, to follow the right edge of shoulder geometric element.

a. From the ribbon menu select Corridors > Edit > Edits 
> Create Point Control

b. Follow the heads up prompts (after each prompt, Left 
click to accept values and move to next prompt):

 Corridor: Select the corridor

 Start Station: 50+00 [5+000]

 End Station: 51+00 [5+030]

 Control Description: Right EOS Control

 Point: EOS_R (select the EOS_R element in View 
1)

 TIP: You can also select the EOS_R point by 
picking it on the cross section.

 Mode: Horizontal

 Control Type: Linear Geometry

 Locate Plan or Profile Element: Select the right 
edge of shoulder element (orange line).

 Use as Secondary Alignment: Yes

 Priority: 1

 Start Offset: 0

 Stop Offset: 0
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Review the point control in cross section view and plan view.

3. Review the cross sections and notice that a magenta box appears at the EOS_R point. The magenta box indicates that there is a point 
control assigned to this point. Any time you create a point control a magenta box will appear on the cross sections indicating that there is 
a point control assigned to that point.

4. Review the plan view and notice that the EOS_R linear feature now follows the right edge of shoulder geometric element.
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Review the Point Control with the Corridor Objects tool.

5. Select the Corridors > Edit > Corridor Objects tool.

6. Select the Corridor. The Corridor Objects window will now appear.

7. Select Point Control on the left side of the dialog. In the middle and right side of the dialog, the point control information is listed. If at any 
time you need to modify the point control you can do it here.

8. Close the Corridor Objects dialog box.

9. Repeat step 2, to create the point control for the left edge of shoulder point EOS_L. Be sure to select the left edge of shoulder geometric 
element named LT_EOS to control the EOS_L point. 
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Exercise 4: Create Superelevation

Description
In this exercise, you will learn how to create superelevation for London Rd. using the superelevation tools. Superelevation is the rotation of 
the pavement on the approach to and through a horizontal curve. Superelevation tools compute how the road will transition from normal cross 
slope to a fully superelevated section and back again.

Skills Taught
 Create superelevation sections and lanes

 Calculate superelevation transitions

 Create superelevation report

 Create and review the superelevation diagram
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Superelevation Workflow

The general workflow for superelevation is listed below:

1. Create 2D dgn file where the superelevation will be stored. (The superelevation data can be in its own 2D dgn file, or it can be created in 
the geometry or corridor dgn files).

 Best Practice is to store superelevation in a separate dgn file.

2. Attach horizontal geometry reference file (Horizontal geometry is required to create superelevation).

3. Create the superelevation section(s). 

4. Define the superelevation lanes. 

5. Calculate superelevation transitions and cross slopes. 

6. Review and edit as needed.

7. Assign superelevation to a corridor. 
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Create Superelevation Sections and Lanes

In this section, you will learn how to create the superelevation sections and lanes. You’ll also learn how to calculate 
superelevation transitions for London Rd.

1. Open Superelevation-LondonRd.dgn [Metric-Superelevation-LondonRd.dgn], the geometry file is already attached as reference file. You 
need the geometry file in order to create superelevation.

2. From the ribbon menu select Corridors > Superelevation > Create > Create Superelevation Sections tool.

c. Set the Feature Definition to Superelevation and key-in SE in the Name field.

3. Follow the heads up prompts (key in the values listed below and Left click to accept and move to the next prompt):

a. Name: Section 1

b. Locate Corridor or Alignment: Select the London Rd. horizontal alignment.

c. Start Station: Press ALT to Lock To Start

d. End Station: Press ALT to Lock To End

e. Minimum Tangent Length: 10000 [3000]

The Minimum Tangent Length value is the determining factor on how superelevation sections are defined between curves along an 
alignment. Setting the value to 0.0 will typically create multiple superelevation sections for each curve along the horizontal alignment. 
Setting the minimum tangent length to a very large number will force only one superelevation section to be created along the entire 
length of the alignment.

f. Lane Creation Method: Manual
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4. Create Left Pavement Lane (continue following the heads up prompts).

a. Enter Lane Name: LT Lane

b. Type: Primary

c. Side of Centerline: Left

d. Inside Edge Offset: 0

e. Width: 12 [3.7]

f. Normal Cross Slope: -2.0%

5. Create Right Pavement Lane (continue to follow the heads up prompts).

a. Enter Lane Name: RT Lane

b. Type: Primary

c. Side of Centerline: Right

d. Inside Edge Offset: 0

e. Width: 12 [3.7]

f. Normal Cross Slope: -2.0%

g. Right click or Reset to complete.
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6. Calculate Superelevation (continue to follow the heads up prompts).

a. Select Rules File: Press ALT and the Down Arrow on the keyboard to select AASHTO_2011_imperial.xml 
[AASHTO_2011_metric.xml], browse to c:\Bentley Training\QuickStart for Corridor Modeling-Road or other folder where you unzipped 
the dataset files to locate this file.

In this example the eMax is calculated using the Values in the AASHTO Superelevation Speed Tables for a Design speed of 50 mph 
[80 kph] and emax of 6%.

b. e Selection: 6%

c. L Selection: Speed Table

d. Design Speed: 50 [80]

e. Pivot Method: Crown

f. Open Editor: No

The Superelevation Section and Lanes are now displayed in View 1.
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Upon completion, the superelevation section, lanes and transitions will be 
created along the alignment. 

 The superelevation section is represented by a 2D closed shape 
drawn along the alignment.

 The superelevation lanes are drawn with rainbow-like colors that 
indicate various cross slopes. 

 The superelevation transitions are assigned to the superelevation 
lanes.

7. Review the superelevation section properties.

a. Select the superelevation shape.

b. Hover your cursor over the superelevation section shape until the 
context sensitive menu appears.

c. Select the superelevation properties tool.

d. Review the superelevation properties.
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8. Review the right lane superelevation transitions

a. Select the right superelevation lane. Notice the stations and cross slopes now 
appear. 

b. Right click to de-select. Or Left click anywhere in the view to de-select.

9. Review the left lane superelevation transitions.

a. Select the left superelevation lane. Again, review the stations and cross slope 
information.

b. Right click to de-select. Or Left click anywhere in the view to de-select.

TIP: To edit the station or cross slope, simply click on the station text or cross slope 
text and enter a new value in the edit field. Stationing can also be changed 
dynamically by selecting the wedge shape and dragging it to the desired station.

The wedge shape also serves as a slope indicator showing the direction of the cross 
slope.

The stationing and decimal place settings can be adjusted under File > Settings > 
File > Design File Settings, the Civil Formatting category listing has options for 
controlling display of element handlers. These settings are not unique to 
superelevation; the same settings are used throughout the Civil products.

The superelevation lane fill settings can be adjusted under File > Settings > User > 
Preferences > View Options - Civil, Superelevation Settings listing has options for 
the superelevation fill. 

Like many tools in the software, the Superelevation tools are “rule based”. When 
superelevation sections and lanes are created, rules and relationships are 
established that associate the superelevation sections and lanes to the horizontal 
geometry. If the horizontal geometry were to change, the superelevation sections 
and lanes would change and follow the new geometry.

Since superelevation depends on the horizontal geometry reference file, you should 
never detach the horizontal geometry file. Doing so will break any rules and 
relationship that exist between the horizontal geometry and the superelevation data.
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Create Superelevation Report and Review Transitions

In this section, you will learn to create the superelevation report and review the superelevation transitions.

1. Select the Element Selection tool.

2. From the ribbon menu select Corridors > Superelevation > Superelevation Report

3. Select the superelevation section and Right click to accept it.

4. Review the superelevation information in the report and close the window when finished.

If you need to adjust the Station and Cross Slope format, go to Tools > Format Options.
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Create and Review the Superelevation Diagram

In addition to reviewing superelevation transitions via the superelevation lanes and via the superelevation report, the software also provides 
the ability to view an editable superelevation control line diagram in a superelevation model view. In this section you learn how to create the 
superelevation model view and review the superelevation control lines.

1. Select the superelevation section.

a. Hover your cursor over the superelevation section shape until the context sensitive menu appears.

b. Select the Open SuperElevation Model tool.

c. Open View 8 by selecting the view 8 button from the bottom of the screen. 

View 8 will appear displaying the superelevation control line diagram.
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Once the superelevation model view is open you will notice 2 superelevation control lines displayed in the view window. The control lines 
represent the superelevation transitions for the left and right lanes of the corridor. Each control line is created from the superelevation 
lane information and is “ruled” to each superelevation lane. Thus, changing the superelevation control lines will adjust the superelevation 
lane stations and slopes. Each control line can be graphically edited or reviewed by simply selecting it and editing the station and slope 
values.

2. Select one of the superelevation control lines in View 8. Notice graphical manipulators and dynamic text appear indicating the Stations 
and Slopes of the transitions. The stations and slopes can be edited by simply selecting the values and entering new values.

3. Left click in View 8 to de-select the superelevation control line.

Another thing to note is the shaded bands in the superelevation view window. Each shaded band indicates where a horizontal curve is located 
along the horizontal alignment. Also, the view is dynamic and the view exaggeration can be adjusted via the View Attributes.
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Exercise 5: Assign Superelevation to Corridor and Review Cross Sections

Description
In this exercise, you will learn to assign superelevation to a corridor and review the cross sections to ensure the superelevation has been 
applied correctly to the corridor.

Skills Taught
 Assign superelevation to a corridor

 Review superelevated cross sections



Copyright © 2021 Bentley Systems, Incorporated 41DO NOT DISTRIBUTE - Printing for student use is permitted

Assign Superelevation to Corridor

In order to assign superelevation to a corridor the superelevation needs to be created in the corridor design file or attached as a reference 
file. Since you created the superelevation in a separate dgn file you will now learn how to attach it as a reference file and assign it to the 
corridor.

1. Open Corridor-LondonRd.dgn [Metric-Corridor-LondonRd.dgn]

2. Click in View 1 to make sure it is the active view and Fit the view if necessary.

3. Attach Superelevation.dgn to Corridor.dgn

a. From the ribbon menu select Home > Primary > Attach Tools > References

b. Select Attach Reference 

c. Select the file Superelevation-LondonRd.dgn [Metric-Superelevation-LondonRd.dgn] 

d. Set Attachment method to Coincident World.

e. Select Open to attach the file.
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4. From the ribbon menu select Corridors > Superelevation > 
Calculate > Assign to Corridor

a. Select superelevation section shape and Right click to accept 
it.

b. Select the Corridor.

c. Review the Associate Superelevation window and press OK

This dialog shows the two template points that define each 
superelevation lane and which of those points the lane pivots 
about. 

The template used for this project has the point CL defined as 
the superelevation pivot point and the points EOP_L and EOP_R 
as the points to be superelevated.

d. Right click to complete the process.

Now that the superelevation has been assigned to the corridor, 
the pavement will be superelevated based on the information 
in the superelevation file. 

Also, be aware that when the superelevation file is assigned to 
the corridor it is now “ruled” or associated to the corridor. If the 
superelevation file is updated the corridor will also update.
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Review Superelevation on the Cross Sections

Review the cross sections to make sure the superelevation has been applied correctly.

1. Select the Element Selection tool.

2. From the ribbon menu select Corridors > Review > Dynamic Sections > Open Cross Section View tool.

3. Locate and select the Corridor.

4. Open View 7 by selecting the view 7 button from the bottom of the screen. View 7 window will appear.

5. Click in View 7, a cross section should now appear.

Note, the magenta boxes that appear at the left and right edge of pavement point locations on the cross sections. These boxes indicate a 
superelevation point control has been created and assigned to the corridor.
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Continually pressing the right arrow key at the top of the cross section view window moves to the next cross section station.

6. Press the right arrow to review the cross sections. As you are moving from cross section to cross section notice how the pavement cross 
slope is now being superelevated where necessary. 

7. To review a specific cross section along the corridor, Right Click in the cross section view window. Select Locate Station Via Datapoint 
and follow the heads up prompts:

a. Left click in the plan view or cross section view

b. Station: 54+60 [5+140], Left click to accept. The cross section should now move to station 54+60 [5+140]

Alternatively, selecting the down arrow next to the station field will allow you to enter a specific station to move to.
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As you can see the cross sections are now superelevated but how do you know what the cross slopes are? To display and review the 
cross slopes you will use the Place Horizontal Temporary Dimension Line tool.

8. Label the cross slopes.

a. Left-click in the cross section view and hold down your right mouse button and select Place Horizontal Temporary Dimension.

b. Place dimension on the right side of the cross section:

 Pick the CL point.

 Pick the EOP_R point.

 Pick a height anywhere on the cross section.
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A temporary dimension line will be placed showing the width and slope.

c. Place temporary dimension line on the left side of the cross section:

 Pick CL point.

 Pick EOP_L point.

 Pick a height anywhere on the cross section.

9. Navigate through the cross sections and notice how the slopes change based on the superelevation that has been applied.
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10. Remove the dimensions:

a. Select Corridors > Review > Dynamic Sections > Remove Temporary Dimensions

b. Left-click in the cross section view.

11. Review the Superelevation Point Controls that were assigned to the corridor.

a. Select the Element Selection tool.

b. Left click in View 1

c. Select the Corridors > Edit > Corridor Objects tool.

d. Select the Corridor.

e. Select Point Control on the left side of the dialog. Review the Superelevation Point Control properties. Note that Superelevation Point 
Controls are created and defined as a Vertical point control.

f. Close the Corridor Objects window.
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Appendix A - Corridor Feature Definitions

Corridor Feature Definitions are preset bundles of settings that control how corridors appear in the 3D model. They also control the level of 
detail included in the 3D model. For preliminary work a Corridor Feature Definition that creates a less detailed 3D model is very useful to 
speed up processing. While later in a project a Corridor Feature Definition for final work is used to produce the most accurate 3D model 
necessary for construction.

Corridor Feature Definitions should be defined in a dgnlib and can be reviewed and edited using the OpenRoads Standards tab in the 
OpenRoads Explorer tool. Once a Corridor Feature Definition is used, it is copied to the local file just like other elements such as levels, 
element templates, text styles, and feature definitions.
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Corridor Feature Definitions have four categories of parameters:

Feature Definition

Defines the corridor feature definition name, description and seed name.

Processing & Critical Sections

One of the parameters of a Corridor Feature Definition is the Template Drop Interval Multiplier. The Template Drop Interval is the interval 
specified when the corridor is created that defines the distance between template drops -- the interval at which cross sectional geometry along 
the corridor is modeled. 

The Template Drop Interval Multiplier increases the template drop interval resulting in a less dense model. For example, the Conceptual 
feature definition has a multiplier of 10. So instead of a model being processed every 10’ [3 m], it is modeled every 100’ [30 m] which results 
in faster processing speed.

Another way Corridor Feature Definitions can speed up processing is by omitting Critical Sections such as horizontal curve cardinal points.

Manipulator Settings

The display settings define how the corridor object appears including its color, weight, etc. and the size of the handles that surround it. There 
are also settings for the appearance of the Template Drop and Transition object graphics that appear in the 2D view.

Display Settings

The Display Settings parameters define the type of 3D elements that are created in the 3D model. Options to display/undisplay Top Mesh, 
Bottom Mesh, 3D Linear Features and Components can be found in Display Settings.
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Display Settings Examples
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Skills Assessment

The questions below will test your retention of the skills covered in this course.

1. Corridors should always be created in a 2D dgn?

a. True 

b. False

2. Which tool is used to view the dynamic cross sections?

a. Create Cross Sections 

b. Create Dynamic Cross Sections

c. Define Cross Section Model

d. Open Cross Section View

3. Which tool gives users the ability to vary pavement thickness, ditch widths, slopes, etc. between any station range along a corridor.

a. Create Point Control 

b. Create Parametric Constraint

c. Corridor Objects

4. Templates are stored in an external template library (.itl file).

a. True 

b. False

5. Which tool lets you review and modify overrides that have been applied to the corridor?

a. Corridor Objects

b. Create Point Control

c. Create Parametric Constraint
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d. Open Cross Section View

6. Where is the corridor data stored?

a. In an external file with an .IRD

b. In an external file with an .ITL

c. In the .dgn file

d. OpenRoads Model Explorer
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Skills Assessment - Answers

The answers to the skills assessment questions are highlighted below. 

1. Corridors should always be created in a 2D dgn?

a. True 

b. False

2. Which tool is used to view the dynamic cross sections?

a. Create Cross Sections 

b. Create Dynamic Cross Sections

c. Define Cross Section Model

d. Open Cross Section View

3. Which tool gives users the ability to vary pavement thickness, ditch widths, slopes, etc. between any station range along a corridor.

a. Create Point Control 

b. Create Parametric Constraint

c. Corridor Objects

4. Templates are stored in an external template library (.itl file).

a. True 

b. False

5. Which tool lets you review and modify overrides that have been applied to the corridor?

a. Corridor Objects

b. Create Point Control

c. Create Parametric Constraint
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d. Open Cross Section View

6. Where is the corridor data stored?

a. In an external file with an .IRD

b. In an external file with an .ITL

c. In the .dgn file

d. OpenRoads Model Explorer
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Summary

In this course, you have learned the many tools and techniques to create a roadway corridor model.

You have learned how to:
 Create a 2D dgn file for the corridor

 Attach Existing Terrain and Geometry Reference Files

 Set Active Terrain Model

 Define 2D & 3D Model Views

 Create a Corridor

 Open the Template Library

 Create a Template Drop

 Review the Corridor in 2D & 3D

 Create Dynamic Cross Sections

 Review the Corridor in 3D

 Create Dynamic Cross Sections

 Create Parametric Constraints

 Review Corridor Objects

 Create Point Controls

 Create Superelevation sections and lanes

 Calculate Superelevation transitions

 Create Superelevation report

 Assign Superelevation to a corridor
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