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About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos 

for this course are available on the LEARNserver and through CONNECT Advisor.

 This PDF file includes bookmarks providing an overview of the document. Click on a bookmark to quickly jump to 
any section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. 
For example: 12.0’ [3.4m].

 This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or
Training-Metric WorkSet delivered with the software.

 The terms “Left-click”, “Click”, “Select” and “Data” are used interchangeably to represent pressing the left mouse 
button. The terms “Right-click” and “Reset” are also used interchangeably to represent pressing the right mouse 
button. If your mouse buttons are assigned differently, such as for left-handed use, you will need to adjust 
accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can also 
submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter experts are 
available to help.

Course Level: Fundamental

http://learn.bentley.com
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Course Overview

The goal of this course is to quickly get you started using the OpenRoads Designer Civil 
Geometry tools to create horizontal and vertical geometry elements.

In this course, you are going to be working on a roadway improvement project for a road named 
London Rd. You will be creating the horizontal and vertical alignment for London Rd. using the 
OpenRoads Designer Civil Geometry tools. 

You will learn how to create, edit, annotate and review civil geometry elements using the 
OpenRoads Designer Civil Geometry tools. You will also learn how to attach an existing terrain 
model and aerial imagery as well as define 2D and 3D views.



Civil Geometry Overview

The civil geometry tools are a dynamic, interactive and rules-based approach to geometry. Civil Geometry or geometric rule-based elements 
are created intelligently as the tools are used and elements are constructed. 

Rule-based elements provide Design Intent that builds associations and relationships between civil elements. Object information (how, where, 
and by what method it was created) is stored with the object to insure the original intent is retained and honored in the design. If an element is 
modified, any related elements will recreate themselves based on these stored relationships. 

All geometric data is stored directly in the design file (.DGN) and can be easily edited and reviewed via the drag handles, dynamic dimensions, 
text manipulators, etc.
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Exercise 1: Create a New File and Review the Interface

In this exercise, you will learn how to select a WorkSpace and WorkSet, create a new 2D design file, and review the ribbon interface.

Skills Taught
 Selecting a WorkSpace and WorkSet

 Create a 2D Design File

 Review the Ribbon Interface
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Select the WorkSpace & WorkSet and Create a New 2D Design File

In this section, you will select the training WorkSpace and WorkSet, and create a new 2D design file. Always start in a 2D design file when 
creating and working with geometry.

1. Start the software.

2. Set the WorkSpace and WorkSet.

The WorkSpace and WorkSet define standards that are used by the software, and the ones used for this training are installed during the 
software installation. 

Typically, the WorkSpace contains organizational standards and the WorkSet contains project standards.

a. Select Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet drop-down 
menu.

3. Create a new 2D design file.

a. Select New File.

b. Browse to c:\Bentley Training\QuickStart for Civil Geometry or other folder where you unzipped the dataset files.

c. Set the Seed to Seed2D - Imperial Training.dgn 

d. Create a new file named Geometry.dgn 

NOTE: The .DGN file format is the standard file format used by the OpenRoads Designer software as well as other Bentley products 
such as MicroStation.

If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to OpenSite Designer. Clicking 
Yes will align the file to the software you are using (OpenRoads Designer or OpenRail Designer). This will have zero impact for 
training. Full information is available at Bentley Communities - Product Realignment.

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
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Review the Interface

In this section, you will learn how to work with the OpenRoads Designer interface.

1. Select the OpenRoads Modeling workflow from the pick list in the upper left corner if it is 
not already active. 

The ribbon menu will change to the OpenRoads Modeling tools. The tools are organized 
on ribbon tabs with the tools grouped into categories on each tab.

 Home - Common tools such as Attributes, Explorer, Attach Reference Tools, Models, Level Display and Element Selection.

 Terrain - Element selection and terrain modeling tools.

 Geometry - Element selection, Civil AccuDraw and geometry tools.

 Site - Parking, Parceling, Pad, Pathways, Grading Proposed, Modify and other tools are available.

 Corridors - Element selection, superelevation and corridor modeling tools.

 Model Detailing - Element selection, Civil Cells and 3D tools (Linear Templates, Surface Templates, etc.).

 Drawing Production - Element selection, saved views, notes, text, annotations, and plans production (cross section, plan, and 
profile) tools.

 Drawing - Commonly used MicroStation drawing tools. To access the complete set of MicroStation tools change the active work 
flow to Drawing, Modeling (3D file only) or Visualization (3D file only).

 Utilities - Additional miscellaneous tools such Geographic Coordinate Systems and Item Types.

 Collaborate - Collaboration and Markup tools.

 View - Commonly used view control tools.
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2. Click on each of the ribbon tabs and notice how each tab has a different set of categories and tools.

3. Also note the tools to the right of the workflow drop down list. Tools 
such as Open File, Save Settings Compress File, Undo, Redo, 
Print, Explorer and Properties can be found here.

A Search Ribbon tool is also available to assist with finding tools on 
the ribbon interface. When you are not sure where to find a tool on the ribbon interface simply key in the command in the Search Ribbon 
field and a search will be performed across all ribbon menus.
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4. Search for a tool using the search ribbon. Key in Arc in the Search Ribbon field.

5. Notice the results of the ribbon search are displayed in a dialog below the 
Search Ribbon field.

6. Hover over Arc Between Points.

The search results expand showing where the Arc Between Points tool is 
located on the ribbon: OpenRoads Modeling -> Geometry -> Horizontal -> Arcs

7. From the search results dialog, Left click, Arc Between Points to launch the 
command.

8. Right click to close the Arc Between Points toolbox.
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9. Introduction to the BackStage View.

a. Activate the BackStage View by clicking File in the ribbon menu.

b. Notice the various other options on this screen such New, Open, Save, Save settings, etc. Whenever you need to create a new file you 
will have to access the BackStage View.

c. Click the Arrow in the upper left corner to return to the main ribbon interface.
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Exercise 2: Create the Horizontal Alignment

In this exercise, you will learn how to create a horizontal alignment for London Rd. using the horizontal geometry tools.

Skills Taught
 Attach Aerial Imagery Reference File

 Create Horizontal Geometry Lines

 Create Horizontal Geometry Curves

 Create the Horizontal Alignment

 Define the Start Station

 Annotate the Horizontal Alignment

 Review Geometry with the Explorer Tool

 Create Horizontal Alignment Report
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Attach Reference File

In this section, you will learn how to attach the Aerial_Topo.dgn as a reference file to your design file. The Aerial_Topo.dgn file contains the PI 
locations (point of intersection) that you will use to create the tangent elements of the alignment.

1. Attach Aerial_Topo.dgn as a reference.

a. Click on Home > Primary > Attach Tools and select References.

The References dialog will now appear as shown above. You use this dialog to attach reference files to design files.

b. In the References dialog, Click on Tools and choose Attach.
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c. The Attach Reference dialog will appear, browse to the location of Aerial_Topo.dgn and Left click on it.

d. Change the Attachment Method to Coincident World.

e. Click Open to attach the file as a reference.
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The Aerial_Topo.dgn will now be attached to the active file and displayed in the References 
Dialog.

f. Close the Reference dialog.

g. Click the Fit view icon so you can see all of the graphics in the design file.

h. Locate and review the magenta circles drawn in the Aerial_Topo.dgn. The magenta 
circles represent the PI points that will be used to place tangent lines between.

TIP: The software also provides the ability to display a background map directly from Bing Maps. 
This option can be found under the View Attributes > Background Map panel.
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Create Horizontal Geometry Lines 

In this section, you will be creating the tangent lines for London Rd. (see image below).

1. Set a Feature Definition to be used with your civil geometry elements.

Feature Definitions are used to control symbology, annotation, and various other properties that are 
applied to the geometric elements. The feature definitions are used to:

 Define what the geometric elements actually are. What is being modeled such as curb, 
centerline, edge of pavement, etc.

 Control symbology in various views, including capability to define differing symbology in plan, 
profile, and 3D spaces

 Define terrain modeling attributes (spot, break line, void, etc.)

 Define surface display characteristics

Feature Definitions are defined and stored in a DGN library delivered with the WorkSpace.

a. Open the Feature Definition Toggle Bar tool by going to Geometry > General Tools > Standards > 
Feature Definition Toolbar.

b. Set the active feature to Geom_Baseline by pressing the down arrow.
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c. Click on the Use Active Feature Definition tool on the Feature Definition Toggle Bar to toggle it ON.

 Setting the Active Feature Definition ensures that all geometric elements created will have the selected feature definition assigned 
to them as you create geometric elements.
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2. Create the tangent lines between known PI points (magenta circles). Use the image to the 
right as a guide.

a. From the ribbon menu select Geometry > Horizontal > Lines > Line Between Points

Notice the heads up display attached to your cursor will be prompting you for a start point.

b. Left click on the Center Snap tool. Be sure AccuSnap is enabled as shown below.

c. Snap to the center of PI#1 and Left click to accept. 

Hint: If you have trouble snapping to the center just approximate the center point and 
move on to the next step.

A Note About Snaps and Design Intent:

When you snap to elements, the software remembers how you snapped to elements and 
what type of snap was used. Thus, a relationship exists between the elements. This is an 
example of Design Intent. 

Design Intent builds associations and relationships between civil elements. Object 
information (how, where, and by what method it was created) is stored with the object to 
insure the original intent is retained and honored in the design. This is a very important 
concept to remember as you work with the product.
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The heads up prompt changes and gives you the option to key in the distance and/or direction as needed. Pressing the Right arrow or 
Left arrow on your keyboard will toggle between Distance and Line Direction input fields.

d. Define the Distance, key in 546.00 in the Distance field and press Enter to lock the value.

e. Press the Right Arrow on your keyboard to switch to the Line Direction field.

f. In the Line Direction field, key in: N01:33:00:W, press Enter to lock the value.

g. Left click to accept.

3. Select the Element Selection tool. 

 The Element Selection tool is used to select elements so they can be edited or manipulated with other commands. 

 It can also be used to exit out of a command.
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4. Set the Element Selection tool to the individual mode by selecting the Individual and New icons in the Element Selection tool setting 
window.

a. Select the line you just created. 

Recall, geometric elements are rule-based elements that provide Design Intent. Notice the line has a distance and direction associated 
with it. The distance and direction represent the rules associated to the element.

Also, note the Drag Handles as well as the Text Manipulators (direction/distance) attached to the line. These provide the ability to 
quickly modify the line. If you need to modify the distance and/or direction you can simply click on distance/direction Text Manipulators 
and key in new values in the edit fields. You can use the Drag Handles to trim/extend, rotate or move the line.
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b. Hover your cursor over the beginning point of the line, the Drag Handle arrows will appear as well as the center point snap indicator. 

The Drag Handle arrows give you the ability to dynamically adjust the end point of the line. By selecting the Drag Handle arrows you 
can extend or trim the line and also change the location of the end point.

The center snap indicator shows that the beginning point of the line was placed by snapping to the center of the circle. This is an 
example of Design Intent. A relationship exists between the beginning point of the line and the circle. Be aware, if the circle is moved 
the line will move. If the circle is deleted the relationship will be removed but the line will remain. This is an important concept to 
understand with regards to snaps.

c. Next, Hover your cursor over the line for a few seconds. A context sensitive menu will appear giving you access to other tools related 
to the element. Context sensitive menus appear if you hover your cursor over OpenRoads Designer elements or objects.

d. Select the Properties tool and review the properties of the line.

Note that the line can be edited within the Properties dialog. The Length, Direction, 
Start Point, End Point, Feature Name and Feature Definition can all be modified within 
this dialog if needed.

e. Left click anywhere in the view to de-select the line.
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5. Continue placing tangent lines.

a. Click the Chain Commands tool on the Feature Definition Toggle Bar. When the Chain 
Commands tool is enabled, the next element is automatically connected to the previous 
element without having to select the start point each time.

b. Re-select the Geometry > Horizontal > Lines > Line Between Points tool.

c. Snap to the end point of the first tangent line to place the start point of the second tangent 
line. 

d. Left click to accept.

e. Left click near the center of the circle at PI #3 to complete placing the tangent line between 
PI #2 and PI #3.

f. Left click near the center of the at PI #4 to place the tangent line between PI #3 and PI #4.

g. Left click near the center of the at PI #5 to place the tangent line between PI #4 and PI #5.

h. Right click to complete.

i. From the Feature Definition Toggle Bar, turn OFF the Chain Commands tool.

Your geometric elements should look like the image to the right once you have completed 
placing all tangent lines. 
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Create Horizontal Geometry Curves

In this section, you will learn how to place the horizontal curves that will be used to create the London Rd. alignment.

1. Create horizontal curves between tangent lines using the Simple Arc tool.

a. From the ribbon menu select Geometry > Horizontal > Arcs > Arc Between Elements > Simple 
Arc

b. Following the heads up prompts, locate and select first tangent element (line between PI #1 and 
PI #2).

c. Locate and select second tangent element (line between PI #2 and PI #3).

d. Define the arc Radius as 600, press Enter to lock the value and Left click to accept.

e. Set the Trim/Extend option to Both and Left click to trim both tangent elements.

NOTE: In lieu of using the heads up prompts, you can also key in values in the toolbox dialog but 
you still need to Left click to accept the values entered.
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2. Create remaining curves for PI#3 and PI#4 using the same methods described in steps 1a. 
through 1e. on the previous page. The radius values are given below:

 Curve 2 at PI#3 Radius = 10000 (curve to the right). Take care when placing this curve, 
since it has a very flat radius. It must curve to the right.

 Curve 3 at PI#4 Radius = 2100 (curve to the left)

3. Modify the first horizontal curve radius.

a. Select the Element Selection tool.

b. Select the first horizontal curve, notice the radius is displayed as 600’.

c. Left click the 600’ value, the edit field will appear.

d. Key-in 700 in the edit field and press Enter (or Left click) to change the radius. 

The curve will update with the new radius and the tangent lines adjust automatically to 
maintain their relationship with the curve. This is another example of Design Intent and 
the rules and relationships that exist between civil geometry elements. The software 
remembers that the original curve was placed between the two tangents and when the 
radius value changed the geometry adjusted itself to maintain the geometric 
relationship.
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Create the Horizontal Alignment

Now that you have all of your horizontal geometry created, you need to combine them together into an alignment. You will do this by using the 
Complex By Elements tool.

1. Use Complex By Elements tool to create the horizontal alignment for London Rd.

a. From the ribbon menu select Geometry > Horizontal > Complex Geometry > Complex By Element

b. In the dialog box, set the following parameters:

 Method: Automatic 

 Maximum Gap: 0.033

 Name: LondonRd

c. Following the heads up prompts: 

 Locate First Element: Select the first tangent line (between PI#1 and PI#2) near the beginning.

 Accept Complex: Left click to accept and create the complex profile element.

NOTE: Where you select the element is important. Each element has a midpoint. Notice when selecting 
the element near the start point an arrow appears pointing north, indicating the direction the alignment 
will be created. If you select the element near the end point, the arrow will change direction, pointing 
south and will not create the alignment in the proper direction.
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The completed complexed horizontal alignment should look like the image to the right. 
The alignment is made up of 4 tangents lines and 3 horizontal curves.

d. Hover over the alignment and select it to display the element information and the edit 
handles. Note that the full alignment is highlighted and is a complex element named 
LondonRd.

e. Right click to de-select the alignment.
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Define the Start Station

In this section, you will learn how to define the start station value and assign it to the horizontal alignment.

1. From the ribbon menu select Geometry > Horizontal > Modify > Start Station

2. Following the heads up prompts:

a. Locate Element: Select the London Rd. alignment.

b. Start Distance: 0, press Enter to lock the value and Left click to accept.

c. Start Station: 50+00, Left click to accept.

3. Review the stationing.

a. Click the Element Selection tool.

b. Select the alignment, notice the alignment displays the new beginning station value.

The begin station is dynamic text which can be adjusted by simply selecting the begin station value and keying in a new value. The 
stationing of the alignment will then update.
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Annotate Horizontal Alignment

In this section, you will learn how to annotate the horizontal alignment. 

1. From the ribbon menu select Drawing Production > Drawing Scales > Annotation 
Scale Lock and set the scale to 1”=100’

2. From the ribbon menu select Drawing Production > Annotations > Element 
Annotation > Annotate Element

3. At the prompt Locate Elements - Reset to Complete, select the alignment and then 
Right click to complete.

The alignment is now annotated. The annotation is also dynamic and associated to the 
alignment. Any changes made to the alignment will update the annotation.

The annotation is defined by an Annotation Group which is associated with the Feature 
Definition. The text size is controlled by the Annotation Scale Lock.
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Review Geometry with the Explorer Tool

In this section, you will learn how to review geometry with the Explorer tool. The Explorer tool can be used to browse and manage data in the 
design file. You can also use it to review, search, zoom to and isolate data. All data is organized and displayed in the Explorer tool under the 
OpenRoads Model panel. As the design progresses, the information is automatically created and updated.

1. Review geometric elements in the Explorer window.

a. Select Home > Primary > Explorer to display the Explorer window.

Expand the OpenRoads Model group by pressing the down arrow.

TIP: It is recommended to always have Explorer open when working in the software.
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Geometric elements associated with alignments are grouped under the Alignments category. To see which elements are part of the 
Alignments category simply click on the small arrow next to the category to expand the list.

b. Click the small arrow next to Alignments to expand the list to see next item in the list.

c. Click the small arrow next to Geom_Baseline to the expand the list (recall Geom_Baseline 
was the feature definition you used to create your geometry.

d. Select Complex Element: LondonRd, observe that the London Rd. alignment is highlighted in 
View 1. This is an example of how Explorer can be used to locate and select an alignment in 
the design file.

e. Right click on Complex Element: LondonRd to review other tools related to the alignment. You can Left click on any item in the list to 
gain access to other tools that can be used.



Copyright © 2021 Bentley Systems, Incorporated 29DO NOT DISTRIBUTE - Printing for student use is permitted

f. Click the small arrow next to Complex Element: LondonRd to expand the list to see the geometric elements associated with the 
alignment. Continue to expand the list to see the details and dependencies.
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Create the Horizontal Alignment Report

In this section, you will learn how to create the horizontal alignment report for London Rd.

1. From the OpenRoads panel, Right click on Complex Element: London Rd. to access the Horizontal Geometry Report

2. Select Horizontal Geometry Report
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3. The Bentley Civil Report Browser dialog will appear and the report will be displayed. Review the report.

After reviewing the report you may want to adjust the precision and format of distances, angles, bearings, etc. You can easily adjust the 
report with the Format Options tool.
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4. Go to Tools > Format Options in the Bentley Civil Report Browser.

5. Change the Format Options as follows:

 Angular - Precision: 0

 Angular - Format: ddd^mm’ss.s”

 Slope - Format: 50%

 Station - Precision: 0.12 [0.123]

 Station - Format: ss+ss.ss [s+sss.ss]

 Direction - Precision: 0

 Direction - Format: ddd^mm’ss.s”

6. Close the Format Options window.
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7. Review the report to ensure the formatting has been adjusted.

8. Save the report.

a. In the Bentley Civil Report Browser window, select File > Save As.

 Browse to C:\Bentley Training\QuickStart for Civil Geometry or other folder where you unzipped the dataset files

 File name: Key in LondonRd

 Save as type: choose Doc File (*.doc).

 Click Save, to save the report.

NOTE: You can also print the report by going to File > Print or Right click in the report window and choose Print.
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Exercise 3: Existing Terrain Model and Define 2D & 3D Views

Skills Taught
 Attach Terrain Model

 Set Terrain Model Active

 Review Design File Models

 Define 2D & 3D Views
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Attach Terrain Model

In this section, you will learn to attach a the existing ground terrain model to your design file. Terrain models are stored in 3D design files. Any 
time you need to use a terrain model within your design file, you just need to attach the terrain model as a reference. 

1. Attach Terrain_Existing.dgn as a reference.

a. Click on Home > Primary > Attach Tools > References.

The References dialog will now appear as shown above. You use this dialog to attach reference files to dgn files.

b. From the References dialog, select the Attach Reference icon or 
Tools > Attach...

c. Select the file Terrain_Existing.dgn

d. Set the Attachment Method to Coincident-World.

e. Click Open
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f. The terrain model, Terrain_Existing.dgn is now attached to the file. 

g. Close the References dialog box.

h. Click the Fit View icon in the top of the view window so you can see all of the graphics in the design file.
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Setting the Active Terrain Model

Setting the terrain model active instructs the software to use the active terrain model as the default terrain model when using other 
OpenRoads Designer tools. In this section, you will learn how to set the terrain model active.

1. Click the Element Selection tool

2. Set the Element Selection tool to the individual mode by selecting the Individual and New icons in the Element Selection tool setting 
window.

3. Left click anywhere on the green shape that outlines the terrain model.

4. Hover the cursor at this location for a few seconds and context sensitive toolbar appears displaying tools commonly used with terrain 
models. More terrain model tools can be found on the Terrain ribbon menu.

5. Select the Set As Active Terrain Model tool.

Setting the terrain model active instructs the software to use the active terrain model as the default terrain model when using other 
OpenRoads Designer tools. You can always change or clear the active terrain model at any time.

Also, when setting the Active Terrain Model the software will automatically create a 3D model inside of your 2D design file. The 3D model 
will be used for the display of 3D data.
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Review Design File Models

A single design file can contain multiple models (2D Models and 3D Models). One of the ways to see how many models are in a design file is 
to access the Models dialog. In this section, you will learn how to review the 2D and 3D models using the Models dialog.

1. From the ribbon menu select Home > Primary > Models

2. Review the Models dialog, notice there are 2 models available, Default and Default-3D. 

Models can be 2D or 3D. It’s very important to realize that even though you started with a 2D design file it is possible to have a 3D model 
also available in the same design file. As a rule, civil geometry should be created in a 2D Model and 2D design file and terrain models are 
created and stored in a 3D model.

Recall that setting a terrain model active automatically creates a 3D model for you when working in a 2D file. The 3D model must be 
created by the product. Do not create your own model named Default-3D, it will not work properly.

Also, the 2D and 3D models are directly related to the model views, recall View 1 is named Default and View 2 is named Default-3D.

3. Close the Models dialog.
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Setting Up Views

In this section, you will learn how to define the 2D and 3D model views.

1. Press F9 on your keyboard.

Notice the views change, you now have 2 view windows open. View 1 on the left is the 2D model view that you started with and View 2 on 
the right is the 3D model view. Pressing the F9 key automatically configures this particular view setup for you, 2D on the left and 3D on the 
right. This will come in handy as you move through the design process.

Also, observe the existing terrain model boundary and contours are displayed in 2D and 3D. The terrain model triangles are not displayed 
at this time. Triangles, breaklines, feature spots and contours can be displayed via the terrain model properties as needed.
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2. If pressing F9 does not configure the views, then in View 1 Right click and hold down the right mouse button to access special view 
control tools. 

a. Select View Control > 2 Views Plan/3D.

b. Click the Fit View icon in the top of the view windows so you can see all of the graphics in both views.
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Exercise 4: Creating Vertical Geometry

In this exercise, you will learn how to create the vertical alignment for London Rd. using the vertical geometry tools.

Skills Taught
 Define Profile Model View

 Create Vertical Geometry Lines

 Create Vertical Geometry Curves

 Create the Vertical Alignment

 Create the Vertical Alignment Report
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Define Profile Model View

Vertical geometry elements are displayed and managed in the Profile Model View. Prior to creating vertical geometry elements you must first 
define a Profile Model View to display the vertical geometry into. In this section, you will learn how to define a Profile Model View and display 
the existing ground profile along the London Rd. alignment.

1. Click in View 1 to make it active.

2. Click the Fit View icon in the top of the View 1 window so you can see all of the graphics in the design file.

3. Click the Element Selection tool.

4. Select the horizontal alignment. Hover your cursor over the alignment until the context sensitive menu appears.

5. Select the Open Profile Model icon, the heads up display will prompt you to Select or Open View.

6. Open View 4 by selecting the view 4 button from the views toggle menu at the bottom of the screen. Profiles can be displayed in any view.

7. Click inside of the View 4 window. View 4 is now defined as the profile model view. Only one profile model view can be active at a time.

8. In View 4, click Fit View. You should now see the existing ground profile (green dashed line).
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9. Select the Element Selection tool.

10. Select the existing ground profile line (green dashed line). 

11. Hover your cursor over the existing ground profile line until the context sensitive menu appears.

12. Click the Set As Active Profile icon to set the existing ground line as the active profile. 

Setting the existing ground profile active associates it with the horizontal alignment. It also draws the profile in the 3D model. This will be 
the default profile for now until you design the proposed vertical alignment. The active profile can be changed at any time.

13. In View 4, select View Attributes in the upper left corner of the view window.

14. Set the profile view Exaggeration to be 20.

Notice how the profile view dynamically adjusts itself to reflect the new vertical exaggeration. The vertical exaggeration can be changed at 
any time.

15. Click the Fit View icon again in View 4 to re-center the graphics.
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Create Vertical Geometry Lines

In this section, you will be creating the vertical geometry tangent lines that will be used to create the vertical alignment for London Rd. (see 
image below). The vertical alignment will be made up of 4 tangents and 3 vertical curves. You will first define the tangent lines and then add 
vertical curves in the next section.

1. Prior to placing elements, on the Feature Definition Toggle Bar ensure that 

 Active Feature Definition is still set to Alignment > Geom_Baseline 

 Use Active Feature Definition toggle is On

2. Click the Chain Commands tool on the Feature Definition Toggle Bar. 

 When the Chain Commands tool is enabled the next element is automatically connected to the previous element without having to 
select the start point each time.

3. Select Geometry > General Tools > Civil Toggles > Civil Accudraw to display the Civil AccuDraw toggle bar. 

 Civil AccuDraw is used for precision input with civil geometry and will be used to place profile elements by station 
and elevation.

a. Click the Toggle Civil AccuDraw icon on the toggle bar.

b. Click the Z (elevation) icon on the toggle bar. 
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4. Create first vertical geometry tangent line.

a. From the ribbon menu select Geometry > Vertical > Lines > Profile Line Between Points

a. Move your cursor into View 4, notice the heads up prompts for Station and Z (elevation). These are the Civil AccuDraw input fields.

b. In the Station field key in 50+00 and press Enter. Notice the station value is now locked.

c. In the Z field key in 167.74 and press Enter.

d. Left click to accept.

5. Continue following the heads up prompts to place the end point of the profile tangent line.

a. Key in 57+16.00 in the Station field and press Enter.

b. Key in 172.31 in the Z field and press Enter.

c. Left click to accept. The first tangent line is now placed.

Note the dynamic display showing the slope and length as you place the line. In addition to placing the line by station and elevation 
you can also place it using a length and slope.
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6. Select the Civil AccuDraw tool to turn off Civil AccuDraw. 

We will now place profile tangent elements by length and slope.

7. Follow the heads up prompt to place the next profile tangent #2

a. In the Length field enter 700, press Enter to lock the value.

b. Press the right arrow to toggle to the Slope field and enter -2.0%, press Enter to lock the value.

c. Left click to accept and move to the next prompt.

8. Create the remaining tangent elements (#3 and #4) using the previous step and the image below as a guide. 

 If you are having trouble keying in values, you can approximate the lengths and slopes. 

 If you make a mistake you can use the Undo button to get back to the previous steps.

9. After the last tangent line is placed, Right click to complete.

10. Press the ESC key to exit the command.

11. From the Feature Definition Toggle Bar, turn OFF the Chain Commands tool.
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12. Review the tangent lines.

a. Use the Element Selection tool and Left click on profile tangent line #1 and notice the slope and length are displayed as well as the 
Drag Handles and Text Manipulators. Clicking on the slope, length, station or elevation will enable you to enter new values at any time. 
Adjusting the Drag Handles will trim/extend or move the line.

b. Right click to de-select the line or Left click anywhere in the view.

13. Review the remaining tangent lines using the procedures described in the above step.

14. Adjust the last tangent line so that it ties into the existing ground profile.

a. Zoom in closer to where the last tangent line was placed.

b. Select the tangent line.

c. Grab onto the end point of the line and move the end point to match the existing ground profile at the same horizontal location 
(approximately 85+47.85, elevation 164.470). Let the Key Point Snap snap to the existing ground profile to define the approximate 
elevation to match the existing ground profile.

15. Click the Fit View icon again in View 4 to re-center the graphics.
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Create Vertical Geometry Curves

In this section, you will learn how to create the vertical curves.

1. Define the Vertical Curves.

a. Define a 300’ vertical curve between tangent lines #1 and #2.

b. Select Geometry > Vertical > Curves > Profile Curve Between Elements > Parabola Between Elements

c. Following the heads up prompts, select tangent line #1 and when prompted select tangent line #2.

(Be sure to keep your cursor below the tangent lines to ensure a crest curve will be created).

d. Following the heads up prompts, in the Length field key in 300 and press Enter to lock the value.

e. Left click to accept and move to the next prompt.

f. Set the Trim/Extend option to Both and Left click to complete the command.

A 300’ vertical curve is now placed between tangent lines #1 and #2.
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2. Define a vertical curve with a K value of 171.00 between tangent lines #2 and #3.

The Geometry > Vertical > Curves > Profile Curve Between Elements > Parabola Between Elements tool should still be active, if not, re-
select it.

a. Following the heads up prompts, select tangent line #2 and when prompted select tangent line #3.

b. Following the heads up prompts, press the Left Arrow key to toggle to Vertical Curve Parameter.

c. Key in 171.00 in the Vertical Curve Parameter field and press Enter to lock the value.

d. Left click to accept and move to the next prompt.

e. Set the Trim/Extend option to Both and Left click to complete the command.

A vertical curve with a K value of 171.00 is now placed between tangent lines #2 and #3.
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3. Using the same process described in the previous steps to create a 400’ vertical curve between the remaining tangent lines #3 and #4.

The completed vertical geometry elements should look like the image below.

4. Modify the length of vertical curve #1 to be 400’

a. Select vertical curve #1, notice the curve length 300.000 is displayed as well as the K 
value.

b. Left click on the curve length value (300.000), enter 400 in the edit field and press 
Enter.

The vertical curve updates and displays the new curve length and K value.
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Create the Vertical Alignment

In this section, you will learn how create the vertical alignment for London Rd.

1. Group the London Rd. vertical geometry elements into a single complex element to create the vertical alignment.

a. Select the Geometry > Vertical > Complex Geometry > Complex by Elements tool.

b. In the dialog box, set the following parameters:

 Method: Automatic 

 Maximum Gap: 0.033

 Name: LondonRd

c. Following the heads up prompts, 

 Locate First Element: Select tangent line #1 near the beginning and then Left click to accept it

 Accept Complex: Left click to accept and create the complex profile element

d. Select the vertical (profile) alignment and note that all the elements are now a complex profile.
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2. Set the newly designed profile as the active profile.

a. Select the Element Selection tool.

b. Select the complex profile element and hover your cursor over it until the context sensitive menu appears.

c. Select the Set As Active Profile tool. 

The newly designed vertical alignment will now be the active vertical alignment associated with the horizontal alignment. A relationship 
now exists between the horizontal and vertical geometry. Be aware that deleting the horizontal geometry or dropping the horizontal 
geometry will impact the vertical geometry.

Whenever you set a profile active a 3D feature which represents that profile will automatically be displayed in the 3D Model view.
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Create the Vertical Alignment Report

In this section, you will learn how to create the vertical alignment report.

1. Select the Element Selection tool.

2. Select the complex profile element and hover your cursor over 
it until the context sensitive menu appears.

3. Select the Profile Report tool.

4. Review the Vertical Alignment report and adjust the report formatting as needed using Tools > Format Options from the report dialog 
menu bar.

5. Close the report window. Congratulations, you have now completed the course.
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Skills Assessment

The questions below will test your retention of the skills covered in this course.

1. Geometry should always be created in a 2D dgn?

a. True

b. False

2. What controls the symbology and display of geometric elements?

a. Feature Definitions

b. Element Attributes

c. Level Manager

d. OpenRoads Model Explorer

3. Setting the Active Feature Definition ensures all geometric elements will have the selected feature definition assigned to them as you 
create geometric elements.

a. True

b. False

4. How does the default 3D Model get created?

a. Setting the Active Terrain Model will automatically create the Default-3D Model.

b. When you create vertical geometry elements, it is created automatically.

c. When you create a new 2D dgn a new Default-3D Model will also be created.

5. Curve radii can be changed easily via the text manipultors and edit fields?

a. True

b. False
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6. Where is all of the OpenRoads Designer Geometry data stored?

a. .ALG File

b. .XML File

c. .DGN file

d. OpenRoads Model Explorer

7. Individual geometric elements must be complexed together in order to create an alignment?

a. True

b. False
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Skills Assessment - Answers

The answers to the skills assessment questions are highlighted below. 

1. Geometry should always be created in a 2D dgn?

a. True

b. False

2. What controls the symbology and display of geometric elements?

a. Feature Definitions

b. Element Attributes

c. Level Manager

d. OpenRoads Model Explorer

3. Setting the Active Feature Definition ensures all geometric elements will have the selected feature definition assigned to them as you 
create geometric elements.

a. True

b. False

4. How does the default 3D Model get created?

a. Setting the Active Terrain Model will automatically create the Default-3D Model.

b. When you create vertical geometry elements, it is created automatically.

c. When you create a new 2D dgn a new Default-3D Model will also be created.

5. Curve radii can be changed easily via the text manipultors and edit fields?

a. True

b. False
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6. Where is all of the OpenRoads Designer Geometry data stored?

a. .ALG File

b. .XML File

c. .DGN file

d. OpenRoads Model Explorer

7. Individual geometric elements must be complexed together in order to create an alignment?

a. True

b. False
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Summary

In this course, you have learned how to create a new file, attach an existing terrain model and aerial imagery as well as define 2D and 3D 
views. You have also learned how to create, edit, annotate and review geometric elements, and how to create horizontal and vertical 
alignments for London Rd. using the civil geometry tools.
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