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Using MicroStation with ProjectWise

There are a few changes to how MicroStation operates when used in the ProjectWise 
environment. When MicroStation is integrated with ProjectWise, file operations such as File > 
Save As, File > Open, and a File > New will default to the folder structure on the ProjectWise 
server. Click on the Cancel button in the ProjectWise environment dialog box and the regular 
Windows system dialog box will appear allowing you to use files located on your local or 
network drives.

This chapter will cover the following additional MicroStation features that operate differently 
when integrated with ProjectWise:

♦ Creating a New MicroStation file

♦ Integrated Title Blocks

♦ Attaching Reference Files

♦ Linking Word and Excel files to MicroStation

Creating a New MicroStation File

There are several methods to create a new drawing file, each with their respective advantages 
and disadvantages. The easiest method is illustrated in the video Creating a New 
MicroStation File.

Note: It is a common mistake to try and use the New>Document command from the 
ProjectWise Document pull-down menu. Do not use this method. All this will do is 
create a place holder for a future file and does not actually create a file that can be used 
by MicroStation.

In addition to the method shown in the video, you can also use the File>New command from 
the MicroStation pull down menu. Using this method will require you to:

♦ Choose a seed file

♦ Choose the folder in which to create the new file

♦ Once the file is created, use the Attributes tab in the Properties dialog box to populate 
the attributes for the file

Integrated Title Blocks

Prior to ProjectWise, all the information in the title block of a drawing had to be entered by 
hand. The video Editing Title Block Attributes in ProjectWise illustrates how to update 
much of the title block information automatically using ProjectWise.

In order to use title block integration, you must use special title blocks containing MicroStation 
tags that are linked to ProjectWise attributes. These title blocks are located in the 
\Documents\Seed_Files folder under the following names:

♦ PW-Plan-Sheet.dgn
♦ PW-PnP-Sheet.dgn
♦ PW-Title-Sheet.dgn

By using these seed files, your drawing will be created to be used as shown in the video and the 
title block will be automatically populated with the project data.

http://www.coloradodot.info/business/designsupport/cadd/projectwise%20-training/pw-newmircostationfile
http://www.coloradodot.info/business/designsupport/cadd/projectwise%20-training/pw-newmircostationfile
http://www.coloradodot.info/business/designsupport/cadd/projectwise%20-training/pw-editingtitleblock.wmv
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Reference Files

Attaching Reference Files

Attaching a reference file in MicroStation using ProjectWise is not much different than the 
method you are already used to. However, you will notice a few differences.

To attach a reference file to a drawing using ProjectWise:

1. Open a drawing you wish to attach a reference to.

2. Go to File > Reference or click on the References button to open up the 
References dialog box.

3. From the References dialog box choose Tools > Attach or select the Attach References 

button .

The first difference is that when attaching a reference file the Attach Reference dialog box will 
default to look for files on the ProjectWise server.

4. Browse to the location of the reference file and select the file(s) you wish to attach.

5. Click the Add button to add the file(s) to the list of selected documents at the bottom of the 
dialog box.

6. Click OK in the Attach Reference dialog box.



Colorado Department of Transportation   Page 59

ProjectWise Users’ Guide Using MicroStation with ProjectWise

7. The normal MicroStation reference attachment window will display as shown below to 
allow you to modify the reference attachment settings as desired.
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8. If you click the Cancel button when the Attach Reference dialog box first appears, a 
second dialog box will display allowing you to attach a reference file from a local or 
network drive.

Note: In general, reference files should be attached from a ProjectWise folder. However, 
ProjectWise allows you to attach reference files from ProjectWise and a local or 
network drive to the same master file.

The second difference is how reference files are listed in the References dialog box. Once a 
reference file is attached to a drawing, there are a couple of ways to tell where a file is being 
referenced from. 

9. If a file is being referenced from a ProjectWise folder the information in the File Name 
column will begin with the prefix PW_WORKDIR: followed by the working directory (a 
folder ID that is assigned by ProjectWise) and finally the filename.

10. If a file is being referenced from a folder on a local or network drive the information in the 
File Name column will only consist of the filename.
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An examples of these reference types are shown below.

In addition to how the files are listed in the dialog box, hovering over a file will display the full 
location and path of the file as shown below.

Opening Files with References Attached

When you attempt to open a file that contains references, the Select Reference Documents 
dialog box will display. There are three areas to be aware of in this dialog box.

♦ Read Only toggle - Toggle this option on if you only want read permissions to the 
reference file(s) attached to the file you are accessing. When this option is toggled on, 
Check Out and Copy Out will be disabled.

♦ Check Out/Copy Out - The Check Out option will make the reference file read only to 
other users while the Copy Out option will allow other users write access to the 
reference file

♦ Status - The Status column indicates whether a reference file stored on your local 
machine is up-to-date or needs refreshing

The information shown when hovering over a file attached from the ProjectWise server is the 
location where the reference file is copied to your local machine.

Another benefit of referencing files from within ProjectWise it that ProjectWise keeps track of 
files using a file ID. This functionality allows you to move a reference file from one 
ProjectWise folder to another without loosing the reference file attachment.

Note: This is only valid for reference files attached from a folder on the ProjectWise 
server. If you move a reference file that is located on a local or network drive, that 
reference file will need to be reattached.

Linking Word and Excel Files to MicroStation

Linking a ProjectWise document to a MicroStation drawing allows you to change the document 
and have those changes automatically reflected in the MicroStation drawing. This is a two stage 
process. The first step is to create a logical set of documents called a Document Set. The 
second step is to use the set to link the documents with the MicroStation drawing.
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Creating a Document Set

1. In the ProjectWise Explorer select the folder where the parent drawing is located. This will 
usually be the \Drawings folder of the specialty group.

2. Right-click on the parent drawing file and select Set > New from the right click menu. 
This will display the Create Document Set dialog box.

3. Enter a Name: and Description: for the new document set. Consider using the name of the 
MicroStation file as the Name: of the new document set. This will help with knowing 
which document set is associated with a drawing. Click OK.

The Document Set window will appear with the parent drawing listed in the window.
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4. Next, Drag and drop any Excel or Word documents that will be referenced to the parent 
drawing into the document set window.

Note: Although documents can be added to the Document Set from any folder within the 
active ProjectWise datasource, ideally they would be added from folders within the 
same project.

5. Once all of the desired documents are added to the document set, close the document set 
window. The Document Set will appear in the ProjectWise Explorer window as indicated 
by the  icon. Notice how the document set has a Name but no FileName as shown 
below.

Note: A document set is not a file and therefore cannot exist outside of ProjectWise.

Using the document set, all files associated with the drawing file can be checked in/out as a 
complete set. Using the document set to check in/out files ensures that the correct files are 
being used in the linked document and are available to other team members when changes 
are made to the base files.

Linking Documents to a Drawing File

The following steps illustrate how to link Excel and Word documents to a MicroStation 
drawing file using document sets. Since ProjectWise copies a document to a local folder upon 
checkout and these files are not always deleted when the document is checked in, this method 
of linking provides for the most reliable results when working in a team environment. 

To link an Excel or Word document to a MicroStation file:
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1. Right-click the document set in the ProjectWise Explorer window and select Check 
Out. This copies all the files in the document set to the ProjectWise working folder on your 
computer and locks the files in ProjectWise from being edited by someone else.

2. Double-click on the document set to open the document set window. You will use this 
window to verify the status of documents as you use them in the following steps.

Notice that because the document set was checked out, all associated files are checked out 
as well.

3. Open the MicroStation drawing and any documents that will be linked to the drawing file.

4. Select the data in the document that you want to link to the drawing. This method will work 
for text in a Word document, rows and columns in an Excel spreadsheet, or other data. The 
following example is an Excel document.
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5. Press Ctrl-C to copy the data to the clipboard.

6. Switch over to the MicroStation application.

7. From the MicroStation Edit menu select Paste Special < Linked Microsoft Office 
Excel Worksheet, then click on Paste.

     

8. Set the position and size of the data in the MicroStation drawing.
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9. Repeat the steps 4-8 for any additional documents to be included.

10. When you close either MicroStation or the documents associated application, you will be 
asked to check in the document. Click the Check In button. This will update the server 
copy of the document. 

Note: You may also get the following error message. This message occurs because the 
documents were all checked out as a set and need to be checked in as a set. If this 
error message appears, click the OK button and proceed to the next step.

11. The final step is to check in the document set. Right-click on the document set in the 
ProjectWise Explorer window and select Check In. This will check in all documents 
associated with the document set and update the server copy of those documents.

Looking at the document set window you will notice that since the document set was 
checked in, all associated documents are checked in as well.



Colorado Department of Transportation   Page 67

ProjectWise Users’ Guide Using MicroStation with ProjectWise

Updating Documents Without Checking Them In

Sometimes you will want to keep the file you are working on checked out but would like others 
to see what changes you have made. The Update Server Copy command allows you to save the 
changes you’ve made to the design file to the ProjectWise server without having to check the 
drawing back in.

There are two ways to update the server copy of a file:

1. If you are already in MicroStation, select Update Server Copy from the File menu.

You can verify this when you see the message Document server copy updated successfully 
in the MicroStation message center.

2. The second method is to Right-click on the file in the ProjectWise explorer window and 
select Update Server Copy from the menu.
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Printing from MicroStation

Several workflows have been created to help you with various printing topics. These 
workflows include:

♦ CDOT Workflow MicroStation Printing

♦ CDOT Workflow Print Organizer

♦ CDOT Workflow Printer Driver Adjustments

♦ CDOT Workflow Printing AutoCAD Files in MicroStation

♦ CDOT Workflow Printing Raster Images

These workflows can be found on the CADD/Engineering and ProjectWise website.




