**MicroStation**

*AccuDraw Bearing and Distance Key-in*

**Did you know that** AccuDraw can operate in a polar or rectangular mode. Hitting the spacebar toggles between the two modes. The following shortcuts have been programmed for polar mode input:

Northeast = quadrant #1

Northwest = quadrant #2

Southwest = quadrant #3

Southeast = quadrant #4

**How do you apply this?** The quadrant number replaces the standard input of N45°23'45"E with a Key-in of **1 45°23'45"** and AccuDraw will interpret it as N45°23'45"E

**Wait, it gets better!** Do you hate keying-in the [shift][6] keystroke to get the degree input? Try hitting the semicolon instead.

So now your input can be: **1 45;23'45**

We just went from 12 keystrokes to 9. While this does not seem to be a huge difference, it does make this task 25% more efficient and eliminates cumbersome keystrokes. We know your supervisor will appreciate the productivity boost!

*From Ron Brys with the Envision Group*
Did you know that you can resize the default size of the accudraw compass? The default size of the compass is set to 40. You can make it smaller with the Key-in: accudraw settings size 20. Values can be anything between 6 and 399.
**MicroStation**

*AccuDraw Compass*

**Did you know** that you can quickly rotate the AccuDraw Compass to maintain its conventional drawing plan mode of X-axis horizontal and Y-axis vertical to the view, instead of having the compass rotate with the element being placed. Simply press the letter **V** on the keyboard to rotate the compass to the "view" plane.

The AccuDraw keyboard shortcut **V** will always rotate the compass to the view in which you are placing elements. You can quickly rotate the compass to a particular view by pressing the appropriate keyboard shortcut below:

- **T** - top view
- **F** - front view
- **S** - side view

Most of the time you will be drawing in a top (plan) view, when doing Civil Design. Other handy rotation options are Rotate Quick (keyboard shortcut **R Q**) which temporarily rotates the compass dynamically as you move your cursor or the Rotate ACS (keyboard shortcut **R A**) which permanently rotates the drawing plane by snapping to known points along an element. These rotation options are handy for matching the angle of existing elements when placing cells or text.
Did you know that you can use the Key-In to switch AccuDraw between Northing/Eastings and X/Y? Key-In `accudraw settings northeast` or `accudraw settings xy` to toggle between the two coordinate input values.
Did you know that if you don’t like keying in a colon (:) to separate the feet from inches when using Accudraw you can use a semi-colon (;) or two periods (..) instead!
Did you know that you can also add and remove elements from a selection set by holding down the `Ctrl` key on the keyboard and selecting the items one by one, or by holding down the `Ctrl` and `Shift` keys at the same time, point to the screen, drag the mouse and touch many elements that you want to add or remove from the selection set all at once. (Similar to a Crossing in other CAD packages)
Did you know that there are other sources that are good for MicroStation training. One author in particular who has always been reputable is Frank Conforti. His book is called Inside MicroStation V8. Another book and author is called Harnessing MicroStation by GV Krishnan. Both are available on Amazon.com. Another site is http://shop.prosoftnet.com/ out of Utah. They have several manuals to choose from. Book stores and Libraries around town, may also carry the above referenced books and others for that matter.

As Always...Happy Cadding!
MicroStation

**Aligning an Element's Edge**

Did you know that you can align an element’s edge (the top, bottom, left, or right) to another element’s edge by using the Align Elements by Edge command in the Manipulate Tool Box. This is the best way to line up general notes or data in a table that are not aligned to each other either vertically or horizontally.

Two ways to do this:

1. Pick the Element Selection icon, than pick the element(s) that you want to align. Next, pick the Manipulate tool box icon (copy, move, and scale etc.), open that up, than scroll over and pick on the Align Elements by Edge icon (3 rectangular boxes aligned diagonally). Choose the edge (the top, bottom, left, or right) how you want your selected element(s) to line up with the element you want to align too. Then, pick the element you want to align too, and accept it (left mouse key). Your selected element(s) will move and it’s edge will be aligned to the same edge of the base element (which was signified by a dashed rectangle around it).

2. Pick the Align Elements by Edge icon first, make sure the edge for alignment (kind of like the element’s justification point) is correct, pick the base element you want to align too, than pick the element you want to be aligned, accept this, then reset (right mouse key). The element that you wanted to align will line up with the element (base element) that you chose to align to.

It will take several minutes of practice to get it, but it will be worth the time and effort because this will reduce a lot of work and be a huge time saver. Give it a try. *Tip from Louis Avgeris- Standards and Specs HQ*
Did you know that you can force the arrow heads to the inside of an angular dimension using the angle between lines command? If you go to the Dimension Styles > Terminators category and change the minimum leader value to 0 this will swing the arrow heads to the inside of the angled lines, as long as the text will also fall within this space. Remember to select the Reset Style so the setting will return to the default setting of Min. Leader 2.500000 when complete. That way all other dimensioning will act as expected.
Did you know that the latest CDOT configuration V2.01, now contains two cells within the General Cell Library called SHEET_Bar-Scale-Horizontal and SHEET_Bar-Scale-Vertical? These cells are to be used as the standard for placing Bar Scales within your drawing. The cells can be found on the CDOT Group Menus General Pull-down under Sheet.

It should be noted that the cells contain tags and can only be edited with the *Edit Tags* command on the Tags Tool Box. They cannot be edited through the *Edit Text* Command. The Tags tool Box is adjacent to the Text Tool Box on the default *Main Tool Frame*. There are other tags being developed within the configuration that will be discussed in the near future.
Did you know that if you are having difficulty selecting graphics within your DGN file, then it may be relative to your Boresite Lock being turned off. Boresite Lock makes it easier when using data points (alone) to identify elements. With Boresite Lock on, data points will find elements at all depths of a view. When Boresite Lock is off, data points (alone) will identify only those elements that are lying on or near the active depth for the view. Whether Boresite Lock is on or off, still you can snap to elements at any depth in a view. The lock should be turned on by default in the CDOT workspace. See Settings > Locks > Boresite on the MicroStation Pulldowns.
Did you know that CADD Library Details are being collected? The Details need to be drawn on appropriate levels, utilizing CDOT Standards. Designers can submit details to Region Representative for review and approval and then details will be included on CDOT Web site for use by others. Submit the drawings to the CADD Manager upon completion.
User Workflow

Change Line Direction

When working with MicroStation files you may need to change the direction of a custom linestyle. This work flow will step you through adjusting them with MicroStation tools.
Steps:

1. From the MicroStation Pulldown Menu *Tools > B-splines Curves > Modify Curves.* The *Modify Curves* toolbar will appear.

2. <D> the *Change Element Direction* icon.

3. Following the prompts from the MicroStation Status bar Identify an Element. <D> an element you want to change direction.

Alternate Steps:

1. From the MicroStation key-in browser. Key-in “*change direction*”

2. <D> the Run icon.

3. Following the prompts from the MicroStation Status bar Identify an Element. <D> an element you want to change direction.

Notes: Prior to executing this command you can create a selection set of elements using PowerSelector.
User Workflow

Changing Cell Scale

When working with MicroStation files you may need to adjust the cell scales for plotting or referencing purposes. This work flow will step you through adjusting them with MicroStation tools.

Before

After
Steps:

Note: Prior to manipulating the original file you may want to make a copy of the file and name the new file accordingly.

1. From the Main Menu Toolframe <D> the PowerSelector icon

2. From the PowerSelector dialog <D> the Show Selection Information icon. The PowerSelector dialog will expand.

3. <D> the [Ty] tab. The available MicroStation Element Types will be displayed in the list.
4. Scroll through the list and <D>the Cell item. All the cells in the design file will be selected.

5. From the Manipulate toolbar <D>the Scale icon.

6. In the Tool Settings dialog, set the desired scale factor.
   - X Scale = 2
   - Y Scale = 2
   - Z Scale = 1
   - About Element Center – Checked

By setting the Z scale factor to 1, this will not modify the elements elevation. If you can not see the About Element Center check box <D>the expand down arrow.
7.  Press a point in the view to accept the scale. The cells will change size.

8.  From the PowerSelector dialog the Clear All icon. All cells in the active design file will be deselected.

Note: If needed select Edit > Undo to revert to the original graphics.
User Workflow

Changing Linestyle Scale

When working with MicroStation files you may need to adjust the linestyle scales for plotting or referencing purposes. This work flow will step you through adjusting them with MicroStation tools.
Steps:

**Note:** Prior to manipulating the original file you may want to make a copy of the file and name the new file accordingly.

1. From the Main Menu Toolframe `<D>` the **PowerSelector** icon.

2. From the PowerSelector dialog `<D>` the **Select All** icon. All elements in the active design file will be selected.

3. In the MicroStation Key-in Browser: Key-in “change linestyle scale x”. “X” is the absolute linestyle scale.

4. `<D>` the **Run** icon. The linestyles will change scale in the view.

5. From the PowerSelector dialog `<D>` the **Clear All** icon. All elements in the active design file will be deselected.

**Note:** If needed select **Edit > Undo** to revert to the original graphics.
User Workflow

Changing Text Scale

When working with MicroStation files you may need to adjust the text scales for plotting or referencing purposes. This work flow will step you through adjusting them with MicroStation tools.
**Steps:**

**Note:** Prior to manipulating the original file you may want to make a copy of the file and name the new file accordingly.

1. From the Main Menu Toolframe <D> the **PowerSelector** icon 📐

2. From the PowerSelector dialog <D> the **Show Selection Information** icon. The PowerSelector dialog will expand.

3. <D> the [Ty] tab. The available MicroStation Element Types will be displayed in the list.
4. Scroll through the list and the Text. All the text in the design file will be selected.

5. From the Manipulate toolbar the Scale icon.

6. In the Tool Settings dialog set the desired scale factor.
   - X Scale = 2
   - Y Scale = 2
   - Z Scale = 1
   - About Element Center - Checked

By setting the Z scale factor to 1, this will not modify the elements elevations. If you can not see the About Element Center check box the expand down arrow.
7. <D>a point in the view to accept the scale. The text will change size.

8. From the PowerSelector dialog <D>the Clear All icon. All text in the active design file will be deselected.

Note: If needed select Edit > Undo to revert to original graphics.
This workflow could be useful for Corridor projects or mapping that was received by outside Agencies (Cities, Counties, other consultants) where other phases of the project are in AutoCAD and need to be referenced into a MicroStation project, but continually come into the wrong coordinate system when referenced. It may be due to a User Defined Coordinated System (UCS) within AutoCAD which may need to be updated to a World Coordinate System (WCS). 

[Click here for more]
Changing From UCS to WCS in AutoCAD
This workflow could be useful for Corridor projects or mapping that was received by outside Agencies (Cities, Counties, other consultants) where other phases of the project are in AutoCAD and need to be referenced into a MicroStation project, but continually come into the wrong coordinate system when referenced. It may be due to a User Defined Coordinated System (UCS) within AutoCAD which may need to be updated to a World Coordinate System (WCS).

Here is the workflow to change the UCS back to the WCS. Go to the item below in AutoCAD.
That brings up the dialog box:

Highlight World and Set Current. That brings you back to the default WCS and Save the file when you exit AutoCAD. Then reference as required into MicroStation.
Did you know that changing an element to bylevel and resetting the scale factor can easily be accomplished? Turn off all the levels except the desired levels to change. Remember that the active level must be one of the desired levels. Select the elements that need updating and choose the change element attributes dialog (shown). Check the boxes as shown and set all the pull-downs to bylevel. Accept the changes in the screen...

Review your changes carefully before closing the file.

.. You can also change the scale factor of the selected elements with the Key-in change linestyle scale 100 (100 being the desired factor that you want the elements to be scaled to).
Did you know that you can define the origin of a selection set that will be written to the clipboard within MicroStation? Once you have determined your selection set, Tentative Snap (middle mouse button) to the desired origin location. Do Not ACCEPT (Left mouse button) the tentative point. Now select Edit > Copy to copy the selection to the clipboard. Once the selection has been defined, you can now Edit > Paste the graphics into the active drawing, or into another drawing. It will be placed about the point established above.
MicroStation

Version of CDOT Configuration

The way that you can tell the version of the configuration you are running is to open up MicroStation and *Hover* over the CDOT Icon on the Main Tool Bar Menu. You will see both a pop-up and a message in the lower left hand corner of the Status Bar.
MicroStation

Converting Complex Chain

Did you know that you can convert a Complex Chain to a Single Element? If the complex element does not contain any arcs, then convert it to a shape using the Modify Element tool. Ensure that the Smartline Modification Settings are set to "Minimize number of linear elements" then snap to the same vertex twice and then reset so the element is not altered in appearance.
Did you know that after creating the necessary grid for the asphalt layer on a typical section, activate ‘Create Region’ from the main menu. In the ‘Create Region’ menu box, choose ‘Opaque’ for the ‘Fill Type’, make sure ‘Keep Original’ is checked, and select the button for ‘Ignore Interior Shapes’ at the bottom of the menu box.

You’ll find that this works much better and faster than the AutoCAD solid command!

Submitted by Brett Nordby Region 5-Durango
Did you know that you can place curved leader lines with the Place Note command? Open the Place Note dialog box, set the Location to Manual and the Leader Type to Curve. You can then place as many curves in your leader line as you wish. You will also need to remember to change the Location setting back to Automatic when you want to place a regular dimension.
**MicroStation**  

*Decimal Feet to Inches*

**Did you know** that if your drawing is set up to display *decimal feet* but you want to enter your values in inches, just precede the value by a .. (dot dot). Not only does this save you time by eliminating the need for calculating the decimal equivalent, it's also way cool!

For example:
If you want 2" simply keyin ..2 instead of 0.167. This will also work with fractions of an inch but is a little tricky on occasion. Key in ..2 1/8 and it will convert it to .177 of a foot.
Did you know that you can force the arrow heads to the inside of an angular dimension using the angle between lines command? If you go to the Dimension Styles > Terminators category and change the minimum leader value to 0 this will swing the arrow heads to the inside of the angled lines, as long as the text will also fall within this space. Remember to select the Reset Style so the setting will return to the default setting of Min. Leader 2.500000 when complete. That way all other dimensioning will act as expected. Click to view the commands.
Angular Dimension Setting

Focus Item Description

Set the space, in text height units, between extension lines and dimension text.
Did you know that dimensions are associated with the Associative Dimension setting in the sheet file. If the Reference file is associated to a dimension upon initial placement, and the reference file is either not found or detached and reattached, the association will be broken. You can drop the dimension through the drop element command (element will become only a graphic group not dimension any longer), place another dimension while associating to the reference file with association selected, or key-in dimension reassociate to associate the dimension again.
Did you know that if you point to your AccuDraw dialog box with your cursor and type the letter Q, you will close or Quit AccuDraw? You can then bring AccuDraw back by selecting its icon on your Primary Tools dialog box or key-in accudraw activate. This will actually toggle Accudraw on or off in the middle of a command. This Key-In would be handy to have on your Function Keys.

If a command is acting different than expected, often times dismissing AccuDraw and reopening it, will help the command to act as desired.
Did you know that you can use the "/" character to divide values in the MicroStation input fields? If you have 75 ft of text height and you want to change it to 37.5 ft of text height. You can add "/2" or "75/2" and the software will calculate the new height. You can divide anything by adding the divide character "/".
Did you know that you can attach multiple reference files quickly and easily by simply dragging and dropping from Windows Explorer into the reference dialog box? Highlight the references you desire in your Windows Explorer and drag them into your MS reference dialog box. A message will appear notifying you how many files you are about to attach. You can change the attachment method and answer OK.

This method works for both references and raster attachments!
Note that if the rasters are not georeferenced they'll all end up at the same coordinates.
Did you know that to break up a dimension element into its component lines, line string, ellipse, arc, or text elements, use the *Drop Element tool* in the Groups tool box or the *Drop Dimension Element Tool* in the Drop tool box? The Dimensioning can still be manipulated as a more primitive group with the Graphic Group Lock turned on. However, the Dimension will no longer be Associative.
Did you know that panning in MicroStation can act similar to AutoCAD panning. Users who miss the middle button pan functionality there is a pretty close equivalent. Click on the Pan display button control, verify that the Dynamic Display is selected on in the Pan View Tool Settings box, then left click a point in your drawing and **hold down the left mouse**. When you drag the mouse the pan anchor point moves the drawing on your screen just like AutoCAD. When you release the left mouse button the drawing has been panned to the new location.

A word of caution, when you exceed the dimensions of the graphics screen without releasing the left mouse button, the drawing appears to be "stuck" on the mouse cursor, even if you release the left mouse button. Simply left click again in the graphics screen to clear the current Pan command.
Did you know that if you cannot edit the text in a title block cell or any other cell for that matter, then the cell was inadvertently placed as a shared cell. You can choose the Drop Element and select the Shared Cells category. Select the pull down and change it to "To Normal Cell", select the title block and accept it in the screen. This will change the cell to a simple cell and will now allow editing.
Did you know when digitizing new linework, you can replace the degree symbol ( ^ ) with a semi-colon ( ; ) when entering angles in AccuDraw? For example: $N89^59'42"E$ can be entered as $N89;59'42"E$
Did you know that you can extract column information from several of MicroStation's dialog boxes? Invoke a CTRL+A to select all entries, then invoke a CTRL+C to copy the text information to the clipboard. Once you've done this you can paste the information into Excel or any other application you want to.

A few dialog boxes you can try this with include: References, Models, Design History, Raster Manager and Element Information details.
Did you know that if you'd like to add the contents of a fence to a new selection set, you can Key-in: Fence Selection New. You can then add more elements to an existing selection set: first place a fence and then Key-in: Fence Selection Append. Finally, if you want to remove elements from a selection set: first place a fence and the Key-in: Fence Selection Remove.
Did you know that if you have a certain level or levels that you want to send to someone, you can turn off all other levels, place a fence around the objects and key-in FF= and then hit a return? A dialog box will appear that will allow you to type in the name of a new file and then save out just the level that is contained in the fence. Once you have accepted the dialog box you must place a data point in the screen to accept the fence contents. A new file will be created with only the levels specified.
Did you know that there is a new text style available in the CDOT Workspace that utilizes a filled background and will be very useful when placing text on top of Raster Images. The style is called "100 Filled and 80 Filled" and is applicable for all English text sizes available in the workspace (.05", .07", .10", .14" and .30"). For more information see the following workflow: CDOT Printing Raster Images
This document guides you through the display settings of raster images and modifying text for better clarity.

**Adjusting Raster Display Settings**

1. Contrast and Brightness controls are used to adjust the display characteristics of raster images. Select **Tools > Raster > Display.**

2. The **Raster Display** tool bar will appear. Click the **Contrast/Brightness** icon.

3. If more than one raster image is displayed in the drawing, the image you want to adjust may not be active. To select a different image, then select the desired image from the view.
4. Determine how you want to adjust the selected raster image. To make an image appear lighter, move the **Brightness** slider to the right or key in a positive value. To increase the contrast of the image (setting apart the display of different entities within the raster file), move the **Contrast** slider to the right or key in a positive value. Using a negative value for contrast will result in a darkened image.

![Contrast/Brightness](image)

5. Continue adjusting **Brightness** and **Contrast** until the desired result is achieved then dismiss the setting dialog.

**Using a Text Style with a Background**

If a raster image is dominated by dark colors, it may be necessary to use a text style with a background.

**Placing Text with a Background**

The only change required for placing text with a background is to select one of the “Filled” Text Styles.

1. Select the **Place Text** icon from the **Main** toolbar.
2. In the **Place Text** settings dialog box, use the **Text Style** pull down menu and select the desired “Filled” **Text Style**.

   ![Place Text settings dialog box](image)

3. In the **Text Editor**, key in the desired text and place as normal. The result will look like the example below:

![Sample Text with Background](image)

**Note:** The color of the text in this example has been changed for clarity.
Modifying InRoads Text to Have a Background

InRoads does not use Text Styles or Annotation Scale. Therefore, text displayed by this program will have to be modified to display a background.

4. Turn off the Graphic Group Lock. All Cardinal Point text and all P.I. text are contained in graphic groups. Turning off the Graphic Group lock will allow the justification to be set for each piece of text as needed.

5. Select Change Text Attributes from the Main toolbar.
6. In the Change Text Attributes dialog box, set the Text Style. Use .10” ENG-100 Filled for Major Stations and .07” ENG—100 Filled for PC, PT, and PI stationing Points. Also, set the desired justification.

![Change Text Attributes dialog box]

**Note:** the following justifications are used by InRoads:

- Major Stations - Left Center
- P.I. Left of Centerline - Right Center
- P.I. Right of Centerline - Left Center
- Cardinal Left of Centerline - Right Bottom
- Cardinal Right of Centerline - Left Bottom

7. Select the desired text from the MicroStation view. Text may be selected individually or use the MicroStation element selection tools to select multiple text entities. Use the element selection tools to select a large number of elements that have the same Text Style and Justification (like Major Stations, for example). For Cardinal Points and P.I. stations, selecting them individually may be a better option as their justification is dependent on the direction of the curve.
**Note:** The text will change to a very small size. Do not worry about that for now. An **Annotation Scale** will be added to all of the text that was modified at one time. This will restore the text to its proper size. As shown below, the text size in the image on the left is correct, but the text styles are wrong. The text in the image on the right has had the correct text style applied, but no adjustment to the text size has been made.

8. Repeat steps 10 and 11 for all of the text placed by InRoads.

9. Highlight all of the InRoads placed text that has been changed to a “Filled” text styles.

**Note:** If no text is highlighted when the “annotationscale add” key in is run, then the annotation scale is applied to all text. This will enlarge InRoads geometry symbols (which come from symbol fonts) by the annotation scale factor.

10. In the Key-in window, type “annotationscale add” and <D> the Run Key-in icon or press the Enter key. This will restore the text to its proper size.

11. Below is an example of InRoads text with a filled background and correct annotation scale.
MicroStation
Level Display and Level Manager

Did you know that you can drag the "Used" tab on the dialog box much closer to the "Name" tab and then sort by the "Used" category. All the tabs can be repositioned on the dialog box in any order that is most useful to the user. You can also Right Click on the tabs and turn on or off any of the desired tabs.
Did you know that there is a Plot Category on the far right hand side of the Level Manager Dialog box? This category can accidentally be turned off on all levels or on a level by level basis, causing elements within your design file to display on the screen, but not show up when you send the file to the plotter. This can be very frustrating, so check to see if the elements in question have accidentally been instructed not to plot. This setting is file specific setting.
Styles that are not displaying correctly is more than likely due to the **Element Line Styles Custom** Scale factor setting not being checked on. The scale factor should be set to 100 by default. If the drawing does not update directly you may also have to key in `dwg ltscale 0` followed by the Enter key. This should fix your linestyle scale viewing issue.
Did you know that the total measurement of a series of lines selected with the selection tool in a drawing may be done by picking the "Measure Length" tool from the "Measure" toolbar (4th icon from the left)? This gives the total of all lines in the selection set.

This command may be used on non-linear elements also, such as arcs, circles, blocks, smart-lines, etc. It will also measure lengths of 3D lines, so be careful if this is not your desired intention.

This tip comes from Hanh Nguyen of Staff Bridge
Did you know that instead of using a measure command inside of MicroStation, you can use AccuDraw for most measuring. As the AccuDraw dialog echoes back the position of the cursor relative to the last data point. A common workflow could be, select the place line command, pick the initial point (which moves the AccuDraw compass to the selected location) and just drag and/or tentative to the point of interest. Toggling between polar or rectangular mode (spacebar) let's you see delta X,Y,Z or Distance & Angle. Thanks Ron Brys for the Tip.
Did you know that after placing Linear Dimensioning you can use several of the Modify Element commands on the dimension. The Modify Element command allows you to modify the extension line and re-associate it's start or stop position. It also allows you to reposition the text that has been placed with the Dimension string. The Insert Vertex allows you to insert additional dimension breaks along a previously placed dimension string, while the Delete Vertex allows you to delete dimension breaks.

Sometimes it is easier to simply redraw the dimension all together, other times it may be better to modify it. Try it, you may like it.
Did you know that you can modify a custom linestyle on the fly by using the Modify Line Style Attribute command? Place the desired lines in your file, choose the modify linestyle attribute command, select the pull-down and choose the shift or scale method. Select the lines that you want to change and dynamically drag the cursor to the desired location. This command only works on previously placed lines, shapes, arcs and circles. View the command.

It should be noted that additional functions are available through the pull-down but scale and shift are the only two commands that work with the CDOT linestyles. The CDOT line widths are driven by weight (through ByLevel settings), and not driven by line width associated with the custom linestyle.
The Command Key-in:

Modify Linestyle Icon showing selections Modify Linestyle shift and Modify Linestyle Scale.
Did you know that there is another way to change entity attributes other than using the standard MicroStation "Change Element Attributes". If you click on the "Element Information" icon (the large "i" icon), then click on the element to view the information. Once the "Element Information" dialog box appears select the level you want to change to, from the Level drop-down combo box list. You can also change the color from the Color drop-down combo box list. After Selecting changes hit the "Apply" button. The element you selected has now been changed to the new level and color.

Thanks JR Heathcote Region 3
MicroStation and AutoCAD Interface

Changing From UCS to WCS in AutoCAD for Reference File Operations in MicroStation

This workflow could be useful for Corridor projects or mapping that was received by outside Agencies (Cities, Counties, other consultants) where other phases of the project are in AutoCAD and need to be referenced into a MicroStation project, but continually come into the wrong coordinate system when referenced. It may be due to a User Defined Coordinated System (UCS) within AutoCAD which may need to be updated to a World Coordinate System (WCS). Click here for more
Changing From UCS to WCS in AutoCAD
This workflow could be useful for Corridor projects or mapping that was received by outside Agencies (Cities, Counties, other consultants) where other phases of the project are in AutoCAD and need to be referenced into a MicroStation project, but continually come into the wrong coordinate system when referenced. It may be due to a User Defined Coordinated System (UCS) within AutoCAD which may need to be updated to a World Coordinate System (WCS).

Here is the workflow to change the UCS back to the WCS. Go to the item below in AutoCAD.
That brings up the dialog box:

Highlight World and Set Current. That brings you back to the default WCS and Save the file when you exit AutoCAD. Then reference as required into MicroStation.
**MicroStation**

*Panning with Cursor only*

**Did you know** that if you hold down the shift key and drag the cursor in any direction, you can *Pan* in that direction? If you want to *Pan* to the right (even in the middle of a command such as *Move*) hold down the shift key and point to the screen along the left side of the monitor, and then slowly drag the cursor to the right. Your view should begin to scroll to the right. Let go of the shift key, quit dragging the cursor and then continue with your *Move* command.
Did you know that in order to print a Dialog Box while inside MicroStation/InRoads, first make the dialog box that you want to capture Active (click on the tool bar)? Once active, with the keyboard, press ALT + Print Screen. Open up a Word document or an email message and with the keyboard, press Ctrl+V (or Edit>Paste or with your mouse Right Click>Paste). This should paste the active dialog box into the document. The dialog box will be easier to manipulate and have more functionality when inserted into Word or Paint.
Did you know when printing a PDF file you may need to turn off the Page Scaling on the print dialog box. Under the Page Handling area, notice the Page Scaling:, Select the pull-down and choose None. This will allow the saved PDF files to be "to scale" when measured with an Engineering scale, similar to a regular print from MicroStation. Click Here to view the affected dialog box.
MicroStation
Problem Placing Fractions

**Known Bug & Workaround** - Once a fraction has been added to the body of any text a “Soft Return” must be used from that time forward. A hard return will cause every fraction within the body of the text to no longer display correctly. This happens in both the *Place Text* command and the *Edit Text* command. A soft return is performed by pressing on the Shift Key and the Enter Key at the same time. The CAD Management team is aware that this is a very difficult Workaround and has made it one of the highest priorities to be fixed.
Did you know that if a file is opened in a Redline "View" only mode, then there are only a few commands available to choose from. It will be very obvious to you as the icons will not look anything like the training class. This mode is also known as "Read Only". Check in the lower right hand corner of the screen, to see if there is a Red "X". If so the file is being opened as "View" only. Printing and measuring are allowed, but commenting is not. In order to open the file for Redline use, try using Start > all programs > Bentley Redline > and select the Bentley Redline executable. You can right click on the executable and send to desktop for a shortcut to the command in the future.
Did you know that you can change the size of AccuDraw's compass? Key-In: accudraw settings size number where number is a value between 6 and 399. The lower the value the smaller the compass; the default number is 40.
Did you know that if you want the Key-In Dialog Box to not take up as much space within your application window when being docked, first minimize the Key-In box by selecting it along the bottom right corner, and drag it to an appropriate size to your liking and then dock the Key-In Box where you want it on the screen? Did you also know that you can use the arrow up and arrow down keys on your keyboard to bring back previously typed Key-In information?
Did you know that you can resize the CDOT Group Menus toolbar? Select the Menu and "undock" or float the toolbar within the drawing workspace. Resize the toolbar by selecting one of the corners, and drag the menu to the size that you desire. If the text does not display correctly after the resize operation, click on the CDOT Icon on the Main MicroStation Toolbar. This will update the text appearance. Now you can bank or "dock" the menu where desired. It can be docked on either monitor, on the top or the bottom of the screen.

The CDOT Icon will also bring back the Group Menu if it is accidentally deleted.
Did you know that you can easily scale elements about their insertion point? Simply Select the elements that you want to manipulate, choose the Scale command, expand the Scale Element Dialog Box with the arrow down (also known as show extended information). Check the About Element Center box and accept the graphics. You will notice that the elements are scaled without changing their insertion.
Did you know that if you have the Use Shared Cell toggle turned on within the cell library dialog box, when you place a cell that has text in it (such as the border cell), the text cannot be edited? This can be frustrating. If you have already placed the cell, you can key-in the command `DROP SHARECELL`. The system will prompt you `Convert Shared cell to Unshared Cell > Identify element`. Once you have selected the element you can now edit the text within the cell.

Remember to uncheck the Use Shared Cell toggle within the cell library dialog box and save settings. This will prevent future shared cell placement.
Did you know that if a fraction is the last character of a sentence and you proceed to the next line with a standard hard return on the keyboard, the fraction will become vertical on the next line within the editor and will not place as expected within MicroStation. To remedy this problem, at the end of the fraction, instead of using a hard return, use a soft return which can be accomplished by holding the SHIFT+ENTER keys. This should prevent the fraction from changing to a different line.
MicroStation

Stretching Graphic Cells

Did you know that you can use the Fence Stretch command and stretch graphic cells without dropping the cell status to simple graphics? Simply place a Fence (Inside Fence Mode is the safest), go to the Manipulate Fence Contents Command. Select the Operation pull-down and choose Stretch. Make sure that the Stretch Cells option is checked. The command wants you to define the origin and then define the distance. The cell will then be stretched. A few additional items to be aware of: make sure that the Cell has NOT been placed as a Shared Cell. Also make sure that your fence is strategically placed so as not to stretch elements that also lie inside the fence (vertices included). Play with the command. It is very powerful.
**MicroStation**

**Configuration Change**

Did you know that the latest configuration now contains the Survey Tabulation sheet. The sheet is not being autopopulated into newly created projects, but does exist in the `C:\Program Files\Workspace-CDOT\Standards-Global\MicroStation\Sheet Borders` and it is called `JPC#SURVTabSheet##.dgn`. The file can be copied to the desired location and renamed with the appropriate project code.
Did you know that when placing text along an element, if the text to be added is too long to match the limits of the element or the font is too large such that the new text is longer than the element, the text will be truncated? Therefore, change the size of the text or make sure the length of the new text is not longer that the limits of the element it is attached to. Submitted by Brett Nordby Region 5-Durango
Did you know that there is a way to place text that is centered between two snap points without using dimensioning or construction lines? Various items are randomly spaced in a file and for visual presentation, snapping to both of them and having MicroStation place text centered between the items is desired.

Try the following with Accudraw enabled:

1) Start the Place Text tool (make sure active justification is set to Center Top, Center Center or Center Bottom).

2) Enter the text to be placed.

3) Tentative on the first point (do not click Data).

4) Press the letter "O". (This moves the Accudraw origin to this point)

5) Tentative on the second point (do not click Data).

6) Enter /2.

7) Click the Data point.
A known problem exists in the MicroStation software as it relates to Text underline spacing. The underline spacing can be applied to text that has been placed in a drawing, through the Change Text Attribute command. Place the text that should be underlined in the design file. Open up the Change Text Attribute tool. Make sure to check only the Underline setting and toggle the setting to Enable. All other settings should not be selected. Apply the desired change to the text and the underline should now display correctly.

The configuration default value defined by the Workspace > Preferences > Text > Underline Spacing (%) 30 will be applied to the text. The underline is applied to the entire line or multiple lines of text. It cannot be applied to only a few words in a line of text.
Did you know that you can tell MicroStation what image to display as the thumbnail in the MicroStation Manager? Create a saved view called PREVIEW (SV=preview) and MicroStation will use it as the source view when previewing from the MicroStation Manager Dialog box. If you're going to use the title-block area of your drawing for a preview, turn off your line weight display from your View Attribute Settings Box (your weight display should actually be turned off in all files by default).

This preview window can be handy for thumbnail display images in Windows Explorer also.
Did you know that if you Key-in Change Dimension Witness you can toggle on or off the dimension witness line (AKA-extension lines) once it has been placed in you design file? To turn the dimension witness line off point to the visible portion of the witness line and accept the line. To turn the dimension witness line back on it is a little more tricky, point to the dimension line close to the arrow and it should toggle back on. Sometimes it takes a few picks, but usually is successful.
**MicroStation**

*Updating Annotation Scale*

**Did you know** that if you've got a file that came from the V7 MicroStation, the text will not have annotation scale applied to it? To do so, turn on the *Annotation Scale Lock* and *Key-In: annotationscale add*. This global keyin will apply the annotation scale of the active model to all text elements in that model. Other *Key-In* commands are: *annotationscale remove* which removes the annotation scale from the file and *annotationscale change 20:1* which actually changes the annotation scale of all text within a file by the ratio given.
Did you know that you can highlight a measured distance from the Tool settings Box, Right Click on the measurement and then do a Copy and Paste into another document. Linear measurements give you the working unit label, but Square Area units don't seem to. The Area unit also doesn't seem to recognize the design coordinate readout. This is a bug that is being looked into.

The measurement can be copied into an Excel table and linked into a document. The measurement doesn't have to be written down, merely pasted into a spreadsheet, which allows less room for error. Click Here to view more.
Settings > Design File > Coordinate Readout to change the unit measured distance readout.
MicroStation

Activating View Attributes Box

Did you know that you can activate the ‘View Attributes’ dialog box with a single click on the Bentley icon (script B) in the upper left-hand corner of your view window. This will pull-down menu in which you can select ‘View Attributes’. You can then uncheck line weights or any other view display settings that you desire.

Submitted by Brett Nordby Region 5-Durango

Another quick way to activate the ‘View Attributes’ dialog box is with a Ctrl+B (Hot Key).
MicroStation

What’s a Transient Element?

Have you seen the message *Element is a Transient Element* in either the status bar or message center and wondered what it meant? A *transient element* is an element created by a tool or application that is stored in memory only and not actually written to the file. A fine example of a transient element would be the *Define Cell Origin* tool - the little cross-hair symbol is a transient element that will go away if you point to the Cell Origin tool again, or re-open the design file.
Did you know that dimension elements have the following advantages:

1. A dimension element can be modified easily.
2. A dimension element can be associated with the element or elements it dimensions.
3. Associated dimensions update automatically when any of the dimensioned elements are modified.
4. Using dimension elements can significantly reduce the size of a design file that has many dimensions, since a dimension element is usually smaller than the corresponding individual elements.
Did you know there is a workaround? - When editing single line text to multi-line text there is a bug in the software. Edit the text as usual, adding the additional lines of text. Accept the text modifications and notice that the line spacing for the multi-line text is incorrect. The spacing does not recognize the line spacing that is set by the configuration. Open the Change Text Attribute command, check the Text Style setting and apply the setting to the text that was placed. The line spacing should now reflect the correct spacing.