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CDOT Customizing the Pay Items Database 
This document guides you through the customization of the CDOT Pay-Items.mdb file 
using the InRoads Pay Item Manager.  When figuring quantities, it is possible that two or 
more features will use the same pay item but require different values for some formula 
variables.  For example, the same paving material may be used for both the roadway and 
driveways but the thickness of that material can vary.   
 
Pay Item Manager will be used to copy a pay item and edit that copy for use with 
different variables or formulas.  
 

Copying The CDOT Pay-Items.mdb: 
 

Because the changes made to the pay items database will be unique to the project, a copy 
of the CDOT Pay-Items.mdb should be placed in the project directory. 
 
Making The Copy 

 
1. Open an Explore window to the C:\Program Files\Workspace-

CDOT\Standards-Global\InRoads directory and copy the entire CDOT Pay 
Items folder. 
 

2. Change the directory to C:\Projects\JPC#\Design\InRoads and paste.  
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Copying A Pay Item: 
 

Now that a copy of the master database has been made, customizing the copy for the 
particular project can be accomplished. 
 
Open InRoads 
 
 3.  Start MicroStation (and InRoads), opening the; 

C:\Projects\JPC#\Design\Working\XXXJPC#QuantityModel##.dgn file.  
 
Open Pay Item Manager And Load The Database 
 
 4.  From the InRoads menu, select Quantities > Pay Item Manager.   This 

displays the Pay Item Manager dialog box. 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
5. From the Pay Item Manager dialog box, select File > Open. 
 
6. In the Open dialog box, Set the directory path to: 

C:\Projects\JPC#\Design\InRoads\CDOT Pay Items\. 
 
7.  Select CDOT Pay-Items.mdb and Open. 
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 To Be Copied Locate The Pay Item

 
 8.  Select Edit > Find from the Pay Item Manager dialog box.  This displays the 

Find dialog box. 
 
 9.  In the Find What field of the Find dialog box, key in the desired Pay Item Code. 

And select Find Next.  The desired pay item will be displayed, highlighted in the 
right pane of the Pay Item Manager dialog box. 

  
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

10.  Select Close from the Find dialog box.   
 

Making The Copy 
 

 11.  In the right pane of the Pay Item Manager window, <R> on the desired Pay Item 
Name. Note: be sure that the cursor is in the Name column.  Select Copy from 
the menu that is displayed. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
12. Move the cursor to the Description column, <R> and select Paste.  A copy of 

the pay item (with (2) appended to the name is placed under the original. 
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Editing The Pay Item:. 
 

Opening The Edit Dialog Box 
 

 13.  In the right pane of the Pay Item Manager window, <D> on the copied Pay 
Item Name. Note: be sure that the cursor is in the Name column.  This will 
highlight the copied Pay Item. 

 
 14. <R> on the Pay Item Name and select Edit.  This displays the Edit Pay Item 

dialog box. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Editing The Pay Item Data 

 
15.  <D> just to the left of the ‘(2) in the Pay Item Name field.  Key in a brief , 

descriptive addition to the name.  Delete the ‘(2)’ 
 

For Example, for pay item 403-32621 that is to be laid down 6” thick, the name could 
read, “403-32621 – 6” Thick”. 
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16.  Do not change the Pay Item Code, Description, or Unit Name.  Doing so will 

result in errors in the pay quantity calculations. 
 
17. A different formula may be selected from the Formula pull-down in the Quantity 

Calculation area. 
 
 For example, there are two formulas for computing tons; ‘Ton’ and ‘Ton – L’.  

‘Ton’ uses the area of a feature and the variables Thickness and WeightCFT.  
‘Ton – L’ uses the length of the feature and the variables Width, Thickness, and 
WeightCFT. 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
Editing Formula Variables 

 
18. <D> on the desired variable from the Variables list in the Quantity Calculation 

area. 
 
19. Highlight the data in the Value field directly below the Variables list and key in 

the desired value.  Press the Tab key to accept the value. 
 
 
 
 
 
 
 
 
 

Version 03.02 Page 5 of 38 Created June, 2007   



CDOT Calculating Quantities With InRoads and Quantity Manager.pdf 

 
 

Deduction From Pay Items 
 
This option is used when two features occupy the same location (are coincident) and one of 
those features can reduce the quantity of the other.  For example, suppose a curb feature is 
stored as a continuous Breakline and an inlet feature is stored as random points on the curb 
Breakline.  For each occurrence of an inlet on the curb, the quantity of the curb can be 
reduced by a defined value. 

 
 20. To add a pay item for deduction <D> on the Pay Item Browser button. This 

displays the Pay Item browser dialog box. 
 
 21. <D> on the desired pay item and select Add.  The Pay Item is add to the  

Deduct From Pay Items list.  <D> on the Close button to dismiss the Pay 
Item browser dialog box. 
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22. <D> on the desired pay item from the list in the Deduct From Pay Items area. 

 
 23. Highlight the data in the Value field directly below the Pay Items list and key 

in the desired value.  Press the Tab key to accept the value. 
 
 
 
 
 
 
 
 
 
 
 
 

The Measurment Area 
 
The options in this area are used to determine how areas and lines are measured.  It is also 
used to specify quantity factors and rounding. 
 
There are two mode of measurement; Planarized and Slope.  Planrized projects the shape to a 
flat (2D) plane for measurement.  Slope measures the actual (3D) shape. 

 
 20. <D> on the desired radio button to select the measurement Mode. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 A Quantity Factor is a multiplier applied to the calculated quantity. 
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  21. If a Quantity Factor is to be used, <D> the check box to the left of Apply 

Quantity Factor. 
 
  22. Highlight the data in the field to the right of Apply Quantity Factor and 

key in the desired value.  Press the Tab key to exit the field. 
 
 
 
 
 
 
 
 
 
 
 
 A Rounding Factor is used to modify the computed value to the nearest specified 

increment. 
 There is also the option to round up or down. 
 
  23 If a Rounding Factor is to be used, <D> the check box to the left of 

Apply Rounding Factor. 
 
  24 Highlight the data in the field to the right of Apply Rounding Factor 

and key in the desired value.  Press the Tab key to exit the field. 
 
  25. Select the desired rounding option from the two radio buttons below 

Apply Rounding Factor. 
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  26. <D> the Apply button to accept all of the changes made to the pay item. 
 
  27. <D> the Close button to dismiss the Edit Pay Item dialog box. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  28.  This completes the edit. 
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Importing Graphics To surface 
This document guides you through the use of the InRoads Import Surface From Graphics 
command.  This command takes the X, Y, and Z coordinate information from a 
MicroStation element and stores it in a DTM file.  This command will be primarily used 
for creating pay quantity data.  Because of the high level of data control required, the 
Load From Fence option is inappropriate and will not be described.  
 
Opening MicroStation And InRoads 

 
3. Start InRoads (and MicroStation).  Set the directory path and highlight the 

desired file.  Select OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Creating Or Opening The Surface 

 
Data imported from graphics can be either loaded into a new or existing surface.   
 

Creating A Surface 
 

 2. In the InRoads menu, <D> on the bottom Surfaces tab.  <R> on the word 
‘Surfaces’ at the top of the left pane then select New from the menu. 
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3. In the Name field of the New window, key in the desired name.  
 
4.  In the Description field, key in the desired description. 
 
5. <D> the Apply button then <D> Close. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Opening An Existing Surface 
 

 6. In the InRoads menu, <D> on the bottom Surfaces tab.  <R> on the word 
‘Surfaces’ at the top of the left pane then select Open from the menu. 
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7. In the Open dialog box, use the Look In pull down menu to select the desired 
directory path. 

 
8. <D> on the desired file name. 
 
9.  <D> on the Open button, then <D> on the Cancel button to dismiss the Open dialog 

box. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Importing Graphic Data 
 

 10. In the InRoads menu, select File > Import > Surface.  The Import Surface dialog 
box will be displayed. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
11. Using the Surface pull down menu, select the desired surface. 
 
12. With the Load From pull down menu, select the desired method. 

 
 a. If all of the elements on a particular level are to be imported, select Level. 
 
 b. If  some elements on a level are to be imported and others are not, then select 

Single Element. 
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13. If Load From is set to Level, then with the Level Pull down menu select the 

desired level.  If Load From is set to Single Element this field is inactive. 
 
14. In the Seed Name field, key in the desired name.  This will be used to name the 

features imported from the graphic elements.  Note: this field may be populated 
if an existing surface is being used. 

 
15. Use the Feature Style pull down menu to select the desired feature style. 
 
16. Select the desired Point Type from the pull down menu.  Note: when importing 

graphics for pay quantities, Random should be used for items paid for as each.  
Breakline is used for items whose quantity is figured from a linear measurement. 

 
17. <D> the Apply button.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 a.  If the Load From is set to Level, all elements on the selected level are 

imported. 
 
 b. If Load From is set to Single Element,  then <D> on the desired element.  

<D> a second time to Accept the selection. 
 
 
 18. After all Levels and Elements are imported, <D> the Close button. 
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Saving The Surface 

 
 10. In the InRoads menu, <R> on the surface name in the left pane then select Save 

from the menu.  If the file existed prior to importing data then the data is saved to 
that file and no further action is required. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
  11.  If the file was new then the Save As dialog box will appear.  Select the directory 

path using the Save In pull down menu. 
 
  12. In the File Name field, key in the desired name. 
 
  13, <D> on the Save button, then <D> on the Close button. 
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5. Select File > Save As from the MicroStation Menu. 

 

Using The Shapes Tool 
This document guides you through the process of creating area surface features for pay 
quantity calculations.  The Shapes Tool is used to create dtm features that define an area.  
The advantage of this tool is that it does not affect the graphic elements used to create the 
features.  So, some of the same elements used to define an area feature can also be used 
to define linear features as well.  
 

Creating A Working DGN file: 
 

Because the Shapes Tool may require additional graphic elements to be added to the 
JPC#Modelxx.dgn file, or existing elements to be modified, a copy of this file should be 
used. 
 
Creating A Copy of the DGN File 

 
4. Start InRoads (and MicroStation).  Set the directory path and highlight the 

desired file.  Select OK. 
 
 

 

 
 
 
 
 
 
 
 
 

Version 03.02 Page 15 of 38 Created June, 2007   



CDOT Calculating Quantities With InRoads and Quantity Manager.pdf 

 
. In the Save As dialog box, set the directory to the Working directory. 

4.  copied file and select OK.  The copied file is 
now open in MicroStation. 

 

 

reparations For Using The Shapes Tool: 
 

reating A surface For Quantity Data 

y 
data.  To 

avoid this roblem a surface will be created to contain only pay quantity data. 

 5. ord 
‘Surfaces’ at the top of the left pane then select New from the menu. 

 

6
 

Key in the new name for the

 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

P

C
 
The design DTM will contain a large number of features that will not be used for quantit
calculation.  Using this surface could produce unwanted or erroneous quantity 

p
 

In the InRoads menu, <D> on the bottom Surfaces tab.  <R> on the w
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. In the Name field of the New window, key in the desired name.  

.  In the Description field, key in the desired description. 

. <D> the Apply button then <D> Close. 

 
 

etting The Level Display 

to turn off those levels that do not contain elements that will be used define the area feature.  

 9. 
y menu will be automatically dismissed when 

10. <R> on the desired level and select Set Active from the menu. 

6
 
7
 
8
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
S
 
The Shapes Tool works with all of the visible graphic elements.  Therefore, it is necessary 

 
Select the Level Display.  Note: if the down arrow next to the Level Display 
button is selected, the Level Displa
the cursor is moved off the menu. 
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 11. All Off from the menu.  This will leave 
only the desired elements displayed. 

 

losing The Area 

  12. on all of t e check boxes. 

 
 

 13. mand. <T> to the end of one of 
the elements that will form the area then <D>. 

 
<R> on the Level Display and select 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
C
 

Use the Match Element Attributes command.  Turn h
<D> on the desired element to match its attributes.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Select the Place Smartline (or Place Line) com
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14. <T> to the end of the next element that will form the area then <D>. 

 15. Repeat this process until all of the gaps in the area are filled.  Below is an 
example of a closed area. 
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reating The Area Feature 

  16. t Quantities > Shapes Tool.  The Shapes Tool 
dialog box will be displayed. 

 

 17. On the Shapes Tool dialog box, select Fill for the Shape entry. 

 18. Using the Surface pull down menu, select the surface created above. 

 19. In the Feature Name field, key in the desired feature name.  

 20. In the Description field, key in the desired text.  

 21. Using the Feature Style pull down menu, select the desired feature style. 

 22. Select Rename for the Duplicate Names setting. 

 23. Toggle on Use Dynamics and Exclude From Triangulation. 

 

C
 

From the InRoads menu, selec
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  24. d 

 
station limits. 

In the Limits area, toggle Station on if desired.  If used, key in the Start an
Stop stations in their respective fields.   Note:  If station limits are used, 
temporary lines extending perpendicular to the active alignment 1,000 feet in 
either direction will be placed at the Start and Stop stations. These will be
used to define areas both inside and outside the 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  25.  Select the Apply button. 
 
  26. Move the cursor inside the desired area.  Closed areas will highlight as the 

cursor is moved through them. 
 
  27. <D> inside the area to create the feature.  <D> a second time to accept.  If 

additional features are to be created using the same settings, these can be 
selected at this time.  The first additional feature will have a ‘1’ appended to 
its name.  This will be incremented by 1 for each additional feature 
thereafter. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  28. After the desired areas have been selected, <R> to redisplay the Shapes Tool 

dialog box and then select Close. 
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Saving The Surface 

 
29. In the InRoads menu, <R> on the surface name in the left pane then 

select Save from the menu.  If the file existed prior to importing data 
then the data is saved to that file and no further action is required. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

30. If the file was new then the Save As dialog box will appear.  Select the 
directory path using the Save In pull down menu. 

 
31. In the File Name field, key in the desired name. 

 
32. <D> on the Save button, then <D> on the Close button. 
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InRoads Compute Quantities 
This document guides you through the use of the InRoads Compute Quantities command.  
This command collects pay quantity data from a DTM and stores it in a database to be 
used with Pay Quantity Manager.  This command requires a surface with pay items 
assigned to the features and a geometry project with a horizontal alignment. 
 
The Compute Quantities Command 

 
7. From the InRoads menu, select Quantities > Compute Quantities.  This will 

display the Compute Quantities dialog box. 
 
 
 
 
 
 
 
 
 
 
 

 
 
2. Select the desired alignment using the Alignment pull down menu.  Quantities 

will only be calculated for features within the station range of the specified 
alignment. 

 
3. Using the Mode pull down menu, select either All or Fence.  The All mode uses 

all features within the alignment, the Fence mode uses only those features that 
are within a defined fence. 
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4. In the Include area, <D> either the All or Selected radio button for Pay 
Items. 
 
5. <D> either the All or Selected radio button for Features. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 Note: If the Selected radio button is chosen, then the items to be processed 

must be identified on their respective tab.  If the All radio button is selected 
all data of that type is processed and its tab is not used. 

 
6. In the Output area, <D> on the browser button next to the Database field.  

This will display the Browse window. 
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7. Select the desired directory path from the Save In pull down menu. 
 
8. In the File Name field, key in the desired filename or select an available one 

from those listed. 
 
9.  <D> on the Save button.  This will dismiss the Browse window and fill in the 

Database field. 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 

10. Select a Mode.  Choose Create to make new file or to overwrite an existing file.  
Choose Append if adding additional data to an existing file.  
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11. Select a Phase from the combo box to the right.  A new Phase can be created 

by keying in a name in the combo box.  Phases are used to group quantities.   
 
12. The Run field is another method of grouping quantities. If desired,  key in a 

Run name in the field to the right. 
 
13. <D> in the Deduction Tolerance check box to turn it on or off.  The field to 

the right is used to define the distance at which features are considered 
coincident.  Key in the desired value. For more information on pay item 
deductions see the “Customizing The Pay Items Database” workflow. 

 
14. <D> in the Sheet Number check box to turn it on or off .  When on, the field 

to the right is made active and a Sheet Number can be keyed in. This field is 
for informational purposes when quantities are tabulated on a per sheet basis. 

 
15.  <D> in the Purge check box to turn it on or off .  When on, this option 

deletes pay quantities from the database if the feature used to calculate the 
quantity has been deleted from the DTM. 
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16. The Symbology area is used to set the parameters for highlighting elements 

that quantities were computed for.  <D> on the check box in the Display 
column to turn the highlight on or off. 

 
The Pay Items Tab 
 
 This tab is used if Pay Items in the Include area is set to Selected. 

 
17. <D> on the Pay Items tab to bring it to the front. 
 
18. Select the Pay Items to be computed by clicking in the check box to its left. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 Note: All of the pay items in the list can be selected by selecting the ‘Root’ 

directory at the top of the list.  If a Category is selected (‘300 Bases’ in the 
example above) then all of the items in that category and its sub-categories 
are selected.  If a Sub-Category is selected (‘603 Culverts and Sewers ‘ 
above) then all of the items in that sub-category are selected.  Finally, 
individual pay items can be selected (‘606-00350 Guardrail Type 3 above). 
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The Features Tab 
 
 This tab is used if Features in the Include area is set to Selected. 

 
19. <D> on the Features tab to bring it to the front. 
 
20. In The Surface area, <D> on the desired surface.  Multiple surfaces can be 

selected by holding the Shift or Ctrl key and then clicking on the desired 
surfaces.  

 
21. In the Features area, <D> on the desired Feature. A consecutive range of 

features can be selected by holding the Shift key then clicking on the first 
and last feature in the range.  A number of individual features can be selected 
by holding the Ctrl key then clicking on the desired features. 

 
 The Locator button can be used to identify features from the graphic 

elements displayed.  The Ctrl key can be used with this option, however, the 
Shift key can not.  To use it, <D> on the Locator button then <D> on the 
desired graphic element. 
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22. <D> the Apply button to calculate the quantities. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
23. When processing is completed, a message stating that the *.mdb file has been 

created will appear in the lower left corner of the InRoads interface. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2
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4. <D> the Close button to dismiss the Compute Quantities dialog 
box.. 
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Working With A Quantity Manager Project 

Opening Quantity Manager 
1. Quantity Manager can be started from the InRoads menu by selecting Quantities > 

Quantity Manager.  It can also be started from the Start menu by selecting Start > All 
Programs > Bentley Civil Engineering > Quantity Manager.  MicroStation and 
InRoads do not have to be running for Quantity Manager to work. 

 

 
 

2. Select Project > Open.   This option is used to load the database created by the 
InRoads Compute Quantities command (see CDOT Compute Quantities.pdf for more 
information).  The ‘Connect to Database’ window will appear.   

 
3. Set the Database pull down to: MS Access 2000.  This is the format used by the 

Compute Quantities command  (SQL Server 2000 and Oracle formats can also be 
used by Quantity Manager) 

 
4. In the ‘File’ box, type in the directory path and file name of the desired file.  The 

‘search’ button to the right of the field can be used to locate and select the desired 
file.  

 
5. Click the Connect button. (unless otherwise noted, the ‘User Name’ and ‘Password’ 

fields are left blank.)  The database is now loaded into Quantity Manager and editing 
can begin. 

 
Edit- The six menu items here work with the Payitem Tree view (in the left pane of 
Qunatity Manager).  They are: Select All, Unselect All, Delete, Rename, Phase, and 
Funding. 
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Select All- This is used to select all of the payitems in a specified category or 
sub-category.  Highlight the desired category or sub-category then select Edit > 
Select All. 
 
Unselect All- Choose this option to unhighlight all of the payitems currently 
highlighted. 
 
Delete- This option is used to remove data.  If a single payitem is selected then 
only that item will be deleted.  However if a category or sub-category is selected, 
then all data within that category or sub-category is deleted also.  To use this 
command, highlight the desired data and select Edit > Delete.  A warning 
message will be displayed reading,” Are you sure you want to delete…”.  Click 
‘Yes’ to delete the selected item(s). 
 
Rename- This option is used to change the name 
of a Caregory, Sub-Category, or Payitem.  
Highlight the object to be changed then select Edit 
> Rename.  This will display the 
‘Rename’ window.  Key in the desired 
name in the field and click ‘OK’. 

Figure 26. The Rename window. 

 
Phase- Choosing this option displays the ‘Phase 
Properties’ window.  From here Phases can be 
added, deleted, or edited.  To add a new phase, 
click the ‘New’ button (left button in the lower 
right corner).  A new row is added to the list 
containing “New Phase 1” in the first column. 
 
To Edit a phase name, double click on the name to 
be changed and type in the new name.  To change 
the funding rule of a phase, click on the default 
funding rule for the desired item and use the pull 
down menu to select another rule. 
 
To delete a phase, highlight the phase and click the 
‘delete’ button (middle button in the lower right 
corner).  Note: if the pase has payitems stored in it, 
then the phase can not be deleted. 
 
The last button is used to create/edit the funding 
rules.  To create a funding property click the 
‘New’ button (left button on the lower left side of 
the window).  Type in the name and description 
for the new property in the respective fields at the 
top of the screen.  To delete a funding rule highlight the name in the Funding 
column and click the ‘Delete’ button  (right button on the lower left side of the 
window).  A warning message appears reading, “Are you sure you want to delete 
the funding rule …?”.  Click yes to delete the rule. 

Figure 28. The Funding Properties 
window. 

Figure 27. The Phase 
Propertieswindow. 
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Funding- There are two options for funding; 
Payer and  Rule.  Rule opens the Funding 
Properties window as described above.  The Payer 
button  displays the Payers window.  Form here 
data can be added, imported from an aecXML file, 
edited, or deleted. 

Figure 29. The Payers window.  
To add anew Payer, click the ‘New’ button (the 
left button in the lower right corner, see figure 29). 
A new row is added to the data above.  This can be 
edited by double clicking in the field, deleting the 
old data, and typing in the new data. 
 
To import data from an aecXML file, click the ‘search’ button (the middle button 
in the lower right corner, see figure 29). Select the desired payers from the list 
and click Import. 
 

View- The commands under this menu item are used to change 
what is seen in the Quantity Manager window. 

 
Refresh- This command updates all displayed fields 
from the database. 
Columns- There are three options for this command, 
one for each pane (Payitem, Quantity, or Element) of the 
Quantity Manager window.  Columns can be turned on or 
off by clicking the check box next to the desired column. 
Expand Category Quantities- When on, quantities 
within the highlighted category are displayed in the 
Quantity pane even when the tree view is collapsed.  
When off, the sub-category folder must be highlighted in 
order to view its quantities. 

Expand Tree- When chosen, all categories, sub-
categories, and pay items are expanded in the Payitem 
Tree (not the Payitem Table).  

Collapse Tree- When chosen, all categories, sub-
categories, and pay items are collapsed in the Payitem 
Tree (not the Payitem Table).  

Figure 29. The View Columns 
window. 

Normal and Tile Horizontally-  these two option 
determine the location of the panes withih Quantity 
Manager. Click on the desired option. 

Insert- These commands are used to add data to the database.  The choices are 
Category, Payitem, and Quantity. 
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Category- There are three options for creating a new 
Category; Above, Below, or Sub-Category.  If ‘Above’ 
is selected, the new category will be placed directly 
over the highlighted category in the payitem tree.   

Figure 30. The New Categories 
Properties window. If ‘Below’ is selected, the new category will be placed 

directly under the highlighted category in the payitem 
tree. 

When Sub-Category is selected the new category is placed inside the highlighted 
category.  

Note: A new category can not be placed above or below the Root category they 
must be placed as sub-categories. 

After the desired option has been selected, the ‘New Categories Properties’ 
window appears.  Type in the desired name for the category and click ‘OK’. 
 
Payitem- Three options are available for the location 
of the new payitem; Above, Below, or In Category.  
Above and Below are available only when a payitem 
is highlighted in the payitem tree.  In Category is 
available only when a Category or Sub-Category is 
highlighted in the payitem tree.   
Click on the desired option to display the ‘New 
Payitem Properties’ window.   

Figure 31. The New Payitem 
Properties window. Payitem Name- Key in the desired name. 

The ‘search’ button can be used to import a 
payitem from the aecXML infrastructure v33 
file if one is loaded.  
Description- Key in the desired description here. 
Unit Cost- Key in the desired unit cost. 
Lump Sum- If the unit cost is a lump sum total, click on this check box. 
Unit- This is the unit type shown in reports, it is not used for any 
calculations.  Key in the desired unit. 
Total Rounding- This number is for informational purposes.  It does not 
affect quantity data entered. Key in the desired number. 

When all of the desired entries have been made click the ‘OK’ button to create the 
payitem.  
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Quantity- This option is used to add an amount to a payitem.  This option is active 
only when a single payitem record is highlighted.  To add a quantity, highlight the 
desired payitem and select Insert > 
Quantity. This will display the ‘New 
Quantity Properties’ window.  It should 
be noted that the only calculation 
performed is to subtract the Deduction 
Quantity from the Rounded Quantity to 
produce the Net Quantity. 
General Tab- This is where the actual 
amount is stored. 

Measurement Basis- This is how 
the feature would have been 
measured if there was one.  There 
are three options; Area, Linear, 
and Each.  Items measured by 
volume (Tons, Gallons, Cubic 
Yards, etc.) or area (Square Feet 
or Square Yards) should be set to ‘Area’. Those measured in Linear Feet or 
Linear Yards should be set to ‘Linear’.  Items listed as Each or Lump Sum 
should use ‘Each’.  Use the pull down menu to select the desired entry. 

Figure 32. The New Quantity Properties 
window. 

Measurement Value- This equates to the area of a shape feature, the length 
of a line feature, and the number of points in a random feature. For a Lump 
Sum payitem this should be 1.  This number is not used for any calculation.  It 
is here to make this payitem record consistent with those imported from the 
DTM. Key in the desired value. 
Computed Quantity- If a formula was utilized, this field is the result of the 
computation. Using a pavement quantity example, a formula computing tons 
from square feet could be utilized. In this case, the tonnage is the Computed 
Quantity.  Entering data into this field auto-fill the Rounded Quantity with the 
same value.  Key in the desired value. 
Rounded Quantity- Some payitems use a Rounding Factor which is applied 
to the Computed Quantity.  If the quantity being entered uses a rounding 
factor, change the number in this field to the rounded computed quantity.  For 
example, concrete pipe is rounded to 2 foot increments.  An 83 foot long pipe 
would be rounded to 84 feet.  Key in the desired value. 
Deduction Quantity- The quantity of some payitems may be reduced by the 
presence of another payitem.  While the payitem causing the reduction is not 
listed here, the amount of the reduction is.  Key in the desired value. 
Net  Quantity- Subtracting the Deduction Quantity from the Rounded Quantity 
yields the Net Quantity.  This is the only calculation performed by this 
command. 
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Sheet Number- This is the name of the sheet upon which the quantities are 
located. This can be useful when computations are tabulated for individual 
sheets. 
Run Name- This is a user-defined name. The run name is a grouping 
mechanism to permit segregation of quantities under the same payitem. It 
could be used to represent quantities of different stages or different 
alternatives. 
Phase- To assign the quantity to a particular phase or change the phase, 
Simply select the desired phase from the pull down menu. 
Phase Button- This is used to display the Phase Properties window.  The use 
of this window is described above. 
Date / Time- This is the date and time that the record was created. 
Set Current Button- If a record is being edited, the Date/Time can be reset to 
the current date and time by clicking this button. 
Remarks- Key-in field for remarks. Limited to 256 characters. 
Description- Key-in field for the Description. Limited to 256 characters. 
Extended Description- Key-in field for the Extended Description. Limited to 
256 characters. 
 
 
 
 
 
 

Location Tab- This tais used to identify the 
location of the quantity in relation to an 
alignment.  

Baseline Chain- The is the alignment to 
be measured from. Use the pull down 
menu to select the desired alignment. 
Minimum and Maximum Station- 
These are used to set a boundary 
around the quantity.  The station 
numbers do not represent the beginning 
or end of a feature, but the lowest and 
highest station at which the quantity 
would occur.  The same can be said 
about the offsets. They do not represent the locations of the beginning and 
end of a feature, but denote the furthest distance to the left and right of the 
alignment that the quantity occurs.  There are three fields for both the 
minimum and maximum station; Station, Offset, and Region. 

Figure 33. The New Quantity Properties 
window, Location tab. 
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Station- key in the desired station number.  Note: station numbers should be 
computed as if there is no station equation. 
Offset- Key in the desired distance.  Left of the alignment is negative, right of 
the alignment is positive. 
Region- This is used if the alignment has a station equation. This option is 
usually selected automatically when the station number is entered. 

Adhoc Attributes Tab- There is no information on the use of this tab. 
 

Tools- Reporting tools are located in this menu item. Under Tools > Reports there are two 
options; Create and Define Styles.  As Defining Styles (other than the samples provided) 
requires knowledge of XML programming, this option will not be discussed here. 
 

Figure 35. The Create Report window.  

Creating A Report- Select Tools > Reports > 
Create to open the ‘Create Report’ window. 

Active Phase- This is determined by the 
Phase selected in Quantity Manager. 
Report Style- Select the desired style from 
the pull down menu. The Style name 
describes the type of information to be 
contained in the report. 
Report Type- This is determined from the 
Report Style chosen. 
Report File Name- Key in the directory path and filename for the output file.  
The ‘search’ button can be used to select the directory path and filename if 
desired. 
Starting Page Number- Some report styles use this information to automatically 
number the pages of the report.  If this field is active, the desired page number 
can be keyed in. 
 

The three buttons at the bottom of the window determine how the information will be 
stored. 
 

Append- Choose this button if this data is to be added to an existing file. Note: 
this button is not available if the report type is PDF. 
Create- This option creates a new file or overwrites an existing file. 
Cancel- This option closes the Create Report window without processing any 
data.  No report is created. 
 

The commands for data entry or modification are available through ‘Right Click’ menus.  
Categories, Payitems, and Quantities each have their own Right Click menu.  To activate a 
Right Click menu, place the cursor over the desired object and click the right mouse button. 
Below are examples of the three Right Click menus. 
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Figure 37. The Quantity Right Click menu. 

Figure 36. The Payitem Right Click menu. 

Figure 35. The Category Right Click menu.  
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