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This document guides you through translating AutoCAD files into MicroStation using a .CSV
remapping file. Steps 1-4 listed below should be followed when saving an AutoCAD file to
MicroStation manually, without the use of a remapping file. The manual method should only be
used on small files where a limited number of levels will need to be changed. In this case, use the
change symbology tools in MicroStation as outlined in the Roadway Drafting Using MicroStation
training manual. Once the levels have been changed manually, follow the steps listed under
“Other Drawing Elements™, beginning on page 9, for updating text, cells, patterning,
dimensioning, and models. For plotting AutoCAD files only, see the workflow, CDOT Printing
AutoCAD Files in MicroStation.

For this workflow not only will you be bringing the files into MicroStation, you will be updating
the files to the CDOT configuration. This means all levels in the MicroStation drawing file will
be standard CDOT levels having bylevel symbology and all drawing files you are translating will
be set up using the standard CDOT workflows. For any questions about the CDOT standard
procedures and workflows please contact the CDOT Help Desk at 303-757-9317 for additional
support on translating your files.

Opening an AutoCAD file in MicroStation

1. From the MicroStation Manager, open an AutoCAD (*.dwg) drawing file. Change
List Files of Type to CAD Files (*.dwg, *.dgn, *.dxf) to view AutoCAD files.
Highlight the desired file and select OK.

MicroStation Manager
Fle Directory Help
Files: Directories:

[12435_ PwWHNERSHIP.dwg

C:hPraojectst 12345 \Miscellaneoush.

R2000 D'wG

12345_ROM dwg
12435_0wNERSHIP.dwg
PHASE3_12345L5CD.dwg
PHASE 3B_12345L5C0. dwg

ExCh
[ Projects
12345
P Miscellaneous

List Files of Type: Diives:
CAD Files [*.dgn.” dwg.” dx_l] R =3 > —
I Fead-Only DG Oplions Cancel

I~ Show File Igons

Workspace
~ User: [EOOT User

—
P Praject: [12385
&

Interface: [COOT
2. The MicroStation DWG/DXF Units dialog box will appear. Verify the Units are
set to Survey Feet and select OK.

L L1l

DWG/DXF Units

MicroStation V8 requires that the file units be accurately specified in order for "True" &
scaling to be calculated correctly when working with cels and reference files.It is not
possible to infer the units for the DWG or DXF file:
"C:\Projects\12345\Miscelaneous)12435_OWNERSHIP.dwg" for the following

reason:

=

IU nits:  Suneey Feet ¥ I

[~ Do not display again [Use this setting for all D%WG/DXF files of this pe]

Version 03.01 Page 1 of 14 Created March, 2007



CDOT Converting AutoCAD File to MicroStation.pdf

3. Select File > Save As.

F% C:\Projects\12345\Misc

File | Edt Element Setting'
[0 New... Ctri+N
— [ Open... Ctrl+0Q
Close Ctris\W
i save Ctri+S
Save As...
Compress
Save Settings Ctrl+F
Reference

Raster Manager

E Models

) Import

3

¢ Export

4. Change the Select Format to Save to MicroStation V8 DGN Files (*.dgn). and
browse to the appropriate folder under the Projects directory. The file will be
automatically saved with the same name as the AutoCAD file with a different
extension. You can rename the file at this time if you choose to do so. Select

Options.

Save As
Directory

Files Directories:

[ 124350MERSHIP. dagr{ - ADrawingzsReference Filesh,
12345R 00/ Modelitd. dan = G
12345RWPL_PEP Generatar. dgn [ Projects
123455 urvept odelftf. dagn = 12345
123455 urveyT opofHS calefti. dan = RO%W _Survey

= Drawings

Select Format To Save:

icraStation V8 DGM Files [7.dgn]

#= Reference_Files

Drives:

=2

i

Cancel

Note: Model files are saved to the specialty group’s Reference_Files folder. Sheet

files are saved under the specialty group’s Drawings folder.
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Editing the CSV file

5. Inthe Save As V8 Option dialog box, open the template CSV file that is created
when you run the CDOT - Create Project Directory application. The CSV file
maps all of the previous AutoCAD layers to the standard CDOT MicroStation levels.
Select the Browse for CSV remapping file icon to edit the CSV file.

Save As V8 Options ‘

CSVFile [ ]

|Br0~.'use for CSV remapping file

el =k =kl =l

0K I Cancel |
6. Browse to C:/Projects/12345/Miscellaneous. Select the file 12345.csv and select
OK.
Select Remapping CSV File

Fie Directory
Files: Directories;
[12345 csv |C:Projectsh 12345\ Miscellansous’ |
12345.c5v | B ==

[ Projects

[ 12345

= Miscellaneous
Caticel

Ligt Filez of Tupe: Dirives:
Remapping Files [* cav] "l = ] Help
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7. The CSV File field will be populated. In the Save As V8 Options dialog box, select
the Edit CSV remapping file icon.

-
Save As V8 Options

pe iy

[Csv Fie 12385 cov | a[E)a
F : |Edrc CSV remapping file

[~ Apply Line Style Mapping
™ Apply Color Mapping
I™ Apply Weight Mapping

[ ok ] Cancel |

8. Microsoft Excel will activate. If the Security Warning dialog box appears, select
Enable Macros.

fecurity Warning

"C:\Projects\12345\Miscellaneous!12345C5V.xls"

centains macros by :
Bentley Systems, Incorporated

A certificate (signing or issuer) has expired.

Macros may contain viruses. It is usually safe to disable
macros, but if the macros are legitimate, you might lose some
functionality.

I Enable Macros I l More Info
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9. In Excel, the Level tab will be active. Select the il icon that is embedded in the
Level cell.

] Microsoft Excel - 12345CsV. =IO

i3] Fe Edt Vew Insert Format Tools Data Window Help £ 3% Adobe PDF
: 5 ik 83

‘5 B 8 T - 00w - ©
L.:‘.:.!’LJ_J‘?-? ..J|_ ||_3 ‘%JLE:.‘H‘-"rRepIyw'rth;hanges... EﬂdREViE\-‘\'...
L S — . &
: Aril ~10 -|B 7 U|E==H W80 5-A

Level Mapping Table

[ show Optional Columns |

3

4

o

6 |Level = V8OutputLevel DWGOutputLay
7

8

9

22

iDawy lg | autoshapess N\ N 1O A 4l
Ready
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10. The fields under Level will be populated with the layers that are defined in the
AutoCAD file.

O M=%
% Fle Edit View Insert Format Tools Data Window Help %+ -4 Adobe PDF
-8 x

DEHROGRTEIS0:8 5 0o -0 B
R W Wt 22 W75 W | < | [y 4] ¥ Reply with Changes... End Review..‘_E

: Aril -1 -[B|z U |E[= =] W80 v&vévg
e e A

B6 - & Level
A | B [ ] ™

1 (o

2

3 Level Mapplng Table

4 [~ Show Optional Columns

5

6 Level IE V8OutputLevel DWGO1L

7 R_SECTION_INFO

8 R_PROPERTY_LINE

9 R_PROPERTY-LINE-TEXT

10 PROPERTY _LINE

11 CDOT_ROW_LINE

12 CDOT_ROW_TEXT

13 R_TEMP-EASEMENT

14 NEW_KEY MAP

15 R_EXISTING

16 OWNER-LABEL

17 R_CENTERLINE

18 DCALIGNMENT

19 R_NOTES

20 HATCH-OVERLAP

21 CDOT_CL_TEXT

22 R_PROPOSED =
Woa >||\Lev2|"s”"<':_é|or§",?'iir’§&ts 7 Lnestyles | < |u| 2l

i Draw~ ¢ |Autoshapess \ N (O M A @@ M ~-LZ-A-= [
Ready UM :
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11. In order to remap to the standard CDOT levels, you will need to manually populate
the V80OutputLevel fields with the standard CDOT levels. When this is complete,
Save the CSV file in Excel and Exit the Excel application window.

| =] Microsoft Excel - 12345 Q
2] He Edt Vew Insert Format Toos Data Window Help 5 3 Adobe PDF

: _ 8 x
DEERASRIVE S8 = bR e B
= 1 3 A ‘ ‘ & LUA—" Reply with Changes... End Revies s
 Arial =1 v|I ul%%ﬁ\ﬁsﬁﬂ ‘vi—[ﬁ'&'%‘
L

B6 - # Level
A B [ I i

1 (i
2

3 Level Mapping Table
| CDOT Standard
4 | [ Show Optional Columns

5

6 Level E VBOutput%vel DWGO1L

7 R_SECTION_INFO

8 R_PROPERTY_LINE
9 | R_PROPERTY-LINE-TEXT

10 PROPERTY_LINE

11 CDOT_ROW_LINE

12 CDOT_ROW_TEXT

13 R_TEMP-EASEMENT

14 NEW_KEY_MAP

15 R_EXISTING

16 OWNER-LABEL AutoCAD

11 R_CENTERLINE Layers

18 DCALIGNMENT

19 R_NOTES

20 HATCH-OVERLAP

21 CDOT_CL_TEXT

22 R_PROPOSED

e nAnoC aupanen ! s
M 4 » W)\ Levels/ Colors / Weights { LineStyles |4 [u| >

i Draw~ g |Autoshapes \ W O A A @B @| D~ F-A-= [
Ready NUM ﬁ

Note: Not all levels need to be populated. Use the standard CDOT levels that are
populated under the AutoCAD layers in the level column to copy/paste to the
V8OutputLevel column. However, some of the MicroStation levels are not in
alphabetical order. Also, blank entries in V80OutputLevel column will be ignored
when processed.

Layers generated in AutoCAD that will be recreated as cells in MicroStation such as
the Border, North Arrow, and Bar Scales do not need to be remapped because they
will automatically come in on the correct levels when the standard CDOT workflows
are followed. Also, the levels used for creating AutoCAD viewports do not need to
be remapped. Items on the Defpoints layer should be remapped to the level
DRAFT_INFO_No-Plot.

The line styles, color, and weight of each level has already been taken into account

through the CSV file. The translation variables in the CSV file have been set to
remap all levels to have bylevel symbology.
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16. In the Save As V8 Options dialog, select the Filter tab. Select Models.

E Save As V8 Options

Remap I References

Geometry: Ewvendhing ¥

Models...

v Auxiliary Coordinate Systems v Mamed Groups
[ Sevediews ¥ Frozen Levels
v Shared CellInstances WV Tags

[ Unused Shared Cell Definitions

[5]4 Cancel

17. From the Select Models dialog, you can isolate the Sheet Layouts from the
Model file. Sheet Layouts are carried over from the AutoCAD Paper Space
functionality. Sheet Layouts are not used in the standard CDOT workflow.
However, they may contain information that will need to be copied to the model
file or to the sheet file. If this is the case, the information will also need to be
translated to CDOT’s standards using the same procedure outlined in this
workflow. The CSV file will only run for the file selected. Highlight the Model
file and select OK.

E Select Models P4
Type 2D/3D| Name Description &
G  Model |

L a3  chest 20
= &  sheet_19
= &  sheet_21 —
| &  sheet_18
| &  sheet_23 -
4 3
0K Cancel ‘

Version 03.01 Page 8 of 14 Created March, 2007



CDOT Converting AutoCAD File to MicroStation.pdf

18. Check on the fields for Apply Level Mapping, Apply Line Style Mapping,

Apply Color Mapping, and Apply Weight Mapping. Select OK.

Save As V8 Options

| References I Filter |

Sy File [12385.cov

Qi

-

W &pply Level Mapping

W &pply Line Style Mapping
W Apply Color Mapping
¥ &pply weight Mapping

Cancel

19. Select OK in the Save As dialog box. The CSV file will execute and the
AutoCAD drawing file will be converted to a MicroStation file.

Save As

Directory

Files:

[ 1243500/NERSHIP. dgn

Directories:

ADrawingz\Reference_Filesh

12345R 0w Modelft.dgn
12348RWPL_P&P Generator.dgn
123455 urveyh odelfii. dan

123485 urven TopoltS caleftt. dgn

[ T
= Projects
212345
= ROW_Survey
= Drawings
= Reference_Files

oK
Cancel
Select Fom  _ Dirives: :
MicroStation W3 DGM Files[dan] | [ C | i :

20. Running the CSV file changed the levels in the Model file drawing. The levels

now have bylevel symbology.

21. From the MicroStation menu, selected Settings > Color Table after the

Version 03.01

MicroStation drawing file has been created.

Tools Utilities W
+ Tool Settings

Manage

AccuDraw

|  Color Tabk... |
Database »
Design File...
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16. Select File > Default.

7 Color Table

17. In the Color Table dialog, select Attach.

-

E Color Table &

I Attach | I Cancel ]

Other Drawing Elements

16. Other updates will need to be made to the files so all drawing elements and sheet
setups conform to the CDOT standards.

17. All of the Sheet Layouts will need to be recreated using CDOT standard workflows.
This means there can only be one Model for each MicroStation file. All of the sheet
borders will need to be placed in their own separate file, called a Sheet File. Then,
the Model file will be referenced to the Sheet File. Please refer to the documents
CDOT Sheet File Creation, CDOT Sheet File Creation Multiple Scales, and CDOT
Creating Multiple Plan Sheets for additional information about this procedure. They
are all accessed from the Windows Start menu under > All Programs >
_CDOT_CADD_Information > Workflows.
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18. Recreate all Dimensions and leader lines (placed by AutoCAD) using the standard
CDOT dimension styles.

fﬂ Element Dimens... E ‘

[ CooT xlQ ‘
¢ M1 Stylec[none) Use Active Settings
i CDOT 2 Accuracy of 012
i CDOT 1 Accuracy of 0.1234

i CDOT 3 Feet and Inches

19. Erase all hatch patterns generated in AutoCAD recreate using the MicroStation
Patterns tools, shown below, or using the CDOT Menus.

4 & 3w B = B

20. All blocks generated in AutoCAD will need to be replaced with the standard CDOT
MicroStation Cells. Cells may be placed using the MicroStation tools or the CDOT
menus.

Lol GRS . §
=Updating Text

21. Text created in AutoCAD with multiple text strings can be converted to a text node in
MicroStation. Some multiple text strings created in AutoCAD will be translated into
a text node when the file is converted. To verify this, select the Element

Information icon |ﬁ Text Nodes will display under the General Tab.

E Element Information

e Text Mode (7) General | Details

AftribiLtes

Caolor;
Style:
Weight:
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22. If not, select all text that will be combined into a text node using the Element
Selection tool. While in the Element Selection command, hold down the Ctrl key to
select individual text strings. Highlight them in the order they are to be placed into
the text node. Do not Window around the multiple lines of text because the text

strings may not merge in the desired order.

E :

%
B .4

3% *

»

+ + Y

[

»
€ =

Element Selection

ROY Q. SMITH & JOYCE L. SMITH
P.0. BOX 555

KIOwA, CO 80117/

RECEPTION NO. 5555855

BOOK 555 PAGE 5505

23. Select the TXT to Node utility from the CDOT Menus under Add On’s.

= CDOT Menu V03.00

Group Display I Add On's I Options  Help

= Drafting Breakline
Linework  Cell Divide
Borders Cloud
lﬂ?;?:ellan Launch AutoTrack

Launch ModZ

Launch SignCAD

Misc. Tools

Point Cells to Graphic Cels
Point Cells to Graphic Cells (Al

Text to Node |

Typical Section Program

24. Select the TXT to Node icon

25. The following dialog box will appear. The selected text will be anchored to the

cursor.

% Convert Text T... g m

Uustification! Left Bottom ¥ |

Active Angle [0°0°0.0000" =
Line Spacing: |‘1.DDDUDD

r [T Delete Original

ROY G SMITH & JOYCE L SmITH

P BOX 855

KIOWs, O 30117 -
ﬁ'élﬁf.‘.éﬁwirh“ 'ﬁiy'—‘-& RESE
HCESEOTAGE 555
NOWA, CO 80117
RECEPTICN NO. 555555

BOOK 555 PAGE 555
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26. Check on Delete Original, set the Justification, and leave the Line Spacing set to
1.00. Place the text in the desired location.

E Convert Text T... g

Flustification:  Left Top 'I
Active Angle [ 0°00.0000" B3
|Line Spacing: | 1.000000 |

r v Delete Original

Note: If the Justification is set to anything other than Left Bottom, double click on
the text after it is placed. The text will be brought into the Text Editor dialog. Click
again on the screen to place the text to its proper location and close the dialog.

27. Select all text and key-in annotationscale add. The text will now recognize the
MicroStation Annotation Scale Factor.

Key-in =
| annatationscale add ﬂ ﬁ "& - ‘

28. Update the text style by selecting Change Text Attributes. Select the desired
CDOT Text Style and select the text placed previously in AutoCAD.

ot |
L%

E ABC 'd A I 1 A A1 AL el D0
A Pl st AEC h."' + AZa AL Az &EE e

% Change Text Attrib... g ]

Tewt Style: [ 07" ENG-100 _»] Q

e ] v

ROY Q. SMITH & JOYCE L. SMITH
P.0O, BOX 555

KIOWA, CO 80117

RECEPTION NO. 522555

BOOK 555 FAGE 555

29. All fractions placed in AutoCAD will need to be re-typed in MicroStation so the
format conforms to CDOT standards.
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Compressing the Model File

30. After all changes and updates have been made to update the drawing into

MicroStation using CDOT standards and standard workflows, select File >
Compress Design. This will remove all AutoCAD information stored in the drawing
buffer. This will ensure that AutoCAD data does not get repopulated into the

drawing.

-

L~

Fie | Edt Element Settings Tooks U

3 New... Ctri+N

— @ Open.. Ctri+0

§ Cose Ctri+wW

| save ctri+S
Save As

[I Compress b Design
Save Settings Ctrl+F Options

E Reference

7 Raster Manager

31. Under Compress > Options, verify that all options are checked ON.

E Compress Options

Compress

Select Actian Allas
Delete Empty Cell Headers EMFTY_CELL
Delete Empty Text Elements EMETY _TEXT
[] Delete Text Elements Containing Only Spaces SFACE_TEXT
Delete Unused Mamed Shared Cells SC_MNAMED
Delete Unused Anomymous Shared Cells SC_ANOMN
Delete Unused Line Styles LINESTYLES
Delete Unused Dimensian Styles DIMSTYLES
Delete Unused Text Styles TEXTSTYLES
Delete Unused Levels LEVELS

Delete Unused Mested Attachment Levels LEVELTABLES

‘ | DK Cancel
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