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InRoads
Added Features to Cross Sections

Did you know that features can be placed in a cross section set at creation or added later by selecting the 
Evaluation > Cross Section > Update Cross Section Command
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InRoads
Adding and Subtracting an Angle in InRoads

Did you know that you can add or subtract from an angle value while keying it in by adding a + or - and 
the amount to be added or subtracted? The software will automatically do the math before sending the 
value to the command.
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InRoads
Adding Points to the end of a feature

Did you know to add points to the end of a feature, use the Surface > Design Surface > Place Feature 
command with the Append option turned on.  If you want to add points to the start of the feature: first use 
the Surface > Edit Surface > Reverse Feature Direction command to reverse the order of the points.
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InRoads
Calculating End-Area Volumes

Did you know when calculating End-Area volumes from cross sections, the InRoads family of products 
automatically draws the cut and fill areas at the same exaggeration as the cross sections? However, the 
true area is used and annotated in the volume calculations. Your CAD software calculates the area based 
on the exaggerated shape, not the true shape.
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InRoads
Cross Section Feature Editing

Did you know that you can edit a feature directly in the Cross Section set instead of modifying the plan 
representation and updating the cross section set?
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InRoads
Cross Section Surface Symbology

Did you know that you can control the symbology for each surface in a cross section set by setting the 
surface's Cross Section Symbology in Surface > Surface Properties and then select the CDOT preference 
that you want to associate with that surface.  
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InRoads
Cross Section to Surface

Did you know that you can add the points from a cross section surface to a DTM by using the Evaluation 
> Cross Section > Cross Section to Surface command?
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InRoads
Cross Section -Use Features Only

Did you know that there are two ways to represent a surface in cross sections? If your model is well 
defined by longitudinal linear features, you can force the cross sections to recognize only the features, 
ignoring any triangle legs along a feature. Select Surface > Surface Properties to choose how your surface 
will be represented.  Choose Advanced Tab and select Use Features only next to the Cross Sections 
portion of the Dialog box.
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InRoads
Decision Table Decisions

Did you know when running Surface > Design Surface > Apply Decision Table, if you don't specify a Final 
Intersection Name, the TC name from the final intersecting segment will be used. 
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MicroStation

InRoads 

Default Active Surface

Did you know that the last loaded surface will become your active surface?  Your 
RWK file determines the order that the surfaces are loaded.  If you want to order your 
surfaces differently, simply delete the surfaces that you want to re-order, manually 
load them in the order that you desire and Save your RWK again. 

 

Remember to save your surface if you have made modifications to it, prior to deleting  
and re-ordering it.
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InRoads
Defining Slopes along Template Segments

Did you know that by default, the slopes of template segments are calculated from pivot to range when 
using the Superelevation command?  If the pivot is on the range point, a zero-percent slope is reported. 
To prevent this, define the crown point on the template and then the slope will be calculated from the 
crown point to the range.
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InRoads 
Roadway Modeler - Design Surface Options

Did you know that on the advanced tab of Roadway modeler, you can toggle OFF 'Empty Design 
Surface', you toggle ON 'Replace' under Duplicate Feature Names.  This will delete/recreate identically 
named DTM features and update the associated graphics in plan view. The help menu is pretty good 
at explaining the other feature options that are available - Choose help within the roadway modeler 
dialog.  Then you don't have to 'search' for the topic.  Thanks Ron Brys for the tip! 
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InRoads
Dithered Features

Did you know that if you see many dithered features in the Features lists throughout the product, it 
means that the Feature’s style is preventing it from being displayed via that command?
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InRoads
Drape Surface Command

Did you know that you can use the Surface > Design Surface > Drape Surface command to “lay” 
graphics on a surface?  This command copies the new “draped” element to a target layer and retains the 
original graphic data.
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InRoads
Editing Feature Points

Did you know that when using the Surface > Edit Surface > Edit Feature Point command, you can edit 
multiple points then click the Apply button once --- all your edits will be applied.
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InRoads 
Empty Design Surface

Did you know that on the advanced tab of Roadway modeler, you can toggle OFF 'Empty Design 
Surface', you toggle ON 'Replace' under Duplicate Feature Names.  This will delete/recreate identically 
named DTM features and update the associated graphics in plan view. The help menu is pretty good 
at explaining the other feature options that are available - Choose help within the roadway modeler 
dialog.  Then you don't have to 'search' for the topic.  Thanks Ron Brys 
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InRoads
Feature and Graphic Lock Toggle

Did you know that you can toggle the Locate lock between Locate Features and Locate Graphics while 
selecting elements during the Surface > Design Surface > Transverse Feature, Longitudinal Feature, and 
Sloped Surface commands without exiting the commands.
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MicroStation

InRoads 

Feature Tag Information

Did you know that Service Pack 4 of Inroads now allows you have to "Hover" over 
an InRoads element and review tag information.  You have to have InRoads opened, 
a DTM file opened and features displayed from the DTM for the hover with attributes 
to work.  Dumb graphics only gives you information on the actual line. You can still 
use the MicroStation Tag Attributes for survey graphics displayed from a field book.  
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InRoads
Generic Transition Control Names

Reduce the number of Decision Tables by using Generic Transition Control Names.  If a project 
is large and contains several intersecting roadways, try to use all encompassing transition control 
names.  Doing so will reduce the number of decision tables and complexity of decision tables.
 
For example, let’s say you have a mainline and many intersecting streets.  Using a set of transition 
control (TC) names for the mainline and a set of generic, all-encompassing TC names for all of the 
intersecting streets greatly reduce the number of decision tables to as few as two – 1 table for the 
mainline and 1 that would cover all of the other roadways.  If you didn’t use the all-encompassing TC 
names, you would have at least 1 for each of the intersecting roadways to keep track of.  To put things 
into perspective, I have at least 100 roadways.  This would mean at least 100 decision tables to track 
and change if there were any changes to the design or tables!  This would be inefficient along with 
trying to keep track and use the several hundred more feature names (TC names) for the project.  
Thank-you to Brett Nordby Region 5 - Durango
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MicroStation

InRoads 

Global Scale Factors 

Did you know that when you cut new cross sections or profiles your global scale 
factors need to be set in order for the text, cells and linestyles to display properly. 
This is an application add-in found under InRoads > Tools > Global Scale factor. The 
factors need to correspond to your desired plot scale. 
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InRoads
Help on a Command

Did you know that you can get help on any InRoads command by positioning the cursor over the 
command and pressing the F1 key on the keyboard?  This will immediately bring up the Help menu for the 
command you are pointing to.  
This will work with both Pull-Down Menu Commands and Icons and will also work in MicroStation, once 
the Help Menu has been opened.
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MicroStation

InRoads 

Input Files 

Did you know that if you have data to key in, instead of entering this data in the key-
in dialog box one command at a time consider placing your commands in an input 
file. Once the input file is created then enter the filename as a response to the current 
active alignment command. For example, creating a horizontal Transition Control 
alignment one could enter Station/Offset commands to do this in an input file.
 
A portion of the input file might look like this:
so=300+00.00,-32.000,0,SH 131 Alignment
so=300+15.00,-32.000,0,SH 131 Alignment
so=301+20.00,-31.395,0,SH 131 Alignment
so=301+67.52,-25.669,0,SH 131 Alignment
so=302+97.60,-25.669,0,SH 131 Alignment
…and so on.

Save this file as something like "C:\Projects\12345\Design\InRoads\TC-POSS.inp"

The above example will create a new alignment in the Active Geometry Project which 
will be the Active Alignment, but will reference another alignment for base 
information. In this case you are specifying which alignment to extract data from, "SH 
131 Alignment". Also note the elevation data field (",0,") is set to 0, or it can be 
defaulted, but you still need to account for the elevation field with comma delimiters if 
you specify an alignment name. Please consult the Bentley help system under the 
"Classic Cogo" commands for additional information.

Open up the key-in dialog box, if necessary.

Create the new alignment under the desired Geometry Project, then activate the 
Horizontal "Add PI" command.

In the key-in text control enter "@c:\Projects\12527\Design\InRoads\TC-POSS.inp", 
then press "Enter". The horizontal PI's will now be added to the alignment from the 
data contained in the input file.

Be sure to include the full path specifier to your input file. 
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InRoads

Intersecting Alignments

Did you know that you can intersect alignments that either overlap or fall short of intersecting another alignment?  You can 
use InRoads geometry tools for trimming or extending alignments. 

 

The Trim & Extend alignment tools can be found by selecting Geometry > Utilities. These tools may appear dithered or not 
show at all.  To activate the tools go to Tools > Application Add-Ins and enable the 'Horizontal and Vertical Elements Add-
In'.

 

Follow the screen prompts carefully to step you  through the commands.

 

Tip and Trick from Ron Brys at the Envision Group 
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InRoads
Label Contours Enhancement

Did you know that you can use the Label Contours command to enhance the automatically generated 
contour annotation from the View Contours dialog box? 
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InRoads
Converting Project Data from other Softwares

Did you know that when converting project data from MOSS, Eagle Point, or some other software 
package that you can use LandXML to transfer the engineering data to InRoads.  LandXML is a 
platform independent file format that is specifically designed to transfer engineering data between 
similar software platforms and it saves a lot of typing too!  Most engineering software used by CDOT 
supports the LandXML file format.
 
JR Heathcote tried using LandXML to transfer a MOSS triangulation model to an InRoads surface and 
it worked like a charm, total time spent in this endeavor was about 5 minutes, most of which was spent 
exporting the data from MOSS. Submitted By JR Heathcote Region 3
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InRoads
“Locate Buttons”

Did you know that the button with the target on it next to key-in/input fields allows you to select graphics 
or a coordinate location in the drawing?  These are referred to as “locate buttons.”
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InRoads
Locating Features in Design File

Did you know that when locating a feature, the feature does not have to be displayed in the graphics file? 
 
 

file:///C|/tips%20and%20tricks/InRoads/InRoads-Tip%20Locating%20Features%20in%20Design%20File.htm5/25/2007 11:48:32 AM



When you act naturally, effortlessly, it is right

InRoads
Locks Dialog Box

 
Did you know that you can right click on the InRoads Menu Bar to pull up the Locks and the Customize 
Tools dialog box?
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InRoads 
InRoads Menu Location 

Did you know that your Bentley InRoads Menu always want to open on your primary monitor?  Through 
discussions with Bentley, it has been determined that this phenomenon is by design.  It is necessary 
because Laptop computers can be used to run InRoads, and if the InRoads menu was banked on the 
secondary monitor, it would be lost when the laptop was used stand-alone. If you drag the InRoads menu 
to your secondary screen, leaving only a very small sliver on the primary screen, the menu will stay 
banked and you won’t have to move it each time you open InRoads.  Thanks to Daniel Thomas with 
Region 4 Traffic. 
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InRoads
Merging Surface Models

Did you know that instead of using the ‘Merge’ command, try to use ‘Copy Portion of Surface’ 
command.  Since ‘Merge’ ignores features in the underlying surface that overlap the merging surface, 
merging them may create some problems with the newly created surface by leaving out or ignoring 
important and necessary features from the old, underlying surface.
  
If the ‘Copy Portion of Surface’ command is used, the designer can decide exactly what features to 
keep from the old, underlying surface.  Also, the designer can decide what features to include from the 
copied surface which may create a more accurate final master surface.  This may be more time-
consuming than using the ‘Merge’ command, but it may also create a more accurate final surface.  To 
find the command, use:  Surface > Edit Surface > Copy Portion of Surface.  The merge command is 
also located here.   Thank-you to Brett Nordby Region 5 - Durango
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InRoads
“More” Options on Surface Command

Did you know using the “More” options on the Surface > Edit Surface > Edit Feature Point command 
allows you to move a point a precise distance, direction and slope from either the point before or after it?
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InRoads
Multiple InRoads Products

 
Did you know that if you want to run more than one InRoads product at the same time, select Tools> 
Application Add-Ins to turn on other InRoads products loaded on the workstation?
 
The menus will change to include commands for all products currently turned on.
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MicroStation

InRoads 

The North Arrow placed by the P&P Generator

Did you know that the North Arrow position is set by the Location in Paper Units in 
the P&P Generator and is set to be placed in the upper right corner of the sheet. This 
is a rough placement and will likely have to be moved for clarity and conflicts on many 
sheets. Once the sheets are constructed each sheet should be checked for optimum 
cell position.

It should also be noted that there is a known bug in the P&P generator which cause 
the cell to be placed on a no plot level.  This can be very frustrating, as you don't 
notice it until you plot.  The North Arrow must be manually moved to the correct level.  
There is a new command being developed in V2.03 of the Configuration that will 
allow you to move the North Arrow in a batch mode on many sheets at a time.  When 
it is available we'll advertise more-it should be available after April 17th.
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InRoads
P & P Generator Tip

Did you know that when running the Evaluation > Plan and Profile Generator command, turn Generate 
Sheets off and run Plan Only method until you have all the plan views at the desired locations. Then use 
the Plan and Profile method in the Use Plan Views mode to create the associated Profile views.

file:///C|/tips%20and%20tricks/InRoads/InRoads-Tip%20P%20&%20P%20Generator.htm5/25/2007 11:48:32 AM



When you act naturally, effortlessly, it is right

InRoads
Point Densification

Did you know that linear DTM features have a point densification property which improves the definition 
of the surface without increasing the size of the DTM?  This is useful for features with long straight 
sections.
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InRoads
Point Snap

Did you know that when selecting a station for a range with Point Snap on, you can select only cardinal 
points along as alignment?  With Point Snap off, you can select intermediate stations along an alignment.
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InRoads
Points to End of Feature

Did you know to add points to the end of a feature, use the Surface > Design Surface > Place Feature 
command with the Append option turned on.  If you want to add points to the start of the feature: first use 
the Surface > Edit Surface > Reverse Feature Direction command to reverse the order of the points.
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InRoads
Populating InRoads Explorer

 
Did you know that you can open data files by dragging them from File Manager of the Windows Explorer 
and dropping them into the InRoads Explorer?
 
InRoads files to utilize this functionality include surfaces (*.dtm), alignments (*.alg) and libraries (*.tml or *.
rwl)  All file types can be selected at the same time and populate the InRoads Explorer window.
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InRoads
Profile Shift in P&P Generator

Did you know that only the highlighted surfaces on the Profile Controls tab will be used to determine if 
the profile needs to shift when running the Evaluation > Plan and Profile Generator command.
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MicroStation

InRoads 

Report Generation and Naming Convention 

Just to let you know that there is a problem with report generation and placing 
spaces in the file name?  We are in the process of determining how this impacts all 
InRoads File naming, but we have heard from Bentley that any files (BIN files for 
example) created for use with the DBAccess reports or Tools>Reports command 
must follow the 8.3 convention. Click Here to review more on this convention. 

The following was received from Keith Sours (Region 3) today 3-28-07:  I just became 
aware (painfully) that Inroads behaves badly if spaces are used in file names in some 
places.  The specific command I became aware of this behavior on is the "Reports" 
command and the Geometry tab.  If I select points, ask for a list of coordinates, 
specify a report format from the dropdown.  Select "text to file" and "text to screen", 
click in the file name box and browse to a directory and enter a file name and click 
"Apply". The specified file name is created but there is nothing in the file and the 
"Results" dialog box just says "reports result" and nothing more. At the bottom of the 
MicroStation window, it says "Successful Completion". 

It was a while before I noticed a file named only with the first word of the specified file 
name and no extension in the specified directory. That file contained my data. If I 
eliminated spaces or replaced them with underscores in the file name, the results 
dialog box contained the expected data.

I don't recall that the use of underscores in lieu of spaces was pointed out as a 
requirement, though the default file names might be a clue.

I have used spaces in many cases with Inroads and MicroStation file names and 
haven't identified other specific problems with file names, but because I frequently 
encounter situations where things don't work as I expect, I am replacing spaces with 
underscores in my file names as a precaution.

Thank-you to Keith for your astute observation and for letting us know.
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InRoads
Locating Features in Design File

Did you know that when locating a feature, the feature does not have to be displayed in the graphics file? 
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InRoads
Right-of Way Definitions

Did you know that Right-of-way definitions can be used only when the method of controlling the side 
slopes is template, cut and fill table or material table?  Decision table definition cannot be used.
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MicroStation

InRoads 

Roadway Modeler Densify Curves

Did you know that sometimes triangulating a surface after running Roadway 
Modeler can result in a cryptic InRoads error message "Point not on Surface", at 
which point the triangulation process is halted. If you get this error message go ahead 
and start Roadway Modeler again, set your surfaces and stationing (if necessary), 
click on the "Advanced" tab and make sure the "Densify Curves Using Chord Height 
Tolerance" control is checked. Then try to run your design surfaces again through the 
Modeler. Most likely you will successfully generate a good triangulation, although you 
may generate a "Point tolerance…" warning message. You can click OK.  During 
triangulation it may still be possible to generate the "Point not on surface" error even 
after you have set your "Chord Height Tolerance" to a different value (as discussed 
below). If this is the case you will need to try other chord height values, however, 
according to the Bentley Help system you should choose increasing chord height 
values until you can successfully triangulate your surface.

One caveat to this solution is; The resulting DTM will, in most cases, be significantly 
larger and take longer to triangulate due to the fact you have added interpolated data 
points on each of your design strings. You can control the size of the DTM somewhat 
by setting the global "Chord Height" tolerance to a value greater than the standard 
default value. To set this value, in InRoads click on the "Tools" pull-down menu, click 
on "Options" to invoke the Options dialog box, click on the "Tolerances" tab and enter 
your "Chord Height" tolerance value.  

As a general rule of thumb a chord height tolerance of 0.05 will produce a 
triangulation of approximately twice the size of a triangulation using the default 0.01 
chord height tolerance. Actual the DTM size will vary depending on the distribution of 
your original data points.

From JR Heathcote Region 3
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MicroStation

InRoads 

Roadway Superelevation 

Thought you should know that a better explanation should be given defining how 
InRoads calculates superelevation.  The AASHTO book "A Policy on Geometric 
Design of Highways and Streets", page 182, recommends that the superelevation 
transition be accomplished throughout the length of the spiral.

InRoads makes the assumption the calculated superelevation transition length from 
AASHTO Method #5, or the transition lengths found in the Superelevation Tables, 
and the user entered spiral length as being one and the same when in fact, this 
assumption may not be valid in all cases. InRoads makes no checks to determine if 
the spiral lengths specified in the horizontal alignment and the superelevation 
transition lengths match. What this means is if the user decides to utilize a spiral 
length longer, or shorter than what is found in the Superelevation Table the critical 
transition stations will not be correctly calculated. 

For example, the user wants to employ a 190 foot spiral length based on good sound 
engineering judgment, and the superelevation table specifies a 167 foot transition, 
InRoads calculates transition stations based on the 167 foot transition length, not the 
190 foot spiral length as is recommended by AASHTO. There is currently no way in 
InRoads to override or synchronize superelevation transitions to use the spiral length 
as defined in the horizontal alignment. The only way to handle this deviation in 
transition lengths is to manually calculate and edit your superelevation transition 
stations using the "Build Super Transitions" dialog box.

From JR Heathcote - R3 Project Manager 
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InRoads
Set Slope along Feature

Did you know that you can use the Surface > Design Surface > Set Slope Along Feature Command to 
set the elevation of all the points of a feature to the same elevation.  Just set the target point to the first 
point and set the elevation, then set the target point to the last point and set the elevation.
Of course this command also changes the elevations of feature points to enforce a specified slope along a 
given range of the feature.
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InRoads
Setting Alignment Points based on other Alignments

Did you know that you can set an alignment point based on an existing alignment that is loaded in 
memory by using Station and Offset?  When in Place or Move PI, type in “so=station, offset, {elevation, 
existing alignment name, geometry project name}”.
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InRoads
Shortcut List

Did you know that you can display a short-cut list of appropriate commands in the InRoads Explorer by 
clicking the right mouse button?

 
 
 

file:///C|/tips%20and%20tricks/InRoads/InRoads-Tip%20ShortCut%20List.htm5/25/2007 11:48:33 AM



When you act naturally, effortlessly, it is right

InRoads
Slope Surface and Longitudinal Features

Did you know that the Surface > Design Surface > Slope Surface and Longitudinal Features commands 
dynamically display the possible solutions?  If you drag the cursor from one side of a element to the other 
you can see the dynamic display, you do not need to know which side you want to place the results ahead 
of time. 
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InRoads
Special Character bearing key-in

 
Did you know that you can type bearings without the special characters within InRoads dialog boxes 
wanting bearing key-in values? For example: you can type “S25 17 52E” and the software will 
automatically convert it to S 25^17’52” E when you press the TAB key.
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MicroStation

InRoads 

Station Lock

Did you know that the InRoads Locks toolbar contains the Station Lock which locks 
you onto even stations in the event that the alignment you are using does not start on 
an even station?  The station will be determined by the interval you are using.  For 
example, if you are stationing an alignment at a 100 ft interval, the display will show 
even 100 ft. stations.  This affects not only station displays but virtually everything 
that uses a station interval, such as cross sections, profiles and roadway modeling.  
For more information about all the InRoads Locks see Page 25 of the training 
manual.   Roadway Design Using InRoads
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The following are several different tips from folks around the state working with the InRoads Survey software package

The following are several different tips from folks around the state working with the InRoads Survey 
software package. 

 These tips are  for a problem in Inroads Survey with duplicate shot numbers.  The original question 
came from John Willis and it read.

" I was wondering if anyone else has had problems in Inroads Survey with duplicate shot numbers in 
files where the shots are stored as observations rather than positions. When I have loaded RTK files 
with the points stored as positions into Inroads it has appended an underscore and a digit to each of 
the duplicate shots. But when I have loaded files shot with a total station with the points stored as 
observations, it is not appending an underscore and a digit to the duplicate shots. Instead it has used 
the coordinates of the first shot and the TMOSS code of the last shot which causes some very strange 
looking graphics. Since the two surveys where I have encountered this problem did not have a lot of 
points stored as observations, I was able solve the problem by renumbering some of the shots in the 
SDR files. However, on large surveys there will be too many shots for this to work.  If any one has 
encountered this problem and found a good solution let me know."

Corey Guerrero writes:  You have hit the nail on the head. We came across this InRoads limitation 
when we were translating the First Adopter projects. The ultimate solution is to renumber all of the 
points within a segment file if you want them to be contained into one fieldbook. The other option is to 
create multiple fieldbooks and merge the .DTM file when writing the Survey Data to Surface. Hopefully, 
the field surveyors are no longer duplicating the points out in the field. This should be avoided at all 
costs, even if your working with a positional file. There is the option to use an alpha character when 
renumbering the points in a translated file. Unfortunately, that isn't a simple solution to renumbering 
old .sdr files and that is the reason for discontinuing this practice in the future. Both Mike and Todd 
should be aware of what you have come across and hopefully they can help you with making multiple 
fieldbooks and merging the .DTM.

Larry Lucas writes:  I had the same problem and all I did was to copy the data from the initial shot, 
renumber the new shot to the next highest number at the end of the file and put in the correct code. I 
did this to the DC file before taking it into Microstation / Inroads. It seemed to work right for me.

Betty Claybrook writes:  We took the time and edited all of our segment files and changed the shot 
numbers. For instance for Seg. A we added an A to the shot#s.

There is a word processing software available on the internet called TextPad, it allows you to edit 
columns, so it goes fairly quickly.

When we had duplicate shots for terrains, we copied the shot to the next line and put the second code 
on the second shot and got rid of that code on the first shot, then make sure you add another alpha 
character or something so the second shot has a unique shot #. The reason we did this is because the 
translator will take a simple code like 600119 and make it 6001.00119. When it does that for a 
duplicate shot then InRoads doesn't get the whole line. So when it comes into your fieldbook you get 
errors and the second code doesn't process. This happened because we took our duplicate shots and 
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The following are several different tips from folks around the state working with the InRoads Survey software package

put the codes on one line so the second code wouldn't come into the fieldbook as a note a 13NM. 
Beware of the control codes such as the "ST, BC, NT, etc.) they take up more space on the line too. 
Basically I think you have only 32 characters on a line for a code, at least for translated files.

Also every time you setup on a point or backsite a point that point# will be in your files several times, 
so when that file is imported into the fieldbook you will get Pt#_1, Pt#-_2, and so on. We deleted those 
out of the fieldbook because you end up with points on top of points. Same thing happens with 08KI's.

Another thing we discovered is in a segment file you have all of your daily files appended, so on a 
conventional survey file you have notes (13NM's) at the top of the file, those need to be deleted or they 
come in as a note on the last shot of the above daily file.

John Willis writes: Actually on the first survey I translated there was just one segment of total station 
shots, so I talked to Bob Mecham at BHI, and he had me put that segment in a separate fieldbook and 
merge the DTMs. I was hoping there was a way to avoid having to do this.

One thing I ran into in merging the DTMs is that the "Merge Surfaces" command is not in Inroads 
Survey. You have to load Inroads from the Applications Add-ins under the Tools pull down menu.

The other day Todd Johnston suggested importing an old SDR20 file with observations into 
TGO, and then exporting an SDR33 file with positions. We just tried this with a file and it 
seemed to work. Anyway, the survey looked okay when we loaded it into Inroads.

John Willis writes more: Duplicate point numbers can be avoided when using TSC1 and TSCe data 
collectors, but I believe that with the SDR 33's you are limited to 4 digits and no alpha for a point 
number. We have pretty much quit using the SDR 33's, but our residency people in Alamosa are still 
using a SET 3 with an SDR 33 for their TMOSS surveys. So I guess we will be dealing with this until 
we get them a new data collector.

Dan Smith's Response: If you set your job up in the SDR33 in alpha mode (I believe that is what its 
called) then you are no longer restricted to 4 digits and it allows alpha as well.

Thanks to everyone for your tips and tricks!
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InRoads
Template Layer Naming Convention

Did you know that when creating your surfaces from your Typical section templates you should consider 
placing a layer designation that uniquely identifies the roadway you are working on?  For example, use 
something like "S.H. 13 Subgrade" and "24 Rd Subgrade" to identify the subgrade layers instead of just 
"Subgrade".  This way if you have to merge both subgrade layers later on, you can do this without having 
to save one surface as another.  A little data naming organization early on will save headaches later.  This 
tip is Thanks to JR Heathcote with Region 3 
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MicroStation

InRoads 

Text Import Wizard

Did you know that there is a Text Import Wizard within the InRoads software for 
bringing in ASCII Text?  The Wizard can be found under the Application Add-ins 
under the Text Import Wizard Add-in.  Once selected the Wizard can then be found 
on the InRoads File pull-down.  

●     Choose the File > Text Import Wizard command, which displays the Text 
Import Wizard dialog box. 

●     With Wizard Name set to < New >, specify the appropriate Data Type and the 
name of the file you want to import. 

●     Click OK.

The Text Import Wizard - Step 1 dialog box appears.

●     Set the Start Import at Row and End Import at Row to specify which lines in 
your file contain the actual data. 

●     Specify the Record Format (either Uniform or Non-Uniform) for your data file. 
●     Specify the Original Data Type (either Fixed Width or Delimited). 
●     Click Next.

The next dialog box to appear in the Text Import Wizard depends on the settings you 
have chosen on the Text Import Wizard - Step 1 dialog box. In particular, the settings 
for Record Format (Uniform or Non-Uniform) and Original Data Type (Fixed Width or 
Delimited) determine which dialog boxes will appear.  These parameters allow four 
possible combinations of settings. Accordingly, there are four distinct workflows 
available in the Text Import Wizard.  See the InRoads Help on the initial Import 
Wizard dialog box to learn more. 
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InRoads
Update Cross Section Command

Did you know that you can use the Evaluation > Cross Section > Update Cross Section command to 
refresh surfaces and features in existing cross section sets by selecting the Refresh option. You can add 
surfaces and features to existing cross section sets by selecting the Display On option and you can 
remove surfaces and features from existing cross section sets by selecting the Display Off option.
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MicroStation

InRoads 

Updating Surface Properties

Did you know that the Existing Ground in the V3.0 configuration has a new 
symbology and is now called T_Existing_Ground as opposed to just Existing Ground.  
It needs to be re-associated with the appropriate existing surface through the Surface 
Properties pull-down > Advanced Tab > Cross Section Symbology, and then select 
the correct symbology. The same is true for all the other Proposed surfaces, but they 
will be associated with the "D_"  preferences.  Example : D_Finished Grade, 
D_Subgrade etc. 

 

Once the updates have been made to the desired surfaces, save the surface and 
then Update your cross sections; Evaluation > Update Cross Section > Select set > 
select Refresh > select Surface > select Apply. The surfaces should now look correct.
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InRoads 
What size pipe am I? 

Did you know that if you are trying to determine what size a pipe is in an existing survey, that you can 
open up the existing dtm surface, use the Surface pulldown in InRoads and View Surface feature and 
select the pipe in question with the target button and then annotate the feature.  Each pipe contains the 
feature style name that matches the type of pipe and the size of pipe that has been located in the field.  It 

will also display the slope when annotating.  

Submitted by Corey Guerrero
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InRoads
Using Wildcards

Did you know that you can use wildcards to specify multiple alignments or point names?  For example, 
“ex*” will select all point names that start with the letters “ex”.
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Tips: 
 

1. Create Geometry Project 
 
2. Horizontal Alignment: 

a. New Horizontal Alignment 
b. Create text file, ne,xxxxxx.xx.xxxxxx.xx 
c. Add PI’s 

i. Geometry, Horizontal Curve Set, Add PI,  
d. Type in input file name @c:/…….txt 
e. Add curves 

i. Geometry, Horizontal Curve Set, Define Curve  
ii. Add radius 

f. Add Stationing 
i. Geometry, Horizontal Curve Set, Stationing  

ii. Change to New Station 
 

3. Vertical Alignment 
a. New Vertical Alignment 
b. Create text file, se=100+00,5485.56 
c. Create Profile 

i. Evaluation, Profile, Create Profile 
d. Add PI’s 

i. Geometry, Vertical Curve Set, Add PI, Apply 
ii. Type in input file name @c:/…….txt 

e. Add curves 
i. Geometry, Vertical Curve Set, Define Curve  

ii. Add radius 
 

4. Templates Library 
a. New Typical Section 
b. Modeler, Define Typical Section 
c. Name typical (i.e. Station 3265+14) 
d. Edit button 

i. Create Layers (i.e. SH 119 top, SH 119 subgrade, SH 119 R40) 
ii. Segment tab 

1. Create typical 
a. Create Features needed  

i. Edge of Travel Lt/Rt - Shoulder 
ii. Shoulder Lt/Rt, - Edge of Pavement 

iii. Hinge – POSS 
iv. Cut – Top of Cut 
v. Fill – Toe of Fill 

b. Mirror template  
i. Change Features from Rt to Lt 

iii. superelevation tab 



1. set range points 
2. set pivot points 

e. Decision Table 
i. Target – Existing terrain dtm 

ii. Start TC – Hinge 
iii. End TC – Cut of Fill 
iv. Slope 
v. Width 

 
5. Roadway Library 

f. New Roadway Library 
g. Modeler, Define Roadway 
h. Name Roadway (SH119) 
i. Edit button 

i. Main Tab (Add station and templates) 
1. Station 
2. Mode (Both, Lt, Rt, Lt and Rt) 
3. Interval (2) 
4. Transition Templates (? – No) 
5. Pick Template 
6. Pick catch point (Decision Table, Template) 
7. Name Pick name of Decision table 

ii. Horizontal and Vertical Controls 
1. Pick transition Control Name (feature to be adjusted) 
2. Pick Horizontal and or Vertical Control 

a. Select appropriate alignment 
3. Start Station 
4. Stop Station 

iii. Defaults 
1. Enter interval 

 
5. Superelevation 

a. New Superelevation (under geometry project) 
b. Modeler, superelevation, build transitions 

i. Station 
ii. Left Rate – Linear 

iii. Right Rate – Linear 
iv. Subgrade 

1. Left Rate 
2. Right Rate 

v. Hand of Curve (left or right) 
vi. Pivot Point Location (from template) 

 
6. Roadway Modeler 

a. Main Tab 
i. Select original surface (or surface to interface) 



b. Advanced Tab 
i. Sides (Lt. and Rt.) 

ii. Superelevation (All layers) 
iii. Transition Control Lines (First Layer) 
iv. Subgrade Intercept (Previous Layer) 

 
 

7. Draw up Cross Section 
a. Set scale of Sections 

i. Tools, options, factors, set scales 
b. evaluation, cross sections, create cross sections 
c. select preference 
d. Annotate Cross Sections 

i. evaluation, cross sections, annotate cross sections 
ii. select preferences 

iii. select surface to annotate (top) 
 

8. Volumes 
a. Evaluation, volumes, end-area volume 

i. Main Tab 
1. Select cross section set 
2. Select original surface 
3. Select design surface (finished surface) 
4. Select subgrade surface (bottom) 

ii. Layer volumes tab 
1. Fill in your surfaces 

a. Top Layer 
b. Bottom Layer 
c. Add 

 
9. Various 

a. Draw up various surfaces 
i. Surface, update 3-D/Plan Surface display 

ii. Pick surface, features, or items 
iii. To draw up a portion place fence and change fence mode 

b. To transition a lane  
i. Modeler, Define Roadway, Edit, Horizontal and Vertical Controls 

tab 
1. Pick horizontal alignment (make sure it is the active 

alignment) 
2. Pick transition control name (feature to transition) 
3. enter start and stop stations 
4. enter start and stop offsets 

c. To find out feature properties 
i. Surface, feature, feature properties 

ii. Select surface 



iii. Select feature 
d. Check/Change properties for surface 

i. Right click on surface 
ii. Properties 

iii. Check preferences 
e. Check/Change properties on alignment 

i. Geometry rename geometry 
ii. Go through horizontal and vertical to check and rename to get 

appropriate preference 
f. Scale Microstation Drawing 

i. Models 
ii. Edit model properties 

iii. Change scale 
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InRoads
Workflow Toolbars

 
 
Did you know that you can develop your own workflow toolbars with Tools> Customize?  Make a new 
toolbar and add the commands that you need in the order they are used.
 
You can even export them to a file and share them with others in you office.
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InRoads
Writing Template Points to a Model

Did you know that you can write your template points to a drawing file while processing a Modeler 
command? Turn on the display Transition Control Lines toggle and the Write lock.
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